Genesyslab.Enterprise.Agent Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Agent Namespace
Send Feedback

Interfaces

Interface | Description
IAgent | Agent interface.

Enumerations

Enumeration | Description
AgentStateType | Agent status.
Generated on

Copyright (c) 2008-2009 Genesys Telecommunications Laboratories, Inc. All rights reserved


AgentStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentStateType Enumeration
See Also Send Feedback
Agent status.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum AgentStateType
Visual Basic (Declaration)
Public Enumeration AgentStateType
Visual C++
public enum class AgentStateType

Members

Member name | Description
Unknown |
LoggedOut |
LoggedIn |
Reserved |
Ready |
NotReady |
AfterCallWork |
Busy |
OutOfService |

See Also

Genesyslab.Enterprise.Agent Namespace


IAgent Interface

[image]

Enterprise SDK 8.0 Reference API
IAgent Interface
Members See Also Send Feedback
Agent interface.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAgent : IIdentity, IRoleable,
    ISerializable, IConfigurable
Visual Basic (Declaration)
Public Interface IAgent _
    Implements IIdentity, IRoleable, ISerializable, IConfigurable
Visual C++
public interface class IAgent : IIdentity,
    IRoleable, ISerializable, IConfigurable

See Also

IAgent Members
Genesyslab.Enterprise.Agent Namespace


IAgent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Members
IAgent Interface Methods Properties See Also Send Feedback

The IAgent type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
DndState | Overloaded.
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
ForwardDestination | Overloaded.
ForwardState | Overloaded.
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)
Queues
State | Overloaded.
WorkModeType | Overloaded.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity. (Inherited from IIdentity.)
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device (Inherited from IIdentity.)
FQName | Fully Qualified Name (Unique ID for this object). (Inherited from IIdentity.)
Group | Groups of identities. (Inherited from IIdentity.)
IdentityBase | Base identity (fro (Inherited from IIdentity.)
Item |
Name | Identity name. (Inherited from IIdentity.)
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity. (Inherited from IIdentity.)

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


IAgent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Methods
IAgent Interface See Also Send Feedback

The IAgent type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
DndState | Overloaded.
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
ForwardDestination | Overloaded.
ForwardState | Overloaded.
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)
Queues
State | Overloaded.
WorkModeType | Overloaded.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Controller Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.Controller Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
Controller()()() | (Inherited from IIdentity.)
Controller(String) | (Inherited from IIdentity.)

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


DndState Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
DndState(IClientChannel) |
DndState(IDevice) |
DndState(IClientChannel, MediaType) |

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


DndState Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool DndState(
    IClientChannel channel
)
Visual Basic (Declaration)
Function DndState ( _
    channel As IClientChannel _
) As Boolean
Visual C++
bool DndState(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


DndState Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool DndState(
    IDevice device
)
Visual Basic (Declaration)
Function DndState ( _
    device As IDevice _
) As Boolean
Visual C++
bool DndState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


DndState Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool DndState(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function DndState ( _
    channel As IClientChannel, _
    media As MediaType _
) As Boolean
Visual C++
bool DndState(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="media"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.DndState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardDestination(IClientChannel) |
ForwardDestination(IDevice) |
ForwardDestination(IClientChannel, MediaType) |

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ForwardDestination(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardDestination ( _
    channel As IClientChannel _
) As String
Visual C++
String^ ForwardDestination(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ForwardDestination(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardDestination ( _
    device As IDevice _
) As String
Visual C++
String^ ForwardDestination(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ForwardDestination(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardDestination ( _
    channel As IClientChannel, _
    media As MediaType _
) As String
Visual C++
String^ ForwardDestination(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="media"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardState(IClientChannel) |
ForwardState(IDevice) |
ForwardState(IClientChannel, MediaType) |

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ForwardState(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardState ( _
    channel As IClientChannel _
) As Boolean
Visual C++
bool ForwardState(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ForwardState(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardState ( _
    device As IDevice _
) As Boolean
Visual C++
bool ForwardState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ForwardState(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardState ( _
    channel As IClientChannel, _
    media As MediaType _
) As Boolean
Visual C++
bool ForwardState(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="media"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardState(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


Queues Method

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.Queues Method
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.Queues(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string[] Queues(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Queues ( _
    channel As IClientChannel _
) As String()
Visual C++
array<String^>^ Queues(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.Queues(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.Queues(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


State Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
State(IClientChannel) |
State(IDevice) |
State(IClientChannel, MediaType) |

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


State Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentStateType State(
    IClientChannel channel
)
Visual Basic (Declaration)
Function State ( _
    channel As IClientChannel _
) As AgentStateType
Visual C++
AgentStateType State(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


State Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentStateType State(
    IDevice device
)
Visual Basic (Declaration)
Function State ( _
    device As IDevice _
) As AgentStateType
Visual C++
AgentStateType State(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


State Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentStateType State(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function State ( _
    channel As IClientChannel, _
    media As MediaType _
) As AgentStateType
Visual C++
AgentStateType State(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="media"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.State(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
WorkModeType(IClientChannel) |
WorkModeType(IDevice) |

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.WorkModeType(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
WorkMode WorkModeType(
    IClientChannel channel
)
Visual Basic (Declaration)
Function WorkModeType ( _
    channel As IClientChannel _
) As WorkMode
Visual C++
WorkMode WorkModeType(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.WorkModeType(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.WorkModeType(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
WorkModeType Overload
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.WorkModeType(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
WorkMode WorkModeType(
    IDevice device
)
Visual Basic (Declaration)
Function WorkModeType ( _
    device As IDevice _
) As WorkMode
Visual C++
WorkMode WorkModeType(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.WorkModeType(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.WorkModeType(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
WorkModeType Overload
Genesyslab.Enterprise.Agent Namespace


IAgent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Properties
IAgent Interface See Also Send Feedback

The IAgent type exposes the following members.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity. (Inherited from IIdentity.)
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device (Inherited from IIdentity.)
FQName | Fully Qualified Name (Unique ID for this object). (Inherited from IIdentity.)
Group | Groups of identities. (Inherited from IIdentity.)
IdentityBase | Base identity (fro (Inherited from IIdentity.)
Item |
Name | Identity name. (Inherited from IIdentity.)
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity. (Inherited from IIdentity.)

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.Item Property
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Agent.IAgent.Item(System.String)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As Object
Visual C++
property Object^ default[String^ key] {
    Object^ get (String^ key);
}

Parameters

key
Type: System..::.String

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Genesyslab.Enterprise.Commons Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Commons Namespace
Send Feedback

Interfaces

Interface | Description
IDeepCopy<(Of <(T>)>) | Creates a full copy of an object instance.
IShallowCopy<(Of <(T>)>) | Hanldes a partial copy of the given object.


IDeepCopy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Interface
Members See Also Send Feedback
Creates a full copy of an object instance.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDeepCopy<T>
Visual Basic (Declaration)
Public Interface IDeepCopy(Of T)
Visual C++
generic<typename T>
public interface class IDeepCopy

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Commons.IDeepCopy`1"]

See Also

IDeepCopy<(Of <(T>)>) Members
Genesyslab.Enterprise.Commons Namespace


IDeepCopy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Members
IDeepCopy<(Of <(T>)>) Interface Methods See Also Send Feedback

The IDeepCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IDeepCopy(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Methods
IDeepCopy<(Of <(T>)>) Interface See Also Send Feedback

The IDeepCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


DeepCopy Method

[image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>)..::.DeepCopy Method
IDeepCopy<(Of <(T>)>) Interface See Also Send Feedback
Full copy of an object

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T DeepCopy()
Visual Basic (Declaration)
Function DeepCopy As T
Visual C++
T DeepCopy()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.IDeepCopy`1.DeepCopy"]

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Interface
Members See Also Send Feedback
Hanldes a partial copy of the given object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IShallowCopy<T>
Visual Basic (Declaration)
Public Interface IShallowCopy(Of T)
Visual C++
generic<typename T>
public interface class IShallowCopy

Type Parameters

T
Object type.

See Also

IShallowCopy<(Of <(T>)>) Members
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Members
IShallowCopy<(Of <(T>)>) Interface Methods See Also Send Feedback

The IShallowCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ShallowCopy | Partial copy of an object

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Methods
IShallowCopy<(Of <(T>)>) Interface See Also Send Feedback

The IShallowCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ShallowCopy | Partial copy of an object

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


ShallowCopy Method

[image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>)..::.ShallowCopy Method
IShallowCopy<(Of <(T>)>) Interface See Also Send Feedback
Partial copy of an object

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T ShallowCopy()
Visual Basic (Declaration)
Function ShallowCopy As T
Visual C++
T ShallowCopy()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.IShallowCopy`1.ShallowCopy"]

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


Genesyslab.Enterprise.Commons.Collections Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Commons.Collections Namespace
Send Feedback

Classes

Class | Description
KeyValueCollection | Describes a Key-value collection of the Enterprise SDK.
KeyValueCollectionHelper | Converts key-value collections.
NullableInt | Nullable integer.


KeyValueCollection Class

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Class
Members See Also Send Feedback
Describes a Key-value collection of the Enterprise SDK.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class KeyValueCollection : NameObjectCollectionBase,
    ISerializable, IDictionary, ICollection, IEnumerable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class KeyValueCollection _
    Inherits NameObjectCollectionBase _
    Implements ISerializable, IDictionary, ICollection, IEnumerable
Visual C++
[SerializableAttribute]
public ref class KeyValueCollection : public NameObjectCollectionBase,
    ISerializable, IDictionary, ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections.Specialized..::.NameObjectCollectionBase
Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

See Also

KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Members

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Members
KeyValueCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The KeyValueCollection type exposes the following members.

Constructors

Name | Description
KeyValueCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
Clear | Clears the collection.
Contains | Returns true if the collection contains this key.
ContainsKey | Returns true if the collection contains this key.
CopyTo | Copies a range of key-value pairs into the given destination array, starting from the given index.
Equals | Returns true if the given object is identical to this collection. (Overrides Object..::.Equals(Object).)
Get | Overloaded.
GetAsBinary | Returns the object associated with the given key as a byte array.
GetAsInt | Returns the object associated with the given key as int.
GetAsKeyValueCollection | Returns the object associated with the given key as KeyValueCollection.
GetAsString | Returns the object associated with the given key as string.
GetEnumerator | (Overrides NameObjectCollectionBase..::.GetEnumerator()()().)
GetHashCode | Returns the collection's hash code. (Overrides Object..::.GetHashCode()()().)
GetKey | Returns the key at the given index.
GetObjectData | (Overrides NameObjectCollectionBase..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Returns the values for this key.
HasKeys | Returns true if the collection has keys.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllKeys | Returns all the keys of the collection.
AllValues | Returns all the values of the collection.
Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
IsFixedSize | Returns true if the collection size is fixed.
IsReadOnly | Returns true if the collection size is read only.
Item | Overloaded.
Keys | Returns all the keys of the collection.
Values | Returns all the values of the collection.

Explicit Interface Implementations

Name | Description
ICollection..::.CopyTo | Copies the entire NameObjectCollectionBase to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from NameObjectCollectionBase.)
IDictionary..::.GetEnumerator |
ICollection..::.IsSynchronized | Gets a value indicating whether access to the NameObjectCollectionBase object is synchronized (thread safe). (Inherited from NameObjectCollectionBase.)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the NameObjectCollectionBase object. (Inherited from NameObjectCollectionBase.)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
KeyValueCollection()()() | Initializes a new instance of the KeyValueCollection class.
KeyValueCollection(KeyValueCollection) | Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the same initial capacity as the number of copied entries.
KeyValueCollection(IEqualityComparer) | Initializes a new empty instance of the KeyValueCollection class which uses the specified hash code provider and the specified comparer.
KeyValueCollection(Int32) | Initializes a new empty instance of the KeyValueCollection class with the specified initial capacity.
KeyValueCollection(Int32, KeyValueCollection) | Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the specified initial capacity or the same initial capacity as the number of copied entries, whichever is greater.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor
KeyValueCollection Class See Also Send Feedback
Initializes a new instance of the KeyValueCollection class.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
KeyValueCollection()

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the same initial capacity as the number of copied entries.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection(
    KeyValueCollection col
)
Visual Basic (Declaration)
Public Sub New ( _
    col As KeyValueCollection _
)
Visual C++
public:
KeyValueCollection(
    KeyValueCollection^ col
)

Parameters

col
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
The KeyValueCollection to copy into the new KeyValueCollection instance.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (IEqualityComparer)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (IEqualityComparer)
KeyValueCollection Class See Also Send Feedback
Initializes a new empty instance of the KeyValueCollection class which uses the specified hash code provider and the specified comparer.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection(
    IEqualityComparer comparer
)
Visual Basic (Declaration)
Public Sub New ( _
    comparer As IEqualityComparer _
)
Visual C++
public:
KeyValueCollection(
    IEqualityComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::.IEqualityComparer
The IComparer to use to determine whether two keys are equal.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (Int32)
KeyValueCollection Class See Also Send Feedback
Initializes a new empty instance of the KeyValueCollection class with the specified initial capacity.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection(
    int capacity
)
Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
Visual C++
public:
KeyValueCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
The initial number of entries that the KeyValueCollection can contain.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Constructor (Int32, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Constructor (Int32, KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Copies the entries from the specified KeyValueCollection to a new KeyValueCollection with the specified initial capacity or the same initial capacity as the number of copied entries, whichever is greater.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection(
    int capacity,
    KeyValueCollection col
)
Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer, _
    col As KeyValueCollection _
)
Visual C++
public:
KeyValueCollection(
    int capacity,
    KeyValueCollection^ col
)

Parameters

capacity
Type: System..::.Int32
The initial number of entries that the KeyValueCollection can contain.
col
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
The KeyValueCollection to copy to the new KeyValueCollection instance.

See Also

KeyValueCollection Class
KeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Methods

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Methods
KeyValueCollection Class See Also Send Feedback

The KeyValueCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Clears the collection.
Contains | Returns true if the collection contains this key.
ContainsKey | Returns true if the collection contains this key.
CopyTo | Copies a range of key-value pairs into the given destination array, starting from the given index.
Equals | Returns true if the given object is identical to this collection. (Overrides Object..::.Equals(Object).)
Get | Overloaded.
GetAsBinary | Returns the object associated with the given key as a byte array.
GetAsInt | Returns the object associated with the given key as int.
GetAsKeyValueCollection | Returns the object associated with the given key as KeyValueCollection.
GetAsString | Returns the object associated with the given key as string.
GetEnumerator | (Overrides NameObjectCollectionBase..::.GetEnumerator()()().)
GetHashCode | Returns the collection's hash code. (Overrides Object..::.GetHashCode()()().)
GetKey | Returns the key at the given index.
GetObjectData | (Overrides NameObjectCollectionBase..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues | Returns the values for this key.
HasKeys | Returns true if the collection has keys.
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection..::.CopyTo | Copies the entire NameObjectCollectionBase to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from NameObjectCollectionBase.)
IDictionary..::.GetEnumerator |

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


IDictionary.GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.IDictionary..::.GetEnumerator Method
KeyValueCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.System#Collections#IDictionary#GetEnumerator"]

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionaryEnumerator IDictionary.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IDictionaryEnumerator
    Implements IDictionary.GetEnumerator
Visual C++
private:
virtual IDictionaryEnumerator^ GetEnumerator() sealed = IDictionary::GetEnumerator

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.System#Collections#IDictionary#GetEnumerator"]

Implements

IDictionary..::.GetEnumerator()()()

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Add(KeyValueCollection) | Adds the given key-value pair.
Add(Object) | Adds the given value as a KeyValueCollection.
Add(Object, Object) | Adds the given key-value pair.
Add(String, KeyValueCollection) | Adds the given value with the given key.
Add(String, NullableInt) | Adds the given key-value pair.
Add(String, array<Byte>[]()[]) | Adds the given key-value pair.
Add(String, Int32) | Adds the given key-value pair.
Add(String, Object) | Adds the given key-value pair.
Add(String, String) | Adds the given key-value pair.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    KeyValueCollection value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As KeyValueCollection _
)
Visual C++
public:
void Add(
    KeyValueCollection^ value
)

Parameters

value
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (Object)
KeyValueCollection Class See Also Send Feedback
Adds the given value as a KeyValueCollection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As Object _
)
Visual C++
public:
void Add(
    Object^ value
)

Parameters

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.Object)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (Object, Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (Object, Object)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    Object key,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As Object, _
    value As Object _
)
Visual C++
public:
virtual void Add(
    Object^ key,
    Object^ value
) sealed

Parameters

key
Type: System..::.Object

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.Object,System.Object)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.Object,System.Object)"]

Implements

IDictionary..::.Add(Object, Object)

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, KeyValueCollection)
KeyValueCollection Class See Also Send Feedback
Adds the given value with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    string key,
    KeyValueCollection value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As KeyValueCollection _
)
Visual C++
public:
void Add(
    String^ key,
    KeyValueCollection^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

value
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, NullableInt)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, NullableInt)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    string key,
    NullableInt value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As NullableInt _
)
Visual C++
public:
void Add(
    String^ key,
    NullableInt^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,Genesyslab.Enterprise.Commons.Collections.NullableInt)"]

value
Type: Genesyslab.Enterprise.Commons.Collections..::.NullableInt

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,Genesyslab.Enterprise.Commons.Collections.NullableInt)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, array<Byte>[]()[])
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As Byte() _
)
Visual C++
public:
void Add(
    String^ key,
    array<unsigned char>^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.Byte[])"]

value
Type: array< System..::.Byte >[]()[]

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.Byte[])"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, Int32)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    string key,
    int value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As Integer _
)
Visual C++
public:
void Add(
    String^ key,
    int value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.Int32)"]

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.Int32)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, Object)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    string key,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As Object _
)
Visual C++
public:
void Add(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.Object)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.Object)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Add Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Add Method (String, String)
KeyValueCollection Class See Also Send Feedback
Adds the given key-value pair.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    string key,
    string value
)
Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As String _
)
Visual C++
public:
void Add(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.String)"]

value
Type: System..::.String

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Add(System.String,System.String)"]

See Also

KeyValueCollection Class
Add Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Clear Method
KeyValueCollection Class See Also Send Feedback
Clears the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

IDictionary..::.Clear()()()

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Contains Method
KeyValueCollection Class See Also Send Feedback
Returns true if the collection contains this key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Contains(
    Object key
)
Visual Basic (Declaration)
Public Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ key
) sealed

Parameters

key
Type: System..::.Object

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Contains(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Contains(System.Object)"]

Implements

IDictionary..::.Contains(Object)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.ContainsKey Method
KeyValueCollection Class See Also Send Feedback
Returns true if the collection contains this key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
public:
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.ContainsKey(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.ContainsKey(System.String)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


CopyTo Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.CopyTo Method
KeyValueCollection Class See Also Send Feedback
Copies a range of key-value pairs into the given destination array, starting from the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void CopyTo(
    Array destination,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    destination As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ destination,
    int index
) sealed

Parameters

destination
Type: System..::.Array
Destination array. If the given index is greater that this destination's length, an ArgumentException exception is thrown.
index
Type: System..::.Int32
Index range to start the copy.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Equals Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Equals Method
KeyValueCollection Class See Also Send Feedback
Returns true if the given object is identical to this collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Equals(System.Object)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Get Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Get Method
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Get(Int32) | Returns the object at the given index.
Get(String) | Returns the object associated with the given key.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Get Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Get Method (Int32)
KeyValueCollection Class See Also Send Feedback
Returns the object at the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Get(
    int index
)
Visual Basic (Declaration)
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
Object^ Get(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Get(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Get(System.Int32)"]

See Also

KeyValueCollection Class
Get Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Get Method (String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Get Method (String)
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Get(
    string key
)
Visual Basic (Declaration)
Public Function Get ( _
    key As String _
) As Object
Visual C++
public:
Object^ Get(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Get(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Get(System.String)"]

See Also

KeyValueCollection Class
Get Overload
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsBinary Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as a byte array.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public byte[] GetAsBinary(
    string key
)
Visual Basic (Declaration)
Public Function GetAsBinary ( _
    key As String _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetAsBinary(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsBinary(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsBinary(System.String)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsInt Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsInt Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as int.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int GetAsInt(
    string key
)
Visual Basic (Declaration)
Public Function GetAsInt ( _
    key As String _
) As Integer
Visual C++
public:
int GetAsInt(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsInt(System.String)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsKeyValueCollection Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsKeyValueCollection Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as KeyValueCollection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetAsKeyValueCollection(
    string key
)
Visual Basic (Declaration)
Public Function GetAsKeyValueCollection ( _
    key As String _
) As KeyValueCollection
Visual C++
public:
KeyValueCollection^ GetAsKeyValueCollection(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsKeyValueCollection(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsKeyValueCollection(System.String)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetAsString Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetAsString Method
KeyValueCollection Class See Also Send Feedback
Returns the object associated with the given key as string.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string GetAsString(
    string key
)
Visual Basic (Declaration)
Public Function GetAsString ( _
    key As String _
) As String
Visual C++
public:
String^ GetAsString(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetAsString(System.String)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetEnumerator Method
KeyValueCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetEnumerator"]

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetEnumerator"]

Implements

IEnumerable..::.GetEnumerator()()()
IEnumerable..::.GetEnumerator()()()

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetHashCode Method
KeyValueCollection Class See Also Send Feedback
Returns the collection's hash code.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetHashCode"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetKey Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetKey Method
KeyValueCollection Class See Also Send Feedback
Returns the key at the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string GetKey(
    int index
)
Visual Basic (Declaration)
Public Function GetKey ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetKey(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetKey(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetKey(System.Int32)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetObjectData Method
KeyValueCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetValues Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.GetValues Method
KeyValueCollection Class See Also Send Feedback
Returns the values for this key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object[] GetValues(
    string key
)
Visual Basic (Declaration)
Public Function GetValues ( _
    key As String _
) As Object()
Visual C++
public:
array<Object^>^ GetValues(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetValues(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.GetValues(System.String)"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


HasKeys Method

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.HasKeys Method
KeyValueCollection Class See Also Send Feedback
Returns true if the collection has keys.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool HasKeys()
Visual Basic (Declaration)
Public Function HasKeys As Boolean
Visual C++
public:
bool HasKeys()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.HasKeys"]

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Remove Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Remove Method
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(Object) | Removes the given key and associated object.
Remove(String) | Removes the given key and associated object.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Remove Method (Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Remove Method (Object)
KeyValueCollection Class See Also Send Feedback
Removes the given key and associated object.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Remove(
    Object key
)
Visual Basic (Declaration)
Public Sub Remove ( _
    key As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ key
) sealed

Parameters

key
Type: System..::.Object

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Remove(System.Object)"]

Implements

IDictionary..::.Remove(Object)

See Also

KeyValueCollection Class
Remove Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Remove Method (String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Remove Method (String)
KeyValueCollection Class See Also Send Feedback
Removes the given key and associated object.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Remove(
    string key
)
Visual Basic (Declaration)
Public Sub Remove ( _
    key As String _
)
Visual C++
public:
void Remove(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollection.Remove(System.String)"]

See Also

KeyValueCollection Class
Remove Overload
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollection Properties

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection Properties
KeyValueCollection Class See Also Send Feedback

The KeyValueCollection type exposes the following members.

Properties

Name | Description
AllKeys | Returns all the keys of the collection.
AllValues | Returns all the values of the collection.
Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
IsFixedSize | Returns true if the collection size is fixed.
IsReadOnly | Returns true if the collection size is read only.
Item | Overloaded.
Keys | Returns all the keys of the collection.
Values | Returns all the values of the collection.

Explicit Interface Implementations

Name | Description
ICollection..::.IsSynchronized | Gets a value indicating whether access to the NameObjectCollectionBase object is synchronized (thread safe). (Inherited from NameObjectCollectionBase.)
ICollection..::.SyncRoot | Gets an object that can be used to synchronize access to the NameObjectCollectionBase object. (Inherited from NameObjectCollectionBase.)

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.AllKeys Property
KeyValueCollection Class See Also Send Feedback
Returns all the keys of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string[] AllKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllKeys As String()
Visual C++
public:
property array<String^>^ AllKeys {
    array<String^>^ get ();
}

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


AllValues Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.AllValues Property
KeyValueCollection Class See Also Send Feedback
Returns all the values of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object[] AllValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllValues As Object()
Visual C++
public:
property array<Object^>^ AllValues {
    array<Object^>^ get ();
}

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


IsFixedSize Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.IsFixedSize Property
KeyValueCollection Class See Also Send Feedback
Returns true if the collection size is fixed.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual C++
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}

Implements

IDictionary..::.IsFixedSize

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


IsReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.IsReadOnly Property
KeyValueCollection Class See Also Send Feedback
Returns true if the collection size is read only.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

IDictionary..::.IsReadOnly

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property
KeyValueCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Returns the value associated with the given index.
Item[([(Object])]) | Returns the value associated with the given key.
Item[([(String])]) | Returns the value associated with the given key.

See Also

KeyValueCollection Class
KeyValueCollection Members
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property (Int32)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property (Int32)
KeyValueCollection Class See Also Send Feedback
Returns the value associated with the given index.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::.Int32

Return Value

See Also

KeyValueCollection Class
Item Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property (Object)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property (Object)
KeyValueCollection Class See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object this[
    Object key
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}

Parameters

key
Type: System..::.Object

Implements

IDictionary..::.Item[([(Object])])

See Also

KeyValueCollection Class
Item Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Item Property (String)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Item Property (String)
KeyValueCollection Class See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object this[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    key As String _
) As Object
Visual C++
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}

Parameters

key
Type: System..::.String

See Also

KeyValueCollection Class
Item Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Keys Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Keys Property
KeyValueCollection Class See Also Send Feedback
Returns all the keys of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection Keys { get; }
Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection
Visual C++
public:
virtual property ICollection^ Keys {
    ICollection^ get () sealed;
}

Implements

IDictionary..::.Keys

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


Values Property

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollection..::.Values Property
KeyValueCollection Class See Also Send Feedback
Returns all the values of the collection.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection
Visual C++
public:
virtual property ICollection^ Values {
    ICollection^ get () sealed;
}

Implements

IDictionary..::.Values

See Also

KeyValueCollection Class
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollectionHelper Class

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper Class
Members See Also Send Feedback
Converts key-value collections.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class KeyValueCollectionHelper
Visual Basic (Declaration)
Public NotInheritable Class KeyValueCollectionHelper
Visual C++
public ref class KeyValueCollectionHelper abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollectionHelper

See Also

KeyValueCollectionHelper Members
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollectionHelper Members

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper Members
KeyValueCollectionHelper Class Methods See Also Send Feedback

Methods

Name | Description
ConvertToEnterpriseKeyValueCollection | Overloaded.
ConvertToPSDKKeyValueCollection | Overloaded.

See Also

KeyValueCollectionHelper Class
Genesyslab.Enterprise.Commons.Collections Namespace


KeyValueCollectionHelper Methods

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper Methods
KeyValueCollectionHelper Class See Also Send Feedback

Methods

Name | Description
ConvertToEnterpriseKeyValueCollection | Overloaded.
ConvertToPSDKKeyValueCollection | Overloaded.

See Also

KeyValueCollectionHelper Class
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToEnterpriseKeyValueCollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToEnterpriseKeyValueCollection Method
KeyValueCollectionHelper Class See Also Send Feedback

Overload List

Name | Description
ConvertToEnterpriseKeyValueCollection(IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Converts the given collection of dynamic attributes to the Enterprise SDK format.
ConvertToEnterpriseKeyValueCollection(KeyValueCollection) | Converts the given Platform SDK key-value collection to the Enterprise SDK format.

See Also

KeyValueCollectionHelper Class
KeyValueCollectionHelper Members
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToEnterpriseKeyValueCollection Method (IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToEnterpriseKeyValueCollection Method (IAttributeDataManager<(Of <(IDynamicAttribute>)>))
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given collection of dynamic attributes to the Enterprise SDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static KeyValueCollection ConvertToEnterpriseKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute> collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToEnterpriseKeyValueCollection ( _
    collection As IAttributeDataManager(Of IDynamicAttribute) _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToEnterpriseKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute^>^ collection
)

Parameters

collection
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)

[Missing <param name="collection"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollectionHelper.ConvertToEnterpriseKeyValueCollection(Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollectionHelper.ConvertToEnterpriseKeyValueCollection(Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

See Also

KeyValueCollectionHelper Class
ConvertToEnterpriseKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToEnterpriseKeyValueCollection Method ()

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToEnterpriseKeyValueCollection Method ()
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given Platform SDK key-value collection to the Enterprise SDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static KeyValueCollection ConvertToEnterpriseKeyValueCollection(
    KeyValueCollection collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToEnterpriseKeyValueCollection ( _
    collection As KeyValueCollection _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToEnterpriseKeyValueCollection(
    KeyValueCollection^ collection
)

Parameters

collection
Type: KeyValueCollection

[Missing <param name="collection"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollectionHelper.ConvertToEnterpriseKeyValueCollection(Genesyslab.Platform.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollectionHelper.ConvertToEnterpriseKeyValueCollection(Genesyslab.Platform.Commons.Collections.KeyValueCollection)"]

See Also

KeyValueCollectionHelper Class
ConvertToEnterpriseKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToPSDKKeyValueCollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToPSDKKeyValueCollection Method
KeyValueCollectionHelper Class See Also Send Feedback

Overload List

Name | Description
ConvertToPSDKKeyValueCollection(KeyValueCollection) | Converts the given Enterprise SDK KeyValueCollection to the PSDK format.
ConvertToPSDKKeyValueCollection(IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Converts the given collection of dynamic attributes to the Platform SDK format.

See Also

KeyValueCollectionHelper Class
KeyValueCollectionHelper Members
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToPSDKKeyValueCollection Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToPSDKKeyValueCollection Method (KeyValueCollection)
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given Enterprise SDK KeyValueCollection to the PSDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static KeyValueCollection ConvertToPSDKKeyValueCollection(
    KeyValueCollection collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToPSDKKeyValueCollection ( _
    collection As KeyValueCollection _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToPSDKKeyValueCollection(
    KeyValueCollection^ collection
)

Parameters

collection
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Enterprise SDK Collection

Return Value

KeyValueCollection in PSDK Format

See Also

KeyValueCollectionHelper Class
ConvertToPSDKKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ConvertToPSDKKeyValueCollection Method (IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
KeyValueCollectionHelper..::.ConvertToPSDKKeyValueCollection Method (IAttributeDataManager<(Of <(IDynamicAttribute>)>))
KeyValueCollectionHelper Class See Also Send Feedback
Converts the given collection of dynamic attributes to the Platform SDK format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static KeyValueCollection ConvertToPSDKKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute> collection
)
Visual Basic (Declaration)
Public Shared Function ConvertToPSDKKeyValueCollection ( _
    collection As IAttributeDataManager(Of IDynamicAttribute) _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ ConvertToPSDKKeyValueCollection(
    IAttributeDataManager<IDynamicAttribute^>^ collection
)

Parameters

collection
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)

[Missing <param name="collection"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollectionHelper.ConvertToPSDKKeyValueCollection(Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.KeyValueCollectionHelper.ConvertToPSDKKeyValueCollection(Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

See Also

KeyValueCollectionHelper Class
ConvertToPSDKKeyValueCollection Overload
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Class

[image]

Enterprise SDK 8.0 Reference API
NullableInt Class
Members See Also Send Feedback
Nullable integer.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class NullableInt
Visual Basic (Declaration)
Public Class NullableInt
Visual C++
public ref class NullableInt

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Commons.Collections..::.NullableInt

See Also

NullableInt Members
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Members

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt Members
NullableInt Class Constructors Methods See Also Send Feedback

The NullableInt type exposes the following members.

Constructors

Name | Description
NullableInt | Overloaded.

Methods

Name | Description
Equals | Returns true if the given object is identical. (Overrides Object..::.Equals(Object).)
GetHashCode | Returns the hash code of this object. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Overloaded.

Operators

Name | Description
Explicit | Returns the object's int value.
Implicit | Creates a new nullable integer.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt Constructor
NullableInt Class See Also Send Feedback

Overload List

Name | Description
NullableInt()()() | Constructor.
NullableInt(Int32) | Constructor.

See Also

NullableInt Class
NullableInt Members
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Constructor

[image]

Enterprise SDK 8.0 Reference API
NullableInt Constructor
NullableInt Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NullableInt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NullableInt()

See Also

NullableInt Class
NullableInt Overload
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
NullableInt Constructor (Int32)
NullableInt Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NullableInt(
    int value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Integer _
)
Visual C++
public:
NullableInt(
    int value
)

Parameters

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.#ctor(System.Int32)"]

See Also

NullableInt Class
NullableInt Overload
Genesyslab.Enterprise.Commons.Collections Namespace


NullableInt Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt Methods
NullableInt Class See Also Send Feedback

The NullableInt type exposes the following members.

Methods

Name | Description
Equals | Returns true if the given object is identical. (Overrides Object..::.Equals(Object).)
GetHashCode | Returns the hash code of this object. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Overloaded.

Operators

Name | Description
Explicit | Returns the object's int value.
Implicit | Creates a new nullable integer.

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


Equals Method

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.Equals Method
NullableInt Class See Also Send Feedback
Returns true if the given object is identical.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.Equals(System.Object)"]

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


Explicit Operator

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.Explicit Operator
NullableInt Class See Also Send Feedback
Returns the object's int value.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static explicit operator int (
    NullableInt ni
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    ni As NullableInt _
) As Integer
Visual C++
static explicit operator int (
    NullableInt^ ni
)

Parameters

ni
Type: Genesyslab.Enterprise.Commons.Collections..::.NullableInt

[Missing <param name="ni"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.op_Explicit(Genesyslab.Enterprise.Commons.Collections.NullableInt)~System.Int32"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.op_Explicit(Genesyslab.Enterprise.Commons.Collections.NullableInt)~System.Int32"]

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.GetHashCode Method
NullableInt Class See Also Send Feedback
Returns the hash code of this object.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.GetHashCode"]

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


Implicit Operator

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.Implicit Operator
NullableInt Class See Also Send Feedback
Creates a new nullable integer.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static implicit operator NullableInt (
    int value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Integer _
) As NullableInt
Visual C++
static implicit operator NullableInt^ (
    int value
)

Parameters

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.op_Implicit(System.Int32)~Genesyslab.Enterprise.Commons.Collections.NullableInt"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.op_Implicit(System.Int32)~Genesyslab.Enterprise.Commons.Collections.NullableInt"]

See Also

NullableInt Class
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method

[image] [image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method
NullableInt Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns the object's string code. (Overrides Object..::.ToString()()().)
ToString(IFormatProvider) | Returns the object's string code.
ToString(String) | Returns the object's string code with the given format.
ToString(String, IFormatProvider) | Returns the object's string code with the given format.

See Also

NullableInt Class
NullableInt Members
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method
NullableInt Class See Also Send Feedback
Returns the object's string code.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString"]

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method (IFormatProvider)

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method (IFormatProvider)
NullableInt Class See Also Send Feedback
Returns the object's string code.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ToString(
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    IFormatProvider^ provider
)

Parameters

provider
Type: System..::.IFormatProvider

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.IFormatProvider)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.IFormatProvider)"]

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method (String)

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method (String)
NullableInt Class See Also Send Feedback
Returns the object's string code with the given format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ToString(
    string format
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String _
) As String
Visual C++
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: System..::.String

[Missing <param name="format"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.String)"]

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


ToString Method (String, IFormatProvider)

[image]

Enterprise SDK 8.0 Reference API
NullableInt..::.ToString Method (String, IFormatProvider)
NullableInt Class See Also Send Feedback
Returns the object's string code with the given format.

Namespace: Genesyslab.Enterprise.Commons.Collections
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ToString(
    string format,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    String^ format,
    IFormatProvider^ provider
)

Parameters

format
Type: System..::.String

[Missing <param name="format"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.String,System.IFormatProvider)"]

provider
Type: System..::.IFormatProvider

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.String,System.IFormatProvider)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Commons.Collections.NullableInt.ToString(System.String,System.IFormatProvider)"]

See Also

NullableInt Class
ToString Overload
Genesyslab.Enterprise.Commons.Collections Namespace


Genesyslab.Enterprise.Communication.AgentService Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Communication.AgentService Namespace
Send Feedback

Classes

Class | Description
AgentServiceREST | AgentService API exposed as WCF ReST API
AgentServiceSOAP | AgentService API exposed as WCF SOAP API

Interfaces

Interface | Description
IAgentServiceRESTContract | AgentService REST WCF Contract
IAgentServiceSOAPContract | AgentService SOAP WCF Contract


AgentServiceREST Class

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST Class
Members See Also Send Feedback
AgentService API exposed as WCF ReST API

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class AgentServiceREST : IAgentServiceRESTContract
Visual Basic (Declaration)
Public Class AgentServiceREST _
    Implements IAgentServiceRESTContract
Visual C++
public ref class AgentServiceREST : IAgentServiceRESTContract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService..::.AgentServiceREST

See Also

AgentServiceREST Members
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceREST Members

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceREST Members
AgentServiceREST Class Constructors Methods Fields Properties See Also Send Feedback

The AgentServiceREST type exposes the following members.

Constructors

Name | Description
AgentServiceREST |

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardCancelJSON | Deactivates the Forward feature for the given device. JSON Format
CallForwardSet | Activates the Forward feature for the given device.
CallForwardSetJSON | Activates the Forward feature for the given device. JSON Format
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAgent | Get an Agent
GetAgentJSON | Get an Agent (JsON Format)
GetAgents | Lists all the Agents in the System
GetAgentsJSON | Get an Agent (JsON Format)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
GetVersionJSON |
Login | Logs in the agent to the ACD group specified by the queue parameter.
LoginJSON | Logs in the agent to the ACD group specified by the queue parameter. JSON Format
Logout | Logs the agent out of the ACD group specified by the parameter queue.
LogoutJSON | Logs the agent out of the ACD group specified by the parameter queue. JSON Format
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
NotReadyJSON | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. JSON Format
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
ReadyJSON | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. JSON Format
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOffJSON | Deactivates the Do Not Disturb feature for the given device. JSON Format
SetDNDOn | Activates the Do Not Disturb feature for the given device.
SetDNDOnJSON | Activates the Do Not Disturb feature for the given device. JSON Format
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
EVENTSTATE |

Properties

Name | Description
ClientChannel |
Details |
Service |

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceREST Constructor

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST Constructor
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentServiceREST(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
AgentServiceREST(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceREST Fields

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceREST Fields
AgentServiceREST Class See Also Send Feedback

The AgentServiceREST type exposes the following members.

Fields

Name | Description
EVENTSTATE |

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


EVENTSTATE Field

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.EVENTSTATE Field
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.EVENTSTATE"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EVENTSTATE
Visual Basic (Declaration)
Public Const EVENTSTATE As String
Visual C++
public:
literal String^ EVENTSTATE

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceREST Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceREST Methods
AgentServiceREST Class See Also Send Feedback

The AgentServiceREST type exposes the following members.

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardCancelJSON | Deactivates the Forward feature for the given device. JSON Format
CallForwardSet | Activates the Forward feature for the given device.
CallForwardSetJSON | Activates the Forward feature for the given device. JSON Format
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAgent | Get an Agent
GetAgentJSON | Get an Agent (JsON Format)
GetAgents | Lists all the Agents in the System
GetAgentsJSON | Get an Agent (JsON Format)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
GetVersionJSON |
Login | Logs in the agent to the ACD group specified by the queue parameter.
LoginJSON | Logs in the agent to the ACD group specified by the queue parameter. JSON Format
Logout | Logs the agent out of the ACD group specified by the parameter queue.
LogoutJSON | Logs the agent out of the ACD group specified by the parameter queue. JSON Format
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
NotReadyJSON | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. JSON Format
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
ReadyJSON | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. JSON Format
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOffJSON | Deactivates the Do Not Disturb feature for the given device. JSON Format
SetDNDOn | Activates the Do Not Disturb feature for the given device.
SetDNDOnJSON | Activates the Do Not Disturb feature for the given device. JSON Format
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.CallForwardCancel Method
AgentServiceREST Class See Also Send Feedback
Deactivates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardCancelResponse CallForwardCancel(
    CallForwardCancelRequest request
)
Visual Basic (Declaration)
Public Function CallForwardCancel ( _
    request As CallForwardCancelRequest _
) As CallForwardCancelResponse
Visual C++
public:
virtual CallForwardCancelResponse^ CallForwardCancel(
    CallForwardCancelRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.CallForwardCancel(CallForwardCancelRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardCancelJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.CallForwardCancelJSON Method
AgentServiceREST Class See Also Send Feedback
Deactivates the Forward feature for the given device. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardCancelResponse CallForwardCancelJSON(
    CallForwardCancelRequest request
)
Visual Basic (Declaration)
Public Function CallForwardCancelJSON ( _
    request As CallForwardCancelRequest _
) As CallForwardCancelResponse
Visual C++
public:
virtual CallForwardCancelResponse^ CallForwardCancelJSON(
    CallForwardCancelRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.CallForwardCancelJSON(CallForwardCancelRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.CallForwardSet Method
AgentServiceREST Class See Also Send Feedback
Activates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardSetResponse CallForwardSet(
    CallForwardSetRequest request
)
Visual Basic (Declaration)
Public Function CallForwardSet ( _
    request As CallForwardSetRequest _
) As CallForwardSetResponse
Visual C++
public:
virtual CallForwardSetResponse^ CallForwardSet(
    CallForwardSetRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.CallForwardSet(CallForwardSetRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardSetJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.CallForwardSetJSON Method
AgentServiceREST Class See Also Send Feedback
Activates the Forward feature for the given device. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardSetResponse CallForwardSetJSON(
    CallForwardSetRequest request
)
Visual Basic (Declaration)
Public Function CallForwardSetJSON ( _
    request As CallForwardSetRequest _
) As CallForwardSetResponse
Visual C++
public:
virtual CallForwardSetResponse^ CallForwardSetJSON(
    CallForwardSetRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.CallForwardSetJSON(CallForwardSetRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgent Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.GetAgent Method
AgentServiceREST Class See Also Send Feedback
Get an Agent

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO GetAgent(
    string name
)
Visual Basic (Declaration)
Public Function GetAgent ( _
    name As String _
) As AgentDTO
Visual C++
public:
virtual AgentDTO^ GetAgent(
    String^ name
) sealed

Parameters

name
Type: System..::.String
Agent Id

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.GetAgent(String)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgentJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.GetAgentJSON Method
AgentServiceREST Class See Also Send Feedback
Get an Agent (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO GetAgentJSON(
    string name
)
Visual Basic (Declaration)
Public Function GetAgentJSON ( _
    name As String _
) As AgentDTO
Visual C++
public:
virtual AgentDTO^ GetAgentJSON(
    String^ name
) sealed

Parameters

name
Type: System..::.String
Agent Id (JsON Format)

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.GetAgentJSON(String)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgents Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.GetAgents Method
AgentServiceREST Class See Also Send Feedback
Lists all the Agents in the System

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<AgentDTO> GetAgents()
Visual Basic (Declaration)
Public Function GetAgents As List(Of AgentDTO)
Visual C++
public:
virtual List<AgentDTO^>^ GetAgents() sealed

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.GetAgents()()()

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgentsJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.GetAgentsJSON Method
AgentServiceREST Class See Also Send Feedback
Get an Agent (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<AgentDTO> GetAgentsJSON()
Visual Basic (Declaration)
Public Function GetAgentsJSON As List(Of AgentDTO)
Visual C++
public:
virtual List<AgentDTO^>^ GetAgentsJSON() sealed

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.GetAgentsJSON()()()

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.GetVersion Method
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.GetVersion"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetVersion()
Visual Basic (Declaration)
Public Function GetVersion As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetVersion() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.GetVersion"]

Implements

IAgentServiceRESTContract..::.GetVersion()()()

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetVersionJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.GetVersionJSON Method
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.GetVersionJSON"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetVersionJSON()
Visual Basic (Declaration)
Public Function GetVersionJSON As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetVersionJSON() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.GetVersionJSON"]

Implements

IAgentServiceRESTContract..::.GetVersionJSON()()()

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Login Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.Login Method
AgentServiceREST Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LoginResponse Login(
    LoginRequest request
)
Visual Basic (Declaration)
Public Function Login ( _
    request As LoginRequest _
) As LoginResponse
Visual C++
public:
virtual LoginResponse^ Login(
    LoginRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.Login(LoginRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


LoginJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.LoginJSON Method
AgentServiceREST Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LoginResponse LoginJSON(
    LoginRequest request
)
Visual Basic (Declaration)
Public Function LoginJSON ( _
    request As LoginRequest _
) As LoginResponse
Visual C++
public:
virtual LoginResponse^ LoginJSON(
    LoginRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.LoginJSON(LoginRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Logout Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.Logout Method
AgentServiceREST Class See Also Send Feedback
Logs the agent out of the ACD group specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LogoutResponse Logout(
    LogoutRequest request
)
Visual Basic (Declaration)
Public Function Logout ( _
    request As LogoutRequest _
) As LogoutResponse
Visual C++
public:
virtual LogoutResponse^ Logout(
    LogoutRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.Logout(LogoutRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


LogoutJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.LogoutJSON Method
AgentServiceREST Class See Also Send Feedback
Logs the agent out of the ACD group specified by the parameter queue. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LogoutResponse LogoutJSON(
    LogoutRequest request
)
Visual Basic (Declaration)
Public Function LogoutJSON ( _
    request As LogoutRequest _
) As LogoutResponse
Visual C++
public:
virtual LogoutResponse^ LogoutJSON(
    LogoutRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.LogoutJSON(LogoutRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


NotReady Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.NotReady Method
AgentServiceREST Class See Also Send Feedback
Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotReadyResponse NotReady(
    NotReadyRequest request
)
Visual Basic (Declaration)
Public Function NotReady ( _
    request As NotReadyRequest _
) As NotReadyResponse
Visual C++
public:
virtual NotReadyResponse^ NotReady(
    NotReadyRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.NotReady(NotReadyRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


NotReadyJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.NotReadyJSON Method
AgentServiceREST Class See Also Send Feedback
Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotReadyResponse NotReadyJSON(
    NotReadyRequest request
)
Visual Basic (Declaration)
Public Function NotReadyJSON ( _
    request As NotReadyRequest _
) As NotReadyResponse
Visual C++
public:
virtual NotReadyResponse^ NotReadyJSON(
    NotReadyRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.NotReadyJSON(NotReadyRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Ready Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.Ready Method
AgentServiceREST Class See Also Send Feedback
Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReadyResponse Ready(
    ReadyRequest request
)
Visual Basic (Declaration)
Public Function Ready ( _
    request As ReadyRequest _
) As ReadyResponse
Visual C++
public:
virtual ReadyResponse^ Ready(
    ReadyRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.Ready(ReadyRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


ReadyJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.ReadyJSON Method
AgentServiceREST Class See Also Send Feedback
Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReadyResponse ReadyJSON(
    ReadyRequest request
)
Visual Basic (Declaration)
Public Function ReadyJSON ( _
    request As ReadyRequest _
) As ReadyResponse
Visual C++
public:
virtual ReadyResponse^ ReadyJSON(
    ReadyRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.ReadyJSON(ReadyRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.SetDNDOff Method
AgentServiceREST Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOffResponse SetDNDOff(
    SetDNDOffRequest request
)
Visual Basic (Declaration)
Public Function SetDNDOff ( _
    request As SetDNDOffRequest _
) As SetDNDOffResponse
Visual C++
public:
virtual SetDNDOffResponse^ SetDNDOff(
    SetDNDOffRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.SetDNDOff(SetDNDOffRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOffJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.SetDNDOffJSON Method
AgentServiceREST Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the given device. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOffResponse SetDNDOffJSON(
    SetDNDOffRequest request
)
Visual Basic (Declaration)
Public Function SetDNDOffJSON ( _
    request As SetDNDOffRequest _
) As SetDNDOffResponse
Visual C++
public:
virtual SetDNDOffResponse^ SetDNDOffJSON(
    SetDNDOffRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.SetDNDOffJSON(SetDNDOffRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.SetDNDOn Method
AgentServiceREST Class See Also Send Feedback
Activates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOnResponse SetDNDOn(
    SetDNDOnRequest request
)
Visual Basic (Declaration)
Public Function SetDNDOn ( _
    request As SetDNDOnRequest _
) As SetDNDOnResponse
Visual C++
public:
virtual SetDNDOnResponse^ SetDNDOn(
    SetDNDOnRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.SetDNDOn(SetDNDOnRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOnJSON Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.SetDNDOnJSON Method
AgentServiceREST Class See Also Send Feedback
Activates the Do Not Disturb feature for the given device. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOnResponse SetDNDOnJSON(
    SetDNDOnRequest request
)
Visual Basic (Declaration)
Public Function SetDNDOnJSON ( _
    request As SetDNDOnRequest _
) As SetDNDOnResponse
Visual C++
public:
virtual SetDNDOnResponse^ SetDNDOnJSON(
    SetDNDOnRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceRESTContract..::.SetDNDOnJSON(SetDNDOnRequest)

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceREST Properties

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceREST Properties
AgentServiceREST Class See Also Send Feedback

The AgentServiceREST type exposes the following members.

Properties

Name | Description
ClientChannel |
Details |
Service |

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


ClientChannel Property

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.ClientChannel Property
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.ClientChannel"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IClientChannel ClientChannel { get; set; }
Visual Basic (Declaration)
Public Property ClientChannel As IClientChannel
Visual C++
public:
virtual property IClientChannel^ ClientChannel {
    IClientChannel^ get () sealed;
    void set (IClientChannel^ value) sealed;
}

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Details Property

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.Details Property
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.Details"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Details { get; set; }
Visual Basic (Declaration)
Public Property Details As KeyValueCollection
Visual C++
public:
virtual property KeyValueCollection^ Details {
    KeyValueCollection^ get () sealed;
    void set (KeyValueCollection^ value) sealed;
}

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Service Property

[image]

Enterprise SDK 8.0 Reference API
AgentServiceREST..::.Service Property
AgentServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.AgentServiceREST.Service"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Service { get; }
Visual Basic (Declaration)
Public ReadOnly Property Service As String
Visual C++
public:
property String^ Service {
    String^ get ();
}

See Also

AgentServiceREST Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceSOAP Class

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP Class
Members See Also Send Feedback
AgentService API exposed as WCF SOAP API

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class AgentServiceSOAP : IAgentServiceSOAPContract
Visual Basic (Declaration)
Public Class AgentServiceSOAP _
    Implements IAgentServiceSOAPContract
Visual C++
public ref class AgentServiceSOAP : IAgentServiceSOAPContract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService..::.AgentServiceSOAP

See Also

AgentServiceSOAP Members
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceSOAP Members

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP Members
AgentServiceSOAP Class Constructors Methods Properties See Also Send Feedback

The AgentServiceSOAP type exposes the following members.

Constructors

Name | Description
AgentServiceSOAP |

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardSet | Activates the Forward feature for the given device.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
Login | Logs in the agent to the ACD group specified by the queue parameter.
Logout | Logs the agent out of the ACD group specified by the parameter queue.
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOn | Activates the Do Not Disturb feature for the given device.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClientChannel | Communication Channel use to send requests to.
Details |
Service | Service Name

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceSOAP Constructor

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP Constructor
AgentServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceSOAP.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentServiceSOAP(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
AgentServiceSOAP(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceSOAP.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceSOAP Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP Methods
AgentServiceSOAP Class See Also Send Feedback

The AgentServiceSOAP type exposes the following members.

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardSet | Activates the Forward feature for the given device.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
Login | Logs in the agent to the ACD group specified by the queue parameter.
Logout | Logs the agent out of the ACD group specified by the parameter queue.
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOn | Activates the Do Not Disturb feature for the given device.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.CallForwardCancel Method
AgentServiceSOAP Class See Also Send Feedback
Deactivates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardCancelResponse CallForwardCancel(
    CallForwardCancelRequest request
)
Visual Basic (Declaration)
Public Function CallForwardCancel ( _
    request As CallForwardCancelRequest _
) As CallForwardCancelResponse
Visual C++
public:
virtual CallForwardCancelResponse^ CallForwardCancel(
    CallForwardCancelRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.CallForwardCancel(CallForwardCancelRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.CallForwardSet Method
AgentServiceSOAP Class See Also Send Feedback
Activates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardSetResponse CallForwardSet(
    CallForwardSetRequest request
)
Visual Basic (Declaration)
Public Function CallForwardSet ( _
    request As CallForwardSetRequest _
) As CallForwardSetResponse
Visual C++
public:
virtual CallForwardSetResponse^ CallForwardSet(
    CallForwardSetRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.CallForwardSet(CallForwardSetRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.GetVersion Method
AgentServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceSOAP.GetVersion"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetVersion()
Visual Basic (Declaration)
Public Function GetVersion As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetVersion() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.AgentServiceSOAP.GetVersion"]

Implements

IAgentServiceSOAPContract..::.GetVersion()()()

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Login Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.Login Method
AgentServiceSOAP Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LoginResponse Login(
    LoginRequest request
)
Visual Basic (Declaration)
Public Function Login ( _
    request As LoginRequest _
) As LoginResponse
Visual C++
public:
virtual LoginResponse^ Login(
    LoginRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.Login(LoginRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Logout Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.Logout Method
AgentServiceSOAP Class See Also Send Feedback
Logs the agent out of the ACD group specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LogoutResponse Logout(
    LogoutRequest request
)
Visual Basic (Declaration)
Public Function Logout ( _
    request As LogoutRequest _
) As LogoutResponse
Visual C++
public:
virtual LogoutResponse^ Logout(
    LogoutRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.Logout(LogoutRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


NotReady Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.NotReady Method
AgentServiceSOAP Class See Also Send Feedback
Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotReadyResponse NotReady(
    NotReadyRequest request
)
Visual Basic (Declaration)
Public Function NotReady ( _
    request As NotReadyRequest _
) As NotReadyResponse
Visual C++
public:
virtual NotReadyResponse^ NotReady(
    NotReadyRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.NotReady(NotReadyRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Ready Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.Ready Method
AgentServiceSOAP Class See Also Send Feedback
Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReadyResponse Ready(
    ReadyRequest request
)
Visual Basic (Declaration)
Public Function Ready ( _
    request As ReadyRequest _
) As ReadyResponse
Visual C++
public:
virtual ReadyResponse^ Ready(
    ReadyRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.Ready(ReadyRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.SetDNDOff Method
AgentServiceSOAP Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOffResponse SetDNDOff(
    SetDNDOffRequest request
)
Visual Basic (Declaration)
Public Function SetDNDOff ( _
    request As SetDNDOffRequest _
) As SetDNDOffResponse
Visual C++
public:
virtual SetDNDOffResponse^ SetDNDOff(
    SetDNDOffRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.SetDNDOff(SetDNDOffRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.SetDNDOn Method
AgentServiceSOAP Class See Also Send Feedback
Activates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOnResponse SetDNDOn(
    SetDNDOnRequest request
)
Visual Basic (Declaration)
Public Function SetDNDOn ( _
    request As SetDNDOnRequest _
) As SetDNDOnResponse
Visual C++
public:
virtual SetDNDOnResponse^ SetDNDOn(
    SetDNDOnRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest
The request to be sent to the server

Return Value

The server's response

Implements

IAgentServiceSOAPContract..::.SetDNDOn(SetDNDOnRequest)

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


AgentServiceSOAP Properties

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP Properties
AgentServiceSOAP Class See Also Send Feedback

The AgentServiceSOAP type exposes the following members.

Properties

Name | Description
ClientChannel | Communication Channel use to send requests to.
Details |
Service | Service Name

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


ClientChannel Property

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.ClientChannel Property
AgentServiceSOAP Class See Also Send Feedback
Communication Channel use to send requests to.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IClientChannel ClientChannel { get; set; }
Visual Basic (Declaration)
Public Property ClientChannel As IClientChannel
Visual C++
public:
virtual property IClientChannel^ ClientChannel {
    IClientChannel^ get () sealed;
    void set (IClientChannel^ value) sealed;
}

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Details Property

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.Details Property
AgentServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.AgentServiceSOAP.Details"]

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Details { get; set; }
Visual Basic (Declaration)
Public Property Details As KeyValueCollection
Visual C++
public:
virtual property KeyValueCollection^ Details {
    KeyValueCollection^ get () sealed;
    void set (KeyValueCollection^ value) sealed;
}

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


Service Property

[image]

Enterprise SDK 8.0 Reference API
AgentServiceSOAP..::.Service Property
AgentServiceSOAP Class See Also Send Feedback
Service Name

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Service { get; }
Visual Basic (Declaration)
Public ReadOnly Property Service As String
Visual C++
public:
property String^ Service {
    String^ get ();
}

See Also

AgentServiceSOAP Class
Genesyslab.Enterprise.Communication.AgentService Namespace


IAgentServiceRESTContract Interface

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract Interface
Members See Also Send Feedback
AgentService REST WCF Contract

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAgentServiceRESTContract
Visual Basic (Declaration)
Public Interface IAgentServiceRESTContract
Visual C++
public interface class IAgentServiceRESTContract

See Also

IAgentServiceRESTContract Members
Genesyslab.Enterprise.Communication.AgentService Namespace


IAgentServiceRESTContract Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract Members
IAgentServiceRESTContract Interface Methods See Also Send Feedback

The IAgentServiceRESTContract type exposes the following members.

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardCancelJSON | Deactivates the Forward feature for the given device., JSON Format
CallForwardSet | Activates the Forward feature for the given device.
CallForwardSetJSON | Activates the Forward feature for the given device. , JSON Format
GetAgent | Get an Agent
GetAgentJSON | Get an Agent (JsON Format)
GetAgents | Lists all the Agents in the System
GetAgentsJSON | Lists all the Agents in the System (JsON Format)
GetVersion | Get Service Version.
GetVersionJSON | Get Service Version. JSON Format
Login | Logs in the agent to the ACD group specified by the queue parameter.
LoginJSON | Logs in the agent to the ACD group specified by the queue parameter., JSON Format
Logout | Logs the agent out of the ACD group specified by the parameter queue.
LogoutJSON | Logs the agent out of the ACD group specified by the parameter queue., JSON Format
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
NotReadyJSON | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. , JSON Format
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
ReadyJSON | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. , JSON Format
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOffJSON | Deactivates the Do Not Disturb feature for the given device., JSON Format
SetDNDOn | Activates the Do Not Disturb feature for the given device.
SetDNDOnJSON | Activates the Do Not Disturb feature for the given device. , JSON Format

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


IAgentServiceRESTContract Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract Methods
IAgentServiceRESTContract Interface See Also Send Feedback

The IAgentServiceRESTContract type exposes the following members.

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardCancelJSON | Deactivates the Forward feature for the given device., JSON Format
CallForwardSet | Activates the Forward feature for the given device.
CallForwardSetJSON | Activates the Forward feature for the given device. , JSON Format
GetAgent | Get an Agent
GetAgentJSON | Get an Agent (JsON Format)
GetAgents | Lists all the Agents in the System
GetAgentsJSON | Lists all the Agents in the System (JsON Format)
GetVersion | Get Service Version.
GetVersionJSON | Get Service Version. JSON Format
Login | Logs in the agent to the ACD group specified by the queue parameter.
LoginJSON | Logs in the agent to the ACD group specified by the queue parameter., JSON Format
Logout | Logs the agent out of the ACD group specified by the parameter queue.
LogoutJSON | Logs the agent out of the ACD group specified by the parameter queue., JSON Format
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
NotReadyJSON | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. , JSON Format
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
ReadyJSON | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. , JSON Format
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOffJSON | Deactivates the Do Not Disturb feature for the given device., JSON Format
SetDNDOn | Activates the Do Not Disturb feature for the given device.
SetDNDOnJSON | Activates the Do Not Disturb feature for the given device. , JSON Format

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.CallForwardCancel Method
IAgentServiceRESTContract Interface See Also Send Feedback
Deactivates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CallForwardCancelResponse CallForwardCancel(
    CallForwardCancelRequest request
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    request As CallForwardCancelRequest _
) As CallForwardCancelResponse
Visual C++
CallForwardCancelResponse^ CallForwardCancel(
    CallForwardCancelRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardCancelJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.CallForwardCancelJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Deactivates the Forward feature for the given device., JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CallForwardCancelResponse CallForwardCancelJSON(
    CallForwardCancelRequest request
)
Visual Basic (Declaration)
Function CallForwardCancelJSON ( _
    request As CallForwardCancelRequest _
) As CallForwardCancelResponse
Visual C++
CallForwardCancelResponse^ CallForwardCancelJSON(
    CallForwardCancelRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.CallForwardSet Method
IAgentServiceRESTContract Interface See Also Send Feedback
Activates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CallForwardSetResponse CallForwardSet(
    CallForwardSetRequest request
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    request As CallForwardSetRequest _
) As CallForwardSetResponse
Visual C++
CallForwardSetResponse^ CallForwardSet(
    CallForwardSetRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardSetJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.CallForwardSetJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Activates the Forward feature for the given device. , JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CallForwardSetResponse CallForwardSetJSON(
    CallForwardSetRequest request
)
Visual Basic (Declaration)
Function CallForwardSetJSON ( _
    request As CallForwardSetRequest _
) As CallForwardSetResponse
Visual C++
CallForwardSetResponse^ CallForwardSetJSON(
    CallForwardSetRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgent Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.GetAgent Method
IAgentServiceRESTContract Interface See Also Send Feedback
Get an Agent

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentDTO GetAgent(
    string name
)
Visual Basic (Declaration)
Function GetAgent ( _
    name As String _
) As AgentDTO
Visual C++
AgentDTO^ GetAgent(
    String^ name
)

Parameters

name
Type: System..::.String
Agent Id

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgentJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.GetAgentJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Get an Agent (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentDTO GetAgentJSON(
    string name
)
Visual Basic (Declaration)
Function GetAgentJSON ( _
    name As String _
) As AgentDTO
Visual C++
AgentDTO^ GetAgentJSON(
    String^ name
)

Parameters

name
Type: System..::.String
Agent Id (JsON Format)

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgents Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.GetAgents Method
IAgentServiceRESTContract Interface See Also Send Feedback
Lists all the Agents in the System

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
List<AgentDTO> GetAgents()
Visual Basic (Declaration)
Function GetAgents As List(Of AgentDTO)
Visual C++
List<AgentDTO^>^ GetAgents()

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetAgentsJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.GetAgentsJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Lists all the Agents in the System (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
List<AgentDTO> GetAgentsJSON()
Visual Basic (Declaration)
Function GetAgentsJSON As List(Of AgentDTO)
Visual C++
List<AgentDTO^>^ GetAgentsJSON()

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.GetVersion Method
IAgentServiceRESTContract Interface See Also Send Feedback
Get Service Version.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetVersion()
Visual Basic (Declaration)
Function GetVersion As KeyValueCollection
Visual C++
KeyValueCollection^ GetVersion()

Return Value

Version details

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetVersionJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.GetVersionJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Get Service Version. JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetVersionJSON()
Visual Basic (Declaration)
Function GetVersionJSON As KeyValueCollection
Visual C++
KeyValueCollection^ GetVersionJSON()

Return Value

Version details

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Login Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.Login Method
IAgentServiceRESTContract Interface See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
LoginResponse Login(
    LoginRequest request
)
Visual Basic (Declaration)
Function Login ( _
    request As LoginRequest _
) As LoginResponse
Visual C++
LoginResponse^ Login(
    LoginRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


LoginJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.LoginJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter., JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
LoginResponse LoginJSON(
    LoginRequest request
)
Visual Basic (Declaration)
Function LoginJSON ( _
    request As LoginRequest _
) As LoginResponse
Visual C++
LoginResponse^ LoginJSON(
    LoginRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Logout Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.Logout Method
IAgentServiceRESTContract Interface See Also Send Feedback
Logs the agent out of the ACD group specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
LogoutResponse Logout(
    LogoutRequest request
)
Visual Basic (Declaration)
Function Logout ( _
    request As LogoutRequest _
) As LogoutResponse
Visual C++
LogoutResponse^ Logout(
    LogoutRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


LogoutJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.LogoutJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Logs the agent out of the ACD group specified by the parameter queue., JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
LogoutResponse LogoutJSON(
    LogoutRequest request
)
Visual Basic (Declaration)
Function LogoutJSON ( _
    request As LogoutRequest _
) As LogoutResponse
Visual C++
LogoutResponse^ LogoutJSON(
    LogoutRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


NotReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.NotReady Method
IAgentServiceRESTContract Interface See Also Send Feedback
Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
NotReadyResponse NotReady(
    NotReadyRequest request
)
Visual Basic (Declaration)
Function NotReady ( _
    request As NotReadyRequest _
) As NotReadyResponse
Visual C++
NotReadyResponse^ NotReady(
    NotReadyRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


NotReadyJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.NotReadyJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. , JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
NotReadyResponse NotReadyJSON(
    NotReadyRequest request
)
Visual Basic (Declaration)
Function NotReadyJSON ( _
    request As NotReadyRequest _
) As NotReadyResponse
Visual C++
NotReadyResponse^ NotReadyJSON(
    NotReadyRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Ready Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.Ready Method
IAgentServiceRESTContract Interface See Also Send Feedback
Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReadyResponse Ready(
    ReadyRequest request
)
Visual Basic (Declaration)
Function Ready ( _
    request As ReadyRequest _
) As ReadyResponse
Visual C++
ReadyResponse^ Ready(
    ReadyRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


ReadyJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.ReadyJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue. , JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReadyResponse ReadyJSON(
    ReadyRequest request
)
Visual Basic (Declaration)
Function ReadyJSON ( _
    request As ReadyRequest _
) As ReadyResponse
Visual C++
ReadyResponse^ ReadyJSON(
    ReadyRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.SetDNDOff Method
IAgentServiceRESTContract Interface See Also Send Feedback
Deactivates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetDNDOffResponse SetDNDOff(
    SetDNDOffRequest request
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    request As SetDNDOffRequest _
) As SetDNDOffResponse
Visual C++
SetDNDOffResponse^ SetDNDOff(
    SetDNDOffRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOffJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.SetDNDOffJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Deactivates the Do Not Disturb feature for the given device., JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetDNDOffResponse SetDNDOffJSON(
    SetDNDOffRequest request
)
Visual Basic (Declaration)
Function SetDNDOffJSON ( _
    request As SetDNDOffRequest _
) As SetDNDOffResponse
Visual C++
SetDNDOffResponse^ SetDNDOffJSON(
    SetDNDOffRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.SetDNDOn Method
IAgentServiceRESTContract Interface See Also Send Feedback
Activates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetDNDOnResponse SetDNDOn(
    SetDNDOnRequest request
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    request As SetDNDOnRequest _
) As SetDNDOnResponse
Visual C++
SetDNDOnResponse^ SetDNDOn(
    SetDNDOnRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOnJSON Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceRESTContract..::.SetDNDOnJSON Method
IAgentServiceRESTContract Interface See Also Send Feedback
Activates the Do Not Disturb feature for the given device. , JSON Format

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetDNDOnResponse SetDNDOnJSON(
    SetDNDOnRequest request
)
Visual Basic (Declaration)
Function SetDNDOnJSON ( _
    request As SetDNDOnRequest _
) As SetDNDOnResponse
Visual C++
SetDNDOnResponse^ SetDNDOnJSON(
    SetDNDOnRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IAgentServiceRESTContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


IAgentServiceSOAPContract Interface

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract Interface
Members See Also Send Feedback
AgentService SOAP WCF Contract

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAgentServiceSOAPContract
Visual Basic (Declaration)
Public Interface IAgentServiceSOAPContract
Visual C++
public interface class IAgentServiceSOAPContract

See Also

IAgentServiceSOAPContract Members
Genesyslab.Enterprise.Communication.AgentService Namespace


IAgentServiceSOAPContract Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract Members
IAgentServiceSOAPContract Interface Methods See Also Send Feedback

The IAgentServiceSOAPContract type exposes the following members.

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardSet | Activates the Forward feature for the given device.
GetVersion | Get Service Version.
Login | Logs in the agent to the ACD group specified by the queue parameter.
Logout | Logs the agent out of the ACD group specified by the parameter queue.
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOn | Activates the Do Not Disturb feature for the given device.

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


IAgentServiceSOAPContract Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract Methods
IAgentServiceSOAPContract Interface See Also Send Feedback

The IAgentServiceSOAPContract type exposes the following members.

Methods

Name | Description
CallForwardCancel | Deactivates the Forward feature for the given device.
CallForwardSet | Activates the Forward feature for the given device.
GetVersion | Get Service Version.
Login | Logs in the agent to the ACD group specified by the queue parameter.
Logout | Logs the agent out of the ACD group specified by the parameter queue.
NotReady | Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
Ready | Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.
SetDNDOff | Deactivates the Do Not Disturb feature for the given device.
SetDNDOn | Activates the Do Not Disturb feature for the given device.

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.CallForwardCancel Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Deactivates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CallForwardCancelResponse CallForwardCancel(
    CallForwardCancelRequest request
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    request As CallForwardCancelRequest _
) As CallForwardCancelResponse
Visual C++
CallForwardCancelResponse^ CallForwardCancel(
    CallForwardCancelRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


CallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.CallForwardSet Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Activates the Forward feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CallForwardSetResponse CallForwardSet(
    CallForwardSetRequest request
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    request As CallForwardSetRequest _
) As CallForwardSetResponse
Visual C++
CallForwardSetResponse^ CallForwardSet(
    CallForwardSetRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.GetVersion Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Get Service Version.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetVersion()
Visual Basic (Declaration)
Function GetVersion As KeyValueCollection
Visual C++
KeyValueCollection^ GetVersion()

Return Value

Version details

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Login Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.Login Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
LoginResponse Login(
    LoginRequest request
)
Visual Basic (Declaration)
Function Login ( _
    request As LoginRequest _
) As LoginResponse
Visual C++
LoginResponse^ Login(
    LoginRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Logout Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.Logout Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Logs the agent out of the ACD group specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
LogoutResponse Logout(
    LogoutRequest request
)
Visual Basic (Declaration)
Function Logout ( _
    request As LogoutRequest _
) As LogoutResponse
Visual C++
LogoutResponse^ Logout(
    LogoutRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


NotReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.NotReady Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Sets the agent status to not ready. The agent is not ready to receive calls. The agent’s telephone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
NotReadyResponse NotReady(
    NotReadyRequest request
)
Visual Basic (Declaration)
Function NotReady ( _
    request As NotReadyRequest _
) As NotReadyResponse
Visual C++
NotReadyResponse^ NotReady(
    NotReadyRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Ready Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.Ready Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Sets the agent status to ready. The agent is ready to receive incoming calls. The agent’s phone set is specified by the parameter dn; the ACD group into which the agent is logged is specified by the parameter queue.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReadyResponse Ready(
    ReadyRequest request
)
Visual Basic (Declaration)
Function Ready ( _
    request As ReadyRequest _
) As ReadyResponse
Visual C++
ReadyResponse^ Ready(
    ReadyRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.SetDNDOff Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Deactivates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetDNDOffResponse SetDNDOff(
    SetDNDOffRequest request
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    request As SetDNDOffRequest _
) As SetDNDOffResponse
Visual C++
SetDNDOffResponse^ SetDNDOff(
    SetDNDOffRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


SetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
IAgentServiceSOAPContract..::.SetDNDOn Method
IAgentServiceSOAPContract Interface See Also Send Feedback
Activates the Do Not Disturb feature for the given device.

Namespace: Genesyslab.Enterprise.Communication.AgentService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetDNDOnResponse SetDNDOn(
    SetDNDOnRequest request
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    request As SetDNDOnRequest _
) As SetDNDOnResponse
Visual C++
SetDNDOnResponse^ SetDNDOn(
    SetDNDOnRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest
The request to be sent to the server

Return Value

The server's response

See Also

IAgentServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.AgentService Namespace


Genesyslab.Enterprise.Communication.AgentService.Type Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Communication.AgentService.Type Namespace
Send Feedback

Classes

Class | Description
CallForwardCancelRequest | AgentService Service, CallForwardCancel Request.
CallForwardCancelResponse | AgentService Service, CallForwardCancel Response.
CallForwardSetRequest | AgentService Service, CallForwardSet Request.
CallForwardSetResponse | AgentService Service, CallForwardSet Response.
LoginRequest | AgentService Service, Login Request.
LoginResponse | AgentService Service, Login Response.
LogoutRequest | AgentService Service, Logout Request.
LogoutResponse | AgentService Service, Logout Response.
NotReadyRequest | AgentService Service, NotReady Request.
NotReadyResponse | AgentService Service, NotReady Response.
ReadyRequest | AgentService Service, Ready Request.
ReadyResponse | AgentService Service, Ready Response.
SetDNDOffRequest | AgentService Service, SetDNDOff Request.
SetDNDOffResponse | AgentService Service, SetDNDOff Response.
SetDNDOnRequest | AgentService Service, SetDNDOn Request.
SetDNDOnResponse | AgentService Service, SetDNDOn Response.


CallForwardCancelRequest Class

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest Class
Members See Also Send Feedback
AgentService Service, CallForwardCancel Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CallForwardCancelRequest
Visual Basic (Declaration)
Public Class CallForwardCancelRequest
Visual C++
public ref class CallForwardCancelRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelRequest

See Also

CallForwardCancelRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest Members
CallForwardCancelRequest Class Constructors Methods Properties See Also Send Feedback

The CallForwardCancelRequest type exposes the following members.

Constructors

Name | Description
CallForwardCancelRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Forwardmode |
Reasons |

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest Constructor
CallForwardCancelRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardCancelRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CallForwardCancelRequest()

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest Methods
CallForwardCancelRequest Class See Also Send Feedback

The CallForwardCancelRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest Properties
CallForwardCancelRequest Class See Also Send Feedback

The CallForwardCancelRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Forwardmode |
Reasons |

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest..::.Agent Property
CallForwardCancelRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest..::.Extensions Property
CallForwardCancelRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Forwardmode Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest..::.Forwardmode Property
CallForwardCancelRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelRequest.Forwardmode"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ForwardModeType Forwardmode { get; set; }
Visual Basic (Declaration)
Public Property Forwardmode As ForwardModeType
Visual C++
public:
property ForwardModeType Forwardmode {
    ForwardModeType get ();
    void set (ForwardModeType value);
}

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelRequest..::.Reasons Property
CallForwardCancelRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CallForwardCancelRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelResponse Class

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelResponse Class
Members See Also Send Feedback
AgentService Service, CallForwardCancel Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CallForwardCancelResponse
Visual Basic (Declaration)
Public Class CallForwardCancelResponse
Visual C++
public ref class CallForwardCancelResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardCancelResponse

See Also

CallForwardCancelResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardCancelResponse Members
CallForwardCancelResponse Class Constructors Methods Properties See Also Send Feedback

The CallForwardCancelResponse type exposes the following members.

Constructors

Name | Description
CallForwardCancelResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

CallForwardCancelResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelResponse Constructor
CallForwardCancelResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardCancelResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CallForwardCancelResponse()

See Also

CallForwardCancelResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardCancelResponse Methods
CallForwardCancelResponse Class See Also Send Feedback

The CallForwardCancelResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallForwardCancelResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardCancelResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardCancelResponse Properties
CallForwardCancelResponse Class See Also Send Feedback

The CallForwardCancelResponse type exposes the following members.

Properties

Name | Description
result |

See Also

CallForwardCancelResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardCancelResponse..::.result Property
CallForwardCancelResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardCancelResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

CallForwardCancelResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetRequest Class

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest Class
Members See Also Send Feedback
AgentService Service, CallForwardSet Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CallForwardSetRequest
Visual Basic (Declaration)
Public Class CallForwardSetRequest
Visual C++
public ref class CallForwardSetRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetRequest

See Also

CallForwardSetRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest Members
CallForwardSetRequest Class Constructors Methods Properties See Also Send Feedback

The CallForwardSetRequest type exposes the following members.

Constructors

Name | Description
CallForwardSetRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Forwardmode |
Number |
Reasons |

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest Constructor
CallForwardSetRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardSetRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CallForwardSetRequest()

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest Methods
CallForwardSetRequest Class See Also Send Feedback

The CallForwardSetRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest Properties
CallForwardSetRequest Class See Also Send Feedback

The CallForwardSetRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Forwardmode |
Number |
Reasons |

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest..::.Agent Property
CallForwardSetRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest..::.Extensions Property
CallForwardSetRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Forwardmode Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest..::.Forwardmode Property
CallForwardSetRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetRequest.Forwardmode"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ForwardModeType Forwardmode { get; set; }
Visual Basic (Declaration)
Public Property Forwardmode As ForwardModeType
Visual C++
public:
property ForwardModeType Forwardmode {
    ForwardModeType get ();
    void set (ForwardModeType value);
}

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Number Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest..::.Number Property
CallForwardSetRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetRequest.Number"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetRequest..::.Reasons Property
CallForwardSetRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CallForwardSetRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetResponse Class

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetResponse Class
Members See Also Send Feedback
AgentService Service, CallForwardSet Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CallForwardSetResponse
Visual Basic (Declaration)
Public Class CallForwardSetResponse
Visual C++
public ref class CallForwardSetResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.CallForwardSetResponse

See Also

CallForwardSetResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardSetResponse Members
CallForwardSetResponse Class Constructors Methods Properties See Also Send Feedback

The CallForwardSetResponse type exposes the following members.

Constructors

Name | Description
CallForwardSetResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

CallForwardSetResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetResponse Constructor
CallForwardSetResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CallForwardSetResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CallForwardSetResponse()

See Also

CallForwardSetResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardSetResponse Methods
CallForwardSetResponse Class See Also Send Feedback

The CallForwardSetResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallForwardSetResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


CallForwardSetResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CallForwardSetResponse Properties
CallForwardSetResponse Class See Also Send Feedback

The CallForwardSetResponse type exposes the following members.

Properties

Name | Description
result |

See Also

CallForwardSetResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
CallForwardSetResponse..::.result Property
CallForwardSetResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.CallForwardSetResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

CallForwardSetResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginRequest Class

[image]

Enterprise SDK 8.0 Reference API
LoginRequest Class
Members See Also Send Feedback
AgentService Service, Login Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class LoginRequest
Visual Basic (Declaration)
Public Class LoginRequest
Visual C++
public ref class LoginRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginRequest

See Also

LoginRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
LoginRequest Members
LoginRequest Class Constructors Methods Properties See Also Send Feedback

The LoginRequest type exposes the following members.

Constructors

Name | Description
LoginRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Password |
Queue |
Reasons |
Workmode |

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
LoginRequest Constructor
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LoginRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoginRequest()

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
LoginRequest Methods
LoginRequest Class See Also Send Feedback

The LoginRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
LoginRequest Properties
LoginRequest Class See Also Send Feedback

The LoginRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Password |
Queue |
Reasons |
Workmode |

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
LoginRequest..::.Agent Property
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
LoginRequest..::.Extensions Property
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
LoginRequest..::.Password Property
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.Password"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
LoginRequest..::.Queue Property
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.Queue"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Queue { get; set; }
Visual Basic (Declaration)
Public Property Queue As String
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
LoginRequest..::.Reasons Property
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Workmode Property

[image]

Enterprise SDK 8.0 Reference API
LoginRequest..::.Workmode Property
LoginRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginRequest.Workmode"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public WorkMode Workmode { get; set; }
Visual Basic (Declaration)
Public Property Workmode As WorkMode
Visual C++
public:
property WorkMode Workmode {
    WorkMode get ();
    void set (WorkMode value);
}

See Also

LoginRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginResponse Class

[image]

Enterprise SDK 8.0 Reference API
LoginResponse Class
Members See Also Send Feedback
AgentService Service, Login Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class LoginResponse
Visual Basic (Declaration)
Public Class LoginResponse
Visual C++
public ref class LoginResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.LoginResponse

See Also

LoginResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
LoginResponse Members
LoginResponse Class Constructors Methods Properties See Also Send Feedback

The LoginResponse type exposes the following members.

Constructors

Name | Description
LoginResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

LoginResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
LoginResponse Constructor
LoginResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.LoginResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LoginResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoginResponse()

See Also

LoginResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
LoginResponse Methods
LoginResponse Class See Also Send Feedback

The LoginResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LoginResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
LoginResponse Properties
LoginResponse Class See Also Send Feedback

The LoginResponse type exposes the following members.

Properties

Name | Description
result |

See Also

LoginResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
LoginResponse..::.result Property
LoginResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LoginResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

LoginResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutRequest Class

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest Class
Members See Also Send Feedback
AgentService Service, Logout Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class LogoutRequest
Visual Basic (Declaration)
Public Class LogoutRequest
Visual C++
public ref class LogoutRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutRequest

See Also

LogoutRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
LogoutRequest Members
LogoutRequest Class Constructors Methods Properties See Also Send Feedback

The LogoutRequest type exposes the following members.

Constructors

Name | Description
LogoutRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Password |
Queue |
Reasons |

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest Constructor
LogoutRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LogoutRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogoutRequest()

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
LogoutRequest Methods
LogoutRequest Class See Also Send Feedback

The LogoutRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
LogoutRequest Properties
LogoutRequest Class See Also Send Feedback

The LogoutRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Password |
Queue |
Reasons |

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest..::.Agent Property
LogoutRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest..::.Extensions Property
LogoutRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest..::.Password Property
LogoutRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutRequest.Password"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest..::.Queue Property
LogoutRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutRequest.Queue"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Queue { get; set; }
Visual Basic (Declaration)
Public Property Queue As String
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
LogoutRequest..::.Reasons Property
LogoutRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

LogoutRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutResponse Class

[image]

Enterprise SDK 8.0 Reference API
LogoutResponse Class
Members See Also Send Feedback
AgentService Service, Logout Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class LogoutResponse
Visual Basic (Declaration)
Public Class LogoutResponse
Visual C++
public ref class LogoutResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.LogoutResponse

See Also

LogoutResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
LogoutResponse Members
LogoutResponse Class Constructors Methods Properties See Also Send Feedback

The LogoutResponse type exposes the following members.

Constructors

Name | Description
LogoutResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

LogoutResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
LogoutResponse Constructor
LogoutResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public LogoutResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogoutResponse()

See Also

LogoutResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
LogoutResponse Methods
LogoutResponse Class See Also Send Feedback

The LogoutResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogoutResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


LogoutResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
LogoutResponse Properties
LogoutResponse Class See Also Send Feedback

The LogoutResponse type exposes the following members.

Properties

Name | Description
result |

See Also

LogoutResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
LogoutResponse..::.result Property
LogoutResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.LogoutResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

LogoutResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyRequest Class

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest Class
Members See Also Send Feedback
AgentService Service, NotReady Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class NotReadyRequest
Visual Basic (Declaration)
Public Class NotReadyRequest
Visual C++
public ref class NotReadyRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyRequest

See Also

NotReadyRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
NotReadyRequest Members
NotReadyRequest Class Constructors Methods Properties See Also Send Feedback

The NotReadyRequest type exposes the following members.

Constructors

Name | Description
NotReadyRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Queue |
Reasons |
Workmode |

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest Constructor
NotReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotReadyRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotReadyRequest()

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NotReadyRequest Methods
NotReadyRequest Class See Also Send Feedback

The NotReadyRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
NotReadyRequest Properties
NotReadyRequest Class See Also Send Feedback

The NotReadyRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Queue |
Reasons |
Workmode |

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest..::.Agent Property
NotReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest..::.Extensions Property
NotReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest..::.Queue Property
NotReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyRequest.Queue"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Queue { get; set; }
Visual Basic (Declaration)
Public Property Queue As String
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest..::.Reasons Property
NotReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Workmode Property

[image]

Enterprise SDK 8.0 Reference API
NotReadyRequest..::.Workmode Property
NotReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyRequest.Workmode"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public WorkMode Workmode { get; set; }
Visual Basic (Declaration)
Public Property Workmode As WorkMode
Visual C++
public:
property WorkMode Workmode {
    WorkMode get ();
    void set (WorkMode value);
}

See Also

NotReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyResponse Class

[image]

Enterprise SDK 8.0 Reference API
NotReadyResponse Class
Members See Also Send Feedback
AgentService Service, NotReady Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class NotReadyResponse
Visual Basic (Declaration)
Public Class NotReadyResponse
Visual C++
public ref class NotReadyResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.NotReadyResponse

See Also

NotReadyResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
NotReadyResponse Members
NotReadyResponse Class Constructors Methods Properties See Also Send Feedback

The NotReadyResponse type exposes the following members.

Constructors

Name | Description
NotReadyResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

NotReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
NotReadyResponse Constructor
NotReadyResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotReadyResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotReadyResponse()

See Also

NotReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NotReadyResponse Methods
NotReadyResponse Class See Also Send Feedback

The NotReadyResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


NotReadyResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
NotReadyResponse Properties
NotReadyResponse Class See Also Send Feedback

The NotReadyResponse type exposes the following members.

Properties

Name | Description
result |

See Also

NotReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
NotReadyResponse..::.result Property
NotReadyResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.NotReadyResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

NotReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyRequest Class

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest Class
Members See Also Send Feedback
AgentService Service, Ready Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ReadyRequest
Visual Basic (Declaration)
Public Class ReadyRequest
Visual C++
public ref class ReadyRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyRequest

See Also

ReadyRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
ReadyRequest Members
ReadyRequest Class Constructors Methods Properties See Also Send Feedback

The ReadyRequest type exposes the following members.

Constructors

Name | Description
ReadyRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Queue |
Reasons |
Workmode |

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest Constructor
ReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReadyRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReadyRequest()

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ReadyRequest Methods
ReadyRequest Class See Also Send Feedback

The ReadyRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ReadyRequest Properties
ReadyRequest Class See Also Send Feedback

The ReadyRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Queue |
Reasons |
Workmode |

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest..::.Agent Property
ReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest..::.Extensions Property
ReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest..::.Queue Property
ReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyRequest.Queue"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Queue { get; set; }
Visual Basic (Declaration)
Public Property Queue As String
Visual C++
public:
property String^ Queue {
    String^ get ();
    void set (String^ value);
}

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest..::.Reasons Property
ReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Workmode Property

[image]

Enterprise SDK 8.0 Reference API
ReadyRequest..::.Workmode Property
ReadyRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyRequest.Workmode"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public WorkMode Workmode { get; set; }
Visual Basic (Declaration)
Public Property Workmode As WorkMode
Visual C++
public:
property WorkMode Workmode {
    WorkMode get ();
    void set (WorkMode value);
}

See Also

ReadyRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyResponse Class

[image]

Enterprise SDK 8.0 Reference API
ReadyResponse Class
Members See Also Send Feedback
AgentService Service, Ready Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ReadyResponse
Visual Basic (Declaration)
Public Class ReadyResponse
Visual C++
public ref class ReadyResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.ReadyResponse

See Also

ReadyResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
ReadyResponse Members
ReadyResponse Class Constructors Methods Properties See Also Send Feedback

The ReadyResponse type exposes the following members.

Constructors

Name | Description
ReadyResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

ReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
ReadyResponse Constructor
ReadyResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReadyResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReadyResponse()

See Also

ReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ReadyResponse Methods
ReadyResponse Class See Also Send Feedback

The ReadyResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


ReadyResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ReadyResponse Properties
ReadyResponse Class See Also Send Feedback

The ReadyResponse type exposes the following members.

Properties

Name | Description
result |

See Also

ReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
ReadyResponse..::.result Property
ReadyResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.ReadyResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

ReadyResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffRequest Class

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest Class
Members See Also Send Feedback
AgentService Service, SetDNDOff Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetDNDOffRequest
Visual Basic (Declaration)
Public Class SetDNDOffRequest
Visual C++
public ref class SetDNDOffRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffRequest

See Also

SetDNDOffRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest Members
SetDNDOffRequest Class Constructors Methods Properties See Also Send Feedback

The SetDNDOffRequest type exposes the following members.

Constructors

Name | Description
SetDNDOffRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Reasons |

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest Constructor
SetDNDOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOffRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOffRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetDNDOffRequest()

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest Methods
SetDNDOffRequest Class See Also Send Feedback

The SetDNDOffRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest Properties
SetDNDOffRequest Class See Also Send Feedback

The SetDNDOffRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Reasons |

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest..::.Agent Property
SetDNDOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOffRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest..::.Extensions Property
SetDNDOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOffRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffRequest..::.Reasons Property
SetDNDOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOffRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetDNDOffRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffResponse Class

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffResponse Class
Members See Also Send Feedback
AgentService Service, SetDNDOff Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetDNDOffResponse
Visual Basic (Declaration)
Public Class SetDNDOffResponse
Visual C++
public ref class SetDNDOffResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOffResponse

See Also

SetDNDOffResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOffResponse Members
SetDNDOffResponse Class Constructors Methods Properties See Also Send Feedback

The SetDNDOffResponse type exposes the following members.

Constructors

Name | Description
SetDNDOffResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SetDNDOffResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffResponse Constructor
SetDNDOffResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOffResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOffResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetDNDOffResponse()

See Also

SetDNDOffResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOffResponse Methods
SetDNDOffResponse Class See Also Send Feedback

The SetDNDOffResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetDNDOffResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOffResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOffResponse Properties
SetDNDOffResponse Class See Also Send Feedback

The SetDNDOffResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SetDNDOffResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOffResponse..::.result Property
SetDNDOffResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOffResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

SetDNDOffResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnRequest Class

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest Class
Members See Also Send Feedback
AgentService Service, SetDNDOn Request.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetDNDOnRequest
Visual Basic (Declaration)
Public Class SetDNDOnRequest
Visual C++
public ref class SetDNDOnRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnRequest

See Also

SetDNDOnRequest Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest Members
SetDNDOnRequest Class Constructors Methods Properties See Also Send Feedback

The SetDNDOnRequest type exposes the following members.

Constructors

Name | Description
SetDNDOnRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Reasons |

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest Constructor
SetDNDOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOnRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOnRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetDNDOnRequest()

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest Methods
SetDNDOnRequest Class See Also Send Feedback

The SetDNDOnRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest Properties
SetDNDOnRequest Class See Also Send Feedback

The SetDNDOnRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Reasons |

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest..::.Agent Property
SetDNDOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOnRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest..::.Extensions Property
SetDNDOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOnRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnRequest..::.Reasons Property
SetDNDOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOnRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetDNDOnRequest Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnResponse Class

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnResponse Class
Members See Also Send Feedback
AgentService Service, SetDNDOn Response.

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetDNDOnResponse
Visual Basic (Declaration)
Public Class SetDNDOnResponse
Visual C++
public ref class SetDNDOnResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.AgentService.Type..::.SetDNDOnResponse

See Also

SetDNDOnResponse Members
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOnResponse Members
SetDNDOnResponse Class Constructors Methods Properties See Also Send Feedback

The SetDNDOnResponse type exposes the following members.

Constructors

Name | Description
SetDNDOnResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SetDNDOnResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnResponse Constructor
SetDNDOnResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOnResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetDNDOnResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetDNDOnResponse()

See Also

SetDNDOnResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOnResponse Methods
SetDNDOnResponse Class See Also Send Feedback

The SetDNDOnResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetDNDOnResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


SetDNDOnResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetDNDOnResponse Properties
SetDNDOnResponse Class See Also Send Feedback

The SetDNDOnResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SetDNDOnResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SetDNDOnResponse..::.result Property
SetDNDOnResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.AgentService.Type.SetDNDOnResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.AgentService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As AgentDTO
Visual C++
public:
property AgentDTO^ result {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

SetDNDOnResponse Class
Genesyslab.Enterprise.Communication.AgentService.Type Namespace


Genesyslab.Enterprise.Communication.InteractionService Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Communication.InteractionService Namespace
Send Feedback

Classes

Class | Description
InteractionServiceREST | InteractionService API exposed as WCF ReST API
InteractionServiceSOAP | InteractionService API exposed as WCF SOAP API

Interfaces

Interface | Description
IInteractionServiceRESTContract | InteractionService REST WCF Contract
IInteractionServiceSOAPContract | InteractionService SOAP WCF Contract


IInteractionServiceRESTContract Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract Interface
Members See Also Send Feedback
InteractionService REST WCF Contract

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IInteractionServiceRESTContract
Visual Basic (Declaration)
Public Interface IInteractionServiceRESTContract
Visual C++
public interface class IInteractionServiceRESTContract

See Also

IInteractionServiceRESTContract Members
Genesyslab.Enterprise.Communication.InteractionService Namespace


IInteractionServiceRESTContract Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract Members
IInteractionServiceRESTContract Interface Methods See Also Send Feedback

The IInteractionServiceRESTContract type exposes the following members.

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AlternateCallJSON | Alternates between the given call and a held call., JSON Format
AnswerCall | Answers the given call (which is the given ringing interaction).
AnswerCallJSON | Answers the given call (which is the given ringing interaction)., JSON Format
CompleteConference | Completes the two-step conference for the given call.
CompleteConferenceJSON | Completes the two-step conference for the given call., JSON Format
CompleteTransfer | Completes the given two-step transfer.
CompleteTransferJSON | Completes the given two-step transfer., JSON Format
DeleteFromConference | Deletes the given party from the conference.
DeleteFromConferenceJSON | Deletes the given party from the conference., JSON Format
GetInteraction | Get an Interaction
GetInteractionJSON | Get an Interaction (JsON Format)
GetInteractions | Lists all the Interactions in the System
GetInteractionsJSON | Lists all the Interactions in the System (JsON Format)
GetVersion | Get Service Version.
GetVersionJSON | Get Service Version. JSON Format
HoldCall | Places the given interaction on hold.
HoldCallJSON | Places the given interaction on hold., JSON Format
InitiateConference | Initiates the two-step conference for the given call.
InitiateConferenceJSON | Initiates the two-step conference for the given call. , JSON Format
InitiateTransfer | Initiates the two-step transfer of the given call.
InitiateTransferJSON | Initiates the two-step transfer of the given call., JSON Format
ListenDisconnect |
ListenDisconnectJSON | , JSON Format
ListenReconnect |
ListenReconnectJSON | , JSON Format
MakeCall | Dials a new call.
MakeCallJSON | Dials a new call., JSON Format
MuteTransfer | Transfers the given interaction in a single blind attempt.
MuteTransferJSON | Transfers the given interaction in a single blind attempt., JSON Format
ReleaseCall | Releases the given interaction.
ReleaseCallJSON | Releases the given interaction., JSON Format
RetrieveCall | Retrieves the given interaction being held.
RetrieveCallJSON | Retrieves the given interaction being held., JSON Format
SendDtmf | Sends digits as DTMF tones on the given phone call.
SendDtmfJSON | Sends digits as DTMF tones on the given phone call., JSON Format
SetCallQualification | Sets the call qualification.
SetCallQualificationJSON | Sets the call qualification., JSON Format
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOffJSON | Cancels the call muting (enables the microphone)., JSON Format
SetMuteOn | Mutes this call (disables the microphone).
SetMuteOnJSON | Mutes this call (disables the microphone)., JSON Format
SingleStepConference | Conferences this call in one step.
SingleStepConferenceJSON | Conferences this call in one step., JSON Format
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransferJSON | Transfers the given interaction in a single step (without creating a consultation call)., JSON Format

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


IInteractionServiceRESTContract Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract Methods
IInteractionServiceRESTContract Interface See Also Send Feedback

The IInteractionServiceRESTContract type exposes the following members.

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AlternateCallJSON | Alternates between the given call and a held call., JSON Format
AnswerCall | Answers the given call (which is the given ringing interaction).
AnswerCallJSON | Answers the given call (which is the given ringing interaction)., JSON Format
CompleteConference | Completes the two-step conference for the given call.
CompleteConferenceJSON | Completes the two-step conference for the given call., JSON Format
CompleteTransfer | Completes the given two-step transfer.
CompleteTransferJSON | Completes the given two-step transfer., JSON Format
DeleteFromConference | Deletes the given party from the conference.
DeleteFromConferenceJSON | Deletes the given party from the conference., JSON Format
GetInteraction | Get an Interaction
GetInteractionJSON | Get an Interaction (JsON Format)
GetInteractions | Lists all the Interactions in the System
GetInteractionsJSON | Lists all the Interactions in the System (JsON Format)
GetVersion | Get Service Version.
GetVersionJSON | Get Service Version. JSON Format
HoldCall | Places the given interaction on hold.
HoldCallJSON | Places the given interaction on hold., JSON Format
InitiateConference | Initiates the two-step conference for the given call.
InitiateConferenceJSON | Initiates the two-step conference for the given call. , JSON Format
InitiateTransfer | Initiates the two-step transfer of the given call.
InitiateTransferJSON | Initiates the two-step transfer of the given call., JSON Format
ListenDisconnect |
ListenDisconnectJSON | , JSON Format
ListenReconnect |
ListenReconnectJSON | , JSON Format
MakeCall | Dials a new call.
MakeCallJSON | Dials a new call., JSON Format
MuteTransfer | Transfers the given interaction in a single blind attempt.
MuteTransferJSON | Transfers the given interaction in a single blind attempt., JSON Format
ReleaseCall | Releases the given interaction.
ReleaseCallJSON | Releases the given interaction., JSON Format
RetrieveCall | Retrieves the given interaction being held.
RetrieveCallJSON | Retrieves the given interaction being held., JSON Format
SendDtmf | Sends digits as DTMF tones on the given phone call.
SendDtmfJSON | Sends digits as DTMF tones on the given phone call., JSON Format
SetCallQualification | Sets the call qualification.
SetCallQualificationJSON | Sets the call qualification., JSON Format
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOffJSON | Cancels the call muting (enables the microphone)., JSON Format
SetMuteOn | Mutes this call (disables the microphone).
SetMuteOnJSON | Mutes this call (disables the microphone)., JSON Format
SingleStepConference | Conferences this call in one step.
SingleStepConferenceJSON | Conferences this call in one step., JSON Format
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransferJSON | Transfers the given interaction in a single step (without creating a consultation call)., JSON Format

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


AlternateCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.AlternateCall Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AlternateCallResponse AlternateCall(
    AlternateCallRequest request
)
Visual Basic (Declaration)
Function AlternateCall ( _
    request As AlternateCallRequest _
) As AlternateCallResponse
Visual C++
AlternateCallResponse^ AlternateCall(
    AlternateCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


AlternateCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.AlternateCallJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Alternates between the given call and a held call., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AlternateCallResponse AlternateCallJSON(
    AlternateCallRequest request
)
Visual Basic (Declaration)
Function AlternateCallJSON ( _
    request As AlternateCallRequest _
) As AlternateCallResponse
Visual C++
AlternateCallResponse^ AlternateCallJSON(
    AlternateCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


AnswerCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.AnswerCall Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AnswerCallResponse AnswerCall(
    AnswerCallRequest request
)
Visual Basic (Declaration)
Function AnswerCall ( _
    request As AnswerCallRequest _
) As AnswerCallResponse
Visual C++
AnswerCallResponse^ AnswerCall(
    AnswerCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


AnswerCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.AnswerCallJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Answers the given call (which is the given ringing interaction)., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AnswerCallResponse AnswerCallJSON(
    AnswerCallRequest request
)
Visual Basic (Declaration)
Function AnswerCallJSON ( _
    request As AnswerCallRequest _
) As AnswerCallResponse
Visual C++
AnswerCallResponse^ AnswerCallJSON(
    AnswerCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.CompleteConference Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CompleteConferenceResponse CompleteConference(
    CompleteConferenceRequest request
)
Visual Basic (Declaration)
Function CompleteConference ( _
    request As CompleteConferenceRequest _
) As CompleteConferenceResponse
Visual C++
CompleteConferenceResponse^ CompleteConference(
    CompleteConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.CompleteConferenceJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Completes the two-step conference for the given call., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CompleteConferenceResponse CompleteConferenceJSON(
    CompleteConferenceRequest request
)
Visual Basic (Declaration)
Function CompleteConferenceJSON ( _
    request As CompleteConferenceRequest _
) As CompleteConferenceResponse
Visual C++
CompleteConferenceResponse^ CompleteConferenceJSON(
    CompleteConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.CompleteTransfer Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CompleteTransferResponse CompleteTransfer(
    CompleteTransferRequest request
)
Visual Basic (Declaration)
Function CompleteTransfer ( _
    request As CompleteTransferRequest _
) As CompleteTransferResponse
Visual C++
CompleteTransferResponse^ CompleteTransfer(
    CompleteTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.CompleteTransferJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Completes the given two-step transfer., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CompleteTransferResponse CompleteTransferJSON(
    CompleteTransferRequest request
)
Visual Basic (Declaration)
Function CompleteTransferJSON ( _
    request As CompleteTransferRequest _
) As CompleteTransferResponse
Visual C++
CompleteTransferResponse^ CompleteTransferJSON(
    CompleteTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


DeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.DeleteFromConference Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DeleteFromConferenceResponse DeleteFromConference(
    DeleteFromConferenceRequest request
)
Visual Basic (Declaration)
Function DeleteFromConference ( _
    request As DeleteFromConferenceRequest _
) As DeleteFromConferenceResponse
Visual C++
DeleteFromConferenceResponse^ DeleteFromConference(
    DeleteFromConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


DeleteFromConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.DeleteFromConferenceJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Deletes the given party from the conference., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DeleteFromConferenceResponse DeleteFromConferenceJSON(
    DeleteFromConferenceRequest request
)
Visual Basic (Declaration)
Function DeleteFromConferenceJSON ( _
    request As DeleteFromConferenceRequest _
) As DeleteFromConferenceResponse
Visual C++
DeleteFromConferenceResponse^ DeleteFromConferenceJSON(
    DeleteFromConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.GetInteraction Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Get an Interaction

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InteractionDTO GetInteraction(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    interactionId As String _
) As InteractionDTO
Visual C++
InteractionDTO^ GetInteraction(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Interaction Id

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteractionJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.GetInteractionJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Get an Interaction (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InteractionDTO GetInteractionJSON(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractionJSON ( _
    interactionId As String _
) As InteractionDTO
Visual C++
InteractionDTO^ GetInteractionJSON(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Interaction Id

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.GetInteractions Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Lists all the Interactions in the System

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
List<InteractionDTO> GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As List(Of InteractionDTO)
Visual C++
List<InteractionDTO^>^ GetInteractions()

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteractionsJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.GetInteractionsJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Lists all the Interactions in the System (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
List<InteractionDTO> GetInteractionsJSON()
Visual Basic (Declaration)
Function GetInteractionsJSON As List(Of InteractionDTO)
Visual C++
List<InteractionDTO^>^ GetInteractionsJSON()

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.GetVersion Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Get Service Version.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetVersion()
Visual Basic (Declaration)
Function GetVersion As KeyValueCollection
Visual C++
KeyValueCollection^ GetVersion()

Return Value

Version details

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetVersionJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.GetVersionJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Get Service Version. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetVersionJSON()
Visual Basic (Declaration)
Function GetVersionJSON As KeyValueCollection
Visual C++
KeyValueCollection^ GetVersionJSON()

Return Value

Version details

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


HoldCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.HoldCall Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
HoldCallResponse HoldCall(
    HoldCallRequest request
)
Visual Basic (Declaration)
Function HoldCall ( _
    request As HoldCallRequest _
) As HoldCallResponse
Visual C++
HoldCallResponse^ HoldCall(
    HoldCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


HoldCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.HoldCallJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Places the given interaction on hold., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
HoldCallResponse HoldCallJSON(
    HoldCallRequest request
)
Visual Basic (Declaration)
Function HoldCallJSON ( _
    request As HoldCallRequest _
) As HoldCallResponse
Visual C++
HoldCallResponse^ HoldCallJSON(
    HoldCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.InitiateConference Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InitiateConferenceResponse InitiateConference(
    InitiateConferenceRequest request
)
Visual Basic (Declaration)
Function InitiateConference ( _
    request As InitiateConferenceRequest _
) As InitiateConferenceResponse
Visual C++
InitiateConferenceResponse^ InitiateConference(
    InitiateConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.InitiateConferenceJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Initiates the two-step conference for the given call. , JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InitiateConferenceResponse InitiateConferenceJSON(
    InitiateConferenceRequest request
)
Visual Basic (Declaration)
Function InitiateConferenceJSON ( _
    request As InitiateConferenceRequest _
) As InitiateConferenceResponse
Visual C++
InitiateConferenceResponse^ InitiateConferenceJSON(
    InitiateConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.InitiateTransfer Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InitiateTransferResponse InitiateTransfer(
    InitiateTransferRequest request
)
Visual Basic (Declaration)
Function InitiateTransfer ( _
    request As InitiateTransferRequest _
) As InitiateTransferResponse
Visual C++
InitiateTransferResponse^ InitiateTransfer(
    InitiateTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.InitiateTransferJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Initiates the two-step transfer of the given call., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InitiateTransferResponse InitiateTransferJSON(
    InitiateTransferRequest request
)
Visual Basic (Declaration)
Function InitiateTransferJSON ( _
    request As InitiateTransferRequest _
) As InitiateTransferResponse
Visual C++
InitiateTransferResponse^ InitiateTransferJSON(
    InitiateTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.ListenDisconnect Method
IInteractionServiceRESTContract Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.IInteractionServiceRESTContract.ListenDisconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ListenDisconnectResponse ListenDisconnect(
    ListenDisconnectRequest request
)
Visual Basic (Declaration)
Function ListenDisconnect ( _
    request As ListenDisconnectRequest _
) As ListenDisconnectResponse
Visual C++
ListenDisconnectResponse^ ListenDisconnect(
    ListenDisconnectRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenDisconnectJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.ListenDisconnectJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
, JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ListenDisconnectResponse ListenDisconnectJSON(
    ListenDisconnectRequest request
)
Visual Basic (Declaration)
Function ListenDisconnectJSON ( _
    request As ListenDisconnectRequest _
) As ListenDisconnectResponse
Visual C++
ListenDisconnectResponse^ ListenDisconnectJSON(
    ListenDisconnectRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.ListenReconnect Method
IInteractionServiceRESTContract Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.IInteractionServiceRESTContract.ListenReconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ListenReconnectResponse ListenReconnect(
    ListenReconnectRequest request
)
Visual Basic (Declaration)
Function ListenReconnect ( _
    request As ListenReconnectRequest _
) As ListenReconnectResponse
Visual C++
ListenReconnectResponse^ ListenReconnect(
    ListenReconnectRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenReconnectJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.ListenReconnectJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
, JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ListenReconnectResponse ListenReconnectJSON(
    ListenReconnectRequest request
)
Visual Basic (Declaration)
Function ListenReconnectJSON ( _
    request As ListenReconnectRequest _
) As ListenReconnectResponse
Visual C++
ListenReconnectResponse^ ListenReconnectJSON(
    ListenReconnectRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


MakeCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.MakeCall Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MakeCallResponse MakeCall(
    MakeCallRequest request
)
Visual Basic (Declaration)
Function MakeCall ( _
    request As MakeCallRequest _
) As MakeCallResponse
Visual C++
MakeCallResponse^ MakeCall(
    MakeCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


MakeCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.MakeCallJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Dials a new call., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MakeCallResponse MakeCallJSON(
    MakeCallRequest request
)
Visual Basic (Declaration)
Function MakeCallJSON ( _
    request As MakeCallRequest _
) As MakeCallResponse
Visual C++
MakeCallResponse^ MakeCallJSON(
    MakeCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


MuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.MuteTransfer Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MuteTransferResponse MuteTransfer(
    MuteTransferRequest request
)
Visual Basic (Declaration)
Function MuteTransfer ( _
    request As MuteTransferRequest _
) As MuteTransferResponse
Visual C++
MuteTransferResponse^ MuteTransfer(
    MuteTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


MuteTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.MuteTransferJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Transfers the given interaction in a single blind attempt., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MuteTransferResponse MuteTransferJSON(
    MuteTransferRequest request
)
Visual Basic (Declaration)
Function MuteTransferJSON ( _
    request As MuteTransferRequest _
) As MuteTransferResponse
Visual C++
MuteTransferResponse^ MuteTransferJSON(
    MuteTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ReleaseCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.ReleaseCall Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReleaseCallResponse ReleaseCall(
    ReleaseCallRequest request
)
Visual Basic (Declaration)
Function ReleaseCall ( _
    request As ReleaseCallRequest _
) As ReleaseCallResponse
Visual C++
ReleaseCallResponse^ ReleaseCall(
    ReleaseCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ReleaseCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.ReleaseCallJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Releases the given interaction., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReleaseCallResponse ReleaseCallJSON(
    ReleaseCallRequest request
)
Visual Basic (Declaration)
Function ReleaseCallJSON ( _
    request As ReleaseCallRequest _
) As ReleaseCallResponse
Visual C++
ReleaseCallResponse^ ReleaseCallJSON(
    ReleaseCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


RetrieveCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.RetrieveCall Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
RetrieveCallResponse RetrieveCall(
    RetrieveCallRequest request
)
Visual Basic (Declaration)
Function RetrieveCall ( _
    request As RetrieveCallRequest _
) As RetrieveCallResponse
Visual C++
RetrieveCallResponse^ RetrieveCall(
    RetrieveCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


RetrieveCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.RetrieveCallJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Retrieves the given interaction being held., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
RetrieveCallResponse RetrieveCallJSON(
    RetrieveCallRequest request
)
Visual Basic (Declaration)
Function RetrieveCallJSON ( _
    request As RetrieveCallRequest _
) As RetrieveCallResponse
Visual C++
RetrieveCallResponse^ RetrieveCallJSON(
    RetrieveCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SendDtmf Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SendDtmf Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SendDtmfResponse SendDtmf(
    SendDtmfRequest request
)
Visual Basic (Declaration)
Function SendDtmf ( _
    request As SendDtmfRequest _
) As SendDtmfResponse
Visual C++
SendDtmfResponse^ SendDtmf(
    SendDtmfRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SendDtmfJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SendDtmfJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Sends digits as DTMF tones on the given phone call., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SendDtmfResponse SendDtmfJSON(
    SendDtmfRequest request
)
Visual Basic (Declaration)
Function SendDtmfJSON ( _
    request As SendDtmfRequest _
) As SendDtmfResponse
Visual C++
SendDtmfResponse^ SendDtmfJSON(
    SendDtmfRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SetCallQualification Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetCallQualificationResponse SetCallQualification(
    SetCallQualificationRequest request
)
Visual Basic (Declaration)
Function SetCallQualification ( _
    request As SetCallQualificationRequest _
) As SetCallQualificationResponse
Visual C++
SetCallQualificationResponse^ SetCallQualification(
    SetCallQualificationRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetCallQualificationJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SetCallQualificationJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Sets the call qualification., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetCallQualificationResponse SetCallQualificationJSON(
    SetCallQualificationRequest request
)
Visual Basic (Declaration)
Function SetCallQualificationJSON ( _
    request As SetCallQualificationRequest _
) As SetCallQualificationResponse
Visual C++
SetCallQualificationResponse^ SetCallQualificationJSON(
    SetCallQualificationRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOff Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SetMuteOff Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetMuteOffResponse SetMuteOff(
    SetMuteOffRequest request
)
Visual Basic (Declaration)
Function SetMuteOff ( _
    request As SetMuteOffRequest _
) As SetMuteOffResponse
Visual C++
SetMuteOffResponse^ SetMuteOff(
    SetMuteOffRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOffJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SetMuteOffJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Cancels the call muting (enables the microphone)., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetMuteOffResponse SetMuteOffJSON(
    SetMuteOffRequest request
)
Visual Basic (Declaration)
Function SetMuteOffJSON ( _
    request As SetMuteOffRequest _
) As SetMuteOffResponse
Visual C++
SetMuteOffResponse^ SetMuteOffJSON(
    SetMuteOffRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOn Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SetMuteOn Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetMuteOnResponse SetMuteOn(
    SetMuteOnRequest request
)
Visual Basic (Declaration)
Function SetMuteOn ( _
    request As SetMuteOnRequest _
) As SetMuteOnResponse
Visual C++
SetMuteOnResponse^ SetMuteOn(
    SetMuteOnRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOnJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SetMuteOnJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Mutes this call (disables the microphone)., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetMuteOnResponse SetMuteOnJSON(
    SetMuteOnRequest request
)
Visual Basic (Declaration)
Function SetMuteOnJSON ( _
    request As SetMuteOnRequest _
) As SetMuteOnResponse
Visual C++
SetMuteOnResponse^ SetMuteOnJSON(
    SetMuteOnRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SingleStepConference Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SingleStepConferenceResponse SingleStepConference(
    SingleStepConferenceRequest request
)
Visual Basic (Declaration)
Function SingleStepConference ( _
    request As SingleStepConferenceRequest _
) As SingleStepConferenceResponse
Visual C++
SingleStepConferenceResponse^ SingleStepConference(
    SingleStepConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SingleStepConferenceJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Conferences this call in one step., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SingleStepConferenceResponse SingleStepConferenceJSON(
    SingleStepConferenceRequest request
)
Visual Basic (Declaration)
Function SingleStepConferenceJSON ( _
    request As SingleStepConferenceRequest _
) As SingleStepConferenceResponse
Visual C++
SingleStepConferenceResponse^ SingleStepConferenceJSON(
    SingleStepConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SingleStepTransfer Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SingleStepTransferResponse SingleStepTransfer(
    SingleStepTransferRequest request
)
Visual Basic (Declaration)
Function SingleStepTransfer ( _
    request As SingleStepTransferRequest _
) As SingleStepTransferResponse
Visual C++
SingleStepTransferResponse^ SingleStepTransfer(
    SingleStepTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceRESTContract..::.SingleStepTransferJSON Method
IInteractionServiceRESTContract Interface See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call)., JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SingleStepTransferResponse SingleStepTransferJSON(
    SingleStepTransferRequest request
)
Visual Basic (Declaration)
Function SingleStepTransferJSON ( _
    request As SingleStepTransferRequest _
) As SingleStepTransferResponse
Visual C++
SingleStepTransferResponse^ SingleStepTransferJSON(
    SingleStepTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest
The JSON request to be sent to the server

Return Value

The server's JSON response

See Also

IInteractionServiceRESTContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


IInteractionServiceSOAPContract Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract Interface
Members See Also Send Feedback
InteractionService SOAP WCF Contract

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IInteractionServiceSOAPContract
Visual Basic (Declaration)
Public Interface IInteractionServiceSOAPContract
Visual C++
public interface class IInteractionServiceSOAPContract

See Also

IInteractionServiceSOAPContract Members
Genesyslab.Enterprise.Communication.InteractionService Namespace


IInteractionServiceSOAPContract Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract Members
IInteractionServiceSOAPContract Interface Methods See Also Send Feedback

The IInteractionServiceSOAPContract type exposes the following members.

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AnswerCall | Answers the given call (which is the given ringing interaction).
CompleteConference | Completes the two-step conference for the given call.
CompleteTransfer | Completes the given two-step transfer.
DeleteFromConference | Deletes the given party from the conference.
GetVersion | Get Service Version.
HoldCall | Places the given interaction on hold.
InitiateConference | Initiates the two-step conference for the given call.
InitiateTransfer | Initiates the two-step transfer of the given call.
ListenDisconnect |
ListenReconnect |
MakeCall | Dials a new call.
MuteTransfer | Transfers the given interaction in a single blind attempt.
ReleaseCall | Releases the given interaction.
RetrieveCall | Retrieves the given interaction being held.
SendDtmf | Sends digits as DTMF tones on the given phone call.
SetCallQualification | Sets the call qualification.
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOn | Mutes this call (disables the microphone).
SingleStepConference | Conferences this call in one step.
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


IInteractionServiceSOAPContract Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract Methods
IInteractionServiceSOAPContract Interface See Also Send Feedback

The IInteractionServiceSOAPContract type exposes the following members.

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AnswerCall | Answers the given call (which is the given ringing interaction).
CompleteConference | Completes the two-step conference for the given call.
CompleteTransfer | Completes the given two-step transfer.
DeleteFromConference | Deletes the given party from the conference.
GetVersion | Get Service Version.
HoldCall | Places the given interaction on hold.
InitiateConference | Initiates the two-step conference for the given call.
InitiateTransfer | Initiates the two-step transfer of the given call.
ListenDisconnect |
ListenReconnect |
MakeCall | Dials a new call.
MuteTransfer | Transfers the given interaction in a single blind attempt.
ReleaseCall | Releases the given interaction.
RetrieveCall | Retrieves the given interaction being held.
SendDtmf | Sends digits as DTMF tones on the given phone call.
SetCallQualification | Sets the call qualification.
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOn | Mutes this call (disables the microphone).
SingleStepConference | Conferences this call in one step.
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


AlternateCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.AlternateCall Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AlternateCallResponse AlternateCall(
    AlternateCallRequest request
)
Visual Basic (Declaration)
Function AlternateCall ( _
    request As AlternateCallRequest _
) As AlternateCallResponse
Visual C++
AlternateCallResponse^ AlternateCall(
    AlternateCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


AnswerCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.AnswerCall Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AnswerCallResponse AnswerCall(
    AnswerCallRequest request
)
Visual Basic (Declaration)
Function AnswerCall ( _
    request As AnswerCallRequest _
) As AnswerCallResponse
Visual C++
AnswerCallResponse^ AnswerCall(
    AnswerCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.CompleteConference Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CompleteConferenceResponse CompleteConference(
    CompleteConferenceRequest request
)
Visual Basic (Declaration)
Function CompleteConference ( _
    request As CompleteConferenceRequest _
) As CompleteConferenceResponse
Visual C++
CompleteConferenceResponse^ CompleteConference(
    CompleteConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.CompleteTransfer Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CompleteTransferResponse CompleteTransfer(
    CompleteTransferRequest request
)
Visual Basic (Declaration)
Function CompleteTransfer ( _
    request As CompleteTransferRequest _
) As CompleteTransferResponse
Visual C++
CompleteTransferResponse^ CompleteTransfer(
    CompleteTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


DeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.DeleteFromConference Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DeleteFromConferenceResponse DeleteFromConference(
    DeleteFromConferenceRequest request
)
Visual Basic (Declaration)
Function DeleteFromConference ( _
    request As DeleteFromConferenceRequest _
) As DeleteFromConferenceResponse
Visual C++
DeleteFromConferenceResponse^ DeleteFromConference(
    DeleteFromConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.GetVersion Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Get Service Version.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetVersion()
Visual Basic (Declaration)
Function GetVersion As KeyValueCollection
Visual C++
KeyValueCollection^ GetVersion()

Return Value

Version details

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


HoldCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.HoldCall Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
HoldCallResponse HoldCall(
    HoldCallRequest request
)
Visual Basic (Declaration)
Function HoldCall ( _
    request As HoldCallRequest _
) As HoldCallResponse
Visual C++
HoldCallResponse^ HoldCall(
    HoldCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.InitiateConference Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InitiateConferenceResponse InitiateConference(
    InitiateConferenceRequest request
)
Visual Basic (Declaration)
Function InitiateConference ( _
    request As InitiateConferenceRequest _
) As InitiateConferenceResponse
Visual C++
InitiateConferenceResponse^ InitiateConference(
    InitiateConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.InitiateTransfer Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InitiateTransferResponse InitiateTransfer(
    InitiateTransferRequest request
)
Visual Basic (Declaration)
Function InitiateTransfer ( _
    request As InitiateTransferRequest _
) As InitiateTransferResponse
Visual C++
InitiateTransferResponse^ InitiateTransfer(
    InitiateTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.ListenDisconnect Method
IInteractionServiceSOAPContract Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.IInteractionServiceSOAPContract.ListenDisconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ListenDisconnectResponse ListenDisconnect(
    ListenDisconnectRequest request
)
Visual Basic (Declaration)
Function ListenDisconnect ( _
    request As ListenDisconnectRequest _
) As ListenDisconnectResponse
Visual C++
ListenDisconnectResponse^ ListenDisconnect(
    ListenDisconnectRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.ListenReconnect Method
IInteractionServiceSOAPContract Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.IInteractionServiceSOAPContract.ListenReconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ListenReconnectResponse ListenReconnect(
    ListenReconnectRequest request
)
Visual Basic (Declaration)
Function ListenReconnect ( _
    request As ListenReconnectRequest _
) As ListenReconnectResponse
Visual C++
ListenReconnectResponse^ ListenReconnect(
    ListenReconnectRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


MakeCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.MakeCall Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MakeCallResponse MakeCall(
    MakeCallRequest request
)
Visual Basic (Declaration)
Function MakeCall ( _
    request As MakeCallRequest _
) As MakeCallResponse
Visual C++
MakeCallResponse^ MakeCall(
    MakeCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


MuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.MuteTransfer Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MuteTransferResponse MuteTransfer(
    MuteTransferRequest request
)
Visual Basic (Declaration)
Function MuteTransfer ( _
    request As MuteTransferRequest _
) As MuteTransferResponse
Visual C++
MuteTransferResponse^ MuteTransfer(
    MuteTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


ReleaseCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.ReleaseCall Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReleaseCallResponse ReleaseCall(
    ReleaseCallRequest request
)
Visual Basic (Declaration)
Function ReleaseCall ( _
    request As ReleaseCallRequest _
) As ReleaseCallResponse
Visual C++
ReleaseCallResponse^ ReleaseCall(
    ReleaseCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


RetrieveCall Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.RetrieveCall Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
RetrieveCallResponse RetrieveCall(
    RetrieveCallRequest request
)
Visual Basic (Declaration)
Function RetrieveCall ( _
    request As RetrieveCallRequest _
) As RetrieveCallResponse
Visual C++
RetrieveCallResponse^ RetrieveCall(
    RetrieveCallRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SendDtmf Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.SendDtmf Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SendDtmfResponse SendDtmf(
    SendDtmfRequest request
)
Visual Basic (Declaration)
Function SendDtmf ( _
    request As SendDtmfRequest _
) As SendDtmfResponse
Visual C++
SendDtmfResponse^ SendDtmf(
    SendDtmfRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.SetCallQualification Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetCallQualificationResponse SetCallQualification(
    SetCallQualificationRequest request
)
Visual Basic (Declaration)
Function SetCallQualification ( _
    request As SetCallQualificationRequest _
) As SetCallQualificationResponse
Visual C++
SetCallQualificationResponse^ SetCallQualification(
    SetCallQualificationRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOff Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.SetMuteOff Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetMuteOffResponse SetMuteOff(
    SetMuteOffRequest request
)
Visual Basic (Declaration)
Function SetMuteOff ( _
    request As SetMuteOffRequest _
) As SetMuteOffResponse
Visual C++
SetMuteOffResponse^ SetMuteOff(
    SetMuteOffRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOn Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.SetMuteOn Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SetMuteOnResponse SetMuteOn(
    SetMuteOnRequest request
)
Visual Basic (Declaration)
Function SetMuteOn ( _
    request As SetMuteOnRequest _
) As SetMuteOnResponse
Visual C++
SetMuteOnResponse^ SetMuteOn(
    SetMuteOnRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.SingleStepConference Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SingleStepConferenceResponse SingleStepConference(
    SingleStepConferenceRequest request
)
Visual Basic (Declaration)
Function SingleStepConference ( _
    request As SingleStepConferenceRequest _
) As SingleStepConferenceResponse
Visual C++
SingleStepConferenceResponse^ SingleStepConference(
    SingleStepConferenceRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionServiceSOAPContract..::.SingleStepTransfer Method
IInteractionServiceSOAPContract Interface See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SingleStepTransferResponse SingleStepTransfer(
    SingleStepTransferRequest request
)
Visual Basic (Declaration)
Function SingleStepTransfer ( _
    request As SingleStepTransferRequest _
) As SingleStepTransferResponse
Visual C++
SingleStepTransferResponse^ SingleStepTransfer(
    SingleStepTransferRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest
The request to be sent to the server

Return Value

The server's response

See Also

IInteractionServiceSOAPContract Interface
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceREST Class

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST Class
Members See Also Send Feedback
InteractionService API exposed as WCF ReST API

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class InteractionServiceREST : IInteractionServiceRESTContract
Visual Basic (Declaration)
Public Class InteractionServiceREST _
    Implements IInteractionServiceRESTContract
Visual C++
public ref class InteractionServiceREST : IInteractionServiceRESTContract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService..::.InteractionServiceREST

See Also

InteractionServiceREST Members
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceREST Members

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST Members
InteractionServiceREST Class Constructors Methods Properties See Also Send Feedback

The InteractionServiceREST type exposes the following members.

Constructors

Name | Description
InteractionServiceREST |

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AlternateCallJSON | Alternates between the given call and a held call. JSON Format
AnswerCall | Answers the given call (which is the given ringing interaction).
AnswerCallJSON | Answers the given call (which is the given ringing interaction). JSON Format
CompleteConference | Completes the two-step conference for the given call.
CompleteConferenceJSON | Completes the two-step conference for the given call. JSON Format
CompleteTransfer | Completes the given two-step transfer.
CompleteTransferJSON | Completes the given two-step transfer. JSON Format
DeleteFromConference | Deletes the given party from the conference.
DeleteFromConferenceJSON | Deletes the given party from the conference. JSON Format
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInteraction | Get an Interaction
GetInteractionJSON | Get an Interaction (JsON Format)
GetInteractions | Lists all the Interactions in the System
GetInteractionsJSON | Lists all the Interactions in the System (JsON Format)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
GetVersionJSON |
HoldCall | Places the given interaction on hold.
HoldCallJSON | Places the given interaction on hold. JSON Format
InitiateConference | Initiates the two-step conference for the given call.
InitiateConferenceJSON | Initiates the two-step conference for the given call. JSON Format
InitiateTransfer | Initiates the two-step transfer of the given call.
InitiateTransferJSON | Initiates the two-step transfer of the given call. JSON Format
ListenDisconnect |
ListenDisconnectJSON | JSON Format
ListenReconnect |
ListenReconnectJSON | JSON Format
MakeCall | Dials a new call.
MakeCallJSON | Dials a new call. JSON Format
MuteTransfer | Transfers the given interaction in a single blind attempt.
MuteTransferJSON | Transfers the given interaction in a single blind attempt. JSON Format
ReleaseCall | Releases the given interaction.
ReleaseCallJSON | Releases the given interaction. JSON Format
RetrieveCall | Retrieves the given interaction being held.
RetrieveCallJSON | Retrieves the given interaction being held. JSON Format
SendDtmf | Sends digits as DTMF tones on the given phone call.
SendDtmfJSON | Sends digits as DTMF tones on the given phone call. JSON Format
SetCallQualification | Sets the call qualification.
SetCallQualificationJSON | Sets the call qualification. JSON Format
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOffJSON | Cancels the call muting (enables the microphone). JSON Format
SetMuteOn | Mutes this call (disables the microphone).
SetMuteOnJSON | Mutes this call (disables the microphone). JSON Format
SingleStepConference | Conferences this call in one step.
SingleStepConferenceJSON | Conferences this call in one step. JSON Format
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransferJSON | Transfers the given interaction in a single step (without creating a consultation call). JSON Format
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClientChannel |
Details |
Service |

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceREST Constructor

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST Constructor
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionServiceREST(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
InteractionServiceREST(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceREST Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST Methods
InteractionServiceREST Class See Also Send Feedback

The InteractionServiceREST type exposes the following members.

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AlternateCallJSON | Alternates between the given call and a held call. JSON Format
AnswerCall | Answers the given call (which is the given ringing interaction).
AnswerCallJSON | Answers the given call (which is the given ringing interaction). JSON Format
CompleteConference | Completes the two-step conference for the given call.
CompleteConferenceJSON | Completes the two-step conference for the given call. JSON Format
CompleteTransfer | Completes the given two-step transfer.
CompleteTransferJSON | Completes the given two-step transfer. JSON Format
DeleteFromConference | Deletes the given party from the conference.
DeleteFromConferenceJSON | Deletes the given party from the conference. JSON Format
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInteraction | Get an Interaction
GetInteractionJSON | Get an Interaction (JsON Format)
GetInteractions | Lists all the Interactions in the System
GetInteractionsJSON | Lists all the Interactions in the System (JsON Format)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
GetVersionJSON |
HoldCall | Places the given interaction on hold.
HoldCallJSON | Places the given interaction on hold. JSON Format
InitiateConference | Initiates the two-step conference for the given call.
InitiateConferenceJSON | Initiates the two-step conference for the given call. JSON Format
InitiateTransfer | Initiates the two-step transfer of the given call.
InitiateTransferJSON | Initiates the two-step transfer of the given call. JSON Format
ListenDisconnect |
ListenDisconnectJSON | JSON Format
ListenReconnect |
ListenReconnectJSON | JSON Format
MakeCall | Dials a new call.
MakeCallJSON | Dials a new call. JSON Format
MuteTransfer | Transfers the given interaction in a single blind attempt.
MuteTransferJSON | Transfers the given interaction in a single blind attempt. JSON Format
ReleaseCall | Releases the given interaction.
ReleaseCallJSON | Releases the given interaction. JSON Format
RetrieveCall | Retrieves the given interaction being held.
RetrieveCallJSON | Retrieves the given interaction being held. JSON Format
SendDtmf | Sends digits as DTMF tones on the given phone call.
SendDtmfJSON | Sends digits as DTMF tones on the given phone call. JSON Format
SetCallQualification | Sets the call qualification.
SetCallQualificationJSON | Sets the call qualification. JSON Format
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOffJSON | Cancels the call muting (enables the microphone). JSON Format
SetMuteOn | Mutes this call (disables the microphone).
SetMuteOnJSON | Mutes this call (disables the microphone). JSON Format
SingleStepConference | Conferences this call in one step.
SingleStepConferenceJSON | Conferences this call in one step. JSON Format
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransferJSON | Transfers the given interaction in a single step (without creating a consultation call). JSON Format
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


AlternateCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.AlternateCall Method
InteractionServiceREST Class See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AlternateCallResponse AlternateCall(
    AlternateCallRequest request
)
Visual Basic (Declaration)
Public Function AlternateCall ( _
    request As AlternateCallRequest _
) As AlternateCallResponse
Visual C++
public:
virtual AlternateCallResponse^ AlternateCall(
    AlternateCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.AlternateCall(AlternateCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


AlternateCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.AlternateCallJSON Method
InteractionServiceREST Class See Also Send Feedback
Alternates between the given call and a held call. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AlternateCallResponse AlternateCallJSON(
    AlternateCallRequest request
)
Visual Basic (Declaration)
Public Function AlternateCallJSON ( _
    request As AlternateCallRequest _
) As AlternateCallResponse
Visual C++
public:
virtual AlternateCallResponse^ AlternateCallJSON(
    AlternateCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.AlternateCallJSON(AlternateCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


AnswerCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.AnswerCall Method
InteractionServiceREST Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AnswerCallResponse AnswerCall(
    AnswerCallRequest request
)
Visual Basic (Declaration)
Public Function AnswerCall ( _
    request As AnswerCallRequest _
) As AnswerCallResponse
Visual C++
public:
virtual AnswerCallResponse^ AnswerCall(
    AnswerCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.AnswerCall(AnswerCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


AnswerCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.AnswerCallJSON Method
InteractionServiceREST Class See Also Send Feedback
Answers the given call (which is the given ringing interaction). JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AnswerCallResponse AnswerCallJSON(
    AnswerCallRequest request
)
Visual Basic (Declaration)
Public Function AnswerCallJSON ( _
    request As AnswerCallRequest _
) As AnswerCallResponse
Visual C++
public:
virtual AnswerCallResponse^ AnswerCallJSON(
    AnswerCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.AnswerCallJSON(AnswerCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.CompleteConference Method
InteractionServiceREST Class See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteConferenceResponse CompleteConference(
    CompleteConferenceRequest request
)
Visual Basic (Declaration)
Public Function CompleteConference ( _
    request As CompleteConferenceRequest _
) As CompleteConferenceResponse
Visual C++
public:
virtual CompleteConferenceResponse^ CompleteConference(
    CompleteConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.CompleteConference(CompleteConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.CompleteConferenceJSON Method
InteractionServiceREST Class See Also Send Feedback
Completes the two-step conference for the given call. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteConferenceResponse CompleteConferenceJSON(
    CompleteConferenceRequest request
)
Visual Basic (Declaration)
Public Function CompleteConferenceJSON ( _
    request As CompleteConferenceRequest _
) As CompleteConferenceResponse
Visual C++
public:
virtual CompleteConferenceResponse^ CompleteConferenceJSON(
    CompleteConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.CompleteConferenceJSON(CompleteConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.CompleteTransfer Method
InteractionServiceREST Class See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteTransferResponse CompleteTransfer(
    CompleteTransferRequest request
)
Visual Basic (Declaration)
Public Function CompleteTransfer ( _
    request As CompleteTransferRequest _
) As CompleteTransferResponse
Visual C++
public:
virtual CompleteTransferResponse^ CompleteTransfer(
    CompleteTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.CompleteTransfer(CompleteTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.CompleteTransferJSON Method
InteractionServiceREST Class See Also Send Feedback
Completes the given two-step transfer. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteTransferResponse CompleteTransferJSON(
    CompleteTransferRequest request
)
Visual Basic (Declaration)
Public Function CompleteTransferJSON ( _
    request As CompleteTransferRequest _
) As CompleteTransferResponse
Visual C++
public:
virtual CompleteTransferResponse^ CompleteTransferJSON(
    CompleteTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.CompleteTransferJSON(CompleteTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


DeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.DeleteFromConference Method
InteractionServiceREST Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DeleteFromConferenceResponse DeleteFromConference(
    DeleteFromConferenceRequest request
)
Visual Basic (Declaration)
Public Function DeleteFromConference ( _
    request As DeleteFromConferenceRequest _
) As DeleteFromConferenceResponse
Visual C++
public:
virtual DeleteFromConferenceResponse^ DeleteFromConference(
    DeleteFromConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.DeleteFromConference(DeleteFromConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


DeleteFromConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.DeleteFromConferenceJSON Method
InteractionServiceREST Class See Also Send Feedback
Deletes the given party from the conference. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DeleteFromConferenceResponse DeleteFromConferenceJSON(
    DeleteFromConferenceRequest request
)
Visual Basic (Declaration)
Public Function DeleteFromConferenceJSON ( _
    request As DeleteFromConferenceRequest _
) As DeleteFromConferenceResponse
Visual C++
public:
virtual DeleteFromConferenceResponse^ DeleteFromConferenceJSON(
    DeleteFromConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.DeleteFromConferenceJSON(DeleteFromConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteraction Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.GetInteraction Method
InteractionServiceREST Class See Also Send Feedback
Get an Interaction

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO GetInteraction(
    string interactionId
)
Visual Basic (Declaration)
Public Function GetInteraction ( _
    interactionId As String _
) As InteractionDTO
Visual C++
public:
virtual InteractionDTO^ GetInteraction(
    String^ interactionId
) sealed

Parameters

interactionId
Type: System..::.String
Interaction Id

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.GetInteraction(String)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteractionJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.GetInteractionJSON Method
InteractionServiceREST Class See Also Send Feedback
Get an Interaction (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO GetInteractionJSON(
    string interactionId
)
Visual Basic (Declaration)
Public Function GetInteractionJSON ( _
    interactionId As String _
) As InteractionDTO
Visual C++
public:
virtual InteractionDTO^ GetInteractionJSON(
    String^ interactionId
) sealed

Parameters

interactionId
Type: System..::.String
Interaction Id

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.GetInteractionJSON(String)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.GetInteractions Method
InteractionServiceREST Class See Also Send Feedback
Lists all the Interactions in the System

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<InteractionDTO> GetInteractions()
Visual Basic (Declaration)
Public Function GetInteractions As List(Of InteractionDTO)
Visual C++
public:
virtual List<InteractionDTO^>^ GetInteractions() sealed

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.GetInteractions()()()

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetInteractionsJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.GetInteractionsJSON Method
InteractionServiceREST Class See Also Send Feedback
Lists all the Interactions in the System (JsON Format)

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<InteractionDTO> GetInteractionsJSON()
Visual Basic (Declaration)
Public Function GetInteractionsJSON As List(Of InteractionDTO)
Visual C++
public:
virtual List<InteractionDTO^>^ GetInteractionsJSON() sealed

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.GetInteractionsJSON()()()

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.GetVersion Method
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.GetVersion"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetVersion()
Visual Basic (Declaration)
Public Function GetVersion As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetVersion() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.GetVersion"]

Implements

IInteractionServiceRESTContract..::.GetVersion()()()

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetVersionJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.GetVersionJSON Method
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.GetVersionJSON"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetVersionJSON()
Visual Basic (Declaration)
Public Function GetVersionJSON As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetVersionJSON() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.GetVersionJSON"]

Implements

IInteractionServiceRESTContract..::.GetVersionJSON()()()

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


HoldCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.HoldCall Method
InteractionServiceREST Class See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public HoldCallResponse HoldCall(
    HoldCallRequest request
)
Visual Basic (Declaration)
Public Function HoldCall ( _
    request As HoldCallRequest _
) As HoldCallResponse
Visual C++
public:
virtual HoldCallResponse^ HoldCall(
    HoldCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.HoldCall(HoldCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


HoldCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.HoldCallJSON Method
InteractionServiceREST Class See Also Send Feedback
Places the given interaction on hold. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public HoldCallResponse HoldCallJSON(
    HoldCallRequest request
)
Visual Basic (Declaration)
Public Function HoldCallJSON ( _
    request As HoldCallRequest _
) As HoldCallResponse
Visual C++
public:
virtual HoldCallResponse^ HoldCallJSON(
    HoldCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.HoldCallJSON(HoldCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.InitiateConference Method
InteractionServiceREST Class See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateConferenceResponse InitiateConference(
    InitiateConferenceRequest request
)
Visual Basic (Declaration)
Public Function InitiateConference ( _
    request As InitiateConferenceRequest _
) As InitiateConferenceResponse
Visual C++
public:
virtual InitiateConferenceResponse^ InitiateConference(
    InitiateConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.InitiateConference(InitiateConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.InitiateConferenceJSON Method
InteractionServiceREST Class See Also Send Feedback
Initiates the two-step conference for the given call. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateConferenceResponse InitiateConferenceJSON(
    InitiateConferenceRequest request
)
Visual Basic (Declaration)
Public Function InitiateConferenceJSON ( _
    request As InitiateConferenceRequest _
) As InitiateConferenceResponse
Visual C++
public:
virtual InitiateConferenceResponse^ InitiateConferenceJSON(
    InitiateConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.InitiateConferenceJSON(InitiateConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.InitiateTransfer Method
InteractionServiceREST Class See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateTransferResponse InitiateTransfer(
    InitiateTransferRequest request
)
Visual Basic (Declaration)
Public Function InitiateTransfer ( _
    request As InitiateTransferRequest _
) As InitiateTransferResponse
Visual C++
public:
virtual InitiateTransferResponse^ InitiateTransfer(
    InitiateTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.InitiateTransfer(InitiateTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.InitiateTransferJSON Method
InteractionServiceREST Class See Also Send Feedback
Initiates the two-step transfer of the given call. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateTransferResponse InitiateTransferJSON(
    InitiateTransferRequest request
)
Visual Basic (Declaration)
Public Function InitiateTransferJSON ( _
    request As InitiateTransferRequest _
) As InitiateTransferResponse
Visual C++
public:
virtual InitiateTransferResponse^ InitiateTransferJSON(
    InitiateTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.InitiateTransferJSON(InitiateTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ListenDisconnect Method
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.ListenDisconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenDisconnectResponse ListenDisconnect(
    ListenDisconnectRequest request
)
Visual Basic (Declaration)
Public Function ListenDisconnect ( _
    request As ListenDisconnectRequest _
) As ListenDisconnectResponse
Visual C++
public:
virtual ListenDisconnectResponse^ ListenDisconnect(
    ListenDisconnectRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.ListenDisconnect(ListenDisconnectRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenDisconnectJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ListenDisconnectJSON Method
InteractionServiceREST Class See Also Send Feedback
JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenDisconnectResponse ListenDisconnectJSON(
    ListenDisconnectRequest request
)
Visual Basic (Declaration)
Public Function ListenDisconnectJSON ( _
    request As ListenDisconnectRequest _
) As ListenDisconnectResponse
Visual C++
public:
virtual ListenDisconnectResponse^ ListenDisconnectJSON(
    ListenDisconnectRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.ListenDisconnectJSON(ListenDisconnectRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ListenReconnect Method
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.ListenReconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenReconnectResponse ListenReconnect(
    ListenReconnectRequest request
)
Visual Basic (Declaration)
Public Function ListenReconnect ( _
    request As ListenReconnectRequest _
) As ListenReconnectResponse
Visual C++
public:
virtual ListenReconnectResponse^ ListenReconnect(
    ListenReconnectRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.ListenReconnect(ListenReconnectRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenReconnectJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ListenReconnectJSON Method
InteractionServiceREST Class See Also Send Feedback
JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenReconnectResponse ListenReconnectJSON(
    ListenReconnectRequest request
)
Visual Basic (Declaration)
Public Function ListenReconnectJSON ( _
    request As ListenReconnectRequest _
) As ListenReconnectResponse
Visual C++
public:
virtual ListenReconnectResponse^ ListenReconnectJSON(
    ListenReconnectRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.ListenReconnectJSON(ListenReconnectRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


MakeCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.MakeCall Method
InteractionServiceREST Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MakeCallResponse MakeCall(
    MakeCallRequest request
)
Visual Basic (Declaration)
Public Function MakeCall ( _
    request As MakeCallRequest _
) As MakeCallResponse
Visual C++
public:
virtual MakeCallResponse^ MakeCall(
    MakeCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.MakeCall(MakeCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


MakeCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.MakeCallJSON Method
InteractionServiceREST Class See Also Send Feedback
Dials a new call. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MakeCallResponse MakeCallJSON(
    MakeCallRequest request
)
Visual Basic (Declaration)
Public Function MakeCallJSON ( _
    request As MakeCallRequest _
) As MakeCallResponse
Visual C++
public:
virtual MakeCallResponse^ MakeCallJSON(
    MakeCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.MakeCallJSON(MakeCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


MuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.MuteTransfer Method
InteractionServiceREST Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MuteTransferResponse MuteTransfer(
    MuteTransferRequest request
)
Visual Basic (Declaration)
Public Function MuteTransfer ( _
    request As MuteTransferRequest _
) As MuteTransferResponse
Visual C++
public:
virtual MuteTransferResponse^ MuteTransfer(
    MuteTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.MuteTransfer(MuteTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


MuteTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.MuteTransferJSON Method
InteractionServiceREST Class See Also Send Feedback
Transfers the given interaction in a single blind attempt. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MuteTransferResponse MuteTransferJSON(
    MuteTransferRequest request
)
Visual Basic (Declaration)
Public Function MuteTransferJSON ( _
    request As MuteTransferRequest _
) As MuteTransferResponse
Visual C++
public:
virtual MuteTransferResponse^ MuteTransferJSON(
    MuteTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.MuteTransferJSON(MuteTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ReleaseCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ReleaseCall Method
InteractionServiceREST Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReleaseCallResponse ReleaseCall(
    ReleaseCallRequest request
)
Visual Basic (Declaration)
Public Function ReleaseCall ( _
    request As ReleaseCallRequest _
) As ReleaseCallResponse
Visual C++
public:
virtual ReleaseCallResponse^ ReleaseCall(
    ReleaseCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.ReleaseCall(ReleaseCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ReleaseCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ReleaseCallJSON Method
InteractionServiceREST Class See Also Send Feedback
Releases the given interaction. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReleaseCallResponse ReleaseCallJSON(
    ReleaseCallRequest request
)
Visual Basic (Declaration)
Public Function ReleaseCallJSON ( _
    request As ReleaseCallRequest _
) As ReleaseCallResponse
Visual C++
public:
virtual ReleaseCallResponse^ ReleaseCallJSON(
    ReleaseCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.ReleaseCallJSON(ReleaseCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


RetrieveCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.RetrieveCall Method
InteractionServiceREST Class See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public RetrieveCallResponse RetrieveCall(
    RetrieveCallRequest request
)
Visual Basic (Declaration)
Public Function RetrieveCall ( _
    request As RetrieveCallRequest _
) As RetrieveCallResponse
Visual C++
public:
virtual RetrieveCallResponse^ RetrieveCall(
    RetrieveCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.RetrieveCall(RetrieveCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


RetrieveCallJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.RetrieveCallJSON Method
InteractionServiceREST Class See Also Send Feedback
Retrieves the given interaction being held. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public RetrieveCallResponse RetrieveCallJSON(
    RetrieveCallRequest request
)
Visual Basic (Declaration)
Public Function RetrieveCallJSON ( _
    request As RetrieveCallRequest _
) As RetrieveCallResponse
Visual C++
public:
virtual RetrieveCallResponse^ RetrieveCallJSON(
    RetrieveCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.RetrieveCallJSON(RetrieveCallRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SendDtmf Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SendDtmf Method
InteractionServiceREST Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SendDtmfResponse SendDtmf(
    SendDtmfRequest request
)
Visual Basic (Declaration)
Public Function SendDtmf ( _
    request As SendDtmfRequest _
) As SendDtmfResponse
Visual C++
public:
virtual SendDtmfResponse^ SendDtmf(
    SendDtmfRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SendDtmf(SendDtmfRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SendDtmfJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SendDtmfJSON Method
InteractionServiceREST Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SendDtmfResponse SendDtmfJSON(
    SendDtmfRequest request
)
Visual Basic (Declaration)
Public Function SendDtmfJSON ( _
    request As SendDtmfRequest _
) As SendDtmfResponse
Visual C++
public:
virtual SendDtmfResponse^ SendDtmfJSON(
    SendDtmfRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SendDtmfJSON(SendDtmfRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SetCallQualification Method
InteractionServiceREST Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetCallQualificationResponse SetCallQualification(
    SetCallQualificationRequest request
)
Visual Basic (Declaration)
Public Function SetCallQualification ( _
    request As SetCallQualificationRequest _
) As SetCallQualificationResponse
Visual C++
public:
virtual SetCallQualificationResponse^ SetCallQualification(
    SetCallQualificationRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SetCallQualification(SetCallQualificationRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetCallQualificationJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SetCallQualificationJSON Method
InteractionServiceREST Class See Also Send Feedback
Sets the call qualification. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetCallQualificationResponse SetCallQualificationJSON(
    SetCallQualificationRequest request
)
Visual Basic (Declaration)
Public Function SetCallQualificationJSON ( _
    request As SetCallQualificationRequest _
) As SetCallQualificationResponse
Visual C++
public:
virtual SetCallQualificationResponse^ SetCallQualificationJSON(
    SetCallQualificationRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SetCallQualificationJSON(SetCallQualificationRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOff Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SetMuteOff Method
InteractionServiceREST Class See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOffResponse SetMuteOff(
    SetMuteOffRequest request
)
Visual Basic (Declaration)
Public Function SetMuteOff ( _
    request As SetMuteOffRequest _
) As SetMuteOffResponse
Visual C++
public:
virtual SetMuteOffResponse^ SetMuteOff(
    SetMuteOffRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SetMuteOff(SetMuteOffRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOffJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SetMuteOffJSON Method
InteractionServiceREST Class See Also Send Feedback
Cancels the call muting (enables the microphone). JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOffResponse SetMuteOffJSON(
    SetMuteOffRequest request
)
Visual Basic (Declaration)
Public Function SetMuteOffJSON ( _
    request As SetMuteOffRequest _
) As SetMuteOffResponse
Visual C++
public:
virtual SetMuteOffResponse^ SetMuteOffJSON(
    SetMuteOffRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SetMuteOffJSON(SetMuteOffRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOn Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SetMuteOn Method
InteractionServiceREST Class See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOnResponse SetMuteOn(
    SetMuteOnRequest request
)
Visual Basic (Declaration)
Public Function SetMuteOn ( _
    request As SetMuteOnRequest _
) As SetMuteOnResponse
Visual C++
public:
virtual SetMuteOnResponse^ SetMuteOn(
    SetMuteOnRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SetMuteOn(SetMuteOnRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOnJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SetMuteOnJSON Method
InteractionServiceREST Class See Also Send Feedback
Mutes this call (disables the microphone). JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOnResponse SetMuteOnJSON(
    SetMuteOnRequest request
)
Visual Basic (Declaration)
Public Function SetMuteOnJSON ( _
    request As SetMuteOnRequest _
) As SetMuteOnResponse
Visual C++
public:
virtual SetMuteOnResponse^ SetMuteOnJSON(
    SetMuteOnRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SetMuteOnJSON(SetMuteOnRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SingleStepConference Method
InteractionServiceREST Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepConferenceResponse SingleStepConference(
    SingleStepConferenceRequest request
)
Visual Basic (Declaration)
Public Function SingleStepConference ( _
    request As SingleStepConferenceRequest _
) As SingleStepConferenceResponse
Visual C++
public:
virtual SingleStepConferenceResponse^ SingleStepConference(
    SingleStepConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SingleStepConference(SingleStepConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepConferenceJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SingleStepConferenceJSON Method
InteractionServiceREST Class See Also Send Feedback
Conferences this call in one step. JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepConferenceResponse SingleStepConferenceJSON(
    SingleStepConferenceRequest request
)
Visual Basic (Declaration)
Public Function SingleStepConferenceJSON ( _
    request As SingleStepConferenceRequest _
) As SingleStepConferenceResponse
Visual C++
public:
virtual SingleStepConferenceResponse^ SingleStepConferenceJSON(
    SingleStepConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SingleStepConferenceJSON(SingleStepConferenceRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SingleStepTransfer Method
InteractionServiceREST Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepTransferResponse SingleStepTransfer(
    SingleStepTransferRequest request
)
Visual Basic (Declaration)
Public Function SingleStepTransfer ( _
    request As SingleStepTransferRequest _
) As SingleStepTransferResponse
Visual C++
public:
virtual SingleStepTransferResponse^ SingleStepTransfer(
    SingleStepTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SingleStepTransfer(SingleStepTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepTransferJSON Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.SingleStepTransferJSON Method
InteractionServiceREST Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call). JSON Format

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepTransferResponse SingleStepTransferJSON(
    SingleStepTransferRequest request
)
Visual Basic (Declaration)
Public Function SingleStepTransferJSON ( _
    request As SingleStepTransferRequest _
) As SingleStepTransferResponse
Visual C++
public:
virtual SingleStepTransferResponse^ SingleStepTransferJSON(
    SingleStepTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceRESTContract..::.SingleStepTransferJSON(SingleStepTransferRequest)

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceREST Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST Properties
InteractionServiceREST Class See Also Send Feedback

The InteractionServiceREST type exposes the following members.

Properties

Name | Description
ClientChannel |
Details |
Service |

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ClientChannel Property

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.ClientChannel Property
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.ClientChannel"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IClientChannel ClientChannel { get; set; }
Visual Basic (Declaration)
Public Property ClientChannel As IClientChannel
Visual C++
public:
virtual property IClientChannel^ ClientChannel {
    IClientChannel^ get () sealed;
    void set (IClientChannel^ value) sealed;
}

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


Details Property

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.Details Property
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.Details"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Details { get; set; }
Visual Basic (Declaration)
Public Property Details As KeyValueCollection
Visual C++
public:
virtual property KeyValueCollection^ Details {
    KeyValueCollection^ get () sealed;
    void set (KeyValueCollection^ value) sealed;
}

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


Service Property

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceREST..::.Service Property
InteractionServiceREST Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceREST.Service"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Service { get; }
Visual Basic (Declaration)
Public ReadOnly Property Service As String
Visual C++
public:
property String^ Service {
    String^ get ();
}

See Also

InteractionServiceREST Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceSOAP Class

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP Class
Members See Also Send Feedback
InteractionService API exposed as WCF SOAP API

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class InteractionServiceSOAP : IInteractionServiceSOAPContract
Visual Basic (Declaration)
Public Class InteractionServiceSOAP _
    Implements IInteractionServiceSOAPContract
Visual C++
public ref class InteractionServiceSOAP : IInteractionServiceSOAPContract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService..::.InteractionServiceSOAP

See Also

InteractionServiceSOAP Members
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceSOAP Members

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP Members
InteractionServiceSOAP Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The InteractionServiceSOAP type exposes the following members.

Constructors

Name | Description
InteractionServiceSOAP |

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AnswerCall | Answers the given call (which is the given ringing interaction).
CompleteConference | Completes the two-step conference for the given call.
CompleteTransfer | Completes the given two-step transfer.
DeleteFromConference | Deletes the given party from the conference.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
HoldCall | Places the given interaction on hold.
InitiateConference | Initiates the two-step conference for the given call.
InitiateTransfer | Initiates the two-step transfer of the given call.
ListenDisconnect |
ListenReconnect |
MakeCall | Dials a new call.
MuteTransfer | Transfers the given interaction in a single blind attempt.
ReleaseCall | Releases the given interaction.
RetrieveCall | Retrieves the given interaction being held.
SendDtmf | Sends digits as DTMF tones on the given phone call.
SetCallQualification | Sets the call qualification.
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOn | Mutes this call (disables the microphone).
SingleStepConference | Conferences this call in one step.
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClientChannel | Communication Channel use to send requests to.
Details |
Service | Service Name

Explicit Interface Implementations

Name | Description
IInteractionServiceSOAPContract..::.GetVersion |

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceSOAP Constructor

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP Constructor
InteractionServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionServiceSOAP(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
InteractionServiceSOAP(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceSOAP Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP Methods
InteractionServiceSOAP Class See Also Send Feedback

The InteractionServiceSOAP type exposes the following members.

Methods

Name | Description
AlternateCall | Alternates between the given call and a held call.
AnswerCall | Answers the given call (which is the given ringing interaction).
CompleteConference | Completes the two-step conference for the given call.
CompleteTransfer | Completes the given two-step transfer.
DeleteFromConference | Deletes the given party from the conference.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
HoldCall | Places the given interaction on hold.
InitiateConference | Initiates the two-step conference for the given call.
InitiateTransfer | Initiates the two-step transfer of the given call.
ListenDisconnect |
ListenReconnect |
MakeCall | Dials a new call.
MuteTransfer | Transfers the given interaction in a single blind attempt.
ReleaseCall | Releases the given interaction.
RetrieveCall | Retrieves the given interaction being held.
SendDtmf | Sends digits as DTMF tones on the given phone call.
SetCallQualification | Sets the call qualification.
SetMuteOff | Cancels the call muting (enables the microphone).
SetMuteOn | Mutes this call (disables the microphone).
SingleStepConference | Conferences this call in one step.
SingleStepTransfer | Transfers the given interaction in a single step (without creating a consultation call).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IInteractionServiceSOAPContract..::.GetVersion |

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


AlternateCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.AlternateCall Method
InteractionServiceSOAP Class See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AlternateCallResponse AlternateCall(
    AlternateCallRequest request
)
Visual Basic (Declaration)
Public Function AlternateCall ( _
    request As AlternateCallRequest _
) As AlternateCallResponse
Visual C++
public:
virtual AlternateCallResponse^ AlternateCall(
    AlternateCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.AlternateCall(AlternateCallRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


AnswerCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.AnswerCall Method
InteractionServiceSOAP Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AnswerCallResponse AnswerCall(
    AnswerCallRequest request
)
Visual Basic (Declaration)
Public Function AnswerCall ( _
    request As AnswerCallRequest _
) As AnswerCallResponse
Visual C++
public:
virtual AnswerCallResponse^ AnswerCall(
    AnswerCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.AnswerCall(AnswerCallRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.CompleteConference Method
InteractionServiceSOAP Class See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteConferenceResponse CompleteConference(
    CompleteConferenceRequest request
)
Visual Basic (Declaration)
Public Function CompleteConference ( _
    request As CompleteConferenceRequest _
) As CompleteConferenceResponse
Visual C++
public:
virtual CompleteConferenceResponse^ CompleteConference(
    CompleteConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.CompleteConference(CompleteConferenceRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


CompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.CompleteTransfer Method
InteractionServiceSOAP Class See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteTransferResponse CompleteTransfer(
    CompleteTransferRequest request
)
Visual Basic (Declaration)
Public Function CompleteTransfer ( _
    request As CompleteTransferRequest _
) As CompleteTransferResponse
Visual C++
public:
virtual CompleteTransferResponse^ CompleteTransfer(
    CompleteTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.CompleteTransfer(CompleteTransferRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


DeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.DeleteFromConference Method
InteractionServiceSOAP Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DeleteFromConferenceResponse DeleteFromConference(
    DeleteFromConferenceRequest request
)
Visual Basic (Declaration)
Public Function DeleteFromConference ( _
    request As DeleteFromConferenceRequest _
) As DeleteFromConferenceResponse
Visual C++
public:
virtual DeleteFromConferenceResponse^ DeleteFromConference(
    DeleteFromConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.DeleteFromConference(DeleteFromConferenceRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.GetVersion Method
InteractionServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.GetVersion"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetVersion()
Visual Basic (Declaration)
Public Function GetVersion As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetVersion() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.GetVersion"]

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


HoldCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.HoldCall Method
InteractionServiceSOAP Class See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public HoldCallResponse HoldCall(
    HoldCallRequest request
)
Visual Basic (Declaration)
Public Function HoldCall ( _
    request As HoldCallRequest _
) As HoldCallResponse
Visual C++
public:
virtual HoldCallResponse^ HoldCall(
    HoldCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.HoldCall(HoldCallRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


IInteractionServiceSOAPContract.GetVersion Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.IInteractionServiceSOAPContract..::.GetVersion Method
InteractionServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.Genesyslab#Enterprise#Communication#InteractionService#IInteractionServiceSOAPContract#GetVersion"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection IInteractionServiceSOAPContract.GetVersion()
Visual Basic (Declaration)
Private Function GetVersion As KeyValueCollection
    Implements IInteractionServiceSOAPContract.GetVersion
Visual C++
private:
virtual KeyValueCollection^ GetVersion() sealed = IInteractionServiceSOAPContract::GetVersion

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.Genesyslab#Enterprise#Communication#InteractionService#IInteractionServiceSOAPContract#GetVersion"]

Implements

IInteractionServiceSOAPContract..::.GetVersion()()()

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.InitiateConference Method
InteractionServiceSOAP Class See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateConferenceResponse InitiateConference(
    InitiateConferenceRequest request
)
Visual Basic (Declaration)
Public Function InitiateConference ( _
    request As InitiateConferenceRequest _
) As InitiateConferenceResponse
Visual C++
public:
virtual InitiateConferenceResponse^ InitiateConference(
    InitiateConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.InitiateConference(InitiateConferenceRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.InitiateTransfer Method
InteractionServiceSOAP Class See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateTransferResponse InitiateTransfer(
    InitiateTransferRequest request
)
Visual Basic (Declaration)
Public Function InitiateTransfer ( _
    request As InitiateTransferRequest _
) As InitiateTransferResponse
Visual C++
public:
virtual InitiateTransferResponse^ InitiateTransfer(
    InitiateTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.InitiateTransfer(InitiateTransferRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.ListenDisconnect Method
InteractionServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.ListenDisconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenDisconnectResponse ListenDisconnect(
    ListenDisconnectRequest request
)
Visual Basic (Declaration)
Public Function ListenDisconnect ( _
    request As ListenDisconnectRequest _
) As ListenDisconnectResponse
Visual C++
public:
virtual ListenDisconnectResponse^ ListenDisconnect(
    ListenDisconnectRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.ListenDisconnect(ListenDisconnectRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.ListenReconnect Method
InteractionServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.ListenReconnect(Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest)"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenReconnectResponse ListenReconnect(
    ListenReconnectRequest request
)
Visual Basic (Declaration)
Public Function ListenReconnect ( _
    request As ListenReconnectRequest _
) As ListenReconnectResponse
Visual C++
public:
virtual ListenReconnectResponse^ ListenReconnect(
    ListenReconnectRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.ListenReconnect(ListenReconnectRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


MakeCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.MakeCall Method
InteractionServiceSOAP Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MakeCallResponse MakeCall(
    MakeCallRequest request
)
Visual Basic (Declaration)
Public Function MakeCall ( _
    request As MakeCallRequest _
) As MakeCallResponse
Visual C++
public:
virtual MakeCallResponse^ MakeCall(
    MakeCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.MakeCall(MakeCallRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


MuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.MuteTransfer Method
InteractionServiceSOAP Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MuteTransferResponse MuteTransfer(
    MuteTransferRequest request
)
Visual Basic (Declaration)
Public Function MuteTransfer ( _
    request As MuteTransferRequest _
) As MuteTransferResponse
Visual C++
public:
virtual MuteTransferResponse^ MuteTransfer(
    MuteTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.MuteTransfer(MuteTransferRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ReleaseCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.ReleaseCall Method
InteractionServiceSOAP Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReleaseCallResponse ReleaseCall(
    ReleaseCallRequest request
)
Visual Basic (Declaration)
Public Function ReleaseCall ( _
    request As ReleaseCallRequest _
) As ReleaseCallResponse
Visual C++
public:
virtual ReleaseCallResponse^ ReleaseCall(
    ReleaseCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.ReleaseCall(ReleaseCallRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


RetrieveCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.RetrieveCall Method
InteractionServiceSOAP Class See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public RetrieveCallResponse RetrieveCall(
    RetrieveCallRequest request
)
Visual Basic (Declaration)
Public Function RetrieveCall ( _
    request As RetrieveCallRequest _
) As RetrieveCallResponse
Visual C++
public:
virtual RetrieveCallResponse^ RetrieveCall(
    RetrieveCallRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.RetrieveCall(RetrieveCallRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SendDtmf Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.SendDtmf Method
InteractionServiceSOAP Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SendDtmfResponse SendDtmf(
    SendDtmfRequest request
)
Visual Basic (Declaration)
Public Function SendDtmf ( _
    request As SendDtmfRequest _
) As SendDtmfResponse
Visual C++
public:
virtual SendDtmfResponse^ SendDtmf(
    SendDtmfRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.SendDtmf(SendDtmfRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.SetCallQualification Method
InteractionServiceSOAP Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetCallQualificationResponse SetCallQualification(
    SetCallQualificationRequest request
)
Visual Basic (Declaration)
Public Function SetCallQualification ( _
    request As SetCallQualificationRequest _
) As SetCallQualificationResponse
Visual C++
public:
virtual SetCallQualificationResponse^ SetCallQualification(
    SetCallQualificationRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.SetCallQualification(SetCallQualificationRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOff Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.SetMuteOff Method
InteractionServiceSOAP Class See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOffResponse SetMuteOff(
    SetMuteOffRequest request
)
Visual Basic (Declaration)
Public Function SetMuteOff ( _
    request As SetMuteOffRequest _
) As SetMuteOffResponse
Visual C++
public:
virtual SetMuteOffResponse^ SetMuteOff(
    SetMuteOffRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.SetMuteOff(SetMuteOffRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SetMuteOn Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.SetMuteOn Method
InteractionServiceSOAP Class See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOnResponse SetMuteOn(
    SetMuteOnRequest request
)
Visual Basic (Declaration)
Public Function SetMuteOn ( _
    request As SetMuteOnRequest _
) As SetMuteOnResponse
Visual C++
public:
virtual SetMuteOnResponse^ SetMuteOn(
    SetMuteOnRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.SetMuteOn(SetMuteOnRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.SingleStepConference Method
InteractionServiceSOAP Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepConferenceResponse SingleStepConference(
    SingleStepConferenceRequest request
)
Visual Basic (Declaration)
Public Function SingleStepConference ( _
    request As SingleStepConferenceRequest _
) As SingleStepConferenceResponse
Visual C++
public:
virtual SingleStepConferenceResponse^ SingleStepConference(
    SingleStepConferenceRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.SingleStepConference(SingleStepConferenceRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


SingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.SingleStepTransfer Method
InteractionServiceSOAP Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepTransferResponse SingleStepTransfer(
    SingleStepTransferRequest request
)
Visual Basic (Declaration)
Public Function SingleStepTransfer ( _
    request As SingleStepTransferRequest _
) As SingleStepTransferResponse
Visual C++
public:
virtual SingleStepTransferResponse^ SingleStepTransfer(
    SingleStepTransferRequest^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest
The request to be sent to the server

Return Value

The server's response

Implements

IInteractionServiceSOAPContract..::.SingleStepTransfer(SingleStepTransferRequest)

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


InteractionServiceSOAP Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP Properties
InteractionServiceSOAP Class See Also Send Feedback

The InteractionServiceSOAP type exposes the following members.

Properties

Name | Description
ClientChannel | Communication Channel use to send requests to.
Details |
Service | Service Name

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


ClientChannel Property

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.ClientChannel Property
InteractionServiceSOAP Class See Also Send Feedback
Communication Channel use to send requests to.

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IClientChannel ClientChannel { get; set; }
Visual Basic (Declaration)
Public Property ClientChannel As IClientChannel
Visual C++
public:
virtual property IClientChannel^ ClientChannel {
    IClientChannel^ get () sealed;
    void set (IClientChannel^ value) sealed;
}

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


Details Property

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.Details Property
InteractionServiceSOAP Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.InteractionServiceSOAP.Details"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Details { get; set; }
Visual Basic (Declaration)
Public Property Details As KeyValueCollection
Visual C++
public:
virtual property KeyValueCollection^ Details {
    KeyValueCollection^ get () sealed;
    void set (KeyValueCollection^ value) sealed;
}

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


Service Property

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceSOAP..::.Service Property
InteractionServiceSOAP Class See Also Send Feedback
Service Name

Namespace: Genesyslab.Enterprise.Communication.InteractionService
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Service { get; }
Visual Basic (Declaration)
Public ReadOnly Property Service As String
Visual C++
public:
property String^ Service {
    String^ get ();
}

See Also

InteractionServiceSOAP Class
Genesyslab.Enterprise.Communication.InteractionService Namespace


Genesyslab.Enterprise.Communication.InteractionService.Type Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace
Send Feedback

Classes

Class | Description
AlternateCallRequest | InteractionService Service, AlternateCall Request.
AlternateCallResponse | InteractionService Service, AlternateCall Response.
AnswerCallRequest | InteractionService Service, AnswerCall Request.
AnswerCallResponse | InteractionService Service, AnswerCall Response.
CompleteConferenceRequest | InteractionService Service, CompleteConference Request.
CompleteConferenceResponse | InteractionService Service, CompleteConference Response.
CompleteTransferRequest | InteractionService Service, CompleteTransfer Request.
CompleteTransferResponse | InteractionService Service, CompleteTransfer Response.
DeleteFromConferenceRequest | InteractionService Service, DeleteFromConference Request.
DeleteFromConferenceResponse | InteractionService Service, DeleteFromConference Response.
HoldCallRequest | InteractionService Service, HoldCall Request.
HoldCallResponse | InteractionService Service, HoldCall Response.
InitiateConferenceRequest | InteractionService Service, InitiateConference Request.
InitiateConferenceResponse | InteractionService Service, InitiateConference Response.
InitiateTransferRequest | InteractionService Service, InitiateTransfer Request.
InitiateTransferResponse | InteractionService Service, InitiateTransfer Response.
ListenDisconnectRequest | InteractionService Service, ListenDisconnect Request.
ListenDisconnectResponse | InteractionService Service, ListenDisconnect Response.
ListenReconnectRequest | InteractionService Service, ListenReconnect Request.
ListenReconnectResponse | InteractionService Service, ListenReconnect Response.
MakeCallRequest | InteractionService Service, MakeCall Request.
MakeCallResponse | InteractionService Service, MakeCall Response.
MuteTransferRequest | InteractionService Service, MuteTransfer Request.
MuteTransferResponse | InteractionService Service, MuteTransfer Response.
ReleaseCallRequest | InteractionService Service, ReleaseCall Request.
ReleaseCallResponse | InteractionService Service, ReleaseCall Response.
RetrieveCallRequest | InteractionService Service, RetrieveCall Request.
RetrieveCallResponse | InteractionService Service, RetrieveCall Response.
SendDtmfRequest | InteractionService Service, SendDtmf Request.
SendDtmfResponse | InteractionService Service, SendDtmf Response.
SetCallQualificationRequest | InteractionService Service, SetCallQualification Request.
SetCallQualificationResponse | InteractionService Service, SetCallQualification Response.
SetMuteOffRequest | InteractionService Service, SetMuteOff Request.
SetMuteOffResponse | InteractionService Service, SetMuteOff Response.
SetMuteOnRequest | InteractionService Service, SetMuteOn Request.
SetMuteOnResponse | InteractionService Service, SetMuteOn Response.
SingleStepConferenceRequest | InteractionService Service, SingleStepConference Request.
SingleStepConferenceResponse | InteractionService Service, SingleStepConference Response.
SingleStepTransferRequest | InteractionService Service, SingleStepTransfer Request.
SingleStepTransferResponse | InteractionService Service, SingleStepTransfer Response.


AlternateCallRequest Class

[image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest Class
Members See Also Send Feedback
InteractionService Service, AlternateCall Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class AlternateCallRequest
Visual Basic (Declaration)
Public Class AlternateCallRequest
Visual C++
public ref class AlternateCallRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallRequest

See Also

AlternateCallRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest Members
AlternateCallRequest Class Constructors Methods Properties See Also Send Feedback

The AlternateCallRequest type exposes the following members.

Constructors

Name | Description
AlternateCallRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest Constructor
AlternateCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.AlternateCallRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AlternateCallRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AlternateCallRequest()

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest Methods
AlternateCallRequest Class See Also Send Feedback

The AlternateCallRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest Properties
AlternateCallRequest Class See Also Send Feedback

The AlternateCallRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest..::.Extensions Property
AlternateCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AlternateCallRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest..::.Interaction Property
AlternateCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AlternateCallRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
AlternateCallRequest..::.Reasons Property
AlternateCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AlternateCallRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

AlternateCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallResponse Class

[image]

Enterprise SDK 8.0 Reference API
AlternateCallResponse Class
Members See Also Send Feedback
InteractionService Service, AlternateCall Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class AlternateCallResponse
Visual Basic (Declaration)
Public Class AlternateCallResponse
Visual C++
public ref class AlternateCallResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.AlternateCallResponse

See Also

AlternateCallResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
AlternateCallResponse Members
AlternateCallResponse Class Constructors Methods Properties See Also Send Feedback

The AlternateCallResponse type exposes the following members.

Constructors

Name | Description
AlternateCallResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

AlternateCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
AlternateCallResponse Constructor
AlternateCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.AlternateCallResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AlternateCallResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AlternateCallResponse()

See Also

AlternateCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AlternateCallResponse Methods
AlternateCallResponse Class See Also Send Feedback

The AlternateCallResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlternateCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AlternateCallResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
AlternateCallResponse Properties
AlternateCallResponse Class See Also Send Feedback

The AlternateCallResponse type exposes the following members.

Properties

Name | Description
result |

See Also

AlternateCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
AlternateCallResponse..::.result Property
AlternateCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AlternateCallResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

AlternateCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallRequest Class

[image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest Class
Members See Also Send Feedback
InteractionService Service, AnswerCall Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class AnswerCallRequest
Visual Basic (Declaration)
Public Class AnswerCallRequest
Visual C++
public ref class AnswerCallRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallRequest

See Also

AnswerCallRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest Members
AnswerCallRequest Class Constructors Methods Properties See Also Send Feedback

The AnswerCallRequest type exposes the following members.

Constructors

Name | Description
AnswerCallRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Interaction |
Reasons |

See Also

AnswerCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest Constructor
AnswerCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.AnswerCallRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AnswerCallRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnswerCallRequest()

See Also

AnswerCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest Methods
AnswerCallRequest Class See Also Send Feedback

The AnswerCallRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnswerCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest Properties
AnswerCallRequest Class See Also Send Feedback

The AnswerCallRequest type exposes the following members.

Properties

Name | Description
Interaction |
Reasons |

See Also

AnswerCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest..::.Interaction Property
AnswerCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AnswerCallRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

AnswerCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
AnswerCallRequest..::.Reasons Property
AnswerCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AnswerCallRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

AnswerCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallResponse Class

[image]

Enterprise SDK 8.0 Reference API
AnswerCallResponse Class
Members See Also Send Feedback
InteractionService Service, AnswerCall Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class AnswerCallResponse
Visual Basic (Declaration)
Public Class AnswerCallResponse
Visual C++
public ref class AnswerCallResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.AnswerCallResponse

See Also

AnswerCallResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
AnswerCallResponse Members
AnswerCallResponse Class Constructors Methods Properties See Also Send Feedback

The AnswerCallResponse type exposes the following members.

Constructors

Name | Description
AnswerCallResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

AnswerCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
AnswerCallResponse Constructor
AnswerCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.AnswerCallResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AnswerCallResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnswerCallResponse()

See Also

AnswerCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AnswerCallResponse Methods
AnswerCallResponse Class See Also Send Feedback

The AnswerCallResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnswerCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


AnswerCallResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
AnswerCallResponse Properties
AnswerCallResponse Class See Also Send Feedback

The AnswerCallResponse type exposes the following members.

Properties

Name | Description
result |

See Also

AnswerCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
AnswerCallResponse..::.result Property
AnswerCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.AnswerCallResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

AnswerCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceRequest Class

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest Class
Members See Also Send Feedback
InteractionService Service, CompleteConference Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CompleteConferenceRequest
Visual Basic (Declaration)
Public Class CompleteConferenceRequest
Visual C++
public ref class CompleteConferenceRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceRequest

See Also

CompleteConferenceRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest Members
CompleteConferenceRequest Class Constructors Methods Properties See Also Send Feedback

The CompleteConferenceRequest type exposes the following members.

Constructors

Name | Description
CompleteConferenceRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest Constructor
CompleteConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteConferenceRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteConferenceRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompleteConferenceRequest()

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest Methods
CompleteConferenceRequest Class See Also Send Feedback

The CompleteConferenceRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest Properties
CompleteConferenceRequest Class See Also Send Feedback

The CompleteConferenceRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest..::.Extensions Property
CompleteConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteConferenceRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest..::.Interaction Property
CompleteConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteConferenceRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceRequest..::.Reasons Property
CompleteConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteConferenceRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CompleteConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceResponse Class

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceResponse Class
Members See Also Send Feedback
InteractionService Service, CompleteConference Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CompleteConferenceResponse
Visual Basic (Declaration)
Public Class CompleteConferenceResponse
Visual C++
public ref class CompleteConferenceResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteConferenceResponse

See Also

CompleteConferenceResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteConferenceResponse Members
CompleteConferenceResponse Class Constructors Methods Properties See Also Send Feedback

The CompleteConferenceResponse type exposes the following members.

Constructors

Name | Description
CompleteConferenceResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

CompleteConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceResponse Constructor
CompleteConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteConferenceResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteConferenceResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompleteConferenceResponse()

See Also

CompleteConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteConferenceResponse Methods
CompleteConferenceResponse Class See Also Send Feedback

The CompleteConferenceResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompleteConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteConferenceResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteConferenceResponse Properties
CompleteConferenceResponse Class See Also Send Feedback

The CompleteConferenceResponse type exposes the following members.

Properties

Name | Description
result |

See Also

CompleteConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
CompleteConferenceResponse..::.result Property
CompleteConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteConferenceResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

CompleteConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferRequest Class

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest Class
Members See Also Send Feedback
InteractionService Service, CompleteTransfer Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CompleteTransferRequest
Visual Basic (Declaration)
Public Class CompleteTransferRequest
Visual C++
public ref class CompleteTransferRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferRequest

See Also

CompleteTransferRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest Members
CompleteTransferRequest Class Constructors Methods Properties See Also Send Feedback

The CompleteTransferRequest type exposes the following members.

Constructors

Name | Description
CompleteTransferRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest Constructor
CompleteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteTransferRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteTransferRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompleteTransferRequest()

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest Methods
CompleteTransferRequest Class See Also Send Feedback

The CompleteTransferRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest Properties
CompleteTransferRequest Class See Also Send Feedback

The CompleteTransferRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest..::.Extensions Property
CompleteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteTransferRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest..::.Interaction Property
CompleteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteTransferRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferRequest..::.Reasons Property
CompleteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteTransferRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CompleteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferResponse Class

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferResponse Class
Members See Also Send Feedback
InteractionService Service, CompleteTransfer Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CompleteTransferResponse
Visual Basic (Declaration)
Public Class CompleteTransferResponse
Visual C++
public ref class CompleteTransferResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.CompleteTransferResponse

See Also

CompleteTransferResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteTransferResponse Members
CompleteTransferResponse Class Constructors Methods Properties See Also Send Feedback

The CompleteTransferResponse type exposes the following members.

Constructors

Name | Description
CompleteTransferResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

CompleteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferResponse Constructor
CompleteTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteTransferResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompleteTransferResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompleteTransferResponse()

See Also

CompleteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteTransferResponse Methods
CompleteTransferResponse Class See Also Send Feedback

The CompleteTransferResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompleteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


CompleteTransferResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CompleteTransferResponse Properties
CompleteTransferResponse Class See Also Send Feedback

The CompleteTransferResponse type exposes the following members.

Properties

Name | Description
result |

See Also

CompleteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
CompleteTransferResponse..::.result Property
CompleteTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.CompleteTransferResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

CompleteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceRequest Class

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest Class
Members See Also Send Feedback
InteractionService Service, DeleteFromConference Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class DeleteFromConferenceRequest
Visual Basic (Declaration)
Public Class DeleteFromConferenceRequest
Visual C++
public ref class DeleteFromConferenceRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceRequest

See Also

DeleteFromConferenceRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest Members
DeleteFromConferenceRequest Class Constructors Methods Properties See Also Send Feedback

The DeleteFromConferenceRequest type exposes the following members.

Constructors

Name | Description
DeleteFromConferenceRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Otherdn |
Reasons |

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest Constructor
DeleteFromConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DeleteFromConferenceRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DeleteFromConferenceRequest()

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest Methods
DeleteFromConferenceRequest Class See Also Send Feedback

The DeleteFromConferenceRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest Properties
DeleteFromConferenceRequest Class See Also Send Feedback

The DeleteFromConferenceRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Otherdn |
Reasons |

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest..::.Extensions Property
DeleteFromConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest..::.Interaction Property
DeleteFromConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest..::.Otherdn Property
DeleteFromConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceRequest..::.Reasons Property
DeleteFromConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

DeleteFromConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceResponse Class

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceResponse Class
Members See Also Send Feedback
InteractionService Service, DeleteFromConference Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class DeleteFromConferenceResponse
Visual Basic (Declaration)
Public Class DeleteFromConferenceResponse
Visual C++
public ref class DeleteFromConferenceResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.DeleteFromConferenceResponse

See Also

DeleteFromConferenceResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceResponse Members
DeleteFromConferenceResponse Class Constructors Methods Properties See Also Send Feedback

The DeleteFromConferenceResponse type exposes the following members.

Constructors

Name | Description
DeleteFromConferenceResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

DeleteFromConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceResponse Constructor
DeleteFromConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DeleteFromConferenceResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DeleteFromConferenceResponse()

See Also

DeleteFromConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceResponse Methods
DeleteFromConferenceResponse Class See Also Send Feedback

The DeleteFromConferenceResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteFromConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


DeleteFromConferenceResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceResponse Properties
DeleteFromConferenceResponse Class See Also Send Feedback

The DeleteFromConferenceResponse type exposes the following members.

Properties

Name | Description
result |

See Also

DeleteFromConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
DeleteFromConferenceResponse..::.result Property
DeleteFromConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.DeleteFromConferenceResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

DeleteFromConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallRequest Class

[image]

Enterprise SDK 8.0 Reference API
HoldCallRequest Class
Members See Also Send Feedback
InteractionService Service, HoldCall Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class HoldCallRequest
Visual Basic (Declaration)
Public Class HoldCallRequest
Visual C++
public ref class HoldCallRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallRequest

See Also

HoldCallRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
HoldCallRequest Members
HoldCallRequest Class Constructors Methods Properties See Also Send Feedback

The HoldCallRequest type exposes the following members.

Constructors

Name | Description
HoldCallRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
HoldCallRequest Constructor
HoldCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.HoldCallRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public HoldCallRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HoldCallRequest()

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
HoldCallRequest Methods
HoldCallRequest Class See Also Send Feedback

The HoldCallRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
HoldCallRequest Properties
HoldCallRequest Class See Also Send Feedback

The HoldCallRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
HoldCallRequest..::.Extensions Property
HoldCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.HoldCallRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
HoldCallRequest..::.Interaction Property
HoldCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.HoldCallRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
HoldCallRequest..::.Reasons Property
HoldCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.HoldCallRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

HoldCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallResponse Class

[image]

Enterprise SDK 8.0 Reference API
HoldCallResponse Class
Members See Also Send Feedback
InteractionService Service, HoldCall Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class HoldCallResponse
Visual Basic (Declaration)
Public Class HoldCallResponse
Visual C++
public ref class HoldCallResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.HoldCallResponse

See Also

HoldCallResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
HoldCallResponse Members
HoldCallResponse Class Constructors Methods Properties See Also Send Feedback

The HoldCallResponse type exposes the following members.

Constructors

Name | Description
HoldCallResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

HoldCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
HoldCallResponse Constructor
HoldCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.HoldCallResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public HoldCallResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HoldCallResponse()

See Also

HoldCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
HoldCallResponse Methods
HoldCallResponse Class See Also Send Feedback

The HoldCallResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HoldCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


HoldCallResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
HoldCallResponse Properties
HoldCallResponse Class See Also Send Feedback

The HoldCallResponse type exposes the following members.

Properties

Name | Description
result |

See Also

HoldCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
HoldCallResponse..::.result Property
HoldCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.HoldCallResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

HoldCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceRequest Class

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest Class
Members See Also Send Feedback
InteractionService Service, InitiateConference Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class InitiateConferenceRequest
Visual Basic (Declaration)
Public Class InitiateConferenceRequest
Visual C++
public ref class InitiateConferenceRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceRequest

See Also

InitiateConferenceRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest Members
InitiateConferenceRequest Class Constructors Methods Properties See Also Send Feedback

The InitiateConferenceRequest type exposes the following members.

Constructors

Name | Description
InitiateConferenceRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest Constructor
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateConferenceRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InitiateConferenceRequest()

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest Methods
InitiateConferenceRequest Class See Also Send Feedback

The InitiateConferenceRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest Properties
InitiateConferenceRequest Class See Also Send Feedback

The InitiateConferenceRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest..::.Extensions Property
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest..::.Interaction Property
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest..::.Location Property
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.Location"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest..::.Otherdn Property
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest..::.Reasons Property
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceRequest..::.Userdata Property
InitiateConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

InitiateConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceResponse Class

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceResponse Class
Members See Also Send Feedback
InteractionService Service, InitiateConference Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class InitiateConferenceResponse
Visual Basic (Declaration)
Public Class InitiateConferenceResponse
Visual C++
public ref class InitiateConferenceResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateConferenceResponse

See Also

InitiateConferenceResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateConferenceResponse Members
InitiateConferenceResponse Class Constructors Methods Properties See Also Send Feedback

The InitiateConferenceResponse type exposes the following members.

Constructors

Name | Description
InitiateConferenceResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

InitiateConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceResponse Constructor
InitiateConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateConferenceResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InitiateConferenceResponse()

See Also

InitiateConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateConferenceResponse Methods
InitiateConferenceResponse Class See Also Send Feedback

The InitiateConferenceResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitiateConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateConferenceResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateConferenceResponse Properties
InitiateConferenceResponse Class See Also Send Feedback

The InitiateConferenceResponse type exposes the following members.

Properties

Name | Description
result |

See Also

InitiateConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
InitiateConferenceResponse..::.result Property
InitiateConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateConferenceResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

InitiateConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferRequest Class

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest Class
Members See Also Send Feedback
InteractionService Service, InitiateTransfer Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class InitiateTransferRequest
Visual Basic (Declaration)
Public Class InitiateTransferRequest
Visual C++
public ref class InitiateTransferRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferRequest

See Also

InitiateTransferRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest Members
InitiateTransferRequest Class Constructors Methods Properties See Also Send Feedback

The InitiateTransferRequest type exposes the following members.

Constructors

Name | Description
InitiateTransferRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest Constructor
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateTransferRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InitiateTransferRequest()

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest Methods
InitiateTransferRequest Class See Also Send Feedback

The InitiateTransferRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest Properties
InitiateTransferRequest Class See Also Send Feedback

The InitiateTransferRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest..::.Extensions Property
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest..::.Interaction Property
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest..::.Location Property
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.Location"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest..::.Otherdn Property
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest..::.Reasons Property
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferRequest..::.Userdata Property
InitiateTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

InitiateTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferResponse Class

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferResponse Class
Members See Also Send Feedback
InteractionService Service, InitiateTransfer Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class InitiateTransferResponse
Visual Basic (Declaration)
Public Class InitiateTransferResponse
Visual C++
public ref class InitiateTransferResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.InitiateTransferResponse

See Also

InitiateTransferResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateTransferResponse Members
InitiateTransferResponse Class Constructors Methods Properties See Also Send Feedback

The InitiateTransferResponse type exposes the following members.

Constructors

Name | Description
InitiateTransferResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

InitiateTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferResponse Constructor
InitiateTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InitiateTransferResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InitiateTransferResponse()

See Also

InitiateTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateTransferResponse Methods
InitiateTransferResponse Class See Also Send Feedback

The InitiateTransferResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitiateTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


InitiateTransferResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InitiateTransferResponse Properties
InitiateTransferResponse Class See Also Send Feedback

The InitiateTransferResponse type exposes the following members.

Properties

Name | Description
result |

See Also

InitiateTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
InitiateTransferResponse..::.result Property
InitiateTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.InitiateTransferResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

InitiateTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectRequest Class

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest Class
Members See Also Send Feedback
InteractionService Service, ListenDisconnect Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ListenDisconnectRequest
Visual Basic (Declaration)
Public Class ListenDisconnectRequest
Visual C++
public ref class ListenDisconnectRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectRequest

See Also

ListenDisconnectRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest Members
ListenDisconnectRequest Class Constructors Methods Properties See Also Send Feedback

The ListenDisconnectRequest type exposes the following members.

Constructors

Name | Description
ListenDisconnectRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Otherdn |
Reasons |

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest Constructor
ListenDisconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenDisconnectRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListenDisconnectRequest()

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest Methods
ListenDisconnectRequest Class See Also Send Feedback

The ListenDisconnectRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest Properties
ListenDisconnectRequest Class See Also Send Feedback

The ListenDisconnectRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Otherdn |
Reasons |

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest..::.Extensions Property
ListenDisconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest..::.Interaction Property
ListenDisconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest..::.Otherdn Property
ListenDisconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectRequest..::.Reasons Property
ListenDisconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ListenDisconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectResponse Class

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectResponse Class
Members See Also Send Feedback
InteractionService Service, ListenDisconnect Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ListenDisconnectResponse
Visual Basic (Declaration)
Public Class ListenDisconnectResponse
Visual C++
public ref class ListenDisconnectResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenDisconnectResponse

See Also

ListenDisconnectResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
ListenDisconnectResponse Members
ListenDisconnectResponse Class Constructors Methods Properties See Also Send Feedback

The ListenDisconnectResponse type exposes the following members.

Constructors

Name | Description
ListenDisconnectResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

ListenDisconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectResponse Constructor
ListenDisconnectResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenDisconnectResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListenDisconnectResponse()

See Also

ListenDisconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ListenDisconnectResponse Methods
ListenDisconnectResponse Class See Also Send Feedback

The ListenDisconnectResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListenDisconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenDisconnectResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ListenDisconnectResponse Properties
ListenDisconnectResponse Class See Also Send Feedback

The ListenDisconnectResponse type exposes the following members.

Properties

Name | Description
result |

See Also

ListenDisconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
ListenDisconnectResponse..::.result Property
ListenDisconnectResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenDisconnectResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

ListenDisconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectRequest Class

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest Class
Members See Also Send Feedback
InteractionService Service, ListenReconnect Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ListenReconnectRequest
Visual Basic (Declaration)
Public Class ListenReconnectRequest
Visual C++
public ref class ListenReconnectRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectRequest

See Also

ListenReconnectRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest Members
ListenReconnectRequest Class Constructors Methods Properties See Also Send Feedback

The ListenReconnectRequest type exposes the following members.

Constructors

Name | Description
ListenReconnectRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Otherdn |
Reasons |

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest Constructor
ListenReconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenReconnectRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListenReconnectRequest()

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest Methods
ListenReconnectRequest Class See Also Send Feedback

The ListenReconnectRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest Properties
ListenReconnectRequest Class See Also Send Feedback

The ListenReconnectRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Otherdn |
Reasons |

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest..::.Extensions Property
ListenReconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest..::.Interaction Property
ListenReconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest..::.Otherdn Property
ListenReconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectRequest..::.Reasons Property
ListenReconnectRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ListenReconnectRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectResponse Class

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectResponse Class
Members See Also Send Feedback
InteractionService Service, ListenReconnect Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ListenReconnectResponse
Visual Basic (Declaration)
Public Class ListenReconnectResponse
Visual C++
public ref class ListenReconnectResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.ListenReconnectResponse

See Also

ListenReconnectResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
ListenReconnectResponse Members
ListenReconnectResponse Class Constructors Methods Properties See Also Send Feedback

The ListenReconnectResponse type exposes the following members.

Constructors

Name | Description
ListenReconnectResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

ListenReconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectResponse Constructor
ListenReconnectResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ListenReconnectResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListenReconnectResponse()

See Also

ListenReconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ListenReconnectResponse Methods
ListenReconnectResponse Class See Also Send Feedback

The ListenReconnectResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListenReconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ListenReconnectResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ListenReconnectResponse Properties
ListenReconnectResponse Class See Also Send Feedback

The ListenReconnectResponse type exposes the following members.

Properties

Name | Description
result |

See Also

ListenReconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
ListenReconnectResponse..::.result Property
ListenReconnectResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ListenReconnectResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

ListenReconnectResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallRequest Class

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest Class
Members See Also Send Feedback
InteractionService Service, MakeCall Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class MakeCallRequest
Visual Basic (Declaration)
Public Class MakeCallRequest
Visual C++
public ref class MakeCallRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallRequest

See Also

MakeCallRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
MakeCallRequest Members
MakeCallRequest Class Constructors Methods Properties See Also Send Feedback

The MakeCallRequest type exposes the following members.

Constructors

Name | Description
MakeCallRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Agent |
Extensions |
Location |
Makecalltype |
Otherdn |
Reasons |
Userdata |

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest Constructor
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MakeCallRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MakeCallRequest()

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MakeCallRequest Methods
MakeCallRequest Class See Also Send Feedback

The MakeCallRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
MakeCallRequest Properties
MakeCallRequest Class See Also Send Feedback

The MakeCallRequest type exposes the following members.

Properties

Name | Description
Agent |
Extensions |
Location |
Makecalltype |
Otherdn |
Reasons |
Userdata |

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Agent Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Agent"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public AgentDTO Agent { get; set; }
Visual Basic (Declaration)
Public Property Agent As AgentDTO
Visual C++
public:
property AgentDTO^ Agent {
    AgentDTO^ get ();
    void set (AgentDTO^ value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Extensions Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Location Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Location"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Makecalltype Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Makecalltype Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Makecalltype"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MakeCallType Makecalltype { get; set; }
Visual Basic (Declaration)
Public Property Makecalltype As MakeCallType
Visual C++
public:
property MakeCallType Makecalltype {
    MakeCallType get ();
    void set (MakeCallType value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Otherdn Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Reasons Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallRequest..::.Userdata Property
MakeCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

MakeCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallResponse Class

[image]

Enterprise SDK 8.0 Reference API
MakeCallResponse Class
Members See Also Send Feedback
InteractionService Service, MakeCall Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class MakeCallResponse
Visual Basic (Declaration)
Public Class MakeCallResponse
Visual C++
public ref class MakeCallResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.MakeCallResponse

See Also

MakeCallResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
MakeCallResponse Members
MakeCallResponse Class Constructors Methods Properties See Also Send Feedback

The MakeCallResponse type exposes the following members.

Constructors

Name | Description
MakeCallResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

MakeCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
MakeCallResponse Constructor
MakeCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MakeCallResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MakeCallResponse()

See Also

MakeCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MakeCallResponse Methods
MakeCallResponse Class See Also Send Feedback

The MakeCallResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MakeCallResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
MakeCallResponse Properties
MakeCallResponse Class See Also Send Feedback

The MakeCallResponse type exposes the following members.

Properties

Name | Description
result |

See Also

MakeCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
MakeCallResponse..::.result Property
MakeCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MakeCallResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

MakeCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferRequest Class

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest Class
Members See Also Send Feedback
InteractionService Service, MuteTransfer Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class MuteTransferRequest
Visual Basic (Declaration)
Public Class MuteTransferRequest
Visual C++
public ref class MuteTransferRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferRequest

See Also

MuteTransferRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest Members
MuteTransferRequest Class Constructors Methods Properties See Also Send Feedback

The MuteTransferRequest type exposes the following members.

Constructors

Name | Description
MuteTransferRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest Constructor
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MuteTransferRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MuteTransferRequest()

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest Methods
MuteTransferRequest Class See Also Send Feedback

The MuteTransferRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest Properties
MuteTransferRequest Class See Also Send Feedback

The MuteTransferRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest..::.Extensions Property
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest..::.Interaction Property
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest..::.Location Property
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.Location"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest..::.Otherdn Property
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest..::.Reasons Property
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferRequest..::.Userdata Property
MuteTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

MuteTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferResponse Class

[image]

Enterprise SDK 8.0 Reference API
MuteTransferResponse Class
Members See Also Send Feedback
InteractionService Service, MuteTransfer Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class MuteTransferResponse
Visual Basic (Declaration)
Public Class MuteTransferResponse
Visual C++
public ref class MuteTransferResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.MuteTransferResponse

See Also

MuteTransferResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
MuteTransferResponse Members
MuteTransferResponse Class Constructors Methods Properties See Also Send Feedback

The MuteTransferResponse type exposes the following members.

Constructors

Name | Description
MuteTransferResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

MuteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
MuteTransferResponse Constructor
MuteTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MuteTransferResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MuteTransferResponse()

See Also

MuteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MuteTransferResponse Methods
MuteTransferResponse Class See Also Send Feedback

The MuteTransferResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MuteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


MuteTransferResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
MuteTransferResponse Properties
MuteTransferResponse Class See Also Send Feedback

The MuteTransferResponse type exposes the following members.

Properties

Name | Description
result |

See Also

MuteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
MuteTransferResponse..::.result Property
MuteTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.MuteTransferResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

MuteTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallRequest Class

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest Class
Members See Also Send Feedback
InteractionService Service, ReleaseCall Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ReleaseCallRequest
Visual Basic (Declaration)
Public Class ReleaseCallRequest
Visual C++
public ref class ReleaseCallRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallRequest

See Also

ReleaseCallRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest Members
ReleaseCallRequest Class Constructors Methods Properties See Also Send Feedback

The ReleaseCallRequest type exposes the following members.

Constructors

Name | Description
ReleaseCallRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest Constructor
ReleaseCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.ReleaseCallRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReleaseCallRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReleaseCallRequest()

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest Methods
ReleaseCallRequest Class See Also Send Feedback

The ReleaseCallRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest Properties
ReleaseCallRequest Class See Also Send Feedback

The ReleaseCallRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest..::.Extensions Property
ReleaseCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ReleaseCallRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest..::.Interaction Property
ReleaseCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ReleaseCallRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallRequest..::.Reasons Property
ReleaseCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ReleaseCallRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

ReleaseCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallResponse Class

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallResponse Class
Members See Also Send Feedback
InteractionService Service, ReleaseCall Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ReleaseCallResponse
Visual Basic (Declaration)
Public Class ReleaseCallResponse
Visual C++
public ref class ReleaseCallResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.ReleaseCallResponse

See Also

ReleaseCallResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
ReleaseCallResponse Members
ReleaseCallResponse Class Constructors Methods Properties See Also Send Feedback

The ReleaseCallResponse type exposes the following members.

Constructors

Name | Description
ReleaseCallResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

ReleaseCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallResponse Constructor
ReleaseCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.ReleaseCallResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReleaseCallResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReleaseCallResponse()

See Also

ReleaseCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ReleaseCallResponse Methods
ReleaseCallResponse Class See Also Send Feedback

The ReleaseCallResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReleaseCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


ReleaseCallResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ReleaseCallResponse Properties
ReleaseCallResponse Class See Also Send Feedback

The ReleaseCallResponse type exposes the following members.

Properties

Name | Description
result |

See Also

ReleaseCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
ReleaseCallResponse..::.result Property
ReleaseCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.ReleaseCallResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

ReleaseCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallRequest Class

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest Class
Members See Also Send Feedback
InteractionService Service, RetrieveCall Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class RetrieveCallRequest
Visual Basic (Declaration)
Public Class RetrieveCallRequest
Visual C++
public ref class RetrieveCallRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallRequest

See Also

RetrieveCallRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest Members
RetrieveCallRequest Class Constructors Methods Properties See Also Send Feedback

The RetrieveCallRequest type exposes the following members.

Constructors

Name | Description
RetrieveCallRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest Constructor
RetrieveCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.RetrieveCallRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public RetrieveCallRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RetrieveCallRequest()

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest Methods
RetrieveCallRequest Class See Also Send Feedback

The RetrieveCallRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest Properties
RetrieveCallRequest Class See Also Send Feedback

The RetrieveCallRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest..::.Extensions Property
RetrieveCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.RetrieveCallRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest..::.Interaction Property
RetrieveCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.RetrieveCallRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallRequest..::.Reasons Property
RetrieveCallRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.RetrieveCallRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

RetrieveCallRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallResponse Class

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallResponse Class
Members See Also Send Feedback
InteractionService Service, RetrieveCall Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class RetrieveCallResponse
Visual Basic (Declaration)
Public Class RetrieveCallResponse
Visual C++
public ref class RetrieveCallResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.RetrieveCallResponse

See Also

RetrieveCallResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
RetrieveCallResponse Members
RetrieveCallResponse Class Constructors Methods Properties See Also Send Feedback

The RetrieveCallResponse type exposes the following members.

Constructors

Name | Description
RetrieveCallResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

RetrieveCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallResponse Constructor
RetrieveCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.RetrieveCallResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public RetrieveCallResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RetrieveCallResponse()

See Also

RetrieveCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
RetrieveCallResponse Methods
RetrieveCallResponse Class See Also Send Feedback

The RetrieveCallResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RetrieveCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


RetrieveCallResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
RetrieveCallResponse Properties
RetrieveCallResponse Class See Also Send Feedback

The RetrieveCallResponse type exposes the following members.

Properties

Name | Description
result |

See Also

RetrieveCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
RetrieveCallResponse..::.result Property
RetrieveCallResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.RetrieveCallResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

RetrieveCallResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfRequest Class

[image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest Class
Members See Also Send Feedback
InteractionService Service, SendDtmf Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SendDtmfRequest
Visual Basic (Declaration)
Public Class SendDtmfRequest
Visual C++
public ref class SendDtmfRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfRequest

See Also

SendDtmfRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest Members
SendDtmfRequest Class Constructors Methods Properties See Also Send Feedback

The SendDtmfRequest type exposes the following members.

Constructors

Name | Description
SendDtmfRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dtmfdigits |
Extensions |
Interaction |
Reasons |

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest Constructor
SendDtmfRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SendDtmfRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SendDtmfRequest()

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest Methods
SendDtmfRequest Class See Also Send Feedback

The SendDtmfRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest Properties
SendDtmfRequest Class See Also Send Feedback

The SendDtmfRequest type exposes the following members.

Properties

Name | Description
Dtmfdigits |
Extensions |
Interaction |
Reasons |

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Dtmfdigits Property

[image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest..::.Dtmfdigits Property
SendDtmfRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfRequest.Dtmfdigits"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Dtmfdigits { get; set; }
Visual Basic (Declaration)
Public Property Dtmfdigits As String
Visual C++
public:
property String^ Dtmfdigits {
    String^ get ();
    void set (String^ value);
}

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest..::.Extensions Property
SendDtmfRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest..::.Interaction Property
SendDtmfRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SendDtmfRequest..::.Reasons Property
SendDtmfRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SendDtmfRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfResponse Class

[image]

Enterprise SDK 8.0 Reference API
SendDtmfResponse Class
Members See Also Send Feedback
InteractionService Service, SendDtmf Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SendDtmfResponse
Visual Basic (Declaration)
Public Class SendDtmfResponse
Visual C++
public ref class SendDtmfResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SendDtmfResponse

See Also

SendDtmfResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SendDtmfResponse Members
SendDtmfResponse Class Constructors Methods Properties See Also Send Feedback

The SendDtmfResponse type exposes the following members.

Constructors

Name | Description
SendDtmfResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SendDtmfResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SendDtmfResponse Constructor
SendDtmfResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SendDtmfResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SendDtmfResponse()

See Also

SendDtmfResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SendDtmfResponse Methods
SendDtmfResponse Class See Also Send Feedback

The SendDtmfResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDtmfResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SendDtmfResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SendDtmfResponse Properties
SendDtmfResponse Class See Also Send Feedback

The SendDtmfResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SendDtmfResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SendDtmfResponse..::.result Property
SendDtmfResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SendDtmfResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SendDtmfResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationRequest Class

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest Class
Members See Also Send Feedback
InteractionService Service, SetCallQualification Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetCallQualificationRequest
Visual Basic (Declaration)
Public Class SetCallQualificationRequest
Visual C++
public ref class SetCallQualificationRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationRequest

See Also

SetCallQualificationRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest Members
SetCallQualificationRequest Class Constructors Methods Properties See Also Send Feedback

The SetCallQualificationRequest type exposes the following members.

Constructors

Name | Description
SetCallQualificationRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Interaction |
Userdata |

See Also

SetCallQualificationRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest Constructor
SetCallQualificationRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SetCallQualificationRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetCallQualificationRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetCallQualificationRequest()

See Also

SetCallQualificationRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest Methods
SetCallQualificationRequest Class See Also Send Feedback

The SetCallQualificationRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetCallQualificationRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest Properties
SetCallQualificationRequest Class See Also Send Feedback

The SetCallQualificationRequest type exposes the following members.

Properties

Name | Description
Interaction |
Userdata |

See Also

SetCallQualificationRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest..::.Interaction Property
SetCallQualificationRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetCallQualificationRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SetCallQualificationRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationRequest..::.Userdata Property
SetCallQualificationRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetCallQualificationRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetCallQualificationRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationResponse Class

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationResponse Class
Members See Also Send Feedback
InteractionService Service, SetCallQualification Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetCallQualificationResponse
Visual Basic (Declaration)
Public Class SetCallQualificationResponse
Visual C++
public ref class SetCallQualificationResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetCallQualificationResponse

See Also

SetCallQualificationResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetCallQualificationResponse Members
SetCallQualificationResponse Class Constructors Methods Properties See Also Send Feedback

The SetCallQualificationResponse type exposes the following members.

Constructors

Name | Description
SetCallQualificationResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SetCallQualificationResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationResponse Constructor
SetCallQualificationResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SetCallQualificationResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetCallQualificationResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetCallQualificationResponse()

See Also

SetCallQualificationResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetCallQualificationResponse Methods
SetCallQualificationResponse Class See Also Send Feedback

The SetCallQualificationResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetCallQualificationResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetCallQualificationResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetCallQualificationResponse Properties
SetCallQualificationResponse Class See Also Send Feedback

The SetCallQualificationResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SetCallQualificationResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SetCallQualificationResponse..::.result Property
SetCallQualificationResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetCallQualificationResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SetCallQualificationResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffRequest Class

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest Class
Members See Also Send Feedback
InteractionService Service, SetMuteOff Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetMuteOffRequest
Visual Basic (Declaration)
Public Class SetMuteOffRequest
Visual C++
public ref class SetMuteOffRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffRequest

See Also

SetMuteOffRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest Members
SetMuteOffRequest Class Constructors Methods Properties See Also Send Feedback

The SetMuteOffRequest type exposes the following members.

Constructors

Name | Description
SetMuteOffRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest Constructor
SetMuteOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOffRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOffRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetMuteOffRequest()

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest Methods
SetMuteOffRequest Class See Also Send Feedback

The SetMuteOffRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest Properties
SetMuteOffRequest Class See Also Send Feedback

The SetMuteOffRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest..::.Extensions Property
SetMuteOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOffRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest..::.Interaction Property
SetMuteOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOffRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffRequest..::.Reasons Property
SetMuteOffRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOffRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetMuteOffRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffResponse Class

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffResponse Class
Members See Also Send Feedback
InteractionService Service, SetMuteOff Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetMuteOffResponse
Visual Basic (Declaration)
Public Class SetMuteOffResponse
Visual C++
public ref class SetMuteOffResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOffResponse

See Also

SetMuteOffResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOffResponse Members
SetMuteOffResponse Class Constructors Methods Properties See Also Send Feedback

The SetMuteOffResponse type exposes the following members.

Constructors

Name | Description
SetMuteOffResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SetMuteOffResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffResponse Constructor
SetMuteOffResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOffResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOffResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetMuteOffResponse()

See Also

SetMuteOffResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOffResponse Methods
SetMuteOffResponse Class See Also Send Feedback

The SetMuteOffResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetMuteOffResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOffResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOffResponse Properties
SetMuteOffResponse Class See Also Send Feedback

The SetMuteOffResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SetMuteOffResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOffResponse..::.result Property
SetMuteOffResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOffResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SetMuteOffResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnRequest Class

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest Class
Members See Also Send Feedback
InteractionService Service, SetMuteOn Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetMuteOnRequest
Visual Basic (Declaration)
Public Class SetMuteOnRequest
Visual C++
public ref class SetMuteOnRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnRequest

See Also

SetMuteOnRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest Members
SetMuteOnRequest Class Constructors Methods Properties See Also Send Feedback

The SetMuteOnRequest type exposes the following members.

Constructors

Name | Description
SetMuteOnRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest Constructor
SetMuteOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOnRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOnRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetMuteOnRequest()

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest Methods
SetMuteOnRequest Class See Also Send Feedback

The SetMuteOnRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest Properties
SetMuteOnRequest Class See Also Send Feedback

The SetMuteOnRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Reasons |

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest..::.Extensions Property
SetMuteOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOnRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest..::.Interaction Property
SetMuteOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOnRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnRequest..::.Reasons Property
SetMuteOnRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOnRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SetMuteOnRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnResponse Class

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnResponse Class
Members See Also Send Feedback
InteractionService Service, SetMuteOn Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SetMuteOnResponse
Visual Basic (Declaration)
Public Class SetMuteOnResponse
Visual C++
public ref class SetMuteOnResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SetMuteOnResponse

See Also

SetMuteOnResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOnResponse Members
SetMuteOnResponse Class Constructors Methods Properties See Also Send Feedback

The SetMuteOnResponse type exposes the following members.

Constructors

Name | Description
SetMuteOnResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SetMuteOnResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnResponse Constructor
SetMuteOnResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOnResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SetMuteOnResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetMuteOnResponse()

See Also

SetMuteOnResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOnResponse Methods
SetMuteOnResponse Class See Also Send Feedback

The SetMuteOnResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetMuteOnResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SetMuteOnResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SetMuteOnResponse Properties
SetMuteOnResponse Class See Also Send Feedback

The SetMuteOnResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SetMuteOnResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SetMuteOnResponse..::.result Property
SetMuteOnResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SetMuteOnResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SetMuteOnResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceRequest Class

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest Class
Members See Also Send Feedback
InteractionService Service, SingleStepConference Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SingleStepConferenceRequest
Visual Basic (Declaration)
Public Class SingleStepConferenceRequest
Visual C++
public ref class SingleStepConferenceRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceRequest

See Also

SingleStepConferenceRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest Members
SingleStepConferenceRequest Class Constructors Methods Properties See Also Send Feedback

The SingleStepConferenceRequest type exposes the following members.

Constructors

Name | Description
SingleStepConferenceRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest Constructor
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepConferenceRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleStepConferenceRequest()

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest Methods
SingleStepConferenceRequest Class See Also Send Feedback

The SingleStepConferenceRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest Properties
SingleStepConferenceRequest Class See Also Send Feedback

The SingleStepConferenceRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest..::.Extensions Property
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest..::.Interaction Property
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest..::.Location Property
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.Location"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest..::.Otherdn Property
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest..::.Reasons Property
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceRequest..::.Userdata Property
SingleStepConferenceRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SingleStepConferenceRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceResponse Class

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceResponse Class
Members See Also Send Feedback
InteractionService Service, SingleStepConference Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SingleStepConferenceResponse
Visual Basic (Declaration)
Public Class SingleStepConferenceResponse
Visual C++
public ref class SingleStepConferenceResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepConferenceResponse

See Also

SingleStepConferenceResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceResponse Members
SingleStepConferenceResponse Class Constructors Methods Properties See Also Send Feedback

The SingleStepConferenceResponse type exposes the following members.

Constructors

Name | Description
SingleStepConferenceResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SingleStepConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceResponse Constructor
SingleStepConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepConferenceResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleStepConferenceResponse()

See Also

SingleStepConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceResponse Methods
SingleStepConferenceResponse Class See Also Send Feedback

The SingleStepConferenceResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleStepConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepConferenceResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceResponse Properties
SingleStepConferenceResponse Class See Also Send Feedback

The SingleStepConferenceResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SingleStepConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepConferenceResponse..::.result Property
SingleStepConferenceResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepConferenceResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SingleStepConferenceResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferRequest Class

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest Class
Members See Also Send Feedback
InteractionService Service, SingleStepTransfer Request.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SingleStepTransferRequest
Visual Basic (Declaration)
Public Class SingleStepTransferRequest
Visual C++
public ref class SingleStepTransferRequest

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferRequest

See Also

SingleStepTransferRequest Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest Members
SingleStepTransferRequest Class Constructors Methods Properties See Also Send Feedback

The SingleStepTransferRequest type exposes the following members.

Constructors

Name | Description
SingleStepTransferRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferRequest Constructor

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest Constructor
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepTransferRequest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleStepTransferRequest()

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest Methods
SingleStepTransferRequest Class See Also Send Feedback

The SingleStepTransferRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest Properties
SingleStepTransferRequest Class See Also Send Feedback

The SingleStepTransferRequest type exposes the following members.

Properties

Name | Description
Extensions |
Interaction |
Location |
Otherdn |
Reasons |
Userdata |

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest..::.Extensions Property
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.Extensions"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Extensions {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest..::.Interaction Property
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.Interaction"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO Interaction { get; set; }
Visual Basic (Declaration)
Public Property Interaction As InteractionDTO
Visual C++
public:
property InteractionDTO^ Interaction {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest..::.Location Property
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.Location"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Otherdn Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest..::.Otherdn Property
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.Otherdn"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Otherdn { get; set; }
Visual Basic (Declaration)
Public Property Otherdn As String
Visual C++
public:
property String^ Otherdn {
    String^ get ();
    void set (String^ value);
}

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest..::.Reasons Property
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.Reasons"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Reasons { get; set; }
Visual Basic (Declaration)
Public Property Reasons As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Reasons {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Userdata Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferRequest..::.Userdata Property
SingleStepTransferRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferRequest.Userdata"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Userdata { get; set; }
Visual Basic (Declaration)
Public Property Userdata As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Userdata {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

SingleStepTransferRequest Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferResponse Class

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferResponse Class
Members See Also Send Feedback
InteractionService Service, SingleStepTransfer Response.

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SingleStepTransferResponse
Visual Basic (Declaration)
Public Class SingleStepTransferResponse
Visual C++
public ref class SingleStepTransferResponse

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Communication.InteractionService.Type..::.SingleStepTransferResponse

See Also

SingleStepTransferResponse Members
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepTransferResponse Members
SingleStepTransferResponse Class Constructors Methods Properties See Also Send Feedback

The SingleStepTransferResponse type exposes the following members.

Constructors

Name | Description
SingleStepTransferResponse |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
result |

See Also

SingleStepTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferResponse Constructor

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferResponse Constructor
SingleStepTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferResponse.#ctor"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SingleStepTransferResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleStepTransferResponse()

See Also

SingleStepTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferResponse Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepTransferResponse Methods
SingleStepTransferResponse Class See Also Send Feedback

The SingleStepTransferResponse type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleStepTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


SingleStepTransferResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SingleStepTransferResponse Properties
SingleStepTransferResponse Class See Also Send Feedback

The SingleStepTransferResponse type exposes the following members.

Properties

Name | Description
result |

See Also

SingleStepTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


result Property

[image]

Enterprise SDK 8.0 Reference API
SingleStepTransferResponse..::.result Property
SingleStepTransferResponse Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Communication.InteractionService.Type.SingleStepTransferResponse.result"]

Namespace: Genesyslab.Enterprise.Communication.InteractionService.Type
Assembly: Genesyslab.Enterprise.Communication (in Genesyslab.Enterprise.Communication.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionDTO result { get; set; }
Visual Basic (Declaration)
Public Property result As InteractionDTO
Visual C++
public:
property InteractionDTO^ result {
    InteractionDTO^ get ();
    void set (InteractionDTO^ value);
}

See Also

SingleStepTransferResponse Class
Genesyslab.Enterprise.Communication.InteractionService.Type Namespace


Genesyslab.Enterprise.ConfigurationObjectModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel Namespace
Send Feedback

Classes

Class | Description
CachingConfServicePolicy | The default policy for a configuration service which has caching enabled.
CfgBase | The parent class for all configuration object categories (structures and classes)
CfgDelta | This is a base class for all Configuration Server delta objects
CfgObject | This is a base class for all standalone Configuration Server objects.
CfgStructure | The base class for all Configuration Server structures.
ConfEvent | This class represents an event fired by Configuration Server
ConfEventObjectCreated | Represents the Configuration Server's object created event.
GlobalConfService |
MiscConstants |
NotificationFilter | This class is used to retrieve events from the Configuration Server. Please, refer to Message Broker application block for more details
NotificationQuery | This class is used to subscribe to notifications from the Configuration Server.
PermissionDescriptor | This class represents access permissions of an associated Configuration Server object.
PropertyAccessHelper |
Subscription | Summary description for Subscription.
WellKnownDbids | This enumeration summarizes standard DBID in Configuration Server
XmlAccessConstants |

Interfaces

Interface | Description
ICfgBase | The base interface for all configuration server objects.
ICfgDelta |
ICfgObject | An interface that should be supported by all configuration classes (objects that can be independently retrieved from Config Server).
ICfgStructure | An interface that should be supported by all configuration structures (configuration objects that are dependent on other configuration objects and can only be retrieved as part of some other object (class)
ICollectionsBroker |
IConfServicePolicy | The interface to be implemented when defining a policy for the configuration service.

Enumerations

Enumeration | Description
ConfEventType | Describes the configuration event types that can be received from Configuration Server.


CachingConfServicePolicy Class

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy Class
Members See Also Send Feedback
The default policy for a configuration service which has caching enabled.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class CachingConfServicePolicy : IConfServicePolicy
Visual Basic (Declaration)
Public NotInheritable Class CachingConfServicePolicy _
    Implements IConfServicePolicy
Visual C++
public ref class CachingConfServicePolicy sealed : IConfServicePolicy

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.CachingConfServicePolicy

See Also

CachingConfServicePolicy Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CachingConfServicePolicy Members

[image] [image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy Members
CachingConfServicePolicy Class Constructors Methods Properties See Also Send Feedback

The CachingConfServicePolicy type exposes the following members.

Constructors

Name | Description
CachingConfServicePolicy |

Methods

Name | Description
AttemptLinkResolutionThroughCache | Determines whether link resolution should be attempted through the cache before querying the configuration server (link resolution refers to the automatic retrieval of configuration objects when certain properties are accessed).
CacheOnRetrieve | Determines whether the specified object should be cached upon being retrieved from the configuration server.
CacheOnSave | Determines whether the specified object should be cached upon being saved in the configuration server.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverwriteCachedVersionOnRetrieve | Determines whether an existing cached object should be overwritten if a newer copy is retrieved from configuration server.
QueryCacheOnRetrieve | Determines whether the cache should be queried before a retrieve operation is performed.
QueryCacheOnRetrieveMultiple | Determines whether the cache should be queried before a retrieve multiple operation is performed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ValidateBeforeSave | Determines whether the properties of an object should be validated for correctness before a save operation is attempted. True by default.

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CachingConfServicePolicy Constructor

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy Constructor
CachingConfServicePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CachingConfServicePolicy.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CachingConfServicePolicy()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CachingConfServicePolicy()

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CachingConfServicePolicy Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy Methods
CachingConfServicePolicy Class See Also Send Feedback

The CachingConfServicePolicy type exposes the following members.

Methods

Name | Description
AttemptLinkResolutionThroughCache | Determines whether link resolution should be attempted through the cache before querying the configuration server (link resolution refers to the automatic retrieval of configuration objects when certain properties are accessed).
CacheOnRetrieve | Determines whether the specified object should be cached upon being retrieved from the configuration server.
CacheOnSave | Determines whether the specified object should be cached upon being saved in the configuration server.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverwriteCachedVersionOnRetrieve | Determines whether an existing cached object should be overwritten if a newer copy is retrieved from configuration server.
QueryCacheOnRetrieve | Determines whether the cache should be queried before a retrieve operation is performed.
QueryCacheOnRetrieveMultiple | Determines whether the cache should be queried before a retrieve multiple operation is performed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


AttemptLinkResolutionThroughCache Method

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.AttemptLinkResolutionThroughCache Method
CachingConfServicePolicy Class See Also Send Feedback
Determines whether link resolution should be attempted through the cache before querying the configuration server (link resolution refers to the automatic retrieval of configuration objects when certain properties are accessed).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool AttemptLinkResolutionThroughCache(
    CfgObjectType objectType
)
Visual Basic (Declaration)
Public Function AttemptLinkResolutionThroughCache ( _
    objectType As CfgObjectType _
) As Boolean
Visual C++
public:
virtual bool AttemptLinkResolutionThroughCache(
    CfgObjectType objectType
) sealed

Parameters

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
This parameter is ignored

Return Value

true for all object types

Implements

IConfServicePolicy..::.AttemptLinkResolutionThroughCache(CfgObjectType)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CacheOnRetrieve Method

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.CacheOnRetrieve Method
CachingConfServicePolicy Class See Also Send Feedback
Determines whether the specified object should be cached upon being retrieved from the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool CacheOnRetrieve(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function CacheOnRetrieve ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool CacheOnRetrieve(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
This paramter is ignored

Return Value

true for all objects

Implements

IConfServicePolicy..::.CacheOnRetrieve(ICfgObject)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CacheOnSave Method

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.CacheOnSave Method
CachingConfServicePolicy Class See Also Send Feedback
Determines whether the specified object should be cached upon being saved in the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool CacheOnSave(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function CacheOnSave ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool CacheOnSave(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
This paramter is ignored

Return Value

true for all objects

Implements

IConfServicePolicy..::.CacheOnSave(ICfgObject)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


OverwriteCachedVersionOnRetrieve Method

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.OverwriteCachedVersionOnRetrieve Method
CachingConfServicePolicy Class See Also Send Feedback
Determines whether an existing cached object should be overwritten if a newer copy is retrieved from configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool OverwriteCachedVersionOnRetrieve(
    ICfgObject newObj
)
Visual Basic (Declaration)
Public Function OverwriteCachedVersionOnRetrieve ( _
    newObj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool OverwriteCachedVersionOnRetrieve(
    ICfgObject^ newObj
) sealed

Parameters

newObj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
This parameter is ignored

Return Value

false for all objects

Implements

IConfServicePolicy..::.OverwriteCachedVersionOnRetrieve(ICfgObject)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


QueryCacheOnRetrieve Method

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.QueryCacheOnRetrieve Method
CachingConfServicePolicy Class See Also Send Feedback
Determines whether the cache should be queried before a retrieve operation is performed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool QueryCacheOnRetrieve(
    ICfgQuery query
)
Visual Basic (Declaration)
Public Function QueryCacheOnRetrieve ( _
    query As ICfgQuery _
) As Boolean
Visual C++
public:
virtual bool QueryCacheOnRetrieve(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
This parameter is ignored

Return Value

false for all queries

Implements

IConfServicePolicy..::.QueryCacheOnRetrieve(ICfgQuery)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


QueryCacheOnRetrieveMultiple Method

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.QueryCacheOnRetrieveMultiple Method
CachingConfServicePolicy Class See Also Send Feedback
Determines whether the cache should be queried before a retrieve multiple operation is performed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool QueryCacheOnRetrieveMultiple(
    ICfgQuery query
)
Visual Basic (Declaration)
Public Function QueryCacheOnRetrieveMultiple ( _
    query As ICfgQuery _
) As Boolean
Visual C++
public:
virtual bool QueryCacheOnRetrieveMultiple(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
This parameter is ignored

Return Value

false for all queries

Implements

IConfServicePolicy..::.QueryCacheOnRetrieveMultiple(ICfgQuery)

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CachingConfServicePolicy Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy Properties
CachingConfServicePolicy Class See Also Send Feedback

The CachingConfServicePolicy type exposes the following members.

Properties

Name | Description
ValidateBeforeSave | Determines whether the properties of an object should be validated for correctness before a save operation is attempted. True by default.

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ValidateBeforeSave Property

[image]

Enterprise SDK 8.0 Reference API
CachingConfServicePolicy..::.ValidateBeforeSave Property
CachingConfServicePolicy Class See Also Send Feedback
Determines whether the properties of an object should be validated for correctness before a save operation is attempted. True by default.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool ValidateBeforeSave { get; set; }
Visual Basic (Declaration)
Public Property ValidateBeforeSave As Boolean
Visual C++
public:
virtual property bool ValidateBeforeSave {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IConfServicePolicy..::.ValidateBeforeSave

See Also

CachingConfServicePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgBase Class

[image]

Enterprise SDK 8.0 Reference API
CfgBase Class
Members See Also Send Feedback
The parent class for all configuration object categories (structures and classes)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgBase : AbstractLogEnabled,
    ICfgBase
Visual Basic (Declaration)
Public MustInherit Class CfgBase _
    Inherits AbstractLogEnabled _
    Implements ICfgBase
Visual C++
public ref class CfgBase abstract : public AbstractLogEnabled,
    ICfgBase

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure

See Also

CfgBase Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgBase Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBase Members
CfgBase Class Methods Properties See Also Send Feedback

The CfgBase type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Overrides Object..::.ToString()()().)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called.
Logger | (Inherited from AbstractLogEnabled.)
Parent | Used to retrieve the parent of the current object

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgBase Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBase Methods
CfgBase Class See Also Send Feedback

The CfgBase type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Overrides Object..::.ToString()()().)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
CfgBase..::.ToString Method
CfgBase Class See Also Send Feedback
Returns a string representation of the object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase.ToString"]

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ToXml Method

[image]

Enterprise SDK 8.0 Reference API
CfgBase..::.ToXml Method
CfgBase Class See Also Send Feedback
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public virtual XElement ToXml()
Visual Basic (Declaration)
Public Overridable Function ToXml As XElement
Visual C++
public:
virtual XElement^ ToXml()

Return Value

an XML "snapshot" of the object

Implements

ICfgBase..::.ToXml()()()

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgBase Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBase Properties
CfgBase Class See Also Send Feedback

The CfgBase type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called.
Logger | (Inherited from AbstractLogEnabled.)
Parent | Used to retrieve the parent of the current object

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
CfgBase..::.Endpoint Property
CfgBase Class See Also Send Feedback
Provides the URI of the Configuration Server to which this object belongs.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Endpoint Endpoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property Endpoint As Endpoint
Visual C++
public:
virtual property Endpoint^ Endpoint {
    Endpoint^ get () sealed;
}

Implements

ICfgBase..::.Endpoint

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
CfgBase..::.Item Property
CfgBase Class See Also Send Feedback
This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object this[
    string propertyName
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    propertyName As String _
) As Object
Visual C++
public:
virtual property Object^ default[String^ propertyName] {
    Object^ get (String^ propertyName) sealed;
    void set (String^ propertyName, Object^ value) sealed;
}

Parameters

propertyName
Type: System..::.String
The name of the property

Implements

ICfgBase..::.Item[([(String])])

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
CfgBase..::.Parent Property
CfgBase Class See Also Send Feedback
Used to retrieve the parent of the current object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgBase Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As CfgBase
Visual C++
public:
property CfgBase^ Parent {
    CfgBase^ get ();
}

See Also

CfgBase Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgDelta Class

[image]

Enterprise SDK 8.0 Reference API
CfgDelta Class
Members See Also Send Feedback
This is a base class for all Configuration Server delta objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDelta : CfgObject, ICfgDelta,
    ICfgBase
Visual Basic (Declaration)
Public Class CfgDelta _
    Inherits CfgObject _
    Implements ICfgDelta, ICfgBase
Visual C++
public ref class CfgDelta : public CfgObject,
    ICfgDelta, ICfgBase

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAccessGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaActionCode
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAgentGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAgentInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAgentLogin
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAlarmCondition
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaApplication
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAppPrototype
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaCallingList
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaCampaign
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaCampaignGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaDN
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaDNGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaEnumerator
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaEnumeratorValue
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaField
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaFilter
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaFolder
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaFormat
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGVPCustomer
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGVPIVRProfile
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGVPReseller
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaHost
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaIVR
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaIVRPort
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaObjectiveTable
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPerson
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPhysicalSwitch
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPlace
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPlaceGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaRole
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaScheduledTask
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaScript
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaService
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaSkill
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaStatDay
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaStatTable
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaSwitch
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTableAccess
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTenant
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTimeZone
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTransaction
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTreatment
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaVoicePrompt

See Also

CfgDelta Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgDelta Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelta Members
CfgDelta Class Methods Properties See Also Send Feedback

The CfgDelta type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Overrides CfgBase..::.ToXml()()().)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDelta Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgDelta Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelta Methods
CfgDelta Class See Also Send Feedback

The CfgDelta type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Overrides CfgBase..::.ToXml()()().)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDelta Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelta..::.SetAccountPermissions Method
CfgDelta Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDelta Class
CfgDelta Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ToXml Method

[image]

Enterprise SDK 8.0 Reference API
CfgDelta..::.ToXml Method
CfgDelta Class See Also Send Feedback
This method returns a copy of the object's internally stored XML representation.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override XElement ToXml()
Visual Basic (Declaration)
Public Overrides Function ToXml As XElement
Visual C++
public:
virtual XElement^ ToXml() override

Return Value

an XML representation of this object

Implements

ICfgBase..::.ToXml()()()
ICfgBase..::.ToXml()()()

See Also

CfgDelta Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgDelta Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelta Properties
CfgDelta Class See Also Send Feedback

The CfgDelta type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDelta Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgObject Class

[image]

Enterprise SDK 8.0 Reference API
CfgObject Class
Members See Also Send Feedback
This is a base class for all standalone Configuration Server objects.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgObject : CfgBase,
    ICfgObject, ICfgBase, ICloneable
Visual Basic (Declaration)
Public MustInherit Class CfgObject _
    Inherits CfgBase _
    Implements ICfgObject, ICfgBase, ICloneable
Visual C++
public ref class CfgObject abstract : public CfgBase,
    ICfgObject, ICfgBase, ICloneable

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAccessGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgActionCode
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentLogin
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAlarmCondition
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgApplication
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAppPrototype
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCallingList
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCampaign
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCampaignGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDN
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDNGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgEnumerator
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgEnumeratorValue
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgField
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgFilter
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgFolder
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgFormat
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGVPCustomer
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGVPIVRProfile
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGVPReseller
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgHost
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgIVR
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgIVRPort
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectiveTable
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPerson
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPhysicalSwitch
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPlace
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPlaceGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgRole
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgScheduledTask
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgScript
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgService
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSkill
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgStatDay
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgStatTable
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSwitch
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTableAccess
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTenant
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTimeZone
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTransaction
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTreatment
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgVoicePrompt

See Also

CfgObject Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgObject Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObject Members
CfgObject Class Methods Properties See Also Send Feedback

The CfgObject type exposes the following members.

Methods

Name | Description
Clone
Delete
Deletes the configuration object from the Configuration Server
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
RemoveAccount
Removes the specified account from the current object's access list.
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid |
ObjectPath | Path of the object in Configuration Server.
ObjectType | Returns the configuration object type
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgObject Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObject Methods
CfgObject Class See Also Send Feedback

The CfgObject type exposes the following members.

Methods

Name | Description
Clone
Delete
Deletes the configuration object from the Configuration Server
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
RemoveAccount
Removes the specified account from the current object's access list.
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Clone Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.Clone Method
CfgObject Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObject.Clone"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A copy of the current object.

Implements

ICloneable..::.Clone()()()

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.Delete Method
CfgObject Class See Also Send Feedback
Deletes the configuration object from the Configuration Server

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
virtual void Delete() sealed

Implements

ICfgObject..::.Delete()()()

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Refresh Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.Refresh Method
CfgObject Class See Also Send Feedback
Retrieves the latest data from the Configuration Server and updates the object's data

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
virtual void Refresh() sealed

Implements

ICfgObject..::.Refresh()()()

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


RemoveAccount Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.RemoveAccount Method
CfgObject Class See Also Send Feedback
Removes the specified account from the current object's access list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void RemoveAccount(
    CfgObject accountObject,
    bool recursive
)
Visual Basic (Declaration)
Public Sub RemoveAccount ( _
    accountObject As CfgObject, _
    recursive As Boolean _
)
Visual C++
public:
void RemoveAccount(
    CfgObject^ accountObject,
    bool recursive
)

Parameters

accountObject
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
the account object to remove from the access list
recursive
Type: System..::.Boolean
specifies whether to remove the account recursively from child objects

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


RetrieveAccountPermissions Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.RetrieveAccountPermissions Method
CfgObject Class See Also Send Feedback
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int RetrieveAccountPermissions(
    CfgObject accountObject
)
Visual Basic (Declaration)
Public Function RetrieveAccountPermissions ( _
    accountObject As CfgObject _
) As Integer
Visual C++
public:
int RetrieveAccountPermissions(
    CfgObject^ accountObject
)

Parameters

accountObject
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Account (can be any Configuration Server class)

Return Value

Permissions mask

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


RetrievePermissions Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.RetrievePermissions Method
CfgObject Class See Also Send Feedback
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Collection<PermissionDescriptor> RetrievePermissions()
Visual Basic (Declaration)
Public Function RetrievePermissions As Collection(Of PermissionDescriptor)
Visual C++
public:
Collection<PermissionDescriptor^>^ RetrievePermissions()

Return Value

A list of Permission objects

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.Save Method
CfgObject Class See Also Send Feedback
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public virtual void Save()
Visual Basic (Declaration)
Public Overridable Sub Save
Visual C++
public:
virtual void Save()

Implements

ICfgObject..::.Save()()()

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObject..::.SetAccountPermissions Method
CfgObject Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default.
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account

See Also

CfgObject Class
CfgObject Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


SetAccountPermissions Method (CfgObject, Int32)

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.SetAccountPermissions Method (CfgObject, Int32)
CfgObject Class See Also Send Feedback
Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAccountPermissions(
    CfgObject accountObject,
    int newPermissionsMask
)
Visual Basic (Declaration)
Public Sub SetAccountPermissions ( _
    accountObject As CfgObject, _
    newPermissionsMask As Integer _
)
Visual C++
public:
void SetAccountPermissions(
    CfgObject^ accountObject,
    int newPermissionsMask
)

Parameters

accountObject
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Account (can be any Configuration Server class)
newPermissionsMask
Type: System..::.Int32
New permissions mask. See
CopyC#
ConfServerPermissions
 enum.

See Also

CfgObject Class
SetAccountPermissions Overload
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


SetAccountPermissions Method (CfgObject, Int32, Boolean)

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.SetAccountPermissions Method (CfgObject, Int32, Boolean)
CfgObject Class See Also Send Feedback
Changes the permissions on this object from the specified account

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAccountPermissions(
    CfgObject accountObject,
    int newPermissionsMask,
    bool recursive
)
Visual Basic (Declaration)
Public Sub SetAccountPermissions ( _
    accountObject As CfgObject, _
    newPermissionsMask As Integer, _
    recursive As Boolean _
)
Visual C++
public:
void SetAccountPermissions(
    CfgObject^ accountObject,
    int newPermissionsMask,
    bool recursive
)

Parameters

accountObject
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Account (can be any Configuration Server class)
newPermissionsMask
Type: System..::.Int32
New permissions mask. See
CopyC#
ConfServerPermissions
 enum.
recursive
Type: System..::.Boolean
This flag, if set to TRUE, directs Configuration Server to remove permissions at the objects subordinate to the one specified in the accountObject parameter. This way all the subordinate objects will receive permissions identical to their parent object. However, this is not the way to set up an individual permission recursively. For this purpose the NoPropagate flag in the permission record should be used. The flag is only relevant to the following object types: CfgFolder, CfgTenant, CfgSwitch, CfgIVR, CfgEnumerator

See Also

CfgObject Class
SetAccountPermissions Overload
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.Update Method
CfgObject Class See Also Send Feedback
Updates the current object from the passed delta object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Update(
    ICfgDelta deltaObject
)
Visual Basic (Declaration)
Public Sub Update ( _
    deltaObject As ICfgDelta _
)
Visual C++
public:
virtual void Update(
    ICfgDelta^ deltaObject
) sealed

Parameters

deltaObject
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgDelta
the delta object received from configuration server

Implements

ICfgObject..::.Update(ICfgDelta)

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgObject Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObject Properties
CfgObject Class See Also Send Feedback

The CfgObject type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid |
ObjectPath | Path of the object in Configuration Server.
ObjectType | Returns the configuration object type
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


FolderId Property

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.FolderId Property
CfgObject Class See Also Send Feedback
This property specifies ID of the folder, in which the object resides in Configuration Server

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FolderId { get; set; }
Visual Basic (Declaration)
Public Property FolderId As Integer
Visual C++
public:
property int FolderId {
    int get ();
    void set (int value);
}

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.ObjectDbid Property
CfgObject Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObject.ObjectDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDbid { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectDbid As Integer
Visual C++
public:
virtual property int ObjectDbid {
    int get () sealed;
}

Return Value

the dbid of the current object, or 0 if object has not been saved

Implements

ICfgObject..::.ObjectDbid

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectPath Property

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.ObjectPath Property
CfgObject Class See Also Send Feedback
Path of the object in Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ObjectPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectPath As String
Visual C++
public:
property String^ ObjectPath {
    String^ get ();
}

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObject..::.ObjectType Property
CfgObject Class See Also Send Feedback
Returns the configuration object type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectType As CfgObjectType
Visual C++
public:
virtual property CfgObjectType ObjectType {
    CfgObjectType get () sealed;
}

Return Value

Implements

ICfgObject..::.ObjectType

See Also

CfgObject Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgStructure Class

[image]

Enterprise SDK 8.0 Reference API
CfgStructure Class
Members See Also Send Feedback
The base class for all Configuration Server structures.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgStructure : CfgBase,
    ICfgStructure, ICfgBase
Visual Basic (Declaration)
Public MustInherit Class CfgStructure _
    Inherits CfgBase _
    Implements ICfgStructure, ICfgBase
Visual C++
public ref class CfgStructure abstract : public CfgBase,
    ICfgStructure, ICfgBase

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACE
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACEID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACL
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACLID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAddress
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentLoginInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAppRank
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAppServicePermission
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCallingListInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCampaignGroupInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgConnInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDelSwitchAccess
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDetectEvent
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDNAccessNumber
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDNInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGroup
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgMemberID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectiveTableRecord
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectResource
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgOS
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgOwnerID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgParentID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPhones
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPortInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgRemovalEvent
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgResourceID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgRoleMember
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServer
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServerHostID
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServerVersion
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServiceInfo
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSkillLevel
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSolutionComponent
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSolutionComponentDefinition
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgStatInterval
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSubcode
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSwitchAccessCode
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgUpdatePackageRecord

See Also

CfgStructure Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgStructure Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructure Members
CfgStructure Class Methods Properties See Also Send Feedback

The CfgStructure type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure.

See Also

CfgStructure Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgStructure Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructure Methods
CfgStructure Class See Also Send Feedback

The CfgStructure type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgStructure Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgStructure Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructure Properties
CfgStructure Class See Also Send Feedback

The CfgStructure type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure.

See Also

CfgStructure Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
CfgStructure..::.Parent Property
CfgStructure Class See Also Send Feedback
Returns the parent configuration server object that references this structure.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICfgObject Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As ICfgObject
Visual C++
public:
virtual property ICfgObject^ Parent {
    ICfgObject^ get () sealed;
}

Return Value

An instance of a configuration server object

Implements

ICfgStructure..::.Parent

See Also

CfgStructure Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Class

[image]

Enterprise SDK 8.0 Reference API
ConfEvent Class
Members See Also Send Feedback
This class represents an event fired by Configuration Server

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ConfEvent
Visual Basic (Declaration)
Public Class ConfEvent
Visual C++
public ref class ConfEvent

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEvent
Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEventObjectCreated

See Also

ConfEvent Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEvent Members
ConfEvent Class Constructors Methods Properties See Also Send Feedback

The ConfEvent type exposes the following members.

Constructors

Name | Description
ConfEvent | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Delta | The object oriented representation of the Delta received with this event. NULL if not available.
Endpoint |
EventType | The type of event received.
ObjectId | The ID of the object about which we're receiving the event.
ObjectType | The type of the object about which we're receiving the event.
XmlDelta | The XML representation of the delta object received with this event. If no delta object is applicable, the property is NULL.

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEvent Constructor
ConfEvent Class See Also Send Feedback

Overload List

Name | Description
ConfEvent(Endpoint, Int32, CfgObjectType, ConfEventType, XDocument) |
ConfEvent(Endpoint, Int32, CfgObjectType, ConfEventType, XDocument, CfgDelta) |

See Also

ConfEvent Class
ConfEvent Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Constructor (, Int32, CfgObjectType, ConfEventType, XDocument)

[image]

Enterprise SDK 8.0 Reference API
ConfEvent Constructor (, Int32, CfgObjectType, ConfEventType, XDocument)
ConfEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEvent(
    Endpoint endpoint,
    int objectId,
    CfgObjectType objectType,
    ConfEventType eventType,
    XDocument deltaObj
)
Visual Basic (Declaration)
Public Sub New ( _
    endpoint As Endpoint, _
    objectId As Integer, _
    objectType As CfgObjectType, _
    eventType As ConfEventType, _
    deltaObj As XDocument _
)
Visual C++
public:
ConfEvent(
    Endpoint^ endpoint,
    int objectId,
    CfgObjectType objectType,
    ConfEventType eventType,
    XDocument^ deltaObj
)

Parameters

endpoint
Type: Endpoint

[Missing <param name="endpoint"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument)"]

objectId
Type: System..::.Int32

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument)"]

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument)"]

eventType
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEventType

[Missing <param name="eventType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument)"]

deltaObj
Type: System.Xml.Linq..::.XDocument

[Missing <param name="deltaObj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument)"]

See Also

ConfEvent Class
ConfEvent Overload
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Constructor (, Int32, CfgObjectType, ConfEventType, XDocument, CfgDelta)

[image]

Enterprise SDK 8.0 Reference API
ConfEvent Constructor (, Int32, CfgObjectType, ConfEventType, XDocument, CfgDelta)
ConfEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEvent(
    Endpoint endpoint,
    int objectId,
    CfgObjectType objectType,
    ConfEventType eventType,
    XDocument deltaObj,
    CfgDelta delta
)
Visual Basic (Declaration)
Public Sub New ( _
    endpoint As Endpoint, _
    objectId As Integer, _
    objectType As CfgObjectType, _
    eventType As ConfEventType, _
    deltaObj As XDocument, _
    delta As CfgDelta _
)
Visual C++
public:
ConfEvent(
    Endpoint^ endpoint,
    int objectId,
    CfgObjectType objectType,
    ConfEventType eventType,
    XDocument^ deltaObj,
    CfgDelta^ delta
)

Parameters

endpoint
Type: Endpoint

[Missing <param name="endpoint"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

objectId
Type: System..::.Int32

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

eventType
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEventType

[Missing <param name="eventType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

deltaObj
Type: System.Xml.Linq..::.XDocument

[Missing <param name="deltaObj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

delta
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta

[Missing <param name="delta"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.#ctor(Genesyslab.Platform.Commons.Protocols.Endpoint,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType,Genesyslab.Enterprise.ConfigurationObjectModel.ConfEventType,System.Xml.Linq.XDocument,Genesyslab.Enterprise.ConfigurationObjectModel.CfgDelta)"]

See Also

ConfEvent Class
ConfEvent Overload
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEvent Methods
ConfEvent Class See Also Send Feedback

The ConfEvent type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.ToString Method
ConfEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the Configuration Server event

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEvent Properties
ConfEvent Class See Also Send Feedback

The ConfEvent type exposes the following members.

Properties

Name | Description
Delta | The object oriented representation of the Delta received with this event. NULL if not available.
Endpoint |
EventType | The type of event received.
ObjectId | The ID of the object about which we're receiving the event.
ObjectType | The type of the object about which we're receiving the event.
XmlDelta | The XML representation of the delta object received with this event. If no delta object is applicable, the property is NULL.

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Delta Property

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.Delta Property
ConfEvent Class See Also Send Feedback
The object oriented representation of the Delta received with this event. NULL if not available.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICfgDelta Delta { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delta As ICfgDelta
Visual C++
public:
property ICfgDelta^ Delta {
    ICfgDelta^ get ();
}

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.Endpoint Property
ConfEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent.Endpoint"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Endpoint Endpoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property Endpoint As Endpoint
Visual C++
public:
property Endpoint^ Endpoint {
    Endpoint^ get ();
}

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


EventType Property

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.EventType Property
ConfEvent Class See Also Send Feedback
The type of event received.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEventType EventType { get; }
Visual Basic (Declaration)
Public ReadOnly Property EventType As ConfEventType
Visual C++
public:
property ConfEventType EventType {
    ConfEventType get ();
}

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectId Property

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.ObjectId Property
ConfEvent Class See Also Send Feedback
The ID of the object about which we're receiving the event.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectId As Integer
Visual C++
public:
property int ObjectId {
    int get ();
}

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.ObjectType Property
ConfEvent Class See Also Send Feedback
The type of the object about which we're receiving the event.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
}

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


XmlDelta Property

[image]

Enterprise SDK 8.0 Reference API
ConfEvent..::.XmlDelta Property
ConfEvent Class See Also Send Feedback
The XML representation of the delta object received with this event. If no delta object is applicable, the property is NULL.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public XDocument XmlDelta { get; }
Visual Basic (Declaration)
Public ReadOnly Property XmlDelta As XDocument
Visual C++
public:
property XDocument^ XmlDelta {
    XDocument^ get ();
}

See Also

ConfEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEventObjectCreated Class

[image]

Enterprise SDK 8.0 Reference API
ConfEventObjectCreated Class
Members See Also Send Feedback
Represents the Configuration Server's object created event.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class ConfEventObjectCreated : ConfEvent
Visual Basic (Declaration)
Public NotInheritable Class ConfEventObjectCreated _
    Inherits ConfEvent
Visual C++
public ref class ConfEventObjectCreated sealed : public ConfEvent

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEvent
Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEventObjectCreated

See Also

ConfEventObjectCreated Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEventObjectCreated Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventObjectCreated Members
ConfEventObjectCreated Class Methods Properties See Also Send Feedback

The ConfEventObjectCreated type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from ConfEvent.)

Properties

Name | Description
Delta | The object oriented representation of the Delta received with this event. NULL if not available. (Inherited from ConfEvent.)
Endpoint | (Inherited from ConfEvent.)
EventType | The type of event received. (Inherited from ConfEvent.)
Object | The newly created object.
ObjectId | The ID of the object about which we're receiving the event. (Inherited from ConfEvent.)
ObjectType | The type of the object about which we're receiving the event. (Inherited from ConfEvent.)
XmlDelta | The XML representation of the delta object received with this event. If no delta object is applicable, the property is NULL. (Inherited from ConfEvent.)

See Also

ConfEventObjectCreated Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEventObjectCreated Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventObjectCreated Methods
ConfEventObjectCreated Class See Also Send Feedback

The ConfEventObjectCreated type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from ConfEvent.)

See Also

ConfEventObjectCreated Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEventObjectCreated Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventObjectCreated Properties
ConfEventObjectCreated Class See Also Send Feedback

The ConfEventObjectCreated type exposes the following members.

Properties

Name | Description
Delta | The object oriented representation of the Delta received with this event. NULL if not available. (Inherited from ConfEvent.)
Endpoint | (Inherited from ConfEvent.)
EventType | The type of event received. (Inherited from ConfEvent.)
Object | The newly created object.
ObjectId | The ID of the object about which we're receiving the event. (Inherited from ConfEvent.)
ObjectType | The type of the object about which we're receiving the event. (Inherited from ConfEvent.)
XmlDelta | The XML representation of the delta object received with this event. If no delta object is applicable, the property is NULL. (Inherited from ConfEvent.)

See Also

ConfEventObjectCreated Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Object Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventObjectCreated..::.Object Property
ConfEventObjectCreated Class See Also Send Feedback
The newly created object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICfgObject Object { get; }
Visual Basic (Declaration)
Public ReadOnly Property Object As ICfgObject
Visual C++
public:
property ICfgObject^ Object {
    ICfgObject^ get ();
}

See Also

ConfEventObjectCreated Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfEventType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ConfEventType Enumeration
See Also Send Feedback
Describes the configuration event types that can be received from Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ConfEventType
Visual Basic (Declaration)
Public Enumeration ConfEventType
Visual C++
public enum class ConfEventType

Members

Member name | Description
ObjectCreated | The event signifies the creation of a Configuration Server object
ObjectDeleted | The event signifies the deletion of a Configuration Server object
ObjectUpdated | The event signifies the update of a Configuration Server object

See Also

Genesyslab.Enterprise.ConfigurationObjectModel Namespace


GlobalConfService Class

[image]

Enterprise SDK 8.0 Reference API
GlobalConfService Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class GlobalConfService
Visual Basic (Declaration)
Public Class GlobalConfService
Visual C++
public ref class GlobalConfService

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.GlobalConfService

See Also

GlobalConfService Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


GlobalConfService Members

[image] [image]

Enterprise SDK 8.0 Reference API
GlobalConfService Members
GlobalConfService Class Methods See Also Send Feedback

The GlobalConfService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NameToObjectType |
ObjectTypeToName |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalConfService Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


GlobalConfService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
GlobalConfService Methods
GlobalConfService Class See Also Send Feedback

The GlobalConfService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NameToObjectType |
ObjectTypeToName |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalConfService Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NameToObjectType Method

[image]

Enterprise SDK 8.0 Reference API
GlobalConfService..::.NameToObjectType Method
GlobalConfService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService.NameToObjectType(System.String)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgObjectType NameToObjectType(
    string objName
)
Visual Basic (Declaration)
Public Shared Function NameToObjectType ( _
    objName As String _
) As CfgObjectType
Visual C++
public:
static CfgObjectType NameToObjectType(
    String^ objName
)

Parameters

objName
Type: System..::.String

[Missing <param name="objName"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService.NameToObjectType(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService.NameToObjectType(System.String)"]

See Also

GlobalConfService Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectTypeToName Method

[image]

Enterprise SDK 8.0 Reference API
GlobalConfService..::.ObjectTypeToName Method
GlobalConfService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService.ObjectTypeToName(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static string ObjectTypeToName(
    CfgObjectType objType
)
Visual Basic (Declaration)
Public Shared Function ObjectTypeToName ( _
    objType As CfgObjectType _
) As String
Visual C++
public:
static String^ ObjectTypeToName(
    CfgObjectType objType
)

Parameters

objType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService.ObjectTypeToName(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.GlobalConfService.ObjectTypeToName(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

GlobalConfService Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgBase Interface

[image]

Enterprise SDK 8.0 Reference API
ICfgBase Interface
Members See Also Send Feedback
The base interface for all configuration server objects.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICfgBase
Visual Basic (Declaration)
Public Interface ICfgBase
Visual C++
public interface class ICfgBase

See Also

ICfgBase Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgBase Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgBase Members
ICfgBase Interface Methods Properties See Also Send Feedback

The ICfgBase type exposes the following members.

Methods

Name | Description
ToXml | Provides an XML representation of the current object.

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs.
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name.

See Also

ICfgBase Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgBase Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgBase Methods
ICfgBase Interface See Also Send Feedback

The ICfgBase type exposes the following members.

Methods

Name | Description
ToXml | Provides an XML representation of the current object.

See Also

ICfgBase Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ToXml Method

[image]

Enterprise SDK 8.0 Reference API
ICfgBase..::.ToXml Method
ICfgBase Interface See Also Send Feedback
Provides an XML representation of the current object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
XElement ToXml()
Visual Basic (Declaration)
Function ToXml As XElement
Visual C++
XElement^ ToXml()

Return Value

an XML "snapshot" of the object

See Also

ICfgBase Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgBase Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgBase Properties
ICfgBase Interface See Also Send Feedback

The ICfgBase type exposes the following members.

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs.
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name.

See Also

ICfgBase Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
ICfgBase..::.Endpoint Property
ICfgBase Interface See Also Send Feedback
Provides the location of the server to which this object belongs.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Endpoint Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Endpoint
Visual C++
property Endpoint^ Endpoint {
    Endpoint^ get ();
}

See Also

ICfgBase Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
ICfgBase..::.Item Property
ICfgBase Interface See Also Send Feedback
This indexer can be used to retrieve any property of the configuration object using the property's string name.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object this[
    string propertyName
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    propertyName As String _
) As Object
Visual C++
property Object^ default[String^ propertyName] {
    Object^ get (String^ propertyName);
    void set (String^ propertyName, Object^ value);
}

Parameters

propertyName
Type: System..::.String

See Also

ICfgBase Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgDelta Interface

[image]

Enterprise SDK 8.0 Reference API
ICfgDelta Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.ICfgDelta"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICfgDelta : ICfgBase
Visual Basic (Declaration)
Public Interface ICfgDelta _
    Implements ICfgBase
Visual C++
public interface class ICfgDelta : ICfgBase

See Also

ICfgDelta Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgDelta Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgDelta Members
ICfgDelta Interface Methods Properties See Also Send Feedback

The ICfgDelta type exposes the following members.

Methods

Name | Description
ToXml | Provides an XML representation of the current object. (Inherited from ICfgBase.)

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs. (Inherited from ICfgBase.)
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name. (Inherited from ICfgBase.)

See Also

ICfgDelta Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgDelta Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgDelta Methods
ICfgDelta Interface See Also Send Feedback

The ICfgDelta type exposes the following members.

Methods

Name | Description
ToXml | Provides an XML representation of the current object. (Inherited from ICfgBase.)

See Also

ICfgDelta Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgDelta Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgDelta Properties
ICfgDelta Interface See Also Send Feedback

The ICfgDelta type exposes the following members.

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs. (Inherited from ICfgBase.)
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name. (Inherited from ICfgBase.)

See Also

ICfgDelta Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgObject Interface

[image]

Enterprise SDK 8.0 Reference API
ICfgObject Interface
Members See Also Send Feedback
An interface that should be supported by all configuration classes (objects that can be independently retrieved from Config Server).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICfgObject : ICfgBase
Visual Basic (Declaration)
Public Interface ICfgObject _
    Implements ICfgBase
Visual C++
public interface class ICfgObject : ICfgBase

See Also

ICfgObject Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgObject Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgObject Members
ICfgObject Interface Methods Properties See Also Send Feedback

The ICfgObject type exposes the following members.

Methods

Name | Description
Delete | Deletes the current object from the configuration.
Refresh | Updates the current object with the latest state from the configuration server.
Save | Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
ToXml | Provides an XML representation of the current object. (Inherited from ICfgBase.)
Update | Updates the current object from the passed delta object

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs. (Inherited from ICfgBase.)
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name. (Inherited from ICfgBase.)
ObjectDbid | Returns the dbid of the current object, or 0 if object has not been saved
ObjectType | Returns object type

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgObject Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgObject Methods
ICfgObject Interface See Also Send Feedback

The ICfgObject type exposes the following members.

Methods

Name | Description
Delete | Deletes the current object from the configuration.
Refresh | Updates the current object with the latest state from the configuration server.
Save | Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
ToXml | Provides an XML representation of the current object. (Inherited from ICfgBase.)
Update | Updates the current object from the passed delta object

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
ICfgObject..::.Delete Method
ICfgObject Interface See Also Send Feedback
Deletes the current object from the configuration.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Delete()
Visual Basic (Declaration)
Sub Delete
Visual C++
void Delete()

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Refresh Method

[image]

Enterprise SDK 8.0 Reference API
ICfgObject..::.Refresh Method
ICfgObject Interface See Also Send Feedback
Updates the current object with the latest state from the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Refresh()
Visual Basic (Declaration)
Sub Refresh
Visual C++
void Refresh()

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
ICfgObject..::.Save Method
ICfgObject Interface See Also Send Feedback
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Save()
Visual Basic (Declaration)
Sub Save
Visual C++
void Save()

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
ICfgObject..::.Update Method
ICfgObject Interface See Also Send Feedback
Updates the current object from the passed delta object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Update(
    ICfgDelta deltaObject
)
Visual Basic (Declaration)
Sub Update ( _
    deltaObject As ICfgDelta _
)
Visual C++
void Update(
    ICfgDelta^ deltaObject
)

Parameters

deltaObject
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgDelta
the delta object representing the changes to be made

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgObject Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgObject Properties
ICfgObject Interface See Also Send Feedback

The ICfgObject type exposes the following members.

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs. (Inherited from ICfgBase.)
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name. (Inherited from ICfgBase.)
ObjectDbid | Returns the dbid of the current object, or 0 if object has not been saved
ObjectType | Returns object type

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
ICfgObject..::.ObjectDbid Property
ICfgObject Interface See Also Send Feedback
Returns the dbid of the current object, or 0 if object has not been saved

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int ObjectDbid { get; }
Visual Basic (Declaration)
ReadOnly Property ObjectDbid As Integer
Visual C++
property int ObjectDbid {
    int get ();
}

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
ICfgObject..::.ObjectType Property
ICfgObject Interface See Also Send Feedback
Returns object type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectType ObjectType { get; }
Visual Basic (Declaration)
ReadOnly Property ObjectType As CfgObjectType
Visual C++
property CfgObjectType ObjectType {
    CfgObjectType get ();
}

Return Value

See Also

ICfgObject Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgStructure Interface

[image]

Enterprise SDK 8.0 Reference API
ICfgStructure Interface
Members See Also Send Feedback
An interface that should be supported by all configuration structures (configuration objects that are dependent on other configuration objects and can only be retrieved as part of some other object (class)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICfgStructure : ICfgBase
Visual Basic (Declaration)
Public Interface ICfgStructure _
    Implements ICfgBase
Visual C++
public interface class ICfgStructure : ICfgBase

See Also

ICfgStructure Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgStructure Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgStructure Members
ICfgStructure Interface Methods Properties See Also Send Feedback

The ICfgStructure type exposes the following members.

Methods

Name | Description
ToXml | Provides an XML representation of the current object. (Inherited from ICfgBase.)

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs. (Inherited from ICfgBase.)
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name. (Inherited from ICfgBase.)
Parent | Returns the structure's parent object. Should be a configuration class.

See Also

ICfgStructure Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgStructure Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgStructure Methods
ICfgStructure Interface See Also Send Feedback

The ICfgStructure type exposes the following members.

Methods

Name | Description
ToXml | Provides an XML representation of the current object. (Inherited from ICfgBase.)

See Also

ICfgStructure Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICfgStructure Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICfgStructure Properties
ICfgStructure Interface See Also Send Feedback

The ICfgStructure type exposes the following members.

Properties

Name | Description
Endpoint | Provides the location of the server to which this object belongs. (Inherited from ICfgBase.)
Item | This indexer can be used to retrieve any property of the configuration object using the property's string name. (Inherited from ICfgBase.)
Parent | Returns the structure's parent object. Should be a configuration class.

See Also

ICfgStructure Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
ICfgStructure..::.Parent Property
ICfgStructure Interface See Also Send Feedback
Returns the structure's parent object. Should be a configuration class.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICfgObject Parent { get; }
Visual Basic (Declaration)
ReadOnly Property Parent As ICfgObject
Visual C++
property ICfgObject^ Parent {
    ICfgObject^ get ();
}

Return Value

See Also

ICfgStructure Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICollectionsBroker Interface

[image]

Enterprise SDK 8.0 Reference API
ICollectionsBroker Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.ICollectionsBroker"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICollectionsBroker
Visual Basic (Declaration)
Public Interface ICollectionsBroker
Visual C++
public interface class ICollectionsBroker

See Also

ICollectionsBroker Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICollectionsBroker Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICollectionsBroker Members
ICollectionsBroker Interface Methods See Also Send Feedback

The ICollectionsBroker type exposes the following members.

Methods

Name | Description
Refresh |

See Also

ICollectionsBroker Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ICollectionsBroker Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICollectionsBroker Methods
ICollectionsBroker Interface See Also Send Feedback

The ICollectionsBroker type exposes the following members.

Methods

Name | Description
Refresh |

See Also

ICollectionsBroker Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Refresh Method

[image]

Enterprise SDK 8.0 Reference API
ICollectionsBroker..::.Refresh Method
ICollectionsBroker Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.ICollectionsBroker.Refresh"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Refresh()
Visual Basic (Declaration)
Sub Refresh
Visual C++
void Refresh()

See Also

ICollectionsBroker Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


IConfServicePolicy Interface

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy Interface
Members See Also Send Feedback
The interface to be implemented when defining a policy for the configuration service.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfServicePolicy
Visual Basic (Declaration)
Public Interface IConfServicePolicy
Visual C++
public interface class IConfServicePolicy

Remarks

The cache-related properties are only valid when caching is enabled.

See Also

IConfServicePolicy Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


IConfServicePolicy Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy Members
IConfServicePolicy Interface Methods Properties See Also Send Feedback

The IConfServicePolicy type exposes the following members.

Methods

Name | Description
AttemptLinkResolutionThroughCache | Determines whether link resolution should be attempted through the cache before querying the configuration server (link resolution refers to the automatic retrieval of configuration objects when certain properties are accessed).
CacheOnRetrieve | Determines whether the specified object should be cached upon being retrieved from the configuration server.
CacheOnSave | Determines whether the specified object should be cached upon being saved in the configuration server.
OverwriteCachedVersionOnRetrieve | Determines whether an existing cached object should be overwritten if a newer copy is retrieved from configuration server.
QueryCacheOnRetrieve | Determines whether the cache should be queried before a retrieve operation is performed.
QueryCacheOnRetrieveMultiple | Determines whether the cache should be queried before a retrieve multiple operation is performed.

Properties

Name | Description
ValidateBeforeSave | Determines whether the properties of an object should be validated for correctness before a save operation is attempted.

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


IConfServicePolicy Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy Methods
IConfServicePolicy Interface See Also Send Feedback

The IConfServicePolicy type exposes the following members.

Methods

Name | Description
AttemptLinkResolutionThroughCache | Determines whether link resolution should be attempted through the cache before querying the configuration server (link resolution refers to the automatic retrieval of configuration objects when certain properties are accessed).
CacheOnRetrieve | Determines whether the specified object should be cached upon being retrieved from the configuration server.
CacheOnSave | Determines whether the specified object should be cached upon being saved in the configuration server.
OverwriteCachedVersionOnRetrieve | Determines whether an existing cached object should be overwritten if a newer copy is retrieved from configuration server.
QueryCacheOnRetrieve | Determines whether the cache should be queried before a retrieve operation is performed.
QueryCacheOnRetrieveMultiple | Determines whether the cache should be queried before a retrieve multiple operation is performed.

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


AttemptLinkResolutionThroughCache Method

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.AttemptLinkResolutionThroughCache Method
IConfServicePolicy Interface See Also Send Feedback
Determines whether link resolution should be attempted through the cache before querying the configuration server (link resolution refers to the automatic retrieval of configuration objects when certain properties are accessed).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool AttemptLinkResolutionThroughCache(
    CfgObjectType objectType
)
Visual Basic (Declaration)
Function AttemptLinkResolutionThroughCache ( _
    objectType As CfgObjectType _
) As Boolean
Visual C++
bool AttemptLinkResolutionThroughCache(
    CfgObjectType objectType
)

Parameters

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of object for which link resolution is to be attempted

Return Value

true if link resolution should be attempted through the cache, false if configuration server should be queried

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CacheOnRetrieve Method

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.CacheOnRetrieve Method
IConfServicePolicy Interface See Also Send Feedback
Determines whether the specified object should be cached upon being retrieved from the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool CacheOnRetrieve(
    ICfgObject obj
)
Visual Basic (Declaration)
Function CacheOnRetrieve ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool CacheOnRetrieve(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The retrieved configuration object

Return Value

true if the object should be cached, false otherwise

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CacheOnSave Method

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.CacheOnSave Method
IConfServicePolicy Interface See Also Send Feedback
Determines whether the specified object should be cached upon being saved in the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool CacheOnSave(
    ICfgObject obj
)
Visual Basic (Declaration)
Function CacheOnSave ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool CacheOnSave(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object being saved

Return Value

true if the object should be cached, false otherwise

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


OverwriteCachedVersionOnRetrieve Method

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.OverwriteCachedVersionOnRetrieve Method
IConfServicePolicy Interface See Also Send Feedback
Determines whether an existing cached object should be overwritten if a newer copy is retrieved from configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool OverwriteCachedVersionOnRetrieve(
    ICfgObject newObj
)
Visual Basic (Declaration)
Function OverwriteCachedVersionOnRetrieve ( _
    newObj As ICfgObject _
) As Boolean
Visual C++
bool OverwriteCachedVersionOnRetrieve(
    ICfgObject^ newObj
)

Parameters

newObj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
the new version of a cached object

Return Value

true if the object should be overwritten in the cache, false otherwise

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


QueryCacheOnRetrieve Method

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.QueryCacheOnRetrieve Method
IConfServicePolicy Interface See Also Send Feedback
Determines whether the cache should be queried before a retrieve operation is performed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool QueryCacheOnRetrieve(
    ICfgQuery query
)
Visual Basic (Declaration)
Function QueryCacheOnRetrieve ( _
    query As ICfgQuery _
) As Boolean
Visual C++
bool QueryCacheOnRetrieve(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
The query for the retrieve operation

Return Value

true if the cache should be queried first, false otherwise.

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


QueryCacheOnRetrieveMultiple Method

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.QueryCacheOnRetrieveMultiple Method
IConfServicePolicy Interface See Also Send Feedback
Determines whether the cache should be queried before a retrieve multiple operation is performed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool QueryCacheOnRetrieveMultiple(
    ICfgQuery query
)
Visual Basic (Declaration)
Function QueryCacheOnRetrieveMultiple ( _
    query As ICfgQuery _
) As Boolean
Visual C++
bool QueryCacheOnRetrieveMultiple(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
The query for the retrieve operation

Return Value

true if the cache should be queried first, false otherwise.

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


IConfServicePolicy Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy Properties
IConfServicePolicy Interface See Also Send Feedback

The IConfServicePolicy type exposes the following members.

Properties

Name | Description
ValidateBeforeSave | Determines whether the properties of an object should be validated for correctness before a save operation is attempted.

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ValidateBeforeSave Property

[image]

Enterprise SDK 8.0 Reference API
IConfServicePolicy..::.ValidateBeforeSave Property
IConfServicePolicy Interface See Also Send Feedback
Determines whether the properties of an object should be validated for correctness before a save operation is attempted.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ValidateBeforeSave { get; set; }
Visual Basic (Declaration)
Property ValidateBeforeSave As Boolean
Visual C++
property bool ValidateBeforeSave {
    bool get ();
    void set (bool value);
}

See Also

IConfServicePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


MiscConstants Class

[image]

Enterprise SDK 8.0 Reference API
MiscConstants Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.MiscConstants"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class MiscConstants
Visual Basic (Declaration)
Public Class MiscConstants
Visual C++
public ref class MiscConstants

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.MiscConstants

See Also

MiscConstants Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


MiscConstants Members

[image] [image]

Enterprise SDK 8.0 Reference API
MiscConstants Members
MiscConstants Class Methods Fields See Also Send Feedback

The MiscConstants type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CfgObjectsNamespace |
DbidPropertyName |

See Also

MiscConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


MiscConstants Fields

[image] [image]

Enterprise SDK 8.0 Reference API
MiscConstants Fields
MiscConstants Class See Also Send Feedback

The MiscConstants type exposes the following members.

Fields

Name | Description
CfgObjectsNamespace |
DbidPropertyName |

See Also

MiscConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


CfgObjectsNamespace Field

[image]

Enterprise SDK 8.0 Reference API
MiscConstants..::.CfgObjectsNamespace Field
MiscConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.MiscConstants.CfgObjectsNamespace"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string CfgObjectsNamespace
Visual Basic (Declaration)
Public Const CfgObjectsNamespace As String
Visual C++
public:
literal String^ CfgObjectsNamespace

See Also

MiscConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


DbidPropertyName Field

[image]

Enterprise SDK 8.0 Reference API
MiscConstants..::.DbidPropertyName Field
MiscConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.MiscConstants.DbidPropertyName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string DbidPropertyName
Visual Basic (Declaration)
Public Const DbidPropertyName As String
Visual C++
public:
literal String^ DbidPropertyName

See Also

MiscConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


MiscConstants Methods

[image] [image]

Enterprise SDK 8.0 Reference API
MiscConstants Methods
MiscConstants Class See Also Send Feedback

The MiscConstants type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MiscConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationFilter Class

[image]

Enterprise SDK 8.0 Reference API
NotificationFilter Class
Members See Also Send Feedback
This class is used to retrieve events from the Configuration Server. Please, refer to Message Broker application block for more details

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class NotificationFilter : IPredicate<ConfEvent>
Visual Basic (Declaration)
Public Class NotificationFilter _
    Implements IPredicate(Of ConfEvent)
Visual C++
public ref class NotificationFilter : IPredicate<ConfEvent^>

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.NotificationFilter

See Also

NotificationFilter Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationFilter Members
NotificationFilter Class Constructors Methods See Also Send Feedback

The NotificationFilter type exposes the following members.

Constructors

Name | Description
NotificationFilter | Creates a new instance of the NotificationFilter

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Used to evaluate whether the specified event passes this filter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationFilter Constructor

[image]

Enterprise SDK 8.0 Reference API
NotificationFilter Constructor
NotificationFilter Class See Also Send Feedback
Creates a new instance of the NotificationFilter

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotificationFilter(
    NotificationQuery query
)
Visual Basic (Declaration)
Public Sub New ( _
    query As NotificationQuery _
)
Visual C++
public:
NotificationFilter(
    NotificationQuery^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.NotificationQuery
the query which this filter is baed on

See Also

NotificationFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationFilter Methods
NotificationFilter Class See Also Send Feedback

The NotificationFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Used to evaluate whether the specified event passes this filter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
NotificationFilter..::.Invoke Method
NotificationFilter Class See Also Send Feedback
Used to evaluate whether the specified event passes this filter.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Invoke(
    ConfEvent obj
)
Visual Basic (Declaration)
Public Function Invoke ( _
    obj As ConfEvent _
) As Boolean
Visual C++
public:
virtual bool Invoke(
    ConfEvent^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEvent
the event to evaluate

Return Value

true if the event passes the filter, false otherwise

Implements

IPredicateInvoke(UTP)

See Also

NotificationFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationQuery Class

[image]

Enterprise SDK 8.0 Reference API
NotificationQuery Class
Members See Also Send Feedback
This class is used to subscribe to notifications from the Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class NotificationQuery
Visual Basic (Declaration)
Public Class NotificationQuery
Visual C++
public ref class NotificationQuery

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.NotificationQuery

See Also

NotificationQuery Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationQuery Members

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQuery Members
NotificationQuery Class Constructors Methods Properties See Also Send Feedback

The NotificationQuery type exposes the following members.

Constructors

Name | Description
NotificationQuery | Creates a new instance of the object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ObjectDbid | This property is used if the client wants to follow changes in a specific object
ObjectType | This property is used if the client wants to subscribe to all events happening with all objects of a the specific type
TenantDbid | This property is used if the client wants to subscribe to all events happening at the specific Tenant

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationQuery Constructor

[image]

Enterprise SDK 8.0 Reference API
NotificationQuery Constructor
NotificationQuery Class See Also Send Feedback
Creates a new instance of the object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotificationQuery()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotificationQuery()

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationQuery Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQuery Methods
NotificationQuery Class See Also Send Feedback

The NotificationQuery type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


NotificationQuery Properties

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQuery Properties
NotificationQuery Class See Also Send Feedback

The NotificationQuery type exposes the following members.

Properties

Name | Description
ObjectDbid | This property is used if the client wants to follow changes in a specific object
ObjectType | This property is used if the client wants to subscribe to all events happening with all objects of a the specific type
TenantDbid | This property is used if the client wants to subscribe to all events happening at the specific Tenant

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
NotificationQuery..::.ObjectDbid Property
NotificationQuery Class See Also Send Feedback
This property is used if the client wants to follow changes in a specific object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDbid { get; set; }
Visual Basic (Declaration)
Public Property ObjectDbid As Integer
Visual C++
public:
property int ObjectDbid {
    int get ();
    void set (int value);
}

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
NotificationQuery..::.ObjectType Property
NotificationQuery Class See Also Send Feedback
This property is used if the client wants to subscribe to all events happening with all objects of a the specific type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
NotificationQuery..::.TenantDbid Property
NotificationQuery Class See Also Send Feedback
This property is used if the client wants to subscribe to all events happening at the specific Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Integer
Visual C++
public:
property int TenantDbid {
    int get ();
    void set (int value);
}

See Also

NotificationQuery Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PermissionDescriptor Class

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor Class
Members See Also Send Feedback
This class represents access permissions of an associated Configuration Server object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class PermissionDescriptor
Visual Basic (Declaration)
Public Class PermissionDescriptor
Visual C++
public ref class PermissionDescriptor

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.PermissionDescriptor

See Also

PermissionDescriptor Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PermissionDescriptor Members

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor Members
PermissionDescriptor Class Constructors Methods Properties See Also Send Feedback

The PermissionDescriptor type exposes the following members.

Constructors

Name | Description
PermissionDescriptor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RetrieveObject | Retrieves an instance of the object specified by the dbid and object type properties of this object
ToString | Returns a string representing the Configuration Server permissions of the specified object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AccessMask | The access mask applicable to the specified object.
ObjectDbid | The dbid of the specified object.
ObjectType | The object type of the specified object

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PermissionDescriptor Constructor

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor Constructor
PermissionDescriptor Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor.#ctor(System.Int32,System.Int32,System.Int32)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public PermissionDescriptor(
    int objectDbid,
    int objectType,
    int accessMask
)
Visual Basic (Declaration)
Public Sub New ( _
    objectDbid As Integer, _
    objectType As Integer, _
    accessMask As Integer _
)
Visual C++
public:
PermissionDescriptor(
    int objectDbid,
    int objectType,
    int accessMask
)

Parameters

objectDbid
Type: System..::.Int32

[Missing <param name="objectDbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor.#ctor(System.Int32,System.Int32,System.Int32)"]

objectType
Type: System..::.Int32

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor.#ctor(System.Int32,System.Int32,System.Int32)"]

accessMask
Type: System..::.Int32

[Missing <param name="accessMask"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor.#ctor(System.Int32,System.Int32,System.Int32)"]

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PermissionDescriptor Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor Methods
PermissionDescriptor Class See Also Send Feedback

The PermissionDescriptor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RetrieveObject | Retrieves an instance of the object specified by the dbid and object type properties of this object
ToString | Returns a string representing the Configuration Server permissions of the specified object. (Overrides Object..::.ToString()()().)

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


RetrieveObject Method

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor..::.RetrieveObject Method
PermissionDescriptor Class See Also Send Feedback
Retrieves an instance of the object specified by the dbid and object type properties of this object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICfgObject RetrieveObject(
    IConfigurationService service,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function RetrieveObject ( _
    service As IConfigurationService, _
    channel As IClientChannel _
) As ICfgObject
Visual C++
public:
ICfgObject^ RetrieveObject(
    IConfigurationService^ service,
    IClientChannel^ channel
)

Parameters

service
Type: IConfigurationService
The configuration service to use to retrieve the data
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor.RetrieveObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

An object retrieved from Configuration Server

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor..::.ToString Method
PermissionDescriptor Class See Also Send Feedback
Returns a string representing the Configuration Server permissions of the specified object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor.ToString"]

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PermissionDescriptor Properties

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor Properties
PermissionDescriptor Class See Also Send Feedback

The PermissionDescriptor type exposes the following members.

Properties

Name | Description
AccessMask | The access mask applicable to the specified object.
ObjectDbid | The dbid of the specified object.
ObjectType | The object type of the specified object

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


AccessMask Property

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor..::.AccessMask Property
PermissionDescriptor Class See Also Send Feedback
The access mask applicable to the specified object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AccessMask { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessMask As Integer
Visual C++
public:
property int AccessMask {
    int get ();
}

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor..::.ObjectDbid Property
PermissionDescriptor Class See Also Send Feedback
The dbid of the specified object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDbid { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectDbid As Integer
Visual C++
public:
property int ObjectDbid {
    int get ();
}

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptor..::.ObjectType Property
PermissionDescriptor Class See Also Send Feedback
The object type of the specified object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
}

See Also

PermissionDescriptor Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PropertyAccessHelper Class

[image]

Enterprise SDK 8.0 Reference API
PropertyAccessHelper Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.PropertyAccessHelper"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class PropertyAccessHelper
Visual Basic (Declaration)
Public MustInherit Class PropertyAccessHelper
Visual C++
public ref class PropertyAccessHelper abstract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.PropertyAccessHelper

See Also

PropertyAccessHelper Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PropertyAccessHelper Members

[image] [image]

Enterprise SDK 8.0 Reference API
PropertyAccessHelper Members
PropertyAccessHelper Class Methods See Also Send Feedback

The PropertyAccessHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSubNode |
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyAccessHelper Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


PropertyAccessHelper Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PropertyAccessHelper Methods
PropertyAccessHelper Class See Also Send Feedback

The PropertyAccessHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSubNode |
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyAccessHelper Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


GetSubNode Method

[image]

Enterprise SDK 8.0 Reference API
PropertyAccessHelper..::.GetSubNode Method
PropertyAccessHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PropertyAccessHelper.GetSubNode(System.Xml.Linq.XElement,System.Xml.Linq.XName)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static XElement GetSubNode(
    XElement node,
    XName name
)
Visual Basic (Declaration)
Public Shared Function GetSubNode ( _
    node As XElement, _
    name As XName _
) As XElement
Visual C++
public:
static XElement^ GetSubNode(
    XElement^ node,
    XName^ name
)

Parameters

node
Type: System.Xml.Linq..::.XElement

[Missing <param name="node"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PropertyAccessHelper.GetSubNode(System.Xml.Linq.XElement,System.Xml.Linq.XName)"]

name
Type: System.Xml.Linq..::.XName

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PropertyAccessHelper.GetSubNode(System.Xml.Linq.XElement,System.Xml.Linq.XName)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.PropertyAccessHelper.GetSubNode(System.Xml.Linq.XElement,System.Xml.Linq.XName)"]

See Also

PropertyAccessHelper Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Subscription Class

[image]

Enterprise SDK 8.0 Reference API
Subscription Class
Members See Also Send Feedback
Summary description for Subscription.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class Subscription
Visual Basic (Declaration)
Public Class Subscription
Visual C++
public ref class Subscription

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.Subscription

See Also

Subscription Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Subscription Members

[image] [image]

Enterprise SDK 8.0 Reference API
Subscription Members
Subscription Class Constructors Methods Properties See Also Send Feedback

The Subscription type exposes the following members.

Constructors

Name | Description
Subscription |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Query |

See Also

Subscription Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Subscription Constructor

[image]

Enterprise SDK 8.0 Reference API
Subscription Constructor
Subscription Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Subscription.#ctor(Genesyslab.Enterprise.ConfigurationObjectModel.NotificationQuery)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Subscription(
    NotificationQuery query
)
Visual Basic (Declaration)
Public Sub New ( _
    query As NotificationQuery _
)
Visual C++
public:
Subscription(
    NotificationQuery^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.NotificationQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Subscription.#ctor(Genesyslab.Enterprise.ConfigurationObjectModel.NotificationQuery)"]

See Also

Subscription Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Subscription Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Subscription Methods
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Subscription Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Subscription Properties

[image] [image]

Enterprise SDK 8.0 Reference API
Subscription Properties
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Properties

Name | Description
Query |

See Also

Subscription Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Query Property

[image]

Enterprise SDK 8.0 Reference API
Subscription..::.Query Property
Subscription Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Subscription.Query"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotificationQuery Query { get; }
Visual Basic (Declaration)
Public ReadOnly Property Query As NotificationQuery
Visual C++
public:
property NotificationQuery^ Query {
    NotificationQuery^ get ();
}

See Also

Subscription Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


WellKnownDbids Class

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids Class
Members See Also Send Feedback
This enumeration summarizes standard DBID in Configuration Server

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class WellKnownDbids
Visual Basic (Declaration)
Public Class WellKnownDbids
Visual C++
public ref class WellKnownDbids

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.WellKnownDbids

See Also

WellKnownDbids Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


WellKnownDbids Members

[image] [image]

Enterprise SDK 8.0 Reference API
WellKnownDbids Members
WellKnownDbids Class Constructors Methods Fields See Also Send Feedback

The WellKnownDbids type exposes the following members.

Constructors

Name | Description
WellKnownDbids |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ConfManagerAppPrototypeDbid | Config manager application template
ConfManagerDbid | DBID of config manager app
ConfServerAppPrototypeDbid | Conf server app template
ConfServerDbid | Primary conf server
EnterpriseModeTenantDbid | Tenant in single tenant environment
EnvironmentDbid | Environment tenant
EnvironmentSupervisorDbid | Default user
EveryoneDbid | Everyone account
SystemDbid | System account

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


WellKnownDbids Constructor

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids Constructor
WellKnownDbids Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.WellKnownDbids.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public WellKnownDbids()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WellKnownDbids()

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


WellKnownDbids Fields

[image] [image]

Enterprise SDK 8.0 Reference API
WellKnownDbids Fields
WellKnownDbids Class See Also Send Feedback

The WellKnownDbids type exposes the following members.

Fields

Name | Description
ConfManagerAppPrototypeDbid | Config manager application template
ConfManagerDbid | DBID of config manager app
ConfServerAppPrototypeDbid | Conf server app template
ConfServerDbid | Primary conf server
EnterpriseModeTenantDbid | Tenant in single tenant environment
EnvironmentDbid | Environment tenant
EnvironmentSupervisorDbid | Default user
EveryoneDbid | Everyone account
SystemDbid | System account

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfManagerAppPrototypeDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.ConfManagerAppPrototypeDbid Field
WellKnownDbids Class See Also Send Feedback
Config manager application template

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int ConfManagerAppPrototypeDbid
Visual Basic (Declaration)
Public Const ConfManagerAppPrototypeDbid As Integer
Visual C++
public:
literal int ConfManagerAppPrototypeDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfManagerDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.ConfManagerDbid Field
WellKnownDbids Class See Also Send Feedback
DBID of config manager app

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int ConfManagerDbid
Visual Basic (Declaration)
Public Const ConfManagerDbid As Integer
Visual C++
public:
literal int ConfManagerDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfServerAppPrototypeDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.ConfServerAppPrototypeDbid Field
WellKnownDbids Class See Also Send Feedback
Conf server app template

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int ConfServerAppPrototypeDbid
Visual Basic (Declaration)
Public Const ConfServerAppPrototypeDbid As Integer
Visual C++
public:
literal int ConfServerAppPrototypeDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


ConfServerDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.ConfServerDbid Field
WellKnownDbids Class See Also Send Feedback
Primary conf server

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int ConfServerDbid
Visual Basic (Declaration)
Public Const ConfServerDbid As Integer
Visual C++
public:
literal int ConfServerDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


EnterpriseModeTenantDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.EnterpriseModeTenantDbid Field
WellKnownDbids Class See Also Send Feedback
Tenant in single tenant environment

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int EnterpriseModeTenantDbid
Visual Basic (Declaration)
Public Const EnterpriseModeTenantDbid As Integer
Visual C++
public:
literal int EnterpriseModeTenantDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


EnvironmentDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.EnvironmentDbid Field
WellKnownDbids Class See Also Send Feedback
Environment tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int EnvironmentDbid
Visual Basic (Declaration)
Public Const EnvironmentDbid As Integer
Visual C++
public:
literal int EnvironmentDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


EnvironmentSupervisorDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.EnvironmentSupervisorDbid Field
WellKnownDbids Class See Also Send Feedback
Default user

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int EnvironmentSupervisorDbid
Visual Basic (Declaration)
Public Const EnvironmentSupervisorDbid As Integer
Visual C++
public:
literal int EnvironmentSupervisorDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


EveryoneDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.EveryoneDbid Field
WellKnownDbids Class See Also Send Feedback
Everyone account

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int EveryoneDbid
Visual Basic (Declaration)
Public Const EveryoneDbid As Integer
Visual C++
public:
literal int EveryoneDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


SystemDbid Field

[image]

Enterprise SDK 8.0 Reference API
WellKnownDbids..::.SystemDbid Field
WellKnownDbids Class See Also Send Feedback
System account

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const int SystemDbid
Visual Basic (Declaration)
Public Const SystemDbid As Integer
Visual C++
public:
literal int SystemDbid

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


WellKnownDbids Methods

[image] [image]

Enterprise SDK 8.0 Reference API
WellKnownDbids Methods
WellKnownDbids Class See Also Send Feedback

The WellKnownDbids type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WellKnownDbids Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


XmlAccessConstants Class

[image]

Enterprise SDK 8.0 Reference API
XmlAccessConstants Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.XmlAccessConstants"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class XmlAccessConstants
Visual Basic (Declaration)
Public Class XmlAccessConstants
Visual C++
public ref class XmlAccessConstants

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel..::.XmlAccessConstants

See Also

XmlAccessConstants Members
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


XmlAccessConstants Members

[image] [image]

Enterprise SDK 8.0 Reference API
XmlAccessConstants Members
XmlAccessConstants Class Methods Fields See Also Send Feedback

The XmlAccessConstants type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
valueXmlName |

See Also

XmlAccessConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


XmlAccessConstants Fields

[image] [image]

Enterprise SDK 8.0 Reference API
XmlAccessConstants Fields
XmlAccessConstants Class See Also Send Feedback

The XmlAccessConstants type exposes the following members.

Fields

Name | Description
valueXmlName |

See Also

XmlAccessConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


valueXmlName Field

[image]

Enterprise SDK 8.0 Reference API
XmlAccessConstants..::.valueXmlName Field
XmlAccessConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.XmlAccessConstants.valueXmlName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string valueXmlName
Visual Basic (Declaration)
Public Const valueXmlName As String
Visual C++
public:
literal String^ valueXmlName

See Also

XmlAccessConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


XmlAccessConstants Methods

[image] [image]

Enterprise SDK 8.0 Reference API
XmlAccessConstants Methods
XmlAccessConstants Class See Also Send Feedback

The XmlAccessConstants type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlAccessConstants Class
Genesyslab.Enterprise.ConfigurationObjectModel Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace
Send Feedback

Classes

Class | Description
CompositeConfCacheQueryEngine | An implementation of the query engine interface which allows for new query interpretation modules to be added at run time.
ConfCacheEvent | Represents a notification event from the cache.
ConfCacheFilter | A filter for ConfCacheEvents. Note that the filter properties are evaluated using the "and" operator. For example, if ObjectDbid and ObjectType are set, events regarding objects with the specified dbid AND the specified type will be sent to the subscriber.
DefaultConfCache | The default implementation of the configuration cache interface.
DefaultConfCachePolicy | The default configuration cache policy.
DefaultConfCacheQueryEngine | The default query engine implementation.
DefaultConfCacheStorage | The default implementation of the configuration cache storage.

Interfaces

Interface | Description
IConfCache | Interface for the configuration object cache.
IConfCachePolicy | The interface to be implemented when defining a cache policy.
IConfCacheQueryEngine | An interface defining a cache query engine contract.
IConfCacheStorage | An interface which defines the contract for a configuration cache storage module.

Enumerations

Enumeration | Description
ConfCacheUpdateType | Describes the types of cache update events fired by the cache.


CompositeConfCacheQueryEngine Class

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine Class
Members See Also Send Feedback
An implementation of the query engine interface which allows for new query interpretation modules to be added at run time.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class CompositeConfCacheQueryEngine : IConfCacheQueryEngine
Visual Basic (Declaration)
Public NotInheritable Class CompositeConfCacheQueryEngine _
    Implements IConfCacheQueryEngine
Visual C++
public ref class CompositeConfCacheQueryEngine sealed : IConfCacheQueryEngine

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.CompositeConfCacheQueryEngine

See Also

CompositeConfCacheQueryEngine Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CompositeConfCacheQueryEngine Members

[image] [image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine Members
CompositeConfCacheQueryEngine Class Constructors Methods See Also Send Feedback

The CompositeConfCacheQueryEngine type exposes the following members.

Constructors

Name | Description
CompositeConfCacheQueryEngine |

Methods

Name | Description
CanExecute | Looks for a query engine in its list which is capable of executing the specified query.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Register | Registers a query engine module.
RetrieveMultipleObjects<(Of <(T>)>) | Looks for a query engine which is capable of executing the specified query, and if found, uses it to retrieve a list of objects based on that query.
RetrieveObject | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Unregisters a query engine module.

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CompositeConfCacheQueryEngine Constructor

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine Constructor
CompositeConfCacheQueryEngine Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.CompositeConfCacheQueryEngine.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CompositeConfCacheQueryEngine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompositeConfCacheQueryEngine()

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CompositeConfCacheQueryEngine Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine Methods
CompositeConfCacheQueryEngine Class See Also Send Feedback

The CompositeConfCacheQueryEngine type exposes the following members.

Methods

Name | Description
CanExecute | Looks for a query engine in its list which is capable of executing the specified query.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Register | Registers a query engine module.
RetrieveMultipleObjects<(Of <(T>)>) | Looks for a query engine which is capable of executing the specified query, and if found, uses it to retrieve a list of objects based on that query.
RetrieveObject | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Unregisters a query engine module.

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CanExecute Method

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.CanExecute Method
CompositeConfCacheQueryEngine Class See Also Send Feedback
Looks for a query engine in its list which is capable of executing the specified query.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool CanExecute(
    ICfgQuery query
)
Visual Basic (Declaration)
Public Function CanExecute ( _
    query As ICfgQuery _
) As Boolean
Visual C++
public:
virtual bool CanExecute(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
the query to execute

Return Value

true if a capable query engine is found, false otherwise

Implements

IConfCacheQueryEngine..::.CanExecute(ICfgQuery)

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Register Method

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.Register Method
CompositeConfCacheQueryEngine Class See Also Send Feedback
Registers a query engine module.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    IConfCacheQueryEngine queryEngine
)
Visual Basic (Declaration)
Public Sub Register ( _
    queryEngine As IConfCacheQueryEngine _
)
Visual C++
public:
void Register(
    IConfCacheQueryEngine^ queryEngine
)

Parameters

queryEngine
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.IConfCacheQueryEngine

[Missing <param name="queryEngine"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.CompositeConfCacheQueryEngine.Register(Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCacheQueryEngine)"]

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultipleObjects(T) Method

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.RetrieveMultipleObjects<(Of <(T>)>) Method
CompositeConfCacheQueryEngine Class See Also Send Feedback
Looks for a query engine which is capable of executing the specified query, and if found, uses it to retrieve a list of objects based on that query.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<T> RetrieveMultipleObjects<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveMultipleObjects(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As ICollection(Of T)
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual ICollection<T>^ RetrieveMultipleObjects(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
The query to execute

Type Parameters

T
The type of objet to retrieve

Return Value

A list of objects matching the passed query

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if no query engine available to execute the query.

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.RetrieveObject Method
CompositeConfCacheQueryEngine Class See Also Send Feedback

Overload List

Name | Description
RetrieveObject<(Of <(T>)>)(ICfgQuery) | Looks for a query engine which is capable of executing the specified query, and if found, uses it to retrieve an object based on that query.
RetrieveObject<(Of <(T>)>)(CfgObjectType, Int32) | Looks for a query engine which returns a result using the parameters passed. Returns the first obtained result.

See Also

CompositeConfCacheQueryEngine Class
CompositeConfCacheQueryEngine Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.RetrieveObject<(Of <(T>)>) Method ()
CompositeConfCacheQueryEngine Class See Also Send Feedback
Looks for a query engine which is capable of executing the specified query, and if found, uses it to retrieve an object based on that query.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public T RetrieveObject<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveObject(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As T
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual T RetrieveObject(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
The query to execute

Type Parameters

T
The type of objet to retrieve

Return Value

An object matching the passed query

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown if no query engine available to execute the query.

See Also

CompositeConfCacheQueryEngine Class
RetrieveObject Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject(T) Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.RetrieveObject<(Of <(T>)>) Method (CfgObjectType, Int32)
CompositeConfCacheQueryEngine Class See Also Send Feedback
Looks for a query engine which returns a result using the parameters passed. Returns the first obtained result.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public T RetrieveObject<T>(
    CfgObjectType type,
    int dbid
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveObject(Of T As ICfgObject) ( _
    type As CfgObjectType, _
    dbid As Integer _
) As T
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual T RetrieveObject(
    CfgObjectType type,
    int dbid
) sealed

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of object (CfgObjectType)
dbid
Type: System..::.Int32
The dbid of the object

Type Parameters

T
The type of objet to retrieve

Return Value

A configuration object with the requested dbid and type

See Also

CompositeConfCacheQueryEngine Class
RetrieveObject Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Unregister Method

[image]

Enterprise SDK 8.0 Reference API
CompositeConfCacheQueryEngine..::.Unregister Method
CompositeConfCacheQueryEngine Class See Also Send Feedback
Unregisters a query engine module.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    IConfCacheQueryEngine queryEngine
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    queryEngine As IConfCacheQueryEngine _
)
Visual C++
public:
void Unregister(
    IConfCacheQueryEngine^ queryEngine
)

Parameters

queryEngine
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.IConfCacheQueryEngine

[Missing <param name="queryEngine"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.CompositeConfCacheQueryEngine.Unregister(Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCacheQueryEngine)"]

See Also

CompositeConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheEvent Class

[image]

Enterprise SDK 8.0 Reference API
ConfCacheEvent Class
Members See Also Send Feedback
Represents a notification event from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class ConfCacheEvent
Visual Basic (Declaration)
Public NotInheritable Class ConfCacheEvent
Visual C++
public ref class ConfCacheEvent sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.ConfCacheEvent

See Also

ConfCacheEvent Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfCacheEvent Members
ConfCacheEvent Class Methods Properties See Also Send Feedback

The ConfCacheEvent type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConfObject | The configuration object affected by the cache update.
UpdateType | The type of update performed on the cache.

See Also

ConfCacheEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfCacheEvent Methods
ConfCacheEvent Class See Also Send Feedback

The ConfCacheEvent type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfCacheEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfCacheEvent Properties
ConfCacheEvent Class See Also Send Feedback

The ConfCacheEvent type exposes the following members.

Properties

Name | Description
ConfObject | The configuration object affected by the cache update.
UpdateType | The type of update performed on the cache.

See Also

ConfCacheEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfObject Property

[image]

Enterprise SDK 8.0 Reference API
ConfCacheEvent..::.ConfObject Property
ConfCacheEvent Class See Also Send Feedback
The configuration object affected by the cache update.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICfgObject ConfObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConfObject As ICfgObject
Visual C++
public:
property ICfgObject^ ConfObject {
    ICfgObject^ get ();
}

See Also

ConfCacheEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


UpdateType Property

[image]

Enterprise SDK 8.0 Reference API
ConfCacheEvent..::.UpdateType Property
ConfCacheEvent Class See Also Send Feedback
The type of update performed on the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfCacheUpdateType UpdateType { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpdateType As ConfCacheUpdateType
Visual C++
public:
property ConfCacheUpdateType UpdateType {
    ConfCacheUpdateType get ();
}

See Also

ConfCacheEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheFilter Class

[image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter Class
Members See Also Send Feedback
A filter for ConfCacheEvents. Note that the filter properties are evaluated using the "and" operator. For example, if ObjectDbid and ObjectType are set, events regarding objects with the specified dbid AND the specified type will be sent to the subscriber.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class ConfCacheFilter : IPredicate<ConfCacheEvent>
Visual Basic (Declaration)
Public NotInheritable Class ConfCacheFilter _
    Implements IPredicate(Of ConfCacheEvent)
Visual C++
public ref class ConfCacheFilter sealed : IPredicate<ConfCacheEvent^>

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.ConfCacheFilter

See Also

ConfCacheFilter Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter Members
ConfCacheFilter Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ConfCacheFilter type exposes the following members.

Constructors

Name | Description
ConfCacheFilter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ObjectDbid | The dbid of the object regarding which events are to be sent to the subscriber.
ObjectType | The type of object regarding which events are to be sent to the subscriber.
UpdateType | The type of update regarding which events are to be sent to the subscriber.

Explicit Interface Implementations

Name | Description
IPredicate<(Of <(ConfCacheEvent>)>)..::.Invoke |

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheFilter Constructor

[image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter Constructor
ConfCacheFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheFilter.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfCacheFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfCacheFilter()

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter Methods
ConfCacheFilter Class See Also Send Feedback

The ConfCacheFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IPredicate<(Of <(ConfCacheEvent>)>)..::.Invoke |

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


(ConfCacheEvent). Method

[image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter..::.<(Of <(ConfCacheEvent>)>)..::. Method
ConfCacheFilter Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheFilter.Genesyslab#Platform#ApplicationBlocks#Commons#IPredicate{T}#Invoke(Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheEvent)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IPredicate<ConfCacheEvent>.Invoke(
    ConfCacheEvent cacheEvent
)
Visual Basic (Declaration)
Private Function Invoke ( _
    cacheEvent As ConfCacheEvent _
) As Boolean Implements IPredicate(Of ConfCacheEvent).Invoke
Visual C++
private:
virtual bool Invoke(
    ConfCacheEvent^ cacheEvent
) sealed = IPredicate<ConfCacheEvent^>::Invoke

Parameters

cacheEvent
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.ConfCacheEvent

[Missing <param name="cacheEvent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheFilter.Genesyslab#Platform#ApplicationBlocks#Commons#IPredicate{T}#Invoke(Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheEvent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheFilter.Genesyslab#Platform#ApplicationBlocks#Commons#IPredicate{T}#Invoke(Genesyslab.Enterprise.ConfigurationObjectModel.Cache.ConfCacheEvent)"]

Implements

IPredicateInvoke(UTP)

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheFilter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter Properties
ConfCacheFilter Class See Also Send Feedback

The ConfCacheFilter type exposes the following members.

Properties

Name | Description
ObjectDbid | The dbid of the object regarding which events are to be sent to the subscriber.
ObjectType | The type of object regarding which events are to be sent to the subscriber.
UpdateType | The type of update regarding which events are to be sent to the subscriber.

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter..::.ObjectDbid Property
ConfCacheFilter Class See Also Send Feedback
The dbid of the object regarding which events are to be sent to the subscriber.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDbid { get; set; }
Visual Basic (Declaration)
Public Property ObjectDbid As Integer
Visual C++
public:
property int ObjectDbid {
    int get ();
    void set (int value);
}

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter..::.ObjectType Property
ConfCacheFilter Class See Also Send Feedback
The type of object regarding which events are to be sent to the subscriber.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


UpdateType Property

[image]

Enterprise SDK 8.0 Reference API
ConfCacheFilter..::.UpdateType Property
ConfCacheFilter Class See Also Send Feedback
The type of update regarding which events are to be sent to the subscriber.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfCacheUpdateType UpdateType { get; set; }
Visual Basic (Declaration)
Public Property UpdateType As ConfCacheUpdateType
Visual C++
public:
property ConfCacheUpdateType UpdateType {
    ConfCacheUpdateType get ();
    void set (ConfCacheUpdateType value);
}

See Also

ConfCacheFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ConfCacheUpdateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ConfCacheUpdateType Enumeration
See Also Send Feedback
Describes the types of cache update events fired by the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ConfCacheUpdateType
Visual Basic (Declaration)
Public Enumeration ConfCacheUpdateType
Visual C++
public enum class ConfCacheUpdateType

Members

Member name | Description
Unspecified | Update type unspecified
ObjectAdded | An object has been added to the cache
ObjectRemoved | An object has been removed from the cache
ObjectUpdated | A previously cached object has been updated.

See Also

Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Class

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Class
Members See Also Send Feedback
The default implementation of the configuration cache interface.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class DefaultConfCache : IConfCache,
    ISubscriber<ConfEvent>, ISubscriptionService<ConfCacheEvent>, IDisposable
Visual Basic (Declaration)
Public NotInheritable Class DefaultConfCache _
    Implements IConfCache, ISubscriber(Of ConfEvent),  _
    ISubscriptionService(Of ConfCacheEvent), IDisposable
Visual C++
public ref class DefaultConfCache sealed : IConfCache,
    ISubscriber<ConfEvent^>, ISubscriptionService<ConfCacheEvent^>, IDisposable

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.DefaultConfCache

See Also

DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Members

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Members
DefaultConfCache Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The DefaultConfCache type exposes the following members.

Constructors

Name | Description
DefaultConfCache | Overloaded.

Methods

Name | Description
Add | Adds a new configuration object to the cache.
AddEndpoint | Adds a supported endpoint to the list. By default, the endpoint of the configuration service with which this cache is initially associated is added. This method should be used to add any other endpoints at which the objects in this cache are valid -- for instance the endpoint of a backup configuration server or a proxy. Note that ALL objects in the cache are assumed to be valid at ALL endpoints. This means that adding unrelated configuration servers to the list is unsupported and will result in undefined behavior.
BeginRefresh | Asynchronously updates all configuration objects in the cache.
Clear | Removes all cache contents.
Contains | Determines whether the cache contains the specified object.
Deserialize | Deserializes the cache from the specified stream.
Dispose | Releases cache resources.
EndRefresh | To be called when the asynchronous refresh operation is complete. If called before the refresh operation completes, this method will block until completion.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Refresh | Synchronously updates all configuration objects which are currently in the cache.
Register | Overloaded.
Remove | Overloaded.
Retrieve | Overloaded.
RetrieveMultiple | Overloaded.
Serialize | Serializes the cache into the specified stream.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.
Update | Overwrites a configuration object which already exists in the cache with a new copy.

Properties

Name | Description
Policy | Returns the current policy associated with this cache.

Explicit Interface Implementations

Name | Description
ISubscriber<(Of <(ConfEvent>)>)..::.Filter |
ISubscriber<(Of <(ConfEvent>)>)..::.Handle |

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Constructor
DefaultConfCache Class See Also Send Feedback

Overload List

Name | Description
DefaultConfCache(IConfigurationService, IClientChannel) | Creates a cache which will use the default policy, storage and query engine.
DefaultConfCache(IConfigurationService, IClientChannel, IConfCachePolicy, IConfCacheStorage, IConfCacheQueryEngine) | Creates a new instance of the configuration cache.

See Also

DefaultConfCache Class
DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Constructor (, IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Constructor (, IClientChannel)
DefaultConfCache Class See Also Send Feedback
Creates a cache which will use the default policy, storage and query engine.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DefaultConfCache(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
DefaultConfCache(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

DefaultConfCache Class
DefaultConfCache Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Constructor (, IClientChannel, IConfCachePolicy, IConfCacheStorage, IConfCacheQueryEngine)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Constructor (, IClientChannel, IConfCachePolicy, IConfCacheStorage, IConfCacheQueryEngine)
DefaultConfCache Class See Also Send Feedback
Creates a new instance of the configuration cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DefaultConfCache(
    IConfigurationService confService,
    IClientChannel channel,
    IConfCachePolicy policy,
    IConfCacheStorage storage,
    IConfCacheQueryEngine queryEngine
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    policy As IConfCachePolicy, _
    storage As IConfCacheStorage, _
    queryEngine As IConfCacheQueryEngine _
)
Visual C++
public:
DefaultConfCache(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    IConfCachePolicy^ policy,
    IConfCacheStorage^ storage,
    IConfCacheQueryEngine^ queryEngine
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCachePolicy,Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCacheStorage,Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCacheQueryEngine)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCachePolicy,Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCacheStorage,Genesyslab.Enterprise.ConfigurationObjectModel.Cache.IConfCacheQueryEngine)"]

policy
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.IConfCachePolicy
The cache policy
storage
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.IConfCacheStorage
The storage to be used in this cache
queryEngine
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.IConfCacheQueryEngine
The query engine to be used to retrieve data from the storage

See Also

DefaultConfCache Class
DefaultConfCache Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Methods
DefaultConfCache Class See Also Send Feedback

The DefaultConfCache type exposes the following members.

Methods

Name | Description
Add | Adds a new configuration object to the cache.
AddEndpoint | Adds a supported endpoint to the list. By default, the endpoint of the configuration service with which this cache is initially associated is added. This method should be used to add any other endpoints at which the objects in this cache are valid -- for instance the endpoint of a backup configuration server or a proxy. Note that ALL objects in the cache are assumed to be valid at ALL endpoints. This means that adding unrelated configuration servers to the list is unsupported and will result in undefined behavior.
BeginRefresh | Asynchronously updates all configuration objects in the cache.
Clear | Removes all cache contents.
Contains | Determines whether the cache contains the specified object.
Deserialize | Deserializes the cache from the specified stream.
Dispose | Releases cache resources.
EndRefresh | To be called when the asynchronous refresh operation is complete. If called before the refresh operation completes, this method will block until completion.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Refresh | Synchronously updates all configuration objects which are currently in the cache.
Register | Overloaded.
Remove | Overloaded.
Retrieve | Overloaded.
RetrieveMultiple | Overloaded.
Serialize | Serializes the cache into the specified stream.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.
Update | Overwrites a configuration object which already exists in the cache with a new copy.

Explicit Interface Implementations

Name | Description
ISubscriber<(Of <(ConfEvent>)>)..::.Handle |

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


(ConfEvent). Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.<(Of <(ConfEvent>)>)..::. Method
DefaultConfCache Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.Genesyslab#Platform#ApplicationBlocks#Commons#Broker#ISubscriber{T}#Handle(Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ISubscriber<ConfEvent>.Handle(
    ConfEvent configEvent
)
Visual Basic (Declaration)
Private Sub Handle ( _
    configEvent As ConfEvent _
) Implements ISubscriber(Of ConfEvent).Handle
Visual C++
private:
virtual void Handle(
    ConfEvent^ configEvent
) sealed = ISubscriber<ConfEvent^>::Handle

Parameters

configEvent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEvent

[Missing <param name="configEvent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.Genesyslab#Platform#ApplicationBlocks#Commons#Broker#ISubscriber{T}#Handle(Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent)"]

Implements

ISubscriberHandle(UTP)

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Add Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Add Method
DefaultConfCache Class See Also Send Feedback
Adds a new configuration object to the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Sub Add ( _
    obj As ICfgObject _
)
Visual C++
public:
virtual void Add(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
A configuration object

Implements

IConfCache..::.Add(ICfgObject)

Remarks

An "ObjectAdded" cache event is fired upon the successful completion of this operation.

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


AddEndpoint Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.AddEndpoint Method
DefaultConfCache Class See Also Send Feedback
Adds a supported endpoint to the list. By default, the endpoint of the configuration service with which this cache is initially associated is added. This method should be used to add any other endpoints at which the objects in this cache are valid -- for instance the endpoint of a backup configuration server or a proxy. Note that ALL objects in the cache are assumed to be valid at ALL endpoints. This means that adding unrelated configuration servers to the list is unsupported and will result in undefined behavior.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void AddEndpoint(
    Endpoint endpoint
)
Visual Basic (Declaration)
Public Sub AddEndpoint ( _
    endpoint As Endpoint _
)
Visual C++
public:
void AddEndpoint(
    Endpoint^ endpoint
)

Parameters

endpoint
Type: Endpoint
The endpoint of a configuration server

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


BeginRefresh Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.BeginRefresh Method
DefaultConfCache Class See Also Send Feedback
Asynchronously updates all configuration objects in the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAsyncResult BeginRefresh(
    AsyncCallback callback
)
Visual Basic (Declaration)
Public Function BeginRefresh ( _
    callback As AsyncCallback _
) As IAsyncResult
Visual C++
public:
virtual IAsyncResult^ BeginRefresh(
    AsyncCallback^ callback
) sealed

Parameters

callback
Type: System..::.AsyncCallback
The callback method to be invoked when the operation completes.

Return Value

The async result associated with this operation.

Implements

IConfCache..::.BeginRefresh(AsyncCallback)

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Clear Method
DefaultConfCache Class See Also Send Feedback
Removes all cache contents.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

IConfCache..::.Clear()()()

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Contains Method
DefaultConfCache Class See Also Send Feedback
Determines whether the cache contains the specified object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Contains(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function Contains ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object to look for

Return Value

true if the object is in the cache, false otherwise

Implements

IConfCache..::.Contains(ICfgObject)

Remarks

For the purposes of this method, two objects are considered equal if they have the same dbid and type.

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Deserialize Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Deserialize Method
DefaultConfCache Class See Also Send Feedback
Deserializes the cache from the specified stream.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Deserialize(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Deserialize ( _
    stream As Stream _
)
Visual C++
public:
virtual void Deserialize(
    Stream^ stream
) sealed

Parameters

stream
Type: System.IO..::.Stream
The stream from which the cache is to be read

Implements

IConfCache..::.Deserialize(Stream)

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Dispose Method
DefaultConfCache Class See Also Send Feedback
Releases cache resources.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


EndRefresh Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.EndRefresh Method
DefaultConfCache Class See Also Send Feedback
To be called when the asynchronous refresh operation is complete. If called before the refresh operation completes, this method will block until completion.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void EndRefresh(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Public Sub EndRefresh ( _
    asyncResult As IAsyncResult _
)
Visual C++
public:
virtual void EndRefresh(
    IAsyncResult^ asyncResult
) sealed

Parameters

asyncResult
Type: System..::.IAsyncResult
The async result associated with the current operation

Implements

IConfCache..::.EndRefresh(IAsyncResult)

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Refresh Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Refresh Method
DefaultConfCache Class See Also Send Feedback
Synchronously updates all configuration objects which are currently in the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh
Visual C++
public:
virtual void Refresh() sealed

Implements

IConfCache..::.Refresh()()()

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Register Method
DefaultConfCache Class See Also Send Feedback

Overload List

Name | Description
Register(ISubscriber<(Of <(ConfCacheEvent>)>)) | Registers a subscriber object for receiving notifications from the cache.
Register(Action<(Of <(ConfCacheEvent>)>)) | Registers a delegate for receiving notifications from the cache.
Register(Action<(Of <(ConfCacheEvent>)>), IPredicate<(Of <(ConfCacheEvent>)>)) | Registers a delegate for receiving notifications from the cache based on the specified filter.

See Also

DefaultConfCache Class
DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Register Method ((ConfCacheEvent))

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Register Method (<(Of <(ConfCacheEvent>)>))
DefaultConfCache Class See Also Send Feedback
Registers a subscriber object for receiving notifications from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    ISubscriber<ConfCacheEvent> subscriber
)
Visual Basic (Declaration)
Public Sub Register ( _
    subscriber As ISubscriber(Of ConfCacheEvent) _
)
Visual C++
public:
virtual void Register(
    ISubscriber<ConfCacheEvent^>^ subscriber
) sealed

Parameters

subscriber
Type: ISubscriber<(Of <( ConfCacheEvent >)>)
the "subscriber" object which will handle the notifications

Implements

ISubscriptionServiceRegister(ISubscriber<(Of <(UTP>)>))

See Also

DefaultConfCache Class
Register Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Register Method (Action(ConfCacheEvent))

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Register Method (Action<(Of <(ConfCacheEvent>)>))
DefaultConfCache Class See Also Send Feedback
Registers a delegate for receiving notifications from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    Action<ConfCacheEvent> handler
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of ConfCacheEvent) _
)
Visual C++
public:
virtual void Register(
    Action<ConfCacheEvent^>^ handler
) sealed

Parameters

handler
Type: System..::.Action <(Of <( ConfCacheEvent >)>)
the notification delegate

Implements

ISubscriptionServiceRegister(Action<(Of <(UTP>)>))

See Also

DefaultConfCache Class
Register Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Register Method (Action(ConfCacheEvent), (ConfCacheEvent))

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Register Method (Action<(Of <(ConfCacheEvent>)>), <(Of <(ConfCacheEvent>)>))
DefaultConfCache Class See Also Send Feedback
Registers a delegate for receiving notifications from the cache based on the specified filter.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    Action<ConfCacheEvent> handler,
    IPredicate<ConfCacheEvent> filter
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of ConfCacheEvent), _
    filter As IPredicate(Of ConfCacheEvent) _
)
Visual C++
public:
virtual void Register(
    Action<ConfCacheEvent^>^ handler,
    IPredicate<ConfCacheEvent^>^ filter
) sealed

Parameters

handler
Type: System..::.Action <(Of <( ConfCacheEvent >)>)
The delegate which will handle the event
filter
Type: IPredicate<(Of <( ConfCacheEvent >)>)
A filter to apply to the event

Implements

ISubscriptionServiceRegister(Action<(Of <(UTP>)>), IPredicate<(Of <(UTP>)>))

See Also

DefaultConfCache Class
Register Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Remove Method
DefaultConfCache Class See Also Send Feedback

Overload List

Name | Description
Remove(ICfgObject) | Removes the specified configuration object from the cache.
Remove(CfgObjectType, Int32) | Removes the configuration object with the specified type and dbid from the cahe.

See Also

DefaultConfCache Class
DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method (ICfgObject)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Remove Method (ICfgObject)
DefaultConfCache Class See Also Send Feedback
Removes the specified configuration object from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Remove(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Sub Remove ( _
    obj As ICfgObject _
)
Visual C++
public:
virtual void Remove(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
A configuration object

Implements

IConfCache..::.Remove(ICfgObject)

Remarks

An "ObjectRemoved" cache event is fired upon the successful completion of this operation.

See Also

DefaultConfCache Class
Remove Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Remove Method (CfgObjectType, Int32)
DefaultConfCache Class See Also Send Feedback
Removes the configuration object with the specified type and dbid from the cahe.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Remove(
    CfgObjectType type,
    int dbid
)
Visual Basic (Declaration)
Public Sub Remove ( _
    type As CfgObjectType, _
    dbid As Integer _
)
Visual C++
public:
virtual void Remove(
    CfgObjectType type,
    int dbid
) sealed

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of configuration object
dbid
Type: System..::.Int32
The dbid of the configuration object

Implements

IConfCache..::.Remove(CfgObjectType, Int32)

Remarks

An "ObjectRemoved" cache event is fired upon the successful completion of this operation.

See Also

DefaultConfCache Class
Remove Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Retrieve Method
DefaultConfCache Class See Also Send Feedback

Overload List

Name | Description
Retrieve<(Of <(T>)>)(ICfgQuery) | Retrieves a configuration object from the cache using the cache's query engine.
Retrieve<(Of <(T>)>)(CfgObjectType, Int32) | Retrieves a configuration object from the cache using the cache's query engine.

See Also

DefaultConfCache Class
DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Retrieve<(Of <(T>)>) Method ()
DefaultConfCache Class See Also Send Feedback
Retrieves a configuration object from the cache using the cache's query engine.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public T Retrieve<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function Retrieve(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As T
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual T Retrieve(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
A query based on which the result is obtained.

Type Parameters

T
The type of configuration object that should be returned

Return Value

A configuration object matching the specified query

See Also

DefaultConfCache Class
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Retrieve<(Of <(T>)>) Method (CfgObjectType, Int32)
DefaultConfCache Class See Also Send Feedback
Retrieves a configuration object from the cache using the cache's query engine.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public T Retrieve<T>(
    CfgObjectType type,
    int dbid
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function Retrieve(Of T As ICfgObject) ( _
    type As CfgObjectType, _
    dbid As Integer _
) As T
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual T Retrieve(
    CfgObjectType type,
    int dbid
) sealed

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of configuration object
dbid
Type: System..::.Int32
The dbid of the configuration object

Type Parameters

T
The type of configuration object that should be returned

Return Value

A configuration object of the requested type

See Also

DefaultConfCache Class
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultiple Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.RetrieveMultiple Method
DefaultConfCache Class See Also Send Feedback

Overload List

Name | Description
RetrieveMultiple<(Of <(T>)>)()()() | Retrieves an enumerable list of all configuration objects in the storage.
RetrieveMultiple<(Of <(T>)>)(ICfgQuery) | Retrieves an enumerable list of objects from the cache using the cache's query engine.

See Also

DefaultConfCache Class
DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultiple(T) Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.RetrieveMultiple<(Of <(T>)>) Method
DefaultConfCache Class See Also Send Feedback
Retrieves an enumerable list of all configuration objects in the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<T> RetrieveMultiple<T>()
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveMultiple(Of T As ICfgObject) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual IEnumerable<T>^ RetrieveMultiple() sealed

Type Parameters

T
The type of configuration object to include (use ICfgObject to retrieve an enumeration of all stored objects)

Return Value

An enumerable list of configuration objects

Remarks

Unlike the other Get methods this method does not use the query engine. Instead, all cached objects are returned, filtered by the T parameter.

See Also

DefaultConfCache Class
RetrieveMultiple Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultiple(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.RetrieveMultiple<(Of <(T>)>) Method ()
DefaultConfCache Class See Also Send Feedback
Retrieves an enumerable list of objects from the cache using the cache's query engine.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<T> RetrieveMultiple<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveMultiple(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual IEnumerable<T>^ RetrieveMultiple(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
A query based on which the result is obtained.

Type Parameters

T
The types of configuration objects to be included in the list.

Return Value

An enumerable list of configuration objects matching the specified query

See Also

DefaultConfCache Class
RetrieveMultiple Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Serialize Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Serialize Method
DefaultConfCache Class See Also Send Feedback
Serializes the cache into the specified stream.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Serialize(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    stream As Stream _
)
Visual C++
public:
virtual void Serialize(
    Stream^ stream
) sealed

Parameters

stream
Type: System.IO..::.Stream
The stream into which the cache is to be written

Implements

IConfCache..::.Serialize(Stream)

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Unregister Method
DefaultConfCache Class See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscriber<(Of <(ConfCacheEvent>)>)) | Unregisters the subscriber from event notifications
Unregister(Action<(Of <(ConfCacheEvent>)>)) | Unregisters the specified delegate from notifications

See Also

DefaultConfCache Class
DefaultConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Unregister Method ((ConfCacheEvent))

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Unregister Method (<(Of <(ConfCacheEvent>)>))
DefaultConfCache Class See Also Send Feedback
Unregisters the subscriber from event notifications

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    ISubscriber<ConfCacheEvent> subscriber
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    subscriber As ISubscriber(Of ConfCacheEvent) _
)
Visual C++
public:
virtual void Unregister(
    ISubscriber<ConfCacheEvent^>^ subscriber
) sealed

Parameters

subscriber
Type: ISubscriber<(Of <( ConfCacheEvent >)>)
the subscriber to unregister

Implements

ISubscriptionServiceUnregister(ISubscriber<(Of <(UTP>)>))

See Also

DefaultConfCache Class
Unregister Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Unregister Method (Action(ConfCacheEvent))

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Unregister Method (Action<(Of <(ConfCacheEvent>)>))
DefaultConfCache Class See Also Send Feedback
Unregisters the specified delegate from notifications

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    Action<ConfCacheEvent> handler
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    handler As Action(Of ConfCacheEvent) _
)
Visual C++
public:
virtual void Unregister(
    Action<ConfCacheEvent^>^ handler
) sealed

Parameters

handler
Type: System..::.Action <(Of <( ConfCacheEvent >)>)
the function to unregister

Implements

ISubscriptionServiceUnregister(Action<(Of <(UTP>)>))

See Also

DefaultConfCache Class
Unregister Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Update Method
DefaultConfCache Class See Also Send Feedback
Overwrites a configuration object which already exists in the cache with a new copy.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Update(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Sub Update ( _
    obj As ICfgObject _
)
Visual C++
public:
virtual void Update(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
A configuration object

Implements

IConfCache..::.Update(ICfgObject)

Remarks

An "ObjectUpdated" cache event is fired upon the successful completion of this operation.

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCache Properties

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCache Properties
DefaultConfCache Class See Also Send Feedback

The DefaultConfCache type exposes the following members.

Properties

Name | Description
Policy | Returns the current policy associated with this cache.

Explicit Interface Implementations

Name | Description
ISubscriber<(Of <(ConfEvent>)>)..::.Filter |

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


(ConfEvent). Property

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.<(Of <(ConfEvent>)>)..::. Property
DefaultConfCache Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCache.Genesyslab#Platform#ApplicationBlocks#Commons#Broker#ISubscriber{T}#Filter"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IPredicate<ConfEvent> ISubscriber<ConfEvent>.Filter { get; }
Visual Basic (Declaration)
Private ReadOnly Property Filter As IPredicate(Of ConfEvent)
    Implements ISubscriber(Of ConfEvent).Filter
Visual C++
private:
virtual property IPredicate<ConfEvent^>^ Filter {
    IPredicate<ConfEvent^>^ get () sealed = ISubscriber<ConfEvent^>::Filter::get;
}

Implements

ISubscriberFilter()()()

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Policy Property

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCache..::.Policy Property
DefaultConfCache Class See Also Send Feedback
Returns the current policy associated with this cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IConfCachePolicy Policy { get; set; }
Visual Basic (Declaration)
Public Property Policy As IConfCachePolicy
Visual C++
public:
virtual property IConfCachePolicy^ Policy {
    IConfCachePolicy^ get () sealed;
    void set (IConfCachePolicy^ value) sealed;
}

Implements

IConfCache..::.Policy

See Also

DefaultConfCache Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCachePolicy Class

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy Class
Members See Also Send Feedback
The default configuration cache policy.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class DefaultConfCachePolicy : IConfCachePolicy
Visual Basic (Declaration)
Public NotInheritable Class DefaultConfCachePolicy _
    Implements IConfCachePolicy
Visual C++
public ref class DefaultConfCachePolicy sealed : IConfCachePolicy

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.DefaultConfCachePolicy

See Also

DefaultConfCachePolicy Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCachePolicy Members

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy Members
DefaultConfCachePolicy Class Constructors Methods Properties See Also Send Feedback

The DefaultConfCachePolicy type exposes the following members.

Constructors

Name | Description
DefaultConfCachePolicy |

Methods

Name | Description
CacheOnCreate | Determines if the passed object should be stored in the cache upon receiving notification of its creation in the configuration server.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveOnDelete | Determines if the passed object should be deleted from the cache if it is deleted from the configuration server.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackUpdates | Determines if the passed object's state should be synchronized with the configuration server upon receiving an update.

Properties

Name | Description
ReturnCopies | Specifies whether the cache should return copies of stored objects or the objects themselves. This property returns "false" by default.

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCachePolicy Constructor

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy Constructor
DefaultConfCachePolicy Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCachePolicy.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DefaultConfCachePolicy()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefaultConfCachePolicy()

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCachePolicy Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy Methods
DefaultConfCachePolicy Class See Also Send Feedback

The DefaultConfCachePolicy type exposes the following members.

Methods

Name | Description
CacheOnCreate | Determines if the passed object should be stored in the cache upon receiving notification of its creation in the configuration server.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveOnDelete | Determines if the passed object should be deleted from the cache if it is deleted from the configuration server.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackUpdates | Determines if the passed object's state should be synchronized with the configuration server upon receiving an update.

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CacheOnCreate Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy..::.CacheOnCreate Method
DefaultConfCachePolicy Class See Also Send Feedback
Determines if the passed object should be stored in the cache upon receiving notification of its creation in the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool CacheOnCreate(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function CacheOnCreate ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool CacheOnCreate(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
This parameter is ignored

Return Value

false for all objects

Implements

IConfCachePolicy..::.CacheOnCreate(ICfgObject)

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RemoveOnDelete Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy..::.RemoveOnDelete Method
DefaultConfCachePolicy Class See Also Send Feedback
Determines if the passed object should be deleted from the cache if it is deleted from the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool RemoveOnDelete(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function RemoveOnDelete ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool RemoveOnDelete(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
This parameter is ignored

Return Value

true for all objects

Implements

IConfCachePolicy..::.RemoveOnDelete(ICfgObject)

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


TrackUpdates Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy..::.TrackUpdates Method
DefaultConfCachePolicy Class See Also Send Feedback
Determines if the passed object's state should be synchronized with the configuration server upon receiving an update.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool TrackUpdates(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function TrackUpdates ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool TrackUpdates(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
This parameter is ignored

Return Value

true for all objects

Implements

IConfCachePolicy..::.TrackUpdates(ICfgObject)

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCachePolicy Properties

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy Properties
DefaultConfCachePolicy Class See Also Send Feedback

The DefaultConfCachePolicy type exposes the following members.

Properties

Name | Description
ReturnCopies | Specifies whether the cache should return copies of stored objects or the objects themselves. This property returns "false" by default.

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ReturnCopies Property

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCachePolicy..::.ReturnCopies Property
DefaultConfCachePolicy Class See Also Send Feedback
Specifies whether the cache should return copies of stored objects or the objects themselves. This property returns "false" by default.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool ReturnCopies { get; set; }
Visual Basic (Declaration)
Public Property ReturnCopies As Boolean
Visual C++
public:
virtual property bool ReturnCopies {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IConfCachePolicy..::.ReturnCopies

See Also

DefaultConfCachePolicy Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheQueryEngine Class

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine Class
Members See Also Send Feedback
The default query engine implementation.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class DefaultConfCacheQueryEngine : IConfCacheQueryEngine
Visual Basic (Declaration)
Public NotInheritable Class DefaultConfCacheQueryEngine _
    Implements IConfCacheQueryEngine
Visual C++
public ref class DefaultConfCacheQueryEngine sealed : IConfCacheQueryEngine

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.DefaultConfCacheQueryEngine

See Also

DefaultConfCacheQueryEngine Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheQueryEngine Members

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine Members
DefaultConfCacheQueryEngine Class Constructors Methods See Also Send Feedback

The DefaultConfCacheQueryEngine type exposes the following members.

Constructors

Name | Description
DefaultConfCacheQueryEngine | Creates a new query engine which works with the specified storage.

Methods

Name | Description
CanExecute | Determines whether the query engine can execute the specified query. Currently, only queries which contain an object type and dbid parameters are supported.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RetrieveMultipleObjects<(Of <(T>)>) | This method is from IConfCacheQueryEngine interface. It is not supported by this implementation.
RetrieveObject | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheQueryEngine Constructor

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine Constructor
DefaultConfCacheQueryEngine Class See Also Send Feedback
Creates a new query engine which works with the specified storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DefaultConfCacheQueryEngine(
    IConfCacheStorage storage
)
Visual Basic (Declaration)
Public Sub New ( _
    storage As IConfCacheStorage _
)
Visual C++
public:
DefaultConfCacheQueryEngine(
    IConfCacheStorage^ storage
)

Parameters

storage
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.IConfCacheStorage
The storage which will be queried

See Also

DefaultConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheQueryEngine Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine Methods
DefaultConfCacheQueryEngine Class See Also Send Feedback

The DefaultConfCacheQueryEngine type exposes the following members.

Methods

Name | Description
CanExecute | Determines whether the query engine can execute the specified query. Currently, only queries which contain an object type and dbid parameters are supported.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RetrieveMultipleObjects<(Of <(T>)>) | This method is from IConfCacheQueryEngine interface. It is not supported by this implementation.
RetrieveObject | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CanExecute Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine..::.CanExecute Method
DefaultConfCacheQueryEngine Class See Also Send Feedback
Determines whether the query engine can execute the specified query. Currently, only queries which contain an object type and dbid parameters are supported.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool CanExecute(
    ICfgQuery query
)
Visual Basic (Declaration)
Public Function CanExecute ( _
    query As ICfgQuery _
) As Boolean
Visual C++
public:
virtual bool CanExecute(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
The query to execute

Return Value

true if the query engine can execute this query, false otherwise

Implements

IConfCacheQueryEngine..::.CanExecute(ICfgQuery)

See Also

DefaultConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultipleObjects(T) Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine..::.RetrieveMultipleObjects<(Of <(T>)>) Method
DefaultConfCacheQueryEngine Class See Also Send Feedback
This method is from IConfCacheQueryEngine interface. It is not supported by this implementation.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<T> RetrieveMultipleObjects<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveMultipleObjects(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As ICollection(Of T)
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual ICollection<T>^ RetrieveMultipleObjects(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCacheQueryEngine.RetrieveMultipleObjects``1(Genesyslab.Enterprise.ConfigurationObjectModel.Queries.ICfgQuery)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCacheQueryEngine.RetrieveMultipleObjects``1(Genesyslab.Enterprise.ConfigurationObjectModel.Queries.ICfgQuery)"]

Return Value

an empty collection

See Also

DefaultConfCacheQueryEngine Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine..::.RetrieveObject Method
DefaultConfCacheQueryEngine Class See Also Send Feedback

Overload List

Name | Description
RetrieveObject<(Of <(T>)>)(ICfgQuery) | Retrieves an object based on the specified query. Note that this implementation only supports the "dbid" and "type" query filters. All other filters are ignored.
RetrieveObject<(Of <(T>)>)(CfgObjectType, Int32) | Retrieves an object using the specified parameters.

See Also

DefaultConfCacheQueryEngine Class
DefaultConfCacheQueryEngine Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine..::.RetrieveObject<(Of <(T>)>) Method ()
DefaultConfCacheQueryEngine Class See Also Send Feedback
Retrieves an object based on the specified query. Note that this implementation only supports the "dbid" and "type" query filters. All other filters are ignored.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public T RetrieveObject<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveObject(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As T
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual T RetrieveObject(
    ICfgQuery^ query
) sealed

Parameters

query
Type: ICfgQuery
The query by which to retrieve the object

Type Parameters

T
The type of object to retrieve

Return Value

The object specified by the query or null if the object is not found

See Also

DefaultConfCacheQueryEngine Class
RetrieveObject Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject(T) Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheQueryEngine..::.RetrieveObject<(Of <(T>)>) Method (CfgObjectType, Int32)
DefaultConfCacheQueryEngine Class See Also Send Feedback
Retrieves an object using the specified parameters.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public T RetrieveObject<T>(
    CfgObjectType type,
    int dbid
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function RetrieveObject(Of T As ICfgObject) ( _
    type As CfgObjectType, _
    dbid As Integer _
) As T
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual T RetrieveObject(
    CfgObjectType type,
    int dbid
) sealed

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of object (CfgObjectType)
dbid
Type: System..::.Int32
The dbid of the object

Type Parameters

T
The type of object to retrieve

Return Value

A configuration object with the requested dbid and type or null if the object is not found

See Also

DefaultConfCacheQueryEngine Class
RetrieveObject Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheStorage Class

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage Class
Members See Also Send Feedback
The default implementation of the configuration cache storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class DefaultConfCacheStorage : IConfCacheStorage,
    IDisposable
Visual Basic (Declaration)
Public NotInheritable Class DefaultConfCacheStorage _
    Implements IConfCacheStorage, IDisposable
Visual C++
public ref class DefaultConfCacheStorage sealed : IConfCacheStorage,
    IDisposable

Remarks

This storage implementation is thread safe.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Cache..::.DefaultConfCacheStorage

See Also

DefaultConfCacheStorage Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheStorage Members

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage Members
DefaultConfCacheStorage Class Constructors Methods See Also Send Feedback

The DefaultConfCacheStorage type exposes the following members.

Constructors

Name | Description
DefaultConfCacheStorage |

Methods

Name | Description
Add | Adds the specified object into the cache.
Clear | Removes all items in storage.
Dispose | Releases the resources associated with the storage.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Remove | Removes the specified configuration object from the storage.
Retrieve | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update | Updates an existing configuration object in the storage with the passed copy.

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheStorage Constructor

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage Constructor
DefaultConfCacheStorage Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCacheStorage.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DefaultConfCacheStorage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefaultConfCacheStorage()

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


DefaultConfCacheStorage Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage Methods
DefaultConfCacheStorage Class See Also Send Feedback

The DefaultConfCacheStorage type exposes the following members.

Methods

Name | Description
Add | Adds the specified object into the cache.
Clear | Removes all items in storage.
Dispose | Releases the resources associated with the storage.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Remove | Removes the specified configuration object from the storage.
Retrieve | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update | Updates an existing configuration object in the storage with the passed copy.

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Add Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Add Method
DefaultConfCacheStorage Class See Also Send Feedback
Adds the specified object into the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Add(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Sub Add ( _
    obj As ICfgObject _
)
Visual C++
public:
virtual void Add(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Cache.DefaultConfCacheStorage.Add(Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

Implements

IConfCacheStorage..::.Add(ICfgObject)

Exceptions

Exception | Condition
System..::.ArgumentException | The object being added has not been saved in the configuration server.
System..::.InvalidOperationException | The object being added is already in the cache (dbid and type are used for the purposes of determining equality)

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Clear Method
DefaultConfCacheStorage Class See Also Send Feedback
Removes all items in storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

IConfCacheStorage..::.Clear()()()

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Dispose Method
DefaultConfCacheStorage Class See Also Send Feedback
Releases the resources associated with the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Remove Method
DefaultConfCacheStorage Class See Also Send Feedback
Removes the specified configuration object from the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Remove(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Function Remove ( _
    obj As ICfgObject _
) As Boolean
Visual C++
public:
virtual bool Remove(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object to remove

Return Value

true if object successfuly deleted, false otherwise.

Implements

IConfCacheStorage..::.Remove(ICfgObject)

Remarks

The object is located using its dbid and type.

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve Method

[image] [image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Retrieve Method
DefaultConfCacheStorage Class See Also Send Feedback

Overload List

Name | Description
Retrieve<(Of <(T>)>)()()() | Retrieves a list of all objects in the storage.
Retrieve<(Of <(T>)>)(Object) | Retrieves a list of objects in storage utilizing a "helper" parameter.

See Also

DefaultConfCacheStorage Class
DefaultConfCacheStorage Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Retrieve<(Of <(T>)>) Method
DefaultConfCacheStorage Class See Also Send Feedback
Retrieves a list of all objects in the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<T> Retrieve<T>()
where T : ICfgObject
Visual Basic (Declaration)
Public Function Retrieve(Of T As ICfgObject) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual IEnumerable<T>^ Retrieve() sealed

Type Parameters

T
The type of object in the resulting list

Return Value

An enumerable list of the requested objects

See Also

DefaultConfCacheStorage Class
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method (Object)

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Retrieve<(Of <(T>)>) Method (Object)
DefaultConfCacheStorage Class See Also Send Feedback
Retrieves a list of objects in storage utilizing a "helper" parameter.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<T> Retrieve<T>(
    Object helper
)
where T : ICfgObject
Visual Basic (Declaration)
Public Function Retrieve(Of T As ICfgObject) ( _
    helper As Object _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
where T : ICfgObject
virtual IEnumerable<T>^ Retrieve(
    Object^ helper
) sealed

Parameters

helper
Type: System..::.Object
can be either "null" to retrieve all objects, or CfgObjectType to retrieve by type.

Type Parameters

T
The type of object in the resulting list

Return Value

An enumerable list of the requested objects

See Also

DefaultConfCacheStorage Class
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
DefaultConfCacheStorage..::.Update Method
DefaultConfCacheStorage Class See Also Send Feedback
Updates an existing configuration object in the storage with the passed copy.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Update(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Sub Update ( _
    obj As ICfgObject _
)
Visual C++
public:
virtual void Update(
    ICfgObject^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The new version of a cached configuration object

Implements

IConfCacheStorage..::.Update(ICfgObject)

Remarks

If the passed object does not already exist in the cache, it is added to the cache. The object's dbid and type are used to determine equality.

See Also

DefaultConfCacheStorage Class
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCache Interface

[image]

Enterprise SDK 8.0 Reference API
IConfCache Interface
Members See Also Send Feedback
Interface for the configuration object cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfCache : ISubscriber<ConfEvent>
Visual Basic (Declaration)
Public Interface IConfCache _
    Implements ISubscriber(Of ConfEvent)
Visual C++
public interface class IConfCache : ISubscriber<ConfEvent^>

See Also

IConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCache Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCache Members
IConfCache Interface Methods Properties See Also Send Feedback

The IConfCache type exposes the following members.

Methods

Name | Description
Add | Adds a new configuration object to the cache.
BeginRefresh | Asynchronously updates all configuration objects in the cache.
Clear | Removes all cache contents.
Contains | Determines whether the cache contains the specified object.
Deserialize | Deserializes the cache from the specified stream.
EndRefresh | To be called when the asynchronous refresh operation is complete. If called before the refresh operation completes, this method will block until completion.
Handle | (Inherited from ISubscriber<(Of <( ConfEvent >)>).)
Refresh | Synchronously updates all configuration objects which are currently in the cache.
Remove | Overloaded.
Retrieve | Overloaded.
RetrieveMultiple | Overloaded.
Serialize | Serializes the cache into the specified stream.
Update | Overwrites a configuration object which already exists in the cache with a new copy.

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( ConfEvent >)>).)
Policy | Returns the current policy associated with this cache.

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCache Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCache Methods
IConfCache Interface See Also Send Feedback

The IConfCache type exposes the following members.

Methods

Name | Description
Add | Adds a new configuration object to the cache.
BeginRefresh | Asynchronously updates all configuration objects in the cache.
Clear | Removes all cache contents.
Contains | Determines whether the cache contains the specified object.
Deserialize | Deserializes the cache from the specified stream.
EndRefresh | To be called when the asynchronous refresh operation is complete. If called before the refresh operation completes, this method will block until completion.
Handle | (Inherited from ISubscriber<(Of <( ConfEvent >)>).)
Refresh | Synchronously updates all configuration objects which are currently in the cache.
Remove | Overloaded.
Retrieve | Overloaded.
RetrieveMultiple | Overloaded.
Serialize | Serializes the cache into the specified stream.
Update | Overwrites a configuration object which already exists in the cache with a new copy.

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Add Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Add Method
IConfCache Interface See Also Send Feedback
Adds a new configuration object to the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Add(
    ICfgObject obj
)
Visual Basic (Declaration)
Sub Add ( _
    obj As ICfgObject _
)
Visual C++
void Add(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
A configuration object

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


BeginRefresh Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.BeginRefresh Method
IConfCache Interface See Also Send Feedback
Asynchronously updates all configuration objects in the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginRefresh(
    AsyncCallback callback
)
Visual Basic (Declaration)
Function BeginRefresh ( _
    callback As AsyncCallback _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginRefresh(
    AsyncCallback^ callback
)

Parameters

callback
Type: System..::.AsyncCallback
The callback method to be invoked when the operation completes.

Return Value

The async result associated with this operation.

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Clear Method
IConfCache Interface See Also Send Feedback
Removes all cache contents.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear
Visual C++
void Clear()

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Contains Method
IConfCache Interface See Also Send Feedback
Determines whether the cache contains the specified object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Contains(
    ICfgObject obj
)
Visual Basic (Declaration)
Function Contains ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool Contains(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object to look for

Return Value

true if the object is in the cache, false otherwise

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Deserialize Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Deserialize Method
IConfCache Interface See Also Send Feedback
Deserializes the cache from the specified stream.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Deserialize(
    Stream stream
)
Visual Basic (Declaration)
Sub Deserialize ( _
    stream As Stream _
)
Visual C++
void Deserialize(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream from which the cache is to be read

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


EndRefresh Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.EndRefresh Method
IConfCache Interface See Also Send Feedback
To be called when the asynchronous refresh operation is complete. If called before the refresh operation completes, this method will block until completion.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void EndRefresh(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Sub EndRefresh ( _
    asyncResult As IAsyncResult _
)
Visual C++
void EndRefresh(
    IAsyncResult^ asyncResult
)

Parameters

asyncResult
Type: System..::.IAsyncResult
The async result associated with the current operation

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Refresh Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Refresh Method
IConfCache Interface See Also Send Feedback
Synchronously updates all configuration objects which are currently in the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Refresh()
Visual Basic (Declaration)
Sub Refresh
Visual C++
void Refresh()

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Remove Method
IConfCache Interface See Also Send Feedback

Overload List

Name | Description
Remove(ICfgObject) | Removes the specified configuration object from the cache.
Remove(CfgObjectType, Int32) | Removes the configuration object with the specified type and dbid from the cahe.

See Also

IConfCache Interface
IConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method (ICfgObject)

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Remove Method (ICfgObject)
IConfCache Interface See Also Send Feedback
Removes the specified configuration object from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Remove(
    ICfgObject obj
)
Visual Basic (Declaration)
Sub Remove ( _
    obj As ICfgObject _
)
Visual C++
void Remove(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
A configuration object

See Also

IConfCache Interface
Remove Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Remove Method (CfgObjectType, Int32)
IConfCache Interface See Also Send Feedback
Removes the configuration object with the specified type and dbid from the cahe.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Remove(
    CfgObjectType type,
    int dbid
)
Visual Basic (Declaration)
Sub Remove ( _
    type As CfgObjectType, _
    dbid As Integer _
)
Visual C++
void Remove(
    CfgObjectType type,
    int dbid
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of configuration object
dbid
Type: System..::.Int32
The dbid of the configuration object

See Also

IConfCache Interface
Remove Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve Method

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Retrieve Method
IConfCache Interface See Also Send Feedback

Overload List

Name | Description
Retrieve<(Of <(T>)>)(ICfgQuery) | Retrieves a configuration object from the cache.
Retrieve<(Of <(T>)>)(CfgObjectType, Int32) | Retrieves a configuration object from the cache.

See Also

IConfCache Interface
IConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Retrieve<(Of <(T>)>) Method ()
IConfCache Interface See Also Send Feedback
Retrieves a configuration object from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T Retrieve<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Function Retrieve(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As T
Visual C++
generic<typename T>
where T : ICfgObject
T Retrieve(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
A query based on which the result is obtained.

Type Parameters

T
The type of configuration object that should be returned

Return Value

A configuration object matching the specified query

See Also

IConfCache Interface
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Retrieve<(Of <(T>)>) Method (CfgObjectType, Int32)
IConfCache Interface See Also Send Feedback
Retrieves a configuration object from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T Retrieve<T>(
    CfgObjectType type,
    int dbid
)
where T : ICfgObject
Visual Basic (Declaration)
Function Retrieve(Of T As ICfgObject) ( _
    type As CfgObjectType, _
    dbid As Integer _
) As T
Visual C++
generic<typename T>
where T : ICfgObject
T Retrieve(
    CfgObjectType type,
    int dbid
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of configuration object
dbid
Type: System..::.Int32
The dbid of the configuration object

Type Parameters

T
The type of configuration object that should be returned

Return Value

A configuration object of the requested type

See Also

IConfCache Interface
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultiple Method

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCache..::.RetrieveMultiple Method
IConfCache Interface See Also Send Feedback

Overload List

Name | Description
RetrieveMultiple<(Of <(T>)>)()()() | Retrieves an enumerable list of objects from the cache.
RetrieveMultiple<(Of <(T>)>)(ICfgQuery) | Retrieves an enumerable list of objects from the cache.

See Also

IConfCache Interface
IConfCache Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultiple(T) Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.RetrieveMultiple<(Of <(T>)>) Method
IConfCache Interface See Also Send Feedback
Retrieves an enumerable list of objects from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> RetrieveMultiple<T>()
where T : ICfgObject
Visual Basic (Declaration)
Function RetrieveMultiple(Of T As ICfgObject) As IEnumerable(Of T)
Visual C++
generic<typename T>
where T : ICfgObject
IEnumerable<T>^ RetrieveMultiple()

Type Parameters

T
The types of configuration objects to be included in the list.

Return Value

An enumerable list of configuration objects matching the specified query

See Also

IConfCache Interface
RetrieveMultiple Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultiple(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.RetrieveMultiple<(Of <(T>)>) Method ()
IConfCache Interface See Also Send Feedback
Retrieves an enumerable list of objects from the cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> RetrieveMultiple<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Function RetrieveMultiple(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
where T : ICfgObject
IEnumerable<T>^ RetrieveMultiple(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
A query based on which the result is obtained.

Type Parameters

T
The types of configuration objects to be included in the list.

Return Value

An enumerable list of configuration objects matching the specified query

See Also

IConfCache Interface
RetrieveMultiple Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Serialize Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Serialize Method
IConfCache Interface See Also Send Feedback
Serializes the cache into the specified stream.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Serialize(
    Stream stream
)
Visual Basic (Declaration)
Sub Serialize ( _
    stream As Stream _
)
Visual C++
void Serialize(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream into which the cache is to be written

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Update Method
IConfCache Interface See Also Send Feedback
Overwrites a configuration object which already exists in the cache with a new copy.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Update(
    ICfgObject obj
)
Visual Basic (Declaration)
Sub Update ( _
    obj As ICfgObject _
)
Visual C++
void Update(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
A configuration object

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCache Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCache Properties
IConfCache Interface See Also Send Feedback

The IConfCache type exposes the following members.

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( ConfEvent >)>).)
Policy | Returns the current policy associated with this cache.

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Policy Property

[image]

Enterprise SDK 8.0 Reference API
IConfCache..::.Policy Property
IConfCache Interface See Also Send Feedback
Returns the current policy associated with this cache.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IConfCachePolicy Policy { get; }
Visual Basic (Declaration)
ReadOnly Property Policy As IConfCachePolicy
Visual C++
property IConfCachePolicy^ Policy {
    IConfCachePolicy^ get ();
}

See Also

IConfCache Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCachePolicy Interface

[image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy Interface
Members See Also Send Feedback
The interface to be implemented when defining a cache policy.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfCachePolicy
Visual Basic (Declaration)
Public Interface IConfCachePolicy
Visual C++
public interface class IConfCachePolicy

See Also

IConfCachePolicy Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCachePolicy Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy Members
IConfCachePolicy Interface Methods Properties See Also Send Feedback

The IConfCachePolicy type exposes the following members.

Methods

Name | Description
CacheOnCreate | Determines if the passed object should be stored in the cache upon receiving notification of its creation in the configuration server.
RemoveOnDelete | Determines if the passed object should be deleted from the cache if it is deleted from the configuration server.
TrackUpdates | Determines if the passed object's state should be synchronized with the configuration server upon receiving an update.

Properties

Name | Description
ReturnCopies | Specifies whether the cache should return copies of stored objects or the objects themselves.

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCachePolicy Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy Methods
IConfCachePolicy Interface See Also Send Feedback

The IConfCachePolicy type exposes the following members.

Methods

Name | Description
CacheOnCreate | Determines if the passed object should be stored in the cache upon receiving notification of its creation in the configuration server.
RemoveOnDelete | Determines if the passed object should be deleted from the cache if it is deleted from the configuration server.
TrackUpdates | Determines if the passed object's state should be synchronized with the configuration server upon receiving an update.

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CacheOnCreate Method

[image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy..::.CacheOnCreate Method
IConfCachePolicy Interface See Also Send Feedback
Determines if the passed object should be stored in the cache upon receiving notification of its creation in the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool CacheOnCreate(
    ICfgObject obj
)
Visual Basic (Declaration)
Function CacheOnCreate ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool CacheOnCreate(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object

Return Value

true if the object should be cached, false otherwise

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RemoveOnDelete Method

[image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy..::.RemoveOnDelete Method
IConfCachePolicy Interface See Also Send Feedback
Determines if the passed object should be deleted from the cache if it is deleted from the configuration server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool RemoveOnDelete(
    ICfgObject obj
)
Visual Basic (Declaration)
Function RemoveOnDelete ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool RemoveOnDelete(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The Configuration object

Return Value

true if the object should be removed, false otherwise

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


TrackUpdates Method

[image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy..::.TrackUpdates Method
IConfCachePolicy Interface See Also Send Feedback
Determines if the passed object's state should be synchronized with the configuration server upon receiving an update.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool TrackUpdates(
    ICfgObject obj
)
Visual Basic (Declaration)
Function TrackUpdates ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool TrackUpdates(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object

Return Value

true if the object should be updated, false otherwise

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCachePolicy Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy Properties
IConfCachePolicy Interface See Also Send Feedback

The IConfCachePolicy type exposes the following members.

Properties

Name | Description
ReturnCopies | Specifies whether the cache should return copies of stored objects or the objects themselves.

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


ReturnCopies Property

[image]

Enterprise SDK 8.0 Reference API
IConfCachePolicy..::.ReturnCopies Property
IConfCachePolicy Interface See Also Send Feedback
Specifies whether the cache should return copies of stored objects or the objects themselves.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ReturnCopies { get; }
Visual Basic (Declaration)
ReadOnly Property ReturnCopies As Boolean
Visual C++
property bool ReturnCopies {
    bool get ();
}

See Also

IConfCachePolicy Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCacheQueryEngine Interface

[image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine Interface
Members See Also Send Feedback
An interface defining a cache query engine contract.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfCacheQueryEngine
Visual Basic (Declaration)
Public Interface IConfCacheQueryEngine
Visual C++
public interface class IConfCacheQueryEngine

See Also

IConfCacheQueryEngine Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCacheQueryEngine Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine Members
IConfCacheQueryEngine Interface Methods See Also Send Feedback

The IConfCacheQueryEngine type exposes the following members.

Methods

Name | Description
CanExecute | Determines whether the query engine can execute the specified query.
RetrieveMultipleObjects<(Of <(T>)>) | Retrieves a collection of objects based on the specified query.
RetrieveObject | Overloaded.

See Also

IConfCacheQueryEngine Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCacheQueryEngine Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine Methods
IConfCacheQueryEngine Interface See Also Send Feedback

The IConfCacheQueryEngine type exposes the following members.

Methods

Name | Description
CanExecute | Determines whether the query engine can execute the specified query.
RetrieveMultipleObjects<(Of <(T>)>) | Retrieves a collection of objects based on the specified query.
RetrieveObject | Overloaded.

See Also

IConfCacheQueryEngine Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


CanExecute Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine..::.CanExecute Method
IConfCacheQueryEngine Interface See Also Send Feedback
Determines whether the query engine can execute the specified query.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool CanExecute(
    ICfgQuery query
)
Visual Basic (Declaration)
Function CanExecute ( _
    query As ICfgQuery _
) As Boolean
Visual C++
bool CanExecute(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
The query to execute

Return Value

true if the query engine can execute this query, false otherwise

See Also

IConfCacheQueryEngine Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveMultipleObjects(T) Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine..::.RetrieveMultipleObjects<(Of <(T>)>) Method
IConfCacheQueryEngine Interface See Also Send Feedback
Retrieves a collection of objects based on the specified query.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<T> RetrieveMultipleObjects<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Function RetrieveMultipleObjects(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As ICollection(Of T)
Visual C++
generic<typename T>
where T : ICfgObject
ICollection<T>^ RetrieveMultipleObjects(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
The query by which to retrieve the objects

Type Parameters

T
The type of object to retrieve

Return Value

The objects specified by the query or an empty collection if no results are matching objects are found

See Also

IConfCacheQueryEngine Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine..::.RetrieveObject Method
IConfCacheQueryEngine Interface See Also Send Feedback

Overload List

Name | Description
RetrieveObject<(Of <(T>)>)(ICfgQuery) | Retrieves an object based on the specified query.
RetrieveObject<(Of <(T>)>)(CfgObjectType, Int32) | Retrieves an object using the specified parameters.

See Also

IConfCacheQueryEngine Interface
IConfCacheQueryEngine Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject(T) Method ()

[image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine..::.RetrieveObject<(Of <(T>)>) Method ()
IConfCacheQueryEngine Interface See Also Send Feedback
Retrieves an object based on the specified query.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RetrieveObject<T>(
    ICfgQuery query
)
where T : ICfgObject
Visual Basic (Declaration)
Function RetrieveObject(Of T As ICfgObject) ( _
    query As ICfgQuery _
) As T
Visual C++
generic<typename T>
where T : ICfgObject
T RetrieveObject(
    ICfgQuery^ query
)

Parameters

query
Type: ICfgQuery
The query by which to retrieve the object

Type Parameters

T
The type of object to retrieve

Return Value

The object specified by the query or null if the object is not found

See Also

IConfCacheQueryEngine Interface
RetrieveObject Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


RetrieveObject(T) Method (CfgObjectType, Int32)

[image]

Enterprise SDK 8.0 Reference API
IConfCacheQueryEngine..::.RetrieveObject<(Of <(T>)>) Method (CfgObjectType, Int32)
IConfCacheQueryEngine Interface See Also Send Feedback
Retrieves an object using the specified parameters.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RetrieveObject<T>(
    CfgObjectType type,
    int dbid
)
where T : ICfgObject
Visual Basic (Declaration)
Function RetrieveObject(Of T As ICfgObject) ( _
    type As CfgObjectType, _
    dbid As Integer _
) As T
Visual C++
generic<typename T>
where T : ICfgObject
T RetrieveObject(
    CfgObjectType type,
    int dbid
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType
The type of object (CfgObjectType)
dbid
Type: System..::.Int32
The dbid of the object

Type Parameters

T
The type of object to retrieve

Return Value

A configuration object with the requested dbid and type or null if the object is not found

See Also

IConfCacheQueryEngine Interface
RetrieveObject Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCacheStorage Interface

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage Interface
Members See Also Send Feedback
An interface which defines the contract for a configuration cache storage module.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfCacheStorage
Visual Basic (Declaration)
Public Interface IConfCacheStorage
Visual C++
public interface class IConfCacheStorage

See Also

IConfCacheStorage Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCacheStorage Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage Members
IConfCacheStorage Interface Methods See Also Send Feedback

The IConfCacheStorage type exposes the following members.

Methods

Name | Description
Add | Adds the configuration object to the storage.
Clear | Removes all items in storage.
Remove | Removes the specified configuration object from the storage.
Retrieve | Overloaded.
Update | Updates an existing configuration object in the storage with the passed copy.

See Also

IConfCacheStorage Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


IConfCacheStorage Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage Methods
IConfCacheStorage Interface See Also Send Feedback

The IConfCacheStorage type exposes the following members.

Methods

Name | Description
Add | Adds the configuration object to the storage.
Clear | Removes all items in storage.
Remove | Removes the specified configuration object from the storage.
Retrieve | Overloaded.
Update | Updates an existing configuration object in the storage with the passed copy.

See Also

IConfCacheStorage Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Add Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Add Method
IConfCacheStorage Interface See Also Send Feedback
Adds the configuration object to the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Add(
    ICfgObject obj
)
Visual Basic (Declaration)
Sub Add ( _
    obj As ICfgObject _
)
Visual C++
void Add(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object

See Also

IConfCacheStorage Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Clear Method
IConfCacheStorage Interface See Also Send Feedback
Removes all items in storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear
Visual C++
void Clear()

See Also

IConfCacheStorage Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Remove Method
IConfCacheStorage Interface See Also Send Feedback
Removes the specified configuration object from the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Remove(
    ICfgObject obj
)
Visual Basic (Declaration)
Function Remove ( _
    obj As ICfgObject _
) As Boolean
Visual C++
bool Remove(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The configuration object to remove

Return Value

true if object successfuly deleted, false otherwise.

See Also

IConfCacheStorage Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve Method

[image] [image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Retrieve Method
IConfCacheStorage Interface See Also Send Feedback

Overload List

Name | Description
Retrieve<(Of <(T>)>)()()() | Retrieves a list of all objects in the storage.
Retrieve<(Of <(T>)>)(Object) | Retrieves a list of objects in storage utilizing a "helper" parameter.

See Also

IConfCacheStorage Interface
IConfCacheStorage Members
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Retrieve<(Of <(T>)>) Method
IConfCacheStorage Interface See Also Send Feedback
Retrieves a list of all objects in the storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> Retrieve<T>()
where T : ICfgObject
Visual Basic (Declaration)
Function Retrieve(Of T As ICfgObject) As IEnumerable(Of T)
Visual C++
generic<typename T>
where T : ICfgObject
IEnumerable<T>^ Retrieve()

Type Parameters

T
The type of object in the resulting list

Return Value

An enumerable list of the requested objects

See Also

IConfCacheStorage Interface
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Retrieve(T) Method (Object)

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Retrieve<(Of <(T>)>) Method (Object)
IConfCacheStorage Interface See Also Send Feedback
Retrieves a list of objects in storage utilizing a "helper" parameter.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> Retrieve<T>(
    Object helper
)
where T : ICfgObject
Visual Basic (Declaration)
Function Retrieve(Of T As ICfgObject) ( _
    helper As Object _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
where T : ICfgObject
IEnumerable<T>^ Retrieve(
    Object^ helper
)

Parameters

helper
Type: System..::.Object
A helper parameter to be defined in each implementation.

Type Parameters

T
The type of object in the resulting list

Return Value

An enumerable list of the requested objects

See Also

IConfCacheStorage Interface
Retrieve Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
IConfCacheStorage..::.Update Method
IConfCacheStorage Interface See Also Send Feedback
Updates an existing configuration object in the storage with the passed copy.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Cache
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Update(
    ICfgObject obj
)
Visual Basic (Declaration)
Sub Update ( _
    obj As ICfgObject _
)
Visual C++
void Update(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject
The new version of a cached configuration object

See Also

IConfCacheStorage Interface
Genesyslab.Enterprise.ConfigurationObjectModel.Cache Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace
Send Feedback

Classes

Class | Description
CfgAccessGroup | Access Groups are groups of Persons who need to have the same set of permissions with respect to Configuration Database objects
CfgACE | CfgACE
CfgACEID | CfgACEID
CfgACL | CfgACL
CfgACLID | CfgACLID
CfgActionCode | Action coding enables agents to report the business results of customer interactions, as well as to explain the reasons for certain operations. After you select an appropriate code from a menu of predefined Action Codes, the code is passed along with its related request. The code then returns with the event, which indicates that the request has been successfully processed. Eventually, the code is stored in the reporting database. You can supplement each Action Code with a number of Subcodes that more precisely characterize the reasons for a certain action.
CfgAddress | CfgAddress
CfgAgentGroup | Groups of Agents are typically set up to provide particular sets of contact center services.
CfgAgentInfo | CfgAgentInfo
CfgAgentLogin | Agent Logins are unique codes defined within a Switch and assigned to agents. They identify which Agent is working at which Place during a particular working session. Configuration of Agent Logins in the Configuration Database must exactly match the configuration of those Agent Logins in the switching system. Before adding or deleting a particular Agent Login, make sure that the same change was made in the database of the switching system. When you specify Agent Logins as objects in a Switch, they are not associated with any particular agents.
CfgAgentLoginInfo | CfgAgentLoginInfo
CfgAlarmCondition | Alarm Conditions specify events that you might want to know about and manage as soon as they occur.
CfgApplication |
CfgAppPrototype | An application prototype.
CfgAppRank | CfgAppRank
CfgAppServicePermission | CfgAppServicePermission
CfgCallingList | Calling Lists are references to tables of information about the numbers to call during an outbound campaign. These objects also specify conditions that Outbound Contact applications observe when working with these Calling Lists.
CfgCallingListInfo | CfgCallingListInfo
CfgCampaign | Campaigns are structures for organizing and managing an automated process of making outbound calls to the destinations specified in Calling Lists.
CfgCampaignGroup | CfgCampaignGroup objects contain information about Campaign groups.
CfgCampaignGroupInfo | CfgCampaignGroupInfo
CfgConnInfo | CfgConnInfo
CfgDelSwitchAccess | CfgDelSwitchAccess
CfgDeltaAccessGroup | CfgDeltaAccessGroup
CfgDeltaActionCode | CfgDeltaActionCode
CfgDeltaAgentGroup | CfgDeltaAgentGroup
CfgDeltaAgentInfo | CfgDeltaAgentInfo
CfgDeltaAgentLogin | CfgDeltaAgentLogin
CfgDeltaAlarmCondition | CfgDeltaAlarmCondition
CfgDeltaApplication | CfgDeltaApplication
CfgDeltaAppPrototype | CfgDeltaAppPrototype
CfgDeltaCallingList | CfgDeltaCallingList
CfgDeltaCampaign | CfgDeltaCampaign
CfgDeltaCampaignGroup | CfgDeltaCampaignGroup
CfgDeltaDN | CfgDeltaDN
CfgDeltaDNGroup | CfgDeltaDNGroup
CfgDeltaEnumerator | CfgDeltaEnumerator
CfgDeltaEnumeratorValue | CfgDeltaEnumeratorValue
CfgDeltaField | CfgDeltaField
CfgDeltaFilter | CfgDeltaFilter
CfgDeltaFolder | CfgDeltaFolder
CfgDeltaFormat | CfgDeltaFormat
CfgDeltaGroup | CfgDeltaGroup
CfgDeltaGVPCustomer | CfgDeltaGVPCustomer
CfgDeltaGVPIVRProfile | CfgDeltaGVPIVRProfile
CfgDeltaGVPReseller | CfgDeltaGVPReseller
CfgDeltaHost | CfgDeltaHost
CfgDeltaIVR | CfgDeltaIVR
CfgDeltaIVRPort | CfgDeltaIVRPort
CfgDeltaObjectiveTable | CfgDeltaObjectiveTable
CfgDeltaPerson | CfgDeltaPerson
CfgDeltaPhysicalSwitch | CfgDeltaPhysicalSwitch
CfgDeltaPlace | CfgDeltaPlace
CfgDeltaPlaceGroup | CfgDeltaPlaceGroup
CfgDeltaRole | CfgDeltaRole
CfgDeltaScheduledTask | CfgDeltaScheduledTask
CfgDeltaScript | CfgDeltaScript
CfgDeltaService | CfgDeltaService
CfgDeltaSkill | CfgDeltaSkill
CfgDeltaStatDay | CfgDeltaStatDay
CfgDeltaStatTable | CfgDeltaStatTable
CfgDeltaSwitch | CfgDeltaSwitch
CfgDeltaTableAccess | CfgDeltaTableAccess
CfgDeltaTenant | CfgDeltaTenant
CfgDeltaTimeZone | CfgDeltaTimeZone
CfgDeltaTransaction | CfgDeltaTransaction
CfgDeltaTreatment | CfgDeltaTreatment
CfgDeltaVoicePrompt | CfgDeltaVoicePrompt
CfgDetectEvent | CfgDetectEvent
CfgDN | A DN is a communication device that is uniquely identified by a directory number, where customer interactions (for example, telephone calls or e-mails) reside and are handled.
CfgDNAccessNumber | CfgDNAccessNumber
CfgDNGroup | You can set up Groups of DNs for use in network-level routing algorithms and in some types of statistics. Consult solution-specific documentation to see if you need to set up DN Groups. When you are specifying a DN Group, remember that the DNs comprising this group must have the same telephony event model.
CfgDNInfo | CfgDNInfo
CfgEnumerator | CfgEnumerator objects are available enumerations, such as MediaType, Service Type, and others.
CfgEnumeratorValue | CfgEnumeratorValue objects contain all of the values for all available enumerators.
CfgField |
CfgFilter |
CfgFolder | Folders can be used to create hierarchies of other types of objects. Each folder can contain a collection of objects of a single type.
CfgFormat | Use Formats to specify Fields that form a data structure (for example, a database table).
CfgGroup | CfgGroup
CfgGVPCustomer | Obsolete. This object is obsolete and no longer in use
CfgGVPIVRProfile | A GVP Voice Application Profile is used by a GVP to define an voice application that can be executed upon request. Each GVP Voice Application is associated with one Tenant. Specified CfgGVPIVRProfile is not found (change/delete) CfgGVPIVRProfile already exists (Add) submited CfgGVPIVRProfile does not have any or all of mandatory fields filled (add/change)
CfgGVPReseller | Obsolete. This object is obsolete and no longer in use.
CfgHost | Hosts are the computers that run the various CTI server applications in an environment.
CfgID | CfgID
CfgIVR | An IVR (Interactive Voice Response) is a telephony object that contains IVR Ports; it is controlled through IVR interface drivers.
CfgIVRPort | An Interactive Voice Response (IVR) Port is a telephony object uniquely identified by the numbers within an IVR at which telephone calls may reside and be handled.
CfgMemberID | CfgMemberID
CfgObjectID | CfgObjectID
CfgObjectiveTable | Objective Tables are collections of Objective Records.
CfgObjectiveTableRecord | CfgObjectiveTableRecord
CfgObjectResource | CfgObjectResource
CfgOS | CfgOS
CfgOwnerID | CfgOwnerID
CfgParentID | CfgParentID
CfgPerson | Persons correspond to contact center personnel___including agents___who need access to CTI applications. The Genesys Framework requires that every person who needs such access be registered in the Configuration Database with an appropriate set of privileges.
CfgPhones | CfgPhones
CfgPhysicalSwitch | Switching Offices are the actual telephone switches that provide telephone service to contact centers.
CfgPlace | A Place is a location that has one or more DNs operated by a single agent. Configure Places and assign individual DNs to them in order to monitor performance and availability of Agents, Agent Groups, and Place Groups, and to provide this information to call-processing applications. A typical Agent Place consists of two DNs: one DN that an agent uses to take customer calls and another DN the agent uses to make consultation calls and transfers. If you are using the multimedia options of the Genesys products, Places may have to be equipped with DNs of other types, such as E-mail Address. Make sure the configuration of Places in the Configuration Database always matches the actual wiring arrangements in the contact center.
CfgPlaceGroup | You can group Places if, according to the call-processing algorithms, the calls have to be distributed among a set of Places under the control of CTI applications rather than through the ACD mechanisms of the Switch. As an example, consider a call-parking service, where a routing application transfers a call to one of the ports assigned to a call-parking Place Group and attaches the information about the treatment to be applied to that call while it is parked.
CfgPortInfo | CfgPortInfo
CfgRemovalEvent | CfgRemovalEvent
CfgResourceID | CfgResourceID
CfgRole |
CfgRoleMember | CfgRoleMember
CfgScheduledTask | A Scheduled Task is a GVP Object in which you schedule the GVP tasks
CfgScript | Scripts identify processing scenarios or treatments that can be applied to customer interactions.
CfgServer | CfgServer
CfgServerHostID | CfgServerHostID
CfgServerVersion | CfgServerVersion
CfgService | Solutions are sets of functions that applications provide. Solutions accomplish particular business tasks in contact centers.
CfgServiceInfo | CfgServiceInfo
CfgSkill | Skills are qualities or abilities that Agents possess. These Skills affect how Agents are placed in a contact center hierarchy. Common skills include abilities in different languages, particular categories of product knowledge, or ability in particular types of sales.
CfgSkillLevel | CfgSkillLevel
CfgSolutionComponent | CfgSolutionComponent
CfgSolutionComponentDefinition | CfgSolutionComponentDefinition
CfgStatDay | A Statistical Day is a numerically-expressed workload that a particular Agent Group is expected to handle during a particular business day.
CfgStatInterval | CfgStatInterval
CfgStatTable | Statistical Tables are groups of Statistical Days that represent statistically-modeled performances of Agent Groups over a calendar period of up to one year. Call-processing applications can use Statistical Tables to provide load balancing between Agent Groups when the real-time statistics for those groups are unavailable.
CfgSubcode | CfgSubcode
CfgSwitch | A Switch is an aggregate of telephony resources within a Switching Office. Most enterprise-level configurations have a one-to-one match between switches and switching offices. However, there may be instances when it is desirable to partition an office into more than one switch, perhaps due to CTI_link capacity limitations, or to create a more efficient and secure numbering plan. In that case, you must define these switches within a switching office.
CfgSwitchAccessCode | CfgSwitchAccessCode
CfgTableAccess | Table Access objects describe database tables of a specified Format and explain how to access these tables through Database Access Points.
CfgTenant | A Tenant is a business whose customer interactions are enabled or enhanced through services offered by a third party, typically a telecommunications service provider. From a functional standpoint, each tenant in a multi-tenant environment is a contact center (single or multi-site) completely equipped to process customer interactions. From an architectural standpoint, however, most of the hardware and software that tenants use to enable or enhance those interactions belongs to the service provider.
CfgTimeZone | Time Zones are predefined objects that provide CTI applications with information about world time zones. Each object describes one time zone.
CfgTransaction | Transactions define how CTI applications calculate customer-defined statistics.
CfgTreatment | Treatments, which are most often used in automated outbound campaigns, tell Outbound Contact Server (OCS) how to respond to an unsuccessful call result (a call that does not reach the intended party). For example, the response to an unsuccessful connection may be to redial, and the response to a successful connection may be to play a message. A Treatment Sequence is a group of treatment objects that all contain the same Call Result value. Treatments in a sequence are applied to a call in their numerical order (see the Treatment property Number in Sequence).
CfgUpdatePackageRecord | CfgUpdatePackageRecord
CfgVoicePrompt |


CfgAccessGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup Class
Members See Also Send Feedback
Access Groups are groups of Persons who need to have the same set of permissions with respect to Configuration Database objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAccessGroup : CfgObject
Visual Basic (Declaration)
Public Class CfgAccessGroup _
    Inherits CfgObject
Visual C++
public ref class CfgAccessGroup : public CfgObject

Remarks

The name of a access group must be unique within the tenant, but can coincide with the names of dn groups, place groups and agent groups of the same tenant.

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAccessGroup

See Also

CfgAccessGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAccessGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup Members
CfgAccessGroup Class Constructors Methods Properties See Also Send Feedback

The CfgAccessGroup type exposes the following members.

Constructors

Name | Description
CfgAccessGroup | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | The DBID of the CfgAccessGroup configuration object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MemberIDs | A pointer to the list of the Persons that form this group (every item of this list is structured as CfgID ).
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Type | Type of this Access Group. Once specified, cannot be changed. Refer to CfgAccessGroupType .

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAccessGroup Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup Constructor
CfgAccessGroup Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAccessGroup(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgAccessGroup(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAccessGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAccessGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAccessGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup Methods
CfgAccessGroup Class See Also Send Feedback

The CfgAccessGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup..::.Save Method
CfgAccessGroup Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup..::.SetAccountPermissions Method
CfgAccessGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgAccessGroup Class
CfgAccessGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAccessGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup Properties
CfgAccessGroup Class See Also Send Feedback

The CfgAccessGroup type exposes the following members.

Properties

Name | Description
DBID | The DBID of the CfgAccessGroup configuration object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MemberIDs | A pointer to the list of the Persons that form this group (every item of this list is structured as CfgID ).
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Type | Type of this Access Group. Once specified, cannot be changed. Refer to CfgAccessGroupType .

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup..::.DBID Property
CfgAccessGroup Class See Also Send Feedback
The DBID of the CfgAccessGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup..::.GroupInfo Property
CfgAccessGroup Class See Also Send Feedback
A pointer to the structure CfgGroup containing general information about this group. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroup GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroup
Visual C++
public:
property CfgGroup^ GroupInfo {
    CfgGroup^ get ();
    void set (CfgGroup^ value);
}

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MemberIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup..::.MemberIDs Property
CfgAccessGroup Class See Also Send Feedback
A pointer to the list of the Persons that form this group (every item of this list is structured as CfgID ).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgID> MemberIDs { get; set; }
Visual Basic (Declaration)
Public Property MemberIDs As ICollection(Of CfgID)
Visual C++
public:
property ICollection<CfgID^>^ MemberIDs {
    ICollection<CfgID^>^ get ();
    void set (ICollection<CfgID^>^ value);
}

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroup..::.Type Property
CfgAccessGroup Class See Also Send Feedback
Type of this Access Group. Once specified, cannot be changed. Refer to CfgAccessGroupType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAccessGroupType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAccessGroupType
Visual C++
public:
property CfgAccessGroupType Type {
    CfgAccessGroupType get ();
    void set (CfgAccessGroupType value);
}

See Also

CfgAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACE Class

[image]

Enterprise SDK 8.0 Reference API
CfgACE Class
Members See Also Send Feedback
CfgACE

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACE : CfgStructure
Visual Basic (Declaration)
Public Class CfgACE _
    Inherits CfgStructure
Visual C++
public ref class CfgACE : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACE

See Also

CfgACE Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACE Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACE Members
CfgACE Class Constructors Methods Properties See Also Send Feedback

The CfgACE type exposes the following members.

Constructors

Name | Description
CfgACE | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AccessMask |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ID |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgACE Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACE Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACE Constructor
CfgACE Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACE(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgACE(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACE.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACE.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACE.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgACE Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACE Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACE Methods
CfgACE Class See Also Send Feedback

The CfgACE type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgACE Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACE Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACE Properties
CfgACE Class See Also Send Feedback

The CfgACE type exposes the following members.

Properties

Name | Description
AccessMask |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ID |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgACE Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AccessMask Property

[image]

Enterprise SDK 8.0 Reference API
CfgACE..::.AccessMask Property
CfgACE Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACE.AccessMask"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AccessMask { get; set; }
Visual Basic (Declaration)
Public Property AccessMask As Integer
Visual C++
public:
property int AccessMask {
    int get ();
    void set (int value);
}

See Also

CfgACE Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACE..::.ID Property
CfgACE Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACE.ID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEID ID { get; set; }
Visual Basic (Declaration)
Public Property ID As CfgACEID
Visual C++
public:
property CfgACEID^ ID {
    CfgACEID^ get ();
    void set (CfgACEID^ value);
}

See Also

CfgACE Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACEID Class

[image]

Enterprise SDK 8.0 Reference API
CfgACEID Class
Members See Also Send Feedback
CfgACEID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACEID : CfgStructure
Visual Basic (Declaration)
Public Class CfgACEID _
    Inherits CfgStructure
Visual C++
public ref class CfgACEID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACEID

See Also

CfgACEID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACEID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEID Members
CfgACEID Class Constructors Methods Properties See Also Send Feedback

The CfgACEID type exposes the following members.

Constructors

Name | Description
CfgACEID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgACEID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACEID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACEID Constructor
CfgACEID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgACEID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACEID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACEID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACEID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgACEID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACEID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEID Methods
CfgACEID Class See Also Send Feedback

The CfgACEID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgACEID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACEID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEID Properties
CfgACEID Class See Also Send Feedback

The CfgACEID type exposes the following members.

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgACEID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACEID..::.DBID Property
CfgACEID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACEID.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgACEID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgACEID..::.Type Property
CfgACEID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACEID.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgACEID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACL Class

[image]

Enterprise SDK 8.0 Reference API
CfgACL Class
Members See Also Send Feedback
CfgACL

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACL : CfgStructure
Visual Basic (Declaration)
Public Class CfgACL _
    Inherits CfgStructure
Visual C++
public ref class CfgACL : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACL

See Also

CfgACL Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACL Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACL Members
CfgACL Class Constructors Methods Properties See Also Send Feedback

The CfgACL type exposes the following members.

Constructors

Name | Description
CfgACL | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
ACEs |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectID |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgACL Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACL Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACL Constructor
CfgACL Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACL(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgACL(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACL.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACL.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACL.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgACL Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACL Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACL Methods
CfgACL Class See Also Send Feedback

The CfgACL type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgACL Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACL Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACL Properties
CfgACL Class See Also Send Feedback

The CfgACL type exposes the following members.

Properties

Name | Description
ACEs |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectID |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgACL Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ACEs Property

[image]

Enterprise SDK 8.0 Reference API
CfgACL..::.ACEs Property
CfgACL Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACL.ACEs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgACE> ACEs { get; set; }
Visual Basic (Declaration)
Public Property ACEs As ICollection(Of CfgACE)
Visual C++
public:
property ICollection<CfgACE^>^ ACEs {
    ICollection<CfgACE^>^ get ();
    void set (ICollection<CfgACE^>^ value);
}

See Also

CfgACL Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACL..::.ObjectID Property
CfgACL Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACL.ObjectID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLID ObjectID { get; set; }
Visual Basic (Declaration)
Public Property ObjectID As CfgACLID
Visual C++
public:
property CfgACLID^ ObjectID {
    CfgACLID^ get ();
    void set (CfgACLID^ value);
}

See Also

CfgACL Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACLID Class

[image]

Enterprise SDK 8.0 Reference API
CfgACLID Class
Members See Also Send Feedback
CfgACLID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACLID : CfgStructure
Visual Basic (Declaration)
Public Class CfgACLID _
    Inherits CfgStructure
Visual C++
public ref class CfgACLID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgACLID

See Also

CfgACLID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACLID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLID Members
CfgACLID Class Constructors Methods Properties See Also Send Feedback

The CfgACLID type exposes the following members.

Constructors

Name | Description
CfgACLID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgACLID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACLID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACLID Constructor
CfgACLID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgACLID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACLID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACLID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACLID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgACLID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACLID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLID Methods
CfgACLID Class See Also Send Feedback

The CfgACLID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgACLID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgACLID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLID Properties
CfgACLID Class See Also Send Feedback

The CfgACLID type exposes the following members.

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgACLID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACLID..::.DBID Property
CfgACLID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACLID.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgACLID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgACLID..::.Type Property
CfgACLID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgACLID.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgACLID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgActionCode Class

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode Class
Members See Also Send Feedback
Action coding enables agents to report the business results of customer interactions, as well as to explain the reasons for certain operations. After you select an appropriate code from a menu of predefined Action Codes, the code is passed along with its related request. The code then returns with the event, which indicates that the request has been successfully processed. Eventually, the code is stored in the reporting database. You can supplement each Action Code with a number of Subcodes that more precisely characterize the reasons for a certain action.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgActionCode : CfgObject
Visual Basic (Declaration)
Public Class CfgActionCode _
    Inherits CfgObject
Visual C++
public ref class CfgActionCode : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgActionCode

See Also

CfgActionCode Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgActionCode Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCode Members
CfgActionCode Class Constructors Methods Properties See Also Send Feedback

The CfgActionCode type exposes the following members.

Constructors

Name | Description
CfgActionCode | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Code | A pointer to the index or abbreviation of the action code. Mandatory. Must be unique within the action code type specified above for the given tenant.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the action code. Mandatory. Must be unique within the action code type specified below for the given tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Subcodes | A pointer to the list of the subcodes defined within the action code (every item of this list is structured as CfgSubcode ). When used as an entry in CfgDeltaActionCode (see below), it is a pointer to a list of subcodes added to the existing list.
Tenant | A unique identifier of the Tenant that this action code belongs to. Mandatory. Once specified, cannot be changed.
Type | Type of the action code. See type CfgActionCodeType. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgActionCode Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode Constructor
CfgActionCode Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCode(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgActionCode(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgActionCode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgActionCode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgActionCode Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCode Methods
CfgActionCode Class See Also Send Feedback

The CfgActionCode type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.Save Method
CfgActionCode Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.SetAccountPermissions Method
CfgActionCode Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgActionCode Class
CfgActionCode Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.SetTenantDBID Method
CfgActionCode Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgActionCode.SetTenantDBID(System.Int32)"]

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgActionCode Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCode Properties
CfgActionCode Class See Also Send Feedback

The CfgActionCode type exposes the following members.

Properties

Name | Description
Code | A pointer to the index or abbreviation of the action code. Mandatory. Must be unique within the action code type specified above for the given tenant.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the action code. Mandatory. Must be unique within the action code type specified below for the given tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Subcodes | A pointer to the list of the subcodes defined within the action code (every item of this list is structured as CfgSubcode ). When used as an entry in CfgDeltaActionCode (see below), it is a pointer to a list of subcodes added to the existing list.
Tenant | A unique identifier of the Tenant that this action code belongs to. Mandatory. Once specified, cannot be changed.
Type | Type of the action code. See type CfgActionCodeType. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Code Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.Code Property
CfgActionCode Class See Also Send Feedback
A pointer to the index or abbreviation of the action code. Mandatory. Must be unique within the action code type specified above for the given tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.DBID Property
CfgActionCode Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.Name Property
CfgActionCode Class See Also Send Feedback
A pointer to the name of the action code. Mandatory. Must be unique within the action code type specified below for the given tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.State Property
CfgActionCode Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Subcodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.Subcodes Property
CfgActionCode Class See Also Send Feedback
A pointer to the list of the subcodes defined within the action code (every item of this list is structured as CfgSubcode ). When used as an entry in CfgDeltaActionCode (see below), it is a pointer to a list of subcodes added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSubcode> Subcodes { get; set; }
Visual Basic (Declaration)
Public Property Subcodes As ICollection(Of CfgSubcode)
Visual C++
public:
property ICollection<CfgSubcode^>^ Subcodes {
    ICollection<CfgSubcode^>^ get ();
    void set (ICollection<CfgSubcode^>^ value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.Tenant Property
CfgActionCode Class See Also Send Feedback
A unique identifier of the Tenant that this action code belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.Type Property
CfgActionCode Class See Also Send Feedback
Type of the action code. See type CfgActionCodeType. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCodeType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgActionCodeType
Visual C++
public:
property CfgActionCodeType Type {
    CfgActionCodeType get ();
    void set (CfgActionCodeType value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCode..::.UserProperties Property
CfgActionCode Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAddress Class

[image]

Enterprise SDK 8.0 Reference API
CfgAddress Class
Members See Also Send Feedback
CfgAddress

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAddress : CfgStructure
Visual Basic (Declaration)
Public Class CfgAddress _
    Inherits CfgStructure
Visual C++
public ref class CfgAddress : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAddress

See Also

CfgAddress Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAddress Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddress Members
CfgAddress Class Constructors Methods Properties See Also Send Feedback

The CfgAddress type exposes the following members.

Constructors

Name | Description
CfgAddress | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgAddress Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAddress Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAddress Constructor
CfgAddress Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgAddress(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAddress.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAddress.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAddress.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgAddress Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAddress Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddress Methods
CfgAddress Class See Also Send Feedback

The CfgAddress type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgAddress Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAddress Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddress Properties
CfgAddress Class See Also Send Feedback

The CfgAddress type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgAddress Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup Class
Members See Also Send Feedback
Groups of Agents are typically set up to provide particular sets of contact center services.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentGroup : CfgObject
Visual Basic (Declaration)
Public Class CfgAgentGroup _
    Inherits CfgObject
Visual C++
public ref class CfgAgentGroup : public CfgObject

Remarks

The name of an agent group must be unique within the tenant, but can coincide with the name of either a place group or a DN group of the same tenant. The name of an agent group cannot be changed until there is at least one agent listed in this group. See agentDBIDs property Deletion of Agent Group X will cause the following events set out in the order of arrival: Modification of campaignGroups of all campaigns that included Agent Group X Deletion of Agent Group X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentGroup

See Also

CfgAgentGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup Members
CfgAgentGroup Class Constructors Methods Properties See Also Send Feedback

The CfgAgentGroup type exposes the following members.

Constructors

Name | Description
CfgAgentGroup | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Agents | A pointer to the list of identifiers of the Agents that form this group.
DBID | The DBID of the CfgAgentGroup configuration object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentGroup Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup Constructor
CfgAgentGroup Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentGroup(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgAgentGroup(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup Methods
CfgAgentGroup Class See Also Send Feedback

The CfgAgentGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup..::.Save Method
CfgAgentGroup Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup..::.SetAccountPermissions Method
CfgAgentGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgAgentGroup Class
CfgAgentGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup Properties
CfgAgentGroup Class See Also Send Feedback

The CfgAgentGroup type exposes the following members.

Properties

Name | Description
Agents | A pointer to the list of identifiers of the Agents that form this group.
DBID | The DBID of the CfgAgentGroup configuration object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Agents Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup..::.Agents Property
CfgAgentGroup Class See Also Send Feedback
A pointer to the list of identifiers of the Agents that form this group.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPerson> Agents { get; set; }
Visual Basic (Declaration)
Public Property Agents As ICollection(Of CfgPerson)
Visual C++
public:
property ICollection<CfgPerson^>^ Agents {
    ICollection<CfgPerson^>^ get ();
    void set (ICollection<CfgPerson^>^ value);
}

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup..::.DBID Property
CfgAgentGroup Class See Also Send Feedback
The DBID of the CfgAgentGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroup..::.GroupInfo Property
CfgAgentGroup Class See Also Send Feedback
A pointer to the structure CfgGroup containing general information about this group. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroup GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroup
Visual C++
public:
property CfgGroup^ GroupInfo {
    CfgGroup^ get ();
    void set (CfgGroup^ value);
}

See Also

CfgAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo Class
Members See Also Send Feedback
CfgAgentInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgAgentInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgAgentInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentInfo

See Also

CfgAgentInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo Members
CfgAgentInfo Class Constructors Methods Properties See Also Send Feedback

The CfgAgentInfo type exposes the following members.

Constructors

Name | Description
CfgAgentInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetCapacityRuleDBID | SetCapacityRuleDBID
SetContractDBID | SetContractDBID
SetPlaceDBID | SetPlaceDBID
SetSiteDBID | SetSiteDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AgentLogins | A pointer to the list of the agent logins assigned to this agent (every item of this list is structured as CfgAgentLoginInfo ). When used as an entry in CfgDeltaAgentInfo (see below), it is a pointer to a list of agent logins added to the existing list.
CapacityRule | A unique identifier of the capacity rule ( CfgScript ) associated with this agent.
Contract | A unique identifier of Cost Contract (CfgObjectiveTable) with which this Agent is associated.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Place | A unique identifier of the Place assigned to this agent by default. The place must belong to the same tenant as the person in question unless this Agent belongs to the tenant Environment (with DBID=1)
Site | A unique identifier of Site (CfgFolder) with which this Agent is associated.
SkillLevels | A pointer to the list of the agent's skill levels (every item of this list is structured as CfgSkillLevel ). When used as an entry in CfgDeltaAgentInfo (see below), it is a pointer to a list of skill levels added to the existing list.

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo Constructor
CfgAgentInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgAgentInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo Methods
CfgAgentInfo Class See Also Send Feedback

The CfgAgentInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetCapacityRuleDBID | SetCapacityRuleDBID
SetContractDBID | SetContractDBID
SetPlaceDBID | SetPlaceDBID
SetSiteDBID | SetSiteDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCapacityRuleDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.SetCapacityRuleDBID Method
CfgAgentInfo Class See Also Send Feedback
SetCapacityRuleDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCapacityRuleDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCapacityRuleDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCapacityRuleDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.SetCapacityRuleDBID(System.Int32)"]

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetContractDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.SetContractDBID Method
CfgAgentInfo Class See Also Send Feedback
SetContractDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetContractDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetContractDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetContractDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.SetContractDBID(System.Int32)"]

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetPlaceDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.SetPlaceDBID Method
CfgAgentInfo Class See Also Send Feedback
SetPlaceDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetPlaceDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetPlaceDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetPlaceDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.SetPlaceDBID(System.Int32)"]

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSiteDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.SetSiteDBID Method
CfgAgentInfo Class See Also Send Feedback
SetSiteDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSiteDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSiteDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSiteDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentInfo.SetSiteDBID(System.Int32)"]

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo Properties
CfgAgentInfo Class See Also Send Feedback

The CfgAgentInfo type exposes the following members.

Properties

Name | Description
AgentLogins | A pointer to the list of the agent logins assigned to this agent (every item of this list is structured as CfgAgentLoginInfo ). When used as an entry in CfgDeltaAgentInfo (see below), it is a pointer to a list of agent logins added to the existing list.
CapacityRule | A unique identifier of the capacity rule ( CfgScript ) associated with this agent.
Contract | A unique identifier of Cost Contract (CfgObjectiveTable) with which this Agent is associated.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Place | A unique identifier of the Place assigned to this agent by default. The place must belong to the same tenant as the person in question unless this Agent belongs to the tenant Environment (with DBID=1)
Site | A unique identifier of Site (CfgFolder) with which this Agent is associated.
SkillLevels | A pointer to the list of the agent's skill levels (every item of this list is structured as CfgSkillLevel ). When used as an entry in CfgDeltaAgentInfo (see below), it is a pointer to a list of skill levels added to the existing list.

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AgentLogins Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.AgentLogins Property
CfgAgentInfo Class See Also Send Feedback
A pointer to the list of the agent logins assigned to this agent (every item of this list is structured as CfgAgentLoginInfo ). When used as an entry in CfgDeltaAgentInfo (see below), it is a pointer to a list of agent logins added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAgentLoginInfo> AgentLogins { get; set; }
Visual Basic (Declaration)
Public Property AgentLogins As ICollection(Of CfgAgentLoginInfo)
Visual C++
public:
property ICollection<CfgAgentLoginInfo^>^ AgentLogins {
    ICollection<CfgAgentLoginInfo^>^ get ();
    void set (ICollection<CfgAgentLoginInfo^>^ value);
}

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.CapacityRule Property
CfgAgentInfo Class See Also Send Feedback
A unique identifier of the capacity rule ( CfgScript ) associated with this agent.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript CapacityRule { get; set; }
Visual Basic (Declaration)
Public Property CapacityRule As CfgScript
Visual C++
public:
property CfgScript^ CapacityRule {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.Contract Property
CfgAgentInfo Class See Also Send Feedback
A unique identifier of Cost Contract (CfgObjectiveTable) with which this Agent is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
    void set (CfgObjectiveTable^ value);
}

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Place Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.Place Property
CfgAgentInfo Class See Also Send Feedback
A unique identifier of the Place assigned to this agent by default. The place must belong to the same tenant as the person in question unless this Agent belongs to the tenant Environment (with DBID=1)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlace Place { get; set; }
Visual Basic (Declaration)
Public Property Place As CfgPlace
Visual C++
public:
property CfgPlace^ Place {
    CfgPlace^ get ();
    void set (CfgPlace^ value);
}

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.Site Property
CfgAgentInfo Class See Also Send Feedback
A unique identifier of Site (CfgFolder) with which this Agent is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; set; }
Visual Basic (Declaration)
Public Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
    void set (CfgFolder^ value);
}

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SkillLevels Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfo..::.SkillLevels Property
CfgAgentInfo Class See Also Send Feedback
A pointer to the list of the agent's skill levels (every item of this list is structured as CfgSkillLevel ). When used as an entry in CfgDeltaAgentInfo (see below), it is a pointer to a list of skill levels added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSkillLevel> SkillLevels { get; set; }
Visual Basic (Declaration)
Public Property SkillLevels As ICollection(Of CfgSkillLevel)
Visual C++
public:
property ICollection<CfgSkillLevel^>^ SkillLevels {
    ICollection<CfgSkillLevel^>^ get ();
    void set (ICollection<CfgSkillLevel^>^ value);
}

See Also

CfgAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLogin Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin Class
Members See Also Send Feedback
Agent Logins are unique codes defined within a Switch and assigned to agents. They identify which Agent is working at which Place during a particular working session. Configuration of Agent Logins in the Configuration Database must exactly match the configuration of those Agent Logins in the switching system. Before adding or deleting a particular Agent Login, make sure that the same change was made in the database of the switching system. When you specify Agent Logins as objects in a Switch, they are not associated with any particular agents.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLogin : CfgObject
Visual Basic (Declaration)
Public Class CfgAgentLogin _
    Inherits CfgObject
Visual C++
public ref class CfgAgentLogin : public CfgObject

Remarks

Deletion of Agent Login X will cause the following events set out in the order of arrival: Modification of agentLogins of the agent who had Agent Login X assigned Deletion of Agent Login X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentLogin

See Also

CfgAgentLogin Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLogin Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin Members
CfgAgentLogin Class Constructors Methods Properties See Also Send Feedback

The CfgAgentLogin type exposes the following members.

Constructors

Name | Description
CfgAgentLogin | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetSwitchDBID
SetSwitchDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginCode | A pointer to the agent login code. Mandatory. Must be unique within the switch. Once specified, cannot be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | The number used as a substitute of a regular agent login in certain types of routing.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | A pointer to the agent login password.
State | Current object state. Mandatory. Refer to CfgObjectState
Switch | A unique identifier of the Switch to which this agent login belongs. Mandatory. Once specified, cannot be changed.
SwitchSpecificType | An integer that corresponds to a combination of switch-specific settings for this agent login. Cannot be set to a zero or negative value.
Tenant | A unique identifier of the Tenant to which this agent login belongs. Read-only (set automatically according to the current value of tenantDBID of the switch specified in switchDBID). See type CfgSwitch .
UseOverride | An indicator of whether the override value shall be used instead of the loginCode value for accessing this agent login in certain types of routing. Recommended to be set to CFGTrue by default. See type CfgFlag .
UserProperties |

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLogin Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin Constructor
CfgAgentLogin Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLogin(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgAgentLogin(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLogin.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLogin.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLogin Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin Methods
CfgAgentLogin Class See Also Send Feedback

The CfgAgentLogin type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetSwitchDBID
SetSwitchDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.Save Method
CfgAgentLogin Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.SetAccountPermissions Method
CfgAgentLogin Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgAgentLogin Class
CfgAgentLogin Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.SetSwitchDBID Method
CfgAgentLogin Class See Also Send Feedback
SetSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLogin.SetSwitchDBID(System.Int32)"]

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.SetTenantDBID Method
CfgAgentLogin Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLogin.SetTenantDBID(System.Int32)"]

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLogin Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin Properties
CfgAgentLogin Class See Also Send Feedback

The CfgAgentLogin type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginCode | A pointer to the agent login code. Mandatory. Must be unique within the switch. Once specified, cannot be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | The number used as a substitute of a regular agent login in certain types of routing.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | A pointer to the agent login password.
State | Current object state. Mandatory. Refer to CfgObjectState
Switch | A unique identifier of the Switch to which this agent login belongs. Mandatory. Once specified, cannot be changed.
SwitchSpecificType | An integer that corresponds to a combination of switch-specific settings for this agent login. Cannot be set to a zero or negative value.
Tenant | A unique identifier of the Tenant to which this agent login belongs. Read-only (set automatically according to the current value of tenantDBID of the switch specified in switchDBID). See type CfgSwitch .
UseOverride | An indicator of whether the override value shall be used instead of the loginCode value for accessing this agent login in certain types of routing. Recommended to be set to CFGTrue by default. See type CfgFlag .
UserProperties |

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.DBID Property
CfgAgentLogin Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LoginCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.LoginCode Property
CfgAgentLogin Class See Also Send Feedback
A pointer to the agent login code. Mandatory. Must be unique within the switch. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LoginCode { get; set; }
Visual Basic (Declaration)
Public Property LoginCode As String
Visual C++
public:
property String^ LoginCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Override Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.Override Property
CfgAgentLogin Class See Also Send Feedback
The number used as a substitute of a regular agent login in certain types of routing.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Override { get; set; }
Visual Basic (Declaration)
Public Property Override As String
Visual C++
public:
property String^ Override {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.Password Property
CfgAgentLogin Class See Also Send Feedback
A pointer to the agent login password.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.State Property
CfgAgentLogin Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.Switch Property
CfgAgentLogin Class See Also Send Feedback
A unique identifier of the Switch to which this agent login belongs. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
    void set (CfgSwitch^ value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SwitchSpecificType Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.SwitchSpecificType Property
CfgAgentLogin Class See Also Send Feedback
An integer that corresponds to a combination of switch-specific settings for this agent login. Cannot be set to a zero or negative value.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SwitchSpecificType { get; set; }
Visual Basic (Declaration)
Public Property SwitchSpecificType As Integer
Visual C++
public:
property int SwitchSpecificType {
    int get ();
    void set (int value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.Tenant Property
CfgAgentLogin Class See Also Send Feedback
A unique identifier of the Tenant to which this agent login belongs. Read-only (set automatically according to the current value of tenantDBID of the switch specified in switchDBID). See type CfgSwitch .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseOverride Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.UseOverride Property
CfgAgentLogin Class See Also Send Feedback
An indicator of whether the override value shall be used instead of the loginCode value for accessing this agent login in certain types of routing. Recommended to be set to CFGTrue by default. See type CfgFlag .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseOverride { get; set; }
Visual Basic (Declaration)
Public Property UseOverride As CfgFlag
Visual C++
public:
property CfgFlag UseOverride {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLogin..::.UserProperties Property
CfgAgentLogin Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLogin.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLoginInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo Class
Members See Also Send Feedback
CfgAgentLoginInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLoginInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgAgentLoginInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgAgentLoginInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAgentLoginInfo

See Also

CfgAgentLoginInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLoginInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo Members
CfgAgentLoginInfo Class Constructors Methods Properties See Also Send Feedback

The CfgAgentLoginInfo type exposes the following members.

Constructors

Name | Description
CfgAgentLoginInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAgentLoginDBID | SetAgentLoginDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AgentLogin | A unique identifier of the Agent Login identifier. Mandatory. Once specified, cannot be changed. The switch that this login identifier belongs to must be assigned to the tenant that this agent belongs to. The same value cannot be repeated within one list. One agent login cannot be assigned to more than one agent.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
WrapupTime | Wrap-up time in seconds associated with this login identifier. Cannot be a negative value.

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLoginInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo Constructor
CfgAgentLoginInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLoginInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgAgentLoginInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLoginInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLoginInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLoginInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLoginInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo Methods
CfgAgentLoginInfo Class See Also Send Feedback

The CfgAgentLoginInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAgentLoginDBID | SetAgentLoginDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAgentLoginDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo..::.SetAgentLoginDBID Method
CfgAgentLoginInfo Class See Also Send Feedback
SetAgentLoginDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAgentLoginDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAgentLoginDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAgentLoginDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAgentLoginInfo.SetAgentLoginDBID(System.Int32)"]

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAgentLoginInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo Properties
CfgAgentLoginInfo Class See Also Send Feedback

The CfgAgentLoginInfo type exposes the following members.

Properties

Name | Description
AgentLogin | A unique identifier of the Agent Login identifier. Mandatory. Once specified, cannot be changed. The switch that this login identifier belongs to must be assigned to the tenant that this agent belongs to. The same value cannot be repeated within one list. One agent login cannot be assigned to more than one agent.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
WrapupTime | Wrap-up time in seconds associated with this login identifier. Cannot be a negative value.

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AgentLogin Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo..::.AgentLogin Property
CfgAgentLoginInfo Class See Also Send Feedback
A unique identifier of the Agent Login identifier. Mandatory. Once specified, cannot be changed. The switch that this login identifier belongs to must be assigned to the tenant that this agent belongs to. The same value cannot be repeated within one list. One agent login cannot be assigned to more than one agent.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLogin AgentLogin { get; set; }
Visual Basic (Declaration)
Public Property AgentLogin As CfgAgentLogin
Visual C++
public:
property CfgAgentLogin^ AgentLogin {
    CfgAgentLogin^ get ();
    void set (CfgAgentLogin^ value);
}

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


WrapupTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfo..::.WrapupTime Property
CfgAgentLoginInfo Class See Also Send Feedback
Wrap-up time in seconds associated with this login identifier. Cannot be a negative value.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int WrapupTime { get; set; }
Visual Basic (Declaration)
Public Property WrapupTime As Integer
Visual C++
public:
property int WrapupTime {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAlarmCondition Class

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition Class
Members See Also Send Feedback
Alarm Conditions specify events that you might want to know about and manage as soon as they occur.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAlarmCondition : CfgObject
Visual Basic (Declaration)
Public Class CfgAlarmCondition _
    Inherits CfgObject
Visual C++
public ref class CfgAlarmCondition : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAlarmCondition

See Also

CfgAlarmCondition Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAlarmCondition Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition Members
CfgAlarmCondition Class Constructors Methods Properties See Also Send Feedback

The CfgAlarmCondition type exposes the following members.

Constructors

Name | Description
CfgAlarmCondition | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetAlarmDetectScriptDBID
SetAlarmDetectScriptDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AlarmDetectEvent | A pointer to the CfgAlarmEvent structure which is used to describe a log event upon which an alarm based on this alarm condition should be detected. Mandatory.
AlarmDetectScript | A unique identifier of a script which describes the logic to be applied to detect an alarm based on this alarm condition. Only a script whose type is CFGAlarmDetection can be specified. Reserved for future use. See CfgScript .
AlarmRemovalEvent | A pointer to the CfgAlarmEvent structure which is used to describe a log event upon which an alarm based on this alarm condition should be removed.
Category | The category of the alarm condition. Mandatory. See type CfgAlarmCategory . Default value is CFGACMajor.
ClearanceScripts | A pointer to a list of identifiers of the CfgScript that describe clearance to an alarm based on this alarm condition. Only scripts whose type is CFGAlarmReaction can be specified. When used as an entry in CfgDeltaAlarmCondition (see below), it is a pointer to a list of identifiers of the scripts added to the existing list. See CfgScript..
ClearanceTimeout | The period of time, in seconds, upon which an alarm based on this alarm condition has to be cleared since the moment it was detected. Default value is 24 hours (24*60*60 = 86400).
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the alarm condition.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsMasked | Determines whether an alarm which is based on this alarm condition should be communicated to Solution Control Interface and reactions to the alarm should be performed. This corresponds to the default value of CFGFalse. Mandatory. See CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the alarm condition. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ReactionScripts | A pointer to a list of identifiers of the CfgScript that describe reactions to an alarm based on this alarm condition. Only scripts whose type is CFGAlarmReaction can be specified. When used as an entry in CfgDeltaAlarmCondition (see below), it is a pointer to a list of identifiers of the scripts added to the existing list. See CfgScript .
State | Current object state. Mandatory. Refer to CfgObjectState
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAlarmCondition Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition Constructor
CfgAlarmCondition Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmCondition(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgAlarmCondition(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAlarmCondition.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAlarmCondition.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAlarmCondition Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition Methods
CfgAlarmCondition Class See Also Send Feedback

The CfgAlarmCondition type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetAlarmDetectScriptDBID
SetAlarmDetectScriptDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.Save Method
CfgAlarmCondition Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.SetAccountPermissions Method
CfgAlarmCondition Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgAlarmCondition Class
CfgAlarmCondition Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAlarmDetectScriptDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.SetAlarmDetectScriptDBID Method
CfgAlarmCondition Class See Also Send Feedback
SetAlarmDetectScriptDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAlarmDetectScriptDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAlarmDetectScriptDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAlarmDetectScriptDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAlarmCondition.SetAlarmDetectScriptDBID(System.Int32)"]

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAlarmCondition Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition Properties
CfgAlarmCondition Class See Also Send Feedback

The CfgAlarmCondition type exposes the following members.

Properties

Name | Description
AlarmDetectEvent | A pointer to the CfgAlarmEvent structure which is used to describe a log event upon which an alarm based on this alarm condition should be detected. Mandatory.
AlarmDetectScript | A unique identifier of a script which describes the logic to be applied to detect an alarm based on this alarm condition. Only a script whose type is CFGAlarmDetection can be specified. Reserved for future use. See CfgScript .
AlarmRemovalEvent | A pointer to the CfgAlarmEvent structure which is used to describe a log event upon which an alarm based on this alarm condition should be removed.
Category | The category of the alarm condition. Mandatory. See type CfgAlarmCategory . Default value is CFGACMajor.
ClearanceScripts | A pointer to a list of identifiers of the CfgScript that describe clearance to an alarm based on this alarm condition. Only scripts whose type is CFGAlarmReaction can be specified. When used as an entry in CfgDeltaAlarmCondition (see below), it is a pointer to a list of identifiers of the scripts added to the existing list. See CfgScript..
ClearanceTimeout | The period of time, in seconds, upon which an alarm based on this alarm condition has to be cleared since the moment it was detected. Default value is 24 hours (24*60*60 = 86400).
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the alarm condition.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsMasked | Determines whether an alarm which is based on this alarm condition should be communicated to Solution Control Interface and reactions to the alarm should be performed. This corresponds to the default value of CFGFalse. Mandatory. See CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the alarm condition. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ReactionScripts | A pointer to a list of identifiers of the CfgScript that describe reactions to an alarm based on this alarm condition. Only scripts whose type is CFGAlarmReaction can be specified. When used as an entry in CfgDeltaAlarmCondition (see below), it is a pointer to a list of identifiers of the scripts added to the existing list. See CfgScript .
State | Current object state. Mandatory. Refer to CfgObjectState
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AlarmDetectEvent Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.AlarmDetectEvent Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to the CfgAlarmEvent structure which is used to describe a log event upon which an alarm based on this alarm condition should be detected. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDetectEvent AlarmDetectEvent { get; set; }
Visual Basic (Declaration)
Public Property AlarmDetectEvent As CfgDetectEvent
Visual C++
public:
property CfgDetectEvent^ AlarmDetectEvent {
    CfgDetectEvent^ get ();
    void set (CfgDetectEvent^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AlarmDetectScript Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.AlarmDetectScript Property
CfgAlarmCondition Class See Also Send Feedback
A unique identifier of a script which describes the logic to be applied to detect an alarm based on this alarm condition. Only a script whose type is CFGAlarmDetection can be specified. Reserved for future use. See CfgScript .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript AlarmDetectScript { get; set; }
Visual Basic (Declaration)
Public Property AlarmDetectScript As CfgScript
Visual C++
public:
property CfgScript^ AlarmDetectScript {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AlarmRemovalEvent Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.AlarmRemovalEvent Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to the CfgAlarmEvent structure which is used to describe a log event upon which an alarm based on this alarm condition should be removed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRemovalEvent AlarmRemovalEvent { get; set; }
Visual Basic (Declaration)
Public Property AlarmRemovalEvent As CfgRemovalEvent
Visual C++
public:
property CfgRemovalEvent^ AlarmRemovalEvent {
    CfgRemovalEvent^ get ();
    void set (CfgRemovalEvent^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Category Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.Category Property
CfgAlarmCondition Class See Also Send Feedback
The category of the alarm condition. Mandatory. See type CfgAlarmCategory . Default value is CFGACMajor.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmCategory Category { get; set; }
Visual Basic (Declaration)
Public Property Category As CfgAlarmCategory
Visual C++
public:
property CfgAlarmCategory Category {
    CfgAlarmCategory get ();
    void set (CfgAlarmCategory value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ClearanceScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.ClearanceScripts Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to a list of identifiers of the CfgScript that describe clearance to an alarm based on this alarm condition. Only scripts whose type is CFGAlarmReaction can be specified. When used as an entry in CfgDeltaAlarmCondition (see below), it is a pointer to a list of identifiers of the scripts added to the existing list. See CfgScript..

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgScript> ClearanceScripts { get; set; }
Visual Basic (Declaration)
Public Property ClearanceScripts As ICollection(Of CfgScript)
Visual C++
public:
property ICollection<CfgScript^>^ ClearanceScripts {
    ICollection<CfgScript^>^ get ();
    void set (ICollection<CfgScript^>^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ClearanceTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.ClearanceTimeout Property
CfgAlarmCondition Class See Also Send Feedback
The period of time, in seconds, upon which an alarm based on this alarm condition has to be cleared since the moment it was detected. Default value is 24 hours (24*60*60 = 86400).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ClearanceTimeout { get; set; }
Visual Basic (Declaration)
Public Property ClearanceTimeout As Integer
Visual C++
public:
property int ClearanceTimeout {
    int get ();
    void set (int value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.DBID Property
CfgAlarmCondition Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.Description Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to the description of the alarm condition.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsMasked Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.IsMasked Property
CfgAlarmCondition Class See Also Send Feedback
Determines whether an alarm which is based on this alarm condition should be communicated to Solution Control Interface and reactions to the alarm should be performed. This corresponds to the default value of CFGFalse. Mandatory. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsMasked { get; set; }
Visual Basic (Declaration)
Public Property IsMasked As CfgFlag
Visual C++
public:
property CfgFlag IsMasked {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.Name Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to the name of the alarm condition. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ReactionScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.ReactionScripts Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to a list of identifiers of the CfgScript that describe reactions to an alarm based on this alarm condition. Only scripts whose type is CFGAlarmReaction can be specified. When used as an entry in CfgDeltaAlarmCondition (see below), it is a pointer to a list of identifiers of the scripts added to the existing list. See CfgScript .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgScript> ReactionScripts { get; set; }
Visual Basic (Declaration)
Public Property ReactionScripts As ICollection(Of CfgScript)
Visual C++
public:
property ICollection<CfgScript^>^ ReactionScripts {
    ICollection<CfgScript^>^ get ();
    void set (ICollection<CfgScript^>^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.State Property
CfgAlarmCondition Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCondition..::.UserProperties Property
CfgAlarmCondition Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgApplication Class

[image]

Enterprise SDK 8.0 Reference API
CfgApplication Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgApplication"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgApplication : CfgObject
Visual Basic (Declaration)
Public Class CfgApplication _
    Inherits CfgObject
Visual C++
public ref class CfgApplication : public CfgObject

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgApplication

See Also

CfgApplication Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgApplication Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplication Members
CfgApplication Class Constructors Methods Properties See Also Send Feedback

The CfgApplication type exposes the following members.

Constructors

Name | Description
CfgApplication | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetAppPrototypeDBID
SetAppPrototypeDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AppPrototype | A unique identifier of an application prototype this application is based on. Optional. See CfgAppPrototype . The association with application prototype could be specified at moment of creation of application object only.
AppServers | A pointer to the list of structures of type CfgConnInfo . CfgConnInfo includes:
AutoRestart | Indicates whether the application should be automatically restarted by Local Control Agent after its crash. Mandatory. Recommended to be set to CFGTrue by default. See comments. See CfgFlag
CommandLine | The name of executable to be used to start the application. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. See comments.
CommandLineArguments | A pointer to the additional arguments to be used to start the application. Optional.
ComponentType | A type of application object. Indicate whenever this is an executable process or it is a service that composed from other services and\or processes"
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FlexibleProperties | A pointer to the list of additional properties. See section Comments at the beginning of this document. Only described below options can be added to this property. This field can not be changed as long as this server remains a backup for some other server (see CfgServer structure) and can only be non-empty for the applications of type CFGTServer and CFGHAProxy
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsPrimary | A role of application within HA/redundancy group. Must be considered in association with redundancyType property. Default is CFGTrue . Read-only (set in accordance with the current role within the HA/redundancy group). See comments. See CfgFlag
IsServer | An indicator of whether this application can be a server to some other applications. Read-only (set automatically according to the value of type above). See CfgFlag .
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the application. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Options | A pointer to the list of application-specific configuration options (see the comments below). When used as an entry in CfgDeltaApplication, it is a pointer to a list of options added to the existing list.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | A pointer to the application password. Max length 64 symbols. Not used in 5.1.
PortInfos | A pointer to the list of structures of type CfgPortInfo containing information about listening ports for this Server application. When used as an entry in CfgDeltaApplication , it is a pointer to a list of port infos added to the existing list.
RedundancyType | Defines the HA type if this application is considered as server. Mandatory. Default is CFGHTColdStandby. See comments. See CfgHAType
Resources | A pointer to the list of the objects associated with this Application (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaApplication , it is a pointer to a list of resources added to the existing list. Only objects of type CfgScript can be associated with Application object through resources
ServerInfo | A pointer to the structure containing server-specific information. Can be specified if, according to the value specified for the type above, the application is a daemon and must be set to NULL otherwise. Once specified, cannot be set to NULL. See CfgServer .
ShutdownTimeout | A period of time within which the application is expected to be completely shut down. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. Default value is 90 seconds. See comments.
StartupTimeout | A period of time within which the application is expected to be completely started. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. Default value is 90 seconds. See comments.
StartupType | A type of application startup. Indicates whether this application have to be started by Management Layer. See type CfgStartupType Read-only. The property is accessible via API only and not shown by Configuration Manager. Specified during application prototype definition automatically according following: The value is associated with application type CfgAppType. The value for the applications of CFGDBServer and CFGApplicationCluster type is set to CFGSUTDisabled, for other applications of server type is set to CFGSUTAutomatic. For the applications of non-server type is set to CFGSUTDisabled.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenants | A pointer to the list of identifiers of the Tenants that are served by this application. Makes sense only for applications of the daemon type. For applications of CFGTServer and CFGHAProxy type, can contain only one tenant. A tenant can be added to this list only if the account that the application is associated with has at least read-only access to this tenant. When used as an entry in CfgDeltaApplication, it is a pointer to a list of identifiers of the tenants added to the existing list.
Type | Type of the application. Mandatory. Set automatically according to the value of type of the application prototype specified in appPrototypeDBID or explicitly during the creation time. Once specified, cannot be changed. See CfgAppType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the application version. Mandatory. Set automatically according to the value of version of the application prototype specified in appPrototypeDBID or explicitly.
WorkDirectory | Working directory for the application. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. See comments.

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgApplication Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgApplication Constructor
CfgApplication Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgApplication(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgApplication.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgApplication.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgApplication Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplication Methods
CfgApplication Class See Also Send Feedback

The CfgApplication type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetAppPrototypeDBID
SetAppPrototypeDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Save Method
CfgApplication Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.SetAccountPermissions Method
CfgApplication Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgApplication Class
CfgApplication Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAppPrototypeDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.SetAppPrototypeDBID Method
CfgApplication Class See Also Send Feedback
SetAppPrototypeDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAppPrototypeDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAppPrototypeDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAppPrototypeDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgApplication.SetAppPrototypeDBID(System.Int32)"]

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgApplication Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplication Properties
CfgApplication Class See Also Send Feedback

The CfgApplication type exposes the following members.

Properties

Name | Description
AppPrototype | A unique identifier of an application prototype this application is based on. Optional. See CfgAppPrototype . The association with application prototype could be specified at moment of creation of application object only.
AppServers | A pointer to the list of structures of type CfgConnInfo . CfgConnInfo includes:
AutoRestart | Indicates whether the application should be automatically restarted by Local Control Agent after its crash. Mandatory. Recommended to be set to CFGTrue by default. See comments. See CfgFlag
CommandLine | The name of executable to be used to start the application. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. See comments.
CommandLineArguments | A pointer to the additional arguments to be used to start the application. Optional.
ComponentType | A type of application object. Indicate whenever this is an executable process or it is a service that composed from other services and\or processes"
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FlexibleProperties | A pointer to the list of additional properties. See section Comments at the beginning of this document. Only described below options can be added to this property. This field can not be changed as long as this server remains a backup for some other server (see CfgServer structure) and can only be non-empty for the applications of type CFGTServer and CFGHAProxy
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsPrimary | A role of application within HA/redundancy group. Must be considered in association with redundancyType property. Default is CFGTrue . Read-only (set in accordance with the current role within the HA/redundancy group). See comments. See CfgFlag
IsServer | An indicator of whether this application can be a server to some other applications. Read-only (set automatically according to the value of type above). See CfgFlag .
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the application. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Options | A pointer to the list of application-specific configuration options (see the comments below). When used as an entry in CfgDeltaApplication, it is a pointer to a list of options added to the existing list.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | A pointer to the application password. Max length 64 symbols. Not used in 5.1.
PortInfos | A pointer to the list of structures of type CfgPortInfo containing information about listening ports for this Server application. When used as an entry in CfgDeltaApplication , it is a pointer to a list of port infos added to the existing list.
RedundancyType | Defines the HA type if this application is considered as server. Mandatory. Default is CFGHTColdStandby. See comments. See CfgHAType
Resources | A pointer to the list of the objects associated with this Application (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaApplication , it is a pointer to a list of resources added to the existing list. Only objects of type CfgScript can be associated with Application object through resources
ServerInfo | A pointer to the structure containing server-specific information. Can be specified if, according to the value specified for the type above, the application is a daemon and must be set to NULL otherwise. Once specified, cannot be set to NULL. See CfgServer .
ShutdownTimeout | A period of time within which the application is expected to be completely shut down. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. Default value is 90 seconds. See comments.
StartupTimeout | A period of time within which the application is expected to be completely started. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. Default value is 90 seconds. See comments.
StartupType | A type of application startup. Indicates whether this application have to be started by Management Layer. See type CfgStartupType Read-only. The property is accessible via API only and not shown by Configuration Manager. Specified during application prototype definition automatically according following: The value is associated with application type CfgAppType. The value for the applications of CFGDBServer and CFGApplicationCluster type is set to CFGSUTDisabled, for other applications of server type is set to CFGSUTAutomatic. For the applications of non-server type is set to CFGSUTDisabled.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenants | A pointer to the list of identifiers of the Tenants that are served by this application. Makes sense only for applications of the daemon type. For applications of CFGTServer and CFGHAProxy type, can contain only one tenant. A tenant can be added to this list only if the account that the application is associated with has at least read-only access to this tenant. When used as an entry in CfgDeltaApplication, it is a pointer to a list of identifiers of the tenants added to the existing list.
Type | Type of the application. Mandatory. Set automatically according to the value of type of the application prototype specified in appPrototypeDBID or explicitly during the creation time. Once specified, cannot be changed. See CfgAppType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the application version. Mandatory. Set automatically according to the value of version of the application prototype specified in appPrototypeDBID or explicitly.
WorkDirectory | Working directory for the application. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. See comments.

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppPrototype Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.AppPrototype Property
CfgApplication Class See Also Send Feedback
A unique identifier of an application prototype this application is based on. Optional. See CfgAppPrototype . The association with application prototype could be specified at moment of creation of application object only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppPrototype AppPrototype { get; set; }
Visual Basic (Declaration)
Public Property AppPrototype As CfgAppPrototype
Visual C++
public:
property CfgAppPrototype^ AppPrototype {
    CfgAppPrototype^ get ();
    void set (CfgAppPrototype^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.AppServers Property
CfgApplication Class See Also Send Feedback
A pointer to the list of structures of type CfgConnInfo . CfgConnInfo includes:

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgConnInfo> AppServers { get; set; }
Visual Basic (Declaration)
Public Property AppServers As ICollection(Of CfgConnInfo)
Visual C++
public:
property ICollection<CfgConnInfo^>^ AppServers {
    ICollection<CfgConnInfo^>^ get ();
    void set (ICollection<CfgConnInfo^>^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AutoRestart Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.AutoRestart Property
CfgApplication Class See Also Send Feedback
Indicates whether the application should be automatically restarted by Local Control Agent after its crash. Mandatory. Recommended to be set to CFGTrue by default. See comments. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag AutoRestart { get; set; }
Visual Basic (Declaration)
Public Property AutoRestart As CfgFlag
Visual C++
public:
property CfgFlag AutoRestart {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CommandLine Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.CommandLine Property
CfgApplication Class See Also Send Feedback
The name of executable to be used to start the application. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CommandLine { get; set; }
Visual Basic (Declaration)
Public Property CommandLine As String
Visual C++
public:
property String^ CommandLine {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CommandLineArguments Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.CommandLineArguments Property
CfgApplication Class See Also Send Feedback
A pointer to the additional arguments to be used to start the application. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CommandLineArguments { get; set; }
Visual Basic (Declaration)
Public Property CommandLineArguments As String
Visual C++
public:
property String^ CommandLineArguments {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ComponentType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.ComponentType Property
CfgApplication Class See Also Send Feedback
A type of application object. Indicate whenever this is an executable process or it is a service that composed from other services and\or processes"

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppComponentType ComponentType { get; set; }
Visual Basic (Declaration)
Public Property ComponentType As CfgAppComponentType
Visual C++
public:
property CfgAppComponentType ComponentType {
    CfgAppComponentType get ();
    void set (CfgAppComponentType value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.DBID Property
CfgApplication Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FlexibleProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.FlexibleProperties Property
CfgApplication Class See Also Send Feedback
A pointer to the list of additional properties. See section Comments at the beginning of this document. Only described below options can be added to this property. This field can not be changed as long as this server remains a backup for some other server (see CfgServer structure) and can only be non-empty for the applications of type CFGTServer and CFGHAProxy

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection FlexibleProperties { get; set; }
Visual Basic (Declaration)
Public Property FlexibleProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ FlexibleProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsPrimary Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.IsPrimary Property
CfgApplication Class See Also Send Feedback
A role of application within HA/redundancy group. Must be considered in association with redundancyType property. Default is CFGTrue . Read-only (set in accordance with the current role within the HA/redundancy group). See comments. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsPrimary { get; set; }
Visual Basic (Declaration)
Public Property IsPrimary As CfgFlag
Visual C++
public:
property CfgFlag IsPrimary {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.IsServer Property
CfgApplication Class See Also Send Feedback
An indicator of whether this application can be a server to some other applications. Read-only (set automatically according to the value of type above). See CfgFlag .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsServer { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsServer As CfgFlag
Visual C++
public:
property CfgFlag IsServer {
    CfgFlag get ();
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Name Property
CfgApplication Class See Also Send Feedback
A pointer to the name of the application. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Options Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Options Property
CfgApplication Class See Also Send Feedback
A pointer to the list of application-specific configuration options (see the comments below). When used as an entry in CfgDeltaApplication, it is a pointer to a list of options added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Options { get; set; }
Visual Basic (Declaration)
Public Property Options As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Options {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Password Property
CfgApplication Class See Also Send Feedback
A pointer to the application password. Max length 64 symbols. Not used in 5.1.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PortInfos Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.PortInfos Property
CfgApplication Class See Also Send Feedback
A pointer to the list of structures of type CfgPortInfo containing information about listening ports for this Server application. When used as an entry in CfgDeltaApplication , it is a pointer to a list of port infos added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPortInfo> PortInfos { get; set; }
Visual Basic (Declaration)
Public Property PortInfos As ICollection(Of CfgPortInfo)
Visual C++
public:
property ICollection<CfgPortInfo^>^ PortInfos {
    ICollection<CfgPortInfo^>^ get ();
    void set (ICollection<CfgPortInfo^>^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RedundancyType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.RedundancyType Property
CfgApplication Class See Also Send Feedback
Defines the HA type if this application is considered as server. Mandatory. Default is CFGHTColdStandby. See comments. See CfgHAType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHAType RedundancyType { get; set; }
Visual Basic (Declaration)
Public Property RedundancyType As CfgHAType
Visual C++
public:
property CfgHAType RedundancyType {
    CfgHAType get ();
    void set (CfgHAType value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Resources Property
CfgApplication Class See Also Send Feedback
A pointer to the list of the objects associated with this Application (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaApplication , it is a pointer to a list of resources added to the existing list. Only objects of type CfgScript can be associated with Application object through resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ServerInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.ServerInfo Property
CfgApplication Class See Also Send Feedback
A pointer to the structure containing server-specific information. Can be specified if, according to the value specified for the type above, the application is a daemon and must be set to NULL otherwise. Once specified, cannot be set to NULL. See CfgServer .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServer ServerInfo { get; set; }
Visual Basic (Declaration)
Public Property ServerInfo As CfgServer
Visual C++
public:
property CfgServer^ ServerInfo {
    CfgServer^ get ();
    void set (CfgServer^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ShutdownTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.ShutdownTimeout Property
CfgApplication Class See Also Send Feedback
A period of time within which the application is expected to be completely shut down. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. Default value is 90 seconds. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ShutdownTimeout { get; set; }
Visual Basic (Declaration)
Public Property ShutdownTimeout As Integer
Visual C++
public:
property int ShutdownTimeout {
    int get ();
    void set (int value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.StartupTimeout Property
CfgApplication Class See Also Send Feedback
A period of time within which the application is expected to be completely started. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. Default value is 90 seconds. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupTimeout { get; set; }
Visual Basic (Declaration)
Public Property StartupTimeout As Integer
Visual C++
public:
property int StartupTimeout {
    int get ();
    void set (int value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.StartupType Property
CfgApplication Class See Also Send Feedback
A type of application startup. Indicates whether this application have to be started by Management Layer. See type CfgStartupType Read-only. The property is accessible via API only and not shown by Configuration Manager. Specified during application prototype definition automatically according following: The value is associated with application type CfgAppType. The value for the applications of CFGDBServer and CFGApplicationCluster type is set to CFGSUTDisabled, for other applications of server type is set to CFGSUTAutomatic. For the applications of non-server type is set to CFGSUTDisabled.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStartupType StartupType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartupType As CfgStartupType
Visual C++
public:
property CfgStartupType StartupType {
    CfgStartupType get ();
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.State Property
CfgApplication Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Tenants Property
CfgApplication Class See Also Send Feedback
A pointer to the list of identifiers of the Tenants that are served by this application. Makes sense only for applications of the daemon type. For applications of CFGTServer and CFGHAProxy type, can contain only one tenant. A tenant can be added to this list only if the account that the application is associated with has at least read-only access to this tenant. When used as an entry in CfgDeltaApplication, it is a pointer to a list of identifiers of the tenants added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> Tenants { get; set; }
Visual Basic (Declaration)
Public Property Tenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ Tenants {
    ICollection<CfgTenant^>^ get ();
    void set (ICollection<CfgTenant^>^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Type Property
CfgApplication Class See Also Send Feedback
Type of the application. Mandatory. Set automatically according to the value of type of the application prototype specified in appPrototypeDBID or explicitly during the creation time. Once specified, cannot be changed. See CfgAppType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.UserProperties Property
CfgApplication Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.Version Property
CfgApplication Class See Also Send Feedback
A pointer to the application version. Mandatory. Set automatically according to the value of version of the application prototype specified in appPrototypeDBID or explicitly.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


WorkDirectory Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplication..::.WorkDirectory Property
CfgApplication Class See Also Send Feedback
Working directory for the application. Must be specified if, according to the value specified in isServer property, the application is a server and optional otherwise. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string WorkDirectory { get; set; }
Visual Basic (Declaration)
Public Property WorkDirectory As String
Visual C++
public:
property String^ WorkDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppPrototype Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype Class
Members See Also Send Feedback
An application prototype.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppPrototype : CfgObject
Visual Basic (Declaration)
Public Class CfgAppPrototype _
    Inherits CfgObject
Visual C++
public ref class CfgAppPrototype : public CfgObject

Remarks

An application prototype cannot be deleted as long as there is at least one application associated with it. Parameter options has the following structure: Each key-value pair of the primary list (TKVList *options) uses the key for the name of a configuration section, and the value for a secondary list, that also has the TKVList structure and specifies the configuration options defined within that section. Each key-value pair of the secondary list uses the key for the name of a configuration option, and the value for its current setting. Configuration options can be defined as variables of integer, character, or binary type. Names of sections must be unique within the primary list. Names of options must be unique within the secondary list. NOTE: Configuration Server is not concerned with logical meanings of application-specific configuration sections, options, or their values. An application prototype of CFGConfigServer type with DBID set to 99 shall be pre-defined (scripted) in the Configuration Database before Configuration Server is started for the first time. The object that represents this application prototype cannot be deleted. An application prototype of CFGSCE type with DBID set to 100 shall be pre-defined (scripted) in the Configuration Database before Configuration Server is started for the first time. The object that represents this application prototype cannot be deleted.

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAppPrototype

See Also

CfgAppPrototype Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppPrototype Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype Members
CfgAppPrototype Class Constructors Methods Properties See Also Send Feedback

The CfgAppPrototype type exposes the following members.

Constructors

Name | Description
CfgAppPrototype | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the application prototype. Mandatory. Once specified, cannot be changed. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Options | A pointer to the list of application-specific configuration options with default values where appropriate (see the comments below). When used as an entry in CfgDeltaApplication, it is a pointer to a list of options added to the existing list.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the application. Mandatory. Once specified, cannot be changed. See CfgAppType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the application version. Once specified, cannot be changed.

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppPrototype Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype Constructor
CfgAppPrototype Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppPrototype(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgAppPrototype(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppPrototype.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppPrototype.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppPrototype Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype Methods
CfgAppPrototype Class See Also Send Feedback

The CfgAppPrototype type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.Save Method
CfgAppPrototype Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.SetAccountPermissions Method
CfgAppPrototype Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgAppPrototype Class
CfgAppPrototype Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppPrototype Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype Properties
CfgAppPrototype Class See Also Send Feedback

The CfgAppPrototype type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the application prototype. Mandatory. Once specified, cannot be changed. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Options | A pointer to the list of application-specific configuration options with default values where appropriate (see the comments below). When used as an entry in CfgDeltaApplication, it is a pointer to a list of options added to the existing list.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the application. Mandatory. Once specified, cannot be changed. See CfgAppType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the application version. Once specified, cannot be changed.

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.DBID Property
CfgAppPrototype Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.Name Property
CfgAppPrototype Class See Also Send Feedback
A pointer to the name of the application prototype. Mandatory. Once specified, cannot be changed. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Options Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.Options Property
CfgAppPrototype Class See Also Send Feedback
A pointer to the list of application-specific configuration options with default values where appropriate (see the comments below). When used as an entry in CfgDeltaApplication, it is a pointer to a list of options added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Options { get; set; }
Visual Basic (Declaration)
Public Property Options As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Options {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.State Property
CfgAppPrototype Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.Type Property
CfgAppPrototype Class See Also Send Feedback
Type of the application. Mandatory. Once specified, cannot be changed. See CfgAppType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.UserProperties Property
CfgAppPrototype Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototype..::.Version Property
CfgAppPrototype Class See Also Send Feedback
A pointer to the application version. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppRank Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppRank Class
Members See Also Send Feedback
CfgAppRank

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppRank : CfgStructure
Visual Basic (Declaration)
Public Class CfgAppRank _
    Inherits CfgStructure
Visual C++
public ref class CfgAppRank : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAppRank

See Also

CfgAppRank Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppRank Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRank Members
CfgAppRank Class Constructors Methods Properties See Also Send Feedback

The CfgAppRank type exposes the following members.

Constructors

Name | Description
CfgAppRank | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AppRank | Application rank. See type CfgRank . Rank CFGTenantAdministrator cannot be assigned to a person whose tenantDBID is 1. Ranks CFGServiceAdministrator and CFGSuperAdministrator cannot be assigned to a person whose tenantDBID is not 1. See type CfgRank.
AppType | Type of the application this rank relates to. May make sense for certain applications of the GUI type. (See CfgAppType and the comment below.) Mandatory. Once specified, cannot be changed. The same value cannot be repeated within one list.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgAppRank Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppRank Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppRank Constructor
CfgAppRank Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppRank(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgAppRank(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppRank.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppRank.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppRank.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgAppRank Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppRank Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRank Methods
CfgAppRank Class See Also Send Feedback

The CfgAppRank type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgAppRank Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppRank Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRank Properties
CfgAppRank Class See Also Send Feedback

The CfgAppRank type exposes the following members.

Properties

Name | Description
AppRank | Application rank. See type CfgRank . Rank CFGTenantAdministrator cannot be assigned to a person whose tenantDBID is 1. Ranks CFGServiceAdministrator and CFGSuperAdministrator cannot be assigned to a person whose tenantDBID is not 1. See type CfgRank.
AppType | Type of the application this rank relates to. May make sense for certain applications of the GUI type. (See CfgAppType and the comment below.) Mandatory. Once specified, cannot be changed. The same value cannot be repeated within one list.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgAppRank Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppRank Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppRank..::.AppRank Property
CfgAppRank Class See Also Send Feedback
Application rank. See type CfgRank . Rank CFGTenantAdministrator cannot be assigned to a person whose tenantDBID is 1. Ranks CFGServiceAdministrator and CFGSuperAdministrator cannot be assigned to a person whose tenantDBID is not 1. See type CfgRank.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRank AppRank { get; set; }
Visual Basic (Declaration)
Public Property AppRank As CfgRank
Visual C++
public:
property CfgRank AppRank {
    CfgRank get ();
    void set (CfgRank value);
}

See Also

CfgAppRank Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppRank..::.AppType Property
CfgAppRank Class See Also Send Feedback
Type of the application this rank relates to. May make sense for certain applications of the GUI type. (See CfgAppType and the comment below.) Mandatory. Once specified, cannot be changed. The same value cannot be repeated within one list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As CfgAppType
Visual C++
public:
property CfgAppType AppType {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgAppRank Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppServicePermission Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermission Class
Members See Also Send Feedback
CfgAppServicePermission

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppServicePermission : CfgStructure
Visual Basic (Declaration)
Public Class CfgAppServicePermission _
    Inherits CfgStructure
Visual C++
public ref class CfgAppServicePermission : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgAppServicePermission

See Also

CfgAppServicePermission Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppServicePermission Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermission Members
CfgAppServicePermission Class Constructors Methods Properties See Also Send Feedback

The CfgAppServicePermission type exposes the following members.

Constructors

Name | Description
CfgAppServicePermission | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgAppServicePermission Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppServicePermission Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermission Constructor
CfgAppServicePermission Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppServicePermission(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgAppServicePermission(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppServicePermission.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppServicePermission.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgAppServicePermission.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgAppServicePermission Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppServicePermission Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermission Methods
CfgAppServicePermission Class See Also Send Feedback

The CfgAppServicePermission type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgAppServicePermission Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgAppServicePermission Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermission Properties
CfgAppServicePermission Class See Also Send Feedback

The CfgAppServicePermission type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgAppServicePermission Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingList Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList Class
Members See Also Send Feedback
Calling Lists are references to tables of information about the numbers to call during an outbound campaign. These objects also specify conditions that Outbound Contact applications observe when working with these Calling Lists.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingList : CfgObject
Visual Basic (Declaration)
Public Class CfgCallingList _
    Inherits CfgObject
Visual C++
public ref class CfgCallingList : public CfgObject

Remarks

Deletion of Calling List X will cause the following events set out in the order of arrival: modification of callingLists of all campaigns that included Calling List X deletion of Calling List X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCallingList

See Also

CfgCallingList Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingList Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingList Members
CfgCallingList Class Constructors Methods Properties See Also Send Feedback

The CfgCallingList type exposes the following members.

Constructors

Name | Description
CfgCallingList | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetFilterDBID
SetFilterDBID
SetLogTableAccessDBID
SetLogTableAccessDBID
SetScriptDBID
SetScriptDBID
SetTableAccessDBID
SetTableAccessDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the calling list description.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Filter | A unique identifier of CfgFilter of this calling list. Optional. If specified, the filter format must have reference to the format the table access refers to.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LogTableAccess | A unique identifier of logTableAccess. It is recommended to dedicate single logTableAccessDBID to all CallingLists associated with one Campaign. . Reference to CfgTableAccess object of CFGTTLogTable type can be used only. Optional.
MaxAttempts | A maximum number of attempts the single record can be dialed for one campaign (total). Default value is 10. Mandatory.
Name | A pointer to the calling list name. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the CfgScript for this calling list. Optional.
State | Current object state. Mandatory. Refer to CfgObjectState
TableAccess | A unique identifier of the table the calling list refers to. Reference to CfgTableAccess object of CFGTTCallingList type can be used only. Mandatory.
Tenant | A unique identifier of the CfgTenant to which this calling list is allocated. Mandatory. Once specified, cannot be changed.
TimeFrom | An earliest time when dial can be done. The value is measured in seconds since 00:00:00 of current day. Default value is 08:00:00. Overwrites the settings in database table specified in field CFGFrom. Mandatory.
TimeUntil | An latest time when dial can be done. The value is measured in seconds since 00:00:00 of current day. Default value is 18:00:00. Overwrites the settings in database table specified in field CFGUntil. Mandatory.
Treatments | A pointer to list of identifiers of CfgTreatment dedicated to the calling list. Optional.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingList Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList Constructor
CfgCallingList Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingList(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgCallingList(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingList Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingList Methods
CfgCallingList Class See Also Send Feedback

The CfgCallingList type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetFilterDBID
SetFilterDBID
SetLogTableAccessDBID
SetLogTableAccessDBID
SetScriptDBID
SetScriptDBID
SetTableAccessDBID
SetTableAccessDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Save Method
CfgCallingList Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.SetAccountPermissions Method
CfgCallingList Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgCallingList Class
CfgCallingList Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetFilterDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.SetFilterDBID Method
CfgCallingList Class See Also Send Feedback
SetFilterDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetFilterDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetFilterDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetFilterDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.SetFilterDBID(System.Int32)"]

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetLogTableAccessDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.SetLogTableAccessDBID Method
CfgCallingList Class See Also Send Feedback
SetLogTableAccessDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetLogTableAccessDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetLogTableAccessDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetLogTableAccessDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.SetLogTableAccessDBID(System.Int32)"]

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetScriptDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.SetScriptDBID Method
CfgCallingList Class See Also Send Feedback
SetScriptDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetScriptDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetScriptDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetScriptDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.SetScriptDBID(System.Int32)"]

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTableAccessDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.SetTableAccessDBID Method
CfgCallingList Class See Also Send Feedback
SetTableAccessDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTableAccessDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTableAccessDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTableAccessDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.SetTableAccessDBID(System.Int32)"]

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.SetTenantDBID Method
CfgCallingList Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingList.SetTenantDBID(System.Int32)"]

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingList Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingList Properties
CfgCallingList Class See Also Send Feedback

The CfgCallingList type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the calling list description.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Filter | A unique identifier of CfgFilter of this calling list. Optional. If specified, the filter format must have reference to the format the table access refers to.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LogTableAccess | A unique identifier of logTableAccess. It is recommended to dedicate single logTableAccessDBID to all CallingLists associated with one Campaign. . Reference to CfgTableAccess object of CFGTTLogTable type can be used only. Optional.
MaxAttempts | A maximum number of attempts the single record can be dialed for one campaign (total). Default value is 10. Mandatory.
Name | A pointer to the calling list name. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the CfgScript for this calling list. Optional.
State | Current object state. Mandatory. Refer to CfgObjectState
TableAccess | A unique identifier of the table the calling list refers to. Reference to CfgTableAccess object of CFGTTCallingList type can be used only. Mandatory.
Tenant | A unique identifier of the CfgTenant to which this calling list is allocated. Mandatory. Once specified, cannot be changed.
TimeFrom | An earliest time when dial can be done. The value is measured in seconds since 00:00:00 of current day. Default value is 08:00:00. Overwrites the settings in database table specified in field CFGFrom. Mandatory.
TimeUntil | An latest time when dial can be done. The value is measured in seconds since 00:00:00 of current day. Default value is 18:00:00. Overwrites the settings in database table specified in field CFGUntil. Mandatory.
Treatments | A pointer to list of identifiers of CfgTreatment dedicated to the calling list. Optional.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.DBID Property
CfgCallingList Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Description Property
CfgCallingList Class See Also Send Feedback
A pointer to the calling list description.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Filter Property
CfgCallingList Class See Also Send Feedback
A unique identifier of CfgFilter of this calling list. Optional. If specified, the filter format must have reference to the format the table access refers to.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilter Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As CfgFilter
Visual C++
public:
property CfgFilter^ Filter {
    CfgFilter^ get ();
    void set (CfgFilter^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LogTableAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.LogTableAccess Property
CfgCallingList Class See Also Send Feedback
A unique identifier of logTableAccess. It is recommended to dedicate single logTableAccessDBID to all CallingLists associated with one Campaign. . Reference to CfgTableAccess object of CFGTTLogTable type can be used only. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccess LogTableAccess { get; set; }
Visual Basic (Declaration)
Public Property LogTableAccess As CfgTableAccess
Visual C++
public:
property CfgTableAccess^ LogTableAccess {
    CfgTableAccess^ get ();
    void set (CfgTableAccess^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MaxAttempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.MaxAttempts Property
CfgCallingList Class See Also Send Feedback
A maximum number of attempts the single record can be dialed for one campaign (total). Default value is 10. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxAttempts { get; set; }
Visual Basic (Declaration)
Public Property MaxAttempts As Integer
Visual C++
public:
property int MaxAttempts {
    int get ();
    void set (int value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Name Property
CfgCallingList Class See Also Send Feedback
A pointer to the calling list name. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Script Property
CfgCallingList Class See Also Send Feedback
A unique identifier of the CfgScript for this calling list. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; set; }
Visual Basic (Declaration)
Public Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.State Property
CfgCallingList Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TableAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.TableAccess Property
CfgCallingList Class See Also Send Feedback
A unique identifier of the table the calling list refers to. Reference to CfgTableAccess object of CFGTTCallingList type can be used only. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccess TableAccess { get; set; }
Visual Basic (Declaration)
Public Property TableAccess As CfgTableAccess
Visual C++
public:
property CfgTableAccess^ TableAccess {
    CfgTableAccess^ get ();
    void set (CfgTableAccess^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Tenant Property
CfgCallingList Class See Also Send Feedback
A unique identifier of the CfgTenant to which this calling list is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeFrom Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.TimeFrom Property
CfgCallingList Class See Also Send Feedback
An earliest time when dial can be done. The value is measured in seconds since 00:00:00 of current day. Default value is 08:00:00. Overwrites the settings in database table specified in field CFGFrom. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeFrom { get; set; }
Visual Basic (Declaration)
Public Property TimeFrom As Integer
Visual C++
public:
property int TimeFrom {
    int get ();
    void set (int value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeUntil Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.TimeUntil Property
CfgCallingList Class See Also Send Feedback
An latest time when dial can be done. The value is measured in seconds since 00:00:00 of current day. Default value is 18:00:00. Overwrites the settings in database table specified in field CFGUntil. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeUntil { get; set; }
Visual Basic (Declaration)
Public Property TimeUntil As Integer
Visual C++
public:
property int TimeUntil {
    int get ();
    void set (int value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Treatments Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.Treatments Property
CfgCallingList Class See Also Send Feedback
A pointer to list of identifiers of CfgTreatment dedicated to the calling list. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTreatment> Treatments { get; set; }
Visual Basic (Declaration)
Public Property Treatments As ICollection(Of CfgTreatment)
Visual C++
public:
property ICollection<CfgTreatment^>^ Treatments {
    ICollection<CfgTreatment^>^ get ();
    void set (ICollection<CfgTreatment^>^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingList..::.UserProperties Property
CfgCallingList Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingListInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo Class
Members See Also Send Feedback
CfgCallingListInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingListInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgCallingListInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgCallingListInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCallingListInfo

See Also

CfgCallingListInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingListInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo Members
CfgCallingListInfo Class Constructors Methods Properties See Also Send Feedback

The CfgCallingListInfo type exposes the following members.

Constructors

Name | Description
CfgCallingListInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetCallingListDBID | SetCallingListDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
CallingList | A unique identifier of the CfgCallingList . Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IsActive | An indicator of whether the calling list is active. See type CfgFlag . Default value is CFGTrue.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Share | A list share factor (list weight). Default value is 10. The calling list is disabled if share factor is set to 0.

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingListInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo Constructor
CfgCallingListInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingListInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgCallingListInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingListInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingListInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingListInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingListInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo Methods
CfgCallingListInfo Class See Also Send Feedback

The CfgCallingListInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetCallingListDBID | SetCallingListDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCallingListDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo..::.SetCallingListDBID Method
CfgCallingListInfo Class See Also Send Feedback
SetCallingListDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCallingListDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCallingListDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCallingListDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCallingListInfo.SetCallingListDBID(System.Int32)"]

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCallingListInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo Properties
CfgCallingListInfo Class See Also Send Feedback

The CfgCallingListInfo type exposes the following members.

Properties

Name | Description
CallingList | A unique identifier of the CfgCallingList . Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IsActive | An indicator of whether the calling list is active. See type CfgFlag . Default value is CFGTrue.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Share | A list share factor (list weight). Default value is 10. The calling list is disabled if share factor is set to 0.

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CallingList Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo..::.CallingList Property
CfgCallingListInfo Class See Also Send Feedback
A unique identifier of the CfgCallingList . Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingList CallingList { get; set; }
Visual Basic (Declaration)
Public Property CallingList As CfgCallingList
Visual C++
public:
property CfgCallingList^ CallingList {
    CfgCallingList^ get ();
    void set (CfgCallingList^ value);
}

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsActive Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo..::.IsActive Property
CfgCallingListInfo Class See Also Send Feedback
An indicator of whether the calling list is active. See type CfgFlag . Default value is CFGTrue.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As CfgFlag
Visual C++
public:
property CfgFlag IsActive {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Share Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfo..::.Share Property
CfgCallingListInfo Class See Also Send Feedback
A list share factor (list weight). Default value is 10. The calling list is disabled if share factor is set to 0.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Share { get; set; }
Visual Basic (Declaration)
Public Property Share As Integer
Visual C++
public:
property int Share {
    int get ();
    void set (int value);
}

See Also

CfgCallingListInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaign Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign Class
Members See Also Send Feedback
Campaigns are structures for organizing and managing an automated process of making outbound calls to the destinations specified in Calling Lists.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaign : CfgObject
Visual Basic (Declaration)
Public Class CfgCampaign _
    Inherits CfgObject
Visual C++
public ref class CfgCampaign : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCampaign

See Also

CfgCampaign Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaign Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaign Members
CfgCampaign Class Constructors Methods Properties See Also Send Feedback

The CfgCampaign type exposes the following members.

Constructors

Name | Description
CfgCampaign | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetScriptDBID
SetScriptDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
CallingLists | A pointer to list of calling lists info dedicated to campaign(every item of this list is structured as CfgCallingListInfo ).
CampaignGroups | Not in use starting from 7.5 release. Campaign Groups are represented as CfgCampaignGroup objects under the Campaigns
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the campaign description.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the campaign name. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the campaign CfgScript . Optional.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this campaign is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaign Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign Constructor
CfgCampaign Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaign(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgCampaign(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaign.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaign.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaign Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaign Methods
CfgCampaign Class See Also Send Feedback

The CfgCampaign type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetScriptDBID
SetScriptDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.Save Method
CfgCampaign Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.SetAccountPermissions Method
CfgCampaign Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgCampaign Class
CfgCampaign Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetScriptDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.SetScriptDBID Method
CfgCampaign Class See Also Send Feedback
SetScriptDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetScriptDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetScriptDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetScriptDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaign.SetScriptDBID(System.Int32)"]

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.SetTenantDBID Method
CfgCampaign Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaign.SetTenantDBID(System.Int32)"]

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaign Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaign Properties
CfgCampaign Class See Also Send Feedback

The CfgCampaign type exposes the following members.

Properties

Name | Description
CallingLists | A pointer to list of calling lists info dedicated to campaign(every item of this list is structured as CfgCallingListInfo ).
CampaignGroups | Not in use starting from 7.5 release. Campaign Groups are represented as CfgCampaignGroup objects under the Campaigns
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the campaign description.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the campaign name. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the campaign CfgScript . Optional.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this campaign is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CallingLists Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.CallingLists Property
CfgCampaign Class See Also Send Feedback
A pointer to list of calling lists info dedicated to campaign(every item of this list is structured as CfgCallingListInfo ).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCallingListInfo> CallingLists { get; set; }
Visual Basic (Declaration)
Public Property CallingLists As ICollection(Of CfgCallingListInfo)
Visual C++
public:
property ICollection<CfgCallingListInfo^>^ CallingLists {
    ICollection<CfgCallingListInfo^>^ get ();
    void set (ICollection<CfgCallingListInfo^>^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CampaignGroups Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.CampaignGroups Property
CfgCampaign Class See Also Send Feedback
Not in use starting from 7.5 release. Campaign Groups are represented as CfgCampaignGroup objects under the Campaigns

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCampaignGroupInfo> CampaignGroups { get; set; }
Visual Basic (Declaration)
Public Property CampaignGroups As ICollection(Of CfgCampaignGroupInfo)
Visual C++
public:
property ICollection<CfgCampaignGroupInfo^>^ CampaignGroups {
    ICollection<CfgCampaignGroupInfo^>^ get ();
    void set (ICollection<CfgCampaignGroupInfo^>^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.DBID Property
CfgCampaign Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.Description Property
CfgCampaign Class See Also Send Feedback
A pointer to the campaign description.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.Name Property
CfgCampaign Class See Also Send Feedback
A pointer to the campaign name. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.Script Property
CfgCampaign Class See Also Send Feedback
A unique identifier of the campaign CfgScript . Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; set; }
Visual Basic (Declaration)
Public Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.State Property
CfgCampaign Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.Tenant Property
CfgCampaign Class See Also Send Feedback
A unique identifier of the CfgTenant to which this campaign is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaign..::.UserProperties Property
CfgCampaign Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup Class
Members See Also Send Feedback
CfgCampaignGroup objects contain information about Campaign groups.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroup : CfgObject
Visual Basic (Declaration)
Public Class CfgCampaignGroup _
    Inherits CfgObject
Visual C++
public ref class CfgCampaignGroup : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCampaignGroup

See Also

CfgCampaignGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup Members
CfgCampaignGroup Class Constructors Methods Properties See Also Send Feedback

The CfgCampaignGroup type exposes the following members.

Constructors

Name | Description
CfgCampaignGroup | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetCampaignDBID
SetCampaignDBID
SetInteractionQueueDBID
SetInteractionQueueDBID
SetIVRProfileDBID
SetIVRProfileDBID
SetOrigDNDBID
SetOrigDNDBID
SetScriptDBID
SetScriptDBID
SetTenantDBID
SetTenantDBID
SetTrunkGroupDNDBID
SetTrunkGroupDNDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Campaign | A unique identifier of the CfgCampaign to which this campaign group is allocated. Mandatory. Once specified, cannot be changed.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to campaign group description.
DialMode | A dial mode dedicated for this group. Default value is CFGDMPredict. See type CfgDialMode . Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupDBID | A unique identifier of the group of Agents or group of Places . Mandatory.
GroupType | A group type. Read only. See CfgObjectType
InteractionQueue | A unique identifier of the Script of type CFGInteractionQueue for this campaign group. Optional.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRProfile | A unique identifier of the object Optional.
Logger | (Inherited from AbstractLogEnabled.)
MaxQueueSize | Maximal number of unprocessed Interactions submitted to Interaction Server or GVP OBN Manager. Optional.
MinRecBuffSize | A record buffering parameter. Default value is 4. Cannot be set to 0. Mandatory.
Name | A pointer to the campaign group name. Mandatory. Must be unique within the Campaign.
NumOfChannels | Maximum number of outbound channels that can be used by this group at one time. Default value is 10. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OperationMode | An operation mode. Default value is CFGOMManual . Refer to CfgOperationMode of User Defined Variable Types. Mandatory.
OptMethod | An optimization method. Default value is CFGOMBusyFactor. Refer to CfgOptimizationMethod of User Defined Variable Types. Mandatory.
OptMethodValue | The value of optimization method specified by optMethod property. Refer to CFGOptimizationMethod of User Defined Variable Types for ranges and default values.
OptRecBuffSize | A record buffering parameter. Default value is 6. Mandatory. The value of this property must always be greater than minRecBuffSize.
OrigDN | A unique identifier of the DN where the dialing should be performed from. DNs of following types can be used to specify this parameter: CFGACDQueue and CFGRoutingPoint. Refer to CfgDNType of User Defined Variable Types. Optional.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the Script for group/campaign. Optional.
Servers | A pointer to the list of unique identifiers to Application objects. Optional. Will be used to configure connectivity to Servers associated with this Campaign. Only one Application of specific application type (CfgAppType) is allowed in the list.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this campaign group is allocated. Read-only. Its value is populated from the associated Campaign object
TrunkGroupDN |
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroup Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup Constructor
CfgCampaignGroup Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroup(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgCampaignGroup(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup Methods
CfgCampaignGroup Class See Also Send Feedback

The CfgCampaignGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetCampaignDBID
SetCampaignDBID
SetInteractionQueueDBID
SetInteractionQueueDBID
SetIVRProfileDBID
SetIVRProfileDBID
SetOrigDNDBID
SetOrigDNDBID
SetScriptDBID
SetScriptDBID
SetTenantDBID
SetTenantDBID
SetTrunkGroupDNDBID
SetTrunkGroupDNDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Save Method
CfgCampaignGroup Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetAccountPermissions Method
CfgCampaignGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgCampaignGroup Class
CfgCampaignGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCampaignDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetCampaignDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetCampaignDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCampaignDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCampaignDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCampaignDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetCampaignDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetInteractionQueueDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetInteractionQueueDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetInteractionQueueDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetInteractionQueueDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetInteractionQueueDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetInteractionQueueDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetInteractionQueueDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetIVRProfileDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetIVRProfileDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetIVRProfileDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetIVRProfileDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetIVRProfileDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetIVRProfileDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetIVRProfileDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetOrigDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetOrigDNDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetOrigDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetOrigDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetOrigDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetOrigDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetOrigDNDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetScriptDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetScriptDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetScriptDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetScriptDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetScriptDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetScriptDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetScriptDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetTenantDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetTenantDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTrunkGroupDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.SetTrunkGroupDNDBID Method
CfgCampaignGroup Class See Also Send Feedback
SetTrunkGroupDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTrunkGroupDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTrunkGroupDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTrunkGroupDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.SetTrunkGroupDNDBID(System.Int32)"]

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup Properties
CfgCampaignGroup Class See Also Send Feedback

The CfgCampaignGroup type exposes the following members.

Properties

Name | Description
Campaign | A unique identifier of the CfgCampaign to which this campaign group is allocated. Mandatory. Once specified, cannot be changed.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to campaign group description.
DialMode | A dial mode dedicated for this group. Default value is CFGDMPredict. See type CfgDialMode . Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupDBID | A unique identifier of the group of Agents or group of Places . Mandatory.
GroupType | A group type. Read only. See CfgObjectType
InteractionQueue | A unique identifier of the Script of type CFGInteractionQueue for this campaign group. Optional.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRProfile | A unique identifier of the object Optional.
Logger | (Inherited from AbstractLogEnabled.)
MaxQueueSize | Maximal number of unprocessed Interactions submitted to Interaction Server or GVP OBN Manager. Optional.
MinRecBuffSize | A record buffering parameter. Default value is 4. Cannot be set to 0. Mandatory.
Name | A pointer to the campaign group name. Mandatory. Must be unique within the Campaign.
NumOfChannels | Maximum number of outbound channels that can be used by this group at one time. Default value is 10. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OperationMode | An operation mode. Default value is CFGOMManual . Refer to CfgOperationMode of User Defined Variable Types. Mandatory.
OptMethod | An optimization method. Default value is CFGOMBusyFactor. Refer to CfgOptimizationMethod of User Defined Variable Types. Mandatory.
OptMethodValue | The value of optimization method specified by optMethod property. Refer to CFGOptimizationMethod of User Defined Variable Types for ranges and default values.
OptRecBuffSize | A record buffering parameter. Default value is 6. Mandatory. The value of this property must always be greater than minRecBuffSize.
OrigDN | A unique identifier of the DN where the dialing should be performed from. DNs of following types can be used to specify this parameter: CFGACDQueue and CFGRoutingPoint. Refer to CfgDNType of User Defined Variable Types. Optional.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the Script for group/campaign. Optional.
Servers | A pointer to the list of unique identifiers to Application objects. Optional. Will be used to configure connectivity to Servers associated with this Campaign. Only one Application of specific application type (CfgAppType) is allowed in the list.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this campaign group is allocated. Read-only. Its value is populated from the associated Campaign object
TrunkGroupDN |
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Campaign Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Campaign Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the CfgCampaign to which this campaign group is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaign Campaign { get; set; }
Visual Basic (Declaration)
Public Property Campaign As CfgCampaign
Visual C++
public:
property CfgCampaign^ Campaign {
    CfgCampaign^ get ();
    void set (CfgCampaign^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.DBID Property
CfgCampaignGroup Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Description Property
CfgCampaignGroup Class See Also Send Feedback
A pointer to campaign group description.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DialMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.DialMode Property
CfgCampaignGroup Class See Also Send Feedback
A dial mode dedicated for this group. Default value is CFGDMPredict. See type CfgDialMode . Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDialMode DialMode { get; set; }
Visual Basic (Declaration)
Public Property DialMode As CfgDialMode
Visual C++
public:
property CfgDialMode DialMode {
    CfgDialMode get ();
    void set (CfgDialMode value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.GroupDBID Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the group of Agents or group of Places . Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int GroupDBID { get; set; }
Visual Basic (Declaration)
Public Property GroupDBID As Integer
Visual C++
public:
property int GroupDBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.GroupType Property
CfgCampaignGroup Class See Also Send Feedback
A group type. Read only. See CfgObjectType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As CfgObjectType
Visual C++
public:
property CfgObjectType GroupType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


InteractionQueue Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.InteractionQueue Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the Script of type CFGInteractionQueue for this campaign group. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript InteractionQueue { get; set; }
Visual Basic (Declaration)
Public Property InteractionQueue As CfgScript
Visual C++
public:
property CfgScript^ InteractionQueue {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IVRProfile Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.IVRProfile Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the object Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPIVRProfile IVRProfile { get; set; }
Visual Basic (Declaration)
Public Property IVRProfile As CfgGVPIVRProfile
Visual C++
public:
property CfgGVPIVRProfile^ IVRProfile {
    CfgGVPIVRProfile^ get ();
    void set (CfgGVPIVRProfile^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MaxQueueSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.MaxQueueSize Property
CfgCampaignGroup Class See Also Send Feedback
Maximal number of unprocessed Interactions submitted to Interaction Server or GVP OBN Manager. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxQueueSize { get; set; }
Visual Basic (Declaration)
Public Property MaxQueueSize As Integer
Visual C++
public:
property int MaxQueueSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MinRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.MinRecBuffSize Property
CfgCampaignGroup Class See Also Send Feedback
A record buffering parameter. Default value is 4. Cannot be set to 0. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property MinRecBuffSize As Integer
Visual C++
public:
property int MinRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Name Property
CfgCampaignGroup Class See Also Send Feedback
A pointer to the campaign group name. Mandatory. Must be unique within the Campaign.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NumOfChannels Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.NumOfChannels Property
CfgCampaignGroup Class See Also Send Feedback
Maximum number of outbound channels that can be used by this group at one time. Default value is 10. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int NumOfChannels { get; set; }
Visual Basic (Declaration)
Public Property NumOfChannels As Integer
Visual C++
public:
property int NumOfChannels {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OperationMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.OperationMode Property
CfgCampaignGroup Class See Also Send Feedback
An operation mode. Default value is CFGOMManual . Refer to CfgOperationMode of User Defined Variable Types. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOperationMode OperationMode { get; set; }
Visual Basic (Declaration)
Public Property OperationMode As CfgOperationMode
Visual C++
public:
property CfgOperationMode OperationMode {
    CfgOperationMode get ();
    void set (CfgOperationMode value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptMethod Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.OptMethod Property
CfgCampaignGroup Class See Also Send Feedback
An optimization method. Default value is CFGOMBusyFactor. Refer to CfgOptimizationMethod of User Defined Variable Types. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOptimizationMethod OptMethod { get; set; }
Visual Basic (Declaration)
Public Property OptMethod As CfgOptimizationMethod
Visual C++
public:
property CfgOptimizationMethod OptMethod {
    CfgOptimizationMethod get ();
    void set (CfgOptimizationMethod value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptMethodValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.OptMethodValue Property
CfgCampaignGroup Class See Also Send Feedback
The value of optimization method specified by optMethod property. Refer to CFGOptimizationMethod of User Defined Variable Types for ranges and default values.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptMethodValue { get; set; }
Visual Basic (Declaration)
Public Property OptMethodValue As Integer
Visual C++
public:
property int OptMethodValue {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.OptRecBuffSize Property
CfgCampaignGroup Class See Also Send Feedback
A record buffering parameter. Default value is 6. Mandatory. The value of this property must always be greater than minRecBuffSize.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property OptRecBuffSize As Integer
Visual C++
public:
property int OptRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OrigDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.OrigDN Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the DN where the dialing should be performed from. DNs of following types can be used to specify this parameter: CFGACDQueue and CFGRoutingPoint. Refer to CfgDNType of User Defined Variable Types. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN OrigDN { get; set; }
Visual Basic (Declaration)
Public Property OrigDN As CfgDN
Visual C++
public:
property CfgDN^ OrigDN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Script Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the Script for group/campaign. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; set; }
Visual Basic (Declaration)
Public Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Servers Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Servers Property
CfgCampaignGroup Class See Also Send Feedback
A pointer to the list of unique identifiers to Application objects. Optional. Will be used to configure connectivity to Servers associated with this Campaign. Only one Application of specific application type (CfgAppType) is allowed in the list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgApplication> Servers { get; set; }
Visual Basic (Declaration)
Public Property Servers As ICollection(Of CfgApplication)
Visual C++
public:
property ICollection<CfgApplication^>^ Servers {
    ICollection<CfgApplication^>^ get ();
    void set (ICollection<CfgApplication^>^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.State Property
CfgCampaignGroup Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.Tenant Property
CfgCampaignGroup Class See Also Send Feedback
A unique identifier of the CfgTenant to which this campaign group is allocated. Read-only. Its value is populated from the associated Campaign object

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TrunkGroupDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.TrunkGroupDN Property
CfgCampaignGroup Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroup.TrunkGroupDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN TrunkGroupDN { get; set; }
Visual Basic (Declaration)
Public Property TrunkGroupDN As CfgDN
Visual C++
public:
property CfgDN^ TrunkGroupDN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroup..::.UserProperties Property
CfgCampaignGroup Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroupInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo Class
Members See Also Send Feedback
CfgCampaignGroupInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroupInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgCampaignGroupInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgCampaignGroupInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgCampaignGroupInfo

See Also

CfgCampaignGroupInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroupInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo Members
CfgCampaignGroupInfo Class Constructors Methods Properties See Also Send Feedback

The CfgCampaignGroupInfo type exposes the following members.

Constructors

Name | Description
CfgCampaignGroupInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetDialerDBID | SetDialerDBID
SetOrigDNDBID | SetOrigDNDBID
SetScriptDBID | SetScriptDBID
SetStatServerDBID | SetStatServerDBID
SetTrunkGroupDNDBID | SetTrunkGroupDNDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Description |
Dialer |
DialMode |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
GroupDBID |
GroupType |
IsActive |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MinRecBuffSize |
NumOfChannels |
OperationMode |
OptMethod |
OptMethodValue |
OptRecBuffSize |
OrigDN |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Script |
StatServer |
TrunkGroupDN |

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroupInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo Constructor
CfgCampaignGroupInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroupInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgCampaignGroupInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroupInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo Methods
CfgCampaignGroupInfo Class See Also Send Feedback

The CfgCampaignGroupInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetDialerDBID | SetDialerDBID
SetOrigDNDBID | SetOrigDNDBID
SetScriptDBID | SetScriptDBID
SetStatServerDBID | SetStatServerDBID
SetTrunkGroupDNDBID | SetTrunkGroupDNDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDialerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.SetDialerDBID Method
CfgCampaignGroupInfo Class See Also Send Feedback
SetDialerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDialerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDialerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDialerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.SetDialerDBID(System.Int32)"]

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetOrigDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.SetOrigDNDBID Method
CfgCampaignGroupInfo Class See Also Send Feedback
SetOrigDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetOrigDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetOrigDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetOrigDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.SetOrigDNDBID(System.Int32)"]

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetScriptDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.SetScriptDBID Method
CfgCampaignGroupInfo Class See Also Send Feedback
SetScriptDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetScriptDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetScriptDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetScriptDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.SetScriptDBID(System.Int32)"]

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetStatServerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.SetStatServerDBID Method
CfgCampaignGroupInfo Class See Also Send Feedback
SetStatServerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetStatServerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetStatServerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetStatServerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.SetStatServerDBID(System.Int32)"]

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTrunkGroupDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.SetTrunkGroupDNDBID Method
CfgCampaignGroupInfo Class See Also Send Feedback
SetTrunkGroupDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTrunkGroupDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTrunkGroupDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTrunkGroupDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.SetTrunkGroupDNDBID(System.Int32)"]

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgCampaignGroupInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo Properties
CfgCampaignGroupInfo Class See Also Send Feedback

The CfgCampaignGroupInfo type exposes the following members.

Properties

Name | Description
Description |
Dialer |
DialMode |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
GroupDBID |
GroupType |
IsActive |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MinRecBuffSize |
NumOfChannels |
OperationMode |
OptMethod |
OptMethodValue |
OptRecBuffSize |
OrigDN |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Script |
StatServer |
TrunkGroupDN |

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.Description Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Dialer Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.Dialer Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.Dialer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication Dialer { get; set; }
Visual Basic (Declaration)
Public Property Dialer As CfgApplication
Visual C++
public:
property CfgApplication^ Dialer {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DialMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.DialMode Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.DialMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDialMode DialMode { get; set; }
Visual Basic (Declaration)
Public Property DialMode As CfgDialMode
Visual C++
public:
property CfgDialMode DialMode {
    CfgDialMode get ();
    void set (CfgDialMode value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.GroupDBID Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.GroupDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int GroupDBID { get; set; }
Visual Basic (Declaration)
Public Property GroupDBID As Integer
Visual C++
public:
property int GroupDBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.GroupType Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.GroupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As CfgObjectType
Visual C++
public:
property CfgObjectType GroupType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsActive Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.IsActive Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.IsActive"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As CfgFlag
Visual C++
public:
property CfgFlag IsActive {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MinRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.MinRecBuffSize Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.MinRecBuffSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property MinRecBuffSize As Integer
Visual C++
public:
property int MinRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NumOfChannels Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.NumOfChannels Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.NumOfChannels"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int NumOfChannels { get; set; }
Visual Basic (Declaration)
Public Property NumOfChannels As Integer
Visual C++
public:
property int NumOfChannels {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OperationMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.OperationMode Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.OperationMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOperationMode OperationMode { get; set; }
Visual Basic (Declaration)
Public Property OperationMode As CfgOperationMode
Visual C++
public:
property CfgOperationMode OperationMode {
    CfgOperationMode get ();
    void set (CfgOperationMode value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptMethod Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.OptMethod Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.OptMethod"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOptimizationMethod OptMethod { get; set; }
Visual Basic (Declaration)
Public Property OptMethod As CfgOptimizationMethod
Visual C++
public:
property CfgOptimizationMethod OptMethod {
    CfgOptimizationMethod get ();
    void set (CfgOptimizationMethod value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptMethodValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.OptMethodValue Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.OptMethodValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptMethodValue { get; set; }
Visual Basic (Declaration)
Public Property OptMethodValue As Integer
Visual C++
public:
property int OptMethodValue {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.OptRecBuffSize Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.OptRecBuffSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property OptRecBuffSize As Integer
Visual C++
public:
property int OptRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OrigDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.OrigDN Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.OrigDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN OrigDN { get; set; }
Visual Basic (Declaration)
Public Property OrigDN As CfgDN
Visual C++
public:
property CfgDN^ OrigDN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.Script Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.Script"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; set; }
Visual Basic (Declaration)
Public Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.StatServer Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.StatServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication StatServer { get; set; }
Visual Basic (Declaration)
Public Property StatServer As CfgApplication
Visual C++
public:
property CfgApplication^ StatServer {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TrunkGroupDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfo..::.TrunkGroupDN Property
CfgCampaignGroupInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgCampaignGroupInfo.TrunkGroupDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN TrunkGroupDN { get; set; }
Visual Basic (Declaration)
Public Property TrunkGroupDN As CfgDN
Visual C++
public:
property CfgDN^ TrunkGroupDN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgCampaignGroupInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgConnInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo Class
Members See Also Send Feedback
CfgConnInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgConnInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgConnInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgConnInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgConnInfo

See Also

CfgConnInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgConnInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfo Members
CfgConnInfo Class Constructors Methods Properties See Also Send Feedback

The CfgConnInfo type exposes the following members.

Constructors

Name | Description
CfgConnInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAppServerDBID | SetAppServerDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AppParams | Connection protocol's application parameters
AppServer | The unique identifier of the Server this application shall connect to as a client when it is started.
CharField1 | Optional text field #1
CharField2 | Optional text field #2
CharField3 | Optional text field #3
CharField4 | Optional text field #4
ConnProtocol | A pointer to the name of the connection control protocol. Available values: addp. Default: none.
Description | Optional description of the connection
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Id | An identifier of the server's listening port. Should correspond to CfgPortInfo.id.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LongField1 | Optional integer field #1
LongField2 | Optional integer field #2
LongField3 | Optional integer field #3
LongField4 | Optional integer field #3
Mode | The trace mode dedicated for this connection. Refer to CfgTraceMode below. Default value: CFGTMNoTraceMode.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ProxyParams | Connection protocol's proxy parameters
TimoutLocal | The heart-bit polling interval measured in seconds, on client site.
TimoutRemote | The heart-bit polling interval measured in seconds, on server site.
TransportParams | Connection protocol's transport parameters

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgConnInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo Constructor
CfgConnInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgConnInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgConnInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgConnInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgConnInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgConnInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgConnInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfo Methods
CfgConnInfo Class See Also Send Feedback

The CfgConnInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAppServerDBID | SetAppServerDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAppServerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.SetAppServerDBID Method
CfgConnInfo Class See Also Send Feedback
SetAppServerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAppServerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAppServerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAppServerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgConnInfo.SetAppServerDBID(System.Int32)"]

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgConnInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfo Properties
CfgConnInfo Class See Also Send Feedback

The CfgConnInfo type exposes the following members.

Properties

Name | Description
AppParams | Connection protocol's application parameters
AppServer | The unique identifier of the Server this application shall connect to as a client when it is started.
CharField1 | Optional text field #1
CharField2 | Optional text field #2
CharField3 | Optional text field #3
CharField4 | Optional text field #4
ConnProtocol | A pointer to the name of the connection control protocol. Available values: addp. Default: none.
Description | Optional description of the connection
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Id | An identifier of the server's listening port. Should correspond to CfgPortInfo.id.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LongField1 | Optional integer field #1
LongField2 | Optional integer field #2
LongField3 | Optional integer field #3
LongField4 | Optional integer field #3
Mode | The trace mode dedicated for this connection. Refer to CfgTraceMode below. Default value: CFGTMNoTraceMode.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ProxyParams | Connection protocol's proxy parameters
TimoutLocal | The heart-bit polling interval measured in seconds, on client site.
TimoutRemote | The heart-bit polling interval measured in seconds, on server site.
TransportParams | Connection protocol's transport parameters

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.AppParams Property
CfgConnInfo Class See Also Send Feedback
Connection protocol's application parameters

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AppParams { get; set; }
Visual Basic (Declaration)
Public Property AppParams As String
Visual C++
public:
property String^ AppParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.AppServer Property
CfgConnInfo Class See Also Send Feedback
The unique identifier of the Server this application shall connect to as a client when it is started.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication AppServer { get; set; }
Visual Basic (Declaration)
Public Property AppServer As CfgApplication
Visual C++
public:
property CfgApplication^ AppServer {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.CharField1 Property
CfgConnInfo Class See Also Send Feedback
Optional text field #1

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField1 { get; set; }
Visual Basic (Declaration)
Public Property CharField1 As String
Visual C++
public:
property String^ CharField1 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.CharField2 Property
CfgConnInfo Class See Also Send Feedback
Optional text field #2

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField2 { get; set; }
Visual Basic (Declaration)
Public Property CharField2 As String
Visual C++
public:
property String^ CharField2 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.CharField3 Property
CfgConnInfo Class See Also Send Feedback
Optional text field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField3 { get; set; }
Visual Basic (Declaration)
Public Property CharField3 As String
Visual C++
public:
property String^ CharField3 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.CharField4 Property
CfgConnInfo Class See Also Send Feedback
Optional text field #4

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField4 { get; set; }
Visual Basic (Declaration)
Public Property CharField4 As String
Visual C++
public:
property String^ CharField4 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ConnProtocol Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.ConnProtocol Property
CfgConnInfo Class See Also Send Feedback
A pointer to the name of the connection control protocol. Available values: addp. Default: none.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ConnProtocol { get; set; }
Visual Basic (Declaration)
Public Property ConnProtocol As String
Visual C++
public:
property String^ ConnProtocol {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.Description Property
CfgConnInfo Class See Also Send Feedback
Optional description of the connection

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.Id Property
CfgConnInfo Class See Also Send Feedback
An identifier of the server's listening port. Should correspond to CfgPortInfo.id.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.LongField1 Property
CfgConnInfo Class See Also Send Feedback
Optional integer field #1

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField1 { get; set; }
Visual Basic (Declaration)
Public Property LongField1 As Integer
Visual C++
public:
property int LongField1 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.LongField2 Property
CfgConnInfo Class See Also Send Feedback
Optional integer field #2

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField2 { get; set; }
Visual Basic (Declaration)
Public Property LongField2 As Integer
Visual C++
public:
property int LongField2 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.LongField3 Property
CfgConnInfo Class See Also Send Feedback
Optional integer field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField3 { get; set; }
Visual Basic (Declaration)
Public Property LongField3 As Integer
Visual C++
public:
property int LongField3 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.LongField4 Property
CfgConnInfo Class See Also Send Feedback
Optional integer field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField4 { get; set; }
Visual Basic (Declaration)
Public Property LongField4 As Integer
Visual C++
public:
property int LongField4 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.Mode Property
CfgConnInfo Class See Also Send Feedback
The trace mode dedicated for this connection. Refer to CfgTraceMode below. Default value: CFGTMNoTraceMode.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTraceMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As CfgTraceMode
Visual C++
public:
property CfgTraceMode Mode {
    CfgTraceMode get ();
    void set (CfgTraceMode value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ProxyParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.ProxyParams Property
CfgConnInfo Class See Also Send Feedback
Connection protocol's proxy parameters

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ProxyParams { get; set; }
Visual Basic (Declaration)
Public Property ProxyParams As String
Visual C++
public:
property String^ ProxyParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimoutLocal Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.TimoutLocal Property
CfgConnInfo Class See Also Send Feedback
The heart-bit polling interval measured in seconds, on client site.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimoutLocal { get; set; }
Visual Basic (Declaration)
Public Property TimoutLocal As Integer
Visual C++
public:
property int TimoutLocal {
    int get ();
    void set (int value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimoutRemote Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.TimoutRemote Property
CfgConnInfo Class See Also Send Feedback
The heart-bit polling interval measured in seconds, on server site.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimoutRemote { get; set; }
Visual Basic (Declaration)
Public Property TimoutRemote As Integer
Visual C++
public:
property int TimoutRemote {
    int get ();
    void set (int value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TransportParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfo..::.TransportParams Property
CfgConnInfo Class See Also Send Feedback
Connection protocol's transport parameters

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string TransportParams { get; set; }
Visual Basic (Declaration)
Public Property TransportParams As String
Visual C++
public:
property String^ TransportParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDelSwitchAccess Class

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess Class
Members See Also Send Feedback
CfgDelSwitchAccess

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDelSwitchAccess : CfgStructure
Visual Basic (Declaration)
Public Class CfgDelSwitchAccess _
    Inherits CfgStructure
Visual C++
public ref class CfgDelSwitchAccess : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDelSwitchAccess

See Also

CfgDelSwitchAccess Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDelSwitchAccess Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess Members
CfgDelSwitchAccess Class Constructors Methods Properties See Also Send Feedback

The CfgDelSwitchAccess type exposes the following members.

Constructors

Name | Description
CfgDelSwitchAccess | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSwitchDBID | SetSwitchDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AccessCode |
DestinationSource |
DnisSource |
DnSource |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExtensionSource |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LocationSource |
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ReasonSource |
RouteType |
Switch |
TargetType |

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDelSwitchAccess Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess Constructor
CfgDelSwitchAccess Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDelSwitchAccess(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgDelSwitchAccess(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDelSwitchAccess Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess Methods
CfgDelSwitchAccess Class See Also Send Feedback

The CfgDelSwitchAccess type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSwitchDBID | SetSwitchDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.SetSwitchDBID Method
CfgDelSwitchAccess Class See Also Send Feedback
SetSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.SetSwitchDBID(System.Int32)"]

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDelSwitchAccess Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess Properties
CfgDelSwitchAccess Class See Also Send Feedback

The CfgDelSwitchAccess type exposes the following members.

Properties

Name | Description
AccessCode |
DestinationSource |
DnisSource |
DnSource |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExtensionSource |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LocationSource |
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ReasonSource |
RouteType |
Switch |
TargetType |

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AccessCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.AccessCode Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.AccessCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AccessCode { get; set; }
Visual Basic (Declaration)
Public Property AccessCode As String
Visual C++
public:
property String^ AccessCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DestinationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.DestinationSource Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.DestinationSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DestinationSource { get; set; }
Visual Basic (Declaration)
Public Property DestinationSource As String
Visual C++
public:
property String^ DestinationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DnisSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.DnisSource Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.DnisSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnisSource { get; set; }
Visual Basic (Declaration)
Public Property DnisSource As String
Visual C++
public:
property String^ DnisSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DnSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.DnSource Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.DnSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnSource { get; set; }
Visual Basic (Declaration)
Public Property DnSource As String
Visual C++
public:
property String^ DnSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ExtensionSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.ExtensionSource Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.ExtensionSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExtensionSource { get; set; }
Visual Basic (Declaration)
Public Property ExtensionSource As String
Visual C++
public:
property String^ ExtensionSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LocationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.LocationSource Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.LocationSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LocationSource { get; set; }
Visual Basic (Declaration)
Public Property LocationSource As String
Visual C++
public:
property String^ LocationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ReasonSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.ReasonSource Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.ReasonSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ReasonSource { get; set; }
Visual Basic (Declaration)
Public Property ReasonSource As String
Visual C++
public:
property String^ ReasonSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.RouteType Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.RouteType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; set; }
Visual Basic (Declaration)
Public Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
    void set (CfgRouteType value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.Switch Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
    void set (CfgSwitch^ value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TargetType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccess..::.TargetType Property
CfgDelSwitchAccess Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDelSwitchAccess.TargetType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTargetType TargetType { get; set; }
Visual Basic (Declaration)
Public Property TargetType As CfgTargetType
Visual C++
public:
property CfgTargetType TargetType {
    CfgTargetType get ();
    void set (CfgTargetType value);
}

See Also

CfgDelSwitchAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAccessGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup Class
Members See Also Send Feedback
CfgDeltaAccessGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaAccessGroup : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaAccessGroup _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaAccessGroup : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAccessGroup

See Also

CfgDeltaAccessGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAccessGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup Members
CfgDeltaAccessGroup Class Methods Properties See Also Send Feedback

The CfgDeltaAccessGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedMemberIDs | AddedMemberIDs
DBID | The DBID of the CfgDeltaAccessGroup configuration object.
DeletedMemberIDs | DeletedMemberIDs
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAccessGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup Methods
CfgDeltaAccessGroup Class See Also Send Feedback

The CfgDeltaAccessGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup..::.SetAccountPermissions Method
CfgDeltaAccessGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaAccessGroup Class
CfgDeltaAccessGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAccessGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup Properties
CfgDeltaAccessGroup Class See Also Send Feedback

The CfgDeltaAccessGroup type exposes the following members.

Properties

Name | Description
AddedMemberIDs | AddedMemberIDs
DBID | The DBID of the CfgDeltaAccessGroup configuration object.
DeletedMemberIDs | DeletedMemberIDs
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedMemberIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup..::.AddedMemberIDs Property
CfgDeltaAccessGroup Class See Also Send Feedback
AddedMemberIDs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgMemberID> AddedMemberIDs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedMemberIDs As ICollection(Of CfgMemberID)
Visual C++
public:
property ICollection<CfgMemberID^>^ AddedMemberIDs {
    ICollection<CfgMemberID^>^ get ();
}

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup..::.DBID Property
CfgDeltaAccessGroup Class See Also Send Feedback
The DBID of the CfgDeltaAccessGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedMemberIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup..::.DeletedMemberIDs Property
CfgDeltaAccessGroup Class See Also Send Feedback
DeletedMemberIDs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgMemberID> DeletedMemberIDs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedMemberIDs As ICollection(Of CfgMemberID)
Visual C++
public:
property ICollection<CfgMemberID^>^ DeletedMemberIDs {
    ICollection<CfgMemberID^>^ get ();
}

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeltaGroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAccessGroup..::.DeltaGroupInfo Property
CfgDeltaAccessGroup Class See Also Send Feedback
DeltaGroupInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDeltaGroup DeltaGroupInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaGroupInfo As CfgDeltaGroup
Visual C++
public:
property CfgDeltaGroup^ DeltaGroupInfo {
    CfgDeltaGroup^ get ();
}

See Also

CfgDeltaAccessGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaActionCode Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode Class
Members See Also Send Feedback
CfgDeltaActionCode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaActionCode : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaActionCode _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaActionCode : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaActionCode

See Also

CfgDeltaActionCode Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaActionCode Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode Members
CfgDeltaActionCode Class Methods Properties See Also Send Feedback

The CfgDeltaActionCode type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedSubcodes | Subcodes
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
Code | Code
DBID | The DBID of the CfgDeltaActionCode configuration object.
DeletedSubcodes | DeletedSubcodes
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaActionCode Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode Methods
CfgDeltaActionCode Class See Also Send Feedback

The CfgDeltaActionCode type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.SetAccountPermissions Method
CfgDeltaActionCode Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaActionCode Class
CfgDeltaActionCode Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaActionCode Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode Properties
CfgDeltaActionCode Class See Also Send Feedback

The CfgDeltaActionCode type exposes the following members.

Properties

Name | Description
AddedSubcodes | Subcodes
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
Code | Code
DBID | The DBID of the CfgDeltaActionCode configuration object.
DeletedSubcodes | DeletedSubcodes
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedSubcodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.AddedSubcodes Property
CfgDeltaActionCode Class See Also Send Feedback
Subcodes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSubcode> AddedSubcodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedSubcodes As ICollection(Of CfgSubcode)
Visual C++
public:
property ICollection<CfgSubcode^>^ AddedSubcodes {
    ICollection<CfgSubcode^>^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.AddedUserProperties Property
CfgDeltaActionCode Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.ChangedUserProperties Property
CfgDeltaActionCode Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Code Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.Code Property
CfgDeltaActionCode Class See Also Send Feedback
Code

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Code { get; }
Visual Basic (Declaration)
Public ReadOnly Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.DBID Property
CfgDeltaActionCode Class See Also Send Feedback
The DBID of the CfgDeltaActionCode configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedSubcodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.DeletedSubcodes Property
CfgDeltaActionCode Class See Also Send Feedback
DeletedSubcodes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSubcode> DeletedSubcodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedSubcodes As ICollection(Of CfgSubcode)
Visual C++
public:
property ICollection<CfgSubcode^>^ DeletedSubcodes {
    ICollection<CfgSubcode^>^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.DeletedUserProperties Property
CfgDeltaActionCode Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.Name Property
CfgDeltaActionCode Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.State Property
CfgDeltaActionCode Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.Tenant Property
CfgDeltaActionCode Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaActionCode..::.Type Property
CfgDeltaActionCode Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCodeType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgActionCodeType
Visual C++
public:
property CfgActionCodeType Type {
    CfgActionCodeType get ();
}

See Also

CfgDeltaActionCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup Class
Members See Also Send Feedback
CfgDeltaAgentGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaAgentGroup : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaAgentGroup _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaAgentGroup : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAgentGroup

See Also

CfgDeltaAgentGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup Members
CfgDeltaAgentGroup Class Methods Properties See Also Send Feedback

The CfgDeltaAgentGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedAgents | AddedAgents
DBID | The DBID of the CfgDeltaAgentGroup configuration object.
DeletedAgents | DeletedAgents
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup Methods
CfgDeltaAgentGroup Class See Also Send Feedback

The CfgDeltaAgentGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup..::.SetAccountPermissions Method
CfgDeltaAgentGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaAgentGroup Class
CfgDeltaAgentGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup Properties
CfgDeltaAgentGroup Class See Also Send Feedback

The CfgDeltaAgentGroup type exposes the following members.

Properties

Name | Description
AddedAgents | AddedAgents
DBID | The DBID of the CfgDeltaAgentGroup configuration object.
DeletedAgents | DeletedAgents
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedAgents Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup..::.AddedAgents Property
CfgDeltaAgentGroup Class See Also Send Feedback
AddedAgents

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPerson> AddedAgents { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedAgents As ICollection(Of CfgPerson)
Visual C++
public:
property ICollection<CfgPerson^>^ AddedAgents {
    ICollection<CfgPerson^>^ get ();
}

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup..::.DBID Property
CfgDeltaAgentGroup Class See Also Send Feedback
The DBID of the CfgDeltaAgentGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAgents Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup..::.DeletedAgents Property
CfgDeltaAgentGroup Class See Also Send Feedback
DeletedAgents

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPerson> DeletedAgents { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAgents As ICollection(Of CfgPerson)
Visual C++
public:
property ICollection<CfgPerson^>^ DeletedAgents {
    ICollection<CfgPerson^>^ get ();
}

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeltaGroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentGroup..::.DeltaGroupInfo Property
CfgDeltaAgentGroup Class See Also Send Feedback
DeltaGroupInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDeltaGroup DeltaGroupInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaGroupInfo As CfgDeltaGroup
Visual C++
public:
property CfgDeltaGroup^ DeltaGroupInfo {
    CfgDeltaGroup^ get ();
}

See Also

CfgDeltaAgentGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo Class
Members See Also Send Feedback
CfgDeltaAgentInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaAgentInfo : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaAgentInfo _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaAgentInfo : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAgentInfo

See Also

CfgDeltaAgentInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo Members
CfgDeltaAgentInfo Class Methods Properties See Also Send Feedback

The CfgDeltaAgentInfo type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
ChangedAgentLogins | ChangedAgentLogins
ChangedSkillLevels | ChangedSkillLevels
DBID | The DBID of the CfgDeltaAgentInfo configuration object.
DeletedAgentLogins | DeletedAgentLogins
DeletedSkills | DeletedSkills
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo Methods
CfgDeltaAgentInfo Class See Also Send Feedback

The CfgDeltaAgentInfo type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo..::.SetAccountPermissions Method
CfgDeltaAgentInfo Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaAgentInfo Class
CfgDeltaAgentInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo Properties
CfgDeltaAgentInfo Class See Also Send Feedback

The CfgDeltaAgentInfo type exposes the following members.

Properties

Name | Description
ChangedAgentLogins | ChangedAgentLogins
ChangedSkillLevels | ChangedSkillLevels
DBID | The DBID of the CfgDeltaAgentInfo configuration object.
DeletedAgentLogins | DeletedAgentLogins
DeletedSkills | DeletedSkills
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedAgentLogins Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo..::.ChangedAgentLogins Property
CfgDeltaAgentInfo Class See Also Send Feedback
ChangedAgentLogins

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAgentLoginInfo> ChangedAgentLogins { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedAgentLogins As ICollection(Of CfgAgentLoginInfo)
Visual C++
public:
property ICollection<CfgAgentLoginInfo^>^ ChangedAgentLogins {
    ICollection<CfgAgentLoginInfo^>^ get ();
}

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedSkillLevels Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo..::.ChangedSkillLevels Property
CfgDeltaAgentInfo Class See Also Send Feedback
ChangedSkillLevels

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSkillLevel> ChangedSkillLevels { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedSkillLevels As ICollection(Of CfgSkillLevel)
Visual C++
public:
property ICollection<CfgSkillLevel^>^ ChangedSkillLevels {
    ICollection<CfgSkillLevel^>^ get ();
}

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo..::.DBID Property
CfgDeltaAgentInfo Class See Also Send Feedback
The DBID of the CfgDeltaAgentInfo configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAgentLogins Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo..::.DeletedAgentLogins Property
CfgDeltaAgentInfo Class See Also Send Feedback
DeletedAgentLogins

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAgentLoginInfo> DeletedAgentLogins { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAgentLogins As ICollection(Of CfgAgentLoginInfo)
Visual C++
public:
property ICollection<CfgAgentLoginInfo^>^ DeletedAgentLogins {
    ICollection<CfgAgentLoginInfo^>^ get ();
}

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedSkills Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentInfo..::.DeletedSkills Property
CfgDeltaAgentInfo Class See Also Send Feedback
DeletedSkills

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSkillLevel> DeletedSkills { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedSkills As ICollection(Of CfgSkillLevel)
Visual C++
public:
property ICollection<CfgSkillLevel^>^ DeletedSkills {
    ICollection<CfgSkillLevel^>^ get ();
}

See Also

CfgDeltaAgentInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentLogin Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin Class
Members See Also Send Feedback
CfgDeltaAgentLogin

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaAgentLogin : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaAgentLogin _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaAgentLogin : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAgentLogin

See Also

CfgDeltaAgentLogin Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentLogin Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin Members
CfgDeltaAgentLogin Class Methods Properties See Also Send Feedback

The CfgDeltaAgentLogin type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaAgentLogin configuration object.
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginCode | LoginCode
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | Override
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | Password
State | State
Switch | Switch
SwitchSpecificType | SwitchSpecificType
Tenant | Tenant
UseOverride | UseOverride

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentLogin Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin Methods
CfgDeltaAgentLogin Class See Also Send Feedback

The CfgDeltaAgentLogin type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.SetAccountPermissions Method
CfgDeltaAgentLogin Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaAgentLogin Class
CfgDeltaAgentLogin Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAgentLogin Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin Properties
CfgDeltaAgentLogin Class See Also Send Feedback

The CfgDeltaAgentLogin type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaAgentLogin configuration object.
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginCode | LoginCode
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | Override
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | Password
State | State
Switch | Switch
SwitchSpecificType | SwitchSpecificType
Tenant | Tenant
UseOverride | UseOverride

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.AddedUserProperties Property
CfgDeltaAgentLogin Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.ChangedUserProperties Property
CfgDeltaAgentLogin Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.DBID Property
CfgDeltaAgentLogin Class See Also Send Feedback
The DBID of the CfgDeltaAgentLogin configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.DeletedUserProperties Property
CfgDeltaAgentLogin Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LoginCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.LoginCode Property
CfgDeltaAgentLogin Class See Also Send Feedback
LoginCode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LoginCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoginCode As String
Visual C++
public:
property String^ LoginCode {
    String^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Override Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.Override Property
CfgDeltaAgentLogin Class See Also Send Feedback
Override

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Override { get; }
Visual Basic (Declaration)
Public ReadOnly Property Override As String
Visual C++
public:
property String^ Override {
    String^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.Password Property
CfgDeltaAgentLogin Class See Also Send Feedback
Password

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; }
Visual Basic (Declaration)
Public ReadOnly Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.State Property
CfgDeltaAgentLogin Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.Switch Property
CfgDeltaAgentLogin Class See Also Send Feedback
Switch

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SwitchSpecificType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.SwitchSpecificType Property
CfgDeltaAgentLogin Class See Also Send Feedback
SwitchSpecificType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SwitchSpecificType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SwitchSpecificType As Integer
Visual C++
public:
property int SwitchSpecificType {
    int get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.Tenant Property
CfgDeltaAgentLogin Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseOverride Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAgentLogin..::.UseOverride Property
CfgDeltaAgentLogin Class See Also Send Feedback
UseOverride

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseOverride { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseOverride As CfgFlag
Visual C++
public:
property CfgFlag UseOverride {
    CfgFlag get ();
}

See Also

CfgDeltaAgentLogin Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAlarmCondition Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition Class
Members See Also Send Feedback
CfgDeltaAlarmCondition

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaAlarmCondition : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaAlarmCondition _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaAlarmCondition : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAlarmCondition

See Also

CfgDeltaAlarmCondition Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAlarmCondition Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition Members
CfgDeltaAlarmCondition Class Methods Properties See Also Send Feedback

The CfgDeltaAlarmCondition type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedClearanceScripts | ClearanceScripts
AddedReactionScripts | ReactionScripts
AddedUserProperties | UserProperties
AlarmDetectEvent | AlarmDetectEvent
AlarmDetectScript | AlarmDetectScript
AlarmRemovalEvent | AlarmRemovalEvent
Category | Category
ChangedUserProperties | ChangedUserProperties
ClearanceTimeout | ClearanceTimeout
DBID | The DBID of the CfgDeltaAlarmCondition configuration object.
DeletedClearanceScripts | DeletedClearanceScripts
DeletedReactionScripts | DeletedReactionScripts
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsMasked | IsMasked
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAlarmCondition Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition Methods
CfgDeltaAlarmCondition Class See Also Send Feedback

The CfgDeltaAlarmCondition type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.SetAccountPermissions Method
CfgDeltaAlarmCondition Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaAlarmCondition Class
CfgDeltaAlarmCondition Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAlarmCondition Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition Properties
CfgDeltaAlarmCondition Class See Also Send Feedback

The CfgDeltaAlarmCondition type exposes the following members.

Properties

Name | Description
AddedClearanceScripts | ClearanceScripts
AddedReactionScripts | ReactionScripts
AddedUserProperties | UserProperties
AlarmDetectEvent | AlarmDetectEvent
AlarmDetectScript | AlarmDetectScript
AlarmRemovalEvent | AlarmRemovalEvent
Category | Category
ChangedUserProperties | ChangedUserProperties
ClearanceTimeout | ClearanceTimeout
DBID | The DBID of the CfgDeltaAlarmCondition configuration object.
DeletedClearanceScripts | DeletedClearanceScripts
DeletedReactionScripts | DeletedReactionScripts
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsMasked | IsMasked
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedClearanceScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.AddedClearanceScripts Property
CfgDeltaAlarmCondition Class See Also Send Feedback
ClearanceScripts

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgScript> AddedClearanceScripts { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedClearanceScripts As ICollection(Of CfgScript)
Visual C++
public:
property ICollection<CfgScript^>^ AddedClearanceScripts {
    ICollection<CfgScript^>^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedReactionScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.AddedReactionScripts Property
CfgDeltaAlarmCondition Class See Also Send Feedback
ReactionScripts

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgScript> AddedReactionScripts { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedReactionScripts As ICollection(Of CfgScript)
Visual C++
public:
property ICollection<CfgScript^>^ AddedReactionScripts {
    ICollection<CfgScript^>^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.AddedUserProperties Property
CfgDeltaAlarmCondition Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AlarmDetectEvent Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.AlarmDetectEvent Property
CfgDeltaAlarmCondition Class See Also Send Feedback
AlarmDetectEvent

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDetectEvent AlarmDetectEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property AlarmDetectEvent As CfgDetectEvent
Visual C++
public:
property CfgDetectEvent^ AlarmDetectEvent {
    CfgDetectEvent^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AlarmDetectScript Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.AlarmDetectScript Property
CfgDeltaAlarmCondition Class See Also Send Feedback
AlarmDetectScript

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript AlarmDetectScript { get; }
Visual Basic (Declaration)
Public ReadOnly Property AlarmDetectScript As CfgScript
Visual C++
public:
property CfgScript^ AlarmDetectScript {
    CfgScript^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AlarmRemovalEvent Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.AlarmRemovalEvent Property
CfgDeltaAlarmCondition Class See Also Send Feedback
AlarmRemovalEvent

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRemovalEvent AlarmRemovalEvent { get; }
Visual Basic (Declaration)
Public ReadOnly Property AlarmRemovalEvent As CfgRemovalEvent
Visual C++
public:
property CfgRemovalEvent^ AlarmRemovalEvent {
    CfgRemovalEvent^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Category Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.Category Property
CfgDeltaAlarmCondition Class See Also Send Feedback
Category

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmCategory Category { get; }
Visual Basic (Declaration)
Public ReadOnly Property Category As CfgAlarmCategory
Visual C++
public:
property CfgAlarmCategory Category {
    CfgAlarmCategory get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.ChangedUserProperties Property
CfgDeltaAlarmCondition Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ClearanceTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.ClearanceTimeout Property
CfgDeltaAlarmCondition Class See Also Send Feedback
ClearanceTimeout

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ClearanceTimeout { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClearanceTimeout As Integer
Visual C++
public:
property int ClearanceTimeout {
    int get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.DBID Property
CfgDeltaAlarmCondition Class See Also Send Feedback
The DBID of the CfgDeltaAlarmCondition configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedClearanceScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.DeletedClearanceScripts Property
CfgDeltaAlarmCondition Class See Also Send Feedback
DeletedClearanceScripts

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgScript> DeletedClearanceScripts { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedClearanceScripts As ICollection(Of CfgScript)
Visual C++
public:
property ICollection<CfgScript^>^ DeletedClearanceScripts {
    ICollection<CfgScript^>^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedReactionScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.DeletedReactionScripts Property
CfgDeltaAlarmCondition Class See Also Send Feedback
DeletedReactionScripts

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgScript> DeletedReactionScripts { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedReactionScripts As ICollection(Of CfgScript)
Visual C++
public:
property ICollection<CfgScript^>^ DeletedReactionScripts {
    ICollection<CfgScript^>^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.DeletedUserProperties Property
CfgDeltaAlarmCondition Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.Description Property
CfgDeltaAlarmCondition Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsMasked Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.IsMasked Property
CfgDeltaAlarmCondition Class See Also Send Feedback
IsMasked

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsMasked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMasked As CfgFlag
Visual C++
public:
property CfgFlag IsMasked {
    CfgFlag get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.Name Property
CfgDeltaAlarmCondition Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAlarmCondition..::.State Property
CfgDeltaAlarmCondition Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaAlarmCondition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaApplication Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication Class
Members See Also Send Feedback
CfgDeltaApplication

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaApplication : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaApplication _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaApplication : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaApplication

See Also

CfgDeltaApplication Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaApplication Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication Members
CfgDeltaApplication Class Methods Properties See Also Send Feedback

The CfgDeltaApplication type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedAppServers | AppServers
AddedFlexibleProperties | FlexibleProperties
AddedOptions | Options
AddedPortInfos | PortInfos
AddedResources | Resources
AddedTenants | Tenants
AddedUserProperties | UserProperties
AppPrototype | AppPrototype
AutoRestart | AutoRestart
ChangedAppServers | ChangedAppServers
ChangedFlexibleProperties | ChangedFlexibleProperties
ChangedOptions | ChangedOptions
ChangedPortInfos | ChangedPortInfos
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
CommandLine | CommandLine
CommandLineArguments | CommandLineArguments
ComponentType | ComponentType
DBID | The DBID of the CfgDeltaApplication configuration object.
DeletedAppServers | DeletedAppServers
DeletedFlexibleProperties | DeletedFlexibleProperties
DeletedOptions | DeletedOptions
DeletedPortInfos | DeletedPortInfos
DeletedResources | DeletedResources
DeletedTenants | DeletedTenants
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsPrimary | IsPrimary
IsServer | IsServer
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | Password
RedundancyType | RedundancyType
ServerInfo | ServerInfo
ShutdownTimeout | ShutdownTimeout
StartupTimeout | StartupTimeout
StartupType | StartupType
State | State
Type | Type
Version | Version
WorkDirectory | WorkDirectory

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaApplication Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication Methods
CfgDeltaApplication Class See Also Send Feedback

The CfgDeltaApplication type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.SetAccountPermissions Method
CfgDeltaApplication Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaApplication Class
CfgDeltaApplication Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaApplication Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication Properties
CfgDeltaApplication Class See Also Send Feedback

The CfgDeltaApplication type exposes the following members.

Properties

Name | Description
AddedAppServers | AppServers
AddedFlexibleProperties | FlexibleProperties
AddedOptions | Options
AddedPortInfos | PortInfos
AddedResources | Resources
AddedTenants | Tenants
AddedUserProperties | UserProperties
AppPrototype | AppPrototype
AutoRestart | AutoRestart
ChangedAppServers | ChangedAppServers
ChangedFlexibleProperties | ChangedFlexibleProperties
ChangedOptions | ChangedOptions
ChangedPortInfos | ChangedPortInfos
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
CommandLine | CommandLine
CommandLineArguments | CommandLineArguments
ComponentType | ComponentType
DBID | The DBID of the CfgDeltaApplication configuration object.
DeletedAppServers | DeletedAppServers
DeletedFlexibleProperties | DeletedFlexibleProperties
DeletedOptions | DeletedOptions
DeletedPortInfos | DeletedPortInfos
DeletedResources | DeletedResources
DeletedTenants | DeletedTenants
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsPrimary | IsPrimary
IsServer | IsServer
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | Password
RedundancyType | RedundancyType
ServerInfo | ServerInfo
ShutdownTimeout | ShutdownTimeout
StartupTimeout | StartupTimeout
StartupType | StartupType
State | State
Type | Type
Version | Version
WorkDirectory | WorkDirectory

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedAppServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedAppServers Property
CfgDeltaApplication Class See Also Send Feedback
AppServers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgConnInfo> AddedAppServers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedAppServers As ICollection(Of CfgConnInfo)
Visual C++
public:
property ICollection<CfgConnInfo^>^ AddedAppServers {
    ICollection<CfgConnInfo^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedFlexibleProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedFlexibleProperties Property
CfgDeltaApplication Class See Also Send Feedback
FlexibleProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedFlexibleProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedFlexibleProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedFlexibleProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedOptions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedOptions Property
CfgDeltaApplication Class See Also Send Feedback
Options

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedOptions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedOptions {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedPortInfos Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedPortInfos Property
CfgDeltaApplication Class See Also Send Feedback
PortInfos

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPortInfo> AddedPortInfos { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedPortInfos As ICollection(Of CfgPortInfo)
Visual C++
public:
property ICollection<CfgPortInfo^>^ AddedPortInfos {
    ICollection<CfgPortInfo^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedResources Property
CfgDeltaApplication Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedTenants Property
CfgDeltaApplication Class See Also Send Feedback
Tenants

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> AddedTenants { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedTenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ AddedTenants {
    ICollection<CfgTenant^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AddedUserProperties Property
CfgDeltaApplication Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppPrototype Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AppPrototype Property
CfgDeltaApplication Class See Also Send Feedback
AppPrototype

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppPrototype AppPrototype { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppPrototype As CfgAppPrototype
Visual C++
public:
property CfgAppPrototype^ AppPrototype {
    CfgAppPrototype^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AutoRestart Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.AutoRestart Property
CfgDeltaApplication Class See Also Send Feedback
AutoRestart

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag AutoRestart { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoRestart As CfgFlag
Visual C++
public:
property CfgFlag AutoRestart {
    CfgFlag get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedAppServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ChangedAppServers Property
CfgDeltaApplication Class See Also Send Feedback
ChangedAppServers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgConnInfo> ChangedAppServers { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedAppServers As ICollection(Of CfgConnInfo)
Visual C++
public:
property ICollection<CfgConnInfo^>^ ChangedAppServers {
    ICollection<CfgConnInfo^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedFlexibleProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ChangedFlexibleProperties Property
CfgDeltaApplication Class See Also Send Feedback
ChangedFlexibleProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedFlexibleProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedFlexibleProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedFlexibleProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedOptions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ChangedOptions Property
CfgDeltaApplication Class See Also Send Feedback
ChangedOptions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedOptions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedOptions {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedPortInfos Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ChangedPortInfos Property
CfgDeltaApplication Class See Also Send Feedback
ChangedPortInfos

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPortInfo> ChangedPortInfos { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedPortInfos As ICollection(Of CfgPortInfo)
Visual C++
public:
property ICollection<CfgPortInfo^>^ ChangedPortInfos {
    ICollection<CfgPortInfo^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ChangedResources Property
CfgDeltaApplication Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ChangedUserProperties Property
CfgDeltaApplication Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CommandLine Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.CommandLine Property
CfgDeltaApplication Class See Also Send Feedback
CommandLine

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CommandLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommandLine As String
Visual C++
public:
property String^ CommandLine {
    String^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CommandLineArguments Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.CommandLineArguments Property
CfgDeltaApplication Class See Also Send Feedback
CommandLineArguments

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CommandLineArguments { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommandLineArguments As String
Visual C++
public:
property String^ CommandLineArguments {
    String^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ComponentType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ComponentType Property
CfgDeltaApplication Class See Also Send Feedback
ComponentType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppComponentType ComponentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ComponentType As CfgAppComponentType
Visual C++
public:
property CfgAppComponentType ComponentType {
    CfgAppComponentType get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DBID Property
CfgDeltaApplication Class See Also Send Feedback
The DBID of the CfgDeltaApplication configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAppServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedAppServers Property
CfgDeltaApplication Class See Also Send Feedback
DeletedAppServers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgConnInfo> DeletedAppServers { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAppServers As ICollection(Of CfgConnInfo)
Visual C++
public:
property ICollection<CfgConnInfo^>^ DeletedAppServers {
    ICollection<CfgConnInfo^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedFlexibleProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedFlexibleProperties Property
CfgDeltaApplication Class See Also Send Feedback
DeletedFlexibleProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedFlexibleProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedFlexibleProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedFlexibleProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedOptions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedOptions Property
CfgDeltaApplication Class See Also Send Feedback
DeletedOptions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedOptions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedOptions {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedPortInfos Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedPortInfos Property
CfgDeltaApplication Class See Also Send Feedback
DeletedPortInfos

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPortInfo> DeletedPortInfos { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedPortInfos As ICollection(Of CfgPortInfo)
Visual C++
public:
property ICollection<CfgPortInfo^>^ DeletedPortInfos {
    ICollection<CfgPortInfo^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedResources Property
CfgDeltaApplication Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedTenants Property
CfgDeltaApplication Class See Also Send Feedback
DeletedTenants

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> DeletedTenants { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedTenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ DeletedTenants {
    ICollection<CfgTenant^>^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.DeletedUserProperties Property
CfgDeltaApplication Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsPrimary Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.IsPrimary Property
CfgDeltaApplication Class See Also Send Feedback
IsPrimary

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As CfgFlag
Visual C++
public:
property CfgFlag IsPrimary {
    CfgFlag get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.IsServer Property
CfgDeltaApplication Class See Also Send Feedback
IsServer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsServer { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsServer As CfgFlag
Visual C++
public:
property CfgFlag IsServer {
    CfgFlag get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.Name Property
CfgDeltaApplication Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.Password Property
CfgDeltaApplication Class See Also Send Feedback
Password

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; }
Visual Basic (Declaration)
Public ReadOnly Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RedundancyType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.RedundancyType Property
CfgDeltaApplication Class See Also Send Feedback
RedundancyType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHAType RedundancyType { get; }
Visual Basic (Declaration)
Public ReadOnly Property RedundancyType As CfgHAType
Visual C++
public:
property CfgHAType RedundancyType {
    CfgHAType get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ServerInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ServerInfo Property
CfgDeltaApplication Class See Also Send Feedback
ServerInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServer ServerInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServerInfo As CfgServer
Visual C++
public:
property CfgServer^ ServerInfo {
    CfgServer^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ShutdownTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.ShutdownTimeout Property
CfgDeltaApplication Class See Also Send Feedback
ShutdownTimeout

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ShutdownTimeout { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShutdownTimeout As Integer
Visual C++
public:
property int ShutdownTimeout {
    int get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.StartupTimeout Property
CfgDeltaApplication Class See Also Send Feedback
StartupTimeout

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupTimeout { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartupTimeout As Integer
Visual C++
public:
property int StartupTimeout {
    int get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.StartupType Property
CfgDeltaApplication Class See Also Send Feedback
StartupType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStartupType StartupType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartupType As CfgStartupType
Visual C++
public:
property CfgStartupType StartupType {
    CfgStartupType get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.State Property
CfgDeltaApplication Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.Type Property
CfgDeltaApplication Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.Version Property
CfgDeltaApplication Class See Also Send Feedback
Version

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


WorkDirectory Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaApplication..::.WorkDirectory Property
CfgDeltaApplication Class See Also Send Feedback
WorkDirectory

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string WorkDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property WorkDirectory As String
Visual C++
public:
property String^ WorkDirectory {
    String^ get ();
}

See Also

CfgDeltaApplication Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAppPrototype Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype Class
Members See Also Send Feedback
CfgDeltaAppPrototype

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaAppPrototype : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaAppPrototype _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaAppPrototype : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaAppPrototype

See Also

CfgDeltaAppPrototype Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAppPrototype Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype Members
CfgDeltaAppPrototype Class Methods Properties See Also Send Feedback

The CfgDeltaAppPrototype type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedOptions | Options
AddedUserProperties | UserProperties
ChangedOptions | ChangedOptions
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaAppPrototype configuration object.
DeletedOptions | DeletedOptions
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Type | Type
Version | Version

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAppPrototype Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype Methods
CfgDeltaAppPrototype Class See Also Send Feedback

The CfgDeltaAppPrototype type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.SetAccountPermissions Method
CfgDeltaAppPrototype Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaAppPrototype Class
CfgDeltaAppPrototype Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaAppPrototype Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype Properties
CfgDeltaAppPrototype Class See Also Send Feedback

The CfgDeltaAppPrototype type exposes the following members.

Properties

Name | Description
AddedOptions | Options
AddedUserProperties | UserProperties
ChangedOptions | ChangedOptions
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaAppPrototype configuration object.
DeletedOptions | DeletedOptions
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Type | Type
Version | Version

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedOptions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.AddedOptions Property
CfgDeltaAppPrototype Class See Also Send Feedback
Options

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedOptions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedOptions {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.AddedUserProperties Property
CfgDeltaAppPrototype Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedOptions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.ChangedOptions Property
CfgDeltaAppPrototype Class See Also Send Feedback
ChangedOptions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedOptions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedOptions {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.ChangedUserProperties Property
CfgDeltaAppPrototype Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.DBID Property
CfgDeltaAppPrototype Class See Also Send Feedback
The DBID of the CfgDeltaAppPrototype configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedOptions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.DeletedOptions Property
CfgDeltaAppPrototype Class See Also Send Feedback
DeletedOptions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedOptions As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedOptions {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.DeletedUserProperties Property
CfgDeltaAppPrototype Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.Name Property
CfgDeltaAppPrototype Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.State Property
CfgDeltaAppPrototype Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.Type Property
CfgDeltaAppPrototype Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaAppPrototype..::.Version Property
CfgDeltaAppPrototype Class See Also Send Feedback
Version

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

CfgDeltaAppPrototype Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCallingList Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList Class
Members See Also Send Feedback
CfgDeltaCallingList

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaCallingList : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaCallingList _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaCallingList : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaCallingList

See Also

CfgDeltaCallingList Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCallingList Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList Members
CfgDeltaCallingList Class Methods Properties See Also Send Feedback

The CfgDeltaCallingList type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedTreatments | Treatments
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaCallingList configuration object.
DeletedTreatments | DeletedTreatments
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Filter | Filter
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LogTableAccess | LogTableAccess
MaxAttempts | MaxAttempts
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
TableAccess | TableAccess
Tenant | Tenant
TimeFrom | TimeFrom
TimeUntil | TimeUntil

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCallingList Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList Methods
CfgDeltaCallingList Class See Also Send Feedback

The CfgDeltaCallingList type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.SetAccountPermissions Method
CfgDeltaCallingList Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaCallingList Class
CfgDeltaCallingList Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCallingList Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList Properties
CfgDeltaCallingList Class See Also Send Feedback

The CfgDeltaCallingList type exposes the following members.

Properties

Name | Description
AddedTreatments | Treatments
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaCallingList configuration object.
DeletedTreatments | DeletedTreatments
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Filter | Filter
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LogTableAccess | LogTableAccess
MaxAttempts | MaxAttempts
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
TableAccess | TableAccess
Tenant | Tenant
TimeFrom | TimeFrom
TimeUntil | TimeUntil

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedTreatments Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.AddedTreatments Property
CfgDeltaCallingList Class See Also Send Feedback
Treatments

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTreatment> AddedTreatments { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedTreatments As ICollection(Of CfgTreatment)
Visual C++
public:
property ICollection<CfgTreatment^>^ AddedTreatments {
    ICollection<CfgTreatment^>^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.AddedUserProperties Property
CfgDeltaCallingList Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.ChangedUserProperties Property
CfgDeltaCallingList Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.DBID Property
CfgDeltaCallingList Class See Also Send Feedback
The DBID of the CfgDeltaCallingList configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedTreatments Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.DeletedTreatments Property
CfgDeltaCallingList Class See Also Send Feedback
DeletedTreatments

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTreatment> DeletedTreatments { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedTreatments As ICollection(Of CfgTreatment)
Visual C++
public:
property ICollection<CfgTreatment^>^ DeletedTreatments {
    ICollection<CfgTreatment^>^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.DeletedUserProperties Property
CfgDeltaCallingList Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.Description Property
CfgDeltaCallingList Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.Filter Property
CfgDeltaCallingList Class See Also Send Feedback
Filter

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilter Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As CfgFilter
Visual C++
public:
property CfgFilter^ Filter {
    CfgFilter^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LogTableAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.LogTableAccess Property
CfgDeltaCallingList Class See Also Send Feedback
LogTableAccess

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccess LogTableAccess { get; }
Visual Basic (Declaration)
Public ReadOnly Property LogTableAccess As CfgTableAccess
Visual C++
public:
property CfgTableAccess^ LogTableAccess {
    CfgTableAccess^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MaxAttempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.MaxAttempts Property
CfgDeltaCallingList Class See Also Send Feedback
MaxAttempts

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxAttempts { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxAttempts As Integer
Visual C++
public:
property int MaxAttempts {
    int get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.Name Property
CfgDeltaCallingList Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.Script Property
CfgDeltaCallingList Class See Also Send Feedback
Script

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; }
Visual Basic (Declaration)
Public ReadOnly Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.State Property
CfgDeltaCallingList Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TableAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.TableAccess Property
CfgDeltaCallingList Class See Also Send Feedback
TableAccess

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccess TableAccess { get; }
Visual Basic (Declaration)
Public ReadOnly Property TableAccess As CfgTableAccess
Visual C++
public:
property CfgTableAccess^ TableAccess {
    CfgTableAccess^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.Tenant Property
CfgDeltaCallingList Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeFrom Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.TimeFrom Property
CfgDeltaCallingList Class See Also Send Feedback
TimeFrom

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeFrom { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeFrom As Integer
Visual C++
public:
property int TimeFrom {
    int get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeUntil Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCallingList..::.TimeUntil Property
CfgDeltaCallingList Class See Also Send Feedback
TimeUntil

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeUntil { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeUntil As Integer
Visual C++
public:
property int TimeUntil {
    int get ();
}

See Also

CfgDeltaCallingList Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaign Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign Class
Members See Also Send Feedback
CfgDeltaCampaign

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaCampaign : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaCampaign _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaCampaign : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaCampaign

See Also

CfgDeltaCampaign Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaign Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign Members
CfgDeltaCampaign Class Methods Properties See Also Send Feedback

The CfgDeltaCampaign type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedCallingLists | CallingLists
AddedCampaignGroups | CampaignGroups
AddedUserProperties | UserProperties
ChangedCallingLists | ChangedCallingLists
ChangedCampaignGroups | ChangedCampaignGroups
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaCampaign configuration object.
DeletedCallingLists | DeletedCallingLists
DeletedCampaignGroups | DeletedCampaignGroups
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
Tenant | Tenant

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaign Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign Methods
CfgDeltaCampaign Class See Also Send Feedback

The CfgDeltaCampaign type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.SetAccountPermissions Method
CfgDeltaCampaign Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaCampaign Class
CfgDeltaCampaign Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaign Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign Properties
CfgDeltaCampaign Class See Also Send Feedback

The CfgDeltaCampaign type exposes the following members.

Properties

Name | Description
AddedCallingLists | CallingLists
AddedCampaignGroups | CampaignGroups
AddedUserProperties | UserProperties
ChangedCallingLists | ChangedCallingLists
ChangedCampaignGroups | ChangedCampaignGroups
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaCampaign configuration object.
DeletedCallingLists | DeletedCallingLists
DeletedCampaignGroups | DeletedCampaignGroups
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
Tenant | Tenant

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedCallingLists Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.AddedCallingLists Property
CfgDeltaCampaign Class See Also Send Feedback
CallingLists

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCallingListInfo> AddedCallingLists { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedCallingLists As ICollection(Of CfgCallingListInfo)
Visual C++
public:
property ICollection<CfgCallingListInfo^>^ AddedCallingLists {
    ICollection<CfgCallingListInfo^>^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedCampaignGroups Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.AddedCampaignGroups Property
CfgDeltaCampaign Class See Also Send Feedback
CampaignGroups

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCampaignGroupInfo> AddedCampaignGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedCampaignGroups As ICollection(Of CfgCampaignGroupInfo)
Visual C++
public:
property ICollection<CfgCampaignGroupInfo^>^ AddedCampaignGroups {
    ICollection<CfgCampaignGroupInfo^>^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.AddedUserProperties Property
CfgDeltaCampaign Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedCallingLists Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.ChangedCallingLists Property
CfgDeltaCampaign Class See Also Send Feedback
ChangedCallingLists

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCallingListInfo> ChangedCallingLists { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedCallingLists As ICollection(Of CfgCallingListInfo)
Visual C++
public:
property ICollection<CfgCallingListInfo^>^ ChangedCallingLists {
    ICollection<CfgCallingListInfo^>^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedCampaignGroups Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.ChangedCampaignGroups Property
CfgDeltaCampaign Class See Also Send Feedback
ChangedCampaignGroups

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCampaignGroupInfo> ChangedCampaignGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedCampaignGroups As ICollection(Of CfgCampaignGroupInfo)
Visual C++
public:
property ICollection<CfgCampaignGroupInfo^>^ ChangedCampaignGroups {
    ICollection<CfgCampaignGroupInfo^>^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.ChangedUserProperties Property
CfgDeltaCampaign Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.DBID Property
CfgDeltaCampaign Class See Also Send Feedback
The DBID of the CfgDeltaCampaign configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedCallingLists Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.DeletedCallingLists Property
CfgDeltaCampaign Class See Also Send Feedback
DeletedCallingLists

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCallingListInfo> DeletedCallingLists { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedCallingLists As ICollection(Of CfgCallingListInfo)
Visual C++
public:
property ICollection<CfgCallingListInfo^>^ DeletedCallingLists {
    ICollection<CfgCallingListInfo^>^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedCampaignGroups Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.DeletedCampaignGroups Property
CfgDeltaCampaign Class See Also Send Feedback
DeletedCampaignGroups

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgCampaignGroupInfo> DeletedCampaignGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedCampaignGroups As ICollection(Of CfgCampaignGroupInfo)
Visual C++
public:
property ICollection<CfgCampaignGroupInfo^>^ DeletedCampaignGroups {
    ICollection<CfgCampaignGroupInfo^>^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.DeletedUserProperties Property
CfgDeltaCampaign Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.Description Property
CfgDeltaCampaign Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.Name Property
CfgDeltaCampaign Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.Script Property
CfgDeltaCampaign Class See Also Send Feedback
Script

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; }
Visual Basic (Declaration)
Public ReadOnly Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.State Property
CfgDeltaCampaign Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaign..::.Tenant Property
CfgDeltaCampaign Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaCampaign Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaignGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup Class
Members See Also Send Feedback
CfgDeltaCampaignGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaCampaignGroup : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaCampaignGroup _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaCampaignGroup : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaCampaignGroup

See Also

CfgDeltaCampaignGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaignGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup Members
CfgDeltaCampaignGroup Class Methods Properties See Also Send Feedback

The CfgDeltaCampaignGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedServers | Servers
AddedUserProperties | UserProperties
Campaign | Campaign
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaCampaignGroup configuration object.
DeletedServers | DeletedServers
DeletedUserProperties | DeletedUserProperties
Description | Description
DialMode | DialMode
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupDBID | GroupDBID
GroupType | GroupType
InteractionQueue | InteractionQueue
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRProfile | IVRProfile
Logger | (Inherited from AbstractLogEnabled.)
MaxQueueSize | MaxQueueSize
MinRecBuffSize | MinRecBuffSize
Name | Name
NumOfChannels | NumOfChannels
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OperationMode | OperationMode
OptMethod | OptMethod
OptMethodValue | OptMethodValue
OptRecBuffSize | OptRecBuffSize
OrigDN | OrigDN
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
Tenant | Tenant
TrunkGroupDN | TrunkGroupDN

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaignGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup Methods
CfgDeltaCampaignGroup Class See Also Send Feedback

The CfgDeltaCampaignGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.SetAccountPermissions Method
CfgDeltaCampaignGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaCampaignGroup Class
CfgDeltaCampaignGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaCampaignGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup Properties
CfgDeltaCampaignGroup Class See Also Send Feedback

The CfgDeltaCampaignGroup type exposes the following members.

Properties

Name | Description
AddedServers | Servers
AddedUserProperties | UserProperties
Campaign | Campaign
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaCampaignGroup configuration object.
DeletedServers | DeletedServers
DeletedUserProperties | DeletedUserProperties
Description | Description
DialMode | DialMode
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupDBID | GroupDBID
GroupType | GroupType
InteractionQueue | InteractionQueue
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRProfile | IVRProfile
Logger | (Inherited from AbstractLogEnabled.)
MaxQueueSize | MaxQueueSize
MinRecBuffSize | MinRecBuffSize
Name | Name
NumOfChannels | NumOfChannels
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OperationMode | OperationMode
OptMethod | OptMethod
OptMethodValue | OptMethodValue
OptRecBuffSize | OptRecBuffSize
OrigDN | OrigDN
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
Tenant | Tenant
TrunkGroupDN | TrunkGroupDN

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.AddedServers Property
CfgDeltaCampaignGroup Class See Also Send Feedback
Servers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgApplication> AddedServers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedServers As ICollection(Of CfgApplication)
Visual C++
public:
property ICollection<CfgApplication^>^ AddedServers {
    ICollection<CfgApplication^>^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.AddedUserProperties Property
CfgDeltaCampaignGroup Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Campaign Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.Campaign Property
CfgDeltaCampaignGroup Class See Also Send Feedback
Campaign

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaign Campaign { get; }
Visual Basic (Declaration)
Public ReadOnly Property Campaign As CfgCampaign
Visual C++
public:
property CfgCampaign^ Campaign {
    CfgCampaign^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.ChangedUserProperties Property
CfgDeltaCampaignGroup Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.DBID Property
CfgDeltaCampaignGroup Class See Also Send Feedback
The DBID of the CfgDeltaCampaignGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.DeletedServers Property
CfgDeltaCampaignGroup Class See Also Send Feedback
DeletedServers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgApplication> DeletedServers { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedServers As ICollection(Of CfgApplication)
Visual C++
public:
property ICollection<CfgApplication^>^ DeletedServers {
    ICollection<CfgApplication^>^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.DeletedUserProperties Property
CfgDeltaCampaignGroup Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.Description Property
CfgDeltaCampaignGroup Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DialMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.DialMode Property
CfgDeltaCampaignGroup Class See Also Send Feedback
DialMode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDialMode DialMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialMode As CfgDialMode
Visual C++
public:
property CfgDialMode DialMode {
    CfgDialMode get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.GroupDBID Property
CfgDeltaCampaignGroup Class See Also Send Feedback
GroupDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int GroupDBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupDBID As Integer
Visual C++
public:
property int GroupDBID {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.GroupType Property
CfgDeltaCampaignGroup Class See Also Send Feedback
GroupType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType GroupType { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupType As CfgObjectType
Visual C++
public:
property CfgObjectType GroupType {
    CfgObjectType get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


InteractionQueue Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.InteractionQueue Property
CfgDeltaCampaignGroup Class See Also Send Feedback
InteractionQueue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript InteractionQueue { get; }
Visual Basic (Declaration)
Public ReadOnly Property InteractionQueue As CfgScript
Visual C++
public:
property CfgScript^ InteractionQueue {
    CfgScript^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IVRProfile Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.IVRProfile Property
CfgDeltaCampaignGroup Class See Also Send Feedback
IVRProfile

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPIVRProfile IVRProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property IVRProfile As CfgGVPIVRProfile
Visual C++
public:
property CfgGVPIVRProfile^ IVRProfile {
    CfgGVPIVRProfile^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MaxQueueSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.MaxQueueSize Property
CfgDeltaCampaignGroup Class See Also Send Feedback
MaxQueueSize

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxQueueSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxQueueSize As Integer
Visual C++
public:
property int MaxQueueSize {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MinRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.MinRecBuffSize Property
CfgDeltaCampaignGroup Class See Also Send Feedback
MinRecBuffSize

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinRecBuffSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinRecBuffSize As Integer
Visual C++
public:
property int MinRecBuffSize {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.Name Property
CfgDeltaCampaignGroup Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NumOfChannels Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.NumOfChannels Property
CfgDeltaCampaignGroup Class See Also Send Feedback
NumOfChannels

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int NumOfChannels { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumOfChannels As Integer
Visual C++
public:
property int NumOfChannels {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OperationMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.OperationMode Property
CfgDeltaCampaignGroup Class See Also Send Feedback
OperationMode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOperationMode OperationMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property OperationMode As CfgOperationMode
Visual C++
public:
property CfgOperationMode OperationMode {
    CfgOperationMode get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptMethod Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.OptMethod Property
CfgDeltaCampaignGroup Class See Also Send Feedback
OptMethod

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOptimizationMethod OptMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property OptMethod As CfgOptimizationMethod
Visual C++
public:
property CfgOptimizationMethod OptMethod {
    CfgOptimizationMethod get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptMethodValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.OptMethodValue Property
CfgDeltaCampaignGroup Class See Also Send Feedback
OptMethodValue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptMethodValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property OptMethodValue As Integer
Visual C++
public:
property int OptMethodValue {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OptRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.OptRecBuffSize Property
CfgDeltaCampaignGroup Class See Also Send Feedback
OptRecBuffSize

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptRecBuffSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property OptRecBuffSize As Integer
Visual C++
public:
property int OptRecBuffSize {
    int get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OrigDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.OrigDN Property
CfgDeltaCampaignGroup Class See Also Send Feedback
OrigDN

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN OrigDN { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrigDN As CfgDN
Visual C++
public:
property CfgDN^ OrigDN {
    CfgDN^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.Script Property
CfgDeltaCampaignGroup Class See Also Send Feedback
Script

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; }
Visual Basic (Declaration)
Public ReadOnly Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.State Property
CfgDeltaCampaignGroup Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.Tenant Property
CfgDeltaCampaignGroup Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TrunkGroupDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaCampaignGroup..::.TrunkGroupDN Property
CfgDeltaCampaignGroup Class See Also Send Feedback
TrunkGroupDN

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN TrunkGroupDN { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrunkGroupDN As CfgDN
Visual C++
public:
property CfgDN^ TrunkGroupDN {
    CfgDN^ get ();
}

See Also

CfgDeltaCampaignGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDN Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN Class
Members See Also Send Feedback
CfgDeltaDN

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaDN : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaDN _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaDN : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaDN

See Also

CfgDeltaDN Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDN Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN Members
CfgDeltaDN Class Methods Properties See Also Send Feedback

The CfgDeltaDN type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedAccessNumbers | AccessNumbers
AddedDestDNs | DestDNs
AddedUserProperties | UserProperties
Association | Association
ChangedUserProperties | ChangedUserProperties
Contract | Contract
DBID | The DBID of the CfgDeltaDN configuration object.
DeletedAccessNumbers | DeletedAccessNumbers
DeletedDestDNs | DeletedDestDNs
DeletedUserProperties | DeletedUserProperties
DNLoginID | DNLoginID
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Group | Group
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginFlag | LoginFlag
Name | Name
Number | Number
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | Override
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RegisterAll | RegisterAll
RouteType | RouteType
Site | Site
State | State
Switch | Switch
SwitchSpecificType | SwitchSpecificType
Tenant | Tenant
Trunks | Trunks
Type | Type
UseOverride | UseOverride

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDN Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN Methods
CfgDeltaDN Class See Also Send Feedback

The CfgDeltaDN type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.SetAccountPermissions Method
CfgDeltaDN Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaDN Class
CfgDeltaDN Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDN Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN Properties
CfgDeltaDN Class See Also Send Feedback

The CfgDeltaDN type exposes the following members.

Properties

Name | Description
AddedAccessNumbers | AccessNumbers
AddedDestDNs | DestDNs
AddedUserProperties | UserProperties
Association | Association
ChangedUserProperties | ChangedUserProperties
Contract | Contract
DBID | The DBID of the CfgDeltaDN configuration object.
DeletedAccessNumbers | DeletedAccessNumbers
DeletedDestDNs | DeletedDestDNs
DeletedUserProperties | DeletedUserProperties
DNLoginID | DNLoginID
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Group | Group
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginFlag | LoginFlag
Name | Name
Number | Number
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | Override
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RegisterAll | RegisterAll
RouteType | RouteType
Site | Site
State | State
Switch | Switch
SwitchSpecificType | SwitchSpecificType
Tenant | Tenant
Trunks | Trunks
Type | Type
UseOverride | UseOverride

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedAccessNumbers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.AddedAccessNumbers Property
CfgDeltaDN Class See Also Send Feedback
AccessNumbers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNAccessNumber> AddedAccessNumbers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedAccessNumbers As ICollection(Of CfgDNAccessNumber)
Visual C++
public:
property ICollection<CfgDNAccessNumber^>^ AddedAccessNumbers {
    ICollection<CfgDNAccessNumber^>^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedDestDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.AddedDestDNs Property
CfgDeltaDN Class See Also Send Feedback
DestDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> AddedDestDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedDestDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ AddedDestDNs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.AddedUserProperties Property
CfgDeltaDN Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Association Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Association Property
CfgDeltaDN Class See Also Send Feedback
Association

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Association { get; }
Visual Basic (Declaration)
Public ReadOnly Property Association As String
Visual C++
public:
property String^ Association {
    String^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.ChangedUserProperties Property
CfgDeltaDN Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Contract Property
CfgDeltaDN Class See Also Send Feedback
Contract

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; }
Visual Basic (Declaration)
Public ReadOnly Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.DBID Property
CfgDeltaDN Class See Also Send Feedback
The DBID of the CfgDeltaDN configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAccessNumbers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.DeletedAccessNumbers Property
CfgDeltaDN Class See Also Send Feedback
DeletedAccessNumbers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNAccessNumber> DeletedAccessNumbers { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAccessNumbers As ICollection(Of CfgDNAccessNumber)
Visual C++
public:
property ICollection<CfgDNAccessNumber^>^ DeletedAccessNumbers {
    ICollection<CfgDNAccessNumber^>^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedDestDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.DeletedDestDNs Property
CfgDeltaDN Class See Also Send Feedback
DeletedDestDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DeletedDestDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedDestDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DeletedDestDNs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.DeletedUserProperties Property
CfgDeltaDN Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DNLoginID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.DNLoginID Property
CfgDeltaDN Class See Also Send Feedback
DNLoginID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DNLoginID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DNLoginID As String
Visual C++
public:
property String^ DNLoginID {
    String^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Group Property
CfgDeltaDN Class See Also Send Feedback
Group

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroup Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As CfgDNGroup
Visual C++
public:
property CfgDNGroup^ Group {
    CfgDNGroup^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LoginFlag Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.LoginFlag Property
CfgDeltaDN Class See Also Send Feedback
LoginFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag LoginFlag { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoginFlag As CfgFlag
Visual C++
public:
property CfgFlag LoginFlag {
    CfgFlag get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Name Property
CfgDeltaDN Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Number Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Number Property
CfgDeltaDN Class See Also Send Feedback
Number

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Number { get; }
Visual Basic (Declaration)
Public ReadOnly Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Override Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Override Property
CfgDeltaDN Class See Also Send Feedback
Override

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Override { get; }
Visual Basic (Declaration)
Public ReadOnly Property Override As String
Visual C++
public:
property String^ Override {
    String^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RegisterAll Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.RegisterAll Property
CfgDeltaDN Class See Also Send Feedback
RegisterAll

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNRegisterFlag RegisterAll { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegisterAll As CfgDNRegisterFlag
Visual C++
public:
property CfgDNRegisterFlag RegisterAll {
    CfgDNRegisterFlag get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.RouteType Property
CfgDeltaDN Class See Also Send Feedback
RouteType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; }
Visual Basic (Declaration)
Public ReadOnly Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Site Property
CfgDeltaDN Class See Also Send Feedback
Site

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; }
Visual Basic (Declaration)
Public ReadOnly Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.State Property
CfgDeltaDN Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Switch Property
CfgDeltaDN Class See Also Send Feedback
Switch

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SwitchSpecificType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.SwitchSpecificType Property
CfgDeltaDN Class See Also Send Feedback
SwitchSpecificType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SwitchSpecificType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SwitchSpecificType As Integer
Visual C++
public:
property int SwitchSpecificType {
    int get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Tenant Property
CfgDeltaDN Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Trunks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Trunks Property
CfgDeltaDN Class See Also Send Feedback
Trunks

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Trunks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Trunks As Integer
Visual C++
public:
property int Trunks {
    int get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.Type Property
CfgDeltaDN Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgDNType
Visual C++
public:
property CfgDNType Type {
    CfgDNType get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseOverride Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDN..::.UseOverride Property
CfgDeltaDN Class See Also Send Feedback
UseOverride

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseOverride { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseOverride As CfgFlag
Visual C++
public:
property CfgFlag UseOverride {
    CfgFlag get ();
}

See Also

CfgDeltaDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDNGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup Class
Members See Also Send Feedback
CfgDeltaDNGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaDNGroup : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaDNGroup _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaDNGroup : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaDNGroup

See Also

CfgDeltaDNGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDNGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup Members
CfgDeltaDNGroup Class Methods Properties See Also Send Feedback

The CfgDeltaDNGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedDNs | AddedDNs
ChangedDNs | ChangedDNs
DBID | The DBID of the CfgDeltaDNGroup configuration object.
DeletedDNs | DeletedDNs
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDNGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup Methods
CfgDeltaDNGroup Class See Also Send Feedback

The CfgDeltaDNGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup..::.SetAccountPermissions Method
CfgDeltaDNGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaDNGroup Class
CfgDeltaDNGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaDNGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup Properties
CfgDeltaDNGroup Class See Also Send Feedback

The CfgDeltaDNGroup type exposes the following members.

Properties

Name | Description
AddedDNs | AddedDNs
ChangedDNs | ChangedDNs
DBID | The DBID of the CfgDeltaDNGroup configuration object.
DeletedDNs | DeletedDNs
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup..::.AddedDNs Property
CfgDeltaDNGroup Class See Also Send Feedback
AddedDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNInfo> AddedDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedDNs As ICollection(Of CfgDNInfo)
Visual C++
public:
property ICollection<CfgDNInfo^>^ AddedDNs {
    ICollection<CfgDNInfo^>^ get ();
}

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup..::.ChangedDNs Property
CfgDeltaDNGroup Class See Also Send Feedback
ChangedDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNInfo> ChangedDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedDNs As ICollection(Of CfgDNInfo)
Visual C++
public:
property ICollection<CfgDNInfo^>^ ChangedDNs {
    ICollection<CfgDNInfo^>^ get ();
}

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup..::.DBID Property
CfgDeltaDNGroup Class See Also Send Feedback
The DBID of the CfgDeltaDNGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup..::.DeletedDNs Property
CfgDeltaDNGroup Class See Also Send Feedback
DeletedDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNInfo> DeletedDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedDNs As ICollection(Of CfgDNInfo)
Visual C++
public:
property ICollection<CfgDNInfo^>^ DeletedDNs {
    ICollection<CfgDNInfo^>^ get ();
}

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeltaGroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaDNGroup..::.DeltaGroupInfo Property
CfgDeltaDNGroup Class See Also Send Feedback
DeltaGroupInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDeltaGroup DeltaGroupInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaGroupInfo As CfgDeltaGroup
Visual C++
public:
property CfgDeltaGroup^ DeltaGroupInfo {
    CfgDeltaGroup^ get ();
}

See Also

CfgDeltaDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumerator Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator Class
Members See Also Send Feedback
CfgDeltaEnumerator

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaEnumerator : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaEnumerator _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaEnumerator : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaEnumerator

See Also

CfgDeltaEnumerator Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumerator Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator Members
CfgDeltaEnumerator Class Methods Properties See Also Send Feedback

The CfgDeltaEnumerator type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaEnumerator configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumerator Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator Methods
CfgDeltaEnumerator Class See Also Send Feedback

The CfgDeltaEnumerator type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.SetAccountPermissions Method
CfgDeltaEnumerator Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaEnumerator Class
CfgDeltaEnumerator Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumerator Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator Properties
CfgDeltaEnumerator Class See Also Send Feedback

The CfgDeltaEnumerator type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaEnumerator configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.AddedUserProperties Property
CfgDeltaEnumerator Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.ChangedUserProperties Property
CfgDeltaEnumerator Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.DBID Property
CfgDeltaEnumerator Class See Also Send Feedback
The DBID of the CfgDeltaEnumerator configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.DeletedUserProperties Property
CfgDeltaEnumerator Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.Description Property
CfgDeltaEnumerator Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.DisplayName Property
CfgDeltaEnumerator Class See Also Send Feedback
DisplayName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.Name Property
CfgDeltaEnumerator Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.State Property
CfgDeltaEnumerator Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.Tenant Property
CfgDeltaEnumerator Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumerator..::.Type Property
CfgDeltaEnumerator Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgEnumeratorType
Visual C++
public:
property CfgEnumeratorType Type {
    CfgEnumeratorType get ();
}

See Also

CfgDeltaEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumeratorValue Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue Class
Members See Also Send Feedback
CfgDeltaEnumeratorValue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaEnumeratorValue : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaEnumeratorValue _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaEnumeratorValue : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaEnumeratorValue

See Also

CfgDeltaEnumeratorValue Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumeratorValue Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue Members
CfgDeltaEnumeratorValue Class Methods Properties See Also Send Feedback

The CfgDeltaEnumeratorValue type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaEnumeratorValue configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Enumerator | Enumerator
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDefault | IsDefault
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumeratorValue Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue Methods
CfgDeltaEnumeratorValue Class See Also Send Feedback

The CfgDeltaEnumeratorValue type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.SetAccountPermissions Method
CfgDeltaEnumeratorValue Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaEnumeratorValue Class
CfgDeltaEnumeratorValue Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaEnumeratorValue Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue Properties
CfgDeltaEnumeratorValue Class See Also Send Feedback

The CfgDeltaEnumeratorValue type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaEnumeratorValue configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Enumerator | Enumerator
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDefault | IsDefault
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.AddedUserProperties Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.ChangedUserProperties Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.DBID Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
The DBID of the CfgDeltaEnumeratorValue configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.DeletedUserProperties Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.Description Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.DisplayName Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
DisplayName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Enumerator Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.Enumerator Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
Enumerator

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumerator Enumerator { get; }
Visual Basic (Declaration)
Public ReadOnly Property Enumerator As CfgEnumerator
Visual C++
public:
property CfgEnumerator^ Enumerator {
    CfgEnumerator^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsDefault Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.IsDefault Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
IsDefault

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDefault { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDefault As CfgFlag
Visual C++
public:
property CfgFlag IsDefault {
    CfgFlag get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.Name Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.State Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaEnumeratorValue..::.Tenant Property
CfgDeltaEnumeratorValue Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaField Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField Class
Members See Also Send Feedback
CfgDeltaField

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaField : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaField _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaField : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaField

See Also

CfgDeltaField Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaField Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaField Members
CfgDeltaField Class Methods Properties See Also Send Feedback

The CfgDeltaField type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaField configuration object.
DefaultValue | DefaultValue
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FieldType | FieldType
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsNullable | IsNullable
IsPrimaryKey | IsPrimaryKey
IsUnique | IsUnique
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Length | Length
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaField Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaField Methods
CfgDeltaField Class See Also Send Feedback

The CfgDeltaField type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.SetAccountPermissions Method
CfgDeltaField Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaField Class
CfgDeltaField Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaField Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaField Properties
CfgDeltaField Class See Also Send Feedback

The CfgDeltaField type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaField configuration object.
DefaultValue | DefaultValue
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FieldType | FieldType
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsNullable | IsNullable
IsPrimaryKey | IsPrimaryKey
IsUnique | IsUnique
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Length | Length
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.AddedUserProperties Property
CfgDeltaField Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.ChangedUserProperties Property
CfgDeltaField Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.DBID Property
CfgDeltaField Class See Also Send Feedback
The DBID of the CfgDeltaField configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DefaultValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.DefaultValue Property
CfgDeltaField Class See Also Send Feedback
DefaultValue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DefaultValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultValue As String
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.DeletedUserProperties Property
CfgDeltaField Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.Description Property
CfgDeltaField Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FieldType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.FieldType Property
CfgDeltaField Class See Also Send Feedback
FieldType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFieldType FieldType { get; }
Visual Basic (Declaration)
Public ReadOnly Property FieldType As CfgFieldType
Visual C++
public:
property CfgFieldType FieldType {
    CfgFieldType get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsNullable Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.IsNullable Property
CfgDeltaField Class See Also Send Feedback
IsNullable

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsNullable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNullable As CfgFlag
Visual C++
public:
property CfgFlag IsNullable {
    CfgFlag get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsPrimaryKey Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.IsPrimaryKey Property
CfgDeltaField Class See Also Send Feedback
IsPrimaryKey

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsPrimaryKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimaryKey As CfgFlag
Visual C++
public:
property CfgFlag IsPrimaryKey {
    CfgFlag get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsUnique Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.IsUnique Property
CfgDeltaField Class See Also Send Feedback
IsUnique

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsUnique { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUnique As CfgFlag
Visual C++
public:
property CfgFlag IsUnique {
    CfgFlag get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Length Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.Length Property
CfgDeltaField Class See Also Send Feedback
Length

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.Name Property
CfgDeltaField Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.State Property
CfgDeltaField Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.Tenant Property
CfgDeltaField Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaField..::.Type Property
CfgDeltaField Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDataType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgDataType
Visual C++
public:
property CfgDataType Type {
    CfgDataType get ();
}

See Also

CfgDeltaField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFilter Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter Class
Members See Also Send Feedback
CfgDeltaFilter

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaFilter : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaFilter _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaFilter : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaFilter

See Also

CfgDeltaFilter Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter Members
CfgDeltaFilter Class Methods Properties See Also Send Feedback

The CfgDeltaFilter type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaFilter configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | Format
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter Methods
CfgDeltaFilter Class See Also Send Feedback

The CfgDeltaFilter type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.SetAccountPermissions Method
CfgDeltaFilter Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaFilter Class
CfgDeltaFilter Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFilter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter Properties
CfgDeltaFilter Class See Also Send Feedback

The CfgDeltaFilter type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaFilter configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | Format
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.AddedUserProperties Property
CfgDeltaFilter Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.ChangedUserProperties Property
CfgDeltaFilter Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.DBID Property
CfgDeltaFilter Class See Also Send Feedback
The DBID of the CfgDeltaFilter configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.DeletedUserProperties Property
CfgDeltaFilter Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.Description Property
CfgDeltaFilter Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Format Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.Format Property
CfgDeltaFilter Class See Also Send Feedback
Format

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As CfgFormat
Visual C++
public:
property CfgFormat^ Format {
    CfgFormat^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.Name Property
CfgDeltaFilter Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.State Property
CfgDeltaFilter Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFilter..::.Tenant Property
CfgDeltaFilter Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFolder Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder Class
Members See Also Send Feedback
CfgDeltaFolder

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaFolder : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaFolder _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaFolder : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaFolder

See Also

CfgDeltaFolder Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFolder Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder Members
CfgDeltaFolder Class Methods Properties See Also Send Feedback

The CfgDeltaFolder type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedObjectIDs | ObjectIDs
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
CustomType | CustomType
DBID | The DBID of the CfgDeltaFolder configuration object.
DeletedObjectIDs | DeletedObjectIDs
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderClass | FolderClass
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OwnerID | OwnerID
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentID | ParentID
State | State
Type | Type

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFolder Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder Methods
CfgDeltaFolder Class See Also Send Feedback

The CfgDeltaFolder type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.SetAccountPermissions Method
CfgDeltaFolder Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaFolder Class
CfgDeltaFolder Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFolder Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder Properties
CfgDeltaFolder Class See Also Send Feedback

The CfgDeltaFolder type exposes the following members.

Properties

Name | Description
AddedObjectIDs | ObjectIDs
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
CustomType | CustomType
DBID | The DBID of the CfgDeltaFolder configuration object.
DeletedObjectIDs | DeletedObjectIDs
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderClass | FolderClass
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OwnerID | OwnerID
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentID | ParentID
State | State
Type | Type

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedObjectIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.AddedObjectIDs Property
CfgDeltaFolder Class See Also Send Feedback
ObjectIDs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectID> AddedObjectIDs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedObjectIDs As ICollection(Of CfgObjectID)
Visual C++
public:
property ICollection<CfgObjectID^>^ AddedObjectIDs {
    ICollection<CfgObjectID^>^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.AddedResources Property
CfgDeltaFolder Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.AddedUserProperties Property
CfgDeltaFolder Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.ChangedResources Property
CfgDeltaFolder Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.ChangedUserProperties Property
CfgDeltaFolder Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CustomType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.CustomType Property
CfgDeltaFolder Class See Also Send Feedback
CustomType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CustomType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CustomType As Integer
Visual C++
public:
property int CustomType {
    int get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.DBID Property
CfgDeltaFolder Class See Also Send Feedback
The DBID of the CfgDeltaFolder configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedObjectIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.DeletedObjectIDs Property
CfgDeltaFolder Class See Also Send Feedback
DeletedObjectIDs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectID> DeletedObjectIDs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedObjectIDs As ICollection(Of CfgObjectID)
Visual C++
public:
property ICollection<CfgObjectID^>^ DeletedObjectIDs {
    ICollection<CfgObjectID^>^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.DeletedResources Property
CfgDeltaFolder Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.DeletedUserProperties Property
CfgDeltaFolder Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.Description Property
CfgDeltaFolder Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FolderClass Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.FolderClass Property
CfgDeltaFolder Class See Also Send Feedback
FolderClass

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolderClass FolderClass { get; }
Visual Basic (Declaration)
Public ReadOnly Property FolderClass As CfgFolderClass
Visual C++
public:
property CfgFolderClass FolderClass {
    CfgFolderClass get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.Name Property
CfgDeltaFolder Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OwnerID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.OwnerID Property
CfgDeltaFolder Class See Also Send Feedback
OwnerID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOwnerID OwnerID { get; }
Visual Basic (Declaration)
Public ReadOnly Property OwnerID As CfgOwnerID
Visual C++
public:
property CfgOwnerID^ OwnerID {
    CfgOwnerID^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ParentID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.ParentID Property
CfgDeltaFolder Class See Also Send Feedback
ParentID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgParentID ParentID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentID As CfgParentID
Visual C++
public:
property CfgParentID^ ParentID {
    CfgParentID^ get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.State Property
CfgDeltaFolder Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFolder..::.Type Property
CfgDeltaFolder Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
}

See Also

CfgDeltaFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFormat Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat Class
Members See Also Send Feedback
CfgDeltaFormat

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaFormat : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaFormat _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaFormat : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaFormat

See Also

CfgDeltaFormat Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFormat Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat Members
CfgDeltaFormat Class Methods Properties See Also Send Feedback

The CfgDeltaFormat type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedFields | Fields
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaFormat configuration object.
DeletedFields | DeletedFields
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFormat Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat Methods
CfgDeltaFormat Class See Also Send Feedback

The CfgDeltaFormat type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.SetAccountPermissions Method
CfgDeltaFormat Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaFormat Class
CfgDeltaFormat Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaFormat Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat Properties
CfgDeltaFormat Class See Also Send Feedback

The CfgDeltaFormat type exposes the following members.

Properties

Name | Description
AddedFields | Fields
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaFormat configuration object.
DeletedFields | DeletedFields
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedFields Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.AddedFields Property
CfgDeltaFormat Class See Also Send Feedback
Fields

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgField> AddedFields { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedFields As ICollection(Of CfgField)
Visual C++
public:
property ICollection<CfgField^>^ AddedFields {
    ICollection<CfgField^>^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.AddedUserProperties Property
CfgDeltaFormat Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.ChangedUserProperties Property
CfgDeltaFormat Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.DBID Property
CfgDeltaFormat Class See Also Send Feedback
The DBID of the CfgDeltaFormat configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedFields Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.DeletedFields Property
CfgDeltaFormat Class See Also Send Feedback
DeletedFields

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgField> DeletedFields { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedFields As ICollection(Of CfgField)
Visual C++
public:
property ICollection<CfgField^>^ DeletedFields {
    ICollection<CfgField^>^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.DeletedUserProperties Property
CfgDeltaFormat Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.Description Property
CfgDeltaFormat Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.Name Property
CfgDeltaFormat Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.State Property
CfgDeltaFormat Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaFormat..::.Tenant Property
CfgDeltaFormat Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup Class
Members See Also Send Feedback
CfgDeltaGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaGroup : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaGroup _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaGroup : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGroup

See Also

CfgDeltaGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup Members
CfgDeltaGroup Class Methods Properties See Also Send Feedback

The CfgDeltaGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedManagers | Managers
AddedRouteDNs | RouteDNs
AddedUserProperties | UserProperties
CapacityRule | CapacityRule
CapacityTable | CapacityTable
ChangedUserProperties | ChangedUserProperties
Contract | Contract
DBID | The DBID of the CfgDeltaGroup configuration object.
DeletedManagers | DeletedManagers
DeletedRouteDNs | DeletedRouteDNs
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
QuotaTable | QuotaTable
Site | Site
State | State
Tenant | Tenant

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup Methods
CfgDeltaGroup Class See Also Send Feedback

The CfgDeltaGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.SetAccountPermissions Method
CfgDeltaGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaGroup Class
CfgDeltaGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup Properties
CfgDeltaGroup Class See Also Send Feedback

The CfgDeltaGroup type exposes the following members.

Properties

Name | Description
AddedManagers | Managers
AddedRouteDNs | RouteDNs
AddedUserProperties | UserProperties
CapacityRule | CapacityRule
CapacityTable | CapacityTable
ChangedUserProperties | ChangedUserProperties
Contract | Contract
DBID | The DBID of the CfgDeltaGroup configuration object.
DeletedManagers | DeletedManagers
DeletedRouteDNs | DeletedRouteDNs
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
QuotaTable | QuotaTable
Site | Site
State | State
Tenant | Tenant

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedManagers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.AddedManagers Property
CfgDeltaGroup Class See Also Send Feedback
Managers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPerson> AddedManagers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedManagers As ICollection(Of CfgPerson)
Visual C++
public:
property ICollection<CfgPerson^>^ AddedManagers {
    ICollection<CfgPerson^>^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedRouteDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.AddedRouteDNs Property
CfgDeltaGroup Class See Also Send Feedback
RouteDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> AddedRouteDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedRouteDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ AddedRouteDNs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.AddedUserProperties Property
CfgDeltaGroup Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.CapacityRule Property
CfgDeltaGroup Class See Also Send Feedback
CapacityRule

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript CapacityRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property CapacityRule As CfgScript
Visual C++
public:
property CfgScript^ CapacityRule {
    CfgScript^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityTable Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.CapacityTable Property
CfgDeltaGroup Class See Also Send Feedback
CapacityTable

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTable CapacityTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property CapacityTable As CfgStatTable
Visual C++
public:
property CfgStatTable^ CapacityTable {
    CfgStatTable^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.ChangedUserProperties Property
CfgDeltaGroup Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.Contract Property
CfgDeltaGroup Class See Also Send Feedback
Contract

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; }
Visual Basic (Declaration)
Public ReadOnly Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.DBID Property
CfgDeltaGroup Class See Also Send Feedback
The DBID of the CfgDeltaGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedManagers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.DeletedManagers Property
CfgDeltaGroup Class See Also Send Feedback
DeletedManagers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPerson> DeletedManagers { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedManagers As ICollection(Of CfgPerson)
Visual C++
public:
property ICollection<CfgPerson^>^ DeletedManagers {
    ICollection<CfgPerson^>^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedRouteDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.DeletedRouteDNs Property
CfgDeltaGroup Class See Also Send Feedback
DeletedRouteDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DeletedRouteDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedRouteDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DeletedRouteDNs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.DeletedUserProperties Property
CfgDeltaGroup Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.Name Property
CfgDeltaGroup Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


QuotaTable Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.QuotaTable Property
CfgDeltaGroup Class See Also Send Feedback
QuotaTable

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTable QuotaTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property QuotaTable As CfgStatTable
Visual C++
public:
property CfgStatTable^ QuotaTable {
    CfgStatTable^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.Site Property
CfgDeltaGroup Class See Also Send Feedback
Site

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; }
Visual Basic (Declaration)
Public ReadOnly Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.State Property
CfgDeltaGroup Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGroup..::.Tenant Property
CfgDeltaGroup Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPCustomer Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer Class
Members See Also Send Feedback
CfgDeltaGVPCustomer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaGVPCustomer : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaGVPCustomer _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaGVPCustomer : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGVPCustomer

See Also

CfgDeltaGVPCustomer Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPCustomer Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer Members
CfgDeltaGVPCustomer Class Methods Properties See Also Send Feedback

The CfgDeltaGVPCustomer type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
Channel | Channel
DBID | The DBID of the CfgDeltaGVPCustomer configuration object.
DeletedUserProperties | DeletedUserProperties
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAdminCustomer | IsAdminCustomer
IsProvisioned | IsProvisioned
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
Notes | Notes
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller | Reseller
State | State
Tenant | Tenant
TimeZone | TimeZone

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPCustomer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer Methods
CfgDeltaGVPCustomer Class See Also Send Feedback

The CfgDeltaGVPCustomer type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.SetAccountPermissions Method
CfgDeltaGVPCustomer Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaGVPCustomer Class
CfgDeltaGVPCustomer Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPCustomer Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer Properties
CfgDeltaGVPCustomer Class See Also Send Feedback

The CfgDeltaGVPCustomer type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
Channel | Channel
DBID | The DBID of the CfgDeltaGVPCustomer configuration object.
DeletedUserProperties | DeletedUserProperties
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAdminCustomer | IsAdminCustomer
IsProvisioned | IsProvisioned
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
Notes | Notes
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller | Reseller
State | State
Tenant | Tenant
TimeZone | TimeZone

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.AddedUserProperties Property
CfgDeltaGVPCustomer Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.ChangedUserProperties Property
CfgDeltaGVPCustomer Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Channel Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.Channel Property
CfgDeltaGVPCustomer Class See Also Send Feedback
Channel

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Channel { get; }
Visual Basic (Declaration)
Public ReadOnly Property Channel As String
Visual C++
public:
property String^ Channel {
    String^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.DBID Property
CfgDeltaGVPCustomer Class See Also Send Feedback
The DBID of the CfgDeltaGVPCustomer configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.DeletedUserProperties Property
CfgDeltaGVPCustomer Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.DisplayName Property
CfgDeltaGVPCustomer Class See Also Send Feedback
DisplayName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsAdminCustomer Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.IsAdminCustomer Property
CfgDeltaGVPCustomer Class See Also Send Feedback
IsAdminCustomer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAdminCustomer { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAdminCustomer As CfgFlag
Visual C++
public:
property CfgFlag IsAdminCustomer {
    CfgFlag get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsProvisioned Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.IsProvisioned Property
CfgDeltaGVPCustomer Class See Also Send Feedback
IsProvisioned

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsProvisioned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsProvisioned As CfgFlag
Visual C++
public:
property CfgFlag IsProvisioned {
    CfgFlag get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.Name Property
CfgDeltaGVPCustomer Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.Notes Property
CfgDeltaGVPCustomer Class See Also Send Feedback
Notes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Reseller Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.Reseller Property
CfgDeltaGVPCustomer Class See Also Send Feedback
Reseller

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPReseller Reseller { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reseller As CfgGVPReseller
Visual C++
public:
property CfgGVPReseller^ Reseller {
    CfgGVPReseller^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.State Property
CfgDeltaGVPCustomer Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.Tenant Property
CfgDeltaGVPCustomer Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPCustomer..::.TimeZone Property
CfgDeltaGVPCustomer Class See Also Send Feedback
TimeZone

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone TimeZone { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As CfgTimeZone
Visual C++
public:
property CfgTimeZone^ TimeZone {
    CfgTimeZone^ get ();
}

See Also

CfgDeltaGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPIVRProfile Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile Class
Members See Also Send Feedback
CfgDeltaGVPIVRProfile

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaGVPIVRProfile : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaGVPIVRProfile _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaGVPIVRProfile : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGVPIVRProfile

See Also

CfgDeltaGVPIVRProfile Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPIVRProfile Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile Members
CfgDeltaGVPIVRProfile Class Methods Properties See Also Send Feedback

The CfgDeltaGVPIVRProfile type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedDIDs | DIDs
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
Customer | Customer
DBID | The DBID of the CfgDeltaGVPIVRProfile configuration object.
DeletedDIDs | DeletedDIDs
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Description | Description
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndServiceDate | EndServiceDate
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsProvisioned | IsProvisioned
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
Notes | Notes
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller | Reseller
StartServiceDate | StartServiceDate
State | State
Status | Status
Tenant | Tenant
Tfn | Tfn
Type | Type

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPIVRProfile Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile Methods
CfgDeltaGVPIVRProfile Class See Also Send Feedback

The CfgDeltaGVPIVRProfile type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.SetAccountPermissions Method
CfgDeltaGVPIVRProfile Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaGVPIVRProfile Class
CfgDeltaGVPIVRProfile Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPIVRProfile Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile Properties
CfgDeltaGVPIVRProfile Class See Also Send Feedback

The CfgDeltaGVPIVRProfile type exposes the following members.

Properties

Name | Description
AddedDIDs | DIDs
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
Customer | Customer
DBID | The DBID of the CfgDeltaGVPIVRProfile configuration object.
DeletedDIDs | DeletedDIDs
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Description | Description
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndServiceDate | EndServiceDate
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsProvisioned | IsProvisioned
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
Notes | Notes
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller | Reseller
StartServiceDate | StartServiceDate
State | State
Status | Status
Tenant | Tenant
Tfn | Tfn
Type | Type

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedDIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.AddedDIDs Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
DIDs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> AddedDIDs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedDIDs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ AddedDIDs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.AddedResources Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.AddedUserProperties Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.ChangedResources Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.ChangedUserProperties Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Customer Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Customer Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Customer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPCustomer Customer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Customer As CfgGVPCustomer
Visual C++
public:
property CfgGVPCustomer^ Customer {
    CfgGVPCustomer^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.DBID Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
The DBID of the CfgDeltaGVPIVRProfile configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedDIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.DeletedDIDs Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
DeletedDIDs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DeletedDIDs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedDIDs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DeletedDIDs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.DeletedResources Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.DeletedUserProperties Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Description Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.DisplayName Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
DisplayName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EndServiceDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.EndServiceDate Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
EndServiceDate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime EndServiceDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndServiceDate As DateTime
Visual C++
public:
property DateTime EndServiceDate {
    DateTime get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsProvisioned Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.IsProvisioned Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
IsProvisioned

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsProvisioned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsProvisioned As CfgFlag
Visual C++
public:
property CfgFlag IsProvisioned {
    CfgFlag get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Name Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Notes Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Notes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Reseller Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Reseller Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Reseller

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPReseller Reseller { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reseller As CfgGVPReseller
Visual C++
public:
property CfgGVPReseller^ Reseller {
    CfgGVPReseller^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartServiceDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.StartServiceDate Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
StartServiceDate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime StartServiceDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartServiceDate As DateTime
Visual C++
public:
property DateTime StartServiceDate {
    DateTime get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.State Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Status Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Status

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Tenant Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tfn Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Tfn Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Tfn

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Tfn { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tfn As String
Visual C++
public:
property String^ Tfn {
    String^ get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPIVRProfile..::.Type Property
CfgDeltaGVPIVRProfile Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRProfileType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgIVRProfileType
Visual C++
public:
property CfgIVRProfileType Type {
    CfgIVRProfileType get ();
}

See Also

CfgDeltaGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPReseller Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller Class
Members See Also Send Feedback
CfgDeltaGVPReseller

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaGVPReseller : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaGVPReseller _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaGVPReseller : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaGVPReseller

See Also

CfgDeltaGVPReseller Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPReseller Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller Members
CfgDeltaGVPReseller Class Methods Properties See Also Send Feedback

The CfgDeltaGVPReseller type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaGVPReseller configuration object.
DeletedUserProperties | DeletedUserProperties
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsParentNSP | IsParentNSP
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
Notes | Notes
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartDate | StartDate
State | State
Tenant | Tenant
TimeZone | TimeZone

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPReseller Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller Methods
CfgDeltaGVPReseller Class See Also Send Feedback

The CfgDeltaGVPReseller type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.SetAccountPermissions Method
CfgDeltaGVPReseller Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaGVPReseller Class
CfgDeltaGVPReseller Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaGVPReseller Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller Properties
CfgDeltaGVPReseller Class See Also Send Feedback

The CfgDeltaGVPReseller type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaGVPReseller configuration object.
DeletedUserProperties | DeletedUserProperties
DisplayName | DisplayName
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsParentNSP | IsParentNSP
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
Notes | Notes
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartDate | StartDate
State | State
Tenant | Tenant
TimeZone | TimeZone

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.AddedUserProperties Property
CfgDeltaGVPReseller Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.ChangedUserProperties Property
CfgDeltaGVPReseller Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.DBID Property
CfgDeltaGVPReseller Class See Also Send Feedback
The DBID of the CfgDeltaGVPReseller configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.DeletedUserProperties Property
CfgDeltaGVPReseller Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.DisplayName Property
CfgDeltaGVPReseller Class See Also Send Feedback
DisplayName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsParentNSP Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.IsParentNSP Property
CfgDeltaGVPReseller Class See Also Send Feedback
IsParentNSP

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsParentNSP { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsParentNSP As CfgFlag
Visual C++
public:
property CfgFlag IsParentNSP {
    CfgFlag get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.Name Property
CfgDeltaGVPReseller Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.Notes Property
CfgDeltaGVPReseller Class See Also Send Feedback
Notes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.StartDate Property
CfgDeltaGVPReseller Class See Also Send Feedback
StartDate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime StartDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.State Property
CfgDeltaGVPReseller Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.Tenant Property
CfgDeltaGVPReseller Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaGVPReseller..::.TimeZone Property
CfgDeltaGVPReseller Class See Also Send Feedback
TimeZone

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone TimeZone { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As CfgTimeZone
Visual C++
public:
property CfgTimeZone^ TimeZone {
    CfgTimeZone^ get ();
}

See Also

CfgDeltaGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaHost Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost Class
Members See Also Send Feedback
CfgDeltaHost

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaHost : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaHost _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaHost : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaHost

See Also

CfgDeltaHost Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaHost Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost Members
CfgDeltaHost Class Methods Properties See Also Send Feedback

The CfgDeltaHost type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedResources | Resources
AddedUserProperties | UserProperties
Address | Address
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
Comment | Comment
ContactPerson | ContactPerson
DBID | The DBID of the CfgDeltaHost configuration object.
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
HWID | HWID
IPaddress | IPaddress
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LCAPort | LCAPort
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OSinfo | OSinfo
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
SCS | SCS
State | State
Type | Type

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaHost Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost Methods
CfgDeltaHost Class See Also Send Feedback

The CfgDeltaHost type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.SetAccountPermissions Method
CfgDeltaHost Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaHost Class
CfgDeltaHost Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaHost Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost Properties
CfgDeltaHost Class See Also Send Feedback

The CfgDeltaHost type exposes the following members.

Properties

Name | Description
AddedResources | Resources
AddedUserProperties | UserProperties
Address | Address
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
Comment | Comment
ContactPerson | ContactPerson
DBID | The DBID of the CfgDeltaHost configuration object.
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
HWID | HWID
IPaddress | IPaddress
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LCAPort | LCAPort
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OSinfo | OSinfo
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
SCS | SCS
State | State
Type | Type

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.AddedResources Property
CfgDeltaHost Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.AddedUserProperties Property
CfgDeltaHost Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.Address Property
CfgDeltaHost Class See Also Send Feedback
Address

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.ChangedResources Property
CfgDeltaHost Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.ChangedUserProperties Property
CfgDeltaHost Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Comment Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.Comment Property
CfgDeltaHost Class See Also Send Feedback
Comment

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Comment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ContactPerson Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.ContactPerson Property
CfgDeltaHost Class See Also Send Feedback
ContactPerson

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPerson ContactPerson { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContactPerson As CfgPerson
Visual C++
public:
property CfgPerson^ ContactPerson {
    CfgPerson^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.DBID Property
CfgDeltaHost Class See Also Send Feedback
The DBID of the CfgDeltaHost configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.DeletedResources Property
CfgDeltaHost Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.DeletedUserProperties Property
CfgDeltaHost Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


HWID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.HWID Property
CfgDeltaHost Class See Also Send Feedback
HWID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string HWID { get; }
Visual Basic (Declaration)
Public ReadOnly Property HWID As String
Visual C++
public:
property String^ HWID {
    String^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IPaddress Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.IPaddress Property
CfgDeltaHost Class See Also Send Feedback
IPaddress

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string IPaddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property IPaddress As String
Visual C++
public:
property String^ IPaddress {
    String^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LCAPort Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.LCAPort Property
CfgDeltaHost Class See Also Send Feedback
LCAPort

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LCAPort { get; }
Visual Basic (Declaration)
Public ReadOnly Property LCAPort As String
Visual C++
public:
property String^ LCAPort {
    String^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.Name Property
CfgDeltaHost Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OSinfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.OSinfo Property
CfgDeltaHost Class See Also Send Feedback
OSinfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOS OSinfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property OSinfo As CfgOS
Visual C++
public:
property CfgOS^ OSinfo {
    CfgOS^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SCS Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.SCS Property
CfgDeltaHost Class See Also Send Feedback
SCS

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication SCS { get; }
Visual Basic (Declaration)
Public ReadOnly Property SCS As CfgApplication
Visual C++
public:
property CfgApplication^ SCS {
    CfgApplication^ get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.State Property
CfgDeltaHost Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaHost..::.Type Property
CfgDeltaHost Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHostType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgHostType
Visual C++
public:
property CfgHostType Type {
    CfgHostType get ();
}

See Also

CfgDeltaHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVR Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR Class
Members See Also Send Feedback
CfgDeltaIVR

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaIVR : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaIVR _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaIVR : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaIVR

See Also

CfgDeltaIVR Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVR Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR Members
CfgDeltaIVR Class Methods Properties See Also Send Feedback

The CfgDeltaIVR type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaIVR configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRServer | IVRServer
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type
Version | Version

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVR Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR Methods
CfgDeltaIVR Class See Also Send Feedback

The CfgDeltaIVR type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.SetAccountPermissions Method
CfgDeltaIVR Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaIVR Class
CfgDeltaIVR Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVR Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR Properties
CfgDeltaIVR Class See Also Send Feedback

The CfgDeltaIVR type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaIVR configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRServer | IVRServer
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type
Version | Version

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.AddedUserProperties Property
CfgDeltaIVR Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.ChangedUserProperties Property
CfgDeltaIVR Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.DBID Property
CfgDeltaIVR Class See Also Send Feedback
The DBID of the CfgDeltaIVR configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.DeletedUserProperties Property
CfgDeltaIVR Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.Description Property
CfgDeltaIVR Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IVRServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.IVRServer Property
CfgDeltaIVR Class See Also Send Feedback
IVRServer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication IVRServer { get; }
Visual Basic (Declaration)
Public ReadOnly Property IVRServer As CfgApplication
Visual C++
public:
property CfgApplication^ IVRServer {
    CfgApplication^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.Name Property
CfgDeltaIVR Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.State Property
CfgDeltaIVR Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.Tenant Property
CfgDeltaIVR Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.Type Property
CfgDeltaIVR Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgIVRType
Visual C++
public:
property CfgIVRType Type {
    CfgIVRType get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVR..::.Version Property
CfgDeltaIVR Class See Also Send Feedback
Version

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

CfgDeltaIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVRPort Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort Class
Members See Also Send Feedback
CfgDeltaIVRPort

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaIVRPort : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaIVRPort _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaIVRPort : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaIVRPort

See Also

CfgDeltaIVRPort Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVRPort Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort Members
CfgDeltaIVRPort Class Methods Properties See Also Send Feedback

The CfgDeltaIVRPort type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaIVRPort configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DN | DN
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVR | IVR
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PortNumber | PortNumber
State | State
Tenant | Tenant

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVRPort Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort Methods
CfgDeltaIVRPort Class See Also Send Feedback

The CfgDeltaIVRPort type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.SetAccountPermissions Method
CfgDeltaIVRPort Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaIVRPort Class
CfgDeltaIVRPort Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaIVRPort Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort Properties
CfgDeltaIVRPort Class See Also Send Feedback

The CfgDeltaIVRPort type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaIVRPort configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DN | DN
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVR | IVR
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PortNumber | PortNumber
State | State
Tenant | Tenant

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.AddedUserProperties Property
CfgDeltaIVRPort Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.ChangedUserProperties Property
CfgDeltaIVRPort Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.DBID Property
CfgDeltaIVRPort Class See Also Send Feedback
The DBID of the CfgDeltaIVRPort configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.DeletedUserProperties Property
CfgDeltaIVRPort Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.Description Property
CfgDeltaIVRPort Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DN Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.DN Property
CfgDeltaIVRPort Class See Also Send Feedback
DN

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN DN { get; }
Visual Basic (Declaration)
Public ReadOnly Property DN As CfgDN
Visual C++
public:
property CfgDN^ DN {
    CfgDN^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IVR Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.IVR Property
CfgDeltaIVRPort Class See Also Send Feedback
IVR

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVR IVR { get; }
Visual Basic (Declaration)
Public ReadOnly Property IVR As CfgIVR
Visual C++
public:
property CfgIVR^ IVR {
    CfgIVR^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PortNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.PortNumber Property
CfgDeltaIVRPort Class See Also Send Feedback
PortNumber

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PortNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PortNumber As String
Visual C++
public:
property String^ PortNumber {
    String^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.State Property
CfgDeltaIVRPort Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaIVRPort..::.Tenant Property
CfgDeltaIVRPort Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaObjectiveTable Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable Class
Members See Also Send Feedback
CfgDeltaObjectiveTable

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaObjectiveTable : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaObjectiveTable _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaObjectiveTable : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaObjectiveTable

See Also

CfgDeltaObjectiveTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaObjectiveTable Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable Members
CfgDeltaObjectiveTable Class Methods Properties See Also Send Feedback

The CfgDeltaObjectiveTable type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedObjectiveRecords | ObjectiveRecords
AddedUserProperties | UserProperties
ChangedObjectiveRecords | ChangedObjectiveRecords
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaObjectiveTable configuration object.
DeletedObjectiveRecords | DeletedObjectiveRecords
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PrepaidCost | PrepaidCost
State | State
Tenant | Tenant
TimeEnd | TimeEnd
TimeStart | TimeStart
TimeZone | TimeZone
Type | Type

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaObjectiveTable Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable Methods
CfgDeltaObjectiveTable Class See Also Send Feedback

The CfgDeltaObjectiveTable type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.SetAccountPermissions Method
CfgDeltaObjectiveTable Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaObjectiveTable Class
CfgDeltaObjectiveTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaObjectiveTable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable Properties
CfgDeltaObjectiveTable Class See Also Send Feedback

The CfgDeltaObjectiveTable type exposes the following members.

Properties

Name | Description
AddedObjectiveRecords | ObjectiveRecords
AddedUserProperties | UserProperties
ChangedObjectiveRecords | ChangedObjectiveRecords
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaObjectiveTable configuration object.
DeletedObjectiveRecords | DeletedObjectiveRecords
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PrepaidCost | PrepaidCost
State | State
Tenant | Tenant
TimeEnd | TimeEnd
TimeStart | TimeStart
TimeZone | TimeZone
Type | Type

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedObjectiveRecords Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.AddedObjectiveRecords Property
CfgDeltaObjectiveTable Class See Also Send Feedback
ObjectiveRecords

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectiveTableRecord> AddedObjectiveRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedObjectiveRecords As ICollection(Of CfgObjectiveTableRecord)
Visual C++
public:
property ICollection<CfgObjectiveTableRecord^>^ AddedObjectiveRecords {
    ICollection<CfgObjectiveTableRecord^>^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.AddedUserProperties Property
CfgDeltaObjectiveTable Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedObjectiveRecords Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.ChangedObjectiveRecords Property
CfgDeltaObjectiveTable Class See Also Send Feedback
ChangedObjectiveRecords

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectiveTableRecord> ChangedObjectiveRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedObjectiveRecords As ICollection(Of CfgObjectiveTableRecord)
Visual C++
public:
property ICollection<CfgObjectiveTableRecord^>^ ChangedObjectiveRecords {
    ICollection<CfgObjectiveTableRecord^>^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.ChangedUserProperties Property
CfgDeltaObjectiveTable Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.DBID Property
CfgDeltaObjectiveTable Class See Also Send Feedback
The DBID of the CfgDeltaObjectiveTable configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedObjectiveRecords Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.DeletedObjectiveRecords Property
CfgDeltaObjectiveTable Class See Also Send Feedback
DeletedObjectiveRecords

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectiveTableRecord> DeletedObjectiveRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedObjectiveRecords As ICollection(Of CfgObjectiveTableRecord)
Visual C++
public:
property ICollection<CfgObjectiveTableRecord^>^ DeletedObjectiveRecords {
    ICollection<CfgObjectiveTableRecord^>^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.DeletedUserProperties Property
CfgDeltaObjectiveTable Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.Description Property
CfgDeltaObjectiveTable Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.Name Property
CfgDeltaObjectiveTable Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PrepaidCost Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.PrepaidCost Property
CfgDeltaObjectiveTable Class See Also Send Feedback
PrepaidCost

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int PrepaidCost { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrepaidCost As Integer
Visual C++
public:
property int PrepaidCost {
    int get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.State Property
CfgDeltaObjectiveTable Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.Tenant Property
CfgDeltaObjectiveTable Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeEnd Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.TimeEnd Property
CfgDeltaObjectiveTable Class See Also Send Feedback
TimeEnd

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime TimeEnd { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeEnd As DateTime
Visual C++
public:
property DateTime TimeEnd {
    DateTime get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeStart Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.TimeStart Property
CfgDeltaObjectiveTable Class See Also Send Feedback
TimeStart

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime TimeStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeStart As DateTime
Visual C++
public:
property DateTime TimeStart {
    DateTime get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.TimeZone Property
CfgDeltaObjectiveTable Class See Also Send Feedback
TimeZone

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone TimeZone { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As CfgTimeZone
Visual C++
public:
property CfgTimeZone^ TimeZone {
    CfgTimeZone^ get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaObjectiveTable..::.Type Property
CfgDeltaObjectiveTable Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgObjectiveTableType
Visual C++
public:
property CfgObjectiveTableType Type {
    CfgObjectiveTableType get ();
}

See Also

CfgDeltaObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPerson Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson Class
Members See Also Send Feedback
CfgDeltaPerson

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaPerson : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaPerson _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaPerson : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPerson

See Also

CfgDeltaPerson Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPerson Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson Members
CfgDeltaPerson Class Methods Properties See Also Send Feedback

The CfgDeltaPerson type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedAppRanks | AppRanks
AddedAssignedTenants | AssignedTenants
AddedUserProperties | UserProperties
Address | Address
AgentInfo | AgentInfo
Birthdate | Birthdate
ChangedAppRanks | ChangedAppRanks
ChangedUserProperties | ChangedUserProperties
Comment | Comment
DBID | The DBID of the CfgDeltaPerson configuration object.
DeletedAppRanks | DeletedAppRanks
DeletedAssignedTenants | DeletedAssignedTenants
DeletedUserProperties | DeletedUserProperties
DeltaAgentInfo | DeltaAgentInfo
EmailAddress | EmailAddress
EmployeeID | EmployeeID
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExternalID | ExternalID
FirstName | FirstName
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAdmin | IsAdmin
IsAgent | IsAgent
IsExternalAuth | IsExternalAuth
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LastName | LastName
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | Password
Phones | Phones
State | State
Tenant | Tenant
UserName | UserName

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPerson Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson Methods
CfgDeltaPerson Class See Also Send Feedback

The CfgDeltaPerson type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.SetAccountPermissions Method
CfgDeltaPerson Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaPerson Class
CfgDeltaPerson Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPerson Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson Properties
CfgDeltaPerson Class See Also Send Feedback

The CfgDeltaPerson type exposes the following members.

Properties

Name | Description
AddedAppRanks | AppRanks
AddedAssignedTenants | AssignedTenants
AddedUserProperties | UserProperties
Address | Address
AgentInfo | AgentInfo
Birthdate | Birthdate
ChangedAppRanks | ChangedAppRanks
ChangedUserProperties | ChangedUserProperties
Comment | Comment
DBID | The DBID of the CfgDeltaPerson configuration object.
DeletedAppRanks | DeletedAppRanks
DeletedAssignedTenants | DeletedAssignedTenants
DeletedUserProperties | DeletedUserProperties
DeltaAgentInfo | DeltaAgentInfo
EmailAddress | EmailAddress
EmployeeID | EmployeeID
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExternalID | ExternalID
FirstName | FirstName
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAdmin | IsAdmin
IsAgent | IsAgent
IsExternalAuth | IsExternalAuth
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LastName | LastName
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | Password
Phones | Phones
State | State
Tenant | Tenant
UserName | UserName

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedAppRanks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.AddedAppRanks Property
CfgDeltaPerson Class See Also Send Feedback
AppRanks

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppRank> AddedAppRanks { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedAppRanks As ICollection(Of CfgAppRank)
Visual C++
public:
property ICollection<CfgAppRank^>^ AddedAppRanks {
    ICollection<CfgAppRank^>^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedAssignedTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.AddedAssignedTenants Property
CfgDeltaPerson Class See Also Send Feedback
AssignedTenants

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> AddedAssignedTenants { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedAssignedTenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ AddedAssignedTenants {
    ICollection<CfgTenant^>^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.AddedUserProperties Property
CfgDeltaPerson Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.Address Property
CfgDeltaPerson Class See Also Send Feedback
Address

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AgentInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.AgentInfo Property
CfgDeltaPerson Class See Also Send Feedback
AgentInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentInfo AgentInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property AgentInfo As CfgAgentInfo
Visual C++
public:
property CfgAgentInfo^ AgentInfo {
    CfgAgentInfo^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Birthdate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.Birthdate Property
CfgDeltaPerson Class See Also Send Feedback
Birthdate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Birthdate { get; }
Visual Basic (Declaration)
Public ReadOnly Property Birthdate As String
Visual C++
public:
property String^ Birthdate {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedAppRanks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.ChangedAppRanks Property
CfgDeltaPerson Class See Also Send Feedback
ChangedAppRanks

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppRank> ChangedAppRanks { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedAppRanks As ICollection(Of CfgAppRank)
Visual C++
public:
property ICollection<CfgAppRank^>^ ChangedAppRanks {
    ICollection<CfgAppRank^>^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.ChangedUserProperties Property
CfgDeltaPerson Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Comment Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.Comment Property
CfgDeltaPerson Class See Also Send Feedback
Comment

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Comment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.DBID Property
CfgDeltaPerson Class See Also Send Feedback
The DBID of the CfgDeltaPerson configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAppRanks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.DeletedAppRanks Property
CfgDeltaPerson Class See Also Send Feedback
DeletedAppRanks

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppRank> DeletedAppRanks { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAppRanks As ICollection(Of CfgAppRank)
Visual C++
public:
property ICollection<CfgAppRank^>^ DeletedAppRanks {
    ICollection<CfgAppRank^>^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAssignedTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.DeletedAssignedTenants Property
CfgDeltaPerson Class See Also Send Feedback
DeletedAssignedTenants

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> DeletedAssignedTenants { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAssignedTenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ DeletedAssignedTenants {
    ICollection<CfgTenant^>^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.DeletedUserProperties Property
CfgDeltaPerson Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeltaAgentInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.DeltaAgentInfo Property
CfgDeltaPerson Class See Also Send Feedback
DeltaAgentInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDeltaAgentInfo DeltaAgentInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaAgentInfo As CfgDeltaAgentInfo
Visual C++
public:
property CfgDeltaAgentInfo^ DeltaAgentInfo {
    CfgDeltaAgentInfo^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EmailAddress Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.EmailAddress Property
CfgDeltaPerson Class See Also Send Feedback
EmailAddress

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmailAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EmployeeID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.EmployeeID Property
CfgDeltaPerson Class See Also Send Feedback
EmployeeID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmployeeID { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmployeeID As String
Visual C++
public:
property String^ EmployeeID {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ExternalID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.ExternalID Property
CfgDeltaPerson Class See Also Send Feedback
ExternalID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExternalID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExternalID As String
Visual C++
public:
property String^ ExternalID {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.FirstName Property
CfgDeltaPerson Class See Also Send Feedback
FirstName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string FirstName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsAdmin Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.IsAdmin Property
CfgDeltaPerson Class See Also Send Feedback
IsAdmin

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAdmin { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAdmin As CfgFlag
Visual C++
public:
property CfgFlag IsAdmin {
    CfgFlag get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.IsAgent Property
CfgDeltaPerson Class See Also Send Feedback
IsAgent

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAgent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsAgent As CfgFlag
Visual C++
public:
property CfgFlag IsAgent {
    CfgFlag get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsExternalAuth Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.IsExternalAuth Property
CfgDeltaPerson Class See Also Send Feedback
IsExternalAuth

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsExternalAuth { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExternalAuth As CfgFlag
Visual C++
public:
property CfgFlag IsExternalAuth {
    CfgFlag get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.LastName Property
CfgDeltaPerson Class See Also Send Feedback
LastName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LastName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.Password Property
CfgDeltaPerson Class See Also Send Feedback
Password

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; }
Visual Basic (Declaration)
Public ReadOnly Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Phones Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.Phones Property
CfgDeltaPerson Class See Also Send Feedback
Phones

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhones Phones { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phones As CfgPhones
Visual C++
public:
property CfgPhones^ Phones {
    CfgPhones^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.State Property
CfgDeltaPerson Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.Tenant Property
CfgDeltaPerson Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPerson..::.UserName Property
CfgDeltaPerson Class See Also Send Feedback
UserName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string UserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
}

See Also

CfgDeltaPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPhysicalSwitch Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch Class
Members See Also Send Feedback
CfgDeltaPhysicalSwitch

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaPhysicalSwitch : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaPhysicalSwitch _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaPhysicalSwitch : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPhysicalSwitch

See Also

CfgDeltaPhysicalSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPhysicalSwitch Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch Members
CfgDeltaPhysicalSwitch Class Methods Properties See Also Send Feedback

The CfgDeltaPhysicalSwitch type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
Address | Address
ChangedUserProperties | ChangedUserProperties
ContactPerson | ContactPerson
DBID | The DBID of the CfgDeltaPhysicalSwitch configuration object.
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Type | Type

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPhysicalSwitch Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch Methods
CfgDeltaPhysicalSwitch Class See Also Send Feedback

The CfgDeltaPhysicalSwitch type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.SetAccountPermissions Method
CfgDeltaPhysicalSwitch Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaPhysicalSwitch Class
CfgDeltaPhysicalSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPhysicalSwitch Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch Properties
CfgDeltaPhysicalSwitch Class See Also Send Feedback

The CfgDeltaPhysicalSwitch type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
Address | Address
ChangedUserProperties | ChangedUserProperties
ContactPerson | ContactPerson
DBID | The DBID of the CfgDeltaPhysicalSwitch configuration object.
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Type | Type

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.AddedUserProperties Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.Address Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
Address

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.ChangedUserProperties Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ContactPerson Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.ContactPerson Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
ContactPerson

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPerson ContactPerson { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContactPerson As CfgPerson
Visual C++
public:
property CfgPerson^ ContactPerson {
    CfgPerson^ get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.DBID Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
The DBID of the CfgDeltaPhysicalSwitch configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.DeletedUserProperties Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.Name Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.State Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPhysicalSwitch..::.Type Property
CfgDeltaPhysicalSwitch Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgSwitchType
Visual C++
public:
property CfgSwitchType Type {
    CfgSwitchType get ();
}

See Also

CfgDeltaPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlace Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace Class
Members See Also Send Feedback
CfgDeltaPlace

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaPlace : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaPlace _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaPlace : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPlace

See Also

CfgDeltaPlace Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlace Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace Members
CfgDeltaPlace Class Methods Properties See Also Send Feedback

The CfgDeltaPlace type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedDNs | DNs
AddedUserProperties | UserProperties
CapacityRule | CapacityRule
ChangedUserProperties | ChangedUserProperties
Contract | Contract
DBID | The DBID of the CfgDeltaPlace configuration object.
DeletedDNs | DeletedDNs
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Site | Site
State | State
Tenant | Tenant

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlace Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace Methods
CfgDeltaPlace Class See Also Send Feedback

The CfgDeltaPlace type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.SetAccountPermissions Method
CfgDeltaPlace Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaPlace Class
CfgDeltaPlace Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlace Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace Properties
CfgDeltaPlace Class See Also Send Feedback

The CfgDeltaPlace type exposes the following members.

Properties

Name | Description
AddedDNs | DNs
AddedUserProperties | UserProperties
CapacityRule | CapacityRule
ChangedUserProperties | ChangedUserProperties
Contract | Contract
DBID | The DBID of the CfgDeltaPlace configuration object.
DeletedDNs | DeletedDNs
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Site | Site
State | State
Tenant | Tenant

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.AddedDNs Property
CfgDeltaPlace Class See Also Send Feedback
DNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> AddedDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ AddedDNs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.AddedUserProperties Property
CfgDeltaPlace Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.CapacityRule Property
CfgDeltaPlace Class See Also Send Feedback
CapacityRule

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript CapacityRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property CapacityRule As CfgScript
Visual C++
public:
property CfgScript^ CapacityRule {
    CfgScript^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.ChangedUserProperties Property
CfgDeltaPlace Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.Contract Property
CfgDeltaPlace Class See Also Send Feedback
Contract

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; }
Visual Basic (Declaration)
Public ReadOnly Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.DBID Property
CfgDeltaPlace Class See Also Send Feedback
The DBID of the CfgDeltaPlace configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.DeletedDNs Property
CfgDeltaPlace Class See Also Send Feedback
DeletedDNs

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DeletedDNs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DeletedDNs {
    ICollection<CfgDN^>^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.DeletedUserProperties Property
CfgDeltaPlace Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.Name Property
CfgDeltaPlace Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.Site Property
CfgDeltaPlace Class See Also Send Feedback
Site

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; }
Visual Basic (Declaration)
Public ReadOnly Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.State Property
CfgDeltaPlace Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlace..::.Tenant Property
CfgDeltaPlace Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlaceGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup Class
Members See Also Send Feedback
CfgDeltaPlaceGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaPlaceGroup : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaPlaceGroup _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaPlaceGroup : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaPlaceGroup

See Also

CfgDeltaPlaceGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlaceGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup Members
CfgDeltaPlaceGroup Class Methods Properties See Also Send Feedback

The CfgDeltaPlaceGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedPlaces | AddedPlaces
DBID | The DBID of the CfgDeltaPlaceGroup configuration object.
DeletedPlaces | DeletedPlaces
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlaceGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup Methods
CfgDeltaPlaceGroup Class See Also Send Feedback

The CfgDeltaPlaceGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup..::.SetAccountPermissions Method
CfgDeltaPlaceGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaPlaceGroup Class
CfgDeltaPlaceGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaPlaceGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup Properties
CfgDeltaPlaceGroup Class See Also Send Feedback

The CfgDeltaPlaceGroup type exposes the following members.

Properties

Name | Description
AddedPlaces | AddedPlaces
DBID | The DBID of the CfgDeltaPlaceGroup configuration object.
DeletedPlaces | DeletedPlaces
DeltaGroupInfo | DeltaGroupInfo
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedPlaces Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup..::.AddedPlaces Property
CfgDeltaPlaceGroup Class See Also Send Feedback
AddedPlaces

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPlace> AddedPlaces { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedPlaces As ICollection(Of CfgPlace)
Visual C++
public:
property ICollection<CfgPlace^>^ AddedPlaces {
    ICollection<CfgPlace^>^ get ();
}

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup..::.DBID Property
CfgDeltaPlaceGroup Class See Also Send Feedback
The DBID of the CfgDeltaPlaceGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedPlaces Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup..::.DeletedPlaces Property
CfgDeltaPlaceGroup Class See Also Send Feedback
DeletedPlaces

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPlace> DeletedPlaces { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedPlaces As ICollection(Of CfgPlace)
Visual C++
public:
property ICollection<CfgPlace^>^ DeletedPlaces {
    ICollection<CfgPlace^>^ get ();
}

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeltaGroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaPlaceGroup..::.DeltaGroupInfo Property
CfgDeltaPlaceGroup Class See Also Send Feedback
DeltaGroupInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDeltaGroup DeltaGroupInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaGroupInfo As CfgDeltaGroup
Visual C++
public:
property CfgDeltaGroup^ DeltaGroupInfo {
    CfgDeltaGroup^ get ();
}

See Also

CfgDeltaPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaRole Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole Class
Members See Also Send Feedback
CfgDeltaRole

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaRole : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaRole _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaRole : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaRole

See Also

CfgDeltaRole Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaRole Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole Members
CfgDeltaRole Class Methods Properties See Also Send Feedback

The CfgDeltaRole type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedMembers | Members
AddedUserProperties | UserProperties
ChangedRoleMembers | ChangedRoleMembers
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaRole configuration object.
DeletedRoleMembers | DeletedRoleMembers
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaRole Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole Methods
CfgDeltaRole Class See Also Send Feedback

The CfgDeltaRole type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.SetAccountPermissions Method
CfgDeltaRole Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaRole Class
CfgDeltaRole Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaRole Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole Properties
CfgDeltaRole Class See Also Send Feedback

The CfgDeltaRole type exposes the following members.

Properties

Name | Description
AddedMembers | Members
AddedUserProperties | UserProperties
ChangedRoleMembers | ChangedRoleMembers
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaRole configuration object.
DeletedRoleMembers | DeletedRoleMembers
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedMembers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.AddedMembers Property
CfgDeltaRole Class See Also Send Feedback
Members

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgRoleMember> AddedMembers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedMembers As ICollection(Of CfgRoleMember)
Visual C++
public:
property ICollection<CfgRoleMember^>^ AddedMembers {
    ICollection<CfgRoleMember^>^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.AddedUserProperties Property
CfgDeltaRole Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedRoleMembers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.ChangedRoleMembers Property
CfgDeltaRole Class See Also Send Feedback
ChangedRoleMembers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgRoleMember> ChangedRoleMembers { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedRoleMembers As ICollection(Of CfgRoleMember)
Visual C++
public:
property ICollection<CfgRoleMember^>^ ChangedRoleMembers {
    ICollection<CfgRoleMember^>^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.ChangedUserProperties Property
CfgDeltaRole Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.DBID Property
CfgDeltaRole Class See Also Send Feedback
The DBID of the CfgDeltaRole configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedRoleMembers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.DeletedRoleMembers Property
CfgDeltaRole Class See Also Send Feedback
DeletedRoleMembers

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgRoleMember> DeletedRoleMembers { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedRoleMembers As ICollection(Of CfgRoleMember)
Visual C++
public:
property ICollection<CfgRoleMember^>^ DeletedRoleMembers {
    ICollection<CfgRoleMember^>^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.DeletedUserProperties Property
CfgDeltaRole Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.Description Property
CfgDeltaRole Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.Name Property
CfgDeltaRole Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.State Property
CfgDeltaRole Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaRole..::.Tenant Property
CfgDeltaRole Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScheduledTask Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask Class
Members See Also Send Feedback
CfgDeltaScheduledTask

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaScheduledTask : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaScheduledTask _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaScheduledTask : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaScheduledTask

See Also

CfgDeltaScheduledTask Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScheduledTask Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask Members
CfgDeltaScheduledTask Class Methods Properties See Also Send Feedback

The CfgDeltaScheduledTask type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaScheduledTask configuration object.
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartTime | StartTime
State | State
Type | Type

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScheduledTask Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask Methods
CfgDeltaScheduledTask Class See Also Send Feedback

The CfgDeltaScheduledTask type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.SetAccountPermissions Method
CfgDeltaScheduledTask Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaScheduledTask Class
CfgDeltaScheduledTask Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScheduledTask Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask Properties
CfgDeltaScheduledTask Class See Also Send Feedback

The CfgDeltaScheduledTask type exposes the following members.

Properties

Name | Description
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaScheduledTask configuration object.
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartTime | StartTime
State | State
Type | Type

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.AddedResources Property
CfgDeltaScheduledTask Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.AddedUserProperties Property
CfgDeltaScheduledTask Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.ChangedResources Property
CfgDeltaScheduledTask Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.ChangedUserProperties Property
CfgDeltaScheduledTask Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.DBID Property
CfgDeltaScheduledTask Class See Also Send Feedback
The DBID of the CfgDeltaScheduledTask configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.DeletedResources Property
CfgDeltaScheduledTask Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.DeletedUserProperties Property
CfgDeltaScheduledTask Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.Description Property
CfgDeltaScheduledTask Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.Name Property
CfgDeltaScheduledTask Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.StartTime Property
CfgDeltaScheduledTask Class See Also Send Feedback
StartTime

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTime As Integer
Visual C++
public:
property int StartTime {
    int get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.State Property
CfgDeltaScheduledTask Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScheduledTask..::.Type Property
CfgDeltaScheduledTask Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTaskType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgTaskType
Visual C++
public:
property CfgTaskType Type {
    CfgTaskType get ();
}

See Also

CfgDeltaScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScript Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript Class
Members See Also Send Feedback
CfgDeltaScript

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaScript : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaScript _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaScript : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaScript

See Also

CfgDeltaScript Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScript Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript Members
CfgDeltaScript Class Methods Properties See Also Send Feedback

The CfgDeltaScript type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
ContactPerson | ContactPerson
DBID | The DBID of the CfgDeltaScript configuration object.
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Index | Index
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScript Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript Methods
CfgDeltaScript Class See Also Send Feedback

The CfgDeltaScript type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.SetAccountPermissions Method
CfgDeltaScript Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaScript Class
CfgDeltaScript Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaScript Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript Properties
CfgDeltaScript Class See Also Send Feedback

The CfgDeltaScript type exposes the following members.

Properties

Name | Description
AddedResources | Resources
AddedUserProperties | UserProperties
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
ContactPerson | ContactPerson
DBID | The DBID of the CfgDeltaScript configuration object.
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Index | Index
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.AddedResources Property
CfgDeltaScript Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.AddedUserProperties Property
CfgDeltaScript Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.ChangedResources Property
CfgDeltaScript Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.ChangedUserProperties Property
CfgDeltaScript Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ContactPerson Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.ContactPerson Property
CfgDeltaScript Class See Also Send Feedback
ContactPerson

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPerson ContactPerson { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContactPerson As CfgPerson
Visual C++
public:
property CfgPerson^ ContactPerson {
    CfgPerson^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.DBID Property
CfgDeltaScript Class See Also Send Feedback
The DBID of the CfgDeltaScript configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.DeletedResources Property
CfgDeltaScript Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.DeletedUserProperties Property
CfgDeltaScript Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Index Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.Index Property
CfgDeltaScript Class See Also Send Feedback
Index

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.Name Property
CfgDeltaScript Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.State Property
CfgDeltaScript Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.Tenant Property
CfgDeltaScript Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaScript..::.Type Property
CfgDeltaScript Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScriptType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgScriptType
Visual C++
public:
property CfgScriptType Type {
    CfgScriptType get ();
}

See Also

CfgDeltaScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaService Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService Class
Members See Also Send Feedback
CfgDeltaService

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaService : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaService _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaService : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaService

See Also

CfgDeltaService Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaService Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaService Members
CfgDeltaService Class Methods Properties See Also Send Feedback

The CfgDeltaService type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Abbr | Abbr
AddedAppServicePermissions | AppServicePermissions
AddedComponentDefinitions | ComponentDefinitions
AddedComponents | Components
AddedResources | Resources
AddedUserProperties | UserProperties
AssignedTenant | AssignedTenant
ChangedAppServicePermissions | ChangedAppServicePermissions
ChangedComponentDefinitions | ChangedComponentDefinitions
ChangedComponents | ChangedComponents
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaService configuration object.
DeletedAppServicePermissions | DeletedAppServicePermissions
DeletedComponentDefinitions | DeletedComponentDefinitions
DeletedComponents | DeletedComponents
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
SCS | SCS
SolutionType | SolutionType
StartupType | StartupType
State | State
Type | Type
Version | Version

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaService Methods
CfgDeltaService Class See Also Send Feedback

The CfgDeltaService type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.SetAccountPermissions Method
CfgDeltaService Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaService Class
CfgDeltaService Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaService Properties
CfgDeltaService Class See Also Send Feedback

The CfgDeltaService type exposes the following members.

Properties

Name | Description
Abbr | Abbr
AddedAppServicePermissions | AppServicePermissions
AddedComponentDefinitions | ComponentDefinitions
AddedComponents | Components
AddedResources | Resources
AddedUserProperties | UserProperties
AssignedTenant | AssignedTenant
ChangedAppServicePermissions | ChangedAppServicePermissions
ChangedComponentDefinitions | ChangedComponentDefinitions
ChangedComponents | ChangedComponents
ChangedResources | ChangedResources
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaService configuration object.
DeletedAppServicePermissions | DeletedAppServicePermissions
DeletedComponentDefinitions | DeletedComponentDefinitions
DeletedComponents | DeletedComponents
DeletedResources | DeletedResources
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
SCS | SCS
SolutionType | SolutionType
StartupType | StartupType
State | State
Type | Type
Version | Version

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Abbr Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.Abbr Property
CfgDeltaService Class See Also Send Feedback
Abbr

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Abbr { get; }
Visual Basic (Declaration)
Public ReadOnly Property Abbr As String
Visual C++
public:
property String^ Abbr {
    String^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedAppServicePermissions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.AddedAppServicePermissions Property
CfgDeltaService Class See Also Send Feedback
AppServicePermissions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppServicePermission> AddedAppServicePermissions { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedAppServicePermissions As ICollection(Of CfgAppServicePermission)
Visual C++
public:
property ICollection<CfgAppServicePermission^>^ AddedAppServicePermissions {
    ICollection<CfgAppServicePermission^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedComponentDefinitions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.AddedComponentDefinitions Property
CfgDeltaService Class See Also Send Feedback
ComponentDefinitions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponentDefinition> AddedComponentDefinitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedComponentDefinitions As ICollection(Of CfgSolutionComponentDefinition)
Visual C++
public:
property ICollection<CfgSolutionComponentDefinition^>^ AddedComponentDefinitions {
    ICollection<CfgSolutionComponentDefinition^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedComponents Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.AddedComponents Property
CfgDeltaService Class See Also Send Feedback
Components

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponent> AddedComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedComponents As ICollection(Of CfgSolutionComponent)
Visual C++
public:
property ICollection<CfgSolutionComponent^>^ AddedComponents {
    ICollection<CfgSolutionComponent^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.AddedResources Property
CfgDeltaService Class See Also Send Feedback
Resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> AddedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ AddedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.AddedUserProperties Property
CfgDeltaService Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AssignedTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.AssignedTenant Property
CfgDeltaService Class See Also Send Feedback
AssignedTenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant AssignedTenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedTenant As CfgTenant
Visual C++
public:
property CfgTenant^ AssignedTenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedAppServicePermissions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.ChangedAppServicePermissions Property
CfgDeltaService Class See Also Send Feedback
ChangedAppServicePermissions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppServicePermission> ChangedAppServicePermissions { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedAppServicePermissions As ICollection(Of CfgAppServicePermission)
Visual C++
public:
property ICollection<CfgAppServicePermission^>^ ChangedAppServicePermissions {
    ICollection<CfgAppServicePermission^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedComponentDefinitions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.ChangedComponentDefinitions Property
CfgDeltaService Class See Also Send Feedback
ChangedComponentDefinitions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponentDefinition> ChangedComponentDefinitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedComponentDefinitions As ICollection(Of CfgSolutionComponentDefinition)
Visual C++
public:
property ICollection<CfgSolutionComponentDefinition^>^ ChangedComponentDefinitions {
    ICollection<CfgSolutionComponentDefinition^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedComponents Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.ChangedComponents Property
CfgDeltaService Class See Also Send Feedback
ChangedComponents

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponent> ChangedComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedComponents As ICollection(Of CfgSolutionComponent)
Visual C++
public:
property ICollection<CfgSolutionComponent^>^ ChangedComponents {
    ICollection<CfgSolutionComponent^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.ChangedResources Property
CfgDeltaService Class See Also Send Feedback
ChangedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> ChangedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedResources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ ChangedResources {
    ICollection<CfgObjectResource^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.ChangedUserProperties Property
CfgDeltaService Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.DBID Property
CfgDeltaService Class See Also Send Feedback
The DBID of the CfgDeltaService configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedAppServicePermissions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.DeletedAppServicePermissions Property
CfgDeltaService Class See Also Send Feedback
DeletedAppServicePermissions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppServicePermission> DeletedAppServicePermissions { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedAppServicePermissions As ICollection(Of CfgAppServicePermission)
Visual C++
public:
property ICollection<CfgAppServicePermission^>^ DeletedAppServicePermissions {
    ICollection<CfgAppServicePermission^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedComponentDefinitions Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.DeletedComponentDefinitions Property
CfgDeltaService Class See Also Send Feedback
DeletedComponentDefinitions

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponentDefinition> DeletedComponentDefinitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedComponentDefinitions As ICollection(Of CfgSolutionComponentDefinition)
Visual C++
public:
property ICollection<CfgSolutionComponentDefinition^>^ DeletedComponentDefinitions {
    ICollection<CfgSolutionComponentDefinition^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedComponents Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.DeletedComponents Property
CfgDeltaService Class See Also Send Feedback
DeletedComponents

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponent> DeletedComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedComponents As ICollection(Of CfgSolutionComponent)
Visual C++
public:
property ICollection<CfgSolutionComponent^>^ DeletedComponents {
    ICollection<CfgSolutionComponent^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedResources Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.DeletedResources Property
CfgDeltaService Class See Also Send Feedback
DeletedResources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgResourceID> DeletedResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedResources As ICollection(Of CfgResourceID)
Visual C++
public:
property ICollection<CfgResourceID^>^ DeletedResources {
    ICollection<CfgResourceID^>^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.DeletedUserProperties Property
CfgDeltaService Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.Name Property
CfgDeltaService Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SCS Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.SCS Property
CfgDeltaService Class See Also Send Feedback
SCS

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication SCS { get; }
Visual Basic (Declaration)
Public ReadOnly Property SCS As CfgApplication
Visual C++
public:
property CfgApplication^ SCS {
    CfgApplication^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SolutionType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.SolutionType Property
CfgDeltaService Class See Also Send Feedback
SolutionType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionType SolutionType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SolutionType As CfgSolutionType
Visual C++
public:
property CfgSolutionType SolutionType {
    CfgSolutionType get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.StartupType Property
CfgDeltaService Class See Also Send Feedback
StartupType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStartupType StartupType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartupType As CfgStartupType
Visual C++
public:
property CfgStartupType StartupType {
    CfgStartupType get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.State Property
CfgDeltaService Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.Type Property
CfgDeltaService Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgChargeType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgChargeType
Visual C++
public:
property CfgChargeType Type {
    CfgChargeType get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaService..::.Version Property
CfgDeltaService Class See Also Send Feedback
Version

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

CfgDeltaService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSkill Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill Class
Members See Also Send Feedback
CfgDeltaSkill

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaSkill : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaSkill _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaSkill : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaSkill

See Also

CfgDeltaSkill Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSkill Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill Members
CfgDeltaSkill Class Methods Properties See Also Send Feedback

The CfgDeltaSkill type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaSkill configuration object.
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSkill Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill Methods
CfgDeltaSkill Class See Also Send Feedback

The CfgDeltaSkill type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.SetAccountPermissions Method
CfgDeltaSkill Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaSkill Class
CfgDeltaSkill Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSkill Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill Properties
CfgDeltaSkill Class See Also Send Feedback

The CfgDeltaSkill type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaSkill configuration object.
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.AddedUserProperties Property
CfgDeltaSkill Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.ChangedUserProperties Property
CfgDeltaSkill Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.DBID Property
CfgDeltaSkill Class See Also Send Feedback
The DBID of the CfgDeltaSkill configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.DeletedUserProperties Property
CfgDeltaSkill Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.Name Property
CfgDeltaSkill Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.State Property
CfgDeltaSkill Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSkill..::.Tenant Property
CfgDeltaSkill Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatDay Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay Class
Members See Also Send Feedback
CfgDeltaStatDay

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaStatDay : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaStatDay _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaStatDay : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaStatDay

See Also

CfgDeltaStatDay Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatDay Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay Members
CfgDeltaStatDay Class Methods Properties See Also Send Feedback

The CfgDeltaStatDay type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedStatIntervals | StatIntervals
AddedUserProperties | UserProperties
ChangedStatIntervals | ChangedStatIntervals
ChangedUserProperties | ChangedUserProperties
Date | Date
Day | Day
DBID | The DBID of the CfgDeltaStatDay configuration object.
DeletedStatIntervals | DeletedStatIntervals
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndTime | EndTime
FlatRate | FlatRate
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IntervalLength | IntervalLength
IsDayOfWeek | IsDayOfWeek
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MaxValue | MaxValue
MinValue | MinValue
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartTime | StartTime
State | State
TargetValue | TargetValue
Tenant | Tenant
Type | Type
UseFlatRate | UseFlatRate

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatDay Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay Methods
CfgDeltaStatDay Class See Also Send Feedback

The CfgDeltaStatDay type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.SetAccountPermissions Method
CfgDeltaStatDay Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaStatDay Class
CfgDeltaStatDay Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatDay Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay Properties
CfgDeltaStatDay Class See Also Send Feedback

The CfgDeltaStatDay type exposes the following members.

Properties

Name | Description
AddedStatIntervals | StatIntervals
AddedUserProperties | UserProperties
ChangedStatIntervals | ChangedStatIntervals
ChangedUserProperties | ChangedUserProperties
Date | Date
Day | Day
DBID | The DBID of the CfgDeltaStatDay configuration object.
DeletedStatIntervals | DeletedStatIntervals
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndTime | EndTime
FlatRate | FlatRate
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IntervalLength | IntervalLength
IsDayOfWeek | IsDayOfWeek
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MaxValue | MaxValue
MinValue | MinValue
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartTime | StartTime
State | State
TargetValue | TargetValue
Tenant | Tenant
Type | Type
UseFlatRate | UseFlatRate

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedStatIntervals Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.AddedStatIntervals Property
CfgDeltaStatDay Class See Also Send Feedback
StatIntervals

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatInterval> AddedStatIntervals { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedStatIntervals As ICollection(Of CfgStatInterval)
Visual C++
public:
property ICollection<CfgStatInterval^>^ AddedStatIntervals {
    ICollection<CfgStatInterval^>^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.AddedUserProperties Property
CfgDeltaStatDay Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedStatIntervals Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.ChangedStatIntervals Property
CfgDeltaStatDay Class See Also Send Feedback
ChangedStatIntervals

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatInterval> ChangedStatIntervals { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedStatIntervals As ICollection(Of CfgStatInterval)
Visual C++
public:
property ICollection<CfgStatInterval^>^ ChangedStatIntervals {
    ICollection<CfgStatInterval^>^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.ChangedUserProperties Property
CfgDeltaStatDay Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Date Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.Date Property
CfgDeltaStatDay Class See Also Send Feedback
Date

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime Date { get; }
Visual Basic (Declaration)
Public ReadOnly Property Date As DateTime
Visual C++
public:
property DateTime Date {
    DateTime get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Day Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.Day Property
CfgDeltaStatDay Class See Also Send Feedback
Day

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Day { get; }
Visual Basic (Declaration)
Public ReadOnly Property Day As Integer
Visual C++
public:
property int Day {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.DBID Property
CfgDeltaStatDay Class See Also Send Feedback
The DBID of the CfgDeltaStatDay configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedStatIntervals Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.DeletedStatIntervals Property
CfgDeltaStatDay Class See Also Send Feedback
DeletedStatIntervals

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatInterval> DeletedStatIntervals { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedStatIntervals As ICollection(Of CfgStatInterval)
Visual C++
public:
property ICollection<CfgStatInterval^>^ DeletedStatIntervals {
    ICollection<CfgStatInterval^>^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.DeletedUserProperties Property
CfgDeltaStatDay Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EndTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.EndTime Property
CfgDeltaStatDay Class See Also Send Feedback
EndTime

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int EndTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndTime As Integer
Visual C++
public:
property int EndTime {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.FlatRate Property
CfgDeltaStatDay Class See Also Send Feedback
FlatRate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FlatRate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FlatRate As Integer
Visual C++
public:
property int FlatRate {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IntervalLength Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.IntervalLength Property
CfgDeltaStatDay Class See Also Send Feedback
IntervalLength

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IntervalLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property IntervalLength As Integer
Visual C++
public:
property int IntervalLength {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsDayOfWeek Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.IsDayOfWeek Property
CfgDeltaStatDay Class See Also Send Feedback
IsDayOfWeek

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDayOfWeek { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDayOfWeek As CfgFlag
Visual C++
public:
property CfgFlag IsDayOfWeek {
    CfgFlag get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MaxValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.MaxValue Property
CfgDeltaStatDay Class See Also Send Feedback
MaxValue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxValue As Integer
Visual C++
public:
property int MaxValue {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MinValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.MinValue Property
CfgDeltaStatDay Class See Also Send Feedback
MinValue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinValue As Integer
Visual C++
public:
property int MinValue {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.Name Property
CfgDeltaStatDay Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.StartTime Property
CfgDeltaStatDay Class See Also Send Feedback
StartTime

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTime As Integer
Visual C++
public:
property int StartTime {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.State Property
CfgDeltaStatDay Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TargetValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.TargetValue Property
CfgDeltaStatDay Class See Also Send Feedback
TargetValue

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TargetValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property TargetValue As Integer
Visual C++
public:
property int TargetValue {
    int get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.Tenant Property
CfgDeltaStatDay Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.Type Property
CfgDeltaStatDay Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDayType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgStatDayType
Visual C++
public:
property CfgStatDayType Type {
    CfgStatDayType get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseFlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatDay..::.UseFlatRate Property
CfgDeltaStatDay Class See Also Send Feedback
UseFlatRate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseFlatRate { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseFlatRate As CfgFlag
Visual C++
public:
property CfgFlag UseFlatRate {
    CfgFlag get ();
}

See Also

CfgDeltaStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatTable Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable Class
Members See Also Send Feedback
CfgDeltaStatTable

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaStatTable : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaStatTable _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaStatTable : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaStatTable

See Also

CfgDeltaStatTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatTable Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable Members
CfgDeltaStatTable Class Methods Properties See Also Send Feedback

The CfgDeltaStatTable type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedStatDays | StatDays
AddedUserProperties | UserProperties
AgentHourlyRate | AgentHourlyRate
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaStatTable configuration object.
DeletedStatDays | DeletedStatDays
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FlatRate | FlatRate
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type
UseFlatRate | UseFlatRate
WaitThreshold | WaitThreshold

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatTable Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable Methods
CfgDeltaStatTable Class See Also Send Feedback

The CfgDeltaStatTable type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.SetAccountPermissions Method
CfgDeltaStatTable Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaStatTable Class
CfgDeltaStatTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaStatTable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable Properties
CfgDeltaStatTable Class See Also Send Feedback

The CfgDeltaStatTable type exposes the following members.

Properties

Name | Description
AddedStatDays | StatDays
AddedUserProperties | UserProperties
AgentHourlyRate | AgentHourlyRate
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaStatTable configuration object.
DeletedStatDays | DeletedStatDays
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FlatRate | FlatRate
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type
UseFlatRate | UseFlatRate
WaitThreshold | WaitThreshold

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedStatDays Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.AddedStatDays Property
CfgDeltaStatTable Class See Also Send Feedback
StatDays

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatDay> AddedStatDays { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedStatDays As ICollection(Of CfgStatDay)
Visual C++
public:
property ICollection<CfgStatDay^>^ AddedStatDays {
    ICollection<CfgStatDay^>^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.AddedUserProperties Property
CfgDeltaStatTable Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AgentHourlyRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.AgentHourlyRate Property
CfgDeltaStatTable Class See Also Send Feedback
AgentHourlyRate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AgentHourlyRate { get; }
Visual Basic (Declaration)
Public ReadOnly Property AgentHourlyRate As Integer
Visual C++
public:
property int AgentHourlyRate {
    int get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.ChangedUserProperties Property
CfgDeltaStatTable Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.DBID Property
CfgDeltaStatTable Class See Also Send Feedback
The DBID of the CfgDeltaStatTable configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedStatDays Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.DeletedStatDays Property
CfgDeltaStatTable Class See Also Send Feedback
DeletedStatDays

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatDay> DeletedStatDays { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedStatDays As ICollection(Of CfgStatDay)
Visual C++
public:
property ICollection<CfgStatDay^>^ DeletedStatDays {
    ICollection<CfgStatDay^>^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.DeletedUserProperties Property
CfgDeltaStatTable Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.FlatRate Property
CfgDeltaStatTable Class See Also Send Feedback
FlatRate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FlatRate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FlatRate As Integer
Visual C++
public:
property int FlatRate {
    int get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.Name Property
CfgDeltaStatTable Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.State Property
CfgDeltaStatTable Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.Tenant Property
CfgDeltaStatTable Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.Type Property
CfgDeltaStatTable Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTableType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgStatTableType
Visual C++
public:
property CfgStatTableType Type {
    CfgStatTableType get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseFlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.UseFlatRate Property
CfgDeltaStatTable Class See Also Send Feedback
UseFlatRate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseFlatRate { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseFlatRate As CfgFlag
Visual C++
public:
property CfgFlag UseFlatRate {
    CfgFlag get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


WaitThreshold Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaStatTable..::.WaitThreshold Property
CfgDeltaStatTable Class See Also Send Feedback
WaitThreshold

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int WaitThreshold { get; }
Visual Basic (Declaration)
Public ReadOnly Property WaitThreshold As Integer
Visual C++
public:
property int WaitThreshold {
    int get ();
}

See Also

CfgDeltaStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSwitch Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch Class
Members See Also Send Feedback
CfgDeltaSwitch

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaSwitch : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaSwitch _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaSwitch : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaSwitch

See Also

CfgDeltaSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSwitch Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch Members
CfgDeltaSwitch Class Methods Properties See Also Send Feedback

The CfgDeltaSwitch type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedSwitchAccessCodes | SwitchAccessCodes
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaSwitch configuration object.
DeletedSwitchAccessCodes | DeletedSwitchAccessCodes
DeletedUserProperties | DeletedUserProperties
DNRange | DNRange
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LinkType | LinkType
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PhysSwitch | PhysSwitch
State | State
Tenant | Tenant
TServer | TServer
Type | Type

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSwitch Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch Methods
CfgDeltaSwitch Class See Also Send Feedback

The CfgDeltaSwitch type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.SetAccountPermissions Method
CfgDeltaSwitch Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaSwitch Class
CfgDeltaSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaSwitch Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch Properties
CfgDeltaSwitch Class See Also Send Feedback

The CfgDeltaSwitch type exposes the following members.

Properties

Name | Description
AddedSwitchAccessCodes | SwitchAccessCodes
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaSwitch configuration object.
DeletedSwitchAccessCodes | DeletedSwitchAccessCodes
DeletedUserProperties | DeletedUserProperties
DNRange | DNRange
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LinkType | LinkType
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PhysSwitch | PhysSwitch
State | State
Tenant | Tenant
TServer | TServer
Type | Type

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedSwitchAccessCodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.AddedSwitchAccessCodes Property
CfgDeltaSwitch Class See Also Send Feedback
SwitchAccessCodes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSwitchAccessCode> AddedSwitchAccessCodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedSwitchAccessCodes As ICollection(Of CfgSwitchAccessCode)
Visual C++
public:
property ICollection<CfgSwitchAccessCode^>^ AddedSwitchAccessCodes {
    ICollection<CfgSwitchAccessCode^>^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.AddedUserProperties Property
CfgDeltaSwitch Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.ChangedUserProperties Property
CfgDeltaSwitch Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.DBID Property
CfgDeltaSwitch Class See Also Send Feedback
The DBID of the CfgDeltaSwitch configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedSwitchAccessCodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.DeletedSwitchAccessCodes Property
CfgDeltaSwitch Class See Also Send Feedback
DeletedSwitchAccessCodes

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSwitchAccessCode> DeletedSwitchAccessCodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedSwitchAccessCodes As ICollection(Of CfgSwitchAccessCode)
Visual C++
public:
property ICollection<CfgSwitchAccessCode^>^ DeletedSwitchAccessCodes {
    ICollection<CfgSwitchAccessCode^>^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.DeletedUserProperties Property
CfgDeltaSwitch Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DNRange Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.DNRange Property
CfgDeltaSwitch Class See Also Send Feedback
DNRange

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DNRange { get; }
Visual Basic (Declaration)
Public ReadOnly Property DNRange As String
Visual C++
public:
property String^ DNRange {
    String^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LinkType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.LinkType Property
CfgDeltaSwitch Class See Also Send Feedback
LinkType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgLinkType LinkType { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkType As CfgLinkType
Visual C++
public:
property CfgLinkType LinkType {
    CfgLinkType get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.Name Property
CfgDeltaSwitch Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PhysSwitch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.PhysSwitch Property
CfgDeltaSwitch Class See Also Send Feedback
PhysSwitch

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhysicalSwitch PhysSwitch { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhysSwitch As CfgPhysicalSwitch
Visual C++
public:
property CfgPhysicalSwitch^ PhysSwitch {
    CfgPhysicalSwitch^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.State Property
CfgDeltaSwitch Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.Tenant Property
CfgDeltaSwitch Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.TServer Property
CfgDeltaSwitch Class See Also Send Feedback
TServer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication TServer { get; }
Visual Basic (Declaration)
Public ReadOnly Property TServer As CfgApplication
Visual C++
public:
property CfgApplication^ TServer {
    CfgApplication^ get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaSwitch..::.Type Property
CfgDeltaSwitch Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgSwitchType
Visual C++
public:
property CfgSwitchType Type {
    CfgSwitchType get ();
}

See Also

CfgDeltaSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTableAccess Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess Class
Members See Also Send Feedback
CfgDeltaTableAccess

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaTableAccess : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaTableAccess _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaTableAccess : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTableAccess

See Also

CfgDeltaTableAccess Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTableAccess Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess Members
CfgDeltaTableAccess Class Methods Properties See Also Send Feedback

The CfgDeltaTableAccess type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DbAccess | DbAccess
DBID | The DBID of the CfgDeltaTableAccess configuration object.
DbTableName | DbTableName
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | Format
IsCachable | IsCachable
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type
UpdateTimeout | UpdateTimeout

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTableAccess Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess Methods
CfgDeltaTableAccess Class See Also Send Feedback

The CfgDeltaTableAccess type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.SetAccountPermissions Method
CfgDeltaTableAccess Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaTableAccess Class
CfgDeltaTableAccess Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTableAccess Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess Properties
CfgDeltaTableAccess Class See Also Send Feedback

The CfgDeltaTableAccess type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DbAccess | DbAccess
DBID | The DBID of the CfgDeltaTableAccess configuration object.
DbTableName | DbTableName
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | Format
IsCachable | IsCachable
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant
Type | Type
UpdateTimeout | UpdateTimeout

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.AddedUserProperties Property
CfgDeltaTableAccess Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.ChangedUserProperties Property
CfgDeltaTableAccess Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DbAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.DbAccess Property
CfgDeltaTableAccess Class See Also Send Feedback
DbAccess

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication DbAccess { get; }
Visual Basic (Declaration)
Public ReadOnly Property DbAccess As CfgApplication
Visual C++
public:
property CfgApplication^ DbAccess {
    CfgApplication^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.DBID Property
CfgDeltaTableAccess Class See Also Send Feedback
The DBID of the CfgDeltaTableAccess configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DbTableName Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.DbTableName Property
CfgDeltaTableAccess Class See Also Send Feedback
DbTableName

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DbTableName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DbTableName As String
Visual C++
public:
property String^ DbTableName {
    String^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.DeletedUserProperties Property
CfgDeltaTableAccess Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.Description Property
CfgDeltaTableAccess Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Format Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.Format Property
CfgDeltaTableAccess Class See Also Send Feedback
Format

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As CfgFormat
Visual C++
public:
property CfgFormat^ Format {
    CfgFormat^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsCachable Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.IsCachable Property
CfgDeltaTableAccess Class See Also Send Feedback
IsCachable

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsCachable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCachable As CfgFlag
Visual C++
public:
property CfgFlag IsCachable {
    CfgFlag get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.Name Property
CfgDeltaTableAccess Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.State Property
CfgDeltaTableAccess Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.Tenant Property
CfgDeltaTableAccess Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.Type Property
CfgDeltaTableAccess Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgTableType
Visual C++
public:
property CfgTableType Type {
    CfgTableType get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UpdateTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTableAccess..::.UpdateTimeout Property
CfgDeltaTableAccess Class See Also Send Feedback
UpdateTimeout

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int UpdateTimeout { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpdateTimeout As Integer
Visual C++
public:
property int UpdateTimeout {
    int get ();
}

See Also

CfgDeltaTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTenant Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant Class
Members See Also Send Feedback
CfgDeltaTenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaTenant : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaTenant _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaTenant : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTenant

See Also

CfgDeltaTenant Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTenant Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant Members
CfgDeltaTenant Class Methods Properties See Also Send Feedback

The CfgDeltaTenant type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedServiceInfo | ServiceInfo
AddedTenants | Tenants
AddedUserProperties | UserProperties
Address | Address
ChangedServiceInfo | ChangedServiceInfo
ChangedUserProperties | ChangedUserProperties
ChargeableNumber | ChargeableNumber
DBID | The DBID of the CfgDeltaTenant configuration object.
DefaultCapacityRule | DefaultCapacityRule
DefaultContract | DefaultContract
DeletedServices | DeletedServices
DeletedTenants | DeletedTenants
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsServiceProvider | IsServiceProvider
IsSuperTenant | IsSuperTenant
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentTenant | ParentTenant
Password | Password
ProviderPerson | ProviderPerson
State | State
TenantPerson | TenantPerson

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTenant Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant Methods
CfgDeltaTenant Class See Also Send Feedback

The CfgDeltaTenant type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.SetAccountPermissions Method
CfgDeltaTenant Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaTenant Class
CfgDeltaTenant Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTenant Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant Properties
CfgDeltaTenant Class See Also Send Feedback

The CfgDeltaTenant type exposes the following members.

Properties

Name | Description
AddedServiceInfo | ServiceInfo
AddedTenants | Tenants
AddedUserProperties | UserProperties
Address | Address
ChangedServiceInfo | ChangedServiceInfo
ChangedUserProperties | ChangedUserProperties
ChargeableNumber | ChargeableNumber
DBID | The DBID of the CfgDeltaTenant configuration object.
DefaultCapacityRule | DefaultCapacityRule
DefaultContract | DefaultContract
DeletedServices | DeletedServices
DeletedTenants | DeletedTenants
DeletedUserProperties | DeletedUserProperties
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsServiceProvider | IsServiceProvider
IsSuperTenant | IsSuperTenant
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentTenant | ParentTenant
Password | Password
ProviderPerson | ProviderPerson
State | State
TenantPerson | TenantPerson

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedServiceInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.AddedServiceInfo Property
CfgDeltaTenant Class See Also Send Feedback
ServiceInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgServiceInfo> AddedServiceInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedServiceInfo As ICollection(Of CfgServiceInfo)
Visual C++
public:
property ICollection<CfgServiceInfo^>^ AddedServiceInfo {
    ICollection<CfgServiceInfo^>^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.AddedTenants Property
CfgDeltaTenant Class See Also Send Feedback
Tenants

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> AddedTenants { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedTenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ AddedTenants {
    ICollection<CfgTenant^>^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.AddedUserProperties Property
CfgDeltaTenant Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.Address Property
CfgDeltaTenant Class See Also Send Feedback
Address

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedServiceInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.ChangedServiceInfo Property
CfgDeltaTenant Class See Also Send Feedback
ChangedServiceInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgServiceInfo> ChangedServiceInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedServiceInfo As ICollection(Of CfgServiceInfo)
Visual C++
public:
property ICollection<CfgServiceInfo^>^ ChangedServiceInfo {
    ICollection<CfgServiceInfo^>^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.ChangedUserProperties Property
CfgDeltaTenant Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChargeableNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.ChargeableNumber Property
CfgDeltaTenant Class See Also Send Feedback
ChargeableNumber

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ChargeableNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChargeableNumber As String
Visual C++
public:
property String^ ChargeableNumber {
    String^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.DBID Property
CfgDeltaTenant Class See Also Send Feedback
The DBID of the CfgDeltaTenant configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DefaultCapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.DefaultCapacityRule Property
CfgDeltaTenant Class See Also Send Feedback
DefaultCapacityRule

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript DefaultCapacityRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultCapacityRule As CfgScript
Visual C++
public:
property CfgScript^ DefaultCapacityRule {
    CfgScript^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DefaultContract Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.DefaultContract Property
CfgDeltaTenant Class See Also Send Feedback
DefaultContract

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable DefaultContract { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultContract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ DefaultContract {
    CfgObjectiveTable^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedServices Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.DeletedServices Property
CfgDeltaTenant Class See Also Send Feedback
DeletedServices

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgServiceInfo> DeletedServices { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedServices As ICollection(Of CfgServiceInfo)
Visual C++
public:
property ICollection<CfgServiceInfo^>^ DeletedServices {
    ICollection<CfgServiceInfo^>^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.DeletedTenants Property
CfgDeltaTenant Class See Also Send Feedback
DeletedTenants

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgTenant> DeletedTenants { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedTenants As ICollection(Of CfgTenant)
Visual C++
public:
property ICollection<CfgTenant^>^ DeletedTenants {
    ICollection<CfgTenant^>^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.DeletedUserProperties Property
CfgDeltaTenant Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsServiceProvider Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.IsServiceProvider Property
CfgDeltaTenant Class See Also Send Feedback
IsServiceProvider

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsServiceProvider { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsServiceProvider As CfgFlag
Visual C++
public:
property CfgFlag IsServiceProvider {
    CfgFlag get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsSuperTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.IsSuperTenant Property
CfgDeltaTenant Class See Also Send Feedback
IsSuperTenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsSuperTenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSuperTenant As CfgFlag
Visual C++
public:
property CfgFlag IsSuperTenant {
    CfgFlag get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.Name Property
CfgDeltaTenant Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ParentTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.ParentTenant Property
CfgDeltaTenant Class See Also Send Feedback
ParentTenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant ParentTenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentTenant As CfgTenant
Visual C++
public:
property CfgTenant^ ParentTenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.Password Property
CfgDeltaTenant Class See Also Send Feedback
Password

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; }
Visual Basic (Declaration)
Public ReadOnly Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ProviderPerson Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.ProviderPerson Property
CfgDeltaTenant Class See Also Send Feedback
ProviderPerson

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPerson ProviderPerson { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProviderPerson As CfgPerson
Visual C++
public:
property CfgPerson^ ProviderPerson {
    CfgPerson^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.State Property
CfgDeltaTenant Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TenantPerson Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTenant..::.TenantPerson Property
CfgDeltaTenant Class See Also Send Feedback
TenantPerson

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPerson TenantPerson { get; }
Visual Basic (Declaration)
Public ReadOnly Property TenantPerson As CfgPerson
Visual C++
public:
property CfgPerson^ TenantPerson {
    CfgPerson^ get ();
}

See Also

CfgDeltaTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTimeZone Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone Class
Members See Also Send Feedback
CfgDeltaTimeZone

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaTimeZone : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaTimeZone _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaTimeZone : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTimeZone

See Also

CfgDeltaTimeZone Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTimeZone Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone Members
CfgDeltaTimeZone Class Methods Properties See Also Send Feedback

The CfgDeltaTimeZone type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaTimeZone configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DSTOffset | DSTOffset
DSTStartDate | DSTStartDate
DSTStopDate | DSTStopDate
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDSTObserved | IsDSTObserved
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
NameMSExplorer | NameMSExplorer
NameNetscape | NameNetscape
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Offset | Offset
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTimeZone Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone Methods
CfgDeltaTimeZone Class See Also Send Feedback

The CfgDeltaTimeZone type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.SetAccountPermissions Method
CfgDeltaTimeZone Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaTimeZone Class
CfgDeltaTimeZone Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTimeZone Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone Properties
CfgDeltaTimeZone Class See Also Send Feedback

The CfgDeltaTimeZone type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaTimeZone configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DSTOffset | DSTOffset
DSTStartDate | DSTStartDate
DSTStopDate | DSTStopDate
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDSTObserved | IsDSTObserved
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
NameMSExplorer | NameMSExplorer
NameNetscape | NameNetscape
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Offset | Offset
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | State
Tenant | Tenant

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.AddedUserProperties Property
CfgDeltaTimeZone Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.ChangedUserProperties Property
CfgDeltaTimeZone Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.DBID Property
CfgDeltaTimeZone Class See Also Send Feedback
The DBID of the CfgDeltaTimeZone configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.DeletedUserProperties Property
CfgDeltaTimeZone Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.Description Property
CfgDeltaTimeZone Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DSTOffset Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.DSTOffset Property
CfgDeltaTimeZone Class See Also Send Feedback
DSTOffset

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DSTOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property DSTOffset As Integer
Visual C++
public:
property int DSTOffset {
    int get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DSTStartDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.DSTStartDate Property
CfgDeltaTimeZone Class See Also Send Feedback
DSTStartDate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DSTStartDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property DSTStartDate As DateTime
Visual C++
public:
property DateTime DSTStartDate {
    DateTime get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DSTStopDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.DSTStopDate Property
CfgDeltaTimeZone Class See Also Send Feedback
DSTStopDate

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DSTStopDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property DSTStopDate As DateTime
Visual C++
public:
property DateTime DSTStopDate {
    DateTime get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsDSTObserved Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.IsDSTObserved Property
CfgDeltaTimeZone Class See Also Send Feedback
IsDSTObserved

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDSTObserved { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDSTObserved As CfgFlag
Visual C++
public:
property CfgFlag IsDSTObserved {
    CfgFlag get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.Name Property
CfgDeltaTimeZone Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NameMSExplorer Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.NameMSExplorer Property
CfgDeltaTimeZone Class See Also Send Feedback
NameMSExplorer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameMSExplorer { get; }
Visual Basic (Declaration)
Public ReadOnly Property NameMSExplorer As String
Visual C++
public:
property String^ NameMSExplorer {
    String^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NameNetscape Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.NameNetscape Property
CfgDeltaTimeZone Class See Also Send Feedback
NameNetscape

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameNetscape { get; }
Visual Basic (Declaration)
Public ReadOnly Property NameNetscape As String
Visual C++
public:
property String^ NameNetscape {
    String^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Offset Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.Offset Property
CfgDeltaTimeZone Class See Also Send Feedback
Offset

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Offset { get; }
Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
Visual C++
public:
property int Offset {
    int get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.State Property
CfgDeltaTimeZone Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTimeZone..::.Tenant Property
CfgDeltaTimeZone Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTransaction Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction Class
Members See Also Send Feedback
CfgDeltaTransaction

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaTransaction : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaTransaction _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaTransaction : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTransaction

See Also

CfgDeltaTransaction Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTransaction Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction Members
CfgDeltaTransaction Class Methods Properties See Also Send Feedback

The CfgDeltaTransaction type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
Alias | Alias
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaTransaction configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RecordPeriod | RecordPeriod
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTransaction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction Methods
CfgDeltaTransaction Class See Also Send Feedback

The CfgDeltaTransaction type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.SetAccountPermissions Method
CfgDeltaTransaction Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaTransaction Class
CfgDeltaTransaction Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTransaction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction Properties
CfgDeltaTransaction Class See Also Send Feedback

The CfgDeltaTransaction type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
Alias | Alias
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaTransaction configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RecordPeriod | RecordPeriod
State | State
Tenant | Tenant
Type | Type

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.AddedUserProperties Property
CfgDeltaTransaction Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Alias Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.Alias Property
CfgDeltaTransaction Class See Also Send Feedback
Alias

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Alias { get; }
Visual Basic (Declaration)
Public ReadOnly Property Alias As String
Visual C++
public:
property String^ Alias {
    String^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.ChangedUserProperties Property
CfgDeltaTransaction Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.DBID Property
CfgDeltaTransaction Class See Also Send Feedback
The DBID of the CfgDeltaTransaction configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.DeletedUserProperties Property
CfgDeltaTransaction Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.Description Property
CfgDeltaTransaction Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.Name Property
CfgDeltaTransaction Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RecordPeriod Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.RecordPeriod Property
CfgDeltaTransaction Class See Also Send Feedback
RecordPeriod

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int RecordPeriod { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordPeriod As Integer
Visual C++
public:
property int RecordPeriod {
    int get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.State Property
CfgDeltaTransaction Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.Tenant Property
CfgDeltaTransaction Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTransaction..::.Type Property
CfgDeltaTransaction Class See Also Send Feedback
Type

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransactionType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgTransactionType
Visual C++
public:
property CfgTransactionType Type {
    CfgTransactionType get ();
}

See Also

CfgDeltaTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTreatment Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment Class
Members See Also Send Feedback
CfgDeltaTreatment

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaTreatment : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaTreatment _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaTreatment : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaTreatment

See Also

CfgDeltaTreatment Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTreatment Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment Members
CfgDeltaTreatment Class Methods Properties See Also Send Feedback

The CfgDeltaTreatment type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
Attempts | Attempts
CallActionCode | CallActionCode
CallResult | CallResult
ChangedUserProperties | ChangedUserProperties
CycleAttempt | CycleAttempt
DateTime | DateTime
DBID | The DBID of the CfgDeltaTreatment configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DestDN | DestDN
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Increment | Increment
Interval | Interval
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Range | Range
RecActionCode | RecActionCode
State | State
Tenant | Tenant

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTreatment Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment Methods
CfgDeltaTreatment Class See Also Send Feedback

The CfgDeltaTreatment type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.SetAccountPermissions Method
CfgDeltaTreatment Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaTreatment Class
CfgDeltaTreatment Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaTreatment Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment Properties
CfgDeltaTreatment Class See Also Send Feedback

The CfgDeltaTreatment type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
Attempts | Attempts
CallActionCode | CallActionCode
CallResult | CallResult
ChangedUserProperties | ChangedUserProperties
CycleAttempt | CycleAttempt
DateTime | DateTime
DBID | The DBID of the CfgDeltaTreatment configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
DestDN | DestDN
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Increment | Increment
Interval | Interval
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Range | Range
RecActionCode | RecActionCode
State | State
Tenant | Tenant

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.AddedUserProperties Property
CfgDeltaTreatment Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Attempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Attempts Property
CfgDeltaTreatment Class See Also Send Feedback
Attempts

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Attempts { get; }
Visual Basic (Declaration)
Public ReadOnly Property Attempts As Integer
Visual C++
public:
property int Attempts {
    int get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CallActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.CallActionCode Property
CfgDeltaTreatment Class See Also Send Feedback
CallActionCode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallActionCode CallActionCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property CallActionCode As CfgCallActionCode
Visual C++
public:
property CfgCallActionCode CallActionCode {
    CfgCallActionCode get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CallResult Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.CallResult Property
CfgDeltaTreatment Class See Also Send Feedback
CallResult

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public GctiCallState CallResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property CallResult As GctiCallState
Visual C++
public:
property GctiCallState CallResult {
    GctiCallState get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.ChangedUserProperties Property
CfgDeltaTreatment Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CycleAttempt Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.CycleAttempt Property
CfgDeltaTreatment Class See Also Send Feedback
CycleAttempt

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CycleAttempt { get; }
Visual Basic (Declaration)
Public ReadOnly Property CycleAttempt As Integer
Visual C++
public:
property int CycleAttempt {
    int get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DateTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.DateTime Property
CfgDeltaTreatment Class See Also Send Feedback
DateTime

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DateTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateTime As DateTime
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.DBID Property
CfgDeltaTreatment Class See Also Send Feedback
The DBID of the CfgDeltaTreatment configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.DeletedUserProperties Property
CfgDeltaTreatment Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Description Property
CfgDeltaTreatment Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DestDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.DestDN Property
CfgDeltaTreatment Class See Also Send Feedback
DestDN

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN DestDN { get; }
Visual Basic (Declaration)
Public ReadOnly Property DestDN As CfgDN
Visual C++
public:
property CfgDN^ DestDN {
    CfgDN^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Increment Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Increment Property
CfgDeltaTreatment Class See Also Send Feedback
Increment

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Increment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Increment As Integer
Visual C++
public:
property int Increment {
    int get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Interval Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Interval Property
CfgDeltaTreatment Class See Also Send Feedback
Interval

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Interval { get; }
Visual Basic (Declaration)
Public ReadOnly Property Interval As Integer
Visual C++
public:
property int Interval {
    int get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Name Property
CfgDeltaTreatment Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Range Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Range Property
CfgDeltaTreatment Class See Also Send Feedback
Range

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Range { get; }
Visual Basic (Declaration)
Public ReadOnly Property Range As Integer
Visual C++
public:
property int Range {
    int get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RecActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.RecActionCode Property
CfgDeltaTreatment Class See Also Send Feedback
RecActionCode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRecActionCode RecActionCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecActionCode As CfgRecActionCode
Visual C++
public:
property CfgRecActionCode RecActionCode {
    CfgRecActionCode get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.State Property
CfgDeltaTreatment Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaTreatment..::.Tenant Property
CfgDeltaTreatment Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaVoicePrompt Class

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt Class
Members See Also Send Feedback
CfgDeltaVoicePrompt

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDeltaVoicePrompt : CfgDelta
Visual Basic (Declaration)
Public Class CfgDeltaVoicePrompt _
    Inherits CfgDelta
Visual C++
public ref class CfgDeltaVoicePrompt : public CfgDelta

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgDelta
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDeltaVoicePrompt

See Also

CfgDeltaVoicePrompt Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaVoicePrompt Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt Members
CfgDeltaVoicePrompt Class Methods Properties See Also Send Feedback

The CfgDeltaVoicePrompt type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaVoicePrompt configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
Switch | Switch
Tenant | Tenant

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaVoicePrompt Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt Methods
CfgDeltaVoicePrompt Class See Also Send Feedback

The CfgDeltaVoicePrompt type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in a class with Configuration Server. Internally generates the correct delta object and sends it to Configuration Server.
(Inherited from CfgObject.)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
This method returns a copy of the object's internally stored XML representation.
(Inherited from CfgDelta.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.SetAccountPermissions Method
CfgDeltaVoicePrompt Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDeltaVoicePrompt Class
CfgDeltaVoicePrompt Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDeltaVoicePrompt Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt Properties
CfgDeltaVoicePrompt Class See Also Send Feedback

The CfgDeltaVoicePrompt type exposes the following members.

Properties

Name | Description
AddedUserProperties | UserProperties
ChangedUserProperties | ChangedUserProperties
DBID | The DBID of the CfgDeltaVoicePrompt configuration object.
DeletedUserProperties | DeletedUserProperties
Description | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | Name
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | Script
State | State
Switch | Switch
Tenant | Tenant

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AddedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.AddedUserProperties Property
CfgDeltaVoicePrompt Class See Also Send Feedback
UserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection AddedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ AddedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChangedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.ChangedUserProperties Property
CfgDeltaVoicePrompt Class See Also Send Feedback
ChangedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection ChangedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChangedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ ChangedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.DBID Property
CfgDeltaVoicePrompt Class See Also Send Feedback
The DBID of the CfgDeltaVoicePrompt configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DeletedUserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.DeletedUserProperties Property
CfgDeltaVoicePrompt Class See Also Send Feedback
DeletedUserProperties

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection DeletedUserProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeletedUserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ DeletedUserProperties {
    KeyValueCollection^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.Description Property
CfgDeltaVoicePrompt Class See Also Send Feedback
Description

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.Name Property
CfgDeltaVoicePrompt Class See Also Send Feedback
Name

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.Script Property
CfgDeltaVoicePrompt Class See Also Send Feedback
Script

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; }
Visual Basic (Declaration)
Public ReadOnly Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.State Property
CfgDeltaVoicePrompt Class See Also Send Feedback
State

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; }
Visual Basic (Declaration)
Public ReadOnly Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.Switch Property
CfgDeltaVoicePrompt Class See Also Send Feedback
Switch

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDeltaVoicePrompt..::.Tenant Property
CfgDeltaVoicePrompt Class See Also Send Feedback
Tenant

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgDeltaVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDetectEvent Class

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent Class
Members See Also Send Feedback
CfgDetectEvent

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDetectEvent : CfgStructure
Visual Basic (Declaration)
Public Class CfgDetectEvent _
    Inherits CfgStructure
Visual C++
public ref class CfgDetectEvent : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDetectEvent

See Also

CfgDetectEvent Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDetectEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent Members
CfgDetectEvent Class Constructors Methods Properties See Also Send Feedback

The CfgDetectEvent type exposes the following members.

Constructors

Name | Description
CfgDetectEvent | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAppDBID | SetAppDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
App |
AppType |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LogEventID |
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
SelectionMode |

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDetectEvent Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent Constructor
CfgDetectEvent Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDetectEvent(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgDetectEvent(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDetectEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent Methods
CfgDetectEvent Class See Also Send Feedback

The CfgDetectEvent type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAppDBID | SetAppDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAppDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent..::.SetAppDBID Method
CfgDetectEvent Class See Also Send Feedback
SetAppDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAppDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAppDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAppDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.SetAppDBID(System.Int32)"]

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDetectEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent Properties
CfgDetectEvent Class See Also Send Feedback

The CfgDetectEvent type exposes the following members.

Properties

Name | Description
App |
AppType |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LogEventID |
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
SelectionMode |

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


App Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent..::.App Property
CfgDetectEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.App"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication App { get; set; }
Visual Basic (Declaration)
Public Property App As CfgApplication
Visual C++
public:
property CfgApplication^ App {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent..::.AppType Property
CfgDetectEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.AppType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As CfgAppType
Visual C++
public:
property CfgAppType AppType {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LogEventID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent..::.LogEventID Property
CfgDetectEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.LogEventID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LogEventID { get; set; }
Visual Basic (Declaration)
Public Property LogEventID As Integer
Visual C++
public:
property int LogEventID {
    int get ();
    void set (int value);
}

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SelectionMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEvent..::.SelectionMode Property
CfgDetectEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDetectEvent.SelectionMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As CfgSelectionMode
Visual C++
public:
property CfgSelectionMode SelectionMode {
    CfgSelectionMode get ();
    void set (CfgSelectionMode value);
}

See Also

CfgDetectEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDN Class

[image]

Enterprise SDK 8.0 Reference API
CfgDN Class
Members See Also Send Feedback
A DN is a communication device that is uniquely identified by a directory number, where customer interactions (for example, telephone calls or e-mails) reside and are handled.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDN : CfgObject
Visual Basic (Declaration)
Public Class CfgDN _
    Inherits CfgObject
Visual C++
public ref class CfgDN : public CfgObject

Remarks

Deletion of DN X will cause the following events set out in the order of arrival: Modification of DNDBIDs of the place that had DN X assigned Modification of destDNDBIDs of all DNs whose destination DNs included DN X Modification of routeDNDBIDs of all agent groups whose route DNs included DN X Modification of routeDNDBIDs of all place groups whose route DNs included DN X Modification of DNs of all DN groups whose DNs included DN X Modification of routeDNDBIDs of all DN groups whose route DNs included DN X Modification of CfgTreatment objects which had destDNDBID field set to DN X Modification of CfgIVRPort objects which had DNDBID field set to DN X Modification of CfgCampaignGroup which had origDNDBID field set to DN X Deletion of DN X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDN

See Also

CfgDN Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDN Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDN Members
CfgDN Class Constructors Methods Properties See Also Send Feedback

The CfgDN type exposes the following members.

Constructors

Name | Description
CfgDN | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetContractDBID
SetContractDBID
SetGroupDBID
SetGroupDBID
SetSiteDBID
SetSiteDBID
SetSwitchDBID
SetSwitchDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AccessNumbers | A pointer to the list of structures that specify the numbers to be dialed from different switches to get this DN. Makes sense only if type is set to CFGExtRoutingPoint and CFGAccessResource. See CfgDNAccessNumber .
Association | A pointer to the identifier of an entity permanently associated with this DN (e.g., an IVR port number, channel name, or access number).
Contract | A unique identifier of Cost Contract (CfgObjectiveTable) with which this DN is associated.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DestDNs | A pointer to the list of identifiers of the objects (DBIDs) to which the calls residing at this DN can be routed/diverted by default. Makes sense only if type is set to CFGRoutingPoint, CFGExtRoutingPoint, CFGServiceNumber, CFGRoutingQueue, CFGACDQueue, CFGVirtACDQueue, or CFGVirtRoutingPoint, and CFGAccessResource and shall be set to NULL for all other values of type. When used as an entry in CfgDeltaDN (see below), it is a pointer to a list of identifiers of the objects added to the existing list. The DN for which this list is specified cannot be added to this list. If DN type is CFGAccessResource the property must be presented on GUI (Config Manager) with caption _Remote Resources_.
DNLoginID | A pointer to the login identifier used to activate this DN. Makes sense only if type is set to CFGACDPosition, CFGExtension, CFGEAPort, CFGVoiceMail, or CFGMixed. For type CFGAccessResource specifies the type of the resource and must be presented on GIU(Configuration Manager) with caption _Resource Type_
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Group | A unique identifier of the DN Group used in number translation.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginFlag | An indicator of whether a login procedure is necessary to activate the telephony object associated with this DN. Read-only (set automatically according to the current value of DNLoginID below). See CfgFlag. The value should not be taken into consideration if DN type is CFGAccessResource.
Name | Name of this DN required if the DN is planned to be used as a target in routing strategies. If specified, must be unique within the tenant this DN belongs to. It is strongly recommended to give names to DNs of the following types: CFGACDQueue, CFGRoutingPoint, CFGVirtualACDQueue, CFGVirtualRoutingPoint, and CFGRoutingQueue.
Number | Directory number assigned to this DN within the switch. Mandatory. Must be unique within the switch for all dn types except CFGDestinationLabel and CFGAccessResource. The uniqueness of CFGAccessResource is defined by combination of number and DN type. Once specified, cannot be changed. Please see the comment regarding the parameter DNRange in CfgSwitch .
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | The number used as a substitute of a regular directory number in certain types of routing.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RegisterAll | An indicator of whether T-Server shall register this DN within the switch. Recommended to be set to CFGDRTrue by default. See CfgDNRegisterFlag .
RouteType | Type of routing that applies to this DN. See type CfgRouteType .
Site | A unique identifier of Site (CfgFolder) with which this DN is associated.
State | Current object state. Mandatory. Refer to CfgObjectState
Switch | A unique identifier of the Switch to which this DN belongs. Mandatory. Once specified, cannot be changed.
SwitchSpecificType | An integer that corresponds to a combination of switch-specific settings for this DN. Cannot be set to a zero or negative value.
Tenant | A unique identifier of the Tenant to which this DN belongs. Read-only (set automatically according to the current value of tenantDBID of the switch specified in switchDBID). See CfgSwitch .
Trunks | Number of trunks associated with this DN. Makes sense only if type is set to CFGDestinationLabel.
Type | Type of this DN. See CfgDNType . Mandatory. Once specified, cannot be changed.
UseOverride | An indicator of whether the override value shall be used instead of the number or name value for accessing this DN in certain types of routing. Recommended to be set to CFGTrue by default. See CfgFlag .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDN Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDN Constructor
CfgDN Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgDN(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDN Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDN Methods
CfgDN Class See Also Send Feedback

The CfgDN type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetContractDBID
SetContractDBID
SetGroupDBID
SetGroupDBID
SetSiteDBID
SetSiteDBID
SetSwitchDBID
SetSwitchDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Save Method
CfgDN Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SetAccountPermissions Method
CfgDN Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDN Class
CfgDN Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetContractDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SetContractDBID Method
CfgDN Class See Also Send Feedback
SetContractDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetContractDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetContractDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetContractDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.SetContractDBID(System.Int32)"]

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetGroupDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SetGroupDBID Method
CfgDN Class See Also Send Feedback
SetGroupDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetGroupDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetGroupDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetGroupDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.SetGroupDBID(System.Int32)"]

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSiteDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SetSiteDBID Method
CfgDN Class See Also Send Feedback
SetSiteDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSiteDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSiteDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSiteDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.SetSiteDBID(System.Int32)"]

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SetSwitchDBID Method
CfgDN Class See Also Send Feedback
SetSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.SetSwitchDBID(System.Int32)"]

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SetTenantDBID Method
CfgDN Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDN.SetTenantDBID(System.Int32)"]

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDN Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDN Properties
CfgDN Class See Also Send Feedback

The CfgDN type exposes the following members.

Properties

Name | Description
AccessNumbers | A pointer to the list of structures that specify the numbers to be dialed from different switches to get this DN. Makes sense only if type is set to CFGExtRoutingPoint and CFGAccessResource. See CfgDNAccessNumber .
Association | A pointer to the identifier of an entity permanently associated with this DN (e.g., an IVR port number, channel name, or access number).
Contract | A unique identifier of Cost Contract (CfgObjectiveTable) with which this DN is associated.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DestDNs | A pointer to the list of identifiers of the objects (DBIDs) to which the calls residing at this DN can be routed/diverted by default. Makes sense only if type is set to CFGRoutingPoint, CFGExtRoutingPoint, CFGServiceNumber, CFGRoutingQueue, CFGACDQueue, CFGVirtACDQueue, or CFGVirtRoutingPoint, and CFGAccessResource and shall be set to NULL for all other values of type. When used as an entry in CfgDeltaDN (see below), it is a pointer to a list of identifiers of the objects added to the existing list. The DN for which this list is specified cannot be added to this list. If DN type is CFGAccessResource the property must be presented on GUI (Config Manager) with caption _Remote Resources_.
DNLoginID | A pointer to the login identifier used to activate this DN. Makes sense only if type is set to CFGACDPosition, CFGExtension, CFGEAPort, CFGVoiceMail, or CFGMixed. For type CFGAccessResource specifies the type of the resource and must be presented on GIU(Configuration Manager) with caption _Resource Type_
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Group | A unique identifier of the DN Group used in number translation.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LoginFlag | An indicator of whether a login procedure is necessary to activate the telephony object associated with this DN. Read-only (set automatically according to the current value of DNLoginID below). See CfgFlag. The value should not be taken into consideration if DN type is CFGAccessResource.
Name | Name of this DN required if the DN is planned to be used as a target in routing strategies. If specified, must be unique within the tenant this DN belongs to. It is strongly recommended to give names to DNs of the following types: CFGACDQueue, CFGRoutingPoint, CFGVirtualACDQueue, CFGVirtualRoutingPoint, and CFGRoutingQueue.
Number | Directory number assigned to this DN within the switch. Mandatory. Must be unique within the switch for all dn types except CFGDestinationLabel and CFGAccessResource. The uniqueness of CFGAccessResource is defined by combination of number and DN type. Once specified, cannot be changed. Please see the comment regarding the parameter DNRange in CfgSwitch .
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Override | The number used as a substitute of a regular directory number in certain types of routing.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RegisterAll | An indicator of whether T-Server shall register this DN within the switch. Recommended to be set to CFGDRTrue by default. See CfgDNRegisterFlag .
RouteType | Type of routing that applies to this DN. See type CfgRouteType .
Site | A unique identifier of Site (CfgFolder) with which this DN is associated.
State | Current object state. Mandatory. Refer to CfgObjectState
Switch | A unique identifier of the Switch to which this DN belongs. Mandatory. Once specified, cannot be changed.
SwitchSpecificType | An integer that corresponds to a combination of switch-specific settings for this DN. Cannot be set to a zero or negative value.
Tenant | A unique identifier of the Tenant to which this DN belongs. Read-only (set automatically according to the current value of tenantDBID of the switch specified in switchDBID). See CfgSwitch .
Trunks | Number of trunks associated with this DN. Makes sense only if type is set to CFGDestinationLabel.
Type | Type of this DN. See CfgDNType . Mandatory. Once specified, cannot be changed.
UseOverride | An indicator of whether the override value shall be used instead of the number or name value for accessing this DN in certain types of routing. Recommended to be set to CFGTrue by default. See CfgFlag .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AccessNumbers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.AccessNumbers Property
CfgDN Class See Also Send Feedback
A pointer to the list of structures that specify the numbers to be dialed from different switches to get this DN. Makes sense only if type is set to CFGExtRoutingPoint and CFGAccessResource. See CfgDNAccessNumber .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNAccessNumber> AccessNumbers { get; set; }
Visual Basic (Declaration)
Public Property AccessNumbers As ICollection(Of CfgDNAccessNumber)
Visual C++
public:
property ICollection<CfgDNAccessNumber^>^ AccessNumbers {
    ICollection<CfgDNAccessNumber^>^ get ();
    void set (ICollection<CfgDNAccessNumber^>^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Association Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Association Property
CfgDN Class See Also Send Feedback
A pointer to the identifier of an entity permanently associated with this DN (e.g., an IVR port number, channel name, or access number).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Association { get; set; }
Visual Basic (Declaration)
Public Property Association As String
Visual C++
public:
property String^ Association {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Contract Property
CfgDN Class See Also Send Feedback
A unique identifier of Cost Contract (CfgObjectiveTable) with which this DN is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
    void set (CfgObjectiveTable^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.DBID Property
CfgDN Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DestDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.DestDNs Property
CfgDN Class See Also Send Feedback
A pointer to the list of identifiers of the objects (DBIDs) to which the calls residing at this DN can be routed/diverted by default. Makes sense only if type is set to CFGRoutingPoint, CFGExtRoutingPoint, CFGServiceNumber, CFGRoutingQueue, CFGACDQueue, CFGVirtACDQueue, or CFGVirtRoutingPoint, and CFGAccessResource and shall be set to NULL for all other values of type. When used as an entry in CfgDeltaDN (see below), it is a pointer to a list of identifiers of the objects added to the existing list. The DN for which this list is specified cannot be added to this list. If DN type is CFGAccessResource the property must be presented on GUI (Config Manager) with caption _Remote Resources_.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DestDNs { get; set; }
Visual Basic (Declaration)
Public Property DestDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DestDNs {
    ICollection<CfgDN^>^ get ();
    void set (ICollection<CfgDN^>^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DNLoginID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.DNLoginID Property
CfgDN Class See Also Send Feedback
A pointer to the login identifier used to activate this DN. Makes sense only if type is set to CFGACDPosition, CFGExtension, CFGEAPort, CFGVoiceMail, or CFGMixed. For type CFGAccessResource specifies the type of the resource and must be presented on GIU(Configuration Manager) with caption _Resource Type_

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DNLoginID { get; set; }
Visual Basic (Declaration)
Public Property DNLoginID As String
Visual C++
public:
property String^ DNLoginID {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Group Property
CfgDN Class See Also Send Feedback
A unique identifier of the DN Group used in number translation.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroup Group { get; set; }
Visual Basic (Declaration)
Public Property Group As CfgDNGroup
Visual C++
public:
property CfgDNGroup^ Group {
    CfgDNGroup^ get ();
    void set (CfgDNGroup^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LoginFlag Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.LoginFlag Property
CfgDN Class See Also Send Feedback
An indicator of whether a login procedure is necessary to activate the telephony object associated with this DN. Read-only (set automatically according to the current value of DNLoginID below). See CfgFlag. The value should not be taken into consideration if DN type is CFGAccessResource.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag LoginFlag { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoginFlag As CfgFlag
Visual C++
public:
property CfgFlag LoginFlag {
    CfgFlag get ();
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Name Property
CfgDN Class See Also Send Feedback
Name of this DN required if the DN is planned to be used as a target in routing strategies. If specified, must be unique within the tenant this DN belongs to. It is strongly recommended to give names to DNs of the following types: CFGACDQueue, CFGRoutingPoint, CFGVirtualACDQueue, CFGVirtualRoutingPoint, and CFGRoutingQueue.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Number Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Number Property
CfgDN Class See Also Send Feedback
Directory number assigned to this DN within the switch. Mandatory. Must be unique within the switch for all dn types except CFGDestinationLabel and CFGAccessResource. The uniqueness of CFGAccessResource is defined by combination of number and DN type. Once specified, cannot be changed. Please see the comment regarding the parameter DNRange in CfgSwitch .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Override Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Override Property
CfgDN Class See Also Send Feedback
The number used as a substitute of a regular directory number in certain types of routing.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Override { get; set; }
Visual Basic (Declaration)
Public Property Override As String
Visual C++
public:
property String^ Override {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RegisterAll Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.RegisterAll Property
CfgDN Class See Also Send Feedback
An indicator of whether T-Server shall register this DN within the switch. Recommended to be set to CFGDRTrue by default. See CfgDNRegisterFlag .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNRegisterFlag RegisterAll { get; set; }
Visual Basic (Declaration)
Public Property RegisterAll As CfgDNRegisterFlag
Visual C++
public:
property CfgDNRegisterFlag RegisterAll {
    CfgDNRegisterFlag get ();
    void set (CfgDNRegisterFlag value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.RouteType Property
CfgDN Class See Also Send Feedback
Type of routing that applies to this DN. See type CfgRouteType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; set; }
Visual Basic (Declaration)
Public Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
    void set (CfgRouteType value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Site Property
CfgDN Class See Also Send Feedback
A unique identifier of Site (CfgFolder) with which this DN is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; set; }
Visual Basic (Declaration)
Public Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
    void set (CfgFolder^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.State Property
CfgDN Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Switch Property
CfgDN Class See Also Send Feedback
A unique identifier of the Switch to which this DN belongs. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
    void set (CfgSwitch^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SwitchSpecificType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.SwitchSpecificType Property
CfgDN Class See Also Send Feedback
An integer that corresponds to a combination of switch-specific settings for this DN. Cannot be set to a zero or negative value.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SwitchSpecificType { get; set; }
Visual Basic (Declaration)
Public Property SwitchSpecificType As Integer
Visual C++
public:
property int SwitchSpecificType {
    int get ();
    void set (int value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Tenant Property
CfgDN Class See Also Send Feedback
A unique identifier of the Tenant to which this DN belongs. Read-only (set automatically according to the current value of tenantDBID of the switch specified in switchDBID). See CfgSwitch .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Trunks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Trunks Property
CfgDN Class See Also Send Feedback
Number of trunks associated with this DN. Makes sense only if type is set to CFGDestinationLabel.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Trunks { get; set; }
Visual Basic (Declaration)
Public Property Trunks As Integer
Visual C++
public:
property int Trunks {
    int get ();
    void set (int value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.Type Property
CfgDN Class See Also Send Feedback
Type of this DN. See CfgDNType . Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgDNType
Visual C++
public:
property CfgDNType Type {
    CfgDNType get ();
    void set (CfgDNType value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseOverride Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.UseOverride Property
CfgDN Class See Also Send Feedback
An indicator of whether the override value shall be used instead of the number or name value for accessing this DN in certain types of routing. Recommended to be set to CFGTrue by default. See CfgFlag .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseOverride { get; set; }
Visual Basic (Declaration)
Public Property UseOverride As CfgFlag
Visual C++
public:
property CfgFlag UseOverride {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDN..::.UserProperties Property
CfgDN Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgDN Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNAccessNumber Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber Class
Members See Also Send Feedback
CfgDNAccessNumber

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNAccessNumber : CfgStructure
Visual Basic (Declaration)
Public Class CfgDNAccessNumber _
    Inherits CfgStructure
Visual C++
public ref class CfgDNAccessNumber : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDNAccessNumber

See Also

CfgDNAccessNumber Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNAccessNumber Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber Members
CfgDNAccessNumber Class Constructors Methods Properties See Also Send Feedback

The CfgDNAccessNumber type exposes the following members.

Constructors

Name | Description
CfgDNAccessNumber | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSwitchDBID | SetSwitchDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Number | A set of digits to be dialed by T-Server/Switch to reach specific external routing point(this DN).
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Switch | A unique identifier of the Switch that initiates call. Mandatory.

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNAccessNumber Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber Constructor
CfgDNAccessNumber Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNAccessNumber(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgDNAccessNumber(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNAccessNumber.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNAccessNumber.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNAccessNumber.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNAccessNumber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber Methods
CfgDNAccessNumber Class See Also Send Feedback

The CfgDNAccessNumber type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSwitchDBID | SetSwitchDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber..::.SetSwitchDBID Method
CfgDNAccessNumber Class See Also Send Feedback
SetSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNAccessNumber.SetSwitchDBID(System.Int32)"]

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNAccessNumber Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber Properties
CfgDNAccessNumber Class See Also Send Feedback

The CfgDNAccessNumber type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Number | A set of digits to be dialed by T-Server/Switch to reach specific external routing point(this DN).
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Switch | A unique identifier of the Switch that initiates call. Mandatory.

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Number Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber..::.Number Property
CfgDNAccessNumber Class See Also Send Feedback
A set of digits to be dialed by T-Server/Switch to reach specific external routing point(this DN).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumber..::.Switch Property
CfgDNAccessNumber Class See Also Send Feedback
A unique identifier of the Switch that initiates call. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
    void set (CfgSwitch^ value);
}

See Also

CfgDNAccessNumber Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup Class
Members See Also Send Feedback
You can set up Groups of DNs for use in network-level routing algorithms and in some types of statistics. Consult solution-specific documentation to see if you need to set up DN Groups. When you are specifying a DN Group, remember that the DNs comprising this group must have the same telephony event model.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNGroup : CfgObject
Visual Basic (Declaration)
Public Class CfgDNGroup _
    Inherits CfgObject
Visual C++
public ref class CfgDNGroup : public CfgObject

Remarks

The name of a DN group must be unique within the tenant, but can coincide with the names of access groups, place groups and agent groups of the same tenant. The name of a DN group cannot be changed until there is at least one DN listed in this group. See DNs property Deletion of DN Group X will cause the following events set out in the order of arrival: Modification of groupDBID of all DNs that used DN Group X for number translation Deletion of DN Group X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDNGroup

See Also

CfgDNGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroup Members
CfgDNGroup Class Constructors Methods Properties See Also Send Feedback

The CfgDNGroup type exposes the following members.

Constructors

Name | Description
CfgDNGroup | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | The DBID of the CfgDNGroup configuration object.
DNs | A pointer to the list of the DNs that form this group (every item of this list is structured as CfgDNInfo ).
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Type | Type of this DN group. Once specified, cannot be changed. Refer to CfgDNGroupType .

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNGroup Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup Constructor
CfgDNGroup Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroup(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgDNGroup(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroup Methods
CfgDNGroup Class See Also Send Feedback

The CfgDNGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup..::.Save Method
CfgDNGroup Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroup..::.SetAccountPermissions Method
CfgDNGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgDNGroup Class
CfgDNGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroup Properties
CfgDNGroup Class See Also Send Feedback

The CfgDNGroup type exposes the following members.

Properties

Name | Description
DBID | The DBID of the CfgDNGroup configuration object.
DNs | A pointer to the list of the DNs that form this group (every item of this list is structured as CfgDNInfo ).
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Type | Type of this DN group. Once specified, cannot be changed. Refer to CfgDNGroupType .

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup..::.DBID Property
CfgDNGroup Class See Also Send Feedback
The DBID of the CfgDNGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup..::.DNs Property
CfgDNGroup Class See Also Send Feedback
A pointer to the list of the DNs that form this group (every item of this list is structured as CfgDNInfo ).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDNInfo> DNs { get; set; }
Visual Basic (Declaration)
Public Property DNs As ICollection(Of CfgDNInfo)
Visual C++
public:
property ICollection<CfgDNInfo^>^ DNs {
    ICollection<CfgDNInfo^>^ get ();
    void set (ICollection<CfgDNInfo^>^ value);
}

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup..::.GroupInfo Property
CfgDNGroup Class See Also Send Feedback
A pointer to the structure CfgGroup containing general information about this group. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroup GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroup
Visual C++
public:
property CfgGroup^ GroupInfo {
    CfgGroup^ get ();
    void set (CfgGroup^ value);
}

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroup..::.Type Property
CfgDNGroup Class See Also Send Feedback
Type of this DN group. Once specified, cannot be changed. Refer to CfgDNGroupType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroupType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgDNGroupType
Visual C++
public:
property CfgDNGroupType Type {
    CfgDNGroupType get ();
    void set (CfgDNGroupType value);
}

See Also

CfgDNGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfo Class
Members See Also Send Feedback
CfgDNInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgDNInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgDNInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgDNInfo

See Also

CfgDNInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfo Members
CfgDNInfo Class Constructors Methods Properties See Also Send Feedback

The CfgDNInfo type exposes the following members.

Constructors

Name | Description
CfgDNInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetDNDBID | SetDNDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DN | A unique identifier of the CfgDN . Mandatory. Once specified, cannot be changed. The same value cannot be repeated within one list.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Trunks | Number of trunks associated with this DN. Cannot be set to a negative value. Makes sense only for DN groups of CFGNetworkPorts type.

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfo Constructor
CfgDNInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgDNInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfo Methods
CfgDNInfo Class See Also Send Feedback

The CfgDNInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetDNDBID | SetDNDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfo..::.SetDNDBID Method
CfgDNInfo Class See Also Send Feedback
SetDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgDNInfo.SetDNDBID(System.Int32)"]

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgDNInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfo Properties
CfgDNInfo Class See Also Send Feedback

The CfgDNInfo type exposes the following members.

Properties

Name | Description
DN | A unique identifier of the CfgDN . Mandatory. Once specified, cannot be changed. The same value cannot be repeated within one list.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Trunks | Number of trunks associated with this DN. Cannot be set to a negative value. Makes sense only for DN groups of CFGNetworkPorts type.

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DN Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfo..::.DN Property
CfgDNInfo Class See Also Send Feedback
A unique identifier of the CfgDN . Mandatory. Once specified, cannot be changed. The same value cannot be repeated within one list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN DN { get; set; }
Visual Basic (Declaration)
Public Property DN As CfgDN
Visual C++
public:
property CfgDN^ DN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Trunks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfo..::.Trunks Property
CfgDNInfo Class See Also Send Feedback
Number of trunks associated with this DN. Cannot be set to a negative value. Makes sense only for DN groups of CFGNetworkPorts type.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Trunks { get; set; }
Visual Basic (Declaration)
Public Property Trunks As Integer
Visual C++
public:
property int Trunks {
    int get ();
    void set (int value);
}

See Also

CfgDNInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumerator Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator Class
Members See Also Send Feedback
CfgEnumerator objects are available enumerations, such as MediaType, Service Type, and others.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumerator : CfgObject
Visual Basic (Declaration)
Public Class CfgEnumerator _
    Inherits CfgObject
Visual C++
public ref class CfgEnumerator : public CfgObject

Remarks

The table below provides a description of predefined CfgEnumerator objects (some fields are omitted for simplicity): Predefined CfgEnumerator Objects DBID Tenant Name Display name Type Description 101 1(101) MediaType Media Type 1 Defines all available Media Types 102 1(101) ServiceType Service Type 1 Defines all available Service Types 103 1(101) CustomerSegment Customer Segment 1 Defines all available Customer Segments 104 1(101) IVR Text To Speech Used IVR Text To Speech Used 1 Defines IVR Text To Speech Used 105 1(101) IVR Speech Recognition Used IVR Speech Recognition Used 1 Defines IVR Speech Recognition Used 106 1(101) IVR Application Name IVR Application Name 1 Defines IVR Application Name 107 1(101) IVR Technical Result IVR Technical Result 1 Defines IVR Technical Result 108 1(101) IVR Technical Result Reason IVR Technical Result Reason 1 Defines IVR Technical Result Reason 109 1(101) Case ID Case ID 1 Defines Case ID 110 1(101) Business Result Business Result 1 Defines Business Result 111 1(101) Root Interaction ID Root Interaction ID 1 Root Interaction ID 112 1(101) InteractionType Interaction Type 1 Predefined list of interaction types supported by contact center 113 1(101) InteractionSubtype Interaction Subtype 1 Predefined list of interaction subtypes supported by contact center 114 1(101) CategoryStructure Category Structure 4 Customer defined 115 1(101) ScreeningRules Screening Rules 4 Customer defined 116 1(101) EmailAccounts Email Accounts 4 Customer defined 117 1(101) StopProcessingReason StopProcessing Reason 1 Predefined, extended by customer 118 1(101) Language Language 1 Extended by customer 119 1(101) DispositionCode Disposition Code 1 Customer defined 120 1(101) ReasonCode Reason Code 1 Customer defined 121 1(101) InteractionAttributes Interaction Attributes 1 List of predefined interaction attributes 122 1(101) ContactAttributes Contact Attributes 1 List of predefined contact attributes In the GUI representation, the name ___Enumerator___ was replaced with ___Business Attribute___ Deletion of Enumerator X will cause the following events set out in the order of arrival: Deletion of all Enumerator values of Enumerator X Deletion of all folders that had Enumerator X defined as the parent object Deletion of Enumerator X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgEnumerator

See Also

CfgEnumerator Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumerator Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumerator Members
CfgEnumerator Class Constructors Methods Properties See Also Send Feedback

The CfgEnumerator type exposes the following members.

Constructors

Name | Description
CfgEnumerator | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the enumerator.
DisplayName | A pointer to the display name of the enumerator to be shown on GUI and in reports. Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the system name of the enumerator to be used primarily by Genesys applications. Mandatory. Must be unique within the tenant environment. Once specified, can not be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this enumerator is allocated. Mandatory. Once specified, cannot be changed.
Type | A type of the enumerator that enumerator belongs to. See CfgEnumerationType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumerator Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator Constructor
CfgEnumerator Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumerator(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgEnumerator(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumerator.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumerator.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumerator Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumerator Methods
CfgEnumerator Class See Also Send Feedback

The CfgEnumerator type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.Save Method
CfgEnumerator Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.SetAccountPermissions Method
CfgEnumerator Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgEnumerator Class
CfgEnumerator Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.SetTenantDBID Method
CfgEnumerator Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumerator.SetTenantDBID(System.Int32)"]

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumerator Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumerator Properties
CfgEnumerator Class See Also Send Feedback

The CfgEnumerator type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the enumerator.
DisplayName | A pointer to the display name of the enumerator to be shown on GUI and in reports. Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the system name of the enumerator to be used primarily by Genesys applications. Mandatory. Must be unique within the tenant environment. Once specified, can not be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this enumerator is allocated. Mandatory. Once specified, cannot be changed.
Type | A type of the enumerator that enumerator belongs to. See CfgEnumerationType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.DBID Property
CfgEnumerator Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.Description Property
CfgEnumerator Class See Also Send Feedback
A pointer to the description of the enumerator.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.DisplayName Property
CfgEnumerator Class See Also Send Feedback
A pointer to the display name of the enumerator to be shown on GUI and in reports. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.Name Property
CfgEnumerator Class See Also Send Feedback
A pointer to the system name of the enumerator to be used primarily by Genesys applications. Mandatory. Must be unique within the tenant environment. Once specified, can not be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.State Property
CfgEnumerator Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.Tenant Property
CfgEnumerator Class See Also Send Feedback
A unique identifier of the CfgTenant to which this enumerator is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.Type Property
CfgEnumerator Class See Also Send Feedback
A type of the enumerator that enumerator belongs to. See CfgEnumerationType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgEnumeratorType
Visual C++
public:
property CfgEnumeratorType Type {
    CfgEnumeratorType get ();
    void set (CfgEnumeratorType value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumerator..::.UserProperties Property
CfgEnumerator Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgEnumerator Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumeratorValue Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue Class
Members See Also Send Feedback
CfgEnumeratorValue objects contain all of the values for all available enumerators.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorValue : CfgObject
Visual Basic (Declaration)
Public Class CfgEnumeratorValue _
    Inherits CfgObject
Visual C++
public ref class CfgEnumeratorValue : public CfgObject

Remarks

The Following table specifies predefined CfgEnumeratorValue objects (some fields are omitted for simplicity) and ranges for each Enumerator: Predefined CfgEnumeratorValue Objects and Their Ranges DBID Enumerator Name Display name Is default? Description 100 101 Voice voice No Media Voice 101 101 Voip voip No Media Voice over IP 102 101 Email email No Media EMail 103 101 Vmail vmail No Media Voice Mail 104 101 Smail smail No Media Scanned Mail 105 101 Chat chat No Media Chat 106 101 Video video No Media Video 107 101 Cobrowsing cobrowsing No Media Cobrowsing 108 101 Whiteboard whiteboard No Media Whiteboard 109 101 Appsharing appsharing No Media Application Sharing 110 101 Webform webform No Media Web Form 111 101 Workitem workitem No Media Workitem 112 101 Callback callback No Media Callback 113 101 Fax fax No Media Fax 114 101 Imchat imchat No Media IMChat 115 101 Busevent busevent No Media Business Event 116 101 Alert alert No Media Alert 117 101 Sms sms No Media SMS 118 101 Any any Yes Media Any 119 101 Auxwork auxwork No Media AuxWork 200 102 Default default Yes Service Type Default 300 103 Default default Yes Customer Segment Default 350 104 Unknown unknown Yes IVR Text To Speech Used Default 353 104 Unknown unknown Yes IVR Speech Recognition Used Default 400 112 Inbound Inbound No Interactions received by contact center from outside clients 401 112 Outbound Outbound No Interactions sent from contact center to external clients 402 112 Internal Internal No Internal interactions between contact center correspondents 403 113 InboundNew Inbound New No New incoming email. Starts a new thread 404 113 InboundCustomerReply Customer Reply No Reply from a customer 405 113 InboundCollaborationReply Inbound Collaboration Reply No Reply from an external source 406 113 InboundNDR NDR No Error message sent back to the system by SMTP server chain 407 113 OutboundNew Outbound New No New message from Contact Center to a customer 408 113 OutboundReply Reply No Reply from Contact Center to a customer 409 113 OutboundAcknowledgement Acknowledgement No Ack message sent to customer by Contact Center 410 113 OutboundAutoResponse Auto Response No Automated reply from Contact Center to a customer 411 113 OutboundRedirect Redirect No Message redirect to an external resource. No reply expected. 412 113 OutboundCollaborationInvite Outbound Collaboration Invite No New message to an external resource 413 113 InternalCollaborationInvite Internal Collaboration Invite No New message to an internal resource 414 113 InternalCollaborationReply Internal Collaboration Reply No Reply from an internal resource 415 117 Normal Normal No StopProcessing Reason Normal 416 117 AutoResponded Auto Responded No StopProcessing Reason Auto Responded 417 117 Terminated Terminated No StopProcessing Reason Terminated 418 117 Sent Sent No StopProcessing Reason Sent 419 117 Forwarded Forwarded No StopProcessing Reason Forwarded 420 117 Re-directed Re-directed No StopProcessing Reason Re-directed 421 118 English English No Language English 422 121 Priority Priority No Interaction Attributes Priority 423 121 Category Category No Interaction Attributes Category 424 121 ServiceType Service Type No Interaction Attributes Service Type 425 121 MediaType Media Type No Interaction Attributes Media Type 426 121 InteractionType Interaction Type No Interaction Attributes Interaction Type 427 121 InteractionSubtype Interaction Subtype No Interaction Attributes Interaction Subtype 428 121 Language Language No Interaction Attributes Language 429 121 StopProcessing-Reason StopProcessing Reason No Interaction Attributes StopProcessing Reason 430 121 DispositionCode Disposition Code No Interaction Attributes Disposition Code 431 121 ReasonCode Reason Code No Interaction Attributes Reason Code 432 122 FirstName First Name No Contact Attributes First Name 433 122 LastName Last Name No Contact Attributes Last Name 434 122 Title Title No Contact Attributes Title 435 122 EmailAddress Email Address No Contact Attributes E-mail Address 436 122 PhoneNumber Phone Number No Contact Attributes Phone Number 437 122 AccountNumber Account Number No Contact Attributes Account Number 438 122 ContactId Contact ID No Contact Attributes Contact ID 439 122 CustomerSegment Customer Segment No Contact Attributes Customer Segment 440 122 PIN PIN No Contact Attributes PIN On GUI representation the name ___EnumeratorValue___ was replaced on ___Attribute Value___

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgEnumeratorValue

See Also

CfgEnumeratorValue Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumeratorValue Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue Members
CfgEnumeratorValue Class Constructors Methods Properties See Also Send Feedback

The CfgEnumeratorValue type exposes the following members.

Constructors

Name | Description
CfgEnumeratorValue | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetEnumeratorDBID
SetEnumeratorDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the enumerator value.
DisplayName | A pointer to the display name of the enumerator to be shown on GUI and in reports. Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Enumerator | A unique identifier of the CfgEnumerator to which this value is allocated. Mandatory. Once specified, cannot be changed.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDefault | An indicator whether the value is default. See CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the system name of the enumerator to be used primarily by Genesys applications. Mandatory. Must be unique within the enumerator object. Once specified, can not be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this enumerator value is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumeratorValue Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue Constructor
CfgEnumeratorValue Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValue(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgEnumeratorValue(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumeratorValue.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumeratorValue.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumeratorValue Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue Methods
CfgEnumeratorValue Class See Also Send Feedback

The CfgEnumeratorValue type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetEnumeratorDBID
SetEnumeratorDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.Save Method
CfgEnumeratorValue Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.SetAccountPermissions Method
CfgEnumeratorValue Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgEnumeratorValue Class
CfgEnumeratorValue Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetEnumeratorDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.SetEnumeratorDBID Method
CfgEnumeratorValue Class See Also Send Feedback
SetEnumeratorDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetEnumeratorDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetEnumeratorDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetEnumeratorDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumeratorValue.SetEnumeratorDBID(System.Int32)"]

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.SetTenantDBID Method
CfgEnumeratorValue Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgEnumeratorValue.SetTenantDBID(System.Int32)"]

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgEnumeratorValue Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue Properties
CfgEnumeratorValue Class See Also Send Feedback

The CfgEnumeratorValue type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the enumerator value.
DisplayName | A pointer to the display name of the enumerator to be shown on GUI and in reports. Mandatory.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Enumerator | A unique identifier of the CfgEnumerator to which this value is allocated. Mandatory. Once specified, cannot be changed.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDefault | An indicator whether the value is default. See CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the system name of the enumerator to be used primarily by Genesys applications. Mandatory. Must be unique within the enumerator object. Once specified, can not be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this enumerator value is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.DBID Property
CfgEnumeratorValue Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.Description Property
CfgEnumeratorValue Class See Also Send Feedback
A pointer to the description of the enumerator value.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.DisplayName Property
CfgEnumeratorValue Class See Also Send Feedback
A pointer to the display name of the enumerator to be shown on GUI and in reports. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Enumerator Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.Enumerator Property
CfgEnumeratorValue Class See Also Send Feedback
A unique identifier of the CfgEnumerator to which this value is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumerator Enumerator { get; set; }
Visual Basic (Declaration)
Public Property Enumerator As CfgEnumerator
Visual C++
public:
property CfgEnumerator^ Enumerator {
    CfgEnumerator^ get ();
    void set (CfgEnumerator^ value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsDefault Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.IsDefault Property
CfgEnumeratorValue Class See Also Send Feedback
An indicator whether the value is default. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDefault { get; set; }
Visual Basic (Declaration)
Public Property IsDefault As CfgFlag
Visual C++
public:
property CfgFlag IsDefault {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.Name Property
CfgEnumeratorValue Class See Also Send Feedback
A pointer to the system name of the enumerator to be used primarily by Genesys applications. Mandatory. Must be unique within the enumerator object. Once specified, can not be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.State Property
CfgEnumeratorValue Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.Tenant Property
CfgEnumeratorValue Class See Also Send Feedback
A unique identifier of the CfgTenant to which this enumerator value is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValue..::.UserProperties Property
CfgEnumeratorValue Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgEnumeratorValue Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgField Class

[image]

Enterprise SDK 8.0 Reference API
CfgField Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgField"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgField : CfgObject
Visual Basic (Declaration)
Public Class CfgField _
    Inherits CfgObject
Visual C++
public ref class CfgField : public CfgObject

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgField

See Also

CfgField Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgField Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgField Members
CfgField Class Constructors Methods Properties See Also Send Feedback

The CfgField type exposes the following members.

Constructors

Name | Description
CfgField | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DefaultValue | A pointer to the default value of field. Specify what value to insert when a user does not enter a value. Optional.
Description | A pointer to the description of field. Optional
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FieldType | A field type. Refer to CfgFieldType of User Defined Variable types. Mandatory, once specified cannot be changed.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsNullable | A flag which determines whether or not a field can allow null values ( NULLs ) for the data in that field. Once specified cannot be changed. See CfgFlag
IsPrimaryKey | A flag which determines whether or not a field is used as primary key. Once specified cannot be changed. See CfgFlag
IsUnique | A flag which determines whether or not a field is used as unique. Once specified cannot be changed. See CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Length | A length of field in data base. Optional, once specified cannot be changed.
Logger | (Inherited from AbstractLogEnabled.)
Name | A field name in data base. Due to restrictions of database engine the recommended length for property name is 1-12 characters. Mandatory, once specified cannot be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant that this field belongs to. Mandatory. Once specified, cannot be changed.
Type | A data type of field in data base. Mandatory, once specified cannot be changed. See CfgDataType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgField Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgField Constructor
CfgField Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgField(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgField(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgField.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgField.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgField Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgField Methods
CfgField Class See Also Send Feedback

The CfgField type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.Save Method
CfgField Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgField..::.SetAccountPermissions Method
CfgField Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgField Class
CfgField Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.SetTenantDBID Method
CfgField Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgField.SetTenantDBID(System.Int32)"]

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgField Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgField Properties
CfgField Class See Also Send Feedback

The CfgField type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DefaultValue | A pointer to the default value of field. Specify what value to insert when a user does not enter a value. Optional.
Description | A pointer to the description of field. Optional
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FieldType | A field type. Refer to CfgFieldType of User Defined Variable types. Mandatory, once specified cannot be changed.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsNullable | A flag which determines whether or not a field can allow null values ( NULLs ) for the data in that field. Once specified cannot be changed. See CfgFlag
IsPrimaryKey | A flag which determines whether or not a field is used as primary key. Once specified cannot be changed. See CfgFlag
IsUnique | A flag which determines whether or not a field is used as unique. Once specified cannot be changed. See CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Length | A length of field in data base. Optional, once specified cannot be changed.
Logger | (Inherited from AbstractLogEnabled.)
Name | A field name in data base. Due to restrictions of database engine the recommended length for property name is 1-12 characters. Mandatory, once specified cannot be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant that this field belongs to. Mandatory. Once specified, cannot be changed.
Type | A data type of field in data base. Mandatory, once specified cannot be changed. See CfgDataType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.DBID Property
CfgField Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DefaultValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.DefaultValue Property
CfgField Class See Also Send Feedback
A pointer to the default value of field. Specify what value to insert when a user does not enter a value. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As String
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.Description Property
CfgField Class See Also Send Feedback
A pointer to the description of field. Optional

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FieldType Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.FieldType Property
CfgField Class See Also Send Feedback
A field type. Refer to CfgFieldType of User Defined Variable types. Mandatory, once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFieldType FieldType { get; set; }
Visual Basic (Declaration)
Public Property FieldType As CfgFieldType
Visual C++
public:
property CfgFieldType FieldType {
    CfgFieldType get ();
    void set (CfgFieldType value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsNullable Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.IsNullable Property
CfgField Class See Also Send Feedback
A flag which determines whether or not a field can allow null values ( NULLs ) for the data in that field. Once specified cannot be changed. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsNullable { get; set; }
Visual Basic (Declaration)
Public Property IsNullable As CfgFlag
Visual C++
public:
property CfgFlag IsNullable {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsPrimaryKey Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.IsPrimaryKey Property
CfgField Class See Also Send Feedback
A flag which determines whether or not a field is used as primary key. Once specified cannot be changed. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsPrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property IsPrimaryKey As CfgFlag
Visual C++
public:
property CfgFlag IsPrimaryKey {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsUnique Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.IsUnique Property
CfgField Class See Also Send Feedback
A flag which determines whether or not a field is used as unique. Once specified cannot be changed. See CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsUnique { get; set; }
Visual Basic (Declaration)
Public Property IsUnique As CfgFlag
Visual C++
public:
property CfgFlag IsUnique {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Length Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.Length Property
CfgField Class See Also Send Feedback
A length of field in data base. Optional, once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.Name Property
CfgField Class See Also Send Feedback
A field name in data base. Due to restrictions of database engine the recommended length for property name is 1-12 characters. Mandatory, once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.State Property
CfgField Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.Tenant Property
CfgField Class See Also Send Feedback
A unique identifier of the CfgTenant that this field belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.Type Property
CfgField Class See Also Send Feedback
A data type of field in data base. Mandatory, once specified cannot be changed. See CfgDataType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDataType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgDataType
Visual C++
public:
property CfgDataType Type {
    CfgDataType get ();
    void set (CfgDataType value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgField..::.UserProperties Property
CfgField Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgField Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFilter Class

[image]

Enterprise SDK 8.0 Reference API
CfgFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFilter"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFilter : CfgObject
Visual Basic (Declaration)
Public Class CfgFilter _
    Inherits CfgObject
Visual C++
public ref class CfgFilter : public CfgObject

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgFilter

See Also

CfgFilter Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilter Members
CfgFilter Class Constructors Methods Properties See Also Send Feedback

The CfgFilter type exposes the following members.

Constructors

Name | Description
CfgFilter | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetFormatDBID
SetFormatDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to filter description.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | A unique identifier of CfgFormat to which this filter is dedicated. Once specified cannot be changed. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to filter name. Must be unique within tenant environment.Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this filter is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section. Among other properties must include kv-pair that specifies the filter sequence which application can use to read information from data table having specified format.

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFilter Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFilter Constructor
CfgFilter Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilter(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgFilter(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFilter.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFilter.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilter Methods
CfgFilter Class See Also Send Feedback

The CfgFilter type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetFormatDBID
SetFormatDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.Save Method
CfgFilter Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.SetAccountPermissions Method
CfgFilter Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgFilter Class
CfgFilter Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetFormatDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.SetFormatDBID Method
CfgFilter Class See Also Send Feedback
SetFormatDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetFormatDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetFormatDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetFormatDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFilter.SetFormatDBID(System.Int32)"]

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.SetTenantDBID Method
CfgFilter Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFilter.SetTenantDBID(System.Int32)"]

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFilter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilter Properties
CfgFilter Class See Also Send Feedback

The CfgFilter type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to filter description.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | A unique identifier of CfgFormat to which this filter is dedicated. Once specified cannot be changed. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to filter name. Must be unique within tenant environment.Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this filter is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section. Among other properties must include kv-pair that specifies the filter sequence which application can use to read information from data table having specified format.

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.DBID Property
CfgFilter Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.Description Property
CfgFilter Class See Also Send Feedback
A pointer to filter description.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Format Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.Format Property
CfgFilter Class See Also Send Feedback
A unique identifier of CfgFormat to which this filter is dedicated. Once specified cannot be changed. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As CfgFormat
Visual C++
public:
property CfgFormat^ Format {
    CfgFormat^ get ();
    void set (CfgFormat^ value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.Name Property
CfgFilter Class See Also Send Feedback
A pointer to filter name. Must be unique within tenant environment.Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.State Property
CfgFilter Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.Tenant Property
CfgFilter Class See Also Send Feedback
A unique identifier of the CfgTenant to which this filter is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilter..::.UserProperties Property
CfgFilter Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section. Among other properties must include kv-pair that specifies the filter sequence which application can use to read information from data table having specified format.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFilter Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFolder Class

[image]

Enterprise SDK 8.0 Reference API
CfgFolder Class
Members See Also Send Feedback
Folders can be used to create hierarchies of other types of objects. Each folder can contain a collection of objects of a single type.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFolder : CfgObject
Visual Basic (Declaration)
Public Class CfgFolder _
    Inherits CfgObject
Visual C++
public ref class CfgFolder : public CfgObject

Remarks

A folder may contain objects of the type equal to the folder's type property or subfolders of this type. An object may be contained in one and only one folder (has only one parent). A folder may be a subfolder of only one parent folder or does not have a parent folder at all (be a default folder under some parent object) There can not be more than one default folder of particular type for some parent object. A folder can not be removed as long as it has at least one subordinate object. A Configuration Unit is a GUI name for the folder of type CfgFolder . Unlike other folders, this folder can not contain ordinary objects, but may contain folders of any type including folders of type CfgFolder (Configuration Units) Configuration Units can only be created under the Tenant object or other Configuration Unit.

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgFolder

See Also

CfgFolder Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFolder Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolder Members
CfgFolder Class Constructors Methods Properties See Also Send Feedback

The CfgFolder type exposes the following members.

Constructors

Name | Description
CfgFolder | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
CustomType | User classificator of the Folder. Optional.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderClass | The class of the Folder.Refer to CfgFolderClass enumeration.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the folder. Mandatory. Must be unique within the parent object.
ObjectDbid | (Inherited from CfgObject.)
ObjectIDs | Pointer to the list of CfgID objects containing the type and DBID of the objects subordinate to this folder. Only objects of the type equal to the folder's type property or subfolders of this type may be contained in this list.
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OwnerID | A structure containing the object type and DBID of the folder's owner object. Unlike parentID, this field defines the folder's logical affiliation rather than its hierarchical affiliation. An owner may be an object of the following types: CfgTenant , CfgSwitch , CfgIVR , or CfgEnumerator . See CfgID .
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentID | A structure containing object type and DBID of the folder's parent, e.g. object which stands higher in the hierarchy. This may be another folder, if this folder is a subfolder, or this field may coincide with ownerID field if this folder is a topmost (default) one. A parent may an object of the following types: CfgFolder , CfgTenant , CfgSwitch , CfgIVR , or CfgEnumerator . See CfgID .
Resources | A pointer to the list of the objects associated with this Folder (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaFolder , it is a pointer to a list of resources added to the existing list. Only objects of type CfgFolder , CfgObjectiveTable , CfgGVPIVRProfile , CfgGVPCustomer , CfgTimeZone , CfgHost can be associated with Folder object through resources
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the objects this folder may contain. A folder may contain either objects of this type or subfolders with the same value of type property. See the CfgObjectType enumeration.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFolder Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFolder Constructor
CfgFolder Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgFolder(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFolder.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFolder.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFolder Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolder Methods
CfgFolder Class See Also Send Feedback

The CfgFolder type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.Save Method
CfgFolder Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.SetAccountPermissions Method
CfgFolder Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgFolder Class
CfgFolder Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFolder Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolder Properties
CfgFolder Class See Also Send Feedback

The CfgFolder type exposes the following members.

Properties

Name | Description
CustomType | User classificator of the Folder. Optional.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderClass | The class of the Folder.Refer to CfgFolderClass enumeration.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the folder. Mandatory. Must be unique within the parent object.
ObjectDbid | (Inherited from CfgObject.)
ObjectIDs | Pointer to the list of CfgID objects containing the type and DBID of the objects subordinate to this folder. Only objects of the type equal to the folder's type property or subfolders of this type may be contained in this list.
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OwnerID | A structure containing the object type and DBID of the folder's owner object. Unlike parentID, this field defines the folder's logical affiliation rather than its hierarchical affiliation. An owner may be an object of the following types: CfgTenant , CfgSwitch , CfgIVR , or CfgEnumerator . See CfgID .
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentID | A structure containing object type and DBID of the folder's parent, e.g. object which stands higher in the hierarchy. This may be another folder, if this folder is a subfolder, or this field may coincide with ownerID field if this folder is a topmost (default) one. A parent may an object of the following types: CfgFolder , CfgTenant , CfgSwitch , CfgIVR , or CfgEnumerator . See CfgID .
Resources | A pointer to the list of the objects associated with this Folder (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaFolder , it is a pointer to a list of resources added to the existing list. Only objects of type CfgFolder , CfgObjectiveTable , CfgGVPIVRProfile , CfgGVPCustomer , CfgTimeZone , CfgHost can be associated with Folder object through resources
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the objects this folder may contain. A folder may contain either objects of this type or subfolders with the same value of type property. See the CfgObjectType enumeration.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CustomType Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.CustomType Property
CfgFolder Class See Also Send Feedback
User classificator of the Folder. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CustomType { get; set; }
Visual Basic (Declaration)
Public Property CustomType As Integer
Visual C++
public:
property int CustomType {
    int get ();
    void set (int value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.DBID Property
CfgFolder Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.Description Property
CfgFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFolder.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FolderClass Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.FolderClass Property
CfgFolder Class See Also Send Feedback
The class of the Folder.Refer to CfgFolderClass enumeration.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolderClass FolderClass { get; set; }
Visual Basic (Declaration)
Public Property FolderClass As CfgFolderClass
Visual C++
public:
property CfgFolderClass FolderClass {
    CfgFolderClass get ();
    void set (CfgFolderClass value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.Name Property
CfgFolder Class See Also Send Feedback
A pointer to name of the folder. Mandatory. Must be unique within the parent object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.ObjectIDs Property
CfgFolder Class See Also Send Feedback
Pointer to the list of CfgID objects containing the type and DBID of the objects subordinate to this folder. Only objects of the type equal to the folder's type property or subfolders of this type may be contained in this list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectID> ObjectIDs { get; set; }
Visual Basic (Declaration)
Public Property ObjectIDs As ICollection(Of CfgObjectID)
Visual C++
public:
property ICollection<CfgObjectID^>^ ObjectIDs {
    ICollection<CfgObjectID^>^ get ();
    void set (ICollection<CfgObjectID^>^ value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OwnerID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.OwnerID Property
CfgFolder Class See Also Send Feedback
A structure containing the object type and DBID of the folder's owner object. Unlike parentID, this field defines the folder's logical affiliation rather than its hierarchical affiliation. An owner may be an object of the following types: CfgTenant , CfgSwitch , CfgIVR , or CfgEnumerator . See CfgID .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOwnerID OwnerID { get; set; }
Visual Basic (Declaration)
Public Property OwnerID As CfgOwnerID
Visual C++
public:
property CfgOwnerID^ OwnerID {
    CfgOwnerID^ get ();
    void set (CfgOwnerID^ value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ParentID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.ParentID Property
CfgFolder Class See Also Send Feedback
A structure containing object type and DBID of the folder's parent, e.g. object which stands higher in the hierarchy. This may be another folder, if this folder is a subfolder, or this field may coincide with ownerID field if this folder is a topmost (default) one. A parent may an object of the following types: CfgFolder , CfgTenant , CfgSwitch , CfgIVR , or CfgEnumerator . See CfgID .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgParentID ParentID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentID As CfgParentID
Visual C++
public:
property CfgParentID^ ParentID {
    CfgParentID^ get ();
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.Resources Property
CfgFolder Class See Also Send Feedback
A pointer to the list of the objects associated with this Folder (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaFolder , it is a pointer to a list of resources added to the existing list. Only objects of type CfgFolder , CfgObjectiveTable , CfgGVPIVRProfile , CfgGVPCustomer , CfgTimeZone , CfgHost can be associated with Folder object through resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.State Property
CfgFolder Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.Type Property
CfgFolder Class See Also Send Feedback
Type of the objects this folder may contain. A folder may contain either objects of this type or subfolders with the same value of type property. See the CfgObjectType enumeration.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolder..::.UserProperties Property
CfgFolder Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFolder Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFormat Class

[image]

Enterprise SDK 8.0 Reference API
CfgFormat Class
Members See Also Send Feedback
Use Formats to specify Fields that form a data structure (for example, a database table).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFormat : CfgObject
Visual Basic (Declaration)
Public Class CfgFormat _
    Inherits CfgObject
Visual C++
public ref class CfgFormat : public CfgObject

Remarks

One format can be dedicated to several objects of type CfgTableAccess . A format cannot be deleted as long as it is associated with at least one TableAccess or Filter (see CfgTableAccess and CfgFilter respectively). The list of fields cannot be changed as long as it is associated with at least one TableAccess or Filter (see CfgTableAccess and CfgFilter , respectively) CfgField must be unique within CfgFormat . Predefined Formats Name Tenant[if applicable] Description Fields Default_Outbound_6 Environment Default format for Outbound Suite (before 7.0 release) CFGFTRecordID CFGFTPhone CFGFTRecordType CFGFTRecordStatus CFGFTDialResult CFGFTNumberOfAttempts CFGFTScheduledTime CFGFTCallTime CFGFTFrom CFGFTUntil CFGFTTimeZone CFGFTCompaignID CFGFTAgentID CFGFTChainID CFGFTNumberInChain CFGFTPhoneType Default_Outbound_70 Environment Default format for Outbound Suite (starting from 7.0 release) CFGFTRecordID CFGFTPhone CFGFTRecordType CFGFTRecordStatus CFGFTDialResult CFGFTNumberOfAttempts CFGFTScheduledTime CFGFTCallTime CFGFTFrom CFGFTUntil CFGFTTimeZone CFGFTCompaignID CFGFTAgentID CFGFTChainID CFGFTNumberInChain CFGFTPhoneType CFGFTGroupDBID CFGFTAppDBID CFGFTTreatments CFGFTMediaRefference CFGFTEmailSubject CFGFTEmailTemplateID CFGFTSwitchID Default_DoNotCall_List Environment Default format for Do Not Call List CFGFTPhone

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgFormat

See Also

CfgFormat Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFormat Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormat Members
CfgFormat Class Constructors Methods Properties See Also Send Feedback

The CfgFormat type exposes the following members.

Constructors

Name | Description
CfgFormat | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of format.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Fields | A pointer to the list of identifiers of CfgField objects that this format consists of.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the format. Due to restrictions of database engine the recommended length for property name is 1-12 characters. Mandatory, once specified cannot be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this format is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFormat Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFormat Constructor
CfgFormat Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormat(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgFormat(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFormat.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFormat.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFormat Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormat Methods
CfgFormat Class See Also Send Feedback

The CfgFormat type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.Save Method
CfgFormat Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.SetAccountPermissions Method
CfgFormat Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgFormat Class
CfgFormat Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.SetTenantDBID Method
CfgFormat Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgFormat.SetTenantDBID(System.Int32)"]

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgFormat Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormat Properties
CfgFormat Class See Also Send Feedback

The CfgFormat type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of format.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Fields | A pointer to the list of identifiers of CfgField objects that this format consists of.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the format. Due to restrictions of database engine the recommended length for property name is 1-12 characters. Mandatory, once specified cannot be changed.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this format is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.DBID Property
CfgFormat Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.Description Property
CfgFormat Class See Also Send Feedback
A pointer to the description of format.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Fields Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.Fields Property
CfgFormat Class See Also Send Feedback
A pointer to the list of identifiers of CfgField objects that this format consists of.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgField> Fields { get; set; }
Visual Basic (Declaration)
Public Property Fields As ICollection(Of CfgField)
Visual C++
public:
property ICollection<CfgField^>^ Fields {
    ICollection<CfgField^>^ get ();
    void set (ICollection<CfgField^>^ value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.Name Property
CfgFormat Class See Also Send Feedback
A pointer to the name of the format. Due to restrictions of database engine the recommended length for property name is 1-12 characters. Mandatory, once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.State Property
CfgFormat Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.Tenant Property
CfgFormat Class See Also Send Feedback
A unique identifier of the CfgTenant to which this format is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormat..::.UserProperties Property
CfgFormat Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFormat Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgGroup Class
Members See Also Send Feedback
CfgGroup

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGroup : CfgStructure
Visual Basic (Declaration)
Public Class CfgGroup _
    Inherits CfgStructure
Visual C++
public ref class CfgGroup : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGroup

See Also

CfgGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroup Members
CfgGroup Class Constructors Methods Properties See Also Send Feedback

The CfgGroup type exposes the following members.

Constructors

Name | Description
CfgGroup | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetCapacityRuleDBID | SetCapacityRuleDBID
SetCapacityTableDBID | SetCapacityTableDBID
SetContractDBID | SetContractDBID
SetQuotaTableDBID | SetQuotaTableDBID
SetSiteDBID | SetSiteDBID
SetTenantDBID | SetTenantDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
CapacityRule | A unique identifier of the capacity rule ( Script ) associated with this group. Applicable for CfgPlaceGroup and CfgAgentGroup only.
CapacityTable | A unique identifier of the Stat Table of CFGCapacityTable type associated with this group.
Contract | A unique identifier of Cost Contract ( Objective Table ) with which this Group is associated.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Managers | A pointer to the list of the identifiers of the CfgPerson objects that serve as supervisors of this group. Applicable for CfgAgentGroup only. When used as an entry in CfgDeltaGroup, it is a pointer to a list of identifiers of the Persons added to the existing list. A person assigned as a supervisor to this Group should belong either to the same Tenant as the Group or to the Tenant Environment.
Name | A pointer to name of the group. Mandatory. See comments to CfgAgentGroup , CfgPlaceGroup, and CfgDNGroup .
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
QuotaTable | A unique identifier of the Stat Table of CFGQuotaTable type associated with this group.
RouteDNs | A pointer to the list of identifiers of the telephony objects from which calls can be routed/diverted to this group. This list can include DNs whose types are set to CFGRoutingPoint, CFGExtRoutingPoint, CFGServiceNumber, CFGRoutingQueue or CFGACDQueue, CFGVirtACDQueue, and CFGVirtRoutingPoint. When used as an entry in CfgDeltaGroup, it is a pointer to a list of identifiers of the DNs added to the existing list.
Site | A unique identifier of Site ( Folder ) with which this Group is associated.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this group belongs to. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGroup Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGroup Constructor
CfgGroup Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroup(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgGroup(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroup Methods
CfgGroup Class See Also Send Feedback

The CfgGroup type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetCapacityRuleDBID | SetCapacityRuleDBID
SetCapacityTableDBID | SetCapacityTableDBID
SetContractDBID | SetContractDBID
SetQuotaTableDBID | SetQuotaTableDBID
SetSiteDBID | SetSiteDBID
SetTenantDBID | SetTenantDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCapacityRuleDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.SetCapacityRuleDBID Method
CfgGroup Class See Also Send Feedback
SetCapacityRuleDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCapacityRuleDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCapacityRuleDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCapacityRuleDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.SetCapacityRuleDBID(System.Int32)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCapacityTableDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.SetCapacityTableDBID Method
CfgGroup Class See Also Send Feedback
SetCapacityTableDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCapacityTableDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCapacityTableDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCapacityTableDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.SetCapacityTableDBID(System.Int32)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetContractDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.SetContractDBID Method
CfgGroup Class See Also Send Feedback
SetContractDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetContractDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetContractDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetContractDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.SetContractDBID(System.Int32)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetQuotaTableDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.SetQuotaTableDBID Method
CfgGroup Class See Also Send Feedback
SetQuotaTableDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetQuotaTableDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetQuotaTableDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetQuotaTableDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.SetQuotaTableDBID(System.Int32)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSiteDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.SetSiteDBID Method
CfgGroup Class See Also Send Feedback
SetSiteDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSiteDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSiteDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSiteDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.SetSiteDBID(System.Int32)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.SetTenantDBID Method
CfgGroup Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGroup.SetTenantDBID(System.Int32)"]

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroup Properties
CfgGroup Class See Also Send Feedback

The CfgGroup type exposes the following members.

Properties

Name | Description
CapacityRule | A unique identifier of the capacity rule ( Script ) associated with this group. Applicable for CfgPlaceGroup and CfgAgentGroup only.
CapacityTable | A unique identifier of the Stat Table of CFGCapacityTable type associated with this group.
Contract | A unique identifier of Cost Contract ( Objective Table ) with which this Group is associated.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Managers | A pointer to the list of the identifiers of the CfgPerson objects that serve as supervisors of this group. Applicable for CfgAgentGroup only. When used as an entry in CfgDeltaGroup, it is a pointer to a list of identifiers of the Persons added to the existing list. A person assigned as a supervisor to this Group should belong either to the same Tenant as the Group or to the Tenant Environment.
Name | A pointer to name of the group. Mandatory. See comments to CfgAgentGroup , CfgPlaceGroup, and CfgDNGroup .
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
QuotaTable | A unique identifier of the Stat Table of CFGQuotaTable type associated with this group.
RouteDNs | A pointer to the list of identifiers of the telephony objects from which calls can be routed/diverted to this group. This list can include DNs whose types are set to CFGRoutingPoint, CFGExtRoutingPoint, CFGServiceNumber, CFGRoutingQueue or CFGACDQueue, CFGVirtACDQueue, and CFGVirtRoutingPoint. When used as an entry in CfgDeltaGroup, it is a pointer to a list of identifiers of the DNs added to the existing list.
Site | A unique identifier of Site ( Folder ) with which this Group is associated.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this group belongs to. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.CapacityRule Property
CfgGroup Class See Also Send Feedback
A unique identifier of the capacity rule ( Script ) associated with this group. Applicable for CfgPlaceGroup and CfgAgentGroup only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript CapacityRule { get; set; }
Visual Basic (Declaration)
Public Property CapacityRule As CfgScript
Visual C++
public:
property CfgScript^ CapacityRule {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityTable Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.CapacityTable Property
CfgGroup Class See Also Send Feedback
A unique identifier of the Stat Table of CFGCapacityTable type associated with this group.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTable CapacityTable { get; set; }
Visual Basic (Declaration)
Public Property CapacityTable As CfgStatTable
Visual C++
public:
property CfgStatTable^ CapacityTable {
    CfgStatTable^ get ();
    void set (CfgStatTable^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.Contract Property
CfgGroup Class See Also Send Feedback
A unique identifier of Cost Contract ( Objective Table ) with which this Group is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
    void set (CfgObjectiveTable^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.DBID Property
CfgGroup Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Managers Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.Managers Property
CfgGroup Class See Also Send Feedback
A pointer to the list of the identifiers of the CfgPerson objects that serve as supervisors of this group. Applicable for CfgAgentGroup only. When used as an entry in CfgDeltaGroup, it is a pointer to a list of identifiers of the Persons added to the existing list. A person assigned as a supervisor to this Group should belong either to the same Tenant as the Group or to the Tenant Environment.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPerson> Managers { get; set; }
Visual Basic (Declaration)
Public Property Managers As ICollection(Of CfgPerson)
Visual C++
public:
property ICollection<CfgPerson^>^ Managers {
    ICollection<CfgPerson^>^ get ();
    void set (ICollection<CfgPerson^>^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.Name Property
CfgGroup Class See Also Send Feedback
A pointer to name of the group. Mandatory. See comments to CfgAgentGroup , CfgPlaceGroup, and CfgDNGroup .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


QuotaTable Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.QuotaTable Property
CfgGroup Class See Also Send Feedback
A unique identifier of the Stat Table of CFGQuotaTable type associated with this group.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTable QuotaTable { get; set; }
Visual Basic (Declaration)
Public Property QuotaTable As CfgStatTable
Visual C++
public:
property CfgStatTable^ QuotaTable {
    CfgStatTable^ get ();
    void set (CfgStatTable^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RouteDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.RouteDNs Property
CfgGroup Class See Also Send Feedback
A pointer to the list of identifiers of the telephony objects from which calls can be routed/diverted to this group. This list can include DNs whose types are set to CFGRoutingPoint, CFGExtRoutingPoint, CFGServiceNumber, CFGRoutingQueue or CFGACDQueue, CFGVirtACDQueue, and CFGVirtRoutingPoint. When used as an entry in CfgDeltaGroup, it is a pointer to a list of identifiers of the DNs added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> RouteDNs { get; set; }
Visual Basic (Declaration)
Public Property RouteDNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ RouteDNs {
    ICollection<CfgDN^>^ get ();
    void set (ICollection<CfgDN^>^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.Site Property
CfgGroup Class See Also Send Feedback
A unique identifier of Site ( Folder ) with which this Group is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; set; }
Visual Basic (Declaration)
Public Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
    void set (CfgFolder^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.State Property
CfgGroup Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.Tenant Property
CfgGroup Class See Also Send Feedback
A unique identifier of the Tenant that this group belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroup..::.UserProperties Property
CfgGroup Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPCustomer Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer Class
Members See Also Send Feedback
This object is obsolete and no longer in use

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("This object is no longer available in Configuration Server")]
public class CfgGVPCustomer : CfgObject
Visual Basic (Declaration)
<ObsoleteAttribute("This object is no longer available in Configuration Server")> _
Public Class CfgGVPCustomer _
    Inherits CfgObject
Visual C++
[ObsoleteAttribute(L"This object is no longer available in Configuration Server")]
public ref class CfgGVPCustomer : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGVPCustomer

See Also

CfgGVPCustomer Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPCustomer Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer Members
CfgGVPCustomer Class Constructors Methods Properties See Also Send Feedback

The CfgGVPCustomer type exposes the following members.

Constructors

Name | Description
CfgGVPCustomer | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetResellerDBID
SetResellerDBID
SetTimeZoneDBID
SetTimeZoneDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Channel |
DBID |
DisplayName |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAdminCustomer |
IsProvisioned |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name |
Notes |
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPCustomer Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer Constructor
CfgGVPCustomer Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPCustomer(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgGVPCustomer(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPCustomer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer Methods
CfgGVPCustomer Class See Also Send Feedback

The CfgGVPCustomer type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetResellerDBID
SetResellerDBID
SetTimeZoneDBID
SetTimeZoneDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.Save Method
CfgGVPCustomer Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.SetAccountPermissions Method
CfgGVPCustomer Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgGVPCustomer Class
CfgGVPCustomer Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetResellerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.SetResellerDBID Method
CfgGVPCustomer Class See Also Send Feedback
SetResellerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetResellerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetResellerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetResellerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.SetResellerDBID(System.Int32)"]

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTimeZoneDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.SetTimeZoneDBID Method
CfgGVPCustomer Class See Also Send Feedback
SetTimeZoneDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTimeZoneDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTimeZoneDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTimeZoneDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.SetTimeZoneDBID(System.Int32)"]

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPCustomer Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer Properties
CfgGVPCustomer Class See Also Send Feedback

The CfgGVPCustomer type exposes the following members.

Properties

Name | Description
Channel |
DBID |
DisplayName |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAdminCustomer |
IsProvisioned |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name |
Notes |
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Channel Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.Channel Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.Channel"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Channel { get; set; }
Visual Basic (Declaration)
Public Property Channel As String
Visual C++
public:
property String^ Channel {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.DBID Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.DisplayName Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsAdminCustomer Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.IsAdminCustomer Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.IsAdminCustomer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAdminCustomer { get; set; }
Visual Basic (Declaration)
Public Property IsAdminCustomer As CfgFlag
Visual C++
public:
property CfgFlag IsAdminCustomer {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsProvisioned Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.IsProvisioned Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.IsProvisioned"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsProvisioned { get; set; }
Visual Basic (Declaration)
Public Property IsProvisioned As CfgFlag
Visual C++
public:
property CfgFlag IsProvisioned {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.Name Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.Notes Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.Notes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Reseller Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.Reseller Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.Reseller"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPReseller Reseller { get; set; }
Visual Basic (Declaration)
Public Property Reseller As CfgGVPReseller
Visual C++
public:
property CfgGVPReseller^ Reseller {
    CfgGVPReseller^ get ();
    void set (CfgGVPReseller^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.State Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.Tenant Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.TimeZone Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.TimeZone"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As CfgTimeZone
Visual C++
public:
property CfgTimeZone^ TimeZone {
    CfgTimeZone^ get ();
    void set (CfgTimeZone^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomer..::.UserProperties Property
CfgGVPCustomer Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPCustomer.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGVPCustomer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPIVRProfile Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile Class
Members See Also Send Feedback
A GVP Voice Application Profile is used by a GVP to define an voice application that can be executed upon request. Each GVP Voice Application is associated with one Tenant. Specified CfgGVPIVRProfile is not found (change/delete) CfgGVPIVRProfile already exists (Add) submited CfgGVPIVRProfile does not have any or all of mandatory fields filled (add/change)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPIVRProfile : CfgObject
Visual Basic (Declaration)
Public Class CfgGVPIVRProfile _
    Inherits CfgObject
Visual C++
public ref class CfgGVPIVRProfile : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGVPIVRProfile

See Also

CfgGVPIVRProfile Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPIVRProfile Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile Members
CfgGVPIVRProfile Class Constructors Methods Properties See Also Send Feedback

The CfgGVPIVRProfile type exposes the following members.

Constructors

Name | Description
CfgGVPIVRProfile | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Customer | obsolete. Not in use
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | An optional short description of this GVP Voice Application Profile.
DIDs | Obsolete. Not in use
DisplayName | A name for this GVP IVR Profile that appears on the console display
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndServiceDate | The date when this GVP IVR Profile ends. This date must be the same as, or later than, the Start of Service.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsProvisioned | obsolete
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the GVP Voice Application Profile. Mandatory. Must be unique within the Tenant.
Notes | Optional notes and information relevant for this GVP Voice Application Profile.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller | obsolette. Not in use
Resources |
StartServiceDate | obsolete .
State | Current object state. Mandatory. Refer to CfgObjectState
Status | obsolete
Tenant | A unique identifier of the CfgTenant to which this GVP Voice Application Profile is allocated. Populated upon creaton. Read-only
Tfn | obsolete
Type | obsolete.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPIVRProfile Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile Constructor
CfgGVPIVRProfile Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPIVRProfile(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgGVPIVRProfile(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPIVRProfile.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPIVRProfile.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPIVRProfile Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile Methods
CfgGVPIVRProfile Class See Also Send Feedback

The CfgGVPIVRProfile type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Save Method
CfgGVPIVRProfile Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.SetAccountPermissions Method
CfgGVPIVRProfile Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgGVPIVRProfile Class
CfgGVPIVRProfile Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.SetTenantDBID Method
CfgGVPIVRProfile Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPIVRProfile.SetTenantDBID(System.Int32)"]

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPIVRProfile Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile Properties
CfgGVPIVRProfile Class See Also Send Feedback

The CfgGVPIVRProfile type exposes the following members.

Properties

Name | Description
Customer | obsolete. Not in use
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | An optional short description of this GVP Voice Application Profile.
DIDs | Obsolete. Not in use
DisplayName | A name for this GVP IVR Profile that appears on the console display
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndServiceDate | The date when this GVP IVR Profile ends. This date must be the same as, or later than, the Start of Service.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsProvisioned | obsolete
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the GVP Voice Application Profile. Mandatory. Must be unique within the Tenant.
Notes | Optional notes and information relevant for this GVP Voice Application Profile.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Reseller | obsolette. Not in use
Resources |
StartServiceDate | obsolete .
State | Current object state. Mandatory. Refer to CfgObjectState
Status | obsolete
Tenant | A unique identifier of the CfgTenant to which this GVP Voice Application Profile is allocated. Populated upon creaton. Read-only
Tfn | obsolete
Type | obsolete.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Customer Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Customer Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolete. Not in use

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPCustomer Customer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Customer As CfgGVPCustomer
Visual C++
public:
property CfgGVPCustomer^ Customer {
    CfgGVPCustomer^ get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.DBID Property
CfgGVPIVRProfile Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Description Property
CfgGVPIVRProfile Class See Also Send Feedback
An optional short description of this GVP Voice Application Profile.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.DIDs Property
CfgGVPIVRProfile Class See Also Send Feedback
Obsolete. Not in use

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DIDs { get; set; }
Visual Basic (Declaration)
Public Property DIDs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DIDs {
    ICollection<CfgDN^>^ get ();
    void set (ICollection<CfgDN^>^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.DisplayName Property
CfgGVPIVRProfile Class See Also Send Feedback
A name for this GVP IVR Profile that appears on the console display

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EndServiceDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.EndServiceDate Property
CfgGVPIVRProfile Class See Also Send Feedback
The date when this GVP IVR Profile ends. This date must be the same as, or later than, the Start of Service.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime EndServiceDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndServiceDate As DateTime
Visual C++
public:
property DateTime EndServiceDate {
    DateTime get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsProvisioned Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.IsProvisioned Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolete

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsProvisioned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsProvisioned As CfgFlag
Visual C++
public:
property CfgFlag IsProvisioned {
    CfgFlag get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Name Property
CfgGVPIVRProfile Class See Also Send Feedback
A pointer to name of the GVP Voice Application Profile. Mandatory. Must be unique within the Tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Notes Property
CfgGVPIVRProfile Class See Also Send Feedback
Optional notes and information relevant for this GVP Voice Application Profile.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Reseller Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Reseller Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolette. Not in use

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPReseller Reseller { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reseller As CfgGVPReseller
Visual C++
public:
property CfgGVPReseller^ Reseller {
    CfgGVPReseller^ get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Resources Property
CfgGVPIVRProfile Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPIVRProfile.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartServiceDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.StartServiceDate Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolete .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime StartServiceDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartServiceDate As DateTime
Visual C++
public:
property DateTime StartServiceDate {
    DateTime get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.State Property
CfgGVPIVRProfile Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Status Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolete

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Tenant Property
CfgGVPIVRProfile Class See Also Send Feedback
A unique identifier of the CfgTenant to which this GVP Voice Application Profile is allocated. Populated upon creaton. Read-only

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tfn Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Tfn Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolete

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Tfn { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tfn As String
Visual C++
public:
property String^ Tfn {
    String^ get ();
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.Type Property
CfgGVPIVRProfile Class See Also Send Feedback
obsolete.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRProfileType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgIVRProfileType
Visual C++
public:
property CfgIVRProfileType Type {
    CfgIVRProfileType get ();
    void set (CfgIVRProfileType value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfile..::.UserProperties Property
CfgGVPIVRProfile Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGVPIVRProfile Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPReseller Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller Class
Members See Also Send Feedback
This object is obsolete and no longer in use.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("This object is no longer available in Configuration Server")]
public class CfgGVPReseller : CfgObject
Visual Basic (Declaration)
<ObsoleteAttribute("This object is no longer available in Configuration Server")> _
Public Class CfgGVPReseller _
    Inherits CfgObject
Visual C++
[ObsoleteAttribute(L"This object is no longer available in Configuration Server")]
public ref class CfgGVPReseller : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgGVPReseller

See Also

CfgGVPReseller Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPReseller Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller Members
CfgGVPReseller Class Constructors Methods Properties See Also Send Feedback

The CfgGVPReseller type exposes the following members.

Constructors

Name | Description
CfgGVPReseller | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
SetTimeZoneDBID
SetTimeZoneDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID |
DisplayName |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsParentNSP |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name |
Notes |
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartDate |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPReseller Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller Constructor
CfgGVPReseller Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPReseller(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgGVPReseller(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPReseller Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller Methods
CfgGVPReseller Class See Also Send Feedback

The CfgGVPReseller type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
SetTimeZoneDBID
SetTimeZoneDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.Save Method
CfgGVPReseller Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.SetAccountPermissions Method
CfgGVPReseller Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgGVPReseller Class
CfgGVPReseller Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.SetTenantDBID Method
CfgGVPReseller Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.SetTenantDBID(System.Int32)"]

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTimeZoneDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.SetTimeZoneDBID Method
CfgGVPReseller Class See Also Send Feedback
SetTimeZoneDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTimeZoneDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTimeZoneDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTimeZoneDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.SetTimeZoneDBID(System.Int32)"]

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgGVPReseller Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller Properties
CfgGVPReseller Class See Also Send Feedback

The CfgGVPReseller type exposes the following members.

Properties

Name | Description
DBID |
DisplayName |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsParentNSP |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name |
Notes |
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartDate |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.DBID Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.DisplayName Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsParentNSP Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.IsParentNSP Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.IsParentNSP"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsParentNSP { get; set; }
Visual Basic (Declaration)
Public Property IsParentNSP As CfgFlag
Visual C++
public:
property CfgFlag IsParentNSP {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.Name Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.Notes Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.Notes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.StartDate Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.StartDate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.State Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.Tenant Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.TimeZone Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.TimeZone"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As CfgTimeZone
Visual C++
public:
property CfgTimeZone^ TimeZone {
    CfgTimeZone^ get ();
    void set (CfgTimeZone^ value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPReseller..::.UserProperties Property
CfgGVPReseller Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgGVPReseller.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGVPReseller Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgHost Class

[image]

Enterprise SDK 8.0 Reference API
CfgHost Class
Members See Also Send Feedback
Hosts are the computers that run the various CTI server applications in an environment.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgHost : CfgObject
Visual Basic (Declaration)
Public Class CfgHost _
    Inherits CfgObject
Visual C++
public ref class CfgHost : public CfgObject

Remarks

A host cannot be deleted as long as there is at least one server associated with it (see CfgServer and CfgApplication ).

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgHost

See Also

CfgHost Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgHost Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHost Members
CfgHost Class Constructors Methods Properties See Also Send Feedback

The CfgHost type exposes the following members.

Constructors

Name | Description
CfgHost | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetSCSDBID
SetSCSDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Address | Not in use.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IPaddress | A pointer to the IP address of the host. Optional. Must be unique within the Configuration Database. Max length 64 symbols.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LCAPort | A port on which the Local Control Agent for this host is supposed to be running. Mandatory. Default value for migration from 5.1.xxx to 5.9.xxx is 4999, for newly created hosts the value must be specified. Allowed value is any positive whole number within 0-9999 range.
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the host. Mandatory. Must be unique within the Configuration Database. Cannot be changed as long as at least one server is assigned to this host.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OSinfo | A pointer to the structure containing information about the operating system of this host. Once specified, cannot be set to NULL. See structure CfgOS .
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources | A pointer to the list of the objects associated with this Host (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaHost , it is a pointer to a list of resources added to the existing list. Only objects of type CfgEnumerationValue , CfgScript and CfgApplication can be associated with Host object through resources
SCS | A unique identifier of an CfgApplication of CFGSCS type which is supposed to monitor/control this host. This property is valid only if Distributed SCS functionality is enabled.
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the host. Mandatory. Once specified, cannot be changed. See type CfgHostType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgHost Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgHost Constructor
CfgHost Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHost(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgHost(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgHost.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgHost.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgHost Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHost Methods
CfgHost Class See Also Send Feedback

The CfgHost type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetSCSDBID
SetSCSDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.Save Method
CfgHost Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHost..::.SetAccountPermissions Method
CfgHost Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgHost Class
CfgHost Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSCSDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.SetSCSDBID Method
CfgHost Class See Also Send Feedback
SetSCSDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSCSDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSCSDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSCSDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgHost.SetSCSDBID(System.Int32)"]

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgHost Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHost Properties
CfgHost Class See Also Send Feedback

The CfgHost type exposes the following members.

Properties

Name | Description
Address | Not in use.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IPaddress | A pointer to the IP address of the host. Optional. Must be unique within the Configuration Database. Max length 64 symbols.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LCAPort | A port on which the Local Control Agent for this host is supposed to be running. Mandatory. Default value for migration from 5.1.xxx to 5.9.xxx is 4999, for newly created hosts the value must be specified. Allowed value is any positive whole number within 0-9999 range.
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the host. Mandatory. Must be unique within the Configuration Database. Cannot be changed as long as at least one server is assigned to this host.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
OSinfo | A pointer to the structure containing information about the operating system of this host. Once specified, cannot be set to NULL. See structure CfgOS .
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources | A pointer to the list of the objects associated with this Host (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaHost , it is a pointer to a list of resources added to the existing list. Only objects of type CfgEnumerationValue , CfgScript and CfgApplication can be associated with Host object through resources
SCS | A unique identifier of an CfgApplication of CFGSCS type which is supposed to monitor/control this host. This property is valid only if Distributed SCS functionality is enabled.
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the host. Mandatory. Once specified, cannot be changed. See type CfgHostType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.Address Property
CfgHost Class See Also Send Feedback
Not in use.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
    void set (CfgAddress^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.DBID Property
CfgHost Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IPaddress Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.IPaddress Property
CfgHost Class See Also Send Feedback
A pointer to the IP address of the host. Optional. Must be unique within the Configuration Database. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string IPaddress { get; set; }
Visual Basic (Declaration)
Public Property IPaddress As String
Visual C++
public:
property String^ IPaddress {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LCAPort Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.LCAPort Property
CfgHost Class See Also Send Feedback
A port on which the Local Control Agent for this host is supposed to be running. Mandatory. Default value for migration from 5.1.xxx to 5.9.xxx is 4999, for newly created hosts the value must be specified. Allowed value is any positive whole number within 0-9999 range.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LCAPort { get; set; }
Visual Basic (Declaration)
Public Property LCAPort As String
Visual C++
public:
property String^ LCAPort {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.Name Property
CfgHost Class See Also Send Feedback
A pointer to name of the host. Mandatory. Must be unique within the Configuration Database. Cannot be changed as long as at least one server is assigned to this host.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OSinfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.OSinfo Property
CfgHost Class See Also Send Feedback
A pointer to the structure containing information about the operating system of this host. Once specified, cannot be set to NULL. See structure CfgOS .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOS OSinfo { get; set; }
Visual Basic (Declaration)
Public Property OSinfo As CfgOS
Visual C++
public:
property CfgOS^ OSinfo {
    CfgOS^ get ();
    void set (CfgOS^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.Resources Property
CfgHost Class See Also Send Feedback
A pointer to the list of the objects associated with this Host (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaHost , it is a pointer to a list of resources added to the existing list. Only objects of type CfgEnumerationValue , CfgScript and CfgApplication can be associated with Host object through resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SCS Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.SCS Property
CfgHost Class See Also Send Feedback
A unique identifier of an CfgApplication of CFGSCS type which is supposed to monitor/control this host. This property is valid only if Distributed SCS functionality is enabled.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication SCS { get; set; }
Visual Basic (Declaration)
Public Property SCS As CfgApplication
Visual C++
public:
property CfgApplication^ SCS {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.State Property
CfgHost Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.Type Property
CfgHost Class See Also Send Feedback
Type of the host. Mandatory. Once specified, cannot be changed. See type CfgHostType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHostType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgHostType
Visual C++
public:
property CfgHostType Type {
    CfgHostType get ();
    void set (CfgHostType value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgHost..::.UserProperties Property
CfgHost Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgHost Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgID Class

[image]

Enterprise SDK 8.0 Reference API
CfgID Class
Members See Also Send Feedback
CfgID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgID : CfgStructure
Visual Basic (Declaration)
Public Class CfgID _
    Inherits CfgStructure
Visual C++
public ref class CfgID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgID

See Also

CfgID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgID Members
CfgID Class Constructors Methods Properties See Also Send Feedback

The CfgID type exposes the following members.

Constructors

Name | Description
CfgID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID | A unique identifier of the object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type | An object's type. See CfgObjectType

See Also

CfgID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgID Constructor
CfgID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgID Methods
CfgID Class See Also Send Feedback

The CfgID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgID Properties
CfgID Class See Also Send Feedback

The CfgID type exposes the following members.

Properties

Name | Description
DBID | A unique identifier of the object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type | An object's type. See CfgObjectType

See Also

CfgID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgID..::.DBID Property
CfgID Class See Also Send Feedback
A unique identifier of the object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgID..::.Type Property
CfgID Class See Also Send Feedback
An object's type. See CfgObjectType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVR Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVR Class
Members See Also Send Feedback
An IVR (Interactive Voice Response) is a telephony object that contains IVR Ports; it is controlled through IVR interface drivers.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVR : CfgObject
Visual Basic (Declaration)
Public Class CfgIVR _
    Inherits CfgObject
Visual C++
public ref class CfgIVR : public CfgObject

Remarks

Deletion of IVR X will cause the following events set out in the order of arrival: Deletion of all IVR Ports of IVR X Deletion of all folders that had IVR X defined as the parent object Deletion of IVR X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgIVR

See Also

CfgIVR Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVR Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVR Members
CfgIVR Class Constructors Methods Properties See Also Send Feedback

The CfgIVR type exposes the following members.

Constructors

Name | Description
CfgIVR | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetIVRServerDBID
SetIVRServerDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the IVR.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRServer | A unique identifier of the CfgApplication of CfgIVRInterfaceServer type permanently associated to serve this IVR.
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the IVR. Mandatory. Must be unique within configuration database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this IVR belongs. Once specified cannot be changed.
Type | Type of this IVR. See type CfgIVRType . Mandatory. Once specified cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the version of the IVR. Mandatory.

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVR Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVR Constructor
CfgIVR Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVR(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgIVR(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVR.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVR.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVR Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVR Methods
CfgIVR Class See Also Send Feedback

The CfgIVR type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetIVRServerDBID
SetIVRServerDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.Save Method
CfgIVR Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.SetAccountPermissions Method
CfgIVR Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgIVR Class
CfgIVR Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetIVRServerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.SetIVRServerDBID Method
CfgIVR Class See Also Send Feedback
SetIVRServerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetIVRServerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetIVRServerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetIVRServerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVR.SetIVRServerDBID(System.Int32)"]

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.SetTenantDBID Method
CfgIVR Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVR.SetTenantDBID(System.Int32)"]

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVR Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVR Properties
CfgIVR Class See Also Send Feedback

The CfgIVR type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the IVR.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVRServer | A unique identifier of the CfgApplication of CfgIVRInterfaceServer type permanently associated to serve this IVR.
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the IVR. Mandatory. Must be unique within configuration database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this IVR belongs. Once specified cannot be changed.
Type | Type of this IVR. See type CfgIVRType . Mandatory. Once specified cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the version of the IVR. Mandatory.

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.DBID Property
CfgIVR Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.Description Property
CfgIVR Class See Also Send Feedback
A pointer to the description of the IVR.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IVRServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.IVRServer Property
CfgIVR Class See Also Send Feedback
A unique identifier of the CfgApplication of CfgIVRInterfaceServer type permanently associated to serve this IVR.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication IVRServer { get; set; }
Visual Basic (Declaration)
Public Property IVRServer As CfgApplication
Visual C++
public:
property CfgApplication^ IVRServer {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.Name Property
CfgIVR Class See Also Send Feedback
A pointer to the name of the IVR. Mandatory. Must be unique within configuration database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.State Property
CfgIVR Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.Tenant Property
CfgIVR Class See Also Send Feedback
A unique identifier of the CfgTenant to which this IVR belongs. Once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.Type Property
CfgIVR Class See Also Send Feedback
Type of this IVR. See type CfgIVRType . Mandatory. Once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgIVRType
Visual C++
public:
property CfgIVRType Type {
    CfgIVRType get ();
    void set (CfgIVRType value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.UserProperties Property
CfgIVR Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVR..::.Version Property
CfgIVR Class See Also Send Feedback
A pointer to the version of the IVR. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVR Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVRPort Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort Class
Members See Also Send Feedback
An Interactive Voice Response (IVR) Port is a telephony object uniquely identified by the numbers within an IVR at which telephone calls may reside and be handled.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVRPort : CfgObject
Visual Basic (Declaration)
Public Class CfgIVRPort _
    Inherits CfgObject
Visual C++
public ref class CfgIVRPort : public CfgObject

Remarks

An IVR port can only be associated with one IVR.

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgIVRPort

See Also

CfgIVRPort Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVRPort Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPort Members
CfgIVRPort Class Constructors Methods Properties See Also Send Feedback

The CfgIVRPort type exposes the following members.

Constructors

Name | Description
CfgIVRPort | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDNDBID
SetDNDBID
SetIVRDBID
SetIVRDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the string describing IVR port.
DN | A unique identifier of CfgDN associated with this IVR port.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVR | A unique identifier of CfgIVR this IVR port belongs to. Mandatory. Once specified, can not be changed
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PortNumber | A pointer to the string, representing number associated with channel on IVR. Mandatory. Must be unique within one IVR. Once specified cannot be changed.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this IVR port belongs. Read-only (set automatically according to the current value of tenantDBID of the IVR specified in IVRDBID). See type CfgIVR .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVRPort Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort Constructor
CfgIVRPort Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRPort(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgIVRPort(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVRPort.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVRPort.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVRPort Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPort Methods
CfgIVRPort Class See Also Send Feedback

The CfgIVRPort type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDNDBID
SetDNDBID
SetIVRDBID
SetIVRDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.Save Method
CfgIVRPort Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.SetAccountPermissions Method
CfgIVRPort Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgIVRPort Class
CfgIVRPort Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.SetDNDBID Method
CfgIVRPort Class See Also Send Feedback
SetDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVRPort.SetDNDBID(System.Int32)"]

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetIVRDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.SetIVRDBID Method
CfgIVRPort Class See Also Send Feedback
SetIVRDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetIVRDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetIVRDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetIVRDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVRPort.SetIVRDBID(System.Int32)"]

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.SetTenantDBID Method
CfgIVRPort Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgIVRPort.SetTenantDBID(System.Int32)"]

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgIVRPort Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPort Properties
CfgIVRPort Class See Also Send Feedback

The CfgIVRPort type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the string describing IVR port.
DN | A unique identifier of CfgDN associated with this IVR port.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
IVR | A unique identifier of CfgIVR this IVR port belongs to. Mandatory. Once specified, can not be changed
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PortNumber | A pointer to the string, representing number associated with channel on IVR. Mandatory. Must be unique within one IVR. Once specified cannot be changed.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this IVR port belongs. Read-only (set automatically according to the current value of tenantDBID of the IVR specified in IVRDBID). See type CfgIVR .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.DBID Property
CfgIVRPort Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.Description Property
CfgIVRPort Class See Also Send Feedback
A pointer to the string describing IVR port.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DN Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.DN Property
CfgIVRPort Class See Also Send Feedback
A unique identifier of CfgDN associated with this IVR port.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN DN { get; set; }
Visual Basic (Declaration)
Public Property DN As CfgDN
Visual C++
public:
property CfgDN^ DN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IVR Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.IVR Property
CfgIVRPort Class See Also Send Feedback
A unique identifier of CfgIVR this IVR port belongs to. Mandatory. Once specified, can not be changed

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVR IVR { get; set; }
Visual Basic (Declaration)
Public Property IVR As CfgIVR
Visual C++
public:
property CfgIVR^ IVR {
    CfgIVR^ get ();
    void set (CfgIVR^ value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PortNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.PortNumber Property
CfgIVRPort Class See Also Send Feedback
A pointer to the string, representing number associated with channel on IVR. Mandatory. Must be unique within one IVR. Once specified cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PortNumber { get; set; }
Visual Basic (Declaration)
Public Property PortNumber As String
Visual C++
public:
property String^ PortNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.State Property
CfgIVRPort Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.Tenant Property
CfgIVRPort Class See Also Send Feedback
A unique identifier of the CfgTenant to which this IVR port belongs. Read-only (set automatically according to the current value of tenantDBID of the IVR specified in IVRDBID). See type CfgIVR .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPort..::.UserProperties Property
CfgIVRPort Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgIVRPort Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgMemberID Class

[image]

Enterprise SDK 8.0 Reference API
CfgMemberID Class
Members See Also Send Feedback
CfgMemberID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgMemberID : CfgStructure
Visual Basic (Declaration)
Public Class CfgMemberID _
    Inherits CfgStructure
Visual C++
public ref class CfgMemberID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgMemberID

See Also

CfgMemberID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgMemberID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberID Members
CfgMemberID Class Constructors Methods Properties See Also Send Feedback

The CfgMemberID type exposes the following members.

Constructors

Name | Description
CfgMemberID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgMemberID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgMemberID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgMemberID Constructor
CfgMemberID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgMemberID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgMemberID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgMemberID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgMemberID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgMemberID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgMemberID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgMemberID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberID Methods
CfgMemberID Class See Also Send Feedback

The CfgMemberID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgMemberID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgMemberID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberID Properties
CfgMemberID Class See Also Send Feedback

The CfgMemberID type exposes the following members.

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgMemberID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgMemberID..::.DBID Property
CfgMemberID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgMemberID.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgMemberID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgMemberID..::.Type Property
CfgMemberID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgMemberID.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
}

See Also

CfgMemberID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectID Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectID Class
Members See Also Send Feedback
CfgObjectID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectID : CfgStructure
Visual Basic (Declaration)
Public Class CfgObjectID _
    Inherits CfgStructure
Visual C++
public ref class CfgObjectID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectID

See Also

CfgObjectID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectID Members
CfgObjectID Class Constructors Methods Properties See Also Send Feedback

The CfgObjectID type exposes the following members.

Constructors

Name | Description
CfgObjectID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgObjectID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectID Constructor
CfgObjectID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgObjectID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgObjectID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectID Methods
CfgObjectID Class See Also Send Feedback

The CfgObjectID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgObjectID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectID Properties
CfgObjectID Class See Also Send Feedback

The CfgObjectID type exposes the following members.

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgObjectID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectID..::.DBID Property
CfgObjectID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectID.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectID..::.Type Property
CfgObjectID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectID.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgObjectID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTable Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable Class
Members See Also Send Feedback
Objective Tables are collections of Objective Records.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTable : CfgObject
Visual Basic (Declaration)
Public Class CfgObjectiveTable _
    Inherits CfgObject
Visual C++
public ref class CfgObjectiveTable : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectiveTable

See Also

CfgObjectiveTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTable Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable Members
CfgObjectiveTable Class Constructors Methods Properties See Also Send Feedback

The CfgObjectiveTable type exposes the following members.

Constructors

Name | Description
CfgObjectiveTable | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
SetTimeZoneDBID
SetTimeZoneDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the objective table.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the objective table. Mandatory. Must be unique within the tenant environment.
ObjectDbid | (Inherited from CfgObject.)
ObjectiveRecords | A pointer to the list of identifiers of objective records comprising this objective table.
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PrepaidCost | A flat rate for the cost per call
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this objective table is allocated. Mandatory. Once specified, cannot be changed.
TimeEnd | The date on which to end the Volume Rate Contract.
TimeStart | The date on which to start the Volume Rate Contract.
TimeZone | A CfgTimeZone associated with this Cost Contract
Type | Objective Table type. Refer to CfgObjectiveTableType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTable Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable Constructor
CfgObjectiveTable Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgObjectiveTable(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTable.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTable.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTable Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable Methods
CfgObjectiveTable Class See Also Send Feedback

The CfgObjectiveTable type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
SetTimeZoneDBID
SetTimeZoneDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.Save Method
CfgObjectiveTable Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.SetAccountPermissions Method
CfgObjectiveTable Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgObjectiveTable Class
CfgObjectiveTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.SetTenantDBID Method
CfgObjectiveTable Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTable.SetTenantDBID(System.Int32)"]

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTimeZoneDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.SetTimeZoneDBID Method
CfgObjectiveTable Class See Also Send Feedback
SetTimeZoneDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTimeZoneDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTimeZoneDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTimeZoneDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTable.SetTimeZoneDBID(System.Int32)"]

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable Properties
CfgObjectiveTable Class See Also Send Feedback

The CfgObjectiveTable type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the description of the objective table.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the objective table. Mandatory. Must be unique within the tenant environment.
ObjectDbid | (Inherited from CfgObject.)
ObjectiveRecords | A pointer to the list of identifiers of objective records comprising this objective table.
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PrepaidCost | A flat rate for the cost per call
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this objective table is allocated. Mandatory. Once specified, cannot be changed.
TimeEnd | The date on which to end the Volume Rate Contract.
TimeStart | The date on which to start the Volume Rate Contract.
TimeZone | A CfgTimeZone associated with this Cost Contract
Type | Objective Table type. Refer to CfgObjectiveTableType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.DBID Property
CfgObjectiveTable Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.Description Property
CfgObjectiveTable Class See Also Send Feedback
A pointer to the description of the objective table.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.Name Property
CfgObjectiveTable Class See Also Send Feedback
A pointer to the name of the objective table. Mandatory. Must be unique within the tenant environment.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectiveRecords Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.ObjectiveRecords Property
CfgObjectiveTable Class See Also Send Feedback
A pointer to the list of identifiers of objective records comprising this objective table.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectiveTableRecord> ObjectiveRecords { get; set; }
Visual Basic (Declaration)
Public Property ObjectiveRecords As ICollection(Of CfgObjectiveTableRecord)
Visual C++
public:
property ICollection<CfgObjectiveTableRecord^>^ ObjectiveRecords {
    ICollection<CfgObjectiveTableRecord^>^ get ();
    void set (ICollection<CfgObjectiveTableRecord^>^ value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PrepaidCost Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.PrepaidCost Property
CfgObjectiveTable Class See Also Send Feedback
A flat rate for the cost per call

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int PrepaidCost { get; set; }
Visual Basic (Declaration)
Public Property PrepaidCost As Integer
Visual C++
public:
property int PrepaidCost {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.State Property
CfgObjectiveTable Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.Tenant Property
CfgObjectiveTable Class See Also Send Feedback
A unique identifier of the CfgTenant to which this objective table is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeEnd Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.TimeEnd Property
CfgObjectiveTable Class See Also Send Feedback
The date on which to end the Volume Rate Contract.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime TimeEnd { get; set; }
Visual Basic (Declaration)
Public Property TimeEnd As DateTime
Visual C++
public:
property DateTime TimeEnd {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeStart Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.TimeStart Property
CfgObjectiveTable Class See Also Send Feedback
The date on which to start the Volume Rate Contract.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime TimeStart { get; set; }
Visual Basic (Declaration)
Public Property TimeStart As DateTime
Visual C++
public:
property DateTime TimeStart {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.TimeZone Property
CfgObjectiveTable Class See Also Send Feedback
A CfgTimeZone associated with this Cost Contract

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As CfgTimeZone
Visual C++
public:
property CfgTimeZone^ TimeZone {
    CfgTimeZone^ get ();
    void set (CfgTimeZone^ value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.Type Property
CfgObjectiveTable Class See Also Send Feedback
Objective Table type. Refer to CfgObjectiveTableType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectiveTableType
Visual C++
public:
property CfgObjectiveTableType Type {
    CfgObjectiveTableType get ();
    void set (CfgObjectiveTableType value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTable..::.UserProperties Property
CfgObjectiveTable Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgObjectiveTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTableRecord Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord Class
Members See Also Send Feedback
CfgObjectiveTableRecord

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTableRecord : CfgStructure
Visual Basic (Declaration)
Public Class CfgObjectiveTableRecord _
    Inherits CfgStructure
Visual C++
public ref class CfgObjectiveTableRecord : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectiveTableRecord

See Also

CfgObjectiveTableRecord Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTableRecord Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord Members
CfgObjectiveTableRecord Class Constructors Methods Properties See Also Send Feedback

The CfgObjectiveTableRecord type exposes the following members.

Constructors

Name | Description
CfgObjectiveTableRecord | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetContractDBID | SetContractDBID
SetCustomerSegmentDBID | SetCustomerSegmentDBID
SetMediaTypeDBID | SetMediaTypeDBID
SetServiceTypeDBID | SetServiceTypeDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Contract | An IT Contract associated with this Objective Record.
CustomerSegment | A unique identifier of the Customer Segment this objective table record is associated with. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name CustomerSegment are allowed in this field.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MediaType | A unique identifier of the Media Type to which this objective table record is allocated. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name MediaType are allowed in this field.
ObjectiveDelta | An objective delta value for this record. Defines the step of objective threshold deviation
ObjectiveThreshold |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ServiceType | A unique identifier of the Service Type this objective table record is associated with. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name ServiceType are allowed in this field.

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTableRecord Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord Constructor
CfgObjectiveTableRecord Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableRecord(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgObjectiveTableRecord(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTableRecord Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord Methods
CfgObjectiveTableRecord Class See Also Send Feedback

The CfgObjectiveTableRecord type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetContractDBID | SetContractDBID
SetCustomerSegmentDBID | SetCustomerSegmentDBID
SetMediaTypeDBID | SetMediaTypeDBID
SetServiceTypeDBID | SetServiceTypeDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetContractDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.SetContractDBID Method
CfgObjectiveTableRecord Class See Also Send Feedback
SetContractDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetContractDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetContractDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetContractDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.SetContractDBID(System.Int32)"]

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCustomerSegmentDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.SetCustomerSegmentDBID Method
CfgObjectiveTableRecord Class See Also Send Feedback
SetCustomerSegmentDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCustomerSegmentDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCustomerSegmentDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCustomerSegmentDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.SetCustomerSegmentDBID(System.Int32)"]

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetMediaTypeDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.SetMediaTypeDBID Method
CfgObjectiveTableRecord Class See Also Send Feedback
SetMediaTypeDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetMediaTypeDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetMediaTypeDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetMediaTypeDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.SetMediaTypeDBID(System.Int32)"]

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetServiceTypeDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.SetServiceTypeDBID Method
CfgObjectiveTableRecord Class See Also Send Feedback
SetServiceTypeDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetServiceTypeDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetServiceTypeDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetServiceTypeDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.SetServiceTypeDBID(System.Int32)"]

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectiveTableRecord Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord Properties
CfgObjectiveTableRecord Class See Also Send Feedback

The CfgObjectiveTableRecord type exposes the following members.

Properties

Name | Description
Contract | An IT Contract associated with this Objective Record.
CustomerSegment | A unique identifier of the Customer Segment this objective table record is associated with. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name CustomerSegment are allowed in this field.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MediaType | A unique identifier of the Media Type to which this objective table record is allocated. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name MediaType are allowed in this field.
ObjectiveDelta | An objective delta value for this record. Defines the step of objective threshold deviation
ObjectiveThreshold |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ServiceType | A unique identifier of the Service Type this objective table record is associated with. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name ServiceType are allowed in this field.

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.Contract Property
CfgObjectiveTableRecord Class See Also Send Feedback
An IT Contract associated with this Objective Record.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTable Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As CfgStatTable
Visual C++
public:
property CfgStatTable^ Contract {
    CfgStatTable^ get ();
    void set (CfgStatTable^ value);
}

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CustomerSegment Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.CustomerSegment Property
CfgObjectiveTableRecord Class See Also Send Feedback
A unique identifier of the Customer Segment this objective table record is associated with. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name CustomerSegment are allowed in this field.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValue CustomerSegment { get; set; }
Visual Basic (Declaration)
Public Property CustomerSegment As CfgEnumeratorValue
Visual C++
public:
property CfgEnumeratorValue^ CustomerSegment {
    CfgEnumeratorValue^ get ();
    void set (CfgEnumeratorValue^ value);
}

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.MediaType Property
CfgObjectiveTableRecord Class See Also Send Feedback
A unique identifier of the Media Type to which this objective table record is allocated. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name MediaType are allowed in this field.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValue MediaType { get; set; }
Visual Basic (Declaration)
Public Property MediaType As CfgEnumeratorValue
Visual C++
public:
property CfgEnumeratorValue^ MediaType {
    CfgEnumeratorValue^ get ();
    void set (CfgEnumeratorValue^ value);
}

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectiveDelta Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.ObjectiveDelta Property
CfgObjectiveTableRecord Class See Also Send Feedback
An objective delta value for this record. Defines the step of objective threshold deviation

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectiveDelta { get; set; }
Visual Basic (Declaration)
Public Property ObjectiveDelta As Integer
Visual C++
public:
property int ObjectiveDelta {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectiveThreshold Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.ObjectiveThreshold Property
CfgObjectiveTableRecord Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectiveTableRecord.ObjectiveThreshold"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectiveThreshold { get; set; }
Visual Basic (Declaration)
Public Property ObjectiveThreshold As Integer
Visual C++
public:
property int ObjectiveThreshold {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ServiceType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecord..::.ServiceType Property
CfgObjectiveTableRecord Class See Also Send Feedback
A unique identifier of the Service Type this objective table record is associated with. Mandatory. Once specified, cannot be changed. Only enumerator values belonging to the enumerator with name ServiceType are allowed in this field.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValue ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As CfgEnumeratorValue
Visual C++
public:
property CfgEnumeratorValue^ ServiceType {
    CfgEnumeratorValue^ get ();
    void set (CfgEnumeratorValue^ value);
}

See Also

CfgObjectiveTableRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectResource Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource Class
Members See Also Send Feedback
CfgObjectResource

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectResource : CfgStructure
Visual Basic (Declaration)
Public Class CfgObjectResource _
    Inherits CfgStructure
Visual C++
public ref class CfgObjectResource : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgObjectResource

See Also

CfgObjectResource Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectResource Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResource Members
CfgObjectResource Class Constructors Methods Properties See Also Send Feedback

The CfgObjectResource type exposes the following members.

Constructors

Name | Description
CfgObjectResource | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
CharField1 | Optional text field #1
CharField2 | Optional text field #2
CharField3 | Optional text field #3
CharField4 | Optional text field #4
Description | Optional description of the resource
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LongField1 | Optional integer field #1
LongField2 | Optional integer field #2
LongField3 | Optional integer field #3
LongField4 | Optional integer field #3
ObjectDBID | An identifier of the object referred by this resource. Type of the object is defined by objectType property
ObjectType | Type of the object referred by this resource. See type CfgObjectType . Mandatory.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ResourceType | Type of the resource. See type CfgResourceType . Mandatory.

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectResource Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource Constructor
CfgObjectResource Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectResource(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgObjectResource(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectResource.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectResource.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgObjectResource.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectResource Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResource Methods
CfgObjectResource Class See Also Send Feedback

The CfgObjectResource type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgObjectResource Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResource Properties
CfgObjectResource Class See Also Send Feedback

The CfgObjectResource type exposes the following members.

Properties

Name | Description
CharField1 | Optional text field #1
CharField2 | Optional text field #2
CharField3 | Optional text field #3
CharField4 | Optional text field #4
Description | Optional description of the resource
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LongField1 | Optional integer field #1
LongField2 | Optional integer field #2
LongField3 | Optional integer field #3
LongField4 | Optional integer field #3
ObjectDBID | An identifier of the object referred by this resource. Type of the object is defined by objectType property
ObjectType | Type of the object referred by this resource. See type CfgObjectType . Mandatory.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ResourceType | Type of the resource. See type CfgResourceType . Mandatory.

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.CharField1 Property
CfgObjectResource Class See Also Send Feedback
Optional text field #1

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField1 { get; set; }
Visual Basic (Declaration)
Public Property CharField1 As String
Visual C++
public:
property String^ CharField1 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.CharField2 Property
CfgObjectResource Class See Also Send Feedback
Optional text field #2

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField2 { get; set; }
Visual Basic (Declaration)
Public Property CharField2 As String
Visual C++
public:
property String^ CharField2 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.CharField3 Property
CfgObjectResource Class See Also Send Feedback
Optional text field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField3 { get; set; }
Visual Basic (Declaration)
Public Property CharField3 As String
Visual C++
public:
property String^ CharField3 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.CharField4 Property
CfgObjectResource Class See Also Send Feedback
Optional text field #4

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField4 { get; set; }
Visual Basic (Declaration)
Public Property CharField4 As String
Visual C++
public:
property String^ CharField4 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.Description Property
CfgObjectResource Class See Also Send Feedback
Optional description of the resource

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.LongField1 Property
CfgObjectResource Class See Also Send Feedback
Optional integer field #1

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField1 { get; set; }
Visual Basic (Declaration)
Public Property LongField1 As Integer
Visual C++
public:
property int LongField1 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.LongField2 Property
CfgObjectResource Class See Also Send Feedback
Optional integer field #2

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField2 { get; set; }
Visual Basic (Declaration)
Public Property LongField2 As Integer
Visual C++
public:
property int LongField2 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.LongField3 Property
CfgObjectResource Class See Also Send Feedback
Optional integer field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField3 { get; set; }
Visual Basic (Declaration)
Public Property LongField3 As Integer
Visual C++
public:
property int LongField3 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.LongField4 Property
CfgObjectResource Class See Also Send Feedback
Optional integer field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField4 { get; set; }
Visual Basic (Declaration)
Public Property LongField4 As Integer
Visual C++
public:
property int LongField4 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.ObjectDBID Property
CfgObjectResource Class See Also Send Feedback
An identifier of the object referred by this resource. Type of the object is defined by objectType property

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDBID { get; set; }
Visual Basic (Declaration)
Public Property ObjectDBID As Integer
Visual C++
public:
property int ObjectDBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.ObjectType Property
CfgObjectResource Class See Also Send Feedback
Type of the object referred by this resource. See type CfgObjectType . Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ResourceType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResource..::.ResourceType Property
CfgObjectResource Class See Also Send Feedback
Type of the resource. See type CfgResourceType . Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgResourceType ResourceType { get; set; }
Visual Basic (Declaration)
Public Property ResourceType As CfgResourceType
Visual C++
public:
property CfgResourceType ResourceType {
    CfgResourceType get ();
    void set (CfgResourceType value);
}

See Also

CfgObjectResource Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOS Class

[image]

Enterprise SDK 8.0 Reference API
CfgOS Class
Members See Also Send Feedback
CfgOS

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgOS : CfgStructure
Visual Basic (Declaration)
Public Class CfgOS _
    Inherits CfgStructure
Visual C++
public ref class CfgOS : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgOS

See Also

CfgOS Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOS Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOS Members
CfgOS Class Constructors Methods Properties See Also Send Feedback

The CfgOS type exposes the following members.

Constructors

Name | Description
CfgOS | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
OStype | Type of the operating system. See type CfgOSType . Mandatory.
OSversion | A pointer to the version of the operating system.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgOS Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOS Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgOS Constructor
CfgOS Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOS(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgOS(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOS.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOS.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOS.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgOS Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOS Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOS Methods
CfgOS Class See Also Send Feedback

The CfgOS type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgOS Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOS Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOS Properties
CfgOS Class See Also Send Feedback

The CfgOS type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
OStype | Type of the operating system. See type CfgOSType . Mandatory.
OSversion | A pointer to the version of the operating system.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgOS Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OStype Property

[image]

Enterprise SDK 8.0 Reference API
CfgOS..::.OStype Property
CfgOS Class See Also Send Feedback
Type of the operating system. See type CfgOSType . Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOSType OStype { get; set; }
Visual Basic (Declaration)
Public Property OStype As CfgOSType
Visual C++
public:
property CfgOSType OStype {
    CfgOSType get ();
    void set (CfgOSType value);
}

See Also

CfgOS Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


OSversion Property

[image]

Enterprise SDK 8.0 Reference API
CfgOS..::.OSversion Property
CfgOS Class See Also Send Feedback
A pointer to the version of the operating system.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string OSversion { get; set; }
Visual Basic (Declaration)
Public Property OSversion As String
Visual C++
public:
property String^ OSversion {
    String^ get ();
    void set (String^ value);
}

See Also

CfgOS Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOwnerID Class

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerID Class
Members See Also Send Feedback
CfgOwnerID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgOwnerID : CfgStructure
Visual Basic (Declaration)
Public Class CfgOwnerID _
    Inherits CfgStructure
Visual C++
public ref class CfgOwnerID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgOwnerID

See Also

CfgOwnerID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOwnerID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerID Members
CfgOwnerID Class Constructors Methods Properties See Also Send Feedback

The CfgOwnerID type exposes the following members.

Constructors

Name | Description
CfgOwnerID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgOwnerID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOwnerID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerID Constructor
CfgOwnerID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOwnerID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgOwnerID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOwnerID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOwnerID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOwnerID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgOwnerID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOwnerID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerID Methods
CfgOwnerID Class See Also Send Feedback

The CfgOwnerID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgOwnerID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgOwnerID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerID Properties
CfgOwnerID Class See Also Send Feedback

The CfgOwnerID type exposes the following members.

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgOwnerID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerID..::.DBID Property
CfgOwnerID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOwnerID.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgOwnerID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerID..::.Type Property
CfgOwnerID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgOwnerID.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgOwnerID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgParentID Class

[image]

Enterprise SDK 8.0 Reference API
CfgParentID Class
Members See Also Send Feedback
CfgParentID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgParentID : CfgStructure
Visual Basic (Declaration)
Public Class CfgParentID _
    Inherits CfgStructure
Visual C++
public ref class CfgParentID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgParentID

See Also

CfgParentID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgParentID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentID Members
CfgParentID Class Constructors Methods Properties See Also Send Feedback

The CfgParentID type exposes the following members.

Constructors

Name | Description
CfgParentID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgParentID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgParentID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgParentID Constructor
CfgParentID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgParentID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgParentID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgParentID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgParentID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgParentID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgParentID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgParentID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentID Methods
CfgParentID Class See Also Send Feedback

The CfgParentID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgParentID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgParentID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentID Properties
CfgParentID Class See Also Send Feedback

The CfgParentID type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgParentID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPerson Class

[image]

Enterprise SDK 8.0 Reference API
CfgPerson Class
Members See Also Send Feedback
Persons correspond to contact center personnel___including agents___who need access to CTI applications. The Genesys Framework requires that every person who needs such access be registered in the Configuration Database with an appropriate set of privileges.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPerson : CfgObject
Visual Basic (Declaration)
Public Class CfgPerson _
    Inherits CfgObject
Visual C++
public ref class CfgPerson : public CfgObject

Remarks

Whether a new person is an agent or not shall be specified at the time when the corresponding CfgPerson object is created. It is not possible to change person's status from a non-agent to an agent (or the other way around) once the CfgPerson object has been created. Deletion of Person X will cause the following events set out in the order of arrival: Modification of agentDBIDs of all agent groups that included Person X as an agent Modification of memberIDs of all access groups that included Person X as a member Deletion of Person X A person cannot be deleted as long as it is associated as an account with at least one daemon application (See CfgApplication and ConfSetAccount). By default, access privileges of a new person will be set according to the following rules: Any non-agent of the Service Provider becomes a member of the default access group Administrators of the Service Provider. Any agent of the Service Provider becomes a member of the default access group Users of the Service Provider. Any non-agent of a particular tenant becomes a member of the default access group Administrators of that tenant. Any agent of a particular tenant becomes a member of the default access group Users of that tenant. Any person added to the Configuration Database is also considered a member of the access group Everyone, which cannot be changed. For specification of access privileges of the above default groups, refer to comments to object CfgAccessGroup in section Access Control Functions and Data Types. Person with DBID = 100 and tenantDBID = 1 shall be pre-defined (scripted) in the Configuration Database before Configuration Server is started for the first time. This person has Full Control permissions with respect to all objects in the Configuration Database, which cannot be changed. The object that represents this person cannot be deleted.

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPerson

See Also

CfgPerson Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPerson Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPerson Members
CfgPerson Class Constructors Methods Properties See Also Send Feedback

The CfgPerson type exposes the following members.

Constructors

Name | Description
CfgPerson | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Address | Not in use.
AgentInfo | A pointer to the structure containing agent-specific information. See structure CfgAgentInfo . Shall be specified if the person is an agent and shall be set to NULL otherwise. Once specified, cannot be set to NULL.
AppRanks | A pointer to the list of the person's ranks with respect to applications (every item of this list is structured as CfgAppRank ). When used as an entry in CfgDeltaPerson (see below), it is a pointer to a list of the ranks added to the existing list.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
EmailAddress | A pointer to the email address of this person. Max length 255 symbols.
EmployeeID | A pointer to the code identifying this person within the tenant staff. Mandatory. Must be unique within the tenant. Max length 64 symbols.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExternalID | A pointer to the string used to identify this person in the external systems. In particular, this field used to store an identifier processed during the authentication in the LDAP repositories.Max length 255 symbols.
FirstName | A pointer to the person's first name. Max length 64 symbols.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAgent | An indicator of whether the person is an agent. Read-only (set automatically according to the current value of agentInfo below). See type CfgFlag.
IsExternalAuth | This field should reflect authentication method that used for the Person. If external authentication is used this flag should be equal to CFGTrue.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LastName | A pointer to the person's last name. Max length 64 symbols.
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | A pointer to the password the person uses to log into a CTI system. Max length 64 symbols.
Phones | Not in use.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant whose employee this person is. Once specified, cannot be changed.
UserName | A pointer to the name the person uses to log into a CTI system. Mandatory. Must be unique within the Configuration Database.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPerson Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPerson Constructor
CfgPerson Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPerson(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgPerson(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPerson.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPerson.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPerson Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPerson Methods
CfgPerson Class See Also Send Feedback

The CfgPerson type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.Save Method
CfgPerson Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.SetAccountPermissions Method
CfgPerson Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgPerson Class
CfgPerson Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.SetTenantDBID Method
CfgPerson Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPerson.SetTenantDBID(System.Int32)"]

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPerson Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPerson Properties
CfgPerson Class See Also Send Feedback

The CfgPerson type exposes the following members.

Properties

Name | Description
Address | Not in use.
AgentInfo | A pointer to the structure containing agent-specific information. See structure CfgAgentInfo . Shall be specified if the person is an agent and shall be set to NULL otherwise. Once specified, cannot be set to NULL.
AppRanks | A pointer to the list of the person's ranks with respect to applications (every item of this list is structured as CfgAppRank ). When used as an entry in CfgDeltaPerson (see below), it is a pointer to a list of the ranks added to the existing list.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
EmailAddress | A pointer to the email address of this person. Max length 255 symbols.
EmployeeID | A pointer to the code identifying this person within the tenant staff. Mandatory. Must be unique within the tenant. Max length 64 symbols.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExternalID | A pointer to the string used to identify this person in the external systems. In particular, this field used to store an identifier processed during the authentication in the LDAP repositories.Max length 255 symbols.
FirstName | A pointer to the person's first name. Max length 64 symbols.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsAgent | An indicator of whether the person is an agent. Read-only (set automatically according to the current value of agentInfo below). See type CfgFlag.
IsExternalAuth | This field should reflect authentication method that used for the Person. If external authentication is used this flag should be equal to CFGTrue.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LastName | A pointer to the person's last name. Max length 64 symbols.
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Password | A pointer to the password the person uses to log into a CTI system. Max length 64 symbols.
Phones | Not in use.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant whose employee this person is. Once specified, cannot be changed.
UserName | A pointer to the name the person uses to log into a CTI system. Mandatory. Must be unique within the Configuration Database.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.Address Property
CfgPerson Class See Also Send Feedback
Not in use.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
    void set (CfgAddress^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AgentInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.AgentInfo Property
CfgPerson Class See Also Send Feedback
A pointer to the structure containing agent-specific information. See structure CfgAgentInfo . Shall be specified if the person is an agent and shall be set to NULL otherwise. Once specified, cannot be set to NULL.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentInfo AgentInfo { get; set; }
Visual Basic (Declaration)
Public Property AgentInfo As CfgAgentInfo
Visual C++
public:
property CfgAgentInfo^ AgentInfo {
    CfgAgentInfo^ get ();
    void set (CfgAgentInfo^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppRanks Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.AppRanks Property
CfgPerson Class See Also Send Feedback
A pointer to the list of the person's ranks with respect to applications (every item of this list is structured as CfgAppRank ). When used as an entry in CfgDeltaPerson (see below), it is a pointer to a list of the ranks added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgAppRank> AppRanks { get; set; }
Visual Basic (Declaration)
Public Property AppRanks As ICollection(Of CfgAppRank)
Visual C++
public:
property ICollection<CfgAppRank^>^ AppRanks {
    ICollection<CfgAppRank^>^ get ();
    void set (ICollection<CfgAppRank^>^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.DBID Property
CfgPerson Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EmailAddress Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.EmailAddress Property
CfgPerson Class See Also Send Feedback
A pointer to the email address of this person. Max length 255 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EmployeeID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.EmployeeID Property
CfgPerson Class See Also Send Feedback
A pointer to the code identifying this person within the tenant staff. Mandatory. Must be unique within the tenant. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmployeeID { get; set; }
Visual Basic (Declaration)
Public Property EmployeeID As String
Visual C++
public:
property String^ EmployeeID {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ExternalID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.ExternalID Property
CfgPerson Class See Also Send Feedback
A pointer to the string used to identify this person in the external systems. In particular, this field used to store an identifier processed during the authentication in the LDAP repositories.Max length 255 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExternalID { get; set; }
Visual Basic (Declaration)
Public Property ExternalID As String
Visual C++
public:
property String^ ExternalID {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.FirstName Property
CfgPerson Class See Also Send Feedback
A pointer to the person's first name. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.IsAgent Property
CfgPerson Class See Also Send Feedback
An indicator of whether the person is an agent. Read-only (set automatically according to the current value of agentInfo below). See type CfgFlag.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAgent { get; set; }
Visual Basic (Declaration)
Public Property IsAgent As CfgFlag
Visual C++
public:
property CfgFlag IsAgent {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsExternalAuth Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.IsExternalAuth Property
CfgPerson Class See Also Send Feedback
This field should reflect authentication method that used for the Person. If external authentication is used this flag should be equal to CFGTrue.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsExternalAuth { get; set; }
Visual Basic (Declaration)
Public Property IsExternalAuth As CfgFlag
Visual C++
public:
property CfgFlag IsExternalAuth {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.LastName Property
CfgPerson Class See Also Send Feedback
A pointer to the person's last name. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.Password Property
CfgPerson Class See Also Send Feedback
A pointer to the password the person uses to log into a CTI system. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Phones Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.Phones Property
CfgPerson Class See Also Send Feedback
Not in use.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhones Phones { get; set; }
Visual Basic (Declaration)
Public Property Phones As CfgPhones
Visual C++
public:
property CfgPhones^ Phones {
    CfgPhones^ get ();
    void set (CfgPhones^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.State Property
CfgPerson Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.Tenant Property
CfgPerson Class See Also Send Feedback
A unique identifier of the Tenant whose employee this person is. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.UserName Property
CfgPerson Class See Also Send Feedback
A pointer to the name the person uses to log into a CTI system. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgPerson..::.UserProperties Property
CfgPerson Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgPerson Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhones Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhones Class
Members See Also Send Feedback
CfgPhones

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhones : CfgStructure
Visual Basic (Declaration)
Public Class CfgPhones _
    Inherits CfgStructure
Visual C++
public ref class CfgPhones : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPhones

See Also

CfgPhones Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhones Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhones Members
CfgPhones Class Constructors Methods Properties See Also Send Feedback

The CfgPhones type exposes the following members.

Constructors

Name | Description
CfgPhones | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgPhones Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhones Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhones Constructor
CfgPhones Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhones(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgPhones(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPhones.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPhones.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPhones.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgPhones Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhones Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhones Methods
CfgPhones Class See Also Send Feedback

The CfgPhones type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgPhones Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhones Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhones Properties
CfgPhones Class See Also Send Feedback

The CfgPhones type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgPhones Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhysicalSwitch Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch Class
Members See Also Send Feedback
Switching Offices are the actual telephone switches that provide telephone service to contact centers.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhysicalSwitch : CfgObject
Visual Basic (Declaration)
Public Class CfgPhysicalSwitch _
    Inherits CfgObject
Visual C++
public ref class CfgPhysicalSwitch : public CfgObject

Remarks

A physical switch cannot be deleted as long as it is associated with at least one switch (see CfgSwitch ).

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPhysicalSwitch

See Also

CfgPhysicalSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhysicalSwitch Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch Members
CfgPhysicalSwitch Class Constructors Methods Properties See Also Send Feedback

The CfgPhysicalSwitch type exposes the following members.

Constructors

Name | Description
CfgPhysicalSwitch | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Address | Not in use.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the switch. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of this physical switch. Mandatory. Once specified, cannot be changed. See CfgSwitchType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhysicalSwitch Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch Constructor
CfgPhysicalSwitch Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhysicalSwitch(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgPhysicalSwitch(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPhysicalSwitch.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPhysicalSwitch.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhysicalSwitch Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch Methods
CfgPhysicalSwitch Class See Also Send Feedback

The CfgPhysicalSwitch type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.Save Method
CfgPhysicalSwitch Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.SetAccountPermissions Method
CfgPhysicalSwitch Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgPhysicalSwitch Class
CfgPhysicalSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPhysicalSwitch Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch Properties
CfgPhysicalSwitch Class See Also Send Feedback

The CfgPhysicalSwitch type exposes the following members.

Properties

Name | Description
Address | Not in use.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the switch. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of this physical switch. Mandatory. Once specified, cannot be changed. See CfgSwitchType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.Address Property
CfgPhysicalSwitch Class See Also Send Feedback
Not in use.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
    void set (CfgAddress^ value);
}

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.DBID Property
CfgPhysicalSwitch Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.Name Property
CfgPhysicalSwitch Class See Also Send Feedback
A pointer to the name of the switch. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.State Property
CfgPhysicalSwitch Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.Type Property
CfgPhysicalSwitch Class See Also Send Feedback
Type of this physical switch. Mandatory. Once specified, cannot be changed. See CfgSwitchType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgSwitchType
Visual C++
public:
property CfgSwitchType Type {
    CfgSwitchType get ();
    void set (CfgSwitchType value);
}

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitch..::.UserProperties Property
CfgPhysicalSwitch Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgPhysicalSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlace Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlace Class
Members See Also Send Feedback
A Place is a location that has one or more DNs operated by a single agent. Configure Places and assign individual DNs to them in order to monitor performance and availability of Agents, Agent Groups, and Place Groups, and to provide this information to call-processing applications. A typical Agent Place consists of two DNs: one DN that an agent uses to take customer calls and another DN the agent uses to make consultation calls and transfers. If you are using the multimedia options of the Genesys products, Places may have to be equipped with DNs of other types, such as E-mail Address. Make sure the configuration of Places in the Configuration Database always matches the actual wiring arrangements in the contact center.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlace : CfgObject
Visual Basic (Declaration)
Public Class CfgPlace _
    Inherits CfgObject
Visual C++
public ref class CfgPlace : public CfgObject

Remarks

Deletion of Place X will cause the following events set out in the order of arrival: Modification of placeDBIDs of all place groups that included Place X Modification of placeDBID of all persons who had Place X assigned as the default place Deletion of Place X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPlace

See Also

CfgPlace Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlace Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlace Members
CfgPlace Class Constructors Methods Properties See Also Send Feedback

The CfgPlace type exposes the following members.

Constructors

Name | Description
CfgPlace | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetCapacityRuleDBID
SetCapacityRuleDBID
SetContractDBID
SetContractDBID
SetSiteDBID
SetSiteDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
CapacityRule | A unique identifier of the capacity rule ( CfgScript ) associated with this place.
Contract | A unique identifier of Cost Contract (CfgObjectiveTable) with which this Place is associated.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DNs | A pointer to the list of identifiers of the telephony objects that are assigned to this place. When used as an entry in CfgDeltaPlace (see below), it is a pointer to a list of identifiers of the objects added to the existing list. DNs assigned to the place must belong to the tenant specified by tenantDBID above. One DN cannot be assigned to more than one place. DNs of the following types cannot be included into a place: CFGACDQueue, CFGRoutingPoint, CFGVirtACDQueue, CFGVirtRoutingPoint, CFGTrunk, CFGTrunkGroup, CFGTieLine, CFGTieLineGroup, CFGExtRoutingPoint and CFGRoutingQueue. CFGDestinationLabel, CFGServiceNumber,CFGAccessResource.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the place. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Site | A unique identifier of Site (CfgFolder) with which this Place is associated.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this place belongs to. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlace Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlace Constructor
CfgPlace Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlace(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgPlace(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlace.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlace.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlace Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlace Methods
CfgPlace Class See Also Send Feedback

The CfgPlace type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetCapacityRuleDBID
SetCapacityRuleDBID
SetContractDBID
SetContractDBID
SetSiteDBID
SetSiteDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.Save Method
CfgPlace Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.SetAccountPermissions Method
CfgPlace Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgPlace Class
CfgPlace Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetCapacityRuleDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.SetCapacityRuleDBID Method
CfgPlace Class See Also Send Feedback
SetCapacityRuleDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetCapacityRuleDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetCapacityRuleDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetCapacityRuleDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlace.SetCapacityRuleDBID(System.Int32)"]

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetContractDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.SetContractDBID Method
CfgPlace Class See Also Send Feedback
SetContractDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetContractDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetContractDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetContractDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlace.SetContractDBID(System.Int32)"]

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSiteDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.SetSiteDBID Method
CfgPlace Class See Also Send Feedback
SetSiteDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSiteDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSiteDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSiteDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlace.SetSiteDBID(System.Int32)"]

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.SetTenantDBID Method
CfgPlace Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlace.SetTenantDBID(System.Int32)"]

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlace Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlace Properties
CfgPlace Class See Also Send Feedback

The CfgPlace type exposes the following members.

Properties

Name | Description
CapacityRule | A unique identifier of the capacity rule ( CfgScript ) associated with this place.
Contract | A unique identifier of Cost Contract (CfgObjectiveTable) with which this Place is associated.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DNs | A pointer to the list of identifiers of the telephony objects that are assigned to this place. When used as an entry in CfgDeltaPlace (see below), it is a pointer to a list of identifiers of the objects added to the existing list. DNs assigned to the place must belong to the tenant specified by tenantDBID above. One DN cannot be assigned to more than one place. DNs of the following types cannot be included into a place: CFGACDQueue, CFGRoutingPoint, CFGVirtACDQueue, CFGVirtRoutingPoint, CFGTrunk, CFGTrunkGroup, CFGTieLine, CFGTieLineGroup, CFGExtRoutingPoint and CFGRoutingQueue. CFGDestinationLabel, CFGServiceNumber,CFGAccessResource.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the place. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Site | A unique identifier of Site (CfgFolder) with which this Place is associated.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this place belongs to. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.CapacityRule Property
CfgPlace Class See Also Send Feedback
A unique identifier of the capacity rule ( CfgScript ) associated with this place.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript CapacityRule { get; set; }
Visual Basic (Declaration)
Public Property CapacityRule As CfgScript
Visual C++
public:
property CfgScript^ CapacityRule {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.Contract Property
CfgPlace Class See Also Send Feedback
A unique identifier of Cost Contract (CfgObjectiveTable) with which this Place is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ Contract {
    CfgObjectiveTable^ get ();
    void set (CfgObjectiveTable^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.DBID Property
CfgPlace Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.DNs Property
CfgPlace Class See Also Send Feedback
A pointer to the list of identifiers of the telephony objects that are assigned to this place. When used as an entry in CfgDeltaPlace (see below), it is a pointer to a list of identifiers of the objects added to the existing list. DNs assigned to the place must belong to the tenant specified by tenantDBID above. One DN cannot be assigned to more than one place. DNs of the following types cannot be included into a place: CFGACDQueue, CFGRoutingPoint, CFGVirtACDQueue, CFGVirtRoutingPoint, CFGTrunk, CFGTrunkGroup, CFGTieLine, CFGTieLineGroup, CFGExtRoutingPoint and CFGRoutingQueue. CFGDestinationLabel, CFGServiceNumber,CFGAccessResource.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgDN> DNs { get; set; }
Visual Basic (Declaration)
Public Property DNs As ICollection(Of CfgDN)
Visual C++
public:
property ICollection<CfgDN^>^ DNs {
    ICollection<CfgDN^>^ get ();
    void set (ICollection<CfgDN^>^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.Name Property
CfgPlace Class See Also Send Feedback
A pointer to the name of the place. Mandatory. Must be unique within the tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.Site Property
CfgPlace Class See Also Send Feedback
A unique identifier of Site (CfgFolder) with which this Place is associated.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolder Site { get; set; }
Visual Basic (Declaration)
Public Property Site As CfgFolder
Visual C++
public:
property CfgFolder^ Site {
    CfgFolder^ get ();
    void set (CfgFolder^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.State Property
CfgPlace Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.Tenant Property
CfgPlace Class See Also Send Feedback
A unique identifier of the Tenant that this place belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlace..::.UserProperties Property
CfgPlace Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgPlace Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlaceGroup Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup Class
Members See Also Send Feedback
You can group Places if, according to the call-processing algorithms, the calls have to be distributed among a set of Places under the control of CTI applications rather than through the ACD mechanisms of the Switch. As an example, consider a call-parking service, where a routing application transfers a call to one of the ports assigned to a call-parking Place Group and attaches the information about the treatment to be applied to that call while it is parked.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceGroup : CfgObject
Visual Basic (Declaration)
Public Class CfgPlaceGroup _
    Inherits CfgObject
Visual C++
public ref class CfgPlaceGroup : public CfgObject

Remarks

The name of a place group must be unique within the tenant, but can coincide with the name of either an agent group or a DN group of the same tenant. The name of a place group cannot be changed until there is at least one place listed in this group. See placeDBIDs property Deletion of Place Group X will cause the following events set out in the order of arrival: Modification of campaignGroups of all campaigns that included Place Group X Deletion of Place Group X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPlaceGroup

See Also

CfgPlaceGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlaceGroup Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup Members
CfgPlaceGroup Class Constructors Methods Properties See Also Send Feedback

The CfgPlaceGroup type exposes the following members.

Constructors

Name | Description
CfgPlaceGroup | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | The DBID of the CfgPlaceGroup configuration object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Places | A pointer to the list of identifiers of the Places that form this group. NOTE: Configuration Server does not place any restrictions regarding the types of DNs in the places that form a group.

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlaceGroup Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup Constructor
CfgPlaceGroup Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceGroup(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgPlaceGroup(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlaceGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPlaceGroup.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlaceGroup Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup Methods
CfgPlaceGroup Class See Also Send Feedback

The CfgPlaceGroup type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup..::.Save Method
CfgPlaceGroup Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup..::.SetAccountPermissions Method
CfgPlaceGroup Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgPlaceGroup Class
CfgPlaceGroup Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPlaceGroup Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup Properties
CfgPlaceGroup Class See Also Send Feedback

The CfgPlaceGroup type exposes the following members.

Properties

Name | Description
DBID | The DBID of the CfgPlaceGroup configuration object.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
GroupInfo | A pointer to the structure CfgGroup containing general information about this group. Mandatory.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Places | A pointer to the list of identifiers of the Places that form this group. NOTE: Configuration Server does not place any restrictions regarding the types of DNs in the places that form a group.

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup..::.DBID Property
CfgPlaceGroup Class See Also Send Feedback
The DBID of the CfgPlaceGroup configuration object.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; }
Visual Basic (Declaration)
Public ReadOnly Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
}

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup..::.GroupInfo Property
CfgPlaceGroup Class See Also Send Feedback
A pointer to the structure CfgGroup containing general information about this group. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroup GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroup
Visual C++
public:
property CfgGroup^ GroupInfo {
    CfgGroup^ get ();
    void set (CfgGroup^ value);
}

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Places Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroup..::.Places Property
CfgPlaceGroup Class See Also Send Feedback
A pointer to the list of identifiers of the Places that form this group. NOTE: Configuration Server does not place any restrictions regarding the types of DNs in the places that form a group.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgPlace> Places { get; set; }
Visual Basic (Declaration)
Public Property Places As ICollection(Of CfgPlace)
Visual C++
public:
property ICollection<CfgPlace^>^ Places {
    ICollection<CfgPlace^>^ get ();
    void set (ICollection<CfgPlace^>^ value);
}

See Also

CfgPlaceGroup Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPortInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo Class
Members See Also Send Feedback
CfgPortInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPortInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgPortInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgPortInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgPortInfo

See Also

CfgPortInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPortInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfo Members
CfgPortInfo Class Constructors Methods Properties See Also Send Feedback

The CfgPortInfo type exposes the following members.

Constructors

Name | Description
CfgPortInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AppParams | Listening port's application parameters
CharField1 | Optional text field #1
CharField2 | Optional text field #2
CharField3 | Optional text field #3
CharField4 | Optional text field #4
ConnProtocol | A pointer to the name of the connection control protocol.
Description | Optional description of the listening port
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Id | An identifier of the server's listening port.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LongField1 | Optional integer field #1
LongField2 | Optional integer field #2
LongField3 | Optional integer field #3
LongField4 | Optional integer field #3
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Port | Listening port value.
TransportParams | Listening port's transport parameters

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPortInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo Constructor
CfgPortInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPortInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgPortInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPortInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPortInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgPortInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPortInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfo Methods
CfgPortInfo Class See Also Send Feedback

The CfgPortInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgPortInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfo Properties
CfgPortInfo Class See Also Send Feedback

The CfgPortInfo type exposes the following members.

Properties

Name | Description
AppParams | Listening port's application parameters
CharField1 | Optional text field #1
CharField2 | Optional text field #2
CharField3 | Optional text field #3
CharField4 | Optional text field #4
ConnProtocol | A pointer to the name of the connection control protocol.
Description | Optional description of the listening port
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Id | An identifier of the server's listening port.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
LongField1 | Optional integer field #1
LongField2 | Optional integer field #2
LongField3 | Optional integer field #3
LongField4 | Optional integer field #3
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Port | Listening port value.
TransportParams | Listening port's transport parameters

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AppParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.AppParams Property
CfgPortInfo Class See Also Send Feedback
Listening port's application parameters

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AppParams { get; set; }
Visual Basic (Declaration)
Public Property AppParams As String
Visual C++
public:
property String^ AppParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.CharField1 Property
CfgPortInfo Class See Also Send Feedback
Optional text field #1

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField1 { get; set; }
Visual Basic (Declaration)
Public Property CharField1 As String
Visual C++
public:
property String^ CharField1 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.CharField2 Property
CfgPortInfo Class See Also Send Feedback
Optional text field #2

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField2 { get; set; }
Visual Basic (Declaration)
Public Property CharField2 As String
Visual C++
public:
property String^ CharField2 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.CharField3 Property
CfgPortInfo Class See Also Send Feedback
Optional text field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField3 { get; set; }
Visual Basic (Declaration)
Public Property CharField3 As String
Visual C++
public:
property String^ CharField3 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CharField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.CharField4 Property
CfgPortInfo Class See Also Send Feedback
Optional text field #4

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField4 { get; set; }
Visual Basic (Declaration)
Public Property CharField4 As String
Visual C++
public:
property String^ CharField4 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ConnProtocol Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.ConnProtocol Property
CfgPortInfo Class See Also Send Feedback
A pointer to the name of the connection control protocol.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ConnProtocol { get; set; }
Visual Basic (Declaration)
Public Property ConnProtocol As String
Visual C++
public:
property String^ ConnProtocol {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.Description Property
CfgPortInfo Class See Also Send Feedback
Optional description of the listening port

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.Id Property
CfgPortInfo Class See Also Send Feedback
An identifier of the server's listening port.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.LongField1 Property
CfgPortInfo Class See Also Send Feedback
Optional integer field #1

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField1 { get; set; }
Visual Basic (Declaration)
Public Property LongField1 As Integer
Visual C++
public:
property int LongField1 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.LongField2 Property
CfgPortInfo Class See Also Send Feedback
Optional integer field #2

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField2 { get; set; }
Visual Basic (Declaration)
Public Property LongField2 As Integer
Visual C++
public:
property int LongField2 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.LongField3 Property
CfgPortInfo Class See Also Send Feedback
Optional integer field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField3 { get; set; }
Visual Basic (Declaration)
Public Property LongField3 As Integer
Visual C++
public:
property int LongField3 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LongField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.LongField4 Property
CfgPortInfo Class See Also Send Feedback
Optional integer field #3

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField4 { get; set; }
Visual Basic (Declaration)
Public Property LongField4 As Integer
Visual C++
public:
property int LongField4 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Port Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.Port Property
CfgPortInfo Class See Also Send Feedback
Listening port value.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Port { get; set; }
Visual Basic (Declaration)
Public Property Port As String
Visual C++
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TransportParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfo..::.TransportParams Property
CfgPortInfo Class See Also Send Feedback
Listening port's transport parameters

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string TransportParams { get; set; }
Visual Basic (Declaration)
Public Property TransportParams As String
Visual C++
public:
property String^ TransportParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRemovalEvent Class

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent Class
Members See Also Send Feedback
CfgRemovalEvent

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRemovalEvent : CfgStructure
Visual Basic (Declaration)
Public Class CfgRemovalEvent _
    Inherits CfgStructure
Visual C++
public ref class CfgRemovalEvent : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgRemovalEvent

See Also

CfgRemovalEvent Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRemovalEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent Members
CfgRemovalEvent Class Constructors Methods Properties See Also Send Feedback

The CfgRemovalEvent type exposes the following members.

Constructors

Name | Description
CfgRemovalEvent | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LogEventID |
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
SelectionMode |

See Also

CfgRemovalEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRemovalEvent Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent Constructor
CfgRemovalEvent Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRemovalEvent(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgRemovalEvent(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRemovalEvent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRemovalEvent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRemovalEvent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgRemovalEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRemovalEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent Methods
CfgRemovalEvent Class See Also Send Feedback

The CfgRemovalEvent type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgRemovalEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRemovalEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent Properties
CfgRemovalEvent Class See Also Send Feedback

The CfgRemovalEvent type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LogEventID |
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
SelectionMode |

See Also

CfgRemovalEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LogEventID Property

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent..::.LogEventID Property
CfgRemovalEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRemovalEvent.LogEventID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LogEventID { get; set; }
Visual Basic (Declaration)
Public Property LogEventID As Integer
Visual C++
public:
property int LogEventID {
    int get ();
    void set (int value);
}

See Also

CfgRemovalEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SelectionMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEvent..::.SelectionMode Property
CfgRemovalEvent Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRemovalEvent.SelectionMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSelectionMode SelectionMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionMode As CfgSelectionMode
Visual C++
public:
property CfgSelectionMode SelectionMode {
    CfgSelectionMode get ();
}

See Also

CfgRemovalEvent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgResourceID Class

[image]

Enterprise SDK 8.0 Reference API
CfgResourceID Class
Members See Also Send Feedback
CfgResourceID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgResourceID : CfgStructure
Visual Basic (Declaration)
Public Class CfgResourceID _
    Inherits CfgStructure
Visual C++
public ref class CfgResourceID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgResourceID

See Also

CfgResourceID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgResourceID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceID Members
CfgResourceID Class Constructors Methods Properties See Also Send Feedback

The CfgResourceID type exposes the following members.

Constructors

Name | Description
CfgResourceID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgResourceID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgResourceID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgResourceID Constructor
CfgResourceID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgResourceID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgResourceID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgResourceID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgResourceID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgResourceID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgResourceID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgResourceID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceID Methods
CfgResourceID Class See Also Send Feedback

The CfgResourceID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgResourceID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgResourceID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceID Properties
CfgResourceID Class See Also Send Feedback

The CfgResourceID type exposes the following members.

Properties

Name | Description
DBID |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Type |

See Also

CfgResourceID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgResourceID..::.DBID Property
CfgResourceID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgResourceID.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgResourceID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgResourceID..::.Type Property
CfgResourceID Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgResourceID.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgResourceID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRole Class

[image]

Enterprise SDK 8.0 Reference API
CfgRole Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRole : CfgObject
Visual Basic (Declaration)
Public Class CfgRole _
    Inherits CfgObject
Visual C++
public ref class CfgRole : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgRole

See Also

CfgRole Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRole Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRole Members
CfgRole Class Constructors Methods Properties See Also Send Feedback

The CfgRole type exposes the following members.

Constructors

Name | Description
CfgRole | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID |
Description |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Members |
Name |
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State |
Tenant |
UserProperties |

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRole Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRole Constructor
CfgRole Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRole(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgRole(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRole Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRole Methods
CfgRole Class See Also Send Feedback

The CfgRole type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.Save Method
CfgRole Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRole..::.SetAccountPermissions Method
CfgRole Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgRole Class
CfgRole Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.SetTenantDBID Method
CfgRole Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.SetTenantDBID(System.Int32)"]

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRole Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRole Properties
CfgRole Class See Also Send Feedback

The CfgRole type exposes the following members.

Properties

Name | Description
DBID |
Description |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Members |
Name |
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State |
Tenant |
UserProperties |

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.DBID Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.Description Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Members Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.Members Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.Members"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgRoleMember> Members { get; set; }
Visual Basic (Declaration)
Public Property Members As ICollection(Of CfgRoleMember)
Visual C++
public:
property ICollection<CfgRoleMember^>^ Members {
    ICollection<CfgRoleMember^>^ get ();
    void set (ICollection<CfgRoleMember^>^ value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.Name Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.State Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.Tenant Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgRole..::.UserProperties Property
CfgRole Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRole.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgRole Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRoleMember Class

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMember Class
Members See Also Send Feedback
CfgRoleMember

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRoleMember : CfgStructure
Visual Basic (Declaration)
Public Class CfgRoleMember _
    Inherits CfgStructure
Visual C++
public ref class CfgRoleMember : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgRoleMember

See Also

CfgRoleMember Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRoleMember Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMember Members
CfgRoleMember Class Constructors Methods Properties See Also Send Feedback

The CfgRoleMember type exposes the following members.

Constructors

Name | Description
CfgRoleMember | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDBID |
ObjectType |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgRoleMember Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRoleMember Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMember Constructor
CfgRoleMember Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRoleMember(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgRoleMember(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRoleMember.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRoleMember.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRoleMember.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgRoleMember Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRoleMember Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMember Methods
CfgRoleMember Class See Also Send Feedback

The CfgRoleMember type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgRoleMember Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgRoleMember Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMember Properties
CfgRoleMember Class See Also Send Feedback

The CfgRoleMember type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
ObjectDBID |
ObjectType |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgRoleMember Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMember..::.ObjectDBID Property
CfgRoleMember Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRoleMember.ObjectDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDBID { get; set; }
Visual Basic (Declaration)
Public Property ObjectDBID As Integer
Visual C++
public:
property int ObjectDBID {
    int get ();
    void set (int value);
}

See Also

CfgRoleMember Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMember..::.ObjectType Property
CfgRoleMember Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgRoleMember.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgRoleMember Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScheduledTask Class

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask Class
Members See Also Send Feedback
A Scheduled Task is a GVP Object in which you schedule the GVP tasks

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScheduledTask : CfgObject
Visual Basic (Declaration)
Public Class CfgScheduledTask _
    Inherits CfgObject
Visual C++
public ref class CfgScheduledTask : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgScheduledTask

See Also

CfgScheduledTask Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScheduledTask Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask Members
CfgScheduledTask Class Constructors Methods Properties See Also Send Feedback

The CfgScheduledTask type exposes the following members.

Constructors

Name | Description
CfgScheduledTask | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | An optional short description of this ScheduledTask.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the ScheduledTask. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources | A pointer to the list of the objects associated with this ScheduledTask (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaScheduledTask , it is a pointer to a list of resources added to the existing list. Only objects of type CfgHost , CfgSwitch , CfgGVPCustomer and can be associated with ScheduledTask object through resources
StartTime | The time the task is to begin.
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the ScheduledTask. Mandatory. Once specified, cannot be changed. See type CfgTaskType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScheduledTask Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask Constructor
CfgScheduledTask Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScheduledTask(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgScheduledTask(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgScheduledTask.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgScheduledTask.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScheduledTask Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask Methods
CfgScheduledTask Class See Also Send Feedback

The CfgScheduledTask type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.Save Method
CfgScheduledTask Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.SetAccountPermissions Method
CfgScheduledTask Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgScheduledTask Class
CfgScheduledTask Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScheduledTask Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask Properties
CfgScheduledTask Class See Also Send Feedback

The CfgScheduledTask type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | An optional short description of this ScheduledTask.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the ScheduledTask. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources | A pointer to the list of the objects associated with this ScheduledTask (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaScheduledTask , it is a pointer to a list of resources added to the existing list. Only objects of type CfgHost , CfgSwitch , CfgGVPCustomer and can be associated with ScheduledTask object through resources
StartTime | The time the task is to begin.
State | Current object state. Mandatory. Refer to CfgObjectState
Type | Type of the ScheduledTask. Mandatory. Once specified, cannot be changed. See type CfgTaskType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.DBID Property
CfgScheduledTask Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.Description Property
CfgScheduledTask Class See Also Send Feedback
An optional short description of this ScheduledTask.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.Name Property
CfgScheduledTask Class See Also Send Feedback
A pointer to name of the ScheduledTask. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.Resources Property
CfgScheduledTask Class See Also Send Feedback
A pointer to the list of the objects associated with this ScheduledTask (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaScheduledTask , it is a pointer to a list of resources added to the existing list. Only objects of type CfgHost , CfgSwitch , CfgGVPCustomer and can be associated with ScheduledTask object through resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.StartTime Property
CfgScheduledTask Class See Also Send Feedback
The time the task is to begin.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As Integer
Visual C++
public:
property int StartTime {
    int get ();
    void set (int value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.State Property
CfgScheduledTask Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.Type Property
CfgScheduledTask Class See Also Send Feedback
Type of the ScheduledTask. Mandatory. Once specified, cannot be changed. See type CfgTaskType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTaskType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgTaskType
Visual C++
public:
property CfgTaskType Type {
    CfgTaskType get ();
    void set (CfgTaskType value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTask..::.UserProperties Property
CfgScheduledTask Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgScheduledTask Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScript Class

[image]

Enterprise SDK 8.0 Reference API
CfgScript Class
Members See Also Send Feedback
Scripts identify processing scenarios or treatments that can be applied to customer interactions.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScript : CfgObject
Visual Basic (Declaration)
Public Class CfgScript _
    Inherits CfgObject
Visual C++
public ref class CfgScript : public CfgObject

Remarks

Deletion of Script X will cause the following events set out in the order of arrival: Modification of campaigns that had scriptDBID field set to Script X Modification of campaign groups that had scriptDBID field set to Script X Modification of calling lists that had scriptDBID field set to Script X Modification of voice prompts that had scriptDBID field set to Script X Modification of alarm conditions that had scriptDBID field set to Script X Modification of alarm conditions that had to Script X included in their reactionScriptDBIDs or clearanceScriptDBIDsfield Modification of agents that had capacityRuleDBID field set to Script X Modification of places that had capacityRuleDBID field set to Script X Modification of agent groups that had capacityRuleDBID field set to Script X Modification of place groups that had capacityRuleDBID field set to Script X Modification of tenants that had defaultCapacityRuleDBID field set to Script X Deletion of Script X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgScript

See Also

CfgScript Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScript Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScript Members
CfgScript Class Constructors Methods Properties See Also Send Feedback

The CfgScript type exposes the following members.

Constructors

Name | Description
CfgScript | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Index | Script index.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the script. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources | A pointer to the list of the objects associated with this Host (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaHost , it is a pointer to a list of resources added to the existing list. Only objects of type CfgAppPrototype and CfgScript and can be associated with Script object through resources
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant this script belongs to. Mandatory. Once specified, cannot be changed.
Type | Type of this script. Mandatory. Once specified, cannot be changed. See type CfgScriptType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScript Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScript Constructor
CfgScript Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgScript(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgScript.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgScript.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScript Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScript Methods
CfgScript Class See Also Send Feedback

The CfgScript type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.Save Method
CfgScript Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScript..::.SetAccountPermissions Method
CfgScript Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgScript Class
CfgScript Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.SetTenantDBID Method
CfgScript Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgScript.SetTenantDBID(System.Int32)"]

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgScript Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScript Properties
CfgScript Class See Also Send Feedback

The CfgScript type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Index | Script index.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the script. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources | A pointer to the list of the objects associated with this Host (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaHost , it is a pointer to a list of resources added to the existing list. Only objects of type CfgAppPrototype and CfgScript and can be associated with Script object through resources
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant this script belongs to. Mandatory. Once specified, cannot be changed.
Type | Type of this script. Mandatory. Once specified, cannot be changed. See type CfgScriptType
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.DBID Property
CfgScript Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Index Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.Index Property
CfgScript Class See Also Send Feedback
Script index.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.Name Property
CfgScript Class See Also Send Feedback
A pointer to the name of the script. Mandatory. Must be unique within the tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.Resources Property
CfgScript Class See Also Send Feedback
A pointer to the list of the objects associated with this Host (every item of this list is structured as CfgObjectResource ). When used as an entry in CfgDeltaHost , it is a pointer to a list of resources added to the existing list. Only objects of type CfgAppPrototype and CfgScript and can be associated with Script object through resources

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.State Property
CfgScript Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.Tenant Property
CfgScript Class See Also Send Feedback
A unique identifier of the Tenant this script belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.Type Property
CfgScript Class See Also Send Feedback
Type of this script. Mandatory. Once specified, cannot be changed. See type CfgScriptType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScriptType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgScriptType
Visual C++
public:
property CfgScriptType Type {
    CfgScriptType get ();
    void set (CfgScriptType value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgScript..::.UserProperties Property
CfgScript Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgScript Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServer Class

[image]

Enterprise SDK 8.0 Reference API
CfgServer Class
Members See Also Send Feedback
CfgServer

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServer : CfgStructure
Visual Basic (Declaration)
Public Class CfgServer _
    Inherits CfgStructure
Visual C++
public ref class CfgServer : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServer

See Also

CfgServer Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServer Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServer Members
CfgServer Class Constructors Methods Properties See Also Send Feedback

The CfgServer type exposes the following members.

Constructors

Name | Description
CfgServer | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetBackupServerDBID | SetBackupServerDBID
SetHostDBID | SetHostDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Attempts | Number of attempts to connect to this server before trying to connect to the backup server. Makes sense only if backupServerDBID is specified. May not be set to a negative value. Recommended to be set to 1 by default.
BackupServer | An identifier of the Server which is to be contacted if connection to this server fails. The backup server must be associated with the same account (see ConfSetAccount) and have the same application type(CfgAppType). One backup server cannot be associated with more than one primary server. See comments.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Host | A unique identifier of the CfgHost where this server resides. Cannot be changed as long as the server is associated with at least one client application or a primary server.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Port | A pointer to the name of the port which client applications should use to open communication sessions to this server. Populated for backward compatibility purpose from portInfos list.
Timeout | Time-out in seconds that the application should run before making a re-connect attempt after a communication session with this server has failed. May not be set to a negative value. Recommended to be set to 10 by default.

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServer Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServer Constructor
CfgServer Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServer(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgServer(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServer.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServer.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServer.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServer Methods
CfgServer Class See Also Send Feedback

The CfgServer type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetBackupServerDBID | SetBackupServerDBID
SetHostDBID | SetHostDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetBackupServerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.SetBackupServerDBID Method
CfgServer Class See Also Send Feedback
SetBackupServerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetBackupServerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetBackupServerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetBackupServerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServer.SetBackupServerDBID(System.Int32)"]

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetHostDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.SetHostDBID Method
CfgServer Class See Also Send Feedback
SetHostDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetHostDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetHostDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetHostDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServer.SetHostDBID(System.Int32)"]

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServer Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServer Properties
CfgServer Class See Also Send Feedback

The CfgServer type exposes the following members.

Properties

Name | Description
Attempts | Number of attempts to connect to this server before trying to connect to the backup server. Makes sense only if backupServerDBID is specified. May not be set to a negative value. Recommended to be set to 1 by default.
BackupServer | An identifier of the Server which is to be contacted if connection to this server fails. The backup server must be associated with the same account (see ConfSetAccount) and have the same application type(CfgAppType). One backup server cannot be associated with more than one primary server. See comments.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Host | A unique identifier of the CfgHost where this server resides. Cannot be changed as long as the server is associated with at least one client application or a primary server.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Port | A pointer to the name of the port which client applications should use to open communication sessions to this server. Populated for backward compatibility purpose from portInfos list.
Timeout | Time-out in seconds that the application should run before making a re-connect attempt after a communication session with this server has failed. May not be set to a negative value. Recommended to be set to 10 by default.

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Attempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.Attempts Property
CfgServer Class See Also Send Feedback
Number of attempts to connect to this server before trying to connect to the backup server. Makes sense only if backupServerDBID is specified. May not be set to a negative value. Recommended to be set to 1 by default.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Attempts { get; set; }
Visual Basic (Declaration)
Public Property Attempts As Integer
Visual C++
public:
property int Attempts {
    int get ();
    void set (int value);
}

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


BackupServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.BackupServer Property
CfgServer Class See Also Send Feedback
An identifier of the Server which is to be contacted if connection to this server fails. The backup server must be associated with the same account (see ConfSetAccount) and have the same application type(CfgAppType). One backup server cannot be associated with more than one primary server. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication BackupServer { get; set; }
Visual Basic (Declaration)
Public Property BackupServer As CfgApplication
Visual C++
public:
property CfgApplication^ BackupServer {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Host Property

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.Host Property
CfgServer Class See Also Send Feedback
A unique identifier of the CfgHost where this server resides. Cannot be changed as long as the server is associated with at least one client application or a primary server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHost Host { get; set; }
Visual Basic (Declaration)
Public Property Host As CfgHost
Visual C++
public:
property CfgHost^ Host {
    CfgHost^ get ();
    void set (CfgHost^ value);
}

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Port Property

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.Port Property
CfgServer Class See Also Send Feedback
A pointer to the name of the port which client applications should use to open communication sessions to this server. Populated for backward compatibility purpose from portInfos list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Port { get; set; }
Visual Basic (Declaration)
Public Property Port As String
Visual C++
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Timeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgServer..::.Timeout Property
CfgServer Class See Also Send Feedback
Time-out in seconds that the application should run before making a re-connect attempt after a communication session with this server has failed. May not be set to a negative value. Recommended to be set to 10 by default.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Timeout { get; set; }
Visual Basic (Declaration)
Public Property Timeout As Integer
Visual C++
public:
property int Timeout {
    int get ();
    void set (int value);
}

See Also

CfgServer Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerHostID Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerHostID Class
Members See Also Send Feedback
CfgServerHostID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerHostID : CfgStructure
Visual Basic (Declaration)
Public Class CfgServerHostID _
    Inherits CfgStructure
Visual C++
public ref class CfgServerHostID : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServerHostID

See Also

CfgServerHostID Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerHostID Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostID Members
CfgServerHostID Class Constructors Methods Properties See Also Send Feedback

The CfgServerHostID type exposes the following members.

Constructors

Name | Description
CfgServerHostID | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgServerHostID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerHostID Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerHostID Constructor
CfgServerHostID Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerHostID(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgServerHostID(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServerHostID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServerHostID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServerHostID.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgServerHostID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerHostID Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostID Methods
CfgServerHostID Class See Also Send Feedback

The CfgServerHostID type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgServerHostID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerHostID Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostID Properties
CfgServerHostID Class See Also Send Feedback

The CfgServerHostID type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgServerHostID Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerVersion Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerVersion Class
Members See Also Send Feedback
CfgServerVersion

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerVersion : CfgStructure
Visual Basic (Declaration)
Public Class CfgServerVersion _
    Inherits CfgStructure
Visual C++
public ref class CfgServerVersion : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServerVersion

See Also

CfgServerVersion Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerVersion Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersion Members
CfgServerVersion Class Constructors Methods Properties See Also Send Feedback

The CfgServerVersion type exposes the following members.

Constructors

Name | Description
CfgServerVersion | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgServerVersion Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerVersion Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerVersion Constructor
CfgServerVersion Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerVersion(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgServerVersion(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServerVersion.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServerVersion.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServerVersion.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgServerVersion Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerVersion Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersion Methods
CfgServerVersion Class See Also Send Feedback

The CfgServerVersion type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgServerVersion Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServerVersion Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersion Properties
CfgServerVersion Class See Also Send Feedback

The CfgServerVersion type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgServerVersion Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgService Class

[image]

Enterprise SDK 8.0 Reference API
CfgService Class
Members See Also Send Feedback
Solutions are sets of functions that applications provide. Solutions accomplish particular business tasks in contact centers.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgService : CfgObject
Visual Basic (Declaration)
Public Class CfgService _
    Inherits CfgObject
Visual C++
public ref class CfgService : public CfgObject

Remarks

The components list of a solution can be populated based on the list of the componentDefinitions the solution is based on. Then, an application for each component within the solution should be assigned according to the type of application specified in SolutionComponentDefinition this solution component is based on and whether or not a solution component is mandatory or optional. Parameters appType, appVersion, and startupPriority are READONLY within solution. It shall be possible to edit the components list of a solution in such a way that one or more copies of a solution component already defined within the solution can be created. If such a copy is made, a unique identifier of an application with the type suitable for the newly created component could be assigned to appDBID parameter in this component. The fact that more than one solution component within a solution may have the same appType, appVersion and startupPriority implies that the order of activation of corresponding applications within the solution may be chosen arbitrarily. For compatibility purposes between 5.1.xx and 5.9.xxx, objects of type CfgService that exist in 5.1.xxx release will have solutionType=CFGSTDefaultSolutionType. If one solution component is used by two different solutions, both solutions should refer to same application of CFGSCS type (SCSDBID)

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgService

See Also

CfgService Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgService Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgService Members
CfgService Class Constructors Methods Properties See Also Send Feedback

The CfgService type exposes the following members.

Constructors

Name | Description
CfgService | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetAssignedTenantDBID
SetAssignedTenantDBID
SetSCSDBID
SetSCSDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AssignedTenant | A unique identifier of the Tenant the solution is assigned to. Optional. If assignedTenantDBID is managed (added/modified/removed) by configuration wizard , the same action (add/modify/remove) has to be initiated by wizard for property tenantDBIDs of CfgApplication if an application belongs to this solution.
ComponentDefinitions | A pointer to a list of predefined solution components for this solution. (Every item of this list is structured as a CfgSolutionComponentDefinition .)
Components | A pointer to a list of solution components defined for this solution (every item of this list is structured as CfgSolutionComponent ). When used as an entry in CfgDeltaService, it is a pointer to a list of solution components added to the existing list.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the service/solution. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources |
SCS | A unique identifier of an Application of CFGSCStype which is supposed to control the solution. See comment number 4. See also CfgSolutionComponent .
SolutionType | The type of the solution. Mandatory. Once specified cannot be changed. See CfgSolutionType .
StartupType | A type of solution/service startup. Specifies whether this solution/service have to be started by Management Layer. See CfgStartupType. Read-only. Specified during application prototype definition. The value is associated with solution type CfgSolutionType. The value for the solutions of CFGSTDefaultSolutionType and CFGSTFramework type is set to CFGSUTManual, and for other applications is set to CFGSUTAutomatic.
State | Current object state. Mandatory. Refer to CfgObjectState
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the version of the solution. Mandatory.

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgService Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgService Constructor
CfgService Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgService(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgService(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgService.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgService.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgService Methods
CfgService Class See Also Send Feedback

The CfgService type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetAssignedTenantDBID
SetAssignedTenantDBID
SetSCSDBID
SetSCSDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.Save Method
CfgService Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgService..::.SetAccountPermissions Method
CfgService Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgService Class
CfgService Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAssignedTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.SetAssignedTenantDBID Method
CfgService Class See Also Send Feedback
SetAssignedTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAssignedTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAssignedTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAssignedTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgService.SetAssignedTenantDBID(System.Int32)"]

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSCSDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.SetSCSDBID Method
CfgService Class See Also Send Feedback
SetSCSDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSCSDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSCSDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSCSDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgService.SetSCSDBID(System.Int32)"]

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgService Properties
CfgService Class See Also Send Feedback

The CfgService type exposes the following members.

Properties

Name | Description
AssignedTenant | A unique identifier of the Tenant the solution is assigned to. Optional. If assignedTenantDBID is managed (added/modified/removed) by configuration wizard , the same action (add/modify/remove) has to be initiated by wizard for property tenantDBIDs of CfgApplication if an application belongs to this solution.
ComponentDefinitions | A pointer to a list of predefined solution components for this solution. (Every item of this list is structured as a CfgSolutionComponentDefinition .)
Components | A pointer to a list of solution components defined for this solution (every item of this list is structured as CfgSolutionComponent ). When used as an entry in CfgDeltaService, it is a pointer to a list of solution components added to the existing list.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the service/solution. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Resources |
SCS | A unique identifier of an Application of CFGSCStype which is supposed to control the solution. See comment number 4. See also CfgSolutionComponent .
SolutionType | The type of the solution. Mandatory. Once specified cannot be changed. See CfgSolutionType .
StartupType | A type of solution/service startup. Specifies whether this solution/service have to be started by Management Layer. See CfgStartupType. Read-only. Specified during application prototype definition. The value is associated with solution type CfgSolutionType. The value for the solutions of CFGSTDefaultSolutionType and CFGSTFramework type is set to CFGSUTManual, and for other applications is set to CFGSUTAutomatic.
State | Current object state. Mandatory. Refer to CfgObjectState
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
Version | A pointer to the version of the solution. Mandatory.

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AssignedTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.AssignedTenant Property
CfgService Class See Also Send Feedback
A unique identifier of the Tenant the solution is assigned to. Optional. If assignedTenantDBID is managed (added/modified/removed) by configuration wizard , the same action (add/modify/remove) has to be initiated by wizard for property tenantDBIDs of CfgApplication if an application belongs to this solution.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant AssignedTenant { get; set; }
Visual Basic (Declaration)
Public Property AssignedTenant As CfgTenant
Visual C++
public:
property CfgTenant^ AssignedTenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ComponentDefinitions Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.ComponentDefinitions Property
CfgService Class See Also Send Feedback
A pointer to a list of predefined solution components for this solution. (Every item of this list is structured as a CfgSolutionComponentDefinition .)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponentDefinition> ComponentDefinitions { get; set; }
Visual Basic (Declaration)
Public Property ComponentDefinitions As ICollection(Of CfgSolutionComponentDefinition)
Visual C++
public:
property ICollection<CfgSolutionComponentDefinition^>^ ComponentDefinitions {
    ICollection<CfgSolutionComponentDefinition^>^ get ();
    void set (ICollection<CfgSolutionComponentDefinition^>^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Components Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.Components Property
CfgService Class See Also Send Feedback
A pointer to a list of solution components defined for this solution (every item of this list is structured as CfgSolutionComponent ). When used as an entry in CfgDeltaService, it is a pointer to a list of solution components added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSolutionComponent> Components { get; set; }
Visual Basic (Declaration)
Public Property Components As ICollection(Of CfgSolutionComponent)
Visual C++
public:
property ICollection<CfgSolutionComponent^>^ Components {
    ICollection<CfgSolutionComponent^>^ get ();
    void set (ICollection<CfgSolutionComponent^>^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.DBID Property
CfgService Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.Name Property
CfgService Class See Also Send Feedback
A pointer to the name of the service/solution. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.Resources Property
CfgService Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgService.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgObjectResource> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As ICollection(Of CfgObjectResource)
Visual C++
public:
property ICollection<CfgObjectResource^>^ Resources {
    ICollection<CfgObjectResource^>^ get ();
    void set (ICollection<CfgObjectResource^>^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SCS Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.SCS Property
CfgService Class See Also Send Feedback
A unique identifier of an Application of CFGSCStype which is supposed to control the solution. See comment number 4. See also CfgSolutionComponent .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication SCS { get; set; }
Visual Basic (Declaration)
Public Property SCS As CfgApplication
Visual C++
public:
property CfgApplication^ SCS {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SolutionType Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.SolutionType Property
CfgService Class See Also Send Feedback
The type of the solution. Mandatory. Once specified cannot be changed. See CfgSolutionType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionType SolutionType { get; set; }
Visual Basic (Declaration)
Public Property SolutionType As CfgSolutionType
Visual C++
public:
property CfgSolutionType SolutionType {
    CfgSolutionType get ();
    void set (CfgSolutionType value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.StartupType Property
CfgService Class See Also Send Feedback
A type of solution/service startup. Specifies whether this solution/service have to be started by Management Layer. See CfgStartupType. Read-only. Specified during application prototype definition. The value is associated with solution type CfgSolutionType. The value for the solutions of CFGSTDefaultSolutionType and CFGSTFramework type is set to CFGSUTManual, and for other applications is set to CFGSUTAutomatic.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStartupType StartupType { get; set; }
Visual Basic (Declaration)
Public Property StartupType As CfgStartupType
Visual C++
public:
property CfgStartupType StartupType {
    CfgStartupType get ();
    void set (CfgStartupType value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.State Property
CfgService Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.UserProperties Property
CfgService Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgService..::.Version Property
CfgService Class See Also Send Feedback
A pointer to the version of the solution. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgService Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServiceInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgServiceInfo Class
Members See Also Send Feedback
CfgServiceInfo

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServiceInfo : CfgStructure
Visual Basic (Declaration)
Public Class CfgServiceInfo _
    Inherits CfgStructure
Visual C++
public ref class CfgServiceInfo : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgServiceInfo

See Also

CfgServiceInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServiceInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfo Members
CfgServiceInfo Class Constructors Methods Properties See Also Send Feedback

The CfgServiceInfo type exposes the following members.

Constructors

Name | Description
CfgServiceInfo | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgServiceInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServiceInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServiceInfo Constructor
CfgServiceInfo Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServiceInfo(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgServiceInfo(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServiceInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServiceInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgServiceInfo.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgServiceInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServiceInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfo Methods
CfgServiceInfo Class See Also Send Feedback

The CfgServiceInfo type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgServiceInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgServiceInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfo Properties
CfgServiceInfo Class See Also Send Feedback

The CfgServiceInfo type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgServiceInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkill Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkill Class
Members See Also Send Feedback
Skills are qualities or abilities that Agents possess. These Skills affect how Agents are placed in a contact center hierarchy. Common skills include abilities in different languages, particular categories of product knowledge, or ability in particular types of sales.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkill : CfgObject
Visual Basic (Declaration)
Public Class CfgSkill _
    Inherits CfgObject
Visual C++
public ref class CfgSkill : public CfgObject

Remarks

Deletion of Skill X will cause the following events set out in the order of arrival: Modification of skillLevels of all agents that were associated with Skill X Deletion of Skill X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSkill

See Also

CfgSkill Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkill Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkill Members
CfgSkill Class Constructors Methods Properties See Also Send Feedback

The CfgSkill type exposes the following members.

Constructors

Name | Description
CfgSkill | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the skill. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this skill belongs to. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkill Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkill Constructor
CfgSkill Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkill(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgSkill(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkill.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkill.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkill Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkill Methods
CfgSkill Class See Also Send Feedback

The CfgSkill type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.Save Method
CfgSkill Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.SetAccountPermissions Method
CfgSkill Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgSkill Class
CfgSkill Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.SetTenantDBID Method
CfgSkill Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkill.SetTenantDBID(System.Int32)"]

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkill Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkill Properties
CfgSkill Class See Also Send Feedback

The CfgSkill type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the skill. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this skill belongs to. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.DBID Property
CfgSkill Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.Name Property
CfgSkill Class See Also Send Feedback
A pointer to the name of the skill. Mandatory. Must be unique within the tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.State Property
CfgSkill Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.Tenant Property
CfgSkill Class See Also Send Feedback
A unique identifier of the Tenant that this skill belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkill..::.UserProperties Property
CfgSkill Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgSkill Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkillLevel Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel Class
Members See Also Send Feedback
CfgSkillLevel

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkillLevel : CfgStructure
Visual Basic (Declaration)
Public Class CfgSkillLevel _
    Inherits CfgStructure
Visual C++
public ref class CfgSkillLevel : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSkillLevel

See Also

CfgSkillLevel Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkillLevel Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel Members
CfgSkillLevel Class Constructors Methods Properties See Also Send Feedback

The CfgSkillLevel type exposes the following members.

Constructors

Name | Description
CfgSkillLevel | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSkillDBID | SetSkillDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Level | Level of the skill. Cannot be a negative value.
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Skill | A unique identifier of the skill the level relates to. See CfgSkill . Mandatory. Once specified, cannot be changed. This skill must belong to the tenant that this agent belongs to. The same value cannot be repeated within one list.

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkillLevel Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel Constructor
CfgSkillLevel Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkillLevel(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgSkillLevel(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkillLevel.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkillLevel.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkillLevel.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkillLevel Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel Methods
CfgSkillLevel Class See Also Send Feedback

The CfgSkillLevel type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSkillDBID | SetSkillDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSkillDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel..::.SetSkillDBID Method
CfgSkillLevel Class See Also Send Feedback
SetSkillDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSkillDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSkillDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSkillDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSkillLevel.SetSkillDBID(System.Int32)"]

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSkillLevel Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel Properties
CfgSkillLevel Class See Also Send Feedback

The CfgSkillLevel type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Level | Level of the skill. Cannot be a negative value.
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
Skill | A unique identifier of the skill the level relates to. See CfgSkill . Mandatory. Once specified, cannot be changed. This skill must belong to the tenant that this agent belongs to. The same value cannot be repeated within one list.

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Level Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel..::.Level Property
CfgSkillLevel Class See Also Send Feedback
Level of the skill. Cannot be a negative value.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Skill Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevel..::.Skill Property
CfgSkillLevel Class See Also Send Feedback
A unique identifier of the skill the level relates to. See CfgSkill . Mandatory. Once specified, cannot be changed. This skill must belong to the tenant that this agent belongs to. The same value cannot be repeated within one list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkill Skill { get; set; }
Visual Basic (Declaration)
Public Property Skill As CfgSkill
Visual C++
public:
property CfgSkill^ Skill {
    CfgSkill^ get ();
    void set (CfgSkill^ value);
}

See Also

CfgSkillLevel Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponent Class

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent Class
Members See Also Send Feedback
CfgSolutionComponent

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSolutionComponent : CfgStructure
Visual Basic (Declaration)
Public Class CfgSolutionComponent _
    Inherits CfgStructure
Visual C++
public ref class CfgSolutionComponent : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSolutionComponent

See Also

CfgSolutionComponent Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponent Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent Members
CfgSolutionComponent Class Constructors Methods Properties See Also Send Feedback

The CfgSolutionComponent type exposes the following members.

Constructors

Name | Description
CfgSolutionComponent | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAppDBID | SetAppDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
App | A unique identifier of an Application with type appType and version appVersion Mandatory (application must be specified within solution) for solution components within a solution if isOptional is set to CFGFalse. The application could be chosen from the list of applications based on application template/prototype specified in appPrototypeDBID.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IsOptional | Determines whether this solution component is optional. Recommended to be set to CFGFalse by default. Must be shown as READONLY property in object of type CfgService (Solution). Refers to CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
StartupPriority | The startup priority of the solution component in a component sequence. Component numbers should be used to determine the order in which components should be started and stopped. Must be defined as positive integer. Mandatory. Once specified cannot be changed. Must be shown as READONLY property in object of type CfgService (Solution).

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponent Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent Constructor
CfgSolutionComponent Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionComponent(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgSolutionComponent(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponent.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent Methods
CfgSolutionComponent Class See Also Send Feedback

The CfgSolutionComponent type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetAppDBID | SetAppDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAppDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent..::.SetAppDBID Method
CfgSolutionComponent Class See Also Send Feedback
SetAppDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetAppDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetAppDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetAppDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponent.SetAppDBID(System.Int32)"]

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent Properties
CfgSolutionComponent Class See Also Send Feedback

The CfgSolutionComponent type exposes the following members.

Properties

Name | Description
App | A unique identifier of an Application with type appType and version appVersion Mandatory (application must be specified within solution) for solution components within a solution if isOptional is set to CFGFalse. The application could be chosen from the list of applications based on application template/prototype specified in appPrototypeDBID.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IsOptional | Determines whether this solution component is optional. Recommended to be set to CFGFalse by default. Must be shown as READONLY property in object of type CfgService (Solution). Refers to CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
StartupPriority | The startup priority of the solution component in a component sequence. Component numbers should be used to determine the order in which components should be started and stopped. Must be defined as positive integer. Mandatory. Once specified cannot be changed. Must be shown as READONLY property in object of type CfgService (Solution).

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


App Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent..::.App Property
CfgSolutionComponent Class See Also Send Feedback
A unique identifier of an Application with type appType and version appVersion Mandatory (application must be specified within solution) for solution components within a solution if isOptional is set to CFGFalse. The application could be chosen from the list of applications based on application template/prototype specified in appPrototypeDBID.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication App { get; set; }
Visual Basic (Declaration)
Public Property App As CfgApplication
Visual C++
public:
property CfgApplication^ App {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsOptional Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent..::.IsOptional Property
CfgSolutionComponent Class See Also Send Feedback
Determines whether this solution component is optional. Recommended to be set to CFGFalse by default. Must be shown as READONLY property in object of type CfgService (Solution). Refers to CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsOptional { get; set; }
Visual Basic (Declaration)
Public Property IsOptional As CfgFlag
Visual C++
public:
property CfgFlag IsOptional {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupPriority Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponent..::.StartupPriority Property
CfgSolutionComponent Class See Also Send Feedback
The startup priority of the solution component in a component sequence. Component numbers should be used to determine the order in which components should be started and stopped. Must be defined as positive integer. Mandatory. Once specified cannot be changed. Must be shown as READONLY property in object of type CfgService (Solution).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupPriority { get; set; }
Visual Basic (Declaration)
Public Property StartupPriority As Integer
Visual C++
public:
property int StartupPriority {
    int get ();
    void set (int value);
}

See Also

CfgSolutionComponent Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponentDefinition Class

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition Class
Members See Also Send Feedback
CfgSolutionComponentDefinition

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSolutionComponentDefinition : CfgStructure
Visual Basic (Declaration)
Public Class CfgSolutionComponentDefinition _
    Inherits CfgStructure
Visual C++
public ref class CfgSolutionComponentDefinition : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSolutionComponentDefinition

See Also

CfgSolutionComponentDefinition Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponentDefinition Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition Members
CfgSolutionComponentDefinition Class Constructors Methods Properties See Also Send Feedback

The CfgSolutionComponentDefinition type exposes the following members.

Constructors

Name | Description
CfgSolutionComponentDefinition | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IsOptional | Determines whether this solution component default value is optional. Recommended to be set to CFGFalse by default. Must be shown as READONLY property in object of type CfgService (Solution). Refers to CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
StartupPriority | The default number of the solution component in a component startup sequence within solution. StartupPriority value should be used to determine the order in which components should be started and stopped. The value defined as default could be changed at time of SolutionComponent definition. Must be defined as positive integer. Mandatory. Must be shown as the READONLY property in an object of type CfgService (Solution).
Type | Type of the application that is used as solution component. Mandatory. Once specified, cannot be changed. See CfgAppType .
Version | A pointer to the application version that is used as solution component. Once specified, cannot be changed.

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponentDefinition Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition Constructor
CfgSolutionComponentDefinition Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionComponentDefinition(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgSolutionComponentDefinition(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponentDefinition.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponentDefinition.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSolutionComponentDefinition.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponentDefinition Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition Methods
CfgSolutionComponentDefinition Class See Also Send Feedback

The CfgSolutionComponentDefinition type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSolutionComponentDefinition Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition Properties
CfgSolutionComponentDefinition Class See Also Send Feedback

The CfgSolutionComponentDefinition type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IsOptional | Determines whether this solution component default value is optional. Recommended to be set to CFGFalse by default. Must be shown as READONLY property in object of type CfgService (Solution). Refers to CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
StartupPriority | The default number of the solution component in a component startup sequence within solution. StartupPriority value should be used to determine the order in which components should be started and stopped. The value defined as default could be changed at time of SolutionComponent definition. Must be defined as positive integer. Mandatory. Must be shown as the READONLY property in an object of type CfgService (Solution).
Type | Type of the application that is used as solution component. Mandatory. Once specified, cannot be changed. See CfgAppType .
Version | A pointer to the application version that is used as solution component. Once specified, cannot be changed.

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsOptional Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition..::.IsOptional Property
CfgSolutionComponentDefinition Class See Also Send Feedback
Determines whether this solution component default value is optional. Recommended to be set to CFGFalse by default. Must be shown as READONLY property in object of type CfgService (Solution). Refers to CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsOptional { get; set; }
Visual Basic (Declaration)
Public Property IsOptional As CfgFlag
Visual C++
public:
property CfgFlag IsOptional {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartupPriority Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition..::.StartupPriority Property
CfgSolutionComponentDefinition Class See Also Send Feedback
The default number of the solution component in a component startup sequence within solution. StartupPriority value should be used to determine the order in which components should be started and stopped. The value defined as default could be changed at time of SolutionComponent definition. Must be defined as positive integer. Mandatory. Must be shown as the READONLY property in an object of type CfgService (Solution).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupPriority { get; set; }
Visual Basic (Declaration)
Public Property StartupPriority As Integer
Visual C++
public:
property int StartupPriority {
    int get ();
    void set (int value);
}

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition..::.Type Property
CfgSolutionComponentDefinition Class See Also Send Feedback
Type of the application that is used as solution component. Mandatory. Once specified, cannot be changed. See CfgAppType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinition..::.Version Property
CfgSolutionComponentDefinition Class See Also Send Feedback
A pointer to the application version that is used as solution component. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSolutionComponentDefinition Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatDay Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay Class
Members See Also Send Feedback
A Statistical Day is a numerically-expressed workload that a particular Agent Group is expected to handle during a particular business day.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatDay : CfgObject
Visual Basic (Declaration)
Public Class CfgStatDay _
    Inherits CfgObject
Visual C++
public ref class CfgStatDay : public CfgObject

Remarks

Deletion of Stat Day X will cause the following events set out in the order of arrival: Modification of statDayDBIDs of all stat tables that included Stat Day X Deletion of Stat Day X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgStatDay

See Also

CfgStatDay Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatDay Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDay Members
CfgStatDay Class Constructors Methods Properties See Also Send Feedback

The CfgStatDay type exposes the following members.

Constructors

Name | Description
CfgStatDay | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Date | Day of specific year calculated since 00:00:00 GMT Jan 1, 1970 measured in seconds. Once specified, cannot be changed. If value is specified the values of parameters isDayOfWeek and day must be ignored.
Day | Day's number. If isDayOfWeek is set to CFGTrue, the allowable range is from 1 to 7 (where 1 stands for Sunday). If isDayOfWeek is set to CFGFalse, the allowable range is from 1 to 366 and 1 (where 1 stands for January 1 and -1 stands for any day). Mandatory. Once specified, cannot be changed. The parameter is ignored if value of parameter date is specified.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndTime | End of business time of day measured in minutes from 00:00. Cannot be negative and can not be greater than 1440. If set to be less than the setting for startTime, implies the time of the next calendar day (night shift).
FlatRate | Amount to be charged for processing the forecast volume of interactions.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IntervalLength | Statistical interval in minutes. Must be a multiple of five. Once specified, cannot be changed. Recommended to be set to 15 by default.
IsDayOfWeek | Indicator of whether this day is identified as a day of week ( CFGTrue) or a day of year (CFGFalse). Mandatory. Once specified, cannot be changed. The parameter is ignored if value of parameter date is specified. Refer to CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MaxValue | Maximum statistical value for the day. Cannot be negative or less than the setting for minValue.
MinValue | Minimum statistical value for the day. Cannot be negative.
Name | A pointer to the name of the day. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartTime | Start of business time of day measured in minutes from 00:00. Cannot be negative and can not be greater than 1440.
State | Current object state. Mandatory. Refer to CfgObjectState
StatIntervals | A pointer to the list of the structures of CfgStatInterval type that associate intervals with certain statistical values. When used as an entry in CfgDeltaStatDay (see below), it is a pointer to a list of structures of type CfgStatInterval added to the existing list.
TargetValue | Target statistical value for the day. Cannot be less than the setting for minVlaue or greater than the setting for maxValue.
Tenant | A unique identifier of the Tenant that this day is defined for. Mandatory. Once specified, cannot be changed.
Type | Statistical Day type. Refer to CfgStatDayType
UseFlatRate | Flag determining whether flatRate (CFGTrue) should be selected. Refer to CfgFlag
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatDay Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay Constructor
CfgStatDay Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDay(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgStatDay(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatDay.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatDay.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatDay Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDay Methods
CfgStatDay Class See Also Send Feedback

The CfgStatDay type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.Save Method
CfgStatDay Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.SetAccountPermissions Method
CfgStatDay Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgStatDay Class
CfgStatDay Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.SetTenantDBID Method
CfgStatDay Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatDay.SetTenantDBID(System.Int32)"]

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatDay Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDay Properties
CfgStatDay Class See Also Send Feedback

The CfgStatDay type exposes the following members.

Properties

Name | Description
Date | Day of specific year calculated since 00:00:00 GMT Jan 1, 1970 measured in seconds. Once specified, cannot be changed. If value is specified the values of parameters isDayOfWeek and day must be ignored.
Day | Day's number. If isDayOfWeek is set to CFGTrue, the allowable range is from 1 to 7 (where 1 stands for Sunday). If isDayOfWeek is set to CFGFalse, the allowable range is from 1 to 366 and 1 (where 1 stands for January 1 and -1 stands for any day). Mandatory. Once specified, cannot be changed. The parameter is ignored if value of parameter date is specified.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
EndTime | End of business time of day measured in minutes from 00:00. Cannot be negative and can not be greater than 1440. If set to be less than the setting for startTime, implies the time of the next calendar day (night shift).
FlatRate | Amount to be charged for processing the forecast volume of interactions.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IntervalLength | Statistical interval in minutes. Must be a multiple of five. Once specified, cannot be changed. Recommended to be set to 15 by default.
IsDayOfWeek | Indicator of whether this day is identified as a day of week ( CFGTrue) or a day of year (CFGFalse). Mandatory. Once specified, cannot be changed. The parameter is ignored if value of parameter date is specified. Refer to CfgFlag
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
MaxValue | Maximum statistical value for the day. Cannot be negative or less than the setting for minValue.
MinValue | Minimum statistical value for the day. Cannot be negative.
Name | A pointer to the name of the day. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StartTime | Start of business time of day measured in minutes from 00:00. Cannot be negative and can not be greater than 1440.
State | Current object state. Mandatory. Refer to CfgObjectState
StatIntervals | A pointer to the list of the structures of CfgStatInterval type that associate intervals with certain statistical values. When used as an entry in CfgDeltaStatDay (see below), it is a pointer to a list of structures of type CfgStatInterval added to the existing list.
TargetValue | Target statistical value for the day. Cannot be less than the setting for minVlaue or greater than the setting for maxValue.
Tenant | A unique identifier of the Tenant that this day is defined for. Mandatory. Once specified, cannot be changed.
Type | Statistical Day type. Refer to CfgStatDayType
UseFlatRate | Flag determining whether flatRate (CFGTrue) should be selected. Refer to CfgFlag
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Date Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.Date Property
CfgStatDay Class See Also Send Feedback
Day of specific year calculated since 00:00:00 GMT Jan 1, 1970 measured in seconds. Once specified, cannot be changed. If value is specified the values of parameters isDayOfWeek and day must be ignored.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic (Declaration)
Public Property Date As DateTime
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Day Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.Day Property
CfgStatDay Class See Also Send Feedback
Day's number. If isDayOfWeek is set to CFGTrue, the allowable range is from 1 to 7 (where 1 stands for Sunday). If isDayOfWeek is set to CFGFalse, the allowable range is from 1 to 366 and 1 (where 1 stands for January 1 and -1 stands for any day). Mandatory. Once specified, cannot be changed. The parameter is ignored if value of parameter date is specified.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Day { get; set; }
Visual Basic (Declaration)
Public Property Day As Integer
Visual C++
public:
property int Day {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.DBID Property
CfgStatDay Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


EndTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.EndTime Property
CfgStatDay Class See Also Send Feedback
End of business time of day measured in minutes from 00:00. Cannot be negative and can not be greater than 1440. If set to be less than the setting for startTime, implies the time of the next calendar day (night shift).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int EndTime { get; set; }
Visual Basic (Declaration)
Public Property EndTime As Integer
Visual C++
public:
property int EndTime {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.FlatRate Property
CfgStatDay Class See Also Send Feedback
Amount to be charged for processing the forecast volume of interactions.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FlatRate { get; set; }
Visual Basic (Declaration)
Public Property FlatRate As Integer
Visual C++
public:
property int FlatRate {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IntervalLength Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.IntervalLength Property
CfgStatDay Class See Also Send Feedback
Statistical interval in minutes. Must be a multiple of five. Once specified, cannot be changed. Recommended to be set to 15 by default.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IntervalLength { get; set; }
Visual Basic (Declaration)
Public Property IntervalLength As Integer
Visual C++
public:
property int IntervalLength {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsDayOfWeek Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.IsDayOfWeek Property
CfgStatDay Class See Also Send Feedback
Indicator of whether this day is identified as a day of week ( CFGTrue) or a day of year (CFGFalse). Mandatory. Once specified, cannot be changed. The parameter is ignored if value of parameter date is specified. Refer to CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDayOfWeek { get; set; }
Visual Basic (Declaration)
Public Property IsDayOfWeek As CfgFlag
Visual C++
public:
property CfgFlag IsDayOfWeek {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MaxValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.MaxValue Property
CfgStatDay Class See Also Send Feedback
Maximum statistical value for the day. Cannot be negative or less than the setting for minValue.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxValue { get; set; }
Visual Basic (Declaration)
Public Property MaxValue As Integer
Visual C++
public:
property int MaxValue {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


MinValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.MinValue Property
CfgStatDay Class See Also Send Feedback
Minimum statistical value for the day. Cannot be negative.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinValue { get; set; }
Visual Basic (Declaration)
Public Property MinValue As Integer
Visual C++
public:
property int MinValue {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.Name Property
CfgStatDay Class See Also Send Feedback
A pointer to the name of the day. Mandatory. Must be unique within the tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StartTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.StartTime Property
CfgStatDay Class See Also Send Feedback
Start of business time of day measured in minutes from 00:00. Cannot be negative and can not be greater than 1440.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As Integer
Visual C++
public:
property int StartTime {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.State Property
CfgStatDay Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatIntervals Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.StatIntervals Property
CfgStatDay Class See Also Send Feedback
A pointer to the list of the structures of CfgStatInterval type that associate intervals with certain statistical values. When used as an entry in CfgDeltaStatDay (see below), it is a pointer to a list of structures of type CfgStatInterval added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatInterval> StatIntervals { get; set; }
Visual Basic (Declaration)
Public Property StatIntervals As ICollection(Of CfgStatInterval)
Visual C++
public:
property ICollection<CfgStatInterval^>^ StatIntervals {
    ICollection<CfgStatInterval^>^ get ();
    void set (ICollection<CfgStatInterval^>^ value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TargetValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.TargetValue Property
CfgStatDay Class See Also Send Feedback
Target statistical value for the day. Cannot be less than the setting for minVlaue or greater than the setting for maxValue.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TargetValue { get; set; }
Visual Basic (Declaration)
Public Property TargetValue As Integer
Visual C++
public:
property int TargetValue {
    int get ();
    void set (int value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.Tenant Property
CfgStatDay Class See Also Send Feedback
A unique identifier of the Tenant that this day is defined for. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.Type Property
CfgStatDay Class See Also Send Feedback
Statistical Day type. Refer to CfgStatDayType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDayType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgStatDayType
Visual C++
public:
property CfgStatDayType Type {
    CfgStatDayType get ();
    void set (CfgStatDayType value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseFlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.UseFlatRate Property
CfgStatDay Class See Also Send Feedback
Flag determining whether flatRate (CFGTrue) should be selected. Refer to CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseFlatRate { get; set; }
Visual Basic (Declaration)
Public Property UseFlatRate As CfgFlag
Visual C++
public:
property CfgFlag UseFlatRate {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDay..::.UserProperties Property
CfgStatDay Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgStatDay Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatInterval Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval Class
Members See Also Send Feedback
CfgStatInterval

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatInterval : CfgStructure
Visual Basic (Declaration)
Public Class CfgStatInterval _
    Inherits CfgStructure
Visual C++
public ref class CfgStatInterval : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgStatInterval

See Also

CfgStatInterval Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatInterval Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatInterval Members
CfgStatInterval Class Constructors Methods Properties See Also Send Feedback

The CfgStatInterval type exposes the following members.

Constructors

Name | Description
CfgStatInterval | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IntervalCount | Interval's number. Once specified, cannot be changed. The first interval has number 1. First interval is always counted from the start of business time set by startTime in CfgStatDay .
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
StatValue1 |
StatValue2 |
StatValue3 |
StatValue4 |

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatInterval Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval Constructor
CfgStatInterval Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatInterval(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgStatInterval(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatInterval Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatInterval Methods
CfgStatInterval Class See Also Send Feedback

The CfgStatInterval type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatInterval Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatInterval Properties
CfgStatInterval Class See Also Send Feedback

The CfgStatInterval type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
IntervalCount | Interval's number. Once specified, cannot be changed. The first interval has number 1. First interval is always counted from the start of business time set by startTime in CfgStatDay .
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
StatValue1 |
StatValue2 |
StatValue3 |
StatValue4 |

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IntervalCount Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval..::.IntervalCount Property
CfgStatInterval Class See Also Send Feedback
Interval's number. Once specified, cannot be changed. The first interval has number 1. First interval is always counted from the start of business time set by startTime in CfgStatDay .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IntervalCount { get; set; }
Visual Basic (Declaration)
Public Property IntervalCount As Integer
Visual C++
public:
property int IntervalCount {
    int get ();
    void set (int value);
}

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatValue1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval..::.StatValue1 Property
CfgStatInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.StatValue1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue1 { get; set; }
Visual Basic (Declaration)
Public Property StatValue1 As Integer
Visual C++
public:
property int StatValue1 {
    int get ();
    void set (int value);
}

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatValue2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval..::.StatValue2 Property
CfgStatInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.StatValue2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue2 { get; set; }
Visual Basic (Declaration)
Public Property StatValue2 As Integer
Visual C++
public:
property int StatValue2 {
    int get ();
    void set (int value);
}

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatValue3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval..::.StatValue3 Property
CfgStatInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.StatValue3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue3 { get; set; }
Visual Basic (Declaration)
Public Property StatValue3 As Integer
Visual C++
public:
property int StatValue3 {
    int get ();
    void set (int value);
}

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatValue4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatInterval..::.StatValue4 Property
CfgStatInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatInterval.StatValue4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue4 { get; set; }
Visual Basic (Declaration)
Public Property StatValue4 As Integer
Visual C++
public:
property int StatValue4 {
    int get ();
    void set (int value);
}

See Also

CfgStatInterval Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatTable Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable Class
Members See Also Send Feedback
Statistical Tables are groups of Statistical Days that represent statistically-modeled performances of Agent Groups over a calendar period of up to one year. Call-processing applications can use Statistical Tables to provide load balancing between Agent Groups when the real-time statistics for those groups are unavailable.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatTable : CfgObject
Visual Basic (Declaration)
Public Class CfgStatTable _
    Inherits CfgObject
Visual C++
public ref class CfgStatTable : public CfgObject

Remarks

Deletion of Stat Table X will cause the following events set out in the order of arrival: Modification of capacityTableDBID or quotaTableDBID of all agent groups that were associated with Stat Table X Modification of capacityTableDBID or quotaTableDBID of all place groups that were associated with Stat Table X Modification of capacityTableDBID or quotaTableDBID of all DN groups that were associated with Stat Table X Deletion of Stat Table X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgStatTable

See Also

CfgStatTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatTable Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTable Members
CfgStatTable Class Constructors Methods Properties See Also Send Feedback

The CfgStatTable type exposes the following members.

Constructors

Name | Description
CfgStatTable | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
AgentHourlyRate | The hourly rate for an agent. This value is used only for Variable Rate Contracts.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FlatRate | A flat rate measured in cost units.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the table. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StatDays | A pointer to the list of identifiers of the Statistical Days that constitute the table. When used as an entry in CfgDeltaStatTable (see below), it is a pointer to a list of days added to the existing list.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this table is defined for. Mandatory. Once specified, cannot be changed.
Type | Type of stat table. Once specified, cannot be changed. Refer to CfgStatTableType .
UseFlatRate | Flag determining whether flatRate (CFGTrue) or agentHourlyRate (CFGFalse) should be selected. Refer to CfgFlag
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
WaitThreshold | The time the Universal Routing Server can wait until the corresponding resources become available.

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatTable Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable Constructor
CfgStatTable Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTable(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgStatTable(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatTable.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatTable.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatTable Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTable Methods
CfgStatTable Class See Also Send Feedback

The CfgStatTable type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.Save Method
CfgStatTable Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.SetAccountPermissions Method
CfgStatTable Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgStatTable Class
CfgStatTable Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.SetTenantDBID Method
CfgStatTable Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgStatTable.SetTenantDBID(System.Int32)"]

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgStatTable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTable Properties
CfgStatTable Class See Also Send Feedback

The CfgStatTable type exposes the following members.

Properties

Name | Description
AgentHourlyRate | The hourly rate for an agent. This value is used only for Variable Rate Contracts.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FlatRate | A flat rate measured in cost units.
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the table. Mandatory. Must be unique within the tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
StatDays | A pointer to the list of identifiers of the Statistical Days that constitute the table. When used as an entry in CfgDeltaStatTable (see below), it is a pointer to a list of days added to the existing list.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this table is defined for. Mandatory. Once specified, cannot be changed.
Type | Type of stat table. Once specified, cannot be changed. Refer to CfgStatTableType .
UseFlatRate | Flag determining whether flatRate (CFGTrue) or agentHourlyRate (CFGFalse) should be selected. Refer to CfgFlag
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.
WaitThreshold | The time the Universal Routing Server can wait until the corresponding resources become available.

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AgentHourlyRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.AgentHourlyRate Property
CfgStatTable Class See Also Send Feedback
The hourly rate for an agent. This value is used only for Variable Rate Contracts.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AgentHourlyRate { get; set; }
Visual Basic (Declaration)
Public Property AgentHourlyRate As Integer
Visual C++
public:
property int AgentHourlyRate {
    int get ();
    void set (int value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.DBID Property
CfgStatTable Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


FlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.FlatRate Property
CfgStatTable Class See Also Send Feedback
A flat rate measured in cost units.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FlatRate { get; set; }
Visual Basic (Declaration)
Public Property FlatRate As Integer
Visual C++
public:
property int FlatRate {
    int get ();
    void set (int value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.Name Property
CfgStatTable Class See Also Send Feedback
A pointer to the name of the table. Mandatory. Must be unique within the tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


StatDays Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.StatDays Property
CfgStatTable Class See Also Send Feedback
A pointer to the list of identifiers of the Statistical Days that constitute the table. When used as an entry in CfgDeltaStatTable (see below), it is a pointer to a list of days added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgStatDay> StatDays { get; set; }
Visual Basic (Declaration)
Public Property StatDays As ICollection(Of CfgStatDay)
Visual C++
public:
property ICollection<CfgStatDay^>^ StatDays {
    ICollection<CfgStatDay^>^ get ();
    void set (ICollection<CfgStatDay^>^ value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.State Property
CfgStatTable Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.Tenant Property
CfgStatTable Class See Also Send Feedback
A unique identifier of the Tenant that this table is defined for. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.Type Property
CfgStatTable Class See Also Send Feedback
Type of stat table. Once specified, cannot be changed. Refer to CfgStatTableType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTableType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgStatTableType
Visual C++
public:
property CfgStatTableType Type {
    CfgStatTableType get ();
    void set (CfgStatTableType value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UseFlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.UseFlatRate Property
CfgStatTable Class See Also Send Feedback
Flag determining whether flatRate (CFGTrue) or agentHourlyRate (CFGFalse) should be selected. Refer to CfgFlag

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseFlatRate { get; set; }
Visual Basic (Declaration)
Public Property UseFlatRate As CfgFlag
Visual C++
public:
property CfgFlag UseFlatRate {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.UserProperties Property
CfgStatTable Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


WaitThreshold Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTable..::.WaitThreshold Property
CfgStatTable Class See Also Send Feedback
The time the Universal Routing Server can wait until the corresponding resources become available.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int WaitThreshold { get; set; }
Visual Basic (Declaration)
Public Property WaitThreshold As Integer
Visual C++
public:
property int WaitThreshold {
    int get ();
    void set (int value);
}

See Also

CfgStatTable Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSubcode Class

[image]

Enterprise SDK 8.0 Reference API
CfgSubcode Class
Members See Also Send Feedback
CfgSubcode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSubcode : CfgStructure
Visual Basic (Declaration)
Public Class CfgSubcode _
    Inherits CfgStructure
Visual C++
public ref class CfgSubcode : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSubcode

See Also

CfgSubcode Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSubcode Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcode Members
CfgSubcode Class Constructors Methods Properties See Also Send Feedback

The CfgSubcode type exposes the following members.

Constructors

Name | Description
CfgSubcode | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Code | A pointer to the index or abbreviation of the subcode. Mandatory. Once specified, cannot be changed.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the subcode. Mandatory. Must be unique within the action code. Once specified, cannot be changed.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgSubcode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSubcode Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSubcode Constructor
CfgSubcode Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSubcode(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgSubcode(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSubcode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSubcode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSubcode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgSubcode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSubcode Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcode Methods
CfgSubcode Class See Also Send Feedback

The CfgSubcode type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgSubcode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSubcode Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcode Properties
CfgSubcode Class See Also Send Feedback

The CfgSubcode type exposes the following members.

Properties

Name | Description
Code | A pointer to the index or abbreviation of the subcode. Mandatory. Once specified, cannot be changed.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the subcode. Mandatory. Must be unique within the action code. Once specified, cannot be changed.
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgSubcode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Code Property

[image]

Enterprise SDK 8.0 Reference API
CfgSubcode..::.Code Property
CfgSubcode Class See Also Send Feedback
A pointer to the index or abbreviation of the subcode. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSubcode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSubcode..::.Name Property
CfgSubcode Class See Also Send Feedback
A pointer to the name of the subcode. Mandatory. Must be unique within the action code. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSubcode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitch Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch Class
Members See Also Send Feedback
A Switch is an aggregate of telephony resources within a Switching Office. Most enterprise-level configurations have a one-to-one match between switches and switching offices. However, there may be instances when it is desirable to partition an office into more than one switch, perhaps due to CTI_link capacity limitations, or to create a more efficient and secure numbering plan. In that case, you must define these switches within a switching office.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitch : CfgObject
Visual Basic (Declaration)
Public Class CfgSwitch _
    Inherits CfgObject
Visual C++
public ref class CfgSwitch : public CfgObject

Remarks

The current version of Configuration Server does not verify correspondence between the switch numbering plan defined by DNRange and the actual DN numbers defined within this switch by number in CfgDN . Such verification may be implemented in one of the next versions. In versions 5.1.1XX and earlier, it is users' responsibility to make sure the range covers all actual DNs of the switch in question. Deletion of Switch X will cause the following events set out in the order of arrival: Modification of switchAccessCodes of all switches that were interfaced with Switch X Modification of voice prompt objects which had switchDBID field set to Switch X Modification of accessNumbers of all DNs which were connected with Switch X Modifications of flexibleProperties of all T-Servers which were connected with Switch X Deletion of all DNs of Switch X (see comments to CfgDN for details) Deletion of all agent logins of Switch X (see comments to CfgAgentLogin for details) Deletion of all folders that had Switch X defined as the parent object Deletion of Switch X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSwitch

See Also

CfgSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitch Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitch Members
CfgSwitch Class Constructors Methods Properties See Also Send Feedback

The CfgSwitch type exposes the following members.

Constructors

Name | Description
CfgSwitch | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetPhysSwitchDBID
SetPhysSwitchDBID
SetTenantDBID
SetTenantDBID
SetTServerDBID
SetTServerDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DNRange | A pointer to a string that describes the numbering plan of the switch. Use a hyphen to specify a range of numbers; use commas to specify a series of stand-alone numbers or ranges (e.g., 1100-1179, 1190-1195, 1199).
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LinkType | Type of the CTI link of this switch. Optional. See CfgLinkType
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the switch. Mandatory. Must be unique within the tenant and the physical switch.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PhysSwitch | A unique identifier of the Physical Switch within which this switch is defined. Mandatory. Once specified, cannot be changed.
State | Current object state. Mandatory. Refer to CfgObjectState
SwitchAccessCodes | A pointer to the list of access codes of the switches that this switch can access (every item of this list is structured as CfgSwitchAccessCode ). When used as an entry in CfgDeltaSwitch , it is a pointer to a list of switch access codes added to the existing list.
Tenant | A unique identifier of the Tenant to which this switch is allocated. Mandatory. Once specified, cannot be changed.
TServer | A unique identifier of the T-Server Application through which the telephony objects of this switch are controlled. Parameter tenantDBIDs of the T-Server must be specified and match the setting of tenantDBID of this switch. One T-Server cannot be associated with more than one switch unless the switch is of type CFGMultimediaSwitch. The property is applicable for 5.1 applications only, for compatibility. Starting from release 6.0 the association between T-Server and switch have to be configured using CfgApplication (T-Server) object. See flexibleProperties in CfgApplication.
Type | Type of the physical switch to which this switch belongs. Read-only (set automatically according to the current value of type of the physical switch specified in physSwitchDBID). See CfgSwitchType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitch Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch Constructor
CfgSwitch Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgSwitch(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitch.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitch.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitch Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitch Methods
CfgSwitch Class See Also Send Feedback

The CfgSwitch type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetPhysSwitchDBID
SetPhysSwitchDBID
SetTenantDBID
SetTenantDBID
SetTServerDBID
SetTServerDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.Save Method
CfgSwitch Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.SetAccountPermissions Method
CfgSwitch Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgSwitch Class
CfgSwitch Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetPhysSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.SetPhysSwitchDBID Method
CfgSwitch Class See Also Send Feedback
SetPhysSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetPhysSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetPhysSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetPhysSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitch.SetPhysSwitchDBID(System.Int32)"]

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.SetTenantDBID Method
CfgSwitch Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitch.SetTenantDBID(System.Int32)"]

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTServerDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.SetTServerDBID Method
CfgSwitch Class See Also Send Feedback
SetTServerDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTServerDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTServerDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTServerDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitch.SetTServerDBID(System.Int32)"]

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitch Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitch Properties
CfgSwitch Class See Also Send Feedback

The CfgSwitch type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DNRange | A pointer to a string that describes the numbering plan of the switch. Use a hyphen to specify a range of numbers; use commas to specify a series of stand-alone numbers or ranges (e.g., 1100-1179, 1190-1195, 1199).
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LinkType | Type of the CTI link of this switch. Optional. See CfgLinkType
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the switch. Mandatory. Must be unique within the tenant and the physical switch.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
PhysSwitch | A unique identifier of the Physical Switch within which this switch is defined. Mandatory. Once specified, cannot be changed.
State | Current object state. Mandatory. Refer to CfgObjectState
SwitchAccessCodes | A pointer to the list of access codes of the switches that this switch can access (every item of this list is structured as CfgSwitchAccessCode ). When used as an entry in CfgDeltaSwitch , it is a pointer to a list of switch access codes added to the existing list.
Tenant | A unique identifier of the Tenant to which this switch is allocated. Mandatory. Once specified, cannot be changed.
TServer | A unique identifier of the T-Server Application through which the telephony objects of this switch are controlled. Parameter tenantDBIDs of the T-Server must be specified and match the setting of tenantDBID of this switch. One T-Server cannot be associated with more than one switch unless the switch is of type CFGMultimediaSwitch. The property is applicable for 5.1 applications only, for compatibility. Starting from release 6.0 the association between T-Server and switch have to be configured using CfgApplication (T-Server) object. See flexibleProperties in CfgApplication.
Type | Type of the physical switch to which this switch belongs. Read-only (set automatically according to the current value of type of the physical switch specified in physSwitchDBID). See CfgSwitchType .
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.DBID Property
CfgSwitch Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DNRange Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.DNRange Property
CfgSwitch Class See Also Send Feedback
A pointer to a string that describes the numbering plan of the switch. Use a hyphen to specify a range of numbers; use commas to specify a series of stand-alone numbers or ranges (e.g., 1100-1179, 1190-1195, 1199).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DNRange { get; set; }
Visual Basic (Declaration)
Public Property DNRange As String
Visual C++
public:
property String^ DNRange {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LinkType Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.LinkType Property
CfgSwitch Class See Also Send Feedback
Type of the CTI link of this switch. Optional. See CfgLinkType

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgLinkType LinkType { get; set; }
Visual Basic (Declaration)
Public Property LinkType As CfgLinkType
Visual C++
public:
property CfgLinkType LinkType {
    CfgLinkType get ();
    void set (CfgLinkType value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.Name Property
CfgSwitch Class See Also Send Feedback
A pointer to the name of the switch. Mandatory. Must be unique within the tenant and the physical switch.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PhysSwitch Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.PhysSwitch Property
CfgSwitch Class See Also Send Feedback
A unique identifier of the Physical Switch within which this switch is defined. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhysicalSwitch PhysSwitch { get; set; }
Visual Basic (Declaration)
Public Property PhysSwitch As CfgPhysicalSwitch
Visual C++
public:
property CfgPhysicalSwitch^ PhysSwitch {
    CfgPhysicalSwitch^ get ();
    void set (CfgPhysicalSwitch^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.State Property
CfgSwitch Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SwitchAccessCodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.SwitchAccessCodes Property
CfgSwitch Class See Also Send Feedback
A pointer to the list of access codes of the switches that this switch can access (every item of this list is structured as CfgSwitchAccessCode ). When used as an entry in CfgDeltaSwitch , it is a pointer to a list of switch access codes added to the existing list.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<CfgSwitchAccessCode> SwitchAccessCodes { get; set; }
Visual Basic (Declaration)
Public Property SwitchAccessCodes As ICollection(Of CfgSwitchAccessCode)
Visual C++
public:
property ICollection<CfgSwitchAccessCode^>^ SwitchAccessCodes {
    ICollection<CfgSwitchAccessCode^>^ get ();
    void set (ICollection<CfgSwitchAccessCode^>^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.Tenant Property
CfgSwitch Class See Also Send Feedback
A unique identifier of the Tenant to which this switch is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.TServer Property
CfgSwitch Class See Also Send Feedback
A unique identifier of the T-Server Application through which the telephony objects of this switch are controlled. Parameter tenantDBIDs of the T-Server must be specified and match the setting of tenantDBID of this switch. One T-Server cannot be associated with more than one switch unless the switch is of type CFGMultimediaSwitch. The property is applicable for 5.1 applications only, for compatibility. Starting from release 6.0 the association between T-Server and switch have to be configured using CfgApplication (T-Server) object. See flexibleProperties in CfgApplication.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication TServer { get; set; }
Visual Basic (Declaration)
Public Property TServer As CfgApplication
Visual C++
public:
property CfgApplication^ TServer {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.Type Property
CfgSwitch Class See Also Send Feedback
Type of the physical switch to which this switch belongs. Read-only (set automatically according to the current value of type of the physical switch specified in physSwitchDBID). See CfgSwitchType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CfgSwitchType
Visual C++
public:
property CfgSwitchType Type {
    CfgSwitchType get ();
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitch..::.UserProperties Property
CfgSwitch Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgSwitch Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitchAccessCode Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode Class
Members See Also Send Feedback
CfgSwitchAccessCode

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitchAccessCode : CfgStructure
Visual Basic (Declaration)
Public Class CfgSwitchAccessCode _
    Inherits CfgStructure
Visual C++
public ref class CfgSwitchAccessCode : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgSwitchAccessCode

See Also

CfgSwitchAccessCode Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitchAccessCode Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode Members
CfgSwitchAccessCode Class Constructors Methods Properties See Also Send Feedback

The CfgSwitchAccessCode type exposes the following members.

Constructors

Name | Description
CfgSwitchAccessCode | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSwitchDBID | SetSwitchDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
AccessCode | A pointer to the access code.
DestinationSource | Source of information to specify parameter destination in function TRouteCall. See comments.
DnisSource | Source of information to specify parameter dnis in function TRouteCall.
DnSource | Source of information to specify parameter dn in function TRouteCall. See comments.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExtensionSource | Source of information to specify parameter extensions in function TRouteCall.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LocationSource | Source of information to specify parameter location in function TRouteCall.
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ReasonSource | Source of information to specify parameter reasons in function TRouteCall.
RouteType | Type of routing for the target specified in targetType for this switch. See CfgRouteType .
Switch | A unique identifier of the Switch to which this access code is assigned. Mandatory. If value is set to 0 the accessCode value is used as default access to this switch if no other access code is specified on source switch to access this switch.
TargetType | Type of the target within the switch specified by switchDBID for which all the routing parameters below are specified. See CfgTargetType .

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitchAccessCode Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode Constructor
CfgSwitchAccessCode Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchAccessCode(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgSwitchAccessCode(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitchAccessCode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitchAccessCode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitchAccessCode.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitchAccessCode Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode Methods
CfgSwitchAccessCode Class See Also Send Feedback

The CfgSwitchAccessCode type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
SetSwitchDBID | SetSwitchDBID
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.SetSwitchDBID Method
CfgSwitchAccessCode Class See Also Send Feedback
SetSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgSwitchAccessCode.SetSwitchDBID(System.Int32)"]

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgSwitchAccessCode Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode Properties
CfgSwitchAccessCode Class See Also Send Feedback

The CfgSwitchAccessCode type exposes the following members.

Properties

Name | Description
AccessCode | A pointer to the access code.
DestinationSource | Source of information to specify parameter destination in function TRouteCall. See comments.
DnisSource | Source of information to specify parameter dnis in function TRouteCall.
DnSource | Source of information to specify parameter dn in function TRouteCall. See comments.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
ExtensionSource | Source of information to specify parameter extensions in function TRouteCall.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
LocationSource | Source of information to specify parameter location in function TRouteCall.
Logger | (Inherited from AbstractLogEnabled.)
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)
ReasonSource | Source of information to specify parameter reasons in function TRouteCall.
RouteType | Type of routing for the target specified in targetType for this switch. See CfgRouteType .
Switch | A unique identifier of the Switch to which this access code is assigned. Mandatory. If value is set to 0 the accessCode value is used as default access to this switch if no other access code is specified on source switch to access this switch.
TargetType | Type of the target within the switch specified by switchDBID for which all the routing parameters below are specified. See CfgTargetType .

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


AccessCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.AccessCode Property
CfgSwitchAccessCode Class See Also Send Feedback
A pointer to the access code.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AccessCode { get; set; }
Visual Basic (Declaration)
Public Property AccessCode As String
Visual C++
public:
property String^ AccessCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DestinationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.DestinationSource Property
CfgSwitchAccessCode Class See Also Send Feedback
Source of information to specify parameter destination in function TRouteCall. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DestinationSource { get; set; }
Visual Basic (Declaration)
Public Property DestinationSource As String
Visual C++
public:
property String^ DestinationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DnisSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.DnisSource Property
CfgSwitchAccessCode Class See Also Send Feedback
Source of information to specify parameter dnis in function TRouteCall.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnisSource { get; set; }
Visual Basic (Declaration)
Public Property DnisSource As String
Visual C++
public:
property String^ DnisSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DnSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.DnSource Property
CfgSwitchAccessCode Class See Also Send Feedback
Source of information to specify parameter dn in function TRouteCall. See comments.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnSource { get; set; }
Visual Basic (Declaration)
Public Property DnSource As String
Visual C++
public:
property String^ DnSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ExtensionSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.ExtensionSource Property
CfgSwitchAccessCode Class See Also Send Feedback
Source of information to specify parameter extensions in function TRouteCall.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExtensionSource { get; set; }
Visual Basic (Declaration)
Public Property ExtensionSource As String
Visual C++
public:
property String^ ExtensionSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


LocationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.LocationSource Property
CfgSwitchAccessCode Class See Also Send Feedback
Source of information to specify parameter location in function TRouteCall.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LocationSource { get; set; }
Visual Basic (Declaration)
Public Property LocationSource As String
Visual C++
public:
property String^ LocationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ReasonSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.ReasonSource Property
CfgSwitchAccessCode Class See Also Send Feedback
Source of information to specify parameter reasons in function TRouteCall.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ReasonSource { get; set; }
Visual Basic (Declaration)
Public Property ReasonSource As String
Visual C++
public:
property String^ ReasonSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.RouteType Property
CfgSwitchAccessCode Class See Also Send Feedback
Type of routing for the target specified in targetType for this switch. See CfgRouteType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; set; }
Visual Basic (Declaration)
Public Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
    void set (CfgRouteType value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.Switch Property
CfgSwitchAccessCode Class See Also Send Feedback
A unique identifier of the Switch to which this access code is assigned. Mandatory. If value is set to 0 the accessCode value is used as default access to this switch if no other access code is specified on source switch to access this switch.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
    void set (CfgSwitch^ value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


TargetType Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCode..::.TargetType Property
CfgSwitchAccessCode Class See Also Send Feedback
Type of the target within the switch specified by switchDBID for which all the routing parameters below are specified. See CfgTargetType .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTargetType TargetType { get; set; }
Visual Basic (Declaration)
Public Property TargetType As CfgTargetType
Visual C++
public:
property CfgTargetType TargetType {
    CfgTargetType get ();
    void set (CfgTargetType value);
}

See Also

CfgSwitchAccessCode Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTableAccess Class

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess Class
Members See Also Send Feedback
Table Access objects describe database tables of a specified Format and explain how to access these tables through Database Access Points.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTableAccess : CfgObject
Visual Basic (Declaration)
Public Class CfgTableAccess _
    Inherits CfgObject
Visual C++
public ref class CfgTableAccess : public CfgObject

Remarks

One TableAccess can be dedicated to several objects of CfgCallingList type. A TableAccess cannot be deleted as long as it is associated with at least one CallingList (see CfgCallingList ).

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTableAccess

See Also

CfgTableAccess Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTableAccess Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccess Members
CfgTableAccess Class Constructors Methods Properties See Also Send Feedback

The CfgTableAccess type exposes the following members.

Constructors

Name | Description
CfgTableAccess | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDbAccessDBID
SetDbAccessDBID
SetFormatDBID
SetFormatDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DbAccess | A unique identifier of the CfgApplication of type CFGDBServer (DB Access Point) through which the table can be accessed. Mandatory.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DbTableName | A pointer to the name of table in data base. Due to restrictions of some database engines the recommended length for property name is 1 to 12 characters. Mandatory.
Description | A list pointer to the description of table.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | A unique identifier of CfgFormat of this table. Once specified cannot be changed. The property is mandatory for all table types except CFGTTLogTable. See CfgTableType.
IsCachable | An indicator of whether the table data shell be mirrored in application memory. See type CfgFlag .
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the mnemonic name of table access. Mandatory. Must be unique within the Tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this table access is allocated. Mandatory. Once specified, cannot be changed.
Type | A type of table. Refer to CfgTableType of User Defined Variable Types. Mandatory. Once specified, cannot be changed.
UpdateTimeout | A timeout between updates of table data in application memory. Active if parameter isCachable set to true only.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTableAccess Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess Constructor
CfgTableAccess Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccess(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgTableAccess(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTableAccess.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTableAccess.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTableAccess Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccess Methods
CfgTableAccess Class See Also Send Feedback

The CfgTableAccess type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDbAccessDBID
SetDbAccessDBID
SetFormatDBID
SetFormatDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.Save Method
CfgTableAccess Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.SetAccountPermissions Method
CfgTableAccess Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgTableAccess Class
CfgTableAccess Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDbAccessDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.SetDbAccessDBID Method
CfgTableAccess Class See Also Send Feedback
SetDbAccessDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDbAccessDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDbAccessDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDbAccessDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTableAccess.SetDbAccessDBID(System.Int32)"]

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetFormatDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.SetFormatDBID Method
CfgTableAccess Class See Also Send Feedback
SetFormatDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetFormatDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetFormatDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetFormatDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTableAccess.SetFormatDBID(System.Int32)"]

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.SetTenantDBID Method
CfgTableAccess Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTableAccess.SetTenantDBID(System.Int32)"]

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTableAccess Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccess Properties
CfgTableAccess Class See Also Send Feedback

The CfgTableAccess type exposes the following members.

Properties

Name | Description
DbAccess | A unique identifier of the CfgApplication of type CFGDBServer (DB Access Point) through which the table can be accessed. Mandatory.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DbTableName | A pointer to the name of table in data base. Due to restrictions of some database engines the recommended length for property name is 1 to 12 characters. Mandatory.
Description | A list pointer to the description of table.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Format | A unique identifier of CfgFormat of this table. Once specified cannot be changed. The property is mandatory for all table types except CFGTTLogTable. See CfgTableType.
IsCachable | An indicator of whether the table data shell be mirrored in application memory. See type CfgFlag .
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the mnemonic name of table access. Mandatory. Must be unique within the Tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this table access is allocated. Mandatory. Once specified, cannot be changed.
Type | A type of table. Refer to CfgTableType of User Defined Variable Types. Mandatory. Once specified, cannot be changed.
UpdateTimeout | A timeout between updates of table data in application memory. Active if parameter isCachable set to true only.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DbAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.DbAccess Property
CfgTableAccess Class See Also Send Feedback
A unique identifier of the CfgApplication of type CFGDBServer (DB Access Point) through which the table can be accessed. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplication DbAccess { get; set; }
Visual Basic (Declaration)
Public Property DbAccess As CfgApplication
Visual C++
public:
property CfgApplication^ DbAccess {
    CfgApplication^ get ();
    void set (CfgApplication^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.DBID Property
CfgTableAccess Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DbTableName Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.DbTableName Property
CfgTableAccess Class See Also Send Feedback
A pointer to the name of table in data base. Due to restrictions of some database engines the recommended length for property name is 1 to 12 characters. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DbTableName { get; set; }
Visual Basic (Declaration)
Public Property DbTableName As String
Visual C++
public:
property String^ DbTableName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.Description Property
CfgTableAccess Class See Also Send Feedback
A list pointer to the description of table.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Format Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.Format Property
CfgTableAccess Class See Also Send Feedback
A unique identifier of CfgFormat of this table. Once specified cannot be changed. The property is mandatory for all table types except CFGTTLogTable. See CfgTableType.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As CfgFormat
Visual C++
public:
property CfgFormat^ Format {
    CfgFormat^ get ();
    void set (CfgFormat^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsCachable Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.IsCachable Property
CfgTableAccess Class See Also Send Feedback
An indicator of whether the table data shell be mirrored in application memory. See type CfgFlag .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsCachable { get; set; }
Visual Basic (Declaration)
Public Property IsCachable As CfgFlag
Visual C++
public:
property CfgFlag IsCachable {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.Name Property
CfgTableAccess Class See Also Send Feedback
A pointer to the mnemonic name of table access. Mandatory. Must be unique within the Tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.State Property
CfgTableAccess Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.Tenant Property
CfgTableAccess Class See Also Send Feedback
A unique identifier of the CfgTenant to which this table access is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.Type Property
CfgTableAccess Class See Also Send Feedback
A type of table. Refer to CfgTableType of User Defined Variable Types. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgTableType
Visual C++
public:
property CfgTableType Type {
    CfgTableType get ();
    void set (CfgTableType value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UpdateTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.UpdateTimeout Property
CfgTableAccess Class See Also Send Feedback
A timeout between updates of table data in application memory. Active if parameter isCachable set to true only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int UpdateTimeout { get; set; }
Visual Basic (Declaration)
Public Property UpdateTimeout As Integer
Visual C++
public:
property int UpdateTimeout {
    int get ();
    void set (int value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccess..::.UserProperties Property
CfgTableAccess Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTableAccess Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTenant Class

[image]

Enterprise SDK 8.0 Reference API
CfgTenant Class
Members See Also Send Feedback
A Tenant is a business whose customer interactions are enabled or enhanced through services offered by a third party, typically a telecommunications service provider. From a functional standpoint, each tenant in a multi-tenant environment is a contact center (single or multi-site) completely equipped to process customer interactions. From an architectural standpoint, however, most of the hardware and software that tenants use to enable or enhance those interactions belongs to the service provider.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTenant : CfgObject
Visual Basic (Declaration)
Public Class CfgTenant _
    Inherits CfgObject
Visual C++
public ref class CfgTenant : public CfgObject

Remarks

Deletion of Tenant X will cause the following events set out in the order of arrival: Modification of tenantDBIDsof all applications associated with Tenant X (see CfgApplication ) Deletion of all agent groups of Tenant X Deletion of all place groups of Tenant X Deletion of all DN groups of Tenant X Deletion of all access groups of Tenant X Deletion of all scripts of Tenant X Deletion of all persons of Tenant X (see comments to CfgPerson for details) Deletion of all places of Tenant X Deletion of all switches of Tenant X (see comments to CfgSwitch for details) Deletion of all skills of Tenant X Deletion of all action codes of Tenant X Deletion of all stat tables of Tenant X Deletion of all stat days of Tenant X Deletion of all transactions of Tenant X Deletion of all fields of Tenant X Deletion of all formats of Tenant X Deletion of all filters of Tenant X Deletion of all table accesses of Tenant X Deletion of all treatments of Tenant X Deletion of all calling lists of Tenant X Deletion of all campaigns of Tenant X Deletion of all time zones of Tenant X Deletion of all voice prompts of Tenant X Deletion of all enumerators of Tenant X (see comments to CfgEnumerator for details) Deletion of all IVRs of Tenant X (see comments to CfgIVR for details) Deletion of all objective tables of Tenant X Deletion of all folders that had Tenant X defined as the parent object Deletion of Tenant X The following tenant is pre-defined (scripted) in the Configuration Database before Configuration Server is started for the first time: dbid = 1 isServiceProvider = CFGTrue name = _Environment_ password = empty string isSuperTenant = CFGFalse state = CFGEnabled This tenant (with DBID=1) cannot be deleted or modified in any way The association between a solution and a tenant should be made using assignedTenantDBIDwithin the CfgService object. The tenant can not be deleted as long as contains persons serving as accounts for some server objects

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTenant

See Also

CfgTenant Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTenant Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenant Members
CfgTenant Class Constructors Methods Properties See Also Send Feedback

The CfgTenant type exposes the following members.

Constructors

Name | Description
CfgTenant | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDefaultCapacityRuleDBID
SetDefaultCapacityRuleDBID
SetDefaultContractDBID
SetDefaultContractDBID
SetParentTenantDBID
SetParentTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Address | Not in use.
ChargeableNumber | A pointer to the string value that is used for service charges of this tenant. Max length 64 symbols.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DefaultCapacityRule | A unique identifier of the capacity rule ( CfgScript ) associated with this tenant.
DefaultContract | A unique identifier of the cost contract ( CfgObjectiveTable ) associated with this tenant.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsServiceProvider | An indicator of whether the tenant belongs to the Service Provider. (see CfgFlag ) Read-only (set automatically when a tenant is created).
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the tenant. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentTenant |
Password | A pointer to the tenant password. Max length 64 symbols.
State | Current object state. Mandatory. Refer to CfgObjectState
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTenant Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTenant Constructor
CfgTenant Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgTenant(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTenant.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTenant.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTenant Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenant Methods
CfgTenant Class See Also Send Feedback

The CfgTenant type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDefaultCapacityRuleDBID
SetDefaultCapacityRuleDBID
SetDefaultContractDBID
SetDefaultContractDBID
SetParentTenantDBID
SetParentTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.Save Method
CfgTenant Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.SetAccountPermissions Method
CfgTenant Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgTenant Class
CfgTenant Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDefaultCapacityRuleDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.SetDefaultCapacityRuleDBID Method
CfgTenant Class See Also Send Feedback
SetDefaultCapacityRuleDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDefaultCapacityRuleDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDefaultCapacityRuleDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDefaultCapacityRuleDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTenant.SetDefaultCapacityRuleDBID(System.Int32)"]

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDefaultContractDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.SetDefaultContractDBID Method
CfgTenant Class See Also Send Feedback
SetDefaultContractDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDefaultContractDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDefaultContractDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDefaultContractDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTenant.SetDefaultContractDBID(System.Int32)"]

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetParentTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.SetParentTenantDBID Method
CfgTenant Class See Also Send Feedback
SetParentTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetParentTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetParentTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetParentTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTenant.SetParentTenantDBID(System.Int32)"]

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTenant Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenant Properties
CfgTenant Class See Also Send Feedback

The CfgTenant type exposes the following members.

Properties

Name | Description
Address | Not in use.
ChargeableNumber | A pointer to the string value that is used for service charges of this tenant. Max length 64 symbols.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
DefaultCapacityRule | A unique identifier of the capacity rule ( CfgScript ) associated with this tenant.
DefaultContract | A unique identifier of the cost contract ( CfgObjectiveTable ) associated with this tenant.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsServiceProvider | An indicator of whether the tenant belongs to the Service Provider. (see CfgFlag ) Read-only (set automatically when a tenant is created).
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to name of the tenant. Mandatory. Must be unique within the Configuration Database.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
ParentTenant |
Password | A pointer to the tenant password. Max length 64 symbols.
State | Current object state. Mandatory. Refer to CfgObjectState
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.Address Property
CfgTenant Class See Also Send Feedback
Not in use.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddress Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddress
Visual C++
public:
property CfgAddress^ Address {
    CfgAddress^ get ();
    void set (CfgAddress^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ChargeableNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.ChargeableNumber Property
CfgTenant Class See Also Send Feedback
A pointer to the string value that is used for service charges of this tenant. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ChargeableNumber { get; set; }
Visual Basic (Declaration)
Public Property ChargeableNumber As String
Visual C++
public:
property String^ ChargeableNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.DBID Property
CfgTenant Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DefaultCapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.DefaultCapacityRule Property
CfgTenant Class See Also Send Feedback
A unique identifier of the capacity rule ( CfgScript ) associated with this tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript DefaultCapacityRule { get; set; }
Visual Basic (Declaration)
Public Property DefaultCapacityRule As CfgScript
Visual C++
public:
property CfgScript^ DefaultCapacityRule {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DefaultContract Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.DefaultContract Property
CfgTenant Class See Also Send Feedback
A unique identifier of the cost contract ( CfgObjectiveTable ) associated with this tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTable DefaultContract { get; set; }
Visual Basic (Declaration)
Public Property DefaultContract As CfgObjectiveTable
Visual C++
public:
property CfgObjectiveTable^ DefaultContract {
    CfgObjectiveTable^ get ();
    void set (CfgObjectiveTable^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsServiceProvider Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.IsServiceProvider Property
CfgTenant Class See Also Send Feedback
An indicator of whether the tenant belongs to the Service Provider. (see CfgFlag ) Read-only (set automatically when a tenant is created).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsServiceProvider { get; set; }
Visual Basic (Declaration)
Public Property IsServiceProvider As CfgFlag
Visual C++
public:
property CfgFlag IsServiceProvider {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.Name Property
CfgTenant Class See Also Send Feedback
A pointer to name of the tenant. Mandatory. Must be unique within the Configuration Database.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


ParentTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.ParentTenant Property
CfgTenant Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTenant.ParentTenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant ParentTenant { get; set; }
Visual Basic (Declaration)
Public Property ParentTenant As CfgTenant
Visual C++
public:
property CfgTenant^ ParentTenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.Password Property
CfgTenant Class See Also Send Feedback
A pointer to the tenant password. Max length 64 symbols.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.State Property
CfgTenant Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenant..::.UserProperties Property
CfgTenant Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTenant Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTimeZone Class

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone Class
Members See Also Send Feedback
Time Zones are predefined objects that provide CTI applications with information about world time zones. Each object describes one time zone.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTimeZone : CfgObject
Visual Basic (Declaration)
Public Class CfgTimeZone _
    Inherits CfgObject
Visual C++
public ref class CfgTimeZone : public CfgObject

Remarks

time_t = int or long i.e. 32 bit value at least The time_t type logically divided into several sections, following bit-mask should be used to get an info: Time_t Bit Mask Description Bits Description Range Comments 0-3 Month, 0-12; DST is not Observed=0 Jan=1 Dec=12 ####### Week 0-5, 7 DST is not observed or week is not specified= 0 Last week of month = 7 Note: The day of last week of month=week will be set to 7, if the day of week does not occur on last week The day of last week of month=week will be set to 1, if the day of week does not occur on first week ####### Day 0-31, 63 DST is not observed = 0 Last day of month = 63 If week is specified (week!=0) the range should be 1-7 Sun=1 Sat=7 13-18 Start_time, Stop_Time 0-47 in 30 minute units 1:00 am = 2 19-24 Year (shift from 2000) 0, 1-38, 39-63 Only if Time Zone is defined for specific Year. 2001 = 1 DST is not observed or year is not specified=0 Values within range 39-63 are not valid 25-30 reserved reserved reserved ####### A flag to recognize custom/6.0 time zone reserved Has to be used to distinguish custom time zones and time zones created before release 6.1: New Style = 1 Old Style or custom time zone = 0 Definition of Time Zones for Calculation Schema name Description offset IsDST Month Week Date Time_start Month Week Date Time_stop Year GMT Greenwich Mean Time 0 TRUE 3 7 1 4 10 7 1 6 0 ECT European Central Time 2 TRUE 3 7 1 4 10 7 1 6 0 EET Eastern European Time 4 TRUE 3 7 1 6 10 7 1 8 0 ART (Arabic) Egypt Standard Time 4 TRUE 4 7 6 0 9 7 6 0 0 EAT Eastern African Time 6 FALSE 0 0 0 0 0 0 0 0 0 MET Middle East Time 7 TRUE 3 0 20 0 9 0 22 0 0 NET Near East Time 8 FALSE 0 0 0 0 0 0 0 0 0 PLT Pakistan Lahore Time 10 FALSE 0 0 0 0 0 0 0 0 0 IST India Standard Time 11 FALSE 0 0 0 0 0 0 0 0 0 BST Bangladesh Standard Time 12 TRUE 3 7 1 0 10 7 1 0 0 VST Vietnam Standard Time 14 FALSE 0 0 0 0 0 0 0 0 0 CTT China Taiwan Time 16 FALSE 0 0 0 0 0 0 0 0 0 JST Japan Standard Time 18 FALSE 0 0 0 0 0 0 0 0 0 KST Korea Standard Time 18 FALSE 0 0 0 0 0 0 0 0 0 ACT Australia Central Time 19 FALSE 0 0 0 0 0 0 0 0 0 AET Australia Eastern Time 20 TRUE 8 7 7 4 3 7 1 4 0 SST Solomon Standard Time 22 FALSE 0 0 0 0 0 0 0 0 0 NST New Zealand Standard Time 24 TRUE 10 1 1 4 3 3 1 6 0 MIT Midway Islands Time -22 FALSE 0 0 0 0 0 0 0 0 0 HST Hawaii Standard Time -20 FALSE 0 0 0 0 0 0 0 0 0 AST Alaska Standard Time -18 TRUE 4 1 1 4 10 7 1 4 0 PST Pacific Standard Time -16 TRUE 4 1 1 4 10 7 1 4 0 PNT Phoenix Standard Time -14 FALSE 0 0 0 0 0 0 0 0 0 MST Mountain Standard Time -14 TRUE 4 1 1 4 10 7 1 4 0 CST Central Standard Time -12 TRUE 4 1 1 4 10 7 1 4 0 EST Eastern Standard Time -10 TRUE 4 1 1 4 10 7 1 4 0 IET Indiana Eastern Standard -10 FALSE 0 0 0 0 0 0 0 0 0 PRT Puerto Rico and US Virgin Islands Time -8 FALSE 0 0 0 0 0 0 0 0 0 CNT Canada Newfoundland Time -7 TRUE 4 1 1 4 10 7 1 4 0 AGT Argentina Standard Time -6 FALSE 0 0 0 0 0 0 0 0 0 BET Brazil Eastern Time -6 TRUE 10 2 1 0 2 7 1 0 0 CAT Central African Time -2 FALSE 0 0 0 0 0 0 0 0 0 AtlST Atlantic Standard Time -8 TRUE 4 1 1 4 10 7 1 4 0 The DSTStartTime / DSTStopTime can be calculated using function ConfCalculateTimeZone(). All calculated values of DSTStartTime / DSTStopTime represnet a calendar value, not a local time at any particular timezone. In order to use this calculated value one can call gmtime() function in C/C++ runtime library to get the value parsed into tm structure. Note, however, that resulted value is not a GMT time of transition, but again a calendar value, applicable for the configured timezone. In this case tm structure and gmtime() function have being reused only to parse configuration, without inheriting their meaning from runtime library. You should be carefull when applying any translations, because funtcions of runtime library that accept a time_t value usually perform additional interpretation of that value as either local or universal time (while actual value in this case is, in fact, just a calendar item, not a time). For instance, you cannot use mktime() or even _mkgmtime() - windows to convert this value back into time_t, because first assume you have a local time that ned to be recalculated to GMT by changing timezone, while second give you much closer result (because it will not count for timezone) but might add/substract one hour from result, due to its DST-awarenes. You should not attempt to convert it back and you shoudl use content of tm structure as a configuration information (including day, month, year fields) and treat this information as applicable for a timezone for that this infromation is supplied.

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTimeZone

See Also

CfgTimeZone Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTimeZone Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZone Members
CfgTimeZone Class Constructors Methods Properties See Also Send Feedback

The CfgTimeZone type exposes the following members.

Constructors

Name | Description
CfgTimeZone | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to time zone description.
DSTOffset | The value of DST offset. Default is 60 (minutes).
DSTStartDate | DST start date. The value is: measured in seconds if 6.0 definition schema is uses. Refer to time_t from time.h of ANSI C library. Year value range 0-2038; performed based on calculation schema. (See comments.)
DSTStopDate | DST stop date. The value is: measured in seconds if 6.0 definition schema is uses. Refer to time_t from time.h of ANSI C library. Year value range 0-2038; performed based on calculation schema. (See comments.)
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDSTObserved |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to time zone name. Mandatory. Must be unique within tenant environment.
NameMSExplorer | A pointer to the time zone name used by Microsoft browser. Mandatory
NameNetscape | A pointer to the time zone name used by Netscape Navigator browser. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Offset | A time zone offset. Any integer value from -24 to 24. Must be considered as value -12 to 12 with 0.5 hour step.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this time zone is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTimeZone Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone Constructor
CfgTimeZone Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZone(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgTimeZone(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTimeZone.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTimeZone.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTimeZone Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZone Methods
CfgTimeZone Class See Also Send Feedback

The CfgTimeZone type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.Save Method
CfgTimeZone Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.SetAccountPermissions Method
CfgTimeZone Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgTimeZone Class
CfgTimeZone Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.SetTenantDBID Method
CfgTimeZone Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTimeZone.SetTenantDBID(System.Int32)"]

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTimeZone Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZone Properties
CfgTimeZone Class See Also Send Feedback

The CfgTimeZone type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to time zone description.
DSTOffset | The value of DST offset. Default is 60 (minutes).
DSTStartDate | DST start date. The value is: measured in seconds if 6.0 definition schema is uses. Refer to time_t from time.h of ANSI C library. Year value range 0-2038; performed based on calculation schema. (See comments.)
DSTStopDate | DST stop date. The value is: measured in seconds if 6.0 definition schema is uses. Refer to time_t from time.h of ANSI C library. Year value range 0-2038; performed based on calculation schema. (See comments.)
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
IsDSTObserved |
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to time zone name. Mandatory. Must be unique within tenant environment.
NameMSExplorer | A pointer to the time zone name used by Microsoft browser. Mandatory
NameNetscape | A pointer to the time zone name used by Netscape Navigator browser. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Offset | A time zone offset. Any integer value from -24 to 24. Must be considered as value -12 to 12 with 0.5 hour step.
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this time zone is allocated. Mandatory. Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.DBID Property
CfgTimeZone Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.Description Property
CfgTimeZone Class See Also Send Feedback
A pointer to time zone description.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DSTOffset Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.DSTOffset Property
CfgTimeZone Class See Also Send Feedback
The value of DST offset. Default is 60 (minutes).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DSTOffset { get; set; }
Visual Basic (Declaration)
Public Property DSTOffset As Integer
Visual C++
public:
property int DSTOffset {
    int get ();
    void set (int value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DSTStartDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.DSTStartDate Property
CfgTimeZone Class See Also Send Feedback
DST start date. The value is: measured in seconds if 6.0 definition schema is uses. Refer to time_t from time.h of ANSI C library. Year value range 0-2038; performed based on calculation schema. (See comments.)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DSTStartDate { get; set; }
Visual Basic (Declaration)
Public Property DSTStartDate As DateTime
Visual C++
public:
property DateTime DSTStartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DSTStopDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.DSTStopDate Property
CfgTimeZone Class See Also Send Feedback
DST stop date. The value is: measured in seconds if 6.0 definition schema is uses. Refer to time_t from time.h of ANSI C library. Year value range 0-2038; performed based on calculation schema. (See comments.)

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DSTStopDate { get; set; }
Visual Basic (Declaration)
Public Property DSTStopDate As DateTime
Visual C++
public:
property DateTime DSTStopDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


IsDSTObserved Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.IsDSTObserved Property
CfgTimeZone Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTimeZone.IsDSTObserved"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDSTObserved { get; set; }
Visual Basic (Declaration)
Public Property IsDSTObserved As CfgFlag
Visual C++
public:
property CfgFlag IsDSTObserved {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.Name Property
CfgTimeZone Class See Also Send Feedback
A pointer to time zone name. Mandatory. Must be unique within tenant environment.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NameMSExplorer Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.NameMSExplorer Property
CfgTimeZone Class See Also Send Feedback
A pointer to the time zone name used by Microsoft browser. Mandatory

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameMSExplorer { get; set; }
Visual Basic (Declaration)
Public Property NameMSExplorer As String
Visual C++
public:
property String^ NameMSExplorer {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


NameNetscape Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.NameNetscape Property
CfgTimeZone Class See Also Send Feedback
A pointer to the time zone name used by Netscape Navigator browser. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameNetscape { get; set; }
Visual Basic (Declaration)
Public Property NameNetscape As String
Visual C++
public:
property String^ NameNetscape {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Offset Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.Offset Property
CfgTimeZone Class See Also Send Feedback
A time zone offset. Any integer value from -24 to 24. Must be considered as value -12 to 12 with 0.5 hour step.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Integer
Visual C++
public:
property int Offset {
    int get ();
    void set (int value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.State Property
CfgTimeZone Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.Tenant Property
CfgTimeZone Class See Also Send Feedback
A unique identifier of the CfgTenant to which this time zone is allocated. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZone..::.UserProperties Property
CfgTimeZone Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTimeZone Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTransaction Class

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction Class
Members See Also Send Feedback
Transactions define how CTI applications calculate customer-defined statistics.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTransaction : CfgObject
Visual Basic (Declaration)
Public Class CfgTransaction _
    Inherits CfgObject
Visual C++
public ref class CfgTransaction : public CfgObject

Remarks

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTransaction

See Also

CfgTransaction Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTransaction Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransaction Members
CfgTransaction Class Constructors Methods Properties See Also Send Feedback

The CfgTransaction type exposes the following members.

Constructors

Name | Description
CfgTransaction | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Alias | An alternative name for this transaction. If specified, must be unique within the object type specified above for the given tenant .
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the text description of the transaction.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the transaction. Mandatory. Must be unique within the transaction type specified below for the given tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RecordPeriod | Period in minutes that shows how often the current value of the transaction is to be reported or recorded in a data storage.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this transaction belongs to. Mandatory. Once specified, cannot be changed.
Type | Type of the transaction. See type CfgTansactionType. Mandatory. Once specified, cannot be changed. Shall be set to CFGTransaction for PEG counts.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTransaction Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction Constructor
CfgTransaction Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransaction(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgTransaction(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTransaction.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTransaction.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTransaction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransaction Methods
CfgTransaction Class See Also Send Feedback

The CfgTransaction type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.Save Method
CfgTransaction Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.SetAccountPermissions Method
CfgTransaction Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgTransaction Class
CfgTransaction Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.SetTenantDBID Method
CfgTransaction Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTransaction.SetTenantDBID(System.Int32)"]

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTransaction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransaction Properties
CfgTransaction Class See Also Send Feedback

The CfgTransaction type exposes the following members.

Properties

Name | Description
Alias | An alternative name for this transaction. If specified, must be unique within the object type specified above for the given tenant .
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the text description of the transaction.
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the name of the transaction. Mandatory. Must be unique within the transaction type specified below for the given tenant.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
RecordPeriod | Period in minutes that shows how often the current value of the transaction is to be reported or recorded in a data storage.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the Tenant that this transaction belongs to. Mandatory. Once specified, cannot be changed.
Type | Type of the transaction. See type CfgTansactionType. Mandatory. Once specified, cannot be changed. Shall be set to CFGTransaction for PEG counts.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Alias Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.Alias Property
CfgTransaction Class See Also Send Feedback
An alternative name for this transaction. If specified, must be unique within the object type specified above for the given tenant .

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Alias { get; set; }
Visual Basic (Declaration)
Public Property Alias As String
Visual C++
public:
property String^ Alias {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.DBID Property
CfgTransaction Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.Description Property
CfgTransaction Class See Also Send Feedback
A pointer to the text description of the transaction.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.Name Property
CfgTransaction Class See Also Send Feedback
A pointer to the name of the transaction. Mandatory. Must be unique within the transaction type specified below for the given tenant.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RecordPeriod Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.RecordPeriod Property
CfgTransaction Class See Also Send Feedback
Period in minutes that shows how often the current value of the transaction is to be reported or recorded in a data storage.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int RecordPeriod { get; set; }
Visual Basic (Declaration)
Public Property RecordPeriod As Integer
Visual C++
public:
property int RecordPeriod {
    int get ();
    void set (int value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.State Property
CfgTransaction Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.Tenant Property
CfgTransaction Class See Also Send Feedback
A unique identifier of the Tenant that this transaction belongs to. Mandatory. Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.Type Property
CfgTransaction Class See Also Send Feedback
Type of the transaction. See type CfgTansactionType. Mandatory. Once specified, cannot be changed. Shall be set to CFGTransaction for PEG counts.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransactionType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgTransactionType
Visual C++
public:
property CfgTransactionType Type {
    CfgTransactionType get ();
    void set (CfgTransactionType value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransaction..::.UserProperties Property
CfgTransaction Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTransaction Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTreatment Class

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment Class
Members See Also Send Feedback
Treatments, which are most often used in automated outbound campaigns, tell Outbound Contact Server (OCS) how to respond to an unsuccessful call result (a call that does not reach the intended party). For example, the response to an unsuccessful connection may be to redial, and the response to a successful connection may be to play a message. A Treatment Sequence is a group of treatment objects that all contain the same Call Result value. Treatments in a sequence are applied to a call in their numerical order (see the Treatment property Number in Sequence).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTreatment : CfgObject
Visual Basic (Declaration)
Public Class CfgTreatment _
    Inherits CfgObject
Visual C++
public ref class CfgTreatment : public CfgObject

Remarks

One Treatment can be associated with several CallingLists (see CfgCallingList ). Deletion of Treatment X will cause the following events set out in the order of arrival: Modification of treatmentDBIDs of all calling lists that included Treatment X Deletion of Treatment X

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgTreatment

See Also

CfgTreatment Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTreatment Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatment Members
CfgTreatment Class Constructors Methods Properties See Also Send Feedback

The CfgTreatment type exposes the following members.

Constructors

Name | Description
CfgTreatment | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDestDNDBID
SetDestDNDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
Attempts | An attempt number to which the action should be performed.
CallActionCode | A call action code. Refer to CfgCallActionCode in User Defined Variable Types. The callActionCode can be applied to following call results only. (Refer to GctiCallState in Variable Types of Common APIs):
CallResult | A call result related to this treatment. Refer to GctiCallState in Variable Types of Common APIs. Mandatory.
CycleAttempt | An maximum number of sequential attempts the treatment can be applied to dn. The parameter is used if recActionCode is set to CFGRACCycle.
DateTime | A time and date when another attempt must be applied again to dn. The parameter is used if recActionCode is set to CFGRACRetryAtDate. Refer to time_t from time.h of ANSI C library.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to treatment action description.
DestDN |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Increment | The time in interval in minutes which increments the interval after each attempt. The parameter is used if recActionCode is set either to CFGRACCycle.
Interval | A time interval in minutes between attempts. The parameter is used if recActionCode is set either to CFGRACCycle or CFGRACRetryIn.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to treatment action name. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Range | Parameter defining a time range
RecActionCode | A record action code. Refer to CfgRecActionCode in User Defined Variable Types.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this treatment action is allocated. Mandatory.Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTreatment Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment Constructor
CfgTreatment Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTreatment(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgTreatment(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTreatment.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTreatment.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTreatment Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatment Methods
CfgTreatment Class See Also Send Feedback

The CfgTreatment type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetDestDNDBID
SetDestDNDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Save Method
CfgTreatment Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.SetAccountPermissions Method
CfgTreatment Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgTreatment Class
CfgTreatment Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetDestDNDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.SetDestDNDBID Method
CfgTreatment Class See Also Send Feedback
SetDestDNDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetDestDNDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetDestDNDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetDestDNDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTreatment.SetDestDNDBID(System.Int32)"]

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.SetTenantDBID Method
CfgTreatment Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTreatment.SetTenantDBID(System.Int32)"]

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgTreatment Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatment Properties
CfgTreatment Class See Also Send Feedback

The CfgTreatment type exposes the following members.

Properties

Name | Description
Attempts | An attempt number to which the action should be performed.
CallActionCode | A call action code. Refer to CfgCallActionCode in User Defined Variable Types. The callActionCode can be applied to following call results only. (Refer to GctiCallState in Variable Types of Common APIs):
CallResult | A call result related to this treatment. Refer to GctiCallState in Variable Types of Common APIs. Mandatory.
CycleAttempt | An maximum number of sequential attempts the treatment can be applied to dn. The parameter is used if recActionCode is set to CFGRACCycle.
DateTime | A time and date when another attempt must be applied again to dn. The parameter is used if recActionCode is set to CFGRACRetryAtDate. Refer to time_t from time.h of ANSI C library.
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to treatment action description.
DestDN |
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Increment | The time in interval in minutes which increments the interval after each attempt. The parameter is used if recActionCode is set either to CFGRACCycle.
Interval | A time interval in minutes between attempts. The parameter is used if recActionCode is set either to CFGRACCycle or CFGRACRetryIn.
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to treatment action name. Mandatory.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Range | Parameter defining a time range
RecActionCode | A record action code. Refer to CfgRecActionCode in User Defined Variable Types.
State | Current object state. Mandatory. Refer to CfgObjectState
Tenant | A unique identifier of the CfgTenant to which this treatment action is allocated. Mandatory.Once specified, cannot be changed.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Attempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Attempts Property
CfgTreatment Class See Also Send Feedback
An attempt number to which the action should be performed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Attempts { get; set; }
Visual Basic (Declaration)
Public Property Attempts As Integer
Visual C++
public:
property int Attempts {
    int get ();
    void set (int value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CallActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.CallActionCode Property
CfgTreatment Class See Also Send Feedback
A call action code. Refer to CfgCallActionCode in User Defined Variable Types. The callActionCode can be applied to following call results only. (Refer to GctiCallState in Variable Types of Common APIs):

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallActionCode CallActionCode { get; set; }
Visual Basic (Declaration)
Public Property CallActionCode As CfgCallActionCode
Visual C++
public:
property CfgCallActionCode CallActionCode {
    CfgCallActionCode get ();
    void set (CfgCallActionCode value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CallResult Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.CallResult Property
CfgTreatment Class See Also Send Feedback
A call result related to this treatment. Refer to GctiCallState in Variable Types of Common APIs. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public GctiCallState CallResult { get; set; }
Visual Basic (Declaration)
Public Property CallResult As GctiCallState
Visual C++
public:
property GctiCallState CallResult {
    GctiCallState get ();
    void set (GctiCallState value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CycleAttempt Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.CycleAttempt Property
CfgTreatment Class See Also Send Feedback
An maximum number of sequential attempts the treatment can be applied to dn. The parameter is used if recActionCode is set to CFGRACCycle.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CycleAttempt { get; set; }
Visual Basic (Declaration)
Public Property CycleAttempt As Integer
Visual C++
public:
property int CycleAttempt {
    int get ();
    void set (int value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DateTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.DateTime Property
CfgTreatment Class See Also Send Feedback
A time and date when another attempt must be applied again to dn. The parameter is used if recActionCode is set to CFGRACRetryAtDate. Refer to time_t from time.h of ANSI C library.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DateTime { get; set; }
Visual Basic (Declaration)
Public Property DateTime As DateTime
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.DBID Property
CfgTreatment Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Description Property
CfgTreatment Class See Also Send Feedback
A pointer to treatment action description.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DestDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.DestDN Property
CfgTreatment Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgTreatment.DestDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDN DestDN { get; set; }
Visual Basic (Declaration)
Public Property DestDN As CfgDN
Visual C++
public:
property CfgDN^ DestDN {
    CfgDN^ get ();
    void set (CfgDN^ value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Increment Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Increment Property
CfgTreatment Class See Also Send Feedback
The time in interval in minutes which increments the interval after each attempt. The parameter is used if recActionCode is set either to CFGRACCycle.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Integer
Visual C++
public:
property int Increment {
    int get ();
    void set (int value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Interval Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Interval Property
CfgTreatment Class See Also Send Feedback
A time interval in minutes between attempts. The parameter is used if recActionCode is set either to CFGRACCycle or CFGRACRetryIn.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Interval { get; set; }
Visual Basic (Declaration)
Public Property Interval As Integer
Visual C++
public:
property int Interval {
    int get ();
    void set (int value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Name Property
CfgTreatment Class See Also Send Feedback
A pointer to treatment action name. Mandatory.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Range Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Range Property
CfgTreatment Class See Also Send Feedback
Parameter defining a time range

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Range { get; set; }
Visual Basic (Declaration)
Public Property Range As Integer
Visual C++
public:
property int Range {
    int get ();
    void set (int value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


RecActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.RecActionCode Property
CfgTreatment Class See Also Send Feedback
A record action code. Refer to CfgRecActionCode in User Defined Variable Types.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRecActionCode RecActionCode { get; set; }
Visual Basic (Declaration)
Public Property RecActionCode As CfgRecActionCode
Visual C++
public:
property CfgRecActionCode RecActionCode {
    CfgRecActionCode get ();
    void set (CfgRecActionCode value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.State Property
CfgTreatment Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.Tenant Property
CfgTreatment Class See Also Send Feedback
A unique identifier of the CfgTenant to which this treatment action is allocated. Mandatory.Once specified, cannot be changed.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatment..::.UserProperties Property
CfgTreatment Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTreatment Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgUpdatePackageRecord Class

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord Class
Members See Also Send Feedback
CfgUpdatePackageRecord

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgUpdatePackageRecord : CfgStructure
Visual Basic (Declaration)
Public Class CfgUpdatePackageRecord _
    Inherits CfgStructure
Visual C++
public ref class CfgUpdatePackageRecord : public CfgStructure

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgStructure
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgUpdatePackageRecord

See Also

CfgUpdatePackageRecord Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgUpdatePackageRecord Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord Members
CfgUpdatePackageRecord Class Constructors Methods Properties See Also Send Feedback

The CfgUpdatePackageRecord type exposes the following members.

Constructors

Name | Description
CfgUpdatePackageRecord | This constructor is intended for creating of detached objects

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
PackageDateTime |
PackageStatus |
PackageVersion |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgUpdatePackageRecord Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord Constructor
CfgUpdatePackageRecord Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgUpdatePackageRecord(
    IConfigurationService confService,
    IClientChannel channel,
    ICfgObject parent
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel, _
    parent As ICfgObject _
)
Visual C++
public:
CfgUpdatePackageRecord(
    IConfigurationService^ confService,
    IClientChannel^ channel,
    ICfgObject^ parent
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgUpdatePackageRecord.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgUpdatePackageRecord.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

parent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgUpdatePackageRecord.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgUpdatePackageRecord Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord Methods
CfgUpdatePackageRecord Class See Also Send Feedback

The CfgUpdatePackageRecord type exposes the following members.

Methods

Name | Description
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
ToString | Returns a string representation of the object. (Inherited from CfgBase.)
ToXml | Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object. (Inherited from CfgBase.)

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgUpdatePackageRecord Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord Properties
CfgUpdatePackageRecord Class See Also Send Feedback

The CfgUpdatePackageRecord type exposes the following members.

Properties

Name | Description
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
PackageDateTime |
PackageStatus |
PackageVersion |
Parent | Returns the parent configuration server object that references this structure. (Inherited from CfgStructure.)

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PackageDateTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord..::.PackageDateTime Property
CfgUpdatePackageRecord Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgUpdatePackageRecord.PackageDateTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PackageDateTime { get; set; }
Visual Basic (Declaration)
Public Property PackageDateTime As String
Visual C++
public:
property String^ PackageDateTime {
    String^ get ();
    void set (String^ value);
}

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PackageStatus Property

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord..::.PackageStatus Property
CfgUpdatePackageRecord Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgUpdatePackageRecord.PackageStatus"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgUpdatePackageStatus PackageStatus { get; set; }
Visual Basic (Declaration)
Public Property PackageStatus As CfgUpdatePackageStatus
Visual C++
public:
property CfgUpdatePackageStatus PackageStatus {
    CfgUpdatePackageStatus get ();
    void set (CfgUpdatePackageStatus value);
}

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


PackageVersion Property

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecord..::.PackageVersion Property
CfgUpdatePackageRecord Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgUpdatePackageRecord.PackageVersion"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PackageVersion { get; set; }
Visual Basic (Declaration)
Public Property PackageVersion As String
Visual C++
public:
property String^ PackageVersion {
    String^ get ();
    void set (String^ value);
}

See Also

CfgUpdatePackageRecord Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgVoicePrompt Class

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgVoicePrompt"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgVoicePrompt : CfgObject
Visual Basic (Declaration)
Public Class CfgVoicePrompt _
    Inherits CfgObject
Visual C++
public ref class CfgVoicePrompt : public CfgObject

Inheritance Hierarchy

System..::.Object
AbstractLogEnabled
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase
Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgObject
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects..::.CfgVoicePrompt

See Also

CfgVoicePrompt Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgVoicePrompt Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt Members
CfgVoicePrompt Class Constructors Methods Properties See Also Send Feedback

The CfgVoicePrompt type exposes the following members.

Constructors

Name | Description
CfgVoicePrompt | This constructor is intended for creating of detached objects

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetScriptDBID
SetScriptDBID
SetSwitchDBID
SetSwitchDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the voice prompt description. Can be used by parking platform or switch for generating voice prompt (Text-to-Speech).
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the voice prompt name that identifies the voice prompt. Should be equal to the voice prompt identifier provided by switch if used for parked call treating. Mandatory. Once specified cannot be changed. Must be unique within tenant it belongs to.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the CfgScript for this voice prompt.
State | Current object state. Mandatory. Refer to CfgObjectState
Switch | A unique identifier of the CfgSwitch to which this voice prompt belongs. Optional.
Tenant | A unique identifier of the CfgTenant to which this voice prompt is allocated. Read only.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgVoicePrompt Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt Constructor
CfgVoicePrompt Class See Also Send Feedback
This constructor is intended for creating of detached objects

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgVoicePrompt(
    IConfigurationService confService,
    IClientChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    confService As IConfigurationService, _
    channel As IClientChannel _
)
Visual C++
public:
CfgVoicePrompt(
    IConfigurationService^ confService,
    IClientChannel^ channel
)

Parameters

confService
Type: IConfigurationService

[Missing <param name="confService"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgVoicePrompt.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgVoicePrompt.#ctor(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgVoicePrompt Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt Methods
CfgVoicePrompt Class See Also Send Feedback

The CfgVoicePrompt type exposes the following members.

Methods

Name | Description
Clone
(Inherited from CfgObject.)
Delete
Deletes the configuration object from the Configuration Server
(Inherited from CfgObject.)
EnableLogging | (Inherited from AbstractLogEnabled.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
OnEnableLogging | (Inherited from AbstractLogEnabled.)
Refresh
Retrieves the latest data from the Configuration Server and updates the object's data
(Inherited from CfgObject.)
RemoveAccount
Removes the specified account from the current object's access list.
(Inherited from CfgObject.)
RetrieveAccountPermissions
Retrieves a permission mask (see
CopyC#
ConfServerPermissions
 enum) of accessing the object by a specified account (another configuration object). For example, called on CfgTenant with CfgAgent as a parameter, returns the set of permissions for this agent to access this tenant.
(Inherited from CfgObject.)
RetrievePermissions
Retrieves a full list of permissions to access this object for all user accounts. See
CopyC#
Permission
 class.
(Inherited from CfgObject.)
Save
Synchronizes changes in the class with Configuration Server.
(Overrides CfgObject..::.Save()()().)
SetAccountPermissions | Overloaded.
SetScriptDBID
SetScriptDBID
SetSwitchDBID
SetSwitchDBID
SetTenantDBID
SetTenantDBID
ToString
Returns a string representation of the object.
(Inherited from CfgBase.)
ToXml
Provides an XML representation of the current object. Note that the XML returned is a copy, and will not be updated should the object change -- unless this method is called again. Likewise, updates to the XML will never affect the object.
(Inherited from CfgBase.)
Update
Updates the current object from the passed delta object
(Inherited from CfgObject.)

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Save Method

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.Save Method
CfgVoicePrompt Class See Also Send Feedback
Synchronizes changes in the class with Configuration Server.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

Implements

ICfgObject..::.Save()()()

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.SetAccountPermissions Method
CfgVoicePrompt Class See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObject, Int32) | Changes the permissions on this object from the specified account. This method sets the permissions recursively on all child objects by default. (Inherited from CfgObject.)
SetAccountPermissions(CfgObject, Int32, Boolean) | Changes the permissions on this object from the specified account (Inherited from CfgObject.)

See Also

CfgVoicePrompt Class
CfgVoicePrompt Members
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetScriptDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.SetScriptDBID Method
CfgVoicePrompt Class See Also Send Feedback
SetScriptDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetScriptDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetScriptDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetScriptDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgVoicePrompt.SetScriptDBID(System.Int32)"]

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetSwitchDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.SetSwitchDBID Method
CfgVoicePrompt Class See Also Send Feedback
SetSwitchDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetSwitchDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetSwitchDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetSwitchDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgVoicePrompt.SetSwitchDBID(System.Int32)"]

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


SetTenantDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.SetTenantDBID Method
CfgVoicePrompt Class See Also Send Feedback
SetTenantDBID

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void SetTenantDBID(
    int dbid
)
Visual Basic (Declaration)
Public Sub SetTenantDBID ( _
    dbid As Integer _
)
Visual C++
public:
void SetTenantDBID(
    int dbid
)

Parameters

dbid
Type: System..::.Int32

[Missing <param name="dbid"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects.CfgVoicePrompt.SetTenantDBID(System.Int32)"]

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


CfgVoicePrompt Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt Properties
CfgVoicePrompt Class See Also Send Feedback

The CfgVoicePrompt type exposes the following members.

Properties

Name | Description
DBID | An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.
Description | A pointer to the voice prompt description. Can be used by parking platform or switch for generating voice prompt (Text-to-Speech).
Endpoint | Provides the URI of the Configuration Server to which this object belongs. (Inherited from CfgBase.)
FolderId | This property specifies ID of the folder, in which the object resides in Configuration Server (Inherited from CfgObject.)
Item | This indexer is used to access any configuration object's property using its string name. Any changes will not be synchronized with Configuration Server until the Save() method is called. (Inherited from CfgBase.)
Logger | (Inherited from AbstractLogEnabled.)
Name | A pointer to the voice prompt name that identifies the voice prompt. Should be equal to the voice prompt identifier provided by switch if used for parked call treating. Mandatory. Once specified cannot be changed. Must be unique within tenant it belongs to.
ObjectDbid | (Inherited from CfgObject.)
ObjectPath | Path of the object in Configuration Server. (Inherited from CfgObject.)
ObjectType | Returns the configuration object type (Inherited from CfgObject.)
Parent | Used to retrieve the parent of the current object (Inherited from CfgBase.)
Script | A unique identifier of the CfgScript for this voice prompt.
State | Current object state. Mandatory. Refer to CfgObjectState
Switch | A unique identifier of the CfgSwitch to which this voice prompt belongs. Optional.
Tenant | A unique identifier of the CfgTenant to which this voice prompt is allocated. Read only.
UserProperties | A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.DBID Property
CfgVoicePrompt Class See Also Send Feedback
An identifier of this object in the Configuration Database. Generated by Configuration Server and is unique within an object type. Identifiers of deleted objects are not used again. Read-only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.Description Property
CfgVoicePrompt Class See Also Send Feedback
A pointer to the voice prompt description. Can be used by parking platform or switch for generating voice prompt (Text-to-Speech).

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.Name Property
CfgVoicePrompt Class See Also Send Feedback
A pointer to the voice prompt name that identifies the voice prompt. Should be equal to the voice prompt identifier provided by switch if used for parked call treating. Mandatory. Once specified cannot be changed. Must be unique within tenant it belongs to.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.Script Property
CfgVoicePrompt Class See Also Send Feedback
A unique identifier of the CfgScript for this voice prompt.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScript Script { get; set; }
Visual Basic (Declaration)
Public Property Script As CfgScript
Visual C++
public:
property CfgScript^ Script {
    CfgScript^ get ();
    void set (CfgScript^ value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.State Property
CfgVoicePrompt Class See Also Send Feedback
Current object state. Mandatory. Refer to CfgObjectState

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.Switch Property
CfgVoicePrompt Class See Also Send Feedback
A unique identifier of the CfgSwitch to which this voice prompt belongs. Optional.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitch Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As CfgSwitch
Visual C++
public:
property CfgSwitch^ Switch {
    CfgSwitch^ get ();
    void set (CfgSwitch^ value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.Tenant Property
CfgVoicePrompt Class See Also Send Feedback
A unique identifier of the CfgTenant to which this voice prompt is allocated. Read only.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenant Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As CfgTenant
Visual C++
public:
property CfgTenant^ Tenant {
    CfgTenant^ get ();
    void set (CfgTenant^ value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePrompt..::.UserProperties Property
CfgVoicePrompt Class See Also Send Feedback
A pointer to the list of user-defined properties.Parameter userProperties has the following structure: Each key-value pair of the primary list (TKVList *userProperties) uses the key for the name of a user-defined section, and the value for a secondary list, that also has the TKVList structure and specifies the properties defined within that section.

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgVoicePrompt Class
Genesyslab.Enterprise.ConfigurationObjectModel.CfgObjects Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace
Send Feedback

Classes

Class | Description
CfgBaseDTO |
CfgObjectDTO |
CfgStructureDTO |


CfgBaseDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgBaseDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgBaseDTO
Visual Basic (Declaration)
Public MustInherit Class CfgBaseDTO
Visual C++
public ref class CfgBaseDTO abstract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO

See Also

CfgBaseDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgBaseDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO Members
CfgBaseDTO Class Methods Fields Properties See Also Send Feedback

The CfgBaseDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DoNotUseThisProperty |

Properties

Name | Description
Data |

See Also

CfgBaseDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgBaseDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO Fields
CfgBaseDTO Class See Also Send Feedback

The CfgBaseDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty |

See Also

CfgBaseDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


DoNotUseThisProperty Field

[image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO..::.DoNotUseThisProperty Field
CfgBaseDTO Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgBaseDTO.DoNotUseThisProperty"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object DoNotUseThisProperty
Visual Basic (Declaration)
Public DoNotUseThisProperty As Object
Visual C++
public:
Object^ DoNotUseThisProperty

See Also

CfgBaseDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgBaseDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO Methods
CfgBaseDTO Class See Also Send Feedback

The CfgBaseDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgBaseDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgBaseDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO Properties
CfgBaseDTO Class See Also Send Feedback

The CfgBaseDTO type exposes the following members.

Properties

Name | Description
Data |

See Also

CfgBaseDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


Data Property

[image]

Enterprise SDK 8.0 Reference API
CfgBaseDTO..::.Data Property
CfgBaseDTO Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgBaseDTO.Data"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Dictionary<string, Object> Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Dictionary(Of String, Object)
Visual C++
public:
property Dictionary<String^, Object^>^ Data {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

See Also

CfgBaseDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgObjectDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgObjectDTO : CfgBaseDTO
Visual Basic (Declaration)
Public MustInherit Class CfgObjectDTO _
    Inherits CfgBaseDTO
Visual C++
public ref class CfgObjectDTO abstract : public CfgBaseDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAccessGroupDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgActionCodeDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentGroupDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentLoginDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAlarmConditionDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgApplicationDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAppPrototypeDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCallingListDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCampaignDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCampaignGroupDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNGroupDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgEnumeratorDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgEnumeratorValueDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFieldDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFilterDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFolderDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFormatDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGVPCustomerDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGVPIVRProfileDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGVPResellerDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgHostDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgIVRDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgIVRPortDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectiveTableDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPersonDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPhysicalSwitchDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPlaceDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPlaceGroupDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgRoleDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgScheduledTaskDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgScriptDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServiceDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSkillDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgStatDayDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgStatTableDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSwitchDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTableAccessDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTenantDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTimeZoneDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTransactionDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTreatmentDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgVoicePromptDTO

See Also

CfgObjectDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgObjectDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO Members
CfgObjectDTO Class Methods Fields Properties See Also Send Feedback

The CfgObjectDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID |

See Also

CfgObjectDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgObjectDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO Fields
CfgObjectDTO Class See Also Send Feedback

The CfgObjectDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgObjectDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgObjectDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO Methods
CfgObjectDTO Class See Also Send Feedback

The CfgObjectDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

CfgObjectDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO..::.ToString Method
CfgObjectDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO.ToString"]

See Also

CfgObjectDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgObjectDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO Properties
CfgObjectDTO Class See Also Send Feedback

The CfgObjectDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID |

See Also

CfgObjectDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectDTO..::.DBID Property
CfgObjectDTO Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgStructureDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgStructureDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgStructureDTO : CfgBaseDTO
Visual Basic (Declaration)
Public MustInherit Class CfgStructureDTO _
    Inherits CfgBaseDTO
Visual C++
public ref class CfgStructureDTO abstract : public CfgBaseDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACEDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACEIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACLDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACLIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAddressDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentLoginInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAppRankDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAppServicePermissionDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCallingListInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCampaignGroupInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgConnInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDelSwitchAccessDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDetectEventDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNAccessNumberDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGroupDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgMemberIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectiveTableRecordDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectResourceDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgOSDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgOwnerIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgParentIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPhonesDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPortInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgRemovalEventDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgResourceIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgRoleMemberDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServerDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServerHostIDDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServerVersionDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServiceInfoDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSkillLevelDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSolutionComponentDefinitionDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSolutionComponentDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgStatIntervalDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSubcodeDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSwitchAccessCodeDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgUpdatePackageRecordDTO

See Also

CfgStructureDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgStructureDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO Members
CfgStructureDTO Class Methods Fields Properties See Also Send Feedback

The CfgStructureDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID |

See Also

CfgStructureDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgStructureDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO Fields
CfgStructureDTO Class See Also Send Feedback

The CfgStructureDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgStructureDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgStructureDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO Methods
CfgStructureDTO Class See Also Send Feedback

The CfgStructureDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

CfgStructureDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO..::.ToString Method
CfgStructureDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgStructureDTO.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgStructureDTO.ToString"]

See Also

CfgStructureDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


CfgStructureDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO Properties
CfgStructureDTO Class See Also Send Feedback

The CfgStructureDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID |

See Also

CfgStructureDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


ParentDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgStructureDTO..::.ParentDBID Property
CfgStructureDTO Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgStructureDTO.ParentDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ParentDBID { get; set; }
Visual Basic (Declaration)
Public Property ParentDBID As Integer
Visual C++
public:
property int ParentDBID {
    int get ();
    void set (int value);
}

See Also

CfgStructureDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace
Send Feedback

Classes

Class | Description
CfgAccessGroupDTO |
CfgACEDTO |
CfgACEIDDTO |
CfgACLDTO |
CfgACLIDDTO |
CfgActionCodeDTO |
CfgAddressDTO |
CfgAgentGroupDTO |
CfgAgentInfoDTO |
CfgAgentLoginDTO |
CfgAgentLoginInfoDTO |
CfgAlarmConditionDTO |
CfgApplicationDTO |
CfgAppPrototypeDTO |
CfgAppRankDTO |
CfgAppServicePermissionDTO |
CfgCallingListDTO |
CfgCallingListInfoDTO |
CfgCampaignDTO |
CfgCampaignGroupDTO |
CfgCampaignGroupInfoDTO |
CfgConnInfoDTO |
CfgDelSwitchAccessDTO |
CfgDetectEventDTO |
CfgDNAccessNumberDTO |
CfgDNDTO |
CfgDNGroupDTO |
CfgDNInfoDTO |
CfgEnumeratorDTO |
CfgEnumeratorValueDTO |
CfgFieldDTO |
CfgFilterDTO |
CfgFolderDTO |
CfgFormatDTO |
CfgGroupDTO |
CfgGVPCustomerDTO |
CfgGVPIVRProfileDTO |
CfgGVPResellerDTO |
CfgHostDTO |
CfgIDDTO |
CfgIVRDTO |
CfgIVRPortDTO |
CfgMemberIDDTO |
CfgObjectIDDTO |
CfgObjectiveTableDTO |
CfgObjectiveTableRecordDTO |
CfgObjectResourceDTO |
CfgOSDTO |
CfgOwnerIDDTO |
CfgParentIDDTO |
CfgPersonDTO |
CfgPhonesDTO |
CfgPhysicalSwitchDTO |
CfgPlaceDTO |
CfgPlaceGroupDTO |
CfgPortInfoDTO |
CfgRemovalEventDTO |
CfgResourceIDDTO |
CfgRoleDTO |
CfgRoleMemberDTO |
CfgScheduledTaskDTO |
CfgScriptDTO |
CfgServerDTO |
CfgServerHostIDDTO |
CfgServerVersionDTO |
CfgServiceDTO |
CfgServiceInfoDTO |
CfgSkillDTO |
CfgSkillLevelDTO |
CfgSolutionComponentDefinitionDTO |
CfgSolutionComponentDTO |
CfgStatDayDTO |
CfgStatIntervalDTO |
CfgStatTableDTO |
CfgSubcodeDTO |
CfgSwitchAccessCodeDTO |
CfgSwitchDTO |
CfgTableAccessDTO |
CfgTenantDTO |
CfgTimeZoneDTO |
CfgTransactionDTO |
CfgTreatmentDTO |
CfgUpdatePackageRecordDTO |
CfgVoicePromptDTO |


CfgAccessGroupDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAccessGroupDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAccessGroupDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgAccessGroupDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgAccessGroupDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAccessGroupDTO

See Also

CfgAccessGroupDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAccessGroupDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupDTO Members
CfgAccessGroupDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAccessGroupDTO type exposes the following members.

Constructors

Name | Description
CfgAccessGroupDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAccessGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAccessGroupDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupDTO Constructor
CfgAccessGroupDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAccessGroupDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAccessGroupDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAccessGroupDTO()

See Also

CfgAccessGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAccessGroupDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupDTO Fields
CfgAccessGroupDTO Class See Also Send Feedback

The CfgAccessGroupDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAccessGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAccessGroupDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupDTO Methods
CfgAccessGroupDTO Class See Also Send Feedback

The CfgAccessGroupDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgAccessGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAccessGroupDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupDTO Properties
CfgAccessGroupDTO Class See Also Send Feedback

The CfgAccessGroupDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAccessGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgACEDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACEDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACEDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgACEDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgACEDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACEDTO

See Also

CfgACEDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEDTO Members
CfgACEDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACEDTO type exposes the following members.

Constructors

Name | Description
CfgACEDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACEDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACEDTO Constructor
CfgACEDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACEDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACEDTO()

See Also

CfgACEDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEDTO Fields
CfgACEDTO Class See Also Send Feedback

The CfgACEDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgACEDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEDTO Methods
CfgACEDTO Class See Also Send Feedback

The CfgACEDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgACEDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEDTO Properties
CfgACEDTO Class See Also Send Feedback

The CfgACEDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACEDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgACEIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACEIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACEIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgACEIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgACEIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACEIDDTO

See Also

CfgACEIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDDTO Members
CfgACEIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACEIDDTO type exposes the following members.

Constructors

Name | Description
CfgACEIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACEIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACEIDDTO Constructor
CfgACEIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACEIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACEIDDTO()

See Also

CfgACEIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDDTO Fields
CfgACEIDDTO Class See Also Send Feedback

The CfgACEIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgACEIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDDTO Methods
CfgACEIDDTO Class See Also Send Feedback

The CfgACEIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgACEIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACEIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDDTO Properties
CfgACEIDDTO Class See Also Send Feedback

The CfgACEIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACEIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgACLDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACLDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACLDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgACLDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgACLDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACLDTO

See Also

CfgACLDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLDTO Members
CfgACLDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACLDTO type exposes the following members.

Constructors

Name | Description
CfgACLDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACLDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACLDTO Constructor
CfgACLDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACLDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACLDTO()

See Also

CfgACLDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLDTO Fields
CfgACLDTO Class See Also Send Feedback

The CfgACLDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgACLDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLDTO Methods
CfgACLDTO Class See Also Send Feedback

The CfgACLDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgACLDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLDTO Properties
CfgACLDTO Class See Also Send Feedback

The CfgACLDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACLDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgACLIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACLIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACLIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgACLIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgACLIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgACLIDDTO

See Also

CfgACLIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDDTO Members
CfgACLIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACLIDDTO type exposes the following members.

Constructors

Name | Description
CfgACLIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACLIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACLIDDTO Constructor
CfgACLIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgACLIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACLIDDTO()

See Also

CfgACLIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDDTO Fields
CfgACLIDDTO Class See Also Send Feedback

The CfgACLIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgACLIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDDTO Methods
CfgACLIDDTO Class See Also Send Feedback

The CfgACLIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgACLIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgACLIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDDTO Properties
CfgACLIDDTO Class See Also Send Feedback

The CfgACLIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgACLIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgActionCodeDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgActionCodeDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgActionCodeDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgActionCodeDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgActionCodeDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgActionCodeDTO

See Also

CfgActionCodeDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgActionCodeDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeDTO Members
CfgActionCodeDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgActionCodeDTO type exposes the following members.

Constructors

Name | Description
CfgActionCodeDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgActionCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgActionCodeDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeDTO Constructor
CfgActionCodeDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgActionCodeDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCodeDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgActionCodeDTO()

See Also

CfgActionCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgActionCodeDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeDTO Fields
CfgActionCodeDTO Class See Also Send Feedback

The CfgActionCodeDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgActionCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgActionCodeDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeDTO Methods
CfgActionCodeDTO Class See Also Send Feedback

The CfgActionCodeDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgActionCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgActionCodeDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeDTO Properties
CfgActionCodeDTO Class See Also Send Feedback

The CfgActionCodeDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgActionCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAddressDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAddressDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAddressDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAddressDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgAddressDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgAddressDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAddressDTO

See Also

CfgAddressDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAddressDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressDTO Members
CfgAddressDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAddressDTO type exposes the following members.

Constructors

Name | Description
CfgAddressDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAddressDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAddressDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAddressDTO Constructor
CfgAddressDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAddressDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddressDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAddressDTO()

See Also

CfgAddressDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAddressDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressDTO Fields
CfgAddressDTO Class See Also Send Feedback

The CfgAddressDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAddressDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAddressDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressDTO Methods
CfgAddressDTO Class See Also Send Feedback

The CfgAddressDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgAddressDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAddressDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressDTO Properties
CfgAddressDTO Class See Also Send Feedback

The CfgAddressDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAddressDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentGroupDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentGroupDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentGroupDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgAgentGroupDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgAgentGroupDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentGroupDTO

See Also

CfgAgentGroupDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentGroupDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupDTO Members
CfgAgentGroupDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentGroupDTO type exposes the following members.

Constructors

Name | Description
CfgAgentGroupDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAgentGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentGroupDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupDTO Constructor
CfgAgentGroupDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentGroupDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentGroupDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentGroupDTO()

See Also

CfgAgentGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentGroupDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupDTO Fields
CfgAgentGroupDTO Class See Also Send Feedback

The CfgAgentGroupDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAgentGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentGroupDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupDTO Methods
CfgAgentGroupDTO Class See Also Send Feedback

The CfgAgentGroupDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgAgentGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentGroupDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupDTO Properties
CfgAgentGroupDTO Class See Also Send Feedback

The CfgAgentGroupDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAgentGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgAgentInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgAgentInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentInfoDTO

See Also

CfgAgentInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoDTO Members
CfgAgentInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentInfoDTO type exposes the following members.

Constructors

Name | Description
CfgAgentInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAgentInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoDTO Constructor
CfgAgentInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentInfoDTO()

See Also

CfgAgentInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoDTO Fields
CfgAgentInfoDTO Class See Also Send Feedback

The CfgAgentInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAgentInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoDTO Methods
CfgAgentInfoDTO Class See Also Send Feedback

The CfgAgentInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgAgentInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoDTO Properties
CfgAgentInfoDTO Class See Also Send Feedback

The CfgAgentInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAgentInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentLoginDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLoginDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgAgentLoginDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgAgentLoginDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentLoginDTO

See Also

CfgAgentLoginDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginDTO Members
CfgAgentLoginDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentLoginDTO type exposes the following members.

Constructors

Name | Description
CfgAgentLoginDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAgentLoginDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginDTO Constructor
CfgAgentLoginDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentLoginDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLoginDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentLoginDTO()

See Also

CfgAgentLoginDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginDTO Fields
CfgAgentLoginDTO Class See Also Send Feedback

The CfgAgentLoginDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAgentLoginDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginDTO Methods
CfgAgentLoginDTO Class See Also Send Feedback

The CfgAgentLoginDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgAgentLoginDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginDTO Properties
CfgAgentLoginDTO Class See Also Send Feedback

The CfgAgentLoginDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAgentLoginDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentLoginInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLoginInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgAgentLoginInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgAgentLoginInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAgentLoginInfoDTO

See Also

CfgAgentLoginInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoDTO Members
CfgAgentLoginInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentLoginInfoDTO type exposes the following members.

Constructors

Name | Description
CfgAgentLoginInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAgentLoginInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoDTO Constructor
CfgAgentLoginInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAgentLoginInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLoginInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentLoginInfoDTO()

See Also

CfgAgentLoginInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoDTO Fields
CfgAgentLoginInfoDTO Class See Also Send Feedback

The CfgAgentLoginInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAgentLoginInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoDTO Methods
CfgAgentLoginInfoDTO Class See Also Send Feedback

The CfgAgentLoginInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgAgentLoginInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAgentLoginInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoDTO Properties
CfgAgentLoginInfoDTO Class See Also Send Feedback

The CfgAgentLoginInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAgentLoginInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAlarmConditionDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAlarmConditionDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAlarmConditionDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgAlarmConditionDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgAlarmConditionDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAlarmConditionDTO

See Also

CfgAlarmConditionDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAlarmConditionDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionDTO Members
CfgAlarmConditionDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAlarmConditionDTO type exposes the following members.

Constructors

Name | Description
CfgAlarmConditionDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAlarmConditionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAlarmConditionDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionDTO Constructor
CfgAlarmConditionDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAlarmConditionDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmConditionDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAlarmConditionDTO()

See Also

CfgAlarmConditionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAlarmConditionDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionDTO Fields
CfgAlarmConditionDTO Class See Also Send Feedback

The CfgAlarmConditionDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAlarmConditionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAlarmConditionDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionDTO Methods
CfgAlarmConditionDTO Class See Also Send Feedback

The CfgAlarmConditionDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgAlarmConditionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAlarmConditionDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionDTO Properties
CfgAlarmConditionDTO Class See Also Send Feedback

The CfgAlarmConditionDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAlarmConditionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgApplicationDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgApplicationDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgApplicationDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgApplicationDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgApplicationDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgApplicationDTO

See Also

CfgApplicationDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgApplicationDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationDTO Members
CfgApplicationDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgApplicationDTO type exposes the following members.

Constructors

Name | Description
CfgApplicationDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgApplicationDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgApplicationDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationDTO Constructor
CfgApplicationDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgApplicationDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplicationDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgApplicationDTO()

See Also

CfgApplicationDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgApplicationDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationDTO Fields
CfgApplicationDTO Class See Also Send Feedback

The CfgApplicationDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgApplicationDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgApplicationDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationDTO Methods
CfgApplicationDTO Class See Also Send Feedback

The CfgApplicationDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgApplicationDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgApplicationDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationDTO Properties
CfgApplicationDTO Class See Also Send Feedback

The CfgApplicationDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgApplicationDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppPrototypeDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAppPrototypeDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppPrototypeDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgAppPrototypeDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgAppPrototypeDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAppPrototypeDTO

See Also

CfgAppPrototypeDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppPrototypeDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeDTO Members
CfgAppPrototypeDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAppPrototypeDTO type exposes the following members.

Constructors

Name | Description
CfgAppPrototypeDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAppPrototypeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppPrototypeDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeDTO Constructor
CfgAppPrototypeDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAppPrototypeDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppPrototypeDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppPrototypeDTO()

See Also

CfgAppPrototypeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppPrototypeDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeDTO Fields
CfgAppPrototypeDTO Class See Also Send Feedback

The CfgAppPrototypeDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAppPrototypeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppPrototypeDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeDTO Methods
CfgAppPrototypeDTO Class See Also Send Feedback

The CfgAppPrototypeDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgAppPrototypeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppPrototypeDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeDTO Properties
CfgAppPrototypeDTO Class See Also Send Feedback

The CfgAppPrototypeDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgAppPrototypeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppRankDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppRankDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAppRankDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppRankDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgAppRankDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgAppRankDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAppRankDTO

See Also

CfgAppRankDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppRankDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankDTO Members
CfgAppRankDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAppRankDTO type exposes the following members.

Constructors

Name | Description
CfgAppRankDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAppRankDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppRankDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppRankDTO Constructor
CfgAppRankDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAppRankDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppRankDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppRankDTO()

See Also

CfgAppRankDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppRankDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankDTO Fields
CfgAppRankDTO Class See Also Send Feedback

The CfgAppRankDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAppRankDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppRankDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankDTO Methods
CfgAppRankDTO Class See Also Send Feedback

The CfgAppRankDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgAppRankDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppRankDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankDTO Properties
CfgAppRankDTO Class See Also Send Feedback

The CfgAppRankDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAppRankDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppServicePermissionDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAppServicePermissionDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppServicePermissionDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgAppServicePermissionDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgAppServicePermissionDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgAppServicePermissionDTO

See Also

CfgAppServicePermissionDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppServicePermissionDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionDTO Members
CfgAppServicePermissionDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAppServicePermissionDTO type exposes the following members.

Constructors

Name | Description
CfgAppServicePermissionDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAppServicePermissionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppServicePermissionDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionDTO Constructor
CfgAppServicePermissionDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgAppServicePermissionDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppServicePermissionDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppServicePermissionDTO()

See Also

CfgAppServicePermissionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppServicePermissionDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionDTO Fields
CfgAppServicePermissionDTO Class See Also Send Feedback

The CfgAppServicePermissionDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgAppServicePermissionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppServicePermissionDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionDTO Methods
CfgAppServicePermissionDTO Class See Also Send Feedback

The CfgAppServicePermissionDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgAppServicePermissionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgAppServicePermissionDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionDTO Properties
CfgAppServicePermissionDTO Class See Also Send Feedback

The CfgAppServicePermissionDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgAppServicePermissionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCallingListDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingListDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgCallingListDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgCallingListDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCallingListDTO

See Also

CfgCallingListDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListDTO Members
CfgCallingListDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCallingListDTO type exposes the following members.

Constructors

Name | Description
CfgCallingListDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgCallingListDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListDTO Constructor
CfgCallingListDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCallingListDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingListDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCallingListDTO()

See Also

CfgCallingListDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListDTO Fields
CfgCallingListDTO Class See Also Send Feedback

The CfgCallingListDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgCallingListDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListDTO Methods
CfgCallingListDTO Class See Also Send Feedback

The CfgCallingListDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgCallingListDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListDTO Properties
CfgCallingListDTO Class See Also Send Feedback

The CfgCallingListDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgCallingListDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCallingListInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingListInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgCallingListInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgCallingListInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCallingListInfoDTO

See Also

CfgCallingListInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoDTO Members
CfgCallingListInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCallingListInfoDTO type exposes the following members.

Constructors

Name | Description
CfgCallingListInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgCallingListInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoDTO Constructor
CfgCallingListInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCallingListInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingListInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCallingListInfoDTO()

See Also

CfgCallingListInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoDTO Fields
CfgCallingListInfoDTO Class See Also Send Feedback

The CfgCallingListInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgCallingListInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoDTO Methods
CfgCallingListInfoDTO Class See Also Send Feedback

The CfgCallingListInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgCallingListInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCallingListInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoDTO Properties
CfgCallingListInfoDTO Class See Also Send Feedback

The CfgCallingListInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgCallingListInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCampaignDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgCampaignDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgCampaignDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCampaignDTO

See Also

CfgCampaignDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignDTO Members
CfgCampaignDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCampaignDTO type exposes the following members.

Constructors

Name | Description
CfgCampaignDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgCampaignDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignDTO Constructor
CfgCampaignDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCampaignDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignDTO()

See Also

CfgCampaignDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignDTO Fields
CfgCampaignDTO Class See Also Send Feedback

The CfgCampaignDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgCampaignDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignDTO Methods
CfgCampaignDTO Class See Also Send Feedback

The CfgCampaignDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgCampaignDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignDTO Properties
CfgCampaignDTO Class See Also Send Feedback

The CfgCampaignDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgCampaignDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCampaignGroupDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroupDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgCampaignGroupDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgCampaignGroupDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCampaignGroupDTO

See Also

CfgCampaignGroupDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupDTO Members
CfgCampaignGroupDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCampaignGroupDTO type exposes the following members.

Constructors

Name | Description
CfgCampaignGroupDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgCampaignGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupDTO Constructor
CfgCampaignGroupDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCampaignGroupDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroupDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignGroupDTO()

See Also

CfgCampaignGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupDTO Fields
CfgCampaignGroupDTO Class See Also Send Feedback

The CfgCampaignGroupDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgCampaignGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupDTO Methods
CfgCampaignGroupDTO Class See Also Send Feedback

The CfgCampaignGroupDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgCampaignGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupDTO Properties
CfgCampaignGroupDTO Class See Also Send Feedback

The CfgCampaignGroupDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgCampaignGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCampaignGroupInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroupInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgCampaignGroupInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgCampaignGroupInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgCampaignGroupInfoDTO

See Also

CfgCampaignGroupInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoDTO Members
CfgCampaignGroupInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCampaignGroupInfoDTO type exposes the following members.

Constructors

Name | Description
CfgCampaignGroupInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgCampaignGroupInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoDTO Constructor
CfgCampaignGroupInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgCampaignGroupInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroupInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignGroupInfoDTO()

See Also

CfgCampaignGroupInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoDTO Fields
CfgCampaignGroupInfoDTO Class See Also Send Feedback

The CfgCampaignGroupInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgCampaignGroupInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoDTO Methods
CfgCampaignGroupInfoDTO Class See Also Send Feedback

The CfgCampaignGroupInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgCampaignGroupInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgCampaignGroupInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoDTO Properties
CfgCampaignGroupInfoDTO Class See Also Send Feedback

The CfgCampaignGroupInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgCampaignGroupInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgConnInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgConnInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgConnInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgConnInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgConnInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgConnInfoDTO

See Also

CfgConnInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgConnInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoDTO Members
CfgConnInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgConnInfoDTO type exposes the following members.

Constructors

Name | Description
CfgConnInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgConnInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgConnInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoDTO Constructor
CfgConnInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgConnInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgConnInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgConnInfoDTO()

See Also

CfgConnInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgConnInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoDTO Fields
CfgConnInfoDTO Class See Also Send Feedback

The CfgConnInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgConnInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgConnInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoDTO Methods
CfgConnInfoDTO Class See Also Send Feedback

The CfgConnInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgConnInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgConnInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoDTO Properties
CfgConnInfoDTO Class See Also Send Feedback

The CfgConnInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgConnInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDelSwitchAccessDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDelSwitchAccessDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDelSwitchAccessDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgDelSwitchAccessDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgDelSwitchAccessDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDelSwitchAccessDTO

See Also

CfgDelSwitchAccessDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDelSwitchAccessDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessDTO Members
CfgDelSwitchAccessDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDelSwitchAccessDTO type exposes the following members.

Constructors

Name | Description
CfgDelSwitchAccessDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDelSwitchAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDelSwitchAccessDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessDTO Constructor
CfgDelSwitchAccessDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDelSwitchAccessDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDelSwitchAccessDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDelSwitchAccessDTO()

See Also

CfgDelSwitchAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDelSwitchAccessDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessDTO Fields
CfgDelSwitchAccessDTO Class See Also Send Feedback

The CfgDelSwitchAccessDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgDelSwitchAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDelSwitchAccessDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessDTO Methods
CfgDelSwitchAccessDTO Class See Also Send Feedback

The CfgDelSwitchAccessDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgDelSwitchAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDelSwitchAccessDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessDTO Properties
CfgDelSwitchAccessDTO Class See Also Send Feedback

The CfgDelSwitchAccessDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDelSwitchAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDetectEventDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDetectEventDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDetectEventDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgDetectEventDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgDetectEventDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDetectEventDTO

See Also

CfgDetectEventDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDetectEventDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventDTO Members
CfgDetectEventDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDetectEventDTO type exposes the following members.

Constructors

Name | Description
CfgDetectEventDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDetectEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDetectEventDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventDTO Constructor
CfgDetectEventDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDetectEventDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDetectEventDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDetectEventDTO()

See Also

CfgDetectEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDetectEventDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventDTO Fields
CfgDetectEventDTO Class See Also Send Feedback

The CfgDetectEventDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgDetectEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDetectEventDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventDTO Methods
CfgDetectEventDTO Class See Also Send Feedback

The CfgDetectEventDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgDetectEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDetectEventDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventDTO Properties
CfgDetectEventDTO Class See Also Send Feedback

The CfgDetectEventDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDetectEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNAccessNumberDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNAccessNumberDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNAccessNumberDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgDNAccessNumberDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgDNAccessNumberDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNAccessNumberDTO

See Also

CfgDNAccessNumberDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNAccessNumberDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberDTO Members
CfgDNAccessNumberDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNAccessNumberDTO type exposes the following members.

Constructors

Name | Description
CfgDNAccessNumberDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDNAccessNumberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNAccessNumberDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberDTO Constructor
CfgDNAccessNumberDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNAccessNumberDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNAccessNumberDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNAccessNumberDTO()

See Also

CfgDNAccessNumberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNAccessNumberDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberDTO Fields
CfgDNAccessNumberDTO Class See Also Send Feedback

The CfgDNAccessNumberDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgDNAccessNumberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNAccessNumberDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberDTO Methods
CfgDNAccessNumberDTO Class See Also Send Feedback

The CfgDNAccessNumberDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgDNAccessNumberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNAccessNumberDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberDTO Properties
CfgDNAccessNumberDTO Class See Also Send Feedback

The CfgDNAccessNumberDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDNAccessNumberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgDNDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgDNDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNDTO

See Also

CfgDNDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNDTO Members
CfgDNDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNDTO type exposes the following members.

Constructors

Name | Description
CfgDNDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgDNDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNDTO Constructor
CfgDNDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNDTO()

See Also

CfgDNDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNDTO Fields
CfgDNDTO Class See Also Send Feedback

The CfgDNDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgDNDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNDTO Methods
CfgDNDTO Class See Also Send Feedback

The CfgDNDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgDNDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNDTO Properties
CfgDNDTO Class See Also Send Feedback

The CfgDNDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgDNDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNGroupDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNGroupDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNGroupDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgDNGroupDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgDNGroupDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNGroupDTO

See Also

CfgDNGroupDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNGroupDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupDTO Members
CfgDNGroupDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNGroupDTO type exposes the following members.

Constructors

Name | Description
CfgDNGroupDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgDNGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNGroupDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupDTO Constructor
CfgDNGroupDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNGroupDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroupDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNGroupDTO()

See Also

CfgDNGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNGroupDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupDTO Fields
CfgDNGroupDTO Class See Also Send Feedback

The CfgDNGroupDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgDNGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNGroupDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupDTO Methods
CfgDNGroupDTO Class See Also Send Feedback

The CfgDNGroupDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgDNGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNGroupDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupDTO Properties
CfgDNGroupDTO Class See Also Send Feedback

The CfgDNGroupDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgDNGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgDNInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgDNInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgDNInfoDTO

See Also

CfgDNInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoDTO Members
CfgDNInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNInfoDTO type exposes the following members.

Constructors

Name | Description
CfgDNInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDNInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfoDTO Constructor
CfgDNInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgDNInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNInfoDTO()

See Also

CfgDNInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoDTO Fields
CfgDNInfoDTO Class See Also Send Feedback

The CfgDNInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgDNInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoDTO Methods
CfgDNInfoDTO Class See Also Send Feedback

The CfgDNInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgDNInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgDNInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoDTO Properties
CfgDNInfoDTO Class See Also Send Feedback

The CfgDNInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgDNInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgEnumeratorDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgEnumeratorDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgEnumeratorDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgEnumeratorDTO

See Also

CfgEnumeratorDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorDTO Members
CfgEnumeratorDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgEnumeratorDTO type exposes the following members.

Constructors

Name | Description
CfgEnumeratorDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgEnumeratorDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorDTO Constructor
CfgEnumeratorDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgEnumeratorDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgEnumeratorDTO()

See Also

CfgEnumeratorDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorDTO Fields
CfgEnumeratorDTO Class See Also Send Feedback

The CfgEnumeratorDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgEnumeratorDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorDTO Methods
CfgEnumeratorDTO Class See Also Send Feedback

The CfgEnumeratorDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgEnumeratorDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorDTO Properties
CfgEnumeratorDTO Class See Also Send Feedback

The CfgEnumeratorDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgEnumeratorDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorValueDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgEnumeratorValueDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorValueDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgEnumeratorValueDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgEnumeratorValueDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgEnumeratorValueDTO

See Also

CfgEnumeratorValueDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorValueDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueDTO Members
CfgEnumeratorValueDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgEnumeratorValueDTO type exposes the following members.

Constructors

Name | Description
CfgEnumeratorValueDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgEnumeratorValueDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorValueDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueDTO Constructor
CfgEnumeratorValueDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgEnumeratorValueDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValueDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgEnumeratorValueDTO()

See Also

CfgEnumeratorValueDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorValueDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueDTO Fields
CfgEnumeratorValueDTO Class See Also Send Feedback

The CfgEnumeratorValueDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgEnumeratorValueDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorValueDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueDTO Methods
CfgEnumeratorValueDTO Class See Also Send Feedback

The CfgEnumeratorValueDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgEnumeratorValueDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgEnumeratorValueDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueDTO Properties
CfgEnumeratorValueDTO Class See Also Send Feedback

The CfgEnumeratorValueDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgEnumeratorValueDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFieldDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgFieldDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFieldDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFieldDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgFieldDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgFieldDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFieldDTO

See Also

CfgFieldDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFieldDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldDTO Members
CfgFieldDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFieldDTO type exposes the following members.

Constructors

Name | Description
CfgFieldDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFieldDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFieldDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFieldDTO Constructor
CfgFieldDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFieldDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFieldDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFieldDTO()

See Also

CfgFieldDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFieldDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldDTO Fields
CfgFieldDTO Class See Also Send Feedback

The CfgFieldDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgFieldDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFieldDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldDTO Methods
CfgFieldDTO Class See Also Send Feedback

The CfgFieldDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgFieldDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFieldDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldDTO Properties
CfgFieldDTO Class See Also Send Feedback

The CfgFieldDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFieldDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFilterDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgFilterDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFilterDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFilterDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgFilterDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgFilterDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFilterDTO

See Also

CfgFilterDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFilterDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterDTO Members
CfgFilterDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFilterDTO type exposes the following members.

Constructors

Name | Description
CfgFilterDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFilterDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFilterDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFilterDTO Constructor
CfgFilterDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFilterDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilterDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFilterDTO()

See Also

CfgFilterDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFilterDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterDTO Fields
CfgFilterDTO Class See Also Send Feedback

The CfgFilterDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgFilterDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFilterDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterDTO Methods
CfgFilterDTO Class See Also Send Feedback

The CfgFilterDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgFilterDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFilterDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterDTO Properties
CfgFilterDTO Class See Also Send Feedback

The CfgFilterDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFilterDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFolderDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgFolderDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFolderDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFolderDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgFolderDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgFolderDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFolderDTO

See Also

CfgFolderDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFolderDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderDTO Members
CfgFolderDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFolderDTO type exposes the following members.

Constructors

Name | Description
CfgFolderDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFolderDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFolderDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFolderDTO Constructor
CfgFolderDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFolderDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolderDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFolderDTO()

See Also

CfgFolderDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFolderDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderDTO Fields
CfgFolderDTO Class See Also Send Feedback

The CfgFolderDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgFolderDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFolderDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderDTO Methods
CfgFolderDTO Class See Also Send Feedback

The CfgFolderDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgFolderDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFolderDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderDTO Properties
CfgFolderDTO Class See Also Send Feedback

The CfgFolderDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFolderDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFormatDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgFormatDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFormatDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFormatDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgFormatDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgFormatDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgFormatDTO

See Also

CfgFormatDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFormatDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatDTO Members
CfgFormatDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFormatDTO type exposes the following members.

Constructors

Name | Description
CfgFormatDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFormatDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFormatDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFormatDTO Constructor
CfgFormatDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgFormatDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormatDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFormatDTO()

See Also

CfgFormatDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFormatDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatDTO Fields
CfgFormatDTO Class See Also Send Feedback

The CfgFormatDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgFormatDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFormatDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatDTO Methods
CfgFormatDTO Class See Also Send Feedback

The CfgFormatDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgFormatDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgFormatDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatDTO Properties
CfgFormatDTO Class See Also Send Feedback

The CfgFormatDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgFormatDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGroupDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgGroupDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGroupDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGroupDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgGroupDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgGroupDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGroupDTO

See Also

CfgGroupDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGroupDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupDTO Members
CfgGroupDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGroupDTO type exposes the following members.

Constructors

Name | Description
CfgGroupDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGroupDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGroupDTO Constructor
CfgGroupDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGroupDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroupDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGroupDTO()

See Also

CfgGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGroupDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupDTO Fields
CfgGroupDTO Class See Also Send Feedback

The CfgGroupDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGroupDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupDTO Methods
CfgGroupDTO Class See Also Send Feedback

The CfgGroupDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGroupDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupDTO Properties
CfgGroupDTO Class See Also Send Feedback

The CfgGroupDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPCustomerDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGVPCustomerDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPCustomerDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgGVPCustomerDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgGVPCustomerDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGVPCustomerDTO

See Also

CfgGVPCustomerDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPCustomerDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerDTO Members
CfgGVPCustomerDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGVPCustomerDTO type exposes the following members.

Constructors

Name | Description
CfgGVPCustomerDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgGVPCustomerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPCustomerDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerDTO Constructor
CfgGVPCustomerDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGVPCustomerDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPCustomerDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPCustomerDTO()

See Also

CfgGVPCustomerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPCustomerDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerDTO Fields
CfgGVPCustomerDTO Class See Also Send Feedback

The CfgGVPCustomerDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgGVPCustomerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPCustomerDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerDTO Methods
CfgGVPCustomerDTO Class See Also Send Feedback

The CfgGVPCustomerDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgGVPCustomerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPCustomerDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerDTO Properties
CfgGVPCustomerDTO Class See Also Send Feedback

The CfgGVPCustomerDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgGVPCustomerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPIVRProfileDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGVPIVRProfileDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPIVRProfileDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgGVPIVRProfileDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgGVPIVRProfileDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGVPIVRProfileDTO

See Also

CfgGVPIVRProfileDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPIVRProfileDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileDTO Members
CfgGVPIVRProfileDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGVPIVRProfileDTO type exposes the following members.

Constructors

Name | Description
CfgGVPIVRProfileDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgGVPIVRProfileDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPIVRProfileDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileDTO Constructor
CfgGVPIVRProfileDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGVPIVRProfileDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPIVRProfileDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPIVRProfileDTO()

See Also

CfgGVPIVRProfileDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPIVRProfileDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileDTO Fields
CfgGVPIVRProfileDTO Class See Also Send Feedback

The CfgGVPIVRProfileDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgGVPIVRProfileDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPIVRProfileDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileDTO Methods
CfgGVPIVRProfileDTO Class See Also Send Feedback

The CfgGVPIVRProfileDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgGVPIVRProfileDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPIVRProfileDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileDTO Properties
CfgGVPIVRProfileDTO Class See Also Send Feedback

The CfgGVPIVRProfileDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgGVPIVRProfileDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPResellerDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGVPResellerDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPResellerDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgGVPResellerDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgGVPResellerDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgGVPResellerDTO

See Also

CfgGVPResellerDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPResellerDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerDTO Members
CfgGVPResellerDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGVPResellerDTO type exposes the following members.

Constructors

Name | Description
CfgGVPResellerDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgGVPResellerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPResellerDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerDTO Constructor
CfgGVPResellerDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgGVPResellerDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPResellerDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPResellerDTO()

See Also

CfgGVPResellerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPResellerDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerDTO Fields
CfgGVPResellerDTO Class See Also Send Feedback

The CfgGVPResellerDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgGVPResellerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPResellerDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerDTO Methods
CfgGVPResellerDTO Class See Also Send Feedback

The CfgGVPResellerDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgGVPResellerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgGVPResellerDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerDTO Properties
CfgGVPResellerDTO Class See Also Send Feedback

The CfgGVPResellerDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgGVPResellerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgHostDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgHostDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgHostDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgHostDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgHostDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgHostDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgHostDTO

See Also

CfgHostDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgHostDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostDTO Members
CfgHostDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgHostDTO type exposes the following members.

Constructors

Name | Description
CfgHostDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgHostDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgHostDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgHostDTO Constructor
CfgHostDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgHostDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHostDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgHostDTO()

See Also

CfgHostDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgHostDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostDTO Fields
CfgHostDTO Class See Also Send Feedback

The CfgHostDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgHostDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgHostDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostDTO Methods
CfgHostDTO Class See Also Send Feedback

The CfgHostDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgHostDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgHostDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostDTO Properties
CfgHostDTO Class See Also Send Feedback

The CfgHostDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgHostDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgIDDTO

See Also

CfgIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDDTO Members
CfgIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgIDDTO type exposes the following members.

Constructors

Name | Description
CfgIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIDDTO Constructor
CfgIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIDDTO()

See Also

CfgIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDDTO Fields
CfgIDDTO Class See Also Send Feedback

The CfgIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDDTO Methods
CfgIDDTO Class See Also Send Feedback

The CfgIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDDTO Properties
CfgIDDTO Class See Also Send Feedback

The CfgIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVRDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgIVRDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVRDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgIVRDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgIVRDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgIVRDTO

See Also

CfgIVRDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRDTO Members
CfgIVRDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgIVRDTO type exposes the following members.

Constructors

Name | Description
CfgIVRDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgIVRDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVRDTO Constructor
CfgIVRDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgIVRDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIVRDTO()

See Also

CfgIVRDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRDTO Fields
CfgIVRDTO Class See Also Send Feedback

The CfgIVRDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgIVRDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRDTO Methods
CfgIVRDTO Class See Also Send Feedback

The CfgIVRDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgIVRDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRDTO Properties
CfgIVRDTO Class See Also Send Feedback

The CfgIVRDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgIVRDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRPortDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgIVRPortDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVRPortDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgIVRPortDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgIVRPortDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgIVRPortDTO

See Also

CfgIVRPortDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRPortDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortDTO Members
CfgIVRPortDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgIVRPortDTO type exposes the following members.

Constructors

Name | Description
CfgIVRPortDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgIVRPortDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRPortDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortDTO Constructor
CfgIVRPortDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgIVRPortDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRPortDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIVRPortDTO()

See Also

CfgIVRPortDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRPortDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortDTO Fields
CfgIVRPortDTO Class See Also Send Feedback

The CfgIVRPortDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgIVRPortDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRPortDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortDTO Methods
CfgIVRPortDTO Class See Also Send Feedback

The CfgIVRPortDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgIVRPortDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgIVRPortDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortDTO Properties
CfgIVRPortDTO Class See Also Send Feedback

The CfgIVRPortDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgIVRPortDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgMemberIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgMemberIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgMemberIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgMemberIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgMemberIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgMemberIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgMemberIDDTO

See Also

CfgMemberIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgMemberIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDDTO Members
CfgMemberIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgMemberIDDTO type exposes the following members.

Constructors

Name | Description
CfgMemberIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgMemberIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgMemberIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgMemberIDDTO Constructor
CfgMemberIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgMemberIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgMemberIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgMemberIDDTO()

See Also

CfgMemberIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgMemberIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDDTO Fields
CfgMemberIDDTO Class See Also Send Feedback

The CfgMemberIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgMemberIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgMemberIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDDTO Methods
CfgMemberIDDTO Class See Also Send Feedback

The CfgMemberIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgMemberIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgMemberIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDDTO Properties
CfgMemberIDDTO Class See Also Send Feedback

The CfgMemberIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgMemberIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgObjectIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgObjectIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectIDDTO

See Also

CfgObjectIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDDTO Members
CfgObjectIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectIDDTO type exposes the following members.

Constructors

Name | Description
CfgObjectIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgObjectIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectIDDTO Constructor
CfgObjectIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectIDDTO()

See Also

CfgObjectIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDDTO Fields
CfgObjectIDDTO Class See Also Send Feedback

The CfgObjectIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgObjectIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDDTO Methods
CfgObjectIDDTO Class See Also Send Feedback

The CfgObjectIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgObjectIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDDTO Properties
CfgObjectIDDTO Class See Also Send Feedback

The CfgObjectIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgObjectIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectiveTableDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTableDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgObjectiveTableDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgObjectiveTableDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectiveTableDTO

See Also

CfgObjectiveTableDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableDTO Members
CfgObjectiveTableDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectiveTableDTO type exposes the following members.

Constructors

Name | Description
CfgObjectiveTableDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgObjectiveTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableDTO Constructor
CfgObjectiveTableDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectiveTableDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectiveTableDTO()

See Also

CfgObjectiveTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableDTO Fields
CfgObjectiveTableDTO Class See Also Send Feedback

The CfgObjectiveTableDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgObjectiveTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableDTO Methods
CfgObjectiveTableDTO Class See Also Send Feedback

The CfgObjectiveTableDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgObjectiveTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableDTO Properties
CfgObjectiveTableDTO Class See Also Send Feedback

The CfgObjectiveTableDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgObjectiveTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableRecordDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectiveTableRecordDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTableRecordDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgObjectiveTableRecordDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgObjectiveTableRecordDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectiveTableRecordDTO

See Also

CfgObjectiveTableRecordDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableRecordDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordDTO Members
CfgObjectiveTableRecordDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectiveTableRecordDTO type exposes the following members.

Constructors

Name | Description
CfgObjectiveTableRecordDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgObjectiveTableRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableRecordDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordDTO Constructor
CfgObjectiveTableRecordDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectiveTableRecordDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableRecordDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectiveTableRecordDTO()

See Also

CfgObjectiveTableRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableRecordDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordDTO Fields
CfgObjectiveTableRecordDTO Class See Also Send Feedback

The CfgObjectiveTableRecordDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgObjectiveTableRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableRecordDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordDTO Methods
CfgObjectiveTableRecordDTO Class See Also Send Feedback

The CfgObjectiveTableRecordDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgObjectiveTableRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectiveTableRecordDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordDTO Properties
CfgObjectiveTableRecordDTO Class See Also Send Feedback

The CfgObjectiveTableRecordDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgObjectiveTableRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectResourceDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectResourceDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectResourceDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgObjectResourceDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgObjectResourceDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgObjectResourceDTO

See Also

CfgObjectResourceDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectResourceDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceDTO Members
CfgObjectResourceDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectResourceDTO type exposes the following members.

Constructors

Name | Description
CfgObjectResourceDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgObjectResourceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectResourceDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceDTO Constructor
CfgObjectResourceDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgObjectResourceDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectResourceDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectResourceDTO()

See Also

CfgObjectResourceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectResourceDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceDTO Fields
CfgObjectResourceDTO Class See Also Send Feedback

The CfgObjectResourceDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgObjectResourceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectResourceDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceDTO Methods
CfgObjectResourceDTO Class See Also Send Feedback

The CfgObjectResourceDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgObjectResourceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgObjectResourceDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceDTO Properties
CfgObjectResourceDTO Class See Also Send Feedback

The CfgObjectResourceDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgObjectResourceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOSDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgOSDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgOSDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgOSDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgOSDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgOSDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgOSDTO

See Also

CfgOSDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOSDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSDTO Members
CfgOSDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgOSDTO type exposes the following members.

Constructors

Name | Description
CfgOSDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgOSDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOSDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgOSDTO Constructor
CfgOSDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgOSDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOSDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgOSDTO()

See Also

CfgOSDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOSDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSDTO Fields
CfgOSDTO Class See Also Send Feedback

The CfgOSDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgOSDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOSDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSDTO Methods
CfgOSDTO Class See Also Send Feedback

The CfgOSDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgOSDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOSDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSDTO Properties
CfgOSDTO Class See Also Send Feedback

The CfgOSDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgOSDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOwnerIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgOwnerIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgOwnerIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgOwnerIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgOwnerIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgOwnerIDDTO

See Also

CfgOwnerIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOwnerIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDDTO Members
CfgOwnerIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgOwnerIDDTO type exposes the following members.

Constructors

Name | Description
CfgOwnerIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgOwnerIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOwnerIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDDTO Constructor
CfgOwnerIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgOwnerIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOwnerIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgOwnerIDDTO()

See Also

CfgOwnerIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOwnerIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDDTO Fields
CfgOwnerIDDTO Class See Also Send Feedback

The CfgOwnerIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgOwnerIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOwnerIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDDTO Methods
CfgOwnerIDDTO Class See Also Send Feedback

The CfgOwnerIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgOwnerIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgOwnerIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDDTO Properties
CfgOwnerIDDTO Class See Also Send Feedback

The CfgOwnerIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgOwnerIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgParentIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgParentIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgParentIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgParentIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgParentIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgParentIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgParentIDDTO

See Also

CfgParentIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgParentIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDDTO Members
CfgParentIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgParentIDDTO type exposes the following members.

Constructors

Name | Description
CfgParentIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgParentIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgParentIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgParentIDDTO Constructor
CfgParentIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgParentIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgParentIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgParentIDDTO()

See Also

CfgParentIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgParentIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDDTO Fields
CfgParentIDDTO Class See Also Send Feedback

The CfgParentIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgParentIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgParentIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDDTO Methods
CfgParentIDDTO Class See Also Send Feedback

The CfgParentIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgParentIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgParentIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDDTO Properties
CfgParentIDDTO Class See Also Send Feedback

The CfgParentIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgParentIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPersonDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgPersonDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPersonDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPersonDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgPersonDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgPersonDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPersonDTO

See Also

CfgPersonDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPersonDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonDTO Members
CfgPersonDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPersonDTO type exposes the following members.

Constructors

Name | Description
CfgPersonDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPersonDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPersonDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPersonDTO Constructor
CfgPersonDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPersonDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPersonDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPersonDTO()

See Also

CfgPersonDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPersonDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonDTO Fields
CfgPersonDTO Class See Also Send Feedback

The CfgPersonDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgPersonDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPersonDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonDTO Methods
CfgPersonDTO Class See Also Send Feedback

The CfgPersonDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgPersonDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPersonDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonDTO Properties
CfgPersonDTO Class See Also Send Feedback

The CfgPersonDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPersonDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhonesDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhonesDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPhonesDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhonesDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgPhonesDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgPhonesDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPhonesDTO

See Also

CfgPhonesDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhonesDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesDTO Members
CfgPhonesDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPhonesDTO type exposes the following members.

Constructors

Name | Description
CfgPhonesDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgPhonesDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhonesDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhonesDTO Constructor
CfgPhonesDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPhonesDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhonesDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPhonesDTO()

See Also

CfgPhonesDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhonesDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesDTO Fields
CfgPhonesDTO Class See Also Send Feedback

The CfgPhonesDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgPhonesDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhonesDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesDTO Methods
CfgPhonesDTO Class See Also Send Feedback

The CfgPhonesDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgPhonesDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhonesDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesDTO Properties
CfgPhonesDTO Class See Also Send Feedback

The CfgPhonesDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgPhonesDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhysicalSwitchDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPhysicalSwitchDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhysicalSwitchDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgPhysicalSwitchDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgPhysicalSwitchDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPhysicalSwitchDTO

See Also

CfgPhysicalSwitchDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhysicalSwitchDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchDTO Members
CfgPhysicalSwitchDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPhysicalSwitchDTO type exposes the following members.

Constructors

Name | Description
CfgPhysicalSwitchDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPhysicalSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhysicalSwitchDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchDTO Constructor
CfgPhysicalSwitchDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPhysicalSwitchDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhysicalSwitchDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPhysicalSwitchDTO()

See Also

CfgPhysicalSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhysicalSwitchDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchDTO Fields
CfgPhysicalSwitchDTO Class See Also Send Feedback

The CfgPhysicalSwitchDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgPhysicalSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhysicalSwitchDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchDTO Methods
CfgPhysicalSwitchDTO Class See Also Send Feedback

The CfgPhysicalSwitchDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgPhysicalSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPhysicalSwitchDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchDTO Properties
CfgPhysicalSwitchDTO Class See Also Send Feedback

The CfgPhysicalSwitchDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPhysicalSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPlaceDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgPlaceDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgPlaceDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPlaceDTO

See Also

CfgPlaceDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceDTO Members
CfgPlaceDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPlaceDTO type exposes the following members.

Constructors

Name | Description
CfgPlaceDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPlaceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceDTO Constructor
CfgPlaceDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPlaceDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPlaceDTO()

See Also

CfgPlaceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceDTO Fields
CfgPlaceDTO Class See Also Send Feedback

The CfgPlaceDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgPlaceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceDTO Methods
CfgPlaceDTO Class See Also Send Feedback

The CfgPlaceDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgPlaceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceDTO Properties
CfgPlaceDTO Class See Also Send Feedback

The CfgPlaceDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPlaceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceGroupDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPlaceGroupDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceGroupDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgPlaceGroupDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgPlaceGroupDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPlaceGroupDTO

See Also

CfgPlaceGroupDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceGroupDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupDTO Members
CfgPlaceGroupDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPlaceGroupDTO type exposes the following members.

Constructors

Name | Description
CfgPlaceGroupDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPlaceGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceGroupDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupDTO Constructor
CfgPlaceGroupDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPlaceGroupDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceGroupDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPlaceGroupDTO()

See Also

CfgPlaceGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceGroupDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupDTO Fields
CfgPlaceGroupDTO Class See Also Send Feedback

The CfgPlaceGroupDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgPlaceGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceGroupDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupDTO Methods
CfgPlaceGroupDTO Class See Also Send Feedback

The CfgPlaceGroupDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgPlaceGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPlaceGroupDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupDTO Properties
CfgPlaceGroupDTO Class See Also Send Feedback

The CfgPlaceGroupDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgPlaceGroupDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPortInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPortInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPortInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgPortInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgPortInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgPortInfoDTO

See Also

CfgPortInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPortInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoDTO Members
CfgPortInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPortInfoDTO type exposes the following members.

Constructors

Name | Description
CfgPortInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgPortInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPortInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoDTO Constructor
CfgPortInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgPortInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPortInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPortInfoDTO()

See Also

CfgPortInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPortInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoDTO Fields
CfgPortInfoDTO Class See Also Send Feedback

The CfgPortInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgPortInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPortInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoDTO Methods
CfgPortInfoDTO Class See Also Send Feedback

The CfgPortInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgPortInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgPortInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoDTO Properties
CfgPortInfoDTO Class See Also Send Feedback

The CfgPortInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgPortInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRemovalEventDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgRemovalEventDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRemovalEventDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgRemovalEventDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgRemovalEventDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgRemovalEventDTO

See Also

CfgRemovalEventDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRemovalEventDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventDTO Members
CfgRemovalEventDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgRemovalEventDTO type exposes the following members.

Constructors

Name | Description
CfgRemovalEventDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgRemovalEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRemovalEventDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventDTO Constructor
CfgRemovalEventDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgRemovalEventDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRemovalEventDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgRemovalEventDTO()

See Also

CfgRemovalEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRemovalEventDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventDTO Fields
CfgRemovalEventDTO Class See Also Send Feedback

The CfgRemovalEventDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgRemovalEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRemovalEventDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventDTO Methods
CfgRemovalEventDTO Class See Also Send Feedback

The CfgRemovalEventDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgRemovalEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRemovalEventDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventDTO Properties
CfgRemovalEventDTO Class See Also Send Feedback

The CfgRemovalEventDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgRemovalEventDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgResourceIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgResourceIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgResourceIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgResourceIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgResourceIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgResourceIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgResourceIDDTO

See Also

CfgResourceIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgResourceIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDDTO Members
CfgResourceIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgResourceIDDTO type exposes the following members.

Constructors

Name | Description
CfgResourceIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgResourceIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgResourceIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgResourceIDDTO Constructor
CfgResourceIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgResourceIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgResourceIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgResourceIDDTO()

See Also

CfgResourceIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgResourceIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDDTO Fields
CfgResourceIDDTO Class See Also Send Feedback

The CfgResourceIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgResourceIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgResourceIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDDTO Methods
CfgResourceIDDTO Class See Also Send Feedback

The CfgResourceIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgResourceIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgResourceIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDDTO Properties
CfgResourceIDDTO Class See Also Send Feedback

The CfgResourceIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgResourceIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgRoleDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgRoleDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRoleDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgRoleDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgRoleDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgRoleDTO

See Also

CfgRoleDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleDTO Members
CfgRoleDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgRoleDTO type exposes the following members.

Constructors

Name | Description
CfgRoleDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgRoleDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRoleDTO Constructor
CfgRoleDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgRoleDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRoleDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgRoleDTO()

See Also

CfgRoleDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleDTO Fields
CfgRoleDTO Class See Also Send Feedback

The CfgRoleDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgRoleDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleDTO Methods
CfgRoleDTO Class See Also Send Feedback

The CfgRoleDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgRoleDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleDTO Properties
CfgRoleDTO Class See Also Send Feedback

The CfgRoleDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgRoleDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleMemberDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgRoleMemberDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRoleMemberDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgRoleMemberDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgRoleMemberDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgRoleMemberDTO

See Also

CfgRoleMemberDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleMemberDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberDTO Members
CfgRoleMemberDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgRoleMemberDTO type exposes the following members.

Constructors

Name | Description
CfgRoleMemberDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgRoleMemberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleMemberDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberDTO Constructor
CfgRoleMemberDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgRoleMemberDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRoleMemberDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgRoleMemberDTO()

See Also

CfgRoleMemberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleMemberDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberDTO Fields
CfgRoleMemberDTO Class See Also Send Feedback

The CfgRoleMemberDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgRoleMemberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleMemberDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberDTO Methods
CfgRoleMemberDTO Class See Also Send Feedback

The CfgRoleMemberDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgRoleMemberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgRoleMemberDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberDTO Properties
CfgRoleMemberDTO Class See Also Send Feedback

The CfgRoleMemberDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgRoleMemberDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScheduledTaskDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgScheduledTaskDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScheduledTaskDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgScheduledTaskDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgScheduledTaskDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgScheduledTaskDTO

See Also

CfgScheduledTaskDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScheduledTaskDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskDTO Members
CfgScheduledTaskDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgScheduledTaskDTO type exposes the following members.

Constructors

Name | Description
CfgScheduledTaskDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgScheduledTaskDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScheduledTaskDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskDTO Constructor
CfgScheduledTaskDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgScheduledTaskDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScheduledTaskDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgScheduledTaskDTO()

See Also

CfgScheduledTaskDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScheduledTaskDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskDTO Fields
CfgScheduledTaskDTO Class See Also Send Feedback

The CfgScheduledTaskDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgScheduledTaskDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScheduledTaskDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskDTO Methods
CfgScheduledTaskDTO Class See Also Send Feedback

The CfgScheduledTaskDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgScheduledTaskDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScheduledTaskDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskDTO Properties
CfgScheduledTaskDTO Class See Also Send Feedback

The CfgScheduledTaskDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgScheduledTaskDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScriptDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgScriptDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgScriptDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScriptDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgScriptDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgScriptDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgScriptDTO

See Also

CfgScriptDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScriptDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptDTO Members
CfgScriptDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgScriptDTO type exposes the following members.

Constructors

Name | Description
CfgScriptDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgScriptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScriptDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScriptDTO Constructor
CfgScriptDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgScriptDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScriptDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgScriptDTO()

See Also

CfgScriptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScriptDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptDTO Fields
CfgScriptDTO Class See Also Send Feedback

The CfgScriptDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgScriptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScriptDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptDTO Methods
CfgScriptDTO Class See Also Send Feedback

The CfgScriptDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgScriptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgScriptDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptDTO Properties
CfgScriptDTO Class See Also Send Feedback

The CfgScriptDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgScriptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServerDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgServerDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgServerDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServerDTO

See Also

CfgServerDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerDTO Members
CfgServerDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServerDTO type exposes the following members.

Constructors

Name | Description
CfgServerDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerDTO Constructor
CfgServerDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServerDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServerDTO()

See Also

CfgServerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerDTO Fields
CfgServerDTO Class See Also Send Feedback

The CfgServerDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgServerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerDTO Methods
CfgServerDTO Class See Also Send Feedback

The CfgServerDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgServerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerDTO Properties
CfgServerDTO Class See Also Send Feedback

The CfgServerDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServerDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerHostIDDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServerHostIDDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerHostIDDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgServerHostIDDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgServerHostIDDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServerHostIDDTO

See Also

CfgServerHostIDDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerHostIDDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDDTO Members
CfgServerHostIDDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServerHostIDDTO type exposes the following members.

Constructors

Name | Description
CfgServerHostIDDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServerHostIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerHostIDDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDDTO Constructor
CfgServerHostIDDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServerHostIDDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerHostIDDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServerHostIDDTO()

See Also

CfgServerHostIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerHostIDDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDDTO Fields
CfgServerHostIDDTO Class See Also Send Feedback

The CfgServerHostIDDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgServerHostIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerHostIDDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDDTO Methods
CfgServerHostIDDTO Class See Also Send Feedback

The CfgServerHostIDDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgServerHostIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerHostIDDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDDTO Properties
CfgServerHostIDDTO Class See Also Send Feedback

The CfgServerHostIDDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServerHostIDDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerVersionDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerVersionDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServerVersionDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerVersionDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgServerVersionDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgServerVersionDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServerVersionDTO

See Also

CfgServerVersionDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerVersionDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionDTO Members
CfgServerVersionDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServerVersionDTO type exposes the following members.

Constructors

Name | Description
CfgServerVersionDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServerVersionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerVersionDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerVersionDTO Constructor
CfgServerVersionDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServerVersionDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerVersionDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServerVersionDTO()

See Also

CfgServerVersionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerVersionDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionDTO Fields
CfgServerVersionDTO Class See Also Send Feedback

The CfgServerVersionDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgServerVersionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerVersionDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionDTO Methods
CfgServerVersionDTO Class See Also Send Feedback

The CfgServerVersionDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgServerVersionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServerVersionDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionDTO Properties
CfgServerVersionDTO Class See Also Send Feedback

The CfgServerVersionDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServerVersionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgServiceDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServiceDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServiceDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgServiceDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgServiceDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServiceDTO

See Also

CfgServiceDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceDTO Members
CfgServiceDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServiceDTO type exposes the following members.

Constructors

Name | Description
CfgServiceDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgServiceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServiceDTO Constructor
CfgServiceDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServiceDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServiceDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServiceDTO()

See Also

CfgServiceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceDTO Fields
CfgServiceDTO Class See Also Send Feedback

The CfgServiceDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgServiceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceDTO Methods
CfgServiceDTO Class See Also Send Feedback

The CfgServiceDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgServiceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceDTO Properties
CfgServiceDTO Class See Also Send Feedback

The CfgServiceDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgServiceDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceInfoDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServiceInfoDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServiceInfoDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgServiceInfoDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgServiceInfoDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgServiceInfoDTO

See Also

CfgServiceInfoDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceInfoDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoDTO Members
CfgServiceInfoDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServiceInfoDTO type exposes the following members.

Constructors

Name | Description
CfgServiceInfoDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServiceInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceInfoDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoDTO Constructor
CfgServiceInfoDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgServiceInfoDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServiceInfoDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServiceInfoDTO()

See Also

CfgServiceInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceInfoDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoDTO Fields
CfgServiceInfoDTO Class See Also Send Feedback

The CfgServiceInfoDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgServiceInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceInfoDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoDTO Methods
CfgServiceInfoDTO Class See Also Send Feedback

The CfgServiceInfoDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgServiceInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgServiceInfoDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoDTO Properties
CfgServiceInfoDTO Class See Also Send Feedback

The CfgServiceInfoDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgServiceInfoDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkillDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSkillDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkillDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgSkillDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgSkillDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSkillDTO

See Also

CfgSkillDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillDTO Members
CfgSkillDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSkillDTO type exposes the following members.

Constructors

Name | Description
CfgSkillDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgSkillDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkillDTO Constructor
CfgSkillDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSkillDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkillDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSkillDTO()

See Also

CfgSkillDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillDTO Fields
CfgSkillDTO Class See Also Send Feedback

The CfgSkillDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSkillDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillDTO Methods
CfgSkillDTO Class See Also Send Feedback

The CfgSkillDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgSkillDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillDTO Properties
CfgSkillDTO Class See Also Send Feedback

The CfgSkillDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgSkillDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillLevelDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSkillLevelDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkillLevelDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgSkillLevelDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgSkillLevelDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSkillLevelDTO

See Also

CfgSkillLevelDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillLevelDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelDTO Members
CfgSkillLevelDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSkillLevelDTO type exposes the following members.

Constructors

Name | Description
CfgSkillLevelDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSkillLevelDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillLevelDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelDTO Constructor
CfgSkillLevelDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSkillLevelDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkillLevelDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSkillLevelDTO()

See Also

CfgSkillLevelDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillLevelDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelDTO Fields
CfgSkillLevelDTO Class See Also Send Feedback

The CfgSkillLevelDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSkillLevelDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillLevelDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelDTO Methods
CfgSkillLevelDTO Class See Also Send Feedback

The CfgSkillLevelDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgSkillLevelDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSkillLevelDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelDTO Properties
CfgSkillLevelDTO Class See Also Send Feedback

The CfgSkillLevelDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSkillLevelDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDefinitionDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSolutionComponentDefinitionDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSolutionComponentDefinitionDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgSolutionComponentDefinitionDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgSolutionComponentDefinitionDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSolutionComponentDefinitionDTO

See Also

CfgSolutionComponentDefinitionDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDefinitionDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionDTO Members
CfgSolutionComponentDefinitionDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSolutionComponentDefinitionDTO type exposes the following members.

Constructors

Name | Description
CfgSolutionComponentDefinitionDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSolutionComponentDefinitionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDefinitionDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionDTO Constructor
CfgSolutionComponentDefinitionDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSolutionComponentDefinitionDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionComponentDefinitionDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSolutionComponentDefinitionDTO()

See Also

CfgSolutionComponentDefinitionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDefinitionDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionDTO Fields
CfgSolutionComponentDefinitionDTO Class See Also Send Feedback

The CfgSolutionComponentDefinitionDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSolutionComponentDefinitionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDefinitionDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionDTO Methods
CfgSolutionComponentDefinitionDTO Class See Also Send Feedback

The CfgSolutionComponentDefinitionDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgSolutionComponentDefinitionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDefinitionDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionDTO Properties
CfgSolutionComponentDefinitionDTO Class See Also Send Feedback

The CfgSolutionComponentDefinitionDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSolutionComponentDefinitionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSolutionComponentDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSolutionComponentDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgSolutionComponentDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgSolutionComponentDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSolutionComponentDTO

See Also

CfgSolutionComponentDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDTO Members
CfgSolutionComponentDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSolutionComponentDTO type exposes the following members.

Constructors

Name | Description
CfgSolutionComponentDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSolutionComponentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDTO Constructor
CfgSolutionComponentDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSolutionComponentDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionComponentDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSolutionComponentDTO()

See Also

CfgSolutionComponentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDTO Fields
CfgSolutionComponentDTO Class See Also Send Feedback

The CfgSolutionComponentDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSolutionComponentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDTO Methods
CfgSolutionComponentDTO Class See Also Send Feedback

The CfgSolutionComponentDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgSolutionComponentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSolutionComponentDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDTO Properties
CfgSolutionComponentDTO Class See Also Send Feedback

The CfgSolutionComponentDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSolutionComponentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatDayDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgStatDayDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatDayDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgStatDayDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgStatDayDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgStatDayDTO

See Also

CfgStatDayDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatDayDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayDTO Members
CfgStatDayDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgStatDayDTO type exposes the following members.

Constructors

Name | Description
CfgStatDayDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgStatDayDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatDayDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayDTO Constructor
CfgStatDayDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgStatDayDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDayDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatDayDTO()

See Also

CfgStatDayDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatDayDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayDTO Fields
CfgStatDayDTO Class See Also Send Feedback

The CfgStatDayDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgStatDayDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatDayDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayDTO Methods
CfgStatDayDTO Class See Also Send Feedback

The CfgStatDayDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgStatDayDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatDayDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayDTO Properties
CfgStatDayDTO Class See Also Send Feedback

The CfgStatDayDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgStatDayDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatIntervalDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgStatIntervalDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatIntervalDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgStatIntervalDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgStatIntervalDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgStatIntervalDTO

See Also

CfgStatIntervalDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatIntervalDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalDTO Members
CfgStatIntervalDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgStatIntervalDTO type exposes the following members.

Constructors

Name | Description
CfgStatIntervalDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgStatIntervalDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatIntervalDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalDTO Constructor
CfgStatIntervalDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgStatIntervalDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatIntervalDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatIntervalDTO()

See Also

CfgStatIntervalDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatIntervalDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalDTO Fields
CfgStatIntervalDTO Class See Also Send Feedback

The CfgStatIntervalDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgStatIntervalDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatIntervalDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalDTO Methods
CfgStatIntervalDTO Class See Also Send Feedback

The CfgStatIntervalDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgStatIntervalDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatIntervalDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalDTO Properties
CfgStatIntervalDTO Class See Also Send Feedback

The CfgStatIntervalDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgStatIntervalDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatTableDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgStatTableDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatTableDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgStatTableDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgStatTableDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgStatTableDTO

See Also

CfgStatTableDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatTableDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableDTO Members
CfgStatTableDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgStatTableDTO type exposes the following members.

Constructors

Name | Description
CfgStatTableDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgStatTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatTableDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableDTO Constructor
CfgStatTableDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgStatTableDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTableDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatTableDTO()

See Also

CfgStatTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatTableDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableDTO Fields
CfgStatTableDTO Class See Also Send Feedback

The CfgStatTableDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgStatTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatTableDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableDTO Methods
CfgStatTableDTO Class See Also Send Feedback

The CfgStatTableDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgStatTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgStatTableDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableDTO Properties
CfgStatTableDTO Class See Also Send Feedback

The CfgStatTableDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgStatTableDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSubcodeDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSubcodeDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSubcodeDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSubcodeDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgSubcodeDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgSubcodeDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSubcodeDTO

See Also

CfgSubcodeDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSubcodeDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeDTO Members
CfgSubcodeDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSubcodeDTO type exposes the following members.

Constructors

Name | Description
CfgSubcodeDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSubcodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSubcodeDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSubcodeDTO Constructor
CfgSubcodeDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSubcodeDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSubcodeDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSubcodeDTO()

See Also

CfgSubcodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSubcodeDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeDTO Fields
CfgSubcodeDTO Class See Also Send Feedback

The CfgSubcodeDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSubcodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSubcodeDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeDTO Methods
CfgSubcodeDTO Class See Also Send Feedback

The CfgSubcodeDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgSubcodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSubcodeDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeDTO Properties
CfgSubcodeDTO Class See Also Send Feedback

The CfgSubcodeDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSubcodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchAccessCodeDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSwitchAccessCodeDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitchAccessCodeDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgSwitchAccessCodeDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgSwitchAccessCodeDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSwitchAccessCodeDTO

See Also

CfgSwitchAccessCodeDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchAccessCodeDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeDTO Members
CfgSwitchAccessCodeDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSwitchAccessCodeDTO type exposes the following members.

Constructors

Name | Description
CfgSwitchAccessCodeDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSwitchAccessCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchAccessCodeDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeDTO Constructor
CfgSwitchAccessCodeDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSwitchAccessCodeDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchAccessCodeDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSwitchAccessCodeDTO()

See Also

CfgSwitchAccessCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchAccessCodeDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeDTO Fields
CfgSwitchAccessCodeDTO Class See Also Send Feedback

The CfgSwitchAccessCodeDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSwitchAccessCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchAccessCodeDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeDTO Methods
CfgSwitchAccessCodeDTO Class See Also Send Feedback

The CfgSwitchAccessCodeDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgSwitchAccessCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchAccessCodeDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeDTO Properties
CfgSwitchAccessCodeDTO Class See Also Send Feedback

The CfgSwitchAccessCodeDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgSwitchAccessCodeDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSwitchDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitchDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgSwitchDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgSwitchDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgSwitchDTO

See Also

CfgSwitchDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchDTO Members
CfgSwitchDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSwitchDTO type exposes the following members.

Constructors

Name | Description
CfgSwitchDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchDTO Constructor
CfgSwitchDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgSwitchDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSwitchDTO()

See Also

CfgSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchDTO Fields
CfgSwitchDTO Class See Also Send Feedback

The CfgSwitchDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchDTO Methods
CfgSwitchDTO Class See Also Send Feedback

The CfgSwitchDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgSwitchDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchDTO Properties
CfgSwitchDTO Class See Also Send Feedback

The CfgSwitchDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgSwitchDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTableAccessDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTableAccessDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTableAccessDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgTableAccessDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgTableAccessDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTableAccessDTO

See Also

CfgTableAccessDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTableAccessDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessDTO Members
CfgTableAccessDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTableAccessDTO type exposes the following members.

Constructors

Name | Description
CfgTableAccessDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTableAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTableAccessDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessDTO Constructor
CfgTableAccessDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTableAccessDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccessDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTableAccessDTO()

See Also

CfgTableAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTableAccessDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessDTO Fields
CfgTableAccessDTO Class See Also Send Feedback

The CfgTableAccessDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgTableAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTableAccessDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessDTO Methods
CfgTableAccessDTO Class See Also Send Feedback

The CfgTableAccessDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgTableAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTableAccessDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessDTO Properties
CfgTableAccessDTO Class See Also Send Feedback

The CfgTableAccessDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTableAccessDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTenantDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgTenantDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTenantDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTenantDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgTenantDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgTenantDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTenantDTO

See Also

CfgTenantDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTenantDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantDTO Members
CfgTenantDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTenantDTO type exposes the following members.

Constructors

Name | Description
CfgTenantDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTenantDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTenantDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTenantDTO Constructor
CfgTenantDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTenantDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenantDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTenantDTO()

See Also

CfgTenantDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTenantDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantDTO Fields
CfgTenantDTO Class See Also Send Feedback

The CfgTenantDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgTenantDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTenantDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantDTO Methods
CfgTenantDTO Class See Also Send Feedback

The CfgTenantDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgTenantDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTenantDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantDTO Properties
CfgTenantDTO Class See Also Send Feedback

The CfgTenantDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTenantDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTimeZoneDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTimeZoneDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTimeZoneDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgTimeZoneDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgTimeZoneDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTimeZoneDTO

See Also

CfgTimeZoneDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTimeZoneDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneDTO Members
CfgTimeZoneDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTimeZoneDTO type exposes the following members.

Constructors

Name | Description
CfgTimeZoneDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTimeZoneDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTimeZoneDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneDTO Constructor
CfgTimeZoneDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTimeZoneDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZoneDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTimeZoneDTO()

See Also

CfgTimeZoneDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTimeZoneDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneDTO Fields
CfgTimeZoneDTO Class See Also Send Feedback

The CfgTimeZoneDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgTimeZoneDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTimeZoneDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneDTO Methods
CfgTimeZoneDTO Class See Also Send Feedback

The CfgTimeZoneDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgTimeZoneDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTimeZoneDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneDTO Properties
CfgTimeZoneDTO Class See Also Send Feedback

The CfgTimeZoneDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTimeZoneDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTransactionDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTransactionDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTransactionDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgTransactionDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgTransactionDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTransactionDTO

See Also

CfgTransactionDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTransactionDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionDTO Members
CfgTransactionDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTransactionDTO type exposes the following members.

Constructors

Name | Description
CfgTransactionDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTransactionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTransactionDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionDTO Constructor
CfgTransactionDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTransactionDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransactionDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTransactionDTO()

See Also

CfgTransactionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTransactionDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionDTO Fields
CfgTransactionDTO Class See Also Send Feedback

The CfgTransactionDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgTransactionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTransactionDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionDTO Methods
CfgTransactionDTO Class See Also Send Feedback

The CfgTransactionDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgTransactionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTransactionDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionDTO Properties
CfgTransactionDTO Class See Also Send Feedback

The CfgTransactionDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTransactionDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTreatmentDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTreatmentDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTreatmentDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgTreatmentDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgTreatmentDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgTreatmentDTO

See Also

CfgTreatmentDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTreatmentDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentDTO Members
CfgTreatmentDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTreatmentDTO type exposes the following members.

Constructors

Name | Description
CfgTreatmentDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTreatmentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTreatmentDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentDTO Constructor
CfgTreatmentDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgTreatmentDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTreatmentDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTreatmentDTO()

See Also

CfgTreatmentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTreatmentDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentDTO Fields
CfgTreatmentDTO Class See Also Send Feedback

The CfgTreatmentDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgTreatmentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTreatmentDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentDTO Methods
CfgTreatmentDTO Class See Also Send Feedback

The CfgTreatmentDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgTreatmentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgTreatmentDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentDTO Properties
CfgTreatmentDTO Class See Also Send Feedback

The CfgTreatmentDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgTreatmentDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgUpdatePackageRecordDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgUpdatePackageRecordDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgUpdatePackageRecordDTO : CfgStructureDTO
Visual Basic (Declaration)
Public Class CfgUpdatePackageRecordDTO _
    Inherits CfgStructureDTO
Visual C++
public ref class CfgUpdatePackageRecordDTO : public CfgStructureDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgStructureDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgUpdatePackageRecordDTO

See Also

CfgUpdatePackageRecordDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgUpdatePackageRecordDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordDTO Members
CfgUpdatePackageRecordDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgUpdatePackageRecordDTO type exposes the following members.

Constructors

Name | Description
CfgUpdatePackageRecordDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgUpdatePackageRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgUpdatePackageRecordDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordDTO Constructor
CfgUpdatePackageRecordDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgUpdatePackageRecordDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgUpdatePackageRecordDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgUpdatePackageRecordDTO()

See Also

CfgUpdatePackageRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgUpdatePackageRecordDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordDTO Fields
CfgUpdatePackageRecordDTO Class See Also Send Feedback

The CfgUpdatePackageRecordDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgUpdatePackageRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgUpdatePackageRecordDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordDTO Methods
CfgUpdatePackageRecordDTO Class See Also Send Feedback

The CfgUpdatePackageRecordDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureDTO.)

See Also

CfgUpdatePackageRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgUpdatePackageRecordDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordDTO Properties
CfgUpdatePackageRecordDTO Class See Also Send Feedback

The CfgUpdatePackageRecordDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
ParentDBID | (Inherited from CfgStructureDTO.)

See Also

CfgUpdatePackageRecordDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgVoicePromptDTO Class

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptDTO Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgVoicePromptDTO"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgVoicePromptDTO : CfgObjectDTO
Visual Basic (Declaration)
Public Class CfgVoicePromptDTO _
    Inherits CfgObjectDTO
Visual C++
public ref class CfgVoicePromptDTO : public CfgObjectDTO

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgBaseDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects..::.CfgVoicePromptDTO

See Also

CfgVoicePromptDTO Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgVoicePromptDTO Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptDTO Members
CfgVoicePromptDTO Class Constructors Methods Fields Properties See Also Send Feedback

The CfgVoicePromptDTO type exposes the following members.

Constructors

Name | Description
CfgVoicePromptDTO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgVoicePromptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgVoicePromptDTO Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptDTO Constructor
CfgVoicePromptDTO Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects.CfgVoicePromptDTO.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgVoicePromptDTO()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgVoicePromptDTO()

See Also

CfgVoicePromptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgVoicePromptDTO Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptDTO Fields
CfgVoicePromptDTO Class See Also Send Feedback

The CfgVoicePromptDTO type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseDTO.)

See Also

CfgVoicePromptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgVoicePromptDTO Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptDTO Methods
CfgVoicePromptDTO Class See Also Send Feedback

The CfgVoicePromptDTO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectDTO.)

See Also

CfgVoicePromptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


CfgVoicePromptDTO Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptDTO Properties
CfgVoicePromptDTO Class See Also Send Feedback

The CfgVoicePromptDTO type exposes the following members.

Properties

Name | Description
Data | (Inherited from CfgBaseDTO.)
DBID | (Inherited from CfgObjectDTO.)

See Also

CfgVoicePromptDTO Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjects Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace
Send Feedback

Classes

Class | Description
SerializationExtension |


SerializationExtension Class

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class SerializationExtension
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class SerializationExtension
Visual C++
[ExtensionAttribute]
public ref class SerializationExtension abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension..::.SerializationExtension

See Also

SerializationExtension Members
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace


SerializationExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
SerializationExtension Members
SerializationExtension Class Methods See Also Send Feedback

The SerializationExtension type exposes the following members.

Methods

Name | Description
AsJson |
AsString |
AsXElement |

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace


SerializationExtension Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SerializationExtension Methods
SerializationExtension Class See Also Send Feedback

The SerializationExtension type exposes the following members.

Methods

Name | Description
AsJson |
AsString |
AsXElement |

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace


AsJson Method

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension..::.AsJson Method
SerializationExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsJson(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static string AsJson(
    this CfgObjectDTO obj
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AsJson ( _
    obj As CfgObjectDTO _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ AsJson(
    CfgObjectDTO^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsJson(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsJson(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace


AsString Method

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension..::.AsString Method
SerializationExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsString(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static string AsString(
    this CfgObjectDTO obj
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AsString ( _
    obj As CfgObjectDTO _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ AsString(
    CfgObjectDTO^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsString(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsString(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace


AsXElement Method

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension..::.AsXElement Method
SerializationExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsXElement(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static XElement AsXElement(
    this CfgObjectDTO obj
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AsXElement ( _
    obj As CfgObjectDTO _
) As XElement
Visual C++
[ExtensionAttribute]
public:
static XElement^ AsXElement(
    CfgObjectDTO^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsXElement(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension.SerializationExtension.AsXElement(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.DTO.Extension Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace
Send Feedback

Classes

Class | Description
CfgBaseEx |
CfgObjectEx |
CfgStructureEx |
ConfEventEx |
NotificationQueryEx |
PermissionDescriptorEx |

Enumerations

Enumeration | Description
ConfEventTypeEx |


CfgBaseEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgBaseEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgBaseEx
Visual Basic (Declaration)
Public MustInherit Class CfgBaseEx
Visual C++
public ref class CfgBaseEx abstract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx

See Also

CfgBaseEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgBaseEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseEx Members
CfgBaseEx Class Methods Fields See Also Send Feedback

The CfgBaseEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DoNotUseThisProperty |

See Also

CfgBaseEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgBaseEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseEx Fields
CfgBaseEx Class See Also Send Feedback

The CfgBaseEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty |

See Also

CfgBaseEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


DoNotUseThisProperty Field

[image]

Enterprise SDK 8.0 Reference API
CfgBaseEx..::.DoNotUseThisProperty Field
CfgBaseEx Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx.DoNotUseThisProperty"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object DoNotUseThisProperty
Visual Basic (Declaration)
Public DoNotUseThisProperty As Object
Visual C++
public:
Object^ DoNotUseThisProperty

See Also

CfgBaseEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgBaseEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgBaseEx Methods
CfgBaseEx Class See Also Send Feedback

The CfgBaseEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgBaseEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgObjectEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgObjectEx : CfgBaseEx
Visual Basic (Declaration)
Public MustInherit Class CfgObjectEx _
    Inherits CfgBaseEx
Visual C++
public ref class CfgObjectEx abstract : public CfgBaseEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAccessGroupEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgActionCodeEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentGroupEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentLoginEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAlarmConditionEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgApplicationEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAppPrototypeEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCallingListEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCampaignEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCampaignGroupEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNGroupEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgEnumeratorEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgEnumeratorValueEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFieldEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFilterEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFolderEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFormatEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGVPCustomerEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGVPIVRProfileEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGVPResellerEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgHostEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgIVREx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgIVRPortEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectiveTableEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPersonEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPhysicalSwitchEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPlaceEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPlaceGroupEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgRoleEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgScheduledTaskEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgScriptEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServiceEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSkillEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgStatDayEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgStatTableEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSwitchEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTableAccessEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTenantEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTimeZoneEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTransactionEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTreatmentEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgVoicePromptEx

See Also

CfgObjectEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgObjectEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectEx Members
CfgObjectEx Class Methods Fields Properties See Also Send Feedback

The CfgObjectEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType |

See Also

CfgObjectEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgObjectEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectEx Fields
CfgObjectEx Class See Also Send Feedback

The CfgObjectEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgObjectEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgObjectEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectEx Methods
CfgObjectEx Class See Also Send Feedback

The CfgObjectEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

CfgObjectEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectEx..::.ToString Method
CfgObjectEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx.ToString"]

See Also

CfgObjectEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgObjectEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectEx Properties
CfgObjectEx Class See Also Send Feedback

The CfgObjectEx type exposes the following members.

Properties

Name | Description
CfgObjectType |

See Also

CfgObjectEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectEx..::.CfgObjectType Property
CfgObjectEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx.CfgObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType CfgObjectType { get; set; }
Visual Basic (Declaration)
Public Property CfgObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType CfgObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgObjectEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgStructureEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgStructureEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgStructureEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgStructureEx : CfgBaseEx
Visual Basic (Declaration)
Public MustInherit Class CfgStructureEx _
    Inherits CfgBaseEx
Visual C++
public ref class CfgStructureEx abstract : public CfgBaseEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACEEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACEIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACLEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACLIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAddressEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentLoginInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAppRankEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAppServicePermissionEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCallingListInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCampaignGroupInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgConnInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDelSwitchAccessEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDetectEventEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNAccessNumberEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGroupEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgMemberIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectiveTableRecordEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectResourceEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgOSEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgOwnerIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgParentIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPhonesEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPortInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgRemovalEventEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgResourceIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgRoleMemberEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServerEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServerHostIDEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServerVersionEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServiceInfoEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSkillLevelEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSolutionComponentDefinitionEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSolutionComponentEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgStatIntervalEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSubcodeEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSwitchAccessCodeEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgUpdatePackageRecordEx

See Also

CfgStructureEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgStructureEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureEx Members
CfgStructureEx Class Methods Fields Properties See Also Send Feedback

The CfgStructureEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID |

See Also

CfgStructureEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgStructureEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureEx Fields
CfgStructureEx Class See Also Send Feedback

The CfgStructureEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgStructureEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgStructureEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureEx Methods
CfgStructureEx Class See Also Send Feedback

The CfgStructureEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

CfgStructureEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
CfgStructureEx..::.ToString Method
CfgStructureEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgStructureEx.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgStructureEx.ToString"]

See Also

CfgStructureEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


CfgStructureEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStructureEx Properties
CfgStructureEx Class See Also Send Feedback

The CfgStructureEx type exposes the following members.

Properties

Name | Description
ParentDBID |

See Also

CfgStructureEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ParentDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgStructureEx..::.ParentDBID Property
CfgStructureEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgStructureEx.ParentDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ParentDBID { get; set; }
Visual Basic (Declaration)
Public Property ParentDBID As Integer
Visual C++
public:
property int ParentDBID {
    int get ();
    void set (int value);
}

See Also

CfgStructureEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ConfEventEx Class

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ConfEventEx
Visual Basic (Declaration)
Public Class ConfEventEx
Visual C++
public ref class ConfEventEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.ConfEventEx

See Also

ConfEventEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ConfEventEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventEx Members
ConfEventEx Class Constructors Methods Properties See Also Send Feedback

The ConfEventEx type exposes the following members.

Constructors

Name | Description
ConfEventEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
EndpointHost |
EndpointName |
EndpointPort |
EventType |
ObjectId |
ObjectType |
XmlDelta |

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ConfEventEx Constructor

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx Constructor
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEventEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfEventEx()

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ConfEventEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventEx Methods
ConfEventEx Class See Also Send Feedback

The ConfEventEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.ToString Method
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.ToString"]

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ConfEventEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventEx Properties
ConfEventEx Class See Also Send Feedback

The ConfEventEx type exposes the following members.

Properties

Name | Description
EndpointHost |
EndpointName |
EndpointPort |
EventType |
ObjectId |
ObjectType |
XmlDelta |

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


EndpointHost Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.EndpointHost Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.EndpointHost"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EndpointHost { get; set; }
Visual Basic (Declaration)
Public Property EndpointHost As String
Visual C++
public:
property String^ EndpointHost {
    String^ get ();
    void set (String^ value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


EndpointName Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.EndpointName Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.EndpointName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EndpointName { get; set; }
Visual Basic (Declaration)
Public Property EndpointName As String
Visual C++
public:
property String^ EndpointName {
    String^ get ();
    void set (String^ value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


EndpointPort Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.EndpointPort Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.EndpointPort"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int EndpointPort { get; set; }
Visual Basic (Declaration)
Public Property EndpointPort As Integer
Visual C++
public:
property int EndpointPort {
    int get ();
    void set (int value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


EventType Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.EventType Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.EventType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEventTypeEx EventType { get; set; }
Visual Basic (Declaration)
Public Property EventType As ConfEventTypeEx
Visual C++
public:
property ConfEventTypeEx EventType {
    ConfEventTypeEx get ();
    void set (ConfEventTypeEx value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ObjectId Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.ObjectId Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.ObjectId"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectId { get; set; }
Visual Basic (Declaration)
Public Property ObjectId As Integer
Visual C++
public:
property int ObjectId {
    int get ();
    void set (int value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.ObjectType Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


XmlDelta Property

[image]

Enterprise SDK 8.0 Reference API
ConfEventEx..::.XmlDelta Property
ConfEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx.XmlDelta"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public XDocument XmlDelta { get; set; }
Visual Basic (Declaration)
Public Property XmlDelta As XDocument
Visual C++
public:
property XDocument^ XmlDelta {
    XDocument^ get ();
    void set (XDocument^ value);
}

See Also

ConfEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ConfEventTypeEx Enumeration

[image]

Enterprise SDK 8.0 Reference API
ConfEventTypeEx Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventTypeEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ConfEventTypeEx
Visual Basic (Declaration)
Public Enumeration ConfEventTypeEx
Visual C++
public enum class ConfEventTypeEx

Members

Member name | Description
ObjectCreated |
ObjectDeleted |
ObjectUpdated |

See Also

Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


NotificationQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class NotificationQueryEx
Visual Basic (Declaration)
Public Class NotificationQueryEx
Visual C++
public ref class NotificationQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.NotificationQueryEx

See Also

NotificationQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


NotificationQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx Members
NotificationQueryEx Class Constructors Methods Properties See Also Send Feedback

The NotificationQueryEx type exposes the following members.

Constructors

Name | Description
NotificationQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
ObjectDbid |
ObjectType |
TenantDbid |

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


NotificationQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx Constructor
NotificationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public NotificationQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotificationQueryEx()

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


NotificationQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx Methods
NotificationQueryEx Class See Also Send Feedback

The NotificationQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx..::.ToString Method
NotificationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx.ToString"]

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


NotificationQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx Properties
NotificationQueryEx Class See Also Send Feedback

The NotificationQueryEx type exposes the following members.

Properties

Name | Description
ObjectDbid |
ObjectType |
TenantDbid |

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx..::.ObjectDbid Property
NotificationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx.ObjectDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ObjectDbid { get; set; }
Visual Basic (Declaration)
Public Property ObjectDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ObjectDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx..::.ObjectType Property
NotificationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectType> ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As Nullable(Of CfgObjectType)
Visual C++
public:
property Nullable<CfgObjectType> ObjectType {
    Nullable<CfgObjectType> get ();
    void set (Nullable<CfgObjectType> value);
}

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryEx..::.TenantDbid Property
NotificationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

NotificationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


PermissionDescriptorEx Class

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class PermissionDescriptorEx
Visual Basic (Declaration)
Public Class PermissionDescriptorEx
Visual C++
public ref class PermissionDescriptorEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.PermissionDescriptorEx

See Also

PermissionDescriptorEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


PermissionDescriptorEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx Members
PermissionDescriptorEx Class Constructors Methods Properties See Also Send Feedback

The PermissionDescriptorEx type exposes the following members.

Constructors

Name | Description
PermissionDescriptorEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
AccessMask |
ObjectDbid |
ObjectType |

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


PermissionDescriptorEx Constructor

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx Constructor
PermissionDescriptorEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public PermissionDescriptorEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PermissionDescriptorEx()

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


PermissionDescriptorEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx Methods
PermissionDescriptorEx Class See Also Send Feedback

The PermissionDescriptorEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx..::.ToString Method
PermissionDescriptorEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx.ToString"]

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


PermissionDescriptorEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx Properties
PermissionDescriptorEx Class See Also Send Feedback

The PermissionDescriptorEx type exposes the following members.

Properties

Name | Description
AccessMask |
ObjectDbid |
ObjectType |

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


AccessMask Property

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx..::.AccessMask Property
PermissionDescriptorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx.AccessMask"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AccessMask { get; set; }
Visual Basic (Declaration)
Public Property AccessMask As Integer
Visual C++
public:
property int AccessMask {
    int get ();
    void set (int value);
}

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx..::.ObjectDbid Property
PermissionDescriptorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx.ObjectDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDbid { get; set; }
Visual Basic (Declaration)
Public Property ObjectDbid As Integer
Visual C++
public:
property int ObjectDbid {
    int get ();
    void set (int value);
}

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
PermissionDescriptorEx..::.ObjectType Property
PermissionDescriptorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As Integer
Visual C++
public:
property int ObjectType {
    int get ();
    void set (int value);
}

See Also

PermissionDescriptorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace
Send Feedback

Classes

Class | Description
CfgAccessGroupEx |
CfgACEEx |
CfgACEIDEx |
CfgACLEx |
CfgACLIDEx |
CfgActionCodeEx |
CfgAddressEx |
CfgAgentGroupEx |
CfgAgentInfoEx |
CfgAgentLoginEx |
CfgAgentLoginInfoEx |
CfgAlarmConditionEx |
CfgApplicationEx |
CfgAppPrototypeEx |
CfgAppRankEx |
CfgAppServicePermissionEx |
CfgCallingListEx |
CfgCallingListInfoEx |
CfgCampaignEx |
CfgCampaignGroupEx |
CfgCampaignGroupInfoEx |
CfgConnInfoEx |
CfgDelSwitchAccessEx |
CfgDetectEventEx |
CfgDNAccessNumberEx |
CfgDNEx |
CfgDNGroupEx |
CfgDNInfoEx |
CfgEnumeratorEx |
CfgEnumeratorValueEx |
CfgFieldEx |
CfgFilterEx |
CfgFolderEx |
CfgFormatEx |
CfgGroupEx |
CfgGVPCustomerEx |
CfgGVPIVRProfileEx |
CfgGVPResellerEx |
CfgHostEx |
CfgIDEx |
CfgIVREx |
CfgIVRPortEx |
CfgMemberIDEx |
CfgObjectIDEx |
CfgObjectiveTableEx |
CfgObjectiveTableRecordEx |
CfgObjectResourceEx |
CfgOSEx |
CfgOwnerIDEx |
CfgParentIDEx |
CfgPersonEx |
CfgPhonesEx |
CfgPhysicalSwitchEx |
CfgPlaceEx |
CfgPlaceGroupEx |
CfgPortInfoEx |
CfgRemovalEventEx |
CfgResourceIDEx |
CfgRoleEx |
CfgRoleMemberEx |
CfgScheduledTaskEx |
CfgScriptEx |
CfgServerEx |
CfgServerHostIDEx |
CfgServerVersionEx |
CfgServiceEx |
CfgServiceInfoEx |
CfgSkillEx |
CfgSkillLevelEx |
CfgSolutionComponentDefinitionEx |
CfgSolutionComponentEx |
CfgStatDayEx |
CfgStatIntervalEx |
CfgStatTableEx |
CfgSubcodeEx |
CfgSwitchAccessCodeEx |
CfgSwitchEx |
CfgTableAccessEx |
CfgTenantEx |
CfgTimeZoneEx |
CfgTransactionEx |
CfgTreatmentEx |
CfgUpdatePackageRecordEx |
CfgVoicePromptEx |


CfgAccessGroupEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAccessGroupEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAccessGroupEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgAccessGroupEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgAccessGroupEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAccessGroupEx

See Also

CfgAccessGroupEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAccessGroupEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx Members
CfgAccessGroupEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAccessGroupEx type exposes the following members.

Constructors

Name | Description
CfgAccessGroupEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
GroupInfo |
MemberIDs |
Type |

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAccessGroupEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx Constructor
CfgAccessGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAccessGroupEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAccessGroupEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAccessGroupEx()

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAccessGroupEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx Fields
CfgAccessGroupEx Class See Also Send Feedback

The CfgAccessGroupEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAccessGroupEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx Methods
CfgAccessGroupEx Class See Also Send Feedback

The CfgAccessGroupEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAccessGroupEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx Properties
CfgAccessGroupEx Class See Also Send Feedback

The CfgAccessGroupEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
GroupInfo |
MemberIDs |
Type |

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx..::.DBID Property
CfgAccessGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAccessGroupEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx..::.GroupInfo Property
CfgAccessGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAccessGroupEx.GroupInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroupEx GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroupEx
Visual C++
public:
property CfgGroupEx^ GroupInfo {
    CfgGroupEx^ get ();
    void set (CfgGroupEx^ value);
}

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MemberIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx..::.MemberIDs Property
CfgAccessGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAccessGroupEx.MemberIDs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgIDEx> MemberIDs { get; set; }
Visual Basic (Declaration)
Public Property MemberIDs As List(Of CfgIDEx)
Visual C++
public:
property List<CfgIDEx^>^ MemberIDs {
    List<CfgIDEx^>^ get ();
    void set (List<CfgIDEx^>^ value);
}

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupEx..::.Type Property
CfgAccessGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAccessGroupEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAccessGroupType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAccessGroupType
Visual C++
public:
property CfgAccessGroupType Type {
    CfgAccessGroupType get ();
    void set (CfgAccessGroupType value);
}

See Also

CfgAccessGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgACEEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACEEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgACEEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgACEEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACEEx

See Also

CfgACEEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEEx Members
CfgACEEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACEEx type exposes the following members.

Constructors

Name | Description
CfgACEEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AccessMask |
ID |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACEEx Constructor
CfgACEEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACEEx()

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEEx Fields
CfgACEEx Class See Also Send Feedback

The CfgACEEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEEx Methods
CfgACEEx Class See Also Send Feedback

The CfgACEEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEEx Properties
CfgACEEx Class See Also Send Feedback

The CfgACEEx type exposes the following members.

Properties

Name | Description
AccessMask |
ID |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AccessMask Property

[image]

Enterprise SDK 8.0 Reference API
CfgACEEx..::.AccessMask Property
CfgACEEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEEx.AccessMask"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AccessMask { get; set; }
Visual Basic (Declaration)
Public Property AccessMask As Integer
Visual C++
public:
property int AccessMask {
    int get ();
    void set (int value);
}

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACEEx..::.ID Property
CfgACEEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEEx.ID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEIDEx ID { get; set; }
Visual Basic (Declaration)
Public Property ID As CfgACEIDEx
Visual C++
public:
property CfgACEIDEx^ ID {
    CfgACEIDEx^ get ();
    void set (CfgACEIDEx^ value);
}

See Also

CfgACEEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACEIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgACEIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgACEIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACEIDEx

See Also

CfgACEIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx Members
CfgACEIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACEIDEx type exposes the following members.

Constructors

Name | Description
CfgACEIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx Constructor
CfgACEIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACEIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACEIDEx()

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx Fields
CfgACEIDEx Class See Also Send Feedback

The CfgACEIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx Methods
CfgACEIDEx Class See Also Send Feedback

The CfgACEIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACEIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx Properties
CfgACEIDEx Class See Also Send Feedback

The CfgACEIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx..::.DBID Property
CfgACEIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgACEIDEx..::.Type Property
CfgACEIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACEIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgACEIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgACLEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACLEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgACLEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgACLEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACLEx

See Also

CfgACLEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLEx Members
CfgACLEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACLEx type exposes the following members.

Constructors

Name | Description
CfgACLEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ACEs |
ObjectID |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACLEx Constructor
CfgACLEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACLEx()

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLEx Fields
CfgACLEx Class See Also Send Feedback

The CfgACLEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLEx Methods
CfgACLEx Class See Also Send Feedback

The CfgACLEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLEx Properties
CfgACLEx Class See Also Send Feedback

The CfgACLEx type exposes the following members.

Properties

Name | Description
ACEs |
ObjectID |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ACEs Property

[image]

Enterprise SDK 8.0 Reference API
CfgACLEx..::.ACEs Property
CfgACLEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLEx.ACEs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgACEEx> ACEs { get; set; }
Visual Basic (Declaration)
Public Property ACEs As List(Of CfgACEEx)
Visual C++
public:
property List<CfgACEEx^>^ ACEs {
    List<CfgACEEx^>^ get ();
    void set (List<CfgACEEx^>^ value);
}

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACLEx..::.ObjectID Property
CfgACLEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLEx.ObjectID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLIDEx ObjectID { get; set; }
Visual Basic (Declaration)
Public Property ObjectID As CfgACLIDEx
Visual C++
public:
property CfgACLIDEx^ ObjectID {
    CfgACLIDEx^ get ();
    void set (CfgACLIDEx^ value);
}

See Also

CfgACLEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgACLIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgACLIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgACLIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgACLIDEx

See Also

CfgACLIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx Members
CfgACLIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgACLIDEx type exposes the following members.

Constructors

Name | Description
CfgACLIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx Constructor
CfgACLIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgACLIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgACLIDEx()

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx Fields
CfgACLIDEx Class See Also Send Feedback

The CfgACLIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx Methods
CfgACLIDEx Class See Also Send Feedback

The CfgACLIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgACLIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx Properties
CfgACLIDEx Class See Also Send Feedback

The CfgACLIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx..::.DBID Property
CfgACLIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgACLIDEx..::.Type Property
CfgACLIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgACLIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgACLIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgActionCodeEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgActionCodeEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgActionCodeEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgActionCodeEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgActionCodeEx

See Also

CfgActionCodeEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgActionCodeEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx Members
CfgActionCodeEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgActionCodeEx type exposes the following members.

Constructors

Name | Description
CfgActionCodeEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Code |
DBID |
Name |
State |
Subcodes |
Tenant |
Type |
UserProperties |

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgActionCodeEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx Constructor
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCodeEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgActionCodeEx()

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgActionCodeEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx Fields
CfgActionCodeEx Class See Also Send Feedback

The CfgActionCodeEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgActionCodeEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx Methods
CfgActionCodeEx Class See Also Send Feedback

The CfgActionCodeEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgActionCodeEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx Properties
CfgActionCodeEx Class See Also Send Feedback

The CfgActionCodeEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Code |
DBID |
Name |
State |
Subcodes |
Tenant |
Type |
UserProperties |

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Code Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.Code Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.Code"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.DBID Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.Name Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.State Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Subcodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.Subcodes Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.Subcodes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgSubcodeEx> Subcodes { get; set; }
Visual Basic (Declaration)
Public Property Subcodes As List(Of CfgSubcodeEx)
Visual C++
public:
property List<CfgSubcodeEx^>^ Subcodes {
    List<CfgSubcodeEx^>^ get ();
    void set (List<CfgSubcodeEx^>^ value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.Tenant Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.Type Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCodeType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgActionCodeType
Visual C++
public:
property CfgActionCodeType Type {
    CfgActionCodeType get ();
    void set (CfgActionCodeType value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeEx..::.UserProperties Property
CfgActionCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgActionCodeEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgActionCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAddressEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAddressEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAddressEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAddressEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgAddressEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgAddressEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAddressEx

See Also

CfgAddressEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAddressEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressEx Members
CfgAddressEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAddressEx type exposes the following members.

Constructors

Name | Description
CfgAddressEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgAddressEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAddressEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAddressEx Constructor
CfgAddressEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAddressEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddressEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAddressEx()

See Also

CfgAddressEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAddressEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressEx Fields
CfgAddressEx Class See Also Send Feedback

The CfgAddressEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAddressEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAddressEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressEx Methods
CfgAddressEx Class See Also Send Feedback

The CfgAddressEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgAddressEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAddressEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAddressEx Properties
CfgAddressEx Class See Also Send Feedback

The CfgAddressEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgAddressEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentGroupEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentGroupEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentGroupEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgAgentGroupEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgAgentGroupEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentGroupEx

See Also

CfgAgentGroupEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentGroupEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx Members
CfgAgentGroupEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentGroupEx type exposes the following members.

Constructors

Name | Description
CfgAgentGroupEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Agents |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
GroupInfo |

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentGroupEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx Constructor
CfgAgentGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentGroupEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentGroupEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentGroupEx()

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentGroupEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx Fields
CfgAgentGroupEx Class See Also Send Feedback

The CfgAgentGroupEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentGroupEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx Methods
CfgAgentGroupEx Class See Also Send Feedback

The CfgAgentGroupEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentGroupEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx Properties
CfgAgentGroupEx Class See Also Send Feedback

The CfgAgentGroupEx type exposes the following members.

Properties

Name | Description
Agents |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
GroupInfo |

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Agents Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx..::.Agents Property
CfgAgentGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentGroupEx.Agents"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Agents { get; set; }
Visual Basic (Declaration)
Public Property Agents As List(Of Integer)
Visual C++
public:
property List<int>^ Agents {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx..::.DBID Property
CfgAgentGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentGroupEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupEx..::.GroupInfo Property
CfgAgentGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentGroupEx.GroupInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroupEx GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroupEx
Visual C++
public:
property CfgGroupEx^ GroupInfo {
    CfgGroupEx^ get ();
    void set (CfgGroupEx^ value);
}

See Also

CfgAgentGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgAgentInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgAgentInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentInfoEx

See Also

CfgAgentInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx Members
CfgAgentInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentInfoEx type exposes the following members.

Constructors

Name | Description
CfgAgentInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AgentLogins |
CapacityRule |
Contract |
ParentDBID | (Inherited from CfgStructureEx.)
Place |
Site |
SkillLevels |

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx Constructor
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentInfoEx()

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx Fields
CfgAgentInfoEx Class See Also Send Feedback

The CfgAgentInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx Methods
CfgAgentInfoEx Class See Also Send Feedback

The CfgAgentInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx Properties
CfgAgentInfoEx Class See Also Send Feedback

The CfgAgentInfoEx type exposes the following members.

Properties

Name | Description
AgentLogins |
CapacityRule |
Contract |
ParentDBID | (Inherited from CfgStructureEx.)
Place |
Site |
SkillLevels |

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AgentLogins Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx..::.AgentLogins Property
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.AgentLogins"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgAgentLoginInfoEx> AgentLogins { get; set; }
Visual Basic (Declaration)
Public Property AgentLogins As List(Of CfgAgentLoginInfoEx)
Visual C++
public:
property List<CfgAgentLoginInfoEx^>^ AgentLogins {
    List<CfgAgentLoginInfoEx^>^ get ();
    void set (List<CfgAgentLoginInfoEx^>^ value);
}

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx..::.CapacityRule Property
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.CapacityRule"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CapacityRule { get; set; }
Visual Basic (Declaration)
Public Property CapacityRule As Integer
Visual C++
public:
property int CapacityRule {
    int get ();
    void set (int value);
}

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx..::.Contract Property
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.Contract"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As Integer
Visual C++
public:
property int Contract {
    int get ();
    void set (int value);
}

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Place Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx..::.Place Property
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.Place"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Place { get; set; }
Visual Basic (Declaration)
Public Property Place As Integer
Visual C++
public:
property int Place {
    int get ();
    void set (int value);
}

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx..::.Site Property
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.Site"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Site { get; set; }
Visual Basic (Declaration)
Public Property Site As Integer
Visual C++
public:
property int Site {
    int get ();
    void set (int value);
}

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SkillLevels Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentInfoEx..::.SkillLevels Property
CfgAgentInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentInfoEx.SkillLevels"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgSkillLevelEx> SkillLevels { get; set; }
Visual Basic (Declaration)
Public Property SkillLevels As List(Of CfgSkillLevelEx)
Visual C++
public:
property List<CfgSkillLevelEx^>^ SkillLevels {
    List<CfgSkillLevelEx^>^ get ();
    void set (List<CfgSkillLevelEx^>^ value);
}

See Also

CfgAgentInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLoginEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgAgentLoginEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgAgentLoginEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentLoginEx

See Also

CfgAgentLoginEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx Members
CfgAgentLoginEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentLoginEx type exposes the following members.

Constructors

Name | Description
CfgAgentLoginEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
LoginCode |
Override |
Password |
State |
Switch |
SwitchSpecificType |
Tenant |
UseOverride |
UserProperties |

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx Constructor
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLoginEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentLoginEx()

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx Fields
CfgAgentLoginEx Class See Also Send Feedback

The CfgAgentLoginEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx Methods
CfgAgentLoginEx Class See Also Send Feedback

The CfgAgentLoginEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx Properties
CfgAgentLoginEx Class See Also Send Feedback

The CfgAgentLoginEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
LoginCode |
Override |
Password |
State |
Switch |
SwitchSpecificType |
Tenant |
UseOverride |
UserProperties |

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.DBID Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LoginCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.LoginCode Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.LoginCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LoginCode { get; set; }
Visual Basic (Declaration)
Public Property LoginCode As String
Visual C++
public:
property String^ LoginCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Override Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.Override Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.Override"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Override { get; set; }
Visual Basic (Declaration)
Public Property Override As String
Visual C++
public:
property String^ Override {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.Password Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.Password"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.State Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.Switch Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As Integer
Visual C++
public:
property int Switch {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SwitchSpecificType Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.SwitchSpecificType Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.SwitchSpecificType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SwitchSpecificType { get; set; }
Visual Basic (Declaration)
Public Property SwitchSpecificType As Integer
Visual C++
public:
property int SwitchSpecificType {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.Tenant Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UseOverride Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.UseOverride Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.UseOverride"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseOverride { get; set; }
Visual Basic (Declaration)
Public Property UseOverride As CfgFlag
Visual C++
public:
property CfgFlag UseOverride {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginEx..::.UserProperties Property
CfgAgentLoginEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAgentLoginEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLoginInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgAgentLoginInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgAgentLoginInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAgentLoginInfoEx

See Also

CfgAgentLoginInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx Members
CfgAgentLoginInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAgentLoginInfoEx type exposes the following members.

Constructors

Name | Description
CfgAgentLoginInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AgentLogin |
ParentDBID | (Inherited from CfgStructureEx.)
WrapupTime |

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx Constructor
CfgAgentLoginInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLoginInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentLoginInfoEx()

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx Fields
CfgAgentLoginInfoEx Class See Also Send Feedback

The CfgAgentLoginInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx Methods
CfgAgentLoginInfoEx Class See Also Send Feedback

The CfgAgentLoginInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAgentLoginInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx Properties
CfgAgentLoginInfoEx Class See Also Send Feedback

The CfgAgentLoginInfoEx type exposes the following members.

Properties

Name | Description
AgentLogin |
ParentDBID | (Inherited from CfgStructureEx.)
WrapupTime |

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AgentLogin Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx..::.AgentLogin Property
CfgAgentLoginInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginInfoEx.AgentLogin"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AgentLogin { get; set; }
Visual Basic (Declaration)
Public Property AgentLogin As Integer
Visual C++
public:
property int AgentLogin {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


WrapupTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginInfoEx..::.WrapupTime Property
CfgAgentLoginInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAgentLoginInfoEx.WrapupTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int WrapupTime { get; set; }
Visual Basic (Declaration)
Public Property WrapupTime As Integer
Visual C++
public:
property int WrapupTime {
    int get ();
    void set (int value);
}

See Also

CfgAgentLoginInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAlarmConditionEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAlarmConditionEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgAlarmConditionEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgAlarmConditionEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAlarmConditionEx

See Also

CfgAlarmConditionEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAlarmConditionEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx Members
CfgAlarmConditionEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAlarmConditionEx type exposes the following members.

Constructors

Name | Description
CfgAlarmConditionEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AlarmDetectEvent |
AlarmDetectScript |
AlarmRemovalEvent |
Category |
CfgObjectType | (Inherited from CfgObjectEx.)
ClearanceScripts |
ClearanceTimeout |
DBID |
Description |
IsMasked |
Name |
ReactionScripts |
State |
UserProperties |

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAlarmConditionEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx Constructor
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmConditionEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAlarmConditionEx()

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAlarmConditionEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx Fields
CfgAlarmConditionEx Class See Also Send Feedback

The CfgAlarmConditionEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAlarmConditionEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx Methods
CfgAlarmConditionEx Class See Also Send Feedback

The CfgAlarmConditionEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAlarmConditionEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx Properties
CfgAlarmConditionEx Class See Also Send Feedback

The CfgAlarmConditionEx type exposes the following members.

Properties

Name | Description
AlarmDetectEvent |
AlarmDetectScript |
AlarmRemovalEvent |
Category |
CfgObjectType | (Inherited from CfgObjectEx.)
ClearanceScripts |
ClearanceTimeout |
DBID |
Description |
IsMasked |
Name |
ReactionScripts |
State |
UserProperties |

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AlarmDetectEvent Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.AlarmDetectEvent Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.AlarmDetectEvent"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDetectEventEx AlarmDetectEvent { get; set; }
Visual Basic (Declaration)
Public Property AlarmDetectEvent As CfgDetectEventEx
Visual C++
public:
property CfgDetectEventEx^ AlarmDetectEvent {
    CfgDetectEventEx^ get ();
    void set (CfgDetectEventEx^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AlarmDetectScript Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.AlarmDetectScript Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.AlarmDetectScript"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AlarmDetectScript { get; set; }
Visual Basic (Declaration)
Public Property AlarmDetectScript As Integer
Visual C++
public:
property int AlarmDetectScript {
    int get ();
    void set (int value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AlarmRemovalEvent Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.AlarmRemovalEvent Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.AlarmRemovalEvent"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRemovalEventEx AlarmRemovalEvent { get; set; }
Visual Basic (Declaration)
Public Property AlarmRemovalEvent As CfgRemovalEventEx
Visual C++
public:
property CfgRemovalEventEx^ AlarmRemovalEvent {
    CfgRemovalEventEx^ get ();
    void set (CfgRemovalEventEx^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Category Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.Category Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.Category"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmCategory Category { get; set; }
Visual Basic (Declaration)
Public Property Category As CfgAlarmCategory
Visual C++
public:
property CfgAlarmCategory Category {
    CfgAlarmCategory get ();
    void set (CfgAlarmCategory value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ClearanceScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.ClearanceScripts Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.ClearanceScripts"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> ClearanceScripts { get; set; }
Visual Basic (Declaration)
Public Property ClearanceScripts As List(Of Integer)
Visual C++
public:
property List<int>^ ClearanceScripts {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ClearanceTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.ClearanceTimeout Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.ClearanceTimeout"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ClearanceTimeout { get; set; }
Visual Basic (Declaration)
Public Property ClearanceTimeout As Integer
Visual C++
public:
property int ClearanceTimeout {
    int get ();
    void set (int value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.DBID Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.Description Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsMasked Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.IsMasked Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.IsMasked"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsMasked { get; set; }
Visual Basic (Declaration)
Public Property IsMasked As CfgFlag
Visual C++
public:
property CfgFlag IsMasked {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.Name Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ReactionScripts Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.ReactionScripts Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.ReactionScripts"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> ReactionScripts { get; set; }
Visual Basic (Declaration)
Public Property ReactionScripts As List(Of Integer)
Visual C++
public:
property List<int>^ ReactionScripts {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.State Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionEx..::.UserProperties Property
CfgAlarmConditionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAlarmConditionEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAlarmConditionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgApplicationEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgApplicationEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgApplicationEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgApplicationEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgApplicationEx

See Also

CfgApplicationEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgApplicationEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx Members
CfgApplicationEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgApplicationEx type exposes the following members.

Constructors

Name | Description
CfgApplicationEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AppPrototype |
AppServers |
AutoRestart |
CfgObjectType | (Inherited from CfgObjectEx.)
CommandLine |
CommandLineArguments |
ComponentType |
DBID |
FlexibleProperties |
IsPrimary |
IsServer |
Name |
Options |
Password |
PortInfos |
RedundancyType |
Resources |
ServerInfo |
ShutdownTimeout |
StartupTimeout |
StartupType |
State |
Tenants |
Type |
UserProperties |
Version |
WorkDirectory |

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgApplicationEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx Constructor
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplicationEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgApplicationEx()

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgApplicationEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx Fields
CfgApplicationEx Class See Also Send Feedback

The CfgApplicationEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgApplicationEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx Methods
CfgApplicationEx Class See Also Send Feedback

The CfgApplicationEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgApplicationEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx Properties
CfgApplicationEx Class See Also Send Feedback

The CfgApplicationEx type exposes the following members.

Properties

Name | Description
AppPrototype |
AppServers |
AutoRestart |
CfgObjectType | (Inherited from CfgObjectEx.)
CommandLine |
CommandLineArguments |
ComponentType |
DBID |
FlexibleProperties |
IsPrimary |
IsServer |
Name |
Options |
Password |
PortInfos |
RedundancyType |
Resources |
ServerInfo |
ShutdownTimeout |
StartupTimeout |
StartupType |
State |
Tenants |
Type |
UserProperties |
Version |
WorkDirectory |

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppPrototype Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.AppPrototype Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.AppPrototype"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AppPrototype { get; set; }
Visual Basic (Declaration)
Public Property AppPrototype As Integer
Visual C++
public:
property int AppPrototype {
    int get ();
    void set (int value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppServers Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.AppServers Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.AppServers"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgConnInfoEx> AppServers { get; set; }
Visual Basic (Declaration)
Public Property AppServers As List(Of CfgConnInfoEx)
Visual C++
public:
property List<CfgConnInfoEx^>^ AppServers {
    List<CfgConnInfoEx^>^ get ();
    void set (List<CfgConnInfoEx^>^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AutoRestart Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.AutoRestart Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.AutoRestart"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag AutoRestart { get; set; }
Visual Basic (Declaration)
Public Property AutoRestart As CfgFlag
Visual C++
public:
property CfgFlag AutoRestart {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CommandLine Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.CommandLine Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.CommandLine"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CommandLine { get; set; }
Visual Basic (Declaration)
Public Property CommandLine As String
Visual C++
public:
property String^ CommandLine {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CommandLineArguments Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.CommandLineArguments Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.CommandLineArguments"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CommandLineArguments { get; set; }
Visual Basic (Declaration)
Public Property CommandLineArguments As String
Visual C++
public:
property String^ CommandLineArguments {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ComponentType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.ComponentType Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.ComponentType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppComponentType ComponentType { get; set; }
Visual Basic (Declaration)
Public Property ComponentType As CfgAppComponentType
Visual C++
public:
property CfgAppComponentType ComponentType {
    CfgAppComponentType get ();
    void set (CfgAppComponentType value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.DBID Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


FlexibleProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.FlexibleProperties Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.FlexibleProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection FlexibleProperties { get; set; }
Visual Basic (Declaration)
Public Property FlexibleProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ FlexibleProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsPrimary Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.IsPrimary Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.IsPrimary"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsPrimary { get; set; }
Visual Basic (Declaration)
Public Property IsPrimary As CfgFlag
Visual C++
public:
property CfgFlag IsPrimary {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.IsServer Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.IsServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsServer { get; set; }
Visual Basic (Declaration)
Public Property IsServer As CfgFlag
Visual C++
public:
property CfgFlag IsServer {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Name Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Options Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Options Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Options"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Options { get; set; }
Visual Basic (Declaration)
Public Property Options As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Options {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Password Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Password"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PortInfos Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.PortInfos Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.PortInfos"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgPortInfoEx> PortInfos { get; set; }
Visual Basic (Declaration)
Public Property PortInfos As List(Of CfgPortInfoEx)
Visual C++
public:
property List<CfgPortInfoEx^>^ PortInfos {
    List<CfgPortInfoEx^>^ get ();
    void set (List<CfgPortInfoEx^>^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RedundancyType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.RedundancyType Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.RedundancyType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHAType RedundancyType { get; set; }
Visual Basic (Declaration)
Public Property RedundancyType As CfgHAType
Visual C++
public:
property CfgHAType RedundancyType {
    CfgHAType get ();
    void set (CfgHAType value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Resources Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ServerInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.ServerInfo Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.ServerInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerEx ServerInfo { get; set; }
Visual Basic (Declaration)
Public Property ServerInfo As CfgServerEx
Visual C++
public:
property CfgServerEx^ ServerInfo {
    CfgServerEx^ get ();
    void set (CfgServerEx^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ShutdownTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.ShutdownTimeout Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.ShutdownTimeout"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ShutdownTimeout { get; set; }
Visual Basic (Declaration)
Public Property ShutdownTimeout As Integer
Visual C++
public:
property int ShutdownTimeout {
    int get ();
    void set (int value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartupTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.StartupTimeout Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.StartupTimeout"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupTimeout { get; set; }
Visual Basic (Declaration)
Public Property StartupTimeout As Integer
Visual C++
public:
property int StartupTimeout {
    int get ();
    void set (int value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.StartupType Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.StartupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStartupType StartupType { get; set; }
Visual Basic (Declaration)
Public Property StartupType As CfgStartupType
Visual C++
public:
property CfgStartupType StartupType {
    CfgStartupType get ();
    void set (CfgStartupType value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.State Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Tenants Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Tenants"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Tenants { get; set; }
Visual Basic (Declaration)
Public Property Tenants As List(Of Integer)
Visual C++
public:
property List<int>^ Tenants {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Type Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.UserProperties Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.Version Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


WorkDirectory Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationEx..::.WorkDirectory Property
CfgApplicationEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgApplicationEx.WorkDirectory"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string WorkDirectory { get; set; }
Visual Basic (Declaration)
Public Property WorkDirectory As String
Visual C++
public:
property String^ WorkDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppPrototypeEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppPrototypeEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgAppPrototypeEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgAppPrototypeEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAppPrototypeEx

See Also

CfgAppPrototypeEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppPrototypeEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx Members
CfgAppPrototypeEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAppPrototypeEx type exposes the following members.

Constructors

Name | Description
CfgAppPrototypeEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Name |
Options |
State |
Type |
UserProperties |
Version |

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppPrototypeEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx Constructor
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppPrototypeEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppPrototypeEx()

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppPrototypeEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx Fields
CfgAppPrototypeEx Class See Also Send Feedback

The CfgAppPrototypeEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppPrototypeEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx Methods
CfgAppPrototypeEx Class See Also Send Feedback

The CfgAppPrototypeEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppPrototypeEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx Properties
CfgAppPrototypeEx Class See Also Send Feedback

The CfgAppPrototypeEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Name |
Options |
State |
Type |
UserProperties |
Version |

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.DBID Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.Name Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Options Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.Options Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.Options"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection Options { get; set; }
Visual Basic (Declaration)
Public Property Options As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ Options {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.State Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.Type Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.UserProperties Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeEx..::.Version Property
CfgAppPrototypeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppPrototypeEx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAppPrototypeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppRankEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppRankEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppRankEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgAppRankEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgAppRankEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAppRankEx

See Also

CfgAppRankEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppRankEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx Members
CfgAppRankEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAppRankEx type exposes the following members.

Constructors

Name | Description
CfgAppRankEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AppRank |
AppType |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppRankEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx Constructor
CfgAppRankEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppRankEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppRankEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppRankEx()

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppRankEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx Fields
CfgAppRankEx Class See Also Send Feedback

The CfgAppRankEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppRankEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx Methods
CfgAppRankEx Class See Also Send Feedback

The CfgAppRankEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppRankEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx Properties
CfgAppRankEx Class See Also Send Feedback

The CfgAppRankEx type exposes the following members.

Properties

Name | Description
AppRank |
AppType |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppRank Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx..::.AppRank Property
CfgAppRankEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppRankEx.AppRank"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRank AppRank { get; set; }
Visual Basic (Declaration)
Public Property AppRank As CfgRank
Visual C++
public:
property CfgRank AppRank {
    CfgRank get ();
    void set (CfgRank value);
}

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppRankEx..::.AppType Property
CfgAppRankEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppRankEx.AppType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As CfgAppType
Visual C++
public:
property CfgAppType AppType {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgAppRankEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppServicePermissionEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppServicePermissionEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppServicePermissionEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgAppServicePermissionEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgAppServicePermissionEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgAppServicePermissionEx

See Also

CfgAppServicePermissionEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppServicePermissionEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionEx Members
CfgAppServicePermissionEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgAppServicePermissionEx type exposes the following members.

Constructors

Name | Description
CfgAppServicePermissionEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgAppServicePermissionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppServicePermissionEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionEx Constructor
CfgAppServicePermissionEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgAppServicePermissionEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppServicePermissionEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppServicePermissionEx()

See Also

CfgAppServicePermissionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppServicePermissionEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionEx Fields
CfgAppServicePermissionEx Class See Also Send Feedback

The CfgAppServicePermissionEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgAppServicePermissionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppServicePermissionEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionEx Methods
CfgAppServicePermissionEx Class See Also Send Feedback

The CfgAppServicePermissionEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgAppServicePermissionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgAppServicePermissionEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppServicePermissionEx Properties
CfgAppServicePermissionEx Class See Also Send Feedback

The CfgAppServicePermissionEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgAppServicePermissionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingListEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgCallingListEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgCallingListEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCallingListEx

See Also

CfgCallingListEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx Members
CfgCallingListEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCallingListEx type exposes the following members.

Constructors

Name | Description
CfgCallingListEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Filter |
LogTableAccess |
MaxAttempts |
Name |
Script |
State |
TableAccess |
Tenant |
TimeFrom |
TimeUntil |
Treatments |
UserProperties |

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx Constructor
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingListEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCallingListEx()

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx Fields
CfgCallingListEx Class See Also Send Feedback

The CfgCallingListEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx Methods
CfgCallingListEx Class See Also Send Feedback

The CfgCallingListEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx Properties
CfgCallingListEx Class See Also Send Feedback

The CfgCallingListEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Filter |
LogTableAccess |
MaxAttempts |
Name |
Script |
State |
TableAccess |
Tenant |
TimeFrom |
TimeUntil |
Treatments |
UserProperties |

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.DBID Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.Description Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.Filter Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.Filter"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As Integer
Visual C++
public:
property int Filter {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LogTableAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.LogTableAccess Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.LogTableAccess"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LogTableAccess { get; set; }
Visual Basic (Declaration)
Public Property LogTableAccess As Integer
Visual C++
public:
property int LogTableAccess {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MaxAttempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.MaxAttempts Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.MaxAttempts"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxAttempts { get; set; }
Visual Basic (Declaration)
Public Property MaxAttempts As Integer
Visual C++
public:
property int MaxAttempts {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.Name Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.Script Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.Script"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Script { get; set; }
Visual Basic (Declaration)
Public Property Script As Integer
Visual C++
public:
property int Script {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.State Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TableAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.TableAccess Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.TableAccess"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TableAccess { get; set; }
Visual Basic (Declaration)
Public Property TableAccess As Integer
Visual C++
public:
property int TableAccess {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.Tenant Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeFrom Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.TimeFrom Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.TimeFrom"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeFrom { get; set; }
Visual Basic (Declaration)
Public Property TimeFrom As Integer
Visual C++
public:
property int TimeFrom {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeUntil Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.TimeUntil Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.TimeUntil"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeUntil { get; set; }
Visual Basic (Declaration)
Public Property TimeUntil As Integer
Visual C++
public:
property int TimeUntil {
    int get ();
    void set (int value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Treatments Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.Treatments Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.Treatments"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Treatments { get; set; }
Visual Basic (Declaration)
Public Property Treatments As List(Of Integer)
Visual C++
public:
property List<int>^ Treatments {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListEx..::.UserProperties Property
CfgCallingListEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgCallingListEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingListInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgCallingListInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgCallingListInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCallingListInfoEx

See Also

CfgCallingListInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx Members
CfgCallingListInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCallingListInfoEx type exposes the following members.

Constructors

Name | Description
CfgCallingListInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CallingList |
IsActive |
ParentDBID | (Inherited from CfgStructureEx.)
Share |

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx Constructor
CfgCallingListInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingListInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCallingListInfoEx()

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx Fields
CfgCallingListInfoEx Class See Also Send Feedback

The CfgCallingListInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx Methods
CfgCallingListInfoEx Class See Also Send Feedback

The CfgCallingListInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCallingListInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx Properties
CfgCallingListInfoEx Class See Also Send Feedback

The CfgCallingListInfoEx type exposes the following members.

Properties

Name | Description
CallingList |
IsActive |
ParentDBID | (Inherited from CfgStructureEx.)
Share |

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CallingList Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx..::.CallingList Property
CfgCallingListInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListInfoEx.CallingList"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CallingList { get; set; }
Visual Basic (Declaration)
Public Property CallingList As Integer
Visual C++
public:
property int CallingList {
    int get ();
    void set (int value);
}

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsActive Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx..::.IsActive Property
CfgCallingListInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListInfoEx.IsActive"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As CfgFlag
Visual C++
public:
property CfgFlag IsActive {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Share Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListInfoEx..::.Share Property
CfgCallingListInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCallingListInfoEx.Share"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Share { get; set; }
Visual Basic (Declaration)
Public Property Share As Integer
Visual C++
public:
property int Share {
    int get ();
    void set (int value);
}

See Also

CfgCallingListInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgCampaignEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgCampaignEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCampaignEx

See Also

CfgCampaignEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx Members
CfgCampaignEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCampaignEx type exposes the following members.

Constructors

Name | Description
CfgCampaignEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CallingLists |
CampaignGroups |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
Script |
State |
Tenant |
UserProperties |

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx Constructor
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignEx()

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx Fields
CfgCampaignEx Class See Also Send Feedback

The CfgCampaignEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx Methods
CfgCampaignEx Class See Also Send Feedback

The CfgCampaignEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx Properties
CfgCampaignEx Class See Also Send Feedback

The CfgCampaignEx type exposes the following members.

Properties

Name | Description
CallingLists |
CampaignGroups |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
Script |
State |
Tenant |
UserProperties |

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CallingLists Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.CallingLists Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.CallingLists"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgCallingListInfoEx> CallingLists { get; set; }
Visual Basic (Declaration)
Public Property CallingLists As List(Of CfgCallingListInfoEx)
Visual C++
public:
property List<CfgCallingListInfoEx^>^ CallingLists {
    List<CfgCallingListInfoEx^>^ get ();
    void set (List<CfgCallingListInfoEx^>^ value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CampaignGroups Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.CampaignGroups Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.CampaignGroups"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgCampaignGroupInfoEx> CampaignGroups { get; set; }
Visual Basic (Declaration)
Public Property CampaignGroups As List(Of CfgCampaignGroupInfoEx)
Visual C++
public:
property List<CfgCampaignGroupInfoEx^>^ CampaignGroups {
    List<CfgCampaignGroupInfoEx^>^ get ();
    void set (List<CfgCampaignGroupInfoEx^>^ value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.DBID Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.Description Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.Name Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.Script Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.Script"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Script { get; set; }
Visual Basic (Declaration)
Public Property Script As Integer
Visual C++
public:
property int Script {
    int get ();
    void set (int value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.State Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.Tenant Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignEx..::.UserProperties Property
CfgCampaignEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgCampaignEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroupEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgCampaignGroupEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgCampaignGroupEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCampaignGroupEx

See Also

CfgCampaignGroupEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx Members
CfgCampaignGroupEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCampaignGroupEx type exposes the following members.

Constructors

Name | Description
CfgCampaignGroupEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Campaign |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DialMode |
GroupDBID |
GroupType |
InteractionQueue |
IVRProfile |
MaxQueueSize |
MinRecBuffSize |
Name |
NumOfChannels |
OperationMode |
OptMethod |
OptMethodValue |
OptRecBuffSize |
OrigDN |
Script |
Servers |
State |
Tenant |
TrunkGroupDN |
UserProperties |

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx Constructor
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroupEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignGroupEx()

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx Fields
CfgCampaignGroupEx Class See Also Send Feedback

The CfgCampaignGroupEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx Methods
CfgCampaignGroupEx Class See Also Send Feedback

The CfgCampaignGroupEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx Properties
CfgCampaignGroupEx Class See Also Send Feedback

The CfgCampaignGroupEx type exposes the following members.

Properties

Name | Description
Campaign |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DialMode |
GroupDBID |
GroupType |
InteractionQueue |
IVRProfile |
MaxQueueSize |
MinRecBuffSize |
Name |
NumOfChannels |
OperationMode |
OptMethod |
OptMethodValue |
OptRecBuffSize |
OrigDN |
Script |
Servers |
State |
Tenant |
TrunkGroupDN |
UserProperties |

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Campaign Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.Campaign Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.Campaign"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Campaign { get; set; }
Visual Basic (Declaration)
Public Property Campaign As Integer
Visual C++
public:
property int Campaign {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.DBID Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.Description Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DialMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.DialMode Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.DialMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDialMode DialMode { get; set; }
Visual Basic (Declaration)
Public Property DialMode As CfgDialMode
Visual C++
public:
property CfgDialMode DialMode {
    CfgDialMode get ();
    void set (CfgDialMode value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.GroupDBID Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.GroupDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int GroupDBID { get; set; }
Visual Basic (Declaration)
Public Property GroupDBID As Integer
Visual C++
public:
property int GroupDBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.GroupType Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.GroupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As CfgObjectType
Visual C++
public:
property CfgObjectType GroupType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


InteractionQueue Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.InteractionQueue Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.InteractionQueue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int InteractionQueue { get; set; }
Visual Basic (Declaration)
Public Property InteractionQueue As Integer
Visual C++
public:
property int InteractionQueue {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IVRProfile Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.IVRProfile Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.IVRProfile"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IVRProfile { get; set; }
Visual Basic (Declaration)
Public Property IVRProfile As Integer
Visual C++
public:
property int IVRProfile {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MaxQueueSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.MaxQueueSize Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.MaxQueueSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxQueueSize { get; set; }
Visual Basic (Declaration)
Public Property MaxQueueSize As Integer
Visual C++
public:
property int MaxQueueSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MinRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.MinRecBuffSize Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.MinRecBuffSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property MinRecBuffSize As Integer
Visual C++
public:
property int MinRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.Name Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


NumOfChannels Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.NumOfChannels Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.NumOfChannels"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int NumOfChannels { get; set; }
Visual Basic (Declaration)
Public Property NumOfChannels As Integer
Visual C++
public:
property int NumOfChannels {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OperationMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.OperationMode Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.OperationMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOperationMode OperationMode { get; set; }
Visual Basic (Declaration)
Public Property OperationMode As CfgOperationMode
Visual C++
public:
property CfgOperationMode OperationMode {
    CfgOperationMode get ();
    void set (CfgOperationMode value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OptMethod Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.OptMethod Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.OptMethod"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOptimizationMethod OptMethod { get; set; }
Visual Basic (Declaration)
Public Property OptMethod As CfgOptimizationMethod
Visual C++
public:
property CfgOptimizationMethod OptMethod {
    CfgOptimizationMethod get ();
    void set (CfgOptimizationMethod value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OptMethodValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.OptMethodValue Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.OptMethodValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptMethodValue { get; set; }
Visual Basic (Declaration)
Public Property OptMethodValue As Integer
Visual C++
public:
property int OptMethodValue {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OptRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.OptRecBuffSize Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.OptRecBuffSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property OptRecBuffSize As Integer
Visual C++
public:
property int OptRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OrigDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.OrigDN Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.OrigDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OrigDN { get; set; }
Visual Basic (Declaration)
Public Property OrigDN As Integer
Visual C++
public:
property int OrigDN {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.Script Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.Script"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Script { get; set; }
Visual Basic (Declaration)
Public Property Script As Integer
Visual C++
public:
property int Script {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Servers Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.Servers Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.Servers"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Servers { get; set; }
Visual Basic (Declaration)
Public Property Servers As List(Of Integer)
Visual C++
public:
property List<int>^ Servers {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.State Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.Tenant Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TrunkGroupDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.TrunkGroupDN Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.TrunkGroupDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TrunkGroupDN { get; set; }
Visual Basic (Declaration)
Public Property TrunkGroupDN As Integer
Visual C++
public:
property int TrunkGroupDN {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupEx..::.UserProperties Property
CfgCampaignGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgCampaignGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroupInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgCampaignGroupInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgCampaignGroupInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgCampaignGroupInfoEx

See Also

CfgCampaignGroupInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx Members
CfgCampaignGroupInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgCampaignGroupInfoEx type exposes the following members.

Constructors

Name | Description
CfgCampaignGroupInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Description |
Dialer |
DialMode |
GroupDBID |
GroupType |
IsActive |
MinRecBuffSize |
NumOfChannels |
OperationMode |
OptMethod |
OptMethodValue |
OptRecBuffSize |
OrigDN |
ParentDBID | (Inherited from CfgStructureEx.)
Script |
StatServer |
TrunkGroupDN |

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx Constructor
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroupInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignGroupInfoEx()

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx Fields
CfgCampaignGroupInfoEx Class See Also Send Feedback

The CfgCampaignGroupInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx Methods
CfgCampaignGroupInfoEx Class See Also Send Feedback

The CfgCampaignGroupInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgCampaignGroupInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx Properties
CfgCampaignGroupInfoEx Class See Also Send Feedback

The CfgCampaignGroupInfoEx type exposes the following members.

Properties

Name | Description
Description |
Dialer |
DialMode |
GroupDBID |
GroupType |
IsActive |
MinRecBuffSize |
NumOfChannels |
OperationMode |
OptMethod |
OptMethodValue |
OptRecBuffSize |
OrigDN |
ParentDBID | (Inherited from CfgStructureEx.)
Script |
StatServer |
TrunkGroupDN |

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.Description Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Dialer Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.Dialer Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.Dialer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Dialer { get; set; }
Visual Basic (Declaration)
Public Property Dialer As Integer
Visual C++
public:
property int Dialer {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DialMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.DialMode Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.DialMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDialMode DialMode { get; set; }
Visual Basic (Declaration)
Public Property DialMode As CfgDialMode
Visual C++
public:
property CfgDialMode DialMode {
    CfgDialMode get ();
    void set (CfgDialMode value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.GroupDBID Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.GroupDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int GroupDBID { get; set; }
Visual Basic (Declaration)
Public Property GroupDBID As Integer
Visual C++
public:
property int GroupDBID {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.GroupType Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.GroupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As CfgObjectType
Visual C++
public:
property CfgObjectType GroupType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsActive Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.IsActive Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.IsActive"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As CfgFlag
Visual C++
public:
property CfgFlag IsActive {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MinRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.MinRecBuffSize Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.MinRecBuffSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property MinRecBuffSize As Integer
Visual C++
public:
property int MinRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


NumOfChannels Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.NumOfChannels Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.NumOfChannels"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int NumOfChannels { get; set; }
Visual Basic (Declaration)
Public Property NumOfChannels As Integer
Visual C++
public:
property int NumOfChannels {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OperationMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.OperationMode Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.OperationMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOperationMode OperationMode { get; set; }
Visual Basic (Declaration)
Public Property OperationMode As CfgOperationMode
Visual C++
public:
property CfgOperationMode OperationMode {
    CfgOperationMode get ();
    void set (CfgOperationMode value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OptMethod Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.OptMethod Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.OptMethod"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOptimizationMethod OptMethod { get; set; }
Visual Basic (Declaration)
Public Property OptMethod As CfgOptimizationMethod
Visual C++
public:
property CfgOptimizationMethod OptMethod {
    CfgOptimizationMethod get ();
    void set (CfgOptimizationMethod value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OptMethodValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.OptMethodValue Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.OptMethodValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptMethodValue { get; set; }
Visual Basic (Declaration)
Public Property OptMethodValue As Integer
Visual C++
public:
property int OptMethodValue {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OptRecBuffSize Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.OptRecBuffSize Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.OptRecBuffSize"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OptRecBuffSize { get; set; }
Visual Basic (Declaration)
Public Property OptRecBuffSize As Integer
Visual C++
public:
property int OptRecBuffSize {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OrigDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.OrigDN Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.OrigDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int OrigDN { get; set; }
Visual Basic (Declaration)
Public Property OrigDN As Integer
Visual C++
public:
property int OrigDN {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.Script Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.Script"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Script { get; set; }
Visual Basic (Declaration)
Public Property Script As Integer
Visual C++
public:
property int Script {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.StatServer Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.StatServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatServer { get; set; }
Visual Basic (Declaration)
Public Property StatServer As Integer
Visual C++
public:
property int StatServer {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TrunkGroupDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupInfoEx..::.TrunkGroupDN Property
CfgCampaignGroupInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgCampaignGroupInfoEx.TrunkGroupDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TrunkGroupDN { get; set; }
Visual Basic (Declaration)
Public Property TrunkGroupDN As Integer
Visual C++
public:
property int TrunkGroupDN {
    int get ();
    void set (int value);
}

See Also

CfgCampaignGroupInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgConnInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgConnInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgConnInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgConnInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgConnInfoEx

See Also

CfgConnInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgConnInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx Members
CfgConnInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgConnInfoEx type exposes the following members.

Constructors

Name | Description
CfgConnInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AppParams |
AppServer |
CharField1 |
CharField2 |
CharField3 |
CharField4 |
ConnProtocol |
Description |
Id |
LongField1 |
LongField2 |
LongField3 |
LongField4 |
Mode |
ParentDBID | (Inherited from CfgStructureEx.)
ProxyParams |
TimoutLocal |
TimoutRemote |
TransportParams |

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgConnInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx Constructor
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgConnInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgConnInfoEx()

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgConnInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx Fields
CfgConnInfoEx Class See Also Send Feedback

The CfgConnInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgConnInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx Methods
CfgConnInfoEx Class See Also Send Feedback

The CfgConnInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgConnInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx Properties
CfgConnInfoEx Class See Also Send Feedback

The CfgConnInfoEx type exposes the following members.

Properties

Name | Description
AppParams |
AppServer |
CharField1 |
CharField2 |
CharField3 |
CharField4 |
ConnProtocol |
Description |
Id |
LongField1 |
LongField2 |
LongField3 |
LongField4 |
Mode |
ParentDBID | (Inherited from CfgStructureEx.)
ProxyParams |
TimoutLocal |
TimoutRemote |
TransportParams |

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.AppParams Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.AppParams"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AppParams { get; set; }
Visual Basic (Declaration)
Public Property AppParams As String
Visual C++
public:
property String^ AppParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.AppServer Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.AppServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AppServer { get; set; }
Visual Basic (Declaration)
Public Property AppServer As Integer
Visual C++
public:
property int AppServer {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.CharField1 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.CharField1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField1 { get; set; }
Visual Basic (Declaration)
Public Property CharField1 As String
Visual C++
public:
property String^ CharField1 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.CharField2 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.CharField2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField2 { get; set; }
Visual Basic (Declaration)
Public Property CharField2 As String
Visual C++
public:
property String^ CharField2 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.CharField3 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.CharField3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField3 { get; set; }
Visual Basic (Declaration)
Public Property CharField3 As String
Visual C++
public:
property String^ CharField3 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.CharField4 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.CharField4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField4 { get; set; }
Visual Basic (Declaration)
Public Property CharField4 As String
Visual C++
public:
property String^ CharField4 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ConnProtocol Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.ConnProtocol Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.ConnProtocol"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ConnProtocol { get; set; }
Visual Basic (Declaration)
Public Property ConnProtocol As String
Visual C++
public:
property String^ ConnProtocol {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.Description Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.Id Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.Id"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.LongField1 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.LongField1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField1 { get; set; }
Visual Basic (Declaration)
Public Property LongField1 As Integer
Visual C++
public:
property int LongField1 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.LongField2 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.LongField2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField2 { get; set; }
Visual Basic (Declaration)
Public Property LongField2 As Integer
Visual C++
public:
property int LongField2 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.LongField3 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.LongField3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField3 { get; set; }
Visual Basic (Declaration)
Public Property LongField3 As Integer
Visual C++
public:
property int LongField3 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.LongField4 Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.LongField4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField4 { get; set; }
Visual Basic (Declaration)
Public Property LongField4 As Integer
Visual C++
public:
property int LongField4 {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.Mode Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.Mode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTraceMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As CfgTraceMode
Visual C++
public:
property CfgTraceMode Mode {
    CfgTraceMode get ();
    void set (CfgTraceMode value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ProxyParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.ProxyParams Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.ProxyParams"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ProxyParams { get; set; }
Visual Basic (Declaration)
Public Property ProxyParams As String
Visual C++
public:
property String^ ProxyParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimoutLocal Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.TimoutLocal Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.TimoutLocal"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimoutLocal { get; set; }
Visual Basic (Declaration)
Public Property TimoutLocal As Integer
Visual C++
public:
property int TimoutLocal {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimoutRemote Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.TimoutRemote Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.TimoutRemote"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimoutRemote { get; set; }
Visual Basic (Declaration)
Public Property TimoutRemote As Integer
Visual C++
public:
property int TimoutRemote {
    int get ();
    void set (int value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TransportParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgConnInfoEx..::.TransportParams Property
CfgConnInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgConnInfoEx.TransportParams"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string TransportParams { get; set; }
Visual Basic (Declaration)
Public Property TransportParams As String
Visual C++
public:
property String^ TransportParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgConnInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDelSwitchAccessEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDelSwitchAccessEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgDelSwitchAccessEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgDelSwitchAccessEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDelSwitchAccessEx

See Also

CfgDelSwitchAccessEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDelSwitchAccessEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx Members
CfgDelSwitchAccessEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDelSwitchAccessEx type exposes the following members.

Constructors

Name | Description
CfgDelSwitchAccessEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AccessCode |
DestinationSource |
DnisSource |
DnSource |
ExtensionSource |
LocationSource |
ParentDBID | (Inherited from CfgStructureEx.)
ReasonSource |
RouteType |
Switch |
TargetType |

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDelSwitchAccessEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx Constructor
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDelSwitchAccessEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDelSwitchAccessEx()

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDelSwitchAccessEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx Fields
CfgDelSwitchAccessEx Class See Also Send Feedback

The CfgDelSwitchAccessEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDelSwitchAccessEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx Methods
CfgDelSwitchAccessEx Class See Also Send Feedback

The CfgDelSwitchAccessEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDelSwitchAccessEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx Properties
CfgDelSwitchAccessEx Class See Also Send Feedback

The CfgDelSwitchAccessEx type exposes the following members.

Properties

Name | Description
AccessCode |
DestinationSource |
DnisSource |
DnSource |
ExtensionSource |
LocationSource |
ParentDBID | (Inherited from CfgStructureEx.)
ReasonSource |
RouteType |
Switch |
TargetType |

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AccessCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.AccessCode Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.AccessCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AccessCode { get; set; }
Visual Basic (Declaration)
Public Property AccessCode As String
Visual C++
public:
property String^ AccessCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DestinationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.DestinationSource Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.DestinationSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DestinationSource { get; set; }
Visual Basic (Declaration)
Public Property DestinationSource As String
Visual C++
public:
property String^ DestinationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DnisSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.DnisSource Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.DnisSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnisSource { get; set; }
Visual Basic (Declaration)
Public Property DnisSource As String
Visual C++
public:
property String^ DnisSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DnSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.DnSource Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.DnSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnSource { get; set; }
Visual Basic (Declaration)
Public Property DnSource As String
Visual C++
public:
property String^ DnSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ExtensionSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.ExtensionSource Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.ExtensionSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExtensionSource { get; set; }
Visual Basic (Declaration)
Public Property ExtensionSource As String
Visual C++
public:
property String^ ExtensionSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LocationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.LocationSource Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.LocationSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LocationSource { get; set; }
Visual Basic (Declaration)
Public Property LocationSource As String
Visual C++
public:
property String^ LocationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ReasonSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.ReasonSource Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.ReasonSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ReasonSource { get; set; }
Visual Basic (Declaration)
Public Property ReasonSource As String
Visual C++
public:
property String^ ReasonSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.RouteType Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.RouteType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; set; }
Visual Basic (Declaration)
Public Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
    void set (CfgRouteType value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.Switch Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As Integer
Visual C++
public:
property int Switch {
    int get ();
    void set (int value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TargetType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDelSwitchAccessEx..::.TargetType Property
CfgDelSwitchAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDelSwitchAccessEx.TargetType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTargetType TargetType { get; set; }
Visual Basic (Declaration)
Public Property TargetType As CfgTargetType
Visual C++
public:
property CfgTargetType TargetType {
    CfgTargetType get ();
    void set (CfgTargetType value);
}

See Also

CfgDelSwitchAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDetectEventEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDetectEventEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDetectEventEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgDetectEventEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgDetectEventEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDetectEventEx

See Also

CfgDetectEventEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDetectEventEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx Members
CfgDetectEventEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDetectEventEx type exposes the following members.

Constructors

Name | Description
CfgDetectEventEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
App |
AppType |
LogEventID |
ParentDBID | (Inherited from CfgStructureEx.)
SelectionMode |

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDetectEventEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx Constructor
CfgDetectEventEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDetectEventEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDetectEventEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDetectEventEx()

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDetectEventEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx Fields
CfgDetectEventEx Class See Also Send Feedback

The CfgDetectEventEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDetectEventEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx Methods
CfgDetectEventEx Class See Also Send Feedback

The CfgDetectEventEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDetectEventEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx Properties
CfgDetectEventEx Class See Also Send Feedback

The CfgDetectEventEx type exposes the following members.

Properties

Name | Description
App |
AppType |
LogEventID |
ParentDBID | (Inherited from CfgStructureEx.)
SelectionMode |

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


App Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx..::.App Property
CfgDetectEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDetectEventEx.App"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int App { get; set; }
Visual Basic (Declaration)
Public Property App As Integer
Visual C++
public:
property int App {
    int get ();
    void set (int value);
}

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx..::.AppType Property
CfgDetectEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDetectEventEx.AppType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As CfgAppType
Visual C++
public:
property CfgAppType AppType {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LogEventID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx..::.LogEventID Property
CfgDetectEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDetectEventEx.LogEventID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LogEventID { get; set; }
Visual Basic (Declaration)
Public Property LogEventID As Integer
Visual C++
public:
property int LogEventID {
    int get ();
    void set (int value);
}

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SelectionMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgDetectEventEx..::.SelectionMode Property
CfgDetectEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDetectEventEx.SelectionMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As CfgSelectionMode
Visual C++
public:
property CfgSelectionMode SelectionMode {
    CfgSelectionMode get ();
    void set (CfgSelectionMode value);
}

See Also

CfgDetectEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNAccessNumberEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNAccessNumberEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNAccessNumberEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgDNAccessNumberEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgDNAccessNumberEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNAccessNumberEx

See Also

CfgDNAccessNumberEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNAccessNumberEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx Members
CfgDNAccessNumberEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNAccessNumberEx type exposes the following members.

Constructors

Name | Description
CfgDNAccessNumberEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Number |
ParentDBID | (Inherited from CfgStructureEx.)
Switch |

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNAccessNumberEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx Constructor
CfgDNAccessNumberEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNAccessNumberEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNAccessNumberEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNAccessNumberEx()

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNAccessNumberEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx Fields
CfgDNAccessNumberEx Class See Also Send Feedback

The CfgDNAccessNumberEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNAccessNumberEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx Methods
CfgDNAccessNumberEx Class See Also Send Feedback

The CfgDNAccessNumberEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNAccessNumberEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx Properties
CfgDNAccessNumberEx Class See Also Send Feedback

The CfgDNAccessNumberEx type exposes the following members.

Properties

Name | Description
Number |
ParentDBID | (Inherited from CfgStructureEx.)
Switch |

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Number Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx..::.Number Property
CfgDNAccessNumberEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNAccessNumberEx.Number"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNAccessNumberEx..::.Switch Property
CfgDNAccessNumberEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNAccessNumberEx.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As Integer
Visual C++
public:
property int Switch {
    int get ();
    void set (int value);
}

See Also

CfgDNAccessNumberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgDNEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgDNEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNEx

See Also

CfgDNEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNEx Members
CfgDNEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNEx type exposes the following members.

Constructors

Name | Description
CfgDNEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AccessNumbers |
Association |
CfgObjectType | (Inherited from CfgObjectEx.)
Contract |
DBID |
DestDNs |
DNLoginID |
Group |
LoginFlag |
Name |
Number |
Override |
RegisterAll |
RouteType |
Site |
State |
Switch |
SwitchSpecificType |
Tenant |
Trunks |
Type |
UseOverride |
UserProperties |

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx Constructor
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNEx()

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNEx Fields
CfgDNEx Class See Also Send Feedback

The CfgDNEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNEx Methods
CfgDNEx Class See Also Send Feedback

The CfgDNEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNEx Properties
CfgDNEx Class See Also Send Feedback

The CfgDNEx type exposes the following members.

Properties

Name | Description
AccessNumbers |
Association |
CfgObjectType | (Inherited from CfgObjectEx.)
Contract |
DBID |
DestDNs |
DNLoginID |
Group |
LoginFlag |
Name |
Number |
Override |
RegisterAll |
RouteType |
Site |
State |
Switch |
SwitchSpecificType |
Tenant |
Trunks |
Type |
UseOverride |
UserProperties |

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AccessNumbers Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.AccessNumbers Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.AccessNumbers"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgDNAccessNumberEx> AccessNumbers { get; set; }
Visual Basic (Declaration)
Public Property AccessNumbers As List(Of CfgDNAccessNumberEx)
Visual C++
public:
property List<CfgDNAccessNumberEx^>^ AccessNumbers {
    List<CfgDNAccessNumberEx^>^ get ();
    void set (List<CfgDNAccessNumberEx^>^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Association Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Association Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Association"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Association { get; set; }
Visual Basic (Declaration)
Public Property Association As String
Visual C++
public:
property String^ Association {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Contract Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Contract"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As Integer
Visual C++
public:
property int Contract {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.DBID Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DestDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.DestDNs Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.DestDNs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> DestDNs { get; set; }
Visual Basic (Declaration)
Public Property DestDNs As List(Of Integer)
Visual C++
public:
property List<int>^ DestDNs {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DNLoginID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.DNLoginID Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.DNLoginID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DNLoginID { get; set; }
Visual Basic (Declaration)
Public Property DNLoginID As String
Visual C++
public:
property String^ DNLoginID {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Group Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Group"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Group { get; set; }
Visual Basic (Declaration)
Public Property Group As Integer
Visual C++
public:
property int Group {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LoginFlag Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.LoginFlag Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.LoginFlag"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag LoginFlag { get; set; }
Visual Basic (Declaration)
Public Property LoginFlag As CfgFlag
Visual C++
public:
property CfgFlag LoginFlag {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Name Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Number Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Number Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Number"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Override Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Override Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Override"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Override { get; set; }
Visual Basic (Declaration)
Public Property Override As String
Visual C++
public:
property String^ Override {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RegisterAll Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.RegisterAll Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.RegisterAll"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNRegisterFlag RegisterAll { get; set; }
Visual Basic (Declaration)
Public Property RegisterAll As CfgDNRegisterFlag
Visual C++
public:
property CfgDNRegisterFlag RegisterAll {
    CfgDNRegisterFlag get ();
    void set (CfgDNRegisterFlag value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.RouteType Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.RouteType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; set; }
Visual Basic (Declaration)
Public Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
    void set (CfgRouteType value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Site Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Site"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Site { get; set; }
Visual Basic (Declaration)
Public Property Site As Integer
Visual C++
public:
property int Site {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.State Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Switch Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As Integer
Visual C++
public:
property int Switch {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SwitchSpecificType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.SwitchSpecificType Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.SwitchSpecificType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SwitchSpecificType { get; set; }
Visual Basic (Declaration)
Public Property SwitchSpecificType As Integer
Visual C++
public:
property int SwitchSpecificType {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Tenant Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Trunks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Trunks Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Trunks"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Trunks { get; set; }
Visual Basic (Declaration)
Public Property Trunks As Integer
Visual C++
public:
property int Trunks {
    int get ();
    void set (int value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.Type Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgDNType
Visual C++
public:
property CfgDNType Type {
    CfgDNType get ();
    void set (CfgDNType value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UseOverride Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.UseOverride Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.UseOverride"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseOverride { get; set; }
Visual Basic (Declaration)
Public Property UseOverride As CfgFlag
Visual C++
public:
property CfgFlag UseOverride {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNEx..::.UserProperties Property
CfgDNEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgDNEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNGroupEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNGroupEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNGroupEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgDNGroupEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgDNGroupEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNGroupEx

See Also

CfgDNGroupEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNGroupEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx Members
CfgDNGroupEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNGroupEx type exposes the following members.

Constructors

Name | Description
CfgDNGroupEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DNs |
GroupInfo |
Type |

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNGroupEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx Constructor
CfgDNGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNGroupEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroupEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNGroupEx()

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNGroupEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx Fields
CfgDNGroupEx Class See Also Send Feedback

The CfgDNGroupEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNGroupEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx Methods
CfgDNGroupEx Class See Also Send Feedback

The CfgDNGroupEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNGroupEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx Properties
CfgDNGroupEx Class See Also Send Feedback

The CfgDNGroupEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DNs |
GroupInfo |
Type |

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx..::.DBID Property
CfgDNGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNGroupEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx..::.DNs Property
CfgDNGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNGroupEx.DNs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgDNInfoEx> DNs { get; set; }
Visual Basic (Declaration)
Public Property DNs As List(Of CfgDNInfoEx)
Visual C++
public:
property List<CfgDNInfoEx^>^ DNs {
    List<CfgDNInfoEx^>^ get ();
    void set (List<CfgDNInfoEx^>^ value);
}

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx..::.GroupInfo Property
CfgDNGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNGroupEx.GroupInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroupEx GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroupEx
Visual C++
public:
property CfgGroupEx^ GroupInfo {
    CfgGroupEx^ get ();
    void set (CfgGroupEx^ value);
}

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupEx..::.Type Property
CfgDNGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNGroupEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroupType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgDNGroupType
Visual C++
public:
property CfgDNGroupType Type {
    CfgDNGroupType get ();
    void set (CfgDNGroupType value);
}

See Also

CfgDNGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgDNInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgDNInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgDNInfoEx

See Also

CfgDNInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx Members
CfgDNInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgDNInfoEx type exposes the following members.

Constructors

Name | Description
CfgDNInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DN |
ParentDBID | (Inherited from CfgStructureEx.)
Trunks |

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx Constructor
CfgDNInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNInfoEx()

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx Fields
CfgDNInfoEx Class See Also Send Feedback

The CfgDNInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx Methods
CfgDNInfoEx Class See Also Send Feedback

The CfgDNInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgDNInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx Properties
CfgDNInfoEx Class See Also Send Feedback

The CfgDNInfoEx type exposes the following members.

Properties

Name | Description
DN |
ParentDBID | (Inherited from CfgStructureEx.)
Trunks |

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DN Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx..::.DN Property
CfgDNInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNInfoEx.DN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DN { get; set; }
Visual Basic (Declaration)
Public Property DN As Integer
Visual C++
public:
property int DN {
    int get ();
    void set (int value);
}

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Trunks Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNInfoEx..::.Trunks Property
CfgDNInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgDNInfoEx.Trunks"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Trunks { get; set; }
Visual Basic (Declaration)
Public Property Trunks As Integer
Visual C++
public:
property int Trunks {
    int get ();
    void set (int value);
}

See Also

CfgDNInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgEnumeratorEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgEnumeratorEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgEnumeratorEx

See Also

CfgEnumeratorEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx Members
CfgEnumeratorEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgEnumeratorEx type exposes the following members.

Constructors

Name | Description
CfgEnumeratorEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DisplayName |
Name |
State |
Tenant |
Type |
UserProperties |

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx Constructor
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgEnumeratorEx()

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx Fields
CfgEnumeratorEx Class See Also Send Feedback

The CfgEnumeratorEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx Methods
CfgEnumeratorEx Class See Also Send Feedback

The CfgEnumeratorEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx Properties
CfgEnumeratorEx Class See Also Send Feedback

The CfgEnumeratorEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DisplayName |
Name |
State |
Tenant |
Type |
UserProperties |

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.DBID Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.Description Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.DisplayName Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.Name Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.State Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.Tenant Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.Type Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgEnumeratorType
Visual C++
public:
property CfgEnumeratorType Type {
    CfgEnumeratorType get ();
    void set (CfgEnumeratorType value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorEx..::.UserProperties Property
CfgEnumeratorEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgEnumeratorEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorValueEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorValueEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgEnumeratorValueEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgEnumeratorValueEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgEnumeratorValueEx

See Also

CfgEnumeratorValueEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorValueEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx Members
CfgEnumeratorValueEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgEnumeratorValueEx type exposes the following members.

Constructors

Name | Description
CfgEnumeratorValueEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DisplayName |
Enumerator |
IsDefault |
Name |
State |
Tenant |
UserProperties |

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorValueEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx Constructor
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValueEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgEnumeratorValueEx()

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorValueEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx Fields
CfgEnumeratorValueEx Class See Also Send Feedback

The CfgEnumeratorValueEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorValueEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx Methods
CfgEnumeratorValueEx Class See Also Send Feedback

The CfgEnumeratorValueEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgEnumeratorValueEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx Properties
CfgEnumeratorValueEx Class See Also Send Feedback

The CfgEnumeratorValueEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DisplayName |
Enumerator |
IsDefault |
Name |
State |
Tenant |
UserProperties |

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.DBID Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.Description Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.DisplayName Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Enumerator Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.Enumerator Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.Enumerator"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Enumerator { get; set; }
Visual Basic (Declaration)
Public Property Enumerator As Integer
Visual C++
public:
property int Enumerator {
    int get ();
    void set (int value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsDefault Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.IsDefault Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.IsDefault"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDefault { get; set; }
Visual Basic (Declaration)
Public Property IsDefault As CfgFlag
Visual C++
public:
property CfgFlag IsDefault {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.Name Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.State Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.Tenant Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueEx..::.UserProperties Property
CfgEnumeratorValueEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgEnumeratorValueEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgEnumeratorValueEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFieldEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFieldEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgFieldEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgFieldEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFieldEx

See Also

CfgFieldEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFieldEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldEx Members
CfgFieldEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFieldEx type exposes the following members.

Constructors

Name | Description
CfgFieldEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DefaultValue |
Description |
FieldType |
IsNullable |
IsPrimaryKey |
IsUnique |
Length |
Name |
State |
Tenant |
Type |
UserProperties |

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFieldEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx Constructor
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFieldEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFieldEx()

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFieldEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldEx Fields
CfgFieldEx Class See Also Send Feedback

The CfgFieldEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFieldEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldEx Methods
CfgFieldEx Class See Also Send Feedback

The CfgFieldEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFieldEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldEx Properties
CfgFieldEx Class See Also Send Feedback

The CfgFieldEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DefaultValue |
Description |
FieldType |
IsNullable |
IsPrimaryKey |
IsUnique |
Length |
Name |
State |
Tenant |
Type |
UserProperties |

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.DBID Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DefaultValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.DefaultValue Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.DefaultValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As String
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.Description Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


FieldType Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.FieldType Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.FieldType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFieldType FieldType { get; set; }
Visual Basic (Declaration)
Public Property FieldType As CfgFieldType
Visual C++
public:
property CfgFieldType FieldType {
    CfgFieldType get ();
    void set (CfgFieldType value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsNullable Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.IsNullable Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.IsNullable"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsNullable { get; set; }
Visual Basic (Declaration)
Public Property IsNullable As CfgFlag
Visual C++
public:
property CfgFlag IsNullable {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsPrimaryKey Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.IsPrimaryKey Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.IsPrimaryKey"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsPrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property IsPrimaryKey As CfgFlag
Visual C++
public:
property CfgFlag IsPrimaryKey {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsUnique Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.IsUnique Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.IsUnique"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsUnique { get; set; }
Visual Basic (Declaration)
Public Property IsUnique As CfgFlag
Visual C++
public:
property CfgFlag IsUnique {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Length Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.Length Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.Length"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.Name Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.State Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.Tenant Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.Type Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDataType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgDataType
Visual C++
public:
property CfgDataType Type {
    CfgDataType get ();
    void set (CfgDataType value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldEx..::.UserProperties Property
CfgFieldEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFieldEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFieldEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFilterEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFilterEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgFilterEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgFilterEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFilterEx

See Also

CfgFilterEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFilterEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterEx Members
CfgFilterEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFilterEx type exposes the following members.

Constructors

Name | Description
CfgFilterEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Format |
Name |
State |
Tenant |
UserProperties |

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFilterEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx Constructor
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilterEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFilterEx()

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFilterEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterEx Fields
CfgFilterEx Class See Also Send Feedback

The CfgFilterEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFilterEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterEx Methods
CfgFilterEx Class See Also Send Feedback

The CfgFilterEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFilterEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterEx Properties
CfgFilterEx Class See Also Send Feedback

The CfgFilterEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Format |
Name |
State |
Tenant |
UserProperties |

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.DBID Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.Description Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Format Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.Format Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.Format"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Format { get; set; }
Visual Basic (Declaration)
Public Property Format As Integer
Visual C++
public:
property int Format {
    int get ();
    void set (int value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.Name Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.State Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.Tenant Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterEx..::.UserProperties Property
CfgFilterEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFilterEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFilterEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFolderEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFolderEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgFolderEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgFolderEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFolderEx

See Also

CfgFolderEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFolderEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderEx Members
CfgFolderEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFolderEx type exposes the following members.

Constructors

Name | Description
CfgFolderEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
CustomType |
DBID |
Description |
FolderClass |
Name |
ObjectIDs |
OwnerID |
ParentID |
Resources |
State |
Type |
UserProperties |

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFolderEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx Constructor
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolderEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFolderEx()

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFolderEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderEx Fields
CfgFolderEx Class See Also Send Feedback

The CfgFolderEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFolderEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderEx Methods
CfgFolderEx Class See Also Send Feedback

The CfgFolderEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFolderEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderEx Properties
CfgFolderEx Class See Also Send Feedback

The CfgFolderEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
CustomType |
DBID |
Description |
FolderClass |
Name |
ObjectIDs |
OwnerID |
ParentID |
Resources |
State |
Type |
UserProperties |

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CustomType Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.CustomType Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.CustomType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CustomType { get; set; }
Visual Basic (Declaration)
Public Property CustomType As Integer
Visual C++
public:
property int CustomType {
    int get ();
    void set (int value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.DBID Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.Description Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


FolderClass Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.FolderClass Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.FolderClass"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolderClass FolderClass { get; set; }
Visual Basic (Declaration)
Public Property FolderClass As CfgFolderClass
Visual C++
public:
property CfgFolderClass FolderClass {
    CfgFolderClass get ();
    void set (CfgFolderClass value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.Name Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.ObjectIDs Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.ObjectIDs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectIDEx> ObjectIDs { get; set; }
Visual Basic (Declaration)
Public Property ObjectIDs As List(Of CfgObjectIDEx)
Visual C++
public:
property List<CfgObjectIDEx^>^ ObjectIDs {
    List<CfgObjectIDEx^>^ get ();
    void set (List<CfgObjectIDEx^>^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OwnerID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.OwnerID Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.OwnerID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOwnerIDEx OwnerID { get; set; }
Visual Basic (Declaration)
Public Property OwnerID As CfgOwnerIDEx
Visual C++
public:
property CfgOwnerIDEx^ OwnerID {
    CfgOwnerIDEx^ get ();
    void set (CfgOwnerIDEx^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ParentID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.ParentID Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.ParentID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgParentIDEx ParentID { get; set; }
Visual Basic (Declaration)
Public Property ParentID As CfgParentIDEx
Visual C++
public:
property CfgParentIDEx^ ParentID {
    CfgParentIDEx^ get ();
    void set (CfgParentIDEx^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.Resources Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.State Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.Type Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderEx..::.UserProperties Property
CfgFolderEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFolderEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFolderEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFormatEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFormatEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgFormatEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgFormatEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgFormatEx

See Also

CfgFormatEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFormatEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatEx Members
CfgFormatEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgFormatEx type exposes the following members.

Constructors

Name | Description
CfgFormatEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Fields |
Name |
State |
Tenant |
UserProperties |

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFormatEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx Constructor
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormatEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFormatEx()

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFormatEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatEx Fields
CfgFormatEx Class See Also Send Feedback

The CfgFormatEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFormatEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatEx Methods
CfgFormatEx Class See Also Send Feedback

The CfgFormatEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgFormatEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatEx Properties
CfgFormatEx Class See Also Send Feedback

The CfgFormatEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Fields |
Name |
State |
Tenant |
UserProperties |

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.DBID Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.Description Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Fields Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.Fields Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.Fields"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Fields { get; set; }
Visual Basic (Declaration)
Public Property Fields As List(Of Integer)
Visual C++
public:
property List<int>^ Fields {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.Name Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.State Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.Tenant Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatEx..::.UserProperties Property
CfgFormatEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgFormatEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgFormatEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGroupEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGroupEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgGroupEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgGroupEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGroupEx

See Also

CfgGroupEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGroupEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupEx Members
CfgGroupEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGroupEx type exposes the following members.

Constructors

Name | Description
CfgGroupEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CapacityRule |
CapacityTable |
Contract |
DBID |
Managers |
Name |
ParentDBID | (Inherited from CfgStructureEx.)
QuotaTable |
RouteDNs |
Site |
State |
Tenant |
UserProperties |

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGroupEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx Constructor
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroupEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGroupEx()

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGroupEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupEx Fields
CfgGroupEx Class See Also Send Feedback

The CfgGroupEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGroupEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupEx Methods
CfgGroupEx Class See Also Send Feedback

The CfgGroupEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGroupEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGroupEx Properties
CfgGroupEx Class See Also Send Feedback

The CfgGroupEx type exposes the following members.

Properties

Name | Description
CapacityRule |
CapacityTable |
Contract |
DBID |
Managers |
Name |
ParentDBID | (Inherited from CfgStructureEx.)
QuotaTable |
RouteDNs |
Site |
State |
Tenant |
UserProperties |

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.CapacityRule Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.CapacityRule"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CapacityRule { get; set; }
Visual Basic (Declaration)
Public Property CapacityRule As Integer
Visual C++
public:
property int CapacityRule {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CapacityTable Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.CapacityTable Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.CapacityTable"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CapacityTable { get; set; }
Visual Basic (Declaration)
Public Property CapacityTable As Integer
Visual C++
public:
property int CapacityTable {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.Contract Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.Contract"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As Integer
Visual C++
public:
property int Contract {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.DBID Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Managers Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.Managers Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.Managers"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Managers { get; set; }
Visual Basic (Declaration)
Public Property Managers As List(Of Integer)
Visual C++
public:
property List<int>^ Managers {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.Name Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


QuotaTable Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.QuotaTable Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.QuotaTable"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int QuotaTable { get; set; }
Visual Basic (Declaration)
Public Property QuotaTable As Integer
Visual C++
public:
property int QuotaTable {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RouteDNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.RouteDNs Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.RouteDNs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> RouteDNs { get; set; }
Visual Basic (Declaration)
Public Property RouteDNs As List(Of Integer)
Visual C++
public:
property List<int>^ RouteDNs {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.Site Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.Site"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Site { get; set; }
Visual Basic (Declaration)
Public Property Site As Integer
Visual C++
public:
property int Site {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.State Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.Tenant Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGroupEx..::.UserProperties Property
CfgGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGroupEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPCustomerEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPCustomerEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgGVPCustomerEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgGVPCustomerEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGVPCustomerEx

See Also

CfgGVPCustomerEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPCustomerEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx Members
CfgGVPCustomerEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGVPCustomerEx type exposes the following members.

Constructors

Name | Description
CfgGVPCustomerEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Channel |
DBID |
DisplayName |
IsAdminCustomer |
IsProvisioned |
Name |
Notes |
Reseller |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPCustomerEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx Constructor
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPCustomerEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPCustomerEx()

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPCustomerEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx Fields
CfgGVPCustomerEx Class See Also Send Feedback

The CfgGVPCustomerEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPCustomerEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx Methods
CfgGVPCustomerEx Class See Also Send Feedback

The CfgGVPCustomerEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPCustomerEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx Properties
CfgGVPCustomerEx Class See Also Send Feedback

The CfgGVPCustomerEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Channel |
DBID |
DisplayName |
IsAdminCustomer |
IsProvisioned |
Name |
Notes |
Reseller |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Channel Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.Channel Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.Channel"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Channel { get; set; }
Visual Basic (Declaration)
Public Property Channel As String
Visual C++
public:
property String^ Channel {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.DBID Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.DisplayName Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsAdminCustomer Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.IsAdminCustomer Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.IsAdminCustomer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAdminCustomer { get; set; }
Visual Basic (Declaration)
Public Property IsAdminCustomer As CfgFlag
Visual C++
public:
property CfgFlag IsAdminCustomer {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsProvisioned Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.IsProvisioned Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.IsProvisioned"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsProvisioned { get; set; }
Visual Basic (Declaration)
Public Property IsProvisioned As CfgFlag
Visual C++
public:
property CfgFlag IsProvisioned {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.Name Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.Notes Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.Notes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Reseller Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.Reseller Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.Reseller"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Reseller { get; set; }
Visual Basic (Declaration)
Public Property Reseller As Integer
Visual C++
public:
property int Reseller {
    int get ();
    void set (int value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.State Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.Tenant Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.TimeZone Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.TimeZone"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As Integer
Visual C++
public:
property int TimeZone {
    int get ();
    void set (int value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPCustomerEx..::.UserProperties Property
CfgGVPCustomerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPCustomerEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGVPCustomerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPIVRProfileEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPIVRProfileEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgGVPIVRProfileEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgGVPIVRProfileEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGVPIVRProfileEx

See Also

CfgGVPIVRProfileEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPIVRProfileEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx Members
CfgGVPIVRProfileEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGVPIVRProfileEx type exposes the following members.

Constructors

Name | Description
CfgGVPIVRProfileEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Customer |
DBID |
Description |
DIDs |
DisplayName |
EndServiceDate |
IsProvisioned |
Name |
Notes |
Reseller |
Resources |
StartServiceDate |
State |
Status |
Tenant |
Tfn |
Type |
UserProperties |

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPIVRProfileEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx Constructor
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPIVRProfileEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPIVRProfileEx()

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPIVRProfileEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx Fields
CfgGVPIVRProfileEx Class See Also Send Feedback

The CfgGVPIVRProfileEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPIVRProfileEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx Methods
CfgGVPIVRProfileEx Class See Also Send Feedback

The CfgGVPIVRProfileEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPIVRProfileEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx Properties
CfgGVPIVRProfileEx Class See Also Send Feedback

The CfgGVPIVRProfileEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Customer |
DBID |
Description |
DIDs |
DisplayName |
EndServiceDate |
IsProvisioned |
Name |
Notes |
Reseller |
Resources |
StartServiceDate |
State |
Status |
Tenant |
Tfn |
Type |
UserProperties |

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Customer Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Customer Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Customer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Customer { get; set; }
Visual Basic (Declaration)
Public Property Customer As Integer
Visual C++
public:
property int Customer {
    int get ();
    void set (int value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.DBID Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Description Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DIDs Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.DIDs Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.DIDs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> DIDs { get; set; }
Visual Basic (Declaration)
Public Property DIDs As List(Of Integer)
Visual C++
public:
property List<int>^ DIDs {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.DisplayName Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


EndServiceDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.EndServiceDate Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.EndServiceDate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime EndServiceDate { get; set; }
Visual Basic (Declaration)
Public Property EndServiceDate As DateTime
Visual C++
public:
property DateTime EndServiceDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsProvisioned Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.IsProvisioned Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.IsProvisioned"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsProvisioned { get; set; }
Visual Basic (Declaration)
Public Property IsProvisioned As CfgFlag
Visual C++
public:
property CfgFlag IsProvisioned {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Name Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Notes Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Notes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Reseller Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Reseller Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Reseller"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Reseller { get; set; }
Visual Basic (Declaration)
Public Property Reseller As Integer
Visual C++
public:
property int Reseller {
    int get ();
    void set (int value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Resources Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartServiceDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.StartServiceDate Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.StartServiceDate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime StartServiceDate { get; set; }
Visual Basic (Declaration)
Public Property StartServiceDate As DateTime
Visual C++
public:
property DateTime StartServiceDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.State Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Status Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Status"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Tenant Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tfn Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Tfn Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Tfn"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Tfn { get; set; }
Visual Basic (Declaration)
Public Property Tfn As String
Visual C++
public:
property String^ Tfn {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.Type Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRProfileType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgIVRProfileType
Visual C++
public:
property CfgIVRProfileType Type {
    CfgIVRProfileType get ();
    void set (CfgIVRProfileType value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileEx..::.UserProperties Property
CfgGVPIVRProfileEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPIVRProfileEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGVPIVRProfileEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPResellerEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPResellerEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgGVPResellerEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgGVPResellerEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgGVPResellerEx

See Also

CfgGVPResellerEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPResellerEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx Members
CfgGVPResellerEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgGVPResellerEx type exposes the following members.

Constructors

Name | Description
CfgGVPResellerEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DisplayName |
IsParentNSP |
Name |
Notes |
StartDate |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPResellerEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx Constructor
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPResellerEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPResellerEx()

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPResellerEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx Fields
CfgGVPResellerEx Class See Also Send Feedback

The CfgGVPResellerEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPResellerEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx Methods
CfgGVPResellerEx Class See Also Send Feedback

The CfgGVPResellerEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgGVPResellerEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx Properties
CfgGVPResellerEx Class See Also Send Feedback

The CfgGVPResellerEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DisplayName |
IsParentNSP |
Name |
Notes |
StartDate |
State |
Tenant |
TimeZone |
UserProperties |

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.DBID Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.DisplayName Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsParentNSP Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.IsParentNSP Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.IsParentNSP"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsParentNSP { get; set; }
Visual Basic (Declaration)
Public Property IsParentNSP As CfgFlag
Visual C++
public:
property CfgFlag IsParentNSP {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.Name Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Notes Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.Notes Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.Notes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.StartDate Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.StartDate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.State Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.Tenant Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.TimeZone Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.TimeZone"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As Integer
Visual C++
public:
property int TimeZone {
    int get ();
    void set (int value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPResellerEx..::.UserProperties Property
CfgGVPResellerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgGVPResellerEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgGVPResellerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgHostEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgHostEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgHostEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgHostEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgHostEx

See Also

CfgHostEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgHostEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostEx Members
CfgHostEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgHostEx type exposes the following members.

Constructors

Name | Description
CfgHostEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Address |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
IPaddress |
LCAPort |
Name |
OSinfo |
Resources |
SCS |
State |
Type |
UserProperties |

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgHostEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx Constructor
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHostEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgHostEx()

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgHostEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostEx Fields
CfgHostEx Class See Also Send Feedback

The CfgHostEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgHostEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostEx Methods
CfgHostEx Class See Also Send Feedback

The CfgHostEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgHostEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostEx Properties
CfgHostEx Class See Also Send Feedback

The CfgHostEx type exposes the following members.

Properties

Name | Description
Address |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
IPaddress |
LCAPort |
Name |
OSinfo |
Resources |
SCS |
State |
Type |
UserProperties |

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.Address Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.Address"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddressEx Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddressEx
Visual C++
public:
property CfgAddressEx^ Address {
    CfgAddressEx^ get ();
    void set (CfgAddressEx^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.DBID Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IPaddress Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.IPaddress Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.IPaddress"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string IPaddress { get; set; }
Visual Basic (Declaration)
Public Property IPaddress As String
Visual C++
public:
property String^ IPaddress {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LCAPort Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.LCAPort Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.LCAPort"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LCAPort { get; set; }
Visual Basic (Declaration)
Public Property LCAPort As String
Visual C++
public:
property String^ LCAPort {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.Name Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OSinfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.OSinfo Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.OSinfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOSEx OSinfo { get; set; }
Visual Basic (Declaration)
Public Property OSinfo As CfgOSEx
Visual C++
public:
property CfgOSEx^ OSinfo {
    CfgOSEx^ get ();
    void set (CfgOSEx^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.Resources Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SCS Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.SCS Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.SCS"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SCS { get; set; }
Visual Basic (Declaration)
Public Property SCS As Integer
Visual C++
public:
property int SCS {
    int get ();
    void set (int value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.State Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.Type Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHostType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgHostType
Visual C++
public:
property CfgHostType Type {
    CfgHostType get ();
    void set (CfgHostType value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostEx..::.UserProperties Property
CfgHostEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgHostEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgHostEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgIDEx

See Also

CfgIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDEx Members
CfgIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgIDEx type exposes the following members.

Constructors

Name | Description
CfgIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIDEx Constructor
CfgIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIDEx()

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDEx Fields
CfgIDEx Class See Also Send Feedback

The CfgIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDEx Methods
CfgIDEx Class See Also Send Feedback

The CfgIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIDEx Properties
CfgIDEx Class See Also Send Feedback

The CfgIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgIDEx..::.DBID Property
CfgIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgIDEx..::.Type Property
CfgIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVREx Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVREx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgIVREx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgIVREx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgIVREx

See Also

CfgIVREx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVREx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVREx Members
CfgIVREx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgIVREx type exposes the following members.

Constructors

Name | Description
CfgIVREx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
IVRServer |
Name |
State |
Tenant |
Type |
UserProperties |
Version |

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVREx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx Constructor
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVREx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIVREx()

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVREx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVREx Fields
CfgIVREx Class See Also Send Feedback

The CfgIVREx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVREx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVREx Methods
CfgIVREx Class See Also Send Feedback

The CfgIVREx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVREx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVREx Properties
CfgIVREx Class See Also Send Feedback

The CfgIVREx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
IVRServer |
Name |
State |
Tenant |
Type |
UserProperties |
Version |

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.DBID Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.Description Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IVRServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.IVRServer Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.IVRServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IVRServer { get; set; }
Visual Basic (Declaration)
Public Property IVRServer As Integer
Visual C++
public:
property int IVRServer {
    int get ();
    void set (int value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.Name Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.State Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.Tenant Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.Type Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgIVRType
Visual C++
public:
property CfgIVRType Type {
    CfgIVRType get ();
    void set (CfgIVRType value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.UserProperties Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVREx..::.Version Property
CfgIVREx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVREx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVREx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVRPortEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVRPortEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgIVRPortEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgIVRPortEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgIVRPortEx

See Also

CfgIVRPortEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVRPortEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx Members
CfgIVRPortEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgIVRPortEx type exposes the following members.

Constructors

Name | Description
CfgIVRPortEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DN |
IVR |
PortNumber |
State |
Tenant |
UserProperties |

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVRPortEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx Constructor
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRPortEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIVRPortEx()

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVRPortEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx Fields
CfgIVRPortEx Class See Also Send Feedback

The CfgIVRPortEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVRPortEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx Methods
CfgIVRPortEx Class See Also Send Feedback

The CfgIVRPortEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgIVRPortEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx Properties
CfgIVRPortEx Class See Also Send Feedback

The CfgIVRPortEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DN |
IVR |
PortNumber |
State |
Tenant |
UserProperties |

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.DBID Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.Description Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DN Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.DN Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.DN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DN { get; set; }
Visual Basic (Declaration)
Public Property DN As Integer
Visual C++
public:
property int DN {
    int get ();
    void set (int value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IVR Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.IVR Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.IVR"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IVR { get; set; }
Visual Basic (Declaration)
Public Property IVR As Integer
Visual C++
public:
property int IVR {
    int get ();
    void set (int value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PortNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.PortNumber Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.PortNumber"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PortNumber { get; set; }
Visual Basic (Declaration)
Public Property PortNumber As String
Visual C++
public:
property String^ PortNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.State Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.Tenant Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortEx..::.UserProperties Property
CfgIVRPortEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgIVRPortEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgIVRPortEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgMemberIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgMemberIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgMemberIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgMemberIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgMemberIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgMemberIDEx

See Also

CfgMemberIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgMemberIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx Members
CfgMemberIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgMemberIDEx type exposes the following members.

Constructors

Name | Description
CfgMemberIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgMemberIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx Constructor
CfgMemberIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgMemberIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgMemberIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgMemberIDEx()

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgMemberIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx Fields
CfgMemberIDEx Class See Also Send Feedback

The CfgMemberIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgMemberIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx Methods
CfgMemberIDEx Class See Also Send Feedback

The CfgMemberIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgMemberIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx Properties
CfgMemberIDEx Class See Also Send Feedback

The CfgMemberIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx..::.DBID Property
CfgMemberIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgMemberIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgMemberIDEx..::.Type Property
CfgMemberIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgMemberIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgMemberIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgObjectIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgObjectIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectIDEx

See Also

CfgObjectIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx Members
CfgObjectIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectIDEx type exposes the following members.

Constructors

Name | Description
CfgObjectIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx Constructor
CfgObjectIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectIDEx()

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx Fields
CfgObjectIDEx Class See Also Send Feedback

The CfgObjectIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx Methods
CfgObjectIDEx Class See Also Send Feedback

The CfgObjectIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx Properties
CfgObjectIDEx Class See Also Send Feedback

The CfgObjectIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx..::.DBID Property
CfgObjectIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectIDEx..::.Type Property
CfgObjectIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgObjectIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTableEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgObjectiveTableEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgObjectiveTableEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectiveTableEx

See Also

CfgObjectiveTableEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx Members
CfgObjectiveTableEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectiveTableEx type exposes the following members.

Constructors

Name | Description
CfgObjectiveTableEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
ObjectiveRecords |
PrepaidCost |
State |
Tenant |
TimeEnd |
TimeStart |
TimeZone |
Type |
UserProperties |

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx Constructor
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectiveTableEx()

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx Fields
CfgObjectiveTableEx Class See Also Send Feedback

The CfgObjectiveTableEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx Methods
CfgObjectiveTableEx Class See Also Send Feedback

The CfgObjectiveTableEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx Properties
CfgObjectiveTableEx Class See Also Send Feedback

The CfgObjectiveTableEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
ObjectiveRecords |
PrepaidCost |
State |
Tenant |
TimeEnd |
TimeStart |
TimeZone |
Type |
UserProperties |

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.DBID Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.Description Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.Name Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectiveRecords Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.ObjectiveRecords Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.ObjectiveRecords"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectiveTableRecordEx> ObjectiveRecords { get; set; }
Visual Basic (Declaration)
Public Property ObjectiveRecords As List(Of CfgObjectiveTableRecordEx)
Visual C++
public:
property List<CfgObjectiveTableRecordEx^>^ ObjectiveRecords {
    List<CfgObjectiveTableRecordEx^>^ get ();
    void set (List<CfgObjectiveTableRecordEx^>^ value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PrepaidCost Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.PrepaidCost Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.PrepaidCost"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int PrepaidCost { get; set; }
Visual Basic (Declaration)
Public Property PrepaidCost As Integer
Visual C++
public:
property int PrepaidCost {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.State Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.Tenant Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeEnd Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.TimeEnd Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.TimeEnd"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime TimeEnd { get; set; }
Visual Basic (Declaration)
Public Property TimeEnd As DateTime
Visual C++
public:
property DateTime TimeEnd {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeStart Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.TimeStart Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.TimeStart"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime TimeStart { get; set; }
Visual Basic (Declaration)
Public Property TimeStart As DateTime
Visual C++
public:
property DateTime TimeStart {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.TimeZone Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.TimeZone"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As Integer
Visual C++
public:
property int TimeZone {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.Type Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectiveTableType
Visual C++
public:
property CfgObjectiveTableType Type {
    CfgObjectiveTableType get ();
    void set (CfgObjectiveTableType value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableEx..::.UserProperties Property
CfgObjectiveTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgObjectiveTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableRecordEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTableRecordEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgObjectiveTableRecordEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgObjectiveTableRecordEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectiveTableRecordEx

See Also

CfgObjectiveTableRecordEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableRecordEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx Members
CfgObjectiveTableRecordEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectiveTableRecordEx type exposes the following members.

Constructors

Name | Description
CfgObjectiveTableRecordEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Contract |
CustomerSegment |
MediaType |
ObjectiveDelta |
ObjectiveThreshold |
ParentDBID | (Inherited from CfgStructureEx.)
ServiceType |

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableRecordEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx Constructor
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableRecordEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectiveTableRecordEx()

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableRecordEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx Fields
CfgObjectiveTableRecordEx Class See Also Send Feedback

The CfgObjectiveTableRecordEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableRecordEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx Methods
CfgObjectiveTableRecordEx Class See Also Send Feedback

The CfgObjectiveTableRecordEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectiveTableRecordEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx Properties
CfgObjectiveTableRecordEx Class See Also Send Feedback

The CfgObjectiveTableRecordEx type exposes the following members.

Properties

Name | Description
Contract |
CustomerSegment |
MediaType |
ObjectiveDelta |
ObjectiveThreshold |
ParentDBID | (Inherited from CfgStructureEx.)
ServiceType |

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx..::.Contract Property
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.Contract"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As Integer
Visual C++
public:
property int Contract {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CustomerSegment Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx..::.CustomerSegment Property
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.CustomerSegment"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CustomerSegment { get; set; }
Visual Basic (Declaration)
Public Property CustomerSegment As Integer
Visual C++
public:
property int CustomerSegment {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx..::.MediaType Property
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.MediaType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MediaType { get; set; }
Visual Basic (Declaration)
Public Property MediaType As Integer
Visual C++
public:
property int MediaType {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectiveDelta Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx..::.ObjectiveDelta Property
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.ObjectiveDelta"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectiveDelta { get; set; }
Visual Basic (Declaration)
Public Property ObjectiveDelta As Integer
Visual C++
public:
property int ObjectiveDelta {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectiveThreshold Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx..::.ObjectiveThreshold Property
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.ObjectiveThreshold"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectiveThreshold { get; set; }
Visual Basic (Declaration)
Public Property ObjectiveThreshold As Integer
Visual C++
public:
property int ObjectiveThreshold {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ServiceType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableRecordEx..::.ServiceType Property
CfgObjectiveTableRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectiveTableRecordEx.ServiceType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As Integer
Visual C++
public:
property int ServiceType {
    int get ();
    void set (int value);
}

See Also

CfgObjectiveTableRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectResourceEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectResourceEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgObjectResourceEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgObjectResourceEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgObjectResourceEx

See Also

CfgObjectResourceEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectResourceEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx Members
CfgObjectResourceEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgObjectResourceEx type exposes the following members.

Constructors

Name | Description
CfgObjectResourceEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CharField1 |
CharField2 |
CharField3 |
CharField4 |
Description |
LongField1 |
LongField2 |
LongField3 |
LongField4 |
ObjectDBID |
ObjectType |
ParentDBID | (Inherited from CfgStructureEx.)
ResourceType |

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectResourceEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx Constructor
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectResourceEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectResourceEx()

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectResourceEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx Fields
CfgObjectResourceEx Class See Also Send Feedback

The CfgObjectResourceEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectResourceEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx Methods
CfgObjectResourceEx Class See Also Send Feedback

The CfgObjectResourceEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgObjectResourceEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx Properties
CfgObjectResourceEx Class See Also Send Feedback

The CfgObjectResourceEx type exposes the following members.

Properties

Name | Description
CharField1 |
CharField2 |
CharField3 |
CharField4 |
Description |
LongField1 |
LongField2 |
LongField3 |
LongField4 |
ObjectDBID |
ObjectType |
ParentDBID | (Inherited from CfgStructureEx.)
ResourceType |

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.CharField1 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.CharField1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField1 { get; set; }
Visual Basic (Declaration)
Public Property CharField1 As String
Visual C++
public:
property String^ CharField1 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.CharField2 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.CharField2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField2 { get; set; }
Visual Basic (Declaration)
Public Property CharField2 As String
Visual C++
public:
property String^ CharField2 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.CharField3 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.CharField3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField3 { get; set; }
Visual Basic (Declaration)
Public Property CharField3 As String
Visual C++
public:
property String^ CharField3 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.CharField4 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.CharField4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField4 { get; set; }
Visual Basic (Declaration)
Public Property CharField4 As String
Visual C++
public:
property String^ CharField4 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.Description Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.LongField1 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.LongField1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField1 { get; set; }
Visual Basic (Declaration)
Public Property LongField1 As Integer
Visual C++
public:
property int LongField1 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.LongField2 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.LongField2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField2 { get; set; }
Visual Basic (Declaration)
Public Property LongField2 As Integer
Visual C++
public:
property int LongField2 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.LongField3 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.LongField3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField3 { get; set; }
Visual Basic (Declaration)
Public Property LongField3 As Integer
Visual C++
public:
property int LongField3 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.LongField4 Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.LongField4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField4 { get; set; }
Visual Basic (Declaration)
Public Property LongField4 As Integer
Visual C++
public:
property int LongField4 {
    int get ();
    void set (int value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.ObjectDBID Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.ObjectDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDBID { get; set; }
Visual Basic (Declaration)
Public Property ObjectDBID As Integer
Visual C++
public:
property int ObjectDBID {
    int get ();
    void set (int value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.ObjectType Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ResourceType Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectResourceEx..::.ResourceType Property
CfgObjectResourceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgObjectResourceEx.ResourceType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgResourceType ResourceType { get; set; }
Visual Basic (Declaration)
Public Property ResourceType As CfgResourceType
Visual C++
public:
property CfgResourceType ResourceType {
    CfgResourceType get ();
    void set (CfgResourceType value);
}

See Also

CfgObjectResourceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOSEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgOSEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOSEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgOSEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgOSEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgOSEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgOSEx

See Also

CfgOSEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOSEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSEx Members
CfgOSEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgOSEx type exposes the following members.

Constructors

Name | Description
CfgOSEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
OStype |
OSversion |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOSEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgOSEx Constructor
CfgOSEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOSEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOSEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgOSEx()

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOSEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSEx Fields
CfgOSEx Class See Also Send Feedback

The CfgOSEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOSEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSEx Methods
CfgOSEx Class See Also Send Feedback

The CfgOSEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOSEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOSEx Properties
CfgOSEx Class See Also Send Feedback

The CfgOSEx type exposes the following members.

Properties

Name | Description
OStype |
OSversion |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OStype Property

[image]

Enterprise SDK 8.0 Reference API
CfgOSEx..::.OStype Property
CfgOSEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOSEx.OStype"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOSType OStype { get; set; }
Visual Basic (Declaration)
Public Property OStype As CfgOSType
Visual C++
public:
property CfgOSType OStype {
    CfgOSType get ();
    void set (CfgOSType value);
}

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


OSversion Property

[image]

Enterprise SDK 8.0 Reference API
CfgOSEx..::.OSversion Property
CfgOSEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOSEx.OSversion"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string OSversion { get; set; }
Visual Basic (Declaration)
Public Property OSversion As String
Visual C++
public:
property String^ OSversion {
    String^ get ();
    void set (String^ value);
}

See Also

CfgOSEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOwnerIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOwnerIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgOwnerIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgOwnerIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgOwnerIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgOwnerIDEx

See Also

CfgOwnerIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOwnerIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx Members
CfgOwnerIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgOwnerIDEx type exposes the following members.

Constructors

Name | Description
CfgOwnerIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOwnerIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx Constructor
CfgOwnerIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOwnerIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgOwnerIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgOwnerIDEx()

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOwnerIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx Fields
CfgOwnerIDEx Class See Also Send Feedback

The CfgOwnerIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOwnerIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx Methods
CfgOwnerIDEx Class See Also Send Feedback

The CfgOwnerIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgOwnerIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx Properties
CfgOwnerIDEx Class See Also Send Feedback

The CfgOwnerIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx..::.DBID Property
CfgOwnerIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOwnerIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgOwnerIDEx..::.Type Property
CfgOwnerIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgOwnerIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgOwnerIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgParentIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgParentIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgParentIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgParentIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgParentIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgParentIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgParentIDEx

See Also

CfgParentIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgParentIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDEx Members
CfgParentIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgParentIDEx type exposes the following members.

Constructors

Name | Description
CfgParentIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgParentIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgParentIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgParentIDEx Constructor
CfgParentIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgParentIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgParentIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgParentIDEx()

See Also

CfgParentIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgParentIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDEx Fields
CfgParentIDEx Class See Also Send Feedback

The CfgParentIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgParentIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgParentIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDEx Methods
CfgParentIDEx Class See Also Send Feedback

The CfgParentIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgParentIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgParentIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgParentIDEx Properties
CfgParentIDEx Class See Also Send Feedback

The CfgParentIDEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgParentIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPersonEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPersonEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgPersonEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgPersonEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPersonEx

See Also

CfgPersonEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPersonEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonEx Members
CfgPersonEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPersonEx type exposes the following members.

Constructors

Name | Description
CfgPersonEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Address |
AgentInfo |
AppRanks |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
EmailAddress |
EmployeeID |
ExternalID |
FirstName |
IsAgent |
IsExternalAuth |
LastName |
Password |
Phones |
State |
Tenant |
UserName |
UserProperties |

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPersonEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx Constructor
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPersonEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPersonEx()

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPersonEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonEx Fields
CfgPersonEx Class See Also Send Feedback

The CfgPersonEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPersonEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonEx Methods
CfgPersonEx Class See Also Send Feedback

The CfgPersonEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPersonEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonEx Properties
CfgPersonEx Class See Also Send Feedback

The CfgPersonEx type exposes the following members.

Properties

Name | Description
Address |
AgentInfo |
AppRanks |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
EmailAddress |
EmployeeID |
ExternalID |
FirstName |
IsAgent |
IsExternalAuth |
LastName |
Password |
Phones |
State |
Tenant |
UserName |
UserProperties |

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.Address Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.Address"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddressEx Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddressEx
Visual C++
public:
property CfgAddressEx^ Address {
    CfgAddressEx^ get ();
    void set (CfgAddressEx^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AgentInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.AgentInfo Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.AgentInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentInfoEx AgentInfo { get; set; }
Visual Basic (Declaration)
Public Property AgentInfo As CfgAgentInfoEx
Visual C++
public:
property CfgAgentInfoEx^ AgentInfo {
    CfgAgentInfoEx^ get ();
    void set (CfgAgentInfoEx^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppRanks Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.AppRanks Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.AppRanks"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgAppRankEx> AppRanks { get; set; }
Visual Basic (Declaration)
Public Property AppRanks As List(Of CfgAppRankEx)
Visual C++
public:
property List<CfgAppRankEx^>^ AppRanks {
    List<CfgAppRankEx^>^ get ();
    void set (List<CfgAppRankEx^>^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.DBID Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


EmailAddress Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.EmailAddress Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.EmailAddress"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


EmployeeID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.EmployeeID Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.EmployeeID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmployeeID { get; set; }
Visual Basic (Declaration)
Public Property EmployeeID As String
Visual C++
public:
property String^ EmployeeID {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ExternalID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.ExternalID Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.ExternalID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExternalID { get; set; }
Visual Basic (Declaration)
Public Property ExternalID As String
Visual C++
public:
property String^ ExternalID {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.FirstName Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.FirstName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.IsAgent Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.IsAgent"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsAgent { get; set; }
Visual Basic (Declaration)
Public Property IsAgent As CfgFlag
Visual C++
public:
property CfgFlag IsAgent {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsExternalAuth Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.IsExternalAuth Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.IsExternalAuth"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsExternalAuth { get; set; }
Visual Basic (Declaration)
Public Property IsExternalAuth As CfgFlag
Visual C++
public:
property CfgFlag IsExternalAuth {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.LastName Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.LastName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.Password Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.Password"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Phones Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.Phones Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.Phones"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhonesEx Phones { get; set; }
Visual Basic (Declaration)
Public Property Phones As CfgPhonesEx
Visual C++
public:
property CfgPhonesEx^ Phones {
    CfgPhonesEx^ get ();
    void set (CfgPhonesEx^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.State Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.Tenant Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.UserName Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.UserName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonEx..::.UserProperties Property
CfgPersonEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPersonEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgPersonEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhonesEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhonesEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhonesEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhonesEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgPhonesEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgPhonesEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPhonesEx

See Also

CfgPhonesEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhonesEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesEx Members
CfgPhonesEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPhonesEx type exposes the following members.

Constructors

Name | Description
CfgPhonesEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgPhonesEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhonesEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhonesEx Constructor
CfgPhonesEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhonesEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhonesEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPhonesEx()

See Also

CfgPhonesEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhonesEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesEx Fields
CfgPhonesEx Class See Also Send Feedback

The CfgPhonesEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgPhonesEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhonesEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesEx Methods
CfgPhonesEx Class See Also Send Feedback

The CfgPhonesEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgPhonesEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhonesEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhonesEx Properties
CfgPhonesEx Class See Also Send Feedback

The CfgPhonesEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgPhonesEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhysicalSwitchEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhysicalSwitchEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgPhysicalSwitchEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgPhysicalSwitchEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPhysicalSwitchEx

See Also

CfgPhysicalSwitchEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhysicalSwitchEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx Members
CfgPhysicalSwitchEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPhysicalSwitchEx type exposes the following members.

Constructors

Name | Description
CfgPhysicalSwitchEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Address |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Name |
State |
Type |
UserProperties |

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhysicalSwitchEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx Constructor
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhysicalSwitchEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPhysicalSwitchEx()

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhysicalSwitchEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx Fields
CfgPhysicalSwitchEx Class See Also Send Feedback

The CfgPhysicalSwitchEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhysicalSwitchEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx Methods
CfgPhysicalSwitchEx Class See Also Send Feedback

The CfgPhysicalSwitchEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPhysicalSwitchEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx Properties
CfgPhysicalSwitchEx Class See Also Send Feedback

The CfgPhysicalSwitchEx type exposes the following members.

Properties

Name | Description
Address |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Name |
State |
Type |
UserProperties |

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx..::.Address Property
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.Address"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddressEx Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddressEx
Visual C++
public:
property CfgAddressEx^ Address {
    CfgAddressEx^ get ();
    void set (CfgAddressEx^ value);
}

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx..::.DBID Property
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx..::.Name Property
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx..::.State Property
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx..::.Type Property
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgSwitchType
Visual C++
public:
property CfgSwitchType Type {
    CfgSwitchType get ();
    void set (CfgSwitchType value);
}

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchEx..::.UserProperties Property
CfgPhysicalSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPhysicalSwitchEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgPhysicalSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgPlaceEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgPlaceEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPlaceEx

See Also

CfgPlaceEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx Members
CfgPlaceEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPlaceEx type exposes the following members.

Constructors

Name | Description
CfgPlaceEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CapacityRule |
CfgObjectType | (Inherited from CfgObjectEx.)
Contract |
DBID |
DNs |
Name |
Site |
State |
Tenant |
UserProperties |

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx Constructor
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPlaceEx()

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx Fields
CfgPlaceEx Class See Also Send Feedback

The CfgPlaceEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx Methods
CfgPlaceEx Class See Also Send Feedback

The CfgPlaceEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx Properties
CfgPlaceEx Class See Also Send Feedback

The CfgPlaceEx type exposes the following members.

Properties

Name | Description
CapacityRule |
CfgObjectType | (Inherited from CfgObjectEx.)
Contract |
DBID |
DNs |
Name |
Site |
State |
Tenant |
UserProperties |

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.CapacityRule Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.CapacityRule"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CapacityRule { get; set; }
Visual Basic (Declaration)
Public Property CapacityRule As Integer
Visual C++
public:
property int CapacityRule {
    int get ();
    void set (int value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Contract Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.Contract Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.Contract"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Contract { get; set; }
Visual Basic (Declaration)
Public Property Contract As Integer
Visual C++
public:
property int Contract {
    int get ();
    void set (int value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.DBID Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DNs Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.DNs Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.DNs"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> DNs { get; set; }
Visual Basic (Declaration)
Public Property DNs As List(Of Integer)
Visual C++
public:
property List<int>^ DNs {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.Name Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Site Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.Site Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.Site"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Site { get; set; }
Visual Basic (Declaration)
Public Property Site As Integer
Visual C++
public:
property int Site {
    int get ();
    void set (int value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.State Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.Tenant Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceEx..::.UserProperties Property
CfgPlaceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgPlaceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceGroupEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceGroupEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceGroupEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgPlaceGroupEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgPlaceGroupEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPlaceGroupEx

See Also

CfgPlaceGroupEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceGroupEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx Members
CfgPlaceGroupEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPlaceGroupEx type exposes the following members.

Constructors

Name | Description
CfgPlaceGroupEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
GroupInfo |
Places |

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceGroupEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx Constructor
CfgPlaceGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceGroupEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceGroupEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPlaceGroupEx()

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceGroupEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx Fields
CfgPlaceGroupEx Class See Also Send Feedback

The CfgPlaceGroupEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceGroupEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx Methods
CfgPlaceGroupEx Class See Also Send Feedback

The CfgPlaceGroupEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPlaceGroupEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx Properties
CfgPlaceGroupEx Class See Also Send Feedback

The CfgPlaceGroupEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
GroupInfo |
Places |

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx..::.DBID Property
CfgPlaceGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceGroupEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


GroupInfo Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx..::.GroupInfo Property
CfgPlaceGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceGroupEx.GroupInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGroupEx GroupInfo { get; set; }
Visual Basic (Declaration)
Public Property GroupInfo As CfgGroupEx
Visual C++
public:
property CfgGroupEx^ GroupInfo {
    CfgGroupEx^ get ();
    void set (CfgGroupEx^ value);
}

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Places Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupEx..::.Places Property
CfgPlaceGroupEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPlaceGroupEx.Places"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> Places { get; set; }
Visual Basic (Declaration)
Public Property Places As List(Of Integer)
Visual C++
public:
property List<int>^ Places {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgPlaceGroupEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPortInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPortInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgPortInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgPortInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgPortInfoEx

See Also

CfgPortInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPortInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx Members
CfgPortInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgPortInfoEx type exposes the following members.

Constructors

Name | Description
CfgPortInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AppParams |
CharField1 |
CharField2 |
CharField3 |
CharField4 |
ConnProtocol |
Description |
Id |
LongField1 |
LongField2 |
LongField3 |
LongField4 |
ParentDBID | (Inherited from CfgStructureEx.)
Port |
TransportParams |

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPortInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx Constructor
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPortInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPortInfoEx()

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPortInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx Fields
CfgPortInfoEx Class See Also Send Feedback

The CfgPortInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPortInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx Methods
CfgPortInfoEx Class See Also Send Feedback

The CfgPortInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgPortInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx Properties
CfgPortInfoEx Class See Also Send Feedback

The CfgPortInfoEx type exposes the following members.

Properties

Name | Description
AppParams |
CharField1 |
CharField2 |
CharField3 |
CharField4 |
ConnProtocol |
Description |
Id |
LongField1 |
LongField2 |
LongField3 |
LongField4 |
ParentDBID | (Inherited from CfgStructureEx.)
Port |
TransportParams |

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AppParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.AppParams Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.AppParams"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AppParams { get; set; }
Visual Basic (Declaration)
Public Property AppParams As String
Visual C++
public:
property String^ AppParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.CharField1 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.CharField1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField1 { get; set; }
Visual Basic (Declaration)
Public Property CharField1 As String
Visual C++
public:
property String^ CharField1 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.CharField2 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.CharField2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField2 { get; set; }
Visual Basic (Declaration)
Public Property CharField2 As String
Visual C++
public:
property String^ CharField2 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.CharField3 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.CharField3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField3 { get; set; }
Visual Basic (Declaration)
Public Property CharField3 As String
Visual C++
public:
property String^ CharField3 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CharField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.CharField4 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.CharField4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string CharField4 { get; set; }
Visual Basic (Declaration)
Public Property CharField4 As String
Visual C++
public:
property String^ CharField4 {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ConnProtocol Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.ConnProtocol Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.ConnProtocol"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ConnProtocol { get; set; }
Visual Basic (Declaration)
Public Property ConnProtocol As String
Visual C++
public:
property String^ ConnProtocol {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.Description Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.Id Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.Id"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.LongField1 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.LongField1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField1 { get; set; }
Visual Basic (Declaration)
Public Property LongField1 As Integer
Visual C++
public:
property int LongField1 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.LongField2 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.LongField2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField2 { get; set; }
Visual Basic (Declaration)
Public Property LongField2 As Integer
Visual C++
public:
property int LongField2 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.LongField3 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.LongField3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField3 { get; set; }
Visual Basic (Declaration)
Public Property LongField3 As Integer
Visual C++
public:
property int LongField3 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LongField4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.LongField4 Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.LongField4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LongField4 { get; set; }
Visual Basic (Declaration)
Public Property LongField4 As Integer
Visual C++
public:
property int LongField4 {
    int get ();
    void set (int value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Port Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.Port Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.Port"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Port { get; set; }
Visual Basic (Declaration)
Public Property Port As String
Visual C++
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TransportParams Property

[image]

Enterprise SDK 8.0 Reference API
CfgPortInfoEx..::.TransportParams Property
CfgPortInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgPortInfoEx.TransportParams"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string TransportParams { get; set; }
Visual Basic (Declaration)
Public Property TransportParams As String
Visual C++
public:
property String^ TransportParams {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPortInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRemovalEventEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRemovalEventEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRemovalEventEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgRemovalEventEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgRemovalEventEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgRemovalEventEx

See Also

CfgRemovalEventEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRemovalEventEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx Members
CfgRemovalEventEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgRemovalEventEx type exposes the following members.

Constructors

Name | Description
CfgRemovalEventEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
LogEventID |
ParentDBID | (Inherited from CfgStructureEx.)
SelectionMode |

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRemovalEventEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx Constructor
CfgRemovalEventEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRemovalEventEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRemovalEventEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgRemovalEventEx()

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRemovalEventEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx Fields
CfgRemovalEventEx Class See Also Send Feedback

The CfgRemovalEventEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRemovalEventEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx Methods
CfgRemovalEventEx Class See Also Send Feedback

The CfgRemovalEventEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRemovalEventEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx Properties
CfgRemovalEventEx Class See Also Send Feedback

The CfgRemovalEventEx type exposes the following members.

Properties

Name | Description
LogEventID |
ParentDBID | (Inherited from CfgStructureEx.)
SelectionMode |

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LogEventID Property

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx..::.LogEventID Property
CfgRemovalEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRemovalEventEx.LogEventID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int LogEventID { get; set; }
Visual Basic (Declaration)
Public Property LogEventID As Integer
Visual C++
public:
property int LogEventID {
    int get ();
    void set (int value);
}

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SelectionMode Property

[image]

Enterprise SDK 8.0 Reference API
CfgRemovalEventEx..::.SelectionMode Property
CfgRemovalEventEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRemovalEventEx.SelectionMode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As CfgSelectionMode
Visual C++
public:
property CfgSelectionMode SelectionMode {
    CfgSelectionMode get ();
    void set (CfgSelectionMode value);
}

See Also

CfgRemovalEventEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgResourceIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgResourceIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgResourceIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgResourceIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgResourceIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgResourceIDEx

See Also

CfgResourceIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgResourceIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx Members
CfgResourceIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgResourceIDEx type exposes the following members.

Constructors

Name | Description
CfgResourceIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgResourceIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx Constructor
CfgResourceIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgResourceIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgResourceIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgResourceIDEx()

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgResourceIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx Fields
CfgResourceIDEx Class See Also Send Feedback

The CfgResourceIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgResourceIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx Methods
CfgResourceIDEx Class See Also Send Feedback

The CfgResourceIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgResourceIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx Properties
CfgResourceIDEx Class See Also Send Feedback

The CfgResourceIDEx type exposes the following members.

Properties

Name | Description
DBID |
ParentDBID | (Inherited from CfgStructureEx.)
Type |

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx..::.DBID Property
CfgResourceIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgResourceIDEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgResourceIDEx..::.Type Property
CfgResourceIDEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgResourceIDEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgObjectType
Visual C++
public:
property CfgObjectType Type {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgResourceIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRoleEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgRoleEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgRoleEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgRoleEx

See Also

CfgRoleEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleEx Members
CfgRoleEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgRoleEx type exposes the following members.

Constructors

Name | Description
CfgRoleEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Members |
Name |
State |
Tenant |
UserProperties |

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx Constructor
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRoleEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgRoleEx()

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleEx Fields
CfgRoleEx Class See Also Send Feedback

The CfgRoleEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleEx Methods
CfgRoleEx Class See Also Send Feedback

The CfgRoleEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleEx Properties
CfgRoleEx Class See Also Send Feedback

The CfgRoleEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Members |
Name |
State |
Tenant |
UserProperties |

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.DBID Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.Description Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Members Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.Members Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.Members"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgRoleMemberEx> Members { get; set; }
Visual Basic (Declaration)
Public Property Members As List(Of CfgRoleMemberEx)
Visual C++
public:
property List<CfgRoleMemberEx^>^ Members {
    List<CfgRoleMemberEx^>^ get ();
    void set (List<CfgRoleMemberEx^>^ value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.Name Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.State Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.Tenant Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleEx..::.UserProperties Property
CfgRoleEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgRoleEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleMemberEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleMemberEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgRoleMemberEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgRoleMemberEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgRoleMemberEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgRoleMemberEx

See Also

CfgRoleMemberEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleMemberEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx Members
CfgRoleMemberEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgRoleMemberEx type exposes the following members.

Constructors

Name | Description
CfgRoleMemberEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ObjectDBID |
ObjectType |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleMemberEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx Constructor
CfgRoleMemberEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleMemberEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRoleMemberEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgRoleMemberEx()

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleMemberEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx Fields
CfgRoleMemberEx Class See Also Send Feedback

The CfgRoleMemberEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleMemberEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx Methods
CfgRoleMemberEx Class See Also Send Feedback

The CfgRoleMemberEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgRoleMemberEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx Properties
CfgRoleMemberEx Class See Also Send Feedback

The CfgRoleMemberEx type exposes the following members.

Properties

Name | Description
ObjectDBID |
ObjectType |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectDBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx..::.ObjectDBID Property
CfgRoleMemberEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleMemberEx.ObjectDBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectDBID { get; set; }
Visual Basic (Declaration)
Public Property ObjectDBID As Integer
Visual C++
public:
property int ObjectDBID {
    int get ();
    void set (int value);
}

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgRoleMemberEx..::.ObjectType Property
CfgRoleMemberEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgRoleMemberEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As CfgObjectType
Visual C++
public:
property CfgObjectType ObjectType {
    CfgObjectType get ();
    void set (CfgObjectType value);
}

See Also

CfgRoleMemberEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScheduledTaskEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScheduledTaskEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgScheduledTaskEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgScheduledTaskEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgScheduledTaskEx

See Also

CfgScheduledTaskEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScheduledTaskEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx Members
CfgScheduledTaskEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgScheduledTaskEx type exposes the following members.

Constructors

Name | Description
CfgScheduledTaskEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
Resources |
StartTime |
State |
Type |
UserProperties |

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScheduledTaskEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx Constructor
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScheduledTaskEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgScheduledTaskEx()

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScheduledTaskEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx Fields
CfgScheduledTaskEx Class See Also Send Feedback

The CfgScheduledTaskEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScheduledTaskEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx Methods
CfgScheduledTaskEx Class See Also Send Feedback

The CfgScheduledTaskEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScheduledTaskEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx Properties
CfgScheduledTaskEx Class See Also Send Feedback

The CfgScheduledTaskEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
Resources |
StartTime |
State |
Type |
UserProperties |

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.DBID Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.Description Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.Name Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.Resources Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.StartTime Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.StartTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As Integer
Visual C++
public:
property int StartTime {
    int get ();
    void set (int value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.State Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.Type Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTaskType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgTaskType
Visual C++
public:
property CfgTaskType Type {
    CfgTaskType get ();
    void set (CfgTaskType value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskEx..::.UserProperties Property
CfgScheduledTaskEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScheduledTaskEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgScheduledTaskEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScriptEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScriptEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgScriptEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgScriptEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgScriptEx

See Also

CfgScriptEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScriptEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptEx Members
CfgScriptEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgScriptEx type exposes the following members.

Constructors

Name | Description
CfgScriptEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Index |
Name |
Resources |
State |
Tenant |
Type |
UserProperties |

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScriptEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx Constructor
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScriptEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgScriptEx()

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScriptEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptEx Fields
CfgScriptEx Class See Also Send Feedback

The CfgScriptEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScriptEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptEx Methods
CfgScriptEx Class See Also Send Feedback

The CfgScriptEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgScriptEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptEx Properties
CfgScriptEx Class See Also Send Feedback

The CfgScriptEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Index |
Name |
Resources |
State |
Tenant |
Type |
UserProperties |

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.DBID Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Index Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.Index Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.Index"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.Name Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.Resources Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.State Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.Tenant Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.Type Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScriptType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgScriptType
Visual C++
public:
property CfgScriptType Type {
    CfgScriptType get ();
    void set (CfgScriptType value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptEx..::.UserProperties Property
CfgScriptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgScriptEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgScriptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgServerEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgServerEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServerEx

See Also

CfgServerEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerEx Members
CfgServerEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServerEx type exposes the following members.

Constructors

Name | Description
CfgServerEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Attempts |
BackupServer |
Host |
ParentDBID | (Inherited from CfgStructureEx.)
Port |
Timeout |

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx Constructor
CfgServerEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServerEx()

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerEx Fields
CfgServerEx Class See Also Send Feedback

The CfgServerEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerEx Methods
CfgServerEx Class See Also Send Feedback

The CfgServerEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerEx Properties
CfgServerEx Class See Also Send Feedback

The CfgServerEx type exposes the following members.

Properties

Name | Description
Attempts |
BackupServer |
Host |
ParentDBID | (Inherited from CfgStructureEx.)
Port |
Timeout |

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Attempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx..::.Attempts Property
CfgServerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx.Attempts"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Attempts { get; set; }
Visual Basic (Declaration)
Public Property Attempts As Integer
Visual C++
public:
property int Attempts {
    int get ();
    void set (int value);
}

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


BackupServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx..::.BackupServer Property
CfgServerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx.BackupServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int BackupServer { get; set; }
Visual Basic (Declaration)
Public Property BackupServer As Integer
Visual C++
public:
property int BackupServer {
    int get ();
    void set (int value);
}

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Host Property

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx..::.Host Property
CfgServerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx.Host"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Host { get; set; }
Visual Basic (Declaration)
Public Property Host As Integer
Visual C++
public:
property int Host {
    int get ();
    void set (int value);
}

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Port Property

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx..::.Port Property
CfgServerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx.Port"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Port { get; set; }
Visual Basic (Declaration)
Public Property Port As String
Visual C++
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Timeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgServerEx..::.Timeout Property
CfgServerEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerEx.Timeout"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Timeout { get; set; }
Visual Basic (Declaration)
Public Property Timeout As Integer
Visual C++
public:
property int Timeout {
    int get ();
    void set (int value);
}

See Also

CfgServerEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerHostIDEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerHostIDEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerHostIDEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgServerHostIDEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgServerHostIDEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServerHostIDEx

See Also

CfgServerHostIDEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerHostIDEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDEx Members
CfgServerHostIDEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServerHostIDEx type exposes the following members.

Constructors

Name | Description
CfgServerHostIDEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgServerHostIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerHostIDEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDEx Constructor
CfgServerHostIDEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerHostIDEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerHostIDEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServerHostIDEx()

See Also

CfgServerHostIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerHostIDEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDEx Fields
CfgServerHostIDEx Class See Also Send Feedback

The CfgServerHostIDEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgServerHostIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerHostIDEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDEx Methods
CfgServerHostIDEx Class See Also Send Feedback

The CfgServerHostIDEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgServerHostIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerHostIDEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerHostIDEx Properties
CfgServerHostIDEx Class See Also Send Feedback

The CfgServerHostIDEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgServerHostIDEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerVersionEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgServerVersionEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerVersionEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServerVersionEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgServerVersionEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgServerVersionEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServerVersionEx

See Also

CfgServerVersionEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerVersionEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionEx Members
CfgServerVersionEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServerVersionEx type exposes the following members.

Constructors

Name | Description
CfgServerVersionEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgServerVersionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerVersionEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServerVersionEx Constructor
CfgServerVersionEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServerVersionEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServerVersionEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServerVersionEx()

See Also

CfgServerVersionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerVersionEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionEx Fields
CfgServerVersionEx Class See Also Send Feedback

The CfgServerVersionEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgServerVersionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerVersionEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionEx Methods
CfgServerVersionEx Class See Also Send Feedback

The CfgServerVersionEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgServerVersionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServerVersionEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServerVersionEx Properties
CfgServerVersionEx Class See Also Send Feedback

The CfgServerVersionEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgServerVersionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServiceEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgServiceEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgServiceEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServiceEx

See Also

CfgServiceEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceEx Members
CfgServiceEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServiceEx type exposes the following members.

Constructors

Name | Description
CfgServiceEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AssignedTenant |
CfgObjectType | (Inherited from CfgObjectEx.)
ComponentDefinitions |
Components |
DBID |
Name |
Resources |
SCS |
SolutionType |
StartupType |
State |
UserProperties |
Version |

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx Constructor
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServiceEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServiceEx()

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceEx Fields
CfgServiceEx Class See Also Send Feedback

The CfgServiceEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceEx Methods
CfgServiceEx Class See Also Send Feedback

The CfgServiceEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceEx Properties
CfgServiceEx Class See Also Send Feedback

The CfgServiceEx type exposes the following members.

Properties

Name | Description
AssignedTenant |
CfgObjectType | (Inherited from CfgObjectEx.)
ComponentDefinitions |
Components |
DBID |
Name |
Resources |
SCS |
SolutionType |
StartupType |
State |
UserProperties |
Version |

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AssignedTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.AssignedTenant Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.AssignedTenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AssignedTenant { get; set; }
Visual Basic (Declaration)
Public Property AssignedTenant As Integer
Visual C++
public:
property int AssignedTenant {
    int get ();
    void set (int value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ComponentDefinitions Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.ComponentDefinitions Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.ComponentDefinitions"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgSolutionComponentDefinitionEx> ComponentDefinitions { get; set; }
Visual Basic (Declaration)
Public Property ComponentDefinitions As List(Of CfgSolutionComponentDefinitionEx)
Visual C++
public:
property List<CfgSolutionComponentDefinitionEx^>^ ComponentDefinitions {
    List<CfgSolutionComponentDefinitionEx^>^ get ();
    void set (List<CfgSolutionComponentDefinitionEx^>^ value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Components Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.Components Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.Components"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgSolutionComponentEx> Components { get; set; }
Visual Basic (Declaration)
Public Property Components As List(Of CfgSolutionComponentEx)
Visual C++
public:
property List<CfgSolutionComponentEx^>^ Components {
    List<CfgSolutionComponentEx^>^ get ();
    void set (List<CfgSolutionComponentEx^>^ value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.DBID Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.Name Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Resources Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.Resources Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.Resources"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgObjectResourceEx> Resources { get; set; }
Visual Basic (Declaration)
Public Property Resources As List(Of CfgObjectResourceEx)
Visual C++
public:
property List<CfgObjectResourceEx^>^ Resources {
    List<CfgObjectResourceEx^>^ get ();
    void set (List<CfgObjectResourceEx^>^ value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SCS Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.SCS Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.SCS"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int SCS { get; set; }
Visual Basic (Declaration)
Public Property SCS As Integer
Visual C++
public:
property int SCS {
    int get ();
    void set (int value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SolutionType Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.SolutionType Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.SolutionType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionType SolutionType { get; set; }
Visual Basic (Declaration)
Public Property SolutionType As CfgSolutionType
Visual C++
public:
property CfgSolutionType SolutionType {
    CfgSolutionType get ();
    void set (CfgSolutionType value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.StartupType Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.StartupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStartupType StartupType { get; set; }
Visual Basic (Declaration)
Public Property StartupType As CfgStartupType
Visual C++
public:
property CfgStartupType StartupType {
    CfgStartupType get ();
    void set (CfgStartupType value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.State Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.UserProperties Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceEx..::.Version Property
CfgServiceEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceEx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgServiceEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceInfoEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceInfoEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServiceInfoEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgServiceInfoEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgServiceInfoEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgServiceInfoEx

See Also

CfgServiceInfoEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceInfoEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoEx Members
CfgServiceInfoEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgServiceInfoEx type exposes the following members.

Constructors

Name | Description
CfgServiceInfoEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgServiceInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceInfoEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoEx Constructor
CfgServiceInfoEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgServiceInfoEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServiceInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServiceInfoEx()

See Also

CfgServiceInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceInfoEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoEx Fields
CfgServiceInfoEx Class See Also Send Feedback

The CfgServiceInfoEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgServiceInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceInfoEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoEx Methods
CfgServiceInfoEx Class See Also Send Feedback

The CfgServiceInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgServiceInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgServiceInfoEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceInfoEx Properties
CfgServiceInfoEx Class See Also Send Feedback

The CfgServiceInfoEx type exposes the following members.

Properties

Name | Description
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgServiceInfoEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkillEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgSkillEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgSkillEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSkillEx

See Also

CfgSkillEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillEx Members
CfgSkillEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSkillEx type exposes the following members.

Constructors

Name | Description
CfgSkillEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Name |
State |
Tenant |
UserProperties |

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx Constructor
CfgSkillEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkillEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSkillEx()

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillEx Fields
CfgSkillEx Class See Also Send Feedback

The CfgSkillEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillEx Methods
CfgSkillEx Class See Also Send Feedback

The CfgSkillEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillEx Properties
CfgSkillEx Class See Also Send Feedback

The CfgSkillEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Name |
State |
Tenant |
UserProperties |

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx..::.DBID Property
CfgSkillEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx..::.Name Property
CfgSkillEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx..::.State Property
CfgSkillEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx..::.Tenant Property
CfgSkillEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillEx..::.UserProperties Property
CfgSkillEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgSkillEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillLevelEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillLevelEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkillLevelEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgSkillLevelEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgSkillLevelEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSkillLevelEx

See Also

CfgSkillLevelEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillLevelEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx Members
CfgSkillLevelEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSkillLevelEx type exposes the following members.

Constructors

Name | Description
CfgSkillLevelEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Level |
ParentDBID | (Inherited from CfgStructureEx.)
Skill |

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillLevelEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx Constructor
CfgSkillLevelEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillLevelEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkillLevelEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSkillLevelEx()

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillLevelEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx Fields
CfgSkillLevelEx Class See Also Send Feedback

The CfgSkillLevelEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillLevelEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx Methods
CfgSkillLevelEx Class See Also Send Feedback

The CfgSkillLevelEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSkillLevelEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx Properties
CfgSkillLevelEx Class See Also Send Feedback

The CfgSkillLevelEx type exposes the following members.

Properties

Name | Description
Level |
ParentDBID | (Inherited from CfgStructureEx.)
Skill |

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Level Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx..::.Level Property
CfgSkillLevelEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillLevelEx.Level"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Skill Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillLevelEx..::.Skill Property
CfgSkillLevelEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSkillLevelEx.Skill"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Skill { get; set; }
Visual Basic (Declaration)
Public Property Skill As Integer
Visual C++
public:
property int Skill {
    int get ();
    void set (int value);
}

See Also

CfgSkillLevelEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentDefinitionEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentDefinitionEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSolutionComponentDefinitionEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgSolutionComponentDefinitionEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgSolutionComponentDefinitionEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSolutionComponentDefinitionEx

See Also

CfgSolutionComponentDefinitionEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentDefinitionEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx Members
CfgSolutionComponentDefinitionEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSolutionComponentDefinitionEx type exposes the following members.

Constructors

Name | Description
CfgSolutionComponentDefinitionEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
IsOptional |
ParentDBID | (Inherited from CfgStructureEx.)
StartupPriority |
Type |
Version |

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentDefinitionEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx Constructor
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentDefinitionEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionComponentDefinitionEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSolutionComponentDefinitionEx()

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentDefinitionEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx Fields
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

The CfgSolutionComponentDefinitionEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentDefinitionEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx Methods
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

The CfgSolutionComponentDefinitionEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentDefinitionEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx Properties
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

The CfgSolutionComponentDefinitionEx type exposes the following members.

Properties

Name | Description
IsOptional |
ParentDBID | (Inherited from CfgStructureEx.)
StartupPriority |
Type |
Version |

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsOptional Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx..::.IsOptional Property
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentDefinitionEx.IsOptional"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsOptional { get; set; }
Visual Basic (Declaration)
Public Property IsOptional As CfgFlag
Visual C++
public:
property CfgFlag IsOptional {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartupPriority Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx..::.StartupPriority Property
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentDefinitionEx.StartupPriority"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupPriority { get; set; }
Visual Basic (Declaration)
Public Property StartupPriority As Integer
Visual C++
public:
property int StartupPriority {
    int get ();
    void set (int value);
}

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx..::.Type Property
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentDefinitionEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgAppType
Visual C++
public:
property CfgAppType Type {
    CfgAppType get ();
    void set (CfgAppType value);
}

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentDefinitionEx..::.Version Property
CfgSolutionComponentDefinitionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentDefinitionEx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSolutionComponentDefinitionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSolutionComponentEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgSolutionComponentEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgSolutionComponentEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSolutionComponentEx

See Also

CfgSolutionComponentEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx Members
CfgSolutionComponentEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSolutionComponentEx type exposes the following members.

Constructors

Name | Description
CfgSolutionComponentEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
App |
IsOptional |
ParentDBID | (Inherited from CfgStructureEx.)
StartupPriority |

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx Constructor
CfgSolutionComponentEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSolutionComponentEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSolutionComponentEx()

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx Fields
CfgSolutionComponentEx Class See Also Send Feedback

The CfgSolutionComponentEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx Methods
CfgSolutionComponentEx Class See Also Send Feedback

The CfgSolutionComponentEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSolutionComponentEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx Properties
CfgSolutionComponentEx Class See Also Send Feedback

The CfgSolutionComponentEx type exposes the following members.

Properties

Name | Description
App |
IsOptional |
ParentDBID | (Inherited from CfgStructureEx.)
StartupPriority |

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


App Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx..::.App Property
CfgSolutionComponentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentEx.App"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int App { get; set; }
Visual Basic (Declaration)
Public Property App As Integer
Visual C++
public:
property int App {
    int get ();
    void set (int value);
}

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsOptional Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx..::.IsOptional Property
CfgSolutionComponentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentEx.IsOptional"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsOptional { get; set; }
Visual Basic (Declaration)
Public Property IsOptional As CfgFlag
Visual C++
public:
property CfgFlag IsOptional {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartupPriority Property

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionComponentEx..::.StartupPriority Property
CfgSolutionComponentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSolutionComponentEx.StartupPriority"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartupPriority { get; set; }
Visual Basic (Declaration)
Public Property StartupPriority As Integer
Visual C++
public:
property int StartupPriority {
    int get ();
    void set (int value);
}

See Also

CfgSolutionComponentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatDayEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatDayEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgStatDayEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgStatDayEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgStatDayEx

See Also

CfgStatDayEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatDayEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx Members
CfgStatDayEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgStatDayEx type exposes the following members.

Constructors

Name | Description
CfgStatDayEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Date |
Day |
DBID |
EndTime |
FlatRate |
IntervalLength |
IsDayOfWeek |
MaxValue |
MinValue |
Name |
StartTime |
State |
StatIntervals |
TargetValue |
Tenant |
Type |
UseFlatRate |
UserProperties |

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatDayEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx Constructor
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDayEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatDayEx()

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatDayEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx Fields
CfgStatDayEx Class See Also Send Feedback

The CfgStatDayEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatDayEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx Methods
CfgStatDayEx Class See Also Send Feedback

The CfgStatDayEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatDayEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx Properties
CfgStatDayEx Class See Also Send Feedback

The CfgStatDayEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
Date |
Day |
DBID |
EndTime |
FlatRate |
IntervalLength |
IsDayOfWeek |
MaxValue |
MinValue |
Name |
StartTime |
State |
StatIntervals |
TargetValue |
Tenant |
Type |
UseFlatRate |
UserProperties |

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Date Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.Date Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.Date"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic (Declaration)
Public Property Date As DateTime
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Day Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.Day Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.Day"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Day { get; set; }
Visual Basic (Declaration)
Public Property Day As Integer
Visual C++
public:
property int Day {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.DBID Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


EndTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.EndTime Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.EndTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int EndTime { get; set; }
Visual Basic (Declaration)
Public Property EndTime As Integer
Visual C++
public:
property int EndTime {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


FlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.FlatRate Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.FlatRate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FlatRate { get; set; }
Visual Basic (Declaration)
Public Property FlatRate As Integer
Visual C++
public:
property int FlatRate {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IntervalLength Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.IntervalLength Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.IntervalLength"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IntervalLength { get; set; }
Visual Basic (Declaration)
Public Property IntervalLength As Integer
Visual C++
public:
property int IntervalLength {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsDayOfWeek Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.IsDayOfWeek Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.IsDayOfWeek"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDayOfWeek { get; set; }
Visual Basic (Declaration)
Public Property IsDayOfWeek As CfgFlag
Visual C++
public:
property CfgFlag IsDayOfWeek {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MaxValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.MaxValue Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.MaxValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MaxValue { get; set; }
Visual Basic (Declaration)
Public Property MaxValue As Integer
Visual C++
public:
property int MaxValue {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


MinValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.MinValue Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.MinValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int MinValue { get; set; }
Visual Basic (Declaration)
Public Property MinValue As Integer
Visual C++
public:
property int MinValue {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.Name Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StartTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.StartTime Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.StartTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As Integer
Visual C++
public:
property int StartTime {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.State Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatIntervals Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.StatIntervals Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.StatIntervals"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgStatIntervalEx> StatIntervals { get; set; }
Visual Basic (Declaration)
Public Property StatIntervals As List(Of CfgStatIntervalEx)
Visual C++
public:
property List<CfgStatIntervalEx^>^ StatIntervals {
    List<CfgStatIntervalEx^>^ get ();
    void set (List<CfgStatIntervalEx^>^ value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TargetValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.TargetValue Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.TargetValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TargetValue { get; set; }
Visual Basic (Declaration)
Public Property TargetValue As Integer
Visual C++
public:
property int TargetValue {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.Tenant Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.Type Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDayType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgStatDayType
Visual C++
public:
property CfgStatDayType Type {
    CfgStatDayType get ();
    void set (CfgStatDayType value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UseFlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.UseFlatRate Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.UseFlatRate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseFlatRate { get; set; }
Visual Basic (Declaration)
Public Property UseFlatRate As CfgFlag
Visual C++
public:
property CfgFlag UseFlatRate {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayEx..::.UserProperties Property
CfgStatDayEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatDayEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgStatDayEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatIntervalEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatIntervalEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgStatIntervalEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgStatIntervalEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgStatIntervalEx

See Also

CfgStatIntervalEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatIntervalEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx Members
CfgStatIntervalEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgStatIntervalEx type exposes the following members.

Constructors

Name | Description
CfgStatIntervalEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
IntervalCount |
ParentDBID | (Inherited from CfgStructureEx.)
StatValue1 |
StatValue2 |
StatValue3 |
StatValue4 |

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatIntervalEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx Constructor
CfgStatIntervalEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatIntervalEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatIntervalEx()

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatIntervalEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx Fields
CfgStatIntervalEx Class See Also Send Feedback

The CfgStatIntervalEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatIntervalEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx Methods
CfgStatIntervalEx Class See Also Send Feedback

The CfgStatIntervalEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatIntervalEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx Properties
CfgStatIntervalEx Class See Also Send Feedback

The CfgStatIntervalEx type exposes the following members.

Properties

Name | Description
IntervalCount |
ParentDBID | (Inherited from CfgStructureEx.)
StatValue1 |
StatValue2 |
StatValue3 |
StatValue4 |

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IntervalCount Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx..::.IntervalCount Property
CfgStatIntervalEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx.IntervalCount"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int IntervalCount { get; set; }
Visual Basic (Declaration)
Public Property IntervalCount As Integer
Visual C++
public:
property int IntervalCount {
    int get ();
    void set (int value);
}

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatValue1 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx..::.StatValue1 Property
CfgStatIntervalEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx.StatValue1"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue1 { get; set; }
Visual Basic (Declaration)
Public Property StatValue1 As Integer
Visual C++
public:
property int StatValue1 {
    int get ();
    void set (int value);
}

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatValue2 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx..::.StatValue2 Property
CfgStatIntervalEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx.StatValue2"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue2 { get; set; }
Visual Basic (Declaration)
Public Property StatValue2 As Integer
Visual C++
public:
property int StatValue2 {
    int get ();
    void set (int value);
}

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatValue3 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx..::.StatValue3 Property
CfgStatIntervalEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx.StatValue3"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue3 { get; set; }
Visual Basic (Declaration)
Public Property StatValue3 As Integer
Visual C++
public:
property int StatValue3 {
    int get ();
    void set (int value);
}

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatValue4 Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatIntervalEx..::.StatValue4 Property
CfgStatIntervalEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatIntervalEx.StatValue4"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int StatValue4 { get; set; }
Visual Basic (Declaration)
Public Property StatValue4 As Integer
Visual C++
public:
property int StatValue4 {
    int get ();
    void set (int value);
}

See Also

CfgStatIntervalEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatTableEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatTableEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgStatTableEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgStatTableEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgStatTableEx

See Also

CfgStatTableEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatTableEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx Members
CfgStatTableEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgStatTableEx type exposes the following members.

Constructors

Name | Description
CfgStatTableEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AgentHourlyRate |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
FlatRate |
Name |
StatDays |
State |
Tenant |
Type |
UseFlatRate |
UserProperties |
WaitThreshold |

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatTableEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx Constructor
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTableEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatTableEx()

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatTableEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx Fields
CfgStatTableEx Class See Also Send Feedback

The CfgStatTableEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatTableEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx Methods
CfgStatTableEx Class See Also Send Feedback

The CfgStatTableEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgStatTableEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx Properties
CfgStatTableEx Class See Also Send Feedback

The CfgStatTableEx type exposes the following members.

Properties

Name | Description
AgentHourlyRate |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
FlatRate |
Name |
StatDays |
State |
Tenant |
Type |
UseFlatRate |
UserProperties |
WaitThreshold |

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AgentHourlyRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.AgentHourlyRate Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.AgentHourlyRate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int AgentHourlyRate { get; set; }
Visual Basic (Declaration)
Public Property AgentHourlyRate As Integer
Visual C++
public:
property int AgentHourlyRate {
    int get ();
    void set (int value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.DBID Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


FlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.FlatRate Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.FlatRate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int FlatRate { get; set; }
Visual Basic (Declaration)
Public Property FlatRate As Integer
Visual C++
public:
property int FlatRate {
    int get ();
    void set (int value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.Name Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


StatDays Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.StatDays Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.StatDays"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<int> StatDays { get; set; }
Visual Basic (Declaration)
Public Property StatDays As List(Of Integer)
Visual C++
public:
property List<int>^ StatDays {
    List<int>^ get ();
    void set (List<int>^ value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.State Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.Tenant Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.Type Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTableType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgStatTableType
Visual C++
public:
property CfgStatTableType Type {
    CfgStatTableType get ();
    void set (CfgStatTableType value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UseFlatRate Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.UseFlatRate Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.UseFlatRate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag UseFlatRate { get; set; }
Visual Basic (Declaration)
Public Property UseFlatRate As CfgFlag
Visual C++
public:
property CfgFlag UseFlatRate {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.UserProperties Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


WaitThreshold Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableEx..::.WaitThreshold Property
CfgStatTableEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgStatTableEx.WaitThreshold"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int WaitThreshold { get; set; }
Visual Basic (Declaration)
Public Property WaitThreshold As Integer
Visual C++
public:
property int WaitThreshold {
    int get ();
    void set (int value);
}

See Also

CfgStatTableEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSubcodeEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSubcodeEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSubcodeEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgSubcodeEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgSubcodeEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSubcodeEx

See Also

CfgSubcodeEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSubcodeEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx Members
CfgSubcodeEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSubcodeEx type exposes the following members.

Constructors

Name | Description
CfgSubcodeEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Code |
Name |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSubcodeEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx Constructor
CfgSubcodeEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSubcodeEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSubcodeEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSubcodeEx()

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSubcodeEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx Fields
CfgSubcodeEx Class See Also Send Feedback

The CfgSubcodeEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSubcodeEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx Methods
CfgSubcodeEx Class See Also Send Feedback

The CfgSubcodeEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSubcodeEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx Properties
CfgSubcodeEx Class See Also Send Feedback

The CfgSubcodeEx type exposes the following members.

Properties

Name | Description
Code |
Name |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Code Property

[image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx..::.Code Property
CfgSubcodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSubcodeEx.Code"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSubcodeEx..::.Name Property
CfgSubcodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSubcodeEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSubcodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchAccessCodeEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitchAccessCodeEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgSwitchAccessCodeEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgSwitchAccessCodeEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSwitchAccessCodeEx

See Also

CfgSwitchAccessCodeEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchAccessCodeEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx Members
CfgSwitchAccessCodeEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSwitchAccessCodeEx type exposes the following members.

Constructors

Name | Description
CfgSwitchAccessCodeEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
AccessCode |
DestinationSource |
DnisSource |
DnSource |
ExtensionSource |
LocationSource |
ParentDBID | (Inherited from CfgStructureEx.)
ReasonSource |
RouteType |
Switch |
TargetType |

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchAccessCodeEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx Constructor
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchAccessCodeEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSwitchAccessCodeEx()

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchAccessCodeEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx Fields
CfgSwitchAccessCodeEx Class See Also Send Feedback

The CfgSwitchAccessCodeEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchAccessCodeEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx Methods
CfgSwitchAccessCodeEx Class See Also Send Feedback

The CfgSwitchAccessCodeEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchAccessCodeEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx Properties
CfgSwitchAccessCodeEx Class See Also Send Feedback

The CfgSwitchAccessCodeEx type exposes the following members.

Properties

Name | Description
AccessCode |
DestinationSource |
DnisSource |
DnSource |
ExtensionSource |
LocationSource |
ParentDBID | (Inherited from CfgStructureEx.)
ReasonSource |
RouteType |
Switch |
TargetType |

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


AccessCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.AccessCode Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.AccessCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string AccessCode { get; set; }
Visual Basic (Declaration)
Public Property AccessCode As String
Visual C++
public:
property String^ AccessCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DestinationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.DestinationSource Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.DestinationSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DestinationSource { get; set; }
Visual Basic (Declaration)
Public Property DestinationSource As String
Visual C++
public:
property String^ DestinationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DnisSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.DnisSource Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.DnisSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnisSource { get; set; }
Visual Basic (Declaration)
Public Property DnisSource As String
Visual C++
public:
property String^ DnisSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DnSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.DnSource Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.DnSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnSource { get; set; }
Visual Basic (Declaration)
Public Property DnSource As String
Visual C++
public:
property String^ DnSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ExtensionSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.ExtensionSource Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.ExtensionSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ExtensionSource { get; set; }
Visual Basic (Declaration)
Public Property ExtensionSource As String
Visual C++
public:
property String^ ExtensionSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LocationSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.LocationSource Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.LocationSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LocationSource { get; set; }
Visual Basic (Declaration)
Public Property LocationSource As String
Visual C++
public:
property String^ LocationSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ReasonSource Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.ReasonSource Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.ReasonSource"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ReasonSource { get; set; }
Visual Basic (Declaration)
Public Property ReasonSource As String
Visual C++
public:
property String^ ReasonSource {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RouteType Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.RouteType Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.RouteType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRouteType RouteType { get; set; }
Visual Basic (Declaration)
Public Property RouteType As CfgRouteType
Visual C++
public:
property CfgRouteType RouteType {
    CfgRouteType get ();
    void set (CfgRouteType value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.Switch Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As Integer
Visual C++
public:
property int Switch {
    int get ();
    void set (int value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TargetType Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchAccessCodeEx..::.TargetType Property
CfgSwitchAccessCodeEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchAccessCodeEx.TargetType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTargetType TargetType { get; set; }
Visual Basic (Declaration)
Public Property TargetType As CfgTargetType
Visual C++
public:
property CfgTargetType TargetType {
    CfgTargetType get ();
    void set (CfgTargetType value);
}

See Also

CfgSwitchAccessCodeEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitchEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgSwitchEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgSwitchEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgSwitchEx

See Also

CfgSwitchEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx Members
CfgSwitchEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgSwitchEx type exposes the following members.

Constructors

Name | Description
CfgSwitchEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DNRange |
LinkType |
Name |
PhysSwitch |
State |
SwitchAccessCodes |
Tenant |
TServer |
Type |
UserProperties |

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx Constructor
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSwitchEx()

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx Fields
CfgSwitchEx Class See Also Send Feedback

The CfgSwitchEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx Methods
CfgSwitchEx Class See Also Send Feedback

The CfgSwitchEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgSwitchEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx Properties
CfgSwitchEx Class See Also Send Feedback

The CfgSwitchEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
DNRange |
LinkType |
Name |
PhysSwitch |
State |
SwitchAccessCodes |
Tenant |
TServer |
Type |
UserProperties |

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.DBID Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DNRange Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.DNRange Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.DNRange"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DNRange { get; set; }
Visual Basic (Declaration)
Public Property DNRange As String
Visual C++
public:
property String^ DNRange {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


LinkType Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.LinkType Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.LinkType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgLinkType LinkType { get; set; }
Visual Basic (Declaration)
Public Property LinkType As CfgLinkType
Visual C++
public:
property CfgLinkType LinkType {
    CfgLinkType get ();
    void set (CfgLinkType value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.Name Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PhysSwitch Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.PhysSwitch Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.PhysSwitch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int PhysSwitch { get; set; }
Visual Basic (Declaration)
Public Property PhysSwitch As Integer
Visual C++
public:
property int PhysSwitch {
    int get ();
    void set (int value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.State Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


SwitchAccessCodes Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.SwitchAccessCodes Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.SwitchAccessCodes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public List<CfgSwitchAccessCodeEx> SwitchAccessCodes { get; set; }
Visual Basic (Declaration)
Public Property SwitchAccessCodes As List(Of CfgSwitchAccessCodeEx)
Visual C++
public:
property List<CfgSwitchAccessCodeEx^>^ SwitchAccessCodes {
    List<CfgSwitchAccessCodeEx^>^ get ();
    void set (List<CfgSwitchAccessCodeEx^>^ value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.Tenant Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


TServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.TServer Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.TServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int TServer { get; set; }
Visual Basic (Declaration)
Public Property TServer As Integer
Visual C++
public:
property int TServer {
    int get ();
    void set (int value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.Type Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgSwitchType
Visual C++
public:
property CfgSwitchType Type {
    CfgSwitchType get ();
    void set (CfgSwitchType value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchEx..::.UserProperties Property
CfgSwitchEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgSwitchEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgSwitchEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTableAccessEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTableAccessEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgTableAccessEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgTableAccessEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTableAccessEx

See Also

CfgTableAccessEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTableAccessEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx Members
CfgTableAccessEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTableAccessEx type exposes the following members.

Constructors

Name | Description
CfgTableAccessEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DbAccess |
DBID |
DbTableName |
Description |
Format |
IsCachable |
Name |
State |
Tenant |
Type |
UpdateTimeout |
UserProperties |

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTableAccessEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx Constructor
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccessEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTableAccessEx()

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTableAccessEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx Fields
CfgTableAccessEx Class See Also Send Feedback

The CfgTableAccessEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTableAccessEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx Methods
CfgTableAccessEx Class See Also Send Feedback

The CfgTableAccessEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTableAccessEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx Properties
CfgTableAccessEx Class See Also Send Feedback

The CfgTableAccessEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DbAccess |
DBID |
DbTableName |
Description |
Format |
IsCachable |
Name |
State |
Tenant |
Type |
UpdateTimeout |
UserProperties |

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DbAccess Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.DbAccess Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.DbAccess"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DbAccess { get; set; }
Visual Basic (Declaration)
Public Property DbAccess As Integer
Visual C++
public:
property int DbAccess {
    int get ();
    void set (int value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.DBID Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DbTableName Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.DbTableName Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.DbTableName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DbTableName { get; set; }
Visual Basic (Declaration)
Public Property DbTableName As String
Visual C++
public:
property String^ DbTableName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.Description Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Format Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.Format Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.Format"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Format { get; set; }
Visual Basic (Declaration)
Public Property Format As Integer
Visual C++
public:
property int Format {
    int get ();
    void set (int value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsCachable Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.IsCachable Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.IsCachable"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsCachable { get; set; }
Visual Basic (Declaration)
Public Property IsCachable As CfgFlag
Visual C++
public:
property CfgFlag IsCachable {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.Name Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.State Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.Tenant Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.Type Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgTableType
Visual C++
public:
property CfgTableType Type {
    CfgTableType get ();
    void set (CfgTableType value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UpdateTimeout Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.UpdateTimeout Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.UpdateTimeout"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int UpdateTimeout { get; set; }
Visual Basic (Declaration)
Public Property UpdateTimeout As Integer
Visual C++
public:
property int UpdateTimeout {
    int get ();
    void set (int value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessEx..::.UserProperties Property
CfgTableAccessEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTableAccessEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTableAccessEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTenantEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTenantEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgTenantEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgTenantEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTenantEx

See Also

CfgTenantEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTenantEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantEx Members
CfgTenantEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTenantEx type exposes the following members.

Constructors

Name | Description
CfgTenantEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Address |
CfgObjectType | (Inherited from CfgObjectEx.)
ChargeableNumber |
DBID |
DefaultCapacityRule |
DefaultContract |
IsServiceProvider |
Name |
ParentTenant |
Password |
State |
UserProperties |

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTenantEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx Constructor
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenantEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTenantEx()

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTenantEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantEx Fields
CfgTenantEx Class See Also Send Feedback

The CfgTenantEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTenantEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantEx Methods
CfgTenantEx Class See Also Send Feedback

The CfgTenantEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTenantEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantEx Properties
CfgTenantEx Class See Also Send Feedback

The CfgTenantEx type exposes the following members.

Properties

Name | Description
Address |
CfgObjectType | (Inherited from CfgObjectEx.)
ChargeableNumber |
DBID |
DefaultCapacityRule |
DefaultContract |
IsServiceProvider |
Name |
ParentTenant |
Password |
State |
UserProperties |

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Address Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.Address Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.Address"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAddressEx Address { get; set; }
Visual Basic (Declaration)
Public Property Address As CfgAddressEx
Visual C++
public:
property CfgAddressEx^ Address {
    CfgAddressEx^ get ();
    void set (CfgAddressEx^ value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ChargeableNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.ChargeableNumber Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.ChargeableNumber"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ChargeableNumber { get; set; }
Visual Basic (Declaration)
Public Property ChargeableNumber As String
Visual C++
public:
property String^ ChargeableNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.DBID Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DefaultCapacityRule Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.DefaultCapacityRule Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.DefaultCapacityRule"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DefaultCapacityRule { get; set; }
Visual Basic (Declaration)
Public Property DefaultCapacityRule As Integer
Visual C++
public:
property int DefaultCapacityRule {
    int get ();
    void set (int value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DefaultContract Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.DefaultContract Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.DefaultContract"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DefaultContract { get; set; }
Visual Basic (Declaration)
Public Property DefaultContract As Integer
Visual C++
public:
property int DefaultContract {
    int get ();
    void set (int value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsServiceProvider Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.IsServiceProvider Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.IsServiceProvider"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsServiceProvider { get; set; }
Visual Basic (Declaration)
Public Property IsServiceProvider As CfgFlag
Visual C++
public:
property CfgFlag IsServiceProvider {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.Name Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


ParentTenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.ParentTenant Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.ParentTenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ParentTenant { get; set; }
Visual Basic (Declaration)
Public Property ParentTenant As Integer
Visual C++
public:
property int ParentTenant {
    int get ();
    void set (int value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.Password Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.Password"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.State Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantEx..::.UserProperties Property
CfgTenantEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTenantEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTenantEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTimeZoneEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTimeZoneEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgTimeZoneEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgTimeZoneEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTimeZoneEx

See Also

CfgTimeZoneEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTimeZoneEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx Members
CfgTimeZoneEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTimeZoneEx type exposes the following members.

Constructors

Name | Description
CfgTimeZoneEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DSTOffset |
DSTStartDate |
DSTStopDate |
IsDSTObserved |
Name |
NameMSExplorer |
NameNetscape |
Offset |
State |
Tenant |
UserProperties |

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTimeZoneEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx Constructor
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZoneEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTimeZoneEx()

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTimeZoneEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx Fields
CfgTimeZoneEx Class See Also Send Feedback

The CfgTimeZoneEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTimeZoneEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx Methods
CfgTimeZoneEx Class See Also Send Feedback

The CfgTimeZoneEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTimeZoneEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx Properties
CfgTimeZoneEx Class See Also Send Feedback

The CfgTimeZoneEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
DSTOffset |
DSTStartDate |
DSTStopDate |
IsDSTObserved |
Name |
NameMSExplorer |
NameNetscape |
Offset |
State |
Tenant |
UserProperties |

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.DBID Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.Description Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DSTOffset Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.DSTOffset Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.DSTOffset"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DSTOffset { get; set; }
Visual Basic (Declaration)
Public Property DSTOffset As Integer
Visual C++
public:
property int DSTOffset {
    int get ();
    void set (int value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DSTStartDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.DSTStartDate Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.DSTStartDate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DSTStartDate { get; set; }
Visual Basic (Declaration)
Public Property DSTStartDate As DateTime
Visual C++
public:
property DateTime DSTStartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DSTStopDate Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.DSTStopDate Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.DSTStopDate"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DSTStopDate { get; set; }
Visual Basic (Declaration)
Public Property DSTStopDate As DateTime
Visual C++
public:
property DateTime DSTStopDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


IsDSTObserved Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.IsDSTObserved Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.IsDSTObserved"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFlag IsDSTObserved { get; set; }
Visual Basic (Declaration)
Public Property IsDSTObserved As CfgFlag
Visual C++
public:
property CfgFlag IsDSTObserved {
    CfgFlag get ();
    void set (CfgFlag value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.Name Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


NameMSExplorer Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.NameMSExplorer Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.NameMSExplorer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameMSExplorer { get; set; }
Visual Basic (Declaration)
Public Property NameMSExplorer As String
Visual C++
public:
property String^ NameMSExplorer {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


NameNetscape Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.NameNetscape Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.NameNetscape"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameNetscape { get; set; }
Visual Basic (Declaration)
Public Property NameNetscape As String
Visual C++
public:
property String^ NameNetscape {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Offset Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.Offset Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.Offset"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Integer
Visual C++
public:
property int Offset {
    int get ();
    void set (int value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.State Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.Tenant Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneEx..::.UserProperties Property
CfgTimeZoneEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTimeZoneEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTimeZoneEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTransactionEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTransactionEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgTransactionEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgTransactionEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTransactionEx

See Also

CfgTransactionEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTransactionEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx Members
CfgTransactionEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTransactionEx type exposes the following members.

Constructors

Name | Description
CfgTransactionEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Alias |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
RecordPeriod |
State |
Tenant |
Type |
UserProperties |

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTransactionEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx Constructor
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransactionEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTransactionEx()

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTransactionEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx Fields
CfgTransactionEx Class See Also Send Feedback

The CfgTransactionEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTransactionEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx Methods
CfgTransactionEx Class See Also Send Feedback

The CfgTransactionEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTransactionEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx Properties
CfgTransactionEx Class See Also Send Feedback

The CfgTransactionEx type exposes the following members.

Properties

Name | Description
Alias |
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
RecordPeriod |
State |
Tenant |
Type |
UserProperties |

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Alias Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.Alias Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.Alias"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Alias { get; set; }
Visual Basic (Declaration)
Public Property Alias As String
Visual C++
public:
property String^ Alias {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.DBID Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.Description Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.Name Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RecordPeriod Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.RecordPeriod Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.RecordPeriod"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int RecordPeriod { get; set; }
Visual Basic (Declaration)
Public Property RecordPeriod As Integer
Visual C++
public:
property int RecordPeriod {
    int get ();
    void set (int value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.State Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.Tenant Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.Type Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransactionType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As CfgTransactionType
Visual C++
public:
property CfgTransactionType Type {
    CfgTransactionType get ();
    void set (CfgTransactionType value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionEx..::.UserProperties Property
CfgTransactionEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTransactionEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTransactionEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTreatmentEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTreatmentEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgTreatmentEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgTreatmentEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgTreatmentEx

See Also

CfgTreatmentEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTreatmentEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx Members
CfgTreatmentEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgTreatmentEx type exposes the following members.

Constructors

Name | Description
CfgTreatmentEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
Attempts |
CallActionCode |
CallResult |
CfgObjectType | (Inherited from CfgObjectEx.)
CycleAttempt |
DateTime |
DBID |
Description |
DestDN |
Increment |
Interval |
Name |
Range |
RecActionCode |
State |
Tenant |
UserProperties |

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTreatmentEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx Constructor
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTreatmentEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTreatmentEx()

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTreatmentEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx Fields
CfgTreatmentEx Class See Also Send Feedback

The CfgTreatmentEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTreatmentEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx Methods
CfgTreatmentEx Class See Also Send Feedback

The CfgTreatmentEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgTreatmentEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx Properties
CfgTreatmentEx Class See Also Send Feedback

The CfgTreatmentEx type exposes the following members.

Properties

Name | Description
Attempts |
CallActionCode |
CallResult |
CfgObjectType | (Inherited from CfgObjectEx.)
CycleAttempt |
DateTime |
DBID |
Description |
DestDN |
Increment |
Interval |
Name |
Range |
RecActionCode |
State |
Tenant |
UserProperties |

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Attempts Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Attempts Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Attempts"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Attempts { get; set; }
Visual Basic (Declaration)
Public Property Attempts As Integer
Visual C++
public:
property int Attempts {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CallActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.CallActionCode Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.CallActionCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallActionCode CallActionCode { get; set; }
Visual Basic (Declaration)
Public Property CallActionCode As CfgCallActionCode
Visual C++
public:
property CfgCallActionCode CallActionCode {
    CfgCallActionCode get ();
    void set (CfgCallActionCode value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CallResult Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.CallResult Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.CallResult"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public GctiCallState CallResult { get; set; }
Visual Basic (Declaration)
Public Property CallResult As GctiCallState
Visual C++
public:
property GctiCallState CallResult {
    GctiCallState get ();
    void set (GctiCallState value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CycleAttempt Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.CycleAttempt Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.CycleAttempt"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int CycleAttempt { get; set; }
Visual Basic (Declaration)
Public Property CycleAttempt As Integer
Visual C++
public:
property int CycleAttempt {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DateTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.DateTime Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.DateTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DateTime DateTime { get; set; }
Visual Basic (Declaration)
Public Property DateTime As DateTime
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.DBID Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Description Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DestDN Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.DestDN Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.DestDN"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DestDN { get; set; }
Visual Basic (Declaration)
Public Property DestDN As Integer
Visual C++
public:
property int DestDN {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Increment Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Increment Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Increment"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Integer
Visual C++
public:
property int Increment {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Interval Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Interval Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Interval"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Interval { get; set; }
Visual Basic (Declaration)
Public Property Interval As Integer
Visual C++
public:
property int Interval {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Name Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Range Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Range Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Range"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Range { get; set; }
Visual Basic (Declaration)
Public Property Range As Integer
Visual C++
public:
property int Range {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


RecActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.RecActionCode Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.RecActionCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgRecActionCode RecActionCode { get; set; }
Visual Basic (Declaration)
Public Property RecActionCode As CfgRecActionCode
Visual C++
public:
property CfgRecActionCode RecActionCode {
    CfgRecActionCode get ();
    void set (CfgRecActionCode value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.State Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.Tenant Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentEx..::.UserProperties Property
CfgTreatmentEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgTreatmentEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgTreatmentEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgUpdatePackageRecordEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgUpdatePackageRecordEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgUpdatePackageRecordEx : CfgStructureEx
Visual Basic (Declaration)
Public Class CfgUpdatePackageRecordEx _
    Inherits CfgStructureEx
Visual C++
public ref class CfgUpdatePackageRecordEx : public CfgStructureEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgStructureEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgUpdatePackageRecordEx

See Also

CfgUpdatePackageRecordEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgUpdatePackageRecordEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx Members
CfgUpdatePackageRecordEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgUpdatePackageRecordEx type exposes the following members.

Constructors

Name | Description
CfgUpdatePackageRecordEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
PackageDateTime |
PackageStatus |
PackageVersion |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgUpdatePackageRecordEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx Constructor
CfgUpdatePackageRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgUpdatePackageRecordEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgUpdatePackageRecordEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgUpdatePackageRecordEx()

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgUpdatePackageRecordEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx Fields
CfgUpdatePackageRecordEx Class See Also Send Feedback

The CfgUpdatePackageRecordEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgUpdatePackageRecordEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx Methods
CfgUpdatePackageRecordEx Class See Also Send Feedback

The CfgUpdatePackageRecordEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgStructureEx.)

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgUpdatePackageRecordEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx Properties
CfgUpdatePackageRecordEx Class See Also Send Feedback

The CfgUpdatePackageRecordEx type exposes the following members.

Properties

Name | Description
PackageDateTime |
PackageStatus |
PackageVersion |
ParentDBID | (Inherited from CfgStructureEx.)

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PackageDateTime Property

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx..::.PackageDateTime Property
CfgUpdatePackageRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgUpdatePackageRecordEx.PackageDateTime"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PackageDateTime { get; set; }
Visual Basic (Declaration)
Public Property PackageDateTime As String
Visual C++
public:
property String^ PackageDateTime {
    String^ get ();
    void set (String^ value);
}

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PackageStatus Property

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx..::.PackageStatus Property
CfgUpdatePackageRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgUpdatePackageRecordEx.PackageStatus"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgUpdatePackageStatus PackageStatus { get; set; }
Visual Basic (Declaration)
Public Property PackageStatus As CfgUpdatePackageStatus
Visual C++
public:
property CfgUpdatePackageStatus PackageStatus {
    CfgUpdatePackageStatus get ();
    void set (CfgUpdatePackageStatus value);
}

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


PackageVersion Property

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageRecordEx..::.PackageVersion Property
CfgUpdatePackageRecordEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgUpdatePackageRecordEx.PackageVersion"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PackageVersion { get; set; }
Visual Basic (Declaration)
Public Property PackageVersion As String
Visual C++
public:
property String^ PackageVersion {
    String^ get ();
    void set (String^ value);
}

See Also

CfgUpdatePackageRecordEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgVoicePromptEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgVoicePromptEx : CfgObjectEx
Visual Basic (Declaration)
Public Class CfgVoicePromptEx _
    Inherits CfgObjectEx
Visual C++
public ref class CfgVoicePromptEx : public CfgObjectEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects..::.CfgVoicePromptEx

See Also

CfgVoicePromptEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgVoicePromptEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx Members
CfgVoicePromptEx Class Constructors Methods Fields Properties See Also Send Feedback

The CfgVoicePromptEx type exposes the following members.

Constructors

Name | Description
CfgVoicePromptEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
Script |
State |
Switch |
Tenant |
UserProperties |

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgVoicePromptEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx Constructor
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgVoicePromptEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgVoicePromptEx()

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgVoicePromptEx Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx Fields
CfgVoicePromptEx Class See Also Send Feedback

The CfgVoicePromptEx type exposes the following members.

Fields

Name | Description
DoNotUseThisProperty | (Inherited from CfgBaseEx.)

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgVoicePromptEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx Methods
CfgVoicePromptEx Class See Also Send Feedback

The CfgVoicePromptEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgObjectEx.)

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


CfgVoicePromptEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx Properties
CfgVoicePromptEx Class See Also Send Feedback

The CfgVoicePromptEx type exposes the following members.

Properties

Name | Description
CfgObjectType | (Inherited from CfgObjectEx.)
DBID |
Description |
Name |
Script |
State |
Switch |
Tenant |
UserProperties |

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


DBID Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.DBID Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.DBID"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int DBID { get; set; }
Visual Basic (Declaration)
Public Property DBID As Integer
Visual C++
public:
property int DBID {
    int get ();
    void set (int value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.Description Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.Description"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.Name Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Script Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.Script Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.Script"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Script { get; set; }
Visual Basic (Declaration)
Public Property Script As Integer
Visual C++
public:
property int Script {
    int get ();
    void set (int value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.State Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectState State { get; set; }
Visual Basic (Declaration)
Public Property State As CfgObjectState
Visual C++
public:
property CfgObjectState State {
    CfgObjectState get ();
    void set (CfgObjectState value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Switch Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.Switch Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.Switch"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Switch { get; set; }
Visual Basic (Declaration)
Public Property Switch As Integer
Visual C++
public:
property int Switch {
    int get ();
    void set (int value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.Tenant Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.Tenant"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Tenant { get; set; }
Visual Basic (Declaration)
Public Property Tenant As Integer
Visual C++
public:
property int Tenant {
    int get ();
    void set (int value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


UserProperties Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptEx..::.UserProperties Property
CfgVoicePromptEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects.CfgVoicePromptEx.UserProperties"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection UserProperties { get; set; }
Visual Basic (Declaration)
Public Property UserProperties As KeyValueCollection
Visual C++
public:
property KeyValueCollection^ UserProperties {
    KeyValueCollection^ get ();
    void set (KeyValueCollection^ value);
}

See Also

CfgVoicePromptEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjects Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace
Send Feedback

Classes

Class | Description
SerializationExtension |


SerializationExtension Class

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class SerializationExtension
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class SerializationExtension
Visual C++
[ExtensionAttribute]
public ref class SerializationExtension abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension..::.SerializationExtension

See Also

SerializationExtension Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace


SerializationExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
SerializationExtension Members
SerializationExtension Class Methods See Also Send Feedback

The SerializationExtension type exposes the following members.

Methods

Name | Description
AsJson |
AsString |
AsXElement |

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace


SerializationExtension Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SerializationExtension Methods
SerializationExtension Class See Also Send Feedback

The SerializationExtension type exposes the following members.

Methods

Name | Description
AsJson |
AsString |
AsXElement |

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace


AsJson Method

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension..::.AsJson Method
SerializationExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsJson(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static string AsJson(
    this CfgObjectEx obj
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AsJson ( _
    obj As CfgObjectEx _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ AsJson(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsJson(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsJson(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace


AsString Method

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension..::.AsString Method
SerializationExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsString(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static string AsString(
    this CfgObjectEx obj
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AsString ( _
    obj As CfgObjectEx _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ AsString(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsString(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsString(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace


AsXElement Method

[image]

Enterprise SDK 8.0 Reference API
SerializationExtension..::.AsXElement Method
SerializationExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsXElement(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static XElement AsXElement(
    this CfgObjectEx obj
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AsXElement ( _
    obj As CfgObjectEx _
) As XElement
Visual C++
[ExtensionAttribute]
public:
static XElement^ AsXElement(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsXElement(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension.SerializationExtension.AsXElement(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

SerializationExtension Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Extension Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace
Send Feedback

Classes

Class | Description
CfgAttributeInfo |
CfgObjectInfo |
CfgObjectTransformer |
CfgTypeInfo |
ConfEventTransformer |
NotificationQueryTransformer |
PermissionTransformer |


CfgAttributeInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgAttributeInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAttributeInfo
Visual Basic (Declaration)
Public Class CfgAttributeInfo
Visual C++
public ref class CfgAttributeInfo

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.CfgAttributeInfo

See Also

CfgAttributeInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgAttributeInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo Members
CfgAttributeInfo Class Constructors Methods Properties See Also Send Feedback

The CfgAttributeInfo type exposes the following members.

Constructors

Name | Description
CfgAttributeInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Changeable |
Name |
Setter |

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgAttributeInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo Constructor
CfgAttributeInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgAttributeInfo.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAttributeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAttributeInfo()

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgAttributeInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo Methods
CfgAttributeInfo Class See Also Send Feedback

The CfgAttributeInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgAttributeInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo Properties
CfgAttributeInfo Class See Also Send Feedback

The CfgAttributeInfo type exposes the following members.

Properties

Name | Description
Changeable |
Name |
Setter |

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Changeable Property

[image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo..::.Changeable Property
CfgAttributeInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgAttributeInfo.Changeable"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Changeable { get; set; }
Visual Basic (Declaration)
Public Property Changeable As Boolean
Visual C++
public:
property bool Changeable {
    bool get ();
    void set (bool value);
}

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo..::.Name Property
CfgAttributeInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgAttributeInfo.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Setter Property

[image]

Enterprise SDK 8.0 Reference API
CfgAttributeInfo..::.Setter Property
CfgAttributeInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgAttributeInfo.Setter"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Setter { get; set; }
Visual Basic (Declaration)
Public Property Setter As String
Visual C++
public:
property String^ Setter {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAttributeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectInfo
Visual Basic (Declaration)
Public Class CfgObjectInfo
Visual C++
public ref class CfgObjectInfo

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.CfgObjectInfo

See Also

CfgObjectInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo Members
CfgObjectInfo Class Constructors Methods Properties See Also Send Feedback

The CfgObjectInfo type exposes the following members.

Constructors

Name | Description
CfgObjectInfo |

Methods

Name | Description
CreateInstance |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Types |

See Also

CfgObjectInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo Constructor
CfgObjectInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectInfo.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectInfo()

See Also

CfgObjectInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo Methods
CfgObjectInfo Class See Also Send Feedback

The CfgObjectInfo type exposes the following members.

Methods

Name | Description
CreateInstance |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgObjectInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CreateInstance Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo..::.CreateInstance Method
CfgObjectInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectInfo.CreateInstance"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgObjectInfo CreateInstance()
Visual Basic (Declaration)
Public Shared Function CreateInstance As CfgObjectInfo
Visual C++
public:
static CfgObjectInfo^ CreateInstance()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectInfo.CreateInstance"]

See Also

CfgObjectInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo Properties
CfgObjectInfo Class See Also Send Feedback

The CfgObjectInfo type exposes the following members.

Properties

Name | Description
Types |

See Also

CfgObjectInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Types Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectInfo..::.Types Property
CfgObjectInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectInfo.Types"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Dictionary<string, CfgTypeInfo> Types { get; set; }
Visual Basic (Declaration)
Public Property Types As Dictionary(Of String, CfgTypeInfo)
Visual C++
public:
property Dictionary<String^, CfgTypeInfo^>^ Types {
    Dictionary<String^, CfgTypeInfo^>^ get ();
    void set (Dictionary<String^, CfgTypeInfo^>^ value);
}

See Also

CfgObjectInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectTransformer Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class CfgObjectTransformer
Visual Basic (Declaration)
Public NotInheritable Class CfgObjectTransformer
Visual C++
public ref class CfgObjectTransformer abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.CfgObjectTransformer

See Also

CfgObjectTransformer Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectTransformer Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer Members
CfgObjectTransformer Class Methods Fields See Also Send Feedback

The CfgObjectTransformer type exposes the following members.

Methods

Name | Description
Cfg2EntBase |
Cfg2EntCollection |
Cfg2EntKVCollection |
Cfg2EntObject |
Cfg2EntType |
Ent2CfgBase |
Ent2CfgBaseCopy |
Ent2CfgCollection |
Ent2CfgKVCollection |
Ent2CfgObject |
Ent2CfgType |
Ent2EnumType |
Enum2CfgType |
Enum2EntType |
GetObjectDBID |

Fields

Name | Description
CfgObjectsAssembly |
EntObjectsAssembly |
EntObjectsNamespace |
EntSuffix |

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectTransformer Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer Fields
CfgObjectTransformer Class See Also Send Feedback

The CfgObjectTransformer type exposes the following members.

Fields

Name | Description
CfgObjectsAssembly |
EntObjectsAssembly |
EntObjectsNamespace |
EntSuffix |

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectsAssembly Field

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.CfgObjectsAssembly Field
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.CfgObjectsAssembly"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string CfgObjectsAssembly
Visual Basic (Declaration)
Public Const CfgObjectsAssembly As String
Visual C++
public:
literal String^ CfgObjectsAssembly

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


EntObjectsAssembly Field

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.EntObjectsAssembly Field
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.EntObjectsAssembly"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EntObjectsAssembly
Visual Basic (Declaration)
Public Const EntObjectsAssembly As String
Visual C++
public:
literal String^ EntObjectsAssembly

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


EntObjectsNamespace Field

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.EntObjectsNamespace Field
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.EntObjectsNamespace"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EntObjectsNamespace
Visual Basic (Declaration)
Public Const EntObjectsNamespace As String
Visual C++
public:
literal String^ EntObjectsNamespace

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


EntSuffix Field

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.EntSuffix Field
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.EntSuffix"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EntSuffix
Visual Basic (Declaration)
Public Const EntSuffix As String
Visual C++
public:
literal String^ EntSuffix

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgObjectTransformer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer Methods
CfgObjectTransformer Class See Also Send Feedback

The CfgObjectTransformer type exposes the following members.

Methods

Name | Description
Cfg2EntBase |
Cfg2EntCollection |
Cfg2EntKVCollection |
Cfg2EntObject |
Cfg2EntType |
Ent2CfgBase |
Ent2CfgBaseCopy |
Ent2CfgCollection |
Ent2CfgKVCollection |
Ent2CfgObject |
Ent2CfgType |
Ent2EnumType |
Enum2CfgType |
Enum2EntType |
GetObjectDBID |

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntBase Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Cfg2EntBase Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntBase(Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgBaseEx Cfg2EntBase(
    CfgBase cfgBase
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntBase ( _
    cfgBase As CfgBase _
) As CfgBaseEx
Visual C++
public:
static CfgBaseEx^ Cfg2EntBase(
    CfgBase^ cfgBase
)

Parameters

cfgBase
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgBase"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntBase(Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntBase(Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntCollection Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Cfg2EntCollection Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntCollection(System.Collections.ICollection)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static ICollection Cfg2EntCollection(
    ICollection cfgCollection
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntCollection ( _
    cfgCollection As ICollection _
) As ICollection
Visual C++
public:
static ICollection^ Cfg2EntCollection(
    ICollection^ cfgCollection
)

Parameters

cfgCollection
Type: System.Collections..::.ICollection

[Missing <param name="cfgCollection"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntCollection(System.Collections.ICollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntCollection(System.Collections.ICollection)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntKVCollection Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Cfg2EntKVCollection Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntKVCollection(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static KeyValueCollection Cfg2EntKVCollection(
    KeyValueCollection cfgCollection
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntKVCollection ( _
    cfgCollection As KeyValueCollection _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ Cfg2EntKVCollection(
    KeyValueCollection^ cfgCollection
)

Parameters

cfgCollection
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="cfgCollection"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntKVCollection(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntKVCollection(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntObject Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Cfg2EntObject Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntObject(System.Object)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Object Cfg2EntObject(
    Object cfgObject
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntObject ( _
    cfgObject As Object _
) As Object
Visual C++
public:
static Object^ Cfg2EntObject(
    Object^ cfgObject
)

Parameters

cfgObject
Type: System..::.Object

[Missing <param name="cfgObject"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntObject(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntObject(System.Object)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntType Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Cfg2EntType Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntType(System.Type)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Cfg2EntType(
    Type cfgType
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntType ( _
    cfgType As Type _
) As Type
Visual C++
public:
static Type^ Cfg2EntType(
    Type^ cfgType
)

Parameters

cfgType
Type: System..::.Type

[Missing <param name="cfgType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntType(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Cfg2EntType(System.Type)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgBase Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2CfgBase Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBase(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgBase Ent2CfgBase(
    IConfigurationService service,
    IClientChannel channel,
    CfgBaseEx entBase,
    CfgBase cfgParent
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgBase ( _
    service As IConfigurationService, _
    channel As IClientChannel, _
    entBase As CfgBaseEx, _
    cfgParent As CfgBase _
) As CfgBase
Visual C++
public:
static CfgBase^ Ent2CfgBase(
    IConfigurationService^ service,
    IClientChannel^ channel,
    CfgBaseEx^ entBase,
    CfgBase^ cfgParent
)

Parameters

service
Type: IConfigurationService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBase(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBase(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

entBase
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx

[Missing <param name="entBase"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBase(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

cfgParent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgParent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBase(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBase(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgBaseCopy Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2CfgBaseCopy Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBaseCopy(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static void Ent2CfgBaseCopy(
    IConfigurationService service,
    IClientChannel channel,
    CfgBase cfgBase,
    CfgBaseEx entBase,
    CfgBase cfgParent
)
Visual Basic (Declaration)
Public Shared Sub Ent2CfgBaseCopy ( _
    service As IConfigurationService, _
    channel As IClientChannel, _
    cfgBase As CfgBase, _
    entBase As CfgBaseEx, _
    cfgParent As CfgBase _
)
Visual C++
public:
static void Ent2CfgBaseCopy(
    IConfigurationService^ service,
    IClientChannel^ channel,
    CfgBase^ cfgBase,
    CfgBaseEx^ entBase,
    CfgBase^ cfgParent
)

Parameters

service
Type: IConfigurationService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBaseCopy(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBaseCopy(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

cfgBase
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgBase"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBaseCopy(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

entBase
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgBaseEx

[Missing <param name="entBase"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBaseCopy(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

cfgParent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgParent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgBaseCopy(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgBaseEx,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgCollection Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2CfgCollection Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Collections.ICollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static ICollection Ent2CfgCollection(
    IConfigurationService service,
    IClientChannel channel,
    ICollection entCollection,
    CfgBase cfgParent
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgCollection ( _
    service As IConfigurationService, _
    channel As IClientChannel, _
    entCollection As ICollection, _
    cfgParent As CfgBase _
) As ICollection
Visual C++
public:
static ICollection^ Ent2CfgCollection(
    IConfigurationService^ service,
    IClientChannel^ channel,
    ICollection^ entCollection,
    CfgBase^ cfgParent
)

Parameters

service
Type: IConfigurationService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Collections.ICollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Collections.ICollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

entCollection
Type: System.Collections..::.ICollection

[Missing <param name="entCollection"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Collections.ICollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

cfgParent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgParent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Collections.ICollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Collections.ICollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgKVCollection Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2CfgKVCollection Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgKVCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static KeyValueCollection Ent2CfgKVCollection(
    IConfigurationService service,
    IClientChannel channel,
    KeyValueCollection entCollection,
    CfgBase cfgParent
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgKVCollection ( _
    service As IConfigurationService, _
    channel As IClientChannel, _
    entCollection As KeyValueCollection, _
    cfgParent As CfgBase _
) As KeyValueCollection
Visual C++
public:
static KeyValueCollection^ Ent2CfgKVCollection(
    IConfigurationService^ service,
    IClientChannel^ channel,
    KeyValueCollection^ entCollection,
    CfgBase^ cfgParent
)

Parameters

service
Type: IConfigurationService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgKVCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgKVCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

entCollection
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="entCollection"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgKVCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

cfgParent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgParent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgKVCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgKVCollection(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgObject Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2CfgObject Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Object,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Object Ent2CfgObject(
    IConfigurationService service,
    IClientChannel channel,
    Object entObject,
    CfgBase cfgParent
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgObject ( _
    service As IConfigurationService, _
    channel As IClientChannel, _
    entObject As Object, _
    cfgParent As CfgBase _
) As Object
Visual C++
public:
static Object^ Ent2CfgObject(
    IConfigurationService^ service,
    IClientChannel^ channel,
    Object^ entObject,
    CfgBase^ cfgParent
)

Parameters

service
Type: IConfigurationService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Object,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Object,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

entObject
Type: System..::.Object

[Missing <param name="entObject"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Object,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

cfgParent
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.CfgBase

[Missing <param name="cfgParent"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Object,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgObject(Genesyslab.Enterprise.Services.Configuration.IConfigurationService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Object,Genesyslab.Enterprise.ConfigurationObjectModel.CfgBase)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgType Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2CfgType Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgType(System.Type)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Ent2CfgType(
    Type entType
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgType ( _
    entType As Type _
) As Type
Visual C++
public:
static Type^ Ent2CfgType(
    Type^ entType
)

Parameters

entType
Type: System..::.Type

[Missing <param name="entType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgType(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2CfgType(System.Type)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2EnumType Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Ent2EnumType Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2EnumType(System.Type)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgObjectType Ent2EnumType(
    Type type
)
Visual Basic (Declaration)
Public Shared Function Ent2EnumType ( _
    type As Type _
) As CfgObjectType
Visual C++
public:
static CfgObjectType Ent2EnumType(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2EnumType(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Ent2EnumType(System.Type)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Enum2CfgType Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Enum2CfgType Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Enum2CfgType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Enum2CfgType(
    CfgObjectType type
)
Visual Basic (Declaration)
Public Shared Function Enum2CfgType ( _
    type As CfgObjectType _
) As Type
Visual C++
public:
static Type^ Enum2CfgType(
    CfgObjectType type
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Enum2CfgType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Enum2CfgType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Enum2EntType Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.Enum2EntType Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Enum2EntType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Enum2EntType(
    CfgObjectType type
)
Visual Basic (Declaration)
Public Shared Function Enum2EntType ( _
    type As CfgObjectType _
) As Type
Visual C++
public:
static Type^ Enum2EntType(
    CfgObjectType type
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Enum2EntType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.Enum2EntType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


GetObjectDBID Method

[image]

Enterprise SDK 8.0 Reference API
CfgObjectTransformer..::.GetObjectDBID Method
CfgObjectTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.GetObjectDBID(System.Object)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Nullable<int> GetObjectDBID(
    Object obj
)
Visual Basic (Declaration)
Public Shared Function GetObjectDBID ( _
    obj As Object _
) As Nullable(Of Integer)
Visual C++
public:
static Nullable<int> GetObjectDBID(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.GetObjectDBID(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgObjectTransformer.GetObjectDBID(System.Object)"]

See Also

CfgObjectTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgTypeInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgTypeInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTypeInfo
Visual Basic (Declaration)
Public Class CfgTypeInfo
Visual C++
public ref class CfgTypeInfo

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.CfgTypeInfo

See Also

CfgTypeInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgTypeInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Members
CfgTypeInfo Class Constructors Methods Properties See Also Send Feedback

The CfgTypeInfo type exposes the following members.

Constructors

Name | Description
CfgTypeInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attributes |
Structure |

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgTypeInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Constructor
CfgTypeInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgTypeInfo.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTypeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTypeInfo()

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgTypeInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Methods
CfgTypeInfo Class See Also Send Feedback

The CfgTypeInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CfgTypeInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Properties
CfgTypeInfo Class See Also Send Feedback

The CfgTypeInfo type exposes the following members.

Properties

Name | Description
Attributes |
Structure |

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo..::.Attributes Property
CfgTypeInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgTypeInfo.Attributes"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Dictionary<string, CfgAttributeInfo> Attributes { get; set; }
Visual Basic (Declaration)
Public Property Attributes As Dictionary(Of String, CfgAttributeInfo)
Visual C++
public:
property Dictionary<String^, CfgAttributeInfo^>^ Attributes {
    Dictionary<String^, CfgAttributeInfo^>^ get ();
    void set (Dictionary<String^, CfgAttributeInfo^>^ value);
}

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Structure Property

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo..::.Structure Property
CfgTypeInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.CfgTypeInfo.Structure"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Structure { get; set; }
Visual Basic (Declaration)
Public Property Structure As Boolean
Visual C++
public:
property bool Structure {
    bool get ();
    void set (bool value);
}

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


ConfEventTransformer Class

[image]

Enterprise SDK 8.0 Reference API
ConfEventTransformer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.ConfEventTransformer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ConfEventTransformer : ITransformer<ConfEventEx, ConfEvent>
Visual Basic (Declaration)
Public Class ConfEventTransformer _
    Implements ITransformer(Of ConfEventEx, ConfEvent)
Visual C++
public ref class ConfEventTransformer : ITransformer<ConfEventEx^, ConfEvent^>

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.ConfEventTransformer

See Also

ConfEventTransformer Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


ConfEventTransformer Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventTransformer Members
ConfEventTransformer Class Constructors Methods See Also Send Feedback

The ConfEventTransformer type exposes the following members.

Constructors

Name | Description
ConfEventTransformer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Transform |

See Also

ConfEventTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


ConfEventTransformer Constructor

[image]

Enterprise SDK 8.0 Reference API
ConfEventTransformer Constructor
ConfEventTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.ConfEventTransformer.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEventTransformer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfEventTransformer()

See Also

ConfEventTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


ConfEventTransformer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfEventTransformer Methods
ConfEventTransformer Class See Also Send Feedback

The ConfEventTransformer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Transform |

See Also

ConfEventTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Transform Method

[image]

Enterprise SDK 8.0 Reference API
ConfEventTransformer..::.Transform Method
ConfEventTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.ConfEventTransformer.Transform(Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfEventEx Transform(
    ConfEvent source
)
Visual Basic (Declaration)
Public Function Transform ( _
    source As ConfEvent _
) As ConfEventEx
Visual C++
public:
virtual ConfEventEx^ Transform(
    ConfEvent^ source
) sealed

Parameters

source
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ConfEvent

[Missing <param name="source"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.ConfEventTransformer.Transform(Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.ConfEventTransformer.Transform(Genesyslab.Enterprise.ConfigurationObjectModel.ConfEvent)"]

Implements

ITransformer<(Of <(TTarget, TSource>)>)..::.Transform(TSource)

See Also

ConfEventTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


NotificationQueryTransformer Class

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class NotificationQueryTransformer
Visual Basic (Declaration)
Public NotInheritable Class NotificationQueryTransformer
Visual C++
public ref class NotificationQueryTransformer abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.NotificationQueryTransformer

See Also

NotificationQueryTransformer Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


NotificationQueryTransformer Members

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer Members
NotificationQueryTransformer Class Methods See Also Send Feedback

The NotificationQueryTransformer type exposes the following members.

Methods

Name | Description
CreateEntNotificationQuery | Overloaded.
Ent2CfgNotificationQuery |

See Also

NotificationQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


NotificationQueryTransformer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer Methods
NotificationQueryTransformer Class See Also Send Feedback

The NotificationQueryTransformer type exposes the following members.

Methods

Name | Description
CreateEntNotificationQuery | Overloaded.
Ent2CfgNotificationQuery |

See Also

NotificationQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CreateEntNotificationQuery Method

[image] [image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer..::.CreateEntNotificationQuery Method
NotificationQueryTransformer Class See Also Send Feedback

Overload List

Name | Description
CreateEntNotificationQuery(KeyValueCollection) |
CreateEntNotificationQuery(CfgObjectDTO) |
CreateEntNotificationQuery(ICfgObject) |
CreateEntNotificationQuery(CfgObjectEx) |

See Also

NotificationQueryTransformer Class
NotificationQueryTransformer Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CreateEntNotificationQuery Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer..::.CreateEntNotificationQuery Method (KeyValueCollection)
NotificationQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static NotificationQuery CreateEntNotificationQuery(
    KeyValueCollection filter
)
Visual Basic (Declaration)
Public Shared Function CreateEntNotificationQuery ( _
    filter As KeyValueCollection _
) As NotificationQuery
Visual C++
public:
static NotificationQuery^ CreateEntNotificationQuery(
    KeyValueCollection^ filter
)

Parameters

filter
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

NotificationQueryTransformer Class
CreateEntNotificationQuery Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CreateEntNotificationQuery Method (CfgObjectDTO)

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer..::.CreateEntNotificationQuery Method (CfgObjectDTO)
NotificationQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static NotificationQuery CreateEntNotificationQuery(
    CfgObjectDTO obj
)
Visual Basic (Declaration)
Public Shared Function CreateEntNotificationQuery ( _
    obj As CfgObjectDTO _
) As NotificationQuery
Visual C++
public:
static NotificationQuery^ CreateEntNotificationQuery(
    CfgObjectDTO^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.DTO..::.CfgObjectDTO

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.DTO.CfgObjectDTO)"]

See Also

NotificationQueryTransformer Class
CreateEntNotificationQuery Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CreateEntNotificationQuery Method (ICfgObject)

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer..::.CreateEntNotificationQuery Method (ICfgObject)
NotificationQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static NotificationQuery CreateEntNotificationQuery(
    ICfgObject obj
)
Visual Basic (Declaration)
Public Shared Function CreateEntNotificationQuery ( _
    obj As ICfgObject _
) As NotificationQuery
Visual C++
public:
static NotificationQuery^ CreateEntNotificationQuery(
    ICfgObject^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.ICfgObject

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.ICfgObject)"]

See Also

NotificationQueryTransformer Class
CreateEntNotificationQuery Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


CreateEntNotificationQuery Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer..::.CreateEntNotificationQuery Method (CfgObjectEx)
NotificationQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static NotificationQuery CreateEntNotificationQuery(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Public Shared Function CreateEntNotificationQuery ( _
    obj As CfgObjectEx _
) As NotificationQuery
Visual C++
public:
static NotificationQuery^ CreateEntNotificationQuery(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.CreateEntNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

NotificationQueryTransformer Class
CreateEntNotificationQuery Overload
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgNotificationQuery Method

[image]

Enterprise SDK 8.0 Reference API
NotificationQueryTransformer..::.Ent2CfgNotificationQuery Method
NotificationQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.Ent2CfgNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static NotificationQuery Ent2CfgNotificationQuery(
    NotificationQueryEx entQuery
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgNotificationQuery ( _
    entQuery As NotificationQueryEx _
) As NotificationQuery
Visual C++
public:
static NotificationQuery^ Ent2CfgNotificationQuery(
    NotificationQueryEx^ entQuery
)

Parameters

entQuery
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.NotificationQueryEx

[Missing <param name="entQuery"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.Ent2CfgNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.NotificationQueryTransformer.Ent2CfgNotificationQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

See Also

NotificationQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


PermissionTransformer Class

[image]

Enterprise SDK 8.0 Reference API
PermissionTransformer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class PermissionTransformer
Visual Basic (Declaration)
Public NotInheritable Class PermissionTransformer
Visual C++
public ref class PermissionTransformer abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal..::.PermissionTransformer

See Also

PermissionTransformer Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


PermissionTransformer Members

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionTransformer Members
PermissionTransformer Class Methods See Also Send Feedback

The PermissionTransformer type exposes the following members.

Methods

Name | Description
Cfg2EntPermission |
Cfg2EntPermissionList |
Ent2CfgPermission |

See Also

PermissionTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


PermissionTransformer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PermissionTransformer Methods
PermissionTransformer Class See Also Send Feedback

The PermissionTransformer type exposes the following members.

Methods

Name | Description
Cfg2EntPermission |
Cfg2EntPermissionList |
Ent2CfgPermission |

See Also

PermissionTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntPermission Method

[image]

Enterprise SDK 8.0 Reference API
PermissionTransformer..::.Cfg2EntPermission Method
PermissionTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Cfg2EntPermission(Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static PermissionDescriptorEx Cfg2EntPermission(
    PermissionDescriptor cfgPermission
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntPermission ( _
    cfgPermission As PermissionDescriptor _
) As PermissionDescriptorEx
Visual C++
public:
static PermissionDescriptorEx^ Cfg2EntPermission(
    PermissionDescriptor^ cfgPermission
)

Parameters

cfgPermission
Type: Genesyslab.Enterprise.ConfigurationObjectModel..::.PermissionDescriptor

[Missing <param name="cfgPermission"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Cfg2EntPermission(Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Cfg2EntPermission(Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor)"]

See Also

PermissionTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Cfg2EntPermissionList Method

[image]

Enterprise SDK 8.0 Reference API
PermissionTransformer..::.Cfg2EntPermissionList Method
PermissionTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Cfg2EntPermissionList(System.Collections.Generic.ICollection{Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor})"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static List<PermissionDescriptorEx> Cfg2EntPermissionList(
    ICollection<PermissionDescriptor> cfgPermissionList
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntPermissionList ( _
    cfgPermissionList As ICollection(Of PermissionDescriptor) _
) As List(Of PermissionDescriptorEx)
Visual C++
public:
static List<PermissionDescriptorEx^>^ Cfg2EntPermissionList(
    ICollection<PermissionDescriptor^>^ cfgPermissionList
)

Parameters

cfgPermissionList
Type: System.Collections.Generic..::.ICollection <(Of <( PermissionDescriptor >)>)

[Missing <param name="cfgPermissionList"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Cfg2EntPermissionList(System.Collections.Generic.ICollection{Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Cfg2EntPermissionList(System.Collections.Generic.ICollection{Genesyslab.Enterprise.ConfigurationObjectModel.PermissionDescriptor})"]

See Also

PermissionTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Ent2CfgPermission Method

[image]

Enterprise SDK 8.0 Reference API
PermissionTransformer..::.Ent2CfgPermission Method
PermissionTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Ent2CfgPermission(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static PermissionDescriptor Ent2CfgPermission(
    PermissionDescriptorEx entPermission
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgPermission ( _
    entPermission As PermissionDescriptorEx _
) As PermissionDescriptor
Visual C++
public:
static PermissionDescriptor^ Ent2CfgPermission(
    PermissionDescriptorEx^ entPermission
)

Parameters

entPermission
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.PermissionDescriptorEx

[Missing <param name="entPermission"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Ent2CfgPermission(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal.PermissionTransformer.Ent2CfgPermission(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.PermissionDescriptorEx)"]

See Also

PermissionTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Internal Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace
Send Feedback

Classes

Class | Description
CfgAccessGroupQueryEx |
CfgActionCodeQueryEx |
CfgAgentGroupQueryEx |
CfgAgentLoginQueryEx |
CfgAlarmConditionQueryEx |
CfgApplicationQueryEx |
CfgAppPrototypeQueryEx |
CfgCallingListQueryEx |
CfgCampaignGroupQueryEx |
CfgCampaignQueryEx |
CfgDNGroupQueryEx |
CfgDNQueryEx |
CfgEnumeratorQueryEx |
CfgEnumeratorValueQueryEx |
CfgFieldQueryEx |
CfgFilterQueryEx |
CfgFolderQueryEx |
CfgFormatQueryEx |
CfgGVPIVRProfileQueryEx |
CfgHostQueryEx |
CfgIVRPortQueryEx |
CfgIVRQueryEx |
CfgObjectiveTableQueryEx |
CfgPersonQueryEx |
CfgPhysicalSwitchQueryEx |
CfgPlaceGroupQueryEx |
CfgPlaceQueryEx |
CfgQueryEx |
CfgScheduledTaskQueryEx |
CfgScriptQueryEx |
CfgServiceQueryEx |
CfgSkillQueryEx |
CfgStatDayQueryEx |
CfgStatTableQueryEx |
CfgSwitchQueryEx |
CfgTableAccessQueryEx |
CfgTenantQueryEx |
CfgTimeZoneQueryEx |
CfgTransactionQueryEx |
CfgTreatmentQueryEx |
CfgVoicePromptQueryEx |


CfgAccessGroupQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAccessGroupQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgAccessGroupQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgAccessGroupQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAccessGroupQueryEx

See Also

CfgAccessGroupQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAccessGroupQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx Members
CfgAccessGroupQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgAccessGroupQueryEx type exposes the following members.

Constructors

Name | Description
CfgAccessGroupQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
PersonDbid |
State |
TenantDbid |

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAccessGroupQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx Constructor
CfgAccessGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAccessGroupQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAccessGroupQueryEx()

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAccessGroupQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx Methods
CfgAccessGroupQueryEx Class See Also Send Feedback

The CfgAccessGroupQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAccessGroupQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx Properties
CfgAccessGroupQueryEx Class See Also Send Feedback

The CfgAccessGroupQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
PersonDbid |
State |
TenantDbid |

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx..::.Dbid Property
CfgAccessGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx..::.Name Property
CfgAccessGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PersonDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx..::.PersonDbid Property
CfgAccessGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx.PersonDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> PersonDbid { get; set; }
Visual Basic (Declaration)
Public Property PersonDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> PersonDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx..::.State Property
CfgAccessGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupQueryEx..::.TenantDbid Property
CfgAccessGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAccessGroupQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAccessGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgActionCodeQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgActionCodeQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgActionCodeQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgActionCodeQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgActionCodeQueryEx

See Also

CfgActionCodeQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgActionCodeQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx Members
CfgActionCodeQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgActionCodeQueryEx type exposes the following members.

Constructors

Name | Description
CfgActionCodeQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
CodeType |
Dbid |
Name |
State |
TenantDbid |

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgActionCodeQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx Constructor
CfgActionCodeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgActionCodeQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgActionCodeQueryEx()

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgActionCodeQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx Methods
CfgActionCodeQueryEx Class See Also Send Feedback

The CfgActionCodeQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgActionCodeQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx Properties
CfgActionCodeQueryEx Class See Also Send Feedback

The CfgActionCodeQueryEx type exposes the following members.

Properties

Name | Description
CodeType |
Dbid |
Name |
State |
TenantDbid |

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CodeType Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx..::.CodeType Property
CfgActionCodeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx.CodeType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgActionCodeType> CodeType { get; set; }
Visual Basic (Declaration)
Public Property CodeType As Nullable(Of CfgActionCodeType)
Visual C++
public:
property Nullable<CfgActionCodeType> CodeType {
    Nullable<CfgActionCodeType> get ();
    void set (Nullable<CfgActionCodeType> value);
}

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx..::.Dbid Property
CfgActionCodeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx..::.Name Property
CfgActionCodeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx..::.State Property
CfgActionCodeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeQueryEx..::.TenantDbid Property
CfgActionCodeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgActionCodeQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgActionCodeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentGroupQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentGroupQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgAgentGroupQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgAgentGroupQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAgentGroupQueryEx

See Also

CfgAgentGroupQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentGroupQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx Members
CfgAgentGroupQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgAgentGroupQueryEx type exposes the following members.

Constructors

Name | Description
CfgAgentGroupQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
PersonDbid |
State |
TenantDbid |

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentGroupQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx Constructor
CfgAgentGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentGroupQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentGroupQueryEx()

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentGroupQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx Methods
CfgAgentGroupQueryEx Class See Also Send Feedback

The CfgAgentGroupQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentGroupQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx Properties
CfgAgentGroupQueryEx Class See Also Send Feedback

The CfgAgentGroupQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
PersonDbid |
State |
TenantDbid |

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx..::.Dbid Property
CfgAgentGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx..::.Name Property
CfgAgentGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PersonDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx..::.PersonDbid Property
CfgAgentGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx.PersonDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> PersonDbid { get; set; }
Visual Basic (Declaration)
Public Property PersonDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> PersonDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx..::.State Property
CfgAgentGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentGroupQueryEx..::.TenantDbid Property
CfgAgentGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentGroupQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentLoginQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAgentLoginQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgAgentLoginQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgAgentLoginQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAgentLoginQueryEx

See Also

CfgAgentLoginQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentLoginQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx Members
CfgAgentLoginQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgAgentLoginQueryEx type exposes the following members.

Constructors

Name | Description
CfgAgentLoginQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
LoginCode |
NoPersonDbid |
State |
SwitchDbid |
TenantDbid |

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentLoginQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx Constructor
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAgentLoginQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAgentLoginQueryEx()

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentLoginQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx Methods
CfgAgentLoginQueryEx Class See Also Send Feedback

The CfgAgentLoginQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAgentLoginQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx Properties
CfgAgentLoginQueryEx Class See Also Send Feedback

The CfgAgentLoginQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
LoginCode |
NoPersonDbid |
State |
SwitchDbid |
TenantDbid |

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx..::.Dbid Property
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


LoginCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx..::.LoginCode Property
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.LoginCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LoginCode { get; set; }
Visual Basic (Declaration)
Public Property LoginCode As String
Visual C++
public:
property String^ LoginCode {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoPersonDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx..::.NoPersonDbid Property
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.NoPersonDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoPersonDbid { get; set; }
Visual Basic (Declaration)
Public Property NoPersonDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoPersonDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx..::.State Property
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SwitchDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx..::.SwitchDbid Property
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.SwitchDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SwitchDbid { get; set; }
Visual Basic (Declaration)
Public Property SwitchDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SwitchDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAgentLoginQueryEx..::.TenantDbid Property
CfgAgentLoginQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAgentLoginQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAgentLoginQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAlarmConditionQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAlarmConditionQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAlarmConditionQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgAlarmConditionQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgAlarmConditionQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAlarmConditionQueryEx

See Also

CfgAlarmConditionQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAlarmConditionQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx Members
CfgAlarmConditionQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgAlarmConditionQueryEx type exposes the following members.

Constructors

Name | Description
CfgAlarmConditionQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
State |

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAlarmConditionQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx Constructor
CfgAlarmConditionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAlarmConditionQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAlarmConditionQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAlarmConditionQueryEx()

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAlarmConditionQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx Methods
CfgAlarmConditionQueryEx Class See Also Send Feedback

The CfgAlarmConditionQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAlarmConditionQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx Properties
CfgAlarmConditionQueryEx Class See Also Send Feedback

The CfgAlarmConditionQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
State |

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx..::.Dbid Property
CfgAlarmConditionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAlarmConditionQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx..::.Name Property
CfgAlarmConditionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAlarmConditionQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmConditionQueryEx..::.State Property
CfgAlarmConditionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAlarmConditionQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgAlarmConditionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgApplicationQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgApplicationQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgApplicationQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgApplicationQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgApplicationQueryEx

See Also

CfgApplicationQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgApplicationQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx Members
CfgApplicationQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgApplicationQueryEx type exposes the following members.

Constructors

Name | Description
CfgApplicationQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
AccountDbid |
AccountType |
AppPrototypeDbid |
AppType |
BackupServerDbid |
Dbid |
HostDbid |
IsServer |
Name |
NoClientDbid |
NoSwitchDbid |
Port |
PrimaryServerDbid |
SameHostAndPort |
ServerDbid |
StartupType |
State |
SwitchDbid |
TenantDbid |
Version |

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgApplicationQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx Constructor
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgApplicationQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgApplicationQueryEx()

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgApplicationQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx Methods
CfgApplicationQueryEx Class See Also Send Feedback

The CfgApplicationQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgApplicationQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx Properties
CfgApplicationQueryEx Class See Also Send Feedback

The CfgApplicationQueryEx type exposes the following members.

Properties

Name | Description
AccountDbid |
AccountType |
AppPrototypeDbid |
AppType |
BackupServerDbid |
Dbid |
HostDbid |
IsServer |
Name |
NoClientDbid |
NoSwitchDbid |
Port |
PrimaryServerDbid |
SameHostAndPort |
ServerDbid |
StartupType |
State |
SwitchDbid |
TenantDbid |
Version |

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AccountDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.AccountDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.AccountDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> AccountDbid { get; set; }
Visual Basic (Declaration)
Public Property AccountDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> AccountDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AccountType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.AccountType Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.AccountType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectType> AccountType { get; set; }
Visual Basic (Declaration)
Public Property AccountType As Nullable(Of CfgObjectType)
Visual C++
public:
property Nullable<CfgObjectType> AccountType {
    Nullable<CfgObjectType> get ();
    void set (Nullable<CfgObjectType> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AppPrototypeDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.AppPrototypeDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.AppPrototypeDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> AppPrototypeDbid { get; set; }
Visual Basic (Declaration)
Public Property AppPrototypeDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> AppPrototypeDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.AppType Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.AppType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgAppType> AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As Nullable(Of CfgAppType)
Visual C++
public:
property Nullable<CfgAppType> AppType {
    Nullable<CfgAppType> get ();
    void set (Nullable<CfgAppType> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


BackupServerDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.BackupServerDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.BackupServerDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> BackupServerDbid { get; set; }
Visual Basic (Declaration)
Public Property BackupServerDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> BackupServerDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.Dbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


HostDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.HostDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.HostDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> HostDbid { get; set; }
Visual Basic (Declaration)
Public Property HostDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> HostDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


IsServer Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.IsServer Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.IsServer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgFlag> IsServer { get; set; }
Visual Basic (Declaration)
Public Property IsServer As Nullable(Of CfgFlag)
Visual C++
public:
property Nullable<CfgFlag> IsServer {
    Nullable<CfgFlag> get ();
    void set (Nullable<CfgFlag> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.Name Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoClientDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.NoClientDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.NoClientDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoClientDbid { get; set; }
Visual Basic (Declaration)
Public Property NoClientDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoClientDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoSwitchDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.NoSwitchDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.NoSwitchDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoSwitchDbid { get; set; }
Visual Basic (Declaration)
Public Property NoSwitchDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoSwitchDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Port Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.Port Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.Port"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Port { get; set; }
Visual Basic (Declaration)
Public Property Port As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PrimaryServerDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.PrimaryServerDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.PrimaryServerDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> PrimaryServerDbid { get; set; }
Visual Basic (Declaration)
Public Property PrimaryServerDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> PrimaryServerDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SameHostAndPort Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.SameHostAndPort Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.SameHostAndPort"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SameHostAndPort { get; set; }
Visual Basic (Declaration)
Public Property SameHostAndPort As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SameHostAndPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ServerDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.ServerDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.ServerDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ServerDbid { get; set; }
Visual Basic (Declaration)
Public Property ServerDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ServerDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


StartupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.StartupType Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.StartupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgStartupType> StartupType { get; set; }
Visual Basic (Declaration)
Public Property StartupType As Nullable(Of CfgStartupType)
Visual C++
public:
property Nullable<CfgStartupType> StartupType {
    Nullable<CfgStartupType> get ();
    void set (Nullable<CfgStartupType> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.State Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SwitchDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.SwitchDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.SwitchDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SwitchDbid { get; set; }
Visual Basic (Declaration)
Public Property SwitchDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SwitchDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.TenantDbid Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgApplicationQueryEx..::.Version Property
CfgApplicationQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgApplicationQueryEx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgApplicationQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAppPrototypeQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgAppPrototypeQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgAppPrototypeQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgAppPrototypeQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAppPrototypeQueryEx

See Also

CfgAppPrototypeQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAppPrototypeQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx Members
CfgAppPrototypeQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgAppPrototypeQueryEx type exposes the following members.

Constructors

Name | Description
CfgAppPrototypeQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
AppType |
Dbid |
Name |
State |
Version |

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAppPrototypeQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx Constructor
CfgAppPrototypeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgAppPrototypeQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgAppPrototypeQueryEx()

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAppPrototypeQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx Methods
CfgAppPrototypeQueryEx Class See Also Send Feedback

The CfgAppPrototypeQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgAppPrototypeQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx Properties
CfgAppPrototypeQueryEx Class See Also Send Feedback

The CfgAppPrototypeQueryEx type exposes the following members.

Properties

Name | Description
AppType |
Dbid |
Name |
State |
Version |

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx..::.AppType Property
CfgAppPrototypeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx.AppType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgAppType> AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As Nullable(Of CfgAppType)
Visual C++
public:
property Nullable<CfgAppType> AppType {
    Nullable<CfgAppType> get ();
    void set (Nullable<CfgAppType> value);
}

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx..::.Dbid Property
CfgAppPrototypeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx..::.Name Property
CfgAppPrototypeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx..::.State Property
CfgAppPrototypeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
CfgAppPrototypeQueryEx..::.Version Property
CfgAppPrototypeQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgAppPrototypeQueryEx.Version"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

CfgAppPrototypeQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCallingListQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCallingListQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgCallingListQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgCallingListQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgCallingListQueryEx

See Also

CfgCallingListQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCallingListQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx Members
CfgCallingListQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgCallingListQueryEx type exposes the following members.

Constructors

Name | Description
CfgCallingListQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
FilterDbid |
LogTableAccessDbid |
Name |
ScriptDbid |
State |
TableAccessDbid |
TenantDbid |
TreatmentDbid |

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCallingListQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx Constructor
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCallingListQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCallingListQueryEx()

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCallingListQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx Methods
CfgCallingListQueryEx Class See Also Send Feedback

The CfgCallingListQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCallingListQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx Properties
CfgCallingListQueryEx Class See Also Send Feedback

The CfgCallingListQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
FilterDbid |
LogTableAccessDbid |
Name |
ScriptDbid |
State |
TableAccessDbid |
TenantDbid |
TreatmentDbid |

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.Dbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FilterDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.FilterDbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.FilterDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FilterDbid { get; set; }
Visual Basic (Declaration)
Public Property FilterDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FilterDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


LogTableAccessDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.LogTableAccessDbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.LogTableAccessDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> LogTableAccessDbid { get; set; }
Visual Basic (Declaration)
Public Property LogTableAccessDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> LogTableAccessDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.Name Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ScriptDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.ScriptDbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.ScriptDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ScriptDbid { get; set; }
Visual Basic (Declaration)
Public Property ScriptDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ScriptDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.State Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TableAccessDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.TableAccessDbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.TableAccessDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TableAccessDbid { get; set; }
Visual Basic (Declaration)
Public Property TableAccessDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TableAccessDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.TenantDbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TreatmentDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCallingListQueryEx..::.TreatmentDbid Property
CfgCallingListQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCallingListQueryEx.TreatmentDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TreatmentDbid { get; set; }
Visual Basic (Declaration)
Public Property TreatmentDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TreatmentDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCallingListQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignGroupQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignGroupQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgCampaignGroupQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgCampaignGroupQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgCampaignGroupQueryEx

See Also

CfgCampaignGroupQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignGroupQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx Members
CfgCampaignGroupQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgCampaignGroupQueryEx type exposes the following members.

Constructors

Name | Description
CfgCampaignGroupQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
CampaignDbid |
Dbid |
GroupDbid |
Name |
State |
TenantDbid |

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignGroupQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx Constructor
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignGroupQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignGroupQueryEx()

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignGroupQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx Methods
CfgCampaignGroupQueryEx Class See Also Send Feedback

The CfgCampaignGroupQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignGroupQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx Properties
CfgCampaignGroupQueryEx Class See Also Send Feedback

The CfgCampaignGroupQueryEx type exposes the following members.

Properties

Name | Description
CampaignDbid |
Dbid |
GroupDbid |
Name |
State |
TenantDbid |

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CampaignDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx..::.CampaignDbid Property
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.CampaignDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CampaignDbid { get; set; }
Visual Basic (Declaration)
Public Property CampaignDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CampaignDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx..::.Dbid Property
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


GroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx..::.GroupDbid Property
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.GroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GroupDbid { get; set; }
Visual Basic (Declaration)
Public Property GroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> GroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx..::.Name Property
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx..::.State Property
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignGroupQueryEx..::.TenantDbid Property
CfgCampaignGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignGroupQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgCampaignQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgCampaignQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgCampaignQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgCampaignQueryEx

See Also

CfgCampaignQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx Members
CfgCampaignQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgCampaignQueryEx type exposes the following members.

Constructors

Name | Description
CfgCampaignQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
CallingListDbid |
Dbid |
GroupDbid |
Name |
ScriptDbid |
State |
TenantDbid |

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx Constructor
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgCampaignQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgCampaignQueryEx()

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx Methods
CfgCampaignQueryEx Class See Also Send Feedback

The CfgCampaignQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgCampaignQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx Properties
CfgCampaignQueryEx Class See Also Send Feedback

The CfgCampaignQueryEx type exposes the following members.

Properties

Name | Description
CallingListDbid |
Dbid |
GroupDbid |
Name |
ScriptDbid |
State |
TenantDbid |

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CallingListDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.CallingListDbid Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.CallingListDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CallingListDbid { get; set; }
Visual Basic (Declaration)
Public Property CallingListDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CallingListDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.Dbid Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


GroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.GroupDbid Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.GroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GroupDbid { get; set; }
Visual Basic (Declaration)
Public Property GroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> GroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.Name Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ScriptDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.ScriptDbid Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.ScriptDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ScriptDbid { get; set; }
Visual Basic (Declaration)
Public Property ScriptDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ScriptDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.State Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgCampaignQueryEx..::.TenantDbid Property
CfgCampaignQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgCampaignQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgCampaignQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNGroupQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNGroupQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgDNGroupQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgDNGroupQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgDNGroupQueryEx

See Also

CfgDNGroupQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNGroupQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx Members
CfgDNGroupQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgDNGroupQueryEx type exposes the following members.

Constructors

Name | Description
CfgDNGroupQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
DnDbid |
DnGroupType |
Name |
State |
TenantDbid |

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNGroupQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx Constructor
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNGroupQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNGroupQueryEx()

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNGroupQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx Methods
CfgDNGroupQueryEx Class See Also Send Feedback

The CfgDNGroupQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNGroupQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx Properties
CfgDNGroupQueryEx Class See Also Send Feedback

The CfgDNGroupQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
DnDbid |
DnGroupType |
Name |
State |
TenantDbid |

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx..::.Dbid Property
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DnDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx..::.DnDbid Property
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.DnDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DnDbid { get; set; }
Visual Basic (Declaration)
Public Property DnDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DnDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DnGroupType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx..::.DnGroupType Property
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.DnGroupType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgDNGroupType> DnGroupType { get; set; }
Visual Basic (Declaration)
Public Property DnGroupType As Nullable(Of CfgDNGroupType)
Visual C++
public:
property Nullable<CfgDNGroupType> DnGroupType {
    Nullable<CfgDNGroupType> get ();
    void set (Nullable<CfgDNGroupType> value);
}

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx..::.Name Property
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx..::.State Property
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupQueryEx..::.TenantDbid Property
CfgDNGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNGroupQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgDNQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgDNQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgDNQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgDNQueryEx

See Also

CfgDNQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx Members
CfgDNQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgDNQueryEx type exposes the following members.

Constructors

Name | Description
CfgDNQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Association |
Dbid |
DnNumber |
DnType |
GroupDbid |
IvrDbid |
Name |
NoPlaceDbid |
PlaceDbid |
State |
SwitchDbid |
TenantDbid |

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx Constructor
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgDNQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgDNQueryEx()

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx Methods
CfgDNQueryEx Class See Also Send Feedback

The CfgDNQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgDNQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx Properties
CfgDNQueryEx Class See Also Send Feedback

The CfgDNQueryEx type exposes the following members.

Properties

Name | Description
Association |
Dbid |
DnNumber |
DnType |
GroupDbid |
IvrDbid |
Name |
NoPlaceDbid |
PlaceDbid |
State |
SwitchDbid |
TenantDbid |

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Association Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.Association Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.Association"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Association { get; set; }
Visual Basic (Declaration)
Public Property Association As String
Visual C++
public:
property String^ Association {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.Dbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DnNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.DnNumber Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.DnNumber"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DnNumber { get; set; }
Visual Basic (Declaration)
Public Property DnNumber As String
Visual C++
public:
property String^ DnNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DnType Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.DnType Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.DnType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgDNType> DnType { get; set; }
Visual Basic (Declaration)
Public Property DnType As Nullable(Of CfgDNType)
Visual C++
public:
property Nullable<CfgDNType> DnType {
    Nullable<CfgDNType> get ();
    void set (Nullable<CfgDNType> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


GroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.GroupDbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.GroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GroupDbid { get; set; }
Visual Basic (Declaration)
Public Property GroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> GroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


IvrDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.IvrDbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.IvrDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> IvrDbid { get; set; }
Visual Basic (Declaration)
Public Property IvrDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> IvrDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.Name Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoPlaceDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.NoPlaceDbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.NoPlaceDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoPlaceDbid { get; set; }
Visual Basic (Declaration)
Public Property NoPlaceDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoPlaceDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PlaceDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.PlaceDbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.PlaceDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> PlaceDbid { get; set; }
Visual Basic (Declaration)
Public Property PlaceDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> PlaceDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.State Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SwitchDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.SwitchDbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.SwitchDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SwitchDbid { get; set; }
Visual Basic (Declaration)
Public Property SwitchDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SwitchDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgDNQueryEx..::.TenantDbid Property
CfgDNQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgDNQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgDNQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgEnumeratorQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgEnumeratorQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgEnumeratorQueryEx

See Also

CfgEnumeratorQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx Members
CfgEnumeratorQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgEnumeratorQueryEx type exposes the following members.

Constructors

Name | Description
CfgEnumeratorQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
DisplayName |
EnumeratorType |
Name |
State |
TenantDbid |

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx Constructor
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgEnumeratorQueryEx()

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx Methods
CfgEnumeratorQueryEx Class See Also Send Feedback

The CfgEnumeratorQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx Properties
CfgEnumeratorQueryEx Class See Also Send Feedback

The CfgEnumeratorQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
DisplayName |
EnumeratorType |
Name |
State |
TenantDbid |

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx..::.Dbid Property
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx..::.DisplayName Property
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


EnumeratorType Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx..::.EnumeratorType Property
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.EnumeratorType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> EnumeratorType { get; set; }
Visual Basic (Declaration)
Public Property EnumeratorType As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> EnumeratorType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx..::.Name Property
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx..::.State Property
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorQueryEx..::.TenantDbid Property
CfgEnumeratorQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorValueQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgEnumeratorValueQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgEnumeratorValueQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgEnumeratorValueQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgEnumeratorValueQueryEx

See Also

CfgEnumeratorValueQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorValueQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx Members
CfgEnumeratorValueQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgEnumeratorValueQueryEx type exposes the following members.

Constructors

Name | Description
CfgEnumeratorValueQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
DefaultValue |
DisplayName |
EnumeratorDbid |
Name |
State |
TenantDbid |

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorValueQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx Constructor
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgEnumeratorValueQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgEnumeratorValueQueryEx()

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorValueQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx Methods
CfgEnumeratorValueQueryEx Class See Also Send Feedback

The CfgEnumeratorValueQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgEnumeratorValueQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx Properties
CfgEnumeratorValueQueryEx Class See Also Send Feedback

The CfgEnumeratorValueQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
DefaultValue |
DisplayName |
EnumeratorDbid |
Name |
State |
TenantDbid |

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.Dbid Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DefaultValue Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.DefaultValue Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.DefaultValue"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DefaultValue {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.DisplayName Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.DisplayName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


EnumeratorDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.EnumeratorDbid Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.EnumeratorDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> EnumeratorDbid { get; set; }
Visual Basic (Declaration)
Public Property EnumeratorDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> EnumeratorDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.Name Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.State Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorValueQueryEx..::.TenantDbid Property
CfgEnumeratorValueQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgEnumeratorValueQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgEnumeratorValueQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFieldQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFieldQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgFieldQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgFieldQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFieldQueryEx

See Also

CfgFieldQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFieldQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx Members
CfgFieldQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgFieldQueryEx type exposes the following members.

Constructors

Name | Description
CfgFieldQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
FieldType |
FormatDbid |
Name |
State |
TenantDbid |
Type |

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFieldQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx Constructor
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFieldQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFieldQueryEx()

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFieldQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx Methods
CfgFieldQueryEx Class See Also Send Feedback

The CfgFieldQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFieldQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx Properties
CfgFieldQueryEx Class See Also Send Feedback

The CfgFieldQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
FieldType |
FormatDbid |
Name |
State |
TenantDbid |
Type |

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.Dbid Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FieldType Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.FieldType Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.FieldType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgFieldType> FieldType { get; set; }
Visual Basic (Declaration)
Public Property FieldType As Nullable(Of CfgFieldType)
Visual C++
public:
property Nullable<CfgFieldType> FieldType {
    Nullable<CfgFieldType> get ();
    void set (Nullable<CfgFieldType> value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FormatDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.FormatDbid Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.FormatDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FormatDbid { get; set; }
Visual Basic (Declaration)
Public Property FormatDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FormatDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.Name Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.State Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.TenantDbid Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgFieldQueryEx..::.Type Property
CfgFieldQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFieldQueryEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgDataType> Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Nullable(Of CfgDataType)
Visual C++
public:
property Nullable<CfgDataType> Type {
    Nullable<CfgDataType> get ();
    void set (Nullable<CfgDataType> value);
}

See Also

CfgFieldQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFilterQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFilterQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgFilterQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgFilterQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFilterQueryEx

See Also

CfgFilterQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFilterQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx Members
CfgFilterQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgFilterQueryEx type exposes the following members.

Constructors

Name | Description
CfgFilterQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
FormatDbid |
Name |
State |
TenantDbid |

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFilterQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx Constructor
CfgFilterQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilterQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFilterQueryEx()

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFilterQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx Methods
CfgFilterQueryEx Class See Also Send Feedback

The CfgFilterQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFilterQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx Properties
CfgFilterQueryEx Class See Also Send Feedback

The CfgFilterQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
FormatDbid |
Name |
State |
TenantDbid |

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx..::.Dbid Property
CfgFilterQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FormatDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx..::.FormatDbid Property
CfgFilterQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx.FormatDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FormatDbid { get; set; }
Visual Basic (Declaration)
Public Property FormatDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FormatDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx..::.Name Property
CfgFilterQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx..::.State Property
CfgFilterQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterQueryEx..::.TenantDbid Property
CfgFilterQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFilterQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFilterQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFolderQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFolderQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgFolderQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgFolderQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFolderQueryEx

See Also

CfgFolderQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFolderQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx Members
CfgFolderQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgFolderQueryEx type exposes the following members.

Constructors

Name | Description
CfgFolderQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
DefaultFolder |
FolderClass |
Name |
ObjectDbid |
ObjectType |
OwnerDbid |
OwnerType |
State |
Type |

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFolderQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx Constructor
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFolderQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFolderQueryEx()

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFolderQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx Methods
CfgFolderQueryEx Class See Also Send Feedback

The CfgFolderQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFolderQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx Properties
CfgFolderQueryEx Class See Also Send Feedback

The CfgFolderQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
DefaultFolder |
FolderClass |
Name |
ObjectDbid |
ObjectType |
OwnerDbid |
OwnerType |
State |
Type |

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.Dbid Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DefaultFolder Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.DefaultFolder Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.DefaultFolder"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DefaultFolder { get; set; }
Visual Basic (Declaration)
Public Property DefaultFolder As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DefaultFolder {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FolderClass Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.FolderClass Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.FolderClass"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FolderClass { get; set; }
Visual Basic (Declaration)
Public Property FolderClass As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FolderClass {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.Name Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ObjectDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.ObjectDbid Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.ObjectDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ObjectDbid { get; set; }
Visual Basic (Declaration)
Public Property ObjectDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ObjectDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.ObjectType Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ObjectType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


OwnerDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.OwnerDbid Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.OwnerDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> OwnerDbid { get; set; }
Visual Basic (Declaration)
Public Property OwnerDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> OwnerDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


OwnerType Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.OwnerType Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.OwnerType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> OwnerType { get; set; }
Visual Basic (Declaration)
Public Property OwnerType As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> OwnerType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.State Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgFolderQueryEx..::.Type Property
CfgFolderQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFolderQueryEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Type {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFolderQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFormatQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFormatQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgFormatQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgFormatQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFormatQueryEx

See Also

CfgFormatQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFormatQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx Members
CfgFormatQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgFormatQueryEx type exposes the following members.

Constructors

Name | Description
CfgFormatQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
FieldDbid |
Name |
State |
TenantDbid |

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFormatQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx Constructor
CfgFormatQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFormatQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFormatQueryEx()

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFormatQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx Methods
CfgFormatQueryEx Class See Also Send Feedback

The CfgFormatQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgFormatQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx Properties
CfgFormatQueryEx Class See Also Send Feedback

The CfgFormatQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
FieldDbid |
Name |
State |
TenantDbid |

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx..::.Dbid Property
CfgFormatQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FieldDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx..::.FieldDbid Property
CfgFormatQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx.FieldDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FieldDbid { get; set; }
Visual Basic (Declaration)
Public Property FieldDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FieldDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx..::.Name Property
CfgFormatQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx..::.State Property
CfgFormatQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgFormatQueryEx..::.TenantDbid Property
CfgFormatQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgFormatQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgFormatQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgGVPIVRProfileQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgGVPIVRProfileQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgGVPIVRProfileQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgGVPIVRProfileQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgGVPIVRProfileQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgGVPIVRProfileQueryEx

See Also

CfgGVPIVRProfileQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgGVPIVRProfileQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx Members
CfgGVPIVRProfileQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgGVPIVRProfileQueryEx type exposes the following members.

Constructors

Name | Description
CfgGVPIVRProfileQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgGVPIVRProfileQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx Constructor
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgGVPIVRProfileQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgGVPIVRProfileQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgGVPIVRProfileQueryEx()

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgGVPIVRProfileQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx Methods
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

The CfgGVPIVRProfileQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgGVPIVRProfileQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx Properties
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

The CfgGVPIVRProfileQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx..::.Dbid Property
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgGVPIVRProfileQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx..::.Name Property
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgGVPIVRProfileQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx..::.State Property
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgGVPIVRProfileQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgGVPIVRProfileQueryEx..::.TenantDbid Property
CfgGVPIVRProfileQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgGVPIVRProfileQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgGVPIVRProfileQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgHostQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgHostQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgHostQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgHostQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgHostQueryEx

See Also

CfgHostQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgHostQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx Members
CfgHostQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgHostQueryEx type exposes the following members.

Constructors

Name | Description
CfgHostQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
HostType |
Name |
OsType |
ScsDbid |
State |

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgHostQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx Constructor
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgHostQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgHostQueryEx()

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgHostQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx Methods
CfgHostQueryEx Class See Also Send Feedback

The CfgHostQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgHostQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx Properties
CfgHostQueryEx Class See Also Send Feedback

The CfgHostQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
HostType |
Name |
OsType |
ScsDbid |
State |

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx..::.Dbid Property
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


HostType Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx..::.HostType Property
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.HostType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgHostType> HostType { get; set; }
Visual Basic (Declaration)
Public Property HostType As Nullable(Of CfgHostType)
Visual C++
public:
property Nullable<CfgHostType> HostType {
    Nullable<CfgHostType> get ();
    void set (Nullable<CfgHostType> value);
}

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx..::.Name Property
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


OsType Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx..::.OsType Property
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.OsType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgOSType> OsType { get; set; }
Visual Basic (Declaration)
Public Property OsType As Nullable(Of CfgOSType)
Visual C++
public:
property Nullable<CfgOSType> OsType {
    Nullable<CfgOSType> get ();
    void set (Nullable<CfgOSType> value);
}

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ScsDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx..::.ScsDbid Property
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.ScsDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ScsDbid { get; set; }
Visual Basic (Declaration)
Public Property ScsDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ScsDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgHostQueryEx..::.State Property
CfgHostQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgHostQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgHostQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRPortQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVRPortQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgIVRPortQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgIVRPortQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgIVRPortQueryEx

See Also

CfgIVRPortQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRPortQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx Members
CfgIVRPortQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgIVRPortQueryEx type exposes the following members.

Constructors

Name | Description
CfgIVRPortQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
DnDbid |
IvrDbid |
PortNumber |
State |
TenantDbid |

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRPortQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx Constructor
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRPortQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIVRPortQueryEx()

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRPortQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx Methods
CfgIVRPortQueryEx Class See Also Send Feedback

The CfgIVRPortQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRPortQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx Properties
CfgIVRPortQueryEx Class See Also Send Feedback

The CfgIVRPortQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
DnDbid |
IvrDbid |
PortNumber |
State |
TenantDbid |

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx..::.Dbid Property
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DnDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx..::.DnDbid Property
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.DnDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DnDbid { get; set; }
Visual Basic (Declaration)
Public Property DnDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DnDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


IvrDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx..::.IvrDbid Property
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.IvrDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> IvrDbid { get; set; }
Visual Basic (Declaration)
Public Property IvrDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> IvrDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PortNumber Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx..::.PortNumber Property
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.PortNumber"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string PortNumber { get; set; }
Visual Basic (Declaration)
Public Property PortNumber As String
Visual C++
public:
property String^ PortNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx..::.State Property
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRPortQueryEx..::.TenantDbid Property
CfgIVRPortQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRPortQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRPortQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgIVRQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgIVRQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgIVRQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgIVRQueryEx

See Also

CfgIVRQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx Members
CfgIVRQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgIVRQueryEx type exposes the following members.

Constructors

Name | Description
CfgIVRQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
IvrServerDbid |
Name |
State |
TenantDbid |
Type |

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx Constructor
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgIVRQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgIVRQueryEx()

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx Methods
CfgIVRQueryEx Class See Also Send Feedback

The CfgIVRQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgIVRQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx Properties
CfgIVRQueryEx Class See Also Send Feedback

The CfgIVRQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
IvrServerDbid |
Name |
State |
TenantDbid |
Type |

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx..::.Dbid Property
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


IvrServerDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx..::.IvrServerDbid Property
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.IvrServerDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> IvrServerDbid { get; set; }
Visual Basic (Declaration)
Public Property IvrServerDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> IvrServerDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx..::.Name Property
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx..::.State Property
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx..::.TenantDbid Property
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgIVRQueryEx..::.Type Property
CfgIVRQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgIVRQueryEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgIVRType> Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Nullable(Of CfgIVRType)
Visual C++
public:
property Nullable<CfgIVRType> Type {
    Nullable<CfgIVRType> get ();
    void set (Nullable<CfgIVRType> value);
}

See Also

CfgIVRQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgObjectiveTableQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgObjectiveTableQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgObjectiveTableQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgObjectiveTableQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgObjectiveTableQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgObjectiveTableQueryEx

See Also

CfgObjectiveTableQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgObjectiveTableQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx Members
CfgObjectiveTableQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgObjectiveTableQueryEx type exposes the following members.

Constructors

Name | Description
CfgObjectiveTableQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgObjectiveTableQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx Constructor
CfgObjectiveTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgObjectiveTableQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgObjectiveTableQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgObjectiveTableQueryEx()

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgObjectiveTableQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx Methods
CfgObjectiveTableQueryEx Class See Also Send Feedback

The CfgObjectiveTableQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgObjectiveTableQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx Properties
CfgObjectiveTableQueryEx Class See Also Send Feedback

The CfgObjectiveTableQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx..::.Dbid Property
CfgObjectiveTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgObjectiveTableQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx..::.Name Property
CfgObjectiveTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgObjectiveTableQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx..::.State Property
CfgObjectiveTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgObjectiveTableQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableQueryEx..::.TenantDbid Property
CfgObjectiveTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgObjectiveTableQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgObjectiveTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPersonQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPersonQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgPersonQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgPersonQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPersonQueryEx

See Also

CfgPersonQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPersonQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx Members
CfgPersonQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgPersonQueryEx type exposes the following members.

Constructors

Name | Description
CfgPersonQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
EmployeeId |
FirstName |
GroupDbid |
IsAgent |
LastName |
LoginDbid |
NoLoginDbid |
NoPlaceDbid |
SkillDbid |
State |
SwitchDbid |
TenantDbid |
UserName |

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPersonQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx Constructor
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPersonQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPersonQueryEx()

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPersonQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx Methods
CfgPersonQueryEx Class See Also Send Feedback

The CfgPersonQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPersonQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx Properties
CfgPersonQueryEx Class See Also Send Feedback

The CfgPersonQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
EmployeeId |
FirstName |
GroupDbid |
IsAgent |
LastName |
LoginDbid |
NoLoginDbid |
NoPlaceDbid |
SkillDbid |
State |
SwitchDbid |
TenantDbid |
UserName |

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.Dbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


EmployeeId Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.EmployeeId Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.EmployeeId"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string EmployeeId { get; set; }
Visual Basic (Declaration)
Public Property EmployeeId As String
Visual C++
public:
property String^ EmployeeId {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.FirstName Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.FirstName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


GroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.GroupDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.GroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GroupDbid { get; set; }
Visual Basic (Declaration)
Public Property GroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> GroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.IsAgent Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.IsAgent"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> IsAgent { get; set; }
Visual Basic (Declaration)
Public Property IsAgent As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> IsAgent {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.LastName Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.LastName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


LoginDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.LoginDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.LoginDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> LoginDbid { get; set; }
Visual Basic (Declaration)
Public Property LoginDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> LoginDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoLoginDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.NoLoginDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.NoLoginDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoLoginDbid { get; set; }
Visual Basic (Declaration)
Public Property NoLoginDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoLoginDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoPlaceDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.NoPlaceDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.NoPlaceDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoPlaceDbid { get; set; }
Visual Basic (Declaration)
Public Property NoPlaceDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoPlaceDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SkillDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.SkillDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.SkillDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SkillDbid { get; set; }
Visual Basic (Declaration)
Public Property SkillDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SkillDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.State Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SwitchDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.SwitchDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.SwitchDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SwitchDbid { get; set; }
Visual Basic (Declaration)
Public Property SwitchDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SwitchDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.TenantDbid Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
CfgPersonQueryEx..::.UserName Property
CfgPersonQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPersonQueryEx.UserName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPersonQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPhysicalSwitchQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPhysicalSwitchQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPhysicalSwitchQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgPhysicalSwitchQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgPhysicalSwitchQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPhysicalSwitchQueryEx

See Also

CfgPhysicalSwitchQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPhysicalSwitchQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx Members
CfgPhysicalSwitchQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgPhysicalSwitchQueryEx type exposes the following members.

Constructors

Name | Description
CfgPhysicalSwitchQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
FolderDbid |
Name |
State |

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPhysicalSwitchQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx Constructor
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPhysicalSwitchQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPhysicalSwitchQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPhysicalSwitchQueryEx()

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPhysicalSwitchQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx Methods
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

The CfgPhysicalSwitchQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPhysicalSwitchQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx Properties
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

The CfgPhysicalSwitchQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
FolderDbid |
Name |
State |

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx..::.Dbid Property
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPhysicalSwitchQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FolderDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx..::.FolderDbid Property
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPhysicalSwitchQueryEx.FolderDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FolderDbid { get; set; }
Visual Basic (Declaration)
Public Property FolderDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FolderDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx..::.Name Property
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPhysicalSwitchQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPhysicalSwitchQueryEx..::.State Property
CfgPhysicalSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPhysicalSwitchQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgPhysicalSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceGroupQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceGroupQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgPlaceGroupQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgPlaceGroupQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPlaceGroupQueryEx

See Also

CfgPlaceGroupQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceGroupQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx Members
CfgPlaceGroupQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgPlaceGroupQueryEx type exposes the following members.

Constructors

Name | Description
CfgPlaceGroupQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
PlaceDbid |
State |
TenantDbid |

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceGroupQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx Constructor
CfgPlaceGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceGroupQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPlaceGroupQueryEx()

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceGroupQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx Methods
CfgPlaceGroupQueryEx Class See Also Send Feedback

The CfgPlaceGroupQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceGroupQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx Properties
CfgPlaceGroupQueryEx Class See Also Send Feedback

The CfgPlaceGroupQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
PlaceDbid |
State |
TenantDbid |

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx..::.Dbid Property
CfgPlaceGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx..::.Name Property
CfgPlaceGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PlaceDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx..::.PlaceDbid Property
CfgPlaceGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx.PlaceDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> PlaceDbid { get; set; }
Visual Basic (Declaration)
Public Property PlaceDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> PlaceDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx..::.State Property
CfgPlaceGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceGroupQueryEx..::.TenantDbid Property
CfgPlaceGroupQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceGroupQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceGroupQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgPlaceQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgPlaceQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgPlaceQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPlaceQueryEx

See Also

CfgPlaceQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx Members
CfgPlaceQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgPlaceQueryEx type exposes the following members.

Constructors

Name | Description
CfgPlaceQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
DnDbid |
GroupDbid |
Name |
NoDnDbid |
PersonDbid |
State |
TenantDbid |

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx Constructor
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgPlaceQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgPlaceQueryEx()

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx Methods
CfgPlaceQueryEx Class See Also Send Feedback

The CfgPlaceQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgPlaceQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx Properties
CfgPlaceQueryEx Class See Also Send Feedback

The CfgPlaceQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
DnDbid |
GroupDbid |
Name |
NoDnDbid |
PersonDbid |
State |
TenantDbid |

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.Dbid Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DnDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.DnDbid Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.DnDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DnDbid { get; set; }
Visual Basic (Declaration)
Public Property DnDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DnDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


GroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.GroupDbid Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.GroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GroupDbid { get; set; }
Visual Basic (Declaration)
Public Property GroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> GroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.Name Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NoDnDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.NoDnDbid Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.NoDnDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> NoDnDbid { get; set; }
Visual Basic (Declaration)
Public Property NoDnDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> NoDnDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


PersonDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.PersonDbid Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.PersonDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> PersonDbid { get; set; }
Visual Basic (Declaration)
Public Property PersonDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> PersonDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.State Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgPlaceQueryEx..::.TenantDbid Property
CfgPlaceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgPlaceQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgPlaceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CfgQueryEx
Visual Basic (Declaration)
Public MustInherit Class CfgQueryEx
Visual C++
public ref class CfgQueryEx abstract

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAccessGroupQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgActionCodeQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAgentGroupQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAgentLoginQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAlarmConditionQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgApplicationQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgAppPrototypeQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgCallingListQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgCampaignGroupQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgCampaignQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgDNGroupQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgDNQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgEnumeratorQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgEnumeratorValueQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFieldQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFilterQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFolderQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgFormatQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgGVPIVRProfileQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgHostQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgIVRPortQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgIVRQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgObjectiveTableQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPersonQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPhysicalSwitchQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPlaceGroupQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgPlaceQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgScheduledTaskQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgScriptQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgServiceQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgSkillQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgStatDayQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgStatTableQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgSwitchQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTableAccessQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTenantQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTimeZoneQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTransactionQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTreatmentQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgVoicePromptQueryEx

See Also

CfgQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryEx Members
CfgQueryEx Class Methods See Also Send Feedback

The CfgQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

CfgQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryEx Methods
CfgQueryEx Class See Also Send Feedback

The CfgQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

CfgQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryEx..::.ToString Method
CfgQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx.ToString"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx.ToString"]

See Also

CfgQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScheduledTaskQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScheduledTaskQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScheduledTaskQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgScheduledTaskQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgScheduledTaskQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgScheduledTaskQueryEx

See Also

CfgScheduledTaskQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScheduledTaskQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx Members
CfgScheduledTaskQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgScheduledTaskQueryEx type exposes the following members.

Constructors

Name | Description
CfgScheduledTaskQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
State |
TaskType |

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScheduledTaskQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx Constructor
CfgScheduledTaskQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScheduledTaskQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScheduledTaskQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgScheduledTaskQueryEx()

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScheduledTaskQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx Methods
CfgScheduledTaskQueryEx Class See Also Send Feedback

The CfgScheduledTaskQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScheduledTaskQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx Properties
CfgScheduledTaskQueryEx Class See Also Send Feedback

The CfgScheduledTaskQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
State |
TaskType |

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx..::.Dbid Property
CfgScheduledTaskQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScheduledTaskQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx..::.Name Property
CfgScheduledTaskQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScheduledTaskQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx..::.State Property
CfgScheduledTaskQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScheduledTaskQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TaskType Property

[image]

Enterprise SDK 8.0 Reference API
CfgScheduledTaskQueryEx..::.TaskType Property
CfgScheduledTaskQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScheduledTaskQueryEx.TaskType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgTaskType> TaskType { get; set; }
Visual Basic (Declaration)
Public Property TaskType As Nullable(Of CfgTaskType)
Visual C++
public:
property Nullable<CfgTaskType> TaskType {
    Nullable<CfgTaskType> get ();
    void set (Nullable<CfgTaskType> value);
}

See Also

CfgScheduledTaskQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScriptQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgScriptQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgScriptQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgScriptQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgScriptQueryEx

See Also

CfgScriptQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScriptQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx Members
CfgScriptQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgScriptQueryEx type exposes the following members.

Constructors

Name | Description
CfgScriptQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
CapacityAgentDbid |
CapacityAgentGroupDbid |
CapacityPlaceDbid |
CapacityPlaceGroupDbid |
CapacityTenantDbid |
Dbid |
ExcludeBytecode |
ExcludeLongstrings |
Name |
ScriptType |
State |
TenantDbid |

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScriptQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx Constructor
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgScriptQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgScriptQueryEx()

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScriptQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx Methods
CfgScriptQueryEx Class See Also Send Feedback

The CfgScriptQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgScriptQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx Properties
CfgScriptQueryEx Class See Also Send Feedback

The CfgScriptQueryEx type exposes the following members.

Properties

Name | Description
CapacityAgentDbid |
CapacityAgentGroupDbid |
CapacityPlaceDbid |
CapacityPlaceGroupDbid |
CapacityTenantDbid |
Dbid |
ExcludeBytecode |
ExcludeLongstrings |
Name |
ScriptType |
State |
TenantDbid |

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CapacityAgentDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.CapacityAgentDbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.CapacityAgentDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CapacityAgentDbid { get; set; }
Visual Basic (Declaration)
Public Property CapacityAgentDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CapacityAgentDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CapacityAgentGroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.CapacityAgentGroupDbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.CapacityAgentGroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CapacityAgentGroupDbid { get; set; }
Visual Basic (Declaration)
Public Property CapacityAgentGroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CapacityAgentGroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CapacityPlaceDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.CapacityPlaceDbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.CapacityPlaceDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CapacityPlaceDbid { get; set; }
Visual Basic (Declaration)
Public Property CapacityPlaceDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CapacityPlaceDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CapacityPlaceGroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.CapacityPlaceGroupDbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.CapacityPlaceGroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CapacityPlaceGroupDbid { get; set; }
Visual Basic (Declaration)
Public Property CapacityPlaceGroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CapacityPlaceGroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CapacityTenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.CapacityTenantDbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.CapacityTenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> CapacityTenantDbid { get; set; }
Visual Basic (Declaration)
Public Property CapacityTenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> CapacityTenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.Dbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ExcludeBytecode Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.ExcludeBytecode Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.ExcludeBytecode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ExcludeBytecode { get; set; }
Visual Basic (Declaration)
Public Property ExcludeBytecode As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ExcludeBytecode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ExcludeLongstrings Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.ExcludeLongstrings Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.ExcludeLongstrings"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ExcludeLongstrings { get; set; }
Visual Basic (Declaration)
Public Property ExcludeLongstrings As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ExcludeLongstrings {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.Name Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ScriptType Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.ScriptType Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.ScriptType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgScriptType> ScriptType { get; set; }
Visual Basic (Declaration)
Public Property ScriptType As Nullable(Of CfgScriptType)
Visual C++
public:
property Nullable<CfgScriptType> ScriptType {
    Nullable<CfgScriptType> get ();
    void set (Nullable<CfgScriptType> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.State Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgScriptQueryEx..::.TenantDbid Property
CfgScriptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgScriptQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgScriptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgServiceQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgServiceQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgServiceQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgServiceQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgServiceQueryEx

See Also

CfgServiceQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgServiceQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx Members
CfgServiceQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgServiceQueryEx type exposes the following members.

Constructors

Name | Description
CfgServiceQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
AppDbid |
AppType |
Dbid |
FolderDbid |
Name |
ScsDbid |
State |
TenantDbid |
Type |

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgServiceQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx Constructor
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgServiceQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgServiceQueryEx()

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgServiceQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx Methods
CfgServiceQueryEx Class See Also Send Feedback

The CfgServiceQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgServiceQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx Properties
CfgServiceQueryEx Class See Also Send Feedback

The CfgServiceQueryEx type exposes the following members.

Properties

Name | Description
AppDbid |
AppType |
Dbid |
FolderDbid |
Name |
ScsDbid |
State |
TenantDbid |
Type |

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AppDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.AppDbid Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.AppDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> AppDbid { get; set; }
Visual Basic (Declaration)
Public Property AppDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> AppDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AppType Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.AppType Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.AppType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgAppType> AppType { get; set; }
Visual Basic (Declaration)
Public Property AppType As Nullable(Of CfgAppType)
Visual C++
public:
property Nullable<CfgAppType> AppType {
    Nullable<CfgAppType> get ();
    void set (Nullable<CfgAppType> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.Dbid Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FolderDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.FolderDbid Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.FolderDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FolderDbid { get; set; }
Visual Basic (Declaration)
Public Property FolderDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FolderDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.Name Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ScsDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.ScsDbid Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.ScsDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ScsDbid { get; set; }
Visual Basic (Declaration)
Public Property ScsDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ScsDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.State Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.TenantDbid Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgServiceQueryEx..::.Type Property
CfgServiceQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgServiceQueryEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Type {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgServiceQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSkillQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSkillQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSkillQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgSkillQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgSkillQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgSkillQueryEx

See Also

CfgSkillQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSkillQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx Members
CfgSkillQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgSkillQueryEx type exposes the following members.

Constructors

Name | Description
CfgSkillQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSkillQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx Constructor
CfgSkillQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSkillQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSkillQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSkillQueryEx()

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSkillQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx Methods
CfgSkillQueryEx Class See Also Send Feedback

The CfgSkillQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSkillQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx Properties
CfgSkillQueryEx Class See Also Send Feedback

The CfgSkillQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx..::.Dbid Property
CfgSkillQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSkillQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx..::.Name Property
CfgSkillQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSkillQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx..::.State Property
CfgSkillQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSkillQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgSkillQueryEx..::.TenantDbid Property
CfgSkillQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSkillQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgSkillQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatDayQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatDayQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgStatDayQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgStatDayQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgStatDayQueryEx

See Also

CfgStatDayQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatDayQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx Members
CfgStatDayQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgStatDayQueryEx type exposes the following members.

Constructors

Name | Description
CfgStatDayQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
StatdayType |
State |
TableDbid |
TenantDbid |

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatDayQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx Constructor
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatDayQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatDayQueryEx()

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatDayQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx Methods
CfgStatDayQueryEx Class See Also Send Feedback

The CfgStatDayQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatDayQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx Properties
CfgStatDayQueryEx Class See Also Send Feedback

The CfgStatDayQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
StatdayType |
State |
TableDbid |
TenantDbid |

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx..::.Dbid Property
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx..::.Name Property
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


StatdayType Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx..::.StatdayType Property
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.StatdayType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgStatDayType> StatdayType { get; set; }
Visual Basic (Declaration)
Public Property StatdayType As Nullable(Of CfgStatDayType)
Visual C++
public:
property Nullable<CfgStatDayType> StatdayType {
    Nullable<CfgStatDayType> get ();
    void set (Nullable<CfgStatDayType> value);
}

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx..::.State Property
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TableDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx..::.TableDbid Property
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.TableDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TableDbid { get; set; }
Visual Basic (Declaration)
Public Property TableDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TableDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayQueryEx..::.TenantDbid Property
CfgStatDayQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatDayQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatDayQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatTableQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgStatTableQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgStatTableQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgStatTableQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgStatTableQueryEx

See Also

CfgStatTableQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatTableQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx Members
CfgStatTableQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgStatTableQueryEx type exposes the following members.

Constructors

Name | Description
CfgStatTableQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
GroupDbid |
Name |
StatDayDbid |
State |
TableType |
TenantDbid |

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatTableQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx Constructor
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgStatTableQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgStatTableQueryEx()

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatTableQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx Methods
CfgStatTableQueryEx Class See Also Send Feedback

The CfgStatTableQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgStatTableQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx Properties
CfgStatTableQueryEx Class See Also Send Feedback

The CfgStatTableQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
GroupDbid |
Name |
StatDayDbid |
State |
TableType |
TenantDbid |

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.Dbid Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


GroupDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.GroupDbid Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.GroupDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GroupDbid { get; set; }
Visual Basic (Declaration)
Public Property GroupDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> GroupDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.Name Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


StatDayDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.StatDayDbid Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.StatDayDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> StatDayDbid { get; set; }
Visual Basic (Declaration)
Public Property StatDayDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> StatDayDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.State Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TableType Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.TableType Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.TableType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TableType { get; set; }
Visual Basic (Declaration)
Public Property TableType As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TableType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableQueryEx..::.TenantDbid Property
CfgStatTableQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgStatTableQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgStatTableQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSwitchQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgSwitchQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgSwitchQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgSwitchQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgSwitchQueryEx

See Also

CfgSwitchQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSwitchQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx Members
CfgSwitchQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgSwitchQueryEx type exposes the following members.

Constructors

Name | Description
CfgSwitchQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |
TserverDbid |

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSwitchQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx Constructor
CfgSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgSwitchQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgSwitchQueryEx()

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSwitchQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx Methods
CfgSwitchQueryEx Class See Also Send Feedback

The CfgSwitchQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgSwitchQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx Properties
CfgSwitchQueryEx Class See Also Send Feedback

The CfgSwitchQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
State |
TenantDbid |
TserverDbid |

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx..::.Dbid Property
CfgSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx..::.Name Property
CfgSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx..::.State Property
CfgSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx..::.TenantDbid Property
CfgSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TserverDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchQueryEx..::.TserverDbid Property
CfgSwitchQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgSwitchQueryEx.TserverDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TserverDbid { get; set; }
Visual Basic (Declaration)
Public Property TserverDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TserverDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgSwitchQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTableAccessQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTableAccessQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgTableAccessQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgTableAccessQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTableAccessQueryEx

See Also

CfgTableAccessQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTableAccessQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx Members
CfgTableAccessQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgTableAccessQueryEx type exposes the following members.

Constructors

Name | Description
CfgTableAccessQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
DbaccessDbid |
Dbid |
DbTableName |
FormatDbid |
Name |
State |
TenantDbid |
Type |

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTableAccessQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx Constructor
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTableAccessQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTableAccessQueryEx()

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTableAccessQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx Methods
CfgTableAccessQueryEx Class See Also Send Feedback

The CfgTableAccessQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTableAccessQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx Properties
CfgTableAccessQueryEx Class See Also Send Feedback

The CfgTableAccessQueryEx type exposes the following members.

Properties

Name | Description
DbaccessDbid |
Dbid |
DbTableName |
FormatDbid |
Name |
State |
TenantDbid |
Type |

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DbaccessDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.DbaccessDbid Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.DbaccessDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DbaccessDbid { get; set; }
Visual Basic (Declaration)
Public Property DbaccessDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DbaccessDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.Dbid Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DbTableName Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.DbTableName Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.DbTableName"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string DbTableName { get; set; }
Visual Basic (Declaration)
Public Property DbTableName As String
Visual C++
public:
property String^ DbTableName {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


FormatDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.FormatDbid Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.FormatDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> FormatDbid { get; set; }
Visual Basic (Declaration)
Public Property FormatDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> FormatDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.Name Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.State Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.TenantDbid Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgTableAccessQueryEx..::.Type Property
CfgTableAccessQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTableAccessQueryEx.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgTableType> Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Nullable(Of CfgTableType)
Visual C++
public:
property Nullable<CfgTableType> Type {
    Nullable<CfgTableType> get ();
    void set (Nullable<CfgTableType> value);
}

See Also

CfgTableAccessQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTenantQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTenantQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTenantQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgTenantQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgTenantQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTenantQueryEx

See Also

CfgTenantQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTenantQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx Members
CfgTenantQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgTenantQueryEx type exposes the following members.

Constructors

Name | Description
CfgTenantQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
AllTenants |
Dbid |
Name |
State |

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTenantQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx Constructor
CfgTenantQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTenantQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTenantQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTenantQueryEx()

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTenantQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx Methods
CfgTenantQueryEx Class See Also Send Feedback

The CfgTenantQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTenantQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx Properties
CfgTenantQueryEx Class See Also Send Feedback

The CfgTenantQueryEx type exposes the following members.

Properties

Name | Description
AllTenants |
Dbid |
Name |
State |

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


AllTenants Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx..::.AllTenants Property
CfgTenantQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTenantQueryEx.AllTenants"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> AllTenants { get; set; }
Visual Basic (Declaration)
Public Property AllTenants As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> AllTenants {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx..::.Dbid Property
CfgTenantQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTenantQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx..::.Name Property
CfgTenantQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTenantQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTenantQueryEx..::.State Property
CfgTenantQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTenantQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgTenantQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTimeZoneQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTimeZoneQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgTimeZoneQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgTimeZoneQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTimeZoneQueryEx

See Also

CfgTimeZoneQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTimeZoneQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx Members
CfgTimeZoneQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgTimeZoneQueryEx type exposes the following members.

Constructors

Name | Description
CfgTimeZoneQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
NameMsexplorer |
NameNetscape |
Offset |
State |
TenantDbid |

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTimeZoneQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx Constructor
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTimeZoneQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTimeZoneQueryEx()

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTimeZoneQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx Methods
CfgTimeZoneQueryEx Class See Also Send Feedback

The CfgTimeZoneQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTimeZoneQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx Properties
CfgTimeZoneQueryEx Class See Also Send Feedback

The CfgTimeZoneQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
NameMsexplorer |
NameNetscape |
Offset |
State |
TenantDbid |

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.Dbid Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.Name Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NameMsexplorer Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.NameMsexplorer Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.NameMsexplorer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameMsexplorer { get; set; }
Visual Basic (Declaration)
Public Property NameMsexplorer As String
Visual C++
public:
property String^ NameMsexplorer {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


NameNetscape Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.NameNetscape Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.NameNetscape"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string NameNetscape { get; set; }
Visual Basic (Declaration)
Public Property NameNetscape As String
Visual C++
public:
property String^ NameNetscape {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Offset Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.Offset Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.Offset"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Offset {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.State Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTimeZoneQueryEx..::.TenantDbid Property
CfgTimeZoneQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTimeZoneQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTimeZoneQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTransactionQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTransactionQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgTransactionQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgTransactionQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTransactionQueryEx

See Also

CfgTransactionQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTransactionQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx Members
CfgTransactionQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgTransactionQueryEx type exposes the following members.

Constructors

Name | Description
CfgTransactionQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
ObjectType |
State |
TenantDbid |

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTransactionQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx Constructor
CfgTransactionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTransactionQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTransactionQueryEx()

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTransactionQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx Methods
CfgTransactionQueryEx Class See Also Send Feedback

The CfgTransactionQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTransactionQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx Properties
CfgTransactionQueryEx Class See Also Send Feedback

The CfgTransactionQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
ObjectType |
State |
TenantDbid |

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx..::.Dbid Property
CfgTransactionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx..::.Name Property
CfgTransactionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx..::.ObjectType Property
CfgTransactionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx.ObjectType"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgTransactionType> ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As Nullable(Of CfgTransactionType)
Visual C++
public:
property Nullable<CfgTransactionType> ObjectType {
    Nullable<CfgTransactionType> get ();
    void set (Nullable<CfgTransactionType> value);
}

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx..::.State Property
CfgTransactionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionQueryEx..::.TenantDbid Property
CfgTransactionQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTransactionQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTransactionQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTreatmentQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTreatmentQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgTreatmentQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgTreatmentQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgTreatmentQueryEx

See Also

CfgTreatmentQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTreatmentQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx Members
CfgTreatmentQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgTreatmentQueryEx type exposes the following members.

Constructors

Name | Description
CfgTreatmentQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
CallActionCode |
CallResult |
Dbid |
DestDnDbid |
Name |
RecActionCode |
State |
TenantDbid |

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTreatmentQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx Constructor
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTreatmentQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTreatmentQueryEx()

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTreatmentQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx Methods
CfgTreatmentQueryEx Class See Also Send Feedback

The CfgTreatmentQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgTreatmentQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx Properties
CfgTreatmentQueryEx Class See Also Send Feedback

The CfgTreatmentQueryEx type exposes the following members.

Properties

Name | Description
CallActionCode |
CallResult |
Dbid |
DestDnDbid |
Name |
RecActionCode |
State |
TenantDbid |

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CallActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.CallActionCode Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.CallActionCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgCallActionCode> CallActionCode { get; set; }
Visual Basic (Declaration)
Public Property CallActionCode As Nullable(Of CfgCallActionCode)
Visual C++
public:
property Nullable<CfgCallActionCode> CallActionCode {
    Nullable<CfgCallActionCode> get ();
    void set (Nullable<CfgCallActionCode> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CallResult Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.CallResult Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.CallResult"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<GctiCallState> CallResult { get; set; }
Visual Basic (Declaration)
Public Property CallResult As Nullable(Of GctiCallState)
Visual C++
public:
property Nullable<GctiCallState> CallResult {
    Nullable<GctiCallState> get ();
    void set (Nullable<GctiCallState> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.Dbid Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


DestDnDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.DestDnDbid Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.DestDnDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> DestDnDbid { get; set; }
Visual Basic (Declaration)
Public Property DestDnDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> DestDnDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.Name Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


RecActionCode Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.RecActionCode Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.RecActionCode"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgRecActionCode> RecActionCode { get; set; }
Visual Basic (Declaration)
Public Property RecActionCode As Nullable(Of CfgRecActionCode)
Visual C++
public:
property Nullable<CfgRecActionCode> RecActionCode {
    Nullable<CfgRecActionCode> get ();
    void set (Nullable<CfgRecActionCode> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.State Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgTreatmentQueryEx..::.TenantDbid Property
CfgTreatmentQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgTreatmentQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgTreatmentQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgVoicePromptQueryEx Class

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgVoicePromptQueryEx : CfgQueryEx
Visual Basic (Declaration)
Public Class CfgVoicePromptQueryEx _
    Inherits CfgQueryEx
Visual C++
public ref class CfgVoicePromptQueryEx : public CfgQueryEx

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgVoicePromptQueryEx

See Also

CfgVoicePromptQueryEx Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgVoicePromptQueryEx Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx Members
CfgVoicePromptQueryEx Class Constructors Methods Properties See Also Send Feedback

The CfgVoicePromptQueryEx type exposes the following members.

Constructors

Name | Description
CfgVoicePromptQueryEx |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

Properties

Name | Description
Dbid |
Name |
ScriptDbid |
State |
SwitchDbid |
TenantDbid |

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgVoicePromptQueryEx Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx Constructor
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgVoicePromptQueryEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgVoicePromptQueryEx()

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgVoicePromptQueryEx Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx Methods
CfgVoicePromptQueryEx Class See Also Send Feedback

The CfgVoicePromptQueryEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | (Inherited from CfgQueryEx.)

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


CfgVoicePromptQueryEx Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx Properties
CfgVoicePromptQueryEx Class See Also Send Feedback

The CfgVoicePromptQueryEx type exposes the following members.

Properties

Name | Description
Dbid |
Name |
ScriptDbid |
State |
SwitchDbid |
TenantDbid |

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Dbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx..::.Dbid Property
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.Dbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> Dbid { get; set; }
Visual Basic (Declaration)
Public Property Dbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Dbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx..::.Name Property
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


ScriptDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx..::.ScriptDbid Property
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.ScriptDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> ScriptDbid { get; set; }
Visual Basic (Declaration)
Public Property ScriptDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> ScriptDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx..::.State Property
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.State"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<CfgObjectState> State { get; set; }
Visual Basic (Declaration)
Public Property State As Nullable(Of CfgObjectState)
Visual C++
public:
property Nullable<CfgObjectState> State {
    Nullable<CfgObjectState> get ();
    void set (Nullable<CfgObjectState> value);
}

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


SwitchDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx..::.SwitchDbid Property
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.SwitchDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> SwitchDbid { get; set; }
Visual Basic (Declaration)
Public Property SwitchDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> SwitchDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


TenantDbid Property

[image]

Enterprise SDK 8.0 Reference API
CfgVoicePromptQueryEx..::.TenantDbid Property
CfgVoicePromptQueryEx Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgVoicePromptQueryEx.TenantDbid"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> TenantDbid { get; set; }
Visual Basic (Declaration)
Public Property TenantDbid As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> TenantDbid {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

CfgVoicePromptQueryEx Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries Namespace


Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace
Send Feedback

Classes

Class | Description
CfgFilterInfo |
CfgQueryInfo |
CfgQueryTransformer |
CfgTypeInfo |


CfgFilterInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgFilterInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgFilterInfo
Visual Basic (Declaration)
Public Class CfgFilterInfo
Visual C++
public ref class CfgFilterInfo

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal..::.CfgFilterInfo

See Also

CfgFilterInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgFilterInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo Members
CfgFilterInfo Class Constructors Methods Properties See Also Send Feedback

The CfgFilterInfo type exposes the following members.

Constructors

Name | Description
CfgFilterInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEnum |
Name |
Type |

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgFilterInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo Constructor
CfgFilterInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgFilterInfo.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgFilterInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgFilterInfo()

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgFilterInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo Methods
CfgFilterInfo Class See Also Send Feedback

The CfgFilterInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgFilterInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo Properties
CfgFilterInfo Class See Also Send Feedback

The CfgFilterInfo type exposes the following members.

Properties

Name | Description
IsEnum |
Name |
Type |

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


IsEnum Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo..::.IsEnum Property
CfgFilterInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgFilterInfo.IsEnum"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsEnum { get; set; }
Visual Basic (Declaration)
Public Property IsEnum As Boolean
Visual C++
public:
property bool IsEnum {
    bool get ();
    void set (bool value);
}

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo..::.Name Property
CfgFilterInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgFilterInfo.Name"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
CfgFilterInfo..::.Type Property
CfgFilterInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgFilterInfo.Type"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

CfgFilterInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgQueryInfo
Visual Basic (Declaration)
Public Class CfgQueryInfo
Visual C++
public ref class CfgQueryInfo

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal..::.CfgQueryInfo

See Also

CfgQueryInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo Members
CfgQueryInfo Class Constructors Methods Properties See Also Send Feedback

The CfgQueryInfo type exposes the following members.

Constructors

Name | Description
CfgQueryInfo |

Methods

Name | Description
CreateInstance |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Types |

See Also

CfgQueryInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo Constructor
CfgQueryInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryInfo.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgQueryInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgQueryInfo()

See Also

CfgQueryInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo Methods
CfgQueryInfo Class See Also Send Feedback

The CfgQueryInfo type exposes the following members.

Methods

Name | Description
CreateInstance |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgQueryInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CreateInstance Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo..::.CreateInstance Method
CfgQueryInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryInfo.CreateInstance"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgQueryInfo CreateInstance()
Visual Basic (Declaration)
Public Shared Function CreateInstance As CfgQueryInfo
Visual C++
public:
static CfgQueryInfo^ CreateInstance()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryInfo.CreateInstance"]

See Also

CfgQueryInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo Properties
CfgQueryInfo Class See Also Send Feedback

The CfgQueryInfo type exposes the following members.

Properties

Name | Description
Types |

See Also

CfgQueryInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Types Property

[image]

Enterprise SDK 8.0 Reference API
CfgQueryInfo..::.Types Property
CfgQueryInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryInfo.Types"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Dictionary<string, CfgTypeInfo> Types { get; set; }
Visual Basic (Declaration)
Public Property Types As Dictionary(Of String, CfgTypeInfo)
Visual C++
public:
property Dictionary<String^, CfgTypeInfo^>^ Types {
    Dictionary<String^, CfgTypeInfo^>^ get ();
    void set (Dictionary<String^, CfgTypeInfo^>^ value);
}

See Also

CfgQueryInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryTransformer Class

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class CfgQueryTransformer
Visual Basic (Declaration)
Public NotInheritable Class CfgQueryTransformer
Visual C++
public ref class CfgQueryTransformer abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal..::.CfgQueryTransformer

See Also

CfgQueryTransformer Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryTransformer Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer Members
CfgQueryTransformer Class Methods Fields See Also Send Feedback

The CfgQueryTransformer type exposes the following members.

Methods

Name | Description
Cfg2EntQuery |
Cfg2EntType |
Ent2CfgQuery |
Ent2CfgType |
Enum2CfgType |
Enum2EntType |

Fields

Name | Description
CfgQueriesAssembly |
CfgQueriesNamespace |
EntQueriesAssembly |
EntQueriesNamespace |
EntSuffix |

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryTransformer Fields

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer Fields
CfgQueryTransformer Class See Also Send Feedback

The CfgQueryTransformer type exposes the following members.

Fields

Name | Description
CfgQueriesAssembly |
CfgQueriesNamespace |
EntQueriesAssembly |
EntQueriesNamespace |
EntSuffix |

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueriesAssembly Field

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.CfgQueriesAssembly Field
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.CfgQueriesAssembly"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string CfgQueriesAssembly
Visual Basic (Declaration)
Public Const CfgQueriesAssembly As String
Visual C++
public:
literal String^ CfgQueriesAssembly

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueriesNamespace Field

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.CfgQueriesNamespace Field
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.CfgQueriesNamespace"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string CfgQueriesNamespace
Visual Basic (Declaration)
Public Const CfgQueriesNamespace As String
Visual C++
public:
literal String^ CfgQueriesNamespace

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


EntQueriesAssembly Field

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.EntQueriesAssembly Field
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.EntQueriesAssembly"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EntQueriesAssembly
Visual Basic (Declaration)
Public Const EntQueriesAssembly As String
Visual C++
public:
literal String^ EntQueriesAssembly

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


EntQueriesNamespace Field

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.EntQueriesNamespace Field
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.EntQueriesNamespace"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EntQueriesNamespace
Visual Basic (Declaration)
Public Const EntQueriesNamespace As String
Visual C++
public:
literal String^ EntQueriesNamespace

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


EntSuffix Field

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.EntSuffix Field
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.EntSuffix"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public const string EntSuffix
Visual Basic (Declaration)
Public Const EntSuffix As String
Visual C++
public:
literal String^ EntSuffix

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgQueryTransformer Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer Methods
CfgQueryTransformer Class See Also Send Feedback

The CfgQueryTransformer type exposes the following members.

Methods

Name | Description
Cfg2EntQuery |
Cfg2EntType |
Ent2CfgQuery |
Ent2CfgType |
Enum2CfgType |
Enum2EntType |

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Cfg2EntQuery Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.Cfg2EntQuery Method
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Cfg2EntQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Queries.CfgFilterBasedQuery)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static CfgQueryEx Cfg2EntQuery(
    CfgFilterBasedQuery cfgQuery
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntQuery ( _
    cfgQuery As CfgFilterBasedQuery _
) As CfgQueryEx
Visual C++
public:
static CfgQueryEx^ Cfg2EntQuery(
    CfgFilterBasedQuery^ cfgQuery
)

Parameters

cfgQuery
Type: CfgFilterBasedQuery

[Missing <param name="cfgQuery"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Cfg2EntQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Queries.CfgFilterBasedQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Cfg2EntQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Queries.CfgFilterBasedQuery)"]

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Cfg2EntType Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.Cfg2EntType Method
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Cfg2EntType(System.Type)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Cfg2EntType(
    Type cfgType
)
Visual Basic (Declaration)
Public Shared Function Cfg2EntType ( _
    cfgType As Type _
) As Type
Visual C++
public:
static Type^ Cfg2EntType(
    Type^ cfgType
)

Parameters

cfgType
Type: System..::.Type

[Missing <param name="cfgType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Cfg2EntType(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Cfg2EntType(System.Type)"]

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Ent2CfgQuery Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.Ent2CfgQuery Method
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Ent2CfgQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static ICfgQuery Ent2CfgQuery(
    CfgQueryEx entQuery
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgQuery ( _
    entQuery As CfgQueryEx _
) As ICfgQuery
Visual C++
public:
static ICfgQuery^ Ent2CfgQuery(
    CfgQueryEx^ entQuery
)

Parameters

entQuery
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="entQuery"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Ent2CfgQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Ent2CfgQuery(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Ent2CfgType Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.Ent2CfgType Method
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Ent2CfgType(System.Type)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Ent2CfgType(
    Type entType
)
Visual Basic (Declaration)
Public Shared Function Ent2CfgType ( _
    entType As Type _
) As Type
Visual C++
public:
static Type^ Ent2CfgType(
    Type^ entType
)

Parameters

entType
Type: System..::.Type

[Missing <param name="entType"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Ent2CfgType(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Ent2CfgType(System.Type)"]

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Enum2CfgType Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.Enum2CfgType Method
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Enum2CfgType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Enum2CfgType(
    CfgObjectType type
)
Visual Basic (Declaration)
Public Shared Function Enum2CfgType ( _
    type As CfgObjectType _
) As Type
Visual C++
public:
static Type^ Enum2CfgType(
    CfgObjectType type
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Enum2CfgType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Enum2CfgType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Enum2EntType Method

[image]

Enterprise SDK 8.0 Reference API
CfgQueryTransformer..::.Enum2EntType Method
CfgQueryTransformer Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Enum2EntType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Type Enum2EntType(
    CfgObjectType type
)
Visual Basic (Declaration)
Public Shared Function Enum2EntType ( _
    type As CfgObjectType _
) As Type
Visual C++
public:
static Type^ Enum2EntType(
    CfgObjectType type
)

Parameters

type
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Enum2EntType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgQueryTransformer.Enum2EntType(Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

CfgQueryTransformer Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgTypeInfo Class

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgTypeInfo"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class CfgTypeInfo
Visual Basic (Declaration)
Public Class CfgTypeInfo
Visual C++
public ref class CfgTypeInfo

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal..::.CfgTypeInfo

See Also

CfgTypeInfo Members
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgTypeInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Members
CfgTypeInfo Class Constructors Methods Properties See Also Send Feedback

The CfgTypeInfo type exposes the following members.

Constructors

Name | Description
CfgTypeInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filters |

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgTypeInfo Constructor

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Constructor
CfgTypeInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgTypeInfo.#ctor"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public CfgTypeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CfgTypeInfo()

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgTypeInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Methods
CfgTypeInfo Class See Also Send Feedback

The CfgTypeInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


CfgTypeInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo Properties
CfgTypeInfo Class See Also Send Feedback

The CfgTypeInfo type exposes the following members.

Properties

Name | Description
Filters |

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Filters Property

[image]

Enterprise SDK 8.0 Reference API
CfgTypeInfo..::.Filters Property
CfgTypeInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal.CfgTypeInfo.Filters"]

Namespace: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal
Assembly: Genesyslab.Enterprise.ConfigurationObjectModel (in Genesyslab.Enterprise.ConfigurationObjectModel.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Dictionary<string, CfgFilterInfo> Filters { get; set; }
Visual Basic (Declaration)
Public Property Filters As Dictionary(Of String, CfgFilterInfo)
Visual C++
public:
property Dictionary<String^, CfgFilterInfo^>^ Filters {
    Dictionary<String^, CfgFilterInfo^>^ get ();
    void set (Dictionary<String^, CfgFilterInfo^>^ value);
}

See Also

CfgTypeInfo Class
Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.Internal Namespace


Genesyslab.Enterprise.Core Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Core Namespace
Send Feedback

Classes

Class | Description
Capability | Describes a capability.
InteractionData | Contains interaction data as dynamic attributes.
PayLoadContext |
Role |

Interfaces

Interface | Description
IDN | Interface for Directory Numbers.


Capability Class

[image]

Enterprise SDK 8.0 Reference API
Capability Class
Members See Also Send Feedback
Describes a capability.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class Capability : ICapability
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Capability _
    Implements ICapability
Visual C++
[SerializableAttribute]
public ref class Capability : ICapability

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.Capability

See Also

Capability Members
Genesyslab.Enterprise.Core Namespace


Capability Members

[image] [image]

Enterprise SDK 8.0 Reference API
Capability Members
Capability Class Constructors Methods Properties See Also Send Feedback

The Capability type exposes the following members.

Constructors

Name | Description
Capability | Constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | Description of the feature.
Name | Capability name.
State | Capability status (enabled, disabled, or inactive.)
Value | True if the capability is activated in CME.

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Capability Constructor

[image]

Enterprise SDK 8.0 Reference API
Capability Constructor
Capability Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Capability(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Capability(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Core.Capability.#ctor(System.String)"]

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Capability Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Capability Methods
Capability Class See Also Send Feedback

The Capability type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Capability Properties

[image] [image]

Enterprise SDK 8.0 Reference API
Capability Properties
Capability Class See Also Send Feedback

The Capability type exposes the following members.

Properties

Name | Description
Description | Description of the feature.
Name | Capability name.
State | Capability status (enabled, disabled, or inactive.)
Value | True if the capability is activated in CME.

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.Description Property
Capability Class See Also Send Feedback
Description of the feature.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

ICapability..::.Description

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.Name Property
Capability Class See Also Send Feedback
Capability name.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ICapability..::.Name

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.State Property
Capability Class See Also Send Feedback
Capability status (enabled, disabled, or inactive.)

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public StateType State { get; set; }
Visual Basic (Declaration)
Public Property State As StateType
Visual C++
public:
virtual property StateType State {
    StateType get () sealed;
    void set (StateType value) sealed;
}

Implements

ICapability..::.State

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
Capability..::.Value Property
Capability Class See Also Send Feedback
True if the capability is activated in CME.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Boolean
Visual C++
public:
virtual property bool Value {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ICapability..::.Value

See Also

Capability Class
Genesyslab.Enterprise.Core Namespace


IDN Interface

[image]

Enterprise SDK 8.0 Reference API
IDN Interface
Members See Also Send Feedback
Interface for Directory Numbers.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDN : IDevice, ISerializable,
    IConfigurable
Visual Basic (Declaration)
Public Interface IDN _
    Implements IDevice, ISerializable, IConfigurable
Visual C++
public interface class IDN : IDevice,
    ISerializable, IConfigurable

See Also

IDN Members
Genesyslab.Enterprise.Core Namespace


IDN Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Members
IDN Interface Methods Properties See Also Send Feedback

The IDN type exposes the following members.

Methods

Name Description
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling (Inherited from IDevice.)
ActiveChannels | List of active channels for this device. (Inherited from IDevice.)
Attributes | (Inherited from IDevice.)
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail. (Inherited from IDevice.)
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on. (Inherited from IDevice.)
Controller | Returns the state controller of the object. (Inherited from IDevice.)
DnAdress |
DndState |
ForwardMode |
ForwardNumber |
ForwardState |
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name. (Inherited from IDevice.)
Group | Group of subdevices which compose this device. (Inherited from IDevice.)
HookState |
Identity | Identity in relation with the device. (Inherited from IDevice.)
IsComposite |
Item |
MuteMode |
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations. (Inherited from IDevice.)
State | Device status. (Inherited from IDevice.)
Strategy | List of stategies handled by the object. (Inherited from IDevice.)
Tenant |

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IDN Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Methods
IDN Interface See Also Send Feedback

The IDN type exposes the following members.

Methods

Name Description
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IDN Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Properties
IDN Interface See Also Send Feedback

The IDN type exposes the following members.

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling (Inherited from IDevice.)
ActiveChannels | List of active channels for this device. (Inherited from IDevice.)
Attributes | (Inherited from IDevice.)
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail. (Inherited from IDevice.)
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on. (Inherited from IDevice.)
Controller | Returns the state controller of the object. (Inherited from IDevice.)
DnAdress |
DndState |
ForwardMode |
ForwardNumber |
ForwardState |
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name. (Inherited from IDevice.)
Group | Group of subdevices which compose this device. (Inherited from IDevice.)
HookState |
Identity | Identity in relation with the device. (Inherited from IDevice.)
IsComposite |
Item |
MuteMode |
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations. (Inherited from IDevice.)
State | Device status. (Inherited from IDevice.)
Strategy | List of stategies handled by the object. (Inherited from IDevice.)
Tenant |

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


DnAdress Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.DnAdress Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.DnAdress"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DnAdressType DnAdress { get; }
Visual Basic (Declaration)
ReadOnly Property DnAdress As DnAdressType
Visual C++
property DnAdressType DnAdress {
    DnAdressType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


DndState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.DndState Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.DndState"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool DndState { get; }
Visual Basic (Declaration)
ReadOnly Property DndState As Boolean
Visual C++
property bool DndState {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardMode Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardMode Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.ForwardMode"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ForwardModeType ForwardMode { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardMode As ForwardModeType
Visual C++
property ForwardModeType ForwardMode {
    ForwardModeType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardNumber Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardNumber Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.ForwardNumber"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ForwardNumber { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardNumber As String
Visual C++
property String^ ForwardNumber {
    String^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardState Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.ForwardState"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ForwardState { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardState As Boolean
Visual C++
property bool ForwardState {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


HookState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.HookState Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.HookState"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
HookStateType HookState { get; }
Visual Basic (Declaration)
ReadOnly Property HookState As HookStateType
Visual C++
property HookStateType HookState {
    HookStateType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IsComposite Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.IsComposite Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.IsComposite"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsComposite { get; }
Visual Basic (Declaration)
ReadOnly Property IsComposite As Boolean
Visual C++
property bool IsComposite {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.Item Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.Item(System.String)"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As Object
Visual C++
property Object^ default[String^ key] {
    Object^ get (String^ key);
}

Parameters

key
Type: System..::.String

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


MuteMode Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.MuteMode Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.MuteMode"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MuteModeType MuteMode { get; }
Visual Basic (Declaration)
ReadOnly Property MuteMode As MuteModeType
Visual C++
property MuteModeType MuteMode {
    MuteModeType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.Tenant Property
IDN Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.IDN.Tenant"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Tenant { get; }
Visual Basic (Declaration)
ReadOnly Property Tenant As String
Visual C++
property String^ Tenant {
    String^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


InteractionData Class

[image]

Enterprise SDK 8.0 Reference API
InteractionData Class
Members See Also Send Feedback
Contains interaction data as dynamic attributes.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class InteractionData : IAttributeDataManager<IDynamicAttribute>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InteractionData _
    Implements IAttributeDataManager(Of IDynamicAttribute)
Visual C++
[SerializableAttribute]
public ref class InteractionData : IAttributeDataManager<IDynamicAttribute^>

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.InteractionData

See Also

InteractionData Members
Genesyslab.Enterprise.Core Namespace


InteractionData Members

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData Members
InteractionData Class Constructors Methods Properties See Also Send Feedback

The InteractionData type exposes the following members.

Constructors

Name | Description
InteractionData | Constructor.

Methods

Name | Description
AllValues | Returns all the values.
ContainsKey | Returns true if this object contains the given key.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAsPSDKCollection | Returns the dynamic attributes as a PSDK collection.
GetElementAsBinary | Returns a dynamic attribute as a binary array.
GetElementAsCollection | Returns a dynamic attribute as an integer.
GetElementAsDynamicAttribute | Returns a dynamic attribute.
GetElementAsInt | Returns a dynamic attribute as an integer.
GetElementAsObject | Returns a dynamic attribute as an object.
GetElementAsString | Returns a dynamic attribute as a string.
GetElementType |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsElementACollection | Returns true if the value for the given key is a collection.
IsSynchronized |
RemoveAll | Removes all values.
RemoveElement | Removes a value.
SetElement | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllKeys | Return all the keys.
Item | Array of dynamic attributes.
Owner | A pointer to the ultimate client class of the InteractionData or PropertyBag.
Section | The name of the InteractionData.

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


InteractionData Constructor

[image]

Enterprise SDK 8.0 Reference API
InteractionData Constructor
InteractionData Class See Also Send Feedback
Constructor.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public InteractionData(
    string section,
    Object owner
)
Visual Basic (Declaration)
Public Sub New ( _
    section As String, _
    owner As Object _
)
Visual C++
public:
InteractionData(
    String^ section,
    Object^ owner
)

Parameters

section
Type: System..::.String
Section name.
owner
Type: System..::.Object
Reference to the instance owner.

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


InteractionData Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData Methods
InteractionData Class See Also Send Feedback

The InteractionData type exposes the following members.

Methods

Name | Description
AllValues | Returns all the values.
ContainsKey | Returns true if this object contains the given key.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAsPSDKCollection | Returns the dynamic attributes as a PSDK collection.
GetElementAsBinary | Returns a dynamic attribute as a binary array.
GetElementAsCollection | Returns a dynamic attribute as an integer.
GetElementAsDynamicAttribute | Returns a dynamic attribute.
GetElementAsInt | Returns a dynamic attribute as an integer.
GetElementAsObject | Returns a dynamic attribute as an object.
GetElementAsString | Returns a dynamic attribute as a string.
GetElementType |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsElementACollection | Returns true if the value for the given key is a collection.
IsSynchronized |
RemoveAll | Removes all values.
RemoveElement | Removes a value.
SetElement | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


AllValues Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AllValues Method
InteractionData Class See Also Send Feedback
Returns all the values.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IDynamicAttribute[] AllValues()
Visual Basic (Declaration)
Public Function AllValues As IDynamicAttribute()
Visual C++
public:
virtual array<IDynamicAttribute^>^ AllValues() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.AllValues"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.AllValues()()()

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.ContainsKey Method
InteractionData Class See Also Send Feedback
Returns true if this object contains the given key.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool ContainsKey(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.ContainsKey(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.ContainsKey(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.ContainsKey(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetAsPSDKCollection Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetAsPSDKCollection Method
InteractionData Class See Also Send Feedback
Returns the dynamic attributes as a PSDK collection.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public KeyValueCollection GetAsPSDKCollection()
Visual Basic (Declaration)
Public Function GetAsPSDKCollection As KeyValueCollection
Visual C++
public:
virtual KeyValueCollection^ GetAsPSDKCollection() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetAsPSDKCollection"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetAsPSDKCollection()()()

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsBinary Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as a binary array.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public byte[] GetElementAsBinary(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsBinary ( _
    key As String _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ GetElementAsBinary(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsBinary(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsBinary(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsBinary(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsCollection Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsCollection Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as an integer.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> GetElementAsCollection(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsCollection ( _
    key As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ GetElementAsCollection(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsCollection(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsCollection(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsCollection(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsDynamicAttribute Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsDynamicAttribute Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IDynamicAttribute GetElementAsDynamicAttribute(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsDynamicAttribute ( _
    key As String _
) As IDynamicAttribute
Visual C++
public:
virtual IDynamicAttribute^ GetElementAsDynamicAttribute(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsDynamicAttribute(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsDynamicAttribute(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsInt Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsInt Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as an integer.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Nullable<int> GetElementAsInt(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsInt ( _
    key As String _
) As Nullable(Of Integer)
Visual C++
public:
virtual Nullable<int> GetElementAsInt(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsInt(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsInt(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsObject Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsObject Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as an object.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object GetElementAsObject(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsObject ( _
    key As String _
) As Object
Visual C++
public:
virtual Object^ GetElementAsObject(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsObject(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsObject(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsObject(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementAsString Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementAsString Method
InteractionData Class See Also Send Feedback
Returns a dynamic attribute as a string.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string GetElementAsString(
    string key
)
Visual Basic (Declaration)
Public Function GetElementAsString ( _
    key As String _
) As String
Visual C++
public:
virtual String^ GetElementAsString(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementAsString(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementAsString(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


GetElementType Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.GetElementType Method
InteractionData Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementType(System.String)"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Type GetElementType(
    string key
)
Visual Basic (Declaration)
Public Function GetElementType ( _
    key As String _
) As Type
Visual C++
public:
virtual Type^ GetElementType(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementType(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.GetElementType(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.GetElementType(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


IsElementACollection Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.IsElementACollection Method
InteractionData Class See Also Send Feedback
Returns true if the value for the given key is a collection.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsElementACollection(
    string key
)
Visual Basic (Declaration)
Public Function IsElementACollection ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool IsElementACollection(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.IsElementACollection(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.IsElementACollection(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


IsSynchronized Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.IsSynchronized Method
InteractionData Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.IsSynchronized(System.String)"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsSynchronized(
    string key
)
Visual Basic (Declaration)
Public Function IsSynchronized ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool IsSynchronized(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.IsSynchronized(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.IsSynchronized(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.IsSynchronized(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


RemoveAll Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.RemoveAll Method
InteractionData Class See Also Send Feedback
Removes all values.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void RemoveAll()
Visual Basic (Declaration)
Public Sub RemoveAll
Visual C++
public:
virtual void RemoveAll() sealed

Implements

IAttributeDataManager<(Of <(T>)>)..::.RemoveAll()()()

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


RemoveElement Method

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.RemoveElement Method
InteractionData Class See Also Send Feedback
Removes a value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool RemoveElement(
    string key
)
Visual Basic (Declaration)
Public Function RemoveElement ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool RemoveElement(
    String^ key
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.RemoveElement(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.RemoveElement(System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.RemoveElement(String)

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


SetElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method
InteractionData Class See Also Send Feedback

Overload List

Name | Description
SetElement(IDynamicAttribute) | Sets a dynamic value.
SetElement(String, IAttributeDataManager<(Of <(IDynamicAttribute>)>)) | Sets a dynamic value.
SetElement(String, array<Byte>[]()[]) | Sets a dynamic value.
SetElement(String, Int32) | Sets a dynamic value.
SetElement(String, Object) | Sets a dynamic value.
SetElement(String, String) | Sets a dynamic value.
SetElement(String, array<Byte>[]()[], String, String) | Sets a dynamic value.
SetElement(String, Object, String, String) | Sets a dynamic value.
SetElement(String, String, String, String) | Sets a dynamic value.

See Also

InteractionData Class
InteractionData Members
Genesyslab.Enterprise.Core Namespace


SetElement Method (IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (IDynamicAttribute)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    IDynamicAttribute value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    value As IDynamicAttribute _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    IDynamicAttribute^ value
) sealed

Parameters

value
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(T)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, IAttributeDataManager(IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, IAttributeDataManager<(Of <(IDynamicAttribute>)>))
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    IAttributeDataManager<IDynamicAttribute> value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As IAttributeDataManager(Of IDynamicAttribute) _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    IAttributeDataManager<IDynamicAttribute^>^ value
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

value
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( IDynamicAttribute >)>)

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, IAttributeDataManager<(Of <(T>)>))

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, array<Byte>[]()[])
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Byte() _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    array<unsigned char>^ value
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[])"]

value
Type: array< System..::.Byte >[]()[]

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[])"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, array<Byte>[]()[])

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, Int32)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    int value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Integer _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    int value
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Int32)"]

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Int32)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, Int32)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, Object)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    Object value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Object _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    Object^ value
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, Object)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    string value
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    String^ value
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String)"]

value
Type: System..::.String

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Byte[], String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, array<Byte>[]()[], String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    byte[] value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Byte(), _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    array<unsigned char>^ value,
    String^ contentType,
    String^ contentTypeVersion
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[],System.String,System.String)"]

value
Type: array< System..::.Byte >[]()[]

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[],System.String,System.String)"]

contentType
Type: System..::.String

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[],System.String,System.String)"]

contentTypeVersion
Type: System..::.String

[Missing <param name="contentTypeVersion"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[],System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Byte[],System.String,System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, array<Byte>[]()[], String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, Object, String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, Object, String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    Object value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As Object, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    Object^ value,
    String^ contentType,
    String^ contentTypeVersion
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object,System.String,System.String)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object,System.String,System.String)"]

contentType
Type: System..::.String

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object,System.String,System.String)"]

contentTypeVersion
Type: System..::.String

[Missing <param name="contentTypeVersion"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object,System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.Object,System.String,System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, Object, String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


SetElement Method (String, String, String, String)

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.SetElement Method (String, String, String, String)
InteractionData Class See Also Send Feedback
Sets a dynamic value.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IAttributeDataManager<IDynamicAttribute> SetElement(
    string key,
    string value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Public Function SetElement ( _
    key As String, _
    value As String, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of IDynamicAttribute)
Visual C++
public:
virtual IAttributeDataManager<IDynamicAttribute^>^ SetElement(
    String^ key,
    String^ value,
    String^ contentType,
    String^ contentTypeVersion
) sealed

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String,System.String,System.String)"]

value
Type: System..::.String

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String,System.String,System.String)"]

contentType
Type: System..::.String

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String,System.String,System.String)"]

contentTypeVersion
Type: System..::.String

[Missing <param name="contentTypeVersion"/> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String,System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.InteractionData.SetElement(System.String,System.String,System.String,System.String)"]

Implements

IAttributeDataManager<(Of <(T>)>)..::.SetElement(String, String, String, String)

See Also

InteractionData Class
SetElement Overload
Genesyslab.Enterprise.Core Namespace


InteractionData Properties

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionData Properties
InteractionData Class See Also Send Feedback

The InteractionData type exposes the following members.

Properties

Name | Description
AllKeys | Return all the keys.
Item | Array of dynamic attributes.
Owner | A pointer to the ultimate client class of the InteractionData or PropertyBag.
Section | The name of the InteractionData.

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.AllKeys Property
InteractionData Class See Also Send Feedback
Return all the keys.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string[] AllKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllKeys As String()
Visual C++
public:
virtual property array<String^>^ AllKeys {
    array<String^>^ get () sealed;
}

Implements

IAttributeDataManager<(Of <(T>)>)..::.AllKeys

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Item Property
InteractionData Class See Also Send Feedback
Array of dynamic attributes.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IDynamicAttribute this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As IDynamicAttribute
Visual C++
public:
virtual property IDynamicAttribute^ default[String^ key] {
    IDynamicAttribute^ get (String^ key) sealed;
}

Parameters

key
Type: System..::.String

Return Value

Implements

IAttributeDataManager<(Of <(T>)>)..::.Item[([(String])])

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Owner Property
InteractionData Class See Also Send Feedback
A pointer to the ultimate client class of the InteractionData or PropertyBag.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Object
Visual C++
public:
virtual property Object^ Owner {
    Object^ get () sealed;
}

Implements

IAttributeDataManager<(Of <(T>)>)..::.Owner

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


Section Property

[image]

Enterprise SDK 8.0 Reference API
InteractionData..::.Section Property
InteractionData Class See Also Send Feedback
The name of the InteractionData.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Section { get; }
Visual Basic (Declaration)
Public ReadOnly Property Section As String
Visual C++
public:
virtual property String^ Section {
    String^ get () sealed;
}

Implements

IAttributeDataManager<(Of <(T>)>)..::.Section

See Also

InteractionData Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Class

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Core.PayLoadContext"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class PayLoadContext : IPayLoadContext
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PayLoadContext _
    Implements IPayLoadContext
Visual C++
[SerializableAttribute]
public ref class PayLoadContext : IPayLoadContext

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.PayLoadContext

See Also

PayLoadContext Members
Genesyslab.Enterprise.Core Namespace


PayLoadContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
PayLoadContext Members
PayLoadContext Class Constructors Methods Properties See Also Send Feedback

The PayLoadContext type exposes the following members.

Constructors

Name | Description
PayLoadContext |

Methods

Name | Description
DeepCopy | Complete copy of the object Msg property is not copied though, for performance issue
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ShallowCopy | Partial copy of the object
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContextState | Get state type of event: Unknown, Created, Updated, Merged, Deleted, Error,
msg | Get raw PSDK message
Reason | Get reason of event update
TimeStamp | Get time stamp of object creation

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Constructor

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext Constructor
PayLoadContext Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Core.PayLoadContext.#ctor(Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Enterprise.Model.Interaction.ContextStateType,Genesyslab.Enterprise.Model.Interaction.ReasonTypes)"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public PayLoadContext(
    IMessage msg,
    ContextStateType contextStateType,
    ReasonTypes reason
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As IMessage, _
    contextStateType As ContextStateType, _
    reason As ReasonTypes _
)
Visual C++
public:
PayLoadContext(
    IMessage^ msg,
    ContextStateType contextStateType,
    ReasonTypes reason
)

Parameters

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Core.PayLoadContext.#ctor(Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Enterprise.Model.Interaction.ContextStateType,Genesyslab.Enterprise.Model.Interaction.ReasonTypes)"]

contextStateType
Type: Genesyslab.Enterprise.Model.Interaction..::.ContextStateType

[Missing <param name="contextStateType"/> documentation for "M:Genesyslab.Enterprise.Core.PayLoadContext.#ctor(Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Enterprise.Model.Interaction.ContextStateType,Genesyslab.Enterprise.Model.Interaction.ReasonTypes)"]

reason
Type: Genesyslab.Enterprise.Model.Interaction..::.ReasonTypes

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Core.PayLoadContext.#ctor(Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Enterprise.Model.Interaction.ContextStateType,Genesyslab.Enterprise.Model.Interaction.ReasonTypes)"]

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PayLoadContext Methods
PayLoadContext Class See Also Send Feedback

The PayLoadContext type exposes the following members.

Methods

Name | Description
DeepCopy | Complete copy of the object Msg property is not copied though, for performance issue
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ShallowCopy | Partial copy of the object
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


DeepCopy Method

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.DeepCopy Method
PayLoadContext Class See Also Send Feedback
Complete copy of the object Msg property is not copied though, for performance issue

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IPayLoadContext DeepCopy()
Visual Basic (Declaration)
Public Function DeepCopy As IPayLoadContext
Visual C++
public:
virtual IPayLoadContext^ DeepCopy() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.PayLoadContext.DeepCopy"]

Implements

IDeepCopy<(Of <(T>)>)..::.DeepCopy()()()

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


ShallowCopy Method

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.ShallowCopy Method
PayLoadContext Class See Also Send Feedback
Partial copy of the object

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IPayLoadContext ShallowCopy()
Visual Basic (Declaration)
Public Function ShallowCopy As IPayLoadContext
Visual C++
public:
virtual IPayLoadContext^ ShallowCopy() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Core.PayLoadContext.ShallowCopy"]

Implements

IShallowCopy<(Of <(T>)>)..::.ShallowCopy()()()

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


PayLoadContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
PayLoadContext Properties
PayLoadContext Class See Also Send Feedback

The PayLoadContext type exposes the following members.

Properties

Name | Description
ContextState | Get state type of event: Unknown, Created, Updated, Merged, Deleted, Error,
msg | Get raw PSDK message
Reason | Get reason of event update
TimeStamp | Get time stamp of object creation

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


ContextState Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.ContextState Property
PayLoadContext Class See Also Send Feedback
Get state type of event: Unknown, Created, Updated, Merged, Deleted, Error,

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ContextStateType ContextState { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContextState As ContextStateType
Visual C++
public:
virtual property ContextStateType ContextState {
    ContextStateType get () sealed;
}

Implements

IPayLoadContext..::.ContextState

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


msg Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.msg Property
PayLoadContext Class See Also Send Feedback
Get raw PSDK message

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IMessage msg { get; }
Visual Basic (Declaration)
Public ReadOnly Property msg As IMessage
Visual C++
public:
virtual property IMessage^ msg {
    IMessage^ get () sealed;
}

Implements

IPayLoadContext..::.msg

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


Reason Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.Reason Property
PayLoadContext Class See Also Send Feedback
Get reason of event update

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReasonTypes Reason { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reason As ReasonTypes
Visual C++
public:
virtual property ReasonTypes Reason {
    ReasonTypes get () sealed;
}

Implements

IPayLoadContext..::.Reason

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


TimeStamp Property

[image]

Enterprise SDK 8.0 Reference API
PayLoadContext..::.TimeStamp Property
PayLoadContext Class See Also Send Feedback
Get time stamp of object creation

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public long TimeStamp { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeStamp As Long
Visual C++
public:
virtual property long long TimeStamp {
    long long get () sealed;
}

Implements

IPayLoadContext..::.TimeStamp

See Also

PayLoadContext Class
Genesyslab.Enterprise.Core Namespace


Role Class

[image]

Enterprise SDK 8.0 Reference API
Role Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Core.Role"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class Role : IRole
Visual Basic (Declaration)
Public Class Role _
    Implements IRole
Visual C++
public ref class Role : IRole

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Core..::.Role

See Also

Role Members
Genesyslab.Enterprise.Core Namespace


Role Members

[image] [image]

Enterprise SDK 8.0 Reference API
Role Members
Role Class Constructors Methods Properties See Also Send Feedback

The Role type exposes the following members.

Constructors

Name | Description
Role | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capabilities |
Description |
Name |
Parameters |
RoleProfile |
Visibility |

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Role Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
Role Constructor
Role Class See Also Send Feedback

Overload List

Name | Description
Role(String, String, RoleProfileType) |
Role(String, String, RoleProfileType, array<Object>[]()[]) |

See Also

Role Class
Role Members
Genesyslab.Enterprise.Core Namespace


Role Constructor (String, String, RoleProfileType)

[image]

Enterprise SDK 8.0 Reference API
Role Constructor (String, String, RoleProfileType)
Role Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Role(
    string name,
    string description,
    RoleProfileType roleProfile
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    roleProfile As RoleProfileType _
)
Visual C++
public:
Role(
    String^ name,
    String^ description,
    RoleProfileType roleProfile
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

description
Type: System..::.String

[Missing <param name="description"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

roleProfile
Type: Genesyslab.Enterprise.Model.ComponentModel..::.RoleProfileType

[Missing <param name="roleProfile"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

See Also

Role Class
Role Overload
Genesyslab.Enterprise.Core Namespace


Role Constructor (String, String, RoleProfileType, Object[])

[image]

Enterprise SDK 8.0 Reference API
Role Constructor (String, String, RoleProfileType, array<Object>[]()[])
Role Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType,System.Object[])"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Role(
    string name,
    string description,
    RoleProfileType roleProfile,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    roleProfile As RoleProfileType, _
    ParamArray parameters As Object() _
)
Visual C++
public:
Role(
    String^ name,
    String^ description,
    RoleProfileType roleProfile,
    ... array<Object^>^ parameters
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType,System.Object[])"]

description
Type: System..::.String

[Missing <param name="description"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType,System.Object[])"]

roleProfile
Type: Genesyslab.Enterprise.Model.ComponentModel..::.RoleProfileType

[Missing <param name="roleProfile"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType,System.Object[])"]

parameters
Type: array< System..::.Object >[]()[]

[Missing <param name="parameters"/> documentation for "M:Genesyslab.Enterprise.Core.Role.#ctor(System.String,System.String,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType,System.Object[])"]

See Also

Role Class
Role Overload
Genesyslab.Enterprise.Core Namespace


Role Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Role Methods
Role Class See Also Send Feedback

The Role type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Role Properties

[image] [image]

Enterprise SDK 8.0 Reference API
Role Properties
Role Class See Also Send Feedback

The Role type exposes the following members.

Properties

Name | Description
Capabilities |
Description |
Name |
Parameters |
RoleProfile |
Visibility |

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Capabilities Property
Role Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.Role.Capabilities"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
public:
virtual property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get () sealed;
}

Implements

IRole..::.Capabilities

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Description Property
Role Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.Role.Description"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

IRole..::.Description

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Name Property
Role Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.Role.Name"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IRole..::.Name

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Parameters Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Parameters Property
Role Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.Role.Parameters"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As Object()
Visual C++
public:
virtual property array<Object^>^ Parameters {
    array<Object^>^ get () sealed;
}

Implements

IRole..::.Parameters

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


RoleProfile Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.RoleProfile Property
Role Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.Role.RoleProfile"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public RoleProfileType RoleProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property RoleProfile As RoleProfileType
Visual C++
public:
virtual property RoleProfileType RoleProfile {
    RoleProfileType get () sealed;
}

Implements

IRole..::.RoleProfile

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
Role..::.Visibility Property
Role Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Core.Role.Visibility"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public VisibilityType Visibility { get; set; }
Visual Basic (Declaration)
Public Property Visibility As VisibilityType
Visual C++
public:
virtual property VisibilityType Visibility {
    VisibilityType get () sealed;
    void set (VisibilityType value) sealed;
}

Implements

IRole..::.Visibility

See Also

Role Class
Genesyslab.Enterprise.Core Namespace


Genesyslab.Enterprise.Exceptions Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions Namespace
Send Feedback

Classes

Class | Description
EnterpriseException | Interface for handling Enterprise Exception.
EnterpriseFrameworkException | Interface for handling Enterprise framework exception.


EnterpriseException Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Class
Members See Also Send Feedback
Interface for handling Enterprise Exception.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class EnterpriseException : Exception
Visual Basic (Declaration)
Public Class EnterpriseException _
    Inherits Exception
Visual C++
public ref class EnterpriseException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException

See Also

EnterpriseException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Members
EnterpriseException Class Constructors Methods Properties See Also Send Feedback

The EnterpriseException type exposes the following members.

Constructors

Name | Description
EnterpriseException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor
EnterpriseException Class See Also Send Feedback

Overload List

Name | Description
EnterpriseException()()() | Creates an instance of EnterpriseException.
EnterpriseException(Int32) | Creates an instance of EnterpriseException.
EnterpriseException(String) | Creates an instance of EnterpriseException.
EnterpriseException(Int32, String) | Creates an instance of EnterpriseException.
EnterpriseException(SerializationInfo, StreamingContext) | Creates an instance of EnterpriseException.
EnterpriseException(String, Exception) | Creates an instance of EnterpriseException.
EnterpriseException(Int32, String, Exception) | Creates an instance of EnterpriseException.

See Also

EnterpriseException Class
EnterpriseException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EnterpriseException()

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (Int32)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
EnterpriseException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Int32)"]

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (String)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
EnterpriseException(
    String^ message
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.String)"]

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (Int32, String)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
EnterpriseException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Int32,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Int32,System.String)"]

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (SerializationInfo, StreamingContext)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (SerializationInfo, StreamingContext)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EnterpriseException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (String, Exception)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.String,System.Exception)"]

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException Constructor (Int32, String, Exception)
EnterpriseException Class See Also Send Feedback
Creates an instance of EnterpriseException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Int32,System.String,System.Exception)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Int32,System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseException.#ctor(System.Int32,System.String,System.Exception)"]

See Also

EnterpriseException Class
EnterpriseException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Methods
EnterpriseException Class See Also Send Feedback

The EnterpriseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseException Properties
EnterpriseException Class See Also Send Feedback

The EnterpriseException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


ErrorCode Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseException..::.ErrorCode Property
EnterpriseException Class See Also Send Feedback
Gets or sets Error code.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ErrorCode { get; set; }
Visual Basic (Declaration)
Public Property ErrorCode As Integer
Visual C++
public:
property int ErrorCode {
    int get ();
    void set (int value);
}

See Also

EnterpriseException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Class
Members See Also Send Feedback
Interface for handling Enterprise framework exception.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class EnterpriseFrameworkException : EnterpriseException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EnterpriseFrameworkException _
    Inherits EnterpriseException
Visual C++
[SerializableAttribute]
public ref class EnterpriseFrameworkException : public EnterpriseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Broker..::.BrokerException
Genesyslab.Enterprise.Exceptions.Channel..::.ChannelException
Genesyslab.Enterprise.Exceptions.Protocol..::.ProtocolException

See Also

EnterpriseFrameworkException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Members
EnterpriseFrameworkException Class Constructors Methods Properties See Also Send Feedback

The EnterpriseFrameworkException type exposes the following members.

Constructors

Name | Description
EnterpriseFrameworkException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseFrameworkException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor
EnterpriseFrameworkException Class See Also Send Feedback

Overload List

Name | Description
EnterpriseFrameworkException()()() | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(Int32) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(String) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(Int32, String) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(SerializationInfo, StreamingContext) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(String, Exception) | Create an instance of EntrepriseFrameworkException.
EnterpriseFrameworkException(Int32, String, Exception) | Create an instance of EntrepriseFrameworkException.

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Members
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EnterpriseFrameworkException()

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (Int32)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
EnterpriseFrameworkException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Int32)"]

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (String)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
EnterpriseFrameworkException(
    String^ message
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.String)"]

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (Int32, String)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
EnterpriseFrameworkException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Int32,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Int32,System.String)"]

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (SerializationInfo, StreamingContext)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (SerializationInfo, StreamingContext)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EnterpriseFrameworkException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (String, Exception)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseFrameworkException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.String,System.Exception)"]

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Constructor (Int32, String, Exception)
EnterpriseFrameworkException Class See Also Send Feedback
Create an instance of EntrepriseFrameworkException.

Namespace: Genesyslab.Enterprise.Exceptions
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseFrameworkException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
EnterpriseFrameworkException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Int32,System.String,System.Exception)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Int32,System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.EnterpriseFrameworkException.#ctor(System.Int32,System.String,System.Exception)"]

See Also

EnterpriseFrameworkException Class
EnterpriseFrameworkException Overload
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Methods
EnterpriseFrameworkException Class See Also Send Feedback

The EnterpriseFrameworkException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EnterpriseFrameworkException Class
Genesyslab.Enterprise.Exceptions Namespace


EnterpriseFrameworkException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseFrameworkException Properties
EnterpriseFrameworkException Class See Also Send Feedback

The EnterpriseFrameworkException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EnterpriseFrameworkException Class
Genesyslab.Enterprise.Exceptions Namespace


Genesyslab.Enterprise.Exceptions.Broker Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Broker Namespace
Send Feedback

Classes

Class | Description
BrokerException | Exception class for Broker.


BrokerException Class

[image]

Enterprise SDK 8.0 Reference API
BrokerException Class
Members See Also Send Feedback
Exception class for Broker.

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class BrokerException : EnterpriseFrameworkException,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class BrokerException _
    Inherits EnterpriseFrameworkException _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class BrokerException : public EnterpriseFrameworkException,
    ISerializable

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Broker..::.BrokerException

See Also

BrokerException Members
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Members

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Members
BrokerException Class Constructors Methods Properties See Also Send Feedback

The BrokerException type exposes the following members.

Constructors

Name | Description
BrokerException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Get error message (Overrides Exception..::.Message.)
Method | Get the strategy name at the origin of error
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Target | Get the strategy name at the origin of error
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor
BrokerException Class See Also Send Feedback

Overload List

Name | Description
BrokerException()()() | Construct an empty exception
BrokerException(String) | Construct an default exception
BrokerException(String, Exception) | Construct an default exception
BrokerException(Object, MethodInfo, String) | Construct an exception with Target object, Method and Message

See Also

BrokerException Class
BrokerException Members
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor
BrokerException Class See Also Send Feedback
Construct an empty exception

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public BrokerException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BrokerException()

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor (String)
BrokerException Class See Also Send Feedback
Construct an default exception

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public BrokerException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
BrokerException(
    String^ message
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.#ctor(System.String)"]

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor (String, Exception)
BrokerException Class See Also Send Feedback
Construct an default exception

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public BrokerException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
BrokerException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.#ctor(System.String,System.Exception)"]

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Constructor (Object, MethodInfo, String)

[image]

Enterprise SDK 8.0 Reference API
BrokerException Constructor (Object, MethodInfo, String)
BrokerException Class See Also Send Feedback
Construct an exception with Target object, Method and Message

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public BrokerException(
    Object target,
    MethodInfo method,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    target As Object, _
    method As MethodInfo, _
    message As String _
)
Visual C++
public:
BrokerException(
    Object^ target,
    MethodInfo^ method,
    String^ message
)

Parameters

target
Type: System..::.Object

[Missing <param name="target"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.#ctor(System.Object,System.Reflection.MethodInfo,System.String)"]

method
Type: System.Reflection..::.MethodInfo

[Missing <param name="method"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.#ctor(System.Object,System.Reflection.MethodInfo,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.#ctor(System.Object,System.Reflection.MethodInfo,System.String)"]

See Also

BrokerException Class
BrokerException Overload
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Methods
BrokerException Class See Also Send Feedback

The BrokerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.GetObjectData Method
BrokerException Class See Also Send Feedback
Custom Serializing

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Broker.BrokerException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


BrokerException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerException Properties
BrokerException Class See Also Send Feedback

The BrokerException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Get error message (Overrides Exception..::.Message.)
Method | Get the strategy name at the origin of error
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Target | Get the strategy name at the origin of error
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Message Property

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.Message Property
BrokerException Class See Also Send Feedback
Get error message

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string Message { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::.Message

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Method Property

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.Method Property
BrokerException Class See Also Send Feedback
Get the strategy name at the origin of error

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public MethodInfo Method { get; }
Visual Basic (Declaration)
Public ReadOnly Property Method As MethodInfo
Visual C++
public:
property MethodInfo^ Method {
    MethodInfo^ get ();
}

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
BrokerException..::.Target Property
BrokerException Class See Also Send Feedback
Get the strategy name at the origin of error

Namespace: Genesyslab.Enterprise.Exceptions.Broker
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Target { get; }
Visual Basic (Declaration)
Public ReadOnly Property Target As Object
Visual C++
public:
property Object^ Target {
    Object^ get ();
}

See Also

BrokerException Class
Genesyslab.Enterprise.Exceptions.Broker Namespace


Genesyslab.Enterprise.Exceptions.Channel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Channel Namespace
Send Feedback

Classes

Class | Description
ChannelException | Interface for handling Channel exception.

Enumerations

Enumeration | Description
ChannelExceptionType | Enumerate for Channel Exception Type.


ChannelException Class

[image]

Enterprise SDK 8.0 Reference API
ChannelException Class
Members See Also Send Feedback
Interface for handling Channel exception.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class ChannelException : EnterpriseFrameworkException,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ChannelException _
    Inherits EnterpriseFrameworkException _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ChannelException : public EnterpriseFrameworkException,
    ISerializable

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Channel..::.ChannelException

See Also

ChannelException Members
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Members
ChannelException Class Constructors Methods Properties See Also Send Feedback

The ChannelException type exposes the following members.

Constructors

Name | Description
ChannelException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor
ChannelException Class See Also Send Feedback

Overload List

Name | Description
ChannelException()()() | Creates an instance of ChannelException.
ChannelException(Int32) | Creates an instance of ChannelException.
ChannelException(String) | Creates an instance of ChannelException.
ChannelException(Int32, String) | Creates an instance of ChannelException.
ChannelException(String, Exception) | Creates an instance of ChannelException.
ChannelException(Int32, String, Exception) | Creates an instance of ChannelException.

See Also

ChannelException Class
ChannelException Members
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ChannelException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChannelException()

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (Int32)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ChannelException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
ChannelException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.Int32)"]

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (String)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ChannelException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ChannelException(
    String^ message
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.String)"]

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (Int32, String)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ChannelException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
ChannelException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.Int32,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.Int32,System.String)"]

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (String, Exception)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ChannelException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ChannelException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.String,System.Exception)"]

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ChannelException Constructor (Int32, String, Exception)
ChannelException Class See Also Send Feedback
Creates an instance of ChannelException.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ChannelException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ChannelException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.Int32,System.String,System.Exception)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.Int32,System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.#ctor(System.Int32,System.String,System.Exception)"]

See Also

ChannelException Class
ChannelException Overload
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Methods
ChannelException Class See Also Send Feedback

The ChannelException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
ChannelException..::.GetObjectData Method
ChannelException Class See Also Send Feedback
Custom Serializing

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Channel.ChannelException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelException Properties
ChannelException Class See Also Send Feedback

The ChannelException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ChannelException Class
Genesyslab.Enterprise.Exceptions.Channel Namespace


ChannelExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChannelExceptionType Enumeration
See Also Send Feedback
Enumerate for Channel Exception Type.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ChannelExceptionType
Visual Basic (Declaration)
Public Enumeration ChannelExceptionType
Visual C++
public enum class ChannelExceptionType

Members

Member name | Description
ChannelUnknownError | Unknown Error.
ChannelConnectionFailed | Connection Failed.
ChannelDoesNotExist | Channel does not exist.
ChannelNotInitializedProperly | Channel is not initialized.
ChannelInvalidTimeout | Invalid Time-out.
ChannelClosingFailed | Closing channel failed.
ChannelSendFailed | Send request failed.
ChannelInvalidProtocol | Invalid protocol for this channel.

See Also

Genesyslab.Enterprise.Exceptions.Channel Namespace


Genesyslab.Enterprise.Exceptions.Configuration Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Configuration Namespace
Send Feedback

Classes

Class | Description
ConfigurationException | This is a basic exception that application block throws in case of abnormal flow (such as 'nothing was found in Configuration Server', 'invalid parameters of connection', etc).
ConfigurationServerException | Exception class used to show configuration server error detail.
ConfigurationServiceException | Exception class used to show configuration service error detail.


ConfigurationException Class

[image]

Enterprise SDK 8.0 Reference API
ConfigurationException Class
Members See Also Send Feedback
This is a basic exception that application block throws in case of abnormal flow (such as 'nothing was found in Configuration Server', 'invalid parameters of connection', etc).

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class ConfigurationException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ConfigurationException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ConfigurationException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions.Configuration..::.ConfigurationException
Genesyslab.Enterprise.Exceptions.Configuration..::.ConfigurationServerException

See Also

ConfigurationException Members
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationException Members
ConfigurationException Class Constructors Methods Properties See Also Send Feedback

The ConfigurationException type exposes the following members.

Constructors

Name | Description
ConfigurationException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationException Constructor
ConfigurationException Class See Also Send Feedback

Overload List

Name | Description
ConfigurationException()()() | Creates the exception class.
ConfigurationException(String) | Creates the exception class.
ConfigurationException(String, Exception) | Creates the exception class.

See Also

ConfigurationException Class
ConfigurationException Members
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Constructor

[image]

Enterprise SDK 8.0 Reference API
ConfigurationException Constructor
ConfigurationException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigurationException()

See Also

ConfigurationException Class
ConfigurationException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationException Constructor (String)
ConfigurationException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfigurationException(
    String^ message
)

Parameters

message
Type: System..::.String
The message.

See Also

ConfigurationException Class
ConfigurationException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationException Constructor (String, Exception)
ConfigurationException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ConfigurationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The innter exception.

See Also

ConfigurationException Class
ConfigurationException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationException Methods
ConfigurationException Class See Also Send Feedback

The ConfigurationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationException Properties
ConfigurationException Class See Also Send Feedback

The ConfigurationException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Class

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Class
Members See Also Send Feedback
Exception class used to show configuration server error detail.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class ConfigurationServerException : ConfigurationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ConfigurationServerException _
    Inherits ConfigurationException
Visual C++
[SerializableAttribute]
public ref class ConfigurationServerException : public ConfigurationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions.Configuration..::.ConfigurationException
Genesyslab.Enterprise.Exceptions.Configuration..::.ConfigurationServerException

See Also

ConfigurationServerException Members
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Members
ConfigurationServerException Class Constructors Methods Properties See Also Send Feedback

The ConfigurationServerException type exposes the following members.

Constructors

Name | Description
ConfigurationServerException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorType | Error type.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
ObjectProperty | The property of the object.
ObjectType | Object type.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationServerException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Constructor
ConfigurationServerException Class See Also Send Feedback

Overload List

Name | Description
ConfigurationServerException()()() | Creates the exception class.
ConfigurationServerException(String) | Creates the exception class.
ConfigurationServerException(String, Exception) | Creates the exception class.
ConfigurationServerException(Int32, Int32, Int32, String) | Creates the exception class.

See Also

ConfigurationServerException Class
ConfigurationServerException Members
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Constructor

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Constructor
ConfigurationServerException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServerException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigurationServerException()

See Also

ConfigurationServerException Class
ConfigurationServerException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Constructor (String)
ConfigurationServerException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServerException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfigurationServerException(
    String^ message
)

Parameters

message
Type: System..::.String
The message.

See Also

ConfigurationServerException Class
ConfigurationServerException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Constructor (String, Exception)
ConfigurationServerException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServerException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ConfigurationServerException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The innter exception.

See Also

ConfigurationServerException Class
ConfigurationServerException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Constructor (Int32, Int32, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Constructor (Int32, Int32, Int32, String)
ConfigurationServerException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServerException(
    int errorType,
    int objectType,
    int objectProperty,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorType As Integer, _
    objectType As Integer, _
    objectProperty As Integer, _
    message As String _
)
Visual C++
public:
ConfigurationServerException(
    int errorType,
    int objectType,
    int objectProperty,
    String^ message
)

Parameters

errorType
Type: System..::.Int32
Error type.
objectType
Type: System..::.Int32
Object type.
objectProperty
Type: System..::.Int32
The property of the object.
message
Type: System..::.String
The message.

See Also

ConfigurationServerException Class
ConfigurationServerException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Methods
ConfigurationServerException Class See Also Send Feedback

The ConfigurationServerException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationServerException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServerException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException Properties
ConfigurationServerException Class See Also Send Feedback

The ConfigurationServerException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorType | Error type.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
ObjectProperty | The property of the object.
ObjectType | Object type.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationServerException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ErrorType Property

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException..::.ErrorType Property
ConfigurationServerException Class See Also Send Feedback
Error type.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ErrorType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorType As Integer
Visual C++
public:
property int ErrorType {
    int get ();
}

See Also

ConfigurationServerException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ObjectProperty Property

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException..::.ObjectProperty Property
ConfigurationServerException Class See Also Send Feedback
The property of the object.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectProperty { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectProperty As Integer
Visual C++
public:
property int ObjectProperty {
    int get ();
}

See Also

ConfigurationServerException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServerException..::.ObjectType Property
ConfigurationServerException Class See Also Send Feedback
Object type.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int ObjectType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectType As Integer
Visual C++
public:
property int ObjectType {
    int get ();
}

See Also

ConfigurationServerException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Class

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Class
Members See Also Send Feedback
Exception class used to show configuration service error detail.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class ConfigurationServiceException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ConfigurationServiceException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ConfigurationServiceException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions.Configuration..::.ConfigurationServiceException

See Also

ConfigurationServiceException Members
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Members
ConfigurationServiceException Class Constructors Methods Properties See Also Send Feedback

The ConfigurationServiceException type exposes the following members.

Constructors

Name | Description
ConfigurationServiceException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationServiceException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Constructor
ConfigurationServiceException Class See Also Send Feedback

Overload List

Name | Description
ConfigurationServiceException()()() | Creates the exception class.
ConfigurationServiceException(String) | Creates the exception class.
ConfigurationServiceException(String, Exception) | Creates the exception class.

See Also

ConfigurationServiceException Class
ConfigurationServiceException Members
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Constructor

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Constructor
ConfigurationServiceException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServiceException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigurationServiceException()

See Also

ConfigurationServiceException Class
ConfigurationServiceException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Constructor (String)
ConfigurationServiceException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServiceException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfigurationServiceException(
    String^ message
)

Parameters

message
Type: System..::.String
The message.

See Also

ConfigurationServiceException Class
ConfigurationServiceException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Constructor (String, Exception)
ConfigurationServiceException Class See Also Send Feedback
Creates the exception class.

Namespace: Genesyslab.Enterprise.Exceptions.Configuration
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationServiceException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ConfigurationServiceException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The innter exception.

See Also

ConfigurationServiceException Class
ConfigurationServiceException Overload
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Methods
ConfigurationServiceException Class See Also Send Feedback

The ConfigurationServiceException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationServiceException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


ConfigurationServiceException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationServiceException Properties
ConfigurationServiceException Class See Also Send Feedback

The ConfigurationServiceException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationServiceException Class
Genesyslab.Enterprise.Exceptions.Configuration Namespace


Genesyslab.Enterprise.Exceptions.Protocol Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Protocol Namespace
Send Feedback

Classes

Class | Description
ProtocolException | Interface for handling Protocol exception.

Enumerations

Enumeration | Description
ProtocolExceptionType | Enumerate for Protocol Exception type.


ProtocolException Class

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Class
Members See Also Send Feedback
Interface for handling Protocol exception.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public class ProtocolException : EnterpriseFrameworkException,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ProtocolException _
    Inherits EnterpriseFrameworkException _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ProtocolException : public EnterpriseFrameworkException,
    ISerializable

Inheritance Hierarchy

System..::.Object
System..::.Exception
Genesyslab.Enterprise.Exceptions..::.EnterpriseException
Genesyslab.Enterprise.Exceptions..::.EnterpriseFrameworkException
Genesyslab.Enterprise.Exceptions.Protocol..::.ProtocolException

See Also

ProtocolException Members
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Members

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Members
ProtocolException Class Constructors Methods Properties See Also Send Feedback

The ProtocolException type exposes the following members.

Constructors

Name | Description
ProtocolException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor
ProtocolException Class See Also Send Feedback

Overload List

Name | Description
ProtocolException()()() | Creates an instance of ProtocolException.
ProtocolException(Int32) | Creates an instance of ProtocolException.
ProtocolException(String) | Creates an instance of ProtocolException.
ProtocolException(Int32, String) | Creates an instance of ProtocolException.
ProtocolException(String, Exception) | Creates an instance of ProtocolException.
ProtocolException(Int32, String, Exception) | Creates an instance of ProtocolException.

See Also

ProtocolException Class
ProtocolException Members
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ProtocolException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProtocolException()

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (Int32)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (Int32)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ProtocolException(
    int errorCode
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
Visual C++
public:
ProtocolException(
    int errorCode
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.Int32)"]

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (String)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (String)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ProtocolException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ProtocolException(
    String^ message
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.String)"]

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (Int32, String)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ProtocolException(
    int errorCode,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
Visual C++
public:
ProtocolException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.Int32,System.String)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.Int32,System.String)"]

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (String, Exception)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ProtocolException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ProtocolException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.String,System.Exception)"]

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Constructor (Int32, String, Exception)

[image]

Enterprise SDK 8.0 Reference API
ProtocolException Constructor (Int32, String, Exception)
ProtocolException Class See Also Send Feedback
Creates an instance of ProtocolException.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ProtocolException(
    int errorCode,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ProtocolException(
    int errorCode,
    String^ message,
    Exception^ innerException
)

Parameters

errorCode
Type: System..::.Int32

[Missing <param name="errorCode"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.Int32,System.String,System.Exception)"]

message
Type: System..::.String

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.Int32,System.String,System.Exception)"]

innerException
Type: System..::.Exception

[Missing <param name="innerException"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.#ctor(System.Int32,System.String,System.Exception)"]

See Also

ProtocolException Class
ProtocolException Overload
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Methods
ProtocolException Class See Also Send Feedback

The ProtocolException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Custom Serializing (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


GetObjectData Method

[image]

Enterprise SDK 8.0 Reference API
ProtocolException..::.GetObjectData Method
ProtocolException Class See Also Send Feedback
Custom Serializing

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo

[Missing <param name="info"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::.StreamingContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Exceptions.Protocol.ProtocolException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolException Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ProtocolException Properties
ProtocolException Class See Also Send Feedback

The ProtocolException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Gets or sets Error code. (Inherited from EnterpriseException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProtocolException Class
Genesyslab.Enterprise.Exceptions.Protocol Namespace


ProtocolExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProtocolExceptionType Enumeration
See Also Send Feedback
Enumerate for Protocol Exception type.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ProtocolExceptionType
Visual Basic (Declaration)
Public Enumeration ProtocolExceptionType
Visual C++
public enum class ProtocolExceptionType

Members

Member name | Description
InvalidParameter | Invalid parameter.
MissingParameter | Missing parameter in protocol.
InvalidObjectState | Invalid object state for this protocol action.
ProtocolUnknownError | Unknown Error.
MissingProtocol | Missing protocol

See Also

Genesyslab.Enterprise.Exceptions.Protocol Namespace


Genesyslab.Enterprise.Extensions Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Extensions Namespace
Send Feedback

Classes

Class | Description
AgentServiceExtensions |
DeviceServiceExtensions | Extends the device service to perform switch-specific actions on the device.
IdentityService |
IMServiceExtensions |
InteractionServiceExtensions |
PAMExtensions | Extension Methods for PAM.
SupervisorServiceExtensions |


AgentServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.AgentServiceExtensions"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class AgentServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class AgentServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class AgentServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.AgentServiceExtensions

See Also

AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AgentServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions Members
AgentServiceExtensions Class Methods See Also Send Feedback

The AgentServiceExtensions type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel | Ends the asynchronous desactivation of the Forward mode for the given agent.
EndCallForwardSet | Ends the asynchonous activation of the Forward mode for the given agent.
EndLogin | Ends the asynchronous login of the agent.
EndLogout | Ends the agent's asynchronous logout of the ACD group specified by the queue parameter.
EndNotReady | Ends the asynchronous operation to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
EndReady | Ends the asynchronous operation to set the agent's status to ready.
EndSetDNDOff | Ends the asynchronous deactivation of the Do Not Disturb mode for the given agent.
EndSetDNDOn | Ends the asynchronous activation of the Do Not Disturb mode for the given agent.
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


AgentServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions Methods
AgentServiceExtensions Class See Also Send Feedback

The AgentServiceExtensions type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel | Ends the asynchronous desactivation of the Forward mode for the given agent.
EndCallForwardSet | Ends the asynchonous activation of the Forward mode for the given agent.
EndLogin | Ends the asynchronous login of the agent.
EndLogout | Ends the agent's asynchronous logout of the ACD group specified by the queue parameter.
EndNotReady | Ends the asynchronous operation to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
EndReady | Ends the asynchronous operation to set the agent's status to ready.
EndSetDNDOff | Ends the asynchronous deactivation of the Do Not Disturb mode for the given agent.
EndSetDNDOn | Ends the asynchronous activation of the Do Not Disturb mode for the given agent.
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete. Begins the asynchronous desactivation of the Forward mode for the given agent.
BeginCallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete. Begins the asynchronous desactivation of the Forward mode for the given agent.
BeginCallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchronous desactivation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchronous desactivation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete. Begins the asynchonous activation of the Forward mode for the given agent.
BeginCallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete. Begins the asynchonous activation of the Forward On mode for the given agent.
BeginCallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchonous activation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Begins the asynchonous activation of the Forward On mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginCallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginLogin(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete.
BeginLogin(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.
BeginLogin(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginLogin(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogin Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous login of the agent into the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginLogin(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogin Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginLogout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginLogout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginLogout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete. Initiates the agent's asynchronous logout of the ACD group specified by the queue parameter.
BeginLogout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the agent's asynchronous logout of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginLogout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginLogout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginLogout Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginNotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete.
BeginNotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginNotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous call to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginNotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginNotReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete. Initiates the asynchronous operation to set the agent's status to ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
BeginReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous operation to set the agent's status to ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginReady Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete. Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.
BeginSetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete. Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.
BeginSetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous deactivation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Obsolete. Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.
BeginSetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Obsolete. Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.
BeginSetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback
Initiates the asynchronous activation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.BeginSetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

AgentServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection) | Obsolete. Deactivates the Forward mode for the given agent.
CallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardCancel(IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Deactivates the Forward mode for the given agent.
CallForwardCancel(IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardCancel Method (IIdentityService, IAgent, IDevice, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> CallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection) | Obsolete. Activates the Forward mode for the given agent.
CallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardSet(IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Activates the Forward mode for the given agent.
CallForwardSet(IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Activates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Activates the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.CallForwardSet Method (IIdentityService, IAgent, IDevice, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> CallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ CallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndCallForwardCancel Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous desactivation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndCallForwardCancel(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardCancel ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndCallForwardCancel(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndCallForwardSet Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchonous activation of the Forward mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndCallForwardSet(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardSet ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndCallForwardSet(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndLogin Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndLogin Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous login of the agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndLogin(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndLogin ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndLogin(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogin(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndLogout Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndLogout Method
AgentServiceExtensions Class See Also Send Feedback
Ends the agent's asynchronous logout of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndLogout(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndLogout ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndLogout(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndLogout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndNotReady Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndNotReady Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation to set the agent's status to not ready for receiving calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndNotReady(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndNotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndNotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndNotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReady Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndReady Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous operation to set the agent's status to ready.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndReady(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndReady(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndSetDNDOff Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous deactivation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndSetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndSetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.EndSetDNDOn Method
AgentServiceExtensions Class See Also Send Feedback
Ends the asynchronous activation of the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> EndSetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ EndSetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

AgentServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


Login Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) | Obsolete. Logs in the agent to the ACD group specified by the queue parameter.
Login(IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Logs in the agent to the ACD group specified by the queue parameter.
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection) | Obsolete.
Login(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection) | Logs the agent into the ACD group specified by the queue parameter.
Login(IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32) | Obsolete.
Login(IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32) | Synchronous login with a specified timeout

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use method without channel as parameters")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use method without channel as parameters")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use method without channel as parameters")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Logs in the agent to the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use method without channel as parameters")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use method without channel as parameters")> _
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use method without channel as parameters")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent into the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Login Method (IIdentityService, IAgent, IDevice, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Synchronous login with a specified timeout

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Login(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Login ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Login(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Login(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Login Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Logout(IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection) | Obsolete.
Logout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection) |
Logout(IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Logs the agent out of the ACD group specified by the queue parameter.
Logout(IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Logs the agent out of the ACD group specified by the queue parameter.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Logout Method (IIdentityService, IAgent, IDevice, String, String, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Logout(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Logout ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Logout(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Logout(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Logout Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
NotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) | Obsolete.
NotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection) | Sets the agent's status to not ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
NotReady(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Sets the agent's status to not ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
NotReady(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to not ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to not ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.NotReady Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> NotReady(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function NotReady ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ NotReady(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.NotReady(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
NotReady Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Ready(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) | Obsolete. Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
Ready(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection) |
Ready(IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.
Ready(IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Sets the agent's status to ready for receiving new calls. The dn paramater specifies the agent’s phone set and the queue specifies the ACD group into which the agent is logged.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.Ready Method (IIdentityService, IAgent, IDevice, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> Ready(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Ready ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ Ready(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.Ready(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
Ready Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection) | Obsolete. Deactivates the Do Not Disturb mode for the given agent.
SetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection) |
SetDNDOff(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Deactivates the Do Not Disturb mode for the given agent.
SetDNDOff(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use a method without channel parameter")> _
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ObsoleteAttribute(L"Use a method without channel parameter")]
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOff Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOff(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOff(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method
AgentServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection) | Obsolete. Activates the Do Not Disturb mode for the given agent.
SetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection) |
SetDNDOn(IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Obsolete. Activates the Do Not Disturb mode for the given agent.
SetDNDOn(IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32) |

See Also

AgentServiceExtensions Class
AgentServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb mode for the given agent.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use a method without channel parameter")]
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
<ObsoleteAttribute("Use a method without channel parameter")> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
[ObsoleteAttribute(L"Use a method without channel parameter")]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
AgentServiceExtensions..::.SetDNDOn Method (IIdentityService, IAgent, IDevice, KeyValueCollection, KeyValueCollection, Int32)
AgentServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IAgent> SetDNDOn(
    this IIdentityService service,
    IAgent agent,
    IDevice device,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IIdentityService, _
    agent As IAgent, _
    device As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IAgent^>^ SetDNDOn(
    IIdentityService^ service,
    IAgent^ agent,
    IDevice^ device,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.AgentServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

AgentServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


DeviceServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions Class
Members See Also Send Feedback
Extends the device service to perform switch-specific actions on the device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class DeviceServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class DeviceServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class DeviceServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.DeviceServiceExtensions

See Also

DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


DeviceServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions Members
DeviceServiceExtensions Class Methods See Also Send Feedback

The DeviceServiceExtensions type exposes the following members.

Methods

Name | Description
Activate | Overloaded.
BeginActivate | Overloaded.
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
BeginUnactivate | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndActivate | Activates the device in the back-end server.
EndCallForwardCancel | Deactivates the Forward feature for the specified device.
EndCallForwardSet | Activates the Forward feature for the specified device.
EndSetDNDOff | Deactivates the Do Not Disturb feature for the specified device.
EndSetDNDOn | Activates the Do Not Disturb feature for the specified device.
EndUnactivate | Unactivates the device in the back-end server.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.
Unactivate | Overloaded.

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


DeviceServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions Methods
DeviceServiceExtensions Class See Also Send Feedback

The DeviceServiceExtensions type exposes the following members.

Methods

Name | Description
Activate | Overloaded.
BeginActivate | Overloaded.
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
BeginUnactivate | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndActivate | Activates the device in the back-end server.
EndCallForwardCancel | Deactivates the Forward feature for the specified device.
EndCallForwardSet | Activates the Forward feature for the specified device.
EndSetDNDOff | Deactivates the Do Not Disturb feature for the specified device.
EndSetDNDOn | Activates the Do Not Disturb feature for the specified device.
EndUnactivate | Unactivates the device in the back-end server.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.
Unactivate | Overloaded.

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


Activate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Activate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection) | Activates synchronously the device in the back-end server.
Activate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32) | Activates synchronously the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback
Activates synchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> Activate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Activate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Activate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
Activate Overload
Genesyslab.Enterprise.Extensions Namespace


Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Activate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Activates synchronously the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> Activate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Activate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Activate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService
Device service.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
registerMode
Type: System..::.Int32
Register mode.
addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Activate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
Activate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginActivate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object) | Activates the device in the back-end server.
BeginActivate(IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object) | Activates the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginActivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginActivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginActivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginActivate Method (IDeviceService, IDevice, IClientChannel, Int32, Int32, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginActivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int registerMode,
    int addressType,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    registerMode As Integer, _
    addressType As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginActivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int registerMode,
    int addressType,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

registerMode
Type: System..::.Int32

[Missing <param name="registerMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

addressType
Type: System..::.Int32

[Missing <param name="addressType"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginActivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Deactivates the Forward feature for the specified device.
BeginCallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Deactivates the Forward feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Activates the Forward feature for the specified device.
BeginCallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Activates the Forward feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginCallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginCallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Deactivates the Do Not Disturb feature for the specified device.
BeginSetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Deactivates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Activates the Do Not Disturb feature for the specified device.
BeginSetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Activates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginSetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginSetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginUnactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object) | Unactivates the device in the back-end server.
BeginUnactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object) | Unactivates the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginUnactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginUnactivate Overload
Genesyslab.Enterprise.Extensions Namespace


BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.BeginUnactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32, AsyncCallback, Object)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginUnactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.BeginUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

DeviceServiceExtensions Class
BeginUnactivate Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardCancel(IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) | Deactivates the Forward feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> CallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardCancel Method (IDeviceService, IDevice, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> CallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
CallForwardCancel Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardSet(IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) | Activates the Forward feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> CallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.CallForwardSet Method (IDeviceService, IDevice, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> CallForwardSet(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ CallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.CallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
CallForwardSet Overload
Genesyslab.Enterprise.Extensions Namespace


EndActivate Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndActivate Method
DeviceServiceExtensions Class See Also Send Feedback
Activates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> EndActivate(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndActivate ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndActivate(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndActivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndCallForwardCancel Method
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> EndCallForwardCancel(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardCancel ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndCallForwardCancel(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardCancel(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndCallForwardSet Method
DeviceServiceExtensions Class See Also Send Feedback
Activates the Forward feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> EndCallForwardSet(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCallForwardSet ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndCallForwardSet(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndCallForwardSet(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndSetDNDOff Method
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> EndSetDNDOff(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndSetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndSetDNDOn Method
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> EndSetDNDOn(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndSetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndSetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndUnactivate Method

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.EndUnactivate Method
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> EndUnactivate(
    this IDeviceService service,
    IDevice device,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndUnactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    aResult As IAsyncResult _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ EndUnactivate(
    IDeviceService^ service,
    IDevice^ device,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.EndUnactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,System.IAsyncResult)"]

See Also

DeviceServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection) | Deactivates the Do Not Disturb feature for the specified device.
SetDNDOff(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Deactivates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> SetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOff Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Deactivates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> SetDNDOff(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOff ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOff(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOff(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
SetDNDOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection) | Activates the Do Not Disturb feature for the specified device.
SetDNDOn(IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Activates the Do Not Disturb feature for the specified device.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> SetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.SetDNDOn Method (IDeviceService, IDevice, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Activates the Do Not Disturb feature for the specified device.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> SetDNDOn(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetDNDOn ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ SetDNDOn(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.SetDNDOn(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
SetDNDOn Overload
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method

[image] [image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method
DeviceServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
Unactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection) | Unactivates the device in the back-end server.
Unactivate(IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32) | Unactivates the device in the back-end server.

See Also

DeviceServiceExtensions Class
DeviceServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> Unactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Unactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Unactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

DeviceServiceExtensions Class
Unactivate Overload
Genesyslab.Enterprise.Extensions Namespace


Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
DeviceServiceExtensions..::.Unactivate Method (IDeviceService, IDevice, IClientChannel, Int32, KeyValueCollection, Int32)
DeviceServiceExtensions Class See Also Send Feedback
Unactivates the device in the back-end server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IDN> Unactivate(
    this IDeviceService service,
    IDevice device,
    IClientChannel channel,
    int controlMode,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Unactivate ( _
    service As IDeviceService, _
    device As IDevice, _
    channel As IClientChannel, _
    controlMode As Integer, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IDN)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IDN^>^ Unactivate(
    IDeviceService^ service,
    IDevice^ device,
    IClientChannel^ channel,
    int controlMode,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IDeviceService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

controlMode
Type: System..::.Int32

[Missing <param name="controlMode"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.DeviceServiceExtensions.Unactivate(Genesyslab.Enterprise.Services.IDeviceService,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

DeviceServiceExtensions Class
Unactivate Overload
Genesyslab.Enterprise.Extensions Namespace


IdentityService Class

[image]

Enterprise SDK 8.0 Reference API
IdentityService Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.IdentityService"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class IdentityService
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class IdentityService
Visual C++
[ExtensionAttribute]
public ref class IdentityService abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.IdentityService

See Also

IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


IdentityService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService Members
IdentityService Class Methods See Also Send Feedback

Methods

Name | Description
GetAgent | Overloaded.
GetAgentService | Overloaded.
GetPerson | Overloaded.
GetPersonService | Overloaded.
GetSupervisor | Overloaded.
GetSupervisorService | Overloaded.

See Also

IdentityService Class
Genesyslab.Enterprise.Extensions Namespace


IdentityService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService Methods
IdentityService Class See Also Send Feedback

Methods

Name | Description
GetAgent | Overloaded.
GetAgentService | Overloaded.
GetPerson | Overloaded.
GetPersonService | Overloaded.
GetSupervisor | Overloaded.
GetSupervisorService | Overloaded.

See Also

IdentityService Class
Genesyslab.Enterprise.Extensions Namespace


GetAgent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgent Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetAgent(IIdentityService, String, Object) |
GetAgent(IIdentityService, String, Object, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetAgent Method (IIdentityService, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgent Method (IIdentityService, String, Object)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IIdentity GetAgent(
    this IIdentityService service,
    string name,
    Object controller
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgent ( _
    service As IIdentityService, _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetAgent(
    IIdentityService^ service,
    String^ name,
    Object^ controller
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

See Also

IdentityService Class
GetAgent Overload
Genesyslab.Enterprise.Extensions Namespace


GetAgent Method (IIdentityService, String, Object, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgent Method (IIdentityService, String, Object, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IIdentity GetAgent(
    this IIdentityService service,
    string name,
    Object controller,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgent ( _
    service As IIdentityService, _
    name As String, _
    controller As Object, _
    role As IRole _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetAgent(
    IIdentityService^ service,
    String^ name,
    Object^ controller,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgent(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetAgent Overload
Genesyslab.Enterprise.Extensions Namespace


GetAgentService Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgentService Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetAgentService(IIdentityService, IAgent) |
GetAgentService(IIdentityService, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetAgentService Method (IIdentityService, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgentService Method (IIdentityService, IAgent)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAgentService GetAgentService(
    this IIdentityService service,
    IAgent agent
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgentService ( _
    service As IIdentityService, _
    agent As IAgent _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetAgentService(
    IIdentityService^ service,
    IAgent^ agent
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IdentityService Class
GetAgentService Overload
Genesyslab.Enterprise.Extensions Namespace


GetAgentService Method (IIdentityService, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetAgentService Method (IIdentityService, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAgentService GetAgentService(
    this IIdentityService service,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetAgentService ( _
    service As IIdentityService, _
    role As IRole _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetAgentService(
    IIdentityService^ service,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetAgentService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetAgentService Overload
Genesyslab.Enterprise.Extensions Namespace


GetPerson Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPerson Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetPerson(IIdentityService, String, Object) |
GetPerson(IIdentityService, String, Object, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetPerson Method (IIdentityService, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPerson Method (IIdentityService, String, Object)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IIdentity GetPerson(
    this IIdentityService service,
    string name,
    Object controller
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPerson ( _
    service As IIdentityService, _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetPerson(
    IIdentityService^ service,
    String^ name,
    Object^ controller
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

See Also

IdentityService Class
GetPerson Overload
Genesyslab.Enterprise.Extensions Namespace


GetPerson Method (IIdentityService, String, Object, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPerson Method (IIdentityService, String, Object, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IIdentity GetPerson(
    this IIdentityService service,
    string name,
    Object controller,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPerson ( _
    service As IIdentityService, _
    name As String, _
    controller As Object, _
    role As IRole _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetPerson(
    IIdentityService^ service,
    String^ name,
    Object^ controller,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPerson(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetPerson Overload
Genesyslab.Enterprise.Extensions Namespace


GetPersonService Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPersonService Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetPersonService(IIdentityService, IAgent) |
GetPersonService(IIdentityService, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetPersonService Method (IIdentityService, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPersonService Method (IIdentityService, IAgent)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAgentService GetPersonService(
    this IIdentityService service,
    IAgent person
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPersonService ( _
    service As IIdentityService, _
    person As IAgent _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetPersonService(
    IIdentityService^ service,
    IAgent^ person
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

person
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="person"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IdentityService Class
GetPersonService Overload
Genesyslab.Enterprise.Extensions Namespace


GetPersonService Method (IIdentityService, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetPersonService Method (IIdentityService, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAgentService GetPersonService(
    this IIdentityService service,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetPersonService ( _
    service As IIdentityService, _
    role As IRole _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetPersonService(
    IIdentityService^ service,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetPersonService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetPersonService Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisor Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisor Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetSupervisor(IIdentityService, String, Object) |
GetSupervisor(IIdentityService, String, Object, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetSupervisor Method (IIdentityService, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisor Method (IIdentityService, String, Object)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IIdentity GetSupervisor(
    this IIdentityService service,
    string name,
    Object controller
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisor ( _
    service As IIdentityService, _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetSupervisor(
    IIdentityService^ service,
    String^ name,
    Object^ controller
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object)"]

See Also

IdentityService Class
GetSupervisor Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisor Method (IIdentityService, String, Object, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisor Method (IIdentityService, String, Object, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IIdentity GetSupervisor(
    this IIdentityService service,
    string name,
    Object controller,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisor ( _
    service As IIdentityService, _
    name As String, _
    controller As Object, _
    role As IRole _
) As IIdentity
Visual C++
[ExtensionAttribute]
public:
static IIdentity^ GetSupervisor(
    IIdentityService^ service,
    String^ name,
    Object^ controller,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

controller
Type: System..::.Object

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisor(Genesyslab.Enterprise.Services.IIdentityService,System.String,System.Object,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetSupervisor Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisorService Method

[image] [image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisorService Method
IdentityService Class See Also Send Feedback

Overload List

Name | Description
GetSupervisorService(IIdentityService, IAgent) |
GetSupervisorService(IIdentityService, IRole) |

See Also

IdentityService Class
IdentityService Members
Genesyslab.Enterprise.Extensions Namespace


GetSupervisorService Method (IIdentityService, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisorService Method (IIdentityService, IAgent)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAgentService GetSupervisorService(
    this IIdentityService service,
    IAgent supervisor
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisorService ( _
    service As IIdentityService, _
    supervisor As IAgent _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetSupervisorService(
    IIdentityService^ service,
    IAgent^ supervisor
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

supervisor
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="supervisor"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IdentityService Class
GetSupervisorService Overload
Genesyslab.Enterprise.Extensions Namespace


GetSupervisorService Method (IIdentityService, IRole)

[image]

Enterprise SDK 8.0 Reference API
IdentityService..::.GetSupervisorService Method (IIdentityService, IRole)
IdentityService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAgentService GetSupervisorService(
    this IIdentityService service,
    IRole role
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function GetSupervisorService ( _
    service As IIdentityService, _
    role As IRole _
) As IAgentService
Visual C++
[ExtensionAttribute]
public:
static IAgentService^ GetSupervisorService(
    IIdentityService^ service,
    IRole^ role
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IIdentityService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.IdentityService.GetSupervisorService(Genesyslab.Enterprise.Services.IIdentityService,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IdentityService Class
GetSupervisorService Overload
Genesyslab.Enterprise.Extensions Namespace


IMServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
IMServiceExtensions Class
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.IMServiceExtensions"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class IMServiceExtensions
Visual Basic (Declaration)
Public NotInheritable Class IMServiceExtensions
Visual C++
public ref class IMServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.IMServiceExtensions

See Also

Genesyslab.Enterprise.Extensions Namespace


InteractionServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class InteractionServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class InteractionServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class InteractionServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.InteractionServiceExtensions

See Also

InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InteractionServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions Members
InteractionServiceExtensions Class Methods See Also Send Feedback

The InteractionServiceExtensions type exposes the following members.

Methods

Name | Description
AlternateCall | Overloaded.
AnswerCall | Overloaded.
BeginAlternateCall | Overloaded.
BeginAnswerCall | Overloaded.
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginDeleteFromConference | Overloaded.
BeginHoldCall | Overloaded.
BeginInitiateConference | Overloaded.
BeginInitiateTransfer | Overloaded.
BeginListenDisconnect | Overloaded.
BeginListenReconnect | Overloaded.
BeginMakeCall | Overloaded.
BeginMuteTransfer | Overloaded.
BeginReconnectCall | Overloaded.
BeginRedirectCall | Overloaded.
BeginReleaseCall | Overloaded.
BeginRetrieveCall | Overloaded.
BeginSendDtmf | Overloaded.
BeginSetCallQualification | Overloaded.
BeginSetMuteOff | Overloaded.
BeginSetMuteOn | Overloaded.
BeginSingleStepConference | Overloaded.
BeginSingleStepTransfer | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
DeleteFromConference | Overloaded.
EndAlternateCall | Ends the asynchronous of a call. Alternates between the given call and a held call.
EndAnswerCall | Ends the asynchronous of a call. Answers the given call (which is the given ringing interaction).
EndCompleteConference | Ends the asynchronous of a call. Completes the two-step conference for the given call.
EndCompleteTransfer | Ends the asynchronous of a call. Completes the given two-step transfer.
EndDeleteFromConference | Ends the asynchronous of a call. Deletes the given party from the conference.
EndHoldCall | Ends the asynchronous of a call. Places the given interaction on hold.
EndInitiateConference | Ends the asynchronous of a call. Initiates the two-step conference for the given call.
EndInitiateTransfer | Ends the asynchronous of a call. Initiates the two-step transfer of the given call.
EndListenDisconnect | Ends the asynchronous of a call.
EndListenReconnect | Ends the asynchronous of a call.
EndMakeCall | Ends the asynchronous of a call. Dials a new call.
EndMuteTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single blind attempt.
EndReconnectCall | End asynchronous reconnect call
EndRedirectCall | End asynchronous redirect call
EndReleaseCall | Ends the asynchronous of a call. Releases the given interaction.
EndRetrieveCall | Ends the asynchronous of a call. Retrieves the given interaction being held.
EndSendDtmf | Ends the asynchronous of a call. Sends digits as DTMF tones on the given phone call.
EndSetCallQualification | Ends the asynchronous of a call. Sets the call qualification.
EndSetMuteOff | Ends the asynchronous of a call. Cancels the call muting (enables the microphone).
EndSetMuteOn | Ends the asynchronous of a call. Mutes this call (disables the microphone).
EndSingleStepConference | Ends the asynchronous of a call. Conferences this call in one step.
EndSingleStepTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single step (without creating a consultation call).
HoldCall | Overloaded.
InitiateConference | Overloaded.
InitiateTransfer | Overloaded.
ListenDisconnect | Overloaded.
ListenReconnect | Overloaded.
MakeCall | Overloaded.
MuteTransfer | Overloaded.
ReconnectCall | Overloaded.
RedirectCall | Overloaded.
ReleaseCall | Overloaded.
RetrieveCall | Overloaded.
SendDtmf | Overloaded.
SetCallQualification | Overloaded.
SetMuteOff | Overloaded.
SetMuteOn | Overloaded.
SingleStepConference | Overloaded.
SingleStepTransfer | Overloaded.

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


InteractionServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions Methods
InteractionServiceExtensions Class See Also Send Feedback

The InteractionServiceExtensions type exposes the following members.

Methods

Name | Description
AlternateCall | Overloaded.
AnswerCall | Overloaded.
BeginAlternateCall | Overloaded.
BeginAnswerCall | Overloaded.
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginDeleteFromConference | Overloaded.
BeginHoldCall | Overloaded.
BeginInitiateConference | Overloaded.
BeginInitiateTransfer | Overloaded.
BeginListenDisconnect | Overloaded.
BeginListenReconnect | Overloaded.
BeginMakeCall | Overloaded.
BeginMuteTransfer | Overloaded.
BeginReconnectCall | Overloaded.
BeginRedirectCall | Overloaded.
BeginReleaseCall | Overloaded.
BeginRetrieveCall | Overloaded.
BeginSendDtmf | Overloaded.
BeginSetCallQualification | Overloaded.
BeginSetMuteOff | Overloaded.
BeginSetMuteOn | Overloaded.
BeginSingleStepConference | Overloaded.
BeginSingleStepTransfer | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
DeleteFromConference | Overloaded.
EndAlternateCall | Ends the asynchronous of a call. Alternates between the given call and a held call.
EndAnswerCall | Ends the asynchronous of a call. Answers the given call (which is the given ringing interaction).
EndCompleteConference | Ends the asynchronous of a call. Completes the two-step conference for the given call.
EndCompleteTransfer | Ends the asynchronous of a call. Completes the given two-step transfer.
EndDeleteFromConference | Ends the asynchronous of a call. Deletes the given party from the conference.
EndHoldCall | Ends the asynchronous of a call. Places the given interaction on hold.
EndInitiateConference | Ends the asynchronous of a call. Initiates the two-step conference for the given call.
EndInitiateTransfer | Ends the asynchronous of a call. Initiates the two-step transfer of the given call.
EndListenDisconnect | Ends the asynchronous of a call.
EndListenReconnect | Ends the asynchronous of a call.
EndMakeCall | Ends the asynchronous of a call. Dials a new call.
EndMuteTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single blind attempt.
EndReconnectCall | End asynchronous reconnect call
EndRedirectCall | End asynchronous redirect call
EndReleaseCall | Ends the asynchronous of a call. Releases the given interaction.
EndRetrieveCall | Ends the asynchronous of a call. Retrieves the given interaction being held.
EndSendDtmf | Ends the asynchronous of a call. Sends digits as DTMF tones on the given phone call.
EndSetCallQualification | Ends the asynchronous of a call. Sets the call qualification.
EndSetMuteOff | Ends the asynchronous of a call. Cancels the call muting (enables the microphone).
EndSetMuteOn | Ends the asynchronous of a call. Mutes this call (disables the microphone).
EndSingleStepConference | Ends the asynchronous of a call. Conferences this call in one step.
EndSingleStepTransfer | Ends the asynchronous of a call. Transfers the given interaction in a single step (without creating a consultation call).
HoldCall | Overloaded.
InitiateConference | Overloaded.
InitiateTransfer | Overloaded.
ListenDisconnect | Overloaded.
ListenReconnect | Overloaded.
MakeCall | Overloaded.
MuteTransfer | Overloaded.
ReconnectCall | Overloaded.
RedirectCall | Overloaded.
ReleaseCall | Overloaded.
RetrieveCall | Overloaded.
SendDtmf | Overloaded.
SetCallQualification | Overloaded.
SetMuteOff | Overloaded.
SetMuteOn | Overloaded.
SingleStepConference | Overloaded.
SingleStepTransfer | Overloaded.

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
AlternateCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
AlternateCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
AlternateCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Alternates between the given call and a held call.
AlternateCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
AlternateCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Synchronous command to Alternate between two interactions Interactions may be linked or not
AlternateCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Synchronous command to Alternate between two interactions Interactions may be linked or not

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current call.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Extension list.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Synchronous command to Alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
Synchronous command to Alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AlternateCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AlternateCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AlternateCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
AlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AnswerCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
AnswerCall(IInteractionService, IInteraction, KeyValueCollection) |
AnswerCall(IInteractionService, IInteraction, KeyValueCollection, Int32) |
AnswerCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection) | Answers the given call (which is the given ringing interaction).
AnswerCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IInteractionService, IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AnswerCall Method (IInteractionService, IInteraction, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IInteractionService, IInteraction, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AnswerCall Method (IInteractionService, IInteraction, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


AnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.AnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> AnswerCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function AnswerCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ AnswerCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.AnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
AnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginAlternateCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginAlternateCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginAlternateCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginAlternateCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginAlternateCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginAlternateCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Asynchronous command to alternate between two interactions Interactions may be linked or not

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAlternateCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAlternateCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAlternateCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAlternateCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAlternateCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAnswerCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginAnswerCall(IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object) |
BeginAnswerCall(IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32) |
BeginAnswerCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object) |
BeginAnswerCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAnswerCall Method (IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAnswerCall Method (IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    timeOut As Integer _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.Int32)"]

See Also

InteractionServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginAnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginAnswerCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginAnswerCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginAnswerCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginAnswerCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginAnswerCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCompleteConference(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteConference(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteConference(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteConference(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteConference(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Asynchronous command to alternate between two interactions Interactions may be linked or not
BeginCompleteConference(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Asynchronous command to alternate between two interactions Interactions may be linked or not

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteConference(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteConference ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteConference(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginCompleteTransfer(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteTransfer(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteTransfer(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteTransfer(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginCompleteTransfer(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCompleteTransfer(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Asynchronous command to alternate between two interactions Interactions may be linked or not

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginCompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginCompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Asynchronous command to alternate between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginCompleteTransfer(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginCompleteTransfer ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginCompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginDeleteFromConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginDeleteFromConference(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginDeleteFromConference(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginDeleteFromConference(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginDeleteFromConference(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginDeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginDeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginDeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginDeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginDeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginDeleteFromConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginDeleteFromConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginDeleteFromConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginDeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginHoldCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginHoldCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginHoldCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginHoldCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginHoldCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginHoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginHoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginHoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginHoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginHoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginHoldCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginHoldCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginHoldCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginHoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginHoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginInitiateConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginInitiateConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginInitiateTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginInitiateTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginInitiateTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginInitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginInitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginInitiateTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginInitiateTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginInitiateTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginInitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenDisconnect Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginListenDisconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenDisconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenDisconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginListenDisconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenDisconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenDisconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenDisconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenReconnect Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginListenReconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenReconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginListenReconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginListenReconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginListenReconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginListenReconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginListenReconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMakeCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginMakeCall(IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginMakeCall(IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Make an asynchronous call on a device
BeginMakeCall(IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginMakeCall(IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Make an asynchronous call on a device

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IInteractionService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IInteractionService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IInteractionService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Make an asynchronous call on a device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IInteractionService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IInteractionService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IInteractionService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IInteractionService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IInteractionService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IInteractionService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Make an asynchronous call on a device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMakeCall(
    this IInteractionService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMakeCall ( _
    service As IInteractionService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMakeCall(
    IInteractionService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMuteTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginMuteTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginMuteTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginMuteTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginMuteTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginMuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginMuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginMuteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginMuteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginMuteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginMuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReconnectCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReconnectCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Begin asynchronous reconnect operation
BeginReconnectCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Begin asynchronous reconnect operation
BeginReconnectCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Begin asynchronous reconnect operation

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReconnectCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReconnectCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReconnectCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReconnectCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRedirectCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginRedirectCall(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Begin asynchronous redirect operation
BeginRedirectCall(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Begin asynchronous redirect operation
BeginRedirectCall(IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Begin asynchronous redirect operation
BeginRedirectCall(IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Begin asynchronous redirect operation

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback
Begin asynchronous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReleaseCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginReleaseCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginReleaseCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginReleaseCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginReleaseCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginReleaseCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginReleaseCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginReleaseCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRetrieveCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginRetrieveCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginRetrieveCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginRetrieveCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginRetrieveCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginRetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginRetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginRetrieveCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginRetrieveCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginRetrieveCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginRetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSendDtmf Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSendDtmf(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSendDtmf(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSendDtmf(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSendDtmf(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IInteractionService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IInteractionService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSendDtmf(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSendDtmf ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSendDtmf(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetCallQualification(IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IInteractionService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetCallQualification(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object) |
BeginSetCallQualification(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetCallQualification(IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IInteractionService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IInteractionService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IInteractionService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetCallQualification(
    this IInteractionService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetCallQualification ( _
    interactionService As IInteractionService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetCallQualification(
    IInteractionService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOff Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetMuteOff(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOff(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetMuteOff(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOff(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOff(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOff ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOff(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOn Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSetMuteOn(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOn(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSetMuteOn(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetMuteOn(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSetMuteOn(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSetMuteOn ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSetMuteOn(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSingleStepConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSingleStepConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginSingleStepTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSingleStepTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginSingleStepTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500
callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


BeginSingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.BeginSingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginSingleStepTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginSingleStepTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginSingleStepTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.BeginSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

InteractionServiceExtensions Class
BeginSingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CompleteConference(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
CompleteConference(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
CompleteConference(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Completes the two-step conference for the given call.
CompleteConference(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
CompleteConference(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Synchronous command to conference between two interactions Interactions may be linked or not
CompleteConference(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Synchronous command to conference between two interactions Interactions may be linked or not

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Synchronous command to conference between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteConference Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
Synchronous command to conference between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteConference(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteConference ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteConference(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
CompleteConference Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
CompleteTransfer(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
CompleteTransfer(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
CompleteTransfer(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Completes the given two-step transfer.
CompleteTransfer(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |
CompleteTransfer(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) |
CompleteTransfer(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Synchronous command to conference between two interactions Interactions may be linked or not

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
reasons
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


CompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.CompleteTransfer Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
Synchronous command to conference between two interactions Interactions may be linked or not

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> CompleteTransfer(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function CompleteTransfer ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ CompleteTransfer(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.CompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
CompleteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.DeleteFromConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
DeleteFromConference(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
DeleteFromConference(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) | Deletes the given party from the conference.
DeleteFromConference(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
DeleteFromConference(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.DeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.DeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.DeleteFromConference Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


DeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.DeleteFromConference Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> DeleteFromConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function DeleteFromConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ DeleteFromConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.DeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
DeleteFromConference Overload
Genesyslab.Enterprise.Extensions Namespace


EndAlternateCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndAlternateCall Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Alternates between the given call and a held call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndAlternateCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndAlternateCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndAlternateCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndAlternateCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndAnswerCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndAnswerCall Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Answers the given call (which is the given ringing interaction).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndAnswerCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndAnswerCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndAnswerCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndAnswerCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndCompleteConference Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Completes the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndCompleteConference(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCompleteConference ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndCompleteConference(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndCompleteConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndCompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndCompleteTransfer Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Completes the given two-step transfer.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndCompleteTransfer(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndCompleteTransfer ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndCompleteTransfer(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndCompleteTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndDeleteFromConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndDeleteFromConference Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Deletes the given party from the conference.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndDeleteFromConference(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndDeleteFromConference ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndDeleteFromConference(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndDeleteFromConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndHoldCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndHoldCall Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndHoldCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndHoldCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndHoldCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndHoldCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndHoldCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndHoldCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndInitiateConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndInitiateConference Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndInitiateConference(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndInitiateConference ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndInitiateConference(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndInitiateConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndInitiateTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndInitiateTransfer Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndInitiateTransfer(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndInitiateTransfer ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndInitiateTransfer(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndInitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndListenDisconnect Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndListenDisconnect Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndListenDisconnect(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndListenDisconnect ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndListenDisconnect(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndListenReconnect Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndListenReconnect Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndListenReconnect(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndListenReconnect ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndListenReconnect(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndMakeCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndMakeCall Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndMakeCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndMakeCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndMakeCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndMakeCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndMakeCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndMakeCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndMuteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndMuteTransfer Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndMuteTransfer(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndMuteTransfer ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndMuteTransfer(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndMuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReconnectCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndReconnectCall Method
InteractionServiceExtensions Class See Also Send Feedback
End asynchronous reconnect call

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndReconnectCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReconnectCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndReconnectCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndRedirectCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndRedirectCall Method
InteractionServiceExtensions Class See Also Send Feedback
End asynchronous redirect call

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndRedirectCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndRedirectCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndRedirectCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndRedirectCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndReleaseCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndReleaseCall Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndReleaseCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndReleaseCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndReleaseCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndRetrieveCall Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndRetrieveCall Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndRetrieveCall(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndRetrieveCall ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndRetrieveCall(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndRetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSendDtmf Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndSendDtmf Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndSendDtmf(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSendDtmf ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSendDtmf(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSendDtmf(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetCallQualification Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndSetCallQualification Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndSetCallQualification(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetCallQualification ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSetCallQualification(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetMuteOff Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndSetMuteOff Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndSetMuteOff(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetMuteOff ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSetMuteOff(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSetMuteOn Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndSetMuteOn Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndSetMuteOn(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSetMuteOn ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSetMuteOn(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSingleStepConference Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndSingleStepConference Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndSingleStepConference(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSingleStepConference ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSingleStepConference(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndSingleStepTransfer Method

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.EndSingleStepTransfer Method
InteractionServiceExtensions Class See Also Send Feedback
Ends the asynchronous of a call. Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> EndSingleStepTransfer(
    this IInteractionService service,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndSingleStepTransfer ( _
    service As IInteractionService, _
    aResult As IAsyncResult _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ EndSingleStepTransfer(
    IInteractionService^ service,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.EndSingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,System.IAsyncResult)"]

See Also

InteractionServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.HoldCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
HoldCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
HoldCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
HoldCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Places the given interaction on hold.
HoldCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.HoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.HoldCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.HoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Places the given interaction on hold.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


HoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.HoldCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> HoldCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function HoldCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ HoldCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.HoldCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
HoldCall Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
InitiateConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
InitiateConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Initiates the two-step conference for the given call.
InitiateConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
InitiateConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Initiates the two-step conference for the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
InitiateConference Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
InitiateTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
InitiateTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Initiates the two-step transfer of the given call.
InitiateTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
InitiateTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Initiates the two-step transfer of the given call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


InitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.InitiateTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> InitiateTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InitiateTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ InitiateTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.InitiateTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
InitiateTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenDisconnect Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ListenDisconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
ListenDisconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
ListenDisconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenDisconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenDisconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenDisconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenDisconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenDisconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenDisconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenDisconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ListenDisconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenReconnect Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ListenReconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
ListenReconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) |
ListenReconnect(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
ListenReconnect(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenReconnect Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


ListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ListenReconnect Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ListenReconnect(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ListenReconnect ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ListenReconnect(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ListenReconnect(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ListenReconnect Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MakeCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
MakeCall(IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
MakeCall(IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Make synchronous call on a Device
MakeCall(IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Dials a new call.
MakeCall(IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Make synchronous call on a Device

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IInteractionService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IInteractionService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IInteractionService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
Make synchronous call on a Device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IInteractionService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IInteractionService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IInteractionService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MakeCall Method (IInteractionService, IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Dials a new call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IInteractionService service,
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IInteractionService, _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IInteractionService^ service,
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Dialing agent.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons for this call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch-specific extension.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MakeCall Method (IInteractionService, IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Make synchronous call on a Device

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MakeCall(
    this IInteractionService service,
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MakeCall ( _
    service As IInteractionService, _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MakeCall(
    IInteractionService^ service,
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MakeCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
MakeCall Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MuteTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
MuteTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
MuteTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Transfers the given interaction in a single blind attempt.
MuteTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
MuteTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single blind attempt.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MuteTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


MuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.MuteTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> MuteTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function MuteTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ MuteTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.MuteTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
MuteTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ReconnectCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation
ReconnectCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Begin synchronous reconnect operation
ReconnectCall(IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IInteractionService service,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IInteractionService service,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReconnectCall Method (IInteractionService, IInteraction, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
ReconnectCall by specifying only one interaction Begin synchronous reconnect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReconnectCall(
    this IInteractionService service,
    IInteraction interactionA,
    IInteraction interactionB,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReconnectCall ( _
    service As IInteractionService, _
    interactionA As IInteraction, _
    interactionB As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReconnectCall(
    IInteractionService^ service,
    IInteraction^ interactionA,
    IInteraction^ interactionB,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionA
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionA"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionB
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interactionB"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReconnectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ReconnectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RedirectCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
RedirectCall(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection) | Begin syncrhonous redirect operation
RedirectCall(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) | Begin syncrhonous redirect operation
RedirectCall(IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection) | Begin syncrhonous redirect operation
RedirectCall(IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) | Begin syncrhonous redirect operation

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RedirectCall Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


RedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RedirectCall Method (IInteractionService, IInteraction, String, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback
Begin syncrhonous redirect operation

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RedirectCall(
    this IInteractionService service,
    IInteraction interaction,
    string otherDN,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RedirectCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RedirectCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    String^ otherDN,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RedirectCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
RedirectCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReleaseCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
ReleaseCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
ReleaseCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
ReleaseCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Releases the given interaction.
ReleaseCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReleaseCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Releases the given interaction.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


ReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.ReleaseCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> ReleaseCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ReleaseCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ ReleaseCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.ReleaseCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
ReleaseCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RetrieveCall Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
RetrieveCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
RetrieveCall(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
RetrieveCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Retrieves the given interaction being held.
RetrieveCall(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RetrieveCall Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Retrieves the given interaction being held.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


RetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.RetrieveCall Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> RetrieveCall(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function RetrieveCall ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ RetrieveCall(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.RetrieveCall(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
RetrieveCall Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SendDtmf Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SendDtmf(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection) |
SendDtmf(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection) | Sends digits as DTMF tones on the given phone call.
SendDtmf(IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
SendDtmf(IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IInteractionService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Sends digits as DTMF tones on the given phone call.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SendDtmf Method (IInteractionService, IInteraction, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IInteractionService interactionService,
    IInteraction interaction,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SendDtmf Method (IInteractionService, IInteraction, IClientChannel, String, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SendDtmf(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string dtmfDigits,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SendDtmf ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    dtmfDigits As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SendDtmf(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ dtmfDigits,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

dtmfDigits
Type: System..::.String

[Missing <param name="dtmfDigits"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SendDtmf(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SendDtmf Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetCallQualification(IInteractionService, IInteraction, KeyValueCollection) |
SetCallQualification(IInteractionService, IInteraction, KeyValueCollection, Int32) |
SetCallQualification(IInteractionService, IInteraction, IClientChannel, KeyValueCollection) | Sets the call qualification.
SetCallQualification(IInteractionService, IClientChannel, IDevice, String, KeyValueCollection) |
SetCallQualification(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32) |
SetCallQualification(IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    userData As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method (IInteractionService, IInteraction, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Sets the call qualification.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IInteractionService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IInteractionService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IInteractionService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetCallQualification Method (IInteractionService, IClientChannel, IDevice, String, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetCallQualification(
    this IInteractionService interactionService,
    IClientChannel channel,
    IDevice device,
    string interactionId,
    KeyValueCollection userData,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetCallQualification ( _
    interactionService As IInteractionService, _
    channel As IClientChannel, _
    device As IDevice, _
    interactionId As String, _
    userData As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetCallQualification(
    IInteractionService^ interactionService,
    IClientChannel^ channel,
    IDevice^ device,
    String^ interactionId,
    KeyValueCollection^ userData,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetCallQualification(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetCallQualification Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOff Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetMuteOff(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
SetMuteOff(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
SetMuteOff(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Cancels the call muting (enables the microphone).
SetMuteOff(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOff Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Cancels the call muting (enables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOff Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOff(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOff ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOff(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOff(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetMuteOff Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOn Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SetMuteOn(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection) |
SetMuteOn(IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32) |
SetMuteOn(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection) | Mutes this call (disables the microphone).
SetMuteOn(IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOn Method (IInteractionService, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IInteractionService interactionService,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Mutes this call (disables the microphone).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SetMuteOn Method (IInteractionService, IInteraction, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SetMuteOn(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SetMuteOn ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SetMuteOn(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SetMuteOn(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SetMuteOn Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepConference Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SingleStepConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Conferences this call in one step.
SingleStepConference(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepConference(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Conferences this call in one step.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepConference Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepConference Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepConference(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepConference ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepConference(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepConference(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SingleStepConference Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepTransfer Method
InteractionServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
SingleStepTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
SingleStepTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Transfers the given interaction in a single step (without creating a consultation call).
SingleStepTransfer(IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |
SingleStepTransfer(IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) |

See Also

InteractionServiceExtensions Class
InteractionServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
InteractionServiceExtensions Class See Also Send Feedback
Transfers the given interaction in a single step (without creating a consultation call).

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService
Service on which this Extension Method apply to
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Communication channel to use
otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

InteractionServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepTransfer Method (IInteractionService, IInteraction, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IInteractionService interactionService,
    IInteraction interaction,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    interactionService As IInteractionService, _
    interaction As IInteraction, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IInteractionService^ interactionService,
    IInteraction^ interaction,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

interactionService
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="interactionService"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


SingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
InteractionServiceExtensions..::.SingleStepTransfer Method (IInteractionService, IInteraction, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
InteractionServiceExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IInteraction> SingleStepTransfer(
    this IInteractionService service,
    IInteraction interaction,
    IClientChannel channel,
    string otherDN,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SingleStepTransfer ( _
    service As IInteractionService, _
    interaction As IInteraction, _
    channel As IClientChannel, _
    otherDN As String, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IInteraction)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IInteraction^>^ SingleStepTransfer(
    IInteractionService^ service,
    IInteraction^ interaction,
    IClientChannel^ channel,
    String^ otherDN,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.IInteractionService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32
Time Out value in milliseconds to wait for Server response, minimum value is 500

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.InteractionServiceExtensions.SingleStepTransfer(Genesyslab.Enterprise.Services.IInteractionService,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

InteractionServiceExtensions Class
SingleStepTransfer Overload
Genesyslab.Enterprise.Extensions Namespace


PAMExtensions Class

[image]

Enterprise SDK 8.0 Reference API
PAMExtensions Class
Members See Also Send Feedback
Extension Methods for PAM.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class PAMExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class PAMExtensions
Visual C++
[ExtensionAttribute]
public ref class PAMExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.PAMExtensions

See Also

PAMExtensions Members
Genesyslab.Enterprise.Extensions Namespace


PAMExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
PAMExtensions Members
PAMExtensions Class Methods See Also Send Feedback

The PAMExtensions type exposes the following members.

Methods

Name | Description
PeekStatus | Peeks the status of an object in the Statistics Server.
SubscribeStatus | Subscribes to the status of an object in the Statistics Server.
UnsubscribeStatus | UnsubscribeStatus of an object in statistics server.

See Also

PAMExtensions Class
Genesyslab.Enterprise.Extensions Namespace


PAMExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PAMExtensions Methods
PAMExtensions Class See Also Send Feedback

The PAMExtensions type exposes the following members.

Methods

Name | Description
PeekStatus | Peeks the status of an object in the Statistics Server.
SubscribeStatus | Subscribes to the status of an object in the Statistics Server.
UnsubscribeStatus | UnsubscribeStatus of an object in statistics server.

See Also

PAMExtensions Class
Genesyslab.Enterprise.Extensions Namespace


PeekStatus Method

[image]

Enterprise SDK 8.0 Reference API
PAMExtensions..::.PeekStatus Method
PAMExtensions Class See Also Send Feedback
Peeks the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<IMonitorEventStatus> PeekStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function PeekStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<IMonitorEventStatus^>^ PeekStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.PeekStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String)"]

objectId
Type: System..::.String

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.PeekStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String)"]

tenantName
Type: System..::.String

[Missing <param name="tenantName"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.PeekStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String)"]

tenantPassword
Type: System..::.String

[Missing <param name="tenantPassword"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.PeekStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String)"]

Return Value

An Envelope that contains the statistic result.

See Also

PAMExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
PAMExtensions..::.SubscribeStatus Method
PAMExtensions Class See Also Send Feedback
Subscribes to the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static bool SubscribeStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function SubscribeStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool SubscribeStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.SubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

objectId
Type: System..::.String

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.SubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantName
Type: System..::.String

[Missing <param name="tenantName"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.SubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantPassword
Type: System..::.String

[Missing <param name="tenantPassword"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.SubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
The notification mode.
notificationValue
Type: System..::.Int32
Notification value according to the notification mode.
  • MonitorNotificationMode.ChangesBased:
    • the event is sent only if the counter value changes by more than this notification value.
  • MonitorNotificationMode.TimeBased: An event is sent every
    CopyC#
    notificationValue
     seconds
listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The callback for receiving result.

Return Value

Returns True if the subscribe request succeeded, False otherwise.

See Also

PAMExtensions Class
Genesyslab.Enterprise.Extensions Namespace


UnsubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
PAMExtensions..::.UnsubscribeStatus Method
PAMExtensions Class See Also Send Feedback
UnsubscribeStatus of an object in statistics server.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static bool UnsubscribeStatus(
    this IMonitorService pamService,
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function UnsubscribeStatus ( _
    pamService As IMonitorService, _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool UnsubscribeStatus(
    IMonitorService^ pamService,
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

pamService
Type: Genesyslab.Enterprise.Services..::.IMonitorService
The PAMService reference.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.UnsubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

objectId
Type: System..::.String

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.UnsubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantName
Type: System..::.String

[Missing <param name="tenantName"/> documentation for "M:Genesyslab.Enterprise.Extensions.PAMExtensions.UnsubscribeStatus(Genesyslab.Enterprise.Services.IMonitorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

listener
Type: Genesyslab.Enterprise.Services..::.MonitorMethodDelegate
The result callback.

Return Value

Returns True if the unsubscribe request succeeded, False otherwise.

See Also

PAMExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SupervisorServiceExtensions Class

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class SupervisorServiceExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class SupervisorServiceExtensions
Visual C++
[ExtensionAttribute]
public ref class SupervisorServiceExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Extensions..::.SupervisorServiceExtensions

See Also

SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


SupervisorServiceExtensions Members

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions Members
SupervisorServiceExtensions Class Methods See Also Send Feedback

The SupervisorServiceExtensions type exposes the following members.

Methods

Name | Description
BeginStartMonitor | Overloaded.
BeginStopMonitor | Overloaded.
EndStartMonitor | End the monitoring feature for the specified device. Synchronous method
EndStopMonitor | Deactivates the monitoring feature for the specified device. Synchronous method
StartMonitor | Overloaded.
StopMonitor | Overloaded.

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


SupervisorServiceExtensions Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions Methods
SupervisorServiceExtensions Class See Also Send Feedback

The SupervisorServiceExtensions type exposes the following members.

Methods

Name | Description
BeginStartMonitor | Overloaded.
BeginStopMonitor | Overloaded.
EndStartMonitor | End the monitoring feature for the specified device. Synchronous method
EndStopMonitor | Deactivates the monitoring feature for the specified device. Synchronous method
StartMonitor | Overloaded.
StopMonitor | Overloaded.

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitor Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginStartMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Activates asynchronously the monitoring feature for the specified device. Asynchronous method
BeginStartMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Activates asynchronously the monitoring feature for the specified device Asynchronous method

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Activates asynchronously the monitoring feature for the specified device. Asynchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginStartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent to be monitored and part of the interaction refenrences
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Monitoring mode
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
timeOut
Type: System..::.Int32
Maximum timeout in seconds
callBack
Type: System..::.AsyncCallback
callBack object
context
Type: System..::.Object
context object

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStartMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Activates asynchronously the monitoring feature for the specified device Asynchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginStartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent to be monitored and part of the interaction refenrences
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Monitoring mode
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
callBack
Type: System..::.AsyncCallback
callback object
context
Type: System..::.Object
context object

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

SupervisorServiceExtensions Class
BeginStartMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitor Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
BeginStopMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) | Deactivates the monitoring feature for the specified device. Asynchronous method
BeginStopMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) | Deactivates the monitoring feature for the specified device. Asynchronous method

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the monitoring feature for the specified device. Asynchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginStopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel device
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
callBack
Type: System..::.AsyncCallback
callBack object
context
Type: System..::.Object
context object

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStopMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


BeginStopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.BeginStopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the monitoring feature for the specified device. Asynchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IAsyncResult BeginStopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BeginStopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
[ExtensionAttribute]
public:
static IAsyncResult^ BeginStopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.BeginStopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel device
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
timeOut
Type: System..::.Int32
Maximum waiting time in seconds
callBack
Type: System..::.AsyncCallback
callBack object
context
Type: System..::.Object
context object

Return Value

IAsyncResult

See Also

SupervisorServiceExtensions Class
BeginStopMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


EndStartMonitor Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.EndStartMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback
End the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> EndStartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndStartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    aResult As IAsyncResult _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ EndStartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.EndStartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.IAsyncResult)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
aResult
Type: System..::.IAsyncResult
callback object

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


EndStopMonitor Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.EndStopMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> EndStopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IAsyncResult aResult
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function EndStopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    aResult As IAsyncResult _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ EndStopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IAsyncResult^ aResult
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.EndStopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.IAsyncResult)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel device
aResult
Type: System..::.IAsyncResult
Callback object

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.EndStopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.IAsyncResult)"]

See Also

SupervisorServiceExtensions Class
Genesyslab.Enterprise.Extensions Namespace


StartMonitor Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
StartMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection) | Activates the monitoring feature for the specified device. Synchronous method
StartMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32) | Activates the monitoring feature for the specified device. Synchronous method
StartMonitor(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection) | Monitor and interaction from a supervisor's device Synchronous method
StartMonitor(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32) | Monitor and interaction from a supervisor's device Synchronous method

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device object
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Activates the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device object
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Supervision mode
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
timeOut
Type: System..::.Int32
Maximum waiting time in seconds

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Monitor and interaction from a supervisor's device Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to be monitored
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent to be monitored and part of the interaction refenrences
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Monitoring mode
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StartMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, SupervisorModeType, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Monitor and interaction from a supervisor's device Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StartMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StartMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    mode As SupervisorModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StartMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    SupervisorModeType mode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StartMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Services.SupervisorModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to be monitored
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent to be monitored and part of the interaction refenrences
mode
Type: Genesyslab.Enterprise.Services..::.SupervisorModeType
Monitoring mode
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
timeOut
Type: System..::.Int32
Maximum waiting time in seconds

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StartMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitor Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitor Method
SupervisorServiceExtensions Class See Also Send Feedback

Overload List

Name | Description
StopMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection) | Deactivates Monitoring feature on the specified device Synchronous method
StopMonitor(ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32) | Deactivates the monitoring feature for the specified device. Synchronous method
StopMonitor(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection) | Deactivates the monitoring feature for the specified device. Synchronous method
StopMonitor(ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32) | Deactivates the monitoring feature for the specified device. Synchronous method

See Also

SupervisorServiceExtensions Class
SupervisorServiceExtensions Members
Genesyslab.Enterprise.Extensions Namespace


StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates Monitoring feature on the specified device Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel device
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IDevice, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IDevice supervisedDevice,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    supervisedDevice As IDevice, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IDevice^ supervisedDevice,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel device
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
supervisedDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent's device
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
timeOut
Type: System..::.Int32
Maximum waiting time in seconds

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent identity instance
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
SupervisorServiceExtensions..::.StopMonitor Method (ISupervisorService, IClientChannel, IDevice, IInteraction, IIdentity, KeyValueCollection, KeyValueCollection, Int32)
SupervisorServiceExtensions Class See Also Send Feedback
Deactivates the monitoring feature for the specified device. Synchronous method

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Extensions (in Genesyslab.Enterprise.Extensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IEnvelope<ISupervisorInfo> StopMonitor(
    this ISupervisorService service,
    IClientChannel channel,
    IDevice supervisorDevice,
    IInteraction interaction,
    IIdentity supervisedIdentity,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function StopMonitor ( _
    service As ISupervisorService, _
    channel As IClientChannel, _
    supervisorDevice As IDevice, _
    interaction As IInteraction, _
    supervisedIdentity As IIdentity, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of ISupervisorInfo)
Visual C++
[ExtensionAttribute]
public:
static IEnvelope<ISupervisorInfo^>^ StopMonitor(
    ISupervisorService^ service,
    IClientChannel^ channel,
    IDevice^ supervisorDevice,
    IInteraction^ interaction,
    IIdentity^ supervisedIdentity,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

service
Type: Genesyslab.Enterprise.Services..::.ISupervisorService

[Missing <param name="service"/> documentation for "M:Genesyslab.Enterprise.Extensions.SupervisorServiceExtensions.StopMonitor(Genesyslab.Enterprise.Services.ISupervisorService,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance
supervisorDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Supervisor's device
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance
supervisedIdentity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent identity instance
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Switch specific data
timeOut
Type: System..::.Int32
Maximum waiting time in seconds

Return Value

<IEnvelope<ISupervisorInfo>>

See Also

SupervisorServiceExtensions Class
StopMonitor Overload
Genesyslab.Enterprise.Extensions Namespace


Genesyslab.Enterprise.Framework.Container.Unity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Framework.Container.Unity Namespace
Send Feedback

Classes

Class | Description
GlobalThreadLifeTimeManager |


GlobalThreadLifeTimeManager Class

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class GlobalThreadLifeTimeManager : LifetimeManager,
    IRequiresRecovery
Visual Basic (Declaration)
Public Class GlobalThreadLifeTimeManager _
    Inherits LifetimeManager _
    Implements IRequiresRecovery
Visual C++
public ref class GlobalThreadLifeTimeManager : public LifetimeManager,
    IRequiresRecovery

Inheritance Hierarchy

System..::.Object
LifetimeManager
Genesyslab.Enterprise.Framework.Container.Unity..::.GlobalThreadLifeTimeManager

See Also

GlobalThreadLifeTimeManager Members
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GlobalThreadLifeTimeManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Members
GlobalThreadLifeTimeManager Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The GlobalThreadLifeTimeManager type exposes the following members.

Constructors

Name | Description
GlobalThreadLifeTimeManager |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Overrides LifetimeManagerGetValue()()().)
RemoveValue | (Overrides LifetimeManagerRemoveValue()()().)
SetValue | (Overrides LifetimeManagerSetValue(Object).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IRequiresRecoveryRecover |

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GlobalThreadLifeTimeManager Constructor

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Constructor
GlobalThreadLifeTimeManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.#ctor"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public GlobalThreadLifeTimeManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GlobalThreadLifeTimeManager()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GlobalThreadLifeTimeManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager Methods
GlobalThreadLifeTimeManager Class See Also Send Feedback

The GlobalThreadLifeTimeManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Overrides LifetimeManagerGetValue()()().)
RemoveValue | (Overrides LifetimeManagerRemoveValue()()().)
SetValue | (Overrides LifetimeManagerSetValue(Object).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IRequiresRecoveryRecover |

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


. Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::...::. Method
GlobalThreadLifeTimeManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.Microsoft#Practices#ObjectBuilder2#IRequiresRecovery#Recover"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void IRequiresRecovery.Recover()
Visual Basic (Declaration)
Private Sub Recover Implements IRequiresRecovery.Recover
Visual C++
private:
virtual void Recover() sealed = IRequiresRecovery::Recover

Implements

IRequiresRecoveryRecover()()()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


GetValue Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::.GetValue Method
GlobalThreadLifeTimeManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.GetValue"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override Object GetValue()
Visual Basic (Declaration)
Public Overrides Function GetValue As Object
Visual C++
public:
virtual Object^ GetValue() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.GetValue"]

Implements

ILifetimePolicyGetValue()()()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


RemoveValue Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::.RemoveValue Method
GlobalThreadLifeTimeManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.RemoveValue"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void RemoveValue()
Visual Basic (Declaration)
Public Overrides Sub RemoveValue
Visual C++
public:
virtual void RemoveValue() override

Implements

ILifetimePolicyRemoveValue()()()

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


SetValue Method

[image]

Enterprise SDK 8.0 Reference API
GlobalThreadLifeTimeManager..::.SetValue Method
GlobalThreadLifeTimeManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.SetValue(System.Object)"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override void SetValue(
    Object newValue
)
Visual Basic (Declaration)
Public Overrides Sub SetValue ( _
    newValue As Object _
)
Visual C++
public:
virtual void SetValue(
    Object^ newValue
) override

Parameters

newValue
Type: System..::.Object

[Missing <param name="newValue"/> documentation for "M:Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager.SetValue(System.Object)"]

Implements

ILifetimePolicySetValue(Object)

See Also

GlobalThreadLifeTimeManager Class
Genesyslab.Enterprise.Framework.Container.Unity Namespace


Genesyslab.Enterprise.Model.Channel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Channel Namespace
Send Feedback

Classes

Class | Description
ChannelExtension |

Interfaces

Interface | Description
IChannelManager | Manages channel information.
IClientChannel | Describes a client channel.
IProtocolManager | Manages protocol information in the up-level channel.

Enumerations

Enumeration | Description
ChannelModeType | Describes the mode assigned to this channel: primary, backup, or none.


ChannelExtension Class

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Channel.ChannelExtension"]

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class ChannelExtension
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class ChannelExtension
Visual C++
[ExtensionAttribute]
public ref class ChannelExtension abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.Channel..::.ChannelExtension

See Also

ChannelExtension Members
Genesyslab.Enterprise.Model.Channel Namespace


ChannelExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelExtension Members
ChannelExtension Class Methods See Also Send Feedback

The ChannelExtension type exposes the following members.

Methods

Name | Description
UseClientCertificate | Use Client Certificate to authenticate on the Genesys Channel
UseClientSidePort | Indicate Channel to use a specific Port to communicate with Genesys Servers
UseServerBasedCertificate | Use Server-Based Certificate to authenticate on the Genesys Channel

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


ChannelExtension Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ChannelExtension Methods
ChannelExtension Class See Also Send Feedback

The ChannelExtension type exposes the following members.

Methods

Name | Description
UseClientCertificate | Use Client Certificate to authenticate on the Genesys Channel
UseClientSidePort | Indicate Channel to use a specific Port to communicate with Genesys Servers
UseServerBasedCertificate | Use Server-Based Certificate to authenticate on the Genesys Channel

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


UseClientCertificate Method

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension..::.UseClientCertificate Method
ChannelExtension Class See Also Send Feedback
Use Client Certificate to authenticate on the Genesys Channel

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static void UseClientCertificate(
    this IClientChannel clientChannel,
    string certificateName
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UseClientCertificate ( _
    clientChannel As IClientChannel, _
    certificateName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void UseClientCertificate(
    IClientChannel^ clientChannel,
    String^ certificateName
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="clientChannel"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.ChannelExtension.UseClientCertificate(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

certificateName
Type: System..::.String
Client Certificate Name

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


UseClientSidePort Method

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension..::.UseClientSidePort Method
ChannelExtension Class See Also Send Feedback
Indicate Channel to use a specific Port to communicate with Genesys Servers

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static void UseClientSidePort(
    this IClientChannel clientChannel,
    string transportAddress,
    int transportPort
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UseClientSidePort ( _
    clientChannel As IClientChannel, _
    transportAddress As String, _
    transportPort As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void UseClientSidePort(
    IClientChannel^ clientChannel,
    String^ transportAddress,
    int transportPort
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel on which the port definition applied
transportAddress
Type: System..::.String
IP Address that the client application will use for its TCP/IP Connection to Genesys Channel
transportPort
Type: System..::.Int32
Port number that the client application will use for its TCP/IP Connection to Genesys Channel

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


UseServerBasedCertificate Method

[image]

Enterprise SDK 8.0 Reference API
ChannelExtension..::.UseServerBasedCertificate Method
ChannelExtension Class See Also Send Feedback
Use Server-Based Certificate to authenticate on the Genesys Channel

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static void UseServerBasedCertificate(
    this IClientChannel clientChannel,
    string certificateName
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UseServerBasedCertificate ( _
    clientChannel As IClientChannel, _
    certificateName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void UseServerBasedCertificate(
    IClientChannel^ clientChannel,
    String^ certificateName
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="clientChannel"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.ChannelExtension.UseServerBasedCertificate(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

certificateName
Type: System..::.String
Certificate Name stored on the Server

See Also

ChannelExtension Class
Genesyslab.Enterprise.Model.Channel Namespace


ChannelModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChannelModeType Enumeration
See Also Send Feedback
Describes the mode assigned to this channel: primary, backup, or none.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ChannelModeType
Visual Basic (Declaration)
Public Enumeration ChannelModeType
Visual C++
public enum class ChannelModeType

Members

Member name | Description
None |
Primary |
Backup |

See Also

Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelManager Interface
Members See Also Send Feedback
Manages channel information.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IChannelManager
Visual Basic (Declaration)
Public Interface IChannelManager
Visual C++
public interface class IChannelManager

See Also

IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager Members
IChannelManager Interface Methods See Also Send Feedback

The IChannelManager type exposes the following members.

Methods

Name | Description
AddChannel | Adds the given channel.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel.
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel.
SendMessage | Sends a message to the given channel.

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager Methods
IChannelManager Interface See Also Send Feedback

The IChannelManager type exposes the following members.

Methods

Name | Description
AddChannel | Adds the given channel.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel.
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel.
SendMessage | Sends a message to the given channel.

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.AddChannel Method
IChannelManager Interface See Also Send Feedback
Adds the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager AddChannel(
    IClientChannel channel,
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel, _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ AddChannel(
    IClientChannel^ channel,
    ProtocolConfiguration^ config
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel name.
config
Type: ProtocolConfiguration
Configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
Connect()()() | Connects all the channels. Note: This method is asynchronous.
Connect(IClientChannel) | Connects the given channel. Note: This method is asynchronous.
Connect(Int32) | Connects all the channels. Note: This method is synchronous.
Connect(String) | Connects the given channel. Note: This method is asynchronous.
Connect(IClientChannel, Int32) | Connects the given channel. Note: This method is synchronous.
Connect(String, Int32) | Connects the given channel. Note: This method is synchronous.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method
IChannelManager Interface See Also Send Feedback
Connects all the channels. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Connect()
Visual Basic (Declaration)
Function Connect As IChannelManager
Visual C++
IChannelManager^ Connect()

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (IClientChannel)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Connect(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Connect ( _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (Int32)
IChannelManager Interface See Also Send Feedback
Connects all the channels. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Connect(
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (String)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Connect(
    string channelName
)
Visual Basic (Declaration)
Function Connect ( _
    channelName As String _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (IClientChannel, Int32)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Connect(
    IClientChannel channel,
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    channel As IClientChannel, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    IClientChannel^ channel,
    int milliseconds
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.Connect(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (String, Int32)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Connect(
    string channelName,
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    channelName As String, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    String^ channelName,
    int milliseconds
)

Parameters

channelName
Type: System..::.String
Channel name.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
CreateChannel(ProtocolConfiguration) | Creates a channel based on a user configuration instance without a switch abstraction.
CreateChannel(ProtocolConfiguration, SwitchModelType) | Creates a channel based on the given user configuration and switch type.
CreateChannel(ProtocolConfiguration, String) | Creates a channel based on the given configuration instance.
CreateChannel(String, ProtocolConfiguration) | Creates a channel without switch asbtraction capability.
CreateChannel(String, IProtocol) | Creates a channel based on already existing connection
CreateChannel(String, ProtocolConfiguration, SwitchModelType) | Creates a named channel, with the given user configuration and switch abstraction capability.
CreateChannel(String, ProtocolConfiguration, String) | Creates a channel, with the given user configuration and switch abstraction capability.
CreateChannel(String, IProtocol, SwitchModelType) | Creates a channel based on already existing connection and switch type.
CreateChannel(String, IProtocol, String) | Creates a channel based on already existing connection and switch type.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method ()

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method ()
IChannelManager Interface See Also Send Feedback
Creates a channel based on a user configuration instance without a switch abstraction.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function CreateChannel ( _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config
)

Parameters

config
Type: ProtocolConfiguration
Custom configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (, SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (, SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a channel based on the given user configuration and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    ProtocolConfiguration config,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    config As ProtocolConfiguration, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config,
    SwitchModelType switchModel
)

Parameters

config
Type: ProtocolConfiguration
User configuration.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (, String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (, String)
IChannelManager Interface See Also Send Feedback
Creates a channel based on the given configuration instance.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    ProtocolConfiguration config,
    string switchType
)
Visual Basic (Declaration)
Function CreateChannel ( _
    config As ProtocolConfiguration, _
    switchType As String _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config,
    String^ switchType
)

Parameters

config
Type: ProtocolConfiguration
Custom configuration instance.
switchType
Type: System..::.String
Switch entry as defined in the Switch Policy Library (SPL). Valid values are :
  • LucentDefinityG3
  • AlcatelA4400DHS3::Classic
  • AlcatelA4400DHS3::Substitute
  • SIPSwitch
  • NortelDMS100
  • NortelMeridianCallCenter

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, )

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, )
IChannelManager Interface See Also Send Feedback
Creates a channel without switch asbtraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config
)

Parameters

name
Type: System..::.String
Channel name.
config
Type: ProtocolConfiguration
User configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, )

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, )
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    IProtocol protocol
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol)"]

protocol
Type: IProtocol

[Missing <param name="protocol"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a named channel, with the given user configuration and switch abstraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config,
    SwitchModelType switchModel
)

Parameters

name
Type: System..::.String
Channel name.
config
Type: ProtocolConfiguration
Configruation instance.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch model.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ProtocolConfiguration,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , String)
IChannelManager Interface See Also Send Feedback
Creates a channel, with the given user configuration and switch abstraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config,
    string switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration, _
    switchModel As String _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config,
    String^ switchModel
)

Parameters

name
Type: System..::.String
Channel name
config
Type: ProtocolConfiguration
Configruation instance
switchModel
Type: System..::.String
Switch entry as defined in the Switch Policy Library (SPL). Valid values are :
  • LucentDefinityG3
  • AlcatelA4400DHS3::Classic
  • AlcatelA4400DHS3::Substitute
  • SIPSwitch
  • NortelDMS100
  • NortelMeridianCallCenter

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ProtocolConfiguration,System.String)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    IProtocol protocol,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol,
    SwitchModelType switchModel
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

protocol
Type: IProtocol

[Missing <param name="protocol"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType

[Missing <param name="switchModel"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , String)
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    IProtocol protocol,
    string switchModel
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol, _
    switchModel As String _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol,
    String^ switchModel
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,System.String)"]

protocol
Type: IProtocol

[Missing <param name="protocol"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,System.String)"]

switchModel
Type: System..::.String

[Missing <param name="switchModel"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.Commons.Protocols.IProtocol,System.String)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


DeleteChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.DeleteChannel Method
IChannelManager Interface See Also Send Feedback
Deletes the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager DeleteChannel(
    string name
)
Visual Basic (Declaration)
Function DeleteChannel ( _
    name As String _
) As IChannelManager
Visual C++
IChannelManager^ DeleteChannel(
    String^ name
)

Parameters

name
Type: System..::.String
Channel name.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
Disconnect()()() | Disconnects all the channels.
Disconnect(IClientChannel) | Disconnects the given channel instance. Note: This method is asynchronous.
Disconnect(String) | Disconnects the given channel. Note: This method is asynchronous.
Disconnect(IClientChannel, Int32) | Disconnects the given channel. Note: This method is synchronous.
Disconnect(String, Int32) | Disconnects the given channel. Note: This method is synchronous.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method
IChannelManager Interface See Also Send Feedback
Disconnects all the channels.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Disconnect()
Visual Basic (Declaration)
Function Disconnect As IChannelManager
Visual C++
IChannelManager^ Disconnect()

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (IClientChannel)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel instance. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Disconnect(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Disconnect ( _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (String)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Disconnect(
    string channelName
)
Visual Basic (Declaration)
Function Disconnect ( _
    channelName As String _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (IClientChannel, Int32)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Disconnect(
    IClientChannel channel,
    int milliseconds
)
Visual Basic (Declaration)
Function Disconnect ( _
    channel As IClientChannel, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    IClientChannel^ channel,
    int milliseconds
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (String, Int32)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager Disconnect(
    string channelName,
    int milliseconds
)
Visual Basic (Declaration)
Function Disconnect ( _
    channelName As String, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    String^ channelName,
    int milliseconds
)

Parameters

channelName
Type: System..::.String
Channel name.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
GetChannel(IDevice) | Returns a channel object from a device
GetChannel(String) | Returns a channel object.
GetChannel(Uri) | Returns the channel with the given URI.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (IDevice)
IChannelManager Interface See Also Send Feedback
Returns a channel object from a device

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel GetChannel(
    IDevice device
)
Visual Basic (Declaration)
Function GetChannel ( _
    device As IDevice _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.GetChannel(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.GetChannel(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (String)
IChannelManager Interface See Also Send Feedback
Returns a channel object.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel GetChannel(
    string channel
)
Visual Basic (Declaration)
Function GetChannel ( _
    channel As String _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    String^ channel
)

Parameters

channel
Type: System..::.String
Channel name.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.GetChannel(System.String)"]

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (Uri)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (Uri)
IChannelManager Interface See Also Send Feedback
Returns the channel with the given URI.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel GetChannel(
    Uri name
)
Visual Basic (Declaration)
Function GetChannel ( _
    name As Uri _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    Uri^ name
)

Parameters

name
Type: System..::.Uri
URI to retrieve from the service registry.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
ListChannels<(Of <(T>)>)()()() | Lists the channels registered in the service.
ListChannels()()() | Lists all the channels registered in the service.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels(T) Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels<(Of <(T>)>) Method
IChannelManager Interface See Also Send Feedback
Lists the channels registered in the service.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel[] ListChannels<T>()
Visual Basic (Declaration)
Function ListChannels(Of T) As IClientChannel()
Visual C++
generic<typename T>
array<IClientChannel^>^ ListChannels()

Type Parameters

T
Protocol type that is being listed

Return Value

IClientChannel []

See Also

IChannelManager Interface
ListChannels Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels Method
IChannelManager Interface See Also Send Feedback
Lists all the channels registered in the service.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel[] ListChannels()
Visual Basic (Declaration)
Function ListChannels As IClientChannel()
Visual C++
array<IClientChannel^>^ ListChannels()

Return Value

IClientChannel []

See Also

IChannelManager Interface
ListChannels Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListDevices Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListDevices Method
IChannelManager Interface See Also Send Feedback
Lists the devices of a specific channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] ListDevices(
    string channelName
)
Visual Basic (Declaration)
Function ListDevices ( _
    channelName As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name.

Return Value

IDevice[]

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


SendMessage Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.SendMessage Method
IChannelManager Interface See Also Send Feedback
Sends a message to the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager SendMessage(
    IClientChannel channel,
    IMessage msg
)
Visual Basic (Declaration)
Function SendMessage ( _
    channel As IClientChannel, _
    msg As IMessage _
) As IChannelManager
Visual C++
IChannelManager^ SendMessage(
    IClientChannel^ channel,
    IMessage^ msg
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
msg
Type: IMessage
Message instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Interface

[image]

Enterprise SDK 8.0 Reference API
IClientChannel Interface
Members See Also Send Feedback
Describes a client channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IClientChannel : IDisposable
Visual Basic (Declaration)
Public Interface IClientChannel _
    Implements IDisposable
Visual C++
public interface class IClientChannel : IDisposable

See Also

IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Members

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Members
IClientChannel Interface Methods Properties See Also Send Feedback

The IClientChannel type exposes the following members.

Methods

Name | Description
Close | Overloaded.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Send | Sends a request through the communication channel to the connected server.

Properties

Name | Description
Endpoint | Endpoint.
EnterpriseProtocols | Protocol manager.
FQName | Fully Qualified Name (unique ID).
GetProtocolRule | Returns the protocol rule.
Mode | Channel Mode.
Name | Name.
Protocol | Protocol associated with this channel.
Receiver | Message receiver.
Requests | Returns requests.
State | Channel Status.
Strategy | Channel strategies.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Methods
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Methods

Name | Description
Close | Overloaded.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Send | Sends a request through the communication channel to the connected server.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Close Method

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method
IClientChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | Closes the communication channel. Note: This method is asynchronous.
Close(Int32) | Closes synchronously the communication channel.

See Also

IClientChannel Interface
IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


Close Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method
IClientChannel Interface See Also Send Feedback
Closes the communication channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Close()
Visual Basic (Declaration)
Sub Close
Visual C++
void Close()

See Also

IClientChannel Interface
Close Overload
Genesyslab.Enterprise.Model.Channel Namespace


Close Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method (Int32)
IClientChannel Interface See Also Send Feedback
Closes synchronously the communication channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Close(
    int milliseconds
)
Visual Basic (Declaration)
Sub Close ( _
    milliseconds As Integer _
)
Visual C++
void Close(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32

[Missing <param name="milliseconds"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IClientChannel.Close(System.Int32)"]

See Also

IClientChannel Interface
Close Overload
Genesyslab.Enterprise.Model.Channel Namespace


Send Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Send Method
IClientChannel Interface See Also Send Feedback
Sends a request through the communication channel to the connected server.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Send(
    IRequest request
)
Visual Basic (Declaration)
Function Send ( _
    request As IRequest _
) As Integer
Visual C++
int Send(
    IRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRequest

[Missing <param name="request"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IClientChannel.Send(Genesyslab.Enterprise.Model.ComponentModel.IRequest)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IClientChannel.Send(Genesyslab.Enterprise.Model.ComponentModel.IRequest)"]

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Properties
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Properties

Name | Description
Endpoint | Endpoint.
EnterpriseProtocols | Protocol manager.
FQName | Fully Qualified Name (unique ID).
GetProtocolRule | Returns the protocol rule.
Mode | Channel Mode.
Name | Name.
Protocol | Protocol associated with this channel.
Receiver | Message receiver.
Requests | Returns requests.
State | Channel Status.
Strategy | Channel strategies.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Endpoint Property
IClientChannel Interface See Also Send Feedback
Endpoint.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Uri Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Uri
Visual C++
property Uri^ Endpoint {
    Uri^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


EnterpriseProtocols Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.EnterpriseProtocols Property
IClientChannel Interface See Also Send Feedback
Protocol manager.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolManager EnterpriseProtocols { get; }
Visual Basic (Declaration)
ReadOnly Property EnterpriseProtocols As IProtocolManager
Visual C++
property IProtocolManager^ EnterpriseProtocols {
    IProtocolManager^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.FQName Property
IClientChannel Interface See Also Send Feedback
Fully Qualified Name (unique ID).

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


GetProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.GetProtocolRule Property
IClientChannel Interface See Also Send Feedback
Returns the protocol rule.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object GetProtocolRule { get; }
Visual Basic (Declaration)
ReadOnly Property GetProtocolRule As Object
Visual C++
property Object^ GetProtocolRule {
    Object^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Mode Property
IClientChannel Interface See Also Send Feedback
Channel Mode.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ChannelModeType Mode { get; }
Visual Basic (Declaration)
ReadOnly Property Mode As ChannelModeType
Visual C++
property ChannelModeType Mode {
    ChannelModeType get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Name Property
IClientChannel Interface See Also Send Feedback
Name.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Protocol Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Protocol Property
IClientChannel Interface See Also Send Feedback
Protocol associated with this channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocol Protocol { get; }
Visual Basic (Declaration)
ReadOnly Property Protocol As IProtocol
Visual C++
property IProtocol^ Protocol {
    IProtocol^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Receiver Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Receiver Property
IClientChannel Interface See Also Send Feedback
Message receiver.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IMessageReceiver Receiver { get; set; }
Visual Basic (Declaration)
Property Receiver As IMessageReceiver
Visual C++
property IMessageReceiver^ Receiver {
    IMessageReceiver^ get ();
    void set (IMessageReceiver^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Requests Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Requests Property
IClientChannel Interface See Also Send Feedback
Returns requests.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequestManager Requests { get; }
Visual Basic (Declaration)
ReadOnly Property Requests As IRequestManager
Visual C++
property IRequestManager^ Requests {
    IRequestManager^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.State Property
IClientChannel Interface See Also Send Feedback
Channel Status.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ChannelState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As ChannelState
Visual C++
property ChannelState State {
    ChannelState get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Strategy Property
IClientChannel Interface See Also Send Feedback
Channel strategies.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager Interface
Members See Also Send Feedback
Manages protocol information in the up-level channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IProtocolManager
Visual Basic (Declaration)
Public Interface IProtocolManager
Visual C++
public interface class IProtocolManager

See Also

IProtocolManager Members
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Members
IProtocolManager Interface Methods Properties See Also Send Feedback

The IProtocolManager type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all the registered protocols.
ContainsKey | Returns true if the given protocol name exists.
List | Lists all the registered protocols.
Remove | Removes the given protocol.

Properties

Name | Description
Item |

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Methods
IProtocolManager Interface See Also Send Feedback

The IProtocolManager type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all the registered protocols.
ContainsKey | Returns true if the given protocol name exists.
List | Lists all the registered protocols.
Remove | Removes the given protocol.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method
IProtocolManager Interface See Also Send Feedback

Overload List

Name | Description
Add(String, IEnterpriseProtocol) | Adds the given communication protocol. Note: The protocol's switch policy must match the channel's switch policy.
Add(String, MediaType, IEnumerable<(Of <(IProtocolRequest>)>)) | Adds the given communication protocol using the channel's switch policy.

See Also

IProtocolManager Interface
IProtocolManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Add Method (String, IEnterpriseProtocol)

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method (String, IEnterpriseProtocol)
IProtocolManager Interface See Also Send Feedback
Adds the given communication protocol. Note: The protocol's switch policy must match the channel's switch policy.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Add(
    string name,
    IEnterpriseProtocol protocol
)
Visual Basic (Declaration)
Sub Add ( _
    name As String, _
    protocol As IEnterpriseProtocol _
)
Visual C++
void Add(
    String^ name,
    IEnterpriseProtocol^ protocol
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.Add(System.String,Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol)"]

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IEnterpriseProtocol

[Missing <param name="protocol"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.Add(System.String,Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol)"]

See Also

IProtocolManager Interface
Add Overload
Genesyslab.Enterprise.Model.Channel Namespace


Add Method (String, MediaType, IEnumerable(IProtocolRequest))

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method (String, MediaType, IEnumerable<(Of <(IProtocolRequest>)>))
IProtocolManager Interface See Also Send Feedback
Adds the given communication protocol using the channel's switch policy.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Add(
    string name,
    MediaType mediaType,
    IEnumerable<IProtocolRequest> listCommands
)
Visual Basic (Declaration)
Sub Add ( _
    name As String, _
    mediaType As MediaType, _
    listCommands As IEnumerable(Of IProtocolRequest) _
)
Visual C++
void Add(
    String^ name,
    MediaType mediaType,
    IEnumerable<IProtocolRequest^>^ listCommands
)

Parameters

name
Type: System..::.String
Protocol name.
mediaType
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
Communication type.
listCommands
Type: System.Collections.Generic..::.IEnumerable <(Of <( IProtocolRequest >)>)
Commands.

See Also

IProtocolManager Interface
Add Overload
Genesyslab.Enterprise.Model.Channel Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Clear Method
IProtocolManager Interface See Also Send Feedback
Deletes all the registered protocols.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear
Visual C++
void Clear()

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.ContainsKey Method
IProtocolManager Interface See Also Send Feedback
Returns true if the given protocol name exists.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.ContainsKey(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.ContainsKey(System.String)"]

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


List Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.List Method
IProtocolManager Interface See Also Send Feedback
Lists all the registered protocols.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerator<IEnterpriseProtocol> List()
Visual Basic (Declaration)
Function List As IEnumerator(Of IEnterpriseProtocol)
Visual C++
IEnumerator<IEnterpriseProtocol^>^ List()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.List"]

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Remove Method
IProtocolManager Interface See Also Send Feedback
Removes the given protocol.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Remove(
    string key
)
Visual Basic (Declaration)
Function Remove ( _
    key As String _
) As Boolean
Visual C++
bool Remove(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.Remove(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IProtocolManager.Remove(System.String)"]

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Properties
IProtocolManager Interface See Also Send Feedback

The IProtocolManager type exposes the following members.

Properties

Name | Description
Item |

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Item Property
IProtocolManager Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Channel.IProtocolManager.Item(System.String)"]

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseProtocol this[
    string name
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As IEnterpriseProtocol
Visual C++
property IEnterpriseProtocol^ default[String^ name] {
    IEnterpriseProtocol^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Genesyslab.Enterprise.Model.Common Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Common Namespace
Send Feedback

Classes

Class | Description
ReadOnlyDictionary<(Of <(TKey, TValue>)>) |


ReadOnlyDictionary(TKey, TValue) Class

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public sealed class ReadOnlyDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class ReadOnlyDictionary(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
Visual C++
generic<typename TKey, typename TValue>
public ref class ReadOnlyDictionary sealed : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2"]

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.Common..::.ReadOnlyDictionary<(Of <(TKey, TValue>)>)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Members
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReadOnlyDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Constructors

Name | Description
ReadOnlyDictionary<(Of <(TKey, TValue>)>) |

Methods

Name | Description
Contains |
ContainsKey |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue |

Properties

Name | Description
Count |
IsReadOnly |
Item |
Keys |
Values |

Explicit Interface Implementations

Name | Description
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Add |
IDictionary<(Of <(TKey, TValue>)>)..::.Add |
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Clear |
IEnumerable..::.GetEnumerator |
IDictionary<(Of <(TKey, TValue>)>)..::.Item |
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Remove |
IDictionary<(Of <(TKey, TValue>)>)..::.Remove |

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Constructor

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Constructor
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.#ctor(System.Collections.Generic.IDictionary{`0,`1})"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ReadOnlyDictionary(
    IDictionary<TKey, TValue> source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As IDictionary(Of TKey, TValue) _
)
Visual C++
public:
ReadOnlyDictionary(
    IDictionary<TKey, TValue>^ source
)

Parameters

source
Type: System.Collections.Generic..::.IDictionary <(Of <( TKey, TValue >)>)

[Missing <param name="source"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.#ctor(System.Collections.Generic.IDictionary{`0,`1})"]

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Methods
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

The ReadOnlyDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Methods

Name | Description
Contains |
ContainsKey |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue |

Explicit Interface Implementations

Name | Description
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Add |
IDictionary<(Of <(TKey, TValue>)>)..::.Add |
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Clear |
IEnumerable..::.GetEnumerator |
ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Remove |
IDictionary<(Of <(TKey, TValue>)>)..::.Remove |

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ICollection(KeyValuePair(TKey, TValue)).Add Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Add Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ICollection<KeyValuePair<TKey, TValue>>.Add(
    KeyValuePair<TKey, TValue> item
)
Visual Basic (Declaration)
Private Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
) Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Add
Visual C++
private:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Add

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <( TKey, TValue >)>)

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IDictionary(TKey, TValue).Add Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IDictionary<(Of <(TKey, TValue>)>)..::.Add Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Add(`0,`1)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void IDictionary<TKey, TValue>.Add(
    TKey key,
    TValue value
)
Visual Basic (Declaration)
Private Sub Add ( _
    key As TKey, _
    value As TValue _
) Implements IDictionary(Of TKey, TValue).Add
Visual C++
private:
virtual void Add(
    TKey key,
    TValue value
) sealed = IDictionary<TKey, TValue>::Add

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Add(`0,`1)"]

value
Type: TValue

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Add(`0,`1)"]

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Add(TKey, TValue)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ICollection(KeyValuePair(TKey, TValue)).Clear Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Clear Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Clear"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ICollection<KeyValuePair<TKey, TValue>>.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Clear
Visual C++
private:
virtual void Clear() sealed = ICollection<KeyValuePair<TKey, TValue>>::Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IEnumerable.GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IEnumerable..::.GetEnumerator Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#IEnumerable#GetEnumerator"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#IEnumerable#GetEnumerator"]

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ICollection(KeyValuePair(TKey, TValue)).Remove Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ICollection<(Of <(KeyValuePair<(Of <(TKey, TValue>)>)>)>)..::.Remove Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ICollection<KeyValuePair<TKey, TValue>>.Remove(
    KeyValuePair<TKey, TValue> item
)
Visual Basic (Declaration)
Private Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean Implements ICollection(Of KeyValuePair(Of TKey, TValue)).Remove
Visual C++
private:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed = ICollection<KeyValuePair<TKey, TValue>>::Remove

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <( TKey, TValue >)>)

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#ICollection{T}#Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IDictionary(TKey, TValue).Remove Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IDictionary<(Of <(TKey, TValue>)>)..::.Remove Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Remove(`0)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IDictionary<TKey, TValue>.Remove(
    TKey key
)
Visual Basic (Declaration)
Private Function Remove ( _
    key As TKey _
) As Boolean Implements IDictionary(Of TKey, TValue).Remove
Visual C++
private:
virtual bool Remove(
    TKey key
) sealed = IDictionary<TKey, TValue>::Remove

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Remove(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Remove(`0)"]

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Remove(TKey)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Contains Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean
Visual C++
public:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <( TKey, TValue >)>)

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.ContainsKey(`0)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool ContainsKey(
    TKey key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
Visual C++
public:
virtual bool ContainsKey(
    TKey key
) sealed

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.ContainsKey(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.ContainsKey(`0)"]

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey(TKey)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


CopyTo Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.CopyTo Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair <(Of <( TKey, TValue >)>) >[]()[]

[Missing <param name="array"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

arrayIndex
Type: System..::.Int32

[Missing <param name="arrayIndex"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


GetEnumerator Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.GetEnumerator Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.GetEnumerator"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
Visual C++
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.GetEnumerator"]

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


TryGetValue Method

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.TryGetValue Method
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.TryGetValue(`0,`1@)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool TryGetValue(
    TKey key,
    out TValue value
)
Visual Basic (Declaration)
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean
Visual C++
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.TryGetValue(`0,`1@)"]

value
Type: TValue %

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.TryGetValue(`0,`1@)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.TryGetValue(`0,`1@)"]

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.TryGetValue(TKey, TValue%)

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


ReadOnlyDictionary(TKey, TValue) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Properties
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

The ReadOnlyDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Properties

Name | Description
Count |
IsReadOnly |
Item |
Keys |
Values |

Explicit Interface Implementations

Name | Description
IDictionary<(Of <(TKey, TValue>)>)..::.Item |

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IDictionary(TKey, TValue).Item Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IDictionary<(Of <(TKey, TValue>)>)..::.Item Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.System#Collections#Generic#IDictionary{TKey@TValue}#Item(`0)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
TValue IDictionary<TKey, TValue>.Item[
    TKey key
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    key As TKey _
) As TValue Implements IDictionary(Of TKey, TValue).Item
Visual C++
private:
virtual property TValue Item[TKey key] {
    TValue get (TKey key) sealed = IDictionary<TKey, TValue>::Item::get;
    void set (TKey key, TValue value) sealed = IDictionary<TKey, TValue>::Item::set;
}

Parameters

key
Type: TKey

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Item[([(TKey])])

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Count Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Count"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


IsReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.IsReadOnly Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.IsReadOnly"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Item Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Item(`0)"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public TValue this[
    TKey key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As TKey _
) As TValue
Visual C++
public:
property TValue default[TKey key] {
    TValue get (TKey key);
}

Parameters

key
Type: TKey

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Keys Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Keys Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Keys"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<TKey> Keys { get; }
Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of TKey)
Visual C++
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Keys

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Values Property

[image]

Enterprise SDK 8.0 Reference API
ReadOnlyDictionary<(Of <(TKey, TValue>)>)..::.Values Property
ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Common.ReadOnlyDictionary`2.Values"]

Namespace: Genesyslab.Enterprise.Model.Common
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ICollection<TValue> Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of TValue)
Visual C++
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Values

See Also

ReadOnlyDictionary<(Of <(TKey, TValue>)>) Class
Genesyslab.Enterprise.Model.Common Namespace


Genesyslab.Enterprise.Model.ComponentModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.ComponentModel Namespace
Send Feedback

Classes

Class | Description
BrokerManager<(Of <(T>)>) |
DualBrokerManager<(Of <(T>)>) |
Helper | Helper class for managing IMessage.
PredicatableWrapper<(Of <(T, S>)>) | IPredicatable wrapper.
SubscribeableWrapper<(Of <(T, S>)>) | ISubscribeable wrapper.

Interfaces

Interface | Description
IAttributeService | Interface for getting and setting attributes.
IBrokerFilter | Interface for managing Message Broker filters.
IBrokerManager | Interface for managing publisher/subscriber pattern.
IBrokerManager<(Of <(T>)>) | Interface for managing publisher/subscriber pattern.
IBrokerPublisher | Interface for managing event publisher to subscribers.
IBrokerSubscriber | Interface for managing event subscription.
IBrokerSubscriber<(Of <(T>)>) | Interface for managing event subscription.
ICapability | Interface for managing capability.
ICategoryManager | Interface for managing the categories of data bag.
IConfigurable | Interface for managing object from Configuration Layer.
IContext | Interface for managing context of instance.
IController | Interface for managing state machine controller pattern.
IDataBag<(Of <(T>)>) | Interface for managing data set.
IDelegateSubscriber<(Of <(T>)>) | Interface for managing Broker subscriber.
IDynamicAttribute | Interface for managing dynamic attributes.
IFilter | Interface for managing Filter for Broker Message.
IPersistable<(Of <(T>)>) | Interface for managing the persistency of objects.
IPredicatable<(Of <(T>)>) | Interface defines contract for using a predicate
IPublishable<(Of <(T>)>) | Interface for publishing typed events to subscribers.
IRequest | Interface for managing request that are sent.
IRequestManager | Interface for managing requests.
IRole | Role interface.
IRoleable | Classes that want to play role should implement this Role based interface
IRoleManager<(Of <(T>)>) | Interface for managing the roles.
IServiceSubscriber | interface defines subscriber contract for Publish/Subscribe pattern
IServiceSubscriber<(Of <(T>)>) | interface defines subscriber contract for Publish/Subscribe pattern
ISubscribeable<(Of <(T>)>) | Defines a subscriber contract for Publish/Subscribe pattern.
ITransformer<(Of <(TTarget, TSource>)>) | Objects transformer.

Enumerations

Enumeration | Description
ItemLocation | Enumerate for location of subscribers.
RoleProfileType | Enumerate the profile types for the Role instances.
StateType | Enumerate the state type of ICapability.
VisibilityType | Enumerates the visibility types for the Role instances.


BrokerManager(T) Class

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class BrokerManager<T> : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Class BrokerManager(Of T) _
    Implements IBrokerManager(Of T), IServiceSubscriber(Of T),  _
    IBrokerSubscriber(Of T), IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public ref class BrokerManager : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1"]

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.BrokerManager<(Of <(T>)>)

See Also

BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Members
BrokerManager<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The BrokerManager<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
BrokerManager<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) |
Register | Overloaded.
Subscriber |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

Properties

Name | Description
BrokerType |
Count |
EventSubscription |
Parent |

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Constructor
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
BrokerManager<(Of <(T>)>)(Object) |
BrokerManager<(Of <(T>)>)(Object, Type) |

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Constructor (Object)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Constructor (Object)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.#ctor(System.Object)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public BrokerManager(
    Object instance
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object _
)
Visual C++
public:
BrokerManager(
    Object^ instance
)

Parameters

instance
Type: System..::.Object

[Missing <param name="instance"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.#ctor(System.Object)"]

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Constructor (Object, Type)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Constructor (Object, Type)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.#ctor(System.Object,System.Type)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public BrokerManager(
    Object instance,
    Type brokerType
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object, _
    brokerType As Type _
)
Visual C++
public:
BrokerManager(
    Object^ instance,
    Type^ brokerType
)

Parameters

instance
Type: System..::.Object

[Missing <param name="instance"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.#ctor(System.Object,System.Type)"]

brokerType
Type: System..::.Type

[Missing <param name="brokerType"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.#ctor(System.Object,System.Type)"]

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Methods
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

The BrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) |
Register | Overloaded.
Subscriber |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Dispose Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Dispose"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.GetList Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) |
GetList(Type, ItemLocation) |

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
public:
generic<typename U>
virtual IEnumerable<U>^ GetList(
    ItemLocation flag
) sealed

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

BrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
public:
virtual IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
) sealed

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Implements

IBrokerManager<(Of <(T>)>)..::.GetList(Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

BrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Publish<(Of <(T>)>) Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Publish``1(``0)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Publish``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Publish``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Publish``1(``0)"]

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) |
Register(Action<(Of <(T>)>)) |
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) |

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Register(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(ISubscribeable<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(System.Action{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(System.Action{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
) sealed

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Subscriber Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Subscriber"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Public Function Subscriber As IServiceSubscriber(Of T)
Visual C++
public:
virtual IServiceSubscriber<T>^ Subscriber() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Subscriber"]

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Unregister Method
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) |
Unregister(Action<(Of <(T>)>)) |

See Also

BrokerManager<(Of <(T>)>) Class
BrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Unregister(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Unregister(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Unregister(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(ISubscribeable<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Unregister(System.Action{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Unregister(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Unregister(System.Action{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(Action<(Of <(T>)>))

See Also

BrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>) Properties
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

The BrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType |
Count |
EventSubscription |
Parent |

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.BrokerType Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.BrokerType"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Type BrokerType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BrokerType As Type
Visual C++
public:
virtual property Type^ BrokerType {
    Type^ get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.BrokerType

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Count Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Count"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Count
IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.EventSubscription Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.EventSubscription"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
Public ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
public:
virtual property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get () sealed;
}

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
BrokerManager<(Of <(T>)>)..::.Parent Property
BrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.BrokerManager`1.Parent"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object
Visual C++
public:
virtual property Object^ Parent {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Parent

See Also

BrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Class

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class DualBrokerManager<T> : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Class DualBrokerManager(Of T) _
    Implements IBrokerManager(Of T), IServiceSubscriber(Of T),  _
    IBrokerSubscriber(Of T), IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public ref class DualBrokerManager : IBrokerManager<T>,
    IServiceSubscriber<T>, IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1"]

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.DualBrokerManager<(Of <(T>)>)

See Also

DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Members
DualBrokerManager<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The DualBrokerManager<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
DualBrokerManager<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) |
Register | Overloaded.
Subscriber |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

Properties

Name | Description
BrokerType |
Count |
EventSubscription |
Parent |

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Constructor
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
DualBrokerManager<(Of <(T>)>)(Object) |
DualBrokerManager<(Of <(T>)>)(Object, Type) |

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Constructor (Object)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Constructor (Object)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.#ctor(System.Object)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DualBrokerManager(
    Object instance
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object _
)
Visual C++
public:
DualBrokerManager(
    Object^ instance
)

Parameters

instance
Type: System..::.Object

[Missing <param name="instance"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.#ctor(System.Object)"]

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Constructor (Object, Type)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Constructor (Object, Type)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.#ctor(System.Object,System.Type)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public DualBrokerManager(
    Object instance,
    Type brokerType
)
Visual Basic (Declaration)
Public Sub New ( _
    instance As Object, _
    brokerType As Type _
)
Visual C++
public:
DualBrokerManager(
    Object^ instance,
    Type^ brokerType
)

Parameters

instance
Type: System..::.Object

[Missing <param name="instance"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.#ctor(System.Object,System.Type)"]

brokerType
Type: System..::.Type

[Missing <param name="brokerType"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.#ctor(System.Object,System.Type)"]

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Methods
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

The DualBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) |
Register | Overloaded.
Subscriber |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unregister | Overloaded.

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Dispose Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Dispose"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.GetList Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) |
GetList(Type, ItemLocation) |

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
public:
generic<typename U>
virtual IEnumerable<U>^ GetList(
    ItemLocation flag
) sealed

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

DualBrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
public:
virtual IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
) sealed

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Implements

IBrokerManager<(Of <(T>)>)..::.GetList(Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

DualBrokerManager<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Publish<(Of <(T>)>) Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Publish``1(``0)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Publish``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Publish``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Publish``1(``0)"]

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) |
Register(Action<(Of <(T>)>)) |
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) |

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Register(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(ISubscribeable<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(System.Action{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(System.Action{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Public Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
public:
virtual void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
) sealed

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Register(System.Action{`0},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Subscriber Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Subscriber"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Public Function Subscriber As IServiceSubscriber(Of T)
Visual C++
public:
virtual IServiceSubscriber<T>^ Subscriber() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Subscriber"]

Implements

IBrokerManager<(Of <(T>)>)..::.Subscriber()()()

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Unregister Method
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) |
Unregister(Action<(Of <(T>)>)) |

See Also

DualBrokerManager<(Of <(T>)>) Class
DualBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Unregister(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
public:
virtual void Unregister(
    ISubscribeable<T>^ subscriber
) sealed

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Unregister(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(ISubscribeable<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Unregister(System.Action{`0})"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Public Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
public:
virtual void Unregister(
    Action<T>^ handler
) sealed

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Unregister(System.Action{`0})"]

Implements

IServiceSubscriber<(Of <(T>)>)..::.Unregister(Action<(Of <(T>)>))

See Also

DualBrokerManager<(Of <(T>)>) Class
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


DualBrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>) Properties
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

The DualBrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType |
Count |
EventSubscription |
Parent |

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.BrokerType Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.BrokerType"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Type BrokerType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BrokerType As Type
Visual C++
public:
virtual property Type^ BrokerType {
    Type^ get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.BrokerType

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Count Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Count"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Count
IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.EventSubscription Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.EventSubscription"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
Public ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
public:
virtual property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get () sealed;
}

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
DualBrokerManager<(Of <(T>)>)..::.Parent Property
DualBrokerManager<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.DualBrokerManager`1.Parent"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object
Visual C++
public:
virtual property Object^ Parent {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IBrokerManager<(Of <(T>)>)..::.Parent

See Also

DualBrokerManager<(Of <(T>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Helper Class

[image]

Enterprise SDK 8.0 Reference API
Helper Class
Members See Also Send Feedback
Helper class for managing IMessage.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class Helper
Visual Basic (Declaration)
Public NotInheritable Class Helper
Visual C++
public ref class Helper abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.Helper

See Also

Helper Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Helper Members

[image] [image]

Enterprise SDK 8.0 Reference API
Helper Members
Helper Class Methods See Also Send Feedback

The Helper type exposes the following members.

Methods

Name | Description
GetFilterCollection<(Of <(T>)>) | Return elements as a collection of a specific type from a dictionary
GetPropertyAsIntValue | Gets property from IMessage as integer.
GetPropertyAsLongValue | Gets property from IMessage as long.
GetPropertyAsObject | Gets property from IMessage as Object.
GetPropertyAsString | Gets property from IMessage as String.
GetReferenceId |
IsNameSpaceInternal | Check if a specific namespace and a given object are part of the same namespace We DO assume here that the namespace is at least two levels deep Eg. LeveL0.Level1. ... If not, we return always FALSE.
SetInfo | Adds in a IMessage request, a KeyValueCollection at key value.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Helper Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Helper Methods
Helper Class See Also Send Feedback

The Helper type exposes the following members.

Methods

Name | Description
GetFilterCollection<(Of <(T>)>) | Return elements as a collection of a specific type from a dictionary
GetPropertyAsIntValue | Gets property from IMessage as integer.
GetPropertyAsLongValue | Gets property from IMessage as long.
GetPropertyAsObject | Gets property from IMessage as Object.
GetPropertyAsString | Gets property from IMessage as String.
GetReferenceId |
IsNameSpaceInternal | Check if a specific namespace and a given object are part of the same namespace We DO assume here that the namespace is at least two levels deep Eg. LeveL0.Level1. ... If not, we return always FALSE.
SetInfo | Adds in a IMessage request, a KeyValueCollection at key value.

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetFilterCollection(T) Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetFilterCollection<(Of <(T>)>) Method
Helper Class See Also Send Feedback
Return elements as a collection of a specific type from a dictionary

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static ICollection<T> GetFilterCollection<T>(
    IDictionary<Type, Object> list
)
Visual Basic (Declaration)
Public Shared Function GetFilterCollection(Of T) ( _
    list As IDictionary(Of Type, Object) _
) As ICollection(Of T)
Visual C++
public:
generic<typename T>
static ICollection<T>^ GetFilterCollection(
    IDictionary<Type^, Object^>^ list
)

Parameters

list
Type: System.Collections.Generic..::.IDictionary <(Of <( Type, Object >)>)

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetFilterCollection``1(System.Collections.Generic.IDictionary{System.Type,System.Object})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetFilterCollection``1(System.Collections.Generic.IDictionary{System.Type,System.Object})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetFilterCollection``1(System.Collections.Generic.IDictionary{System.Type,System.Object})"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsIntValue Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsIntValue Method
Helper Class See Also Send Feedback
Gets property from IMessage as integer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static int GetPropertyAsIntValue(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsIntValue ( _
    attribute As String, _
    msg As IMessage _
) As Integer
Visual C++
public:
static int GetPropertyAsIntValue(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String

[Missing <param name="attribute"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsIntValue(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsIntValue(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsIntValue(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsLongValue Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsLongValue Method
Helper Class See Also Send Feedback
Gets property from IMessage as long.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static long GetPropertyAsLongValue(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsLongValue ( _
    attribute As String, _
    msg As IMessage _
) As Long
Visual C++
public:
static long long GetPropertyAsLongValue(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String

[Missing <param name="attribute"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsLongValue(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsLongValue(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsLongValue(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsObject Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsObject Method
Helper Class See Also Send Feedback
Gets property from IMessage as Object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static Object GetPropertyAsObject(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsObject ( _
    attribute As String, _
    msg As IMessage _
) As Object
Visual C++
public:
static Object^ GetPropertyAsObject(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String

[Missing <param name="attribute"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsObject(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsObject(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsObject(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetPropertyAsString Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetPropertyAsString Method
Helper Class See Also Send Feedback
Gets property from IMessage as String.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static string GetPropertyAsString(
    string attribute,
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetPropertyAsString ( _
    attribute As String, _
    msg As IMessage _
) As String
Visual C++
public:
static String^ GetPropertyAsString(
    String^ attribute,
    IMessage^ msg
)

Parameters

attribute
Type: System..::.String

[Missing <param name="attribute"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsString(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsString(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetPropertyAsString(System.String,Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetReferenceId Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.GetReferenceId Method
Helper Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetReferenceId(Genesyslab.Platform.Commons.Protocols.IMessage)"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static int GetReferenceId(
    IMessage msg
)
Visual Basic (Declaration)
Public Shared Function GetReferenceId ( _
    msg As IMessage _
) As Integer
Visual C++
public:
static int GetReferenceId(
    IMessage^ msg
)

Parameters

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetReferenceId(Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.GetReferenceId(Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsNameSpaceInternal Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.IsNameSpaceInternal Method
Helper Class See Also Send Feedback
Check if a specific namespace and a given object are part of the same namespace We DO assume here that the namespace is at least two levels deep Eg. LeveL0.Level1. ... If not, we return always FALSE.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static bool IsNameSpaceInternal(
    string targetNamespace,
    Object data
)
Visual Basic (Declaration)
Public Shared Function IsNameSpaceInternal ( _
    targetNamespace As String, _
    data As Object _
) As Boolean
Visual C++
public:
static bool IsNameSpaceInternal(
    String^ targetNamespace,
    Object^ data
)

Parameters

targetNamespace
Type: System..::.String
string
data
Type: System..::.Object
object

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.IsNameSpaceInternal(System.String,System.Object)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetInfo Method

[image]

Enterprise SDK 8.0 Reference API
Helper..::.SetInfo Method
Helper Class See Also Send Feedback
Adds in a IMessage request, a KeyValueCollection at key value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static IMessage SetInfo(
    IMessage request,
    string key,
    IDictionary info
)
Visual Basic (Declaration)
Public Shared Function SetInfo ( _
    request As IMessage, _
    key As String, _
    info As IDictionary _
) As IMessage
Visual C++
public:
static IMessage^ SetInfo(
    IMessage^ request,
    String^ key,
    IDictionary^ info
)

Parameters

request
Type: IMessage
the IMessage request
key
Type: System..::.String
the key index
info
Type: System.Collections..::.IDictionary
the dictionary to be changed into KeyValueCollection for the key

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.Helper.SetInfo(Genesyslab.Platform.Commons.Protocols.IMessage,System.String,System.Collections.IDictionary)"]

See Also

Helper Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Interface

[image]

Enterprise SDK 8.0 Reference API
IAttributeService Interface
Members See Also Send Feedback
Interface for getting and setting attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAttributeService
Visual Basic (Declaration)
Public Interface IAttributeService
Visual C++
public interface class IAttributeService

See Also

IAttributeService Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService Members
IAttributeService Interface Methods See Also Send Feedback

The IAttributeService type exposes the following members.

Methods

Name | Description
GetAttributes | Gets Attributes.
SetAttributes | Overloaded.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService Methods
IAttributeService Interface See Also Send Feedback

The IAttributeService type exposes the following members.

Methods

Name | Description
GetAttributes | Gets Attributes.
SetAttributes | Overloaded.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetAttributes Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.GetAttributes Method
IAttributeService Interface See Also Send Feedback
Gets Attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IDynamicAttribute> GetAttributes(
    string name
)
Visual Basic (Declaration)
Function GetAttributes ( _
    name As String _
) As IDictionary(Of String, IDynamicAttribute)
Visual C++
IDictionary<String^, IDynamicAttribute^>^ GetAttributes(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.GetAttributes(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.GetAttributes(System.String)"]

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method
IAttributeService Interface See Also Send Feedback

Overload List

Name | Description
SetAttributes(String, IDynamicAttribute) | Sets attributes from another IDynamicAttribute instance.
SetAttributes(String, IDictionary<(Of <(String, IDynamicAttribute>)>)) | Sets attributes from a dictionary instance.

See Also

IAttributeService Interface
IAttributeService Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method (String, IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method (String, IDynamicAttribute)
IAttributeService Interface See Also Send Feedback
Sets attributes from another IDynamicAttribute instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeService SetAttributes(
    string name,
    IDynamicAttribute attribute
)
Visual Basic (Declaration)
Function SetAttributes ( _
    name As String, _
    attribute As IDynamicAttribute _
) As IAttributeService
Visual C++
IAttributeService^ SetAttributes(
    String^ name,
    IDynamicAttribute^ attribute
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.SetAttributes(System.String,Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute)"]

attribute
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute

[Missing <param name="attribute"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.SetAttributes(System.String,Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.SetAttributes(System.String,Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute)"]

See Also

IAttributeService Interface
SetAttributes Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method (String, IDictionary(String, IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method (String, IDictionary<(Of <(String, IDynamicAttribute>)>))
IAttributeService Interface See Also Send Feedback
Sets attributes from a dictionary instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeService SetAttributes(
    string name,
    IDictionary<string, IDynamicAttribute> attributes
)
Visual Basic (Declaration)
Function SetAttributes ( _
    name As String, _
    attributes As IDictionary(Of String, IDynamicAttribute) _
) As IAttributeService
Visual C++
IAttributeService^ SetAttributes(
    String^ name,
    IDictionary<String^, IDynamicAttribute^>^ attributes
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.SetAttributes(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

attributes
Type: System.Collections.Generic..::.IDictionary <(Of <( String, IDynamicAttribute >)>)

[Missing <param name="attributes"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.SetAttributes(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IAttributeService.SetAttributes(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.ComponentModel.IDynamicAttribute})"]

See Also

IAttributeService Interface
SetAttributes Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Interface
Members See Also Send Feedback
Interface for managing Message Broker filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IBrokerFilter
Visual Basic (Declaration)
Public Interface IBrokerFilter
Visual C++
public interface class IBrokerFilter

See Also

IBrokerFilter Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Members
IBrokerFilter Interface Methods See Also Send Feedback

The IBrokerFilter type exposes the following members.

Methods

Name | Description
Filters<(Of <(T>)>) | Gets the Collection of Message Broker Filters.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Methods
IBrokerFilter Interface See Also Send Feedback

The IBrokerFilter type exposes the following members.

Methods

Name | Description
Filters<(Of <(T>)>) | Gets the Collection of Message Broker Filters.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filters(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerFilter..::.Filters<(Of <(T>)>) Method
IBrokerFilter Interface See Also Send Feedback
Gets the Collection of Message Broker Filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<T> Filters<T>()
Visual Basic (Declaration)
Function Filters(Of T) As ICollection(Of T)
Visual C++
generic<typename T>
ICollection<T>^ Filters()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerFilter.Filters``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerFilter.Filters``1"]

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager Interface
Members See Also Send Feedback
Interface for managing publisher/subscriber pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IBrokerManager : IServiceSubscriber,
    IBrokerSubscriber, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Interface IBrokerManager _
    Implements IServiceSubscriber, IBrokerSubscriber, IBrokerPublisher, IDisposable
Visual C++
public interface class IBrokerManager : IServiceSubscriber,
    IBrokerSubscriber, IBrokerPublisher, IDisposable

See Also

IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Members
IBrokerManager Interface Methods Properties See Also Send Feedback

The IBrokerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber<(Of <(T>)>) | Gets the subscription service.
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the (Inherited from IBrokerSubscriber.)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Methods
IBrokerManager Interface See Also Send Feedback

The IBrokerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber<(Of <(T>)>) | Gets the subscription service.
Unregister | Overloaded.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber.)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(T) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList<(Of <(T>)>) Method (ItemLocation)
IBrokerManager Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> GetList<T>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of T) ( _
    flag As ItemLocation _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

IBrokerManager Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList Method (Type, ItemLocation)
IBrokerManager Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Implements

IBrokerSubscriber..::.GetList(Type, ItemLocation)

See Also

IBrokerManager Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Register Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Register<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing (Inherited from IServiceSubscriber.)
Register<(Of <(T>)>)(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs (Inherited from IServiceSubscriber.)
Register<(Of <(T>)>)(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events (Inherited from IServiceSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Subscriber<(Of <(T>)>) Method
IBrokerManager Interface See Also Send Feedback
Gets the subscription service.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IServiceSubscriber Subscriber<T>()
Visual Basic (Declaration)
Function Subscriber(Of T) As IServiceSubscriber
Visual C++
generic<typename T>
IServiceSubscriber^ Subscriber()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.Subscriber``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.Subscriber``1"]

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Unregister Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Unregister<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities (Inherited from IServiceSubscriber.)
Unregister<(Of <(T>)>)(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events (Inherited from IServiceSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Properties
IBrokerManager Interface See Also Send Feedback

The IBrokerManager type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the (Inherited from IBrokerSubscriber.)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.BrokerType Property
IBrokerManager Interface See Also Send Feedback
Gets the type of broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Type BrokerType { get; }
Visual Basic (Declaration)
ReadOnly Property BrokerType As Type
Visual C++
property Type^ BrokerType {
    Type^ get ();
}

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Count Property
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Count | Gets the number of subscribers.
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Count Property
IBrokerManager Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

Implements

IBrokerSubscriber..::.Count

See Also

IBrokerManager Interface
Count Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Parent Property
IBrokerManager Interface See Also Send Feedback
Gets and sets the parent of the Broker Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing publisher/subscriber pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IBrokerManager<T> : IServiceSubscriber<T>,
    IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Interface IBrokerManager(Of T) _
    Implements IServiceSubscriber(Of T), IBrokerSubscriber(Of T),  _
    IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public interface class IBrokerManager : IServiceSubscriber<T>,
    IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1"]

See Also

IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Members
IBrokerManager<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber | Gets the subscription service.
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Methods
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber | Gets the subscription service.
Unregister | Overloaded.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
generic<typename U>
IEnumerable<U>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

IBrokerManager<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Implements

IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

IBrokerManager<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Register Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing (Inherited from IServiceSubscriber<(Of <(T>)>).)
Register(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs (Inherited from IServiceSubscriber<(Of <(T>)>).)
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Subscriber Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the subscription service.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Function Subscriber As IServiceSubscriber(Of T)
Visual C++
IServiceSubscriber<T>^ Subscriber()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1.Subscriber"]

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Unregister Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities (Inherited from IServiceSubscriber<(Of <(T>)>).)
Unregister(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Properties
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.BrokerType Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the type of broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Type BrokerType { get; }
Visual Basic (Declaration)
ReadOnly Property BrokerType As Type
Visual C++
property Type^ BrokerType {
    Type^ get ();
}

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Count Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Count | Gets the number of subscribers.
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Count Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

IBrokerManager<(Of <(T>)>) Interface
Count Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Parent Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets and sets the parent of the Broker Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Interface
Members See Also Send Feedback
Interface for managing event publisher to subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IBrokerPublisher
Visual Basic (Declaration)
Public Interface IBrokerPublisher
Visual C++
public interface class IBrokerPublisher

See Also

IBrokerPublisher Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Members
IBrokerPublisher Interface Methods See Also Send Feedback

The IBrokerPublisher type exposes the following members.

Methods

Name | Description
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Methods
IBrokerPublisher Interface See Also Send Feedback

The IBrokerPublisher type exposes the following members.

Methods

Name | Description
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher..::.Publish<(Of <(T>)>) Method
IBrokerPublisher Interface See Also Send Feedback
Publishes an object to listening subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
generic<typename T>
IBrokerPublisher^ Publish(
    T obj
)

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerPublisher.Publish``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerPublisher.Publish``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerPublisher.Publish``1(``0)"]

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Interface
Members See Also Send Feedback
Interface for managing event subscription.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IBrokerSubscriber
Visual Basic (Declaration)
Public Interface IBrokerSubscriber
Visual C++
public interface class IBrokerSubscriber

See Also

IBrokerSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Members
IBrokerSubscriber Interface Methods Properties See Also Send Feedback

The IBrokerSubscriber type exposes the following members.

Methods

Name | Description
GetList | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Methods
IBrokerSubscriber Interface See Also Send Feedback

Methods

Name | Description
GetList | Overloaded.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList Method
IBrokerSubscriber Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.

See Also

IBrokerSubscriber Interface
IBrokerSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(T) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList<(Of <(T>)>) Method (ItemLocation)
IBrokerSubscriber Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> GetList<T>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of T) ( _
    flag As ItemLocation _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

IBrokerSubscriber Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList Method (Type, ItemLocation)
IBrokerSubscriber Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

IBrokerSubscriber Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Properties
IBrokerSubscriber Interface See Also Send Feedback

The IBrokerSubscriber type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.Count Property
IBrokerSubscriber Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.EventSubscription Property
IBrokerSubscriber Interface See Also Send Feedback
Gets the

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IServiceSubscriber EventSubscription { get; }
Visual Basic (Declaration)
ReadOnly Property EventSubscription As IServiceSubscriber
Visual C++
property IServiceSubscriber^ EventSubscription {
    IServiceSubscriber^ get ();
}

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing event subscription.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IBrokerSubscriber<T>
Visual Basic (Declaration)
Public Interface IBrokerSubscriber(Of T)
Visual C++
generic<typename T>
public interface class IBrokerSubscriber

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1"]

See Also

IBrokerSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Members
IBrokerSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IBrokerSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetList | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Methods
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
GetList | Overloaded.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList Method
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
IBrokerSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
generic<typename U>
IEnumerable<U>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Properties
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.Count Property
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.EventSubscription Property
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get ();
}

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Interface

[image]

Enterprise SDK 8.0 Reference API
ICapability Interface
Members See Also Send Feedback
Interface for managing capability.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICapability
Visual Basic (Declaration)
Public Interface ICapability
Visual C++
public interface class ICapability

See Also

ICapability Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICapability Members
ICapability Interface Properties See Also Send Feedback

The ICapability type exposes the following members.

Properties

Name | Description
Description | Get capability description
Name | Get capability name
State | Get or set capability state : Inactive, , Disabled or Enabled
Value | Get or set task value (task is ON or OFF)

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICapability Properties
ICapability Interface See Also Send Feedback

The ICapability type exposes the following members.

Properties

Name | Description
Description | Get capability description
Name | Get capability name
State | Get or set capability state : Inactive, , Disabled or Enabled
Value | Get or set task value (task is ON or OFF)

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Description Property
ICapability Interface See Also Send Feedback
Get capability description

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Name Property
ICapability Interface See Also Send Feedback
Get capability name

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.State Property
ICapability Interface See Also Send Feedback
Get or set capability state : Inactive, , Disabled or Enabled

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
StateType State { get; set; }
Visual Basic (Declaration)
Property State As StateType
Visual C++
property StateType State {
    StateType get ();
    void set (StateType value);
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Value Property
ICapability Interface See Also Send Feedback
Get or set task value (task is ON or OFF)

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Value { get; set; }
Visual Basic (Declaration)
Property Value As Boolean
Visual C++
property bool Value {
    bool get ();
    void set (bool value);
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Interface

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager Interface
Members See Also Send Feedback
Interface for managing the categories of data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICategoryManager
Visual Basic (Declaration)
Public Interface ICategoryManager
Visual C++
public interface class ICategoryManager

See Also

ICategoryManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Members
ICategoryManager Interface Methods Properties See Also Send Feedback

The ICategoryManager type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag.
RemoveCategory | Removes a category in a data bag.

Properties

Name | Description
ListCategories | Gets the list of categories in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Methods
ICategoryManager Interface See Also Send Feedback

The ICategoryManager type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag.
RemoveCategory | Removes a category in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


CreateCategory Method

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.CreateCategory Method
ICategoryManager Interface See Also Send Feedback
Creates a category in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool CreateCategory(
    string key,
    string category
)
Visual Basic (Declaration)
Function CreateCategory ( _
    key As String, _
    category As String _
) As Boolean
Visual C++
bool CreateCategory(
    String^ key,
    String^ category
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.ICategoryManager.CreateCategory(System.String,System.String)"]

category
Type: System..::.String

[Missing <param name="category"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.ICategoryManager.CreateCategory(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.ICategoryManager.CreateCategory(System.String,System.String)"]

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RemoveCategory Method

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.RemoveCategory Method
ICategoryManager Interface See Also Send Feedback
Removes a category in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool RemoveCategory(
    string key
)
Visual Basic (Declaration)
Function RemoveCategory ( _
    key As String _
) As Boolean
Visual C++
bool RemoveCategory(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.ICategoryManager.RemoveCategory(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.ICategoryManager.RemoveCategory(System.String)"]

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Properties
ICategoryManager Interface See Also Send Feedback

The ICategoryManager type exposes the following members.

Properties

Name | Description
ListCategories | Gets the list of categories in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListCategories Property

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.ListCategories Property
ICategoryManager Interface See Also Send Feedback
Gets the list of categories in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable ListCategories { get; }
Visual Basic (Declaration)
ReadOnly Property ListCategories As IEnumerable
Visual C++
property IEnumerable^ ListCategories {
    IEnumerable^ get ();
}

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IConfigurable Interface

[image]

Enterprise SDK 8.0 Reference API
IConfigurable Interface
Members See Also Send Feedback
Interface for managing object from Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfigurable
Visual Basic (Declaration)
Public Interface IConfigurable
Visual C++
public interface class IConfigurable

See Also

IConfigurable Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IConfigurable Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurable Members
IConfigurable Interface Methods See Also Send Feedback

The IConfigurable type exposes the following members.

Methods

Name Description
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.

See Also

IConfigurable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IConfigurable Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurable Methods
IConfigurable Interface See Also Send Feedback

The IConfigurable type exposes the following members.

Methods

Name Description
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.

See Also

IConfigurable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Exists Method

[image]

Enterprise SDK 8.0 Reference API
IConfigurable..::.Exists Method
IConfigurable Interface See Also Send Feedback
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Exists()
Visual Basic (Declaration)
Function Exists As Boolean
Visual C++
bool Exists()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IConfigurable.Exists"]

See Also

IConfigurable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Interface

[image]

Enterprise SDK 8.0 Reference API
IContext Interface
Members See Also Send Feedback
Interface for managing context of instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IContext
Visual Basic (Declaration)
Public Interface IContext
Visual C++
public interface class IContext

See Also

IContext Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContext Members
IContext Interface Properties See Also Send Feedback

The IContext type exposes the following members.

Properties

Name | Description
Description | Gets and sets the description of the context.
Name | Gets and sets the name of the context.

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContext Properties
IContext Interface See Also Send Feedback

The IContext type exposes the following members.

Properties

Name | Description
Description | Gets and sets the description of the context.
Name | Gets and sets the name of the context.

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Description Property
IContext Interface See Also Send Feedback
Gets and sets the description of the context.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Name Property
IContext Interface See Also Send Feedback
Gets and sets the name of the context.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Interface

[image]

Enterprise SDK 8.0 Reference API
IController Interface
Members See Also Send Feedback
Interface for managing state machine controller pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IController
Visual Basic (Declaration)
Public Interface IController
Visual C++
public interface class IController

See Also

IController Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Members

[image] [image]

Enterprise SDK 8.0 Reference API
IController Members
IController Interface Methods Properties See Also Send Feedback

The IController type exposes the following members.

Methods

Name | Description
HandleEvent | Calls the state machine with an event transition for changing the state.

Properties

Name | Description
State | Gets the state machine of this controller.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IController Methods
IController Interface See Also Send Feedback

The IController type exposes the following members.

Methods

Name | Description
HandleEvent | Calls the state machine with an event transition for changing the state.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


HandleEvent Method

[image]

Enterprise SDK 8.0 Reference API
IController..::.HandleEvent Method
IController Interface See Also Send Feedback
Calls the state machine with an event transition for changing the state.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ControllerResponse HandleEvent(
    string eventName
)
Visual Basic (Declaration)
Function HandleEvent ( _
    eventName As String _
) As ControllerResponse
Visual C++
ControllerResponse HandleEvent(
    String^ eventName
)

Parameters

eventName
Type: System..::.String

[Missing <param name="eventName"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IController.HandleEvent(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IController.HandleEvent(System.String)"]

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IController Properties
IController Interface See Also Send Feedback

The IController type exposes the following members.

Properties

Name | Description
State | Gets the state machine of this controller.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IController..::.State Property
IController Interface See Also Send Feedback
Gets the state machine of this controller.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IStateMachineState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As IStateMachineState
Visual C++
property IStateMachineState^ State {
    IStateMachineState^ get ();
}

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing data set.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDataBag<T> : ICategoryManager
Visual Basic (Declaration)
Public Interface IDataBag(Of T) _
    Implements ICategoryManager
Visual C++
generic<typename T>
public interface class IDataBag : ICategoryManager

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IDataBag`1"]

See Also

IDataBag<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Members
IDataBag<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag. (Inherited from ICategoryManager.)
RemoveCategory | Removes a category in a data bag. (Inherited from ICategoryManager.)

Properties

Name | Description
Item | Gets or Sets the value for a section.
ListCategories | Gets the list of categories in a data bag. (Inherited from ICategoryManager.)
ListSections | Gets the list of section of this data bag.
Owner | Gets the owner instance (any instance of any class) of this data.

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Methods
IDataBag<(Of <(T>)>) Interface See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag. (Inherited from ICategoryManager.)
RemoveCategory | Removes a category in a data bag. (Inherited from ICategoryManager.)

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Properties
IDataBag<(Of <(T>)>) Interface See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Item | Gets or Sets the value for a section.
ListCategories | Gets the list of categories in a data bag. (Inherited from ICategoryManager.)
ListSections | Gets the list of section of this data bag.
Owner | Gets the owner instance (any instance of any class) of this data.

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.Item Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets or Sets the value for a section.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T this[
    string section
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    section As String _
) As T
Visual C++
property T default[String^ section] {
    T get (String^ section);
    void set (String^ section, T value);
}

Parameters

section
Type: System..::.String

Return Value

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListSections Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.ListSections Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of section of this data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string[] ListSections { get; }
Visual Basic (Declaration)
ReadOnly Property ListSections As String()
Visual C++
property array<String^>^ ListSections {
    array<String^>^ get ();
}

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.Owner Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets the owner instance (any instance of any class) of this data.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As Object
Visual C++
property Object^ Owner {
    Object^ get ();
}

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing Broker subscriber.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDelegateSubscriber<T> : ISubscriber<T>
Visual Basic (Declaration)
Public Interface IDelegateSubscriber(Of T) _
    Implements ISubscriber(Of T)
Visual C++
generic<typename T>
public interface class IDelegateSubscriber : ISubscriber<T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IDelegateSubscriber`1"]

See Also

IDelegateSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Members
IDelegateSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | (Inherited from ISubscriber<(Of <( T >)>).)

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( T >)>).)
Handler | Gets the handler that manages event.

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Methods
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | (Inherited from ISubscriber<(Of <( T >)>).)

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Properties
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( T >)>).)
Handler | Gets the handler that manages event.

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handler Property

[image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>)..::.Handler Property
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the handler that manages event.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Action<T> Handler { get; }
Visual Basic (Declaration)
ReadOnly Property Handler As Action(Of T)
Visual C++
property Action<T>^ Handler {
    Action<T>^ get ();
}

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Interface

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Interface
Members See Also Send Feedback
Interface for managing dynamic attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDynamicAttribute
Visual Basic (Declaration)
Public Interface IDynamicAttribute
Visual C++
public interface class IDynamicAttribute

See Also

IDynamicAttribute Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Members
IDynamicAttribute Interface Properties See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets the content type of the value.
ContentTypeVersion | Gets or set the content type version.
ExpiresAt | Gets or sets the expire date of the attribute validity.
Key | Gets the key value of the attribute.
ReadOnly | Gets or sets the read-only flag on the attribute.
Value | Gets or vets the value of the attribute.

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Properties
IDynamicAttribute Interface See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets the content type of the value.
ContentTypeVersion | Gets or set the content type version.
ExpiresAt | Gets or sets the expire date of the attribute validity.
Key | Gets the key value of the attribute.
ReadOnly | Gets or sets the read-only flag on the attribute.
Value | Gets or vets the value of the attribute.

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContentType Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ContentType Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the content type of the value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ContentType { get; set; }
Visual Basic (Declaration)
Property ContentType As String
Visual C++
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContentTypeVersion Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ContentTypeVersion Property
IDynamicAttribute Interface See Also Send Feedback
Gets or set the content type version.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ContentTypeVersion { get; set; }
Visual Basic (Declaration)
Property ContentTypeVersion As String
Visual C++
property String^ ContentTypeVersion {
    String^ get ();
    void set (String^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ExpiresAt Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ExpiresAt Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the expire date of the attribute validity.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
long ExpiresAt { get; set; }
Visual Basic (Declaration)
Property ExpiresAt As Long
Visual C++
property long long ExpiresAt {
    long long get ();
    void set (long long value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Key Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.Key Property
IDynamicAttribute Interface See Also Send Feedback
Gets the key value of the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Key { get; }
Visual Basic (Declaration)
ReadOnly Property Key As String
Visual C++
property String^ Key {
    String^ get ();
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ReadOnly Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the read-only flag on the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ReadOnly { get; set; }
Visual Basic (Declaration)
Property ReadOnly As Boolean
Visual C++
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.Value Property
IDynamicAttribute Interface See Also Send Feedback
Gets or vets the value of the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Value { get; set; }
Visual Basic (Declaration)
Property Value As Object
Visual C++
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Interface

[image]

Enterprise SDK 8.0 Reference API
IFilter Interface
Members See Also Send Feedback
Interface for managing Filter for Broker Message.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IFilter
Visual Basic (Declaration)
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Members
IFilter Interface Methods Properties See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
GetFilters | Gets the filters.

Properties

Name | Description
Key | Gets the key of the filter.
Target | Gets the target type on which filter is applied.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
GetFilters | Gets the filters.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetFilters Method

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.GetFilters Method
IFilter Interface See Also Send Feedback
Gets the filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object GetFilters()
Visual Basic (Declaration)
Function GetFilters As Object
Visual C++
Object^ GetFilters()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IFilter.GetFilters"]

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Properties
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Properties

Name | Description
Key | Gets the key of the filter.
Target | Gets the target type on which filter is applied.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Key Property

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.Key Property
IFilter Interface See Also Send Feedback
Gets the key of the filter.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Key { get; }
Visual Basic (Declaration)
ReadOnly Property Key As String
Visual C++
property String^ Key {
    String^ get ();
}

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.Target Property
IFilter Interface See Also Send Feedback
Gets the target type on which filter is applied.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Type Target { get; }
Visual Basic (Declaration)
ReadOnly Property Target As Type
Visual C++
property Type^ Target {
    Type^ get ();
}

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the persistency of objects.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPersistable<T>
Visual Basic (Declaration)
Public Interface IPersistable(Of T)
Visual C++
generic<typename T>
public interface class IPersistable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1"]

See Also

IPersistable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Members
IPersistable<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
IsDirty |
Save | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Methods
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
IsDirty |
Save | Overloaded.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsDirty Method

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.IsDirty Method
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.IsDirty"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsDirty()
Visual Basic (Declaration)
Function IsDirty As Boolean
Visual C++
bool IsDirty()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.IsDirty"]

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server.
Save(T, IStrategy) | Save data by executing the specified strategy

See Also

IPersistable<(Of <(T>)>) Interface
IPersistable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method (T)

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method (T)
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Saves the object into the Contact Server.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Save(
    T data
)
Visual Basic (Declaration)
Function Save ( _
    data As T _
) As Boolean
Visual C++
bool Save(
    T data
)

Parameters

data
Type: T

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0)"]

See Also

IPersistable<(Of <(T>)>) Interface
Save Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method (T, )

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method (T, )
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Save data by executing the specified strategy

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Save(
    T data,
    IStrategy strategy
)
Visual Basic (Declaration)
Function Save ( _
    data As T, _
    strategy As IStrategy _
) As Boolean
Visual C++
bool Save(
    T data,
    IStrategy^ strategy
)

Parameters

data
Type: T

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

IPersistable<(Of <(T>)>) Interface
Save Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Properties
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContactServerId Property

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.ContactServerId Property
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ContactServerId { get; }
Visual Basic (Declaration)
ReadOnly Property ContactServerId As String
Visual C++
property String^ ContactServerId {
    String^ get ();
}

Return Value

string

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface defines contract for using a predicate

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPredicatable<T>
Visual Basic (Declaration)
Public Interface IPredicatable(Of T)
Visual C++
generic<typename T>
public interface class IPredicatable

Type Parameters

T
Type of data

See Also

IPredicatable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Members
IPredicatable<(Of <(T>)>) Interface Methods See Also Send Feedback

The IPredicatable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Invoke | Object to be used for checking the predicate condition

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Methods
IPredicatable<(Of <(T>)>) Interface See Also Send Feedback

The IPredicatable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Invoke | Object to be used for checking the predicate condition

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>)..::.Invoke Method
IPredicatable<(Of <(T>)>) Interface See Also Send Feedback
Object to be used for checking the predicate condition

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Invoke(
    T obj
)
Visual Basic (Declaration)
Function Invoke ( _
    obj As T _
) As Boolean
Visual C++
bool Invoke(
    T obj
)

Parameters

obj
Type: T
Represents the truth or false of the predicate's condition

Return Value

bool

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for publishing typed events to subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPublishable<T>
Visual Basic (Declaration)
Public Interface IPublishable(Of T)
Visual C++
generic<typename T>
public interface class IPublishable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IPublishable`1"]

See Also

IPublishable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Members
IPublishable<(Of <(T>)>) Interface Methods See Also Send Feedback

The IPublishable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Publish | Publishes an event to listening subscribers.

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Methods
IPublishable<(Of <(T>)>) Interface See Also Send Feedback

The IPublishable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Publish | Publishes an event to listening subscribers.

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish Method

[image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>)..::.Publish Method
IPublishable<(Of <(T>)>) Interface See Also Send Feedback
Publishes an event to listening subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IPublishable<T> Publish(
    T obj
)
Visual Basic (Declaration)
Function Publish ( _
    obj As T _
) As IPublishable(Of T)
Visual C++
IPublishable<T>^ Publish(
    T obj
)

Parameters

obj
Type: T
Object to publish

Return Value

IPublishable

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Interface

[image]

Enterprise SDK 8.0 Reference API
IRequest Interface
Members See Also Send Feedback
Interface for managing request that are sent.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IRequest : ISerializable
Visual Basic (Declaration)
Public Interface IRequest _
    Implements ISerializable
Visual C++
public interface class IRequest : ISerializable

See Also

IRequest Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Members
IRequest Interface Methods Properties See Also Send Feedback

The IRequest type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
Endpoint | Gets the request End-point.
ExpiresAt | Gets or sets the expire date of the request.
IsOriginating | Gets or sets the originating value.
Msg | Gets the IMessage that is sent.
ParentRequestId | Gets the parent request identifier.
RequestId | Gets the unique request identifier.
RequestResult | Gets or sets the request result value.
SourceName | Gets the source name.
SourceUid | Gets the source unique identifier.
TimeStampCreation | Gets the time stamp of request creation.
TimeStampRcv | Gets or sets the time stamp of request return.
TimeStampTx | Gets or sets the time stamp of request transmit.

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Methods
IRequest Interface See Also Send Feedback

The IRequest type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Properties
IRequest Interface See Also Send Feedback

The IRequest type exposes the following members.

Properties

Name | Description
Endpoint | Gets the request End-point.
ExpiresAt | Gets or sets the expire date of the request.
IsOriginating | Gets or sets the originating value.
Msg | Gets the IMessage that is sent.
ParentRequestId | Gets the parent request identifier.
RequestId | Gets the unique request identifier.
RequestResult | Gets or sets the request result value.
SourceName | Gets the source name.
SourceUid | Gets the source unique identifier.
TimeStampCreation | Gets the time stamp of request creation.
TimeStampRcv | Gets or sets the time stamp of request return.
TimeStampTx | Gets or sets the time stamp of request transmit.

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Endpoint Property
IRequest Interface See Also Send Feedback
Gets the request End-point.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Uri Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Uri
Visual C++
property Uri^ Endpoint {
    Uri^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ExpiresAt Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.ExpiresAt Property
IRequest Interface See Also Send Feedback
Gets or sets the expire date of the request.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
long ExpiresAt { get; }
Visual Basic (Declaration)
ReadOnly Property ExpiresAt As Long
Visual C++
property long long ExpiresAt {
    long long get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsOriginating Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.IsOriginating Property
IRequest Interface See Also Send Feedback
Gets or sets the originating value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsOriginating { get; set; }
Visual Basic (Declaration)
Property IsOriginating As Boolean
Visual C++
property bool IsOriginating {
    bool get ();
    void set (bool value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Msg Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Msg Property
IRequest Interface See Also Send Feedback
Gets the IMessage that is sent.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IMessage Msg { get; }
Visual Basic (Declaration)
ReadOnly Property Msg As IMessage
Visual C++
property IMessage^ Msg {
    IMessage^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ParentRequestId Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.ParentRequestId Property
IRequest Interface See Also Send Feedback
Gets the parent request identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int ParentRequestId { get; }
Visual Basic (Declaration)
ReadOnly Property ParentRequestId As Integer
Visual C++
property int ParentRequestId {
    int get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RequestId Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.RequestId Property
IRequest Interface See Also Send Feedback
Gets the unique request identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int RequestId { get; }
Visual Basic (Declaration)
ReadOnly Property RequestId As Integer
Visual C++
property int RequestId {
    int get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RequestResult Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.RequestResult Property
IRequest Interface See Also Send Feedback
Gets or sets the request result value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool RequestResult { get; set; }
Visual Basic (Declaration)
Property RequestResult As Boolean
Visual C++
property bool RequestResult {
    bool get ();
    void set (bool value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SourceName Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.SourceName Property
IRequest Interface See Also Send Feedback
Gets the source name.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string SourceName { get; }
Visual Basic (Declaration)
ReadOnly Property SourceName As String
Visual C++
property String^ SourceName {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SourceUid Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.SourceUid Property
IRequest Interface See Also Send Feedback
Gets the source unique identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string SourceUid { get; }
Visual Basic (Declaration)
ReadOnly Property SourceUid As String
Visual C++
property String^ SourceUid {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampCreation Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampCreation Property
IRequest Interface See Also Send Feedback
Gets the time stamp of request creation.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
long TimeStampCreation { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStampCreation As Long
Visual C++
property long long TimeStampCreation {
    long long get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampRcv Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampRcv Property
IRequest Interface See Also Send Feedback
Gets or sets the time stamp of request return.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
long TimeStampRcv { get; set; }
Visual Basic (Declaration)
Property TimeStampRcv As Long
Visual C++
property long long TimeStampRcv {
    long long get ();
    void set (long long value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampTx Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampTx Property
IRequest Interface See Also Send Feedback
Gets or sets the time stamp of request transmit.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
long TimeStampTx { get; set; }
Visual Basic (Declaration)
Property TimeStampTx As Long
Visual C++
property long long TimeStampTx {
    long long get ();
    void set (long long value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Interface

[image]

Enterprise SDK 8.0 Reference API
IRequestManager Interface
Members See Also Send Feedback
Interface for managing requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IRequestManager
Visual Basic (Declaration)
Public Interface IRequestManager
Visual C++
public interface class IRequestManager

See Also

IRequestManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Members
IRequestManager Interface Methods Properties See Also Send Feedback

The IRequestManager type exposes the following members.

Methods

Name | Description
Count | Gets the number of requests.
DeleteRequestById | Delete a single request
GetInitialRequest | Gets the request by its initial request.
GetRequestByDevice | Gets the list of requests by device identifier.
GetRequestById | Gets the request by its identifier.
GetRequestByMsg | Gets the request by its IMessage.
GetRequestBySourceUid | Gets the list of requests by source unique identifier.
ListRequests | Gets the list of requests.

Properties

Name | Description
Parent | Gets the parent object.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Methods
IRequestManager Interface See Also Send Feedback

The IRequestManager type exposes the following members.

Methods

Name | Description
Count | Gets the number of requests.
DeleteRequestById | Delete a single request
GetInitialRequest | Gets the request by its initial request.
GetRequestByDevice | Gets the list of requests by device identifier.
GetRequestById | Gets the request by its identifier.
GetRequestByMsg | Gets the request by its IMessage.
GetRequestBySourceUid | Gets the list of requests by source unique identifier.
ListRequests | Gets the list of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.Count Method
IRequestManager Interface See Also Send Feedback
Gets the number of requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Count()
Visual Basic (Declaration)
Function Count As Integer
Visual C++
int Count()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.Count"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


DeleteRequestById Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.DeleteRequestById Method
IRequestManager Interface See Also Send Feedback
Delete a single request

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool DeleteRequestById(
    int id
)
Visual Basic (Declaration)
Function DeleteRequestById ( _
    id As Integer _
) As Boolean
Visual C++
bool DeleteRequestById(
    int id
)

Parameters

id
Type: System..::.Int32
Request Id

Return Value

bool

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetInitialRequest Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetInitialRequest Method
IRequestManager Interface See Also Send Feedback
Gets the request by its initial request.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequest GetInitialRequest(
    IRequest request
)
Visual Basic (Declaration)
Function GetInitialRequest ( _
    request As IRequest _
) As IRequest
Visual C++
IRequest^ GetInitialRequest(
    IRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRequest

[Missing <param name="request"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetInitialRequest(Genesyslab.Enterprise.Model.ComponentModel.IRequest)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetInitialRequest(Genesyslab.Enterprise.Model.ComponentModel.IRequest)"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestByDevice Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestByDevice Method
IRequestManager Interface See Also Send Feedback
Gets the list of requests by device identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequest[] GetRequestByDevice(
    string id
)
Visual Basic (Declaration)
Function GetRequestByDevice ( _
    id As String _
) As IRequest()
Visual C++
array<IRequest^>^ GetRequestByDevice(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestByDevice(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestByDevice(System.String)"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestById Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestById Method
IRequestManager Interface See Also Send Feedback
Gets the request by its identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequest GetRequestById(
    int id
)
Visual Basic (Declaration)
Function GetRequestById ( _
    id As Integer _
) As IRequest
Visual C++
IRequest^ GetRequestById(
    int id
)

Parameters

id
Type: System..::.Int32

[Missing <param name="id"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestById(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestById(System.Int32)"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestByMsg Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestByMsg Method
IRequestManager Interface See Also Send Feedback
Gets the request by its IMessage.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequest GetRequestByMsg(
    IMessage msg
)
Visual Basic (Declaration)
Function GetRequestByMsg ( _
    msg As IMessage _
) As IRequest
Visual C++
IRequest^ GetRequestByMsg(
    IMessage^ msg
)

Parameters

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestByMsg(Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestByMsg(Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestBySourceUid Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestBySourceUid Method
IRequestManager Interface See Also Send Feedback
Gets the list of requests by source unique identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequest[] GetRequestBySourceUid(
    string id
)
Visual Basic (Declaration)
Function GetRequestBySourceUid ( _
    id As String _
) As IRequest()
Visual C++
array<IRequest^>^ GetRequestBySourceUid(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestBySourceUid(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.GetRequestBySourceUid(System.String)"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRequests Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.ListRequests Method
IRequestManager Interface See Also Send Feedback
Gets the list of requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRequest[] ListRequests()
Visual Basic (Declaration)
Function ListRequests As IRequest()
Visual C++
array<IRequest^>^ ListRequests()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRequestManager.ListRequests"]

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Properties
IRequestManager Interface See Also Send Feedback

The IRequestManager type exposes the following members.

Properties

Name | Description
Parent | Gets the parent object.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.Parent Property
IRequestManager Interface See Also Send Feedback
Gets the parent object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Parent { get; }
Visual Basic (Declaration)
ReadOnly Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
}

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Interface

[image]

Enterprise SDK 8.0 Reference API
IRole Interface
Members See Also Send Feedback
Role interface.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IRole
Visual Basic (Declaration)
Public Interface IRole
Visual C++
public interface class IRole

See Also

IRole Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRole Members
IRole Interface Properties See Also Send Feedback

The IRole type exposes the following members.

Properties

Name | Description
Capabilities | Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.
Description | Role description.
Name | Role name.
Parameters | Returns the parameters associated with the role.
RoleProfile | Role profile: custom or system.
Visibility | Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRole Properties
IRole Interface See Also Send Feedback

The IRole type exposes the following members.

Properties

Name | Description
Capabilities | Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.
Description | Role description.
Name | Role name.
Parameters | Returns the parameters associated with the role.
RoleProfile | Role profile: custom or system.
Visibility | Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Capabilities Property
IRole Interface See Also Send Feedback
Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Description Property
IRole Interface See Also Send Feedback
Role description.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Name Property
IRole Interface See Also Send Feedback
Role name.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parameters Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Parameters Property
IRole Interface See Also Send Feedback
Returns the parameters associated with the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object[] Parameters { get; }
Visual Basic (Declaration)
ReadOnly Property Parameters As Object()
Visual C++
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RoleProfile Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.RoleProfile Property
IRole Interface See Also Send Feedback
Role profile: custom or system.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
RoleProfileType RoleProfile { get; }
Visual Basic (Declaration)
ReadOnly Property RoleProfile As RoleProfileType
Visual C++
property RoleProfileType RoleProfile {
    RoleProfileType get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Visibility Property
IRole Interface See Also Send Feedback
Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
VisibilityType Visibility { get; set; }
Visual Basic (Declaration)
Property Visibility As VisibilityType
Visual C++
property VisibilityType Visibility {
    VisibilityType get ();
    void set (VisibilityType value);
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Interface

[image]

Enterprise SDK 8.0 Reference API
IRoleable Interface
Members See Also Send Feedback
Classes that want to play role should implement this Role based interface

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IRoleable
Visual Basic (Declaration)
Public Interface IRoleable
Visual C++
public interface class IRoleable

See Also

IRoleable Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleable Members
IRoleable Interface Properties See Also Send Feedback

The IRoleable type exposes the following members.

Properties

Name | Description
Role | Gets or sets the role of an object.

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleable Properties
IRoleable Interface See Also Send Feedback

The IRoleable type exposes the following members.

Properties

Name | Description
Role | Gets or sets the role of an object.

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Role Property

[image]

Enterprise SDK 8.0 Reference API
IRoleable..::.Role Property
IRoleable Interface See Also Send Feedback
Gets or sets the role of an object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRole Role { get; set; }
Visual Basic (Declaration)
Property Role As IRole
Visual C++
property IRole^ Role {
    IRole^ get ();
    void set (IRole^ value);
}

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the roles.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IRoleManager<T>
where T : IRoleable
Visual Basic (Declaration)
Public Interface IRoleManager(Of T As IRoleable)
Visual C++
generic<typename T>
where T : IRoleable
public interface class IRoleManager

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1"]

See Also

IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Members
IRoleManager<(Of <(T>)>) Interface Methods See Also Send Feedback

The IRoleManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetActionsRole | Overloaded.
GetObjectRole | Overloaded.
HasRole | Overloaded.
ListRoles | Overloaded.
RegisterActionsForRole | Registers actions available for a role.
RegisterObjectRole | Registers Role available for an object type.
UnregisterActionsForRole | Unregisters actions available for a role.
UnregisterObjectRole | Unregisters Role.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Methods
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

The IRoleManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetActionsRole | Overloaded.
GetObjectRole | Overloaded.
HasRole | Overloaded.
ListRoles | Overloaded.
RegisterActionsForRole | Registers actions available for a role.
RegisterObjectRole | Registers Role available for an object type.
UnregisterActionsForRole | Unregisters actions available for a role.
UnregisterObjectRole | Unregisters Role.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role.
GetActionsRole<(Of <(U>)>)(RoleProfileType) | Gets the actions of a role profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole(U) Method (IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole<(Of <(U>)>) Method (IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the actions of a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
U GetActionsRole<U>(
    IRole role
)
Visual Basic (Declaration)
Function GetActionsRole(Of U) ( _
    role As IRole _
) As U
Visual C++
generic<typename U>
U GetActionsRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetActionsRole``1(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetActionsRole``1(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetActionsRole``1(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
GetActionsRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole(U) Method (RoleProfileType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole<(Of <(U>)>) Method (RoleProfileType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the actions of a role profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
U GetActionsRole<U>(
    RoleProfileType role
)
Visual Basic (Declaration)
Function GetActionsRole(Of U) ( _
    role As RoleProfileType _
) As U
Visual C++
generic<typename U>
U GetActionsRole(
    RoleProfileType role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.RoleProfileType

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetActionsRole``1(Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetActionsRole``1(Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetActionsRole``1(Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

See Also

IRoleManager<(Of <(T>)>) Interface
GetActionsRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role.
GetObjectRole(T, RoleProfileType) | Gets the Role for an object according to the profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method (T, IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method (T, IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role for an object according to the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T GetObjectRole(
    T baseObject,
    IRole role
)
Visual Basic (Declaration)
Function GetObjectRole ( _
    baseObject As T, _
    role As IRole _
) As T
Visual C++
T GetObjectRole(
    T baseObject,
    IRole^ role
)

Parameters

baseObject
Type: T

[Missing <param name="baseObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetObjectRole(`0,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetObjectRole(`0,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetObjectRole(`0,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
GetObjectRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method (T, RoleProfileType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method (T, RoleProfileType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role for an object according to the profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T GetObjectRole(
    T baseObject,
    RoleProfileType role
)
Visual Basic (Declaration)
Function GetObjectRole ( _
    baseObject As T, _
    role As RoleProfileType _
) As T
Visual C++
T GetObjectRole(
    T baseObject,
    RoleProfileType role
)

Parameters

baseObject
Type: T

[Missing <param name="baseObject"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetObjectRole(`0,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.RoleProfileType

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetObjectRole(`0,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.GetObjectRole(`0,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

See Also

IRoleManager<(Of <(T>)>) Interface
GetObjectRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role.
HasRole(T, RoleProfileType) | Gets the Role availability for an object type according to the profile type.
HasRole(T, Type) | Gets the Role availability for an object type according to the action.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool HasRole(
    T target,
    IRole role
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    role As IRole _
) As Boolean
Visual C++
bool HasRole(
    T target,
    IRole^ role
)

Parameters

target
Type: T

[Missing <param name="target"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, RoleProfileType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, RoleProfileType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool HasRole(
    T target,
    RoleProfileType role
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    role As RoleProfileType _
) As Boolean
Visual C++
bool HasRole(
    T target,
    RoleProfileType role
)

Parameters

target
Type: T

[Missing <param name="target"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.RoleProfileType

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,Genesyslab.Enterprise.Model.ComponentModel.RoleProfileType)"]

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, Type)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, Type)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the action.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool HasRole(
    T target,
    Type ActionRole
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    ActionRole As Type _
) As Boolean
Visual C++
bool HasRole(
    T target,
    Type^ ActionRole
)

Parameters

target
Type: T

[Missing <param name="target"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,System.Type)"]

ActionRole
Type: System..::.Type

[Missing <param name="ActionRole"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.HasRole(`0,System.Type)"]

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role.
ListRoles(T) | Gets the list of Role available for an object type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of Role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRole[] ListRoles()
Visual Basic (Declaration)
Function ListRoles As IRole()
Visual C++
array<IRole^>^ ListRoles()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.ListRoles"]

See Also

IRoleManager<(Of <(T>)>) Interface
ListRoles Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method (T)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method (T)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of Role available for an object type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRole[] ListRoles(
    T target
)
Visual Basic (Declaration)
Function ListRoles ( _
    target As T _
) As IRole()
Visual C++
array<IRole^>^ ListRoles(
    T target
)

Parameters

target
Type: T

[Missing <param name="target"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.ListRoles(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.ListRoles(`0)"]

See Also

IRoleManager<(Of <(T>)>) Interface
ListRoles Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


RegisterActionsForRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.RegisterActionsForRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Registers actions available for a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRoleManager<T> RegisterActionsForRole(
    Type abstractActionRole,
    Type concreteActionRole,
    IRole role
)
Visual Basic (Declaration)
Function RegisterActionsForRole ( _
    abstractActionRole As Type, _
    concreteActionRole As Type, _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ RegisterActionsForRole(
    Type^ abstractActionRole,
    Type^ concreteActionRole,
    IRole^ role
)

Parameters

abstractActionRole
Type: System..::.Type

[Missing <param name="abstractActionRole"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterActionsForRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

concreteActionRole
Type: System..::.Type

[Missing <param name="concreteActionRole"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterActionsForRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterActionsForRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterActionsForRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RegisterObjectRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.RegisterObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Registers Role available for an object type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRoleManager<T> RegisterObjectRole(
    Type abstractObjectRole,
    Type concreteObjectRole,
    IRole role
)
Visual Basic (Declaration)
Function RegisterObjectRole ( _
    abstractObjectRole As Type, _
    concreteObjectRole As Type, _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ RegisterObjectRole(
    Type^ abstractObjectRole,
    Type^ concreteObjectRole,
    IRole^ role
)

Parameters

abstractObjectRole
Type: System..::.Type

[Missing <param name="abstractObjectRole"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterObjectRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

concreteObjectRole
Type: System..::.Type

[Missing <param name="concreteObjectRole"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterObjectRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterObjectRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.RegisterObjectRole(System.Type,System.Type,Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


UnregisterActionsForRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.UnregisterActionsForRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Unregisters actions available for a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRoleManager<T> UnregisterActionsForRole(
    IRole role
)
Visual Basic (Declaration)
Function UnregisterActionsForRole ( _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ UnregisterActionsForRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.UnregisterActionsForRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.UnregisterActionsForRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


UnregisterObjectRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.UnregisterObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Unregisters Role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRoleManager<T> UnregisterObjectRole(
    IRole role
)
Visual Basic (Declaration)
Function UnregisterObjectRole ( _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ UnregisterObjectRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.UnregisterObjectRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IRoleManager`1.UnregisterObjectRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Interface

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Interface
Members See Also Send Feedback
interface defines subscriber contract for Publish/Subscribe pattern

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IServiceSubscriber
Visual Basic (Declaration)
Public Interface IServiceSubscriber
Visual C++
public interface class IServiceSubscriber

See Also

IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Members

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Members
IServiceSubscriber Interface Methods See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Methods
IServiceSubscriber Interface See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register Method
IServiceSubscriber Interface See Also Send Feedback

Overload List

Name | Description
Register<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing
Register<(Of <(T>)>)(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs
Register<(Of <(T>)>)(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events

See Also

IServiceSubscriber Interface
IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Interface of subscriber object being registered. To be used for publishing activities processing

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Register<T>(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
generic<typename T>
void Register(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <(T>)>)
Object that should receive events

Type Parameters

T
Type of parameter

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (Action<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Registeres an action to be performed when a publishing event occurs

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Register<T>(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    handler As Action(Of T) _
)
Visual C++
generic<typename T>
void Register(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <(T>)>)
Represents the method that performs an action on the specified object when a publishing event occurs

Type Parameters

T
Type of parameter

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Register a callback method for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Register<T>(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
generic<typename T>
void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
)

Parameters

handler
Type: System..::.Action <(Of <(T>)>)
Function that performs an action on the specified object T when a publishing event occurs
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <(T>)>)
filter predicate that allows checking whether publishing event should be processed or ignored

Type Parameters

T
Type of data to handle

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister Method
IServiceSubscriber Interface See Also Send Feedback

Overload List

Name | Description
Unregister<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities
Unregister<(Of <(T>)>)(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events

See Also

IServiceSubscriber Interface
IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister(T) Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister<(Of <(T>)>) Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Unregisters a subscriber (instance) from notifications about publishing activities

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Unregister<T>(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Unregister(Of T) ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
generic<typename T>
void Unregister(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <(T>)>)
Interface of subscriber object being unregistered

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber.Unregister``1(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{``0})"]

See Also

IServiceSubscriber Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister(T) Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister<(Of <(T>)>) Method (Action<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Unregister a subscriber (method) previously registered for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Unregister<T>(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Unregister(Of T) ( _
    handler As Action(Of T) _
)
Visual C++
generic<typename T>
void Unregister(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <(T>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber.Unregister``1(System.Action{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber.Unregister``1(System.Action{``0})"]

See Also

IServiceSubscriber Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
interface defines subscriber contract for Publish/Subscribe pattern

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IServiceSubscriber<T>
Visual Basic (Declaration)
Public Interface IServiceSubscriber(Of T)
Visual C++
generic<typename T>
public interface class IServiceSubscriber

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber`1"]

See Also

IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Members
IServiceSubscriber<(Of <(T>)>) Interface Methods See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Methods
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing
Register(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Interface of subscriber object being registered. To be used for publishing activities processing

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
void Register(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
Object that should receive events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Registeres an action to be performed when a publishing event occurs

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
void Register(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <( T >)>)
Represents the method that performs an action on the specified object when a publishing event occurs

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Register a callback method for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
)

Parameters

handler
Type: System..::.Action <(Of <( T >)>)
Function that performs an action on the specified object T when a publishing event occurs
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)
filter predicate that allows checking whether publishing event should be processed or ignored

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities
Unregister(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Unregisters a subscriber (instance) from notifications about publishing activities

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
void Unregister(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
Interface of subscriber object being unregistered

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Unregister a subscriber (method) previously registered for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
void Unregister(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber`1.Unregister(System.Action{`0})"]

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Interface
Members See Also Send Feedback
Defines a subscriber contract for Publish/Subscribe pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ISubscribeable<T>
Visual Basic (Declaration)
Public Interface ISubscribeable(Of T)
Visual C++
generic<typename T>
public interface class ISubscribeable

Type Parameters

T
Type of data

See Also

ISubscribeable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Members
ISubscribeable<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | Processes a publishing event.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Methods
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | Processes a publishing event.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>)..::.Handle Method
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback
Processes a publishing event.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Handle(
    T obj
)
Visual Basic (Declaration)
Sub Handle ( _
    obj As T _
)
Visual C++
void Handle(
    T obj
)

Parameters

obj
Type: T
Event that the subscribers can process.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Properties
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>)..::.Filter Property
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback
Returns the filter predicate which indicates whether publishing event should be processed or ignored.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IPredicatable<T> Filter { get; }
Visual Basic (Declaration)
ReadOnly Property Filter As IPredicatable(Of T)
Visual C++
property IPredicatable<T>^ Filter {
    IPredicatable<T>^ get ();
}

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ItemLocation Enumeration

[image]

Enterprise SDK 8.0 Reference API
ItemLocation Enumeration
See Also Send Feedback
Enumerate for location of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[FlagsAttribute]
public enum ItemLocation
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ItemLocation
Visual C++
[FlagsAttribute]
public enum class ItemLocation

Members

Member name | Description
Internal |
External |
All |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Interface

[image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Interface
Members See Also Send Feedback
Objects transformer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ITransformer<TTarget, TSource>
Visual Basic (Declaration)
Public Interface ITransformer(Of TTarget, TSource)
Visual C++
generic<typename TTarget, typename TSource>
public interface class ITransformer

Type Parameters

TTarget

[Missing <typeparam name="TTarget"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.ITransformer`2"]

TSource

[Missing <typeparam name="TSource"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.ITransformer`2"]

See Also

ITransformer<(Of <(TTarget, TSource>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Members
ITransformer<(Of <(TTarget, TSource>)>) Interface Methods See Also Send Feedback

The ITransformer<(Of <(TTarget, TSource>)>) type exposes the following members.

Methods

Name | Description
Transform | Thransforms the source object to target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Methods
ITransformer<(Of <(TTarget, TSource>)>) Interface See Also Send Feedback

The ITransformer<(Of <(TTarget, TSource>)>) type exposes the following members.

Methods

Name | Description
Transform | Thransforms the source object to target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Transform Method

[image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>)..::.Transform Method
ITransformer<(Of <(TTarget, TSource>)>) Interface See Also Send Feedback
Thransforms the source object to target object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
TTarget Transform(
    TSource source
)
Visual Basic (Declaration)
Function Transform ( _
    source As TSource _
) As TTarget
Visual C++
TTarget Transform(
    TSource source
)

Parameters

source
Type: TSource
The object to transform.

Return Value

Target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Class

[image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Class
Members See Also Send Feedback
IPredicatable wrapper.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class PredicatableWrapper<T, S> : IPredicatable<T>
Visual Basic (Declaration)
Public Class PredicatableWrapper(Of T, S) _
    Implements IPredicatable(Of T)
Visual C++
generic<typename T, typename S>
public ref class PredicatableWrapper : IPredicatable<T>

Type Parameters

T
Targer data type.
S
Source data type.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.PredicatableWrapper<(Of <(T, S>)>)

See Also

PredicatableWrapper<(Of <(T, S>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Members

[image] [image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Members
PredicatableWrapper<(Of <(T, S>)>) Class Constructors Methods See Also Send Feedback

The PredicatableWrapper<(Of <(T, S>)>) type exposes the following members.

Constructors

Name | Description
PredicatableWrapper<(Of <(T, S>)>) | PredicatableWrapper constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Invoke the source condition.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Constructor

[image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Constructor
PredicatableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
PredicatableWrapper constructor.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public PredicatableWrapper(
    ITransformer<S, T> transformer,
    IPredicatable<S> predicate
)
Visual Basic (Declaration)
Public Sub New ( _
    transformer As ITransformer(Of S, T), _
    predicate As IPredicatable(Of S) _
)
Visual C++
public:
PredicatableWrapper(
    ITransformer<S, T>^ transformer,
    IPredicatable<S>^ predicate
)

Parameters

transformer
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ITransformer <(Of <( S, T >)>)
Data transformer.
predicate
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( S >)>)
The filter to wrap.

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


PredicatableWrapper(T, S) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>) Methods
PredicatableWrapper<(Of <(T, S>)>) Class See Also Send Feedback

The PredicatableWrapper<(Of <(T, S>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invoke | Invoke the source condition.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
PredicatableWrapper<(Of <(T, S>)>)..::.Invoke Method
PredicatableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
Invoke the source condition.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool Invoke(
    T obj
)
Visual Basic (Declaration)
Public Function Invoke ( _
    obj As T _
) As Boolean
Visual C++
public:
virtual bool Invoke(
    T obj
) sealed

Parameters

obj
Type: T
Data.

Return Value

The result of the condition.

Implements

IPredicatable<(Of <(T>)>)..::.Invoke(T)

See Also

PredicatableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


RoleProfileType Enumeration

[image]

Enterprise SDK 8.0 Reference API
RoleProfileType Enumeration
See Also Send Feedback
Enumerate the profile types for the Role instances.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum RoleProfileType
Visual Basic (Declaration)
Public Enumeration RoleProfileType
Visual C++
public enum class RoleProfileType

Members

Member name | Description
Agent |
Supervisor |
Person |
Custom |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


StateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StateType Enumeration
See Also Send Feedback
Enumerate the state type of ICapability.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum StateType
Visual Basic (Declaration)
Public Enumeration StateType
Visual C++
public enum class StateType

Members

Member name | Description
Inactive |
Disabled |
Enabled |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Class

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Class
Members See Also Send Feedback
ISubscribeable wrapper.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SubscribeableWrapper<T, S> : ISubscribeable<T>
Visual Basic (Declaration)
Public Class SubscribeableWrapper(Of T, S) _
    Implements ISubscribeable(Of T)
Visual C++
generic<typename T, typename S>
public ref class SubscribeableWrapper : ISubscribeable<T>

Type Parameters

T
Targer data type.
S
Source data type.

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Model.ComponentModel..::.SubscribeableWrapper<(Of <(T, S>)>)

See Also

SubscribeableWrapper<(Of <(T, S>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Members

[image] [image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Members
SubscribeableWrapper<(Of <(T, S>)>) Class Constructors Methods Properties See Also Send Feedback

The SubscribeableWrapper<(Of <(T, S>)>) type exposes the following members.

Constructors

Name | Description
SubscribeableWrapper<(Of <(T, S>)>) | SubscribeableWrapper constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle | Publish the data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filter | Wrapped filter predicate.

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Constructor

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Constructor
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
SubscribeableWrapper constructor.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SubscribeableWrapper(
    ITransformer<S, T> transformer,
    ISubscribeable<S> subscriber
)
Visual Basic (Declaration)
Public Sub New ( _
    transformer As ITransformer(Of S, T), _
    subscriber As ISubscribeable(Of S) _
)
Visual C++
public:
SubscribeableWrapper(
    ITransformer<S, T>^ transformer,
    ISubscribeable<S>^ subscriber
)

Parameters

transformer
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ITransformer <(Of <( S, T >)>)
Data transformer.
subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( S >)>)
The subscriber to wrap.

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Methods
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback

The SubscribeableWrapper<(Of <(T, S>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle | Publish the data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>)..::.Handle Method
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
Publish the data.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Handle(
    T obj
)
Visual Basic (Declaration)
Public Sub Handle ( _
    obj As T _
)
Visual C++
public:
virtual void Handle(
    T obj
) sealed

Parameters

obj
Type: T
Data.

Implements

ISubscribeable<(Of <(T>)>)..::.Handle(T)

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscribeableWrapper(T, S) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>) Properties
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback

The SubscribeableWrapper<(Of <(T, S>)>) type exposes the following members.

Properties

Name | Description
Filter | Wrapped filter predicate.

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
SubscribeableWrapper<(Of <(T, S>)>)..::.Filter Property
SubscribeableWrapper<(Of <(T, S>)>) Class See Also Send Feedback
Wrapped filter predicate.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IPredicatable<T> Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As IPredicatable(Of T)
Visual C++
public:
virtual property IPredicatable<T>^ Filter {
    IPredicatable<T>^ get () sealed;
}

Implements

ISubscribeable<(Of <(T>)>)..::.Filter

See Also

SubscribeableWrapper<(Of <(T, S>)>) Class
Genesyslab.Enterprise.Model.ComponentModel Namespace


VisibilityType Enumeration

[image]

Enterprise SDK 8.0 Reference API
VisibilityType Enumeration
See Also Send Feedback
Enumerates the visibility types for the Role instances.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[FlagsAttribute]
public enum VisibilityType
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration VisibilityType
Visual C++
[FlagsAttribute]
public enum class VisibilityType

Members

Member name | Description
Unknown |
Monitoring |
Coaching |
Reviewing |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


Genesyslab.Enterprise.Model.Configuration Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Configuration Namespace
Send Feedback

Enumerations

Enumeration | Description
CfgAccessGroupType |
CfgActionCodeType |
CfgAlarmCategory |
CfgAppComponentType |
CfgAppType |
CfgCallActionCode |
CfgChargeType |
CfgDataType |
CfgDialMode |
CfgDNGroupType |
CfgDNRegisterFlag |
CfgDNType |
CfgEnumeratorType |
CfgErrorType |
CfgFieldType |
CfgFlag |
CfgFolderClass |
CfgHAType |
CfgHostType |
CfgIVRProfileType |
CfgIVRType |
CfgLinkType |
CfgObjectiveTableType |
CfgObjectProperty |
CfgObjectState |
CfgObjectType |
CfgOperationMode |
CfgOptimizationMethod |
CfgOSType |
CfgRank |
CfgRecActionCode |
CfgResourceType |
CfgRouteType |
CfgScriptType |
CfgSelectionMode |
CfgSolutionType |
CfgStartupType |
CfgStatDayType |
CfgStatTableType |
CfgSwitchType |
CfgTableType |
CfgTargetType |
CfgTaskType |
CfgTraceMode |
CfgTransactionType |
CfgUpdatePackageStatus |
GctiCallState |


CfgAccessGroupType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgAccessGroupType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgAccessGroupType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgAccessGroupType
Visual Basic (Declaration)
Public Enumeration CfgAccessGroupType
Visual C++
public enum class CfgAccessGroupType

Members

Member name | Description
CFGNoAccessGroupType |
CFGDefaultGroup |
CFGUsersGroup |
CFGAdministratorsGroup |
CFGSuperAdministratorsGroup |
CFGSystemGroup |
CFGEveryoneGroup |
CFGMaxAccessGroupType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgActionCodeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgActionCodeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgActionCodeType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgActionCodeType
Visual Basic (Declaration)
Public Enumeration CfgActionCodeType
Visual C++
public enum class CfgActionCodeType

Members

Member name | Description
CFGNoActionCode |
CFGInboundCall |
CFGOutboundCall |
CFGInternalCall |
CFGTransfer |
CFGConference |
CFGLogin |
CFGLogout |
CFGReady |
CFGNotReady |
CFGBusyOn |
CFGBusyOff |
CFGForwardOn |
CFGForwardOff |
CFGMaxActionCodeType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgAlarmCategory Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgAlarmCategory Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgAlarmCategory"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgAlarmCategory
Visual Basic (Declaration)
Public Enumeration CfgAlarmCategory
Visual C++
public enum class CfgAlarmCategory

Members

Member name | Description
CFGACNoAlarmCategory |
CFGACCritical |
CFGACMajor |
CFGACMinor |
CFGACMaxAlarmCategory |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgAppComponentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgAppComponentType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgAppComponentType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgAppComponentType
Visual Basic (Declaration)
Public Enumeration CfgAppComponentType
Visual C++
public enum class CfgAppComponentType

Members

Member name | Description
CFGAppComponentUnknown |
CFGAppComponentSubProcess |
CFGAppComponentService |
CFGAppComponent |
CFGAppComponentAccessPoint |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgAppType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgAppType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgAppType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgAppType
Visual Basic (Declaration)
Public Enumeration CfgAppType
Visual C++
public enum class CfgAppType

Members

Member name | Description
CFGNoApplication |
CFGTServer |
CFGStatServer |
CFGBillingServer |
CFGBillingClient |
CFGAgentView |
CFGEAServer |
CFGEAClient |
CFGDBServer |
CFGCallConcentrator |
CFGSDialer |
CFGListManager |
CFGCMServer |
CFGCMClient |
CFGLME |
CFGRouterServer |
CFGStrategyBuilder |
CFGStrategyLoader |
CFGAgentDesktop |
CFGSCE |
CFGCCView |
CFGConfigServer |
CFGThirdPartyApp |
CFGThirdPartyServer |
CFGStrategySimulator |
CFGStrategyScheduler |
CFGDARTServer |
CFGDARTClient |
CFGCustomServer |
CFGExternalRouter |
CFGVirtualInteractiveT |
CFGVirtualRP |
CFGDatabase |
CFGNetVector |
CFGDetailBiller |
CFGSummaryBiller |
CFGNACD |
CFGBackUpControlClient |
CFGInfomartStatCollector |
CFGInfomartStatConfigurator |
CFGIVRInterfaceServer |
CFGIServer |
CFGMessageServer |
CFGSCS |
CFGSCI |
CFGSNMPAgent |
CFGRealDBServer |
CFGWFMClient |
CFGWFMDataAggregator |
CFGWFMWebServices |
CFGWFMScheduleServer |
CFGInteractionRoutingDesigner |
CFGETLProxy |
CFGITCUtility |
CFGVCServer |
CFGGDMETL |
CFGVSSShared |
CFGVSSConsole |
CFGCCAnalizerDataMart |
CFGChatServer |
CFGCallbackServer |
CFGCoBrowsingServer |
CFGSMSServer |
CFGContactServer |
CFGEmailServer |
CFGMediaLink |
CFGWebInteractionRequestsServer |
CFGWebStatServer |
CFGWebInteractionServer |
CFGWebOptionRoutePoint |
CFGWebClient |
CFGContactServerManager |
CFGContentAnalyzer |
CFGResponseManager |
CFGVoIPController |
CFGVoIPDevice |
CFGAutomatedWorkflowEngine |
CFGHAProxy |
CFGVoIPStreamManager |
CFGVoIPDMXServer |
CFGWebAPIServer |
CFGLoadBalancer |
CFGApplicationCluster |
CFGLoadDistributionServer |
CFGGProxy |
CFGGIS |
CFGAgentDesktopDeliveryServer |
CFGGCNClient |
CFGIVRDT |
CFGGCNThinServer |
CFGClassificationServer |
CFGTrainingServer |
CFGUniversalCallbackServer |
CFGCPDServerProxy |
CFGXLinkController |
CFGKWorkerPortal |
CFGWFMServer |
CFGWFMBuilder |
CFGWFMReports |
CFGWFMWeb |
CFGKnowledgeManager |
CFGIVRDriver |
CFGIVRLibrary |
CFGLCSAdapter |
CFGDesktopNETServer |
CFGSiebel7ConfSynchComponent |
CFGSiebel7CampSynchComponent |
CFGGenericServer |
CFGGenericClient |
CFGCallDirector |
CFGSIPCommunicationServer |
CFGInteractionServer |
CFGIntegrationServer |
CFGWFMDaemon |
CFGGVPPolicyManager |
CFGGVPCiscoQueueAdapter |
CFGGVPTextToSpeechServer |
CFGGVPASRLogManager |
CFGGVPBandwidthManager |
CFGGVPEventsCollector |
CFGGVPCacheServer |
CFGGVPASRLogServer |
CFGGVPASRPackageLoader |
CFGGVPIPCommunicationServer |
CFGGVPResourceManager |
CFGGVPSIPSessionManager |
CFGGVPMediaGateway |
CFGGVPSoftSwitch |
CFGGVPCoreService |
CFGGVPVoiceCommunicationServer |
CFGGVPUnifiedLoginServer |
CFGGVPCallStatusMonitor |
CFGGVPReporter |
CFGGVPH323SessionManager |
CFGGVPASRLogManagerAgent |
CFGGVPGenesysQueueAdapter |
CFGGVPIServer |
CFGGVPSCPGateway |
CFGGVPSRPServer |
CFGGVPMRCPTTSServer |
CFGGVPCCSServer |
CFGGVPMRCPASRServer |
CFGGVPNetworkMonitor |
CFGGVPOBNManager |
CFGGVPSelfServiceProvisioningServer |
CFGGVPMCP |
CFGGVPFetchingModule |
CFGGVPMCPLegacyInterpreter |
CFGGVPCCP |
CFGGVPResourceMgr |
CFGGVPClusterMgr |
CFGGVPMediaServer |
CFGGVPPSTNConnector |
CFGGVPReportingSever |
CFGGVPASG |
CFGGVPCTIConnector |
CFGResourceAccessPoint |
CFGInteractionWorkspace |
CFGAdvisors |
CFGESSExtensibleServices |
CFGCustomerView |
CFGMaxAppType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgCallActionCode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgCallActionCode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgCallActionCode"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgCallActionCode
Visual Basic (Declaration)
Public Enumeration CfgCallActionCode
Visual C++
public enum class CfgCallActionCode

Members

Member name | Description
CFGCACNoCallActionCode |
CFGCACConnect |
CFGCACDrop |
CFGCACMuteTransfer |
CFGCACTransfer |
CFGCACRoute |
CFGCACPlayMessage |
CFGCACSendFax |
CFGCACSendPage |
CFGCACSendEmail |
CFGCACMaxCallActionCode |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgChargeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgChargeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgChargeType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgChargeType
Visual Basic (Declaration)
Public Enumeration CfgChargeType
Visual C++
public enum class CfgChargeType

Members

Member name | Description
CFGNoChargeType |
CFGFree |
CFGFlatRate |
CFGInstance |
CFGDuration |
CFGMaxChargeType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgDataType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgDataType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgDataType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgDataType
Visual Basic (Declaration)
Public Enumeration CfgDataType
Visual C++
public enum class CfgDataType

Members

Member name | Description
CFGDTNoDataType |
CFGDTInt |
CFGDTFloat |
CFGDTChar |
CFGDTVarChar |
CFGDTDateTime |
CFGDTMaxDataType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgDialMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgDialMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgDialMode"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgDialMode
Visual Basic (Declaration)
Public Enumeration CfgDialMode
Visual C++
public enum class CfgDialMode

Members

Member name | Description
CFGDMNoDialMode |
CFGDMPredict |
CFGDMProgress |
CFGDMPreview |
CFGDMProgressAndSeize |
CFGDMPredictAndSeize |
CFGDMPower |
CFGDMPowerAndSeize |
CFGDMPushPreview |
CFGDMProgressGVP |
CFGDMPredictGVP |
CFGDMPowerGVP |
CFGDMMaxDialMode |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgDNGroupType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgDNGroupType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgDNGroupType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgDNGroupType
Visual Basic (Declaration)
Public Enumeration CfgDNGroupType
Visual C++
public enum class CfgDNGroupType

Members

Member name | Description
CFGNoDNGroup |
CFGSinglePorts |
CFGACDQueues |
CFGRoutingPoints |
CFGNetworkPorts |
CFGServiceNumbers |
CFGMaxDNGroupType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgDNRegisterFlag Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgDNRegisterFlag Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgDNRegisterFlag"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgDNRegisterFlag
Visual Basic (Declaration)
Public Enumeration CfgDNRegisterFlag
Visual C++
public enum class CfgDNRegisterFlag

Members

Member name | Description
CFGDRUnknown |
CFGDRFalse |
CFGDRTrue |
CFGDROnDemand |
CFGMaxDNRegisterFlag |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgDNType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgDNType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgDNType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgDNType
Visual Basic (Declaration)
Public Enumeration CfgDNType
Visual C++
public enum class CfgDNType

Members

Member name | Description
CFGNoDN |
CFGExtension |
CFGACDPosition |
CFGACDQueue |
CFGRoutingPoint |
CFGVirtACDQueue |
CFGVirtRoutingPoint |
CFGEAPort |
CFGVoiceMail |
CFGCellular |
CFGCP |
CFGFAX |
CFGData |
CFGMusic |
CFGTrunk |
CFGTrunkGroup |
CFGTieLine |
CFGTieLineGroup |
CFGMixed |
CFGExtRoutingPoint |
CFGDestinationLabel |
CFGServiceNumber |
CFGRoutingQueue |
CFGCommDN |
CFGEmail |
CFGVoIP |
CFGVideo |
CFGChat |
CFGCoBrowse |
CFGVoIPService |
CFGWorkflow |
CFGAccessResource |
CFGGVPDID |
CFGMaxDNType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgEnumeratorType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgEnumeratorType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgEnumeratorType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgEnumeratorType
Visual Basic (Declaration)
Public Enumeration CfgEnumeratorType
Visual C++
public enum class CfgEnumeratorType

Members

Member name | Description
CFGENTNoEnumeratorType |
CFGENTInteractionOperationalAttribute |
CFGENTRole |
CFGENTContactAttribute |
CFGENTCustom |
CFGENTGVPMasterList |
CFGENTGVPCustomList |
CFGENTGVPMasterDefault |
CFGENTGVPCustomDefault |
CFGENTGVPAlias |
CFGENTMaxEnumeratorType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgErrorType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgErrorType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgErrorType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgErrorType
Visual Basic (Declaration)
Public Enumeration CfgErrorType
Visual C++
public enum class CfgErrorType

Members

Member name | Description
CFGNoError |
CFGServerNotFound |
CFGWrongProtocol |
CFGUnknownMessage |
CFGLoginIncorrect |
CFGNoDBAccess |
CFGDBError |
CFGAppSecurityViolation |
CFGAccessDenied |
CFGNoPermission |
CFGObjectNotFound |
CFGListItemNotFound |
CFGUniquenessViolation |
CFGDependentObjects |
CFGIncompleteObjectData |
CFGIncorrectReferences |
CFGUnchangeableInfo |
CFGValueOutOfRange |
CFGUnspecifiedModification |
CFGDBResponseTimedOut |
CFGWrongAPIParameters |
CFGConnWriteError |
CFGConnReadError |
CFGConfigFileNotRead |
CFGConfigFileIncorrect |
CFGObjectPackingError |
CFGUndefinedError |
CFGHistoryLogExpired |
CFGForcedDisconnect |
CFGReadOnlyOperationalModeActivated |
CFGSetOperationalModeFailed |
CFGUnsupportedProperty |
CFGUnsupportedObject |
CFGExternalAuthenticationError |
CFGLocaleItemNotChanged |
CFGLocaleItemNotFound |
CFGXMLParseError |
CFGChangePasswordDenied |
CFGUnsecureConnectionDenied |
CFGEmptyPasswordDenied |
CFGMaxErrorType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgFieldType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgFieldType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgFieldType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgFieldType
Visual Basic (Declaration)
Public Enumeration CfgFieldType
Visual C++
public enum class CfgFieldType

Members

Member name | Description
CFGFTNoFieldType |
CFGFTRecordID |
CFGFTPhone |
CFGFTRecordType |
CFGFTRecordStatus |
CFGFTDialResult |
CFGFTNumberOfAttempts |
CFGFTScheduledTime |
CFGFTCallTime |
CFGFTFrom |
CFGFTUntil |
CFGFTTimeZone |
CFGFTCampaignID |
CFGFTAgentID |
CFGFTChainID |
CFGFTNumberInChain |
CFGFTCustomField |
CFGFTANI |
CFGFTLATA |
CFGFTNPA |
CFGFTNPA_NXX |
CFGFTStateCode |
CFGFTInfoDigits |
CFGFTCountryCode |
CFGFTPhoneType |
CFGFTGroupDBID |
CFGFTAppDBID |
CFGFTTreatments |
CFGFTMediaRefference |
CFGFTEmailSubject |
CFGFTEmailTemplateID |
CFGFTSwitchID |
CFGFTMaxFieldType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgFlag Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgFlag Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgFlag"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgFlag
Visual Basic (Declaration)
Public Enumeration CfgFlag
Visual C++
public enum class CfgFlag

Members

Member name | Description
CFGNoFlag |
CFGFalse |
CFGTrue |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgFolderClass Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgFolderClass Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgFolderClass"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgFolderClass
Visual Basic (Declaration)
Public Enumeration CfgFolderClass
Visual C++
public enum class CfgFolderClass

Members

Member name | Description
CFGFCNoClass |
CFGFCDefault |
CFGFCSite |
CFGFCGVPCustomerGroup |
CFGFCGVPIVRProfileGroup |
CFGFCGVPRoot |
CFGFCHostGroup |
CFGFCGVPCustomerGroupRoot |
CFGFCGVPIVRProfileGroupRoot |
CFGFCHostGroupRoot |
CFGFCGVPDIDGroups |
CFGFCGVPDIDs |
CFGFCMaxClass |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgHAType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgHAType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgHAType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgHAType
Visual Basic (Declaration)
Public Enumeration CfgHAType
Visual C++
public enum class CfgHAType

Members

Member name | Description
CFGHTNoHAType |
CFGHTColdStanby |
CFGHTWarmStanby |
CFGHTHotStanby |
CFGHTMaxHAtype |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgHostType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgHostType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgHostType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgHostType
Visual Basic (Declaration)
Public Enumeration CfgHostType
Visual C++
public enum class CfgHostType

Members

Member name | Description
CFGNoHost |
CFGNetworkServer |
CFGTenantServer |
CFGServiceWorkstation |
CFGTenantWorkstation |
CFGAgentWorkstation |
CFGAuxComputer |
CFGGVPWorkstation |
CFGMaxHostType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgIVRProfileType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgIVRProfileType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgIVRProfileType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgIVRProfileType
Visual Basic (Declaration)
Public Enumeration CfgIVRProfileType
Visual C++
public enum class CfgIVRProfileType

Members

Member name | Description
CFGIPTNoType |
CFGIPTInbound |
CFGIPTMaxType |
CFGIPTOutbound |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgIVRType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgIVRType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgIVRType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgIVRType
Visual Basic (Declaration)
Public Enumeration CfgIVRType
Visual C++
public enum class CfgIVRType

Members

Member name | Description
CFGIVRTNoIVRType |
CFGIVRTConversant |
CFGIVRTWVRForAIX |
CFGIVRTDirectTalk6000 |
CFGIVRTSyntellectVocalPoint |
CFGIVRTSyntellectPremier |
CFGIVRTSyntellectVista |
CFGIVRTVoiceTek |
CFGIVRTAgility |
CFGIVRTMeridianIntegrated |
CFGIVRTSymposiumOpen |
CFGIVRTEdify |
CFGIVRTBrite |
CFGIVRTShowNTel |
CFGIVRTIntervoiceBrite |
CFGIVRTIntervoice |
CFGIVRTPeriphonics |
CFGIVRTAmerex |
CFGIVRTWVRForWindows |
CFGIVRTDirectTalkNT |
CFGIVRTGenesysVoicePlatform |
CFGIVRTeleraGVP |
CFGIVRTMPS |
CFGIVRTAspectCSS |
CFGIVRTMSSpeechServer |
CFGIVRTOtherIVRType |
CFGIVRTEnvox |
CFGIVRTMaxIVRType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgLinkType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgLinkType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgLinkType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgLinkType
Visual Basic (Declaration)
Public Enumeration CfgLinkType
Visual C++
public enum class CfgLinkType

Members

Member name | Description
CFGNoLink |
CFGMeridianLink4 |
CFGMeridianLink5 |
CFGGalaxyLink |
CFGSpectrumLink |
CFGCompuCall05 |
CFGCompuCall06 |
CFGCallVisorASAI |
CFGEthernetASAI |
CFGApplicationBridge5 |
CFGApplicationBridge6 |
CFGCallBridge2 |
CFGCallBridge3 |
CFGOAI |
CFGApplicationLink |
CFGPinnacle |
CFGMadgeLink |
CFGNECLink |
CFGFujitsuLink |
CFGHostInterfaceLink |
CFGWorkStationInterfaceLink |
CFGGateway01Link |
CFGApplicationConnectivityLink10 |
CFGApplicationConnectivityLink20 |
CFGCallBridgeACLISDNS0ISO |
CFGCallBridgeACLV24ISO |
CFGiSLinkCSTAI |
CFGMatraLinkCSTAII |
CFGApplicationLinkCSTA |
CFGiCAT23ICCL2 |
CFGiCAT3xICCL3 |
CFGApplicationLinkCSTAI |
CFGApplicationLinkCSTAII |
CFGGenericLink |
CFGCompuCall09 |
CFGCompuCall10 |
CFGCompuCall11 |
CFGApplicationBridge7 |
CFGCallBridge4 |
CfgDelcoACD |
CFGHitachiCx8000 |
CFGStarexLink |
CFGMiTai7_3 |
CFGMeridianLinkServices |
CFGApplicationConnectivityLinkCSTA |
CFGCallBridgeDX |
CFGCoralLink |
CFGMaxLinkType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgObjectiveTableType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgObjectiveTableType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgObjectiveTableType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgObjectiveTableType
Visual Basic (Declaration)
Public Enumeration CfgObjectiveTableType
Visual C++
public enum class CfgObjectiveTableType

Members

Member name | Description
CFGOTTNoType |
CFGOTTDefault |
CFGOTTCostContract |
CFGOTTMaxType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgObjectProperty Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgObjectProperty Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgObjectProperty"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgObjectProperty
Visual Basic (Declaration)
Public Enumeration CfgObjectProperty
Visual C++
public enum class CfgObjectProperty

Members

Member name | Description
CFGNoProperty |
CFGAbbr |
CFGAccessCode |
CFGAddedAgentDBIDs |
CFGAddedPlaceDBIDs |
CFGAddress |
CFGAddressLine1 |
CFGAddressLine2 |
CFGAddressLine3 |
CFGAddressLine4 |
CFGAddressLine5 |
CFGAgentDBIDs |
CFGAgentInfo |
CFGAgentLoginDBID |
CFGAgentLogins |
CFGAppRank |
CFGAppRanks |
CFGAppServerDBIDs |
CFGAppServicePermissions |
CFGAppType |
CFGAssignedTenantDBIDs |
CFGAssociation |
CFGBackupServerDBID |
CFGBirthdate |
CFGChangedAgentLogins |
CFGChangedAppRanks |
CFGChangedAppServicePermissions |
CFGChangedOptions |
CFGChangedServiceInfo |
CFGChangedSkillLevels |
CFGChargeableNumber |
CFGCode |
CFGComment |
CFGContactPersonDBID |
CFGDBID |
CFGDeletedAgentDBIDs |
CFGDeletedAgentLoginDBIDs |
CFGDeletedAppRanks |
CFGDeletedAppServerDBIDs |
CFGDeletedAppServicePermissions |
CFGDeletedAssignedTenantDBIDs |
CFGDeletedDestDNDBIDs |
CFGDeletedDNDBIDs |
CFGDeletedManagerDBIDs |
CFGDeletedOptions |
CFGDeletedPlaceDBIDs |
CFGDeletedRouteDNDBIDs |
CFGDeletedServiceDBIDs |
CFGDeletedSkillDBIDs |
CFGDeletedSubcodes |
CFGDeletedSwitchAccessCodes |
CFGDeletedTenantDBIDs |
CFGDeltaActionCode |
CFGDeltaAgentInfo |
CFGDeltaApplication |
CFGDeltaDN |
CFGDeltaGroup |
CFGDeltaGroupInfo |
CFGDeltaPerson |
CFGDeltaPlace |
CFGDeltaService |
CFGDeltaSwitch |
CFGDeltaTenant |
CFGDestDNDBIDs |
CFGDNDBIDs |
CFGDNLoginID |
CFGEmployeeID |
CFGFax |
CFGFirstName |
CFGGroupInfo |
CFGHome |
CFGHostDBID |
CFGHWID |
CFGIndex |
CFGIPaddress |
CFGIsAdmin |
CFGIsAgent |
CFGIsChargeable |
CFGIsServer |
CFGIsServiceProvider |
CFGIsSuperTenant |
CFGLastName |
CFGLevel |
CFGLinkType |
CFGLoginCode |
CFGLoginFlag |
CFGManagerDBIDs |
CFGMobile |
CFGModem |
CFGName |
CFGNumber |
CFGOffice |
CFGOptions |
CFGOSinfo |
CFGOStype |
CFGOSversion |
CFGPager |
CFGPassword |
CFGPermissionMask |
CFGPhones |
CFGPhonesComment |
CFGPhysSwitchDBID |
CFGPlaceDBID |
CFGPlaceDBIDs |
CFGPort |
CFGProviderPersonDBID |
CFGRouteDNDBIDs |
CFGServerInfo |
CFGServiceDBID |
CFGServiceInfo |
CFGSkillDBID |
CFGSkillLevels |
CFGSubcodes |
CFGSwitchAccessCodes |
CFGSwitchDBID |
CFGTenantDBID |
CFGTenantDBIDs |
CFGTenantPersonDBID |
CFGTimeout |
CFGTServerDBID |
CFGType |
CFGUserName |
CFGVersion |
CFGWrapupTime |
CFGDNRange |
CFGRegisterAll |
CFGAddedDNs |
CFGAlias |
CFGAttempts |
CFGCapacityTableDBID |
CFGChangedStatIntervals |
CFGChangedUserProperties |
CFGDay |
CFGDeletedStatDayDBIDs |
CFGDeletedStatIntervals |
CFGDeletedUserProperties |
CFGDeltaAgentLogin |
CFGDeltaHost |
CFGDeltaPhysicalSwitch |
CFGDeltaScript |
CFGDeltaSkill |
CFGDeltaStatDay |
CFGDeltaStatTable |
CFGDeltaTransaction |
CFGDescription |
CFGEndTime |
CFGGroupDBID |
CFGIntervalLength |
CFGIsDayOfWeek |
CFGMaxValue |
CFGMinValue |
CFGOverride |
CFGQuotaTableDBID |
CFGRecordPeriod |
CFGRouteType |
CFGStartTime |
CFGStatDayDBIDs |
CFGState |
CFGStatIntervals |
CFGTargetValue |
CFGTrunks |
CFGUserProperties |
CFGAppPrototypeDBID |
CFGDeltaAppPrototype |
CFGDNs |
CFGChangedDNs |
CFGTargetType |
CFGDnSource |
CFGDestinationSource |
CFGLocationSource |
CFGDnisSource |
CFGReasonSource |
CFGExtensionSource |
CFGUseOverride |
CFGSwitchSpecificType |
CFGMemberIDs |
CFGDeltaAccessGroup |
CFGDeletedMemberIDs |
CFGAddedMemberIDs |
CFGAccessMask |
CFGCount |
CFGAccount |
CFGDeltaFolder |
CFGOwnerID |
CFGAccessNumbers |
CFGDeletedAccessNumbers |
CFGLADANSwitchDBID |
CFGLADANNumber |
CFGLDDANSwitchDBID |
CFGLDDANNumber |
CFGDate |
CFGLength |
CFGFieldType |
CFGDefaultValue |
CFGIsPrimaryKey |
CFGIsUnique |
CFGIsNullable |
CFGDeltaField |
CFGFieldDBIDs |
CFGDeltaFormat |
CFGDeletedFieldDBIDs |
CFGDbAccessDBID |
CFGFormatDBID |
CFGDbTableName |
CFGDeltaTableAccess |
CFGTableAccessDBID |
CFGFilterDBID |
CFGTreatmentDBIDs |
CFGLogTableAccessDBID |
CFGTimeFrom |
CFGTimeUntil |
CFGMaxAttempts |
CFGScriptDBID |
CFGDeltaCallingList |
CFGDeletedTreatmentDBIDs |
CFGCallingLists |
CFGCampaignGroups |
CFGDeltaCampaign |
CFGDeletedCallingListDBIDs |
CFGChangedCallingLists |
CFGDeletedCampaignGroupDBIDs |
CFGChangedCampaignGroups |
CFGCallResult |
CFGRecActionCode |
CFGDateTime |
CFGCycleAttempt |
CFGInterval |
CFGIncrement |
CFGCallActionCode |
CFGDestDNDBID |
CFGDeltaTreatment |
CFGDeltaFilter |
CFGOffset |
CFGIsDSTObserved |
CFGDSTStartDate |
CFGDSTStopDate |
CFGNameNetscape |
CFGNameMSExplorer |
CFGDeltaTimeZone |
CFGIsCachable |
CFGUpdateTimeout |
CFGLACLICallingListDBID |
CFGLACLIShare |
CFGLACLIIsActive |
CFGLCCLICallingListDBID |
CFGLCCLIShare |
CFGLCCLIIsActive |
CFGLACGIGroupDBID |
CFGLACGIGroupType |
CFGLACGIDescription |
CFGLACGIDialerDBID |
CFGLACGIStatServerDBID |
CFGLACGIIsActive |
CFGLACGIDialMode |
CFGLACGIOrigDNDBID |
CFGLACGINumOfChannels |
CFGLACGIOperationMode |
CFGLACGIMinRecBuffSize |
CFGLACGIOptRecBuffSize |
CFGLACGIOptMethod |
CFGLACGIOptMethodValue |
CFGLACGIScriptDBID |
CFGLCCGIGroupDBID |
CFGLCCGIGroupType |
CFGLCCGIDescription |
CFGLCCGIDialerDBID |
CFGLCCGIStatServerDBID |
CFGLCCGIIsActive |
CFGLCCGIDialMode |
CFGLCCGIOrigDNDBID |
CFGLCCGINumOfChannels |
CFGLCCGIOperationMode |
CFGLCCGIMinRecBuffSize |
CFGLCCGIOptRecBuffSize |
CFGLCCGIOptMethod |
CFGLCCGIOptMethodValue |
CFGLCCGIScriptDBID |
CFGDeltaVoicePrompt |
CFGFlexibleProperties |
CFGDeletedFlexibleProperties |
CFGChangedFlexibleProperties |
CFGWorkDirectory |
CFGCommandLine |
CFGAutoRestart |
CFGStartupTimeout |
CFGShutdownTimeout |
CFGLCAPort |
CFGSolutionTemplateDBID |
CFGComponents |
CFGSCSDBID |
CFGAssignedTenantDBID |
CFGSolutionType |
CFGDeletedComponents |
CFGChangedComponents |
CFGLogEventID |
CFGSelectionMode |
CFGAppDBID |
CFGDeltaSolutionTemplate |
CFGCategory |
CFGAlarmDetectEvent |
CFGAlarmRemovalEvent |
CFGAlarmDetectScriptDBID |
CFGClearanceTimeout |
CFGReactionScriptDBIDs |
CFGIsMasked |
CFGDeltaAlarmCondition |
CFGDeletedReactionScriptDBIDs |
CFGPortNumber |
CFGIVRType |
CFGDNDBID |
CFGDeltaIVRPort |
CFGPortDBIDs |
CFGIVRServerDBID |
CFGDeltaIVR |
CFGDeletedPortDBIDs |
CFGAppVersion |
CFGStartupPriority |
CFGIsOptional |
CFGObjectIDs |
CFGDeletedObjectIDs |
CFGMaxObjectProperty |
CFGSchemaItemID |
CFGSchemaItemStyle |
CFGSchemaItemName |
CFGSchemaItemRefID |
CFGSyntaxID |
CFGAttrID |
CFGClassAttrs |
CFGSchemaItemsNumber |
CFGMsgEventType |
CFGMsgParamList |
CFGEnumPairs |
CFGPropDefaultValue |
CFGSchemaProtocolID |
CFGSchemaProtocolName |
CFGSchemaErrorPackCode |
CFGSchemaPackCodeSet |
CFGSchemaServerVersion |
CFGSchemaServerHostID |
CFGSchemaSyntaxTable |
CFGSchemaAttrTable |
CFGSchemaClassTable |
CFGSchemaDeltaTable |
CFGSchemaStructTable |
CFGSchemaMsgAttrTable |
CFGSchemaMsgTable |
CFGSchemaBriefTable |
CFGSchemaEnumTable |
CFGSchemaErrorTable |
CFGFromSwitchDBID |
CFGMemberDBID |
CFGMemberCSID |
CFGPersonDBID |
CFGMemberType |
CFGSwitchType |
CFGDnGroupType |
CFGChargeType |
CFGHostType |
CFGScriptType |
CFGActionCodeType |
CFGActionCodeDBID |
CFGIntervalCount |
CFGStatValue1 |
CFGStatValue2 |
CFGStatValue3 |
CFGStatValue4 |
CFGStatDayDBID |
CFGTableType |
CFGObjectType |
CFGCSID |
CFGCampaignDBID |
CFGDataType |
CFGAlarmConditionDBID |
CFGObjectDBID |
CFGTransactionType |
CFGCountACE |
CFGACEArray |
CFGAccessID |
CFGObjectID |
CFGTenantName |
CFGDeletedDNsDBIDs |
CFGHostName |
CFGHostAddress |
CFGMajorVersion |
CFGMinorVersion |
CFGBuildNumber |
CFGBuildIndex |
CFGStructureVersion |
CFGErrorClass |
CFGErrorLevel |
CFGRedundancyType |
CFGIsPrimary |
CFGAppServerDBID |
CFGConnProtocol |
CFGTimoutLocal |
CFGTimoutRemote |
CFGTraceMode |
CFGChangedAppServerDBIDs |
CFGSchemaFilterTable |
CFGLinkClassID |
CFGLinkAttrID |
CFGParentID |
CFGErrorLogID |
CFGComponentDefs |
CFGStartupType |
CFGCommandLineArguments |
CFGStatTableType |
CFGIVRDBID |
CFGCapacityRuleDBID |
CFGDefaultCapacityRuleDBID |
CFGDeletedComponentDefinitions |
CFGChangedComponentDefinitions |
CFGAccessGroupTypeProp |
CFGEnumeratorDBID |
CFGIsDefault |
CFGObjectiveRecords |
CFGMediaTypeDBID |
CFGServiceTypeDBID |
CFGCustomerSegmentDBID |
CFGObjectiveThreshold |
CFGObjectiveDelta |
CFGDeltaEnumerator |
CFGDeltaEnumeratorValue |
CFGDeltaObjectiveTable |
CFGDeletedObjectiveRecords |
CFGChangedObjectiveRecords |
CFGClearanceScriptDBIDs |
CFGDeletedClearanceScriptDBIDs |
CFGEnumeratorType |
CFGDisplayName |
CFGRange |
CFGEMailAddress |
CFGExternalID |
CFGPackageVersion |
CFGPackageStatus |
CFGPackageDateTime |
CFGSchemaLinkType |
CFGSchemaLinkAttribute |
CFGClassLinks |
CFGFolderClass |
CFGCustomType |
CFGObjectResources |
CFGChangedObjectResources |
CFGDeletedObjectResources |
CFGResourceType |
CFGCharField1 |
CFGCharField2 |
CFGCharField3 |
CFGCharField4 |
CFGLongField1 |
CFGLongField2 |
CFGLongField3 |
CFGLongField4 |
CFGPrepaidCost |
CFGTimeZoneDBID |
CFGTimeStart |
CFGTimeEnd |
CFGContractDBID |
CFGWaitThreshold |
CFGCFlatRate |
CFGAgentHourlyRate |
CFGStatDayType |
CFGSiteDBID |
CFGDefaultContractDBID |
CFGPortInfos |
CFGConnID |
CFGTransportParams |
CFGAppParams |
CFGProxyParams |
CFGSecurityParams |
CFGServerDBIDs |
CFGMaxQueueSize |
CFGIVRProfileDBID |
CFGDeltaCampaignGroup |
CFGDeletedServerDBIDs |
CFGDSTOffset |
CFGStartDate |
CFGIsParentNSP |
CFGNotes |
CFGResellerDBID |
CFGChannel |
CFGIsProvisioned |
CFGIsAdminCustomer |
CFGCustomerDBID |
CFGStartServiceDate |
CFGEndServiceDate |
CFGIVRProfileType |
CFGTfn |
CFGIVRProfileStatus |
CFGDIDDBIDs |
CFGDeltaGVPReseller |
CFGDeltaGVPCustomer |
CFGDeltaGVPIVRProfile |
CFGDeletedDIDDBIDs |
CFGTaskType |
CFGDeltaScheduledTask |
CFGInteractionQueueDBID |
CFGUseFlatRate |
CFGChangedPortInfos |
CFGDeletedPortInfos |
CFGObjectiveTableType |
CFGAppComponentType |
CFGParentTenantDBID |
CFGIsExternalAuth |
CFGTrunkGroupDNDBID |
CFGDeltaRole |
CFGRoleMembers |
CFGChangedRoleMembers |
CFGDeletedRoleMembers |
CFGMaxProperty |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgObjectState Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgObjectState Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgObjectState"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgObjectState
Visual Basic (Declaration)
Public Enumeration CfgObjectState
Visual C++
public enum class CfgObjectState

Members

Member name | Description
CFGNoObjectState |
CFGEnabled |
CFGDisabled |
CFGDeleted |
CFGMaxObjectState |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgObjectType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgObjectType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgObjectType
Visual Basic (Declaration)
Public Enumeration CfgObjectType
Visual C++
public enum class CfgObjectType

Members

Member name | Description
CFGNoObject |
CFGSwitch |
CFGDN |
CFGPerson |
CFGPlace |
CFGAgentGroup |
CFGPlaceGroup |
CFGTenant |
CFGService |
CFGApplication |
CFGHost |
CFGPhysicalSwitch |
CFGScript |
CFGSkill |
CFGActionCode |
CFGAgentLogin |
CFGTransaction |
CFGDNGroup |
CFGStatDay |
CFGStatTable |
CFGAppPrototype |
CFGAccessGroup |
CFGFolder |
CFGField |
CFGFormat |
CFGTableAccess |
CFGCallingList |
CFGCampaign |
CFGTreatment |
CFGFilter |
CFGTimeZone |
CFGVoicePrompt |
CFGIVRPort |
CFGIVR |
CFGAlarmCondition |
CFGEnumerator |
CFGEnumeratorValue |
CFGObjectiveTable |
CFGCampaignGroup |
CFGGVPReseller |
CFGGVPCustomer |
CFGGVPIVRProfile |
CFGScheduledTask |
CFGRole |
CFGMaxObjectType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgOperationMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgOperationMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgOperationMode"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgOperationMode
Visual Basic (Declaration)
Public Enumeration CfgOperationMode
Visual C++
public enum class CfgOperationMode

Members

Member name | Description
CFGOMNoOperationMode |
CFGOMManual |
CFGOMSchedule |
CFGOMMaxOperationMode |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgOptimizationMethod Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgOptimizationMethod Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgOptimizationMethod"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgOptimizationMethod
Visual Basic (Declaration)
Public Enumeration CfgOptimizationMethod
Visual C++
public enum class CfgOptimizationMethod

Members

Member name | Description
CFGOMNoOptimizationMethod |
CFGOMBusyFactor |
CFGOMOverdialRate |
CFGOMWaitTime |
CFGOMMaxOptimizationMethod |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgOSType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgOSType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgOSType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgOSType
Visual Basic (Declaration)
Public Enumeration CfgOSType
Visual C++
public enum class CfgOSType

Members

Member name | Description
CFGNoOS |
CFGSolaris |
CFGSolarisX86 |
CFGDigitalUNIX |
CFGHPUX |
CFGAIX |
CFGSunOS |
CFGWinNT |
CFGWindows |
CFGOS2 |
CFGMacintosh |
CFGTandemUNIX |
CFGUnixWare |
CFGWindows2000 |
CFGWindowsXP |
CFGWindowsServer2003 |
CFGRedHatLinux |
CFGWindowsServer2008 |
CFGWindowsVista |
CFGMaxOSType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgRank Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgRank Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgRank"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgRank
Visual Basic (Declaration)
Public Enumeration CfgRank
Visual C++
public enum class CfgRank

Members

Member name | Description
CFGNoRank |
CFGUser |
CFGDesigner |
CFGTenantAdministrator |
CFGServiceAdministrator |
CFGSuperAdministrator |
CFGMaxRank |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgRecActionCode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgRecActionCode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgRecActionCode"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgRecActionCode
Visual Basic (Declaration)
Public Enumeration CfgRecActionCode
Visual C++
public enum class CfgRecActionCode

Members

Member name | Description
CFGRACNoRecActionCode |
CFGRACMarkDB |
CFGRACMarkAllChain |
CFGRACCycle |
CFGRACRetryIn |
CFGRACRetryAtDate |
CFGRACNextInChain |
CFGRACNextInChainAfter |
CFGRACNextInChainAtDate |
CFGRACAssignToGroup |
CFGRACMarkAsAgentError |
CFGRACReschedule |
CFGRACDelegateForProcessing |
CFGRACExecuteSQLstatement |
CFGRACMaxRecActionCode |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgResourceType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgResourceType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgResourceType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgResourceType
Visual Basic (Declaration)
Public Enumeration CfgResourceType
Visual C++
public enum class CfgResourceType

Members

Member name | Description
CFGRTNoType |
CFGRTTimeZone |
CFGRTContract |
CFGRTSiteAccess |
CFGRTGVPGroupCustomer |
CFGRTGVPGroupIVRProfile |
CFGRTGVPServerType |
CFGRTGVPServerTypeDisabled |
CFGRTGVPServer |
CFGRTGVPProcessNode |
CFGRTGVPDataNode |
CFGRTGVPTemplate |
CFGRTGroupHost |
CFGRTTaskGVPIVRProfile |
CFGRTTaskGVPCustomer |
CFGRTTaskSwitch |
CFGRTTaskHost |
CFGRTEnumerator |
CFGRTEnumeratorValue |
CFGRTScript |
CFGRTApplication |
CFGRTMaxType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgRouteType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgRouteType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgRouteType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgRouteType
Visual Basic (Declaration)
Public Enumeration CfgRouteType
Visual C++
public enum class CfgRouteType

Members

Member name | Description
CFGNoRoute |
CFGDefault |
CFGLabel |
CFGOverwriteDNIS |
CFGDDD |
CFGIDDD |
CFGDirect |
CFGReject |
CFGAnnouncement |
CFGPostFeature |
CFGDirectAgent |
CFGUseExternalProtocol |
CFGGetFromDN |
CFGXRouteTypeDefault |
CFGXRouteTypeRoute |
CFGXRouteTypeDirect |
CFGXRouteTypeReroute |
CFGXRouteTypeDirectUUI |
CFGXRouteTypeDirectANI |
CFGXRouteTypeDirectNoToken |
CFGXRouteTypeDNISPooling |
CFGXRouteTypeDirectDNISnANI |
CFGXRouteTypeExtProtocol |
CFGXRouteTypeDirectDigits |
CFGXRouteTypeForbidden |
CFGXRouteTypeISCCProtocol |
CFGXRouteTypePullBack |
CFGXRouteTypeDirectNetworkCallID |
CFGMaxRouteType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgScriptType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgScriptType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgScriptType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgScriptType
Visual Basic (Declaration)
Public Enumeration CfgScriptType
Visual C++
public enum class CfgScriptType

Members

Member name | Description
CFGNoScript |
CFGDataCollection |
CFGServiceSelection |
CFGEnhancedQueuing |
CFGScriptConfiguration |
CFGSimpleRouting |
CFGEnhancedRouting |
CFGVoiceFile |
CFGOutboundCampaign |
CFGOutboundFormat |
CFGOutboundList |
CFGOutboundFilter |
CFGOutboundTreatment |
CFGOutboundAlert |
CFGSchedule |
CFGAlarmDetection |
CFGAlarmReaction |
CFGVssSystemSchema |
CFGVssSharedSchema |
CFGVssServerSchema |
CFGVssObject |
CFGEmailAckReceipt |
CFGCapacityRule |
CFGInteractionQueue |
CFGInteractionQueueView |
CFGInteractionWorkBin |
CFGInteractionSubmitter |
CFGInteractionSnapshot |
CFGBusinessProcess |
CFGSupervisorData |
CFGInteractionWorkflowTrigger |
CFGGVPReport |
CFGOutboundSchedule |
CFGESSDialPlan |
CFGMaxScriptType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgSelectionMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgSelectionMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgSelectionMode"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgSelectionMode
Visual Basic (Declaration)
Public Enumeration CfgSelectionMode
Visual C++
public enum class CfgSelectionMode

Members

Member name | Description
CFGSMNoSelectionMode |
CFGSMByAppDBID |
CFGSMAppType |
CFGSMByAny |
CFGSMMaxSelectionMode |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgSolutionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgSolutionType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgSolutionType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgSolutionType
Visual Basic (Declaration)
Public Enumeration CfgSolutionType
Visual C++
public enum class CfgSolutionType

Members

Member name | Description
CFGSTNoSolutionType |
CFGSTDefaultSolutionType |
CFGSTIntegratedScreenPop |
CFGSTEnterpriseRouting |
CFGSTNetworkRouting |
CFGSTOutboundDialing |
CFGSTWorkforceManagement |
CFGSTVoiceSelfService |
CFGSTInternetContactCenter |
CFGSTWorkflowRouting |
CFGSTInformationAnalysis |
CFGSTKnowledgeWorker |
CFGSTBranchOffice |
CFGSTFramework |
CFGSTExpressEdition |
CFGSTMultiChannelRouting |
CFGSTDesktopNETServerSolution |
CFGSTMaxSolutionType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgStartupType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgStartupType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgStartupType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgStartupType
Visual Basic (Declaration)
Public Enumeration CfgStartupType
Visual C++
public enum class CfgStartupType

Members

Member name | Description
CFGSUTNoStartupType |
CFGSUTAutomatic |
CFGSUTManual |
CFGSUTDisabled |
CFGSUTMaxStartupType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgStatDayType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgStatDayType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgStatDayType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgStatDayType
Visual Basic (Declaration)
Public Enumeration CfgStatDayType
Visual C++
public enum class CfgStatDayType

Members

Member name | Description
CFGSDTNoType |
CFGSDTDefault |
CFGSDTDayContract |
CFGSDTMaxType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgStatTableType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgStatTableType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgStatTableType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgStatTableType
Visual Basic (Declaration)
Public Enumeration CfgStatTableType
Visual C++
public enum class CfgStatTableType

Members

Member name | Description
CFGNoStatTable |
CFGCapacityTable |
CFGQuotaTable |
CFGSpecialDayTable |
CFGVolumeContractTable |
CFGVariableRateContractTable |
CFGMaxStatTableType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgSwitchType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgSwitchType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgSwitchType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgSwitchType
Visual Basic (Declaration)
Public Enumeration CfgSwitchType
Visual C++
public enum class CfgSwitchType

Members

Member name | Description
CFGNoSwitch |
CFGNortelMeridian |
CFGRockwellSpectrum |
CFGRockwellGalaxy |
CFGNortelDMS100 |
CFGLucentDefinityG3 |
CFGAspectCallCenter |
CFGRolm9751CBX |
CFGSiemensHicom300E |
CFGIntecomIBX80 |
CFGEricssonMD110 |
CFGLucent5ESS |
CFGMadge |
CFGNEC |
CFGFujitsu |
CFGHarrisVoiceFrame |
CFGGateway01 |
CFGSiemensHicom150 |
CFGSiemensHicom300 |
CFGPhilipsSophoiS3000 |
CFGMatraMC6500 |
CFGSiemensHicom150H |
CFGEricssonACP1000 |
CFGSiemensGECiSDX |
CFGAlcatelA4400DHS3 |
CFGGenericSwitch |
CFGDelcoACD |
CFGHitachiCX8000 |
CFGLGStarex |
CFGMitelSX2000 |
CFGNortelMeridianCallCenter |
CFGSiemensHicom150E |
CFGSiemensRealtisDX |
CFGTadiranCoral |
CFGVoIPSMCPSwitch |
CFGVirtualSwitchIIF |
CFGInternetGateway |
CFGATT800ICPGateway |
CFGSprintSiteRPGateway |
CFGBellCanadaATFGateway |
CFGAlcatelSCPGateway |
CFGBellAtlanticISCPGateway |
CFGConcert800Gateway |
CFGAlcatelDTAGSCPGateway |
CFGKPNNetworkGateway |
CFGAlcatelTISCPGateway |
CFGAlcatelBTSCPGateway |
CFG3511ProtocolInterface |
CFGDatavoiceDharma |
CFGHuaweiCC08 |
CFGLucentIndexSDX |
CFGSiemensHicom300H |
CFGSiemensHiPath4000 |
CFGAlcatelA4200 |
CFGTenovisIntegral33 |
CFGTelera |
CFGNGSN |
CFGGenSpec |
CFGVoicePortal |
CFGKWGateway |
CFGSiemensHicom300Real |
CFGGenSpecXML |
CFGOPSI |
CFGCiscoCM |
CFGMultimediaSwitch |
CFGVerizonISCPGateway |
CFGAlcatel5020OPSI |
CFGAvayaIPOffice |
CFGMitelMN3300 |
CFGSamsungIPPCXIAP |
CFGSiemensHiPath3000 |
CFGEOneQueue |
CFGTenovisI55 |
CFGSIPSwitch |
CFGDigitroAXS20 |
CFGGVPDIDGroup |
CFGSIPNetworkSwitch |
CFGNECSV7000 |
CFGRadvisionIContact |
CFGAvayaTSAPI |
CFGHuaweiNGN |
CFGMaxSwitchType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgTableType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgTableType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgTableType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgTableType
Visual Basic (Declaration)
Public Enumeration CfgTableType
Visual C++
public enum class CfgTableType

Members

Member name | Description
CFGTTNoTableType |
CFGTTCallingList |
CFGTTLogTable |
CFGTTANI |
CFGTTLATA |
CFGTTNPA |
CFGTTNPA_NXX |
CFGTTStateCode |
CFGTTInfoDigits |
CFGTTCountryCode |
CFGTTCustomType |
CFGTTDoNotCallList |
CFGTTEmailContactLists |
CFGTTMaxTableType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgTargetType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgTargetType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgTargetType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgTargetType
Visual Basic (Declaration)
Public Enumeration CfgTargetType
Visual C++
public enum class CfgTargetType

Members

Member name | Description
CFGNoTarget |
CFGTargetAgent |
CFGTargetPlace |
CFGTargetAgentGroup |
CFGTargetPlaceGroup |
CFGTargetRoutingPoint |
CFGTargetACDQueue |
CFGTargetDestinationLabel |
CFGTargetACDQueueGroup |
CFGTargetExtRoutingPoint |
CFGTargetISCC |
CFGMaxTargetType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgTaskType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgTaskType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgTaskType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgTaskType
Visual Basic (Declaration)
Public Enumeration CfgTaskType
Visual C++
public enum class CfgTaskType

Members

Member name | Description
CFGTTNoType |
CFGTTUpdateAppIVR |
CFGTTRegenerateIVRProfiles |
CFGTTRegenerateDIDGroups |
CFGTTSwapIVRURLs |
CFGTTMaxType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgTraceMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgTraceMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgTraceMode"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgTraceMode
Visual Basic (Declaration)
Public Enumeration CfgTraceMode
Visual C++
public enum class CfgTraceMode

Members

Member name | Description
CFGTMNoTraceMode |
CFGTMNone |
CFGTMLocal |
CFGTMRemote |
CFGTMBoth |
CFGTMMaxTraceMode |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgTransactionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgTransactionType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgTransactionType"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgTransactionType
Visual Basic (Declaration)
Public Enumeration CfgTransactionType
Visual C++
public enum class CfgTransactionType

Members

Member name | Description
CFGTRTNoTransactionType |
CFGTRTCallData |
CFGTRTBusinessAttribute |
CFGTRTBusinessSituation |
CFGTRTBusinessRule |
CFGTRTBusinessAction |
CFGTRTStatFilter |
CFGTRTStatTimeRange |
CFGTRTStatTimeProfile |
CFGTRTStatType |
CFGTRTStatMetric |
CFGTRTList |
CFGTRTMacro |
CFGTRTMaxTransactionType |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


CfgUpdatePackageStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
CfgUpdatePackageStatus Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.CfgUpdatePackageStatus"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum CfgUpdatePackageStatus
Visual Basic (Declaration)
Public Enumeration CfgUpdatePackageStatus
Visual C++
public enum class CfgUpdatePackageStatus

Members

Member name | Description
CFGUPSNoStatus |
CFGUPSNonApplied |
CFGUPSPartiallyApplied |
CFGUPSFullyApplied |
CFGUPSMaxStatus |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


GctiCallState Enumeration

[image]

Enterprise SDK 8.0 Reference API
GctiCallState Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Configuration.GctiCallState"]

Namespace: Genesyslab.Enterprise.Model.Configuration
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum GctiCallState
Visual Basic (Declaration)
Public Enumeration GctiCallState
Visual C++
public enum class GctiCallState

Members

Member name | Description
GctiCStOk |
GctiCStGeneralError |
GctiCStSystemError |
GctiCStBusy |
GctiCStNoAnswer |
GctiCStSitDetected |
GctiCStAnswMachine |
GctiCStAllTrunksBusy |
GctiCStSitInvalidNum |
GctiCStSitVacant |
GctiCStSitIntercept |
GctiCStSitUnknown |
GctiCStSitNocircuit |
GctiCStSitReorder |
GctiCStFaxDetected |
GctiCStAbandoned |
GctiCStDropped |
GctiCStDroppedNoAns |
GctiCStUnknown |
GctiCStSilence |
GctiCStAnswer |
GctiCStNuTone |
GctiCStNoDialTone |
GctiCStNoProgress |
GctiCStNoRingBack |
GctiCStNoEstablished |
GctiCStPagerDetected |
GctiCStWrongParty |
GctiCStDialErr |
GctiCStDropErr |
GctiCStSwitchErr |
GctiCStNoFreePortErr |
GctiCStTransferErr |
GctiCStStale |
GctiCStAgentCallBackErr |
GctiCStGroupCallBackErr |
GctiCStDoNotCall |
GctiCStCancel |
GctiCStWrongNumber |
GctiCSt_MAX |

See Also

Genesyslab.Enterprise.Model.Configuration Namespace


Genesyslab.Enterprise.Model.Device Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Device Namespace
Send Feedback

Interfaces

Interface | Description
IDevice | Describes a device. To learn how to create a device, or how to register for its events, see the summary descriptions and examples of [!:Genesyslab.Enterprise.Services.IDeviceService].

Enumerations

Enumeration | Description
DeviceStateType | Enumeration for the possible states of a device.
DeviceType | Enumeration for the device types that you can find in the supported switches.
ForwardModeType | Enumeration types for the forward mode.


DeviceStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceStateType Enumeration
See Also Send Feedback
Enumeration for the possible states of a device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public enum DeviceStateType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration DeviceStateType
Visual C++
[SerializableAttribute]
public enum class DeviceStateType

Members

Member name | Description
Unknown |
OutOfService |
Registering |
Registered |
NotRegistered |
Unavailable |

See Also

Genesyslab.Enterprise.Model.Device Namespace


DeviceType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceType Enumeration
See Also Send Feedback
Enumeration for the device types that you can find in the supported switches.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum DeviceType
Visual Basic (Declaration)
Public Enumeration DeviceType
Visual C++
public enum class DeviceType

Members

Member name | Description
Unknown |
Acdposition |
Extension |

See Also

Genesyslab.Enterprise.Model.Device Namespace


ForwardModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ForwardModeType Enumeration
See Also Send Feedback
Enumeration types for the forward mode.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ForwardModeType
Visual Basic (Declaration)
Public Enumeration ForwardModeType
Visual C++
public enum class ForwardModeType

Members

Member name | Description
Unknown |
None |
Unconditional |
OnBusy |
OnNoAnswer |
OnBusyAndNoAnswer |
SendAllCalls |

See Also

Genesyslab.Enterprise.Model.Device Namespace


IDevice Interface

[image]

Enterprise SDK 8.0 Reference API
IDevice Interface
Members See Also Send Feedback
Describes a device. To learn how to create a device, or how to register for its events, see the summary descriptions and examples of [!:Genesyslab.Enterprise.Services.IDeviceService].

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDevice : ISerializable
Visual Basic (Declaration)
Public Interface IDevice _
    Implements ISerializable
Visual C++
public interface class IDevice : ISerializable

See Also

IDevice Members
Genesyslab.Enterprise.Model.Device Namespace


IDevice Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Members
IDevice Interface Methods Properties See Also Send Feedback

The IDevice type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling
ActiveChannels | List of active channels for this device.
Attributes |
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on.
Controller | Returns the state controller of the object.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.
Group | Group of subdevices which compose this device.
Identity | Identity in relation with the device.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.
State | Device status.
Strategy | List of stategies handled by the object.

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


IDevice Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Methods
IDevice Interface See Also Send Feedback

The IDevice type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


IDevice Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Properties
IDevice Interface See Also Send Feedback

The IDevice type exposes the following members.

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling
ActiveChannels | List of active channels for this device.
Attributes |
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.
Context | The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on.
Controller | Returns the state controller of the object.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.
Group | Group of subdevices which compose this device.
Identity | Identity in relation with the device.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.
State | Device status.
Strategy | List of stategies handled by the object.

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


ActionsTransitions Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.ActionsTransitions Property
IDevice Interface See Also Send Feedback
The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool[] ActionsTransitions { get; }
Visual Basic (Declaration)
ReadOnly Property ActionsTransitions As Boolean()
Visual C++
property array<bool>^ ActionsTransitions {
    array<bool>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


ActiveChannels Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.ActiveChannels Property
IDevice Interface See Also Send Feedback
List of active channels for this device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Uri[] ActiveChannels { get; }
Visual Basic (Declaration)
ReadOnly Property ActiveChannels As Uri()
Visual C++
property array<Uri^>^ ActiveChannels {
    array<Uri^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Attributes Property
IDevice Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Device.IDevice.Attributes"]

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Attributes {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Capabilities Property
IDevice Interface See Also Send Feedback
Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Context Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Context Property
IDevice Interface See Also Send Feedback
The device context, a set of information about the device, such as its location, its peripheral types (mobile phone, iphone), and so on.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IContext> Context { get; }
Visual Basic (Declaration)
ReadOnly Property Context As IDictionary(Of String, IContext)
Visual C++
property IDictionary<String^, IContext^>^ Context {
    IDictionary<String^, IContext^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Controller Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Controller Property
IDevice Interface See Also Send Feedback
Returns the state controller of the object.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Controller { get; }
Visual Basic (Declaration)
ReadOnly Property Controller As Object
Visual C++
property Object^ Controller {
    Object^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.FQName Property
IDevice Interface See Also Send Feedback

Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Group Property
IDevice Interface See Also Send Feedback
Group of subdevices which compose this device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IDevice> Group { get; }
Visual Basic (Declaration)
ReadOnly Property Group As IDictionary(Of String, IDevice)
Visual C++
property IDictionary<String^, IDevice^>^ Group {
    IDictionary<String^, IDevice^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Identity Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Identity Property
IDevice Interface See Also Send Feedback
Identity in relation with the device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IIdentity> Identity { get; }
Visual Basic (Declaration)
ReadOnly Property Identity As IDictionary(Of String, IIdentity)
Visual C++
property IDictionary<String^, IIdentity^>^ Identity {
    IDictionary<String^, IIdentity^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Name Property
IDevice Interface See Also Send Feedback
Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.State Property
IDevice Interface See Also Send Feedback
Device status.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DeviceStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As DeviceStateType
Visual C++
property DeviceStateType State {
    DeviceStateType get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Strategy Property
IDevice Interface See Also Send Feedback
List of stategies handled by the object.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Genesyslab.Enterprise.Model.Envelope Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Envelope Namespace
Send Feedback

Interfaces

Interface Description
IEnvelope<(Of <(T>)>)
Describes the event that occurred on the related published object, and contains the updated copy of this object.

This container is divided into two parts:

  • Header Details the event information.
  • BodyCopy of the published object.
Note: Make sure that you use the returned object copy to update accordingly your application and in further calls to Enterprise SDK methods. Do not keep a reference on a deprecated copy: if a new event occurs

IHeader
Describes the event which occurred on a published object. This interface details what happened to this object (modification if State value is 0, else this is an error) and provides its context as the list of the related protocol messages which resulted in this E-SDK event.
  • The last protocol message is available in CurrentContext.
  • Other related messages are available in the ContextByIndex(Int32).
IPayLoadContext
Describes an event and its associated protocol message (msg).

Enumerations

Enumeration | Description
EnvelopeStateType | Status of the envelope.


EnvelopeStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
EnvelopeStateType Enumeration
See Also Send Feedback
Status of the envelope.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum EnvelopeStateType
Visual Basic (Declaration)
Public Enumeration EnvelopeStateType
Visual C++
public enum class EnvelopeStateType

Members

Member name | Description
Unknown | Unknown.
Created | Creation.
Complete | Complete.
Read | Read.
Written | Written.
Copied | Copied.
Closed | Closed.

See Also

Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Interface
Members See Also Send Feedback
Describes the event that occurred on the related published object, and contains the updated copy of this object.

This container is divided into two parts:

  • Header Details the event information.
  • BodyCopy of the published object.
Note: Make sure that you use the returned object copy to update accordingly your application and in further calls to Enterprise SDK methods. Do not keep a reference on a deprecated copy: if a new event occurs

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEnvelope<T>
Visual Basic (Declaration)
Public Interface IEnvelope(Of T)
Visual C++
generic<typename T>
public interface class IEnvelope

Type Parameters

T
Type of the published object.

Remarks

To receive events, your application must register a callback method with the service. For instance, see the IChannelService description to read an example of callback registration on a given channel.

See Also

IEnvelope<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Members
IEnvelope<(Of <(T>)>) Interface Properties See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Body | Returns the copy of the published object.
EnvelopeState | Status of this envelope.
Header | Details the event information.

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Properties
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Body | Returns the copy of the published object.
EnvelopeState | Status of this envelope.
Header | Details the event information.

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Body Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.Body Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Returns the copy of the published object.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T Body { get; }
Visual Basic (Declaration)
ReadOnly Property Body As T
Visual C++
property T Body {
    T get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


EnvelopeState Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.EnvelopeState Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Status of this envelope.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
EnvelopeStateType EnvelopeState { get; }
Visual Basic (Declaration)
ReadOnly Property EnvelopeState As EnvelopeStateType
Visual C++
property EnvelopeStateType EnvelopeState {
    EnvelopeStateType get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Header Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.Header Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Details the event information.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IHeader Header { get; }
Visual Basic (Declaration)
ReadOnly Property Header As IHeader
Visual C++
property IHeader^ Header {
    IHeader^ get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Interface

[image]

Enterprise SDK 8.0 Reference API
IHeader Interface
Members See Also Send Feedback
Describes the event which occurred on a published object. This interface details what happened to this object (modification if State value is 0, else this is an error) and provides its context as the list of the related protocol messages which resulted in this E-SDK event.
  • The last protocol message is available in CurrentContext.
  • Other related messages are available in the ContextByIndex(Int32).

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IHeader
Visual Basic (Declaration)
Public Interface IHeader
Visual C++
public interface class IHeader

See Also

IHeader Members
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Members

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Members
IHeader Interface Methods Properties See Also Send Feedback

The IHeader type exposes the following members.

Methods

Name | Description
ContextByIndex | Returns the related protocol message with the given index.

Properties

Name Description
CorrelationId
ID of the request associated with this event.
Count
Number of protocol messages associated with this event message.
CurrentContext
Returns the context of the last protocol message.
Message
Error message if State > 0.
SourceName
Name of the source object which published the event.
SourceUid
FQName of the source object which published the event.
State
Event state.
  • State=0: modification.
  • State>0: error code

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Methods
IHeader Interface See Also Send Feedback

The IHeader type exposes the following members.

Methods

Name | Description
ContextByIndex | Returns the related protocol message with the given index.

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


ContextByIndex Method

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.ContextByIndex Method
IHeader Interface See Also Send Feedback
Returns the related protocol message with the given index.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IPayLoadContext ContextByIndex(
    int index
)
Visual Basic (Declaration)
Function ContextByIndex ( _
    index As Integer _
) As IPayLoadContext
Visual C++
IPayLoadContext^ ContextByIndex(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the message (range: 0-count)

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Envelope.IHeader.ContextByIndex(System.Int32)"]

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Properties
IHeader Interface See Also Send Feedback

The IHeader type exposes the following members.

Properties

Name Description
CorrelationId
ID of the request associated with this event.
Count
Number of protocol messages associated with this event message.
CurrentContext
Returns the context of the last protocol message.
Message
Error message if State > 0.
SourceName
Name of the source object which published the event.
SourceUid
FQName of the source object which published the event.
State
Event state.
  • State=0: modification.
  • State>0: error code

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CorrelationId Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CorrelationId Property
IHeader Interface See Also Send Feedback
ID of the request associated with this event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int CorrelationId { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelationId As Integer
Visual C++
property int CorrelationId {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.Count Property
IHeader Interface See Also Send Feedback
Number of protocol messages associated with this event message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CurrentContext Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CurrentContext Property
IHeader Interface See Also Send Feedback
Returns the context of the last protocol message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IPayLoadContext CurrentContext { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentContext As IPayLoadContext
Visual C++
property IPayLoadContext^ CurrentContext {
    IPayLoadContext^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Message Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.Message Property
IHeader Interface See Also Send Feedback
Error message if State > 0.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Message { get; }
Visual Basic (Declaration)
ReadOnly Property Message As String
Visual C++
property String^ Message {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


SourceName Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.SourceName Property
IHeader Interface See Also Send Feedback
Name of the source object which published the event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string SourceName { get; }
Visual Basic (Declaration)
ReadOnly Property SourceName As String
Visual C++
property String^ SourceName {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


SourceUid Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.SourceUid Property
IHeader Interface See Also Send Feedback
FQName of the source object which published the event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string SourceUid { get; }
Visual Basic (Declaration)
ReadOnly Property SourceUid As String
Visual C++
property String^ SourceUid {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.State Property
IHeader Interface See Also Send Feedback
Event state.
  • State=0: modification.
  • State>0: error code

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int State { get; }
Visual Basic (Declaration)
ReadOnly Property State As Integer
Visual C++
property int State {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Interface

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Interface
Members See Also Send Feedback
Describes an event and its associated protocol message (msg).

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPayLoadContext
Visual Basic (Declaration)
Public Interface IPayLoadContext
Visual C++
public interface class IPayLoadContext

See Also

IPayLoadContext Members
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Members
IPayLoadContext Interface Properties See Also Send Feedback

The IPayLoadContext type exposes the following members.

Properties

Name Description
ContextState
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error
msg
Returns the raw associated PSDK message.
Reason
Returns the reason of this event update.
TimeStamp
Returns the time stamp of the object creation.

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Properties
IPayLoadContext Interface See Also Send Feedback

The IPayLoadContext type exposes the following members.

Properties

Name Description
ContextState
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error
msg
Returns the raw associated PSDK message.
Reason
Returns the reason of this event update.
TimeStamp
Returns the time stamp of the object creation.

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


ContextState Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.ContextState Property
IPayLoadContext Interface See Also Send Feedback
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ContextStateType ContextState { get; }
Visual Basic (Declaration)
ReadOnly Property ContextState As ContextStateType
Visual C++
property ContextStateType ContextState {
    ContextStateType get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


msg Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.msg Property
IPayLoadContext Interface See Also Send Feedback
Returns the raw associated PSDK message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IMessage msg { get; }
Visual Basic (Declaration)
ReadOnly Property msg As IMessage
Visual C++
property IMessage^ msg {
    IMessage^ get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Reason Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.Reason Property
IPayLoadContext Interface See Also Send Feedback
Returns the reason of this event update.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ReasonTypes Reason { get; }
Visual Basic (Declaration)
ReadOnly Property Reason As ReasonTypes
Visual C++
property ReasonTypes Reason {
    ReasonTypes get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


TimeStamp Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.TimeStamp Property
IPayLoadContext Interface See Also Send Feedback
Returns the time stamp of the object creation.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
long TimeStamp { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStamp As Long
Visual C++
property long long TimeStamp {
    long long get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Genesyslab.Enterprise.Model.Identity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Identity Namespace
Send Feedback

Interfaces

Interface | Description
IAlias | Describes an alias associated with an identity.
IAliasManager | Manages the aliases of an existing identity.
ICredential | Describes credentials.
IEntity | Describes a person as an entity (first name, last name, IDs) with associated business values.
IIdentity | Describes an identity.
IIdentityType | Identity type.

Enumerations

Enumeration | Description
WorkMode | Describes the agent's workmode.


IAlias Interface

[image]

Enterprise SDK 8.0 Reference API
IAlias Interface
Members See Also Send Feedback
Describes an alias associated with an identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAlias
Visual Basic (Declaration)
Public Interface IAlias
Visual C++
public interface class IAlias

See Also

IAlias Members
Genesyslab.Enterprise.Model.Identity Namespace


IAlias Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAlias Members
IAlias Interface Properties See Also Send Feedback

The IAlias type exposes the following members.

Properties

Name | Description
Name | Alias name.

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAlias Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAlias Properties
IAlias Interface See Also Send Feedback

The IAlias type exposes the following members.

Properties

Name | Description
Name | Alias name.

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IAlias..::.Name Property
IAlias Interface See Also Send Feedback
Alias name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Interface

[image]

Enterprise SDK 8.0 Reference API
IAliasManager Interface
Members See Also Send Feedback
Manages the aliases of an existing identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAliasManager
Visual Basic (Declaration)
Public Interface IAliasManager
Visual C++
public interface class IAliasManager

See Also

IAliasManager Members
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager Members
IAliasManager Interface Methods See Also Send Feedback

The IAliasManager type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias.
ListAliases | Returns the list of aliases asscoiated with the given identity.
LookupByAlias | Searches for an alias.
RemoveAlias | Overloaded.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager Methods
IAliasManager Interface See Also Send Feedback

The IAliasManager type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias.
ListAliases | Returns the list of aliases asscoiated with the given identity.
LookupByAlias | Searches for an alias.
RemoveAlias | Overloaded.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


AddAlias Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.AddAlias Method
IAliasManager Interface See Also Send Feedback
Adds an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAliasManager AddAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function AddAlias ( _
    identityAlias As IAlias _
) As IAliasManager
Visual C++
IAliasManager^ AddAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias

[Missing <param name="identityAlias"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.AddAlias(Genesyslab.Enterprise.Model.Identity.IAlias)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.AddAlias(Genesyslab.Enterprise.Model.Identity.IAlias)"]

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


ListAliases Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.ListAliases Method
IAliasManager Interface See Also Send Feedback
Returns the list of aliases asscoiated with the given identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAlias[] ListAliases(
    string name
)
Visual Basic (Declaration)
Function ListAliases ( _
    name As String _
) As IAlias()
Visual C++
array<IAlias^>^ ListAliases(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.ListAliases(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.ListAliases(System.String)"]

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


LookupByAlias Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.LookupByAlias Method
IAliasManager Interface See Also Send Feedback
Searches for an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity LookupByAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function LookupByAlias ( _
    identityAlias As IAlias _
) As IIdentity
Visual C++
IIdentity^ LookupByAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias

[Missing <param name="identityAlias"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.LookupByAlias(Genesyslab.Enterprise.Model.Identity.IAlias)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.LookupByAlias(Genesyslab.Enterprise.Model.Identity.IAlias)"]

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method
IAliasManager Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias.
RemoveAlias(String) | Removes an alias.

See Also

IAliasManager Interface
IAliasManager Members
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method (IAlias)

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method (IAlias)
IAliasManager Interface See Also Send Feedback
Removes an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAliasManager RemoveAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function RemoveAlias ( _
    identityAlias As IAlias _
) As IAliasManager
Visual C++
IAliasManager^ RemoveAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias

[Missing <param name="identityAlias"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.RemoveAlias(Genesyslab.Enterprise.Model.Identity.IAlias)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.RemoveAlias(Genesyslab.Enterprise.Model.Identity.IAlias)"]

See Also

IAliasManager Interface
RemoveAlias Overload
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method (String)
IAliasManager Interface See Also Send Feedback
Removes an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAliasManager RemoveAlias(
    string identityAlias
)
Visual Basic (Declaration)
Function RemoveAlias ( _
    identityAlias As String _
) As IAliasManager
Visual C++
IAliasManager^ RemoveAlias(
    String^ identityAlias
)

Parameters

identityAlias
Type: System..::.String

[Missing <param name="identityAlias"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.RemoveAlias(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IAliasManager.RemoveAlias(System.String)"]

See Also

IAliasManager Interface
RemoveAlias Overload
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Interface

[image]

Enterprise SDK 8.0 Reference API
ICredential Interface
Members See Also Send Feedback
Describes credentials.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ICredential
Visual Basic (Declaration)
Public Interface ICredential
Visual C++
public interface class ICredential

See Also

ICredential Members
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICredential Members
ICredential Interface Properties See Also Send Feedback

The ICredential type exposes the following members.

Properties

Name | Description
Password | Password.

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICredential Properties
ICredential Interface See Also Send Feedback

The ICredential type exposes the following members.

Properties

Name | Description
Password | Password.

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
ICredential..::.Password Property
ICredential Interface See Also Send Feedback
Password.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Password { get; set; }
Visual Basic (Declaration)
Property Password As String
Visual C++
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Interface

[image]

Enterprise SDK 8.0 Reference API
IEntity Interface
Members See Also Send Feedback
Describes a person as an entity (first name, last name, IDs) with associated business values.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEntity
Visual Basic (Declaration)
Public Interface IEntity
Visual C++
public interface class IEntity

See Also

IEntity Members
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEntity Members
IEntity Interface Properties See Also Send Feedback

The IEntity type exposes the following members.

Properties

Name | Description
Agent | Returns the agent IDs associated with this person.
Attributes | Entity attributes.
Email | Returns the person's e-mail.
EmployeeId | Returns the employee ID of this person.
ExternalUserId | Returns the external user ID.
FirstName | Returns the first name of this person.
FQName | Fully Qualified Name associated with the object instance.
IsAgent | Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.
IsEnabled | Returns true if this person is activated in the Configuration Layer.
LastName | Returns the last name of this person.
UserName | Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEntity Properties
IEntity Interface See Also Send Feedback

The IEntity type exposes the following members.

Properties

Name | Description
Agent | Returns the agent IDs associated with this person.
Attributes | Entity attributes.
Email | Returns the person's e-mail.
EmployeeId | Returns the employee ID of this person.
ExternalUserId | Returns the external user ID.
FirstName | Returns the first name of this person.
FQName | Fully Qualified Name associated with the object instance.
IsAgent | Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.
IsEnabled | Returns true if this person is activated in the Configuration Layer.
LastName | Returns the last name of this person.
UserName | Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Agent Property
IEntity Interface See Also Send Feedback
Returns the agent IDs associated with this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IIdentity> Agent { get; }
Visual Basic (Declaration)
ReadOnly Property Agent As ICollection(Of IIdentity)
Visual C++
property ICollection<IIdentity^>^ Agent {
    ICollection<IIdentity^>^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Attributes Property
IEntity Interface See Also Send Feedback
Entity attributes.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Email Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Email Property
IEntity Interface See Also Send Feedback
Returns the person's e-mail.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Email { get; }
Visual Basic (Declaration)
ReadOnly Property Email As String
Visual C++
property String^ Email {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


EmployeeId Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.EmployeeId Property
IEntity Interface See Also Send Feedback
Returns the employee ID of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string EmployeeId { get; }
Visual Basic (Declaration)
ReadOnly Property EmployeeId As String
Visual C++
property String^ EmployeeId {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


ExternalUserId Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.ExternalUserId Property
IEntity Interface See Also Send Feedback
Returns the external user ID.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ExternalUserId { get; }
Visual Basic (Declaration)
ReadOnly Property ExternalUserId As String
Visual C++
property String^ ExternalUserId {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.FirstName Property
IEntity Interface See Also Send Feedback
Returns the first name of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FirstName { get; }
Visual Basic (Declaration)
ReadOnly Property FirstName As String
Visual C++
property String^ FirstName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.FQName Property
IEntity Interface See Also Send Feedback
Fully Qualified Name associated with the object instance.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.IsAgent Property
IEntity Interface See Also Send Feedback
Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsAgent { get; }
Visual Basic (Declaration)
ReadOnly Property IsAgent As Boolean
Visual C++
property bool IsAgent {
    bool get ();
}

Return Value

bool

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IsEnabled Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.IsEnabled Property
IEntity Interface See Also Send Feedback
Returns true if this person is activated in the Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsEnabled { get; }
Visual Basic (Declaration)
ReadOnly Property IsEnabled As Boolean
Visual C++
property bool IsEnabled {
    bool get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.LastName Property
IEntity Interface See Also Send Feedback
Returns the last name of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string LastName { get; }
Visual Basic (Declaration)
ReadOnly Property LastName As String
Visual C++
property String^ LastName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.UserName Property
IEntity Interface See Also Send Feedback
Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string UserName { get; }
Visual Basic (Declaration)
ReadOnly Property UserName As String
Visual C++
property String^ UserName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentity Interface
Members See Also Send Feedback
Describes an identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIdentity : IRoleable,
    ISerializable
Visual Basic (Declaration)
Public Interface IIdentity _
    Implements IRoleable, ISerializable
Visual C++
public interface class IIdentity : IRoleable,
    ISerializable

See Also

IIdentity Members
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Members
IIdentity Interface Methods Properties See Also Send Feedback

The IIdentity type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity.
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device
FQName | Fully Qualified Name (Unique ID for this object).
Group | Groups of identities.
IdentityBase | Base identity (fro
Name | Identity name.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity.

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Methods
IIdentity Interface See Also Send Feedback

The IIdentity type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method
IIdentity Interface See Also Send Feedback

Overload List

Name | Description
Controller()()() |
Controller(String) |

See Also

IIdentity Interface
IIdentity Members
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method
IIdentity Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.Controller"]

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Controller()
Visual Basic (Declaration)
Function Controller As Object
Visual C++
Object^ Controller()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.Controller"]

See Also

IIdentity Interface
Controller Overload
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method (String)
IIdentity Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.Controller(System.String)"]

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Controller(
    string deviceName
)
Visual Basic (Declaration)
Function Controller ( _
    deviceName As String _
) As Object
Visual C++
Object^ Controller(
    String^ deviceName
)

Parameters

deviceName
Type: System..::.String

[Missing <param name="deviceName"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.Controller(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.Controller(System.String)"]

See Also

IIdentity Interface
Controller Overload
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Properties
IIdentity Interface See Also Send Feedback

The IIdentity type exposes the following members.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity.
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device
FQName | Fully Qualified Name (Unique ID for this object).
Group | Groups of identities.
IdentityBase | Base identity (fro
Name | Identity name.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity.

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Attributes Property
IIdentity Interface See Also Send Feedback
Dynamic and static data defined for this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Attributes {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Devices Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Devices Property
IIdentity Interface See Also Send Feedback
Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IDevice> Devices { get; }
Visual Basic (Declaration)
ReadOnly Property Devices As IDictionary(Of String, IDevice)
Visual C++
property IDictionary<String^, IDevice^>^ Devices {
    IDictionary<String^, IDevice^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.FQName Property
IIdentity Interface See Also Send Feedback
Fully Qualified Name (Unique ID for this object).

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Group Property
IIdentity Interface See Also Send Feedback
Groups of identities.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IIdentity> Group { get; }
Visual Basic (Declaration)
ReadOnly Property Group As IDictionary(Of String, IIdentity)
Visual C++
property IDictionary<String^, IIdentity^>^ Group {
    IDictionary<String^, IIdentity^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IdentityBase Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.IdentityBase Property
IIdentity Interface See Also Send Feedback
Base identity (fro

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity IdentityBase { get; }
Visual Basic (Declaration)
ReadOnly Property IdentityBase As IIdentity
Visual C++
property IIdentity^ IdentityBase {
    IIdentity^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Name Property
IIdentity Interface See Also Send Feedback
Identity name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Strategy Property
IIdentity Interface See Also Send Feedback
Strategies for this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityType Interface
Members See Also Send Feedback
Identity type.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIdentityType
Visual Basic (Declaration)
Public Interface IIdentityType
Visual C++
public interface class IIdentityType

See Also

IIdentityType Members
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityType Members
IIdentityType Interface Properties See Also Send Feedback

The IIdentityType type exposes the following members.

Properties

Name | Description
Name | Type name.

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityType Properties
IIdentityType Interface See Also Send Feedback

The IIdentityType type exposes the following members.

Properties

Name | Description
Name | Type name.

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IIdentityType..::.Name Property
IIdentityType Interface See Also Send Feedback
Type name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


WorkMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
WorkMode Enumeration
See Also Send Feedback
Describes the agent's workmode.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum WorkMode
Visual Basic (Declaration)
Public Enumeration WorkMode
Visual C++
public enum class WorkMode

Members

Member name | Description
Unknown | Unknown.
ManualIn | Manual in.
AutoIn | Auto in.
LegalGuard | Legar guard.
AfterCallWork | After call work.
AuxWork | Auxiliary work.
NoCallDisconnect | No call disconnect.
WalkAway | Walk away (absent).
ReturnBack | Return back.

See Also

Genesyslab.Enterprise.Model.Identity Namespace


Genesyslab.Enterprise.Model.Interaction Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Interaction Namespace
Send Feedback

Interfaces

Interface Description
IAttributeDataManager<(Of <(T>)>)
Manages attribute data.
IExtension
Describes the interaction's extension.
IIMEvent
Describes a new event during an instant messaging session.
IIMInteraction
Describes an Instant Messaging session.
IIMMessage
Represents a message during an Instant Messaging session.
IIMParty
Represents a party of the Instant Messaging session.
IIMPartyJoined
Occurs during an Instant Messaging session if a party joined.
IIMPartyLeft
Occurs during an Instant Messaging chat session if a party left.
IIMPartyReenter
Occurs during an Instant Messaging session if a party reentered.
IIMTranscript
Represents the update of the transcript in an Instant Messaging session.
IInteraction
Describes an interaction.
IInteractionType
Describes the interaction type:
  • Media content.
  • Media direction.
  • The interaction's subtype.
  • Internality.
IParty
Describes one party of a device or a call.
IPreviewInteraction
Describes a preview interaction.

Enumerations

Enumeration | Description
ContextStateType |
InteractionStateType | Lists the possible types for interactions state.
MakeCallType | Enumerates the possible call types for voice interactions.
MediaContentType | Enumerates the media content types.
PartyInfoType | Enumerates the party types.
PartyType | Lists the possible party types.
ProfileType | Enumerates the profile types.
ReasonTypes |
Visibility | Lists the possible values for the party's visibility.


ContextStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ContextStateType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.ContextStateType"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ContextStateType
Visual Basic (Declaration)
Public Enumeration ContextStateType
Visual C++
public enum class ContextStateType

Members

Member name | Description
Unknown |
Created |
Updated |
Merged |
Deleted |
Error |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Manages attribute data.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAttributeDataManager<T>
Visual Basic (Declaration)
Public Interface IAttributeDataManager(Of T)
Visual C++
generic<typename T>
public interface class IAttributeDataManager

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1"]

See Also

IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Members
IAttributeDataManager<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
AllValues | All the values.
ContainsKey | True if contains the given key.
GetAsPSDKCollection | Returns this manager's content as a Platform SDK collection.
GetElementAsBinary | Returns the element associated with the given key as a byte array.
GetElementAsCollection | Returns the element associated with the given key as a collection.
GetElementAsDynamicAttribute | Returns the element associated with the given key as a dynamic attribute.
GetElementAsInt | Returns the element associated with the given key as int.
GetElementAsObject | Returns the element associated with the given key as an object.
GetElementAsString | Returns the element associated with the given key as a string.
GetElementType | Returns the type for the element associated with the given key.
IsElementACollection | True if the value associated with the given key is a collection.
IsSynchronized | True if the manager is synchronized.
RemoveAll | Removes all the elements.
RemoveElement | Removes the element associated with the given key.
SetElement | Overloaded.

Properties

Name | Description
AllKeys | All the keys.
Item | Returns the value associated with the given key.
Owner | Returns the owner of this object.
Section | Returns the section name.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Methods
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
AllValues | All the values.
ContainsKey | True if contains the given key.
GetAsPSDKCollection | Returns this manager's content as a Platform SDK collection.
GetElementAsBinary | Returns the element associated with the given key as a byte array.
GetElementAsCollection | Returns the element associated with the given key as a collection.
GetElementAsDynamicAttribute | Returns the element associated with the given key as a dynamic attribute.
GetElementAsInt | Returns the element associated with the given key as int.
GetElementAsObject | Returns the element associated with the given key as an object.
GetElementAsString | Returns the element associated with the given key as a string.
GetElementType | Returns the type for the element associated with the given key.
IsElementACollection | True if the value associated with the given key is a collection.
IsSynchronized | True if the manager is synchronized.
RemoveAll | Removes all the elements.
RemoveElement | Removes the element associated with the given key.
SetElement | Overloaded.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AllValues Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AllValues Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
All the values.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T[] AllValues()
Visual Basic (Declaration)
Function AllValues As T()
Visual C++
array<T>^ AllValues()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.AllValues"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.ContainsKey Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if contains the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.ContainsKey(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.ContainsKey(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetAsPSDKCollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetAsPSDKCollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns this manager's content as a Platform SDK collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetAsPSDKCollection()
Visual Basic (Declaration)
Function GetAsPSDKCollection As KeyValueCollection
Visual C++
KeyValueCollection^ GetAsPSDKCollection()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetAsPSDKCollection"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsBinary Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a byte array.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
byte[] GetElementAsBinary(
    string key
)
Visual Basic (Declaration)
Function GetElementAsBinary ( _
    key As String _
) As Byte()
Visual C++
array<unsigned char>^ GetElementAsBinary(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsBinary(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsBinary(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsCollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsCollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> GetElementAsCollection(
    string key
)
Visual Basic (Declaration)
Function GetElementAsCollection ( _
    key As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ GetElementAsCollection(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsCollection(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsCollection(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a dynamic attribute.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T GetElementAsDynamicAttribute(
    string key
)
Visual Basic (Declaration)
Function GetElementAsDynamicAttribute ( _
    key As String _
) As T
Visual C++
T GetElementAsDynamicAttribute(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsDynamicAttribute(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsDynamicAttribute(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsInt Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsInt Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as int.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Nullable<int> GetElementAsInt(
    string key
)
Visual Basic (Declaration)
Function GetElementAsInt ( _
    key As String _
) As Nullable(Of Integer)
Visual C++
Nullable<int> GetElementAsInt(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsInt(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsObject Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsObject Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as an object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object GetElementAsObject(
    string key
)
Visual Basic (Declaration)
Function GetElementAsObject ( _
    key As String _
) As Object
Visual C++
Object^ GetElementAsObject(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsObject(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsObject(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsString Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsString Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a string.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string GetElementAsString(
    string key
)
Visual Basic (Declaration)
Function GetElementAsString ( _
    key As String _
) As String
Visual C++
String^ GetElementAsString(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsString(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementAsString(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementType Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementType Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the type for the element associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Type GetElementType(
    string key
)
Visual Basic (Declaration)
Function GetElementType ( _
    key As String _
) As Type
Visual C++
Type^ GetElementType(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementType(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.GetElementType(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the value associated with the given key is a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsElementACollection(
    string key
)
Visual Basic (Declaration)
Function IsElementACollection ( _
    key As String _
) As Boolean
Visual C++
bool IsElementACollection(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.IsElementACollection(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.IsElementACollection(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsSynchronized Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsSynchronized Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the manager is synchronized.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsSynchronized(
    string key
)
Visual Basic (Declaration)
Function IsSynchronized ( _
    key As String _
) As Boolean
Visual C++
bool IsSynchronized(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.IsSynchronized(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.IsSynchronized(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RemoveAll Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.RemoveAll Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Removes all the elements.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void RemoveAll()
Visual Basic (Declaration)
Sub RemoveAll
Visual C++
void RemoveAll()

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RemoveElement Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.RemoveElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Removes the element associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool RemoveElement(
    string key
)
Visual Basic (Declaration)
Function RemoveElement ( _
    key As String _
) As Boolean
Visual C++
bool RemoveElement(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.RemoveElement(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.RemoveElement(System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
SetElement(T) | Sets an element.
SetElement(String, IAttributeDataManager<(Of <(T>)>)) | Sets an element.
SetElement(String, array<Byte>[]()[]) | Sets an element.
SetElement(String, Int32) | Sets an element.
SetElement(String, Object) | Sets an element.
SetElement(String, String) | Sets an element.
SetElement(String, array<Byte>[]()[], String, String) | Sets an element.
SetElement(String, Object, String, String) | Sets an element.
SetElement(String, String, String, String) | Sets an element.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (T)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (T)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    T value
)
Visual Basic (Declaration)
Function SetElement ( _
    value As T _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    T value
)

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(`0)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    IAttributeDataManager<T> value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    IAttributeDataManager<T>^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{`0})"]

value
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager{`0})"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, array<Byte>[]()[])
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Byte() _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    array<unsigned char>^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[])"]

value
Type: array< System..::.Byte >[]()[]

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[])"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    int value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Integer _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    int value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Int32)"]

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Int32)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Object)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Object _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    string value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String)"]

value
Type: System..::.String

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Byte[], String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, array<Byte>[]()[], String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    byte[] value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Byte(), _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    array<unsigned char>^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[],System.String,System.String)"]

value
Type: array< System..::.Byte >[]()[]

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[],System.String,System.String)"]

contentType
Type: System..::.String

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[],System.String,System.String)"]

contentTypeVersion
Type: System..::.String

[Missing <param name="contentTypeVersion"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[],System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Byte[],System.String,System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Object, String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Object, String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    Object value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Object, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    Object^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object,System.String,System.String)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object,System.String,System.String)"]

contentType
Type: System..::.String

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object,System.String,System.String)"]

contentTypeVersion
Type: System..::.String

[Missing <param name="contentTypeVersion"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object,System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.Object,System.String,System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, String, String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    string value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As String, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    String^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String,System.String,System.String)"]

value
Type: System..::.String

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String,System.String,System.String)"]

contentType
Type: System..::.String

[Missing <param name="contentType"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String,System.String,System.String)"]

contentTypeVersion
Type: System..::.String

[Missing <param name="contentTypeVersion"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String,System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IAttributeDataManager`1.SetElement(System.String,System.String,System.String,System.String)"]

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Properties
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
AllKeys | All the keys.
Item | Returns the value associated with the given key.
Owner | Returns the owner of this object.
Section | Returns the section name.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AllKeys Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
All the keys.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string[] AllKeys { get; }
Visual Basic (Declaration)
ReadOnly Property AllKeys As String()
Visual C++
property array<String^>^ AllKeys {
    array<String^>^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As T
Visual C++
property T default[String^ key] {
    T get (String^ key);
}

Parameters

key
Type: System..::.String

Return Value

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Owner Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the owner of this object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As Object
Visual C++
property Object^ Owner {
    Object^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Section Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Section Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the section name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Section { get; }
Visual Basic (Declaration)
ReadOnly Property Section As String
Visual C++
property String^ Section {
    String^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Interface

[image]

Enterprise SDK 8.0 Reference API
IExtension Interface
Members See Also Send Feedback
Describes the interaction's extension.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

See Also

IExtension Members
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
IExtension Members
IExtension Interface Properties See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Attributes | Content of the extension (dynamic attributes).
Description | Description of the extension's content.
Name | Extension name.

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Attributes | Content of the extension (dynamic attributes).
Description | Description of the extension's content.
Name | Extension name.

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Attributes Property
IExtension Interface See Also Send Feedback
Content of the extension (dynamic attributes).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Description Property
IExtension Interface See Also Send Feedback
Description of the extension's content.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Name Property
IExtension Interface See Also Send Feedback
Extension name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Interface

[image]

Enterprise SDK 8.0 Reference API
IIMEvent Interface
Members See Also Send Feedback
Describes a new event during an instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMEvent
Visual Basic (Declaration)
Public Interface IIMEvent
Visual C++
public interface class IIMEvent

See Also

IIMEvent Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Members
IIMEvent Interface Properties See Also Send Feedback

The IIMEvent type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event.
Party | Returns the party of this IM event

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Properties
IIMEvent Interface See Also Send Feedback

The IIMEvent type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event.
Party | Returns the party of this IM event

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Date Property

[image]

Enterprise SDK 8.0 Reference API
IIMEvent..::.Date Property
IIMEvent Interface See Also Send Feedback
Returns the date of this IM event.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DateTime Date { get; }
Visual Basic (Declaration)
ReadOnly Property Date As DateTime
Visual C++
property DateTime Date {
    DateTime get ();
}

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Party Property

[image]

Enterprise SDK 8.0 Reference API
IIMEvent..::.Party Property
IIMEvent Interface See Also Send Feedback
Returns the party of this IM event

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIMParty Party { get; }
Visual Basic (Declaration)
ReadOnly Property Party As IIMParty
Visual C++
property IIMParty^ Party {
    IIMParty^ get ();
}

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction Interface
Members See Also Send Feedback
Describes an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMInteraction : IInteraction,
    ISerializable
Visual Basic (Declaration)
Public Interface IIMInteraction _
    Implements IInteraction, ISerializable
Visual C++
public interface class IIMInteraction : IInteraction,
    ISerializable

See Also

IIMInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Members
IIMInteraction Interface Methods Properties See Also Send Feedback

The IIMInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)

Properties

Name Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
IMEvent
Returns the events of the instant messaging session.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue
Queues associated with the interaction.
(Inherited from IInteraction.)
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Methods
IIMInteraction Interface See Also Send Feedback

The IIMInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Properties
IIMInteraction Interface See Also Send Feedback

The IIMInteraction type exposes the following members.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
IMEvent
Returns the events of the instant messaging session.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue
Queues associated with the interaction.
(Inherited from IInteraction.)
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMEvent Property

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction..::.IMEvent Property
IIMInteraction Interface See Also Send Feedback
Returns the events of the instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IIMEvent> IMEvent { get; }
Visual Basic (Declaration)
ReadOnly Property IMEvent As ICollection(Of IIMEvent)
Visual C++
property ICollection<IIMEvent^>^ IMEvent {
    ICollection<IIMEvent^>^ get ();
}

Return Value

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Interface

[image]

Enterprise SDK 8.0 Reference API
IIMMessage Interface
Members See Also Send Feedback
Represents a message during an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMMessage : IIMEvent
Visual Basic (Declaration)
Public Interface IIMMessage _
    Implements IIMEvent
Visual C++
public interface class IIMMessage : IIMEvent

See Also

IIMMessage Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Members
IIMMessage Interface Properties See Also Send Feedback

The IIMMessage type exposes the following members.

Properties

Name Description
Content
Returns the text of this message.
ContentType
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".
Date
Returns the date of this IM event.
(Inherited from IIMEvent.)
Party
Returns the party of this IM event
(Inherited from IIMEvent.)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Properties
IIMMessage Interface See Also Send Feedback

The IIMMessage type exposes the following members.

Properties

Name Description
Content
Returns the text of this message.
ContentType
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".
Date
Returns the date of this IM event.
(Inherited from IIMEvent.)
Party
Returns the party of this IM event
(Inherited from IIMEvent.)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Content Property

[image]

Enterprise SDK 8.0 Reference API
IIMMessage..::.Content Property
IIMMessage Interface See Also Send Feedback
Returns the text of this message.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Content { get; }
Visual Basic (Declaration)
ReadOnly Property Content As String
Visual C++
property String^ Content {
    String^ get ();
}

Return Value

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContentType Property

[image]

Enterprise SDK 8.0 Reference API
IIMMessage..::.ContentType Property
IIMMessage Interface See Also Send Feedback
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ContentType { get; }
Visual Basic (Declaration)
ReadOnly Property ContentType As String
Visual C++
property String^ ContentType {
    String^ get ();
}

Return Value

"text/plain" or "text/html"

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Interface

[image]

Enterprise SDK 8.0 Reference API
IIMParty Interface
Members See Also Send Feedback
Represents a party of the Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMParty
Visual Basic (Declaration)
Public Interface IIMParty
Visual C++
public interface class IIMParty

See Also

IIMParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Members
IIMParty Interface Properties See Also Send Feedback

The IIMParty type exposes the following members.

Properties

Name | Description
Nickname | Returns the nickname of this party.
Type | Returns the type of this party.
Visibility | Returns the visibility of this party.

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Properties
IIMParty Interface See Also Send Feedback

The IIMParty type exposes the following members.

Properties

Name | Description
Nickname | Returns the nickname of this party.
Type | Returns the type of this party.
Visibility | Returns the visibility of this party.

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Nickname Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Nickname Property
IIMParty Interface See Also Send Feedback
Returns the nickname of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Nickname { get; }
Visual Basic (Declaration)
ReadOnly Property Nickname As String
Visual C++
property String^ Nickname {
    String^ get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Type Property
IIMParty Interface See Also Send Feedback
Returns the type of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
PartyType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As PartyType
Visual C++
property PartyType Type {
    PartyType get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Visibility Property
IIMParty Interface See Also Send Feedback
Returns the visibility of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Visibility Visibility { get; }
Visual Basic (Declaration)
ReadOnly Property Visibility As Visibility
Visual C++
property Visibility Visibility {
    Visibility get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party joined.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMPartyJoined : IIMEvent
Visual Basic (Declaration)
Public Interface IIMPartyJoined _
    Implements IIMEvent
Visual C++
public interface class IIMPartyJoined : IIMEvent

See Also

IIMPartyJoined Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Members
IIMPartyJoined Interface Properties See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Properties
IIMPartyJoined Interface See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Interface
Members See Also Send Feedback
Occurs during an Instant Messaging chat session if a party left.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMPartyLeft : IIMEvent
Visual Basic (Declaration)
Public Interface IIMPartyLeft _
    Implements IIMEvent
Visual C++
public interface class IIMPartyLeft : IIMEvent

See Also

IIMPartyLeft Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Members
IIMPartyLeft Interface Properties See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Properties
IIMPartyLeft Interface See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party reentered.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMPartyReenter : IIMEvent
Visual Basic (Declaration)
Public Interface IIMPartyReenter _
    Implements IIMEvent
Visual C++
public interface class IIMPartyReenter : IIMEvent

See Also

IIMPartyReenter Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Members
IIMPartyReenter Interface Properties See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Properties
IIMPartyReenter Interface See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Interface

[image]

Enterprise SDK 8.0 Reference API
IIMTranscript Interface
Members See Also Send Feedback
Represents the update of the transcript in an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMTranscript : IIMEvent
Visual Basic (Declaration)
Public Interface IIMTranscript _
    Implements IIMEvent
Visual C++
public interface class IIMTranscript : IIMEvent

See Also

IIMTranscript Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMTranscript Members
IIMTranscript Interface Properties See Also Send Feedback

The IIMTranscript type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)
Transcript | Returns the updated transcript of this IM chat session as a Collection of IIMEvent.

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMTranscript Properties
IIMTranscript Interface See Also Send Feedback

The IIMTranscript type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)
Transcript | Returns the updated transcript of this IM chat session as a Collection of IIMEvent.

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Transcript Property

[image]

Enterprise SDK 8.0 Reference API
IIMTranscript..::.Transcript Property
IIMTranscript Interface See Also Send Feedback
Returns the updated transcript of this IM chat session as a Collection of IIMEvent.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IIMEvent> Transcript { get; }
Visual Basic (Declaration)
ReadOnly Property Transcript As ICollection(Of IIMEvent)
Visual C++
property ICollection<IIMEvent^>^ Transcript {
    ICollection<IIMEvent^>^ get ();
}

Return Value

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IInteraction Interface
Members See Also Send Feedback
Describes an interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IInteraction : ISerializable
Visual Basic (Declaration)
Public Interface IInteraction _
    Implements ISerializable
Visual C++
public interface class IInteraction : ISerializable

See Also

IInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Members
IInteraction Interface Methods Properties See Also Send Feedback

The IInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
ActiveChannel
Returns the active channel.
Channels
Returns the channels associated with this interaction.
Controller
Controller.
Customer
Returns the customer party.
Data
Returns the data associated with the interaction.
EndDate
Interaction end data. Same as server end date.
FQName
Returns the interaction's Fully Qualified Name (unique Id).
Id
Returns the interaction's identifier.
IdType
Returns the interaction type.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
Originator
Returns the originting party when interaction is transfered
Owner
Returns the party who owns this interaction.
Parties
Returns all the parties involved wihtin the interaction.
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
Queue
Queues associated with the interaction.
RelatedId
Returns the related interaction IDs.
StartDate
Interaction start data. Same as the server date.
State
Returns the interaction status.
Strategy
Returns the strategies associated with the interaction.
Target
Returns the target party when interaction is transfered

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Methods
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible.

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsDone Method

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IsDone Method
IInteraction Interface See Also Send Feedback
Returns true if the interaction is disabled. When done, further state changes are impossible.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsDone()
Visual Basic (Declaration)
Function IsDone As Boolean
Visual C++
bool IsDone()

Return Value

bool

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Properties
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
ActiveChannel
Returns the active channel.
Channels
Returns the channels associated with this interaction.
Controller
Controller.
Customer
Returns the customer party.
Data
Returns the data associated with the interaction.
EndDate
Interaction end data. Same as server end date.
FQName
Returns the interaction's Fully Qualified Name (unique Id).
Id
Returns the interaction's identifier.
IdType
Returns the interaction type.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
Originator
Returns the originting party when interaction is transfered
Owner
Returns the party who owns this interaction.
Parties
Returns all the parties involved wihtin the interaction.
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
Queue
Queues associated with the interaction.
RelatedId
Returns the related interaction IDs.
StartDate
Interaction start data. Same as the server date.
State
Returns the interaction status.
Strategy
Returns the strategies associated with the interaction.
Target
Returns the target party when interaction is transfered

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActionsTransitions Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.ActionsTransitions Property
IInteraction Interface See Also Send Feedback
Get IsPossible feature

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool[] ActionsTransitions { get; }
Visual Basic (Declaration)
ReadOnly Property ActionsTransitions As Boolean()
Visual C++
property array<bool>^ ActionsTransitions {
    array<bool>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActiveChannel Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.ActiveChannel Property
IInteraction Interface See Also Send Feedback
Returns the active channel.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel ActiveChannel { get; set; }
Visual Basic (Declaration)
Property ActiveChannel As IClientChannel
Visual C++
property IClientChannel^ ActiveChannel {
    IClientChannel^ get ();
    void set (IClientChannel^ value);
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Channels Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Channels Property
IInteraction Interface See Also Send Feedback
Returns the channels associated with this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IClientChannel> Channels { get; }
Visual Basic (Declaration)
ReadOnly Property Channels As IDictionary(Of String, IClientChannel)
Visual C++
property IDictionary<String^, IClientChannel^>^ Channels {
    IDictionary<String^, IClientChannel^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Controller Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Controller Property
IInteraction Interface See Also Send Feedback
Controller.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Controller { get; }
Visual Basic (Declaration)
ReadOnly Property Controller As Object
Visual C++
property Object^ Controller {
    Object^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Customer Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Customer Property
IInteraction Interface See Also Send Feedback
Returns the customer party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IParty Customer { get; }
Visual Basic (Declaration)
ReadOnly Property Customer As IParty
Visual C++
property IParty^ Customer {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Data Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Data Property
IInteraction Interface See Also Send Feedback
Returns the data associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Data {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


EndDate Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.EndDate Property
IInteraction Interface See Also Send Feedback
Interaction end data. Same as server end date.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DateTime EndDate { get; }
Visual Basic (Declaration)
ReadOnly Property EndDate As DateTime
Visual C++
property DateTime EndDate {
    DateTime get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.FQName Property
IInteraction Interface See Also Send Feedback
Returns the interaction's Fully Qualified Name (unique Id).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Id Property
IInteraction Interface See Also Send Feedback
Returns the interaction's identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IdType Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IdType Property
IInteraction Interface See Also Send Feedback
Returns the interaction type.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteractionType IdType { get; }
Visual Basic (Declaration)
ReadOnly Property IdType As IInteractionType
Visual C++
property IInteractionType^ IdType {
    IInteractionType^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Item Property
IInteraction Interface See Also Send Feedback
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object this[
    string name
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As Object
Visual C++
property Object^ default[String^ name] {
    Object^ get (String^ name);
}

Parameters

name
Type: System..::.String

Return Value

object

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Originator Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Originator Property
IInteraction Interface See Also Send Feedback
Returns the originting party when interaction is transfered

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IParty Originator { get; }
Visual Basic (Declaration)
ReadOnly Property Originator As IParty
Visual C++
property IParty^ Originator {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Owner Property
IInteraction Interface See Also Send Feedback
Returns the party who owns this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IParty Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As IParty
Visual C++
property IParty^ Owner {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Parties Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Parties Property
IInteraction Interface See Also Send Feedback
Returns all the parties involved wihtin the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IParty[] Parties { get; }
Visual Basic (Declaration)
ReadOnly Property Parties As IParty()
Visual C++
property array<IParty^>^ Parties {
    array<IParty^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Profile Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Profile Property
IInteraction Interface See Also Send Feedback
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ProfileType Profile { get; }
Visual Basic (Declaration)
ReadOnly Property Profile As ProfileType
Visual C++
property ProfileType Profile {
    ProfileType get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Queue Property
IInteraction Interface See Also Send Feedback
Queues associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string[] Queue { get; }
Visual Basic (Declaration)
ReadOnly Property Queue As String()
Visual C++
property array<String^>^ Queue {
    array<String^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RelatedId Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.RelatedId Property
IInteraction Interface See Also Send Feedback
Returns the related interaction IDs.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string[] RelatedId { get; }
Visual Basic (Declaration)
ReadOnly Property RelatedId As String()
Visual C++
property array<String^>^ RelatedId {
    array<String^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.StartDate Property
IInteraction Interface See Also Send Feedback
Interaction start data. Same as the server date.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
DateTime StartDate { get; }
Visual Basic (Declaration)
ReadOnly Property StartDate As DateTime
Visual C++
property DateTime StartDate {
    DateTime get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.State Property
IInteraction Interface See Also Send Feedback
Returns the interaction status.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
InteractionStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As InteractionStateType
Visual C++
property InteractionStateType State {
    InteractionStateType get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Strategy Property
IInteraction Interface See Also Send Feedback
Returns the strategies associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Target Property
IInteraction Interface See Also Send Feedback
Returns the target party when interaction is transfered

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IParty Target { get; }
Visual Basic (Declaration)
ReadOnly Property Target As IParty
Visual C++
property IParty^ Target {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionType Interface
Members See Also Send Feedback
Describes the interaction type:
  • Media content.
  • Media direction.
  • The interaction's subtype.
  • Internality.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IInteractionType
Visual Basic (Declaration)
Public Interface IInteractionType
Visual C++
public interface class IInteractionType

See Also

IInteractionType Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Members
IInteractionType Interface Properties See Also Send Feedback

The IInteractionType type exposes the following members.

Properties

Name | Description
Direction | Media direction.
Internal | True if the interaction is internal. False if interaction is external Null is interaction type is not known
MediaType | Type for the media content.
Subtype | Interaction subtype (string).

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Properties
IInteractionType Interface See Also Send Feedback

The IInteractionType type exposes the following members.

Properties

Name | Description
Direction | Media direction.
Internal | True if the interaction is internal. False if interaction is external Null is interaction type is not known
MediaType | Type for the media content.
Subtype | Interaction subtype (string).

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Direction Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Direction Property
IInteractionType Interface See Also Send Feedback
Media direction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MediaDirectionType Direction { get; }
Visual Basic (Declaration)
ReadOnly Property Direction As MediaDirectionType
Visual C++
property MediaDirectionType Direction {
    MediaDirectionType get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Internal Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Internal Property
IInteractionType Interface See Also Send Feedback
True if the interaction is internal. False if interaction is external Null is interaction type is not known

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Nullable<bool> Internal { get; }
Visual Basic (Declaration)
ReadOnly Property Internal As Nullable(Of Boolean)
Visual C++
property Nullable<bool> Internal {
    Nullable<bool> get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.MediaType Property
IInteractionType Interface See Also Send Feedback
Type for the media content.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MediaContentType MediaType { get; }
Visual Basic (Declaration)
ReadOnly Property MediaType As MediaContentType
Visual C++
property MediaContentType MediaType {
    MediaContentType get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Subtype Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Subtype Property
IInteractionType Interface See Also Send Feedback
Interaction subtype (string).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Subtype { get; }
Visual Basic (Declaration)
ReadOnly Property Subtype As String
Visual C++
property String^ Subtype {
    String^ get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
InteractionStateType Enumeration
See Also Send Feedback
Lists the possible types for interactions state.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum InteractionStateType
Visual Basic (Declaration)
Public Enumeration InteractionStateType
Visual C++
public enum class InteractionStateType

Members

Member name | Description
Unknown |
PresentedIn |
PresentedOut |
Connected |
Held |
Ended |
Dropped |
Queued |
Abandonned |
Redirected |
HeldPresentedIn |
HeldPresentedOut |
Preview |
Busy |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


IParty Interface

[image]

Enterprise SDK 8.0 Reference API
IParty Interface
Members See Also Send Feedback
Describes one party of a device or a call.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IParty : IRoleable
Visual Basic (Declaration)
Public Interface IParty _
    Implements IRoleable
Visual C++
public interface class IParty : IRoleable

See Also

IParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Members
IParty Interface Properties See Also Send Feedback

The IParty type exposes the following members.

Properties

Name | Description
Attributes | Dynamic/static data of the party.
Context | Context of the party.
Device | Linked devices to the party.
DisplayName | Name displayed to the user
Extensions | Extensions of the party instance.
Interaction | Linked interaction to the party.
IsMonitored | True if the party is monitored.
IsOwner | True if this party is the interaction's owner.
Name | Name of the party.
PartyType | Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.
Role | Overloaded.

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Properties
IParty Interface See Also Send Feedback

The IParty type exposes the following members.

Properties

Name | Description
Attributes | Dynamic/static data of the party.
Context | Context of the party.
Device | Linked devices to the party.
DisplayName | Name displayed to the user
Extensions | Extensions of the party instance.
Interaction | Linked interaction to the party.
IsMonitored | True if the party is monitored.
IsOwner | True if this party is the interaction's owner.
Name | Name of the party.
PartyType | Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.
Role | Overloaded.

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Attributes Property
IParty Interface See Also Send Feedback
Dynamic/static data of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Context Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Context Property
IParty Interface See Also Send Feedback
Context of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IContext Context { get; }
Visual Basic (Declaration)
ReadOnly Property Context As IContext
Visual C++
property IContext^ Context {
    IContext^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Device Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Device Property
IParty Interface See Also Send Feedback
Linked devices to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] Device { get; }
Visual Basic (Declaration)
ReadOnly Property Device As IDevice()
Visual C++
property array<IDevice^>^ Device {
    array<IDevice^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.DisplayName Property
IParty Interface See Also Send Feedback
Name displayed to the user

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string DisplayName { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayName As String
Visual C++
property String^ DisplayName {
    String^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Extensions Property
IParty Interface See Also Send Feedback
Extensions of the party instance.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IExtension> Extensions { get; }
Visual Basic (Declaration)
ReadOnly Property Extensions As IDictionary(Of String, IExtension)
Visual C++
property IDictionary<String^, IExtension^>^ Extensions {
    IDictionary<String^, IExtension^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Interaction Property
IParty Interface See Also Send Feedback
Linked interaction to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction Interaction { get; }
Visual Basic (Declaration)
ReadOnly Property Interaction As IInteraction
Visual C++
property IInteraction^ Interaction {
    IInteraction^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsMonitored Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsMonitored Property
IParty Interface See Also Send Feedback
True if the party is monitored.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsMonitored { get; }
Visual Basic (Declaration)
ReadOnly Property IsMonitored As Boolean
Visual C++
property bool IsMonitored {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsOwner Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsOwner Property
IParty Interface See Also Send Feedback
True if this party is the interaction's owner.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsOwner { get; }
Visual Basic (Declaration)
ReadOnly Property IsOwner As Boolean
Visual C++
property bool IsOwner {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Name Property
IParty Interface See Also Send Feedback
Name of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PartyType Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.PartyType Property
IParty Interface See Also Send Feedback
Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
PartyInfoType PartyType { get; }
Visual Basic (Declaration)
ReadOnly Property PartyType As PartyInfoType
Visual C++
property PartyInfoType PartyType {
    PartyInfoType get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Role Property

[image] [image]

Enterprise SDK 8.0 Reference API
IParty..::.Role Property
IParty Interface See Also Send Feedback

Overload List

Name | Description
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Role | Roles assigned to the party.

See Also

IParty Interface
IParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


Role Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Role Property
IParty Interface See Also Send Feedback
Roles assigned to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRole Role { get; }
Visual Basic (Declaration)
ReadOnly Property Role As IRole
Visual C++
property IRole^ Role {
    IRole^ get ();
}

Implements

IRoleable..::.Role

See Also

IParty Interface
Role Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Interface
Members See Also Send Feedback
Describes a preview interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPreviewInteraction : ISerializable
Visual Basic (Declaration)
Public Interface IPreviewInteraction _
    Implements ISerializable
Visual C++
public interface class IPreviewInteraction : ISerializable

See Also

IPreviewInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Members
IPreviewInteraction Interface Methods See Also Send Feedback

The IPreviewInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Methods
IPreviewInteraction Interface See Also Send Feedback

The IPreviewInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MakeCallType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MakeCallType Enumeration
See Also Send Feedback
Enumerates the possible call types for voice interactions.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum MakeCallType
Visual Basic (Declaration)
Public Enumeration MakeCallType
Visual C++
public enum class MakeCallType

Members

Member name | Description
Regular |
DirectAgent |
SupervisorAssist |
Priority |
DirectPriority |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


MediaContentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaContentType Enumeration
See Also Send Feedback
Enumerates the media content types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum MediaContentType
Visual Basic (Declaration)
Public Enumeration MediaContentType
Visual C++
public enum class MediaContentType

Members

Member name | Description
MediaVoice |
MediaChat |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


PartyInfoType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyInfoType Enumeration
See Also Send Feedback
Enumerates the party types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum PartyInfoType
Visual Basic (Declaration)
Public Enumeration PartyInfoType
Visual C++
public enum class PartyInfoType

Members

Member name | Description
Unknown |
Caller |
Callee |
ConferenceMember |
ConferenceMaster |
Supervisor |
Originator |
Target |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


PartyType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyType Enumeration
See Also Send Feedback
Lists the possible party types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum PartyType
Visual Basic (Declaration)
Public Enumeration PartyType
Visual C++
public enum class PartyType

Members

Member name | Description
Unknown | Constant for unknown type.
Client | Constant for client type.
Agent | Constant for agent type.
Supervisor | Constant for supervisor type.
External | Constant for external type.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ProfileType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProfileType Enumeration
See Also Send Feedback
Enumerates the profile types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ProfileType
Visual Basic (Declaration)
Public Enumeration ProfileType
Visual C++
public enum class ProfileType

Members

Member name | Description
Unknown |
Primary |
PrimaryInConf |
Transfered |
TransferedInConf |
Consult |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ReasonTypes Enumeration

[image]

Enterprise SDK 8.0 Reference API
ReasonTypes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.ReasonTypes"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[FlagsAttribute]
public enum ReasonTypes
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ReasonTypes
Visual C++
[FlagsAttribute]
public enum class ReasonTypes

Members

Member name | Description
None |
ObjectState |
ObjectComposition |
ObjectSubscriber |
ObjectListener |
ObjectContainer |
ObjectForwardMode |
ObjectDndMode |
ObjectAttribute |
StrategyAttribute |
ContextAttribute |
CapableAttribute |
AliasAttribute |
RoleAttribute |
MediaProtocolAttribute |
ConfigurableAttribute |
FilterAttribute |
ControllerAttribute |
CredentialAttribute |
ExtensionAttribute |
PartyAttribute |
SubscriberAttribute |
CustomDataAttribute |
SubSystem |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


Visibility Enumeration

[image]

Enterprise SDK 8.0 Reference API
Visibility Enumeration
See Also Send Feedback
Lists the possible values for the party's visibility.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum Visibility
Visual Basic (Declaration)
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Unknown | Constant for unknown visibility.
All | Constant for all visibility (conference).
Int | Constant for internal visibility (coaching).
Vip | Constant for secrete intrusion visibility (monitor).

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


Genesyslab.Enterprise.Model.Protocol Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Protocol Namespace
Send Feedback

Interfaces

Interface | Description
IEnterpriseProtocol | Interface for handling Media protocol.
IParam | Interface for managing protocol parameters.
IProtocolRequest | Interface for managing protocol.
ISwitchPolicy<(Of <(T>)>) | Interface for managing the switch policy.

Enumerations

Enumeration | Description
MediaDirectionType | Enumerates the media direction types.
MediaType | Enumerates for the media types.
SwitchModelType | Enumerates the switch model types.


IEnterpriseProtocol Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Interface
Members See Also Send Feedback
Interface for handling Media protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEnterpriseProtocol
Visual Basic (Declaration)
Public Interface IEnterpriseProtocol
Visual C++
public interface class IEnterpriseProtocol

See Also

IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Members
IEnterpriseProtocol Interface Methods Properties See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Methods

Name | Description
Add | Overloaded.
GetProtocolRequest | Overloaded.
Remove | Removes a protocol.

Properties

Name | Description
ListProtocols | Gets the list of media protocols.
MediaSupport | Gets the media type of the protocol.
Name | Gets the name of the protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Methods
IEnterpriseProtocol Interface See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Methods

Name | Description
Add | Overloaded.
GetProtocolRequest | Overloaded.
Remove | Removes a protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method
IEnterpriseProtocol Interface See Also Send Feedback

Overload List

Name | Description
Add(IProtocolRequest) | Adds a protocol.
Add(IEnumerable<(Of <(IProtocolRequest>)>)) | Adds a list of protocols.

See Also

IEnterpriseProtocol Interface
IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method (IProtocolRequest)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method (IProtocolRequest)
IEnterpriseProtocol Interface See Also Send Feedback
Adds a protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseProtocol Add(
    IProtocolRequest protocol
)
Visual Basic (Declaration)
Function Add ( _
    protocol As IProtocolRequest _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Add(
    IProtocolRequest^ protocol
)

Parameters

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IProtocolRequest

[Missing <param name="protocol"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.Add(Genesyslab.Enterprise.Model.Protocol.IProtocolRequest)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.Add(Genesyslab.Enterprise.Model.Protocol.IProtocolRequest)"]

See Also

IEnterpriseProtocol Interface
Add Overload
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method (IEnumerable(IProtocolRequest))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method (IEnumerable<(Of <(IProtocolRequest>)>))
IEnterpriseProtocol Interface See Also Send Feedback
Adds a list of protocols.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseProtocol Add(
    IEnumerable<IProtocolRequest> protocols
)
Visual Basic (Declaration)
Function Add ( _
    protocols As IEnumerable(Of IProtocolRequest) _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Add(
    IEnumerable<IProtocolRequest^>^ protocols
)

Parameters

protocols
Type: System.Collections.Generic..::.IEnumerable <(Of <( IProtocolRequest >)>)

[Missing <param name="protocols"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.Add(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Protocol.IProtocolRequest})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.Add(System.Collections.Generic.IEnumerable{Genesyslab.Enterprise.Model.Protocol.IProtocolRequest})"]

See Also

IEnterpriseProtocol Interface
Add Overload
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method
IEnterpriseProtocol Interface See Also Send Feedback

Overload List

Name | Description
GetProtocolRequest(String) | Gets a protocol by its name.
GetProtocolRequest(String, Boolean) | Gets a protocol by name and switch abstraction flag.

See Also

IEnterpriseProtocol Interface
IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method (String)
IEnterpriseProtocol Interface See Also Send Feedback
Gets a protocol by its name.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest GetProtocolRequest(
    string name
)
Visual Basic (Declaration)
Function GetProtocolRequest ( _
    name As String _
) As IProtocolRequest
Visual C++
IProtocolRequest^ GetProtocolRequest(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.GetProtocolRequest(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.GetProtocolRequest(System.String)"]

See Also

IEnterpriseProtocol Interface
GetProtocolRequest Overload
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method (String, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method (String, Boolean)
IEnterpriseProtocol Interface See Also Send Feedback
Gets a protocol by name and switch abstraction flag.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest GetProtocolRequest(
    string name,
    bool enableSwitchAbstraction
)
Visual Basic (Declaration)
Function GetProtocolRequest ( _
    name As String, _
    enableSwitchAbstraction As Boolean _
) As IProtocolRequest
Visual C++
IProtocolRequest^ GetProtocolRequest(
    String^ name,
    bool enableSwitchAbstraction
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.GetProtocolRequest(System.String,System.Boolean)"]

enableSwitchAbstraction
Type: System..::.Boolean

[Missing <param name="enableSwitchAbstraction"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.GetProtocolRequest(System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.GetProtocolRequest(System.String,System.Boolean)"]

See Also

IEnterpriseProtocol Interface
GetProtocolRequest Overload
Genesyslab.Enterprise.Model.Protocol Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Remove Method
IEnterpriseProtocol Interface See Also Send Feedback
Removes a protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseProtocol Remove(
    IProtocolRequest protocol
)
Visual Basic (Declaration)
Function Remove ( _
    protocol As IProtocolRequest _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Remove(
    IProtocolRequest^ protocol
)

Parameters

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IProtocolRequest

[Missing <param name="protocol"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.Remove(Genesyslab.Enterprise.Model.Protocol.IProtocolRequest)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IEnterpriseProtocol.Remove(Genesyslab.Enterprise.Model.Protocol.IProtocolRequest)"]

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Properties
IEnterpriseProtocol Interface See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Properties

Name | Description
ListProtocols | Gets the list of media protocols.
MediaSupport | Gets the media type of the protocol.
Name | Gets the name of the protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ListProtocols Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.ListProtocols Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the list of media protocols.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IProtocolRequest> ListProtocols { get; }
Visual Basic (Declaration)
ReadOnly Property ListProtocols As ICollection(Of IProtocolRequest)
Visual C++
property ICollection<IProtocolRequest^>^ ListProtocols {
    ICollection<IProtocolRequest^>^ get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


MediaSupport Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.MediaSupport Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the media type of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MediaType MediaSupport { get; }
Visual Basic (Declaration)
ReadOnly Property MediaSupport As MediaType
Visual C++
property MediaType MediaSupport {
    MediaType get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Name Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the name of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Interface

[image]

Enterprise SDK 8.0 Reference API
IParam Interface
Members See Also Send Feedback
Interface for managing protocol parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IParam
Visual Basic (Declaration)
Public Interface IParam
Visual C++
public interface class IParam

See Also

IParam Members
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Members

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Members
IParam Interface Methods Properties See Also Send Feedback

The IParam type exposes the following members.

Methods

Name | Description
Get | Gets the object.
ParamType | Gets the type of parameter.
Set | Sets an object as parameter.

Properties

Name | Description
Name | Gets the name of the parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Methods
IParam Interface See Also Send Feedback

The IParam type exposes the following members.

Methods

Name | Description
Get | Gets the object.
ParamType | Gets the type of parameter.
Set | Sets an object as parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Get Method
IParam Interface See Also Send Feedback
Gets the object.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Get()
Visual Basic (Declaration)
Function Get As Object
Visual C++
Object^ Get()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IParam.Get"]

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ParamType Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.ParamType Method
IParam Interface See Also Send Feedback
Gets the type of parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Type ParamType()
Visual Basic (Declaration)
Function ParamType As Type
Visual C++
Type^ ParamType()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IParam.ParamType"]

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Set Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Set Method
IParam Interface See Also Send Feedback
Sets an object as parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IParam Set(
    Object data
)
Visual Basic (Declaration)
Function Set ( _
    data As Object _
) As IParam
Visual C++
IParam^ Set(
    Object^ data
)

Parameters

data
Type: System..::.Object

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IParam.Set(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IParam.Set(System.Object)"]

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Properties
IParam Interface See Also Send Feedback

The IParam type exposes the following members.

Properties

Name | Description
Name | Gets the name of the parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Name Property
IParam Interface See Also Send Feedback
Gets the name of the parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Interface
Members See Also Send Feedback
Interface for managing protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IProtocolRequest
Visual Basic (Declaration)
Public Interface IProtocolRequest
Visual C++
public interface class IProtocolRequest

See Also

IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Members
IProtocolRequest Interface Methods Properties See Also Send Feedback

The IProtocolRequest type exposes the following members.

Methods

Name | Description
AddParam | Adds a parameter to this protocol.
CreateCommands | Creates a command for this protocol.
Get | Gets a parameter.
GetCommands | Returns the list of commands for this protocol.
GetParams | Returns all the parameters of the protocol.
RemoveParam | Removes a parameter from this protocol.
To | Sets the channel where to send the request and all parameters.
With | Overloaded.

Properties

Name | Description
Description | Gets the description of the protocol.
IsSynchronized | Returns true if the protocol is synchronized.
Name | Returns the name of the procotol.
SwitchPolicy | Gets or sets the switch policy which applies to this protocol and switch.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Methods
IProtocolRequest Interface See Also Send Feedback

The IProtocolRequest type exposes the following members.

Methods

Name | Description
AddParam | Adds a parameter to this protocol.
CreateCommands | Creates a command for this protocol.
Get | Gets a parameter.
GetCommands | Returns the list of commands for this protocol.
GetParams | Returns all the parameters of the protocol.
RemoveParam | Removes a parameter from this protocol.
To | Sets the channel where to send the request and all parameters.
With | Overloaded.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


AddParam Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.AddParam Method
IProtocolRequest Interface See Also Send Feedback
Adds a parameter to this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest AddParam(
    IParam item
)
Visual Basic (Declaration)
Function AddParam ( _
    item As IParam _
) As IProtocolRequest
Visual C++
IProtocolRequest^ AddParam(
    IParam^ item
)

Parameters

item
Type: Genesyslab.Enterprise.Model.Protocol..::.IParam

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.AddParam(Genesyslab.Enterprise.Model.Protocol.IParam)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.AddParam(Genesyslab.Enterprise.Model.Protocol.IParam)"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


CreateCommands Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.CreateCommands Method
IProtocolRequest Interface See Also Send Feedback
Creates a command for this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<IProtocolRequest> CreateCommands()
Visual Basic (Declaration)
Function CreateCommands As ICollection(Of IProtocolRequest)
Visual C++
ICollection<IProtocolRequest^>^ CreateCommands()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.CreateCommands"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Get Method
IProtocolRequest Interface See Also Send Feedback
Gets a parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Get(
    string name
)
Visual Basic (Declaration)
Function Get ( _
    name As String _
) As Object
Visual C++
Object^ Get(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.Get(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.Get(System.String)"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetCommands Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.GetCommands Method
IProtocolRequest Interface See Also Send Feedback
Returns the list of commands for this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ICollection<string> GetCommands()
Visual Basic (Declaration)
Function GetCommands As ICollection(Of String)
Visual C++
ICollection<String^>^ GetCommands()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.GetCommands"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetParams Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.GetParams Method
IProtocolRequest Interface See Also Send Feedback
Returns all the parameters of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IParam> GetParams()
Visual Basic (Declaration)
Function GetParams As IDictionary(Of String, IParam)
Visual C++
IDictionary<String^, IParam^>^ GetParams()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.GetParams"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


RemoveParam Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.RemoveParam Method
IProtocolRequest Interface See Also Send Feedback
Removes a parameter from this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest RemoveParam(
    IParam item
)
Visual Basic (Declaration)
Function RemoveParam ( _
    item As IParam _
) As IProtocolRequest
Visual C++
IProtocolRequest^ RemoveParam(
    IParam^ item
)

Parameters

item
Type: Genesyslab.Enterprise.Model.Protocol..::.IParam

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.RemoveParam(Genesyslab.Enterprise.Model.Protocol.IParam)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.RemoveParam(Genesyslab.Enterprise.Model.Protocol.IParam)"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


To Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method
IProtocolRequest Interface See Also Send Feedback
Sets the channel where to send the request and all parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int To(
    IClientChannel channel
)
Visual Basic (Declaration)
Function To ( _
    channel As IClientChannel _
) As Integer
Visual C++
int To(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.To(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.To(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


With Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method
IProtocolRequest Interface See Also Send Feedback

Overload List

Name | Description
With(array<Object>[]()[]) | Sets a list of parameters.
With(String, Int32) | Sets an integer parameter.
With(String, Object) | Sets an object parameter.
With(String, String) | Sets a string parameter.

See Also

IProtocolRequest Interface
IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (Object[])

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (array<Object>[]()[])
IProtocolRequest Interface See Also Send Feedback
Sets a list of parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest With(
    params Object[] list
)
Visual Basic (Declaration)
Function With ( _
    ParamArray list As Object() _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    ... array<Object^>^ list
)

Parameters

list
Type: array< System..::.Object >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.Object[])"]

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, Int32)
IProtocolRequest Interface See Also Send Feedback
Sets an integer parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest With(
    string name,
    int value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As Integer _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    int value
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.Int32)"]

value
Type: System..::.Int32

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.Int32)"]

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, Object)
IProtocolRequest Interface See Also Send Feedback
Sets an object parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest With(
    string name,
    Object value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As Object _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.Object)"]

value
Type: System..::.Object

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.Object)"]

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, String)
IProtocolRequest Interface See Also Send Feedback
Sets a string parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IProtocolRequest With(
    string name,
    string value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As String _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.String)"]

value
Type: System..::.String

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.With(System.String,System.String)"]

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Properties
IProtocolRequest Interface See Also Send Feedback

The IProtocolRequest type exposes the following members.

Properties

Name | Description
Description | Gets the description of the protocol.
IsSynchronized | Returns true if the protocol is synchronized.
Name | Returns the name of the procotol.
SwitchPolicy | Gets or sets the switch policy which applies to this protocol and switch.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Description Property
IProtocolRequest Interface See Also Send Feedback
Gets the description of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IsSynchronized Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.IsSynchronized Property
IProtocolRequest Interface See Also Send Feedback
Returns true if the protocol is synchronized.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsSynchronized { get; }
Visual Basic (Declaration)
ReadOnly Property IsSynchronized As Boolean
Visual C++
property bool IsSynchronized {
    bool get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Name Property
IProtocolRequest Interface See Also Send Feedback
Returns the name of the procotol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


SwitchPolicy Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.SwitchPolicy Property
IProtocolRequest Interface See Also Send Feedback
Gets or sets the switch policy which applies to this protocol and switch.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object SwitchPolicy { get; set; }
Visual Basic (Declaration)
Property SwitchPolicy As Object
Visual C++
property Object^ SwitchPolicy {
    Object^ get ();
    void set (Object^ value);
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the switch policy.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ISwitchPolicy<T>
Visual Basic (Declaration)
Public Interface ISwitchPolicy(Of T)
Visual C++
generic<typename T>
public interface class ISwitchPolicy

Type Parameters

T
Type.

See Also

ISwitchPolicy<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Members
ISwitchPolicy<(Of <(T>)>) Interface Properties See Also Send Feedback

The ISwitchPolicy<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
GetProtocolRule | Gets the rules that manages a protocol according to a switch.

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Properties
ISwitchPolicy<(Of <(T>)>) Interface See Also Send Feedback

The ISwitchPolicy<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
GetProtocolRule | Gets the rules that manages a protocol according to a switch.

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>)..::.GetProtocolRule Property
ISwitchPolicy<(Of <(T>)>) Interface See Also Send Feedback
Gets the rules that manages a protocol according to a switch.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T GetProtocolRule { get; set; }
Visual Basic (Declaration)
Property GetProtocolRule As T
Visual C++
property T GetProtocolRule {
    T get ();
    void set (T value);
}

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


MediaDirectionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaDirectionType Enumeration
See Also Send Feedback
Enumerates the media direction types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum MediaDirectionType
Visual Basic (Declaration)
Public Enumeration MediaDirectionType
Visual C++
public enum class MediaDirectionType

Members

Member name | Description
Unknown | Unknown direction.
In | Inbound direction.
Out | Outbound direction.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


MediaType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaType Enumeration
See Also Send Feedback
Enumerates for the media types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[FlagsAttribute]
public enum MediaType
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration MediaType
Visual C++
[FlagsAttribute]
public enum class MediaType

Members

Member name | Description
Unknown | Media type not specified
Voice | Voice media.
Chat | Chat, Instant Messaging media.
Custom | Custom media.
All | All media.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


SwitchModelType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SwitchModelType Enumeration
See Also Send Feedback
Enumerates the switch model types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum SwitchModelType
Visual Basic (Declaration)
Public Enumeration SwitchModelType
Visual C++
public enum class SwitchModelType

Members

Member name | Description
Unknown | Unknown Switch.
AlcatelOxeClassic | Alcatel Oxe in Classic Mode Switch.
AlcatelOxeSubstitute | Alcatel Oxe in Substitute Mode Switch.
AlcatelOxeEmulated | Alcatel Oxe in Emulated Mode Switch.
LucentDefinityG3 | Lucent G3 Switch.
NortelDMS100 | Nortel DMS 100 Switch.
GenesysSip | Genesys SIP Server Soft Switch.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


Genesyslab.Enterprise.Model.ServiceModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.ServiceModel Namespace
Send Feedback

Interfaces

Interface Description
IEnterpriseServiceProvider

Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

IService
Service data.


IEnterpriseServiceProvider Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Interface
Members See Also Send Feedback

Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEnterpriseServiceProvider
Visual Basic (Declaration)
Public Interface IEnterpriseServiceProvider
Visual C++
public interface class IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Members
IEnterpriseServiceProvider Interface Methods Properties See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances.

Properties

Name | Description
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
Provider | ¨ESDK provider.
ServiceName | Name.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Methods
IEnterpriseServiceProvider Interface See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Evaluate<(Of <(T>)>)(T) | Applies the strategies of the container to objects built externally.
Evaluate<(Of <(T>)>)(T, String) | Applies the strategies of the container to objects built externally.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T)
IEnterpriseServiceProvider Interface See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider Evaluate<T>(
    T data
)
Visual Basic (Declaration)
Function Evaluate(Of T) ( _
    data As T _
) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ Evaluate(
    T data
)

Parameters

data
Type: T
Data.

Type Parameters

T
Data type.

Return Value

Provider.

See Also

IEnterpriseServiceProvider Interface
Evaluate Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate(T) Method (T, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider Evaluate<T>(
    T data,
    string name
)
Visual Basic (Declaration)
Function Evaluate(Of T) ( _
    data As T, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ Evaluate(
    T data,
    String^ name
)

Parameters

data
Type: T
Data.
name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

Type Parameters

T
Data type.

Return Value

Provider.

See Also

IEnterpriseServiceProvider Interface
Evaluate Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.
Load(Assembly) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.
Load(String) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Load()
Visual Basic (Declaration)
Function Load As Boolean
Visual C++
bool Load()

Return Value

True if the services are loaded.

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method (Assembly)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method (Assembly)
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Load(
    Assembly asssembly
)
Visual Basic (Declaration)
Function Load ( _
    asssembly As Assembly _
) As Boolean
Visual C++
bool Load(
    Assembly^ asssembly
)

Parameters

asssembly
Type: System.Reflection..::.Assembly
Assembly which describes the services.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Load(System.Reflection.Assembly)"]

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method (String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool Load(
    string filename
)
Visual Basic (Declaration)
Function Load ( _
    filename As String _
) As Boolean
Visual C++
bool Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
XML file which describes the services.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Load(System.String)"]

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterInstance(TInterface) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers an instance with the container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider RegisterInstance<TInterface>(
    string name,
    TInterface instance
)
Visual Basic (Declaration)
Function RegisterInstance(Of TInterface) ( _
    name As String, _
    instance As TInterface _
) As IEnterpriseServiceProvider
Visual C++
generic<typename TInterface>
IEnterpriseServiceProvider^ RegisterInstance(
    String^ name,
    TInterface instance
)

Parameters

name
Type: System..::.String
Name for the new instance.
instance
Type: TInterface
Instance to register.

Type Parameters

TInterface
Type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterInstance``1(System.String,``0)"]

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
RegisterType<(Of <(T>)>)()()() | Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.
RegisterType(Type, Type) | Registers a type mapping with the container, where the created instances will use the provided LifetimeManager.
RegisterType(Type, Type, String) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider RegisterType<T>()
Visual Basic (Declaration)
Function RegisterType(Of T) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ RegisterType()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType``1"]

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type)
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances will use the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to
)

Parameters

from
Type: System..::.Type

[Missing <param name="from"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type)"]

to
Type: System..::.Type

[Missing <param name="to"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type)"]

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name
)

Parameters

from
Type: System..::.Type

[Missing <param name="from"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

to
Type: System..::.Type

[Missing <param name="to"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Resolve<(Of <(T>)>)()()() | Resolves an instance of the requested type.
Resolve<(Of <(T>)>)(String) | Resolves an instance.
Resolve(Type) | Resolves an instance of the requested type.
Resolve(Type, String) | Resolves an instance of the requested type with the given name.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T Resolve<T>()
Visual Basic (Declaration)
Function Resolve(Of T) As T
Visual C++
generic<typename T>
T Resolve()

Type Parameters

T
Type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Resolve``1"]

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve(T) Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve<(Of <(T>)>) Method (String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T Resolve<T>(
    string name
)
Visual Basic (Declaration)
Function Resolve(Of T) ( _
    name As String _
) As T
Visual C++
generic<typename T>
T Resolve(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the service to resolve.

Type Parameters

T
Type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Resolve``1(System.String)"]

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method (Type)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Resolve(
    Type t
)
Visual Basic (Declaration)
Function Resolve ( _
    t As Type _
) As Object
Visual C++
Object^ Resolve(
    Type^ t
)

Parameters

t
Type: System..::.Type
Type to resolve.

Return Value

Instance.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method (Type, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method (Type, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type with the given name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Resolve(
    Type t,
    string name
)
Visual Basic (Declaration)
Function Resolve ( _
    t As Type, _
    name As String _
) As Object
Visual C++
Object^ Resolve(
    Type^ t,
    String^ name
)

Parameters

t
Type: System..::.Type
Type to resolve.
name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Resolve(System.Type,System.String)"]

Return Value

object

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


ResolveAll(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.ResolveAll<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves all the instances.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> ResolveAll<T>()
Visual Basic (Declaration)
Function ResolveAll(Of T) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ResolveAll()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.ResolveAll``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.ResolveAll``1"]

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Properties
IEnterpriseServiceProvider Interface See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Properties

Name | Description
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
Provider | ¨ESDK provider.
ServiceName | Name.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Filter Property
IEnterpriseServiceProvider Interface See Also Send Feedback
Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Filter { get; set; }
Visual Basic (Declaration)
Property Filter As String
Visual C++
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Provider Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Provider Property
IEnterpriseServiceProvider Interface See Also Send Feedback
¨ESDK provider.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseServiceProvider Provider { get; }
Visual Basic (Declaration)
ReadOnly Property Provider As IEnterpriseServiceProvider
Visual C++
property IEnterpriseServiceProvider^ Provider {
    IEnterpriseServiceProvider^ get ();
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.ServiceName Property
IEnterpriseServiceProvider Interface See Also Send Feedback
Name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ServiceName { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceName As String
Visual C++
property String^ ServiceName {
    String^ get ();
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Interface

[image]

Enterprise SDK 8.0 Reference API
IService Interface
Members See Also Send Feedback
Service data.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IService : IDisposable
Visual Basic (Declaration)
Public Interface IService _
    Implements IDisposable
Visual C++
public interface class IService : IDisposable

See Also

IService Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IService Members
IService Interface Methods Properties See Also Send Feedback

The IService type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

Properties

Name | Description
Container | Container.
Description | Service description.
FQName | Fully Qualified Name.
LifeTimeManager | Life time manager.
ParentContainer | Parent container.
ServiceName | Name of the service.

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IService Methods
IService Interface See Also Send Feedback

The IService type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IService Properties
IService Interface See Also Send Feedback

The IService type exposes the following members.

Properties

Name | Description
Container | Container.
Description | Service description.
FQName | Fully Qualified Name.
LifeTimeManager | Life time manager.
ParentContainer | Parent container.
ServiceName | Name of the service.

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Container Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.Container Property
IService Interface See Also Send Feedback
Container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Container { get; }
Visual Basic (Declaration)
ReadOnly Property Container As Object
Visual C++
property Object^ Container {
    Object^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.Description Property
IService Interface See Also Send Feedback
Service description.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.FQName Property
IService Interface See Also Send Feedback
Fully Qualified Name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


LifeTimeManager Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.LifeTimeManager Property
IService Interface See Also Send Feedback
Life time manager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Type LifeTimeManager { get; }
Visual Basic (Declaration)
ReadOnly Property LifeTimeManager As Type
Visual C++
property Type^ LifeTimeManager {
    Type^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ParentContainer Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.ParentContainer Property
IService Interface See Also Send Feedback
Parent container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object ParentContainer { get; }
Visual Basic (Declaration)
ReadOnly Property ParentContainer As Object
Visual C++
property Object^ ParentContainer {
    Object^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.ServiceName Property
IService Interface See Also Send Feedback
Name of the service.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string ServiceName { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceName As String
Visual C++
property String^ ServiceName {
    String^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Genesyslab.Enterprise.Protocols.Configuration Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Protocols.Configuration Namespace
Send Feedback

Classes

Class | Description
ConfigurationProtocolRequest |


ConfigurationProtocolRequest Class

[image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest"]

Namespace: Genesyslab.Enterprise.Protocols.Configuration
Assembly: Genesyslab.Enterprise.Protocols (in Genesyslab.Enterprise.Protocols.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class ConfigurationProtocolRequest : ProtocolRequest
Visual Basic (Declaration)
Public Class ConfigurationProtocolRequest _
    Inherits ProtocolRequest
Visual C++
public ref class ConfigurationProtocolRequest : public ProtocolRequest

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
ProtocolRequest
Genesyslab.Enterprise.Protocols.Configuration..::.ConfigurationProtocolRequest

See Also

ConfigurationProtocolRequest Members
Genesyslab.Enterprise.Protocols.Configuration Namespace


ConfigurationProtocolRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Members
ConfigurationProtocolRequest Class Constructors Methods Properties See Also Send Feedback

The ConfigurationProtocolRequest type exposes the following members.

Constructors

Name | Description
ConfigurationProtocolRequest | Overloaded.

Methods

Name | Description
CreateCommands | (Overrides ProtocolRequestCreateCommands()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SwitchPolicy | (Overrides ProtocolRequestSwitchPolicy()()().)

See Also

ConfigurationProtocolRequest Class
Genesyslab.Enterprise.Protocols.Configuration Namespace


ConfigurationProtocolRequest Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Constructor
ConfigurationProtocolRequest Class See Also Send Feedback

Overload List

Name | Description
ConfigurationProtocolRequest(String, Boolean) |
ConfigurationProtocolRequest(String, String, Boolean) |

See Also

ConfigurationProtocolRequest Class
ConfigurationProtocolRequest Members
Genesyslab.Enterprise.Protocols.Configuration Namespace


ConfigurationProtocolRequest Constructor (String, Boolean)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Constructor (String, Boolean)
ConfigurationProtocolRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.Boolean)"]

Namespace: Genesyslab.Enterprise.Protocols.Configuration
Assembly: Genesyslab.Enterprise.Protocols (in Genesyslab.Enterprise.Protocols.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationProtocolRequest(
    string name,
    bool sync
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    sync As Boolean _
)
Visual C++
public:
ConfigurationProtocolRequest(
    String^ name,
    bool sync
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.Boolean)"]

sync
Type: System..::.Boolean

[Missing <param name="sync"/> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.Boolean)"]

See Also

ConfigurationProtocolRequest Class
ConfigurationProtocolRequest Overload
Genesyslab.Enterprise.Protocols.Configuration Namespace


ConfigurationProtocolRequest Constructor (String, String, Boolean)

[image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Constructor (String, String, Boolean)
ConfigurationProtocolRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.String,System.Boolean)"]

Namespace: Genesyslab.Enterprise.Protocols.Configuration
Assembly: Genesyslab.Enterprise.Protocols (in Genesyslab.Enterprise.Protocols.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ConfigurationProtocolRequest(
    string name,
    string description,
    bool sync
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    sync As Boolean _
)
Visual C++
public:
ConfigurationProtocolRequest(
    String^ name,
    String^ description,
    bool sync
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.String,System.Boolean)"]

description
Type: System..::.String

[Missing <param name="description"/> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.String,System.Boolean)"]

sync
Type: System..::.Boolean

[Missing <param name="sync"/> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.#ctor(System.String,System.String,System.Boolean)"]

See Also

ConfigurationProtocolRequest Class
ConfigurationProtocolRequest Overload
Genesyslab.Enterprise.Protocols.Configuration Namespace


ConfigurationProtocolRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Methods
ConfigurationProtocolRequest Class See Also Send Feedback

The ConfigurationProtocolRequest type exposes the following members.

Methods

Name | Description
CreateCommands | (Overrides ProtocolRequestCreateCommands()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationProtocolRequest Class
Genesyslab.Enterprise.Protocols.Configuration Namespace


CreateCommands Method

[image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest..::.CreateCommands Method
ConfigurationProtocolRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.CreateCommands"]

Namespace: Genesyslab.Enterprise.Protocols.Configuration
Assembly: Genesyslab.Enterprise.Protocols (in Genesyslab.Enterprise.Protocols.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override ICollection<IProtocolRequest> CreateCommands()
Visual Basic (Declaration)
Public Overrides Function CreateCommands As ICollection(Of IProtocolRequest)
Visual C++
public:
virtual ICollection<IProtocolRequest^>^ CreateCommands() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.CreateCommands"]

Implements

IProtocolRequest..::.CreateCommands()()()

See Also

ConfigurationProtocolRequest Class
Genesyslab.Enterprise.Protocols.Configuration Namespace


ConfigurationProtocolRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest Properties
ConfigurationProtocolRequest Class See Also Send Feedback

The ConfigurationProtocolRequest type exposes the following members.

Properties

Name | Description
SwitchPolicy | (Overrides ProtocolRequestSwitchPolicy()()().)

See Also

ConfigurationProtocolRequest Class
Genesyslab.Enterprise.Protocols.Configuration Namespace


SwitchPolicy Property

[image]

Enterprise SDK 8.0 Reference API
ConfigurationProtocolRequest..::.SwitchPolicy Property
ConfigurationProtocolRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Protocols.Configuration.ConfigurationProtocolRequest.SwitchPolicy"]

Namespace: Genesyslab.Enterprise.Protocols.Configuration
Assembly: Genesyslab.Enterprise.Protocols (in Genesyslab.Enterprise.Protocols.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override Object SwitchPolicy { get; set; }
Visual Basic (Declaration)
Public Overrides Property SwitchPolicy As Object
Visual C++
public:
virtual property Object^ SwitchPolicy {
    Object^ get () override;
    void set (Object^ value) override;
}

Implements

IProtocolRequest..::.SwitchPolicy

See Also

ConfigurationProtocolRequest Class
Genesyslab.Enterprise.Protocols.Configuration Namespace


Genesyslab.Enterprise.Services Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services Namespace
Send Feedback

Classes

Class Description
CustomSubscriber<(Of <(T>)>)
EnterpriseServiceProvider
Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

EnterpriseServiceProviderExtension
SupervisorObjectState
SupervisorService
Monitor class implementation

Interfaces

Interface | Description
IAgentService |
IChannelService | Interface for managing channels. With this interface, you declare and declare new communication channels, one for each media connection (for instance a switch.)
IConfigurator | Object auto-configuration interface
IDeviceDomain | Manages device data.
IDeviceService | Manages handlers and filters on devices.
IEntityDomain | Manages entities and identities for groups and persons.
IEventManager<(Of <(D, T>)>) | Event Manager.
IIdentityDomain | Manages the identity domain.
IIdentityService | Manages the identities. Note: To use an agent with a device, create a link between these objects with the IIdentityService.SetDevice() method.
IIMDomain | Manages Instant Messaging data.
IIMService | Manages the instant messaging features.
IInteractionDomain | Enables your application to manage interactions.
IInteractionService | Manages callback and filters related to interaction events.
IMonitorService | Statistics service.
IPreviewDomain | Preview Interaction domain.
IPreviewService | Manages the Preview Interaction features.
IPSTService | Provides Possible State Transition (PST) information. The isPossible methods of this service use the loaded stategies and the given objects' data (including its own status and strategies) to determine whether a requested action can be processed. The isCapable methods of this service use the loaded strategies to indicate whether the feature is available regardless of the object status. For instance, if your switch does not provide a mute feature, the isCapable methods return false for the ProtocolAction.MuteOn action.
ISupervisorDomain | Actions part of the monitoring domain
ISupervisorInfo | Describes the monitoring information of the object which is identified by the Id member. The MonitorObject member identifies the type of the monitored object (possible types are enumerated in SupervisorObjectType: agent, interaction, device, and so on.)
ISupervisorService | Manages actions and events related to monitoring events.

Delegates

Delegate | Description
MonitorMethodDelegate | Listener for Statistics events. This is the callback for subscribed statistics events.

Enumerations

Enumeration | Description
AgentAction | Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.
DeviceAction | Enumerates the actions that are possible on this device. To be used in the methods of IsPossible.
MessageContentType | Enumerates the content type of the message.
MonitorNotificationMode | Statistics Notification mode. Event notification mode for subscribed statistics.
MonitorObjectType | Enumerate for statistics object type. Type of the statistics objects that can be monitored.
ProtocolAction | Enumerates the actions that are possible on this interaction. To be used in the methods of IsPossible.
SupervisorModeType | Enumerates the monitor modes.
SupervisorObjectType | Enumerates the types of objects involved in monitoring.
SupervisorStateType | Enumerates the monitor statuses.


AgentAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum AgentAction
Visual Basic (Declaration)
Public Enumeration AgentAction
Visual C++
public enum class AgentAction

Members

Member name | Description
Login | Login this device.
Logout | Logout this device.
NotReady | Sets not ready this device.
Ready | Sets this device ready.

See Also

Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Class

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.CustomSubscriber`1"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public abstract class CustomSubscriber<T> : ContainerBase,
    IBrokerSubscriber<T>, IBrokerPublisher
Visual Basic (Declaration)
Public MustInherit Class CustomSubscriber(Of T) _
    Inherits ContainerBase _
    Implements IBrokerSubscriber(Of T), IBrokerPublisher
Visual C++
generic<typename T>
public ref class CustomSubscriber abstract : public ContainerBase,
    IBrokerSubscriber<T>, IBrokerPublisher

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.CustomSubscriber`1"]

Inheritance Hierarchy

System..::.Object
ContainerBase
Genesyslab.Enterprise.Services..::.CustomSubscriber<(Of <(T>)>)
Genesyslab.Enterprise.Services..::.SupervisorService

See Also

CustomSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Members
CustomSubscriber<(Of <(T>)>) Class Methods Properties See Also Send Feedback

The CustomSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
EventSubscription |

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Methods
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

The CustomSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Publish<(Of <(T>)>) |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.GetList Method
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) |
GetList(Type, ItemLocation) |

See Also

CustomSubscriber<(Of <(T>)>) Class
CustomSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Services Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
public:
generic<typename U>
virtual IEnumerable<U>^ GetList(
    ItemLocation flag
) sealed

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Type Parameters

U

[Missing <typeparam name="U"/> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList``1(Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

See Also

CustomSubscriber<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Services Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Public Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
public:
virtual IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
) sealed

Parameters

targetObject
Type: System..::.Type

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation

[Missing <param name="flag"/> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.GetList(System.Type,Genesyslab.Enterprise.Model.ComponentModel.ItemLocation)"]

Implements

IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

CustomSubscriber<(Of <(T>)>) Class
GetList Overload
Genesyslab.Enterprise.Services Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.Publish<(Of <(T>)>) Method
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.Publish``1(``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Public Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
public:
generic<typename T>
virtual IBrokerPublisher^ Publish(
    T obj
) sealed

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.Publish``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.Publish``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.CustomSubscriber`1.Publish``1(``0)"]

Implements

IBrokerPublisher..::.Publish<(Of <(T>)>)(T)

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


CustomSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>) Properties
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

The CustomSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count |
EventSubscription |

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.Count Property
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.CustomSubscriber`1.Count"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
CustomSubscriber<(Of <(T>)>)..::.EventSubscription Property
CustomSubscriber<(Of <(T>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.CustomSubscriber`1.EventSubscription"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public virtual IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
public:
virtual property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get ();
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.EventSubscription

See Also

CustomSubscriber<(Of <(T>)>) Class
Genesyslab.Enterprise.Services Namespace


DeviceAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this device. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum DeviceAction
Visual Basic (Declaration)
Public Enumeration DeviceAction
Visual C++
public enum class DeviceAction

Members

Member name | Description
CancelForward | Sets the Forwarding feature to Off.
Login | Login this device.
Logout | Logout this device.
NotReady | Sets not ready this device.
Ready | Sets this device ready.
SetDNDOff | Deactivates the Do-Not-Disturb (DND) mode.
SetDNDOn | Activates the Do-Not-Disturb (DND) mode.
SetForward | Sets the Forwarding feature to On.

See Also

Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Class
Members See Also Send Feedback
Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class EnterpriseServiceProvider : IService,
    IEnterpriseServiceProvider, IDisposable
Visual Basic (Declaration)
Public Class EnterpriseServiceProvider _
    Implements IService, IEnterpriseServiceProvider, IDisposable
Visual C++
public ref class EnterpriseServiceProvider : IService,
    IEnterpriseServiceProvider, IDisposable

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.EnterpriseServiceProvider

See Also

EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Members
EnterpriseServiceProvider Class Constructors Methods Properties See Also Send Feedback

The EnterpriseServiceProvider type exposes the following members.

Constructors

Name | Description
EnterpriseServiceProvider | Overloaded.

Methods

Name | Description
Dispose | Cleans this object. Therefore, you should call GC.SupressFinalize to take this object off the finalization queue and prevent finalization code for this object from executing a second time.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Container | Container.
Description | Description.
Filter |
FQName | Fully Qualified Name (Unique ID).
LifeTimeManager | Lifetime manager.
Logger | Returns the logger.
ParentContainer | Parent container.
Provider | Applies the strategies of the container to objects built externally.
ServiceName | Returns the service name.

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
EnterpriseServiceProvider(ILogger) | Creates a new service provider instance, which uses the given logger.
EnterpriseServiceProvider(Object, ILogger) | Injection constructor.
EnterpriseServiceProvider(Object, Type, ILogger) | Injection constructor.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor ()

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor ()
EnterpriseServiceProvider Class See Also Send Feedback
Creates a new service provider instance, which uses the given logger.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseServiceProvider(
    ILogger log
)
Visual Basic (Declaration)
Public Sub New ( _
    log As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    ILogger^ log
)

Parameters

log
Type: ILogger
Logger.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (Object, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (Object, )
EnterpriseServiceProvider Class See Also Send Feedback
Injection constructor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseServiceProvider(
    Object container,
    ILogger log
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object, _
    log As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    Object^ container,
    ILogger^ log
)

Parameters

container
Type: System..::.Object

[Missing <param name="container"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.#ctor(System.Object,Genesyslab.Platform.Commons.Logging.ILogger)"]

log
Type: ILogger

[Missing <param name="log"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.#ctor(System.Object,Genesyslab.Platform.Commons.Logging.ILogger)"]

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Constructor (Object, Type, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Constructor (Object, Type, )
EnterpriseServiceProvider Class See Also Send Feedback
Injection constructor.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public EnterpriseServiceProvider(
    Object container,
    Type lfm,
    ILogger log
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object, _
    lfm As Type, _
    log As ILogger _
)
Visual C++
public:
EnterpriseServiceProvider(
    Object^ container,
    Type^ lfm,
    ILogger^ log
)

Parameters

container
Type: System..::.Object

[Missing <param name="container"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.#ctor(System.Object,System.Type,Genesyslab.Platform.Commons.Logging.ILogger)"]

lfm
Type: System..::.Type

[Missing <param name="lfm"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.#ctor(System.Object,System.Type,Genesyslab.Platform.Commons.Logging.ILogger)"]

log
Type: ILogger

[Missing <param name="log"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.#ctor(System.Object,System.Type,Genesyslab.Platform.Commons.Logging.ILogger)"]

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Overload
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Methods
EnterpriseServiceProvider Class See Also Send Feedback

The EnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
Dispose | Cleans this object. Therefore, you should call GC.SupressFinalize to take this object off the finalization queue and prevent finalization code for this object from executing a second time.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Dispose Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Dispose Method
EnterpriseServiceProvider Class See Also Send Feedback
Cleans this object. Therefore, you should call GC.SupressFinalize to take this object off the finalization queue and prevent finalization code for this object from executing a second time.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Evaluate Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Evaluate Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
Evaluate<(Of <(T>)>)(T) | Applies the strategies of the container to objects built externally.
Evaluate<(Of <(T>)>)(T, String) | Evaluate a typed and named object externally created with container strategies (Externally means not created by the serviceProvider container)

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


Evaluate(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T)
EnterpriseServiceProvider Class See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider Evaluate<T>(
    T data
)
Visual Basic (Declaration)
Public Function Evaluate(Of T) ( _
    data As T _
) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename T>
virtual IEnterpriseServiceProvider^ Evaluate(
    T data
) sealed

Parameters

data
Type: T
Data.

Type Parameters

T
Data type.

Return Value

Provider.

Implements

IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>)(T)

See Also

EnterpriseServiceProvider Class
Evaluate Overload
Genesyslab.Enterprise.Services Namespace


Evaluate(T) Method (T, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T, String)
EnterpriseServiceProvider Class See Also Send Feedback
Evaluate a typed and named object externally created with container strategies (Externally means not created by the serviceProvider container)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider Evaluate<T>(
    T data,
    string name
)
Visual Basic (Declaration)
Public Function Evaluate(Of T) ( _
    data As T, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename T>
virtual IEnterpriseServiceProvider^ Evaluate(
    T data,
    String^ name
) sealed

Parameters

data
Type: T

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

Return Value

IEnterpriseServiceProvider

Implements

IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>)(T, String)

See Also

EnterpriseServiceProvider Class
Evaluate Overload
Genesyslab.Enterprise.Services Namespace


Load Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the predefined services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the Initialize() method, and call this Load() method.
Load(Assembly) | Loads a specific assembly into the ServiceProvider container.
Load(String) | Loads a configuration file to configure the container. Loading does not overwrite the existing configuration of the container.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


Load Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method
EnterpriseServiceProvider Class See Also Send Feedback
Loads the predefined services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the Initialize() method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public virtual bool Load()
Visual Basic (Declaration)
Public Overridable Function Load As Boolean
Visual C++
public:
virtual bool Load()

Return Value

True if the services are loaded.

Implements

IEnterpriseServiceProvider..::.Load()()()

See Also

EnterpriseServiceProvider Class
Load Overload
Genesyslab.Enterprise.Services Namespace


Load Method (Assembly)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method (Assembly)
EnterpriseServiceProvider Class See Also Send Feedback
Loads a specific assembly into the ServiceProvider container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public virtual bool Load(
    Assembly assembly
)
Visual Basic (Declaration)
Public Overridable Function Load ( _
    assembly As Assembly _
) As Boolean
Visual C++
public:
virtual bool Load(
    Assembly^ assembly
)

Parameters

assembly
Type: System.Reflection..::.Assembly
Assembly to load

Return Value

bool

Implements

IEnterpriseServiceProvider..::.Load(Assembly)

See Also

EnterpriseServiceProvider Class
Load Overload
Genesyslab.Enterprise.Services Namespace


Load Method (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Load Method (String)
EnterpriseServiceProvider Class Example See Also Send Feedback
Loads a configuration file to configure the container. Loading does not overwrite the existing configuration of the container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public virtual bool Load(
    string filename
)
Visual Basic (Declaration)
Public Overridable Function Load ( _
    filename As String _
) As Boolean
Visual C++
public:
virtual bool Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
Complete path of the configuration filename

Return Value

bool

Implements

IEnterpriseServiceProvider..::.Load(String)

Examples

Example of a Unity configuration file for EntrepriseSDK.
CopyC#
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
 <configSections>
  <section name="unity"
            type="Microsoft.Practices.Unity.Configuration.UnityConfigurationSection, Microsoft.Practices.Unity.Configuration, Version=1.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
            />
 </configSections>
 <unity>
   <typeAliases>
     <typeAlias alias="personalLifetimeManager"
          type="Genesyslab.Enterprise.Framework.Container.Unity.GlobalThreadLifeTimeManager,
              Genesyslab.Enterprise.Framework" />
     <typeAlias alias="identityService"
          type="Genesyslab.Enterprise.Services.IIdentityService, Genesyslab.Enterprise.Services" />
     <typeAlias alias="interactionService"
         type="Genesyslab.Enterprise.Services.IInteractionService, Genesyslab.Enterprise.Services" />
     <typeAlias alias="channelService"
         type="Genesyslab.Enterprise.Services.IChannelService, Genesyslab.Enterprise.Services" />
     <typeAlias alias="deviceService"
         type="Genesyslab.Enterprise.Services.IDeviceService, Genesyslab.Enterprise.Services" />
   </typeAliases>
   <containers>
     <container>
       <types>
         <type type="identityService"
               mapTo="Genesyslab.Enterprise.Services.IdentityService, Genesyslab.Enterprise.Services " name="identityService">
           <lifetime type="personalLifetimeManager" />
         </type>
         <type type="interactionService"
               mapTo="Genesyslab.Enterprise.Services.InteractionService, Genesyslab.Enterprise.Services " name="interactionService">
           <lifetime type="personalLifetimeManager" />
         </type>
         <type type="channelService"
             mapTo="Genesyslab.Enterprise.Services.ChannelService, Genesyslab.Enterprise.Services " name="channelService">
           <lifetime type="personalLifetimeManager" />
         </type>
         <type type="deviceService"
            mapTo="Genesyslab.Enterprise.Services.DeviceService, Genesyslab.Enterprise.Services " name="deviceService">
           <lifetime type="personalLifetimeManager" />
         </type>
         </types>
         <instances>
         </instances>
         <extensions>
           <add type="Microsoft.Practices.Unity.InterceptionExtension.Interception, Microsoft.Practices.Unity.Interception" />
         </extensions>
       <extensionConfig>
         </extensionConfig>
       </container>
     </containers>
 </unity>
</configuration>

See Also

EnterpriseServiceProvider Class
Load Overload
Genesyslab.Enterprise.Services Namespace


RegisterInstance(TInterface) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Registers an instance with the container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider RegisterInstance<TInterface>(
    string name,
    TInterface instance
)
Visual Basic (Declaration)
Public Function RegisterInstance(Of TInterface) ( _
    name As String, _
    instance As TInterface _
) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename TInterface>
virtual IEnterpriseServiceProvider^ RegisterInstance(
    String^ name,
    TInterface instance
) sealed

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterInstance``1(System.String,``0)"]

instance
Type: TInterface

[Missing <param name="instance"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterInstance``1(System.String,``0)"]

Type Parameters

TInterface

[Missing <typeparam name="TInterface"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterInstance``1(System.String,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterInstance``1(System.String,``0)"]

Implements

IEnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>)(String, TInterface)

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


RegisterType Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
RegisterType<(Of <(TType>)>)()()() | Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.
RegisterType(Type, Type) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


RegisterType(TType) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType<(Of <(TType>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider RegisterType<TType>()
Visual Basic (Declaration)
Public Function RegisterType(Of TType) As IEnterpriseServiceProvider
Visual C++
public:
generic<typename TType>
virtual IEnterpriseServiceProvider^ RegisterType() sealed

Type Parameters

TType

[Missing <typeparam name="TType"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType``1"]

Implements

IEnterpriseServiceProvider..::.RegisterType<(Of <(T>)>)()()()

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


RegisterType Method (Type, Type)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method (Type, Type)
EnterpriseServiceProvider Class See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to
)
Visual Basic (Declaration)
Public Function RegisterType ( _
    from As Type, _
    to As Type _
) As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to
) sealed

Parameters

from
Type: System..::.Type

[Missing <param name="from"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type)"]

to
Type: System..::.Type

[Missing <param name="to"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type)"]

Implements

IEnterpriseServiceProvider..::.RegisterType(Type, Type)

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


RegisterType Method (Type, Type, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.RegisterType Method (Type, Type, String)
EnterpriseServiceProvider Class See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name
)
Visual Basic (Declaration)
Public Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
public:
virtual IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name
) sealed

Parameters

from
Type: System..::.Type

[Missing <param name="from"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

to
Type: System..::.Type

[Missing <param name="to"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.RegisterType(System.Type,System.Type,System.String)"]

Implements

IEnterpriseServiceProvider..::.RegisterType(Type, Type, String)

See Also

EnterpriseServiceProvider Class
RegisterType Overload
Genesyslab.Enterprise.Services Namespace


Resolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve Method
EnterpriseServiceProvider Class See Also Send Feedback

Overload List

Name | Description
Resolve<(Of <(TType>)>)()()() | Resolves an instance of the requested type.
Resolve<(Of <(TType>)>)(String) | Resolves an instance of the requested type.
Resolve(Type) | Resolves an instance of the requested type.
Resolve(Type, String) | Resolves an instance of the requested type.

See Also

EnterpriseServiceProvider Class
EnterpriseServiceProvider Members
Genesyslab.Enterprise.Services Namespace


Resolve(TType) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve<(Of <(TType>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public TType Resolve<TType>()
Visual Basic (Declaration)
Public Function Resolve(Of TType) As TType
Visual C++
public:
generic<typename TType>
virtual TType Resolve() sealed

Type Parameters

TType

[Missing <typeparam name="TType"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve``1"]

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


Resolve(TType) Method (String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve<(Of <(TType>)>) Method (String)
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public TType Resolve<TType>(
    string name
)
Visual Basic (Declaration)
Public Function Resolve(Of TType) ( _
    name As String _
) As TType
Visual C++
public:
generic<typename TType>
virtual TType Resolve(
    String^ name
) sealed

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve``1(System.String)"]

Type Parameters

TType

[Missing <typeparam name="TType"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve``1(System.String)"]

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


Resolve Method (Type)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve Method (Type)
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Resolve(
    Type t
)
Visual Basic (Declaration)
Public Function Resolve ( _
    t As Type _
) As Object
Visual C++
public:
virtual Object^ Resolve(
    Type^ t
) sealed

Parameters

t
Type: System..::.Type

[Missing <param name="t"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve(System.Type)"]

Implements

IEnterpriseServiceProvider..::.Resolve(Type)

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


Resolve Method (Type, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Resolve Method (Type, String)
EnterpriseServiceProvider Class See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Resolve(
    Type t,
    string name
)
Visual Basic (Declaration)
Public Function Resolve ( _
    t As Type, _
    name As String _
) As Object
Visual C++
public:
virtual Object^ Resolve(
    Type^ t,
    String^ name
) sealed

Parameters

t
Type: System..::.Type

[Missing <param name="t"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve(System.Type,System.String)"]

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Resolve(System.Type,System.String)"]

Implements

IEnterpriseServiceProvider..::.Resolve(Type, String)

See Also

EnterpriseServiceProvider Class
Resolve Overload
Genesyslab.Enterprise.Services Namespace


ResolveAll(T) Method

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.ResolveAll<(Of <(T>)>) Method
EnterpriseServiceProvider Class See Also Send Feedback
Resolves all.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<T> ResolveAll<T>()
Visual Basic (Declaration)
Public Function ResolveAll(Of T) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
virtual IEnumerable<T>^ ResolveAll() sealed

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.ResolveAll``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.ResolveAll``1"]

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProvider Properties

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider Properties
EnterpriseServiceProvider Class See Also Send Feedback

The EnterpriseServiceProvider type exposes the following members.

Properties

Name | Description
Container | Container.
Description | Description.
Filter |
FQName | Fully Qualified Name (Unique ID).
LifeTimeManager | Lifetime manager.
Logger | Returns the logger.
ParentContainer | Parent container.
Provider | Applies the strategies of the container to objects built externally.
ServiceName | Returns the service name.

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Container Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Container Property
EnterpriseServiceProvider Class See Also Send Feedback
Container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object Container { get; }
Visual Basic (Declaration)
Public ReadOnly Property Container As Object
Visual C++
public:
virtual property Object^ Container {
    Object^ get () sealed;
}

Implements

IService..::.Container

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Description Property
EnterpriseServiceProvider Class See Also Send Feedback
Description.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IService..::.Description

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Filter Property
EnterpriseServiceProvider Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.EnterpriseServiceProvider.Filter"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IEnterpriseServiceProvider..::.Filter

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.FQName Property
EnterpriseServiceProvider Class See Also Send Feedback
Fully Qualified Name (Unique ID).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string FQName { get; internal set; }
Visual Basic (Declaration)
Public Property FQName As String
Visual C++
public:
virtual property String^ FQName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IService..::.FQName

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


LifeTimeManager Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.LifeTimeManager Property
EnterpriseServiceProvider Class See Also Send Feedback
Lifetime manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Type LifeTimeManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property LifeTimeManager As Type
Visual C++
public:
virtual property Type^ LifeTimeManager {
    Type^ get () sealed;
}

Implements

IService..::.LifeTimeManager

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Logger Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Logger Property
EnterpriseServiceProvider Class See Also Send Feedback
Returns the logger.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ILogger Logger { get; }
Visual Basic (Declaration)
Public ReadOnly Property Logger As ILogger
Visual C++
public:
property ILogger^ Logger {
    ILogger^ get ();
}

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


ParentContainer Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.ParentContainer Property
EnterpriseServiceProvider Class See Also Send Feedback
Parent container.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public Object ParentContainer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentContainer As Object
Visual C++
public:
virtual property Object^ ParentContainer {
    Object^ get () sealed;
}

Implements

IService..::.ParentContainer

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


Provider Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.Provider Property
EnterpriseServiceProvider Class See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnterpriseServiceProvider Provider { get; }
Visual Basic (Declaration)
Public ReadOnly Property Provider As IEnterpriseServiceProvider
Visual C++
public:
virtual property IEnterpriseServiceProvider^ Provider {
    IEnterpriseServiceProvider^ get () sealed;
}

Return Value

IEnterpriseServiceProvider

Implements

IEnterpriseServiceProvider..::.Provider

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProvider..::.ServiceName Property
EnterpriseServiceProvider Class See Also Send Feedback
Returns the service name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public string ServiceName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServiceName As String
Visual C++
public:
virtual property String^ ServiceName {
    String^ get () sealed;
}

Implements

IService..::.ServiceName
IEnterpriseServiceProvider..::.ServiceName

See Also

EnterpriseServiceProvider Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProviderExtension Class

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static class EnterpriseServiceProviderExtension
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class EnterpriseServiceProviderExtension
Visual C++
[ExtensionAttribute]
public ref class EnterpriseServiceProviderExtension abstract sealed

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.EnterpriseServiceProviderExtension

See Also

EnterpriseServiceProviderExtension Members
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProviderExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension Members
EnterpriseServiceProviderExtension Class Methods See Also Send Feedback

Methods

Name | Description
Init | Overloaded.

See Also

EnterpriseServiceProviderExtension Class
Genesyslab.Enterprise.Services Namespace


EnterpriseServiceProviderExtension Methods

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension Methods
EnterpriseServiceProviderExtension Class See Also Send Feedback

Methods

Name | Description
Init | Overloaded.

See Also

EnterpriseServiceProviderExtension Class
Genesyslab.Enterprise.Services Namespace


Init Method

[image] [image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension..::.Init Method
EnterpriseServiceProviderExtension Class See Also Send Feedback

Overload List

Name | Description
Init(IEnterpriseServiceProvider, ConfServerConfiguration) |
Init(IEnterpriseServiceProvider, IProtocol, CfgAppType, String) |

See Also

EnterpriseServiceProviderExtension Class
EnterpriseServiceProviderExtension Members
Genesyslab.Enterprise.Services Namespace


Init Method (IEnterpriseServiceProvider, )

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension..::.Init Method (IEnterpriseServiceProvider, )
EnterpriseServiceProviderExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ConfServerConfiguration)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static void Init(
    this IEnterpriseServiceProvider provider,
    ConfServerConfiguration confServerConfiguration
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub Init ( _
    provider As IEnterpriseServiceProvider, _
    confServerConfiguration As ConfServerConfiguration _
)
Visual C++
[ExtensionAttribute]
public:
static void Init(
    IEnterpriseServiceProvider^ provider,
    ConfServerConfiguration^ confServerConfiguration
)

Parameters

provider
Type: Genesyslab.Enterprise.Model.ServiceModel..::.IEnterpriseServiceProvider

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ConfServerConfiguration)"]

confServerConfiguration
Type: ConfServerConfiguration

[Missing <param name="confServerConfiguration"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ConfServerConfiguration)"]

See Also

EnterpriseServiceProviderExtension Class
Init Overload
Genesyslab.Enterprise.Services Namespace


Init Method (IEnterpriseServiceProvider, , CfgAppType, String)

[image]

Enterprise SDK 8.0 Reference API
EnterpriseServiceProviderExtension..::.Init Method (IEnterpriseServiceProvider, , CfgAppType, String)
EnterpriseServiceProviderExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Configuration.CfgAppType,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.PSDKExtensions (in Genesyslab.Enterprise.PSDKExtensions.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public static void Init(
    this IEnterpriseServiceProvider provider,
    IProtocol configurationProtocol,
    CfgAppType appType,
    string appName
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub Init ( _
    provider As IEnterpriseServiceProvider, _
    configurationProtocol As IProtocol, _
    appType As CfgAppType, _
    appName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void Init(
    IEnterpriseServiceProvider^ provider,
    IProtocol^ configurationProtocol,
    CfgAppType appType,
    String^ appName
)

Parameters

provider
Type: Genesyslab.Enterprise.Model.ServiceModel..::.IEnterpriseServiceProvider

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Configuration.CfgAppType,System.String)"]

configurationProtocol
Type: IProtocol

[Missing <param name="configurationProtocol"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Configuration.CfgAppType,System.String)"]

appType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgAppType

[Missing <param name="appType"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Configuration.CfgAppType,System.String)"]

appName
Type: System..::.String

[Missing <param name="appName"/> documentation for "M:Genesyslab.Enterprise.Services.EnterpriseServiceProviderExtension.Init(Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider,Genesyslab.Platform.Commons.Protocols.IProtocol,Genesyslab.Enterprise.Model.Configuration.CfgAppType,System.String)"]

See Also

EnterpriseServiceProviderExtension Class
Init Overload
Genesyslab.Enterprise.Services Namespace


IAgentService Interface

[image]

Enterprise SDK 8.0 Reference API
IAgentService Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.IAgentService"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IAgentService
Visual Basic (Declaration)
Public Interface IAgentService
Visual C++
public interface class IAgentService

See Also

IAgentService Members
Genesyslab.Enterprise.Services Namespace


IAgentService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService Members
IAgentService Interface Methods See Also Send Feedback

The IAgentService type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel |
EndCallForwardSet |
EndLogin |
EndLogout |
EndNotReady |
EndReady |
EndSetDNDOff |
EndSetDNDOn |
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


IAgentService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService Methods
IAgentService Interface See Also Send Feedback

The IAgentService type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel |
EndCallForwardSet |
EndLogin |
EndLogout |
EndNotReady |
EndReady |
EndSetDNDOff |
EndSetDNDOn |
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginCallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginCallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginCallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginCallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginCallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginCallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginCallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginCallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginCallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginCallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginCallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


BeginLogin Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginLogin(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |
BeginLogin(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginLogin(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginLogin ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogin(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginLogin Overload
Genesyslab.Enterprise.Services Namespace


BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginLogin(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginLogin ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogin(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginLogin Overload
Genesyslab.Enterprise.Services Namespace


BeginLogout Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginLogout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginLogout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginLogout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginLogout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginLogout Overload
Genesyslab.Enterprise.Services Namespace


BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginLogout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginLogout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginLogout Overload
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginNotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginNotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginNotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginNotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginNotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginNotReady Overload
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginNotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginNotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginNotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginNotReady Overload
Genesyslab.Enterprise.Services Namespace


BeginReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginReady Overload
Genesyslab.Enterprise.Services Namespace


BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginReady Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginSetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginSetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginSetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginSetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginSetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginSetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object) |
BeginSetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginSetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginSetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginSetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IAsyncResult BeginSetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context
)
Visual Basic (Declaration)
Function BeginSetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object)"]

See Also

IAgentService Interface
BeginSetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> CallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
CallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> CallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
CallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection) |
CallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> CallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
CallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> CallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
CallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndCallForwardCancel Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndCallForwardCancel(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCallForwardCancel ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndCallForwardCancel(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndCallForwardSet Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndCallForwardSet(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCallForwardSet ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndCallForwardSet(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndLogin Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndLogin Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndLogin(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndLogin ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndLogin(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndLogout Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndLogout Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndLogout(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndLogout ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndLogout(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndNotReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndNotReady Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndNotReady(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndNotReady ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndNotReady(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndReady Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndReady(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndReady ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndReady(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndSetDNDOff Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndSetDNDOff(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndSetDNDOff ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndSetDNDOff(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndSetDNDOn Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> EndSetDNDOn(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndSetDNDOn ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndSetDNDOn(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


Login Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Login(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection) |
Login(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> Login(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Login ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Login(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
Login Overload
Genesyslab.Enterprise.Services Namespace


Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method (IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> Login(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function Login ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Login(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
Login Overload
Genesyslab.Enterprise.Services Namespace


Logout Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Logout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection) |
Logout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> Logout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Logout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Logout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
Logout Overload
Genesyslab.Enterprise.Services Namespace


Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method (IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> Logout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function Logout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Logout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
Logout Overload
Genesyslab.Enterprise.Services Namespace


NotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
NotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) |
NotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> NotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function NotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ NotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
NotReady Overload
Genesyslab.Enterprise.Services Namespace


NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> NotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function NotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ NotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
NotReady Overload
Genesyslab.Enterprise.Services Namespace


Ready Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Ready(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection) |
Ready(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> Ready(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Ready ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Ready(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
Ready Overload
Genesyslab.Enterprise.Services Namespace


Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method (IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> Ready(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function Ready ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Ready(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
Ready Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection) |
SetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> SetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
SetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> SetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
SetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection) |
SetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> SetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IAgentService Interface
SetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method (IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnvelope<IAgent> SetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IAgentService Interface
SetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


IChannelService Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelService Interface
Members Example See Also Send Feedback
Interface for managing channels.

With this interface, you declare and declare new communication channels, one for each media connection (for instance a switch.)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IChannelService : IChannelManager,
    IEventManager<IChannelService, IClientChannel>
Visual Basic (Declaration)
Public Interface IChannelService _
    Implements IChannelManager, IEventManager(Of IChannelService, IClientChannel)
Visual C++
public interface class IChannelService : IChannelManager,
    IEventManager<IChannelService^, IClientChannel^>

Examples

This code sample show how to create and register a channel:
CopyC#
IChannelService channelService = EsdkService.Resolve<IChannelService>("channelService");
TServerConfiguration conf = new TServerConfiguration("Label name");
//Identify the client in TServer
conf.ClientName = "Channel Name";
conf.Uri = new Uri("tcp://hostname:port_value");
conf.WarmStandbyAttempts = 10;
conf.WarmStandbyTimeout = 5;
conf.WarmStandbyUri = new Uri("tcp://hostname:19345");
conf.UseAddp = false;

channelService.CreateChannel("Label name", conf, SwitchModelType.LucentDefinityG3 );
Genesyslab.Enterprise.Model.Channel.IClientChannel channel = channelService.GetChannel("Label name");

Then you can register a method for channel events:

CopyC#
//Register for Channel events
channelService.RegisterEvents<Genesyslab.Enterprise.Model.Channel.IClientChannel>(channel, new Action<Genesyslab.Enterprise.Model.Channel.IClientChannel>(ChannelEvent));

Do not forget to declare a ChannelEvent method somewhere else in your code, as shown below:

CopyC#
protected void ChannelEvent(Genesyslab.Enterprise.Model.Channel.IClientChannel channel)
{
        System.Console.Write("[ChannelEvent] Status="+ channel.State));
}

Then, you can bind devices with channels. In the following code snippet, DeviceA is a reference of type IDevice.

CopyC#
channelService.BindDevice(deviceA, channel);
 Note: See IDeviceService for further details about creating and managing devices.

See Also

IChannelService Members
Genesyslab.Enterprise.Services Namespace


IChannelService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Members
IChannelService Interface Methods Properties See Also Send Feedback

The IChannelService type exposes the following members.

Methods

Name | Description
AddChannel | Overloaded.
BindDevice | Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel. (Inherited from IChannelManager.)
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel. (Inherited from IChannelManager.)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
SendMessage | Sends a message to the given channel. (Inherited from IChannelManager.)
UnbindDevice | Unbinds a device.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

Properties

Name | Description
ProtocolManager | Returns the associated protocol manager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Methods
IChannelService Interface See Also Send Feedback

The IChannelService type exposes the following members.

Methods

Name | Description
AddChannel | Overloaded.
BindDevice | Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel. (Inherited from IChannelManager.)
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel. (Inherited from IChannelManager.)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
SendMessage | Sends a message to the given channel. (Inherited from IChannelManager.)
UnbindDevice | Unbinds a device.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.AddChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
AddChannel(IClientChannel) | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
AddChannel(IClientChannel, ProtocolConfiguration) | Adds the given channel. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


BindDevice Method

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.BindDevice Method
IChannelService Interface See Also Send Feedback
Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager BindDevice(
    IDevice device,
    IClientChannel channel
)
Visual Basic (Declaration)
Function BindDevice ( _
    device As IDevice, _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ BindDevice(
    IDevice^ device,
    IClientChannel^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to bind with the channel.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChannelService.BindDevice(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Remarks

See also this service description for code examples.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace
Genesyslab.Enterprise.Services..::.IDeviceService


Connect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.Connect Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
Connect()()() | Connects all the channels. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(IClientChannel) | Connects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(Int32) | Connects all the channels. Note: This method is synchronous. (Inherited from IChannelManager.)
Connect(String) | Connects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(IClientChannel, Int32) | Connects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)
Connect(String, Int32) | Connects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


CreateChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.CreateChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
CreateChannel(ProtocolConfiguration) | Creates a channel based on a user configuration instance without a switch abstraction. (Inherited from IChannelManager.)
CreateChannel(ProtocolConfiguration, SwitchModelType) | Creates a channel based on the given user configuration and switch type. (Inherited from IChannelManager.)
CreateChannel(ProtocolConfiguration, String) | Creates a channel based on the given configuration instance. (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration) | Creates a channel without switch asbtraction capability. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol) | Creates a channel based on already existing connection (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration, SwitchModelType) | Creates a named channel, with the given user configuration and switch abstraction capability. (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration, String) | Creates a channel, with the given user configuration and switch abstraction capability. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol, SwitchModelType) | Creates a channel based on already existing connection and switch type. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol, String) | Creates a channel based on already existing connection and switch type. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


Disconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.Disconnect Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
Disconnect()()() | Disconnects all the channels. (Inherited from IChannelManager.)
Disconnect(IClientChannel) | Disconnects the given channel instance. Note: This method is asynchronous. (Inherited from IChannelManager.)
Disconnect(String) | Disconnects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Disconnect(IClientChannel, Int32) | Disconnects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)
Disconnect(String, Int32) | Disconnects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


GetChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.GetChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
GetChannel(IDevice) | Returns a channel object from a device (Inherited from IChannelManager.)
GetChannel(String) | Returns a channel object. (Inherited from IChannelManager.)
GetChannel(Uri) | Returns the channel with the given URI. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


ListChannels Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.ListChannels Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
ListChannels<(Of <(T>)>)()()() | Lists the channels registered in the service. (Inherited from IChannelManager.)
ListChannels()()() | Lists all the channels registered in the service. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.RegisterEvents Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


UnbindDevice Method

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.UnbindDevice Method
IChannelService Interface See Also Send Feedback
Unbinds a device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IChannelManager UnbindDevice(
    IDevice device,
    IClientChannel channel
)
Visual Basic (Declaration)
Function UnbindDevice ( _
    device As IDevice, _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ UnbindDevice(
    IDevice^ device,
    IClientChannel^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to unbind.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChannelService.UnbindDevice(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Properties
IChannelService Interface See Also Send Feedback

The IChannelService type exposes the following members.

Properties

Name | Description
ProtocolManager | Returns the associated protocol manager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


ProtocolManager Property

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.ProtocolManager Property
IChannelService Interface See Also Send Feedback
Returns the associated protocol manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object ProtocolManager { get; }
Visual Basic (Declaration)
ReadOnly Property ProtocolManager As Object
Visual C++
property Object^ ProtocolManager {
    Object^ get ();
}

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IConfigurator Interface

[image]

Enterprise SDK 8.0 Reference API
IConfigurator Interface
Members See Also Send Feedback
Object auto-configuration interface

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IConfigurator
Visual Basic (Declaration)
Public Interface IConfigurator
Visual C++
public interface class IConfigurator

See Also

IConfigurator Members
Genesyslab.Enterprise.Services Namespace


IConfigurator Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurator Members
IConfigurator Interface Methods See Also Send Feedback

Methods

Name | Description
Configure | Overloaded.

See Also

IConfigurator Interface
Genesyslab.Enterprise.Services Namespace


IConfigurator Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurator Methods
IConfigurator Interface See Also Send Feedback

Methods

Name | Description
Configure | Overloaded.

See Also

IConfigurator Interface
Genesyslab.Enterprise.Services Namespace


Configure Method

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurator..::.Configure Method
IConfigurator Interface See Also Send Feedback

Overload List

Name | Description
Configure(IClientChannel, Object) | Configures selected object
Configure<(Of <(T>)>)(IClientChannel, T) | Configures selected object

See Also

IConfigurator Interface
IConfigurator Members
Genesyslab.Enterprise.Services Namespace


Configure Method (IClientChannel, Object)

[image]

Enterprise SDK 8.0 Reference API
IConfigurator..::.Configure Method (IClientChannel, Object)
IConfigurator Interface See Also Send Feedback
Configures selected object

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
Object Configure(
    IClientChannel channel,
    Object obj
)
Visual Basic (Declaration)
Function Configure ( _
    channel As IClientChannel, _
    obj As Object _
) As Object
Visual C++
Object^ Configure(
    IClientChannel^ channel,
    Object^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The Configuration server connection channel
obj
Type: System..::.Object
The object type which will be configured

Return Value

Configured object

Remarks

The

obj

must be decorated by configuration attributes

See Also

IConfigurator Interface
Configure Overload
Genesyslab.Enterprise.Services Namespace


Configure(T) Method (IClientChannel, T)

[image]

Enterprise SDK 8.0 Reference API
IConfigurator..::.Configure<(Of <(T>)>) Method (IClientChannel, T)
IConfigurator Interface See Also Send Feedback
Configures selected object

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T Configure<T>(
    IClientChannel channel,
    T obj
)
Visual Basic (Declaration)
Function Configure(Of T) ( _
    channel As IClientChannel, _
    obj As T _
) As T
Visual C++
generic<typename T>
T Configure(
    IClientChannel^ channel,
    T obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The Configuration server connection channel
obj
Type: T
The object type which will be configured

Type Parameters

T
The object type which will be configured

Return Value

Configured object

Remarks

The

obj

must be decorated by configuration attributes

See Also

IConfigurator Interface
Configure Overload
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Interface
Members See Also Send Feedback
Manages device data.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDeviceDomain
Visual Basic (Declaration)
Public Interface IDeviceDomain
Visual C++
public interface class IDeviceDomain

See Also

IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Members
IDeviceDomain Interface Methods See Also Send Feedback

The IDeviceDomain type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group.
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel.
GetDevices | Returns the all devices associated with the given DN name / tenant.
ListDevices | Overloaded.
RemoveDevice | Removes the given device from the given group.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Methods
IDeviceDomain Interface See Also Send Feedback

The IDeviceDomain type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group.
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel.
GetDevices | Returns the all devices associated with the given DN name / tenant.
ListDevices | Overloaded.
RemoveDevice | Removes the given device from the given group.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


AddDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.AddDevice Method
IDeviceDomain Interface See Also Send Feedback
Adds the given device to the given group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceDomain AddDevice(
    IDevice device,
    IDevice group,
    bool allowEvents
)
Visual Basic (Declaration)
Function AddDevice ( _
    device As IDevice, _
    group As IDevice, _
    allowEvents As Boolean _
) As IDeviceDomain
Visual C++
IDeviceDomain^ AddDevice(
    IDevice^ device,
    IDevice^ group,
    bool allowEvents
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to add to the group
group
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Group of devices
allowEvents
Type: System..::.Boolean
true to enable event reporting for the given device.

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateDevice(String, DeviceType) | Obsolete. Creates a device with a specific name and type (see CME).
CreateDevice(String, IClientChannel, array<IDevice>[]()[]) | Obsolete.
CreateDevice(String, DeviceType, Object) | Obsolete. Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, SwitchConfig, array<IDevice>[]()[]) | Obsolete. Creates a virtual device based on the given configuration. Default tenant is used
CreateDevice(String, String, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, IClientChannel, array<IDevice>[]()[]) |
CreateDevice(String, String, DeviceType, Object) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, SwitchConfig, array<IDevice>[]()[]) | Creates a virtual device based on the given configuration.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with a specific name and type (see CME).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice CreateDevice(
    string name,
    DeviceType deviceType
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    deviceType As DeviceType _
) As IDevice
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
IDevice^ CreateDevice(
    String^ name,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, IClientChannel, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, IClientChannel, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice[] CreateDevice(
    string name,
    IClientChannel channel,
    IDevice[] list
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    channel As IClientChannel, _
    list As IDevice() _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    IClientChannel^ channel,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, DeviceType, Object)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, DeviceType, Object)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice CreateDevice(
    string name,
    DeviceType deviceType,
    Object stateController
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    deviceType As DeviceType, _
    stateController As Object _
) As IDevice
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
IDevice^ CreateDevice(
    String^ name,
    DeviceType deviceType,
    Object^ stateController
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.
stateController
Type: System..::.Object
Controller object

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, , IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, , array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given configuration. Default tenant is used

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice[] CreateDevice(
    string name,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
config
Type: SwitchConfig
Configuration structure.
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized.

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, IClientChannel, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, IClientChannel, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    IClientChannel channel,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    channel As IClientChannel, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    IClientChannel^ channel,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.
stateController
Type: System..::.Object
State controller.

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, , IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, , array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given configuration.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
tenant
Type: System..::.String
Name of related tenant to which device belongd to
config
Type: SwitchConfig
Configuration structure.
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized.

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
DeleteDevice(IDevice) | Deletes a device.
DeleteDevice(String, String, String) | Deletes the given device.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method (IDevice)
IDeviceDomain Interface See Also Send Feedback
Deletes a device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceDomain DeleteDevice(
    IDevice device
)
Visual Basic (Declaration)
Function DeleteDevice ( _
    device As IDevice _
) As IDeviceDomain
Visual C++
IDeviceDomain^ DeleteDevice(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to delete.

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
DeleteDevice Overload
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method (String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method (String, String, String)
IDeviceDomain Interface See Also Send Feedback
Deletes the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void DeleteDevice(
    string name,
    string tenant,
    string channel
)
Visual Basic (Declaration)
Sub DeleteDevice ( _
    name As String, _
    tenant As String, _
    channel As String _
)
Visual C++
void DeleteDevice(
    String^ name,
    String^ tenant,
    String^ channel
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
Tenant name
channel
Type: System..::.String

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.DeleteDevice(System.String,System.String,System.String)"]

See Also

IDeviceDomain Interface
DeleteDevice Overload
Genesyslab.Enterprise.Services Namespace


GetDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.GetDevice Method
IDeviceDomain Interface See Also Send Feedback
Returns the device associated with the given DN name / tenant / Channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice GetDevice(
    string name,
    string tenant,
    string channel
)
Visual Basic (Declaration)
Function GetDevice ( _
    name As String, _
    tenant As String, _
    channel As String _
) As IDevice
Visual C++
IDevice^ GetDevice(
    String^ name,
    String^ tenant,
    String^ channel
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
tenant name
channel
Type: System..::.String

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.GetDevice(System.String,System.String,System.String)"]

Return Value

Created device.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


GetDevices Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.GetDevices Method
IDeviceDomain Interface See Also Send Feedback
Returns the all devices associated with the given DN name / tenant.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] GetDevices(
    string name,
    string tenant
)
Visual Basic (Declaration)
Function GetDevices ( _
    name As String, _
    tenant As String _
) As IDevice()
Visual C++
array<IDevice^>^ GetDevices(
    String^ name,
    String^ tenant
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
tenant name

Return Value

Created devices.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
ListDevices(IDevice) | Lists all the devices which compose the given device or which are stored in the service.
ListDevices(IDevice, String) | Lists all the devices which compose the given device or which are stored in the service.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


ListDevices Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (IDevice)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which compose the given device or which are stored in the service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] ListDevices(
    IDevice device
)
Visual Basic (Declaration)
Function ListDevices ( _
    device As IDevice _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device name, or null to get all the devices of the service.

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (IDevice, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (IDevice, String)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which compose the given device or which are stored in the service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] ListDevices(
    IDevice device,
    string channel
)
Visual Basic (Declaration)
Function ListDevices ( _
    device As IDevice, _
    channel As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    IDevice^ device,
    String^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device name, or null to get all the devices of the service.
channel
Type: System..::.String
channel

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


RemoveDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.RemoveDevice Method
IDeviceDomain Interface See Also Send Feedback
Removes the given device from the given group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceDomain RemoveDevice(
    IDevice device,
    IDevice group
)
Visual Basic (Declaration)
Function RemoveDevice ( _
    device As IDevice, _
    group As IDevice _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RemoveDevice(
    IDevice^ device,
    IDevice^ group
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to remove from the specified group
group
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Group

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.RemoveDevice(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


IDeviceService Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceService Interface
Members Example See Also Send Feedback
Manages handlers and filters on devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IDeviceService : IDeviceDomain
Visual Basic (Declaration)
Public Interface IDeviceService _
    Implements IDeviceDomain
Visual C++
public interface class IDeviceService : IDeviceDomain

Examples

The following code snippet shows how to register a handler on a device. First, retrieve an instance of the service.
CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);
IDeviceService deviceService = EsdkService.Resolve<IDeviceService>("deviceService");
 Then, registers a handler on a device, of type extension for instance.
CopyC#
IDevice deviceA = deviceService.CreateDevice("Device name", DeviceType.Extension);
deviceService.RegisterEvents(deviceA, new Action<IEnvelope<IDN>>(DeviceEvent));
 Also, declare your event handler.
CopyC#
protected void DeviceEvent(IEnvelope<IDN> tsp)
{
    if (tsp != null)
    {
        int referenceId = tsp.Header.CorrelationId;
        string dn = tsp.Body.Name;
        //...
     }
}

See Also

IDeviceService Members
Genesyslab.Enterprise.Services Namespace


IDeviceService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService Members
IDeviceService Interface Methods See Also Send Feedback

The IDeviceService type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group. (Inherited from IDeviceDomain.)
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel. (Inherited from IDeviceDomain.)
GetDevices | Returns the all devices associated with the given DN name / tenant. (Inherited from IDeviceDomain.)
ListDevices | Overloaded.
ListFilter<(Of <(T>)>) | Returns the list of filters for the given device.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers an event filter for the given device.
RemoveDevice | Removes the given device from the given group. (Inherited from IDeviceDomain.)
UnRegisterEvents | Unregisters the given handler for the specified device.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given device.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


IDeviceService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService Methods
IDeviceService Interface See Also Send Feedback

The IDeviceService type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group. (Inherited from IDeviceDomain.)
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel. (Inherited from IDeviceDomain.)
GetDevices | Returns the all devices associated with the given DN name / tenant. (Inherited from IDeviceDomain.)
ListDevices | Overloaded.
ListFilter<(Of <(T>)>) | Returns the list of filters for the given device.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers an event filter for the given device.
RemoveDevice | Removes the given device from the given group. (Inherited from IDeviceDomain.)
UnRegisterEvents | Unregisters the given handler for the specified device.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given device.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


CreateDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.CreateDevice Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
CreateDevice(String, DeviceType) | Obsolete. Creates a device with a specific name and type (see CME). (Inherited from IDeviceDomain.)
CreateDevice(String, IClientChannel, array<IDevice>[]()[]) | Obsolete. (Inherited from IDeviceDomain.)
CreateDevice(String, DeviceType, Object) | Obsolete. Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, SwitchConfig, array<IDevice>[]()[]) | Obsolete. Creates a virtual device based on the given configuration. Default tenant is used (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, IClientChannel, array<IDevice>[]()[]) | (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, SwitchConfig, array<IDevice>[]()[]) | Creates a virtual device based on the given configuration. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.DeleteDevice Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
DeleteDevice(IDevice) | Deletes a device. (Inherited from IDeviceDomain.)
DeleteDevice(String, String, String) | Deletes the given device. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.ListDevices Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
ListDevices(IDevice) | Lists all the devices which compose the given device or which are stored in the service. (Inherited from IDeviceDomain.)
ListDevices(IDevice, String) | Lists all the devices which compose the given device or which are stored in the service. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.ListFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Returns the list of filters for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IDevice device
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    device As IDevice _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.

Type Parameters

T
Type for the returned filters.

Return Value

Filters for this device.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>)) | Registers the given handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers the given event handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers the given event handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers the given event handler for the given device.

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)))

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>))
IDeviceService Interface See Also Send Feedback
Registers the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceDomain RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler method.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<>[]()[], array<IFilter>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to register.
strategyList
Type: array< IStrategy >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Event handler to register.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategies.
filterList
Type: array< System..::.Attribute >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},System.Attribute[],System.Attribute[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to register.
strategyList
Type: array< System..::.String >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Registers an event filter for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceService RegisterFilter<T>(
    IDevice device,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    device As IDevice, _
    filter As T _
) As IDeviceService
Visual C++
generic<typename T>
IDeviceService^ RegisterFilter(
    IDevice^ device,
    T filter
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
filter
Type: T
Filter to register.

Type Parameters

T
Filter type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterFilter``1(Genesyslab.Enterprise.Model.Device.IDevice,``0)"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterEvents Method
IDeviceService Interface See Also Send Feedback
Unregisters the given handler for the specified device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceDomain UnRegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ UnRegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to unregister.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Unregisters a filter for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDeviceService UnRegisterFilter<T>(
    IDevice device,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    device As IDevice, _
    filter As T _
) As IDeviceService
Visual C++
generic<typename T>
IDeviceService^ UnRegisterFilter(
    IDevice^ device,
    T filter
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
filter
Type: T
Filter to unregister.

Type Parameters

T
Filter type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Device.IDevice,``0)"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


IEntityDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain Interface
Members See Also Send Feedback
Manages entities and identities for groups and persons.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEntityDomain : IAliasManager
Visual Basic (Declaration)
Public Interface IEntityDomain _
    Implements IAliasManager
Visual C++
public interface class IEntityDomain : IAliasManager

See Also

IEntityDomain Members
Genesyslab.Enterprise.Services Namespace


IEntityDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain Members
IEntityDomain Interface Methods See Also Send Feedback

The IEntityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddRole | Adds a Role.
CreatePerson | Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.
DeletePerson | Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListPersons | Lists the Identities (group) for the specified group.
ListRoles | Lists the roles.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RemoveAlias | Overloaded.
RemovePerson | Removes an Identity from and existing object Group.
RemoveRole | Removes the specified Role.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


IEntityDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain Methods
IEntityDomain Interface See Also Send Feedback

The IEntityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddRole | Adds a Role.
CreatePerson | Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.
DeletePerson | Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListPersons | Lists the Identities (group) for the specified group.
ListRoles | Lists the roles.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RemoveAlias | Overloaded.
RemovePerson | Removes an Identity from and existing object Group.
RemoveRole | Removes the specified Role.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


AddRole Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.AddRole Method
IEntityDomain Interface See Also Send Feedback
Adds a Role.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEntityDomain AddRole(
    IRole role
)
Visual Basic (Declaration)
Function AddRole ( _
    role As IRole _
) As IEntityDomain
Visual C++
IEntityDomain^ AddRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.AddRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.AddRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


CreatePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.CreatePerson Method
IEntityDomain Interface See Also Send Feedback
Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity CreatePerson(
    string name
)
Visual Basic (Declaration)
Function CreatePerson ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ CreatePerson(
    String^ name
)

Parameters

name
Type: System..::.String
Name to create.

Return Value

Created identity.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


DeletePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.DeletePerson Method
IEntityDomain Interface See Also Send Feedback
Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEntityDomain DeletePerson(
    IEntity group
)
Visual Basic (Declaration)
Function DeletePerson ( _
    group As IEntity _
) As IEntityDomain
Visual C++
IEntityDomain^ DeletePerson(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
Group

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.DeletePerson(Genesyslab.Enterprise.Model.Identity.IEntity)"]

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListPersons Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.ListPersons Method
IEntityDomain Interface See Also Send Feedback
Lists the Identities (group) for the specified group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEntity[] ListPersons(
    IEntity group
)
Visual Basic (Declaration)
Function ListPersons ( _
    group As IEntity _
) As IEntity()
Visual C++
array<IEntity^>^ ListPersons(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity

[Missing <param name="group"/> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.ListPersons(Genesyslab.Enterprise.Model.Identity.IEntity)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.ListPersons(Genesyslab.Enterprise.Model.Identity.IEntity)"]

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.ListRoles Method
IEntityDomain Interface See Also Send Feedback
Lists the roles.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IRole[] ListRoles()
Visual Basic (Declaration)
Function ListRoles As IRole()
Visual C++
array<IRole^>^ ListRoles()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.ListRoles"]

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemoveAlias Method
IEntityDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IEntityDomain Interface
IEntityDomain Members
Genesyslab.Enterprise.Services Namespace


RemovePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemovePerson Method
IEntityDomain Interface See Also Send Feedback
Removes an Identity from and existing object Group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEntityDomain RemovePerson(
    IEntity group
)
Visual Basic (Declaration)
Function RemovePerson ( _
    group As IEntity _
) As IEntityDomain
Visual C++
IEntityDomain^ RemovePerson(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity

[Missing <param name="group"/> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.RemovePerson(Genesyslab.Enterprise.Model.Identity.IEntity)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.RemovePerson(Genesyslab.Enterprise.Model.Identity.IEntity)"]

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveRole Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemoveRole Method
IEntityDomain Interface See Also Send Feedback
Removes the specified Role.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEntityDomain RemoveRole(
    IRole role
)
Visual Basic (Declaration)
Function RemoveRole ( _
    role As IRole _
) As IEntityDomain
Visual C++
IEntityDomain^ RemoveRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole

[Missing <param name="role"/> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.RemoveRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEntityDomain.RemoveRole(Genesyslab.Enterprise.Model.ComponentModel.IRole)"]

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Interface

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Interface
Members See Also Send Feedback
Event Manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEventManager<D, T>
where D : class
Visual Basic (Declaration)
Public Interface IEventManager(Of D As Class, T)
Visual C++
generic<typename D, typename T>
where D : ref class
public interface class IEventManager

Type Parameters

D

[Missing <typeparam name="D"/> documentation for "T:Genesyslab.Enterprise.Services.IEventManager`2"]

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.IEventManager`2"]

See Also

IEventManager<(Of <(D, T>)>) Members
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Members
IEventManager<(Of <(D, T>)>) Interface Methods See Also Send Feedback

The IEventManager<(Of <(D, T>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method.
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel.
UnRegisterEvents | Unregisters a specific handler for a given channel.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Methods
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback

The IEventManager<(Of <(D, T>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method.
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel.
UnRegisterEvents | Unregisters a specific handler for a given channel.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.AddChannel Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel _
) As D
Visual C++
D AddChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.AddChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers a callback method on the given channel with attribute filters.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters.

See Also

IEventManager<(Of <(D, T>)>) Interface
IEventManager<(Of <(D, T>)>) Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T))

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>))
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method for the given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T) _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1})"]

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1})"]

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<>[]()[], array<IFilter>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.
strategyList
Type: array< IStrategy >[]()[]
The strategies to apply with filters. Strategy must be of filter type.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Array of filters.

Return Value

ISupervisorService

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with attribute filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.
strategyList
Type: array< System..::.Attribute >[]()[]
Array of strategies attribute. Strategy must be of filter type
filterList
Type: array< System..::.Attribute >[]()[]
Array of filters attributes (defined within the code).

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1},System.Attribute[],System.Attribute[])"]

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As String(), _
    filterList As IFilter() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.
strategyList
Type: array< System..::.String >[]()[]
Names of the strategies to apply with the filters. Strategy must be of IFilter type.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
List of filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RemoveChannel Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Removes the given channel from the monitoring list. Your application no longer receives events for this channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function RemoveChannel ( _
    channel As IClientChannel _
) As D
Visual C++
D RemoveChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.RemoveChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.UnRegisterEvents Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Unregisters a specific handler for a given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
D UnRegisterEvents(
    IClientChannel channel,
    Action<T> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T) _
) As D
Visual C++
D UnRegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1})"]

handler
Type: System..::.Action <(Of <( T >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEventManager`2.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{`1})"]

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Interface
Members See Also Send Feedback
Manages the identity domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIdentityDomain : IAliasManager,
    IRoleManager<IIdentity>
Visual Basic (Declaration)
Public Interface IIdentityDomain _
    Implements IAliasManager, IRoleManager(Of IIdentity)
Visual C++
public interface class IIdentityDomain : IAliasManager,
    IRoleManager<IIdentity^>

See Also

IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Members
IIdentityDomain Interface Methods See Also Send Feedback

The IIdentityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group.
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity.
GetIdentities | Returns all the registered identity intances.
GetIdentity | Retrieves the identity associated with the given name.
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component).
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance.
RemoveIdentity | Removes the Identity from the given Identity Group.
SetDevice | Associates a device with an identity instance.
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Methods
IIdentityDomain Interface See Also Send Feedback

The IIdentityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group.
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity.
GetIdentities | Returns all the registered identity intances.
GetIdentity | Retrieves the identity associated with the given name.
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component).
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance.
RemoveIdentity | Removes the Identity from the given Identity Group.
SetDevice | Associates a device with an identity instance.
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


AddIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.AddIdentity Method
IIdentityDomain Interface See Also Send Feedback
Adds the Identity to the given Identity group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityDomain AddIdentity(
    IIdentity identity,
    IIdentity group,
    bool allowEvents
)
Visual Basic (Declaration)
Function AddIdentity ( _
    identity As IIdentity, _
    group As IIdentity, _
    allowEvents As Boolean _
) As IIdentityDomain
Visual C++
IIdentityDomain^ AddIdentity(
    IIdentity^ identity,
    IIdentity^ group,
    bool allowEvents
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity to add.
group
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Group of identities.
allowEvents
Type: System..::.Boolean
True to allow event propagation to the upper layer.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateIdentity(String) | Creates a new non-group Identity with the specified name.
CreateIdentity(String, Object) | Creates a new non-composite Identity with the specified name and controller.

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method (String)
IIdentityDomain Interface See Also Send Feedback
Creates a new non-group Identity with the specified name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity CreateIdentity(
    string name
)
Visual Basic (Declaration)
Function CreateIdentity ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ CreateIdentity(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.CreateIdentity(System.String)"]

Return Value

IIdentity

See Also

IIdentityDomain Interface
CreateIdentity Overload
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method (String, Object)
IIdentityDomain Interface See Also Send Feedback
Creates a new non-composite Identity with the specified name and controller.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity CreateIdentity(
    string name,
    Object controller
)
Visual Basic (Declaration)
Function CreateIdentity ( _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
IIdentity^ CreateIdentity(
    String^ name,
    Object^ controller
)

Parameters

name
Type: System..::.String
Name of the new identity.
controller
Type: System..::.Object
Controller.

Return Value

IIdentity

See Also

IIdentityDomain Interface
CreateIdentity Overload
Genesyslab.Enterprise.Services Namespace


DeleteIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.DeleteIdentity Method
IIdentityDomain Interface See Also Send Feedback
Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityDomain DeleteIdentity(
    IIdentity identity
)
Visual Basic (Declaration)
Function DeleteIdentity ( _
    identity As IIdentity _
) As IIdentityDomain
Visual C++
IIdentityDomain^ DeleteIdentity(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity

[Missing <param name="identity"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.DeleteIdentity(Genesyslab.Enterprise.Model.Identity.IIdentity)"]

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetActionsRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role. (Inherited from IRoleManager<(Of <(T>)>).)
GetActionsRole<(Of <(U>)>)(RoleProfileType) | Gets the actions of a role profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


GetDevices Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetDevices Method
IIdentityDomain Interface See Also Send Feedback
Returns all the devices associated with this identity.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDevice[] GetDevices(
    IIdentity identity
)
Visual Basic (Declaration)
Function GetDevices ( _
    identity As IIdentity _
) As IDevice()
Visual C++
array<IDevice^>^ GetDevices(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
identity instance

Return Value

IDevice[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetIdentities Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetIdentities Method
IIdentityDomain Interface See Also Send Feedback
Returns all the registered identity intances.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity[] GetIdentities()
Visual Basic (Declaration)
Function GetIdentities As IIdentity()
Visual C++
array<IIdentity^>^ GetIdentities()

Return Value

IIdentity[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetIdentity Method
IIdentityDomain Interface See Also Send Feedback
Retrieves the identity associated with the given name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity GetIdentity(
    string name
)
Visual Basic (Declaration)
Function GetIdentity ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ GetIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
Name.

Return Value

IIdentity

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetObjectRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
GetObjectRole(T, RoleProfileType) | Gets the Role for an object according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.HasRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, RoleProfileType) | Gets the Role availability for an object type according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, Type) | Gets the Role availability for an object type according to the action. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
IsIdentity(IIdentity) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities.
IsIdentity(String) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method (IIdentity)
IIdentityDomain Interface See Also Send Feedback
Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsIdentity(
    IIdentity identity
)
Visual Basic (Declaration)
Function IsIdentity ( _
    identity As IIdentity _
) As Boolean
Visual C++
bool IsIdentity(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity

[Missing <param name="identity"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.IsIdentity(Genesyslab.Enterprise.Model.Identity.IIdentity)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.IsIdentity(Genesyslab.Enterprise.Model.Identity.IIdentity)"]

See Also

IIdentityDomain Interface
IsIdentity Overload
Genesyslab.Enterprise.Services Namespace


IsIdentity Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method (String)
IIdentityDomain Interface See Also Send Feedback
Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsIdentity(
    string name
)
Visual Basic (Declaration)
Function IsIdentity ( _
    name As String _
) As Boolean
Visual C++
bool IsIdentity(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.IsIdentity(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.IsIdentity(System.String)"]

See Also

IIdentityDomain Interface
IsIdentity Overload
Genesyslab.Enterprise.Services Namespace


ListIdentities Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.ListIdentities Method
IIdentityDomain Interface See Also Send Feedback
Lists all the identities that belong to an identity group (which is a composite component).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentity[] ListIdentities(
    IIdentity identity
)
Visual Basic (Declaration)
Function ListIdentities ( _
    identity As IIdentity _
) As IIdentity()
Visual C++
array<IIdentity^>^ ListIdentities(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity to search.

Return Value

IIdentity[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.ListRoles Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role. (Inherited from IRoleManager<(Of <(T>)>).)
ListRoles(T) | Gets the list of Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveAlias Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


RemoveDevice Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveDevice Method
IIdentityDomain Interface See Also Send Feedback
Removes the device from the given identity instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityDomain RemoveDevice(
    IIdentity identity,
    IDevice device
)
Visual Basic (Declaration)
Function RemoveDevice ( _
    identity As IIdentity, _
    device As IDevice _
) As IIdentityDomain
Visual C++
IIdentityDomain^ RemoveDevice(
    IIdentity^ identity,
    IDevice^ device
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity target instance.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to be linked.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveIdentity Method
IIdentityDomain Interface See Also Send Feedback
Removes the Identity from the given Identity Group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityDomain RemoveIdentity(
    IIdentity identity,
    IIdentity group
)
Visual Basic (Declaration)
Function RemoveIdentity ( _
    identity As IIdentity, _
    group As IIdentity _
) As IIdentityDomain
Visual C++
IIdentityDomain^ RemoveIdentity(
    IIdentity^ identity,
    IIdentity^ group
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity

[Missing <param name="identity"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.RemoveIdentity(Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Model.Identity.IIdentity)"]

group
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Target group.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


SetDevice Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.SetDevice Method
IIdentityDomain Interface See Also Send Feedback
Associates a device with an identity instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityDomain SetDevice(
    IIdentity identity,
    IDevice device
)
Visual Basic (Declaration)
Function SetDevice ( _
    identity As IIdentity, _
    device As IDevice _
) As IIdentityDomain
Visual C++
IIdentityDomain^ SetDevice(
    IIdentity^ identity,
    IDevice^ device
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity

[Missing <param name="identity"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.SetDevice(Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Model.Device.IDevice)"]

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Services.IIdentityDomain.SetDevice(Genesyslab.Enterprise.Model.Identity.IIdentity,Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


IIdentityService Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityService Interface
Members Example See Also Send Feedback
Manages the identities.
Note: To use an agent with a device, create a link between these objects with the IIdentityService.SetDevice() method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIdentityService : IIdentityDomain,
    IAliasManager, IRoleManager<IIdentity>
Visual Basic (Declaration)
Public Interface IIdentityService _
    Implements IIdentityDomain, IAliasManager, IRoleManager(Of IIdentity)
Visual C++
public interface class IIdentityService : IIdentityDomain,
    IAliasManager, IRoleManager<IIdentity^>

Examples

Associate an Agent with a Device and monitor Agent Events.
CopyC#
IIdentityService identityService = EsdkService.Resolve<IIdentityService>("identityService");
            if (identityService != null)
            {
               //Create Agent
               agent = identityService.CreateIdentity("Lucent_1000") as IAgent;

               //Associate the Agent with a Device
               identityService.SetDevice(agent, device);

               //Register a handler
               identityService.RegisterEvents(agentA, new Action<IEnvelope<IAgent>>(AgentEvent));
               //...
            }
 To make this snippet work, you need to declare an AgentEvent() method:
CopyC#
[EnterpriseAgentEvent()]
protected void AgentEvent(IEnvelope<IAgent> tsp)
{
    int referenceId = tsp.Header.CorrelationId;
    //...
}

See Also

IIdentityService Members
Genesyslab.Enterprise.Services Namespace


IIdentityService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService Members
IIdentityService Interface Methods See Also Send Feedback

The IIdentityService type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group. (Inherited from IIdentityDomain.)
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation. (Inherited from IIdentityDomain.)
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity. (Inherited from IIdentityDomain.)
GetIdentities | Returns all the registered identity intances. (Inherited from IIdentityDomain.)
GetIdentity | Retrieves the identity associated with the given name. (Inherited from IIdentityDomain.)
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListFilter<(Of <(T>)>) | Returns the filters registered for the given agent.
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component). (Inherited from IIdentityDomain.)
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given agent.
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance. (Inherited from IIdentityDomain.)
RemoveIdentity | Removes the Identity from the given Identity Group. (Inherited from IIdentityDomain.)
SetDevice | Associates a device with an identity instance. (Inherited from IIdentityDomain.)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters for the events of the given agent.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given agent.
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


IIdentityService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService Methods
IIdentityService Interface See Also Send Feedback

The IIdentityService type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group. (Inherited from IIdentityDomain.)
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation. (Inherited from IIdentityDomain.)
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity. (Inherited from IIdentityDomain.)
GetIdentities | Returns all the registered identity intances. (Inherited from IIdentityDomain.)
GetIdentity | Retrieves the identity associated with the given name. (Inherited from IIdentityDomain.)
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListFilter<(Of <(T>)>) | Returns the filters registered for the given agent.
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component). (Inherited from IIdentityDomain.)
ListRoles | Overloaded.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given agent.
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveDevice | Removes the device from the given identity instance. (Inherited from IIdentityDomain.)
RemoveIdentity | Removes the Identity from the given Identity Group. (Inherited from IIdentityDomain.)
SetDevice | Associates a device with an identity instance. (Inherited from IIdentityDomain.)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters for the events of the given agent.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given agent.
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.CreateIdentity Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
CreateIdentity(String) | Creates a new non-group Identity with the specified name. (Inherited from IIdentityDomain.)
CreateIdentity(String, Object) | Creates a new non-composite Identity with the specified name and controller. (Inherited from IIdentityDomain.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.GetActionsRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role. (Inherited from IRoleManager<(Of <(T>)>).)
GetActionsRole<(Of <(U>)>)(RoleProfileType) | Gets the actions of a role profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.GetObjectRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
GetObjectRole(T, RoleProfileType) | Gets the Role for an object according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.HasRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, RoleProfileType) | Gets the Role availability for an object type according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, Type) | Gets the Role availability for an object type according to the action. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.IsIdentity Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
IsIdentity(IIdentity) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities. (Inherited from IIdentityDomain.)
IsIdentity(String) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities. (Inherited from IIdentityDomain.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.ListFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Returns the filters registered for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IIdentity agent
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    agent As IIdentity _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IIdentity^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent

Type Parameters

T
Filter type.

Return Value

Filters of the agent.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.ListRoles Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role. (Inherited from IRoleManager<(Of <(T>)>).)
ListRoles(T) | Gets the list of Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>)) | Registers an event handler for the given agent.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers for agent events with a handler, a strategy list, and a filter list.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers for agent events with a handler, and arrays of attributes for strategies and filters.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers for agent events with a handler, a list of strategy IDs, and a filter list.

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)))

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>))
IIdentityService Interface Example See Also Send Feedback
Registers an event handler for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)) _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler method to register.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.RegisterEvents(Genesyslab.Enterprise.Model.Identity.IIdentity,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Agent.IAgent}})"]

Examples

CopyC#
IIdentityService identityService = EsdkService.Resolve<IIdentityService>("identityService");
            if (identityService != null)
            {
               //Create Agent
               agent = identityService.CreateIdentity("Lucent_1000") as IAgent;

               //Associate the Agent with a Device
               identityService.SetDevice(agent, device);

               //Register a handler
               identityService.RegisterEvents(agentA, new Action<IEnvelope<IAgent>>(AgentEvent));
               //...
            }
 To make this snippet work, you need to declare an AgentEvent() method:
CopyC#
[EnterpriseAgentEvent()]
protected void AgentEvent(IEnvelope<IAgent> tsp)
{
    int referenceId = tsp.Header.CorrelationId;
    //...
}

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<>[]()[], array<IFilter>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, a strategy list, and a filter list.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to register.
strategyList
Type: array< IStrategy >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.RegisterEvents(Genesyslab.Enterprise.Model.Identity.IIdentity,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Agent.IAgent}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, and arrays of attributes for strategies and filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler method to register.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategy attributes
filterList
Type: array< System..::.Attribute >[]()[]
Filter attributes.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.RegisterEvents(Genesyslab.Enterprise.Model.Identity.IIdentity,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Agent.IAgent}},System.Attribute[],System.Attribute[])"]

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, a list of strategy IDs, and a filter list.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to register.
strategyList
Type: array< System..::.String >[]()[]
Strategy IDs.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.RegisterEvents(Genesyslab.Enterprise.Model.Identity.IIdentity,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Agent.IAgent}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Registers a filter for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService RegisterFilter<T>(
    IIdentity agent,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    agent As IIdentity, _
    filter As T _
) As IIdentityService
Visual C++
generic<typename T>
IIdentityService^ RegisterFilter(
    IIdentity^ agent,
    T filter
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
filter
Type: T
Registers the filter for the given agent.

Type Parameters

T
Type for the filter.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.RegisterFilter``1(Genesyslab.Enterprise.Model.Identity.IIdentity,``0)"]

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RemoveAlias Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.UnRegisterEvents Method
IIdentityService Interface See Also Send Feedback
Unregisters for the events of the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService UnRegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)) _
) As IIdentityService
Visual C++
IIdentityService^ UnRegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to unregister.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.UnRegisterEvents(Genesyslab.Enterprise.Model.Identity.IIdentity,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Agent.IAgent}})"]

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.UnRegisterFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Unregisters a filter for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IIdentityService UnRegisterFilter<T>(
    IIdentity agent,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    agent As IIdentity, _
    filter As T _
) As IIdentityService
Visual C++
generic<typename T>
IIdentityService^ UnRegisterFilter(
    IIdentity^ agent,
    T filter
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
filter
Type: T
The filter to unregister.

Type Parameters

T
Type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIdentityService.UnRegisterFilter``1(Genesyslab.Enterprise.Model.Identity.IIdentity,``0)"]

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


IIMDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IIMDomain Interface
Members See Also Send Feedback
Manages Instant Messaging data.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMDomain
Visual Basic (Declaration)
Public Interface IIMDomain
Visual C++
public interface class IIMDomain

See Also

IIMDomain Members
Genesyslab.Enterprise.Services Namespace


IIMDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain Members
IIMDomain Interface Methods See Also Send Feedback

The IIMDomain type exposes the following members.

Methods

Name | Description
GetAttachedData | Returns the user defined attached data of this interaction.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SetAttachedData | Overloaded.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


IIMDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain Methods
IIMDomain Interface See Also Send Feedback

The IIMDomain type exposes the following members.

Methods

Name | Description
GetAttachedData | Returns the user defined attached data of this interaction.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SetAttachedData | Overloaded.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetAttachedData Method
IIMDomain Interface See Also Send Feedback
Returns the user defined attached data of this interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.GetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IDictionary<string, Object>

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.RemoveAttachedData Method
IIMDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.RemoveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String)"]

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.RemoveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String)"]

Return Value

IInteraction

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SaveAttachedData Method
IIMDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
IInteraction^ SaveAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.SaveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.SaveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically.
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method (IInteraction, KeyValueCollection)
IIMDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

data
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.IIMDomain.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

IInteraction

See Also

IIMDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method (IInteraction, String, Object)
IIMDomain Interface See Also Send Feedback
Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

IInteraction

See Also

IIMDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IIMService Interface

[image]

Enterprise SDK 8.0 Reference API
IIMService Interface
Members Example See Also Send Feedback
Manages the instant messaging features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IIMService : IIMDomain,
    IBrokerSubscriber<IEnvelope<IIMInteraction>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>,
    IPersistable<IIMInteraction>
Visual Basic (Declaration)
Public Interface IIMService _
    Implements IIMDomain, IBrokerSubscriber(Of IEnvelope(Of IIMInteraction)),  _
    IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)), IPersistable(Of IIMInteraction)
Visual C++
public interface class IIMService : IIMDomain,
    IBrokerSubscriber<IEnvelope<IIMInteraction^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>,
    IPersistable<IIMInteraction^>

Examples

As a start, you need to get a reference on the ESDK instance of the Instant Messaging Service.
CopyC#
IIMService imService = EsdkService.Resolve<IIMService>("IMService");
 To start a new instant messaging session, follow these steps:
  • Connect a channel and register a device on a switch which handles Instant Messaging. (See IChannelService and IDeviceService).
  • Login an agent on a device.
  • Start a session on this device with the IM service as shown in the following code snippet.
CopyC#
IAsyncResult asyncResult = imService.BeginMakeCall(deviceA, channel, OtherDN, Genesyslab.Enterprise.Model.Interaction.MakeCallType.Regular, null, userData, null, null, null, null);
IEnvelope<IInteraction> env = imService.EndMakeCall(asyncResult);
IIMInteraction ixn = (IIMInteraction) env.Body;
imService.SendMessage(ixn, "message", "text/html");
IParty[] colParties = ixn.Parties;
 Above, our code starts asynchronously the IM session. Once started, this session corresponds to a new IIMInteraction which is used till the session ends. Then, you can use the IInteractionService to monitor status changes and new instant messages. You need to register an interaction event handler to receive the instant messages (see the IInteractionService for further details.) The following code snippet retrieves the last instant message of the updated interaction.
CopyC#
 [EnterpriseInteractionEvent("TServerSIPChannel")]
 protected void InteractionEvent(IEnvelope<IInteraction> tsp)
 {
    if (tsp != null)
    {
        if ( (tsp.Header != null) && (tsp.Body != null))
        {
            if (tsp.Header.CurrentContext.ContextState == ContextStateType.Updated)
            {
                IIMInteraction interaction = (IIMInteraction) tsp.Body;
                if (interaction != null)
                {
                    if (interaction.IMEvent != null)
                    {
                        // Use IMEvent field to update your application with the last event received.
                    }
                }
            }
        }
    }
}
 To stop the session, use the IInteractionService.releaseCall() method.

See Also

IIMService Members
Genesyslab.Enterprise.Services Namespace


IIMService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Members
IIMService Interface Methods Properties See Also Send Feedback

The IIMService type exposes the following members.

Methods

Name | Description
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IIMDomain.)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
MakeCall | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
ReleaseCall | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SendMessage | Overloaded.
SetAttachedData | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


IIMService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Methods
IIMService Interface See Also Send Feedback

The IIMService type exposes the following members.

Methods

Name | Description
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IIMDomain.)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
MakeCall | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
ReleaseCall | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SendMessage | Overloaded.
SetAttachedData | Overloaded.

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetList Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


MakeCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.MakeCall Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
MakeCall(IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) | Starts a new instant messaging session. See the service description for a code sample.
MakeCall(IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection) |
MakeCall(IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Starts a new instant messaging session. See the service description for a code sample.
MakeCall(IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32) | Starts a new instant messaging session. See the service description for a code sample.

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


MakeCall Method (IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.MakeCall Method (IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IIMService Interface See Also Send Feedback
Starts a new instant messaging session. See the service description for a code sample.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void MakeCall(
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Sub MakeCall ( _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
)
Visual C++
void MakeCall(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent (the caller).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel to use.
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons of the call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Call extensions.

See Also

IIMService Interface
MakeCall Overload
Genesyslab.Enterprise.Services Namespace


MakeCall Method (IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.MakeCall Method (IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection)
IIMService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void MakeCall(
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Sub MakeCall ( _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
)
Visual C++
void MakeCall(
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

device
Type: Genesyslab.Enterprise.Core..::.IDN

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

otherDN
Type: System..::.String

[Missing <param name="otherDN"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType

[Missing <param name="makeCallType"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

location
Type: System..::.String

[Missing <param name="location"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="userData"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IIMService.MakeCall(Genesyslab.Enterprise.Core.IDN,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.MakeCallType,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IIMService Interface
MakeCall Overload
Genesyslab.Enterprise.Services Namespace


MakeCall Method (IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.MakeCall Method (IAgent, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IIMService Interface See Also Send Feedback
Starts a new instant messaging session. See the service description for a code sample.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void MakeCall(
    IAgent agent,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Sub MakeCall ( _
    agent As IAgent, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
)
Visual C++
void MakeCall(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent (the caller).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel to use.
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons of the call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Call extensions.
timeOut
Type: System..::.Int32
Timeout.

See Also

IIMService Interface
MakeCall Overload
Genesyslab.Enterprise.Services Namespace


MakeCall Method (IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.MakeCall Method (IDN, IClientChannel, String, MakeCallType, String, KeyValueCollection, KeyValueCollection, KeyValueCollection, Int32)
IIMService Interface See Also Send Feedback
Starts a new instant messaging session. See the service description for a code sample.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void MakeCall(
    IDN device,
    IClientChannel channel,
    string otherDN,
    MakeCallType makeCallType,
    string location,
    KeyValueCollection userData,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Sub MakeCall ( _
    device As IDN, _
    channel As IClientChannel, _
    otherDN As String, _
    makeCallType As MakeCallType, _
    location As String, _
    userData As KeyValueCollection, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
)
Visual C++
void MakeCall(
    IDN^ device,
    IClientChannel^ channel,
    String^ otherDN,
    MakeCallType makeCallType,
    String^ location,
    KeyValueCollection^ userData,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Core..::.IDN
The device (the caller).
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel to use.
otherDN
Type: System..::.String
DN to call.
makeCallType
Type: Genesyslab.Enterprise.Model.Interaction..::.MakeCallType
Call type.
location
Type: System..::.String
Location.
userData
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
User data.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons of the call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Call extensions.
timeOut
Type: System..::.Int32
Timeout.

See Also

IIMService Interface
MakeCall Overload
Genesyslab.Enterprise.Services Namespace


ReleaseCall Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.ReleaseCall Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
ReleaseCall(IClientChannel, IInteraction, KeyValueCollection, KeyValueCollection) | Stops the instant messaging session. See the service description for a code sample.
ReleaseCall(IClientChannel, IInteraction, KeyValueCollection, KeyValueCollection, Int32) | Stops the instant messaging session. See the service description for a code sample.

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


ReleaseCall Method (IClientChannel, IInteraction, KeyValueCollection, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.ReleaseCall Method (IClientChannel, IInteraction, KeyValueCollection, KeyValueCollection)
IIMService Interface See Also Send Feedback
Stops the instant messaging session. See the service description for a code sample.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ReleaseCall(
    IClientChannel channel,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Sub ReleaseCall ( _
    channel As IClientChannel, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection _
)
Visual C++
void ReleaseCall(
    IClientChannel^ channel,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel to use.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction that contains the instant messaging session.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons of the call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Call extensions.

See Also

IIMService Interface
ReleaseCall Overload
Genesyslab.Enterprise.Services Namespace


ReleaseCall Method (IClientChannel, IInteraction, KeyValueCollection, KeyValueCollection, Int32)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.ReleaseCall Method (IClientChannel, IInteraction, KeyValueCollection, KeyValueCollection, Int32)
IIMService Interface See Also Send Feedback
Stops the instant messaging session. See the service description for a code sample.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ReleaseCall(
    IClientChannel channel,
    IInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut
)
Visual Basic (Declaration)
Sub ReleaseCall ( _
    channel As IClientChannel, _
    interaction As IInteraction, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer _
)
Visual C++
void ReleaseCall(
    IClientChannel^ channel,
    IInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel to use.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction that contains the instant messaging session.
reasons
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Reasons of the call.
extensions
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection
Call extensions.
timeOut
Type: System..::.Int32
Timeout.

See Also

IIMService Interface
ReleaseCall Overload
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.Save Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


SendMessage Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.SendMessage Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
SendMessage(IIMInteraction, String, MessageContentType) | Sends an instant message.
SendMessage(IIMInteraction, String, String) | Obsolete. Sends an instant message.

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


SendMessage Method (IIMInteraction, String, MessageContentType)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.SendMessage Method (IIMInteraction, String, MessageContentType)
IIMService Interface See Also Send Feedback
Sends an instant message.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void SendMessage(
    IIMInteraction context,
    string message,
    MessageContentType contentType
)
Visual Basic (Declaration)
Sub SendMessage ( _
    context As IIMInteraction, _
    message As String, _
    contentType As MessageContentType _
)
Visual C++
void SendMessage(
    IIMInteraction^ context,
    String^ message,
    MessageContentType contentType
)

Parameters

context
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
The Instant Messaging context.
message
Type: System..::.String
The message to send.
contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType
The MIME type of the message.

See Also

IIMService Interface
SendMessage Overload
Genesyslab.Enterprise.Services Namespace


SendMessage Method (IIMInteraction, String, String)

[image]

Enterprise SDK 8.0 Reference API
IIMService..::.SendMessage Method (IIMInteraction, String, String)
IIMService Interface See Also Send Feedback
Sends an instant message.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("Use SendMessage(IIMInteraction context, string message, MessageContentType contentType) method")]
void SendMessage(
    IIMInteraction context,
    string message,
    string contentType
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use SendMessage(IIMInteraction context, string message, MessageContentType contentType) method")> _
Sub SendMessage ( _
    context As IIMInteraction, _
    message As String, _
    contentType As String _
)
Visual C++
[ObsoleteAttribute(L"Use SendMessage(IIMInteraction context, string message, MessageContentType contentType) method")]
void SendMessage(
    IIMInteraction^ context,
    String^ message,
    String^ contentType
)

Parameters

context
Type: Genesyslab.Enterprise.Model.Interaction..::.IIMInteraction
The Instant Messaging context.
message
Type: System..::.String
The message to send.
contentType
Type: System..::.String
The MIME type of the message.

See Also

IIMService Interface
SendMessage Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.SetAttachedData Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


IIMService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Properties
IIMService Interface See Also Send Feedback

The IIMService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Interface
Members See Also Send Feedback
Enables your application to manage interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IInteractionDomain
Visual Basic (Declaration)
Public Interface IInteractionDomain
Visual C++
public interface class IInteractionDomain

Remarks

You can find code snippets for interaction creation in the CreateInteraction(IEnumerable<(Of <(IDevice>)>)) methods.

See Also

IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Members
IInteractionDomain Interface Methods See Also Send Feedback

The IInteractionDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Methods
IInteractionDomain Interface See Also Send Feedback

The IInteractionDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID.
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method (IEnumerable<(Of <(IDevice>)>))
IInteractionDomain Interface See Also Send Feedback
Creates a new interaction associated with a set of devices and a unique ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction CreateInteraction(
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IEnumerable<IDevice^>^ deviceList
)

Parameters

deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices associated with the interaction.

Return Value

IInteraction

Remarks

The following example shows how to make an Asynchronous Activate command. ///
CopyC#
IInteraction interaction = interactionService.CreateInteraction(deviceList);
if (interaction != null)
{
    ISubscribeable<IEnvelope>IRequest subscriber = interaction as ISubscribeable<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IInteractionDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IInteraction, IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method (IInteraction, IEnumerable<(Of <(IDevice>)>))
IInteractionDomain Interface Example See Also Send Feedback
Uses an existing interaction to create a new interaction associated with a set of devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction CreateInteraction(
    IInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    currentInteraction As IInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
)

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current instance of the interaction.
deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices to associate with the new interaction.

Return Value

IInteraction

Examples

The following example shows how to make an Asynchronous Activate command.
CopyC#
IInteraction interaction = interactionService.CreateInteraction(previousInteraction, deviceList);
if (interaction != null)
{
    ISubscriber<IEnvelope<IRequest>> subscriber = interaction as ISubscriber<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IInteractionDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.DeleteInteraction Method
IInteractionDomain Interface See Also Send Feedback
Deletes the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteractionDomain DeleteInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function DeleteInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.DeleteInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IInteractionDomain

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Returns the user defined attached data of this interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.GetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

IDictionary<string, Object>

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method (IAgent, String)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.GetInteraction(Genesyslab.Enterprise.Agent.IAgent,System.String)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.GetInteraction(Genesyslab.Enterprise.Agent.IAgent,System.String)"]

Return Value

IInteraction

See Also

IInteractionDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDN, String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method (IDN, String)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction GetInteraction(
    IDN dn,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    dn As IDN, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IDN^ dn,
    String^ interactionId
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device linked to the interaction
interactionId
Type: System..::.String
Unique Id of the interaction

Return Value

IInteraction

See Also

IInteractionDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions.
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists.
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists.
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method
IInteractionDomain Interface See Also Send Feedback
Returns all the existing interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions()

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (IAgent)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interactions associated with an Agent, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Function GetInteractions ( _
    agent As IAgent _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IAgent^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent.

Return Value

IInteraction[]

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDN)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (IDN)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interactions associated with a device, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction[] GetInteractions(
    IDN dn
)
Visual Basic (Declaration)
Function GetInteractions ( _
    dn As IDN _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IDN^ dn
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device.

Return Value

IInteraction[]

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (String)
IInteractionDomain Interface See Also Send Feedback
Returns the existing interaction(s) associated with an interaction ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractions ( _
    interactionId As String _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction.

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.RemoveAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.RemoveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String)"]

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.RemoveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String)"]

Return Value

IInteraction

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SaveAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
IInteraction^ SaveAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.SaveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.SaveAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SaveInteraction Method
IInteractionDomain Interface See Also Send Feedback
Saves the interaction in the service's repository. All data are synchronized with the back-end servers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteractionDomain SaveInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ SaveInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.SaveInteraction(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically.
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method (IInteraction, KeyValueCollection)
IInteractionDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

data
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionDomain.SetAttachedData(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

IInteraction

See Also

IInteractionDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method (IInteraction, String, Object)
IInteractionDomain Interface See Also Send Feedback
Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

IInteraction

See Also

IInteractionDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IInteractionService Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionService Interface
Members Example See Also Send Feedback
Manages callback and filters related to interaction events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IInteractionService : IInteractionDomain,
    IEventManager<IInteractionService, IEnvelope<IInteraction>>, IBrokerSubscriber<IEnvelope<IInteraction>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IInteraction>
Visual Basic (Declaration)
Public Interface IInteractionService _
    Implements IInteractionDomain, IEventManager(Of IInteractionService, IEnvelope(Of IInteraction)),  _
    IBrokerSubscriber(Of IEnvelope(Of IInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IInteraction)
Visual C++
public interface class IInteractionService : IInteractionDomain,
    IEventManager<IInteractionService^, IEnvelope<IInteraction^>^>, IBrokerSubscriber<IEnvelope<IInteraction^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IInteraction^>

Examples

The following code sample registers a handler for a given interaction.
CopyC#
EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager));
IInteractionService interactionService = EsdkService.Resolve<IInteractionService>("interactionService");
interactionService.RegisterEvents<IEnvelope<IInteraction>>(channel, new Action<IEnvelope<IInteraction>>(InteractionEvent));
 To make this snippet work, you must also declare an InteractionEvent method.
CopyC#
//Filter sample and declaration of the handler
[EnterpriseInteractionEvent("TServerSIPChannel")]
     protected void InteractionEvent(IEnvelope<IInteraction> tsp)
     {
     }

See Also

IInteractionService Members
Genesyslab.Enterprise.Services Namespace


IInteractionService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService Members
IInteractionService Interface Methods Properties See Also Send Feedback

The IInteractionService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IInteractionDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IInteractionDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IInteractionDomain.)
SetAttachedData | Overloaded.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IInteractionService Interface
Genesyslab.Enterprise.Services Namespace


IInteractionService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService Methods
IInteractionService Interface See Also Send Feedback

The IInteractionService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IInteractionDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IInteractionDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IInteractionDomain.)
SetAttachedData | Overloaded.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

See Also

IInteractionService Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.CreateInteraction Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID. (Inherited from IInteractionDomain.)
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices. (Inherited from IInteractionDomain.)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.GetInteraction Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists. (Inherited from IInteractionDomain.)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.GetInteractions Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions. (Inherited from IInteractionDomain.)
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID. (Inherited from IInteractionDomain.)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.GetList Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.ListFilter<(Of <(T>)>) Method
IInteractionService Interface See Also Send Feedback
Lists the filters registered for the given interaction instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As IInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Target interaction object.

Type Parameters

T
Type of data handled in filter object

Return Value

Filters.

See Also

IInteractionService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.RegisterEvents Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.RegisterFilter<(Of <(T>)>) Method
IInteractionService Interface See Also Send Feedback
Registers a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteractionService RegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IInteractionService
Visual C++
generic<typename T>
IInteractionService^ RegisterFilter(
    IInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction.
filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.IInteractionService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IInteraction,``0)"]

Type Parameters

T
Filter type.

Return Value

IInteractionService

See Also

IInteractionService Interface
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.Save Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.SetAttachedData Method
IInteractionService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)

See Also

IInteractionService Interface
IInteractionService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionService..::.UnRegisterFilter<(Of <(T>)>) Method
IInteractionService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IInteractionService UnRegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IInteractionService
Visual C++
generic<typename T>
IInteractionService^ UnRegisterFilter(
    IInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IInteractionService

See Also

IInteractionService Interface
Genesyslab.Enterprise.Services Namespace


IInteractionService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionService Properties
IInteractionService Interface See Also Send Feedback

The IInteractionService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IInteractionService Interface
Genesyslab.Enterprise.Services Namespace


IMonitorService Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorService Interface
See Also Send Feedback
Statistics service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IMonitorService
Visual Basic (Declaration)
Public Interface IMonitorService
Visual C++
public interface class IMonitorService

See Also

Genesyslab.Enterprise.Services Namespace


IPreviewDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewDomain Interface
See Also Send Feedback
Preview Interaction domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPreviewDomain
Visual Basic (Declaration)
Public Interface IPreviewDomain
Visual C++
public interface class IPreviewDomain

See Also

Genesyslab.Enterprise.Services Namespace


IPreviewService Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewService Interface
Members See Also Send Feedback
Manages the Preview Interaction features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPreviewService : IPreviewDomain,
    IBrokerPublisher
Visual Basic (Declaration)
Public Interface IPreviewService _
    Implements IPreviewDomain, IBrokerPublisher
Visual C++
public interface class IPreviewService : IPreviewDomain,
    IBrokerPublisher

See Also

IPreviewService Members
Genesyslab.Enterprise.Services Namespace


IPreviewService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewService Members
IPreviewService Interface Methods See Also Send Feedback

The IPreviewService type exposes the following members.

Methods

Name | Description
Accept | Accepts to preview the interaction.
Decline | Declines to preview the interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


IPreviewService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewService Methods
IPreviewService Interface See Also Send Feedback

The IPreviewService type exposes the following members.

Methods

Name | Description
Accept | Accepts to preview the interaction.
Decline | Declines to preview the interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


Accept Method

[image]

Enterprise SDK 8.0 Reference API
IPreviewService..::.Accept Method
IPreviewService Interface See Also Send Feedback
Accepts to preview the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Accept(
    IInteraction interaction
)
Visual Basic (Declaration)
Sub Accept ( _
    interaction As IInteraction _
)
Visual C++
void Accept(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Preview Interaction. An interaction in InteractionStateType.Preview state.

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


Decline Method

[image]

Enterprise SDK 8.0 Reference API
IPreviewService..::.Decline Method
IPreviewService Interface See Also Send Feedback
Declines to preview the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Decline(
    IInteraction interaction
)
Visual Basic (Declaration)
Sub Decline ( _
    interaction As IInteraction _
)
Visual C++
void Decline(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Preview Interaction. This interaction is in InteractionStateType.Preview state.

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


IPSTService Interface

[image]

Enterprise SDK 8.0 Reference API
IPSTService Interface
Members See Also Send Feedback
Provides Possible State Transition (PST) information. The isPossible methods of this service use the loaded stategies and the given objects' data (including its own status and strategies) to determine whether a requested action can be processed. The isCapable methods of this service use the loaded strategies to indicate whether the feature is available regardless of the object status. For instance, if your switch does not provide a mute feature, the isCapable methods return false for the ProtocolAction.MuteOn action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IPSTService
Visual Basic (Declaration)
Public Interface IPSTService
Visual C++
public interface class IPSTService

Remarks

Make sure that you do not pass deprecated references when calling the methods of this service. On events, ESDK updates core objects (interactions, agents, DNs, and so on.) and provides your application with a new copy of the updated object, but ESDK does not update this copy with further events. As a result, if you pass a reference on an old copy instead of the most recent one to this service, it returns deprecated results instead of the current possible state transitions for this object.

See Also

IPSTService Members
Genesyslab.Enterprise.Services Namespace


IPSTService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService Members
IPSTService Interface Methods See Also Send Feedback

Methods

Name | Description
AreCapable | Overloaded.
ArePossible | Overloaded.
IsCapable | Overloaded.
IsPossible | Overloaded.

See Also

IPSTService Interface
Genesyslab.Enterprise.Services Namespace


IPSTService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService Methods
IPSTService Interface See Also Send Feedback

Methods

Name | Description
AreCapable | Overloaded.
ArePossible | Overloaded.
IsCapable | Overloaded.
IsPossible | Overloaded.

See Also

IPSTService Interface
Genesyslab.Enterprise.Services Namespace


AreCapable Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
AreCapable(IClientChannel) | Returns the list of actions that the given channel supports as a table of bool values.
AreCapable(String) | Returns the list of actions that the given channel supports as a table of bool values.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


AreCapable Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method (IClientChannel)
IPSTService Interface See Also Send Feedback
Returns the list of actions that the given channel supports as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool[] AreCapable(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AreCapable ( _
    channel As IClientChannel _
) As Boolean()
Visual C++
array<bool>^ AreCapable(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel object.

Return Value

null in case of error, or an array of bool values; true for each action that the channel supports, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
AreCapable Overload
Genesyslab.Enterprise.Services Namespace


AreCapable Method (String)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method (String)
IPSTService Interface See Also Send Feedback
Returns the list of actions that the given channel supports as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool[] AreCapable(
    string ID
)
Visual Basic (Declaration)
Function AreCapable ( _
    ID As String _
) As Boolean()
Visual C++
array<bool>^ AreCapable(
    String^ ID
)

Parameters

ID
Type: System..::.String
The channel ID.

Return Value

null in case of error, or an array of bool values; true for each action that the channel supports, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
AreCapable Overload
Genesyslab.Enterprise.Services Namespace


ArePossible Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
ArePossible(IDevice) | Returns the list of actions that your application can request for the given device as a table of bool values.
ArePossible(IInteraction) | Returns the list of actions that your application can request for the given interaction as a table of bool values.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


ArePossible Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method (IDevice)
IPSTService Interface See Also Send Feedback
Returns the list of actions that your application can request for the given device as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool[] ArePossible(
    IDevice device
)
Visual Basic (Declaration)
Function ArePossible ( _
    device As IDevice _
) As Boolean()
Visual C++
array<bool>^ ArePossible(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.

Return Value

null in case of error, or an array of bool values; true for each permitted action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
ArePossible Overload
Genesyslab.Enterprise.Services Namespace


ArePossible Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method (IInteraction)
IPSTService Interface See Also Send Feedback
Returns the list of actions that your application can request for the given interaction as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool[] ArePossible(
    IInteraction interaction
)
Visual Basic (Declaration)
Function ArePossible ( _
    interaction As IInteraction _
) As Boolean()
Visual C++
array<bool>^ ArePossible(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction object.

Return Value

null in case of error, or an array of bool values, true for each permitted action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
ArePossible Overload
Genesyslab.Enterprise.Services Namespace


IsCapable Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
IsCapable(IClientChannel, ProtocolAction) | Returns true if the channel is capable to perform this action.
IsCapable(String, ProtocolAction) | Returns true if the channel is capable to perform this action.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


IsCapable Method (IClientChannel, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method (IClientChannel, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the channel is capable to perform this action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsCapable(
    IClientChannel channel,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsCapable ( _
    channel As IClientChannel, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsCapable(
    IClientChannel^ channel,
    ProtocolAction action
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The action.

Return Value

true if the channel is capable of the action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsCapable Overload
Genesyslab.Enterprise.Services Namespace


IsCapable Method (String, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method (String, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the channel is capable to perform this action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsCapable(
    string ID,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsCapable ( _
    ID As String, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsCapable(
    String^ ID,
    ProtocolAction action
)

Parameters

ID
Type: System..::.String
The channel ID.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
the action

Return Value

true if the channel is capable of the action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsCapable Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
IsPossible(IDevice, DeviceAction) | Returns true if the given action is available on the given device.
IsPossible(IDevice, ProtocolAction) | Obsolete. Returns true if the given action is available on the given device.
IsPossible(IInteraction, ProtocolAction) | Returns true if you can process the given protocol action on the given interaction.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, DeviceAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, DeviceAction)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsPossible(
    IDevice device,
    DeviceAction action
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As DeviceAction _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    DeviceAction action
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.
action
Type: Genesyslab.Enterprise.Services..::.DeviceAction
The action.

Return Value

true if the action can be invoked according to the device status, false otherwise

Remarks

See the remark section in this service description

Remarks

See the remark section in this service description

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[ObsoleteAttribute("use:  bool IsPossible(Genesyslab.Enterprise.Model.Device.IDevice device, Genesyslab.Enterprise.Services.DeviceAction action")]
bool IsPossible(
    IDevice device,
    ProtocolAction action
)
Visual Basic (Declaration)
<ObsoleteAttribute("use:  bool IsPossible(Genesyslab.Enterprise.Model.Device.IDevice device, Genesyslab.Enterprise.Services.DeviceAction action")> _
Function IsPossible ( _
    device As IDevice, _
    action As ProtocolAction _
) As Boolean
Visual C++
[ObsoleteAttribute(L"use:  bool IsPossible(Genesyslab.Enterprise.Model.Device.IDevice device, Genesyslab.Enterprise.Services.DeviceAction action")]
bool IsPossible(
    IDevice^ device,
    ProtocolAction action
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The action.

Return Value

true if the action can be invoked according to the device status, false otherwise

Remarks

See the remark section in this service description

Remarks

See the remark section in this service description

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if you can process the given protocol action on the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    ProtocolAction action
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The requested action.

Return Value

true if the action can be invoked according to the interaction status, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Interface
Members See Also Send Feedback
Actions part of the monitoring domain

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ISupervisorDomain
Visual Basic (Declaration)
Public Interface ISupervisorDomain
Visual C++
public interface class ISupervisorDomain

See Also

ISupervisorDomain Members
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Members
ISupervisorDomain Interface Methods See Also Send Feedback

The ISupervisorDomain type exposes the following members.

Methods

Name | Description
AddRequest | A Request to the service
IsMonitored | Overloaded.

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Methods
ISupervisorDomain Interface See Also Send Feedback

The ISupervisorDomain type exposes the following members.

Methods

Name | Description
AddRequest | A Request to the service
IsMonitored | Overloaded.

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


AddRequest Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.AddRequest Method
ISupervisorDomain Interface See Also Send Feedback
A Request to the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool AddRequest(
    SupervisorObjectState request
)
Visual Basic (Declaration)
Function AddRequest ( _
    request As SupervisorObjectState _
) As Boolean
Visual C++
bool AddRequest(
    SupervisorObjectState^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Services..::.SupervisorObjectState
Request to be Added

Return Value

bool

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method
ISupervisorDomain Interface See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Returns true if the given device is monitored.
IsMonitored(IIdentity) | Returns true if the given identity is monitored.
IsMonitored(IInteraction) | Returns true if the given interaction is monitored.

See Also

ISupervisorDomain Interface
ISupervisorDomain Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IDevice)
ISupervisorDomain Interface See Also Send Feedback
Returns true if the given device is monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsMonitored(
    IDevice device
)
Visual Basic (Declaration)
Function IsMonitored ( _
    device As IDevice _
) As Boolean
Visual C++
bool IsMonitored(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to evaluate

Return Value

bool

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IIdentity)
ISupervisorDomain Interface See Also Send Feedback
Returns true if the given identity is monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsMonitored(
    IIdentity identity
)
Visual Basic (Declaration)
Function IsMonitored ( _
    identity As IIdentity _
) As Boolean
Visual C++
bool IsMonitored(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity instance

Return Value

bool

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IInteraction)
ISupervisorDomain Interface See Also Send Feedback
Returns true if the given interaction is monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
bool IsMonitored(
    IInteraction interaction
)
Visual Basic (Declaration)
Function IsMonitored ( _
    interaction As IInteraction _
) As Boolean
Visual C++
bool IsMonitored(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

bool

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Interface
Members See Also Send Feedback
Describes the monitoring information of the object which is identified by the Id member. The MonitorObject member identifies the type of the monitored object (possible types are enumerated in SupervisorObjectType: agent, interaction, device, and so on.)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ISupervisorInfo : ISerializable
Visual Basic (Declaration)
Public Interface ISupervisorInfo _
    Implements ISerializable
Visual C++
public interface class ISupervisorInfo : ISerializable

See Also

ISupervisorInfo Members
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Members
ISupervisorInfo Interface Methods Properties See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
Id | Returns the ID of the monitored object.
Media | Returns the media type of the monitored object.
MonitorObject | Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).
MonitorState | Returns the monitoring status for the associated object (On, Off).

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Methods
ISupervisorInfo Interface See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Properties
ISupervisorInfo Interface See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Properties

Name | Description
Id | Returns the ID of the monitored object.
Media | Returns the media type of the monitored object.
MonitorObject | Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).
MonitorState | Returns the monitoring status for the associated object (On, Off).

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.Id Property
ISupervisorInfo Interface See Also Send Feedback
Returns the ID of the monitored object.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


Media Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.Media Property
ISupervisorInfo Interface See Also Send Feedback
Returns the media type of the monitored object.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
MediaType Media { get; }
Visual Basic (Declaration)
ReadOnly Property Media As MediaType
Visual C++
property MediaType Media {
    MediaType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


MonitorObject Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.MonitorObject Property
ISupervisorInfo Interface See Also Send Feedback
Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SupervisorObjectType MonitorObject { get; }
Visual Basic (Declaration)
ReadOnly Property MonitorObject As SupervisorObjectType
Visual C++
property SupervisorObjectType MonitorObject {
    SupervisorObjectType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


MonitorState Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.MonitorState Property
ISupervisorInfo Interface See Also Send Feedback
Returns the monitoring status for the associated object (On, Off).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
SupervisorStateType MonitorState { get; }
Visual Basic (Declaration)
ReadOnly Property MonitorState As SupervisorStateType
Visual C++
property SupervisorStateType MonitorState {
    SupervisorStateType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService Interface
Members Example See Also Send Feedback
Manages actions and events related to monitoring events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface ISupervisorService : IEventManager<ISupervisorService, IEnvelope<ISupervisorInfo>>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo>>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface ISupervisorService _
    Implements IEventManager(Of ISupervisorService, IEnvelope(Of ISupervisorInfo)),  _
    ISupervisorDomain, IBrokerSubscriber(Of IEnvelope(Of ISupervisorInfo)), IBrokerPublisher,  _
    ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class ISupervisorService : IEventManager<ISupervisorService^, IEnvelope<ISupervisorInfo^>^>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo^>^>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest^>^>

Examples

The following code sample registers a handler for a given interaction.
CopyC#
 EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager));
ISupervisorService monitorService = EsdkService.Resolve<ISupervisorService>("monitorService");
interactionService.RegisterEvents<IEnvelope<ISupervisorInfo>>(channel, new Action<IEnvelope<ISupervisorInfo>>(MonitorEvent));
 To make this snippet work, you must also declare an InteractionEvent method.
CopyC#
//Filter sample and declaration of the handler
[EnterpriseMonitorEvent("TServerSIPChannel")]
     protected void MonitorEvent(IEnvelope<ISupervisorInfo> tsp)
     {
     }

See Also

ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


ISupervisorService Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Members
ISupervisorService Interface Methods Properties See Also Send Feedback

The ISupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
AddRequest | A Request to the service (Inherited from ISupervisorDomain.)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) | Lists the filters registered for the given supervision instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given supervision
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given supervision

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Methods
ISupervisorService Interface See Also Send Feedback

The ISupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not report events. Your application needs to call the [!:StartMonitor] method. (Inherited from IEventManager<(Of <(D, T>)>).)
AddRequest | A Request to the service (Inherited from ISupervisorDomain.)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) | Lists the filters registered for the given supervision instance.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given supervision
RemoveChannel | Removes the given channel from the monitoring list. Your application no longer receives events for this channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given supervision

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.GetList Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.IsMonitored Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Returns true if the given device is monitored. (Inherited from ISupervisorDomain.)
IsMonitored(IIdentity) | Returns true if the given identity is monitored. (Inherited from ISupervisorDomain.)
IsMonitored(IInteraction) | Returns true if the given interaction is monitored. (Inherited from ISupervisorDomain.)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.ListFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Lists the filters registered for the given supervision instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    ISupervisorInfo context
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    context As ISupervisorInfo _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    ISupervisorInfo^ context
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.ISupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Type Parameters

T
Type of data handled in filter object

Return Value

IEnumerable<T>

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.RegisterEvents Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.RegisterFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Registers a filter for the given supervision

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ISupervisorService RegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
generic<typename T>
ISupervisorService^ RegisterFilter(
    ISupervisorInfo^ context,
    T filter
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
ISupervisorInfo
filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.ISupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Type Parameters

T
Filter type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.ISupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.UnRegisterFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Unregisters a filter for the given supervision

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
ISupervisorService UnRegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
generic<typename T>
ISupervisorService^ UnRegisterFilter(
    ISupervisorInfo^ context,
    T filter
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
ISupervisorInfo
filter
Type: T
Filter instance

Type Parameters

T
Type of data for the filter instance.

Return Value

ISupervisorService

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Properties
ISupervisorService Interface See Also Send Feedback

The ISupervisorService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


MessageContentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MessageContentType Enumeration
See Also Send Feedback
Enumerates the content type of the message.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum MessageContentType
Visual Basic (Declaration)
Public Enumeration MessageContentType
Visual C++
public enum class MessageContentType

Members

Member name | Description
TextPlain | Textual data; Defined in RFC 2046 and RFC 3676. text/plain
TextHTML | Content HTML; Defined in RFC 2854. text/html

See Also

Genesyslab.Enterprise.Services Namespace


MonitorMethodDelegate Delegate

[image]

Enterprise SDK 8.0 Reference API
MonitorMethodDelegate Delegate
See Also Send Feedback
Listener for Statistics events. This is the callback for subscribed statistics events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public delegate void MonitorMethodDelegate(
    IEnvelope<IMonitorEventStatus> msg
)
Visual Basic (Declaration)
Public Delegate Sub MonitorMethodDelegate ( _
    msg As IEnvelope(Of IMonitorEventStatus) _
)
Visual C++
public delegate void MonitorMethodDelegate(
    IEnvelope<IMonitorEventStatus^>^ msg
)

Parameters

msg
Type: Genesyslab.Enterprise.Model.Envelope..::.IEnvelope <(Of <( IMonitorEventStatus >)>)

See Also

Genesyslab.Enterprise.Services Namespace


MonitorNotificationMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorNotificationMode Enumeration
See Also Send Feedback
Statistics Notification mode. Event notification mode for subscribed statistics.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum MonitorNotificationMode
Visual Basic (Declaration)
Public Enumeration MonitorNotificationMode
Visual C++
public enum class MonitorNotificationMode

Members

Member name | Description
ChangesBased | Based on statistics changes.
TimeBased | Based on time.

See Also

Genesyslab.Enterprise.Services Namespace


MonitorObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorObjectType Enumeration
See Also Send Feedback
Enumerate for statistics object type. Type of the statistics objects that can be monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum MonitorObjectType
Visual Basic (Declaration)
Public Enumeration MonitorObjectType
Visual C++
public enum class MonitorObjectType

Members

Member name | Description
Agent | Gets statistics of Agent type.
AgentGroup | Gets statistics of AgentGroup type.

See Also

Genesyslab.Enterprise.Services Namespace


ProtocolAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProtocolAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this interaction. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum ProtocolAction
Visual Basic (Declaration)
Public Enumeration ProtocolAction
Visual C++
public enum class ProtocolAction

Members

Member name | Description
Alternate | Places the active call on hold and connects the call that was held.
AnswerCall | Answers the ringing call.
AttachUserData | Attach User Data to the current call.
CancelForward | Sets the Forwarding feature to Off.
CompleteConference | Completes a conference previously initiated.
CompleteTransfer | Completes the two-step transfer.
InitConference | Initiates a conference. Holds the current call and dials a consultation call with another agent.
DeleteFromConference | Deletes a party from the conference.
DeleteUserData | Delete User Data from the current call.
Hold | Places the call on hold.
InitTransfer | Initiates a two-step transfer. Holds the current call and dials a consultation call with another agent.
ListenDisconnect | Sets the Deaf mode for the specified party.
ListenReconnect | Cancels Deaf mode for the specified party.
Login | Login this device.
Logout | Logout this device.
MakeCall | Makes a regular call.
MuteOff | Cancels the Mute mode for the specified party.
MuteOn | Sets the Mute mode for the specified party.
MuteTransfer | Transfers this call in one blind step to the destination.
NotReady | Sets not ready this device.
Ready | Sets this device ready.
Reconnect | Releases the active call and retrieves the previously held call.
RedirectCall | Redirects the call, without an answer.
ReleaseCall | Releases the call.
Retrieve | Retrieves the call placed on hold.
SendDTMF | Sends digits to an Interactive Voice Response (IVR) system.
SetDNDOff | Deactivates the Do-Not-Disturb (DND) mode.
SetDNDOn | Activates the Do-Not-Disturb (DND) mode.
SetForward | Sets the Forwarding feature to On.
SingleStepConference | Adds a new party to an existing call and creates a conference.
SingleStepTransfer | Transfers this call in one step to the destination.
UpdateUserData | Update User Data of the current call.

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorModeType Enumeration
See Also Send Feedback
Enumerates the monitor modes.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum SupervisorModeType
Visual Basic (Declaration)
Public Enumeration SupervisorModeType
Visual C++
public enum class SupervisorModeType

Members

Member name | Description
Single | Monitor once call.
All | Monitor all calls until explicitely canceled.

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Class

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.SupervisorObjectState"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SupervisorObjectState
Visual Basic (Declaration)
Public Class SupervisorObjectState
Visual C++
public ref class SupervisorObjectState

Inheritance Hierarchy

System..::.Object
Genesyslab.Enterprise.Services..::.SupervisorObjectState

See Also

SupervisorObjectState Members
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Members

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Members
SupervisorObjectState Class Constructors Methods Properties See Also Send Feedback

The SupervisorObjectState type exposes the following members.

Constructors

Name | Description
SupervisorObjectState |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Mode |
Originator |
State |
Target |

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Constructor

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Constructor
SupervisorObjectState Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorObjectState.#ctor"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SupervisorObjectState()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SupervisorObjectState()

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Methods
SupervisorObjectState Class See Also Send Feedback

The SupervisorObjectState type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectState Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState Properties
SupervisorObjectState Class See Also Send Feedback

The SupervisorObjectState type exposes the following members.

Properties

Name | Description
Mode |
Originator |
State |
Target |

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.Mode Property
SupervisorObjectState Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.SupervisorObjectState.Mode"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SupervisorModeType Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As SupervisorModeType
Visual C++
public:
property SupervisorModeType Mode {
    SupervisorModeType get ();
    void set (SupervisorModeType value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


Originator Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.Originator Property
SupervisorObjectState Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.SupervisorObjectState.Originator"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IDevice Originator { get; set; }
Visual Basic (Declaration)
Public Property Originator As IDevice
Visual C++
public:
property IDevice^ Originator {
    IDevice^ get ();
    void set (IDevice^ value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.State Property
SupervisorObjectState Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.SupervisorObjectState.State"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SupervisorStateType State { get; set; }
Visual Basic (Declaration)
Public Property State As SupervisorStateType
Visual C++
public:
property SupervisorStateType State {
    SupervisorStateType get ();
    void set (SupervisorStateType value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectState..::.Target Property
SupervisorObjectState Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.SupervisorObjectState.Target"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IDevice Target { get; set; }
Visual Basic (Declaration)
Public Property Target As IDevice
Visual C++
public:
property IDevice^ Target {
    IDevice^ get ();
    void set (IDevice^ value);
}

See Also

SupervisorObjectState Class
Genesyslab.Enterprise.Services Namespace


SupervisorObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectType Enumeration
See Also Send Feedback
Enumerates the types of objects involved in monitoring.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum SupervisorObjectType
Visual Basic (Declaration)
Public Enumeration SupervisorObjectType
Visual C++
public enum class SupervisorObjectType

Members

Member name | Description
Agent |
Device |
Interaction |

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorService Class

[image]

Enterprise SDK 8.0 Reference API
SupervisorService Class
Members See Also Send Feedback
Monitor class implementation

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public class SupervisorService : CustomSubscriber<IEnvelope<ISupervisorInfo>>,
    ISupervisorService, IEventManager<ISupervisorService, IEnvelope<ISupervisorInfo>>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo>>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Class SupervisorService _
    Inherits CustomSubscriber(Of IEnvelope(Of ISupervisorInfo)) _
    Implements ISupervisorService, IEventManager(Of ISupervisorService, IEnvelope(Of ISupervisorInfo)),  _
    ISupervisorDomain, IBrokerSubscriber(Of IEnvelope(Of ISupervisorInfo)), IBrokerPublisher,  _
    ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public ref class SupervisorService : public CustomSubscriber<IEnvelope<ISupervisorInfo^>^>,
    ISupervisorService, IEventManager<ISupervisorService^, IEnvelope<ISupervisorInfo^>^>,
    ISupervisorDomain, IBrokerSubscriber<IEnvelope<ISupervisorInfo^>^>, IBrokerPublisher,
    ISubscribeable<IEnvelope<IRequest^>^>

Inheritance Hierarchy

System..::.Object
ContainerBase
Genesyslab.Enterprise.Services..::.CustomSubscriber <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)
Genesyslab.Enterprise.Services..::.SupervisorService

See Also

SupervisorService Members
Genesyslab.Enterprise.Services Namespace


SupervisorService Members

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Members
SupervisorService Class Constructors Methods Properties See Also Send Feedback

The SupervisorService type exposes the following members.

Constructors

Name | Description
SupervisorService | Overloaded.

Methods

Name | Description
AddChannel | Add a channel to the service
AddRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid) (Overrides Object..::.GetHashCode()()().)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle |
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) |
ListStrategies | List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported
Publish<(Of <(T>)>) | (Inherited from CustomSubscriber<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) |
RemoveAllStrategies |
RemoveChannel | Remove a channel from the service
RemoveStrategy |
SetStrategy |
ToString | Returns the Id of the service (Overrides Object..::.ToString()()().)
UnRegisterEvents | Overloaded.
UnRegisterFilter<(Of <(T>)>) |

Properties

Name | Description
Count | (Inherited from CustomSubscriber<(Of <(T>)>).)
Description | Get friendly description of the service (Overrides ContainerBaseDescription()()().)
EventSubscription | (Inherited from CustomSubscriber<(Of <(T>)>).)
Filter |
ServiceName | Get friendly service name (Overrides ContainerBaseServiceName()()().)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SupervisorService Constructor

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Constructor
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
SupervisorService(IContainerBase) |
SupervisorService(IContainerBase, IBrokerManager<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>)) |

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


SupervisorService Constructor ()

[image]

Enterprise SDK 8.0 Reference API
SupervisorService Constructor ()
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SupervisorService(
    IContainerBase provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase _
)
Visual C++
public:
SupervisorService(
    IContainerBase^ provider
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase)"]

See Also

SupervisorService Class
SupervisorService Overload
Genesyslab.Enterprise.Services Namespace


SupervisorService Constructor (, IBrokerManager(IEnvelope(ISupervisorInfo)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService Constructor (, IBrokerManager<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>))
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public SupervisorService(
    IContainerBase provider,
    IBrokerManager<IEnvelope<ISupervisorInfo>> eventBroker
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IContainerBase, _
    eventBroker As IBrokerManager(Of IEnvelope(Of ISupervisorInfo)) _
)
Visual C++
public:
SupervisorService(
    IContainerBase^ provider,
    IBrokerManager<IEnvelope<ISupervisorInfo^>^>^ eventBroker
)

Parameters

provider
Type: IContainerBase

[Missing <param name="provider"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

eventBroker
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IBrokerManager <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="eventBroker"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.#ctor(Genesyslab.Enterprise.Model.ServiceModel.IContainerBase,Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

See Also

SupervisorService Class
SupervisorService Overload
Genesyslab.Enterprise.Services Namespace


SupervisorService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Methods
SupervisorService Class See Also Send Feedback

The SupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Add a channel to the service
AddRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid) (Overrides Object..::.GetHashCode()()().)
GetList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle |
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) |
ListStrategies | List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported
Publish<(Of <(T>)>) | (Inherited from CustomSubscriber<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) |
RemoveAllStrategies |
RemoveChannel | Remove a channel from the service
RemoveStrategy |
SetStrategy |
ToString | Returns the Id of the service (Overrides Object..::.ToString()()().)
UnRegisterEvents | Overloaded.
UnRegisterFilter<(Of <(T>)>) |

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.AddChannel Method
SupervisorService Class See Also Send Feedback
Add a channel to the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function AddChannel ( _
    channel As IClientChannel _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ AddChannel(
    IClientChannel^ channel
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance

Return Value

ISupervisorService

Implements

IEventManager<(Of <(D, T>)>)..::.AddChannel(IClientChannel)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


AddRequest Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.AddRequest Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.AddRequest(Genesyslab.Enterprise.Services.SupervisorObjectState)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool AddRequest(
    SupervisorObjectState request
)
Visual Basic (Declaration)
Public Function AddRequest ( _
    request As SupervisorObjectState _
) As Boolean
Visual C++
public:
virtual bool AddRequest(
    SupervisorObjectState^ request
) sealed

Parameters

request
Type: Genesyslab.Enterprise.Services..::.SupervisorObjectState

[Missing <param name="request"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.AddRequest(Genesyslab.Enterprise.Services.SupervisorObjectState)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.AddRequest(Genesyslab.Enterprise.Services.SupervisorObjectState)"]

Implements

ISupervisorDomain..::.AddRequest(SupervisorObjectState)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


GetHashCode Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.GetHashCode Method
SupervisorService Class See Also Send Feedback
Get hash code of object Hascode is computed by concatenating the Name and the FQName (Uid)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

int

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.GetList Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | (Inherited from CustomSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | (Inherited from CustomSubscriber<(Of <(T>)>).)

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.Handle Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.Handle(Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public void Handle(
    IEnvelope<IRequest> obj
)
Visual Basic (Declaration)
Public Sub Handle ( _
    obj As IEnvelope(Of IRequest) _
)
Visual C++
public:
virtual void Handle(
    IEnvelope<IRequest^>^ obj
) sealed

Parameters

obj
Type: Genesyslab.Enterprise.Model.Envelope..::.IEnvelope <(Of <( IRequest >)>)

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.Handle(Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest})"]

Implements

ISubscribeable<(Of <(T>)>)..::.Handle(T)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Check if the specified device is monitored
IsMonitored(IIdentity) | Check if an identity is currently monitored or not
IsMonitored(IInteraction) | Check if an interaction is currently monitored

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method (IDevice)
SupervisorService Class See Also Send Feedback
Check if the specified device is monitored

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsMonitored(
    IDevice device
)
Visual Basic (Declaration)
Public Function IsMonitored ( _
    device As IDevice _
) As Boolean
Visual C++
public:
virtual bool IsMonitored(
    IDevice^ device
) sealed

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to evaluate

Return Value

bool

Implements

ISupervisorDomain..::.IsMonitored(IDevice)

See Also

SupervisorService Class
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method (IIdentity)
SupervisorService Class See Also Send Feedback
Check if an identity is currently monitored or not

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsMonitored(
    IIdentity identity
)
Visual Basic (Declaration)
Public Function IsMonitored ( _
    identity As IIdentity _
) As Boolean
Visual C++
public:
virtual bool IsMonitored(
    IIdentity^ identity
) sealed

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity instance

Return Value

bool

Implements

ISupervisorDomain..::.IsMonitored(IIdentity)

See Also

SupervisorService Class
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.IsMonitored Method (IInteraction)
SupervisorService Class See Also Send Feedback
Check if an interaction is currently monitored

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public bool IsMonitored(
    IInteraction interaction
)
Visual Basic (Declaration)
Public Function IsMonitored ( _
    interaction As IInteraction _
) As Boolean
Visual C++
public:
virtual bool IsMonitored(
    IInteraction^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

bool

Implements

ISupervisorDomain..::.IsMonitored(IInteraction)

See Also

SupervisorService Class
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ListFilter<(Of <(T>)>) Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IEnumerable<T> ListFilter<T>(
    ISupervisorInfo interaction
)
Visual Basic (Declaration)
Public Function ListFilter(Of T) ( _
    interaction As ISupervisorInfo _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
virtual IEnumerable<T>^ ListFilter(
    ISupervisorInfo^ interaction
) sealed

Parameters

interaction
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


ListStrategies Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ListStrategies Method
SupervisorService Class See Also Send Feedback
List strategies within the interaction object specified If a null parameter is used, strategies from the service are reported

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IStrategy[] ListStrategies(
    ISupervisorInfo targetObject
)
Visual Basic (Declaration)
Public Function ListStrategies ( _
    targetObject As ISupervisorInfo _
) As IStrategy()
Visual C++
public:
virtual array<IStrategy^>^ ListStrategies(
    ISupervisorInfo^ targetObject
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ListStrategies(Genesyslab.Enterprise.Services.ISupervisorInfo)"]

Return Value

IStrategy []

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) |

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>))
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)) _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>))

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)), [], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<>[]()[], array<IFilter>[]()[])
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

strategyList
Type: array< IStrategy >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

strategyList
Type: array< System..::.Attribute >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

filterList
Type: array< System..::.Attribute >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.Attribute[],System.Attribute[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService RegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Public Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)), _
    strategyList As String(), _
    filterList As IFilter() _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

strategyList
Type: array< System..::.String >[]()[]

[Missing <param name="strategyList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]

[Missing <param name="filterList"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Implements

IEventManager<(Of <(D, T>)>)..::.RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])

See Also

SupervisorService Class
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RegisterFilter<(Of <(T>)>) Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService RegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Public Function RegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
public:
generic<typename T>
virtual ISupervisorService^ RegisterFilter(
    ISupervisorInfo^ context,
    T filter
) sealed

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Implements

ISupervisorService..::.RegisterFilter<(Of <(T>)>)(ISupervisorInfo, T)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RemoveAllStrategies Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RemoveAllStrategies Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveAllStrategies"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IStrategyManager<ISupervisorInfo> RemoveAllStrategies()
Visual Basic (Declaration)
Public Function RemoveAllStrategies As IStrategyManager(Of ISupervisorInfo)
Visual C++
public:
virtual IStrategyManager<ISupervisorInfo^>^ RemoveAllStrategies() sealed

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveAllStrategies"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RemoveChannel Method
SupervisorService Class See Also Send Feedback
Remove a channel from the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Public Function RemoveChannel ( _
    channel As IClientChannel _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ RemoveChannel(
    IClientChannel^ channel
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
channel instance

Return Value

ISupervisorService

Implements

IEventManager<(Of <(D, T>)>)..::.RemoveChannel(IClientChannel)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


RemoveStrategy Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.RemoveStrategy Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IStrategyManager<ISupervisorInfo> RemoveStrategy(
    ISupervisorInfo targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function RemoveStrategy ( _
    targetObject As ISupervisorInfo, _
    strategy As IStrategy _
) As IStrategyManager(Of ISupervisorInfo)
Visual C++
public:
virtual IStrategyManager<ISupervisorInfo^>^ RemoveStrategy(
    ISupervisorInfo^ targetObject,
    IStrategy^ strategy
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.RemoveStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SetStrategy Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.SetStrategy Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IStrategyManager<ISupervisorInfo> SetStrategy(
    ISupervisorInfo targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Public Function SetStrategy ( _
    targetObject As ISupervisorInfo, _
    strategy As IStrategy _
) As IStrategyManager(Of ISupervisorInfo)
Visual C++
public:
virtual IStrategyManager<ISupervisorInfo^>^ SetStrategy(
    ISupervisorInfo^ targetObject,
    IStrategy^ strategy
) sealed

Parameters

targetObject
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.SetStrategy(Genesyslab.Enterprise.Services.ISupervisorInfo,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ToString Method
SupervisorService Class See Also Send Feedback
Returns the Id of the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.ToString"]

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterEvents Method
SupervisorService Class See Also Send Feedback

Overload List

Name | Description
UnRegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(IRequest>)>)>)>)) | Unregister events from the specified channel
UnRegisterEvents(IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>)) |

See Also

SupervisorService Class
SupervisorService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method (IClientChannel, Action(IEnvelope(IRequest)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(IRequest>)>)>)>))
SupervisorService Class See Also Send Feedback
Unregister events from the specified channel

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService UnRegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<IRequest>> handler
)
Visual Basic (Declaration)
Public Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of IRequest)) _
) As ISupervisorService
Visual C++
public:
ISupervisorService^ UnRegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<IRequest^>^>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest}})"]

handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IRequest >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Model.ComponentModel.IRequest}})"]

Return Value

IInteractionService

See Also

SupervisorService Class
UnRegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method (IClientChannel, Action(IEnvelope(ISupervisorInfo)))

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterEvents Method (IClientChannel, Action<(Of <(IEnvelope<(Of <(ISupervisorInfo>)>)>)>))
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService UnRegisterEvents(
    IClientChannel channel,
    Action<IEnvelope<ISupervisorInfo>> handler
)
Visual Basic (Declaration)
Public Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of IEnvelope(Of ISupervisorInfo)) _
) As ISupervisorService
Visual C++
public:
virtual ISupervisorService^ UnRegisterEvents(
    IClientChannel^ channel,
    Action<IEnvelope<ISupervisorInfo^>^>^ handler
) sealed

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ISupervisorInfo >)>)>)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Services.ISupervisorInfo}})"]

Implements

IEventManager<(Of <(D, T>)>)..::.UnRegisterEvents(IClientChannel, Action<(Of <(T>)>))

See Also

SupervisorService Class
UnRegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.UnRegisterFilter<(Of <(T>)>) Method
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public ISupervisorService UnRegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Public Function UnRegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
public:
generic<typename T>
virtual ISupervisorService^ UnRegisterFilter(
    ISupervisorInfo^ context,
    T filter
) sealed

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.SupervisorService.UnRegisterFilter``1(Genesyslab.Enterprise.Services.ISupervisorInfo,``0)"]

Implements

ISupervisorService..::.UnRegisterFilter<(Of <(T>)>)(ISupervisorInfo, T)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SupervisorService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
SupervisorService Properties
SupervisorService Class See Also Send Feedback

The SupervisorService type exposes the following members.

Properties

Name | Description
Count | (Inherited from CustomSubscriber<(Of <(T>)>).)
Description | Get friendly description of the service (Overrides ContainerBaseDescription()()().)
EventSubscription | (Inherited from CustomSubscriber<(Of <(T>)>).)
Filter |
ServiceName | Get friendly service name (Overrides ContainerBaseServiceName()()().)

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.Description Property
SupervisorService Class See Also Send Feedback
Get friendly description of the service

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string Description { get; set; }
Visual Basic (Declaration)
Public Overrides Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IService..::.Description

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.Filter Property
SupervisorService Class See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.SupervisorService.Filter"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public IPredicatable<IEnvelope<IRequest>> Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As IPredicatable(Of IEnvelope(Of IRequest))
Visual C++
public:
virtual property IPredicatable<IEnvelope<IRequest^>^>^ Filter {
    IPredicatable<IEnvelope<IRequest^>^>^ get () sealed;
}

Implements

ISubscribeable<(Of <(T>)>)..::.Filter

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
SupervisorService..::.ServiceName Property
SupervisorService Class See Also Send Feedback
Get friendly service name

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public override string ServiceName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ServiceName As String
Visual C++
public:
virtual property String^ ServiceName {
    String^ get () override;
}

Implements

IService..::.ServiceName
IEnterpriseServiceProvider..::.ServiceName

See Also

SupervisorService Class
Genesyslab.Enterprise.Services Namespace


SupervisorStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorStateType Enumeration
See Also Send Feedback
Enumerates the monitor statuses.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public enum SupervisorStateType
Visual Basic (Declaration)
Public Enumeration SupervisorStateType
Visual C++
public enum class SupervisorStateType

Members

Member name | Description
Unknown |
On |
Off |

See Also

Genesyslab.Enterprise.Services Namespace


Genesyslab.Enterprise.Services.Configuration Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Configuration Namespace
Send Feedback

Interfaces

Interface | Description
IEnterpriseConfigurationService |
IEnterpriseConfigurationServiceDomain |


IEnterpriseConfigurationService Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEnterpriseConfigurationService : IEnterpriseConfigurationServiceDomain,
    IBrokerSubscriber<ConfEventEx>
Visual Basic (Declaration)
Public Interface IEnterpriseConfigurationService _
    Implements IEnterpriseConfigurationServiceDomain, IBrokerSubscriber(Of ConfEventEx)
Visual C++
public interface class IEnterpriseConfigurationService : IEnterpriseConfigurationServiceDomain,
    IBrokerSubscriber<ConfEventEx^>

See Also

IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService Members
IEnterpriseConfigurationService Interface Methods Properties See Also Send Feedback

The IEnterpriseConfigurationService type exposes the following members.

Methods

Name | Description
AddChannel | (Inherited from IEnterpriseConfigurationServiceDomain.)
Authenticate | Overloaded.
ChangeOperationalMode | Overloaded.
ChangePassword | Overloaded.
CreateObject | Overloaded.
DeleteObject | Overloaded.
DeleteObjectByDbId | Overloaded.
GetList | Overloaded.
ReadOperationalMode | Overloaded.
RefreshObject | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter | Overloaded.
RegisterPermissionsNotification | Overloaded.
RemoveAccount | Overloaded.
RemoveChannel | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveAccountPermissions | Overloaded.
RetrieveMultipleObjects | Overloaded.
RetrieveObject | Overloaded.
RetrieveObjectByDbId | Overloaded.
RetrievePermissions | Overloaded.
SaveObject | Overloaded.
SetAccountPermissions | Overloaded.
UnregisterEvents | Overloaded.
UnregisterFilter | Overloaded.
UnregisterPermissionsNotification | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
DefaultChannel | (Inherited from IEnterpriseConfigurationServiceDomain.)
EventSubscription | Gets the (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IEnterpriseConfigurationService Interface
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService Methods
IEnterpriseConfigurationService Interface See Also Send Feedback

The IEnterpriseConfigurationService type exposes the following members.

Methods

Name | Description
AddChannel | (Inherited from IEnterpriseConfigurationServiceDomain.)
Authenticate | Overloaded.
ChangeOperationalMode | Overloaded.
ChangePassword | Overloaded.
CreateObject | Overloaded.
DeleteObject | Overloaded.
DeleteObjectByDbId | Overloaded.
GetList | Overloaded.
ReadOperationalMode | Overloaded.
RefreshObject | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter | Overloaded.
RegisterPermissionsNotification | Overloaded.
RemoveAccount | Overloaded.
RemoveChannel | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveAccountPermissions | Overloaded.
RetrieveMultipleObjects | Overloaded.
RetrieveObject | Overloaded.
RetrieveObjectByDbId | Overloaded.
RetrievePermissions | Overloaded.
SaveObject | Overloaded.
SetAccountPermissions | Overloaded.
UnregisterEvents | Overloaded.
UnregisterFilter | Overloaded.
UnregisterPermissionsNotification | Overloaded.

See Also

IEnterpriseConfigurationService Interface
Genesyslab.Enterprise.Services.Configuration Namespace


Authenticate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.Authenticate Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
Authenticate(String, String) | (Inherited from IEnterpriseConfigurationServiceDomain.)
Authenticate(IClientChannel, String, String) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


ChangeOperationalMode Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.ChangeOperationalMode Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
ChangeOperationalMode(Int32) | (Inherited from IEnterpriseConfigurationServiceDomain.)
ChangeOperationalMode(IClientChannel, Int32) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


ChangePassword Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.ChangePassword Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
ChangePassword(String, String, String) | (Inherited from IEnterpriseConfigurationServiceDomain.)
ChangePassword(IClientChannel, String, String, String) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


CreateObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.CreateObject Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
CreateObject(CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
CreateObject<(Of <(T>)>)(T) | (Inherited from IEnterpriseConfigurationServiceDomain.)
CreateObject(IClientChannel, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
CreateObject<(Of <(T>)>)(IClientChannel, T) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.DeleteObject Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
DeleteObject(CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
DeleteObject(IClientChannel, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObjectByDbId Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.DeleteObjectByDbId Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
DeleteObjectByDbId(Int32, CfgObjectType) | (Inherited from IEnterpriseConfigurationServiceDomain.)
DeleteObjectByDbId(IClientChannel, Int32, CfgObjectType) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.GetList Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


ReadOperationalMode Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.ReadOperationalMode Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
ReadOperationalMode()()() | (Inherited from IEnterpriseConfigurationServiceDomain.)
ReadOperationalMode(IClientChannel) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RefreshObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RefreshObject Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RefreshObject(CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RefreshObject<(Of <(T>)>)(T) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RefreshObject(IClientChannel, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RefreshObject<(Of <(T>)>)(IClientChannel, T) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(ISubscribeable<(Of <(ConfEventEx>)>)) |
RegisterEvents(Action<(Of <(ConfEventEx>)>)) |
RegisterEvents(IClientChannel, ISubscribeable<(Of <(ConfEventEx>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(ConfEventEx>)>)) |
RegisterEvents(Action<(Of <(ConfEventEx>)>), IPredicatable<(Of <(ConfEventEx>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(ConfEventEx>)>), IPredicatable<(Of <(ConfEventEx>)>)) |

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method (ISubscribeable(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method (ISubscribeable<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterEvents(
    ISubscribeable<ConfEventEx> subscriber
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    subscriber As ISubscribeable(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterEvents(
    ISubscribeable<ConfEventEx^>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( ConfEventEx >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method (Action(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method (Action<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterEvents(
    Action<ConfEventEx> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    handler As Action(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterEvents(
    Action<ConfEventEx^>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <( ConfEventEx >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method (IClientChannel, ISubscribeable(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method (IClientChannel, ISubscribeable<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterEvents(
    IClientChannel channel,
    ISubscribeable<ConfEventEx> subscriber
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    subscriber As ISubscribeable(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterEvents(
    IClientChannel^ channel,
    ISubscribeable<ConfEventEx^>^ subscriber
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( ConfEventEx >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method (IClientChannel, Action(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method (IClientChannel, Action<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterEvents(
    IClientChannel channel,
    Action<ConfEventEx> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterEvents(
    IClientChannel^ channel,
    Action<ConfEventEx^>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

handler
Type: System..::.Action <(Of <( ConfEventEx >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method (Action(ConfEventEx), IPredicatable(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method (Action<(Of <(ConfEventEx>)>), IPredicatable<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterEvents(
    Action<ConfEventEx> handler,
    IPredicatable<ConfEventEx> filter
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    handler As Action(Of ConfEventEx), _
    filter As IPredicatable(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterEvents(
    Action<ConfEventEx^>^ handler,
    IPredicatable<ConfEventEx^>^ filter
)

Parameters

handler
Type: System..::.Action <(Of <( ConfEventEx >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( ConfEventEx >)>)

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterEvents Method (IClientChannel, Action(ConfEventEx), IPredicatable(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterEvents Method (IClientChannel, Action<(Of <(ConfEventEx>)>), IPredicatable<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterEvents(
    IClientChannel channel,
    Action<ConfEventEx> handler,
    IPredicatable<ConfEventEx> filter
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of ConfEventEx), _
    filter As IPredicatable(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterEvents(
    IClientChannel^ channel,
    Action<ConfEventEx^>^ handler,
    IPredicatable<ConfEventEx^>^ filter
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

handler
Type: System..::.Action <(Of <( ConfEventEx >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( ConfEventEx >)>)

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx},Genesyslab.Enterprise.Model.ComponentModel.IPredicatable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RegisterFilter(KeyValueCollection) |
RegisterFilter(CfgObjectEx) |
RegisterFilter(NotificationQueryEx) |
RegisterFilter(IClientChannel, KeyValueCollection) |
RegisterFilter(IClientChannel, CfgObjectEx) |
RegisterFilter(IClientChannel, NotificationQueryEx) |

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method (KeyValueCollection)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterFilter(
    KeyValueCollection filter
)
Visual Basic (Declaration)
Function RegisterFilter ( _
    filter As KeyValueCollection _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterFilter(
    KeyValueCollection^ filter
)

Parameters

filter
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IEnterpriseConfigurationService Interface
RegisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method (CfgObjectEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterFilter(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function RegisterFilter ( _
    obj As CfgObjectEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterFilter(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationService Interface
RegisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method (NotificationQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method (NotificationQueryEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterFilter(
    NotificationQueryEx query
)
Visual Basic (Declaration)
Function RegisterFilter ( _
    query As NotificationQueryEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterFilter(
    NotificationQueryEx^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.NotificationQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

See Also

IEnterpriseConfigurationService Interface
RegisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method (IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method (IClientChannel, KeyValueCollection)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterFilter(
    IClientChannel channel,
    KeyValueCollection filter
)
Visual Basic (Declaration)
Function RegisterFilter ( _
    channel As IClientChannel, _
    filter As KeyValueCollection _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterFilter(
    IClientChannel^ channel,
    KeyValueCollection^ filter
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

filter
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IEnterpriseConfigurationService Interface
RegisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterFilter(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function RegisterFilter ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterFilter(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationService Interface
RegisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterFilter Method (IClientChannel, NotificationQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterFilter Method (IClientChannel, NotificationQueryEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService RegisterFilter(
    IClientChannel channel,
    NotificationQueryEx query
)
Visual Basic (Declaration)
Function RegisterFilter ( _
    channel As IClientChannel, _
    query As NotificationQueryEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ RegisterFilter(
    IClientChannel^ channel,
    NotificationQueryEx^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.NotificationQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.RegisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

See Also

IEnterpriseConfigurationService Interface
RegisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterPermissionsNotification Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RegisterPermissionsNotification Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RegisterPermissionsNotification()()() | (Inherited from IEnterpriseConfigurationServiceDomain.)
RegisterPermissionsNotification(IClientChannel) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RemoveAccount Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RemoveAccount Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RemoveAccount(CfgObjectEx, CfgObjectEx, Boolean) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RemoveAccount(IClientChannel, CfgObjectEx, CfgObjectEx, Boolean) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RetrieveAccountPermissions Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RetrieveAccountPermissions(CfgObjectEx, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveAccountPermissions(IClientChannel, CfgObjectEx, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveMultipleObjects Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RetrieveMultipleObjects Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RetrieveMultipleObjects(CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveMultipleObjects<(Of <(T>)>)(CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveMultipleObjects<(Of <(T>)>)(IClientChannel, CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveMultipleObjects(IClientChannel, CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RetrieveObject Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RetrieveObject(CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveObject<(Of <(T>)>)(CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveObject<(Of <(T>)>)(IClientChannel, CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveObject(IClientChannel, CfgQueryEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObjectByDbId Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RetrieveObjectByDbId Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RetrieveObjectByDbId<(Of <(T>)>)(Int32) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveObjectByDbId<(Of <(T>)>)(IClientChannel, Int32) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveObjectByDbId(Int32, CfgObjectType) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrieveObjectByDbId(IClientChannel, Int32, CfgObjectType) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrievePermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.RetrievePermissions Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
RetrievePermissions(CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
RetrievePermissions(IClientChannel, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


SaveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.SaveObject Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
SaveObject(CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
SaveObject<(Of <(T>)>)(T) | (Inherited from IEnterpriseConfigurationServiceDomain.)
SaveObject(IClientChannel, CfgObjectEx) | (Inherited from IEnterpriseConfigurationServiceDomain.)
SaveObject<(Of <(T>)>)(IClientChannel, T) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.SetAccountPermissions Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObjectEx, CfgObjectEx, Int32) | (Inherited from IEnterpriseConfigurationServiceDomain.)
SetAccountPermissions(IClientChannel, CfgObjectEx, CfgObjectEx, Int32) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterEvents Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
UnregisterEvents(ISubscribeable<(Of <(ConfEventEx>)>)) |
UnregisterEvents(Action<(Of <(ConfEventEx>)>)) |
UnregisterEvents(IClientChannel, ISubscribeable<(Of <(ConfEventEx>)>)) |
UnregisterEvents(IClientChannel, Action<(Of <(ConfEventEx>)>)) |

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterEvents Method (ISubscribeable(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterEvents Method (ISubscribeable<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterEvents(
    ISubscribeable<ConfEventEx> subscriber
)
Visual Basic (Declaration)
Function UnregisterEvents ( _
    subscriber As ISubscribeable(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterEvents(
    ISubscribeable<ConfEventEx^>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( ConfEventEx >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
UnregisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterEvents Method (Action(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterEvents Method (Action<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterEvents(
    Action<ConfEventEx> handler
)
Visual Basic (Declaration)
Function UnregisterEvents ( _
    handler As Action(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterEvents(
    Action<ConfEventEx^>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <( ConfEventEx >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
UnregisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterEvents Method (IClientChannel, ISubscribeable(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterEvents Method (IClientChannel, ISubscribeable<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterEvents(
    IClientChannel channel,
    ISubscribeable<ConfEventEx> subscriber
)
Visual Basic (Declaration)
Function UnregisterEvents ( _
    channel As IClientChannel, _
    subscriber As ISubscribeable(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterEvents(
    IClientChannel^ channel,
    ISubscribeable<ConfEventEx^>^ subscriber
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( ConfEventEx >)>)

[Missing <param name="subscriber"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.ComponentModel.ISubscribeable{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
UnregisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterEvents Method (IClientChannel, Action(ConfEventEx))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterEvents Method (IClientChannel, Action<(Of <(ConfEventEx>)>))
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterEvents(
    IClientChannel channel,
    Action<ConfEventEx> handler
)
Visual Basic (Declaration)
Function UnregisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of ConfEventEx) _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterEvents(
    IClientChannel^ channel,
    Action<ConfEventEx^>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

handler
Type: System..::.Action <(Of <( ConfEventEx >)>)

[Missing <param name="handler"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterEvents(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Action{Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.ConfEventEx})"]

See Also

IEnterpriseConfigurationService Interface
UnregisterEvents Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
UnregisterFilter(KeyValueCollection) |
UnregisterFilter(CfgObjectEx) |
UnregisterFilter(NotificationQueryEx) |
UnregisterFilter(IClientChannel, KeyValueCollection) |
UnregisterFilter(IClientChannel, CfgObjectEx) |
UnregisterFilter(IClientChannel, NotificationQueryEx) |

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method (KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method (KeyValueCollection)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterFilter(
    KeyValueCollection filter
)
Visual Basic (Declaration)
Function UnregisterFilter ( _
    filter As KeyValueCollection _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterFilter(
    KeyValueCollection^ filter
)

Parameters

filter
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IEnterpriseConfigurationService Interface
UnregisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method (CfgObjectEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterFilter(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function UnregisterFilter ( _
    obj As CfgObjectEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterFilter(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationService Interface
UnregisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method (NotificationQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method (NotificationQueryEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterFilter(
    NotificationQueryEx query
)
Visual Basic (Declaration)
Function UnregisterFilter ( _
    query As NotificationQueryEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterFilter(
    NotificationQueryEx^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.NotificationQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

See Also

IEnterpriseConfigurationService Interface
UnregisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method (IClientChannel, KeyValueCollection)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method (IClientChannel, KeyValueCollection)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterFilter(
    IClientChannel channel,
    KeyValueCollection filter
)
Visual Basic (Declaration)
Function UnregisterFilter ( _
    channel As IClientChannel, _
    filter As KeyValueCollection _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterFilter(
    IClientChannel^ channel,
    KeyValueCollection^ filter
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

filter
Type: Genesyslab.Enterprise.Commons.Collections..::.KeyValueCollection

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IEnterpriseConfigurationService Interface
UnregisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterFilter(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function UnregisterFilter ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterFilter(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationService Interface
UnregisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterFilter Method (IClientChannel, NotificationQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterFilter Method (IClientChannel, NotificationQueryEx)
IEnterpriseConfigurationService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationService UnregisterFilter(
    IClientChannel channel,
    NotificationQueryEx query
)
Visual Basic (Declaration)
Function UnregisterFilter ( _
    channel As IClientChannel, _
    query As NotificationQueryEx _
) As IEnterpriseConfigurationService
Visual C++
IEnterpriseConfigurationService^ UnregisterFilter(
    IClientChannel^ channel,
    NotificationQueryEx^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.NotificationQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationService.UnregisterFilter(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.NotificationQueryEx)"]

See Also

IEnterpriseConfigurationService Interface
UnregisterFilter Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterPermissionsNotification Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService..::.UnregisterPermissionsNotification Method
IEnterpriseConfigurationService Interface See Also Send Feedback

Overload List

Name | Description
UnregisterPermissionsNotification()()() | (Inherited from IEnterpriseConfigurationServiceDomain.)
UnregisterPermissionsNotification(IClientChannel) | (Inherited from IEnterpriseConfigurationServiceDomain.)

See Also

IEnterpriseConfigurationService Interface
IEnterpriseConfigurationService Members
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationService Properties
IEnterpriseConfigurationService Interface See Also Send Feedback

The IEnterpriseConfigurationService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
DefaultChannel | (Inherited from IEnterpriseConfigurationServiceDomain.)
EventSubscription | Gets the (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IEnterpriseConfigurationService Interface
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationServiceDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IEnterpriseConfigurationServiceDomain
Visual Basic (Declaration)
Public Interface IEnterpriseConfigurationServiceDomain
Visual C++
public interface class IEnterpriseConfigurationServiceDomain

See Also

IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationServiceDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain Members
IEnterpriseConfigurationServiceDomain Interface Methods Properties See Also Send Feedback

The IEnterpriseConfigurationServiceDomain type exposes the following members.

Methods

Name | Description
AddChannel |
Authenticate | Overloaded.
ChangeOperationalMode | Overloaded.
ChangePassword | Overloaded.
CreateObject | Overloaded.
DeleteObject | Overloaded.
DeleteObjectByDbId | Overloaded.
ReadOperationalMode | Overloaded.
RefreshObject | Overloaded.
RegisterPermissionsNotification | Overloaded.
RemoveAccount | Overloaded.
RemoveChannel |
RetrieveAccountPermissions | Overloaded.
RetrieveMultipleObjects | Overloaded.
RetrieveObject | Overloaded.
RetrieveObjectByDbId | Overloaded.
RetrievePermissions | Overloaded.
SaveObject | Overloaded.
SetAccountPermissions | Overloaded.
UnregisterPermissionsNotification | Overloaded.

Properties

Name | Description
DefaultChannel |

See Also

IEnterpriseConfigurationServiceDomain Interface
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationServiceDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain Methods
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

The IEnterpriseConfigurationServiceDomain type exposes the following members.

Methods

Name | Description
AddChannel |
Authenticate | Overloaded.
ChangeOperationalMode | Overloaded.
ChangePassword | Overloaded.
CreateObject | Overloaded.
DeleteObject | Overloaded.
DeleteObjectByDbId | Overloaded.
ReadOperationalMode | Overloaded.
RefreshObject | Overloaded.
RegisterPermissionsNotification | Overloaded.
RemoveAccount | Overloaded.
RemoveChannel |
RetrieveAccountPermissions | Overloaded.
RetrieveMultipleObjects | Overloaded.
RetrieveObject | Overloaded.
RetrieveObjectByDbId | Overloaded.
RetrievePermissions | Overloaded.
SaveObject | Overloaded.
SetAccountPermissions | Overloaded.
UnregisterPermissionsNotification | Overloaded.

See Also

IEnterpriseConfigurationServiceDomain Interface
Genesyslab.Enterprise.Services.Configuration Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.AddChannel Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.AddChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationServiceDomain AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel _
) As IEnterpriseConfigurationServiceDomain
Visual C++
IEnterpriseConfigurationServiceDomain^ AddChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.AddChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.AddChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
Genesyslab.Enterprise.Services.Configuration Namespace


Authenticate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.Authenticate Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
Authenticate(String, String) |
Authenticate(IClientChannel, String, String) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


Authenticate Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.Authenticate Method (String, String)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(System.String,System.String)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Authenticate(
    string userName,
    string userPassword
)
Visual Basic (Declaration)
Sub Authenticate ( _
    userName As String, _
    userPassword As String _
)
Visual C++
void Authenticate(
    String^ userName,
    String^ userPassword
)

Parameters

userName
Type: System..::.String

[Missing <param name="userName"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(System.String,System.String)"]

userPassword
Type: System..::.String

[Missing <param name="userPassword"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(System.String,System.String)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
Authenticate Overload
Genesyslab.Enterprise.Services.Configuration Namespace


Authenticate Method (IClientChannel, String, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.Authenticate Method (IClientChannel, String, String)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void Authenticate(
    IClientChannel channel,
    string userName,
    string userPassword
)
Visual Basic (Declaration)
Sub Authenticate ( _
    channel As IClientChannel, _
    userName As String, _
    userPassword As String _
)
Visual C++
void Authenticate(
    IClientChannel^ channel,
    String^ userName,
    String^ userPassword
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String)"]

userName
Type: System..::.String

[Missing <param name="userName"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String)"]

userPassword
Type: System..::.String

[Missing <param name="userPassword"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.Authenticate(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
Authenticate Overload
Genesyslab.Enterprise.Services.Configuration Namespace


ChangeOperationalMode Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ChangeOperationalMode Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
ChangeOperationalMode(Int32) |
ChangeOperationalMode(IClientChannel, Int32) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


ChangeOperationalMode Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ChangeOperationalMode Method (Int32)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(System.Int32)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int ChangeOperationalMode(
    int operationalMode
)
Visual Basic (Declaration)
Function ChangeOperationalMode ( _
    operationalMode As Integer _
) As Integer
Visual C++
int ChangeOperationalMode(
    int operationalMode
)

Parameters

operationalMode
Type: System..::.Int32

[Missing <param name="operationalMode"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(System.Int32)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
ChangeOperationalMode Overload
Genesyslab.Enterprise.Services.Configuration Namespace


ChangeOperationalMode Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ChangeOperationalMode Method (IClientChannel, Int32)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int ChangeOperationalMode(
    IClientChannel channel,
    int operationalMode
)
Visual Basic (Declaration)
Function ChangeOperationalMode ( _
    channel As IClientChannel, _
    operationalMode As Integer _
) As Integer
Visual C++
int ChangeOperationalMode(
    IClientChannel^ channel,
    int operationalMode
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

operationalMode
Type: System..::.Int32

[Missing <param name="operationalMode"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangeOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
ChangeOperationalMode Overload
Genesyslab.Enterprise.Services.Configuration Namespace


ChangePassword Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ChangePassword Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
ChangePassword(String, String, String) |
ChangePassword(IClientChannel, String, String, String) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


ChangePassword Method (String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ChangePassword Method (String, String, String)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(System.String,System.String,System.String)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ChangePassword(
    string userName,
    string userPassword,
    string newUserPassword
)
Visual Basic (Declaration)
Sub ChangePassword ( _
    userName As String, _
    userPassword As String, _
    newUserPassword As String _
)
Visual C++
void ChangePassword(
    String^ userName,
    String^ userPassword,
    String^ newUserPassword
)

Parameters

userName
Type: System..::.String

[Missing <param name="userName"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(System.String,System.String,System.String)"]

userPassword
Type: System..::.String

[Missing <param name="userPassword"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(System.String,System.String,System.String)"]

newUserPassword
Type: System..::.String

[Missing <param name="newUserPassword"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(System.String,System.String,System.String)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
ChangePassword Overload
Genesyslab.Enterprise.Services.Configuration Namespace


ChangePassword Method (IClientChannel, String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ChangePassword Method (IClientChannel, String, String, String)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,System.String)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void ChangePassword(
    IClientChannel channel,
    string userName,
    string userPassword,
    string newUserPassword
)
Visual Basic (Declaration)
Sub ChangePassword ( _
    channel As IClientChannel, _
    userName As String, _
    userPassword As String, _
    newUserPassword As String _
)
Visual C++
void ChangePassword(
    IClientChannel^ channel,
    String^ userName,
    String^ userPassword,
    String^ newUserPassword
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,System.String)"]

userName
Type: System..::.String

[Missing <param name="userName"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,System.String)"]

userPassword
Type: System..::.String

[Missing <param name="userPassword"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,System.String)"]

newUserPassword
Type: System..::.String

[Missing <param name="newUserPassword"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ChangePassword(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,System.String)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
ChangePassword Overload
Genesyslab.Enterprise.Services.Configuration Namespace


CreateObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.CreateObject Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateObject(CfgObjectEx) |
CreateObject<(Of <(T>)>)(T) |
CreateObject(IClientChannel, CfgObjectEx) |
CreateObject<(Of <(T>)>)(IClientChannel, T) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


CreateObject Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.CreateObject Method (CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx CreateObject(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function CreateObject ( _
    obj As CfgObjectEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ CreateObject(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
CreateObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


CreateObject(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.CreateObject<(Of <(T>)>) Method (T)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(``0)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T CreateObject<T>(
    T obj
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function CreateObject(Of T As CfgObjectEx) ( _
    obj As T _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T CreateObject(
    T obj
)

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(``0)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
CreateObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


CreateObject Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.CreateObject Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx CreateObject(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function CreateObject ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ CreateObject(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
CreateObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


CreateObject(T) Method (IClientChannel, T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.CreateObject<(Of <(T>)>) Method (IClientChannel, T)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T CreateObject<T>(
    IClientChannel channel,
    T obj
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function CreateObject(Of T As CfgObjectEx) ( _
    channel As IClientChannel, _
    obj As T _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T CreateObject(
    IClientChannel^ channel,
    T obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.CreateObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
CreateObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DeleteObject Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
DeleteObject(CfgObjectEx) |
DeleteObject(IClientChannel, CfgObjectEx) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObject Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DeleteObject Method (CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void DeleteObject(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Sub DeleteObject ( _
    obj As CfgObjectEx _
)
Visual C++
void DeleteObject(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
DeleteObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObject Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DeleteObject Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void DeleteObject(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Sub DeleteObject ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
)
Visual C++
void DeleteObject(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
DeleteObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObjectByDbId Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DeleteObjectByDbId Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
DeleteObjectByDbId(Int32, CfgObjectType) |
DeleteObjectByDbId(IClientChannel, Int32, CfgObjectType) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObjectByDbId Method (Int32, CfgObjectType)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DeleteObjectByDbId Method (Int32, CfgObjectType)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void DeleteObjectByDbId(
    int dbId,
    CfgObjectType objectType
)
Visual Basic (Declaration)
Sub DeleteObjectByDbId ( _
    dbId As Integer, _
    objectType As CfgObjectType _
)
Visual C++
void DeleteObjectByDbId(
    int dbId,
    CfgObjectType objectType
)

Parameters

dbId
Type: System..::.Int32

[Missing <param name="dbId"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
DeleteObjectByDbId Overload
Genesyslab.Enterprise.Services.Configuration Namespace


DeleteObjectByDbId Method (IClientChannel, Int32, CfgObjectType)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DeleteObjectByDbId Method (IClientChannel, Int32, CfgObjectType)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void DeleteObjectByDbId(
    IClientChannel channel,
    int dbId,
    CfgObjectType objectType
)
Visual Basic (Declaration)
Sub DeleteObjectByDbId ( _
    channel As IClientChannel, _
    dbId As Integer, _
    objectType As CfgObjectType _
)
Visual C++
void DeleteObjectByDbId(
    IClientChannel^ channel,
    int dbId,
    CfgObjectType objectType
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

dbId
Type: System..::.Int32

[Missing <param name="dbId"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DeleteObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
DeleteObjectByDbId Overload
Genesyslab.Enterprise.Services.Configuration Namespace


ReadOperationalMode Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ReadOperationalMode Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
ReadOperationalMode()()() |
ReadOperationalMode(IClientChannel) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


ReadOperationalMode Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ReadOperationalMode Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ReadOperationalMode"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int ReadOperationalMode()
Visual Basic (Declaration)
Function ReadOperationalMode As Integer
Visual C++
int ReadOperationalMode()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ReadOperationalMode"]

See Also

IEnterpriseConfigurationServiceDomain Interface
ReadOperationalMode Overload
Genesyslab.Enterprise.Services.Configuration Namespace


ReadOperationalMode Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.ReadOperationalMode Method (IClientChannel)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ReadOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int ReadOperationalMode(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ReadOperationalMode ( _
    channel As IClientChannel _
) As Integer
Visual C++
int ReadOperationalMode(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ReadOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.ReadOperationalMode(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
ReadOperationalMode Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RefreshObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RefreshObject Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RefreshObject(CfgObjectEx) |
RefreshObject<(Of <(T>)>)(T) |
RefreshObject(IClientChannel, CfgObjectEx) |
RefreshObject<(Of <(T>)>)(IClientChannel, T) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RefreshObject Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RefreshObject Method (CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx RefreshObject(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function RefreshObject ( _
    obj As CfgObjectEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ RefreshObject(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RefreshObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RefreshObject(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RefreshObject<(Of <(T>)>) Method (T)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(``0)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RefreshObject<T>(
    T obj
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RefreshObject(Of T As CfgObjectEx) ( _
    obj As T _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T RefreshObject(
    T obj
)

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(``0)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RefreshObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RefreshObject Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RefreshObject Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx RefreshObject(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function RefreshObject ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ RefreshObject(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RefreshObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RefreshObject(T) Method (IClientChannel, T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RefreshObject<(Of <(T>)>) Method (IClientChannel, T)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RefreshObject<T>(
    IClientChannel channel,
    T obj
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RefreshObject(Of T As CfgObjectEx) ( _
    channel As IClientChannel, _
    obj As T _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T RefreshObject(
    IClientChannel^ channel,
    T obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RefreshObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RefreshObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterPermissionsNotification Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RegisterPermissionsNotification Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RegisterPermissionsNotification()()() |
RegisterPermissionsNotification(IClientChannel) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterPermissionsNotification Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RegisterPermissionsNotification Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RegisterPermissionsNotification"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void RegisterPermissionsNotification()
Visual Basic (Declaration)
Sub RegisterPermissionsNotification
Visual C++
void RegisterPermissionsNotification()

See Also

IEnterpriseConfigurationServiceDomain Interface
RegisterPermissionsNotification Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RegisterPermissionsNotification Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RegisterPermissionsNotification Method (IClientChannel)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RegisterPermissionsNotification(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void RegisterPermissionsNotification(
    IClientChannel channel
)
Visual Basic (Declaration)
Sub RegisterPermissionsNotification ( _
    channel As IClientChannel _
)
Visual C++
void RegisterPermissionsNotification(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RegisterPermissionsNotification(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RegisterPermissionsNotification Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RemoveAccount Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RemoveAccount Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAccount(CfgObjectEx, CfgObjectEx, Boolean) |
RemoveAccount(IClientChannel, CfgObjectEx, CfgObjectEx, Boolean) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RemoveAccount Method (CfgObjectEx, CfgObjectEx, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RemoveAccount Method (CfgObjectEx, CfgObjectEx, Boolean)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void RemoveAccount(
    CfgObjectEx obj,
    CfgObjectEx account,
    bool recursive
)
Visual Basic (Declaration)
Sub RemoveAccount ( _
    obj As CfgObjectEx, _
    account As CfgObjectEx, _
    recursive As Boolean _
)
Visual C++
void RemoveAccount(
    CfgObjectEx^ obj,
    CfgObjectEx^ account,
    bool recursive
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

account
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="account"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

recursive
Type: System..::.Boolean

[Missing <param name="recursive"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RemoveAccount Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RemoveAccount Method (IClientChannel, CfgObjectEx, CfgObjectEx, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RemoveAccount Method (IClientChannel, CfgObjectEx, CfgObjectEx, Boolean)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void RemoveAccount(
    IClientChannel channel,
    CfgObjectEx obj,
    CfgObjectEx account,
    bool recursive
)
Visual Basic (Declaration)
Sub RemoveAccount ( _
    channel As IClientChannel, _
    obj As CfgObjectEx, _
    account As CfgObjectEx, _
    recursive As Boolean _
)
Visual C++
void RemoveAccount(
    IClientChannel^ channel,
    CfgObjectEx^ obj,
    CfgObjectEx^ account,
    bool recursive
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

account
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="account"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

recursive
Type: System..::.Boolean

[Missing <param name="recursive"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveAccount(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Boolean)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RemoveAccount Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RemoveChannel Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IEnterpriseConfigurationServiceDomain RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function RemoveChannel ( _
    channel As IClientChannel _
) As IEnterpriseConfigurationServiceDomain
Visual C++
IEnterpriseConfigurationServiceDomain^ RemoveChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RemoveChannel(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveAccountPermissions Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RetrieveAccountPermissions(CfgObjectEx, CfgObjectEx) |
RetrieveAccountPermissions(IClientChannel, CfgObjectEx, CfgObjectEx) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveAccountPermissions Method (CfgObjectEx, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveAccountPermissions Method (CfgObjectEx, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int RetrieveAccountPermissions(
    CfgObjectEx obj,
    CfgObjectEx account
)
Visual Basic (Declaration)
Function RetrieveAccountPermissions ( _
    obj As CfgObjectEx, _
    account As CfgObjectEx _
) As Integer
Visual C++
int RetrieveAccountPermissions(
    CfgObjectEx^ obj,
    CfgObjectEx^ account
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

account
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="account"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveAccountPermissions Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveAccountPermissions Method (IClientChannel, CfgObjectEx, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveAccountPermissions Method (IClientChannel, CfgObjectEx, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int RetrieveAccountPermissions(
    IClientChannel channel,
    CfgObjectEx obj,
    CfgObjectEx account
)
Visual Basic (Declaration)
Function RetrieveAccountPermissions ( _
    channel As IClientChannel, _
    obj As CfgObjectEx, _
    account As CfgObjectEx _
) As Integer
Visual C++
int RetrieveAccountPermissions(
    IClientChannel^ channel,
    CfgObjectEx^ obj,
    CfgObjectEx^ account
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

account
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="account"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveAccountPermissions Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveMultipleObjects Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveMultipleObjects Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RetrieveMultipleObjects(CfgQueryEx) |
RetrieveMultipleObjects<(Of <(T>)>)(CfgQueryEx) |
RetrieveMultipleObjects<(Of <(T>)>)(IClientChannel, CfgQueryEx) |
RetrieveMultipleObjects(IClientChannel, CfgQueryEx) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveMultipleObjects Method (CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveMultipleObjects Method (CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx[] RetrieveMultipleObjects(
    CfgQueryEx query
)
Visual Basic (Declaration)
Function RetrieveMultipleObjects ( _
    query As CfgQueryEx _
) As CfgObjectEx()
Visual C++
array<CfgObjectEx^>^ RetrieveMultipleObjects(
    CfgQueryEx^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveMultipleObjects Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveMultipleObjects(T) Method (CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveMultipleObjects<(Of <(T>)>) Method (CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T[] RetrieveMultipleObjects<T>(
    CfgQueryEx query
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RetrieveMultipleObjects(Of T As CfgObjectEx) ( _
    query As CfgQueryEx _
) As T()
Visual C++
generic<typename T>
where T : CfgObjectEx
array<T>^ RetrieveMultipleObjects(
    CfgQueryEx^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveMultipleObjects Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveMultipleObjects(T) Method (IClientChannel, CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveMultipleObjects<(Of <(T>)>) Method (IClientChannel, CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T[] RetrieveMultipleObjects<T>(
    IClientChannel channel,
    CfgQueryEx query
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RetrieveMultipleObjects(Of T As CfgObjectEx) ( _
    channel As IClientChannel, _
    query As CfgQueryEx _
) As T()
Visual C++
generic<typename T>
where T : CfgObjectEx
array<T>^ RetrieveMultipleObjects(
    IClientChannel^ channel,
    CfgQueryEx^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveMultipleObjects Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveMultipleObjects Method (IClientChannel, CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveMultipleObjects Method (IClientChannel, CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx[] RetrieveMultipleObjects(
    IClientChannel channel,
    CfgQueryEx query
)
Visual Basic (Declaration)
Function RetrieveMultipleObjects ( _
    channel As IClientChannel, _
    query As CfgQueryEx _
) As CfgObjectEx()
Visual C++
array<CfgObjectEx^>^ RetrieveMultipleObjects(
    IClientChannel^ channel,
    CfgQueryEx^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveMultipleObjects(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveMultipleObjects Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObject Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RetrieveObject(CfgQueryEx) |
RetrieveObject<(Of <(T>)>)(CfgQueryEx) |
RetrieveObject<(Of <(T>)>)(IClientChannel, CfgQueryEx) |
RetrieveObject(IClientChannel, CfgQueryEx) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObject Method (CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObject Method (CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx RetrieveObject(
    CfgQueryEx query
)
Visual Basic (Declaration)
Function RetrieveObject ( _
    query As CfgQueryEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ RetrieveObject(
    CfgQueryEx^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObject(T) Method (CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObject<(Of <(T>)>) Method (CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RetrieveObject<T>(
    CfgQueryEx query
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RetrieveObject(Of T As CfgObjectEx) ( _
    query As CfgQueryEx _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T RetrieveObject(
    CfgQueryEx^ query
)

Parameters

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObject(T) Method (IClientChannel, CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObject<(Of <(T>)>) Method (IClientChannel, CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RetrieveObject<T>(
    IClientChannel channel,
    CfgQueryEx query
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RetrieveObject(Of T As CfgObjectEx) ( _
    channel As IClientChannel, _
    query As CfgQueryEx _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T RetrieveObject(
    IClientChannel^ channel,
    CfgQueryEx^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObject Method (IClientChannel, CfgQueryEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObject Method (IClientChannel, CfgQueryEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx RetrieveObject(
    IClientChannel channel,
    CfgQueryEx query
)
Visual Basic (Declaration)
Function RetrieveObject ( _
    channel As IClientChannel, _
    query As CfgQueryEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ RetrieveObject(
    IClientChannel^ channel,
    CfgQueryEx^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

query
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries..::.CfgQueryEx

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.Queries.CfgQueryEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObjectByDbId Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObjectByDbId Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RetrieveObjectByDbId<(Of <(T>)>)(Int32) |
RetrieveObjectByDbId<(Of <(T>)>)(IClientChannel, Int32) |
RetrieveObjectByDbId(Int32, CfgObjectType) |
RetrieveObjectByDbId(IClientChannel, Int32, CfgObjectType) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObjectByDbId(T) Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObjectByDbId<(Of <(T>)>) Method (Int32)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(System.Int32)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RetrieveObjectByDbId<T>(
    int dbId
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RetrieveObjectByDbId(Of T As CfgObjectEx) ( _
    dbId As Integer _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T RetrieveObjectByDbId(
    int dbId
)

Parameters

dbId
Type: System..::.Int32

[Missing <param name="dbId"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(System.Int32)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(System.Int32)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObjectByDbId Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObjectByDbId(T) Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObjectByDbId<(Of <(T>)>) Method (IClientChannel, Int32)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T RetrieveObjectByDbId<T>(
    IClientChannel channel,
    int dbId
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function RetrieveObjectByDbId(Of T As CfgObjectEx) ( _
    channel As IClientChannel, _
    dbId As Integer _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T RetrieveObjectByDbId(
    IClientChannel^ channel,
    int dbId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

dbId
Type: System..::.Int32

[Missing <param name="dbId"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObjectByDbId Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObjectByDbId Method (Int32, CfgObjectType)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObjectByDbId Method (Int32, CfgObjectType)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx RetrieveObjectByDbId(
    int dbId,
    CfgObjectType objectType
)
Visual Basic (Declaration)
Function RetrieveObjectByDbId ( _
    dbId As Integer, _
    objectType As CfgObjectType _
) As CfgObjectEx
Visual C++
CfgObjectEx^ RetrieveObjectByDbId(
    int dbId,
    CfgObjectType objectType
)

Parameters

dbId
Type: System..::.Int32

[Missing <param name="dbId"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObjectByDbId Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrieveObjectByDbId Method (IClientChannel, Int32, CfgObjectType)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrieveObjectByDbId Method (IClientChannel, Int32, CfgObjectType)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx RetrieveObjectByDbId(
    IClientChannel channel,
    int dbId,
    CfgObjectType objectType
)
Visual Basic (Declaration)
Function RetrieveObjectByDbId ( _
    channel As IClientChannel, _
    dbId As Integer, _
    objectType As CfgObjectType _
) As CfgObjectEx
Visual C++
CfgObjectEx^ RetrieveObjectByDbId(
    IClientChannel^ channel,
    int dbId,
    CfgObjectType objectType
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

dbId
Type: System..::.Int32

[Missing <param name="dbId"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

objectType
Type: Genesyslab.Enterprise.Model.Configuration..::.CfgObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrieveObjectByDbId(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.Int32,Genesyslab.Enterprise.Model.Configuration.CfgObjectType)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrieveObjectByDbId Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrievePermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrievePermissions Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
RetrievePermissions(CfgObjectEx) |
RetrievePermissions(IClientChannel, CfgObjectEx) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


RetrievePermissions Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrievePermissions Method (CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
PermissionDescriptorEx[] RetrievePermissions(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function RetrievePermissions ( _
    obj As CfgObjectEx _
) As PermissionDescriptorEx()
Visual C++
array<PermissionDescriptorEx^>^ RetrievePermissions(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrievePermissions Overload
Genesyslab.Enterprise.Services.Configuration Namespace


RetrievePermissions Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.RetrievePermissions Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
PermissionDescriptorEx[] RetrievePermissions(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function RetrievePermissions ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
) As PermissionDescriptorEx()
Visual C++
array<PermissionDescriptorEx^>^ RetrievePermissions(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.RetrievePermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
RetrievePermissions Overload
Genesyslab.Enterprise.Services.Configuration Namespace


SaveObject Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SaveObject Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
SaveObject(CfgObjectEx) |
SaveObject<(Of <(T>)>)(T) |
SaveObject(IClientChannel, CfgObjectEx) |
SaveObject<(Of <(T>)>)(IClientChannel, T) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


SaveObject Method (CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SaveObject Method (CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx SaveObject(
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function SaveObject ( _
    obj As CfgObjectEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ SaveObject(
    CfgObjectEx^ obj
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
SaveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


SaveObject(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SaveObject<(Of <(T>)>) Method (T)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(``0)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T SaveObject<T>(
    T obj
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function SaveObject(Of T As CfgObjectEx) ( _
    obj As T _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T SaveObject(
    T obj
)

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(``0)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
SaveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


SaveObject Method (IClientChannel, CfgObjectEx)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SaveObject Method (IClientChannel, CfgObjectEx)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
CfgObjectEx SaveObject(
    IClientChannel channel,
    CfgObjectEx obj
)
Visual Basic (Declaration)
Function SaveObject ( _
    channel As IClientChannel, _
    obj As CfgObjectEx _
) As CfgObjectEx
Visual C++
CfgObjectEx^ SaveObject(
    IClientChannel^ channel,
    CfgObjectEx^ obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
SaveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


SaveObject(T) Method (IClientChannel, T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SaveObject<(Of <(T>)>) Method (IClientChannel, T)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
T SaveObject<T>(
    IClientChannel channel,
    T obj
)
where T : CfgObjectEx
Visual Basic (Declaration)
Function SaveObject(Of T As CfgObjectEx) ( _
    channel As IClientChannel, _
    obj As T _
) As T
Visual C++
generic<typename T>
where T : CfgObjectEx
T SaveObject(
    IClientChannel^ channel,
    T obj
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SaveObject``1(Genesyslab.Enterprise.Model.Channel.IClientChannel,``0)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
SaveObject Overload
Genesyslab.Enterprise.Services.Configuration Namespace


SetAccountPermissions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SetAccountPermissions Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAccountPermissions(CfgObjectEx, CfgObjectEx, Int32) |
SetAccountPermissions(IClientChannel, CfgObjectEx, CfgObjectEx, Int32) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


SetAccountPermissions Method (CfgObjectEx, CfgObjectEx, Int32)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SetAccountPermissions Method (CfgObjectEx, CfgObjectEx, Int32)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void SetAccountPermissions(
    CfgObjectEx obj,
    CfgObjectEx account,
    int newPermissionsMask
)
Visual Basic (Declaration)
Sub SetAccountPermissions ( _
    obj As CfgObjectEx, _
    account As CfgObjectEx, _
    newPermissionsMask As Integer _
)
Visual C++
void SetAccountPermissions(
    CfgObjectEx^ obj,
    CfgObjectEx^ account,
    int newPermissionsMask
)

Parameters

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

account
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="account"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

newPermissionsMask
Type: System..::.Int32

[Missing <param name="newPermissionsMask"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
SetAccountPermissions Overload
Genesyslab.Enterprise.Services.Configuration Namespace


SetAccountPermissions Method (IClientChannel, CfgObjectEx, CfgObjectEx, Int32)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.SetAccountPermissions Method (IClientChannel, CfgObjectEx, CfgObjectEx, Int32)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void SetAccountPermissions(
    IClientChannel channel,
    CfgObjectEx obj,
    CfgObjectEx account,
    int newPermissionsMask
)
Visual Basic (Declaration)
Sub SetAccountPermissions ( _
    channel As IClientChannel, _
    obj As CfgObjectEx, _
    account As CfgObjectEx, _
    newPermissionsMask As Integer _
)
Visual C++
void SetAccountPermissions(
    IClientChannel^ channel,
    CfgObjectEx^ obj,
    CfgObjectEx^ account,
    int newPermissionsMask
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

obj
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="obj"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

account
Type: Genesyslab.Enterprise.ConfigurationObjectModel.Serializable..::.CfgObjectEx

[Missing <param name="account"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

newPermissionsMask
Type: System..::.Int32

[Missing <param name="newPermissionsMask"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.SetAccountPermissions(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,Genesyslab.Enterprise.ConfigurationObjectModel.Serializable.CfgObjectEx,System.Int32)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
SetAccountPermissions Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterPermissionsNotification Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.UnregisterPermissionsNotification Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

Overload List

Name | Description
UnregisterPermissionsNotification()()() |
UnregisterPermissionsNotification(IClientChannel) |

See Also

IEnterpriseConfigurationServiceDomain Interface
IEnterpriseConfigurationServiceDomain Members
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterPermissionsNotification Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.UnregisterPermissionsNotification Method
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.UnregisterPermissionsNotification"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void UnregisterPermissionsNotification()
Visual Basic (Declaration)
Sub UnregisterPermissionsNotification
Visual C++
void UnregisterPermissionsNotification()

See Also

IEnterpriseConfigurationServiceDomain Interface
UnregisterPermissionsNotification Overload
Genesyslab.Enterprise.Services.Configuration Namespace


UnregisterPermissionsNotification Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.UnregisterPermissionsNotification Method (IClientChannel)
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.UnregisterPermissionsNotification(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
void UnregisterPermissionsNotification(
    IClientChannel channel
)
Visual Basic (Declaration)
Sub UnregisterPermissionsNotification ( _
    channel As IClientChannel _
)
Visual C++
void UnregisterPermissionsNotification(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.UnregisterPermissionsNotification(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IEnterpriseConfigurationServiceDomain Interface
UnregisterPermissionsNotification Overload
Genesyslab.Enterprise.Services.Configuration Namespace


IEnterpriseConfigurationServiceDomain Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain Properties
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

The IEnterpriseConfigurationServiceDomain type exposes the following members.

Properties

Name | Description
DefaultChannel |

See Also

IEnterpriseConfigurationServiceDomain Interface
Genesyslab.Enterprise.Services.Configuration Namespace


DefaultChannel Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseConfigurationServiceDomain..::.DefaultChannel Property
IEnterpriseConfigurationServiceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Configuration.IEnterpriseConfigurationServiceDomain.DefaultChannel"]

Namespace: Genesyslab.Enterprise.Services.Configuration
Assembly: Genesyslab.Enterprise.Services.Configuration (in Genesyslab.Enterprise.Services.Configuration.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IClientChannel DefaultChannel { get; set; }
Visual Basic (Declaration)
Property DefaultChannel As IClientChannel
Visual C++
property IClientChannel^ DefaultChannel {
    IClientChannel^ get ();
    void set (IClientChannel^ value);
}

See Also

IEnterpriseConfigurationServiceDomain Interface
Genesyslab.Enterprise.Services.Configuration Namespace


Genesyslab.Enterprise.Services.Model Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Model Namespace
Send Feedback

Interfaces

Interface | Description
IMonitorAgentGroupStatus | AgentGroup status.
IMonitorAgentStatus | Interface for Agent Status Monitoring.
IMonitorEventStatus | Interface for Event Status Monitoring.

Enumerations

Enumeration | Description
AgentGroupStatus | Enumerate for Agent Group statistics object type.
AgentStatus | Enumerate for Agent statistics object type.


AgentGroupStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentGroupStatus Enumeration
See Also Send Feedback
Enumerate for Agent Group statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public enum AgentGroupStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration AgentGroupStatus
Visual C++
[SerializableAttribute]
public enum class AgentGroupStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |

See Also

Genesyslab.Enterprise.Services.Model Namespace


AgentStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentStatus Enumeration
See Also Send Feedback
Enumerate for Agent statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
[SerializableAttribute]
public enum AgentStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration AgentStatus
Visual C++
[SerializableAttribute]
public enum class AgentStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |

See Also

Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Interface
Members See Also Send Feedback
AgentGroup status.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IMonitorAgentGroupStatus : IMonitorEventStatus,
    ISerializable
Visual Basic (Declaration)
Public Interface IMonitorAgentGroupStatus _
    Implements IMonitorEventStatus, ISerializable
Visual C++
public interface class IMonitorAgentGroupStatus : IMonitorEventStatus,
    ISerializable

See Also

IMonitorAgentGroupStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Members
IMonitorAgentGroupStatus Interface Methods Properties See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
AgentCount |
GroupID |
Status |

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Methods
IMonitorAgentGroupStatus Interface See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Properties
IMonitorAgentGroupStatus Interface See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Properties

Name | Description
AgentCount |
GroupID |
Status |

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentCount Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.AgentCount Property
IMonitorAgentGroupStatus Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Model.IMonitorAgentGroupStatus.AgentCount"]

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
int AgentCount { get; }
Visual Basic (Declaration)
ReadOnly Property AgentCount As Integer
Visual C++
property int AgentCount {
    int get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


GroupID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.GroupID Property
IMonitorAgentGroupStatus Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Model.IMonitorAgentGroupStatus.GroupID"]

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string GroupID { get; }
Visual Basic (Declaration)
ReadOnly Property GroupID As String
Visual C++
property String^ GroupID {
    String^ get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.Status Property
IMonitorAgentGroupStatus Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Model.IMonitorAgentGroupStatus.Status"]

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentGroupStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As AgentGroupStatus
Visual C++
property AgentGroupStatus Status {
    AgentGroupStatus get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Interface
Members See Also Send Feedback
Interface for Agent Status Monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IMonitorAgentStatus : IMonitorEventStatus,
    ISerializable
Visual Basic (Declaration)
Public Interface IMonitorAgentStatus _
    Implements IMonitorEventStatus, ISerializable
Visual C++
public interface class IMonitorAgentStatus : IMonitorEventStatus,
    ISerializable

See Also

IMonitorAgentStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Members
IMonitorAgentStatus Interface Methods Properties See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
AgentID | returns the Agent ID.
MediaStatuses | returns the DN statuses of the agent.
PlaceID | returns the Place ID of the Agent.
Status | returns the status of the agent.

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Methods
IMonitorAgentStatus Interface See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Properties
IMonitorAgentStatus Interface See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Properties

Name | Description
AgentID | returns the Agent ID.
MediaStatuses | returns the DN statuses of the agent.
PlaceID | returns the Place ID of the Agent.
Status | returns the status of the agent.

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.AgentID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Agent ID.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string AgentID { get; }
Visual Basic (Declaration)
ReadOnly Property AgentID As String
Visual C++
property String^ AgentID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaStatuses Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaStatuses Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the DN statuses of the agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
IDictionary<string, IMonitorMediaStatus> MediaStatuses { get; }
Visual Basic (Declaration)
ReadOnly Property MediaStatuses As IDictionary(Of String, IMonitorMediaStatus)
Visual C++
property IDictionary<String^, IMonitorMediaStatus^>^ MediaStatuses {
    IDictionary<String^, IMonitorMediaStatus^>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


PlaceID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.PlaceID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Place ID of the Agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
string PlaceID { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceID As String
Visual C++
property String^ PlaceID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.Status Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the status of the agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
AgentStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As AgentStatus
Visual C++
property AgentStatus Status {
    AgentStatus get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Interface
Members See Also Send Feedback
Interface for Event Status Monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.0.1.23 (8.0.1.23)

Syntax

C#
public interface IMonitorEventStatus : ISerializable
Visual Basic (Declaration)
Public Interface IMonitorEventStatus _
    Implements ISerializable
Visual C++
public interface class IMonitorEventStatus : ISerializable

See Also

IMonitorEventStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Members
IMonitorEventStatus Interface Methods See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Methods
IMonitorEventStatus Interface See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace